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CHAPTER 1 

InterPlace Introduction 

Congratulations on your purchase of P-CAD InterPlace.  P-CAD InterPlace (IPL) is a productivity-
enhancing tool that integrates seamlessly into the P-CAD suite of circuit board design products.   

InterPlace excels at organizing the variety of objects in a design.  Components can be arranged in 
logical or physical groups and easily gathered together in preparation for placement on the circuit 
board.  In addition, InterPlace incorporates the design rules, or constraints, used to ensure 
successful placement, routing, or manufacture of a printed circuit board.    

Today’s engineers face the challenge of designing faster circuits of increasing complexity on 
smaller boards.  In addition, these boards are to be manufactured with minimum time and cost.  
InterPlace provides you with powerful visualization and placement tools, which help you to quickly 
avoid constraint violations or resolve constraint conflicts.   

P-CAD InterPlace is an advanced placement tool for the Microsoft® Windows 95™, Windows 98™, 
Windows 2000™, or Windows NT™ operating systems.  InterPlace contains a combination of 
features designed to significantly reduce the number of design iterations needed to produce a 
successful board layout. 

P-CAD IPL Features 
This section highlights some of the important P-CAD InterPlace features:   

• New and unique ways to view and organize your designs.  You can simultaneously view and 
manipulate the arrangement of the components and nets on the physical board layout.  The 
Layout View of IPL graphically depicts component placement and connectivity.  In addition, the 
Design Manager allows you to view the design contents in terms of components, nets, 
partitions, rooms, net classes and class-to-class rules. 

• IPL is a component organization and preplacement tool.  With IPL you can organize 
components and prepare your board layout before you begin placement.  Components can be 
grouped in logical partitions and physical rooms and quickly clustered from diverse locations 
to make placement easier.  You can swap components, fix them in place and rotate them 
around their own reference points.  Net connections are optimized on-the-fly when 
components are moved. You can also select components and drag and drop them into other 
locations, even another window. 
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• Easy placement of discrete components.  Discrete components, such as bypass caps, can be 
associated with a particular component with just a mouse click using the Discrete Placement 
function.  Eliminate searching among the typically large quantities of discrete components by 
using the Discrete Placement function to locate them for you.  You can choose to locate these 
components by Type or Value.  IPL dynamically tracks available and placed components and 
displays updated counts with each placement. 

• Application integration.  P-CAD Schematic, P-CAD PCB and P-CAD Relay software is tightly 
integrated with P-CAD InterPlace, assuring the synchronization of design file updates between 
the applications.   

• Productivity features that make design work easier.  Increasing productivity is simple when you 
put InterPlace features to use.  You can easily drag components from a variety of locations and 
simply drop them into the board layout.  Swap components with just a couple clicks of the 
mouse.  You can quickly fix a component in its place.  IPL optimizes network connections on-
the-fly when components are moved.  Group components with like characteristics, like the 
same reference designators, type, etc., using the Cluster By command.  Rotate components to 
an absolute degree using their own reference points.   

• Valid Placement Area Visualization.  P-CAD InterPlace provides a visible placement area for 
your components based on design constraints.  Using the Visible Placement Area tools, you 
can quickly view the exact physical location on the board where a component can be placed 
without violating a constraint restriction.  Being able to place the component knowing it will 
not violate a design rule reduces errors and saves correction time. 

About this Guide 
This manual provides information about P-CAD InterPlace.  It includes the following sections: 

• Getting Started: Chapters 2 and 3 tell you what you need to get started using P-CAD InterPlace.  
It provides installation instructions and walks you through the basic capabilities of P-CAD IPL 
and its interaction with P-CAD Schematic, PCB or Relay.  

• Using InterPlace: Chapters 4 through 8 provide information that you need to work with P-CAD 
IPL.  They give you details on organizing design objects in the Design Manager Layout View 
using rooms and partitions, and placing design components on your board layout. 

• InterPlace Reference: Chapters 9 through 14 include an extensive command reference, 
covering all of P-CAD InterPlace. 

IPL within the P-CAD Product Suite 
The interface of InterPlace varies depending on the design file you have loaded.  For instance, 
designs loaded from P-CAD Schematic have no board layout presentation of the design, therefore 
Layout View activities are not available.  When no icon is displayed, the feature is available for all 
designs. 
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The icon may also be found in the chapter introduction, if all features in that chapter are design 
specific.  

P-CAD PCB Icon 
When a design is loaded from PCB, the full suite of InterPlace features is available.  When a feature 
is exclusive to a PCB design, the PCB icon is display in the left margin. 
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CHAPTER 2 

Installation and Setup 

This chapter lists the required hardware and software settings you need to install the P-CAD  Suite.  

System Requirements 
Make sure that your PC and its software conform to the following P-CAD requirements and 
recommendations.  

Recommended System 
• Windows NT 4/2000 Professional 

• PC with Pentium III Processor 

• 128MB RAM (256MB for high component/net count) 

• 400MB Hard Disk Space 

• Desktop area 1024x768 pixels 

• 32-bit Color Palette 

• CD-ROM Drive 

• Mouse or compatible pointing device. 

Minimum System 
• Windows 95/98/2000Me 

• PC with Pentium 166MHz 

• 64MB RAM 

• 200MB Hard Disk Space (without ISO libraries) 

• Desktop area 800x600 pixels 

• 256 Color Palette 

• CD-ROM Drive 

• Mouse. 
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Installing P-CAD Products 
For up-to-date installation information refer to the file Readme.WRI, located on the product CD. This file 
can also be found in the application program folder (\Program Files\P-CAD 2002) after installation. 
Note that the setup program on the Product CD can also be used to Repair or Remove an existing P-CAD 
Installation. 
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CHAPTER 3 

InterPlace Basics 

This chapter introduces many of the basic features you need to know when using P-CAD 
InterPlace.  It includes general information on such topics as: 

• Using IPL from PCB, Relay, or Schematic 

• IPL user interface. 

• Loading, saving, and closing a design. 

• Right mouse commands. 

What is presented here is a high level look at InterPlace capabilities.  These capabilities are detailed 
in later chapters. 

To keep with the easy-to-use tradition of P-CAD applications, much of the basic functionality of 
P-CAD InterPlace is similar to P-CAD PCB.  As a Windows user, you will also be familiar with many 
of the basic manipulations used for managing designs in IPL. 

Using InterPlace 
InterPlace is a versatile application that can be used to manage object organization on both a 
Schematic and a PCB design.  For a PCB design, IPL contains additional functionality which speeds 
component placement such as on-the-fly net optimization, data tips, discrete placement tools and 
component swap.  

The role of InterPlace in the P-CAD product suite is summarized in the sections below.  

PCB and Relay Designs in IPL 
InterPlace can be invoked from P-CAD PCB or P-CAD Relay to perform object organization, floor 
planning and component placement.  For instance, you can quickly group components into logical 
groups, or partitions, using the Design Manager View. You can then place these partitioned 
components into a specific physical board region, or room, in the InterPlace Layout View.   

Unless specified, all references to InterPlace features when a PCB design is loaded are also relevant 
when a Relay design is loaded. 



Chapter 3: InterPlace Basics About the User Interface 

8 InterPlace User’s Guide 

To achieve these functions, when you launch IPL from PCB you have access to the Layout View and 
the Design Manager.  Each of these aspects of the InterPlace interface is discussed in About the 
User Interface below. 

Schematic Designs in IPL 
InterPlace can be activated from P-CAD Schematic to view design data and organize design 
components.  From Schematic, you may use IPL to define logical groupings of components and 
placement requirements to keep the PCB Designer informed of your design intentions. 

To achieve these functions, when you launch IPL from Schematic you have access to the Design 
Manager.  Each of these aspects of the InterPlace interface is discussed in About the User Interface 
below. 

The component placement interface, the Layout View, is not available in InterPlace for a Schematic 
design. 

About the User Interface 
The P-CAD InterPlace interface follows the standard Windows format, with the addition of IPL 
specific controls.  This section provides an overview of the user interface, including the menu bar, 
toolbars, and basic screen layout. 

InterPlace Interface 
When you first access P-CAD InterPlace, the interface displays an empty area for each of the views 
as shown below.  Some menu functions, except File » Load PCB Design, File » Load Schematic 
Design, Help and Exit are grayed, indicating they are unavailable.   
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When you load a design file from a P-CAD application, the design information is displayed in the 
appropriate viewing areas.  The InterPlace workspace views include: 

• The Layout View  

• The Design Manager 

Designs loaded from P-CAD PCB, Relay or Schematic provide the design information as it pertains 
to the Design Manager.  When a design is loaded from PCB, InterPlace also graphically displays the 
board in the Layout View.  

Each of these InterPlace views is summarized in the InterPlace Views section.   

Menu Bar 
The menu bar allows you easy access to InterPlace commands and functions.  The menu commands 
available depend on whether the design is loaded from PCB or Schematic, since the function of IPL 
differs for each application.  

Before you load a design, the IPL menu bar contains only the File and Help menu items.  From the 
File menu you can choose to load a PCB or Schematic design. 

When you load a design from PCB, the menu bar of IPL appears as follows:   

 

A design loaded from Schematic activates the abbreviated menu bar as shown below: 

 

To activate a menu, click the menu title or press the Alt key in combination with the underlined 
letter of the menu title (e.g., Alt+F to open the File menu).  When the menu appears, click a menu 
item, or press the underlined key, to enable a command. 

• A command followed by three dots (e.g., Open...) opens a dialog when you choose it. 

• The menu bar wraps if you reduce the width of the window. In contrast, other areas of the 
screen truncate with screen reduction. 

InterPlace Toolbars 
Toolbars provide shortcuts to commonly used commands and functions.  Toolbars appear when 
you activate the appropriate View command.  Once a toolbar is visible on your screen, you can use 
your mouse to drag it to a new position.  It can be docked along the edges of your screen, or left 
floating in the middle of your display.  A floating toolbar can be resized.   

Tool Tips explain each of the toolbar buttons.  To activate a Tool Tip, simply place the mouse over 
the button.  

P-CAD InterPlace has one basic toolbar: the command toolbar.  When a design is loaded from PCB, 
an additional Layout View options toolbar is available for each placement interface window.   
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These toolbars are detailed in the sections below. 

Command Toolbar 
The Command Toolbar provides shortcuts to menu commands and other system functions.   

The Command Toolbar is attached to the main workspace, or Layout View.  When a design has 
been loaded into InterPlace from PCB the toolbar shortcuts apply to the Layout View and appear as 
follows: 

 

The buttons on the command toolbar perform the following functions: 

 
Edit Select 

 
File Update PCB/Schematic 

 
Edit Undo 

 
Edit Redo 

 
Edit Measure 

 
View Zoom 

 
Edit Discrete Placement 

When a design has been loaded into IPL from Schematic the toolbar shortcuts apply only to the File 
» Update Schematic command. 

Layout View Options Toolbar 
The Layout View Options toolbar is available only when the design is loaded into InterPlace from 
PCB.  These commands apply to specific Layout View windows.  If you have multiple Layout View 
windows open on a design, each window has its own toolbar.  Actions from this toolbar impact only 
the design in its specific window.   

The Layout View Options toolbar provides board layer control and activates the Visible Placement 
Area, and appears as follows in the Layout View workspace: 

 

Layout View Board Control: The buttons that appear on the Layout View Board Control options 
toolbar allow you to choose the current layer and enable or disable the background display of the 
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opposite layer.  The buttons are: Top Current, Top Only, Bottom Current, and Bottom Only.  They 
are grouped in pairs and only one button in one pair can be active at any time. 

The first button in either pair enables the current layer, either the Top or Bottom.  Once the current 
layer is selected, the second button in the pair enables or disables the display of the opposite layer.  
For example, the toolbar displayed above indicates that the Top layer is the current one, and the 
display of the bottom layer is enabled. 

 

Visible Placement Area: The buttons that appear on the Layout View VPA toolbar are used to 
enable the display of an area on the board where a selected component can be placed without 
violating existing constraints.   

The Visible Placement Areas are divided into three domains: Physical, Electrical and Room.  Within 
each domain certain constraints, such as clearances and maximum net lengths, are used to 
calculate and visually display an error-free location in which to place the selected component.  

Each constraint domain is enabled by clicking the appropriate button, and disabled by clicking it 
again. 

Prompt Line 
The prompt line lies below the work area and is the first line of the prompt/status line area, 
extending the complete width of the InterPlace display (the second line being the status line).  It 
can be displayed or hidden using the View » Prompt Line command.  When the prompt line has not 
been enabled, the area is empty.   

 

When you first enable a command or process, the prompt line displays a prompt message that 
provides useful instructions on what to do when a certain tool or item is selected. 

Status Line 
The status line area, located at the bottom of the screen, can be displayed or hidden using the View 
» Status Line command.  A check mark next to the status line indicates that the status line is 
activated.  

The status line is available when a design is loaded into InterPlace from PCB.  The status line 
includes additional functionality for the placement interface windows: the X and Y coordinates and 
the grid toggle buttons.  The status line of IPL is pictured below: 

 

Status Information Area 
Displays information relevant to the action you are currently performing. 
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The information area displays the following types of data: 

• Identifies selected objects either specifically (reference designator) or generally (number of 
items selected). 

• The delta X and delta Y measurements of objects being moved. 

X and Y Coordinates  
These two values in the lower-left corner of the status line show you the position of the cursor as 
you move it over the Layout View workspace. The display lets you enter the exact X and Y 
coordinates of specific points on the screen. 

Keyboard shortcuts listed below are defaults; you can change them using the Options » 
Preferences command. 

If the Select tool is enabled, these boxes act as a shortcut for the View Jump Location command: 

1. Press the J key to get focus on the X coordinate edit box. 

2. Type an X coordinate value. 

3. Press the Tab key to move to the Y coordinate box. 

4. Type a Y coordinate value.   

5. Press Enter.  The cursor moves to the new X, Y coordinate, scrolling the workspace if 
necessary. 

The coordinate values express either millimeters or mils, depending on the settings in the Options 
Configure dialog. The decimal point for mm is set at hundredths and for mils at tenths.  Negative 
numbers appear in relative grid mode only when the relative origin point is somewhere other than 
the lower-left (absolute) origin. 

Grid Toggle Buttons 
The Grid Toggle button and the grid combo box beside it allow you to easily switch between grid 
settings and add new grid settings.  The toggle buttons switch between absolute grid  and 
relative grid .  Your absolute and relative grid values can be changed from the combo box.  The 
A key also toggles between absolute and relative grids. 

Absolute grid always uses the lower-left corner of the workspace as the origin point (X and Y are 
both zero).  Relative grid allows you to specify any point as an origin point.  You can even make the 
origin point for relative the same as for absolute, thereby making the toggle button a combination 
of grid sizes rather than absolute vs. relative. 

Use the drop down combo box to select a new grid and to add new grids to your design. 
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To add a new grid, type a new value and press Enter.  The new grid becomes the current grid.  The 
G key scrolls forward through the list of grid settings.  Shift+G scrolls back through the list. 

Data Tips 
Data tips are available in the Layout View when the design is loaded into InterPlace from PCB.  
When you place the mouse over a room, a component, a component pad, or a connection, a data 
tip appears which contains information about the underlying object.   

A component data tip is shown in the diagram below: 

 

For rooms, the data tip contains the following room properties: 

• Room Name 

• Placement Side 

For components, the data tip contains the following component properties: 

• Reference Designator 

• Component Type 

• Value 

For component pads, the data tip contains the following component pad properties: 

• Component Reference Designator 

• Component Pad Number 

• Net Name 

For connections, a data tip contains the following connection properties: 

• Net Name 

• Reference Designators of Connected Components 

• Pad Numbers of Connection Endpoints 

You can turn off the display of the properties data tips in the Options Display dialog. 

InterPlace Views 
Each view in InterPlace specializes in a unique design function. The Layout View provides the 
graphical representation of the PCB design and the workspace to physically arrange components 
on the board outline. The Design Manager View is used to organize design objects and provide 
many different aspects of the design’s data.  
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The Layout View 
When a design is loaded into InterPlace from PCB, you can reconfigure the board’s components in 
a Layout View window. The Layout View window shown below displays the board layout of a 
design: 

 

In the IPL Layout View window, the board outline, components, and other design objects that 
influence component placement are displayed.  Only the Top and/or Bottom layers are visible.   

Several windows can be open simultaneously.  In these windows, you can view multiple aspects of 
the same design.  For example if components are moved in one window, their new location is 
reflected in the other open design windows.  Components can even be moved between windows.  
You can easily switch between windows by clicking on the window tabs at the bottom left of your 
workspace. 

For more information about loading a design and using the Layout View of InterPlace, refer to The 
Layout View, (page 21). 

The Design Manager 
The Design Manager View provides a simple interface for organizing groups of design components 
and affords easy access to information about the nets, net classes and class-to-classes in your 
design. 

With InterPlace, you can divide the design into smaller logical blocks, or partitions, and organize 
the components within these divisions.  You can also manage physical regions on the PCB board 
layout, called rooms, where the partitions can be assigned. 

The Design Manager view may be enabled or disabled using the View » Design Manager command. 
When visible, the view can be disabled by clicking the appropriate button at the top right corner.  
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The Design Manager can be resized by positioning the cursor on the edge of the line you want to 
move, then dragging it to the right or left and releasing the button at the desired location.  
Additionally, if you double-click on the gray lines at the top of the view, the view is undocked and 
floats in the middle of your display.  You can then use your mouse to drag it to a new position. 

When enabled, the view appears in your workspace as shown below: 

 

For more information about using Design Manager, refer to The Design Manager View (page 37). 

Loading, Saving and Exiting a Design 
This section details basic manipulations within InterPlace, including loading and updating a design, 
as well as exiting the application.  

Loading a Design 
To load a design into P-CAD InterPlace, the design must first be opened in P-CAD PCB, P-CAD 
Relay, or P-CAD Schematic.   

Once the design is open and active in the originating P-CAD application, choose the Utils » P-CAD 
Design Constraint Manager command.  The Design Constraint Manager command is used to 
launch InterPlace and/or Parametric Constraint Solver, depending on which product licenses you 
have purchased.  You can also launch InterPlace from your Windows desktop. 

From the InterPlace File menu choose the Load PCB Design or the Load Schematic Design 
command to begin the design loading process.   
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After a design has been loaded, the File » Load PCB Design and File » Load Schematic Design 
commands are changed to File » Update PCB or File » Update Schematic, depending on the 
application from which the design was loaded. 

 

The design is loaded automatically and the InterPlace workspace displays the appropriate viewing 
areas.  The Design Manager View is always displayed.  If the design is loaded from PCB, the Layout 
View appears and contains design objects required for accurate component placement. 

Only designs with a complete board outline may be loaded into IPL from PCB or Relay.  Extraneous 
line segments, such as hand drawn dimensions using the line tool, can be moved off the board 
layer (e.g., to assembly layer) so the design may be loaded.  

While a design is loaded, the originating P-CAD application is locked so that conflicting changes to 
the design or the design constraints cannot be made.  Refer to P-CAD Application Lock for details. 

P-CAD Application Lock 
When P-CAD InterPlace is running, the P-CAD application from which the design originated is 
locked.  The lock prevents conflicting changes to the PCB or Schematic design.  The following 
warning is displayed over the PCB or Schematic workspace while the design is loaded into 
InterPlace. 
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Cancel terminates the DBX (P-CAD Database Exchange programmer's interface) connection 
between the applications.   

Design information is communicated between the originating application and InterPlace via DBX.  
If you wish to update the design with changes made in InterPlace, do not click Cancel.  To unlock 
the design, use either the File » Update PCB or File » Update Schematic command to save changes 
to the original design.  Then, close the design or exit InterPlace. 

Saving the Design  
If you would like to continue working on the current design, use the File » Update PCB or File » 
Update Schematic commands or click the Update PCB or Update Schematic buttons to save the 
changes to the original PCB or Schematic design file.  With any of these commands, the file remains 
open so you can continue working on it in P-CAD IPL.  The current design file name and location 
are unchanged by this command. 

If you have finished working with the current design, choose File » Close.  This command closes all 
InterPlace views.  The design is unlocked in the originating P-CAD application, permitting changes 
again in the current PCB or Schematic design editor.  

Exiting InterPlace 
Choose the File » Exit command to exit P-CAD InterPlace.   

If an open design has been modified since the last save, you are prompted whether you want to 
save the changes. 

The design files are unlocked in the originating P-CAD application, permitting changes again in the 
PCB or Schematic design editor. 

The program writes information to the .ini file when you choose Exit.  This information, which 
will apply to subsequent InterPlace sessions, consists of parameters and settings such as values set 
in Options Configure, etc.   

Right Mouse Commands 
When you select an object and click the right mouse button, a pop-up menu appears providing 
shortcuts to common commands performed on selected objects.  This menu changes depending 
on the object you select and the view from which they are selected. 
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The following table summarizes the commands that appear on the pop-up menu along with the 
P-CAD design in which it is active. 

 

Command Description PCB SCH 

Add Selected 
Components 

Adds the selected components to 
a partition. 

Yes Yes 

Add To Adds selected components to a 
room. 

Yes  

Cluster By  Provides a way to group 
components in a common area 
based on a criteria chosen from 
the pull right list of selection 
options. 

Yes  

Delete Deletes a selected partition or 
class-to-class. 

Yes Yes 

Delete Net Class Deletes a selected net class. Yes Yes 

Hide Connections Makes the net connections 
invisible for a selected net. 

Yes  

Highlight Highlights the nets in a Class-to-
Class when the connections are 
visible. 

Yes  

Highlight Attached 
Nets 

Highlights nets attached to the 
selected objects in the current 
highlight color. 

Yes  

Highlight 
Components 

Highlights the selected 
components in the current 
highlight color. 

Yes  

Highlight Nets Highlights the selected nets in the 
current highlight color. 

Yes  

Highlight Room and 
Assigned 
Components 

Highlights a selected room along 
with the components included in 
the room. 

Yes  

Jump To Component Positions the cursor on the 
selected component in the Layout 
View. 

Yes  

Jump to Pin Positions the cursor on the 
selected net pin in the Layout 
View. 

Yes  
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Command Description PCB SCH 

Move To Moves selected components to a 
partition, or selected nets to a Net 
Class. 

Yes Yes 

New Class to Class Adds a new class-to-class to the 
design. 

Yes Yes 

New Net Class Adds a new net class to the 
design. 

Yes Yes 

New Partition Creates a new partition. Yes Yes 

Remove Component Removes selected components 
from a partition. 

Yes Yes 

Remove Nets Removes nets from a net class Yes Yes 

Rename Renames a partition. Yes Yes 

Rename Net Class Renames a selected net class. Yes Yes 

Show Connections Makes the net connections visible 
for a selected net. 

Yes  

Show Connections 
on Drag 

Makes the net connections visible 
for a selected net when 
components in the net are 
moved. 

Yes  

Select Component Selects an individual component, 
or the components assigned to a 
room or partition. 

Yes  

Unhighlight Removes highlighting from the 
nets in a Class-to-Class when the 
connections are visible and 
highlighted. 

Yes  

Unhighlight 
Attached Nets 

Removes highlighting from the 
nets attached to the selected 
objects when they are visible and 
highlighted. 

Yes  

Unhighlight 
Components 

Removes highlighting from 
highlighted components. 

Yes  

Unhighlight Nets Removes highlighting from 
selected, highlighted nets. 

Yes  
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Command Description PCB SCH 

Unhighlight Room 
and Assigned 
Components 

Removes highlighting from a 
highlighted room and its assigned 
components. 

Yes  
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CHAPTER 4 

The Layout View 

In this chapter, the InterPlace Layout View is detailed.  Manipulations of the design objects are 
covered, including controlling design layers, placing and moving components, viewing connections 
and turning on a Visible Placement Area.   

The Layout View is only available if a design has been loaded from PCB or Relay. InterPlace 
interacts with P-CAD PCB to obtain the most current design information and displays only the 
information relevant to component placement.  Changes made to the design in IPL can later be 
transferred back to update the PCB design file.   

Working with the Layout View 
The Layout View in InterPlace displays the graphic presentation of the design.  The board outline, 
components and net connections appear in this area.  

Because InterPlace works with design information relevant to component placement, only certain 
elements of design objects are loaded such as the board outline, connections, components, 
keepouts, pads and mounting holes and rooms.  

You can display the design in multiple Layout View windows simultaneously.   Each open Layout 
View window’s functions can be controlled individually.  You can toggle back and forth between 
the windows, and arrange them in the workspace so they are all displayed at once. 

With the Options Display dialog you can control familiar settings such as the background, highlight 
and selection colors used in the design’s display.  In InterPlace, the board outline and power pin 
colors can also be changed.  You can modify the cursor style and enable or disable the display of 
information in the data tips.  The font size for the reference designator text can be specified as well. 

More information on the Options Display dialog can be found in Options Commands, (page 105). 

Viewing the Layout View 
The Layout View of InterPlace is displayed in the workspace along with the Design Manager.  
Before a design has been loaded the IPL workspace appears as shown below: 
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The gray area at the left side of the workspace is the Layout View with no design loaded.  The right 
side of the workspace contains the Design Manager view, which is detailed in The Design Manager 
View, (page 37). 

Loading Designs 
A design is loaded into InterPlace using the File » Load PCB/Schematic Design command(s).  When 
the design is loaded from PCB or Relay, the graphic representation of the information pertinent to 
component placement appears in the Layout View.  A loaded design might appear as follows: 
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The design file data imported into InterPlace is detailed in Design Objects. 

Design Objects 
When loaded into InterPlace, only objects that impact component placement are visible.  Visible 
objects are listed below:   

• Board outline 

• Connections 

• Components 

• Keepouts 

• Pads or Mounting Holes 

• Rooms 

The board outline, rooms, keepouts, pads, and mounting holes provide visible indications of where 
to place a component. These objects can not be selected.  Only components may be selected and 
moved. 

Polygon keepouts placed on the Top or Bottom (or All) layer, are transferred into InterPlace.  Line 
keepouts are not transferred.  

You may indicate a cut away portion in the interior of the board as surrounded by a contiguous line 
in PCB.  If there exists more than one complete outline, InterPlace interprets each as a board 
outline.  Because a design can have only one board outline, the design will not be loaded into IPL.  
To indicate the cut away board area, use instead a polygonal keepout on all board layers.    

All design objects must be loaded with the original design.  New components or new rooms, for 
example, cannot be added to the InterPlace workspace after the design has been loaded.  

The table below shows the display characteristics of the design objects loaded into the Layout 
View: 

 

Data Loaded Display Characteristics 

Board Outline Lines and arcs only.  

Keepouts Only Poly Keepouts defined as top, bottom and all layer are displayed.  
Poly Keepouts appear in the color(s) selected in the IPL Options Display 
dialog. 

Mounting 
Holes 

Holes are displayed in a close approximation of their original shape. 

Free Pads Free pads are displayed in a rounded, rectangular shape.   
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Data Loaded Display Characteristics 

Rooms Rooms are transparent with boundaries that use the color(s) selected in 
the IPL Options Display dialog.  Rooms appear on a layer according to 
their PlacementSide attribute value (top, bottom or both). 

Layers Only Top and Bottom layers are displayed.   

Grids Grids mirror the settings from the PCB design.  New grids can be added, 
but are not exported back to PCB. 

Components Lines, arcs and pads are imported and displayed in their original size.  
The RefDes and object outlines are displayed in the color(s) selected in 
the IPL Options Display dialog and include selected, fixed, highlight and 
layer colors.   

All components of a single type are represented as a single instance in 
IPL.  Silk screen edits done in PCB may not be displayed in IPL. 

 

Using Multiple Windows  
P-CAD InterPlace allows you to open multiple windows on the same design to view different parts 
of it simultaneously.  To open multiple windows, choose the Window » New Window command. 

Opening multiple windows of a design can be used to view the Top and Bottom layers of the same 
design.  Or, multiple windows may be used to work on two different regions of the board 
simultaneously.  Also, you may want to zoom in on a group of unplaced components in one 
window; while in the other window, you focus on the board region where this component group 
will be placed.  A component can be selected, dragged across the window boundaries, and placed 
on the board in another window.  

Each window you open creates a Layout View window inside the main application window in which 
you can edit the design.  As is standard in Windows, you can change the length and width of each 
window in relation to the other windows running on your screen.  You can also activate or 
deactivate other screen areas such as the Design Manager, toolbars and status/prompt line areas, 
which alternately decreases or increases the available space in the application window. 

An InterPlace workspace with multiple views of the same design is shown below: 
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You can easily switch between windows by clicking on the window tabs at the bottom left of your 
workspace: 

 

Board Layer Controls  
Each window in P-CAD InterPlace has a set of toolbar buttons for the board’s layer control as 
shown below: 

 

These Layout View options toolbar buttons perform the following functions in the order they 
appear on the toolbar: 

• Top Current: Displays components placed on the Top layer in the chosen layer color. 

• Top Only: Hides the components placed on the bottom layer when the Top Current button is 
depressed. 

• Bottom Current: Displays components placed on the Bottom layer in the chosen layer color. 

• Bottom Only: Hides the components placed on the Top layer when the Bottom Current button 
is depressed. 
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In InterPlace, only the Top and Bottom layers of any design can be displayed. One layer can be 
current at a time.  When a layer is current, the components on that layer may be selected using the 
Edit » Select tool. 

To set the current layer, click the corresponding Top Current or Bottom Current button.  To view 
only the components on the Top layer, press the Top Only button.  To display only the components 
on the Bottom layer press the Bottom Only button. 

With multiple windows open you can have both the Top and Bottom layers current simultaneously.  
You can then select and move components from the Top layer to the Bottom layer and vice versa. 

Visible Placement Area Controls  
Each window in P-CAD InterPlace has a set of toolbar buttons for the individual Visible Placement 
domains as shown below: 

 

The three Visible Placement Areas are Physical, Electrical and Room.  When one or more of the 
placement areas is enabled, InterPlace displays an error-free area on the board where a selected 
component may be placed. 

The Visible Placement Area, (page 75) describes in detail how to use this powerful placement tool. 

Display Settings 
As in P-CAD PCB, you have the option to choose how objects are displayed in your IPL board 
design.  Among the familiar settings you can choose are: 

• Colors for Layers, Pads, Components, Reference Designators, Keepouts, Background, 
Highlights, Selection, Connects, 1x and 10x Grids, Fixed Components, All Layer Keepouts and 
Power Pins. 

• Cursor Style, which can be Arrow, Small, or Large Cross. 

• Miscellaneous settings in which you can choose to display scroll bars, a component’s reference 
designator and draft mode display. 

InterPlace provides additional viewing options such as: 

• A different display color for your board outline and connected power pins. 

• A unique color for the Visible Placement Area. 

• Turning on or off the display of information provided in a data tip. 

• Setting the exact font size of the component reference designator. 

Refer to Options Commands, (page 105), for all the information on options settings. 
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Working with Components 
One of the InterPlace specialties is component manipulation.  You can move, place, swap, and fix 
components, rearranging their layout on the board to satisfy the design constraints.   

When a PCB design is initially loaded into the P-CAD InterPlace Layout View, the components are 
located in their original position.  These components may be easily moved in IPL.  They can be 
dragged and dropped anywhere on the workspace – and even across windows! 

All components must be loaded from the original design.  New components cannot be added to 
the InterPlace workspace.   

Organizing and Placing Components, (page 55), has complete details on using the organization and 
placement functions and tools provided by InterPlace. 

Locating Components 
In order to begin placing or moving components in the Layout View, you first need to locate them.  
InterPlace provides the ability to cluster a group of components into a common area, locate a 
specific component and jump directly to a desired location.  In addition, you can highlight 
components and nets across the applications under certain conditions.   

Additional information on highlighting across applications follows in Cross-Probing Between 
Applications, (page 28). 

Clustering Components 
Placing components onto the board is much easier if the components you need are first grouped 
together in a common work area.  From that grouping of components you can quickly find a 
particular one and place it in the desired position on the board.   

The Cluster By command in the Edit menu offers the following options by which you can gather 
components into a common area: 

• By Reference Designator 

• By Type 

• By Package size 

• By Pin Count 

• By ComponentHeight Attribute 

• By PlacementSide Attribute 

Refer to Edit Commands, (page 87), for more information on each of the clustering options, or 
Organizing and Placing Components, (page 55), which provides details on using the cluster option. 
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Locating a Specific Component 
With the Edit Move By RefDes command, you can select a component by its reference designator.  
Once identified, the component is highlighted and the cursor becomes an X.  You can click the left 
mouse button anywhere in the workspace and the component is placed in that position. 

From the Edit Properties dialog, you can view or modify the properties of the selected component.  
For information, refer to Accessing Component Information, (page 31).  

Refer to Edit Commands, (page 87), for more information on the Edit » Move By RefDes command.  

Jumping to a Location 
If you know the X and Y location coordinates of a component, or you want to quickly position your 
cursor in a particular spot on the board, you can use the View » Jump Location command.   

Once the desired location coordinates are entered in the View Jump Location dialog, and you click 
OK, your cursor is positioned at that point on the board.  You can also use the J key to enter those 
coordinates on the status line, as you do in PCB. 

View Commands, (page 99), has complete information on the View » Jump Location command. 

Cross-Probing Between Applications 
When you enable the DDE Hotlinks option in the Options Configure dialogs of P-CAD Schematic 
and P-CAD InterPlace, it is possible to highlight a component or net in Schematic and see the 
corresponding component or net highlighted in InterPlace as well.   

Working with PCB and Schematic, (page 69) has the step-by-step instructions on setting up the 
cross probing between applications. 

Placing Components 
The design components imported to InterPlace from the P-CAD PCB design can be manipulated in 
many ways. Components can be placed onto the board using the drag and drop method, the Place 
On command and the Discrete Placement tool.  Once placed in their proper board position, they 
can be moved, fixed, rotated, flipped and swapped.   

Organizing and Placing Components, (page 55), has detailed instructions on how to use the 
placement functions and tools. 

Component Placement 
When the board design is loaded into P-CAD InterPlace, the components are in their original 
position on the workspace.  This may be within or outside of the board outline (i.e., placed or 
unplaced). 

To place a selected component(s) in the Layout View of IPL, depress the left mouse button, drag the 
component(s) to the new location and release the button.  If the component is released within the 
board outline, it is placed. 
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You may, for example, want to move an unplaced component onto the board to place it.  Or, you 
may want to move a placed component to a region outside of the board outline so that you can 
rearrange other, placed components. 

A selected component or group of components can be forced onto either the Top or Bottom layer 
using the Edit » Place On command.  If you have selected a group of components, some residing 
on the Top layer and others on the Bottom, the Place On command places them all on the layer of 
choice. 

You can also move components in IPL using the familiar commands: Edit » Move By RefDes and 
Edit » Align Components.  Refer to Edit Commands, (page 87), for details. 

Fixing Components 
A fixed component in InterPlace may not change its location.  For example, the following 
commands do not operate on a fixed component: 

• Move (dragging a selected component) 

• Move By Refdes   

• Rotate 

• Flip 

• Align Component 

A fixed component is displayed in the Fixed color selected using the Options Display dialog.  

To fix a component that has been placed on the board outline you only need to select it and 
choose the Fix Component command from the Edit or right mouse menus.  You can Unfix the 
component(s) in the same way, choosing the Unfix Component command instead. 

Rotating Components 
As in PCB, you can rotate selected components 90 degrees by pressing R (or Shift+R).  In InterPlace, 
you can also rotate all selected components to an absolute angle.  For example, you can choose to 
rotate all selected components to 90 degrees. To do so, choose the desired degree from the 
options listed when the Edit » Rotate To command is chosen. 

The selected components are all rotated to the specified angle, regardless of their initial 
orientation.  A single, selected component rotates around its own reference point.  When a group 
of components is selected, and the R key pressed, the group rotates around a reference point 
placed, by default, in the middle of the group.   

You can change the reference point around which a group of components rotates by placing a 
selection point at the desired location inside the selected group.  To do so, select the group of 
components and choose Selection Point from the right mouse menu.  Position the cursor at the 
desired location inside the block of components and click the left mouse button.  The components 
will now be rotated around the new reference point.  
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Flipping Components 
As in PCB, you can flip selected components to the opposite board side by pressing the F key.  In 
InterPlace, you can also flip all selected components to a particular board side.  For example, you 
can choose to flip all selected components to the Bottom layer. To flip the selected components 
choose the Edit » Place On command, and then the desired layer (Top or Bottom). 

The selected components are all flipped to the specified layer, regardless of their initial flipped 
value.  

Discrete Component Placement 
With a design that uses large numbers of discrete components, like bypass caps, a designer can 
spend a lot of time finding and placing these components. The Discrete Placement tool helps you 
reduce the time expended placing these components.  With just a few clicks of the mouse you can 
rapidly position a large number of discrete components near their associated components, 
eliminating the need to find each of them and drag them into place.  

The Discrete Placement tool finds the discrete components you want to place by component Type 
or Value.  It permits you to specify how many are to be placed with each mouse click.  It keeps track 
of the number of the components that have been placed, and how many are still available.  You can 
also designate whether they should be placed on the same or opposite side of the current layer. 

Each time you click the left mouse button over a placed component, InterPlace positions the 
specified number of discrete components near that component.   

Organizing and Placing Components, (page 55), provides complete instructions on using the 
Discrete Placement tool. 

Moving Components 
Designing an efficient, functional board means moving components and connections a number of 
times to obtain the optimal design.  InterPlace lets you move components around a single Layout 
View or from one Layout View to another.  You can also drag components from a list in the Design 
Manager View and drop them into a Layout View.  In addition, the locations of two selected 
components can be swapped. 

Organizing and Placing Components, (page 55), provides more information on getting components 
into their most efficient position in the board design. 

Moving Components Across Windows 
When you have multiple design windows open, you can select one or more components in one 
window, drag them across the window boundary, and place them in another window.  Refer to 
Using Multiple Windows for details. 

Moving Components from the Design Manager 
You can move one or more components into the Layout View from the Design Manager 
Components, Partitions or Rooms pages.  Simply select the component(s) name(s) in the Design 
Manager tree, drag them to the desired location in the board outline and drop them! 
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Swapping Components 
You can interchange the location of two components in the Layout View.  Simply select two 
components, and from the Edit or right mouse menu choose the Swap Component command.   

The selected components exchange positions, including placement layer, while maintaining their 
individual rotations. 

Aligning Components 
Components can be aligned around a selection reference point either horizontally or vertically, 
and as an option, they can be equally spaced.  If a number of components are off-grid, they can be 
aligned back onto the grid. 

InterPlace, like PCB, helps to quickly and accurately align components in the locations where they 
are most likely to satisfy the design constraints.  Selected components are aligned using the Align 
Components command from the Edit or right mouse menus. 

Fixed components cannot be aligned and the Align Components command is undoable. 

Refer to Edit Commands, (page 87), for additional instructions on using the Align Components 
command. 

Accessing Component Information 
Component Properties include basic information about the component, including reference 
designator, type, attributes, etc.  These properties can be viewed in a data tip or by displaying the 
component properties dialogs.  

Component Data Tips 
Use the data tip feature of InterPlace to get a quick look at some basic component properties.  
When you place the cursor over a component or component pad, a data tip appears which contains 
information about the underlying object, as shown below for a component:  

 

For a component, the data tip displays the reference designator, component type and value.  The 
data tip for a component pad shows its component reference designator, component pad number 
and net name.  The room name and placement side are displayed in a room data tip. 

Make sure you are not overlying a connection line if you wish to view a component, pad or room 
data tip.  You can turn off the display of the properties data tips in the Options Display dialog.   
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Component Properties 
Select a component(s) and choose Edit » Properties to view the selected component’s properties.  
You can also choose the right mouse Properties command.  The Component Properties dialog is 
displayed and details component characteristics, including design constraints or attributes assigned 
to that component. 

Refer to Edit Properties, (page 88), for information. 

Component properties can be modified using P-CAD PCB or P-CAD Relay. 

Using Net Connections 
Connections between components can be viewed in P-CAD InterPlace to visualize routability and 
net length requirements.   

By viewing connections you can envision the board’s routing channels, spacing components 
appropriately.  Also, you can distribute the density of connection lines to minimize routing 
congestion.  When the Visible Placement Area Electrical domain is enabled, and a maximum net 
length constraint applied, InterPlace shows you where the component can be placed without 
violating the necessary net length. 

In InterPlace, net lengths may be optimized as a component is moved using automatic net 
optimization.  You can choose the component’s placement location knowing in advance the 
configuration of connection lines.  Refer to Optimizing Net Connections, (page 33) for more 
information. 

By default, net connections are hidden in InterPlace.  The visibility of these connections can be 
enabled in a variety of ways.  For more information, see Setting Display Options of Specific Nets, 
(page 33). 

Accessing Connection Information 
When you place the mouse over a connection in the current layer, a data tip appears which 
contains information about the underlying object.  For connections, a data tip contains the 
following connection properties: 

• Net Name 

• Reference Designators of Connected Components 

• Pad Numbers of Connection Endpoints 

A connection data tip is shown below: 
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Similar data tips are available for components, component pads and rooms.  Connection data tips 
take precedence over component data tips, but not component pad data tips.   

You can turn off the display of the data tips, in the Options Display dialog.   

Setting Display Options of Specific Nets 
InterPlace provides the ability to show, show only on drag or hide the net connections in your 
design.  When the net connections are visible, you can highlight and unhighlight them. 

To choose the desired net connection display, you must first select the nets in the Design Manager 
view.  Then, from the right mouse menu you can select the kind of display you want to see: 

• Show Connections 

• Show Connections on Drag 

• Hide Connections 

To highlight a net with visible connections, select the net and choose Highlight from the right 
mouse menu.  You can remove the highlighting by choosing the Unhighlight command in the right 
mouse menu. 

For more information, see The Design Manager View, (page 37). 

Optimizing Net Connections 
Net connections may be automatically optimized as the components are moved to new locations.  
This shortens the length of the connections between net nodes.  Optimization rearranges 
connections logically in order to produce shortened or more direct routings, or dispersed routings, 
which ease congestion in certain board areas. 

You may not want to optimize nets with a large number of nodes, such as power or ground nets.  
You can specify a default value for the maximum pin count of a net if it is to be automatically 
optimized.  Nets with equal or fewer nodes are automatically optimized; nets with more nodes are 
not optimized.   

To specify this default value, choose Options » Configure: 
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Enter the desired value for the Net Optimize Max Pin Count. 

You can override this default value by assigning an Optimize attribute to specific nets.  For 
example, you may wish to optimize only one of the four nets in the design, which have more than 
20 nodes.  Alternatively, you may choose not to optimize a particular net despite its small number 
of nodes.  

Attributes can be assigned to nets in PCB prior to loading the design into InterPlace.  See your PCB 
User’s Guide for more information. 

Modifying Connection Properties 
You can modify the attributes or design constraints of a net using PCB.  See your PCB User’s Guide 
for details. 

Layout View Right Mouse Commands 
When you select an object and click the right mouse button, a pop-up menu appears providing 
shortcuts to common commands performed on selected objects.   

The following list summarizes the commands, which appear on the pop-up menu in the Layout 
View. 

• Align:  A shortcut for Edit » Align Components.  Components can be aligned around a 
selection reference point either horizontally or vertically, and as an option, equally spacing the 
parts. 

• Cluster By: This command provides a way to group components in a common area based on a 
criteria chosen from the pull right list of selection options. 

• Fix Components: A shortcut to Edit » Fix Components.  This command fixes the selected 
components so they may not be moved, rotated, or flipped. 
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• Highlight:  A shortcut to Edit » Highlight.  This command highlights the selected objects the 
current highlight color. 

• Highlight Attached Nets: This command highlights nets attached to the selected objects in the 
current highlight color. 

This also highlights the corresponding component in Schematic if the DDE Hotlinks check box 
in the Options Configure dialog is checked. 

• Place On: This command places a selected component(s) on the layer (top or bottom) chosen 
from the pull right list. 

• Properties:  A shortcut to Edit » Properties.  Depending on the object(s) selected, the 
appropriate Edit Properties dialog appears. 

• Rotate To: This command displays an additional menu from which you can choose an absolute 
degree of rotation for a selected component(s).   

• Selection Point: This command allows you to relocate a selection reference point for the 
selected object or objects. 

• Unfix Components: A shortcut to Edit » Unfix Components.  This command unfixes the 
selected components so they may once again be moved, rotated, or flipped. 

• Unhighlight:  A shortcut to Edit » Unhighlight.  This command removes the highlighting from 
selected objects. 

• Unhighlight Attached Nets: This command removes the highlighting from nets attached to the 
selected objects. 
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CHAPTER 5 

The Design Manager View 

Design floor planning is an integral element of the Design Manager View. With InterPlace, you can 
divide the design into smaller logical blocks or partitions. You can also manage physical regions on 
the board layout, called rooms, where these partitions can be assigned. The Design Manager View 
provides a simple interface for organizing design components into these logical and physical 
divisions.  

In addition to organizing the design components into logical and physical regions, the Design 
Manager provides easy access to information about the nets, net classes and class-to-class rules in 
your design.   

In this chapter, each method of organizing components, nets and net classes is discussed, as well as 
how you can use them to expedite the design and production of an efficient and cost effective 
circuit board. 

Working with the Design Manager View 
The Design Manager View of InterPlace displays the design information in either a tree-like 
structure or a simple list. You can view design data from a number of perspectives: components, 
nets, partitions, rooms, a net class and a class-to-class, each of which is available in a Design 
Manager View page. 

In the Components page you can rearrange the display of the details shown there by sorting the list 
of components using any of the column headings.  You can create partitions in the partitions page, 
and add components to or remove components from the partitions.  If you created a room in the 
PCB design, you can add or remove components in those rooms.  From the Nets page you can 
highlight existing nets and show their connections, and the nets can be organized into net classes 
and class-to-class groupings in their respective pages.  

In addition to viewing and organizing your design data, the Design Manager also provides easy 
access to other design features. You can move components from the Design Manager pages and 
cluster a group of components into a common work area in the Layout View workspace for a PCB 
design. 

In the next sections you will learn how to access the Design Manager View, move around in each of 
the pages, and employ its powerful functionality to expedite your design efforts. 
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Accessing the Design Manager View 
When you launch the InterPlace application, the Design Manager View appears if it was displayed 
at the time you last exited the application.  IPL stores the position and size of the Design Manager 
View from your last session in the .ini file and reconstructs those settings in the workspace for 
the new session. 

Before a design is loaded, the Design Manager View is empty.  Once a design is loaded using the 
File » Load PCB or Schematic Design commands, the Design Manager View displays the design data 
in the relevant pages.   

You can choose to view or hide the Design Manager View using the View » Design Manager 
command.   

The Design Manager View is displayed in the right side of the InterPlace workspace when IPL is 
launched, as displayed below for a PCB design:   

 

Accessing Design Manager Pages 
To access any of the pages in the Design Manager View, simply click the appropriate tab at the 
bottom of the view.  The data presented in the six different views of the design data are shown 
below with their associated icon:  

 

 
Components Page 

 
Nets Page 
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Partitions Page 

 
Rooms Page 

 
Net Class Page 

 
Class-to-Class Page 

 

On each page, except the Components Page, is a tree structure or hierarchy, containing all of the 
information pertinent to that page.  You can view the page’s contents at various levels of detail by 
expanding or collapsing the branches of the tree. 

Groupings containing collapsed levels are shown with a  sign.  To expand the grouping, simply 
click the .  Expanded groupings are shown with a  sign.  To collapse the grouping, simply click 
the   sign.  You can also use the  and  keys on a selected group to collapse or expand 
groupings, respectively. 

Selecting Items in Design Manager 
In order to perform functions on the data items in your design, you must first select one or more 
items in a page.  For instance, you may want to select components to add to a room or partition.  
You might also want to create a new net class or class-to-class from selected nets and net classes.   

Items can be selected using any of these methods: 

• To Select a Single Item:  Position the cursor on the item and click the left mouse button. 

• To Select a Contiguous Block of Items:  Position the cursor on the first item in the block and 
click the left mouse button, press the Shift key and click on the last item in the block.  You can 
also select an item, then press the Shift+End keys to select all the items that follow to the end 
of the list. 

• To Select Multiple Individual Items:  Press the Ctrl key while clicking the left mouse button on 
each item you want to select.   

You can right mouse click on a selected item(s) in the tree to access its pop-up command menu.  
Refer to Design Manager Right Mouse Commands, (page 51), for the complete list of right mouse 
commands. 

Common Design Manager View Commands and Functions 
There are commands and functions that are common to more than one of the pages in the Design 
Manager View.  For instance, you can cluster components from all of the pages and highlight 
components from the Components, Partitions and Rooms pages. 
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Selecting Components across Views 
When a design is loaded from PCB, you can select components from the Components, Partition 
and Rooms pages, and make them “selected” in the Layout View using the Select Components 
command in the right mouse menu.   

Making components selected in the Layout View is additive.  Each time you apply the Select 
Components command to a selected component from the Components, Partition or Rooms pages, 
it becomes selected in addition to any other components already selected in the Layout View.  
When all the desired components are selected in the Layout View, you can move them as a block 
around the workspace. 

Dragging a Component from Design Manager 
You can place a component into the Layout View from the Design Manager Components, Partitions 
or Rooms pages.  Simply select the component(s) in the Design Manager page, press the left mouse 
button, drag the object to the desired location in the board outline in the Layout View, and release 
the mouse button. 

Clustering Components 
You can cluster a group of selected components into a common work area in the Layout View using 
the Cluster By command.  A number of components grouped by Type, for instance, gives you easier 
access to the components for quicker placement on the board outline. 

In addition to clustering selected components as a group from the Components, Partitions and 
Rooms pages, you can select nets and net classes from their pages, or net classes from the class-to-
class page, and cluster the components they contain. 

Selected components are physically arranged in the workspace based on the chosen clustering 
option.  Clustering options are listed below: 

• By Reference Designator 

• By Type 

• By Package Size 

• By Pin Count 

• By ComponentHeight Attribute 

• By PlacementSide Attribute 

Organizing and Placing Components, (page 55), provides detailed information on using the 
clustering tool. 

Highlighting Objects 
There are a variety of ways and a number of objects that can be highlighted or unhighlighted using 
the appropriate commands.  The following table shows where highlighting options can be initiated, 
and which objects can be highlighted or unhighlighted. 
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Initiation Point Objects Highlighted or Unhighlighted 

Components Page Components 

Attached Nets 

Nets Page Nets 

Partitions Page Components 

Attached Nets 

Rooms Page Components 

Attached Nets 

Room and Assigned Components 

Net Class Page Nets 

Class-to-Class Page Net Classes within a Class-to-Class.  In this case the two net 
classes within the class-to-class are each highlighted in a different 
color. 

 

Once the objects are selected, and the appropriate highlighting command chosen, the Layout View 
displays the object(s) in the highlight color designated in the Options Display dialog. 

Net connections must first be made visible in order for them to be highlighted.  Using the Nets 
Page describes how to make a net visible. 

Refer to Options Commands, (page 105), for more information on the Options Display dialog 
where the highlighting color is selected. 

Unhighlighting Objects 
Highlighted objects can be unhighlighted using the Unhighlight command in the right mouse 
menu.  Each of the highlight commands shown in the table above has a complementary unhighlight 
command. 

Jumping to Components and Pins 
InterPlace makes it possible to quickly find a specific component.  When you select a component in 
the Components, Partitions or Rooms pages and choose the Jump to Component command, IPL 
finds that component’s location in the Layout View.   

In addition to finding a specific component, you can also let InterPlace locate a specific pin in a 
network.  To find a pin, simply click the  button next to the desired net in the Nets page to 
display the pins in that net, select the pin you want to locate, and then the Jump to Pin command.   

In both cases, the cursor is placed over the object in the Layout View.  If the object is on the current 
layer and the data tips have been enabled in the Options Display dialog, the relevant data tip 
information is displayed as well. 
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Using the Components Page  
The Components Page lists all the components in the design, along with some pertinent 
information about each of them, including the Type, Value, Placed indicator and Partition name.   

You can sort the components by clicking any of the column headers. 

Components can be dragged into the Layout View for placement on the PCB board and you can 
cluster a group of them into a common work area from the Design Manager View.  You can select a 
component in the Design Manager View and jump to its location in the Layout View using the Jump 
to Component command.  Components and their attached nets can be highlighted and 
unhighlighted as described in Common Design Manager View Command and Functions. 

Component Information 
For each component in the design, the following information is displayed: 

• Reference Designator or component identifier. 

• Type of component. 

• Value assigned to the component. 

• Placed indicates whether the component is or isn’t located on the board outline. 

• Partition displays the name of the partition the components is assigned to, if any. 

The Components Page appears as follows: 
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Sorting the Components 
You can sort the list of components for easier viewing by simply clicking on one of the column 
headings.  For instance, if you want to see which components have been placed on the board, or 
which ones are available to be placed, click the Placed column heading and the unplaced 
components float to the top of the list.   

Using the Nets Page  
The Nets Page of the Design Manager View displays a list of the nets in the design, and their 
associated pins.  From the Nets Page, you can highlight a net, show or hide the connections, jump 
to a particular node or cluster the components in a net into a common work area. 

Net Information 
The Nets page displays a list of the nets resident in the loaded design.  Nodes associated with each 
net are listed for designs loaded from PCB. 

A Schematic design loaded into InterPlace displays only the list of nets in the design.  No other 
functionality, such as highlighting or showing connections, is available, since there is no Layout 
View in which to display the results of these commands. 

The Nets page of the Design Manager View is displayed as follows:   
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Showing and Hiding Net Connections 
Component placement or movement on the board is sometimes simpler if the net connections are 
not visible.  The display of the nets in your design is controlled using the Show Connections and 
Hide Connections commands in the right mouse menu.  Another option available for displaying 
nets is the Show Connections on Drag command, where the nets are only visible when 
components are being moved. 

To turn on the display of one or more nets, simply select the desired net(s) and choose the Show 
Connections or Show Connections on Drag commands from the right mouse menu.  You can also 
enable the net connections display by selecting the net category in the Nets Page or a net class 
category in the Net Class Page and then the appropriate Show Connections commands in the right 
mouse menu. 

To hide the connections display, choose the Hide Connections command in the right mouse menu.   

Using the Partitions Page  
InterPlace provides a way to assemble components logically in a group referred to as a partition.  
Using a partition to group components is a great way to start organizing your design’s components.  
For instance, you can establish partitions with like properties, such as the analog or digital 
components, or partitions that contain components destined for a particular layer. 

Once the partitions are established, it is easy to highlight the entire partition of components, or 
their attached nets for a PCB design.  You can cluster the components in a partition for easy 
placement in the Layout View, or drag individual components from the partition and drop them in 
the Layout View.   

Partitions names can be used to describe the way the components are organized for easy 
identification.  For instance, you may have a partition containing the analog components and name 
it AnalogPart, or for components located on a Schematic Sheet number one you can create a 
partition called Sheet1Part. 

Organizing and Placing Components, (page 55), has more information on using partitions to help 
organize designs. 

Partition Information 
The Partitions page of the Design Manager View displays the list of components not assigned to a 
partition, provides the ability to create and delete partitions, and add or remove components from 
the partitions.   

Components can belong to only one partition at any time. 

When you first enter the Partitions page of the Design Manager View, and no partitions have been 
created, the components are grouped in the Unpartitioned Components list and are not visible.  
Click the  button next to Unpartitioned Components to display the list of components. 

The Partitions Page appears as follows: 
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Creating Partitions 
Components in a design with no partitions are, by default, unpartitioned.  A new partition is 
created using the New Partition command in the right mouse menu. The partition name can be 
changed. 

To Create a Partition   
1. Select the Unpartitioned Components folder or an existing partition.  

2. Choose the New Partition command from the right mouse menu.  The partition is given a 
default name of PartitionX, where X is a number incremented with each added partition. 

Deleting Partitions 
Any partition you create can be deleted.  If a deleted partition has components assigned to it, those 
components are placed back into the Unpartitioned Components list and the associated Partition 
name is deleted from the Components Page.  

To Delete A Partition   
1. Select an existing partition.   

2. From the right mouse menu, choose Delete or press the Delete key.  If the partition has 
assigned components, the components are placed back in the Unpartitioned Components list 
and the partition is deleted. 

The Unpartitioned Components folder cannot be modified or deleted.   
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Renaming Partitions 
The partition can be renamed.  Partition name changes are also reflected in the Partition column of 
the Components Page. 

To Rename a Partition   
1. Select an existing partition.  

2. From the right mouse menu choose the Rename command.  You may also double click on the 
partition name to put the field in edit mode.   

3. Enter the new partition name and press Enter. 

Adding Components to a Partition 
When a design is loaded into InterPlace, the components not assigned to a partition are part of the 
Unpartitioned Components list.  Selected components can be moved to a newly established 
partition using the Move To command or by dragging them from the Unpartitioned list into the 
target partition.   

Removing Components from a Partition 
When you remove components from a partition they are placed back into the Unpartitioned 
Components list.  Selected components are removed by dragging them from a partition into the 
Unpartitioned Components list or another partition by using the Remove Components command 
in the right mouse menu. 

Using the Rooms Page  
InterPlace allows you to group components into a physical area on the board known as a Room.  As 
an example, you may want the analog components in your design to be physically located at the 
front of the board and the digital components in the back.  The Rooms page provides an easy way 
to organize these components in the PCB design. 

Rooms must be placed on the board in PCB before the design is loaded into InterPlace.  A room 
cannot be created in InterPlace.  See your PCB User’s Guide for instructions on creating rooms. 

When components have been assigned to a room, it is easy to graphically highlight the entire 
group of components, or their attached nets.  You can cluster the components assigned to a Room 
for easy placement in the Layout View, or drag individual components from the room’s component 
list and drop them in the Layout View. 

Refer to Organizing and Placing Components, (page 55), for more information on the use of Rooms. 

Rooms Information 
When you enter the Rooms page of the Design Manager View, all of the design components are 
listed in the Available Components list and are not visible until you click the  button.   
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Components can be assigned to more than one Room, therefore, the list of Available Components 
does not change even after a component has been assigned to a room.  All components remain 
available for room assignment at all times. 

In addition to the Available Components folder, there is a Top, Bottom and Top or Bottom 
folder.  Existing Rooms are displayed in their appropriate folder, depending on the layer placement. 

The Rooms Page, expanded to show the available rooms, appears as follows: 

 

Adding Components to a Room 
When a design is loaded into InterPlace, the components available to be assigned to rooms are 
listed in the Available Components list.  Selected components can be added to a room using the 
Add To command or by dragging them from the Available Components list into the target room.   

Components can be included in more than one room, therefore the list of Available Components 
does not change when components are added to or deleted from a room.  Instead of being moved, 
component information is copied from the Available Components list into the target Room. 

Removing Components from a Room 
Selected components can be removed from a room only by using the Remove Components 
command in the right mouse menu. 

Using the Net Class Page  
Nets that are part of a design loaded into InterPlace can be organized into Net Classes using the 
Net Class page.  Grouping nets into a Net Class saves time and effort when you want to apply 
specific design constraints to a number of nets.  With the nets organized in a Net Class, 
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constraint(s) can be applied once to the Net Class, instead of repeating the constraint for each of 
the individual nets. 

Once a Net Class is established, you can delete and rename it.  You can move the nets from one 
Net Class to another using the drag and drop method or the Move To command.  

The nets in a Net Class can be highlighted and unhighlighted in the Layout View for a PCB design.  
You can also enable or disable the constant visibility of the connections or choose to show them 
only when their components are moved. 

Net Class Information 
The Net Class page of the Design Manager View displays the design’s net classes and nets.  When a 
net has not been assigned to a Net Class, it is listed in the Available Nets folder.  The 
Available Nets and any Net Class folders can be expanded for Viewing the included nets by 
clicking the  button or pressing the  key.  To collapse the lists, click the  button or press the 

 key.  

The Net Class Page, showing the expanded list for each of the existing Net Classes, appears as 
follows: 

 

Creating a Net Class 
A new Net Class is created by choosing the New Net Class command from the right mouse menu in 
the Net Class page.  

To Create a Net Class 
1. Select the Available Nets folder, an existing net class or simply click in the workspace.  
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2. Choose the New Net Class command from the right mouse menu.  The net class is given a 
default name of NetClassX, where X is a number incremented with each added net class. 

Deleting a Net Class 
Any Net Class in the design can also be deleted. 

To Delete A Net Class   
1. Select an existing net class.   

2. From the right mouse menu, choose Delete Net Class or press the Delete key.  If the net class 
has assigned nets, the nets are placed back in the Available Nets list and the net class is 
deleted. 

Renaming a Net Class 
The Net Class can be renamed.  

To Rename a Net Class   
1. Select an existing net class.  

2. From the right mouse menu, choose the Rename Net Class command to put the field in edit 
mode.   

3. Enter the new net class name and press Enter. 

Adding Nets to a Net Class 
Any net in the design is available to be added to a Net Class.  A net can belong to only one Net 
Class at a time.  To add a selected net to a Net Class, use the drag and drop method or the Move To 
command in the right mouse menu. 

Removing Nets from a Net Class 
Nets removed from a Net Class are placed back into the Available Nets list.  Selected nets are 
removed from a Net Class by dragging them from the Net Class into the Available Nets list or by 
using the Remove Nets command in the right mouse menu. 

Using the Class-to-Class Page  
When you have established Net Classes in your design, you can define constraints that apply to 
only those unique Net Classes.   

For instance, a single net in your design requires a clearance greater than any other net clearance.  
You can assign this one net to a net class, and all the rest to another net class.  The clearance 
constraint between the two net classes essentially keeps the single net in the first net class an 
exceptional distance from the other nets in the second net class. 

The nets in a Class-to-Class can be highlighted and unhighlighted for a PCB design.  You can enable 
or disable the consistent visibility of the net connections or show them only when their 
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components are moved.  Components connected by the nets in the Class-to-Class can also be 
grouped in the Layout View using the clustering tool. 

Class-to-Class Information 
The Class-to-Class page of the Design Manager View groups the design’s net classes in the list of 
Available Net Classes and does not display them until you click the  button.   

The Class-to-Class Page appears as follows: 

 

Creating a Class-to-Class 
A new Class-to-Class is created by selecting one or two net classes and then choosing the New 
Class-to-Class command from the right mouse menu.   

To Create a Class-to-Class 
1. Expand the Available Net Classes folder, if it is not expanded, to display the available net 

classes, by clicking the  button.  

2. Select one or two of the Net Classes in the list of available net classes.  The new Class-to-Class 
name is the name of the first net class with the name of the second appended to it.  If you only 
select one net class, the new Class-to-Class name is the net class name repeated. 

Deleting a Class-to-Class 
You can delete any Class-to-Class in the design. 

To Delete A Class-to-Class   
1. Select an existing class-to-class.   
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2. From the right mouse menu, choose Delete or press the Delete key.   

Design Manager Right Mouse Commands  
When you select an object and click the right mouse button, a pop-up menu appears providing 
access to the commands you can perform in the Design Manager View.   

The following table summarizes the commands, which appear on the pop-up menus, and the page 
where the command is available. 

The column headings indicate the page as follows:  C=Components; N=Nets; P=Partition; 
R=Rooms; NC=Net Class; CC=Class-to-Class. 

 

C N P R NC CC Command 

  X    Add Selected Components:  This 
command adds the selected 
components to a partition. 

   X   Add To:  This command is used to 
add selected components to a room. 

X X X X X X Cluster By:  This command provides 
a way to group components in a 
common area based on a criteria 
chosen from the pull right list of 
selection options. 

  X   X Delete:  This command deletes a 
selected partition or class-to-class. 

    X  Delete Net Class: This command 
deletes a selected net class. 

 X   X X Hide Connections:  This commands 
makes the net connections invisible 
for a selected net. 

     X Highlight:  This command highlights 
the nets in a Class-to-Class when the 
connections are visible. 

X  X X   Highlight Attached Nets:  This 
command highlights nets attached to 
the selected objects in the current 
highlight color. 
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C N P R NC CC Command 

X  X X   Highlight Components:  This 
command highlights the selected 
components in the current highlight 
color. 

 X   X  Highlight Nets:  This command 
highlights the selected nets in the 
current highlight color. 

   X   Highlight Room and Assigned 
Components:  This command 
highlights a selected room along 
with the components included in the 
room. 

X  X X   Jump To Component:  This 
command positions the cursor on 
the selected component in the 
Layout View. 

 X     Jump to Pin:  This command 
positions the cursor on the selected 
net pin in the Layout View. 

  X  X  Move To:  This command moves 
selected components to a partition, 
or selected nets to a Net Class. 

     X New Class to Class:  This command 
is used to add a new class-to-class to 
the design. 

    X  New Net Class:  This command is 
used to add a new net class to the 
design. 

  X    New Partition:  This command 
creates a new partition. 

  X X   Remove Component:  This 
command removes selected 
components from a partition. 

    X  Remove Nets:  This command 
removes nets from a net class. 

  X    Rename:  This command is used to 
rename a partition. 
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C N P R NC CC Command 

    X  Rename Net Class:  This command 
allows you to rename a selected net 
class. 

 X   X X Show Connections:  This commands 
makes the net connections visible 
for a selected net. 

 X   X X Show Connections on Drag:  This 
commands makes the net 
connections visible for a selected 
net when components in the net are 
moved. 

X  X X   Select Component:  This command 
selects an individual component, or 
the components assigned to a room 
or partition. 

     X Unhighlight:  This command 
unhighlights the nets in a Class-to-
Class when the connections are 
visible and highlighted. 

X  X X   Unhighlight Attached Nets:  This 
command removes highlighting 
from highlighted nets attached to 
the selected objects when they are 
visible and highlighted. 

X  X X   Unhighlight Components:  This 
command removes highlighting 
from highlighted components. 

 X     Unhighlight Nets:  This command 
removes highlighting from the 
highlighted nets. 

   X   Unhighlight Room and Assigned 
Components:  This command 
removes highlighting from a 
highlighted room and its assigned 
components. 
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CHAPTER 6 

Organizing and Placing Components 

Whether you are working on a PCB or a Schematic design, P-CAD InterPlace will help you organize 
the many objects in your design.  InterPlace specializes in two of the basic areas of board design: 
object organization and component placement for PCB designs.  A well organized board is 
essential to minimizing constraint violations resulting in more efficiently designed and 
manufactured circuit boards.  Being well-organized also reduces the time it takes to get that design 
out the door. 

The Design Manager View in InterPlace provides easy access to information on the components 
and nets in your design.  In the Design Manager you can assign components to logical blocks or 
partitions and group nets into a net class and class-to-classes.  For a PCB design, you can even 
group components into a room in preparation for placing them in a specific physical location on 
the board. 

The Layout View, or placement interface, is available to designs loaded from PCB or Relay.  
Manipulation of the design objects, including controlling design layers, using rooms, moving 
components, and viewing connections are just a small part of the productivity enhancing tools 
available in InterPlace.  InterPlace also provides a Visible Placement Area tool which shows an area 
on the board, based on constraints, where a component can be placed without incurring errors. 

This chapter explains in detail how to use the organizational tools for your PCB or Schematic 
design objects.  You will learn how to create partitions, net classes and class-to-class rules, and how 
to assign members to them.  For PCB designs there are instructions on employing the placement 
functions, such as clustering, discrete placement and drag and drop across windows, which make 
placing objects on the board a breeze.  Using the Visible Placement Area tool is introduced as well. 

Organizing Design Objects 
When a PCB or Schematic design is loaded into InterPlace, the components and nets are divided in 
the Design Manager View and displayed in one of these individual pages: Components, Nets, 
Partitions, Rooms, Net Class and Class-to-Class.  

This portion of the chapter contains an explanation of the InterPlace organizational processes for 
the Partitions and Rooms pages, and includes step-by-step instructions on how to use them.   



Chapter 6: Organizing and Placing Components Organizing Design Objects 

56 InterPlace User’s Guide 

The Design Manager View, (page 37), contains an overview of all functions available in the Design 
Manager View, along with detailed instructions on functions unrelated to organizing design data. 

The Design Manager View 
Each of the design data sections, except the components page, uses a tree-like structure in which 
lists of objects can be expanded or contracted depending on your desired view.   

The Design Manager View appears as follows: 

 

Each page of data is accessible by clicking on the appropriate tab at the bottom of the view.  The six 
pages are: 

 

 
Components Page 

 
Nets Page 

 
Partitions Page 

 
Rooms Page 
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Net Class Page 

 
Class-to-Class Page 

 

The Components Page 
The Components Page is an ideal way to view the complete list of components in your design.  For 
each component in the list the following essential information is displayed:   

• Reference Designator: The reference designator of the component. 

• Type: The component type. 

• Value: The value assigned to the component. 

• Placed: If any part of the component touches the board edge, or is located inside of the board 
outline, the Placed indicator displays Yes. 

• Partition: If the component has been assigned to a partition the name of the partition is shown 
here. 

Using the sorting capability of the Components Page you can quickly determine, for example, 
which components have been placed and which are assigned to a partition. 

The Nets Page 
The next informational page is the Nets Page.  All nets in the loaded design are present in the list of 
nets for both PCB and Schematic designs.  For a PCB design, from the Nets Page, you can also 
enable the connection display as well as physically cluster the components in the selected net in 
the Layout View. 

The Partitions Page 
The Partitions Page is where a logical grouping of components, a partition, is created, and 
components assigned to it.  For all designs you can create, rename and delete a partition.  
Components can be added or removed from the partition, and for PCB designs you can physically 
cluster components belonging to a partition in the Layout View. 

The Partitions Page is shown below: 
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Adding a Component to a Partition  
1. Display the list of Unpartitioned Components by clicking the  button.   

2. Select the desired components from the list. 

3. Choose the Move To command from the right mouse menu, and then select the target 
partition from the right pull down list.  You can also press the left mouse button and drag the 
selected components into the target partition. 

Removing a Component from a Partition   
To remove all components from a partition and delete the partition: 

1. Select the partition.  

2. From the right mouse menu, choose Delete or press the Delete key.  If the partition has 
assigned components, the components are placed back in the Unpartitioned Components list 
and the partition is deleted. 

To remove a portion of the assigned components: 

1. Select the desired components. 

2. Choose the Remove Components command from the right mouse menu, or drag them back 
into the Unpartitioned Components folder. 

A component can belong to only one partition at any time. 

Clustering Components in a Partition 
For a PCB design, components in one or more selected partitions can be retrieved from their 
current positions and grouped in the Layout View in a common area using the Cluster By command 
in the right mouse menu. 
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The Rooms Page 
When a room has been placed in a PCB design, InterPlace provides a vehicle with which to organize 
a set of components destined for placement in the room.  You may want to position the analog 
components in a room located in the back of the board, for instance.  By grouping the analog 
components in a room, you can then quickly cluster and place them in one easy step. 

The Rooms Page appears as follows: 

 

Creating a Room   
Physically drawing the boundaries of a room must be completed in PCB before the design is loaded 
into InterPlace.  The location of the room, Top, Bottom or Top or Bottom, is determined at the time 
the room is placed in the design.  See your PCB User’s Guide for more information on placing a 
room. 

Adding Components to a Room  
1. Select the desired components in the list of Available Components.   

2. Choose the Add To command from the right mouse menu and the specific room from the pull 
down list, or press the left mouse button and drag the selected components to their room 
destination. 

Removing Components from a Room  
1. Select the desired components in the room. 

2. Choose the Remove Components command from the right mouse menu.  The components 
are removed from the room. 
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A component can belong to any number of rooms at the same time. 

Clustering Components in a Room   
For a PCB design, components in one or more selected rooms can be retrieved from their current 
positions and grouped in the Layout View in a common area using the Cluster By command in the 
right mouse menu. 

The Net Class Page 
Organizing nets into one class is, again, an easy way to apply constraints once instead of 
individually to each net.  The Net Class Page is detailed in The Design Manager View, (page 37). 

The Class-to-Class Page 
Once you have established Net Classes in your design, you can define constraints that will apply to 
only those unique Net Classes in a Class-to-Class.  The Class-to-Class page is detailed in The Design 
Manager View, (page 37). 

Placing Design Objects 
Now that the components are organized in the desired partitions or rooms, and your nets are 
comfortably settled in their net classes and class-to-classes, you can begin to gather components in 
preparation for placing them on the board. 

This section of the chapter details the many means provided by InterPlace to collect components 
into a common workspace, such as the Cluster By command.  You will learn about the productivity 
enhancing tools that make placing the components easy, in particular the discrete placement tool.  
You will be introduced to the Visible Placement Area tool, which provides an area on the board 
where a component can be placed without incurring errors.  In addition to gathering and placing 
components, there is a section on working with multiple windows, and another that describes how 
to fine-tune component placement. 

Finding and Gathering Components 
In a design with a large number of components, it becomes a monumental task to find and locate 
them so that they can be easily placed on the board.  With InterPlace, gathering components into a 
common area is quick and varied. 

Components can be clustered from a variety of places: rooms, partitions and nets are just a few.  
You can drag components from the Design Manager View and drop them into the Layout View. A 
specific component can be moved from one place to another just by knowing its reference 
designator.  Finding a component is easy when you can jump right to it, or select it from the Design 
Manager View. 

Clustering Components 
The Cluster By command is available on every menu in the Layout View and the Design Manager 
View.  The Cluster tool in InterPlace finds designated components and lets you place them in a 
chosen location arranged by the property of your choice.   
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The options available in the Cluster By command are: 

• By Reference Designator 

• By Type 

• By Package size 

• By Pin Count 

• By ComponentHeight Attribute 

• By PlacementSide Attribute 

For all of the above options, when the components are drawn in the new location, they are 
arranged alphabetically by the value of the selected option.  For instance, if you select a group of 
components having different types in the Components Page of the Design Manager View, the 
cluster would appear as follows: 

 

The components are arranged alphanumerically by their type and then by their reference 
designator.  In the above display you can see that the components U6 and U9, which have a type 
beginning with 7 are displayed first.  The next set of components are those with a type of CAP300, 
POLCAP and then the one with RES4SIPICS type.  From this clustering of components, each can be 
moved into their position on the board. 

Since the Cluster By command appears in all the menus, you can choose to group components in 
many ways.  The following list details the clustering possibilities in InterPlace: 

• Layout View Edit menu:  This command allows you to cluster any selected components 
displayed in the Layout View whether they are placed on or off the board. 

• Design Manager View Components Page:  This command clusters the components selected in 
the component list. 

• Design Manager View Nets Page:  This command clusters the components resident in the 
selected nets. 
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• Design Manager View Partitions Page:  This command clusters the components assigned to 
the selected partitions. 

• Design Manager View Rooms Page:  This command clusters the components assigned to the 
selected rooms. 

• Design Manager View Net Classes Page:  This command clusters the components belonging to 
the nets in the selected Net Classes. 

• Design Manager View Class-to-Class Page:  This command cluster the components in the nets 
that belong to the net classes which comprise the selected Class-to-Class. 

Drag and Drop Gathering 
You can gather components in a work area using the drag and drop method of component 
movement.  Components can even be moved across windows from the Design Manager View into 
the Layout View.   

One or more selected components in the Layout View can be dragged to a new location anywhere 
in the Layout View.   

Selected components from the Design Manager View Components, Rooms and Partitions Pages 
can be dragged into the Layout View and then placed on the board.   

Finding a Component by Name 
As part of the InterPlace gathering tools, you can employ the Move By RefDes command in the Edit 
menu to find and select a specific component by following these steps:   

1. Choose the Move By RefDes command in the Edit menu of the Layout View which displays 
the Edit Move By RefDes dialog shown below: 

 

2. Enter the Reference Designator in the RefDes edit box, or select one from the pull down list of 
all components in the design by clicking the down arrow.  When you click OK, InterPlace 
locates and selects the component.   

3. Move the cursor, which has changed to an X, to the desired position in the workspace and 
click the left mouse button.  The selected component moves to the new location. 
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Jumping to a Component’s Location 
If you need to find a component and do not know the exact location, you can let InterPlace locate it 
for you.   

To jump to a component: 

1. Select a single component from any component list in the Design Manager View.  This 
includes the Components Page, the Partitions Page and the Rooms Page. 

2. Choose the Jump to Component command in the right mouse menu.  InterPlace positions the 
cursor over the selected component and, if the data tips are enabled, displays the 
component’s reference designator, type and value. 

Finding Components by Selection 
When components are highlighted or selected, it is easy to locate them on the board.  InterPlace 
uses the Select Components command to find designated components and place them in select 
mode. 

To use the Select Components command: 

1. Select one or more components in the Design Manager View.  The components can be 
selected from the Components, Partitions or Rooms Pages. 

2. Choose the Select Components command from the right mouse menu.  The components you 
chose in the Design Manager View are now selected in the Layout View. 

Placing Components 
One of the significant areas of board design in which InterPlace excels is component placement.  
Positioning components to maximize board real estate is crucial to efficient design and competitive 
manufacturing costs. 

InterPlace provides placement tools that enhance design productivity.  The Discrete Placement 
tool, for example, lets you position large numbers of discrete components with other components 
with just a few clicks of the mouse.  The Visible Placement Area tool helps you see the exact area of 
the board where a component can be placed without incurring a constraint error. 

You can direct layer placement using the Place On command.  Some of the gathering tools 
discussed earlier in this chapter, such as the Cluster By and Select Components commands and 
drag/drop and jumping, can be utilized for component placement as well. 

Discrete Placement 
With a design that uses large numbers of discrete components, like bypass caps, a designer can 
spend a lot of time finding and placing these components. The Discrete Placement tool helps you 
reduce the time expended placing these components.  With just a few clicks of the mouse you can 
rapidly position a large number of discrete components near their associated components, 
eliminating the need to find each of them and drag them into place.  

Follow these steps to rapidly associate multiple components with others in your design: 



Chapter 6: Organizing and Placing Components Placing Design Objects 

64 InterPlace User’s Guide 

1. Select the Discrete Placement command in the Edit Menu of the Layout View.  The Discrete 
Placement dialog, shown below, is displayed: 

 

2. The Discrete Placement tool finds the discrete components you want to place by component 
Type or Value.  Enter either a Value or Type in the respective edit boxes, or choose a Value or 
Type from the drop down lists associated with each. 

3. Specify how many discrete components are to be placed with each mouse click by entering a 
quantity in the Quantity edit box.  You may also click the up and down arrows to increase or 
decrease the quantity.   

4. Enable the appropriate radio button in the Place On section to direct the component 
placement to be on the Same Side or the Opposite Side of the current layer. 

5. Click OK.  The cursor changes to an X and is positioned in the Layout View.  The Prompt Line 
and Status Line, if visible, display information about the placements.   

6. Position the cursor over the placed component with which you want the discrete components 
associated, and click the left mouse button. 

Each time you click the left mouse button over the placed component, InterPlace positions the 
specified number of discrete components near that component.   

Prompt Line:  While you are in the Discrete Placement mode, the prompt line displays usage 
instructions as shown below: 

 

Click the left mouse button to place discretes; the right mouse button to end placement.  While 
you are placing you can increase the placement quantity by pressing the A key, and decrease the 
quantity with the Shift+A keys. 

Status Line: The status line displays the choices you made in the Discrete Placement dialog, as 
shown below: 
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Included in this informational display are the Type and Value of the discrete component being 
placed, the Quantity that is placed each time you click the mouse button, the number of Unplaced 
components available for placement, and the placement Side. 

If you change the placement quantity, and as the number of available components decreases with 
each placement, InterPlace dynamically updates this display so that you always have the most 
current information.   

Using the Visible Placement Area Tool 
The Visible Placement Area tool provides a display of the physical regions on a board where a 
component can be placed without breaking any rules.  The VPA works in three domains: Physical, 
Electrical and Room.  In each of the domains, if there are constraints applied, InterPlace calculates 
where a selected component can be placed without violating the rules for the selected constraint 
domain. 

For more information and instructions on using the Visible Placement Area tool, see The Visible 
Placement Area, (page 75). 

Using Gathering Tools for Placement 
Some of the gathering tools provided in InterPlace can also be used to place the components on 
the board.  For all of the brief descriptions below, see the Finding and Gathering Components 
section earlier in this chapter for more details. 

• You can select components in the Design Manager View and drag them into the Layout View 
to be dropped in position.  Using Multiple Windows describes component placement between 
views. 

• A component, once found using the Move by RefDes command, can be placed on the board. 

• Components identified in the Layout View using the Select Components command in the 
Design Manager View, now selected, can be moved into their board destination. 

Using Multiple Windows  
P-CAD InterPlace allows you to open multiple windows on the same design to view different parts 
of it simultaneously.  To open multiple windows, choose the Window » New Window command. 

Opening multiple windows of the same design can be used to view the Top and Bottom layers of 
the same design.  Or, multiple windows may be used to work on two different regions of the board 
simultaneously.  Also, you may want to zoom in on a group of unplaced components in one 
window; while in the other window, you focus on the board region where this component group 
will be placed.  A component can be selected, dragged across the window boundaries, and placed 
on the board in the opposite window.   

Each window you open creates a Layout View window inside the main application window in which 
you can edit the design.  As is standard in Windows, you can change the length and width of each 
window in relation to the other windows running on your screen.  You can also activate or 
deactivate the Design Manager View, toolbars and status/prompt line areas, which alternately 
decreases or increases the available space in the application window. 

An InterPlace workspace with multiple views of the same design is shown below: 
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You can easily switch between windows by clicking on the window tabs at the bottom left of your 
workspace: 

 

Fine-Tuning Component Placement 
One of the InterPlace specialties is component manipulation.  You can move, swap, align and fix 
components, rearranging their layout on the board to satisfy the design constraints.   

Once components are located in their initial positions on the board, you can fix them in place if 
you do not want them to be moved.  Components can be rotated to an absolute degree or in 90 
degree increments.  You can flip components from the Top to the Bottom layer, and vice versa.  
Two components’ locations can be swapped, and you can align a group of components horizontally 
or vertically. 

Fixing and Unfixing Components 
A fixed component in InterPlace may not change its location.  For example, the following 
commands do not operate on a fixed component: 

• Move (dragging a selected component) 

• Move By RefDes   

• Rotate 

• Flip 
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• Align Component 

A fixed component is displayed in the Fixed color selected using the Options Display dialog.  

To fix a component:  

1. Select the component(s). 

2. Choose Fix Components from the Edit menu or the right mouse pop-up menu. 

To unfix a component, choose instead the Unfix Components command.  

Rotating Components 
As in PCB, you can rotate selected components 90 degrees by pressing R (or Shift+R).  When a 
block of selected components are rotated using the R key, the entire block revolves around a 
selection point placed, by default, in the middle of the block.  The selection point can be 
repositioned by choosing the Selection Point command and then clicking in the block of 
components at the desired location. 

In InterPlace, you can also rotate all selected components to an absolute angle.  For example, you 
can choose to rotate all selected components to 90 degrees. To do so: 

1. Select a component(s). 

2. Choose Rotate To from the Edit menu and then the desired rotation angle from the pull right 
list. 

  

The selected components are all rotated to the specified angle, regardless of their initial 
orientation.  A single component rotates around its own reference point.  Each component in a 
group of selected components rotates around its own reference point when the Rotate To 
command is used. 

Flipping Components 
As in PCB, you can flip selected components to the opposite board side by pressing F.  In 
InterPlace, you can also flip all selected components to a particular board side.  For example, you 
can choose to flip all selected components to the Bottom layer. To do so: 

1. Select a component(s). 

2. Choose Place On from the Edit menu and drag the mouse to the right to select the placement 
layer. 
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The selected components are all flipped to the specified layer, regardless of their initial flipped 
value.  

Swapping Components 
You can interchange the position of two components on the board outline in the Layout View.  To 
do so: 

1. Select two placed components. 

2. Choose Swap Components from the Edit menu or the right mouse pop-up menu. 

The selected components exchange positions, including placement layer, while maintaining their 
individual rotation and constraints. 

Aligning Components 
Aligning components in InterPlace is identical to the same procedure in PCB.  Selected 
components can be aligned around a selection reference point horizontally or vertically, and even 
equally spaced.  Fixed components, of course, cannot be aligned.   

Detailed instructions on using the Align Components command can be found in the  Edit 
Commands chapter in your PCB User’s Guide.  
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CHAPTER 7 

Working with PCB and Schematic 

InterPlace enhances the design capabilities of P-CAD PCB, P-CAD Relay and P-CAD Schematic by 
providing easy access to design information and constraint management, and for PCB designs, an 
easy placement interface. 

The cohesion between the originating application and InterPlace makes loading a design easy.  If 
the applications are launched in a specified sequence, you can cross-probe between the 
applications to find and highlight components and nets in more than one design view.   

In InterPlace, you can load a Design Technology Parameters file with constraints that have proven 
successful in previous designs.  Placement specific constraints can then be copied into the current 
design.   

Updates made to the design in IPL can be included in an Engineering Change Order and applied to 
the matching PCB or Schematic design.   

This chapter describes how incorporating the capabilities of InterPlace with the P-CAD suite of 
applications enhances your circuit board design efforts.  

Basic Inter-Application Functions 
In this section you will learn how to start InterPlace, load a design and use the applications in 
tandem to find and highlight objects in more than one view. 

Launching InterPlace 
Once a design has been opened in one of the P-CAD applications (i.e., PCB, Relay or Schematic), 
you can launch InterPlace by choosing the Utils » P-CAD Design Constraint Manager or Utils » 
P-CAD Interplace/PCS command. The Design Constraint Manager provides access to both 
InterPlace and the Parametric Constraint Solver, depending on the license you have purchased.  
InterPlace can also be launched from your Windows desktop. 

Loading a Design 
When InterPlace is first launched, the application’s workspace is blank.  To load a design from PCB, 
Relay or Schematic, choose the appropriate command from the File menu as shown below: 
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When a design is open in InterPlace, the originating application is locked.  Changes to the design 
can be made only in IPL.  Once the design is closed or IPL is exited, the originating application is 
unlocked and can be updated. 

The Layout View, (page 21), details which design objects are loaded into InterPlace and describes 
how they are displayed. 

Cross-Probing Between Applications 
When you enable the DDE Hotlinks option in the Options Configure dialogs of P-CAD Schematic 
and P-CAD InterPlace, it is possible to highlight a component or net in Schematic and see the 
corresponding component or net highlighted in InterPlace as well.   

Because the Layout View is not available for designs loaded into InterPlace from Schematic, the 
graphic representation of the design must come from the PCB design file. 

In order to establish the necessary communication link and load the design files correctly, you 
must follow these steps: 

1. Open P-CAD Schematic. 

2. Open P-CAD InterPlace using the Utils » Design Constraint Manager command.  This 
establishes the link between Schematic and InterPlace.  Only two applications can be linked at 
any time.  Do not load the Schematic design into InterPlace. 

3. Open P-CAD PCB and load the desired design. 

4. Load the PCB design in InterPlace.  InterPlace now graphically displays the design in its Layout 
View and locks PCB to any updates. 

5. Load the Schematic design in the Schematic application.  A net or component highlighted in 
Schematic will be highlighted in IPL as well since the two applications were linked at step 2. 

When components or nets are highlighted in both Schematic and InterPlace, you can select the 
highlighted objects in InterPlace using the Edit » Select Highlighted command.  Once selected, you 
can perform additional operations on the objects in InterPlace such as moving, fixing, etc. 

If you change the highlight color of an object in the InterPlace, the same object in Schematic is 
automatically updated with that same highlight color. 

Using a Design Technology Parameters File 
When a design is loaded into InterPlace the existing constraints are included and accessible 
through Options » Design Rules.  If you have a Design Technology Parameters file containing 
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constraints that have proven successful in previous designs, you can load that file into InterPlace 
and update pertinent attributes in the current design. 

This section describes which of the features of the Design Technology Parameters file are available 
to the design while in InterPlace. 

For more complete information on the Design Technology Parameters file, see your PCB User’s 
Guide or Schematic User’s Guide. 

Accessing a DTP 
To access a Design Technology Parameters file, choose the File » Design Technology Parameters 
command.  The Design Technology Parameters dialog, shown on the next page, appears:  

 

DTP Operations 
The following list shows which operations are available in InterPlace from the Design Technology 
Parameters dialog: 

• Update From Design 

• Copy To Design 

• Properties 

• New Section or Item 

• Rename 
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• Delete 

• Statistics 

For each of the categories in the file, a particular set of operations is allowed.  In all cases, you can 
Update From Design and Copy To Design, as well as Delete items in each category.  In addition to 
those basic functions, the following additional operations are available in each of the categories: 

• Class-to-Class Rules: In this category you can add a New Section or item. 

• Global Rules (Layers): For the entire category you can add a New Section or item.  For an 
individual layer in this category you can access the Properties and Statistics, as well as Rename 
an item. 

• Net Class Definitions: In this category a New Section or item can be added. 

• Net Class Rules: In this category a New Section or item can be added. 

• Net Rules: A New Section or item can be added to the category.  The Properties and Statistics 
are accessible for individual nets, which can also be Renamed. 

The Attribute Handling On Copy section of the Design Technology Parameters dialog is enabled 
for the Copy to Design function for selected Class-to-Class Rules, Net Class Rules, Net Rules or 
individual nets.  You may choose to Merge Attributes in the design with those in the DTP file, or 
Replace Design Attributes with those in the DTP file by clicking the appropriate radio button.   

Refer to your PCB User’s Guide, File Commands, for more information on how the Merge 
Attributes function behaves in each of the relevant categories. 

How InterPlace Updates Affect PCB and Schematic 
Updates made to a design in InterPlace are saved to the design file.  These changes, once 
committed to the design file, can become part of an Engineering Change Order and subsequently 
transferred to a matching design in PCB or Schematic.  

Recording Changes with ECOs 
If you have turned on the ECO recorder in your originating application before making changes to 
the design in InterPlace, the changes will be recorded in the .eco file when the design is saved.  If 
you are using the WAS/IS ECO format you should note that only RefDes changes are recorded, and 
because you cannot change the RefDes in IPL, InterPlace will make no updates to these files. 

Once you exit InterPlace, you can import or export from PCB or Schematic the changes recorded in 
the ECO file, just as you would have done if those changes had been made in PCB or Schematic. 

Make sure to turn on the ECO recorder before launching InterPlace and loading the design. 

If you should forget to turn on the ECO recorder, you can still record the changes by following 
these steps: 

1. Return to the originating application.   
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2. Terminate the link between the applications by clicking the Cancel button on the P-CAD DBX 
dialog, shown below: 

 

3. Turn on the ECO recorder using the Utils » Record ECOs command or by clicking the  
button. 

4. Return to InterPlace and save the changes to the design using the File » Update 
PCB/Schematic Design command.   

5. The error message dialog, shown below, informs you that the connection has been 
terminated.  Click the OK button to continue. 

 

6. In the next DBX Error dialog you must choose whether to re-establish the connection and 
continue the update process or cancel it. 

 

7. If you wish to continue the update, click the OK button.  P-CAD DBX is automatically re-
activated and the link between the applications re-established.  The changes saved to the file 
in IPL are also saved to the ECO recorder. 

If you chose either the File » Close or File » Exit commands in step #4, and you click the Cancel 
button in the DBX Error dialog, your design is cleared from the InterPlace workspace and the 
changes you made are not recorded in the design file. 
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CHAPTER 8 

The Visible Placement Area 

In addition to the basic Room tools available in the Layout View of the InterPlace, IPL also provides 
a visual display on the board showing the area where components can be placed without violating 
constraints you have assigned to a PCB design.   

In combination with the basic Room tools, the Visible Placement Area enhances your ability to 
place components quickly, accurately and violation free.  The VPA interface displays the legal 
region of the board where a selected component may be placed after accounting for clearance, net 
connection length and Room inclusion rules. 

This chapter describes the basic functionality of working with the Visible Placement Area tool.  You 
will also learn which constraints are employed by VPA for the individual constraint domains, and 
how to apply them during component placement. 

Since only PCB designs use the graphical representation of the board layout, components and nets, 
this chapter applies only to designs loaded from PCB. 

 Working with the Visible Placement Area 
Working with the Visible Placement Area is easy once you know the VPA basic functions.  In this 
section you will learn how to enable the VPA domains using the VPA toolbar and select the color 
the VPA domain area uses in its display.  The way a component is measured, which determines if it 
will fit in the constraint area, is defined here as well. 

The VPA Toolbar 
The VPA toolbar is attached to the main workspace in the Layout View.  The VPA toolbar, shown 
below, activates the display of each of the placement domains. 

 

The buttons on the VPA toolbar enable the constraint domain display as follows: 
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Physical Domain 

 
Electrical Domain 

 
Room Domain 

 

The options in the VPA toolbar impact only its specific design window.  When you have multiple 
design windows open in the Layout View, each window has its own set of VPA toolbar buttons.  For 
example, you may enable the display of the Electrical Domain in one window, and the display of the 
Physical Domain in a second window. 

VPA Domain Display Options 
The Visible Placement domains can be displayed within the board outline in the color of your 
choice.  The VPA button in the Options Display dialog displays the standard Windows color dialog 
where you can choose or design a color for the VPA display. 

For more information on using the Options Display dialog, see Options Commands, (page 105). 

Enabling and Disabling a VPA Domain 
To enable the display of one or more constraint domains, click each desired domain button on the 
VPA toolbar. 

When a domain is selected, its corresponding button appears pushed.  Click the domain’s button 
again to disable it. 

Constraint Domains 
P-CAD InterPlace specializes in managing constraints which impact the optimal layout of the 
components on the board.  These constraints are used in the definition of the Visible Placement 
Area to determine and display a region on the board where components can be placed without 
violating the assigned rules.   

InterPlace categorizes the constraints by function into domains.  Each domain contains certain 
constraints that apply to a specific function as described below: 

• Physical:  Physical constraints specify clearances between design objects and between those 
objects and the board edges.  

• Electrical:  The Electrical domain provides maximum length measurements for net connections. 

• Room:  Room constraints define maximum component height and room placement. 

The constraint domains, the constraints within each domain and the precedence level at which they 
are applied are listed in the following table:   
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Domain Constraint Name Precedence Level 

Physical  BoardEdgeClearance 
ComponentSpacing 
PadToPadClearance 
Clearance 

D 
D, L, C 
D, L, NC, N, CC 
D, L, NC, N, CC 

Electrical  MaxNetLength D, NC, N 

Room  MaxComponentHeight 
Room Inclusion 

D, L, R 
R 

 

For the Precedence Level, the following notation has been used: C=Component; CC=Class-to-
Class; D=Design; L=Layer; NC=Net Class; N=Net; and R=Room. 

Viewing Constraint Domains 
You can choose to display one or more of the Visible Placement Area domains, in any combination, 
within the board outline.  If more than one domain is selected, the Visible Placement Area 
displayed satisfies all selected domain constraints simultaneously.  The optimal Room location of a 
component also satisfies these selected constraint domains. 

To view the Visible Placement Area(s) for a selected component: 

1. Choose which constraint domain(s) you wish to view: Physical, Electrical or Room.  Click the 
corresponding button(s) on the VPA toolbar: Physical Domain, Electrical Domain, or Room 
Domain.  Any or all of the constraint domains may be viewed simultaneously. 

2. Select one component.  The placement regions for that component, which satisfy the selected 
constraint domains, are displayed in the Visible Placement Area color specified in Options 
Display.   

The Bounding Rectangle, which measures the area needed to place the component inside the 
constraint domain, combines the pads with the lines and arcs defined on the non-signal layer 
specified by the component attribute PackageOutlineLayer.  

Constraint Visualization 
With the Visible Placement Area, you have the ability to visualize the impact of design constraints 
on component placement.   

When a component is selected for placement, the regions available for placement that satisfy the 
selected constraints are highlighted within the board outline.  These regions can be viewed for all 
domains either individually or in combination.  The valid placement area is displayed as a colored 
region on the board surface; this region is called the Visible Placement Area. 

An example of combining constraint domains is shown below:   
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If the component is placed within the subset of the constraint areas common to both the Physical 
and Electrical constraints, it will satisfy the allowed placement area.  Notice in the example above 
that to satisfy the Physical constraints or the Electrical constraints large regions of the board are 
available for component placement.  To satisfy both the Physical and Electrical constraints 
simultaneously, however, the available visible placement area for valid component placement is 
significantly reduced. 

You can view the visible placement area of a component for any constraint domain combination.  
The visible placement area aids in component placement.  Additionally, it can help you determine 
which design constraints are critically limiting placement options in a board region. 

Physical Constraints 
The following table shows the constraints utilized by VPA in the Physical domain, along with a 
definition, valid entries and the units available: 

 

Constraint Name Description Units 

PadToPadClearance Definition:  Overrides the default 
Clearance by specifying a pad to 
pad clearance value. 

Valid Range:  > 0 

mil, inch, mm, cm 

ComponentSpacing Definition:  The clearance value 
between components. 

Valid Range:  > 0 

mil, inch, mm, cm 
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Constraint Name Description Units 

BoardEdgeClearance Definition:  The clearance value 
between an object and the board 
edge. 

Valid Range:  > 0 

mil, inch, mm, cm 

Clearance Definition:  The clearance value 
between any net object. 

Valid Range:  > 0 

mil, inch, mm, cm 

 

Electrical Constraints 
The following table shows the constraints utilized by VPA in the Electrical domain, along with a 
definition, valid entries and the units available: 

 

Constraint Name Description Units 

MaxNetLength Definition:  The maximum length of 
each net connection emanating 
from the selected component.  The 
length is based on the distance 
between pads, not the length of the 
entire net.  PCB considers only 
routed copper lengths when 
determining the maximum 
allowable distance between two 
nodes. 

Valid Range:  > 0 

mil, inch, mm, cm 

 

Room Constraints 
The following table shows the constraints utilized by VPA in the Room domain, along with a 
definition, valid entries and the units available 

 

Constraint Name Description Units 

MaxComponentHeight Definition: The maximum 
component height allowed for a 
specified area of the board. 

Valid Range:  > 0 

mil, inch, mm, cm 

Room Inclusion Definition:  VPA checks for a 
room(s) assignment and, if a 

N/A 
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Constraint Name Description Units 
room(s) is assigned, restricts the 
visible placement area to the 
assigned room(s). 
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CHAPTER 9 

File Commands 

The File commands allow you to load, close, and update designs with their 
design constraints into P-CAD InterPlace.  From the File menu, you can also exit 
the application. 

The File menu displayed in the margin, containing the File » Load PCB Design 
and File » Load Schematic Design commands, is available when a design is yet 
to be loaded. An expanded File menu is available once the PCB or Schematic 
design has been loaded into InterPlace.  See the following pages for details. 

Most of the File commands cannot be undone, meaning that once an action is taken, it cannot be 
reversed by the Edit » Undo command. 

File Load PCB Design 
The File » Load PCB Design command loads an existing PCB design file into 
P-CAD InterPlace.   

Before a design has been loaded, the File menu appears as shown in the 
chapter introduction.  When a design is loaded, the File menu changes, as 
shown in the margin, to include the additional commands: Close, Update PCB, 
Reports, Design Technology Parameters and Exit. 

To load the design into InterPlace, the design must be currently open in P-CAD 
PCB or P-CAD Relay.  When you choose Load PCB Design, the design that is 
active in the P-CAD application is automatically loaded into the InterPlace 

workspace.  The design will be locked in the originating application while accessed through 
InterPlace to prevent conflicting modifications. 

After loading, the board outline and components appear in a Layout View window.  Refer to The 
Layout View, (page 21), for additional details.  The Design Manager View organization tools become 
available as well.  Refer to The Design Manager View, (page 37), for more information. 
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File Load Schematic Design 
The File » Load Schematic Design command loads an existing Schematic design 
file into P-CAD InterPlace.  If a design is already loaded, this command is 
unavailable. 

Before a design has been loaded, the File menu appears as shown in the 
chapter introduction.  When a design is loaded, the File menu changes, as 
shown in the margin, to include the additional commands: Close, Update 
Schematic, Reports, Design Technology Parameters and Exit. 

To load the design into InterPlace, the design must be currently open in P-CAD 
Schematic.  When you choose Load Schematic Design, the design that is active 

in the P-CAD application is automatically loaded into the InterPlace workspace.  The design will be 
locked in the originating application while accessed through InterPlace to prevent conflicting 
modifications. 

The organizational abilities of the Design Manager View become accessible.  Refer to The Design 
Manager View, (page 37), for more information. 

File Close 
Closes all views for the design in InterPlace.  The design is unlocked in the originating application, 
permitting changes again in the PCB or Schematic design editor. 

If the design has been changed but not yet saved, you are asked whether or not you want to save 
your changes before closing.   

File Update PCB  
Saves the changes to the PCB or Relay design.  When you select File » Update PCB, the file remains 
open so you can continue working on it in InterPlace. 

File Update Schematic  
Saves the changes to the Schematic design file.  When you select File » Update Schematic, the file 
remains open so you can continue working on it in InterPlace.   
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File Reports 
Allows you to generate reports with specific output options.  The selected Style Format dictates the 
options available for each of the styles: Comma Separated and Report.  With the Report style, in 
addition to the Report Options, Lines per Page and Report Destination, you may select the page 
format and define the Header and Footer.  These options are saved when you exit the program.   

The dialog appears as follows: 

 

Filename 
You may specify the report or reports you wish to generate from the list of report types listed in the 
Report Options area.  Each report type has its own, unique file extension; the filename defaults to 
the name of the current design.   

Report File Extensions 
The extensions are set as listed below and cannot be changed.  The files are all saved as text files.  

• constraint_domain.txt 

• precedence_level.txt 

• net_classes.txt 

• class_to_class.txt 

• partitions.txt. 
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Report Options 
The reports are described below: 

• Constraint Domain:  The Constraint Domain report lists the three domains pertinent to 
placement constraint management:  Physical, Electrical, and Room.  Within each domain, in 
their precedence order, are each item’s constraint names, values, expressions and comments. 

• Precedence Level:  The Precedence Level report shows, for each precedence level and item, 
the constraint names, values, expressions and comments. 

• Net Class:  The Net Class report shows the nets that are assigned to each net class in the 
design.  

• Class-to-Class:  The Class-To-Class report shows the net classes assigned to each class-to-class 
along with the constraints added to the class-to-class. 

• Partitions:  The Partitions report lists the components assigned to each Partition. 

Page Format 
These Page Format options are enabled when the Report format is selected: 

• Use Header and Use Footer include the information you specified in the header and footer 
dialog fields. 

• Date/Page includes the current date and the page number.   

• Pagination allows you to create your own pagination (lines per page).  When this option is 
enabled print from the DOS Print command, not the Notepad. 

Style Format 
• Comma Separated puts all data in comma-separated format.  This format can be imported into 

other spreadsheet and database programs. 

• Report produces a report format with columns and spaces, etc. 

Lines per Page 
Lines per Page allows you to specify the number of lines per page in your report. 

Report Destination Window 
• Screen sends the output to a file and opens the file using the Notepad Utility. 

• File sends the output to a file. 

• Printer sends output directly to the printer without creating files. 

Generate 
Generates all selected reports using the options selected. 
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File Design Technology Parameters 
Captures design data, including design constraints, and stores this data in a design technology 
parameters file.  This data can be used in any P-CAD design.  Thus this file becomes a template from 
which you can selectively use the captured design data in any design. 

A design technology parameters file is like a storage box.  You can reorganize it, add or remove 
items, alter some of its contents, and use what is stored inside.  For a project or series of projects, 
you may have several items that you will have to use repeatedly for creating PCB or Schematic 
designs.  The design technology parameters file is a perfect storage box for the following design 
items:  class-to-class rules, global (layer) rules, layer sets, net class definitions, net class rules, net 
rules and pad and via styles. 

Design constraints, or rules, can be transferred using a design technology parameter file between 
InterPlace and any PCB or Schematic design.   

In P-CAD InterPlace, Design Technology Parameters can be used in a variety of ways, including: 

• Applying company-standard design rules to your board layout. 

• Storing design rules created or organized in InterPlace for later use in other PCB or Schematic 
designs.  You can create or change design rules pertaining to Class-to-Class Rules, Global 
(layer) Rules, Net Class Definitions, Net Class Rules and Net Rules in InterPlace. 

For more information, see Using a Design Technology Parameters File, (page 70). 

File Exit 
Exits the InterPlace program.   

If the design has been modified since the last save, you are prompted whether you want to save the 
changes. 

The design file is unlocked in the originating application, permitting changes again in the PCB or 
Schematic design editor. 

The program writes information to the .ini file when you choose Exit.  This information, which 
will apply to subsequent InterPlace sessions, consists of parameters and settings such as values set 
in Options Configure, etc. 
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CHAPTER 10 

Edit Commands 

Edit commands allow you to make changes to objects in the InterPlace 
workspace.  Often these editing actions can be reversed using the Undo 
command. 

The Edit menu, shown in the left margin, exists only when a PCB design is loaded 
into InterPlace.  

Many of the Edit commands operate only if the object is already selected.  See 
Edit » Select for selection details. 
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Edit Undo (Ctrl+Z) 
Undo reverses your last completed action to the design.  You can undo component modifications 
in the Layout View such as move, rotate, and flip (actions performed in Select mode).  Many File 
commands, such as File Load Design, Update Design, etc. cannot be undone.  If an action cannot 
be undone (or there is nothing to undo), Undo appears grayed on the Edit menu. 

The Undo button on the toolbar and the U key are equivalent to the Edit » Undo command.   

Edit Properties 
Displays the Properties dialog for the component selected in the Layout View.  This dialog lets you 
query the selected component’s properties.  You must use the Select tool to select the 
component(s) before you can choose Edit » Properties from the Edit menu or the right mouse 
popup menu. 

The Properties dialog that appears is specific to the component you select.  If multiple components 
are selected, the properties displayed match in all selected components. 

Right Mouse Button to Select Properties 
You can also choose the Properties command from a pop-up menu.  Select a component and click 
the right mouse button to bring up a pop-up menu.  

See Right Mouse Commands, (page 17), for a complete list of right mouse commands. 

Double Click to Select Properties 
If the Double Click Displays Properties option is enabled in the Options Preferences dialog, you 
can also choose the Properties command by left double-clicking on a component to open its 
Property dialog. 

Data Tips 
 A data tip contains information about the underlying object and appears when you place the 
mouse over the following objects: 

• A component 

• A component pad 

• A connection 

• A room 

For components, the information displayed includes the reference designator, component type, 
and value attribute.  For a component pad, this information includes the reference designator, pad 
number, and attached net name.  For a connection, this information includes the net name, as well 
as the reference designators and pad numbers of the connection attachments.  For rooms, the 
room name and placement side are displayed. 
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A connection data tip is shown in the diagram below: 

 

You can turn off the display of the properties data tips in the Options Display dialog. 

Component Properties 
When you select one or more components and choose the Edit » Properties command, the 
Component Properties dialog appears with the Pattern tab selected. 

 

The Component Properties dialog allows you to observe properties for the selected component.   

Tabs provide access to additional information: 

• Pattern:  Displays the component pattern and its properties, including reference designator, 
type, value, and fixed state. The Pattern Graphic used is also listed. 

• Pattern Pads:  Lists the pin numbers of the pads, as well as their location, rotation, and pad 
style. 

• Component:  Displays component information on a gate-by-gate basis. 

• Component Pins:  Displays the pin information for the component, including pin number, pin 
designator, pin equivalence, and electrical type. 

• Attributes:  Displays the component’s attributes by their name and value.  
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All component properties are defined in P-CAD PCB or Relay.  These attributes are transferred into 
P-CAD InterPlace upon loading the design.  Refer to your PCB User’s Guide or online help for 
information about modifying component properties or attributes. 

Edit Move By RefDes 
This command allows you to select and move a component in the Layout View by entering its 
reference designator, without knowing where the component is located in the design.   

This command does not work on fixed components. 

When you choose this command the Edit Move By RefDes dialog appears: 

 

To move a component by its reference designator: 

1. Enable the Select tool. 

2. Choose the Edit » Move By RefDes command. 

3. Select a reference designator from, or type a value in, the RefDes drop down combo box.  The 
list contains all reference designators in the design. 

4. Click OK. 

5. The component is selected, and the cursor appears as a crosshair shape.   

6. Move the cursor to the workspace location where you want to place the component.   

7. Click to move it to the new location.     

You can click down to make a ghost, then drag and drop (release) to place it more accurately.  To 
cancel ghosting (and moving) of a component, click the right mouse button. 
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Edit Align Components 
In the Layout View, components can be aligned around a selection reference point either 
horizontally or vertically, and as an option, the components can be equally spaced.  If a number of 
components are off-grid, these components can be aligned back on-grid.   

The alignment of components is undoable.   

This command does not work on fixed components. 

Align Horizontally or Vertically 
To align a component: 

1. Select the components to align.   

2. Place a selection reference point using the right mouse pop-up menu.  This is the point about 
which the components will be aligned, either horizontally or vertically. 

Without selecting a selection reference point, the alignment and component spacing options 
are grayed. 

3. Select the command Edit » Align Components.   The Edit Align Components dialog appears. 

 

4. Select either horizontal or vertical alignment. 

5. To align the components with equal spacing, check the Space Equally check box and enter the 
Spacing value.  The spacing value is the distance between the reference points of the 
components. 

6. Press OK and the selected components will be aligned. 

Align to Grid 
To align a component to grid: 
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1. Select the component(s).   

2. Select the command Edit » Align Components.   The Edit Align Components dialog appears as 
shown above. 

3. Click OK and the selected components are aligned to grid.  Each selected off-grid component 
is moved to the nearest grid point. 

Edit Fix Components 
Fixes selected components in their position on the board outline in the Layout View.  Fixed 
components cannot be moved, rotated, or flipped. 

Edit Unfix Components 
Unfixes selected components in the Layout View.  Unfixed components can be moved, rotated, or 
flipped.  

Edit Swap Components 
Reverses the position of two selected components. 

Edit Rotate To 
Used to rotate to an absolute degree, chosen from the list of options shown below, a single 
component or a group of components.   

 

The selected component(s) are rotated about their own reference point(s).   

Edit Place On 
Places a selected component or group of components on a chosen layer (Top or Bottom), as shown 
below: 
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Edit Cluster By 
Groups components into a common area from anywhere in the design.  Components may be 
gathered by reference designator, type, package size, pin count or the ComponentHeight and 
PlacementSide attributes from the Cluster By options list, shown below: 

 

Once the cluster is selected, the cursor changes to an X.  Position the cursor in the Layout View 
location where you want the components to be placed and click the left mouse button.  The 
components appear clustered in the order chosen from the Cluster By options. 

Edit Select All 
Selects all items on all enabled layers of the Layout View and makes them available for additional 
commands to be performed.   

Edit Deselect All 
Deselects all currently selected items in the Layout View.  

Edit Highlight 
Highlights the selected item or items in the Layout View using the current highlight color chosen 
through the Options » Display command.   

You can change the highlight color for an object you want highlighted without affecting the 
highlight colors of other highlighted objects.  To do so, change the highlight color in the Options 
Display dialog, select the object, and choose Edit » Highlight from the Edit menu or Highlight from 
the popup menu.  Repeat this process for each object you want to highlight, so that each object 
selected has a different highlight color. 

When you choose this command, the selected items are drawn in the highlight color until they are 
unhighlighted.  The selection color overrides the highlight color, so you won't see the highlights 
until the items are deselected. 

You can also access this command by selecting an item or items, clicking the right mouse button to 
bring up the popup menu, and choosing Highlight. 



Chapter 10: Edit Commands Edit Unhighlight 

94 InterPlace User’s Guide 

Objects can be highlighted between the applications when the DDE Hotlinks option is enabled in 
their respective Options Configure dialogs.  The Layout View, (page 21), provides detailed 
instructions on Cross-Probing Between Applications. 

Edit Unhighlight  
Removes the highlighting from the selected item or items in the Layout View and restores the 
normal object colors. 

If P-CAD InterPlace and P-CAD Schematic or PCB are both running, and if the DDE Hotlinks check 
box in the Options Configure dialog is checked in both applications, the highlights are removed 
from the selected item or items in both applications. 

You can also access this command by selecting an item or items, clicking the right mouse button to 
bring up the popup menu, and choosing Unhighlight. 

Edit Unhighlight All 
Select the Unhighlight All command to remove the highlight from all items in the Layout View and 
to restore the normal object colors.  This command applies to all highlighted objects, regardless of 
whether they are selected or not. 

If P-CAD InterPlace and P-CAD Schematic or PCB are both running, and if the DDE Hotlinks check 
box in the Options Configure dialog is checked in both applications, the highlights are removed 
from the selected item or items in both applications. 

Edit Measure  
 Measures the X distance, Y distance, and total distance between two points in the placement 
interface.  Use the ruler button on the toolbar as a shortcut for the Edit » Measure command. 

You can measure vertical, horizontal, and diagonal distances and the results appear on the status 
line.  The measurements are in either mils or millimeters, depending on current settings in Options 
Configure.   

Measure is a mode, meaning that if you were, for example, selecting objects, when you use 
Measure you exit the select mode to go into measure mode.  After you have measured, you need to 
restart whatever mode you were in to resume editing. 

To measure the distance between points: 

 

1. Select Measure from the Edit menu (or use the toolbar button).   
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2. Move the cursor to the first point of your measurement in the workspace.  Click and drag to 
the end point of the measurement.   

3. Before you release, look at the results on the status line for X distance, Y distance, and T (for 
total) distance (in mm or mils).  When you release the button, the results disappear. 

Measuring with the mouse does not snap to grid, if you have View Snap to Grid disabled. 

Edit Select  
Edit » Select is a tool which allows you to perform operations on design objects in the Layout View.  
You can select items within the Constraint Editor and the Design Manager Views without enabling 
the Select tool. 

Select can also be enabled from the toolbar button (arrow).  The S key may also be used as a 
shortcut key. 

Select Actions 
• single-, multiple-, block-select. 

• move, resize, rotate, flip, modify, highlight, unhighlight, fix, and unfix. 

Status line information 
When you select an item, the status line information area identifies the item, either specifically 
(part reference designator) or generally (number of items selected). 

 

Select Commands 
Edit Align Components, Move by RefDes, Rotate To, Place On, Cluster By, Select All, Deselect All, 
Highlight, Unhighlight, Fix Components, Unfix Components, and Properties are operational in 
Select mode.   

Select actions are possible only if an object is selected.  For example, you cannot fix a component 
unless it has been selected. 

Information included in this section only covers the mouse/cursor actions for Select. 

Selecting Objects 
To single select, click a single object.  All other selected objects are deselected.  You must be on 
the object’s layer. 

To multiple select, first select a single object.  Then, hold down the Ctrl key and click on additional 
objects/items.  The selected objects are surrounded by a selection box, which increases as you add 
items to the multiple selection.  Click again on selected items (still using the Ctrl key) to deselect 
them individually.  If you release the Ctrl key and click anywhere other than one of the selected 
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objects, all are deselected.  You can select a list of items in any of the Design Manager View pages 
from the first selected item to the end of the list by selecting the first item and then pressing the 
Shift+End keys. 

To deselect, click an empty area of the workspace to deselect all items outside the selection region 
or choose the Edit » Deselect All command. 

To block select, click, hold and drag the cursor to create a selection box surrounding a block of 
objects, then release the button.  You can add objects to the block selection individually by doing a 
multiple select (see above paragraph).  To cancel while dragging the selection box, click the right 
mouse button. 

When block selecting, the selection window follows the layer option and selection mode set in the 
Options » Block Selection command.  Inside Block is the default setting, which means that all items 
completely inside the selection block will be included.  If you have the Outside Block option 
enabled, then the selection occurs outside of the selection block.  If you have the Touching Block 
option enabled, a block selection includes everything inside and touching the selection block. 

A block selection mask can be used.  Objects can be filtered or masked in a variety of ways, 
depending on how you set up the selection options.  Use the Options » Block Selection command 
for altering or setting the selection options. 

When Objects Overlap 
Only objects on the current layer may be selected.  If objects on the top and bottom layers overlap, 
you must move to the object’s layer to select it.  Click the Top Current or Bottom Current button on 
the toolbar to make that layer current. 

Objects on both Top and Bottom layers may be selected using the Options » Block Selection or Edit 
» Select All commands. 

Moving Objects  
To move an object, select it, then click on the object and drag the cursor to the new location.  
Release to place the object.  In P-CAD InterPlace, only components may be selected and moved.   

If you are moving multiple objects within a selection box, click anywhere in the selection box and 
drag; all the selected objects in the box follow.  Release the button to place the objects. 

To cancel a move in progress, click the right mouse button while the left mouse button is still 
depressed. 

Rotating and Flipping 
Select a component.  Rotate and flip functions work on multiple- or block-selected objects as well. 

Press R to rotate 90 degrees counterclockwise. Shift+R rotates the object by the value specified in 
the Rotation Increment field of the Options Configure dialog (default is 45 degrees). 

To flip, press F while the object is selected.  The object is flipped to the opposite side of the board.  
The object’s orientation reverses (about the Y axis) since you view the component from its back 
side. 
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When you flip a component, pad characteristics on the Top layer are swapped with corresponding 
characteristics on the Bottom layer.   

Viewing Properties 
With the Select tool enabled, choose Edit » Properties after an object is selected to display a 
Properties dialog for the selected object.  Refer to Edit Properties, (page 88), for information on the 
Properties dialogs and data tips. 

Right Mouse Button Commands 
When you select an object and click the right mouse button, a pop-up menu appears providing 
shortcuts to common commands performed on selected objects.   

The pop-up menu is operational in Select mode.   

Refer to Design Manager Right Mouse Commands, (page 51), for a summary of the right mouse 
command pop-up options. 

 

Edit Discrete Placement 
The Discrete Placement command is used to associate discrete components, such as bypass caps, 
with particular components.  These discrete components are quickly located and easily moved into 
place with the Edit » Discrete Placement command.  IPL dynamically maintains a count of placed 
and available components. 

Select the Edit » Discrete Placement command or click the Discrete Placement button on the 
command toolbar to display the dialog: 

 

The options in the Discrete Placement dialog are: 

• Quantity:  The Quantity edit box indicates the number of components to be placed. 
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• Unplaced/Placed:  Displays the number of components that have been placed and those that 
remain to be placed.  These counts are dynamically updated as components are placed. 

• Value:  Type in the Value of the components to be placed or choose from the list of 
components that appears when you click the down arrow button. 

• Type:  Enter the Type of the components to be placed or choose from the list of components 
that appears when you click the down arrow button. 

• Place On:  Enable Same Side or Opposite Side by clicking the desired button. 

To place components using Discrete Placement: 

1. Select the Edit » Discrete Placement command or click the Discrete Placement button on the 
command toolbar.  The Discrete Placement dialog appears. 

2. Enter a Value or Type in the appropriate edit box, or select the desired component’s Value or 
Type from the drop down lists.  InterPlace displays how many of the selected component have 
been placed and how many are available to be placed. 

3. Enter the number of components to be placed in the Quantity edit box.  You must enter a 
quantity less than or equal to the number of unplaced components. 

4. Choose the layer side on which to place the component. 

5. Click OK to begin the placement.  The Discrete Placement dialog disappears and the cursor, 
which is now a cross, is positioned in the Layout View.  

6. Position the cursor over the component with which you want to associate the discrete 
component(s) and click the left mouse button.  The number of components you entered in 
the Quantity box are placed next to that component.  Continue clicking over each component 
where you want to place the discrete components.  When you have finished placing the 
discrete components, click the right mouse button to terminate placement for that 
component. 

To continue placement of another type of discrete component, simply click the left mouse button 
and the Discrete Placement dialog reappears. 
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CHAPTER 11 

View Commands 

View commands allow you to temporarily alter your view of the workspace.  In 
the Layout View of a loaded PCB design, you can change the view to better 
pinpoint locations and objects in the design.  You can also enable or disable the 
display of the Design Manager View, toolbars, and other workspace 
information.  

For more permanent adjustments to your display characteristics, refer to the 
Options menu. 

The View menu of InterPlace, for a design loaded from PCB, is shown in the left 
margin.  When a design is loaded from Schematic, the View menu is reduced.  
Commands available in the View menu when a Schematic design is loaded are 
noted in this chapter with the Schematic icon. 
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View Redraw 
Clears everything in the Layout View window to the background color and then repaints the 
screen.   

View Redraw is good to use when you have leftover shapes from moving objects; Redraw erases 
leftover graphics. 

When you redraw, the items that reside on the current layer are drawn last.  The current layer for 
the active window is indicated by its Top Current or Bottom Current toolbar buttons. 

This command causes collocated top and bottom layer items to be drawn in the correct order.  For 
example, if the current layer is Top, all Top layer SMT pads of an edge connector are drawn on top 
all Bottom layer SMT pads in the edge connector.  Other View/Zoom commands do not necessarily 
draw collocated pads in the correct order. 

To interrupt a redraw in progress, click the right mouse button or press Esc. 

View Extent 
Displays the extent of all objects placed in the Layout View window. 

P-CAD Interplace computes and draws the window(s) so that all placed objects are visible on 
enabled layers.  Disabled layers are ignored. 

To enable a layer, click the Top Current or Bottom Current button(s) on the Layout View Options 
Toolbar.  Disable a layer by clicking the Disable Bottom or Disable Top buttons on this same 
toolbar. 

View Last 
Redraws the previous view, if you have altered the view in any way.   

There is no previous view until you run at least one View command that changes the view area.  If 
you run View » Last multiple times, you toggle between the last two views. 

Scrolling does not affect the previous view. 

View All 
Redraws the Layout View window with the entire workspace shown. The scroll bars don’t appear at 
this zoom level. 

The workspace size displayed matches that of the loaded P-CAD PCB or Relay design.  

View » All is the default view when you load a PCB design into P-CAD Interplace. 



View Center Chapter 11: View Commands 

InterPlace User’s Guide 101 

View Center 
 Redraws the Layout View window using the cursor as the relative center point.   

The cursor becomes a magnifying glass shape, signifying the zoom mode and prompting you to 
click in the workspace; the point where you click in the workspace becomes the center of the 
screen.  To cancel the zoom after the magnifying glass cursor appears, click the right mouse button 
or press Esc. 

The selected point may not be in the center of the screen if you are near a workspace boundary. 

C Key 
The shortcut key for View » Center is C.  Using C is useful for panning across the workspace.  You 
don't need to click the mouse button, just move the cursor to the point you want centered and 
press C.  You can also use the arrow keys to pan your workspace if you've enabled the Autopan 
option in the Options Configure dialog. 

View Zoom In 
Zooms in by the magnification factor set in Options Configure.  The zoom factor must be greater 
than 1. 

When you select View » Zoom In, the cursor takes on the shape of a magnifying glass (the zoom 
cursor), prompting you to click for the center point of the zoomed area.  The cursor position 
becomes the center of the zoomed-in area.  You must re-invoke the command for every zoom 
action.  To cancel the zoom after the zoom cursor appears, click the right mouse button or press 
Esc. 

Plus Key (+) 
An easier way to zoom in is to use the plus key (+) as a shortcut (the keypad plus key is also 
functional).  Your current cursor location becomes the center of the zoom action when you press 
the plus key; you don't have to click in the workspace. 

View Zoom Out 
Zooms outs by the magnification factor set in Options Configure.  This is a temporary mode that 
does not affect whatever other mode you may be operating in. 

When you select View » Zoom Out, the cursor takes on the shape of a magnifying glass (the zoom 
cursor), prompting you to click for the center point of the zoomed area.  The cursor position 
becomes the center of the zoomed-out area.  You must re-invoke the command for every zoom 
action.  To cancel the zoom after the zoom cursor appears, click the right mouse button or press 
Esc. 
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Minus Key (-) 
An easier way to zoom out is to use the minus key (-) as a shortcut (the keypad minus key is also 
functional).  Your current cursor location becomes the center of the zoom action when you press 
the minus key; you don't have to click in the workspace. 

View Zoom Window   
Zooms to an area of the placement interface window that is specified by a zoom window.  A zoom 
window is a rectangle you click and drag to create in the workspace; the window you create will fill 
the screen, depending on the shape of the window that you draw.  This is a temporary mode that 
does not affect whatever other mode you may be operating in.   

 Zoom through a Window 
There are three ways to invoke the zoom window:  the Z key, the toolbar zoom button, or the View 
» Zoom Window command from the menu bar.  In any case, after it is invoked, you must draw the 
zoom window in the placement interface window.   

1. After you enable the zoom window function, the cursor becomes a magnifying glass shape 
until you click and drag to create a rectangular shape around a specified view area.   

2. Release when you have completed your "window".  The area you surround with the zoom 
window is enlarged on the screen (the window fills the screen).   

3. The active tool is still active after you do the zoom window action.  

You must drag the cursor to create a zoom window.  If you click and release in the workspace 
without dragging the cursor, the program responds with a beep, and does not zoom in.   

To cancel the zoom action once the zoom cursor appears, click the right mouse button or press 
Esc. 

View Jump Location 
Positions the cursor to a specified location (X, Y coordinates) in the placement interface window.  
You can also use the J key to enter coordinates on the status line. 

If you are zoomed in, this command pans the workspace to the specified location, attempting to 
center the location.  Your current zoom setting is not changed by the jump location panning 
(except View Last will be updated).  If the specified location is already visible on the screen, no 
panning is necessary. 

The units used for the location value (mil or mm) are determined by the setting in Options 
Configure.  Select Options » Configure to override the default settings. 

The location is also based on the Options Grids setting, either Absolute or Relative; e.g., if your grid 
setting is in Relative mode, then the location is a Relative coordinate.  Also, you can use negative 
coordinate values when in Relative mode.  Refer to Options Grids, (page 110), for more information. 
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Jump to a Location 
1. Choose Jump Location from the View menu.   

 

2. When the dialog appears, specify the X and Y coordinates (in the text boxes) of where you 
want your cursor to be in the workspace. 

3. Click OK. 

View Command Toolbar 
With this command you show or hide the command toolbar.  A check mark next to the toolbar 
menu item indicates that the toolbar is visible.  The toolbar gives you quick access to the most 
frequently file management and editing commands (such as the Select tool).  

The Command toolbar for a Schematic design, which consists of only the Update Schematic 
command, is permanent and the display cannot be disabled.  

The Command toolbar, for designs loaded from PCB, is displayed below:  

 

Disabling the command increases the space within the applicable window. 

The setting of the toolbar visibility is saved to your .ini file when you exit the program, and 
restored when you restart it. 

View Prompt Line 
Allows you to either show or hide the prompt line.  A check mark next to the prompt line menu 
item indicates that the prompt line is visible.  

 

The prompt line is useful in that it gives instructions on what to do in certain modes.  For example, 
while you are in the Select mode, it tells you what to do next, depending on what action you have 
already taken. 
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The current settings for the visibility of the prompt line will be saved to your .ini file when you 
exit the program. 

View Status Line 
Allows you to either show or hide the status line.   A check mark next to the status line menu item 
indicates that the status line is visible.  The status line provides status information.  For a design 
loaded from PCB, it also allows you to change grid spacing and view current placement 
coordinates, as shown below:   

 

A check mark alongside the command indicates that the status line is visible.  Disabling the 
command increases the space within the applicable window. 

The setting of the status line visibility is saved to your .ini file when you exit the program, and 
restored when you restart it. 

View Snap to Grid 
Enables a snappy cursor, meaning that the cursor can only move from grid point to grid point 
within the placement interface, as opposed to a free floating cursor.  The benefits of a snappy 
cursor are mainly a question of personal preference (e.g., you may be accustomed to a snappy 
cursor from other program applications).  Also, a snappy cursor can create a predictable point of 
reference and placement when moving and rotating objects or measuring distances.   

At times you may want to disable this command (and cause the cursor to float freely).   

The current settings for Snap to Grid (whether it is enabled or disabled) is saved to your .ini file 
when you exit the program. 

View Layout View Options Toolbar 
Displays or hides the Layout View Toolbar. 

View VPA Toolbar 
Displays or hides the Visible Placement Toolbar. 

View Design Manager 
Displays the Design Manager View.  In the Design Manager, you can organize design components 
into logical partitions or physical rooms.  These rooms and partitions can be used for grouping 
unplaced components, as well as placing them in a common board region.  For more information, 
see The Design Manager View, (page 37).
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CHAPTER 12 

Options Commands 

The Options commands allow you to change settings affecting many P-CAD InterPlace 
actions.  For example, you can use the Options commands to determine block 
selection criteria (selection mask), set default units (mm or mils), specify grid settings, 
and select object display colors. 

The Options menu, shown in the left margin, is available when a PCB design has been 
loaded into InterPlace.  When a design is loaded from Schematic into IPL, only the 
Options » Configure command is available. 

 

Options Block Selection 
Defines selection filter(s) for block selects (see Edit » Select).  You can configure the block select 
feature to select all components by type, or even objects with specific parameters.  The selection 
possibilities can be as specific, limited, or as general as you choose. 

Choose Options » Block Selection to display the Options Block Selection dialog.  From this dialog 
you can set criteria affecting the selection of specific objects and layers. 
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Items 
In the Items area, you can specify individual objects for inclusion in a block select. Enable the 
specific items you would like to include by clicking the item. 

In P-CAD InterPlace, you can block select components.   

Items Buttons (Selection Mask Dialog) 
The component selection has a corresponding Property button .  A Property button has three 
states: 

• Included (checked). 

• Excluded (blank). 

• Masked (grayed). 

This feature allows you to narrow your selection further by setting specific properties as selection.  
To access the property “mask”, set the item check box to its third state, the masked (grayed) state.  
This allows access to the item button as shown in the following illustration: 

 

Then click the Component button to display the respective Selection Mask dialog: 



Options Block Selection Chapter 12: Options Commands 

InterPlace User’s Guide 107 

 

In the Selection Mask dialog, you can specify the parameters for the components that you want as 
part of the selection block.   

Selection Mask Parameters 
You can select components by a variety of parameters, specified in the Selection Mask dialog.  A 
summary of these parameters is listed below. 

For Component, you can specify component type, reference designator, value, fixed position, and 
attributes.  For example, you can include a specific component of a certain value, and the block 
select will include only those of that value.  Type, reference designator, and value fields support 
wild card characters: ? to match any single character, and * to match a sequence of zero or more 
characters.  For example, a RefDes value of U? matches all components with a two character RefDes 
string beginning with U. 

Layers 
The Layers area of the dialog allows you to select any combination of layers for the selection mask.  
To choose a layer, check its corresponding check box by clicking it.  Checked layers will become 
part of the selection list.   

With Options » Block Selection you can select items that are not located on the current layer. 

Select Mode Box 
Inside Block is the default setting, which means that all items completely inside the selection block 
will be included, according to the selection criteria you establish in this dialog. 
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Outside Block allows you to select outside of the block select (outside of the selecting rectangle).  
All of the selection criteria that you specify in the Options Block Selection dialog will function 
outside the block rather than inside. 

Touching Block selects all items inside and touching the selection block.  This is a more inclusive 
selection option than Inside Block. 

Selecting and Modifying 
This is a scenario for selecting all capacitors on the top layer of your board:  

1. Choose Options » Block Selection to display the dialog. 

2. Click on the Component check box until the check box becomes grayed.  The Component 
button then becomes ungrayed. 

3. Click on the Component button to display the Component Selection Mask dialog.  

4. Choose the component type CAP from the drop down Type list, or enter *CAP* in the Type 
box.  The former option chooses only components with the exact name CAP (i.e., CAP300 is 
not selected).  The latter option chooses all components that have the three letters CAP 
located anywhere in their name.  Click OK. 

5. In the Layers area, click Bottom Layer to uncheck its box.  The Top Layer box alone is checked 
to allow selection on only the top layer. 

6. In the Select Mode area, click the Inside Block radio button to enable it. 

7. Do a block select of the complete design by clicking and dragging from one corner of the 
region to the other.  Only the capacitors within the selected region will be selected.   

Options Configure 
When you select this command, the Options Configure dialog appears as shown below.  This 
command is available when a design is loaded from Schematic, PCB or Relay. 
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From the Options Configure dialog, you can set many of the general P-CAD InterPlace parameters.  
A design loaded from PCB has access to all the options in the Options Configure dialog.  A 
Schematic design, which lacks the graphic presentation of the design in the Layout View, has access 
to only the Units, File Viewer and DDE Hotlinks.   

The Options Configure dialog contains the following options. 

• Units: You can alter your display units between mils and millimeters with this option.  
Dimensions are not altered, only the unit of measurement of dimension.  A mil equals 0.001 
inch or .0254 mm.  A mm equals 0.001 meter. 

This setting affects all dialogs, reports, Status line displays, etc. containing measurements.  For 
example, setting Units to mm causes all dialogs to display measurements in millimeters.  
These units can be overridden in many command settings. 

• Autopan: Allows you to adjust the amount of autopanning that occurs when you move the 
cursor to the edge of the screen with the arrow keys.  An autopan of 25 moves anything at the 
edge of the screen 25% nearer to the center of the screen; 50 moves fringe objects to the 
center, etc. 

• Rotation Increment: The rotation value you set here is activated when you select an object and 
use Shift+R to rotate it.  Values must be between 0 and 360 degrees, and can be specified down 
to tenth degree resolution. 

You can also use the R key to rotate a selected object by 90 degrees; R is not affected by what 
you specify in this dialog.  

• Net Optimize Max Pin Count: Allows you to specify the default pin count for determining 
whether a net is automatically optimized.  If the net has more than this number of nodes, it is 
not optimized.   

• Zoom Factor: Allows you to adjust the amount of zoom that will occur when View » Zoom In 
or View » Zoom Out is enabled.  A factor of 2.00 will double (or halve) the size of objects in the 
workspace, etc.  Zoom factors must be greater than 1.00. 
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• DDE Hotlinks: If checked, this option enables exchange of hotlink data with P-CAD Schematic.  
Hotlink data consists of highlighting and unhighlighting commands for components and nets.  
The state of the DDE Hotlinks option is saved in the .ini file. 

The Layout View, (page 21), has detailed information on how to use Cross-Probing Between 
Applications. 

Options Grids 
Defines the current placement grid.  

When you choose Options » Grids, the following dialog appears: 

 

The grid units used are determined by the Units setting in Options Configure. 

Mode 
You can specify Absolute when you want the grid origin point to be the lower-left corner of the 
workspace.  You can specify Relative to allow any point as an origin point. 

A typical setting is to set your Absolute mode to 100 mil grid spacing and Relative to 25 mil grid 
spacing.  In this way, you can toggle the Grid button on the status line between 100 mil and 25 mil.  
(The relative grid origin should be set to Absolute 0,0 for this to work.) 

Visible Grid Style 
The Visible enable box allows you to display or not display grids.  When you enable this option, the 
grid style options are available.  Dotted displays pinpoint grid points, while Hatched draws lines 
along the grids to show grid intersections (like graph paper). 

Relative Grid Origin 
You can specify your X and Y relative grid origins by entering the coordinates if you have disabled 
the Prompt for Origin option.   
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If you switch to Relative grid in the dialog and the Prompt for Origin dialog is enabled, you will be 
prompted for the new origin point after you click OK.  You will be prompted every time you 
change from Absolute to Relative Grids using the Grid Toggle button or the A key. 

Grid Spacing: Uniform/Nonuniform 
You can select appropriate values for grid spacing for specific modes in the Grids list box.  You are 
not limited to using the grids in the list box; you can specify your own custom grid spacing in the 
Grid Spacing edit box, then click Add to add it to available choices in the list box.  To delete a grid-
spacing value, highlight it in the Grids list box and click Delete. 

The grid defines the spacing pattern of the grid points. The grid pattern may be uniform (equal 
spaces between all lines) or it may be nonuniform.  To specify a nonuniform grid, enter explicitly 
the multiple spacing values, e.g., 40-20-40.  

Remember to set up your grids correctly before you place your components.  It is important that 
you place the components on the appropriate grids (e.g., standard DIP components on 100 mil 
absolute).   

Grid Toggle Button (or G key) 
You can easily toggle between absolute and relative grid settings with the Grid Toggle button or G 
key.  The button appears as  for absolute grid spacing and  for relative grid spacing.  Your absolute 
and relative grids are determined by what you have set in the Options Grids dialog.  For example, if 
you have Relative set to 25 mils and Absolute set to 100 mils, the Status line will read 25 mil when 
you are in Relative grid and 100 mil when you are in Absolute grid.   

If you use the grid toggle button or the G key to switch to Relative, you will be prompted for the 
origin point if you have the Prompt for Origin option enabled in Options Grids.  The crosshair 
cursor (the cursor displayed when the system is awaiting input) is displayed; when you click in the 
workspace, that becomes the relative origin point (X=O, Y=O) and the cursor returns to normal. 

Options Display 
Defines color preferences, cursor style, and other display-related items for P-CAD InterPlace.  
When you choose Options » Display, the Options Display dialog appears:  
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The colors you establish in the dialog are saved in your .ini file. 

Each of the options is summarized below. 

Layer/Item Colors 
This is a color matrix with items across the top (columns) and layers along the side (rows).  You can 
specify everything on a layer to be of one color by clicking on a layer button (e.g., Bottom).  By the 
same process, you can make an object the same color on all layers by clicking an item button (e.g., 
Pad).  Or you can make an object a specific color on a specific layer by clicking on the square where 
the object and the layer meet.  Any of these choices display the Color dialog.  

Color dialog 
When you click a layer or item button, the Color dialog appears where you can choose a color for 
the layer, object, or combination.  You can also display the Color dialog by right mouse clicking an 
individual layer or item.  In the Color dialog, simply click one of the 20 colors and the color is 
applied.   

To close the Color dialog without choosing a color, press the Esc key. 

To select a custom color, click the Custom button on the Color dialog.  Select a custom color from 
the common Windows Color dialog by one of the following methods: 

Method 1: 

1. Click on one of the predefined colors in the Basic colors section.   

2. Click OK to select the color. 
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Method 2: 

1. Define the custom color by either: 

• Clicking over the color palette to define the Red/Green/Blue settings.  Move the 
arrowhead at the far right up and down to set the luminescence of the color. 

• Type in the desired Red/Green/Blue settings for the color. 

2. Click the Add to Custom Colors button. The selected color appears in the Custom colors 
section.   

3. Click OK to select the color. 

The display of the custom colors in your P-CAD design depends on the color settings of your video 
display.  When the video display is set to 256 colors, these custom colors are approximated by the 
nearest solid color; the Red/Green/Blue settings for the selected color are retained.  When the 
video display is set to more than 256 colors, the custom colors are accurately displayed. 

Once custom colors are selected, they appear as the chosen item or display color on the Options 
Display dialog or the Printer Colors dialog.  These colors are saved in the .ini file for use in later 
design sessions.  In the Custom colors section of the common Windows Color dialog, however, 
colors not selected for an item/display color are forgotten once the P-CAD application is exited. 

Display Colors 
These buttons determine general display colors, regardless of layer or item colors.  You must be 
careful that your display colors do not conflict with layer or item colors that you specify; for 
example, if you set background color to be the same as component color, your components will 
not appear. 

These commands also display the Color dialog, where you can select your display color. 

Each object you select and highlight appears in the current highlight color.  You can use highlight 
colors to highlight objects using different colors.  To do so, change the highlight color, select the 
object, and choose the Edit » Highlight command.  Repeat this process for each object you want to 
highlight, so that each object selected has a different highlight color.  When you change the 
highlight color of one object, it does not affect the highlight color of other highlighted objects, 
which are not selected. 

Cursor Style 
Allows you to change the shape of your cursor to arrow, small cross, or large cross.  The large cross 
stretches horizontally and vertically to the edges of the screen. 

Miscellaneous 
The following items appear in the Miscellaneous box. 

Drag by Outline 
Allows you to drag objects around the screen more quickly by only displaying the bounding box of 
the objects that are being moved.  This only affects the move operations of the Edit » Select 
command and the Cluster By command. 
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Draft Mode 
Displays a thin (single-pixel) outline of pads and text. 

Displays segmented, outlined representations of arcs, lines, and any line segment objects.  Draft 
Mode can help in faster redraws and also allows you to view any segment overlaps.   

Draft Mode displays outline forms. 

Scroll Bars 
Enables or disables the display of Windows scroll bars in the active window. 

Data Tips 
Enables or disables the display of data tips.  Data tips provide a quick view of the properties for 
components, component pads, and connections. 

Comp RefDes 
Enables or disables the display of the component reference designators. Generally, the maximum 
size of the text is determined by the component outline.  To restrict the text size when zooming in 
on a component, enter the maximum point size in the Max RefDes Font Size box.   

Show Power Pins 
Check the Show Power Pins box to enable the display of those pins designated as power pins in the 
chosen Power Pins color.   

Max RefDes Font Size 
Allows you to enter a maximum font size in which the Reference Designator is displayed. 

Defaults Button 
The Defaults button on the Options Display dialog returns your display setup to the default 
scheme. 

Options Preferences 
Defines keyboard and mouse preferences used to set up the application.  The default keyboard 
shortcuts are listed in Appendix B. 

When you choose the Options » Preferences command, the dialog appears with the Keyboard tab 
selected: 



Options Preferences Chapter 12: Options Commands 

InterPlace User’s Guide 115 

 

Keyboard Tab 
The Keyboard tab lets you customize key assignments for menu commands and shortcut key 
commands. 

• Command Type:  Choose the type of command for which you want to change shortcut key 
assignments. 

• Menu Commands/Shortcut Commands:  Select the command you want to add a shortcut key 
assignment to or from which you want to remove a shortcut key assignment. 

• Current Keys:  Displays the existing key assignments for the command you select in the Menu 
Commands/Shortcut Commands box. 

• Press a Shortcut Key: Press the keys you want to assign to the selected command.  You can 
press the Ctrl or Shift key plus any other combination of numeric or alphabetic keys and 
function keys. 

F10 is reserved by Windows and cannot be assigned to any other command. 

If the shortcut is currently assigned, the current assignment appears in the Current Binding 
field just below this box. 

• Assign:  Assigns the key appearing in the Press a Shortcut Key box to the selected command.  If 
the shortcut is currently assigned, the current assignment disappears 

• Remove:  Removes the key you select in the Current Keys box. 
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• Key File:  Allows you to select or create a key binding file to use with this application.  When 
the Select Key File dialog appears, select the file you want to use.  The current key file appears 
at the top of the dialog, and is written to the application .ini file. 

• Defaults:  Restores original default shortcut key assignments to all commands. 

Mouse Tab 
When you select the Mouse tab, the Options Preferences dialog appears as follows: 

 

The Mouse tab lets you customize certain mouse behaviors. 

• Ctrl/Shift Behavior:  Allows you to choose which keys to use (Ctrl or Shift) for multiple 
selections. 

• Cycle-Picking Threshold:  The number of pixels you can move the mouse during cycle-picking. 

• Double-Click Displays Properties:  When enabled, this option allows you to double-click a 
component to bring up its Properties dialog. 

Options Design Rules 
When you choose the Options » Design Rules command, the Design Rules dialog appears with the 
Design tab selected with values for Silkscreen and Hole to Hole Clearance assigned.   
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If you have purchased P-CAD Parametric Constraint Solver, the Options Design Rules dialog is 
unavailable because PCS provides extended access to the design rules. 

Design Tab 
The Design tab shows global default clearance rules which apply to the entire design. 

 

Layer Tab 
The Layer tab of the Options Design Rules dialog contains the default clearance values for signal 
layers and displays them as shown below: 

 

Layers are ordered according to the layer order set with the Options » Layers command in PCB 
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The clearance values of the layer you select appear in the Pad to Pad, Pad to Line, Line to Line, Pad 
to Via, Line to Via, and Via to Via boxes. If you have a variety of settings and you click on two layers 
that contain conflicting values, the box is blank.  The value you enter in the box is applied to the 
selected layer(s) when you click the Update button.  

Clearance Rules 
When a clearance rule for a specific object is requested (e.g., DRC), the design rules category 
determines which rules apply and the order in which they are applied.  Options Commands, in 
your PCB User’s Guide, has more information on the way clearance rules are handled by DRC. 

Rooms Tab 
Clicking the Rooms tab displays all of the Rooms in the design as seen below: 

 

Select a Room from the Rooms list box and its associated Rules are displayed along with its 
Placement Side.  If you want to add, delete or edit the rules click the Edit Rules button and make 
the appropriate changes in the Attribute dialog. 

You can edit a rule’s properties by double clicking the rule in the Rules list box. 

Net Class Tab 
When you click the Net Class tab, the dialog appears as follows: 
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The Net Class tab lists all net classes and the rules associated with each. 

To edit a rule’s Properties, double-click the rule in the Rules list box. 

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.  Refer to the 
Edit Nets command section in Options Commands, in your PCB User’s Guide for more information. 

Net Tab 
When you click the Net tab, the dialog appears as follows: 

 

The Net tab allows you to specify clearance rules for a specific net in the design.  The dialog lists all 
nets and shows the rules associated with the net you select from the Nets list box.   

To edit a rule’s Properties, double-click the rule in the Rules list box. 
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To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.  Refer to the 
Edit Nets command section in Options Commands, in your PCB User’s Guide for more information. 

Class to Class Tab 
When you click the Class to Class tab, the dialog appears as follows: 

 

The Class To Class tab allows you to specify clearance rules between nets grouped into a Net Class.  
The dialog lists all class to class definitions and the rules associated with each. 

To create a Class to Class definition , select nets classes from the two Net Class Name list boxes, 
and click Add Definition.  Once you have created a definition, it can be deleted using the Delete 
Definition button and modified using the Modify Definition button. 

To edit a rule’s Properties, double-click the rule in the Rules list box. 

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.  Refer to the 
Edit Nets command section in Options Commands, in your PCB User’s Guide for more information. 
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CHAPTER 13 

Window Commands 

 

Window commands allow you to manage multiple Layout 
View windows. 

P-CAD InterPlace allows you to open multiple windows on 
the same design to view different parts of it at once.  
Because the Layout View window is not available for designs 
loaded from Schematic, the window commands are relevant 
only to designs loaded from PCB. 

The window you are working in is the active window.  The work that you perform in the active 
window is reflected in all windows of the design.  

Window New Window 
Allows you to open additional Layout View windows for the design.  You can move independently 
in each window, making it easy to compare different parts of the same design.  For more 
information, refer to Using Multiple Windows in The Layout View, (page 21). 

A number identifying the window is added to the file name in the Title bar and at the bottom of the 
Window menu.  For example: C:\InstallationDirectory\TUTORIAL\TUTOR.PCB:2. 

Window Cascade 
Arranges all open Layout view windows so that the window titles are visible. 

All windows overlap, starting in the upper-left corner of your workspace.  You can see each 
window's title, making it easy to switch between windows. 

Window Tile 
Arranges all open Layout View windows so that all windows are visible. 
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Windows are resized and arranged side-by-side so that all windows are visible and none overlap. 

Window Arrange Icons 
Arranges Layout view window icons (minimized windows) in the main application window.  This 
command arranges these icons so that they are evenly spaced and don't overlap. 

Windows can be minimized into icons by clicking Minimize button, the left-most of the three 
buttons in the upper-right corner of the window.  

You can open one of these window icons by double clicking it. 

Selecting a Window 
The bottom of the Window menu lists all open windows.  To make a window active select it from 
this list.  Design windows appear on the Windows menu in the order that you opened them. 

You can also switch between windows using the window tabs at the bottom left of the Layout View 
window. 

If there are more than nine windows opened, an option More Windows... appears.  Select it to see 
additional windows. 

To close a window, double click the control button in the upper-left corner of the window.  Closing 
the last window is equivalent to the File » Close command. 
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CHAPTER 14 

Help Commands 

 

P-CAD InterPlace provides extensive online help.  The online help 
contains reference information, but differs from the manual in its 
format and accessibility. 

The main advantages to online help are the availability of hypertext links between related subjects 
(an electronic cross-reference utility), and the keyword search function (an electronic index). 

Help P-CAD InterPlace Help Topics 
Displays the P-CAD InterPlace online help including the Contents tab, which is structured to match 
the order of commands as they appear in the product, and the Index tab, which lets you look up a 
specific concept or keyword. 

Help How to Use Help 
Connects you to the Windows help system, where instructions on how to use the help system are 
provided. 

Help About P-CAD InterPlace 
Displays a dialog that contains information such as the product version number, release date, 
memory used, memory available, and license number. 
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APPENDIX A 

Keyboard Reference 

This chapter is a reference of commands and functions accessed through P-CAD shortcut keys and 
standard Windows accelerators.   

Standard Windows key combinations are functional for all of the menu commands; use the normal 
combination Alt,x,y, where x equals the underlined menu character, and y equals the underlined 
command character. 

The InterPlace Keyboard Reference section includes general keystrokes available with InterPlace.  
The InterPlace Keyboard Reference section includes keystrokes specific to P-CAD InterPlace. 

You can use the Options Preference dialog to change shortcut keys for commands. 
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InterPlace Keyboard Reference 
 

Alt+F4 (File Exit) Shortcut for File » Exit, which exits the P-CAD program.  If the current 
design has been modified since the last save, you will be prompted 
(YES or NO) as to whether you want to save the changes to the file.  
The program will write information to the .ini file when you exit. 

Alt + mouse click For any click-and-drag or drag and drop operations, you can hold 
down the Alt key, click the left mouse button, then move or drag the 
object wherever you want without having to keep the mouse button 
depressed.  Without the Alt key, you would normally have to click 
and drag with the button depressed while you are dragging. 

arrow keys A directional arrow key moves the cursor to the next grid point.  If 
Ctrl+arrow, then the cursor is moved 10 grid points, which can be 
used to pan the screen. 

Ctrl+S (File Update 
PCB) 

Saves changes to the current design without closing it.   

Ctrl+Z (Edit Undo) A shortcut for Edit » Undo, which reverses a completed action.   

Ctrl+F4 (File Close) Closes the current design, but does not exit the InterPlace 
application.   

Ctrl+F6  and 
Ctrl+Tab 

Switches focus to the next window.  Use Ctrl+Shift+F6 or 
(Ctrl+Shift+Tab) to switch focus to the previous window.  

Shift+F (Edit Fix 
Components) 

Fixes selected components in the workspace.  Fixed components 
cannot be moved, rotated, or flipped. 

Shift+U (Edit Unfix 
Components) 

Unfixes selected components in the workspace.  Unfixed 
components can be moved, rotated, or flipped. 

Shift+End (Select 
to end of list) 

Selects all items from the first selected item to the end of the list. 

Shift+F4 (Window 
Tile) 

Shortcut for the Windows Tile command.  Windows are resized and 
arranged side-by-side so that all windows are visible and none 
overlap. 

Shift+F5 (Window 
Cascade) 

Shortcut for the Windows Cascade command.  All windows overlap, 
starting in the upper-left corner of your Workspace.  You can see 
each window's title, making it easy to switch between windows. 

F1 (Help) Displays context-sensitive help.  If you put focus on a command or 
dialog and press F1, the Help window appears containing 
information specific to the focus item. 
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Page Down Scrolls one page down in the workspace. Ctrl+Page Down scrolls 
one page right. 

Page Up Scrolls one page up in the workspace. Ctrl+Page Up scrolls one page 
left. 

SPACEBAR The SPACEBAR can be used in place of the left mouse button; but 
the action is different.  To simulate a typical click and release of the 
mouse button, you need to press and release the SPACEBAR twice.  
Therefore, to simulate the click and hold mouse action, you press 
and release the SPACEBAR once.  As the left mouse button is used in 
such a variety of ways throughout the P-CAD program, this 
SPACEBAR keystroke can become a regular part of your work. 

Esc (Escape) Terminates placement of objects with multiple segments; it also 
cancels a redraw in progress.  It is often equivalent to the right 
mouse button.  Esc also exits from dialogs (equaling the Close or 
Cancel button). 

+ Plus Key (View 
Zoom In) 

Shortcut for View » Zoom In command.  The keypad plus key also 
works.  The plus key causes a zoom in to occur at the cursor location.  
Refer to the View » Zoom In command documentation for more 
information.  The plus key does not change the cursor to a zoom 
cursor (as do the zoom commands from the View menu). 

- Minus Key (View 
Zoom Out) 

Shortcut for View » Zoom Out command.  The keypad minus key 
also works.  The minus key causes a zoom out to occur at the cursor 
location.  The minus key does not change the cursor to a zoom 
cursor (as do the zoom commands from the View menu). 

A key (Grid 
Toggle) 

Toggles between absolute and relative grid settings. 

C Key (View 
Center) 

Shortcut for View » Center command.  This command allows you to 
center your cursor location.  Place the cursor in the area of your 
design that you want centered and press C.  Repeated uses of the C 
key can be used to pan across the workspace. 

F Key (Flip Object) Flips an object during place and move operations.  Not all objects 
can be flipped.  Refer to the Edit » Select command (in this Reference 
manual) for more information about flipping objects. 

G Key (Grid Select) This key scrolls forward through the list of grid settings.  Use Shift+G 
to scroll back through the list. 

J Key (Enter 
Coordinate) 

Gives focus to the X coordinate box in the status line.  From there, 
you can enter new X coordinate.  Then, click Tab to give focus to the 
Y coordinate and enter its new value. 
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L and Shift+L Keys 
(Change Layer) 

L and Shift+L cycle through the board layers, toggling between 
making the Top or Bottom layer current.  

R and Shift+R keys 
(Rotate) 

R Rotates objects 90 degrees during Place and Select operations.  
Shift+R rotates objects by the rotation angle specified in the Options 
Configure dialog.  For more information about rotating objects with 
Select operations refer to the Edit » Select command.  

S Key (Select) Shortcut for the Edit » Select command (also the toolbar Select 
button).  When enabled, you are able to click on objects to highlight 
them for selection, then move, rotate, and otherwise modify them. 

U Key (Undo) Shortcut for the Edit » Undo command, which reverse a completed 
action. 

X Key (Cursor 
Style)  

Toggles between the three cursor styles: Arrow, Small Cross, and 
Large Cross. 

Z Key (Zoom 
Window) 

Shortcut for the View » Zoom Window command.  Just press Z and 
then draw the zoom window; a zoom cursor (magnifying glass) will 
display until you draw the zoom window.  Whatever you surround 
with the zoom window will fill the screen. 
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Index 

-A- 
absolute 

degree rotation ..........................................29 
grid toggle ...........................................12, 111 

align to grid ....................................................91 
aligning components .......................31, 68, 91 
All, View command ....................................100 
altering ...................see editing or modifying 
autopanning, adjusting..............................109 

-B- 
block selection 

select mode box ......................................107 
Block Selection, Options ..........................105 
board 

layers ............................................................25 
bounding rectangle......................................77 
buttons 

command toolbar....................................103 
grid toggle ...........................................12, 111 
visible placement area..............................26 
VPA toolbar.................................................75 

-C- 
cascade..........................................................121 
Center, View command.............................101 
changing ................see editing or modifying 
Class to Class clearances...........................120 
class-to-class ..................................................49 

creating new ...............................................50 
deleting........................................................50 
report ...........................................................84 

clearance rules ............................................118 
closing a design.......................................17, 82 
Cluster By, Edit command...........................93 
clustering components ...............................60 

clustering options .................................. 40, 61 
colors 

custom....................................................... 112 
display ....................................................... 113 
display options ........................................ 111 
display settings ...........................................26 
layer/item.................................................. 112 

command toolbar ...................................... 103 
Command Toolbar, View command...... 103 
common commands.....................................39 
components ............................................ 23, 27 

adding to partitions...................................46 
adding to rooms.........................................47 
align to grid .................................................91 
aligning.................................................. 31, 68 
cluster options............................................27 
clustering.................................. 27, 40, 60, 93 
data tips........................................................31 
definition of fixed ............................... 29, 66 
Design Manager page...............................42 
discrete placement ............................. 30, 63 
drag and drop ...................................... 30, 62 
drag from design manager ......................30 
dragging from Design Manager .............40 
finding ..........................................................60 
fixing ...................................................... 29, 67 
flipping .................................................. 30, 67 
gathering......................................................60 
in partitions .................................................45 
information in Design Manager .............42 
jump location..............................................28 
jump to.................................................. 41, 63 
locating.................................................. 27, 28 
logical partitions ........................................44 
move by refdes...........................................62 
moving ............................................ 28, 30, 96 
moving across windows ...........................30 
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organizing..............................................37, 55 
pad 

data tip ......................................................31 
place on (layer)...........................................29 
placement fine-tuning..............................66 
placing................................. 28, 55, 60, 63, 92 
placing between windows.................24, 65 
placing with VPA ........................................65 
properties ........................................31, 32, 89 
reference designator ..............................114 
removing from partition...........................46 
removing from rooms...............................47 
rotating.............................................29, 67, 92 
select command.........................................63 
selecting in Layout View ..........................40 
selection criteria ......................................107 
selection point............................................29 
sorting in Design Manager ......................43 
swapping................................................31, 68 
unfixing ..................................................29, 67 
unhighlighting............................................41 
unpartitioned..............................................44 

Configure, Options command.................108 
connections....................................................32 

data tips........................................................32 
hiding ...........................................................44 
jump to a......................................................33 
optimize by pin count ..............................33 
optimizing ...................................................33 
properties ....................................................34 
show on drag ..............................................44 
showing........................................................44 

constraint domain report ............................84 
constraint domains.......................................76 
controlling board layers ..............................25 
coordinates, X and Y.....................................12 
copying.................................. see also pasting 
Cross Probing ..........................................28, 70 
current layer...................................................25 
cursor 

free floating...............................................104 
snappy ........................................................104 

cursor style ...................................................113 
cursor,tracker.................................................12 
cut away boards.............................................23 
cutting................ see also deletingor pasting 

-D- 
data tips ........................................ 13, 31, 32, 63 

displaying............................................ 26, 114 
DBX 

connection 
re-establishing........................................ 73 

Database Exchange Interface ................. 16 
lock............................................................... 16 

DBX errors...................................................... 73 
DDE Hotlinks.......................28, 35, 70, 94, 110 
deleting 

items in a block........................................ 108 
Deselect All, Edit command....................... 93 
deselecting objects ...................................... 96 
design 

clearances ................................................. 117 
components 

organizing................................................ 37 
constraints 

domain domain ...................................... 77 
PlacementGrid...................................... 110 
viewing..................................................... 77 
visualization ............................................ 77 

loading......................................................... 69 
updates........................................................ 72 

Design Constraint Manager 
InterPlace .................................................... 69 
Parametric Constraint Solver.................. 69 

Design Manager View ......................... 14, 104 
accessing..................................................... 38 
Class-to-Class Page ................................... 49 
collapsing groups...................................... 39 
commands .................................................. 51 
common commands................................. 39 
Components Page..................................... 42 
expanding groups..................................... 39 
icons............................................................. 38 
Net Class Page ........................................... 47 
Nets Page .................................................... 43 
Partitions Page ........................................... 44 
Rooms Page ................................................ 46 
viewing ........................................................ 37 

Design Rules, Options .............................. 116 
Design Technology Parameters ................ 70 

available operations in IPL ...................... 71 
Merge Attributes ....................................... 72 
Replace Design Attributes ...................... 72 
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Design Technology Parameters, File 
command ....................................................85 

discrete components 
placement 

prompt line..............................................64 
status line .................................................64 

placing..........................................................30 
Discrete Placement, Edit command..........97 
Display 

board outline..............................................26 
data tips .......................................................26 
font size for refdes ....................................26 
Options........................................................26 
power pins ..................................................26 
settings.........................................................26 
Visible Placement Area.............................26 
VPA options ................................................76 

Display, Options command......................111 
domain 

design constraints .....................................77 
domain domain.............................................77 
domains 

viewing.........................................................77 
draft mode....................................................114 
drag and drop..........................................62, 96 
drag by outline ............................................113 
DTP 

accessing a file ...........................................71 

-E- 
ECO 

recording changes.....................................72 
ECO Files 

.ECO file.......................................................72 

.WAS file ......................................................72 
Edit Commands.............................................87 

Align Components ....................................91 
Cluster By ....................................................93 
Deselect All .................................................93 
Discrete placement ...................................97 
Fix Components.........................................92 
Highlight......................................................93 
Measure.......................................................94 
Move By RefDes.........................................90 
Place on .......................................................92 
Properties ....................................................88 
Rotate To .....................................................92 

Select ............................................................95 
Select All ......................................................93 
Swap Components ....................................92 
Undo.............................................................88 
Unfix Components ....................................92 
unhighlight..................................................94 
Unhighlight All ...........................................94 

editing...............................see also modifying 
items in a block ....................................... 108 

electrical constraints ....................................79 
MaxNetLength............................................79 

enabling layers...............................................25 
Exit File command.........................................85 
exiting InterPlace ..........................................17 
Extent, View command ............................. 100 

-F- 
features..............................................................1 
File Commands 

Close.............................................................82 
Design Technology Parameters..............85 
Exit .................................................................85 
Load PCB Design........................................81 
Load Schematic Design ............................82 
Reports .........................................................83 
Update PCB .................................................82 
Update Schematic......................................82 

Fix Components, Edit command ...............92 
fixed component 

definition .............................................. 29, 66 
flip object key ............................................. 127 
flipping ............................................................96 

components ................................................67 

-G- 
gathering components ................................60 

drag and drop .............................................62 
gathering tools...............................................65 
grid 

nonuniform.............................................. 111 
origin ......................................................... 110 
snap cursor to.......................................... 104 
spacing ...................................................... 111 
style 

dotted..................................................... 110 
hatched .................................................. 110 
visible ..................................................... 110 

toggle 
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(absolute and relative settings) ...........12 
(absolute and relative settings) .........111 

uniform ......................................................111 
Grid Toggle button.....................................111 
Grids 

Options ......................................................110 

-H- 
hardware requirements.................................5 
Help Commands .........................................123 

About P-CAD IPL......................................123 
How to Use Help .....................................123 
P-CAD IPL Help Topics ...........................123 

hide connections ....................................33, 44 
highlight..........................................................40 

connections ................................................33 
removing......................................................94 

Highlight, Edit command ............................93 
horizontal alignment....................................91 
hotlinks,enabling ........................................110 
how to use help...........................................123 
hypertext links .............................................123 

-I- 
icons 

arrange window icons ............................122 
command toolbar ....................................103 
Design Manager View...............................38 
toolbar............................................................9 

imperial units ...............................................109 
importing .............................. see also loading 
INI file..............................................................17 
Installation and Setup 

installing P-CAD products .........................6 
system requirements ..................................5 

inter-application 
probing ........................................................70 

inter-application functions .........................69 
probing ........................................................28 

InterPlace 
interface.........................................................8 
using from Relay ..........................................7 
using from Schematic .................................8 

InterPlace 
basics ..............................................................7 
exit.................................................................17 
launching.....................................................69 
Layout View.................................................21 

placement visualization........................... 77 
using from PCB............................................ 7 

items 
selecting ...................................................... 39 

-J- 
jump 

to component ...................................... 41, 63 
to location........................................... 28, 103 
to pin............................................................ 41 

Jump Location, View command.............. 102 

-K- 
keepouts......................................................... 23 
keyboard 

preferences .............................................. 115 
reference................................................... 126 

keys, shortcut .............................................. 126 

-L- 
Last, View command.................................. 100 
launching 

Design Constraint Manager.................... 69 
InterPlace .................................................... 15 

layer selection mask .................................. 107 
layers ............................................................... 25 
layers selection criteria ............................. 107 
laying out the board .................................... 21 
Layout View ................................................... 14 

Board Control ............................................ 10 
display characteristics .............................. 23 
multiple windows ..................................... 24 
options toolbar .......................................... 10 
Options Toolbar...................................... 104 
switching between windows.................. 14 
viewing ........................................................ 21 
Visible Placement Area ............................ 11 

loading................................. see also opening 
a board outline .......................................... 16 
a design ....................................................... 15 
a PCB design............................................... 81 
a Schematic design ................................... 82 
board outline ............................................. 23 
components ......................................... 23, 24 
cut away boards......................................... 23 
designs ........................................................ 22 
free pads ..................................................... 23 
grids ............................................................. 24 
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keepouts......................................................23 
layers ............................................................24 
mounting holes..........................................23 
rooms ...........................................................24 

locating components .............................27, 28 
location, jumping to...................................102 
lock 

application ............................................16, 70 
terminating ..............................................73 

-M- 
max refdes font size ...................................114 
Measure, Edit command .............................94 
menu bar ..........................................................9 
metric units ..................................................109 
mode 

changing absolute and relative grid....110 
draft ............................................................114 

modify shortcut.............................................97 
modifying .............................. see also editing 
mouse preferences ....................................116 
Move By RefDes............................................62 
moving 

components..........................................28, 30 
items in a block........................................108 

-N- 
net 

class ..............................................................47 
adding nets to .........................................49 
creating new............................................48 
deleting.....................................................49 
renaming ..................................................49 
report ........................................................84 

classes ........................................................118 
clearances..................................................119 
connections ................................................32 
optimization .............................................109 
page ..............................................................43 
removing from Net Classes.....................49 
unhighlighting............................................41 

new window.................................................121 
nonuniform grid spacing ..........................111 

-O- 
object selection mask ................................106 
objects 

highlighting.................................................40 

placing..........................................................60 
opening .................................see also loading 
optimization 

setting pin count..................................... 109 
optimizing connections...............................33 
Options Commands 

Block Selection........................................ 105 
Configure.................................................. 108 
Design Rules ............................................ 116 
Display....................................................... 111 

Defaults.................................................. 114 
Miscellaneous ...................................... 113 
show power pins ................................. 114 

Grids .......................................................... 110 
Preferences .............................................. 114 

Options display 
max refdes font size ............................... 114 

organizing 
in Class-to-Class Page ...............................60 
in Components Page.................................57 
in Net Class Page........................................60 
in Nets Page ................................................57 
in Partitions Page .......................................57 
in Rooms Page ............................................59 
objects ..........................................................55 

outline, drag by........................................... 113 

-P- 
PackageOutlineLayer ...................................77 
panning (View Center command).......... 101 
panning screen, adjusting........................ 109 
partitions 

adding components ........................... 46, 58 
adding new..................................................45 
clustering components.............................58 
deleting ........................................................45 
page ..............................................................44 
removing components ...................... 46, 58 
renaming......................................................46 
report............................................................84 

P-CAD InterPlace 
features ..........................................................1 

P-CAD IPL Help Topics, Help .................. 123 
P-CAD PCB Icon ..............................................3 
physical constraints ......................................78 

BoardEdgeClearance.......................... 77, 79 
Clearance.....................................................79 
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ComponentSpacing ............................77, 78 
PadToPadClearance ............................77, 78 

pins 
jump to.........................................................41 

Place On, Edit command .............................92 
placement 

domains .......................................................76 
fine-tuning...................................................66 
interface.......................................................21 
visible placement area..............................26 
Visible Placement Area.............................65 

PlacementGrid constraint .........................110 
placing ................................... see also pasting 

components..........................................28, 63 
between windows ............................24, 65 

discrete components ..........................63, 97 
pop-up commands .................................34, 51 
pop-up menu.................................................97 
power pins 

display settings...........................................26 
displaying ..................................................114 

precedence level report ..............................84 
Preferences, Options command .............114 
previous view...............................................100 
prompt line...............................................11, 64 
Prompt Line, View command...................103 
properties .......................................................31 

component..................................................89 
connections ..........................................32, 34 
data tips........................................................88 
double-click item.......................................88 
right mouse menu .....................................88 

Properties, Edit command...........................88 

-R- 
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