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CHAPTER 1 

Introduction to the Library Executive User’s Guide 

This introduction to the Library Executive User’s Guide summarizes the powerful, advanced 
features of Library Executive, as well as details the contents of the manual to follow. 

Library Executive is a utility, with a user-friendly interface, used in conjunction with P-CAD PCB and 
P-CAD Schematic to efficiently create and maintain component data. These components can then 
be placed into PCB and Schematic designs. 

With Library Executive you can search libraries for a variety of attributes using the Query tool. 
External data files may be imported, queried, or used to create or update your P-CAD libraries. Also, 
components in a design can quickly be verified and modified, if desired, when updates are made to 
a library. Many of these features, including Query, can be used directly from P-CAD PCB and 
Schematic. 

Library Executive is partnered with a Pattern Editor and Symbol Editor that include wizards that 
accelerate pattern and symbol creation. Once created, the patterns and symbols can be easily 
attached to components. General knowledge of P-CAD PCB or P-CAD Schematic may be a 
prerequisite to using certain Library Executive functions. Refer to your P-CAD PCB User’s Guide or 
P-CAD Schematic User’s Guide for information about these products. 

About this Manual 
This manual is a combined user's guide and reference manual for P-CAD Library Executive.  

Chapter 2: Chapter 2 is useful for setting up and learning how to use the basics of Library Executive.  

Chapter 3: Chapter 3 consists of a tutorial that takes you through the process of creating a new 
library with new symbols, patterns and components. 

Chapter 4: Chapter 4 describes library concepts, such as how patterns, symbols and components 
occupy the same library, the use of component, pattern and symbol aliases, and the important 
distinction between pin designators and pad, or pin, numbers. 

Chapter 5 and 6: Chapter 5 and 6 summarize the features available in the Pattern Editor and Symbol 
Editor. These editors include the Pattern and Symbol Wizard, quick and easy utilities that jump start 
component creation. 
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Chapter 7 to 13: Chapters 7 through 13 describes the Source Browser and Query features, as well as 
how to import component data from a non-P-CAD source, update, create and verify libraries and 
produce reports. 

Chapter 14 to 22: Chapters 14 through 22 contain the Command Reference for Library Executive. 
They are useful for looking up specific information about the program commands. They list and 
describe all of the menu commands in the order that they appear on the Library Executive menu. 
These chapters also provide all related functions and options that work in conjunction with, or are 
alternatives to, the listed commands. 

Installation and Setup 
This section lists the required hardware and software settings you need to install the P-CAD  Suite.  

System Requirements 
Make sure that your PC and its software conform to the following P-CAD requirements and 
recommendations.  

Recommended System 
• Windows NT 4/2000 Professional 

• PC with Pentium III Processor 

• 128MB RAM (256MB for high component/net count) 

• 400MB Hard Disk Space 

• Desktop area 1024x768 pixels 

• 32-bit Color Palette 

• CD-ROM Drive 

• Mouse or compatible pointing device 

Minimum System 
• Windows 95/98/2000Me 

• PC with Pentium 166MHz 

• 64MB RAM 

• 200MB Hard Disk Space (without ISO libraries) 

• Desktop area 800x600 pixels 

• 256 Color Palette 

• CD-ROM Drive 

• Mouse 

Installing P-CAD Products 
For up-to-date installation information refer to the file Readme.WRI, located on the product CD. 
This file can also be found in the application program folder (\Program Files\P-CAD 2002) 
after installation. Note that the setup program on the Product CD can also be used to Repair or 
Remove an existing P-CAD Installation.
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CHAPTER 2 

Library Basics 

This chapter provides important information about the basic functions and features of the P-CAD 
Library Executive, such as: 

• A description of the user interface 

• A description of the Symbol View, Pattern View and Pins View dialogs spreadsheet 

• A description of the advanced views, including the Source Browser and Query 

• Spreadsheet editing 

• Library Executive commands 

• Keyboard specifics. 

User Interface 
This section provides an overview of the Library Executive user interface.  

Menu Bar 
The menu bar provides access to Library Executive commands and functions. 

 

To activate a menu, click the Menu Title or press the ALT key in combination with the underlined 
letter of the menu title (e.g. ALT+C to display the Component menu). When the menu appears, 
click the Menu Item, or press the underlined key, to choose a command. 

A command followed by three dots (e.g. Open...) opens a dialog when you choose it. 

Toolbar  
A toolbar provides shortcuts to commonly used commands and functions. It appears when you 
choose the View » Toolbar command. You can use your mouse to drag it to a new location on your 
screen.  
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Tool Tips explain each of the toolbar buttons. To activate a Tool Tip, place the mouse over the 
button. The Tool Tip pops up. 

 

The toolbar buttons are shortcuts for the following commonly used commands. 

 

Use this button To do this 

 
Component » New: Create a new component. 

 
Component » Open: Open an existing component. 

 
Component » Save: Save the current component. 

 
Edit » Cut: Cut whatever is selected in the spreadsheet to the 
clipboard. 

 
Edit » Copy: Copy whatever is selected in the spreadsheet to the 
clipboard. 

 
Edit » Paste: Paste the contents of the clipboard to the current 
selection. 

 
Edit » Slide Selection Up: Slides the selected information up one 
row in the spreadsheet. 

 
Edit » Slide Selection Down: Slides the selected information down 
one row in the spreadsheet. 

 
Edit » Component Attr: Modify the attributes of the current 
component. 

 
View » Component Information: Opens and closes the Component 
Information dialog. 

 
View » Pins View: Opens and closes the Pins View dialog. 

 
View » Pattern View: Opens and closes the Pattern View dialog. 

 
View » Symbol View: Opens and closes the Symbol View dialog. 

 
Component » Validate: Validates the component for errors. 
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Use this button To do this 

 
Edit » Undo: Allows you to undo the last action. 

 
Source Browser: Opens the Source Browser dialog. 

 

You can turn on or off the display of the Toolbar by choosing the View » Toolbar command. 

Custom Toolbar 
You can create a Custom Toolbar for quick access to other applications from Library Executive. 
Programs are added to the Custom Toolbar by choosing the Utils » Customize command. You can 
start any of the applications by clicking their Custom Toolbar buttons or selecting them from the 
list of applications that appear in the Utils menu.  

Complete instructions on creating and using a Custom Toolbar are found in Utils Commands (page 
263). 

Prompt Line 
The prompt line at the bottom of the window displays information prompting you on the 
appropriate action to take. You can turn on or off the display of the Prompt Line by choosing the 
View » Prompt Line command.  

 

Library Executive Layout  
When you first access Library Executive, the interface is blank. All toolbar functions except 
Component New and Component Open are grayed, indicating they are unavailable. When you 
open a component (Component » Open) or create a new component (Component » New), the 
Component Information dialog opens and tool bar functions are enabled. Three other dialogs 
provide detailed information about the component and let you create pad to pin associations.  
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The Component interface comprises four main dialogs. The Component Information dialog 
provides information about a component. The three View dialogs provide visual feedback for 
patterns and symbols as the component is being created. This includes highlighting of pins and 
pads and the automatic selection of a spreadsheet row (in all three views) based on your selection 
within the pattern or symbol browse window. During component creation as much information as 
possible is automatically filled in for you. Changes you make to one dialog are reflected in the 
other three. 

Each of the dialogs may be resized to offer more or less viewing area depending on your needs. 
Each dialog can be accessed from any of the other three. 

A brief description of each dialog is presented in this section. For a detailed description of these 
dialogs, see View Component Info (page 255). 

Component Information 
The Component Information dialog, shown in the following figure, provides general information 
about a component. 
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From this dialog, you can set the component type as homogeneous or heterogeneous, select 
alternate views, set the number of gates and gate numbering style, define the total number of pins, 
attach patterns and symbols and assign a reference designator prefix. 

The maximum number of gates per component is 5,000. You can have as many as 10,000 pins per 
component. 

Pattern View 
The Pattern View dialog lets you select a pattern for the component and displays the information as 
shown in the following figure. 
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In the Pattern View dialog you can associate pin information to each pattern pad. A browse window 
displays the current pattern and the spreadsheet displays information about the pin/pad association. 
Click the Select Pattern button to open the Library Browse dialog where you can select a new pattern. 

Symbol View 
The Symbol View dialog lets you define symbols for the component. 

 

Use the Symbol View dialog to build an association between symbol pin information and the 
pattern’s pads. A browse window displays the attached current symbol(s) and the spreadsheet 
displays information about the pin/pad association. Click the Select Symbol button to open the 
Library Browse dialog where you can select a new symbol. 

Pins View 
The Pins View dialog is a spreadsheet view of the component, as shown in the following figure. 
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This dialog lets you associate pin information with each pattern pad, where each row corresponds 
to the pad number of an attached pattern, if a pattern is attached. The number of pins cannot be 
greater than the number of pads. 

The Pins View dialog consists of rows and columns identifying component properties such as Pin 
Designator, Gate # and Sym Pin #, all of which can be edited (e.g. to assign an electrical type). 
Above these rows and columns is a spreadsheet edit box (in the top-left corner) and buttons to 
open other views. 

Source Browser 
The Source Browser provides easy access to all of the component data from a variety of sources 
and most of the commands in Library Executive. 

The Source Browser is shown in the following figure. 

 

The Source Browser is a storage place for P-CAD libraries, library sets, an imported source file and 
query results. Its tree like structure provides easy access to each of these sources and their 
contents. When a source is selected, the shortcut menu provides access to the commands available 
for execution on that source. Refer to The Source Browser (page 91) for additional information. 

Query Dialog 
The Query dialog is a spreadsheet dialog in which component search criteria may be entered, as 
shown in the following figure.  

 

When Query is chosen, the selected source is searched for components satisfying the specified 
criteria. These components are listed in a Query Result Viewer dialog. See Viewer Dialog (page 10) 
for more information. 
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The Query dialog is a spreadsheet. Refer to the information in About the Spreadsheet Views (page 
10) for details on manipulating spreadsheets. 

The Query dialog can be accessed directly from P-CAD PCB and Schematic. Components in the 
embedded Query Result can be placed directly into the current design. Refer to Querying Libraries 
(page 103), for additional information. 

Viewer Dialog 
The Viewer dialog displays the components contained within a variety of sources. Query results, 
imported library source files, cross link results and P-CAD libraries all have their contents displayed 
in the spreadsheet Viewer.  

 

From the Viewer dialog, you can access many of the Library Executive features and functions, 
including query, verification and reports. Also, components selected in the Viewer can be placed 
directly into a P- CAD PCB or Schematic design. 

The file Viewer dialog is a spreadsheet. Refer to the information in About the Spreadsheet Views 
(page 10) for details on manipulating spreadsheets. 

Each of the Viewer dialogs are identical, independent of the source. However, the commands that 
may be accessed from the Viewer menu vary. For a summary of the Viewer dialog menu 
commands, refer to Viewer Menu Commands (page 15). For information on the Imported Source 
File Viewer, refer to Importing Data from an External Source (page 121). For information on the 
Query Results Viewer, refer to Querying Libraries (page 103). The commands accessible from a 
P-CAD library and Cross Link Results Viewers are the same as from a Query Result Viewer. 

About the Spreadsheet Views 
In Library Executive, each of the three view dialogs (Pattern View, Symbol View and Pins View) 
contains a spreadsheet displaying information about the pin/pad association of the component. 
The Query dialog and the file Viewer are also spreadsheets. These dialogs display the component 
attributes and/or their search criteria.  

This section describes the spreadsheet views of Library Executive. It includes detailed definitions of 
the fundamental building blocks of a component.  

Information about spreadsheet editing techniques and shortcuts can be found in Spreadsheet 
Editing (page 12). 
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Spreadsheet Columns 
The columns, which appear in all three common Library view dialogs, are used as follows: 

• Row Number: Each row number represents a pattern pad if a pattern is attached.  

 

• Pin Des: The pin designator is the name assigned to each pad/pin association. 

• Gate #: The gate number defines the gate on which the pin is located. In multi-gate 
components, the gates are uniquely numbered from 1 through n. 

• Sym Pin #: The number of the pin on the attached symbol. Symbol pin numbers must be 
unique and must exist in the attached symbol. 

• Pin Name: The pin name for the corresponding pad/pin association. 

• Gate Eq: The gate equivalence column indicates which gates within a component, or between 
components of the same type, are logically equivalent and may be swapped by choosing the 
Utils » Optimize Nets gate swap command. For two gates to be considered logically equivalent, 
the Gate Eq values must be identical and non-zero.  

Equivalent gates must have the same number of pins. A zero value (shown as a blank in the 
spreadsheet) indicates that the gate isn’t swappable. See the Utils Optimize Nets command 
section in the P-CAD PCB User’s Guide for information on swapping gates. 

• Pin Eq: Indicates which pins within a gate are logically equivalent and may be swapped by 
choosing the Utils Optimize Nets pin swap command. The pin equivalence values must be 
identical for a swap to occur between two pins. Non-swappable pins are indicated with a zero 
value. 

Jumper pins are listed as JMP-n, where all pins with the same -n value are considered jumpered 
together. A JMP1 jumpered pin is displayed as JMP. 

• Elec Type: The type of pin. Options appear in a shortcut menu, described in Electrical Pin Types 
(page 11). 

If a cell is blank, it has a value of zero (or an electrical type of Unknown). 

Electrical Pin Types 
The Elec Type cells are a combination of edit box and list. Click in the cell to select it and then click 
the Down Arrow next to the box at the top of the window to display a list of electrical pin types. 
Select the pin type you want from the list and it changes in the cell.  
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You can also access electrical types by typing the first letter of a given type. Where more than one 
type begins with the same letter (e.g. Passive-H and Passive-L), pressing the letter scrolls through 
the types. 

Spreadsheet Editing 
This section describes some common spreadsheet editing functions and also provides a list of 
keyboard shortcuts.  

To perform this task: Follow these steps: 

Edit a cell Type directly in a highlighted cell or select the cell and enter 
information. When you move off the cell (using one of the arrow or 
mouse keys) or press ENTER, the new information appears in the cell. 
ESC cancels the changes. When a list is available, the contents of a 
cell can be modified either by selecting an option from the list or 
typing the entry directly. 

Select a cell or cells To select a single cell press the left mouse button and drag the cursor 
to select additional cells. You can also hold down the SHIFT key and 
use the arrow keys to select multiple cells. 

Select a column 

Click the column heading button to select all cells in the 
corresponding column. 

Select a row 

 

Click the row button to highlight an entire row. 

Cut a cell or cells Choose the Edit » Cut command to remove the selection and place it 
onto the Clipboard. The selection can be a cell or a cell range. 

Shortcuts: 

Click the Cut button  

Press the CTRL+X keys 
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To perform this task: Follow these steps: 

Copy a cell or cells Choose the Edit » Copy command to copy the selection onto the 
Clipboard. The selection can be a cell or a cell range. 

Shortcuts: 

Click the Copy button  

Press the CTRL+C keys 

Paste information 
into a cell or cells 

Choose the Edit » Paste command to paste the contents of the 
Clipboard into a cell. If you select multiple cells, the contents of the 
Clipboard will be pasted into each cell. 

The paste area can be a single cell or a cell range. If the paste area is a 
single cell, this cell is the upper-left corner of the paste area; the rest 
of the copied data is pasted below and to the right of this cell. 

Shortcuts: 

Click the Paste button  
Press the CTRL+V keys 

Slide selected cells 
up or down 

To slide row 12 up to row 10: 

1. Select the columns in row 12 that you want to slide. 

2. Press the CTRL key and slide the row up. 

 

Before sliding row 12 data into row 10 

3. Notice that row 10 and 11 have been pushed down. 

 

After sliding row 12 data into row 10 

Shortcuts: 

Press the CTRL+UP keys 

Press the CTRL+DOWN keys 
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To perform this task: Follow these steps: 

Undo a task Choose the Edit » Undo command to undo the previous action. 

Shortcuts: 

Click the Undo button  

Press the CTRL+Z keys 

Move between cells Press the TAB key to move to the next cell; SHIFT+TAB to move back 
to the previous cell. 

Shortcuts: 

Click a cell 

Move a Column Select the column in the View dialog. Press the left mouse button and 
the SHIFT key. Drag the column to its new location. A black line 
indicates where the column will be placed when the mouse button is 
released. 

Enable All In the Save To Library and Query dialogs, columns containing check 
boxes can be entirely selected by clicking the column header. For 
example, click Show to select all check boxes in the Show column. In 
the Save To Library dialog, only one column can be selected at a time; 
clicking a column header button toggles the check box columns. 

Place a Queried 
Component 

In the embedded Query dialog, double click a component row to 
select it for placement. The workspace appears in Place Component 
mode with the selected component available for placement. 

 

Resizing Spreadsheet Views 
You can resize a spreadsheet view when you want to simultaneously display multiple windows, or 
when you want to add or reduce the number of spreadsheet rows in a window. 

 

To perform this task: Follow these steps: 

Reduce a view to an icon Click the Minimize button  

Restore a view to its previous size and location Click the Restore button  

Close a view window Click the Close button  

Change the size of a view window Point to the window’s border. When the 

pointer becomes a ↔ , click and drag the 
border to size the window proportionately.  
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To perform this task: Follow these steps: 

Expand the number of displayed spreadsheet 
rows 

Point to the window’s border. When the 

pointer becomes a ↔ hold the SHIFT key 
and drag the border until the desired 
number of rows appears. 

 

Menu Commands 
Additional menu commands exist in the Viewer and from the shortcut menus.  

Viewer Menu Commands 
This section describes how to use the menu commands for the Library Executive Viewer dialog. 
These commands are listed in the order that they appear on the dialog menu: Table, Column and 
Row.  

The Viewer is used for Query Results, P-CAD libraries, Cross Link Results and imported external 
source files. The Viewer menus are identical for the four sources with the exception of the Table 
command Map Fields, available for the external source file Viewer only.  

Table Commands 
Table commands allow you to access other features of Library Executive, including Query, Cross 
Link, Verify, Report and Library Save. They also allow you to rearrange the contents of the table by 
using cut, copy and paste. Of particular importance for importing files from an external source are 
the Map Fields and Cross Link commands, which are also entered from the Table menu. 

The Table menu is used in the external source file Viewer dialog. The Map Fields command is not 
available in the Table menu of the Viewer dialog for Query Results, Cross Link Results and P-CAD 
library files. 

• Cut: Removes any selected component row from the Viewer and moves it to the Clipboard. 

• Copy: Copies any selected item from the Viewer onto the Clipboard. 

• Paste: Pastes items from the Clipboard onto the Viewer. 

• Map Fields: Opens the Map Fields dialog where you can map the field names imported from an 
external source file to field names recognized by P-CAD Library Executive. 

• Cross Link: Opens the Cross Link dialog where you can link component attributes in the 
selected file with their corresponding components in another source. The Cross Link Results 
Viewer displays a combination of the attributes in the two source files for the linked 
components.  

• Query: Opens the Query dialog where you can narrow the component list of the imported 
library by including search criteria. 
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• Verify: Opens the Verify dialog where you can compare the components in the Viewer with 
components in a design or library. 

• Report: Opens the Report dialog where you can set up and generate a report on the 
components included in the Viewer. 

• Save to Library: Opens the Save Source dialog where you can save components in the Viewer 
to a P-CAD library. 

• Close: Closes the Viewer. 

The Verify and Save to Library commands are only available if the primary field, ComponentName, 
is present. 

Column Commands 
The Column commands for a selected column are available from the Column menu as well as from 
the shortcut menu. The commands allow you to add, remove, rename and sort the columns of 
fields and their values. 

• Add: Adds a column to the Viewer to the left of the currently selected column. Displays a dialog 
prompting you for the new field name. A pick list of predefined field names is available in the 
Add dialog. 

• Delete: Removes the currently selected column from the Viewer. 

• Rename: Displays a dialog that requests a new name for the currently selected column. 

• Sort: There are two methods available to sort columns: Allow Duplicates and Resolve 
Duplicates.  

The Allow Duplicates command sorts the field values, grouping duplicate values together. 

If you would like unique field values, use the Resolve Duplicates command. The suffixes _1, _2, 
_3, etc. are added to the end of repeated values. The Resolve Duplicates command may be 
preferred, for example, when sorting the ComponentName field, since P-CAD requires a 
unique name for each component. The Resolve Duplicates command is available only for fields 
with data type String. 

The sorting method for String and Integer data types differs. The default data type, String, is 
always used when saving attributes to a P-CAD library. Only modifiable attributes (not read-
only) are saved to the library. 

Row Commands 
The Row commands for a selected column are available from the Row menu as well as from the 
shortcut menu. With the Row commands, you can add a row or remove the component in the 
selected row. You can place a component in a P-CAD PCB or Schematic design. You can also open 
a component to view its component information. 

• Delete: Removes the currently selected row from the Viewer. 
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• Place: Places the selected component in a running PCB or Schematic design and opens the 
Place Part or Place Component dialog open with the component selected. 

• Open: Displays the Component Information dialog. Refer to View Commands (page 255), for 
additional information. 

The Open command is only available if the row contains the ComponentName and 
ComponentLibrary field. The Place command requires the row represents a valid component 
with an attached symbol or pattern. 

Source Browser Shortcut Menu Commands 
When you select an object in the Library Executive Source Browser and click the right mouse 
button, a shortcut menu opens, providing access to common commands performed on selected 
objects. The commands on the shortcut menu change depending on the object selected. 

The following commands appear on the shortcut menu. 

 

Choose this Command: To do this: 

Add Library Opens a standard window where you can navigate to and select 
the library you want to add to a selected library set. 

Cross Link Opens the Cross Link dialog where you can link component 
attributes in the selected file viewer with their corresponding 
components in another source. The Cross Link Results Viewer 
displays a combination of the attributes in the two source files for 
the linked components. 

Delete Deletes the selected library set. You can also press the DELETE 
key. 

Delete Attributes Deletes selected user-defined attributes from a P-CAD library. 

Map Fields Opens the Map Fields dialog where you can map the field names 
imported from an external source file to field names recognized 
by Library Executive. 

New Comma-delimited 
File 

Opens the Import Comma-delimited File dialog where you can 
select a non-P-CAD component data file to import into Library 
Executive. 

New Library Set Adds a new library set to the Source Browser. 

Open Opens the Component Information dialog. See View Commands 
(page 255), for additional information. 

Place Opens the Place Component dialog in PCB or the Place Part dialog 
in Schematic with the selected component name selected for 
placement. 
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Choose this Command: To do this: 

Query Opens the Query dialog where you can search the selected 
source. Query can be selected from a library, library set, an 
external source file, or a Query Result. 

Reload Reloads an external file, a library, or a library set’s contents into 
P-CAD Library Executive. The contents of a library or external 
source file are read automatically when the library components 
are viewed, queried, verified, or used in a report. If, for example, 
the library contents are modified by another designer, you can 
refresh the library contents in Library Executive by selecting the 
library and choosing Reload. 

Remove Removes the selected source from the Source Browser. You can 
also press the DELETE key. 

Rename Renames the library set. 

Report Opens the Report dialog where you can set up and generate a 
report on the selected source. 

Save to Library Opens the Save Source dialog where you can create or update a 
P-CAD library from the selected source. 

Verify Opens the Verify dialog where you can generate a difference 
report comparing the selected source to a P-CAD library or library 
set. 

View Opens the selected pattern, symbol, or source Viewer. 

 

Keyboard Shortcuts 
The Library Executive spreadsheet editors have specific P-CAD keyboard features in addition to 
some standard Windows accelerators (shortcut keys). They are listed in the following table. 

 

Press these keys: To do this: 

ALT+F4 

(Exit) 

Closes the active dialog. If no dialog is active, this works as a 
shortcut for Component Exit or File Exit, which exits the Library 
Executive program. If the current component has been modified 
since the last save, you will be prompted whether you want to 
save the changes. The program will write information to the 
cmp.ini file when you exit. 

CTRL+C 

(Edit Copy) 

A shortcut for Edit » Copy. Copies text from the selected cell(s) in 
the spreadsheet to the Clipboard. Main window must have focus. 



Keyboard Shortcuts Chapter 2: Library Basics 

Library Executive User’s Guide 19 

Press these keys: To do this: 

CTRL+Down 

(Edit Slide Down) 

Slides the selected information down in the spreadsheet. 

CTRL+N 

(Component New) 

A shortcut for Component » New. This command clears the 
spreadsheet to load the new component. Main window must have 
focus. 

CTRL+O 

(Component Open) 

Opens the Component Open dialog where you can choose a 
component. Main window must have focus. 

CTRL+S 

(Component Save) 

Saves changes to the current component without closing it. To 
save the component to a different name or location, choose 
Component » Save As. To clear the spreadsheet, choose 
Component » New. Main window must have focus. 

CTRL+UP 

(Edit Slide Up) 

Slides the selected information up in the spreadsheet. 

CTRL+V 

(Edit Paste) 

A shortcut for Edit » Paste. You can paste information from the 
Clipboard to the selected cells in the spreadsheet. 

CTRL+X 

(Edit Cut) 

A shortcut for Edit » Cut. Removes text from the selected cell(s) in 
the spreadsheet and places it on the Clipboard. 

F1 

(Help) 

Displays context-sensitive help. If you put focus on a Library 
Executive command or dialog (by mouse or keyboard) and press 
F1, the Help window appears containing information specific to 
the focus item. 

F2 

(Edit) 

Moves the cursor to a cell where you can modify its contents. 

TAB Moves forward from left to right one cell at a time. If you made a 
change to the previous cell, the change takes effect when you 
press TAB. 

SHIFT+TAB Moves backwards through the cells one at a time. 

Arrow keys If you haven't specified any change to a cell (nothing entered in 
the edit box), then the arrow keys will function normally, moving 
between cells in any direction. If you have made changes, the 
arrow keys allow you to commit the change and move to another 
cell. 

The SHIFT+arrow keys extend the selection. 
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Press these keys: To do this: 

DELETE Deletes items from the selected cell or cells. 

HOME Moves the cursor positioned in an edit box to the beginning (left 
side) of the box. When the cursor is positioned in the 
spreadsheet, it moves to the beginning of the row. 

END Moves the cursor positioned in an edit box to the end (right side) 
of the box. When the cursor is positioned in the spreadsheet, it 
moves to the end of the row. 

ENTER Transfers the change you make in the edit box to the cell that is 
being edited and moves the selection to the next cell below the 
current one. 

PgUp Scrolls the spreadsheet one page up. If the spreadsheet is only 
one page, scrolls to the top of the page. 

PgDn Scrolls the spreadsheet one page down. If the spreadsheet is only 
one page, scrolls to the bottom of the page. 
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CHAPTER 3 

Library Executive Tutorial 

Welcome to the P-CAD Library Executive tutorial. In this chapter, we will be investigating how to 
create libraries and components from scratch, as well as how to use the Symbol and Pattern Editors. 
After we have created a new symbol, pattern and component, we will have a quick look at the 
Source Browser. 

In this tutorial, we will create a symbol and pattern for a component, which is based on the logical 
diagram of the 7400 below. 

 

When creating our new component, we will follow these general steps: 

1. Create a new library, or open an existing one in which to store the 
component.  

2. Create a new symbol, e.g. NAND, or use an existing P-CAD supplied one, 
which will represent the component parts in a Schematic design. 

3. Create a new pattern, or use an existing P-CAD supplied one, e.g. DIP14, 
which will represent the component parts in a PCB design. 
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4. Create a new component, complete with Pin View information, which links the symbol, pattern 
and component information together. 

5. Validate and save the component into a library. 

For more information about the topics in this tutorial, press F1 for online Help. 

Creating a New Library 
First we will create a new library to house the symbol, pattern and component we will make. 

To create a new library: 

1. Open P-CAD Library Executive. You can open the Library Executive as a program by itself or by 
choosing Utils » Library Executive from the main menu of P-CAD Schematic or P-CAD PCB. The 
Library Executive window opens. A Default Library Set appears in the Source Browser window. 

 

2. Choose Library » New. The Library New dialog displays. 

 

3. Navigate to the folder you want the library saved into, e.g. the Demo folder in the P-CAD 
installation directory. 

4. Type in the new library name, e.g. Mylibrary.lib, and click Save. A new library has been 
created in the Demo folder. 
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Creating a New Symbol 
The new symbol we will create will be based on a symbol created by the Symbol Wizard. This will 
give us the basic shape we require and then we will use the Symbol Editor to make some 
alterations. 

1. Create the new symbol using Symbol » New to open the Symbol Wizard. 

 

2. Fill in the fields as illustrated above, with a Symbol Width of 400 mil, Pin Spacing of 100 mil, 2 
pins left, 1 pin right and Symbol Outline, Pin Name and Pin Des selected to display. 

3. Click Finish to close the Symbol Wizard. The Symbol Editor is now displayed in which you can 
modify the new symbol if necessary.  
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4. Choose Options » Display to turn off a pin display option. Click on the Miscellaneous tab. 

 

5. Deselect Display Default Pin Des and click OK. 

Modifying a Symbol 
Now we can modify the symbol created by the Wizard to form a NAND gate symbol as shown in the 
following figure.  
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1. First, we will add a new grid spacing of 20mil to allow for easier object placement. To do this, 
type 20 into the Grid Spacing box located on the status line and press Enter. 

2. Use the zoom keys + (zoom in) and – (zoom out) to view the symbol as necessary. 

3. Now we will make the symbol bigger by selecting and deleting the right-hand vertical line of 
the box. Click on the line to select it and press the Delete key. 

4. Make the remaining body of the symbol 400 mils high by selecting the bottom line and the 
{Type} field and moving them down 100 mils as shown. 

  

5. Extend the remaining vertical line to meet the bottom line. To do this, select the vertical line, 
click on the editing handle at the end and drag the line to its new position. 

6. Select the pin number 3 and move it out of the way while we create the arc. 

7. To create an arc with a 200mil radius, select Place » Arc or click the  toolbar button. Place 
the cursor over the end of the line at the top right of the symbol where you want the arc to 
start. Click and drag the cursor from the top to the bottom and release. An arc appears. Press F 
to flip the arc over and then click again at the bottom to place it. Right-click, or press ESC, to 
end arc placement. 
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8. Choose the Select tool  to reposition the {Refdes} and {Type} fields and move pin number 2 
down 100 mils. Simply select the objects and drag them to their new positions. 

9. Double-click on pin 3 to open the Pins Properties dialog and add a dot to the Outside Edge. 
Select Pin Name and Pin Des in the Display frame so these values will display with the pins and 
click OK. 

 

10. Your symbol should now resemble the NAND gate symbol shown at the beginning of this 
section, so let’s save it to the library Mylibrary.lib. 

11. Choose Symbol » Save and the Symbol Save to Library displays. 

 

12. Choose the library we created earlier by clicking on Library and navigate to Mylibrary.lib. 
Type NAND in the Symbol field and click OK. 

13. Close the Symbol Editor by choosing Symbol » Exit or click on the Close button . 
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14. You will be asked to save your symbol again but choose No since no changes have been made 
since you last saved it. 

Creating a New Pattern 
Although we have a DIP14 already created and available through a number of P-CAD supplied 
libraries, we will take a quick detour to look at the Pattern Editor and how the Pattern Wizard would 
create a pattern to your specifications. 

1. Choose Pattern » New from the Library Executive main menu to open the Pattern Wizard. 

2. Select DIP from the Pattern Type list and fill in the other fields as per the illustration below, i.e. 
14 pads down, 100mil Pad to Pad Spacing, 300mil Pattern Width, Pad 1 Position of 1. Make sure 
the Silk Screen checkbox is selected and the Silk Rectangle Width is 200mil and Height is 
700.0mil. Leave the Pad Styles as defaults. 

 

3. Click Finish to close the Pattern Wizard. The Pattern Editor is now displayed in which you can 
modify the new pattern if necessary by using the standard P-CAD PCB drawing tools.  
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4. For this tutorial we will not need to alter the pattern that was created by the Pattern Wizard, so 
we will save the pattern into our library by choosing Pattern » Save. Navigate to the library 
Mylibrary.lib by clicking on the Library button, enter the library pathname and click Open. 

5. Type DIP14 in the Pattern field and click OK. 

 

6. Close the Pattern Editor by choosing Pattern » Exit or clicking on the Close button . 

7. You will be asked to save your pattern again but choose No as no changes have been made. 
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8. You are returned to the Library Executive window. Now we will create a component that uses 
the symbol and pattern we have created. 

Creating a New Component 
Creating a new component will link a symbol and pattern together with necessary pin information.  

1. Choose Component » New in the Library Executive. You are prompted to open the library into 
which this component will be stored. 

 

2. Select Mylibrary.lib from the Demo folder and click Open. The Component Information 
dialog displays. 

 

3. Enter the number of gates (4) and press Enter. The ‘gates’ referred to when creating 
components in this section are referred to as ‘parts’ when they are being placed in a Schematic 
design.  
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4. Notice that the Gate # spreadsheet appears at the bottom of the Component Information 
dialog. Gate Equivalence (Gate Eq) values indicate which gates (parts) within a component are 
logically equivalent and may be swapped in a PCB design. For two gates to be considered 
logically equivalent, the Gate Eq values must be identical and non-zero. Equivalent gates must 
also have the same number of pins. A zero value (or a blank cell in the spreadsheet) indicates 
that the gate is not swappable. 

See the Utils Optimize Nets command section in the P-CAD PCB User’s Guide for information 
on swapping gates. 

 

5. Leave the Component Type information as defaults since we are creating a normal component 
type that is homogeneous (all gates use the same symbol) with alphabetic gate numbering. 
Since you set the component style to Homogeneous, then all Gate Eq values are set to the first 
Gate Eq value of 1.  

There are five types of components: Normal, Power, Sheet Connector, Module, and Link. 
Naming a component type allows that component to properly associate with net connections. 
The component type also determines whether the component will appear in the netlist or bill 
of materials. 

Adding the Symbol 
First we will add the symbol NAND to the component. This symbol is a representation of the part of 
a component when placed in a schematic design using P-CAD Schematic. 

1. Click on Select Symbol to choose which symbol you are attaching to the component. The 
Library Browse window displays the symbols available in the selected library.  
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2. Our NAND symbol is already selected, so click OK to add it to the component. You are 
returned to the Component Information dialog.  

3. Notice that the NAND symbol name has been added into the Gate # spreadsheet at the bottom 
of the Component Information dialog.  

Adding the Pattern 
Next a pattern is added to the component to represent the component’s footprint when placed in a 
PCB design using P-CAD PCB. Pad information from the pattern is used for matching pin to pad 
numbers when editing the Pins View later in this tutorial. 

1. Click on Select Pattern to choose the pattern this component will use when placed in a PCB 
design. The Library Browse window displays the patterns available in the selected library. 

 

2. Our DIP14 pattern is already selected, so click OK to add it to the component. You are 
returned to the Component Information dialog. Notice that the pattern name, DIP14, has been 
added to the top right of the dialog and the number of pads has been set to 14. 

3. To view all the different parts of our component, click on Symbol View, Pattern View and Pins 
View and arrange the windows on your screen so that you can see what is happening as you 
change the pin information. 
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The final stage of setting up our new component is editing the Pins View spreadsheet so that the 
logical pins and the physical pins are correctly matched. 

Editing the Pins View Spreadsheet 
You define the electrical properties of your component in the Pins View spreadsheet. When you 
attach a pattern to a component, pad numbers and pin designators (Pin Des) are filled in. When you 
select a symbol, gate numbers (Gate #) and pin numbers for that symbol (Sym Pin #) are 
automatically added. Electrical types default to Unknown. 

For information about spreadsheet editing techniques, refer to Library Basics (page 3). 

1. Click on the Pins View spreadsheet that you opened by clicking on Pins View. Notice that the 
program has automatically filled in some of the columns from information already supplied. 
We will be checking this information and adding new data. 

2. Make sure that the pin information corresponds to the pads on the pattern in a way that 
matches the 7400 component specifications by checking the pin designators.  
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3. In this example, the pin designators coincide with the pad numbers and so can be left as 
entered. 

 

4. Notice that rows 13 and 14 do not have Gate # and Sym Pin # entries. This is because there are 
only 12 pins on the 4 NAND symbols associated with the pattern, but there are 14 pads on the 
DIP14. These two extra rows will be used to specify the hidden power and ground pins that are 
associated with pads 7 and 14 respectively.  

5. Let’s shift the pin information in rows 7 through 12 down one row to make room for the hidden 
power pin data to be filled in later. Select the information associated with gates 3 and 4 as 
shown below.  
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6. To quickly move the selected cells down to allow room to add power pin information for pin 
number 7, click the Shift Down button  on the Library Executive main toolbar to move the 
selected data down one row. 

 

7. The Sym Pin # (Symbol Pin Number) is the number of the corresponding pin on the 
attached symbol. Now we will map the Symbol Pin # to the physical Pin Designators 
based on specifications found in the manufacturer’s data book.  

The Sym Pin # information added automatically is only half correct. Delete the Sym Pin 
# data for pins 8 to 13 by selecting them and pressing the Delete key. Type in the new 
values as shown right. You can type directly in a highlighted cell or highlight the edit 
box at the top of the window and type in information. To enter the data, press Enter or 
move the cursor to another cell using the arrow keys or the mouse. 

8. We will only be allocating Pin Names to the power pins in this exercise, so type in GND 
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for pin 7 and VCC as the Pin Name for pin 14. Hidden power pins are automatically connected 
to the net specified by the Pin Name. 

9. Now we can add Gate Eq (Gate Equivalence) of 1 to the gates. All gates are equivalent in a 
homogenous component and so all the gates will be using the same symbol. To quickly fill this 
column, type 1 in the first cell of the Gate Eq column and press Enter.  

10. Assign Pin Eq (Pin Equivalence) values for the component if pin swapping is required when 
using the component in both P-CAD PCB and Schematic. The Pin Eq indicates which pins 
within a gate are logically equivalent and may be swapped. These values must be non-zero and 
identical for a swap to occur between two pins. Non-swappable pins are indicated with a zero 
or blank.  

Both input pins (Symbol Pin # 1 and 2) can be swapped in this example, so enter the same code 
for these pins, e.g. 1. 

11. Finally, we will assign the Electrical Types to each pin, e.g. Input, Output and Power. The 
electrical types may be entered quickly by selecting the appropriate cell and typing the first 
letter of the electrical type name, for example, I for input and O for output. If there is more 
than one electrical type that starts with the same letter, type the letter again to select the next 
one, e.g. press P until the type Power appears. 

Alternatively, select a cell in the Electrical Type column and right-click to choose the Electrical 
Types command from the shortcut menu. 

12. When entering electrical types by typing in the first letter, notice that the power and ground 
pins were automatically filled in with a value of “PWR” for the gate number. If you used the 
shortcut menu to enter the electrical types, PWR is not automatically added, so type in PWR to 
complete the spreadsheet as below. 

 

Now we can check and validate our new component before we save it to a library. 
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Visually checking the pin information 
Before we leave the component views, we can have a quick visual check that the pins have been set 
correctly. As you select a Pin Number’s row, the corresponding pin is highlighted in the Symbol 
View and its corresponding pad is highlighted in the Pattern View. In the example below, pin 
number 13 has been selected and highlighted in all views. 

 

Validating and Saving a Component 
As a final check that the component is correct, we can validate it.  

1. Choose Component » Validate or click on the  button on the Library Executive main toolbar. 
If the component and its pins have been set up properly, there should be no errors. If you have 
errors, the error description will indicate which part needs to be altered. Fix the error(s) and 
revalidate the component until the following dialog displays and click OK. 

 

2. Choose Component » Save to complete the creation of the new component. The Component 
Name dialog displays. 
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3. Name the new component 7400 and click OK. 

4. Close the Component Information dialog by clicking on the Close button . 

Using the Source Browser 
The Source Browser can be used to display all of the component data currently available in the 
P-CAD Library Executive. We will add our new library to the Default Library Set that will load every 
time you access the Library Executive and then check the contents of the new library using the 
Source Browser. 

1. To access the Source Browser, click the Source Browser button  on the Library Executive 
toolbar or choose View » Source Browser from the menu. The Source Browser window 
displays. 

 

The Source Browser is organized in a tree-like structure that shows the relationship between 
the component data sources. The tree structure allows you to view all Library Executive library 
sets and their contents at various levels of detail by expanding or collapsing the branches of 
the tree. To expand a branch, simply click the + to the right of its name. Expanded branches are 
shown with a - sign. To collapse the branch, click the - sign. 

2. To add our new library to the Default Library Set, right-click on DEFAULT_LIBRARY_SET and 
choose Add Library from the shortcut menu. The Open dialog displays. 
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3. Select Mylibrary.lib from the list of libraries available in the Demo folder of the P-CAD 
installation directory and click Open. 

4. Expand the Default Library Set to display the names of libraries already added. Then expand 
Mylibrary.lib to view the components, patterns and symbols stored in it. 

 

5. Double-click on a component name, e.g. 7400, to display its Component Information dialog. 

6. Double-click on a pattern name, e.g. DIP14, and the pattern will display in the Pattern Viewer. 
You can then edit the pattern by clicking Edit in the Pattern Viewer, if required. Click Close to 
return to the Source Browser. 

7. Double-click on a symbol name, e.g. NAND, to view or edit the symbol via the Symbol Viewer. 
Click Close to return to the Source Browser. 

For more information about the other features available in the Source Browser, see The Source 
Browser (page 91).
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CHAPTER 4 

Libraries 

This chapter provides important information about the structure and characteristics of P-CAD 
libraries, including: 

• Integrated, pattern and custom libraries 

• Using the Library Index 

• Creating, updating and saving libraries 

• The relationship between and usage of components, patterns and symbols 

• Pin numbers, pad numbers and pin designators 

• Pattern library naming conventions 

• Updating libraries with swap information 

• Errors preventing saving 

• Copying, renaming and using aliases 

• Compacting libraries 

Integrated, Pattern and Custom Libraries 
A library with components having both pattern and symbol information is an integrated library. 
Both schematics and printed circuit boards can be built with the same components from an 
integrated library.  

P-CAD includes 334 new component libraries, containing over 27,000 components. These libraries 
have been developed by the P-CAD Library Development Center in accordance with the ISO 9001 
certifed component development process that they have established. 

P-CAD supports two types of libraries: integrated and pattern. In P-CAD, a library can contain three 
types of items: logical components, pattern graphics and symbol graphics. Components contain 
only logical information – the associated graphics for Schematic symbols and PCB patterns are 
stored separately. This is the key to understanding how P-CAD libraries are structured. 
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Integrated Libraries 
Integrated libraries contain intelligent components suitable for use with both P-CAD Schematic 
and PCB. The components in these libraries have logical pin designators and pin data specific to the 
type of the component (e.g. SN7400N). These components reference the appropriate Schematic 
symbol graphics and PCB pattern graphics (also known as footprints or decals).  

In a typical integrated library, many components reference the same pattern graphic since those 
components have the same PCB pattern. Note that the component gives the pattern and symbol 
graphics all their “intelligence”; pattern graphics and symbol graphics do not contain any logical 
information such as pin designator values. 

Pattern Libraries 
Pattern libraries contain generic components that have generic pin designators and pin data and a 
reference to a PCB pattern graphic. These libraries do not contain Schematic symbol graphics and 
are unusable with P-CAD Schematic.  

If you use P-CAD Schematic, you must use the integrated libraries since the PCB-specific libraries 
contain no symbol graphics. If you import a netlist from P-CAD Schematic, it is recommend you use 
the integrated libraries in PCB. This allows you to maintain synchronized PCB and schematic 
designs between P-CAD Schematic and P-CAD PCB in such areas as: 

• Hotlink support 

• ECO support 

• Pin and gate swapping 

If you use a third party schematic editor to create netlists for PCB, it is recommended you use the 
generic PCB pattern libraries in PCB. These generic pattern libraries are identified by names starting 
with pcb, e.g. pcbmain.lib. 

Custom Libraries 
The component libraries supplied with the P-CAD family of applications may be updated in future 
releases, so it is strongly suggested that you do not modify the P-CAD-supplied libraries. Save your 
custom components to a separate library, for example Custom.lib. Then, you can install future 
releases of P-CAD libraries and maintain your custom components. 

Viewing Contents of the Libraries 
To view the contents of any library, use the browse function of the Place Component dialog in 
P-CAD Schematic and PCB, or use the capabilities of the Source Browser and the file Viewer. 

You can print a complete, formatted listing of the components within each library with the report 
feature. For complete information on using the report features, see Reports (page 145). 

Using the Library Index 
Each new P-CAD supplied library is based on a component range available from a device 
manufacturer. A complete library index, Library Index.XLS, can be found in the Lib folder of 
the P-CAD installation directory. Use this file to review the complete list of new components.  
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Each component entry has the following information: 

 

Column Description 

Name This is the Component Type. 

Description This is a description of what the component actually is. 

Manufacturer This is the company that actually makes the component. 

Class This is the general class that the component falls into, e.g. 
Communication, Logic. 

Sub Class This is the more specific sub class that the component falls into, e.g. for 
the Logic class, the component might fall into the sub class of Gate, 
Register, Switch, etc. 

Datasheet Date/Rev.  This is the date/revision number of the datasheet associated with the 
component. 

Package Code This is the manufacturer's code for the component package. 

Package Type This is the type of package that the component comes in, e.g. DIP, CAN. 

Footprint Code This is the name of the associated pattern that is used for the 
component in the PCB Editor. 

SIM Model File This is the associated model file for the component. If the component 
has an entry in this field, then the component can be simulated. 

Revision History This is an entry showing when the component was first available in 
P-CAD and any subsequent modifications that have been made. 

 

Each library name is based on the manufacturer's name and the library sub-class. The library class is 
also included when necessary to distinguish between sub-classes. For example, the NEC 8-bit 
Microcontrollers are in a library called "NEC Microcontroller 8-Bit.lib, and the Analog Devices 
operational amplifiers are in a library called "AD Operational Amplifier.lib". 

To use the spreadsheet to locate a component and therefore identify which library you should add 
to the current open libraries list, follow the steps below: 

1. Using Windows Explorer, browse to the Library Index (Library Index.xls in the Lib folder 
of the P-CAD installation directory) and double-click on the file;’scon. The Library Index 
displays as a spreadsheet. 
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2. Click on the <Date> tab in the bottom left-hand corner to make the component sheet active. 

3. Search the spreadsheet to find the component you require using the Edit » Find command. 

4. Determine the name of the library in which the required component resides and add it to the 
open libraries list. 

Creating and Updating Libraries 

Creating a New Library 
To create a new library from the selected source, follow these steps: 

1. Choose the Save to Library command. Refer to Accessing the Save To Library Command (page 
46) for additional information. The Save Source dialog appears. 
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2. Select the Create New option button. 

3. Enter in the desired library name in the File Name box, or click the Library button to navigate to 
and select the desired directory.  

4. Click Save. The Save Source dialog now displays with the desired library name. 

5. If the Create component time stamps if not present check box is selected, the attributes 
CreateDate and ModifyDate are added to the component with the current date and time.  

6. The Attributes To Be Created box lists the attributes in the selected source. All attributes in this 
list are saved to the specified library unless the corresponding check box in the Ignore column 
is selected. 

7. Click OK. A new P-CAD library has been created which contains the selected component 
attributes.  

Updating an Existing Library 
To update an existing P-CAD library, follow these steps: 

1. Choose the Save to Library command. Refer to Accessing the Save To Library Command (page 
46) for additional information. The Save Source dialog appears. 

 

2. Select the Update option button. 

3. Enter the desired library name in the box or click the Library button to navigate to and select 
the desired library. The selected library name is now displayed.  

If the Create new components box is selected, components in the source that are not already 
in the selected library are added to the library. 
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If the Update only components with matching library name box is selected, Library Executive 
searches the source for components whose ComponentLibrary attribute matches the selected 
library. Only matched components are updated or added to that library. 

When updating a library, the component’s time stamp attribute ModifyDate, if present, is 
automatically updated with the current date and time. If the Create component time stamps if 
not present check box is selected, and the ModifyDate attribute does not exist, the ModifyDate 
attribute is added to the component library.  

All attributes that will be updated in the library are listed in the Attribute Conflict Resolution 
section.  

Read-only attributes cannot be modified and cannot be saved to a P-CAD library. These 
attributes are displayed in red on the library Viewer and Query Result Table. 

In this section, you can specify how to handle discrepancies between the source and the target 
library. Difference handling can be customized for each attribute by the following simple rules: 

• If the Ignore check box is selected, the source attribute is ignored. It is neither created nor 
updated in the specified library. 

• If the attribute exists in both the source and the library, and the Source check box is 
selected, the source is favored. The source attribute value replaces the present library 
attribute value. 

• If the attribute exists in both the source and the library, and the Library check box is 
selected, the library is favored. The library attribute value remains unchanged. 

• If the attribute in the source does not exist in the library component and the Ignore check 
box is cleared, it is added. 

4. Click OK. The library has been updated to reflect the new attribute values.  

Any new components have been added if the Create new components check box was selected. 
Refer to Creating a New Library (page 42) for details about the completeness of components 
created by the Save To Library command. 

Saving a Library 
You can create or update a P-CAD library from a variety of sources: 

• a modified P-CAD library 

• an imported library from an external source 

• a query result 

• a cross link result 

The only requirement is that you have the primary field, ComponentName, uniquely defined.  
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To save a source to a P-CAD library, choose the Save to Library command. Refer to Setting up a 
Library Set (page 45) for more information. 

What is Saved? 
You can customize which component attributes are stored in a P-CAD library. For example, if 
pricing is important for component selection, you can choose to save the Cost attribute. Later, you 
can query on this attribute for component selection.  

Many attributes can be saved to a P-CAD library, including user-defined attributes that can be 
tailored to enhance your particular PCB design projects. The default data type, String, is always 
used when these attributes are saved.  

Read-only attributes are unmodifiable and cannot be saved to a P-CAD library. There is one 
exception to this rule: when a new library is created, the read-only ComponentName field can be 
saved. Complete, integrated components can be created in this new library. 

Read-only attributes are displayed in red on the library Viewer and Query Result Table. 

Setting up a Library Set 
This section illustrates the process of setting up a library set. MYSET will contain the following 
libraries: Demo.lib and Ale_tutor.lib. These libraries can be found in the Demo and Tutorial 
folders in the P-CAD installation directory, respectively. 

To make the Demo.lib and Ale_tutor.lib libraries available for Library Executive, you can 
define a library set containing the two libraries. You can define the library set from the Source 
Browser or from the Library Setup dialog.  

To use the Library Setup dialog, follow these steps: 

1.  Choose Library Setup to open the Library Setup dialog. 

 

2. Click the Add Set button. An edit box appears in the Library Sets box. 

3. Type MYSET into the edit box to define your new library set. Press ENTER. 

4. While MYSET is selected, click the Add Library button to navigate to and select the libraries you 
want to add to the set. 
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5. Navigate to the Demo folder in the P-CAD installation directory and choose Demo.lib. Click 
Open. Demo.lib appears in the Members box. 

6. Repeat steps 4 and 5 to add the library Ale_tutor.lib in the Tutorial folder in the P-CAD 
installation directory to the library set MYSET. 

7. Click Close.  

To view the contents of the library set, click the Source Browser button on the toolbar to 
access the Source Browser tree. 

8. Expand both the root of the tree and library set MYSET to view its contents. 

 

To add another library to the set, you can simply select the set in the Source Browser tree and 
choose Add Library from the shortcut menu.  

Accessing the Save To Library Command 
Choose the Save To Library command to update or create a P-CAD component library. The Save To 
Library command can be accessed from the Source Browser, the File Menu, and the Table Menu. 
The location from which you choose the Save To Library command defines the components you 
intend to store in the library. For example, choosing Save To Library from a Query Result table 
stores the components listed in that Query Result.  

This section describes how and where to choose the Save To Library command to get the results 
you desire. 

From the Source Browser 
1. Select any library, query result, or external source file from the Source Browser tree.  

2. Choose Save to Library from the shortcut menu. One of the following results occurs: 

• If you select a library, the components listed in that library are stored in the specified new 
P-CAD library. If modifications to that library were made while in Library Executive, that 
same library can be updated with this command to reflect those changes. 

• If you select a query result, the components listed in that Query Result table are stored or 
updated in the specified library. 

• If you select a cross link result, the components listed in that Cross Link Result table are 
stored or updated in the specified library. 
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• If you select an external source file, the components listed in the file Viewer are stored in 
the specified P-CAD library. Updates can be easily made to P-CAD libraries from an 
external source file using this command, making changes to your corporate component 
database easy to incorporate into your PCB designs. 

From the Table Menu 
1. Choose Save to Library from the Table menu in the Viewer for imported source files, query 

results, cross link results and P-CAD libraries.  

2. The contents of the current table are saved to a library. 

From the File Menu 
1. Choose Save to Library from the File Menu. 

2. The mapped, imported source file is saved to a library. 

Time Stamps 
In Library Executive, you can automatically mark the time when a component in a P-CAD library was 
created, modified or verified. These times are saved in the user-defined attributes CreateDate, 
ModifyDate, and VerifyDate fields. Time Stamp makes keeping track of libraries effortless. 

The Time Stamp feature of Library Executive can save you both time and headaches, especially if 
more than one designer is using and modifying the same component libraries. For example, you 
may want to find all components in a P-CAD library that have been modified after a certain date. 
With this feature, you can quickly find what changes have been made since you last used the 
library. 

Time stamps are available from these Library Executive commands and features: 

• Save To Library: The Save To Library command controls both the CreateDate and ModifyDate 
fields. The Save To Library command is discussed in to Creating a New Library (page 42). 

• Verify: The Verify command controls the VerifyDate field. For additional information on the 
Verify command, see Chapter 10, Library Verification (page 137) 

• Query: Time Stamps can also be used in the Query utility. For information on how to search 
for a CreateDate, ModifyDate, or VerifyDate field, refer to Querying Libraries (page 103). 

Components, Patterns and Symbols 
P-CAD integrated libraries contain components, patterns and symbols.  

A component contains the logical and electrical data for a device and two graphical 
representations: 

• One or more symbols for a Schematic representation. 

• A pattern for a PCB representation. 
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Each component consists of one or more logical gates packaged into a physical component. A 
single pattern is the basic graphical structure used in the creation and display of an entire 
component in PCB.  

 

A symbol is the basic graphical structure used in the creation and display of a single gate in 
Schematic, as shown in the following figure.  
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The integrated libraries supplied with P-CAD can have symbols of different names that are 
graphically identical. 

PCB cannot use a component or pattern by itself, it requires a component/pattern combination. 
Schematic needs a component/symbol combination. When a component is placed, it references 
the pattern and/or symbols attached to it for graphical structure. Numerous components can 
reference the same pattern or symbol. The component and the pattern and symbols it references 
must reside in the same library. 

The following is an illustration of four components within a P-CAD library, all of which reference a 
DIP14 pattern. Although not shown, the same would hold true for components sharing symbols in 
Schematic. 

SN7400N

CUST1

CUST2

"DIP14"

"DIP14" "DIP14"

"DIP14"

QNX7

DIP14
 

Renaming or deleting a pattern could have a profound impact on a library. If you change the name 
of a DIP14 pattern to D14, for example, the four components shown above would reference a 
nonexistent pattern.  

The graphical pattern DIP14 only needs to be stored as one entity. When you place a component, 
the component locates the named pattern structure and imports it into the design along with the 
component information. The same holds true for symbols. 

A P-CAD library could contain many components, but only one pattern and one symbol, and it 
would be complete as long as all the patterns and symbols that the components reference exist in 
the library. 

It is likely that a library will have multiple components using the same patterns and symbols. This 
saves space and makes global edits of a pattern or symbol efficient. It is also potentially dangerous, 
as any changes to a pattern or symbol affect all components referencing that pattern or symbol.  

Component Types 
There are five component types: Normal, Power, Sheet Connector, Module and Link. By specifying 
a component type, you can properly associate the net connections for that component. The 
component type is specified in the Component Information dialog. 

• Normal: The most common type of component, for example diodes, DIPs and resistors. On a 
Normal component, the pins are associated with the net to which they are connected. Normal 
components appear in the netlist and the Bill of Materials. 
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• Power: A special component, used only in Schematic designs, representing a connection to a 
power source. This component type does not appear in the netlist or Bill of Materials. 
However, any pin connected to this component will be associated with the power net. 

• Sheet Connector: A component with no net intelligence. This component type is commonly 
used to import non-intelligent graphics from a library, such as company logos or a chart. It 
does not appear in a netlist or Bill of Materials. 

• Module: Used with hierarchical designs, a module component represents another sheet of 
circuitry in a design. Module components are used on the parent sheet to maintain 
connections to the link components.  

• Link: Used with hierarchical designs to represent another sheet of circuitry in a design. Links 
are used on the child sheet to maintain connections to the module components.  

Pattern Graphics in the Library Executive 
Pattern graphics are the graphical representation of the pattern that is used when placing 
components in P-CAD PCB. Every pattern has at least one pattern graphic with the default name of 
Primary that is created when you use the Pattern Editor.  

You can set up multiple and varying pattern graphics for the patterns associated with components. 
This allows differing pattern graphics to be automatically applied when placing a component, 
depending on whether the component is placed on the top or bottom of the board, how it is 
rotated and the chosen direction of solder flow. Pattern graphics may be a different orientation or a 
different size from the base pattern.  

The pattern graphics are stored in the pattern file within a library. You can attach (copy) pattern 
graphics from other patterns to a target pattern as long as they are all in the same library. You can 
create new pattern graphics or modify existing pattern graphics using the Pattern Editor. Refer to 
Pattern Graphics in the Pattern Editor (page 68).  

Adding existing pattern graphics to a target pattern 
1. Choose Library » Pattern Graphics. The Library Pattern Graphics dialog displays. 

2. Open a source library where the target pattern and the already created pattern graphics reside. 
Click on Library to open the Library Select dialog and navigate to the required library and click 
Open. 

3. Choose a target pattern to which you want to add additional pattern graphics by selecting the 
required pattern name from the Target Pattern drop down list. If only one pattern graphic 
exists for this target pattern, the word ‘Primary’ displays and the primary pattern graphic is 
shown in the view window. If there are other pattern graphics already attached, their names 
will be listed as well. 

4. Click on the Alternates tab and search through a list of all source patterns in the library and 
select the new pattern graphic you want to copy to the target pattern. Type in a new pattern 
graphic name and click Copy to Target. The new name is added to the Target Pattern Graphics 
list. Click on names in this list to see the pattern graphics associated with the target pattern in 
the view window. 
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5. Click on the Orientations tab to specify which pattern graphics are to be used for a specific 
orientation. Up to eight different pattern graphics can be used to represent various component 
orientations, depending on whether the component is flipped or rotated by 0°, 90°, 180° or 
270°. 

6. Click on Apply Pattern Changes to Library and click OK to close the dialog. 

For more details, refer to Library Pattern Graphics (page 214) in the command reference section. 

Pin Numbers vs. Pad Numbers vs. Pin Designators 
An important fact to understand about components and patterns or symbols is that pad numbers 
do not equal pin designator values and that symbol pin numbers do not equal pin designator 
values, except by a coincidence.  

Pin designators are the critical piece of data that map physical pads (in PCB) to logical pins (in 
Schematic). Pad numbers are just identifiers for pads, used to cross-reference with the pin 
designators when assigning the pin designator values. Similarly, symbol pin numbers are just pin 
identifiers. Using an ordered, linear, pad or pin numbering system makes identifying pad numbers 
and symbol pin numbers easier, but you could just as easily number them randomly and still assign 
pin designator values to them. 

In the component/pattern/symbol combination, pattern and symbols contain only pad and symbol 
pin numbers, whereas components contain pin designators. Each pin designator references one 
pad number and one symbol pin number.  

For example, suppose you are creating a 6-pin component with pin designators A through F. You 
could number your pads and assign pin designators as follows. 

   

If your pads were numbered differently, the mapping would change, but the pin assignments 
would remain the same. 
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Therefore, the pad numbers are irrelevant, except for the purpose of assigning pin designators. 
Regardless of the numbering, the pin designator assignments in this example are as follows: 

 

This is analogous for Schematic symbol pin numbers. 

Pattern Library Naming Conventions 
When looking through the pattern libraries, most pattern names will be familiar. However, the 
following naming conventions may help to clarify the more obscure pattern names.  

Patterns for surface mount packages are built to the current standards developed by IPC - 
"Association Connecting Electronics Industries". IPC claims that these land patterns are transparent 
to the manufacturing process but recommends that they should be optimized to suit the soldering 
type (wave, reflow) and assembly (components mounted on one or both sides of the board, etc). 

Land patterns for BGA devices follow the assumptions found in standard, IPC-SM-782A, 
Amendment 2 (April 1999). The pads for this standard are defined by the etched copper, rather than 
by the solder mask. Land patterns for other surface mount components follow the assumptions 
found in standard, IPC-SM-782A, Amendment 1 (October 1996). 

All pattern dimensions are calculated in metric units. Hard metric dimensions are employed in 
accordance with the JEDEC JC-11 "Metrication Policy", SPP-003B (February 1998). Departures to this 
policy are made for some silkscreen dimensions and critical dimensions such as pitch and row 
spacing. 

Pattern Acronyms 
The pattern naming convention is in sympathy with the IPC component names and the JEDEC 
Standard, JESD30-B, "Descriptive Designation System for Semiconductor-Device Packages" (April 
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1995). The system is based upon a minimum, compulsory 2 to 4-letter code that describes the 
Package Outline Style. Further optional characters are used to provide additional information such 
as the number of terminals and their position. Seven fields are available for the assignment of a 
name to each pattern. Pattern names of Chip Resistors, Chip Capacitors and certain other packages 
do not follow this system. 

The following fields make up the acronym for a pattern name: 

1.  Features Package Specific Features 

2. Position  Terminal Position 

3.  Package  Package Outline Style 

4.  Dimensions Major dimensions of package 

5.  -Form  - Lead Form 

6.  Count  Terminal Count 

7.  Supplementary  /Supplementary Information 

Examples: 

TSSO6x14-G16  Thin Shrink (TS) Small Outline (SO) with package dimensions of 6 & 14mm for the 
respective parameters of D & H and 16 Gull (G) wing leads. 

DIP-24/D31  24 pin, Dual In-Line Package with a silk screen length of 31mm for the dimension, D. 

 

1. Package Specific Features (nominal dimension) 
 

Designator  Description 

B  Bumpered (Corner Bumpers present) Employed with QFP family 

C Ceramic 

E  Enlarged pitch (>1.27 mm) 

F  Fine pitch (<=0.50 mm) Restrict to QFP family 

L  Low profile (1.4 mm body thickness) 

M Metal 

R  Rectangular 

S  Shrink pitch (<=0.65 mm). All families except QFP 

T  Thin profile (1.0 mm body thickness) 

TS  Thin shrink (1.0 mm body thickness, <=0.65 mm pitch) 

U  Ultra-thin profile (<1.0 mm body thickness) 
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2. Terminal/Pin Position (Seating plane is the bottom of the package) 
 

Designator  Description 

A  Axial - Terminals extend from both ends in the direction of the major axis 
of a cylindrical or elliptical package. 

B  Bottom - Terminals extend from the bottom of the package. 

D  Dual - Terminals are on opposite sides of a square or rectangular package 
or located in two parallel rows. 

P  Perpendicular - Terminals are perpendicular to seating plane on a square 
or rectangular package. Restrict to PGA family. 

Q  Quad - Terminals are on the four sides of a square or rectangular package 
or located in four parallel rows. 

S  Single - Terminals are on one surface of a square or rectangular package 
in a single row. 

Z  Zig-zag - Terminals are on one surface of a square or rectangular package 
arranged in a staggered configuration. 

 

3. Package Outline Style 
 

Designator  Description 

AB  Axial Bipolar Capacitor 

CAN  Can 

CC  Chip Carrier 

CY  Cylinder or Can 

DO Diode Outline 

FM  Flange Mount 

FP  Flatpack 

GA  Grid Array 

IL  In-Line Package 

IP  In-Line Package (Restrict to DIP/SIP/ZIP) 

LF  Long Form Horizontal Package 

MELF Metal Electrode Face 

PM  Post/Stud Mount 

RB  Radial Bipolar Capacitor 

SO  Small Outline 
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SOT Small Outline Transistor 

TO  Transistor Outline 

TP  Tape Pack 
 

4. Major dimensions of package (mm) 
 

Designator  Description 

##x##    BGA and PGA - Silk Screen dimensions, DxE 

/##x##    Diode Outline - Length by width, mmx10 

##x##    QFP (except Bumpered style) - Body of the package dimensions, E1xD1 

##x##    Thin Shrink Small Outline - Short package length by largest overall length 
including terminals, DxH 

 

5. -Lead Form (or Terminal Shape) 
 

Designator  Description 

B  Butt or Ball - A short lead or solder ball intended for attachment 
perpendicular to the land structure. 

C   “C” bend - A “C” shaped noncompliant lead bent down and under the 
body of the package. 

F  Flat - A compliant or noncompliant, nonformed flat lead that extends 
away from the body of the package. 

G  Gull wing - A compliant lead bent down from the body of the package 
with a foot at the end pointing away from the package. 

J   “J” bend - A “J” shaped compliant or noncompliant lead bent down 
and back under the body of the package. 

N  No lead - Metallized terminal pads located on the body of the package. 

P  Pin or Peg - A tempered lead extending from the bottom of the package 
and intended for attachment to a plated through-hole in the land 
structure. 

R  Wraparound - A metallized noncompliant terminal wrapped around the 
package body. 

T  Through-hole - A terminal with flat or V-shaped cross-section, 
extending from the side of the body and intended for attachment to a 
through-hole. 
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W  Wire - An untempered wire lead extending from the body of the 
package. 

Y  Screw - A threaded hole. 

 

6. Terminal/Pin Count 
 

Designator  Description 

# Number of terminals. Include those of the type described by the 'lead 
form' designator 

(#) Number of terminal positions. Include only if this figure differs from the 
number of terminals given above. Do not apply to Grid Arrays. 

 

7. /Supplementary Information 
 

Designator  Description 

F  Flange, Tab or mounting on PCB board 

H  Drill Diameter 

M  Modified 

N  Terminals numbered from a corner of the pattern 

S  Stagger lead form 

T  Terminals numbered from a center of one side of the pattern 

V  Mounted vertically 

W  Spacing lead form 

#  This pin, at least, is absent 
 

Letters may refer to the dimensions of a pattern parameter. Where this is the case, the dimension is 
given in millimeters and follows the letter. Example: CAN-12/D9.4 12 pin can with silk screen length 
of 9.4mm for the dimension, D. 

Entering Equivalence Information 
When adding Schematic information to existing pattern libraries, there are two equivalence 
columns in the Pins View dialog that should be correctly completed: the Gate Eq column and the 
Pin Eq column. These columns and their contents are detailed in Library Basics (page 3).  

The Gate Eq should be set to reflect actual gate equivalences. If this information is not set correctly, 
the Schematic Utils » Renumber command, the automatic RefDes increment feature in the Place » 
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Part command and the gate swapping functionality of the PCB Utils » Optimize Nets command may 
not behave as expected. 

The Pin Eq should be set to reflect actual pin equivalences. If this information is not set correctly, 
the pin swapping functionality of the PCB Utils » Optimize Nets command may not behave as 
expected.  

When the gate equivalence of a pin is filled in, all other pins in that gate automatically have their 
gate equivalence changed to match. 

Errors that Prevent Saving a Component 
You cannot save a component using the Save or Save As command if an error exists. For a list of 
error messages, see System Messages (page 275). 

Copying, Renaming and Using Aliases 
When you copy a component to another library, you generally need to copy its pattern and symbol 
too. If patterns and symbols referenced by the component are not in the same library as the 
component, the component cannot be placed since its graphics are missing. 

You can rename components, pattern and symbols, but this is an action that must be undertaken 
with care. If you prefer to use a different naming convention for your components, patterns and 
symbols, you can create aliases for them by choosing the Library » Alias command without having 
to alter the original name.  

Aliases are preferable for a number of reasons: it's a safe way to use a variety of naming 
conventions; there is no danger of making global mistakes (which is possible when you rename) 
and the flexibility of using aliases allows the component, pattern, or symbol to be referenced by 
any of its aliases. 

Compact Program 
The COMPACT program is used to compress P-CAD component libraries that were translated from 
P-CAD PCB (6/400) pattern libraries or Tango-Schematic part libraries. Compacted libraries can be 
used directly, without uncompressing. The Library » Translate command does not automatically run 
the COMPACT routine. Uncompacted library files work; they just take up more disk space than 
compacted library files. The component libraries supplied with P-CAD have already been 
compacted. 

The COMPACT program must be run from a DOS prompt. For example, if you choose Library » 
Translate to create a new P-CAD library called Mycustom.lib, then you can create an equivalent, 
compressed version of this called Custom.lib as follows: 

C> COMPACT MYCUSTOM.lib CUSTOM.lib CUSTOM.ERR 

The Custom.err file contains a list of any errors encountered during the compaction process. 
Once compaction is complete, you can delete the original Mycustom.lib file and the 
Custom.err file.  
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CHAPTER 5 

The Pattern Editor 

Introducing Pattern Editor 
Pattern Editor allows you to create and modify patterns quickly. Once created, a pattern can be 
saved to a library or saved as a pattern file. This file can be modified, allowing you to create new 
patterns. Pattern Editor includes the Pattern Wizard which automates pattern generation. Pattern 
Editor contains a user-friendly interface which is very similar to P-CAD PCB. 

This chapter lists the features which are unique to Pattern Editor. It then describes the Pattern 
Editor interface, detailing those features which are distinct from P-CAD PCB. 

Pattern Editor Features 
This section highlights some of the important Pattern Editor features: 

• The ability to load and save patterns, or partially created patterns, from a P-CAD library. 

• Pattern Wizard automates pattern creation. 

• Utils » Validate command allows you to validate a pattern before saving it to a library. 

• Enhanced Place » Pad command to support automatic incrementing of pad numbers. 

• Enhanced manual pad renumbering supports single select pad renumbering and drag select 
for multiple pad renumbering. 

• The ability to automatically match a pin’s default pin designator to the pin number. 

• All pattern attributes, including RefDes and Type, available from a single Attributes dialog.  

• Separate commands for placing reference points (Place » Ref Point), glue points (Place » Glue 
Point) and pick points (Place » Pick Point). 

• Pattern graphics can be added or removed 

• Unique keyboard shortcuts and access from other programs in the P-CAD suite of products. 
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The Pattern Editor Interface 
Pattern Editor is very similar to P-CAD PCB so much of it will be familiar. This section details those 
functions which are unique to Pattern Editor. If you need information about common features, 
consult your P-CAD user documentation. 

Starting Pattern Editor 
In addition to starting Pattern Editor from Windows 95, Windows 98, Windows 2000 and Windows 
NT, you can start it from other P-CAD programs by choosing the Utils » Pattern Editor command. 
You can also access Pattern Editor from Library Executive by choosing the Pattern » New or Pattern 
» Open commands.  

Pattern Editor is also available from the Source Browser. By choosing the View command in the 
shortcut menu for a selected item in the Source Browser tree, you can view a pattern in the Pattern 
Viewer dialog. The Edit button on the Pattern Viewer dialog also opens the Pattern Editor. 

When you start Pattern Editor, the interface appears as shown in the following figure. 

 

The following Pattern Editor commands and functions are distinctly different in their usage or 
access than those of P-CAD PCB:  

• Pattern » Open: Opens pattern files (.pat) that can be modified and saved to a library. See 
Pattern Editor online help for details. 

• Pattern » Save to File and Save to File As: Saves a pattern file (.pat). This is a unique file type 
that allows you to keep patterns for later use, without having to save them to a library. 
Invalidated or incomplete patterns can be saved in this way. See Working with Pattern Files 
(page 65) for details. 
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• Pattern » Save and Save As: Saves the current pattern to a library. See Working with Pattern 
Files (page 65) for details. 

• Pattern » Pattern Wizard: Opens the Pattern Wizard which simplifies pattern creation. See 
Pattern Wizard (page 61) for more details. 

• Pattern » Attributes: Allows you to create and modify pattern attributes for the current pattern 
file, including invisible attributes. This command is similar to the Attributes function of PCB’s 
File Design Info command which presents design-level attributes. See Pattern Attributes (page 
67) for details. 

• Place » Pad: Opens a dialog where you can set a starting pad number and increment value 
before placing pads. See Pad Placement (page 69) for details. 

• Place » Ref Point, Place » Glue Point, Place » Pick Point and Place » Test Point: Separate place 
commands replace the PCB Place » Point command. Toolbar buttons provide easy access to 
these commands. See Placing Points (page 74) for details. 

• Utils » Renumber: Unlike PCB, pad renumbering in Pattern Editor can be performed 
automatically by dragging the mouse over a series of pads. Pads can also be renumbered 
manually by selecting one pad at a time. See Renumbering Pads (page 70) for details. 

• Utils » Validate: Allows you to validate a pattern before saving it to a library. See Working with 
Pattern Files (page 65) for details. 

Pattern Wizard 
Pattern Wizard automates pattern generation, providing a quick way to create a pattern. A pattern 
created with Pattern Wizard is like any other pattern; you can modify it, save it as a pattern file and 
save it to a library.  

To open Pattern Wizard: 

1. Make sure no pads have been placed in the active window. 

2. Choose Pattern » Pattern Wizard to open the Pattern Wizard dialog, shown in the following 
figure. 
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Pattern Wizard displays the last pattern you created. The left side of the wizard contains the fields 
you need to complete to create a pattern; the right side displays the pattern you are creating in a 
window.  

Notice this window is like any other Pattern Editor window. You can resize this window, use zoom 
in and out and place objects into it. 

The Pattern Wizard contains the following items:  

• Pattern Type: The pattern type may be set to DIP, QUAD or ARRAY to indicate the type of 
pattern you want to create. The remaining fields change depending on your selection. 

• Number of Pads Down: A DIP pattern, specifies the number of total pads. For example, 14 pads 
indicate 7 pads on each side of the DIP pattern. For QUAD or ARRAY pattern types, specifies 
the number of pads along each side of the pattern. 

• Number of Pads Across: Specifies the number of pads along the top and bottom of a QUAD or 
ARRAY pattern. Not used for DIP patterns. 

• Pad to Pad Spacing (On Center): The vertical distance between the pads of a DIP pattern or the 
distance between any two pads for a QUAD or ARRAY pattern. The distance is measured from 
pad center to pad center. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 10.0mil or 0.50mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Pattern Width: The horizontal distance between the Pad columns of a DIP pattern measured 
from pad center to pad center. The distance between the pad columns of a QUAD pattern 
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measured from the outside edges of the pads. The Pattern Width value is not available for 
ARRAY patterns. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 10.0mil or 0.50mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Pattern Height: The vertical distance between the pad rows of a QUAD pattern measured from 
the outside edges of the pads. The Pattern Width value is not available for DIP and ARRAY 
patterns. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 10.0mil or 0.50mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Pad 1 Position: Indicates which pad will become pad number 1 when the pattern is created on 
the PCB design. The value is only used for DIP and QUAD patterns. The remaining pads will be 
numbered in a counterclockwise order starting from pad 1. 

The Pad 1 Position value is not available for ARRAY patterns. The first pad of an ARRAY pattern 
is always the upper left corner pad (typically designated A1). If that pad has been removed 
using the Corner Pads options, then the next pad (A2) will be used for pad 1. 

• Pad Style (Pad 1-For DIP patterns only): Choose the pad style from those in the open PCB 
design to be used for pad 1. Use the Rotate box to rotate the pad style 90 degrees separately 
from the other pads of the DIP pattern. 

• Pad Style (Others-For DIP patterns only): Choose the pad style from those in the Options Pad 
Style dialog in PCB to be used for all other pads. Use the Rotate box to rotate the pad style 90 
degrees separately from pad 1's style. 

• Pad Style (Top & Bottom-For QUAD patterns only): Choose the pad style from those in the 
open PCB design to be used for the top and bottom pads. Use the Rotate box to rotate the pad 
style 90 degrees. 

• Pad Style (Left & Right-For QUAD patterns only): Choose the pad style from those in the open 
PCB design to be used for the left and right side pads. Use the Rotate box to rotate the pad 
style 90 degrees. 

• Pad Style (For ARRAY patterns only): Choose the pad style from those in the open PCB design 
to be used for all pads. Use the Rotate box to rotate the pad style 90 degrees. 

• Corner Pads (For ARRAY patterns only): The outside four corner pads and the inside four 
corner pads (if a cutout section is present in the array pattern) may be added or removed 
individually by selecting the check boxes in the Corner Pads group. 

• Cutout Pads Down (For ARRAY patterns only): The number of pads to be removed from the 
center of the ARRAY pattern. The number of Cutout Pads Down must be greater than or equal 
to 0 and less than the Number of Pads Down. Also, the number of Cutout Pads Down must be 
an odd value if the Number of Pads Down is an odd value and even when the Number of Pads 
Down is even. When the Cutout Pads Across value is 0, the Cutout Pads Down value will be 
ignored. 
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• Cutout Pads Across (For ARRAY patterns only): The number of pads to be removed from the 
center of the ARRAY pattern. The number of Cutout Pads Across must be greater than or equal 
to 0 and less than the Number of Pads Across. Also, the number of Cutout Pads Across must be 
an odd value if the Number of Pads Across is an odd value and even when the Number of Pads 
Across is even. When the Cutout Pads Down value is 0, the Cutout Pads Across value will be 
ignored. 

• Total Pads (For ARRAY patterns only): The number of pads in the ARRAY pattern. 

• Default Pin Designators (For ARRAY patterns only): Accesses the Default Pin Designator 
Assistant where you can designate the letters or numbers used as the beginning values for the 
Default Pin Des to name the rows and columns. Specify the starting corner and choose the 
characters you want to skip when numbering. Skipped characters can only be letters; numbers 
cannot be skipped. The characters chosen as the beginning of a row or column cannot be used 
as skipped characters and vice versa. 

For DIP and QUAD patterns, the Default Pin Designators are automatically numbered starting 
at the pad position indicated by the Pad 1 Position entry. 

• Silk Screen: The silk screen may be turned on or off by selecting this check box. 

• Silk Line Width: The line width used to create and display all silkscreen lines. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 1.0mil or 0.10mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Silk Rectangle Width: The width of the silk screen for the pattern. The value is measured from 
centerline to centerline. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 25.0mil or 1.00mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Silk Rectangle Height: The height of the silk screen for the pattern. The value is measured from 
centerline to centerline. 

The value may be typed in the box using the appropriate mil or mm number. Use the slide 
arrows to change the value up or down by 25.0mil or 1.00mm. Use the SHIFT key with the slide 
arrows to increment the value by 0.1mil or 0.01mm. 

• Notch Type: For DIP patterns, the Notch Type may be either None, Arc, Square, or Triangle. 

For QUAD and ARRAY patterns, the Notch Type may be either None, Upper Left, Upper Right, 
Lower Left, or Lower Left. 

• Current Pattern Graphics: Displays the pattern graphic name linked to the component. 
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Working with Pattern Files 
In Pattern Editor, patterns can be saved as pattern files (.pat). This allows you to save partially 
created patterns and to create pattern templates that you can use to create new patterns. Before a 
pattern can be copied to a library, it must pass a validation test. If it fails, you can save it as a .pat 
file and return to it at a later time. 

Loading a Pattern from a Library 
1. You can load an existing pattern from a library and modify it to create a new pattern. When you 

choose Pattern » Open, the Open dialog appears. 

 

2. Notice that this dialog allows you to open pattern files (.pat) and library files (.lib). When 
you choose a library file and click Open, the Library Browse dialog opens, as shown in the 
following figure. 
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3. Select a pattern from the list (e.g. DIP14) and click OK. The pattern is loaded into Pattern Editor. 
When a pattern is loaded from a library, the library and pattern name appear in the title bar.  

 

Notice that the pattern name and source library appear in the title bar even though this pattern 
has not been saved as a .pat file.  

Saving a Pattern to a Library 
Once you have created a pattern, you can save it to a library after it has been validated.  

1. Choose Utils » Validate. 

If your pattern fails validation, an error message appears. For a list of error messages, see 
Appendix B, System Messages (page 275). 

2. Choose Pattern » Save or Pattern » Save As. The Pattern Save To Library dialog opens. 
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3. Select the library you want to save the pattern to, then specify a pattern name. If the pattern 
was loaded from a library, that library appears in the Library box and the pattern name appears 
in the Pattern box. 

4. If you want to just create a pattern (not a component), click OK. 

To automatically create a component that corresponds to the pattern, select the Create 
Component check box and give the component a new name in the Component box before 
you click OK. If the existing default pin designators are correct for the new pattern, you do not 
have to change them. You can set the default pin designators to Match Default Pin Des to Pin 
Numbers by selecting that check box. 

If the Create Component box is left cleared, an electrically complete component can be 
generated with this pattern.  

Saving a Pattern as a Pattern File 
The Pattern » Save to File and Pattern » Save to File As commands save a pattern as a pattern file 
(.pat) without having to save them to a library, allowing you to keep patterns for later use. 

Pattern Attributes 
All pattern-level attributes, including invisible attributes like RefDes and Type, can be viewed and 
modified by choosing the Pattern » Attributes command. 

When you choose Attributes, the Attributes dialog opens. 

 

In the Attributes dialog you can view, add, modify, or delete attributes or access a web site. The 
dialog contains a two-column table showing the name of the attribute in the left column and 
corresponding value in the right column. 

• Adding an Attribute: Click the Add button to open the Attribute Property dialog. Enter a name 
and value for the attribute and set attribute properties. Click OK and the attribute is added to 
the table.  
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• Viewing or Changing Attribute Properties: Select an attribute from the table and click the 
Properties button (or double-click the attribute) to open the Attribute Property dialog to view 
or change an attribute’s properties.  

• Deleting an Attribute: Select an attribute in the table and click Delete, or press the DELETE key. 

• Launching a reference link: When the special attribute Reference, whose value is a reference 
link, is added to the pattern, you can select the Reference attribute and click the Launch button 
to start an application, access a web address, or open a document. 

For details about this function, refer to your P-CAD PCB User’s Guide. 

Pattern Graphics in the Pattern Editor 
This feature allows you to set up multiple and varying pattern graphics for the patterns associated 
with components. This allows differing pattern graphics to be automatically applied for a 
component, depending on whether the component is placed on the top or bottom of the board, 
how it is rotated and the chosen direction of solder flow. Pattern graphics can be added to a 
primary base pattern through the Pattern Editor, especially handy when you need to modify a 
pattern graphic, e.g. change its size, before adding it. The Library Executive, however, includes a 
more comprehensive way of handling pattern graphics, so refer to Pattern Graphics in the Library 
Executive (page 50). 

Add, Remove and Rename Pattern Graphics 
Load the base pattern that you want to add the pattern graphics to. From the Pattern menu, select 
one of the following: 

• Add Pattern Graphics: This command allows you to create new, empty pattern graphics and 
add them to the base pattern. Also available by clicking on the  button on the main toolbar. 

• Remove Pattern Graphics: This command allows you to remove pattern graphics from the base 
pattern. Also available by clicking on the  button on the main toolbar. 

• Rename Pattern Graphics: This command allows you to change the name of any of the pattern 
graphics already attached to the base pattern. Also available by clicking on the  button on 
the main toolbar. 

Next and Previous Pattern Graphics 
• Choose View » Next Pattern Graphic or View » Previous Pattern Graphic to switch between the 

pattern graphics of a pattern as you can only work on one pattern graphic at a time. Also 
available by clicking on the  (next) and  (previous) buttons on the main toolbar. 

Orientations 
Choose Utils » Orientations to specify which pattern graphics are to be used for a specific 
orientation. Up to eight different pattern graphics can be used to represent various component 
orientations, depending on whether the component is flipped or unflipped and whether it is 
rotated by 0°, 90°, 180° or 270°. To use the orientations when placing components in P-CAD 
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PCB, make sure Autoswap is turned on. Refer to your P-CAD PCB User’s Guide for more 
information about pattern graphics orientations. 

Pattern Graphics in the Pattern Wizard 
Whenever the Pattern Wizard is invoked, it operates on the current pattern graphics. The 
Wizard includes a non-editable field that displays the current pattern graphic. The Title bar also 
displays which pattern graphic is current, in the format: 

  [Library name [Pattern name: Current Pattern Graphics name]] 

This means that you can add several blank pattern graphics to a pattern, switch to the pattern 
graphic you want to work with using the Next/Previous Pattern Graphics options and then use 
the Pattern Wizard to place the particular graphic elements. 

Pad Placement 
In Pattern Editor, the Place » Pad command shows you the next available pad number and lets you 
increment pad numbers.  

To place a pad: 

1. Choose Place » Pad or click the toolbar Pad button to open the Place Pad dialog. 

 

2. The Unused Pad Number box defaults to the next unused pad number; click the Down Arrow 
to display the list of unused pads. Choose a number or choose ># to begin numbering from 
that number (#) onwards. 

3. The Starting Pad Number box defaults to the next available pad number. To change the default 
value, type a new number in the box.  

4. If you place a pad with a duplicate pad number, you hear a warning beep. 

5. Enter the number (positive or negative) by which you want to increment pad numbers in the 
Increment Pad Number box. 

You’re now ready to start placing pads.  

6. Click OK to begin. 

You can click, drag and release for more accurate placement with a ghosted pad outline.  
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The Status Line shows the pad number of the pad about to be placed and also indicates if the 
pad number is a duplicate. 

The N key increments the pad number about to be placed by one; SHIFT+N decrements the 
number. Thus if 6 is the next available pad number, pressing N would result in the pad being 
assigned number 7; pressing SHIFT+N would result in the pad being assigned number 5. 

7. Continue adding a sequence of pads by clicking in the workspace. As you do, each is 
incremented according to the options you set in the dialog. 

8. To stop, right-click, press ESC, or click the Select toolbar button. 

The Undo command removes the entire sequence of pads. The BACKSPACE key removes the 
last placed pad. 

Rotate or Flip a Pad 
In Pattern Editor, pads can be flipped as well as rotated during placement using one of the 
following methods: 

• To flip a pad as you are placing it, press F while the pad is ghosted before final placement. 
When you flip a pad, the hole range does not flip with it. 

• To rotate a pad as you are placing it, press the R key while the pad is ghosted before final 
placement. The resulting rotation angle is applied to the next pad you place.  
Refer to your P-CAD PCB User’s Guide for additional information. 

• To rotate or flip a pad after it has been placed, select it and press R to rotate or F to flip. The R 
key rotates the pad 90 degrees, SHIFT+R rotates by the rotation increment set in Options » 
Configure.  

Renumbering Pads 
The renumbering function in Pattern Editor, unlike PCB, supports single select pad renumbering 
and drag select for multiple pad renumbering. Remember to turn on the display of the Pad 
Numbers in the Miscellaneous tab of the Options Display dialog. 

To number the pads you placed: 

1. Choose the Select tool. 

2. Change to the layer on which the pads are placed. 

3. Choose Utils » Renumber to open the Utils Renumber dialog.  
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4. Specify Starting Pad Number and Increment Pad Number, as appropriate. 

5. Click OK. Notice that the cursor changes to the crosshair shape. 

You are in a temporary mode of assigning numbers, so every time you hold down the left-
button and drag it over a pad, you renumber that pad (you can also click a pad to renumber it). 

For example, the first pad you drag the mouse over would be number 1 (if Starting Pad Number 
was specified as 1), the second pad number 2 (if the Increment Pad Number was specified as 1).  

As you drag the mouse over a pad while in the Renumber mode, it shows that a number has 
been assigned. Once a pad is renumbered, you cannot change its number without choosing 
the Renumber command again. 

The Status line information area displays the pad number every time you (re)number a pad. 

The N key increments the pad about to be renumbered by one; SHIFT+N decrements the 
number. Thus if 6 is the next available pad number, pressing N would result in the pad being 
assigned number 7; pressing SHIFT+N would result in the pad being assigned number 5. 

You can use the unwind feature to reverse the renumbering process. The BACKSPACE key 
unwinds the renumbering. 

6. Right-click or press ESC to end the Renumber sequence. 

The Undo command reverses the entire renumbered sequence. 

You can also select a pad and choose Properties to open the Pad Properties dialog and assign a 
pad number.  

Renumbering Default Pin Designators 
The renumbering function in Pattern Editor, unlike in PCB, supports single select pad renumbering 
and drag select for multiple pad renumbering. Remember to turn on the display of the Pin Des in 
the Miscellaneous tab of the Options Display dialog. 

To number the pin designators on the pads you placed: 

1. Choose the Select tool. 

2. Change to the layer on which the pads are placed. 
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3. Choose Utils » Renumber to open the Utils Renumber dialog. 

 

4. Select Default Pin Designator for the Type. 

5. Specify Starting PinDes and Increment Value, as appropriate. 

6. Click OK. Notice that the cursor changes to the crosshair shape. 

7. You are in a temporary mode of assigning numbers, so every time you hold down the left-
button and drag it over a pad, you renumber that pad’s Default Pin Designator. You can also 
click a pad to renumber it. 

For example, the Default Pin Designator of the first pad you drag the mouse over would be 
number A1 (if Starting PinDes was specified as A), the second pad number A2 (if the Increment 
Value was specified as 1).  

As you drag the mouse over a pad while in the Renumber Pin Des mode, it shows that a default 
pin designator has been assigned. Once a pad’s DPD is renumbered, you cannot change its 
DPD without rerunning the Renumber command. 

The Status Line information area displays the Default Pin Designator every time you 
(re)number. 

The N key increments the pad about to be renumbered by one; SHIFT+N decrements the 
number. Thus if 6 is the next available pad number, pressing N would result in the pad being 
assigned number 7; pressing SHIFT+N would result in the pad being assigned number 5. 

You can use the unwind feature to reverse the renumbering process. The BACKSPACE key 
unwinds the renumbering. 

8. Right mouse-click or press ESC to end the Renumber sequence. 

The Undo command reverses the entire renumbered sequence. 

You can also select a pad and choose Properties to open the Pad Properties dialog and assign a 
pad number.  

Default Pin Designators in the Wizard 
While in the Pattern Wizard, the default pin designators for ARRAY type patterns can be changed 
using the Default Pin Designator Assistant.  
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1. In the Miscellaneous tab of the Options Display dialog, select the Pin Des check box in the 
Free Pads frame. 

 

2. Click OK to return to the Pattern Wizard. 

3. Click the Default Pin Designator button to display the Default Pin Designator Assistant. 
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The example box in the center of the dialog shows how the different values affect the 
numbering. Any changes made to the row and column values are immediately reflected here, 
except for the Skip Characters. 

4. Specify the Beginning Row Value and Beginning Column Value in the appropriate boxes. You 
can use letters or numbers as a beginning value.  

5. Check the corner where the numbering should begin. In the example, the upper left corner is 
selected. 

6. If you want to skip a letter, enter the letter in the Skip Characters box. Only letters can be 
skipped. A character used as a Beginning Row Value or Beginning Column Value cannot be 
designated as a Skip Character. 

7. Click OK to apply the default pin designator renumbering.  

Placing Points 
Separate commands let you place Reference Points, Glue Points, Pick Points and Test Points on 
your pattern. Those commands are discussed in this section. 

Reference Points 
The Place » Ref Point command places a Reference Point on a pattern before it is saved to a library.  

You need to specify a Reference Point on a pattern object before it is saved to a pattern library. The 
Ref Point appears in the same color as the 1x grid color in Options » Display. 

When you place a Reference Point on an object, the pattern will move with the cursor at the 
reference point. Patterns are flipped and rotated about the Reference Point. For most patterns, 
select a reference point in the center of pad #1. 

Pattern Editor automatically places a Ref Point on a pad or at center of pads if you save a pattern to a 
library without a Ref Point. 

Glue Points 
The Place » Glue Point command places a glue point on a pattern before it is saved to a library.  

Glue Points are used to hold components in place until they are soldered during manufacturing. A 
glue dot can be placed as part of a pattern before saving the pattern to a library.  

Pick Points 
The Place » Pick Point command places a Pick Point on a pattern before it is saved to a library.  

Pick Points provide reference points in directing the pick and place mechanism (or auto insert) in 
manufacturing (picking up the component and placing it on the board).  

Test Points 
The Place » Test Point command places a Test Point on a pattern before it is saved to a library.  
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Test Points can be placed on any non-signal layer and can be placed either on the Top or Bottom of 
the board. The side of the board is independent of the layer name. For example, if you place a test 
point on the Bottom Silk layer and set the side of board to Top, the test point can be tested from 
the top. New design rules/attributes have been implemented to allow for checking of test point 
violations. 

Placing a Point 
To place a point: 

1. Choose the appropriate Place command (Ref Point, Glue Point or Pick Point) or click one of 
the point buttons on the toolbar. 

2. Click the cursor where you want to place the point. 

You can move a point by selecting it and dragging it to a new location. 

Pick Points and Glue Points can be flipped to the bottom layer. They use the line color from the 
layer that they are on. 

 

Keyboard Shortcuts 
This section contains a list of keyboard shortcuts unique to Pattern Editor. 

 

Press these keys: To do this: 

BACKSPACE  
(Unwind) 

Used as unwind command while placing objects with multiple 
segments (e.g. lines, polygons, pads). Each BACKSPACE stroke 
unwinds the previously placed item. 

N and SHIFT+N  
(increment 
 and decrement) 

N increments a pad by one when placing or renumbering pads. 
SHIFT+N decrements a pad by one when placing or renumbering 
pads. 
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CHAPTER 6 
 

The Symbol Editor 

Introducing Symbol Editor 
Symbol Editor allows you to create and modify symbols quickly. Once created, a symbol can be 
saved to a library or as a symbol file that can be modified, allowing you to create new symbols. 
Symbol Editor includes the Symbol Wizard that automates symbol generation. 

Symbol Editor’s interface is similar to P-CAD Schematic. 

This chapter lists Symbol Editor features and describes the Symbol Editor interface, detailing those 
features which are distinct from P-CAD Schematic.  

Symbol Editor Features 
This section highlights some of the important Symbol Editor features: 

• The ability to load and save symbols from a P-CAD library. 

• The ability to load and save partially created symbols. 

• Symbol Wizard automates symbol creation. 

• Utils » Validate command validates a symbol before saving it to a library. 

• Enhanced Place » Pin and Pin Properties functions support automatic incrementing of pin 
numbers, easy to use display characteristics and a display area that shows how the pin will 
appear. 

• Pin Properties includes ability to increment pin names. 

• Enhanced manual pin renumbering supports single select pin renumbering and drag select for 
multiple pin renumbering. 

• The ability to automatically match a pin’s default pin designator to the pin number. 
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• All symbol attributes, including RefDes and Type, available from a single Attributes dialog. 

• Unique keyboard shortcuts. 

• Access from other programs in the P-CAD product suite. 

The Symbol Editor Interface 
Symbol Editor is very similar to P-CAD Schematic so much of it will be familiar. This section details 
those functions that are unique to Symbol Editor. If you need information about common features, 
consult your P-CAD user documentation. 

Starting Symbol Editor 
In addition to starting Symbol Editor from Windows 95, Windows 98, Windows 2000 and Windows 
NT, you can start it from other P-CAD programs by choosing the Utils » Symbol Editor command. 
Symbol Editor can also be accessed from Library Executive by choosing the Symbol » New or 
Symbol » Open command. 

Symbol Editor can be started from the Library Executive Source Browser by choosing View in the 
shortcut menu for a selected item in the Source Browser tree. You can then view a symbol in the 
Symbol Viewer dialog. The Edit button on the Symbol Viewer dialog also starts Symbol Editor. 

When you start Symbol Editor, the interface appears as shown below. 
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The following Symbol Editor commands and functions are distinctly different in their usage or 
access than those of P-CAD Schematic:  

• Symbol » Open: Opens symbol files (.sym) which can then be modified and saved to a library. 
See Symbol Editor online help for details. 

• Symbol » Save to File and Save to File As: Saves a symbol to a file (.sym) which allows you to 
keep symbols for later use, without having to save them to a library. Invalidated or incomplete 
symbols can be saved in this way. See Working with Symbol Files (page 81) for details. 

• Symbol » Save and Save As: Saves the current symbol to a library. See Working with Symbol 
Files (page 81) for details. 

• Symbol Wizard: Opens a wizard used to simplify symbol creation. See Symbol Wizard (page 79) 
for more details. 

• Symbol » Attributes: Allows you to create and modify symbol attributes for the current symbol 
file, including invisible attributes. See Symbol Attributes (page 83) for details. 

• Place » Pin and Pin Properties: Opens the Place Pins dialog where you can set a starting pin 
number and increment value before placing pins. Option buttons make it easy to set display 
characteristics, and a display area shows you the results of your selection. See Pin Placement 
(page 84) for details. 

• Utils » Renumber: Automates pin renumbering in Symbol Editor by dragging the mouse over a 
series of pins. Pins can also be renumbered manually by selecting one pin at a time. See 
Renumbering Pins (page 88) for details. 

• Utils Validate: Allows you to validate a symbol before saving it to a library. See Working with 
Symbol Files (page 81) for details.  

Symbol Wizard 
Symbol Wizard automates symbol generation, providing a quick way to create a symbol. A symbol 
created with Symbol Wizard is like any other symbol; you can modify it, save it as a symbol file and 
save it to a library.  

To open Symbol Wizard: 

1. Make sure no pins have been placed in the active window. 

2. Choose Symbol » Symbol Wizard to open the Symbol Wizard dialog. 
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Symbol Wizard displays the last symbol you created. The left side of the wizard contains the fields 
you need to complete to create a symbol; the right side displays the symbol you are creating in a 
window.  

Notice this window is like any other Symbol Editor window. You can resize this window, use zoom 
in and out and place objects into it. 

The Symbol Wizard contains the following items:  

• Symbol Width: The width of the symbol being created. The slide arrows increase and decrease 
the width by the amount set in the Pin Spacing field or in 100 mil increments if you hold down 
the SHIFT key. 

• Pin Spacing: The spacing between pins. The slide arrows increase and decrease the spacing in 
25 mil increments or in 1 mil increments if you hold down the SHIFT key. 

• Number of Pins Left: The number of pins on the left side of the symbol. 

• Number of Pins Right: The number of pins on the right side of the symbol. 

• Symbol Outline: Turns on or off the graphical representation of the symbol. 

• Line Width: The line width. The slide arrows scroll through the values defined by choosing the 
Options Current Line command. You can also add a new line width in the Options Current Line 
dialog. 

• Default Pin Name: The default pin name of the current pin. 

• Default Pin Designator: The default pin designator for the current pin. 

• Current Pin Number: The current pin number. The slide arrows scroll through each pin 
number, allowing you to assign pin names and Default Pin Designators. 



Working with Symbol Files Chapter 6: The Symbol Editor 

Library Executive User’s Guide 81 

• Length: Selects the pin length of all pins in the symbol. Select User and enter a value to set a 
custom pin length. 

• Display: Turns on or off the display of the Pin Name and Pin Des. 

Working with Symbol Files 
Symbols can be saved as symbol files (.sym), allowing you to save partially created symbols and to 
create symbol templates, which you can use to create new symbols. Before a symbol can be copied 
to a library, it must pass a validation test. If it fails, you can save it as a .sym file and return to it at a 
later time. 

Loading a Symbol from a Library 
You can load an existing symbol from a library and modify it to create a new symbol. When you 
choose Symbol » Open, the Open dialog appears. 

 

Notice that this dialog allows you to open symbol files (.sym) and library files (.lib). When you 
choose a library file and click Open, the Library Browse dialog opens. 
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Select a symbol from the list (e.g. T-7400) and click OK. The symbol is loaded into Symbol Editor. 
When a symbol is loaded from a library, the library and symbol name appear in the title bar. The 
symbol name and source library appear in the title bar even though this symbol has not been saved 
as a .sym file.  

 

Saving a Symbol to a Library 
Once a symbol is created, you can save it to a library after it has been validated.  

1. Choose Utils » Validate. 

If your symbol fails validation, an error message appears. For a list of error messages, see 
Appendix B, System Messages (page 275). 

2. Choose Symbol » Save to open the Symbol Save To Library dialog, shown below. 

 

3. Select the library you want to save the symbol to and then specify a symbol name. If the symbol 
was loaded from a library, that library appears in the Library box and the symbol name appears 
in the Symbol box. 
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4. If you want to just create a symbol (not a component), click OK. 

To create a component automatically that corresponds to the symbol, select the Create 
Component check box before you click OK. If the existing default pin designators are correct 
for the new symbol, you do not have to change them. You can set the default pin designators 
to Match Default Pin Designators to Pin Numbers if you select this check box. 

If the Create Component box is cleared, an electrically complete component can be generated 
with this symbol attached.  

5. Click OK. The symbol is saved to the library. 

6. If the Create Component check box is selected, the Save Component As dialog opens. 

 

7. Type a component name in the Component Name box, select a component type and click OK. 

Saving a Symbol as a Symbol file 
Choose the Symbol » Save to File or Symbol » Save to File As command to save a symbol as a 
symbol file (.sym), a unique file type that allows you to keep symbols for later use, without having 
to save them to a library. 

Symbol Attributes 
All symbol attributes, including invisible attributes like RefDes and Type, can be viewed and 
modified by choosing the Symbol » Attributes command. 

When you choose Attributes, the Attributes dialog opens. 
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In the Attributes dialog you can view, add, modify or delete attributes. The dialog contains a two-
column table showing the name of the attribute in the left column and corresponding value in the 
right column. 

• Adding an Attribute: Click the Add button to open the Place Attribute dialog. Select an 
Attribute Category and Name or, if defining a new {user-defined} attribute, enter a Name and 
then set the Value for the attribute. Click OK and the attribute is added to the table.  

• Viewing or Changing Attribute Properties: Select an attribute from the table and click the 
Properties button (or double-click the attribute) to open the Attribute Properties dialog to view 
the attribute’s properties or change the attribute’s value.  

• To Delete an Attribute: Select an attribute in the table and click Delete, or press the DELETE 
key. 

• Launching a Reference link: When the special attribute Reference, whose value is a reference 
link, is added to the pattern, you can select the Reference attribute and click the Launch button 
to start a program or web address to display a document or web site. 

For details about this function, refer to the P-CAD Schematic User’s Guide. 

Pin Placement 
The Place » Pin command shows you the next available pin number and lets you increment pin 
numbers.  

To place a pin: 

1. Choose Place Pin or click the toolbar Pin button to open the Place Pin dialog. 
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2. In the Text Style frame, set the text style for the pin name and pin designator. Click the Text 
Styles button to open the Options Text Style dialog, where you can add or modify existing text 
styles for your design. 

3. In the Display frame, select the Pin Name and Pin Des check boxes to turn on the display of 
the pin name and pin designator. Clear the check boxes to turn off the display. 

4. Type the default pin name, if desired, in the Default Pin Name box. The default pin name is a 
placeholder for the real pin name. Use this default label to change the orientation or position 
of the pin name. The default pin name, like a pin number, cannot be edited once the pin is 
attached to a symbol. Select the Increment Pin Name check box so that each time this pin is 
placed the pin name is one greater than the last pin placed. 

5. Type the default pin designator, if desired, in the Default Pin Designator box. The default pin 
designator can be incremented each time a pin is placed by selecting the Increment Pin Des 
check box. 

6. The Unused Pin Number box defaults to the next unused pin number; unused pins are shown 
in the list that appears when you click the Down Arrow. Choose a number or choose ># to 
begin numbering from that number (#) onwards. 

7. The Starting Pin Number box defaults to the next available pin number. To change the default 
value, type a new number in the box.  

If you place a pin with a duplicate pin number, you hear a warning beep. 

8. Enter the number (positive or negative) by which you want to increment pin numbers in the 
Increment Pin Number box. 

9. Select the desired pin length option button from the options in the Length frame.  
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10. Select the desired display characteristics by selecting the Inside Edge, Outside Edge, Inside and 
Outside option buttons.  

11. Click OK. 

12. Move the cursor to the location in the active window where you want to place the pin and click 
to place it. Drag and drop (release) to place it more accurately. (An alternate method for drag-
and-drop is ALT+click and then release the ALT .You can then move the pin freely with the 
mouse without having to keep the button depressed.) To cancel the pin placement, right 
mouse-click. 

The Status Line shows the pin number of the pin about to be placed and also indicates if the 
pin number is a duplicate. 

The N key increments the pin about to be placed by one; SHIFT+N decrements the number. If 
6 is the next available pin number, pressing N would result in the pin being assigned number 7; 
pressing SHIFT+N would result in the pin being assigned number 5. 

You can continue to place similar pins by clicking in additional locations. Pin attributes 
previously specified (in the Place Pin dialog) are also displayed. 

13. To stop, right mouse-click, or press ESC, or click the Select toolbar button. 

The Undo command removes the entire sequence of pins. The BACKSPACE key removes the 
last placed pin. 

Pin names and pin designators can be subselected for moving, flipping and rotating.  

Rotate or Flip a Pin 
In Symbol Editor, pins can be flipped as well as rotated during placement. 

• To flip a pin as you are placing it, press F while the pin is ghosted before final placement.  

• To rotate a pin as you are placing it, press the R key while the pin is ghosted before final 
placement. The resulting rotation angle is applied to the next pin you place.  
Refer to your P-CAD Schematic User’s Guide for additional information. 

• To rotate or flip a pin after it has been placed, select it and press R to rotate or F to flip. The R 
key rotates the pin 90 degrees.  

Pin Properties 
The Pin Properties dialog allows you to view or change pin properties.  

If two or more selected pins have differing properties, those properties appear in gray or blanked 
out. When you select a value for one of these properties it is applied to all the selected pins. 

When you select a pin and choose Properties, the Pin Properties dialog opens. 
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Changing Pin Properties 
The following options are available in the Pin Properties dialog: 

• Text Style: Change the text style of the Pin Name and Pin Des by selecting one of the existing 
styles in the Pin Name or Pin Des lists.  

To modify or add a new text style, click the Text Styles button to open the Options Text Style 
dialog.  

• Display: Select the Pin Name and Pin Des check boxes to display the pin name and/or pin 
designator. 

• Default Pin Name: Enter or modify a default pin name. 

• Default Pin Designator: Enter or modify a default pin designator. 

• Pin Number: Changing the pin number is useful when you only want to change one or two 
pins. If you want to renumber a series of pins, choose Utils » Renumber for smoother and 
faster action. 

• Length: Select Short (100 mil), Normal (300 mil), Long (500 mil), or set your own length by 
clicking the User option and entering a length in the box. 

• Inside Edge, Outside Edge, Inside, Outside frames: Select the option buttons to turn on various 
display characteristics. These display characteristics include all attribute symbols that may be 
attached to a pin for design clarification and are for graphical appearance only.  



Chapter 6: The Symbol Editor Renumbering Pins 

88 Library Executive User’s Guide 

Renumbering Pins 
The renumbering function in Symbol Editor, unlike Schematic, supports single select pin 
renumbering and drag select for multiple pin renumbering. 

To renumber the Pin Numbers: 

1. Choose the Select tool. 

2. Choose Utils » Renumber to open the Utils Renumber dialog. 

 

3. Clear the Display Default Pin Des check box in the Miscellaneous tab of the Options Display 
dialog. 

4. Select the Pin Number option button. 

5. Specify Starting Pin Number and Increment Value, as appropriate.  

6. Click OK. Notice that the cursor changes to the crosshair shape. 

You are in a temporary mode of assigning numbers, so every time you hold down the left-
button and drag it over a pin, you renumber that pin. You can also click a pin to renumber it. 
For example, the first pin you drag the mouse over would be number 1 (if Starting Pin Number 
was specified as 1), the second pin number 2 (if the Increment Value was specified as 1).  

As you drag the mouse over a pin while in the Renumber mode, it shows that a number has 
been assigned. Once a pin is renumbered, you cannot change its number without choosing 
the Renumber command again. 

The Status Line information area displays the pin number every time you (re)number a pin. 

The N key increments the pin about to be renumbered by one; SHIFT+N decrements the 
number. If 6 is the next available pin number, pressing N would result in the pin being 
assigned number 7; pressing SHIFT+N would result in the pin being assigned number 5. 

You can use the unwind feature to reverse the renumbering process. The BACKSPACE key 
unwinds the renumbering. 

7. Right-click, or press ESC, to end the Renumber sequence. 

The Undo command reverses the entire renumbered sequence. 



Renumbering Default Pin Names Chapter 6: The Symbol Editor 

Library Executive User’s Guide 89 

Renumbering Default Pin Names 
You can renumber Default Pin Names by following these steps: 

1. Choose the Utils » Renumber command to open the Utils Renumber dialog. 

  

2. Select the Default Pin Name option button. Notice that the Starting Pin Name value changes to 
A, instead of 1. You can enter any alphanumeric prefix as the Starting Pin Name. 

3. Follow the steps outlined in Renumbering Pins (page 88) to renumber each pin’s Default Pin 
Name as you click on each pin. 

Renumbering Default Pin Designators 
You can renumber the Default Pin Designators by following these steps: 

1. Choose Utils » Renumber to open the Utils Renumber dialog. 

 

2. Select the Default Pin Designator option button. Notice that the Starting Pin Designator value 
changes to A, instead of 1. You can enter any alphanumeric character as the Starting Pin 
Designator. 

3. Follow the steps outlined in Renumbering Pins (page 88) to renumber each pin’s Default Pin 
Designator as you click each pin. 
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You can also select a pin, choose Properties and then assign a pin number, pin name and pin 
designator.  

Placing Reference Points 
The Place » Ref Point command places a reference point on a symbol before it is saved to a library.  

Symbol Editor automatically places a Ref Point on a pin or at center of pins if you save a symbol to a 
library without a Ref Point. 

Refer to your P-CAD Schematic User’s Guide for additional information. 

Keyboard Shortcuts 
This section contains a list of keyboard shortcuts unique to Symbol Editor. 

 

Press these keys: To do this: 

BACKSPACE 

(Unwind) 

Used as unwind command while placing objects with 
multiple segments (e.g. lines, polygons, pins). Each 
BACKSPACE stroke unwinds the previously placed item. 

N and SHIFT+N 

(increment and decrement) 

N increments a pin by one when placing or renumbering 
pins. SHIFT+N decrements a pin by one when placing or 
renumbering pins. 
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CHAPTER 7 

The Source Browser 

Using the Source Browser 
The Source Browser displays component data currently available in P-CAD Library Executive in an 
easy-to-use Graphical User Interface (GUI). It is organized in a tree like structure that shows the 
relationship between these component data sources. The Source Browser provides access to all the 
information and many of the commands available to you while using Library Executive. 

The Source Browser contains any or all of the following items: 

• P-CAD library sets: A library set contains a group of P-CAD libraries. Many of the Library 
Executive commands can operate on either an individual library or a group of libraries 
simultaneously by selecting a library set. For more information, refer to Library Sets (page 95). 

• P-CAD libraries: A P-CAD library can be accessed through the Source Browser. Libraries in the 
Source Browser are always contained within a Library Set. You can open the library to view or 
edit the components, patterns and symbols it contains. For more information, refer to 
Browsing Components, Patterns and Symbols (page 96). 

• External source file: A component data file from a non-P-CAD source can be imported into 
Library Executive. The component attributes of the external source file can be used for many of 
the Library Executive functions, including updating a P-CAD library. For more information, see 
Importing Data from an External Source (page 121). 

• Query results: A search, or query, can be conducted on any source for a component or 
component attribute satisfying specified criteria. A Query Result is added to the Source 
Browser after a Query is complete. The Query Result contains all components or component 
attributes from the selected source that satisfy the search criteria. For more information, see 
Querying Libraries (page 103). 

• Cross link results: Component attributes in two different sources can be linked together with 
the Cross Link command. A Cross Link Result is added to the Source Browser after a Cross Link 
is complete. This Cross Link Result contains a combination of the attributes in both sources. 
For more information, see Understanding Cross Linking (page 130). 
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From the Source Browser, you can access almost all of the Library Executive commands. These 
commands are detailed in Source Browser Shortcut Menu Commands (page 17). A brief summary of 
each can be found in Source Browser Commands (page 92). 

Source Browser Commands 
When you select a source in the Library Executive Source Browser and right mouse-click, a shortcut 
menu opens, providing access to common commands performed on a selected object. This menu 
changes depending on the object selected. The commands available are summarized in the 
following table. 

 

Choose this 
Command: 

To do this: 

Add Library Add a library to the selected library set. 

Cross Link Open the Cross Link dialog. 

Delete Delete the selected library set. You can also press the DELETE key. 

Delete Attributes Delete selected user-defined attributes from a P-CAD library. 

Map Fields Open the Map Fields dialog. 

New Comma- 
delimited File 

Open the Import Comma-delimited File dialog. 

New Library Set Add a new library set. 

Open Open the Component Information dialog. 

Place Open the Place Component or Place Part dialog in the selected P-CAD 
application. 

Query Open the Query dialog. 

Reload Reload an external file, a library, or a library set’s contents into P-CAD 
Library Executive.  

Remove Remove the selected source from the Source Browser. You can also 
press the DELETE key 

Rename Rename the library set. 

Report Open the Report dialog. 

Save to Library Open the Save Source dialog. 

Verify Open the Verify dialog. 

View Open the selected pattern, symbol or Viewer. 
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The following diagram illustrates the shortcut commands available for each source in the Source 
Browser.  

 

This chapter summarizes the Source Browser, its contents and its function as the take off point to 
the other Library Executive features. For additional information about the use of Query, Cross Link, 
Verify, Reports, Place and Save To Library from the Source Browser, refer to Accessing Other 
Features (page 99). 

The Source Browser Interface 
To open the Source Browser, click the Source Browser button on the Library Executive toolbar or 
choose View » Source Browser. 
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The Source Browser dialog displays information in a tree structure, or hierarchy. You can browse 
the tree to view its contents. The source files in the Source Browser can be a library set, a library, an 
external source file, a query result, or a cross link result.  

Right mouse-clicking on a selected item in the tree opens the Library Executive shortcut command 
menu. Refer to Source Browser Commands (page 92) and Accessing Other Features (page 99) for 
additional information. 

 

The tree structure allows you to view all Library Executive source files and their contents at various 
levels of detail using the following commands and functions: 

• Groupings containing collapsed levels are shown with a + sign. To expand the grouping, simply 
click the + sign. Expanded groupings are shown with a – sign. To collapse the grouping, simply 
click the – sign.  

When modifications are made to the library contents from outside Library Executive Source 
Browser, the graphics representing the library contents may not be current. 

• To refresh the Source Browser contents, collapse the tree from the modified level. For 
example, when a component is removed from a library, collapse both the component level and 
the library level to refresh their contents. Expand the levels again to view their current 
contents. 

• To refresh the Library Executive memory, so that the Viewer contents reflect recent changes to 
a library or library set, choose Reload. Since Query, Verify, Cross Link and Report functions 
operate on the source in memory, choosing the Reload command assures you that you are 
operating on the most current library contents.  
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Library Sets 
A library set is a group of P-CAD library files. In the Source Browser, you can open up a library set 
to view its contents including the components and their associated symbols and patterns. You can 
also perform operations, such as query and verify, on the library set or its contents.  

This section discusses the creation and use of library sets. Operations on library sets and other 
Source Browser contents are summarized in Accessing Other Features (page 99). 

Library Setup 
The Library Setup dialog provides the methods to organize and manage library file names and 
library sets.  

1. Choose Library Setup to open the Library Setup dialog. 

 

2. Select a library set from the Library Sets list. The libraries contained in the set are listed in the 
Members list. 

To be usable in P-CAD Library Executive, all available libraries must be in one or more library sets. A 
default library set, called DEFAULT_LIBRARY_SET, includes any open library files that do not have a 
set specified explicitly.  

Library sets defined in the Library Setup dialog are saved in the initialization file, cmp.ini, for the 
next time you start Library Executive. 

Adding, Deleting and Renaming Library Sets 
To add a new library set: 

1. Click the Add Set button. 

2. Type the name of the new library set in the box. 

To delete a library set: 

1. Select a library set from the Library Sets list. 

2. Click the Delete button.  
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3. Deleting a set removes the set and the libraries it contains.  

To rename a library set: 

1. Select a library set from the Library Sets list. 

2. Click the Rename button. 

3. Modify the set name in the box. 

Modifying Library Set Contents 
To add a library to the selected library set: 

1. Click the Add Library button.  

2. Navigate to and select the desired library. 

3. Click Open. 

Selected libraries can be removed from a library set by clicking Remove.  

Modifying Library Sets from the Source Browser 
You can add, rename and delete selected libraries and library sets directly from the Source Browser 
by choosing those commands from the shortcut menu.  

Other operations, including Query, Verify, View and Reload, are also accessible through the 
shortcut menus. 

Browsing Components, Patterns and Symbols 
From the Source Browser, you can view the contents of a library, including its components, 
patterns and symbols, by following these steps:  

1. Expand a library set and one of the libraries contained within it by clicking the + sign to their 
left. Inside a library are three items: components, patterns and symbols. In the Source Browser 
tree, shown in the following figure, some of these items have been expanded to expose the 
contents of the library. 
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The component icon in the Source Browser indicates whether the component has an attached 
pattern or symbol, as shown below:  

 

Component Icon Description 

 A component with no pattern or symbol attached. 

 A component with only a pattern attached. 

 A component with only a symbol attached. 

 
A component with both a pattern and symbol attached. 

 

2. If you select a component in the Source Browser tree, you can choose the Open or Place 
commands from the shortcut menu to open or place the selected item.  

3. You can view a selected pattern or symbol by choosing the View command from the shortcut 
menu. 

Opening a Component 
To open a component, follow these steps: 

1. Select a component in the Source Browser tree. 

2. Choose the Open command from the shortcut menu. You can also open a component by 
double-clicking on the component name in the Source Browser tree. The Component 
Information dialog opens. 

 



Chapter 7: The Source Browser Deleting Library Attributes 

98 Library Executive User’s Guide 

 The Component Information dialog provides general information about a component. From this 
dialog, you can complete many functions including setting the component type as homogeneous 
or heterogeneous, selecting alternate views, setting the number of gates and gate numbering style, 
and defining the total number of pins.  

For more information about the Component Information dialog, see the View » Component Info 
command in View Component Info (page 255). 

Viewing and Editing a Pattern or Symbol 
To view or edit a pattern or symbol, follow these steps: 

1. Select a pattern or symbol in the Source Browser. 

2. Choose the View command from the shortcut menu. You can also view a pattern or symbol by 
double-clicking its name in the Source Browser tree. 

When you view a pattern, for example, the Pattern Viewer dialog opens:  

 

The P-CAD Pattern Editor can be opened by clicking the Edit button on the Pattern Viewer 
dialog. See The Pattern Editor (page 59), for information on using the Pattern Editor 

The P-CAD Symbol Editor can be opened by clicking the Edit button on the Symbol Viewer 
dialog. See The Symbol Editor (page 77), for information on using the Symbol Editor. 

Deleting Library Attributes 
From the Source Browser, you can remove user-defined attributes from a P-CAD library. 

To delete attributes from a P-CAD library: 

1. Select the library in the Source Browser tree. 
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2. Choose Delete Attributes to open the Delete Attributes dialog. 

 

The name of the selected library appears in the Source box. The user-defined attributes that 
may be deleted from the library appear in the Selected Attributes Will Be Deleted box. 

3. Select the check box to the left of the attribute you want to delete from the library. All selected 
attributes will be deleted from the library. Clear the check boxes of the attributes you want to 
leave in the library. 

4. Click OK. The selected attributes are automatically removed from the library. 

Accessing Other Features 
From the Source Browser you can perform queries, import data from an external source, cross link 
and update or create libraries. You can even place components selected in the Source Browser 
directly to a design in PCB or Schematic. 

The shortcut menus vary depending on the item selected in the Source Browser. This section lists 
the features accessible from selected items in the Source Browser.  

Query 
With Query, you can search for components with particular specifications. You can designate a 
wide variety of component characteristics, including cost, manufacturer, number of pins, etc. 
Searches can be conducted both on P-CAD libraries and on external sources, such as a company-
wide database. 

You can access Query from the Source Browser by selecting a library set, a library, an external 
source file, a cross link result, or another query result and choosing the Query command. 

Query results are stored on the Source Browser tree, where you can view the query spreadsheet, 
generate a report, cross link, save the query to a library or query again. 

For more information about Query see Querying Libraries (page 103). 

Importing Data from an External Source 
Component data from a non-P-CAD source can easily be imported into Library Executive.  
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To import an external source from the Source Browser, select the root of the Source Browser tree 
(Sources) and choose New Comma Separated File.  

The Map Fields and Cross Link commands are available from the Source Browser shortcut menu 
when you select an external source file.  

For more information about importing component data from a non-P-CAD source, see Importing 
Data from an External Source (page 121). 

Cross Linking 
Cross Linking allows you to quickly combine component attribute information from two different 
sources. Refer to the section Understanding Cross Linking (page 130) for details about the cross link 
feature. 

The Cross Link feature is available from the Source Browser by selecting a library set, a library, an 
external source file, a cross link result, or another query result and choosing the Cross Link 
command from the shortcut menu. 

Cross Link results, stored on the Source Browser tree, provide access to view the cross link 
spreadsheet, generate a report, query, cross link again, or save the cross link result to a library by 
choosing the appropriate commands in the shortcut menu. 

Updating or Creating Libraries 
You can create or update P-CAD libraries from several sources. A new library can be created from 
an external source file and updated as the external source file changes. You can also use query 
results or cross link results to create or update libraries. 

To create or update libraries from the Source Browser, select the external source file, cross link 
result, or query result from the Source Browser tree and choose the Save To Library command.  

Verify 
P-CAD Library Executive supports four consistency verifications from the Source Browser: 

• Between a P-CAD library or library set and another P-CAD library or library set. 

• Between an external source file and a P-CAD library or library set. 

• Between a Query Result and a P-CAD library or library set. 

• Between a Cross Link Result and a P-CAD library or library set. 

A difference report file is generated from the Source Browser tree, by selecting a P-CAD library or 
library set, the external source file, a cross link result, or a query result and choosing the Verify 
command. 

For more information on verification, see Library Verification (page 137). 
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Reports 
To generate a report using a P-CAD library, an external source file, a cross link result, or a query 
result from the Source Browser, select the item from the Source Browser tree and choose the 
Report command.  

For additional information about generating reports, refer to Reports (page 145). 

Component Placement 
To place components into P-CAD PCB or P-CAD Schematic from the Source Browser: 

1. Select the component from the Source Browser tree.  

2. While PCB or Schematic is running, choose the Place command. 

3. Select the desired application, PCB or Schematic. 

For more information about placing components in a P-CAD PCB or P-CAD Schematic design, see 
Component Placement (page 163). 
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CHAPTER 8 

Querying Libraries 

Using Query 
With P-CAD Library Executive, you can search for components using a wide variety of search 
criteria. For example, you may be searching for a component with a prescribed functionality that is 
available at a low price. In Library Executive, you simply specify these criteria in an easy-to-use 
spreadsheet form and a list of the ideal component(s) appears. 

You can query P-CAD libraries or library sets, an external source file, like the corporate component 
database, or another query result to narrow your component search by additional criteria.  

A query result can be used to update or create a P-CAD library. It can also be used to verify 
component data sources, finding differences between a library and a select set of components. 

This chapter details how to use the Library Executive Query.  

Fields and Data Types 
To both search and enter data into P-CAD Library Executive, it is useful to understand the 
commonly used component attributes, or fields, and how they are stored in memory.  

This section discusses both the fields that are immediately recognized by P-CAD Library Executive 
and their data types. Additional user-defined fields may also be included. 

Fields 
Fields are the names, recognized by P-CAD Library Executive, for component attributes. Fields 
include attributes and property names such as ComponentName, RefDesPrefix and NumberOfPins. 

In general, a property is an intrinsic building block of a component. For example, the number of 
pads on the component is a property. An attribute is additional component information that may 
be relevant to the design, manufacture or production of the printed circuit board. Throughout this 
document, the term attribute is used to generally describe both component properties and 
attributes.  
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A list of field names is included in the following table:  

 

Field Names Read- only Field Type Data Type 

ComponentName Yes Primary key String 

RefDesPrefix No Predefined property String 

PatternName Yes Predefined property String 

NumberOfPads Yes Predefined property Integer 

NumberOfPins Yes Predefined property Integer 

NumberOfParts Yes Predefined property Integer 

ComponentLibrary Yes Predefined property String 

ComponentType Yes Predefined property ComponentType 

Homogeneous Yes Predefined property Boolean 

AlphaNumeric Yes Predefined property Boolean 

HasIEEE Yes Predefined property Boolean 

HasDemorgan Yes Predefined property Boolean 

Value No Predefined attribute String 

ComponentHeight No Predefined attribute String 

Description No Predefined attribute String 

Link Yes Predefined attribute String 

NoSwap No Predefined attribute String 

Part Number No Predefined attribute String 

SwapEquivalence No Predefined attribute String 

Tolerance No User-defined attribute String 

Wattage No User-defined attribute String 

PowerConsumption No User-defined attribute String 

Manufacturer No User-defined attribute String 

Supplier No User-defined attribute String 

Cost No User-defined attribute String 

Leadtime No User-defined attribute String 
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Field Names Read- only Field Type Data Type 

CreateDate Yes User-defined attribute DateTime 

ModifyDate Yes User-defined attribute DateTime 

VerifyDate Yes User-defined attribute DateTime 

 

There are three types of Field names: 

• Primary key 

• Predefined properties and attributes 

• User-defined attributes 

There is only one primary key, ComponentName. This attribute is required for all P-CAD library 
components. The ComponentName field contains the name of the component and is the 
fundamental field used for component selection in P-CAD PCB, Schematic and Library Executive. 

Predefined properties and attributes are fields that P-CAD libraries use to define the structure and 
function of the component. These predefined fields are specifically listed in the Attribute Properties 
dialog. See Edit Commands (page 249) for details. 

The user-defined attributes are field names that are recognized by P-CAD, but are not specifically 
listed in the Attribute Properties dialog. Although any user-defined attribute may be defined, an 
assortment of preset attributes, listed in the above table, are available in the Field column list (see 
Selecting Search and Display Fields (page 106). These attributes may be useful in determining the 
feasibility for manufacturing a board, such as cost and supplier. 

The data types of these fields impacts how you enter and search for component attributes. See Data 
Types (page 105) for a summary of data types available in Library Executive. 

Fields that are read-only have values that cannot be modified in Library Executive Viewers. 

Data Types 
Each field contains attribute or property values. These values are stored in memory as a particular 
data type. The following data types are supported in Library Executive: 

• String: String data is a collection of alphabetic or numeric characters. All user-defined fields are 
stored in the String data type, with the exception of the Timestamps. 

• Integer: Integer data values do not contain a decimal point. For example, the numbers 3, 6 and 
9 are integers, but 8.5 is not.  

• Boolean: Boolean data can be one of two values. True or False are Boolean. True and False data 
values are also represented by the numbers 1 and 0, respectively.  

• DateTime: DateTime data specifies the time an event occurred. It can include the day, month, 
year, hour, minute and second.  
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• ComponentType: The ComponentType data can be one of the following values: Normal, 
Power, Sheet Connector, Module or Link. 

The Data Type of the field is important for searching, comparing, sorting and displaying 
component attribute values. 

Setting up a Query 
To complete a query, you must: 

• Set up the search and display fields. 

• Specify search criteria. 

• Specify the desired output. 

• Execute the query. 

The following section discusses defining your search and display fields, as well as setting up your 
search criteria using query operators. It is followed by a brief summary of how to generate the 
query output. Query output is detailed in Using Query Results (page 116). 

The Query dialog is a spreadsheet. Refer to Library Basics (page 3) for details on manipulating 
spreadsheets. 

The Query command searches for components from the current contents of Library Executive 
memory, as displayed in the Viewer. Query does not search the original source file. If changes have 
been made to a library, choose Reload to refresh the library components in Library Executive’s 
memory before conducting the Query.  

Selecting Search and Display Fields 
For a Query, you must select the fields you want to search, as well as the fields to be displayed in 
your query result. The search fields are used to specify criteria important to your component 
search. Display fields contain the information you want to view in your query result. 

When conducting a Query, both search and display fields should be in your Field list in the Query 
dialog. To put a field in the Field list, you can do one of the following: 

• Click the Select All button. All of the fields defined for the present query source appear in the 
Field list. 

• Select desired fields from the pick list. When you click the Field column a down arrow appears 
to the right. Click the Down Arrow and the field list appears, where you can select the desired 
field. The field is automatically placed on the spreadsheet.  

• The Clear All button removes all fields from the Field list. 

• To add additional fields to a filled spreadsheet, click the Add Row button. A new row appears 
at the end of the Field list. 
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Search Fields 
A search field is used to specify your component search criteria. To make a field a search field, you 
must define search criteria in the Criteria(And) and Or columns of the Query dialog. See Selecting 
the Search Criteria (page 107) and And Versus Or (page 112) for more information. 

Display Fields 
A display field is included in the query results. To make a field a display field, select the Show check 
box next to the field name in the Field list.  

You can search for a field and not display its value in the Query Result table. To do so, specify a 
search criterion for the field, but clear its Show check box.  

Selecting the Search Criteria 
To complete any component search, you must specify what you are looking for. Search criteria 
define a condition that a component attribute must satisfy in order for the component to be 
acceptable.  

To specify search criteria, you must determine three things: 

• The Field you wish to search. 

• The Data Type of that Field. 

• The Query operator and values to limit the Field values.  

This section discusses query operators, including wildcard characters. These are the fundamentals 
needed to create any component search.  

Special Search Criteria by Data Type (page 109) details how the search expression is constructed 
when searching for a unique data type: Boolean, ComponentType, or DateTime. When searching 
for a String or Integer data type, only the information available in this section is required. 

A general search expression usually has the form of a query operator followed by a value. A 
combination of search expressions on multiple fields can limit the component search even further, 
making the search for the ideal component quick and easy. For details on how to combine more 
than one search expression, refer to And Versus Or (page 112). 

Query Operators 
To precisely define your search criteria, the Query function uses a set of operators selected from a 
list of available operators. 

When you click the spreadsheet in the Criteria(And) and Or columns, a down arrow appears to the 
right. Click the Down Arrow to display the operator list and then click on the operator you want to 
use. The operator is automatically placed on the spreadsheet. Operators may also be typed directly 
into the spreadsheet. 

The available operators are listed in the following table. 
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Operator Function 

= Exactly equal to 

If used with a wildcard operator, * or ?, this operator becomes literal. It 
searches for a set of characters with, for example, a question mark at the end. 

< Less than 

> Greater than 

<= Less than or equal to 

>= Greater than or equal to 

<> Not equal to 

IsLike If used with a wildcard operator, IsLike means is similar to. For example, IsLike 
5* could be 50, 510, 5, etc. 

If not used with a wildcard operator, IsLike is equivalent to =. 

IsNotLike If used with a wildcard operator, IsNotLike means is not similar to. For 
example, IsNotLike 5* could be 14 or 20 or 42, but not 50, 510, or 5. 

If not used with a wildcard operator, IsNotLike is equivalent to <>. 

Exist The attribute exists. 

NotExist The attribute does not exist. 

AnyValue The attribute exists and it has some value. 

NoValue The attribute exists, but it is assigned no value. 

 

To specify search criteria, the operator is generally followed by alphanumeric characters, as shown 
in the following spreadsheet.  

 

The four operators, Exist, NotExist, AnyValue and NoValue, are not followed by alphanumeric 
characters. 
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For the above query, one component found could be DIP24, a homogeneous component with 6 
parts and a ComponentType attribute. Notice that you can search for a homogeneous component 
without displaying the Homogeneous field value in the query result. Because of the search criteria, 
all components in the query result will have a value True for the Homogeneous field. This value, 
however, is not displayed in the Query Result because its Show box is cleared. 

If a search criteria entry is not preceded by an operator, the operator is assumed to be IsLike. 

Wildcard Characters 
There are two wildcard characters recognized by Query: ? and *. Wildcard characters can represent 
any alphanumeric character. The wildcard character ? represents exactly one character; the 
wildcard character * can more generally represent zero to any number of characters. 

For example, DIP*, could be DIP24, DIP16 or DIP8. Whereas DIP?4 must remain five characters long 
and end with the number 4, such as DIP14 or DIP24. 

Special Search Criteria by Data Type 
How you specify search criteria depends on what you’re searching for. Knowing the data type of 
the field you want to search, you can narrow the field of results. 

When searching for an Integer or String, all you need to know to create a successful search criteria 
is summarized in Selecting the Search Criteria (page 107). 

When searching for a Boolean, ComponentType, or DateTime data type, additional details are 
helpful to understand how to define a successful search. This section discusses how to search for 
Boolean (True/ False), ComponentType and DateTime data values. 

True and False 
Several standard field types defined in P-CAD libraries have a Boolean data type. Boolean data is 
either True or False. This can also be represented numerically as the numbers 0 or 1, for False and 
True respectively.  

The following predefined fields are Boolean:  

• Homogeneous: Whether or not the component is homogeneous. In a homogeneous 
component, all gates use the same symbol.  

• AlphaNumeric: Whether the gate numbering in the reference designator is alphanumeric. If 
True, the gate numbering contains letters, such as U1: A and U1: B. If false, the gate numbering 
is numeric only, such as U1: 1 and U1: 2. 

• HasIEEE: Whether the gate has an IEEE representation. 

• HasDemorgan: Whether the gate has a DeMorgan representation. 

To search for True/False values using the Query search criteria, you can type a variety of 
expressions in the Query dialog. These expressions are summarized in the following table. 
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Search Description Expressions 

Find the True values for this Boolean field. True 
= True 
1 
= 1 
> 0 

Find the False values for this Boolean field. False 
= False 
0 
= 0 
< 1 

 

No wildcards are allowed when searching for a True or False value.  

ComponentType 
The ComponentType attribute has five possible values: Normal, Power, Sheet Connector, Module, 
or Link. The ComponentType attribute is not stored as a character string. To search for any of these 
ComponentType values, the full value must be entered in the search expression. Wildcard 
characters are not allowed. The search is not sensitive to case.  

For example, to search for a ComponentType of Power, the following entries could be made in the 
Criteria(And) column: Power, = Power, power, or = power. But you cannot search for = Pow*. The 
wildcard would be taken literally and no components would be found. 

Dates and Times 
You can Query for the CreateDate, ModifyDate and VerifyDate fields. For example, you may want 
to find all components in a P-CAD library that have been modified after a certain date. This feature 
may be particularly useful if you are not the only one using and modifying the same library files. 

The CreateDate, ModifyDate and VerifyDate attributes can be automatically added to and updated 
in your P-CAD libraries. If the Query operator requires a value, the query expression for the above 
fields must contain at least the date. Both date and time are optional. There are many date and time 
formats acceptable to the Query utility. 

Date 
When entering the month and day in a Criteria (And) or Or column, use the following formats: 

 

Description: Month and Day Value 

A three letter month abbreviation followed by the day number.  Jul 23 

The full month’s name followed by the day number. July 23 

The month number followed by the day number, divided by a 
slash. 

7/23 
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The date requires both a month and day. Including the year in the date is optional. If a year is 
included, the following formats may be used: 

Description: Month, Day and Year Value 

If the month is either a three letter abbreviation or the full 
name, the day number must be followed by a comma. The year 
is either a 2 digit or 4 digit entry. 

Jul 23, 2001 

Jul 23, 01 

If the month and day are number values, the year number 
follows divided by a slash. 

7/23/2001 

7/23/01 

 

If the year is not included, the current year is assumed. For example, if today’s date is January 2nd, 
2001, then a query expression containing 12/31 will automatically be December 31st 2001, not 2000. 

Time 
The time entry, if included, follows the date. The Date and Time values must be divided by a space. 
Time requires only an hour value. Minutes and seconds are optional. When entering the time and 
date in a Criteria (And) or Or column, the time is always entered as a series of numbers divided by 
colons. 

Time value: HH:MM:SS 

• HH: The hour value on a 24 hour clock (0-24). The hour is required if a time value is used in the 
query expression. 

• MM: The minute value (0-59). 

• SS: The second value (0-59). 

For example, to find a component that was modified in a library after 11:47 am on the July 23, 1997, 
the following search criteria may be entered in the Query dialog: 
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And Versus Or 
In the Query dialog there are several columns where you can enter search criteria, the Criteria 
(And) column and the Or columns. When combining more than one search expression in a single 
query, both columns may be used to precisely define the desired component. This section details 
how different combinations of two or more search criteria can be used to construct a wide variety 
of component searches 

When you enter your search criteria, its spreadsheet location defines your intended search. If you 
want to find a component that satisfies criteria X AND criteria Y, place X and Y in the same column. 
If you want to find a component to either satisfy criteria X OR criteria Y, place X and Y in different 
columns. 

You can only use one search criteria per spreadsheet cell. Spreadsheet rows can be added to 
contain duplicate Field names if more than one search criteria is required on a single attribute. 

For example, in the following query, the search is for a component that has one pin and whose 
name begins with the number 4. After executing this search, a one pin component with the name 
4DHX57 might appear on the Query Results table. 

 

On the other hand, in the following query, the search is for a component that has one pin or whose 
name begins with the number 4. After executing this search, a one pin component with the name 
4DHX57 might again appear on the Query Results table. However, it could be followed by the two 
pin component 4DXF42S and the one pin component 6HGD32. 

 

You can put a field name in more than one row. This is needed for finding a component that has 
between 5 and 10 pins, for example: 

 

There can be multiple Or columns if you want to search for components with criteria X or Y or Z. 
You can add Or columns to the spreadsheet, by clicking the Add Column button. Additional 
columns are included to the right of present Or columns. 

You can also have multiple entries in an Or column if you want to search for components with the 
criteria X and Y or criteria L and M. 
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Specifying Output 
You can specify the Query output in two ways: 

• Which fields are displayed in the query result. 

• Whether or not the present query overwrites the previous result. 

To display a particular field in a query result, select the Show check box to the right of the field 
name. 

To preserve the present query results, select the New Results Table check box. When the new 
query is executed, both the original query result and the new query result tables remain in 
memory. Easy access to all query result tables is available through the Source Browser. Refer to The 
Source Browser (page 91), for additional information. 

Executing a Query 
After setting up your query, click the Query button. P-CAD Library Executive will search the 
selected source and automatically display the components satisfying your search criteria in a Query 
Result Viewer table.  

For more information about the Query Result Viewer and how you can use query results in Library 
Executive, see Query Results (page 113). 

Query Results 
When you execute a Query, the components found in the search appear on the Query Results 
Viewer.  

This section describes the Query Result Viewer spreadsheet and how you can use it. 

Query Result Viewer 
After executing a Query, the Query Result Viewer spreadsheet appears.  

 

The Query Result Viewer is a simple spreadsheet form; it contains all of the components in the 
queried source that satisfy the selected criteria. Across the top of the table are the selected display 
fields. Their values, for each of the components found, are listed in the appropriate column. 
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The Query Result Viewer dialog is a spreadsheet. Refer to Library Basics (page 3) for details on 
manipulating spreadsheets. 

Individual read-only field values cannot be modified, although read-only fields may be added or 
deleted from the table. A read-only field is displayed in red on the Viewer. 

Query Result Menu Commands 
The following reference section describes how to use all of the menu commands for the Query 
Result Viewer. These commands are listed in the order that they appear on the dialog menu: Table, 
Column and Row.  

Table Commands 
The Table commands allow you to access other features of P-CAD Library Executive, including 
Query, Cross Link, Verify, Report and Save To Library. They also allow you to rearrange the 
contents of the table by using cut, copy and paste. The following table describes the Table 
commands. 

 

Command Description 

Cut Deletes any selected component row from the Query Result Viewer and 
moves it to the Clipboard. This command will not work on a read-only field. 

Copy Copies selected item(s) from the Query Result Viewer onto the Clipboard. 

Paste Pastes items from the Clipboard onto the Query Results Viewer. The Paste 
command will not work on a read-only field. 

Query Opens the Query dialog where you narrow the component list of the 
present Query Results Viewer by including more search criteria. 

Cross Link Opens the Cross Link dialog where you can link component attributes in 
the selected file with their corresponding components in another source. 
The Cross Link Results Viewer displays a combination of the attributes in 
the two source files for the linked components. 

Verify Opens the Verify dialog where you can compare the components on the 
Query Results Viewer with components in a P-CAD library. 

Report Opens the Report dialog where you can generate a report on the 
components included in the Query Result Viewer.  

Save To Library Opens the Save Source dialog where you can save the components of the 
Query Result Viewer to a P-CAD library. 

Close Closes the Query Result Viewer. 

 

For more information about Query, Verify, Report and Save commands applied to a Query Result 
Viewer, see Using Query Results (page 116). 



Query Results Chapter 8: Querying Libraries 

Library Executive User’s Guide 115 

Column Commands 
The Column commands are available from the Column or shortcut menus when a column is 
selected from the Query Result Viewer. With the Column commands you can add, remove, rename 
and sort the columns of fields and their values.  

The following table describes the Column commands. 

 

Command Description 

Add Adds a column to the Query Result Viewer to the left of the currently 
selected column. Displays a dialog prompting you for the new field name. 

Delete Removes the currently selected column from the Query Result Viewer. 

Rename Opens a dialog where you can designate a new name for the currently 
selected column. 

Sort There are two methods available to sort columns: Allow Duplicates and 
Resolve Duplicates. 

The Allow Duplicates command sorts the field values, grouping duplicate 
values together. 

If you want unique field values, use the Resolve Duplicates command. The 
suffixes _1, _2, _3, etc. are added to the end of repeated values. The Resolve 
Duplicates command may be preferred, for example, when sorting the 
ComponentName field, since P-CAD requires a unique name for each 
component. The Resolve Duplicates command is available only for fields 
with data type String. 

 

Row Commands 
The Row commands are available when a row is selected from the Query Result Viewer either from 
the Row menu or the shortcut menu. With the Row commands, you can remove the component in 
the selected row. You can place a component in a P-CAD PCB or Schematic design. You can also 
open a component to view its component information. 

 

Command Description 

Delete Removes the currently selected row (component) from the Query Result 
Viewer. 

Place Places the selected component in a running PCB or Schematic design. Makes 
the program current with the Place Part or Place Component dialog open and 
the component selected. 

Open Opens the Component Information dialog.  
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The Open command is only available if the row contains the ComponentName and 
ComponentLibrary field. The Place command requires the row represents a valid component with 
an attached symbol or pattern. 

For more information about placing a component from a Query Result Viewer into a PCB or 
Schematic design commands, see Using Query Results (page 116). 

Using Query Results 
After completing a Query, all of the components satisfying the search criteria are displayed in a 
Query Results Viewer. You can use these components as you would any other source in Library 
Executive and place components selected in the Query Results Viewer directly to a design in PCB 
or Schematic. 

This section lists the primary features you can access from the Query Results Viewer.  

Query 
Choose Query from the Table menu to open the Query dialog. With Query, you can further limit 
the component list of your Query Result by specifying additional search criteria.  

Query results are stored on the Source Browser tree. The shortcut menu on a query result allows 
you to view the query spreadsheet, generate a report, save the query to a library, or query again. 

Cross Link 
Choose Cross Link from the Table menu to open the Cross Link dialog. With Cross Link, you can 
link a component attribute in the query result with a matching attribute in a P-CAD library or library 
set. All attributes, from both the query result and the library, are displayed in the Cross Link Results 
Viewer.  

Cross Link results are stored on the Source Browser tree. The shortcut menu on a cross link result 
allows you to view the cross link Viewer spreadsheet, generate a report, save the result to a library, 
query, or cross link again. 

Refer to Understanding Cross Linking (page 130) for details about the cross link feature. 

Verify 
From the Query Results Viewer, you can verify the consistency between the queried components 
and a set of P-CAD libraries. A report is generated if any differences are found. 

Choose Verify from the Table menu or from the shortcut menu in the Source Browser, after 
selecting the query result from the Source Browser tree.  

For more information see Library Verification (page 137). 

Reports 
To generate a report on a query result from the Query Result Viewer, choose Report from the Table 
menu or from the shortcut menu when a query result is selected in the Source Browser tree.  

For additional information about generating reports, refer to Reports (page 145). 
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Updating or Creating Libraries 
You can use query results to create or update libraries. If a library is created from the Query Result 
Viewer, the library will include only the queried components. If a library is updated from the Query 
Result Viewer, only the select group of queried components in the table will be modified in the 
library. The attributes in the Query Result Viewer will be created or updated in the P-CAD library 
for components with the same name. 

From the Query Result Viewer, choose the Save To Library command from the Table menu. You 
can also create or update libraries from the Source Browser by selecting the query result from the 
Source Browser tree and choosing Save To Library from the shortcut menu.  

Placing Components 
To place a component into P-CAD PCB or P-CAD Schematic from the Query Result Viewer: 

1. Select the row containing the desired component information. 

2. Choose Place in the Row menu. 

3. Drag the mouse to the right over the arrowhead to select the desired application, PCB or 
Schematic. 

If you have accessed Query from either a PCB Component Properties dialog or a Schematic 
Parts Properties dialog, a Replace button appears in the upper left corner of the Query Result 
Viewer. To replace the current component with a selected component in the Query Result 
Viewer, click the Replace button. 

You can also select the component from the Source Browser tree and choose Place PCB or Place 
Schematic from the shortcut menu.  

For more information about placing components in a P-CAD PCB or P-CAD Schematic design, see 
Component Placement (page 163). 

Accessing Query and Query Results 
There are several locations in Library Executive from which you can access the Query dialog and 
the Query Result Viewers.  

Accessing Query from the Source Browser 
Query results are stored on the Source Browser tree. The shortcut menu on a query result allows 
you to view the query Viewer spreadsheet, generate a report, save the query to a library, or query 
again. 

You can access the Query dialog from the Source Browser by selecting a library set, a library, an 
external source file, a cross link result, or another query result and choosing Query from the 
shortcut menu.  

Accessing Query from the Utils Menu 
Choose Utils » Query to open the Query dialog containing the most recent Query conducted. 
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Accessing Query from the File Menu 
Choose File » Query to open the Query dialog containing the most recent Query, if any, conducted 
on the external source file.  

The File » Query command only queries a non-P-CAD data source file. 

 

Using Query from PCB and Schematic 
When Library Executive is installed, a Query button appears on the Place Part dialog in Schematic 
and the Place Component dialog in PCB.  

1. Click the Query button to access the Query dialog.  

2. To access Query from PCB or Schematic, you can also choose the Query command that 
appears in the application’s Library menu. 

The appearance and function of the Query dialog, when embedded in PCB or Schematic, is slightly 
modified. This section describes the changes to the Query dialog and how it is used from PCB and 
Schematic. 

Embedded Query Dialog 
When accessing the Library Executive Query embedded within Schematic or PCB, the Query dialog 
has a slightly modified appearance and function. The embedded Query dialog is shown below. 

  

The first difference you might note is the list of open libraries on the left hand side. Selecting the 
check box next to the library name indicates that you would like to search that library using Query. 
You can open additional libraries by clicking the Library Setup button.  

A second difference is the Scan button in the upper right hand corner. Clicking the Scan button 
searches all open libraries for user-defined component attributes and adds them to the pick list for 
the Fields column. By default the pick list contains only the primary field, ComponentName, and 
the other predefined attributes. User-defined component attributes may also be typed directly into 
the Fields column if you know the name of the attribute. 
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For the embedded query, there can be only one Query Result table. 

Using the Embedded Query 
This section contains a quick summary of using the Query embedded in PCB and Schematic.  

1. Choose Library Query or click the Query button in the Place Component or Place Parts dialog 
to open the Query dialog. 

2. Select the check boxes next to the open libraries that you wish to query for components. 

3. Specify the search and display fields in the Fields column.  

To include user-defined attributes in the pick list, click the Scan button. All open libraries are 
searched for user-defined attributes; the attributes are added to the list. 

4. Set up the search criteria in the Criteria (And) and Or columns. 

5. Click Query. The Query Results Table appears with the components satisfying the search 
criteria in each row. The component(s) can then be placed in the PCB or Schematic design or 
queried again. 
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CHAPTER 9 

Importing Data from an External Source 

One of the most exciting features of P-CAD Library Executive is its ability to create and update a 
P-CAD library file from almost any source, including your company’s component database. Once 
imported, the imported attributes can be used to create a P-CAD library, to verify and update a 
P-CAD library, or to search for the optimal component to place directly into a PCB or Schematic 
design. 

With P-CAD Library Executive you can easily keep your P-CAD libraries current to changes in 
component attributes, availability and pricing. The ability to import data from any non-P-CAD 
source, combined with the other powerful features of P-CAD Library Executive, create a quick, 
convenient, no-fail system to find the best PCB design at the lowest cost. 

What Can Be Imported?  
Any component library or component database can be imported into Library Executive. For 
example, you may have a corporate component database that changes regularly to reflect the 
variable inventory and cost of components. This component database can be easily imported into 
P-CAD, updated regularly and searched for the optimal component to place in a design. 

Before importing component data or a component library from a non-P-CAD source, it must be 
converted to a simple ASCII file format. The character-delimited ASCII file understood by Library 
Executive is a basic, inclusive format that can be created from any component database. Most 
spreadsheet applications allow you to output an ASCII file containing the spreadsheet data in a 
character-delimited file format. See Character Separated File Format (page 121) for details. 

Character Separated File Format 
There are two different, but closely related, character-delimited file formats that can be imported 
into Library Executive. The difference between the two is solely on the file’s first line. The first line 
can contain one of the following: 

• A list of character-separated field names. 

• A list of character-separated field values, with no field name headers. 
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In the first format, line 1 contains a list of character -separated field names. Each field name is 
translated as a component attribute. Line 2 and greater contain a list of character-separated values 
corresponding to the attribute. 

For example, the first few lines of a delimited file (using the letter x as its delimiter) to be imported 
into Library Executive could be: 

“Part Type”x”Part Number”x”Cost (in $)”x”Vendor”x”Quantity” 

“7400SL”x”0412345”x”0.25”x”Intel”x”10” 

“RAM128KX8”x”0324314”x”50.0”x”National Semiconductor”x”25” 

In the second format, there is no list of field names. Line 1 and greater simply contain the list of 
comma- separated values. In the absence of the field name list, default field names are generated 
for each column of the file. 

In the second format, the above example would be simply: 

“7400SL”x”0412345”x”0.25”x”Intel”x”10” 

“RAM128KX8”x”0324314”x”50.0”x”National Semiconductor”x”25” 

For a character-separated file of the latter format, default field name headers will be attached when 
imported.  

In both cases, the imported field name headers can be mapped to field names recognized by 
P-CAD. 

Import Limitations 
There are a few limitations regarding what may be imported into Library Executive. First, there are 
maximum limits on how long an attribute name or value may be. Second, list separators and 
comment characters, with the exception of the double quote, can be changed to a character of 
your choice. 

• Attribute Names and Values: A maximum number of characters that may be included in 
attribute names and values when importing them into P-CAD Library Executive. The 
ComponentName field value has a maximum length of 30 characters. In general, attribute 
names can have a maximum length of 20 characters. An attribute value can be up to 250 
characters in length. 

• Using and Importing Special Characters: Special characters, except the double quote, may be 
imported. The double quote is used exclusively to enclose a string of characters. Any character 
can be part of the characters inside a double quoted string of characters. 

For example, you can include the following component description attribute: “3 Input NAND 
Gate, .01 uF” with a comma delimiter. To import this description, the comma-delimited file 
should contain “3 Input NAND Gate\, .01 uF”. The comma becomes part of the attribute 
value, as opposed to signifying the beginning of the next attribute. 
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Importing a Character Separated File 
For any set of component attributes, either in a P-CAD library or in an external source file, there is 
an attribute (or combination of attributes) that indicate which component the set of attribute values 
belongs to. In a P-CAD library, the component name is the identifier that references only one 
unique component with that name in the library. When a ComponentName field is specified, all 
component attributes associated with that particular P-CAD library component are automatically 
included. The ComponentName in P-CAD is the key that references the rest of that component’s 
attributes.  

Depending on how your external component database is organized, a specific attribute or set of 
attributes identifies a component and all its associated component attributes. This attribute may or 
may not be the component name as used by P-CAD. In this document, the attribute that identifies 
the component and its attributes is called the primary key when referring to P-CAD’s 
ComponentName. The attribute(s) used to identify the component and its attribute in an external 
source file is called an index identifier. 

The P-CAD ComponentName must be associated with the imported data so that Library Executive 
can determine which library or design component the imported attributes belong to. This 
association of the ComponentName field with the imported component data can be completed 
with one of two commands: Map Fields or Cross Link. The command of choice depends on the 
original contents of the imported character-delimited file.  

To import a character-separated file containing component attribute data, follow these steps: 

1. Choose the File » Import command to open the Import Separated List File dialog. 

 

You can also access the Import Separated List File dialog from the Source Browser. Select the 
root of the Source Browser tree, Sources, and choose New Comma-Separated File from the 
shortcut menu. 

2. Click the Browse button to navigate to and select the file containing the character-delimited 
file. 

3. Click Open. The name of the file to be imported is displayed next to the Browse button. 
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4. If the first line of the character-delimited file contains field names, select the First line contains 
field names option button. 

If the first line of the character-delimited file does not contain field names, select the Generate 
default field names option button. Default field names will be attached to the imported data. 

The primary key, ComponentName, is the only attribute required for the import process. This 
attribute tells Library Executive which component the imported attributes belong to.  

To include the ComponentName field in your imported data file, there are two possible 
processes depending on the contents of your external source file: field mapping or cross 
linking. Field mapping is appropriate for character-delimited files containing the P-CAD 
primary key, ComponentName. On the other hand, cross linking is optimal for importing 
external source files that do not contain this essential information.  

Refer to the Field Mapping (page 124) or Cross Linking (page 126), for details. 

In both cases, any imported field name header can be mapped to a field name recognized by P- 
CAD. For example, the imported field name Component Price may be mapped to the P-CAD- 
recognized field name, Cost. Any field name can be mapped by choosing the File » Map Fields 
command. 

5. Choose the desired separator character from the list in the List Separator box or type the 
character you want to use (with the exception of the double quote). 

6. Select the character to be used to denote comments from the Comment Character list or type 
the character you want to use (except a double quote). 

7. Click OK to open the Viewer dialog.  

Field Mapping 
P-CAD Library Executive has knowledge of a set of field names, including a primary key, predefined 
properties and attributes and user-defined attributes. These fields are listed in Fields and Data 
Types (page 103). 

When importing data from an external source, the original field names may or may not be 
recognized by P-CAD. If unrecognized, Library Executive assumes the data within the field are user-
defined attribute values. If recognized, the component data within those fields are understood by 
P-CAD.  

Both user-defined and predefined attributes can be used throughout Library Executive, including 
library update, design and library verification and query. If you want to compare, for instance, the 
number of pads on the component in the P-CAD library and the external source file, both must be 
named the P-CAD recognized name NumberOfPads. Mapping fields in the imported source file 
connects the attributes and their values between the P-CAD library and external source. 

The File » Map Fields command maps the field name to predefined attribute or property names 
recognized by P-CAD or to other user-defined attribute names. 

The primary key, ComponentName, is the only attribute required to complete the import process. 
This attribute tells Library Executive which component the imported attribute values belong to. If 
the imported file contains the ComponentName field, the import process can be completed by 



Importing a Character Separated File Chapter 9: Importing Data from an External Source 

Library Executive User’s Guide 125 

field mapping. If the imported file does not contain a component name attribute, refer to Cross 
Linking (page 126) for details on how to include this required ComponentName field. 

The mapped fields are properties and attributes that form the building blocks of a complete, 
intelligent component.  

Map Fields maps the original character-delimited file. Any modifications made to the file contents 
within the Viewer prior to mapping will be lost when the Map Fields command is chosen. To save 
these modifications, choose Save To Library before mapping. 

To map the imported fields: 

1. Choose Map Fields from the Table menu of the Viewer to open the Map Fields dialog. 

 

You can also choose Map Fields from the File menu on the main Library Executive dialog or 
from the shortcut menu when the imported external file is selected. 

The fields in the Map Fields dialog are: 

Original Field Name: The field names from the imported separated list file or the default field 
names if generated by P-CAD Library Executive.  

New Field Name: The field name to be used by P-CAD.  

Data Type: The field type that defaults to String for any unrecognized field name.  

Mapping: Shows if the attribute has been mapped to a recognizable predefined P-CAD field 
name or to a user-defined name.  

2. To map the imported fields to names recognized by P-CAD, click in the New Field Name 
column. A down arrow appears at the right of the selected field name. Click the Down Arrow 
and the field list appears. 

3. Select the desired P-CAD field name from the list. The field is automatically placed on the 
spreadsheet. The field type is automatically updated in the Data Type column for the P-CAD 
recognized name. 

4. Modify the Data Type from the list of data types available in the third column. Modifying the 
data type from its default value may be desired for two reasons:  

Sort order: The Integer and String data types have different sorting orders. See Viewer Menu 
Commands (page 131) for more information. 



Chapter 9: Importing Data from an External Source Importing a Character Separated File 

126 Library Executive User’s Guide 

Display: Selecting Boolean data type displays True or False attribute values. Selecting Integer 
displays these attributes as the integers 0 or 1. 

The mapped field values are attributes that can be used to update, verify, or search 
components in the imported file or library. Read-only attributes are for search and display 
purposes only. The default data type, String, is always used when saving the remaining 
attributes to a P-CAD library. 

Read-only attributes cannot be modified nor saved to a P-CAD library. These attributes are 
displayed in red on the imported file Viewer. 

When the Original Field Name is mapped to a New Field Name the field type is automatically 
updated in the Mapping column. The field type indicates whether the attribute is a primary 
key, a predefined attribute, or a user-defined attribute. 

5. You can map the original field name to more than one P-CAD recognized field name. Click the 
Add Row button to add an additional row to the end of the table. A list of original field names 
from the separated list source file is available in the first column.  

This one-to-many mapping may be useful when your corporate database is indexed differently 
than a P-CAD library. For example, the database contains two 7400 components produced by 
two different manufacturers. The database field Part Number can be mapped to both a 
ComponentName field, which must be unique for P-CAD products, and a predefined Part 
Number field, which is the original name 7400.  

Click the Delete Row button to delete a selected row. 

You can only delete rows that have been added to the table. 

6. When all Original Field Names have been mapped to their desired New Field Name, click the 
Map button. You are reminded that the original imported file is mapped, any changes you have 
made to the file contents in the Viewer are lost during the mapping process.  

7. The Viewer reappears with the fields mapped to the chosen P-CAD values. The word, mapped, 
will appear next to the mapped file name. 

Library Executive remembers the specified field mapping for the latest mapped file. For example, 
changes are made to your corporate component database every week. With Library Executive 
mapping, you can periodically update your component libraries. If you map the fields today, then 
next week when you import the database again to verify your P-CAD library, the mapping is 
completed automatically.  

If you import a file with the same filename but different field names than the previously imported 
file, the original mapping will be overwritten.  

Cross Linking 
The Cross Link command links attributes from two sources and combines them into one. Although 
the Cross Link command can link any two source files in Library Executive, it can be particularly 
useful when importing an external source file that does not include a ComponentName field. 
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Combining component attributes from a P-CAD library and an external source file can help you 
easily include the required ComponentName field in the imported data. 

In Field Mapping (page 124) the field mapping of an imported separated list file was discussed. Field 
mapping is the optimal method of including the required ComponentName field in the imported 
file, if the external source file contains the ComponentName field. For example, the source file field 
Name of Component may be mapped to the P-CAD primary key ComponentName using the Map 
Fields command. 

If the external source file does not contain the name of the components, the Cross Link command 
is the optimal method to include a ComponentName field. For instance, the component 
information you want to import is organized with a unique Part Number as the database index 
identifier. There is a component name field, but the component names are not unique. There may 
be, for instance, several components named 7400 produced by different manufacturers. These 
components are distinguished by a unique Part Number in the database.  

The Cross Link feature of P-CAD Library Executive allows you to link the unique Part Number 
directly to its corresponding component in the P-CAD libraries. The imported separated list file 
does not need to have a unique ComponentName field.  

The Cross Link command can link the Part Number in the external source file to the 
ComponentName field in a P-CAD library. The result of the Cross Link command is a table 
containing a combination of component attributes from the two linked component data sources. 
When importing an external source file, the common sources to be linked are the external source 
file, a P-CAD library and a map file. The Cross Link command, the above mentioned source files and 
how they are used in the process of importing an external source file, is discussed in Attaching the 
Index Identifier (page 127) which details how a map file is used to link the Part Number to the 
ComponentName, followed by Import By Linking the Index Identifier (page 128) which describes 
how to complete the import process once the ComponentName has been included with the 
external source file’s component attributes.  

The cross linked component attributes are displayed in a file Viewer dialog and are stored in a 
Cross Link Result. This Cross Link Result can be accessed through the Source Browser and used as 
the source for any P-CAD Library Executive function. For example, cross linked component 
attributes can easily be used to update or verify P-CAD libraries. Components in a Cross Link Result 
may also be placed directly in a PCB or Schematic design, if the components are complete. 

The power and flexibility of the Cross Link feature aids far more than simply importing external 
source files. Cross Link is a quick way to combine component attributes from a variety of sources. 
Refer to Understanding Cross Linking (page 130) to maximize the cross link power at your 
fingertips. 

Attaching the Index Identifier 
In order to cross link an external source file, you must associate the index identifier (one or more 
fields which uniquely identify each component) in your character-delimited file to its respective 
component in a P-CAD library. If your database component attributes are organized by Part 
Number and each Part Number is unique, for example, you will link each Part Number to its P-CAD 
ComponentName.  
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Making this link between the components in the external source file and the P-CAD library can be 
accomplished in many ways. You can choose to enter the Part Number as a user-defined attribute 
in your P-CAD library by typing the index identifier attribute(s) directly into a Library Executive 
spreadsheet. You can also choose to use a map file to automatically connect the Part Number to the 
ComponentName by choosing the Cross Link command, which is the recommended method.  

The end result of whatever process you choose is a single source file containing both the P-CAD 
ComponentName and the component’s index identifier as a user-defined attribute(s). For example, 
cross linking a map file with a P-CAD library will result in a source containing all of the component 
properties and attributes stored in the library, including ComponentName and the index identifier 
for each component from the map file, for example Part Number. If your database uses a 
combination of Part Number and Manufacturer attributes to reference its components, then the 
source file would contain columns for both these fields and ComponentName.  

For example, start by importing a map file that contains the two fields: ComponentName and Part 
Number. The Cross Link command links the ComponentName of the map file to a P-CAD Library. 
The cross link result then has all of the P-CAD library data and an additional user-defined attribute 
column, Part Number for each component. The cross link result may now be used to save the Part 
Number attribute to the library, or to link to the Part Number attribute of another external source 
file.  

Import By Linking the Index Identifier 
The Cross Link command links two source files by matching component attributes. Beginning with 
the newly created source file that contains the ComponentName and the index identifier, you can 
cross link with an external source containing only the index identifier. This link adds the 
ComponentName field required by P-CAD to the appropriate components of the external source. 
In the example begun in Attaching the Index Identifier (page 127), you want to link the Part Number 
in the imported character- delimited file to the Part Number in the source file that contains both 
the ComponentName and Part Number.  

One source, the external source file, contains all of the attributes you wish to import from your 
company component database and the index identifier, Part Number. This external source does not 
have the essential ComponentName field that identifies a P-CAD component. The other source, 
either a P-CAD library or a cross link result, contains other component attributes, including the Part 
Number index identifier and the P-CAD primary key, ComponentName.  

The Cross Link command links the attributes of these two source files by matching the unique Part 
Numbers of the two sources. The result of the cross link is displayed in a Viewer spreadsheet. The 
cross link result will contain every component found in both source files. All component attributes 
from both sources will be included in the result.  

To cross link the imported field, an initial association must be made between the unique index 
identifier(s) in the external source file and the corresponding components in the P-CAD libraries as 
described in Attaching the Index Identifier (page 127). The following steps complete the cross link 
for the imported fields: 

1. Choose the Cross Link command from the Table menu of the Viewer to open the Cross Link 
dialog. 
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You can also choose the Cross Link command from the File menu on the main Library 
Executive dialog or from the shortcut menu when the imported external file is selected in the 
Source Browser. 

2. In the Select Source Fields to Cross Link box, select the check box to the left of the field 
name(s) to link to the source file created in Attaching the Index Identifier (page 127). The Part 
Number is the unique index identifier for the corporate component database and the check 
box to the left of the Part Number field should be selected. 

3. In the Select Target Library/Set to Cross Link box, expand the groupings by clicking the + sign 
to their left. Navigate to the desired target source, library or library set and select the target.  

In this case, a P-CAD component library has been updated to include the index identifier of the 
imported external source. If you do not wish to save the index identifier to your P-CAD 
libraries this target may also be a Cross Link result.  

4. Click OK. 

The selected target is searched for the chosen source field, in this case the index identifier Part 
Number. When a component with a matching source field is found in the target, all component 
information in both sources is displayed in the Cross Link Result Viewer. 
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The Cross Link Result Viewer is a simple spreadsheet form; attributes found in both the source file 
and the target are displayed. Across the top of the table are the fields found in the source and 
target. If a field name is found in both source and target, values from the target field are 
distinguished by their column header TARGET:FieldName. The field values, for each of the 
components found, are listed in the appropriate column. 

For details on manipulating the Cross Link Result Viewer spreadsheet, see Library Basics (page 3). 

Understanding Cross Linking 
Cross linking is one of the most powerful features of P-CAD Library Executive. You can cross link 
between any two sources in P-CAD Library Executive: an external source file, a P-CAD library or 
library set, a query result and a cross link result. The output is a result in the Viewer spreadsheet 
that contains a combination of the component attributes originally in both sources. 

The Cross Link command links the source files as they are in memory. If changes have been made 
to a library used as the cross link source or target, the Reload command refreshes the library 
components in Library Executive’s memory before the Cross Link is performed. 

To understand how cross linking can be used to combine data from various sources, consider the 
following examples. 

Setting up a Cross Link 
The examples in this section both work with the same two source files: Source #1 contains 3 
components (A, B and C); source #2 contains only two components (A and C). Each of these sources 
contains different component attributes. The only requirement for cross linking is that the two 
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sources have one common attribute. This common attribute will be used to link the sources 
together. In this example, the common attribute will be ComponentName, but it could be anything. 

With these two source files you could: 

• Combine the attributes in Source 1 and 2 to produce a component containing complete 
attribute information from both sources that can be placed on a PCB or Schematic design.  

• Use a combination of attributes from both sources to verify or update components in a P-CAD 
library.  

• Generate a report about the components, which includes the attributes from both sources. 

Source #1 is a P-CAD library that has all the component attributes needed for an integrated library 
component and contains four attributes: ComponentName, Attr1, Attr2 and Attr3. 

Source #2 contains component attributes from an external source and also includes information 
about cost and availability of some of the library (Source #1) components. Specifically, source #2 
has the ComponentName and Attr3 attributes. Instead of Attr1 and Attr2, this source contains Attr5 
and Attr6. 

Cross Link Example #1 
In example number one, both ComponentName and Attr3 are used to link the fields between the 
two source files. The result of this cross link is a file containing only components matching the 
ComponentName and Attr3 field values.  

Cross Link Example #2 
In this example only the field ComponentName is used. This second cross link produces a new file 
containing all six attributes. The result differs from the first Cross Link Result in that there will be 
two Attr3 attributes, one from Source #1 and another from Source #2. In this case, there is no 
attempt at comparing the repeated attributes, so components with matching or unmatching Attr3 
values are included.  

Cross Link Results are stored in the Source Browser. You can select a result at any time in the future 
to use a particular combination of components and component attributes. With a cross link result 
you can update a library, search for a component with specific attributes, generate a report, verify 
attributes in a P-CAD library and even cross link again to another Source file.  

Viewer Menu Commands 
The following reference section describes how to use all of the menu commands for the Viewer. 
These commands are listed in the order that they appear on the dialog menu: Table, Column and 
Row.  

The Viewer displays the contents of both an external source file and the cross link results. The 
Viewer for the external source file has the additional Table command Map Fields. 
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Table Commands 
The Table commands allow you to access other features of P-CAD Library Executive, including 
Query, Cross Link, Verify, Report and Save To Library. They also allow you to rearrange the 
contents of the table by using cut, copy and paste. Of particular importance for importing files from 
an external source are the Map Fields and Cross Link commands which can be accessed from the 
Table menu. 

 

Command Description 

Cut Deletes any selected component row from the Viewer and moves it to the 
Clipboard. 

Copy Copies selected item(s) from the Query Result Viewer onto the Clipboard. 

Paste Pastes items from the Clipboard onto the Viewer. 

Query Opens the Query dialog where you can narrow the component list of the 
imported file by including search criteria. 

Cross Link Opens the Cross Link dialog where you can link component attributes in the 
selected file with their corresponding components in another source. The 
Cross Link Results Viewer displays a combination of the attributes in the two 
source files for the linked components. 

Verify Opens the Verify dialog where you can compare the components in the 
Viewer with components in a library. 

Report Opens the Report dialog where you can generate a report on the 
components included in the Viewer. 

Save To Library Opens the Save Source dialog where you can save the components in the 
Viewer to a P-CAD library 

Map Fields Opens the Map Fields dialog where you can map the field names imported 
from an external source file to field names recognized by P-CAD Library 
Executive. 

Close Closes the Viewer. 

 

The Verify and Save To Library commands are only available if the primary field, ComponentName, 
is present. 

For more information about Query, Cross Link, Verify, Report and Save To Library commands 
applied to the imported file, see Using the Imported Source File (page 134). 
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Column Commands 
The Column commands are available from the Column menu and the shortcut menu when a 
column is selected in the Viewer. These commands allow you to add, remove and sort the columns 
of fields and their values. 

 

Command Description 

Add Adds a column to the Viewer to the left of the currently selected column. 
Opens a dialog where you can choose a new field name.  

Delete Removes the currently selected column from the Viewer. 

Rename Opens a dialog where you can specify a new name for the currently selected 
column. 

Sort Two methods are available to sort columns: Allow Duplicates and Resolve 
Duplicates.  

The Allow Duplicates command sorts the field values, grouping duplicate 
values together. 

The Resolve Duplicates command sorts the fields uniquely. The suffixes _1, 
_2, _3, etc. are added to the end of repeated values. The Resolve Duplicates 
command may be preferred when sorting the ComponentName field, since 
P-CAD requires a unique name for each component. The Resolve Duplicates 
command is available only for fields with data type String. 

 

There is a different sorting method for String and Integer data types. The default data type, String, is 
always used when saving attributes to a P-CAD library. Only modifiable attributes (not read- only) 
are saved to the library. 

Row Commands 
The Row commands are available from the Row menu or the shortcut menu when a row is selected 
in the Viewer. With the Row commands, you can add a row or remove the component in the 
selected row. You can place a component in a P-CAD PCB or Schematic design. You can also open 
a component to view its component information. 

Command Description 

Delete Removes the currently selected row from the Viewer. 

Place Places the selected component in a running PCB or Schematic design. Brings 
up the application with the Place Part or Place Component dialog open and 
the component selected. 

Open Opens the Component Information dialog.  
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The Open command is only available if the row contains the ComponentName and 
ComponentLibrary fields. The Place command requires the row represents a valid component with 
an attached symbol or pattern. 

For more information about placing a component from the Viewer into a PCB or Schematic design 
commands, see Using the Imported Source File (page 134). 

Using the Imported Source File 
From the Viewer, the command menus access the Library Executive features. You can even place 
components selected in the Viewer directly to a design in PCB or Schematic. 

This section lists the primary features you can access from the Viewer.  

Query 
You can access Query from the Viewer by choosing Query from the Table command menu. With 
Query, you further limit the component list of the imported source file by specifying desired 
search criteria.  

Query results are stored on the Source Browser tree. The shortcut menu on a query result allows 
you to view the query spreadsheet, generate a report, save the query to a library, or query again. 

Cross Link 
You can access Cross Link from the Viewer by choosing Cross Link from the Table command menu. 
With Cross Link, you can link a component attribute in the mapped imported source file with a 
matching attribute in any target source: a P-CAD library, query result, or cross link result. All 
attributes, from both the source file and the library, are displayed in the Cross Link Results Viewer.  

Cross Link results are stored on the Source Browser tree. The shortcut menu on a cross link result 
allows you to view the cross link Viewer spreadsheet, generate a report, save the cross link result to 
a library, query, or cross link again. 

Refer to Understanding Cross Linking (page 130) for details about the cross link feature. 

Verify 
From the Viewer, you can verify the consistency between the imported components and a set of 
P-CAD libraries. A report is generated if any differences are found. 

The Verify command is available from the Table menu or from the shortcut menu for a selected, 
imported separated list file in the Source Browser tree.  

For more information on verification, see Library Verification (page 137). 

Reports 
To generate a report on an imported source file from the Viewer, choose Report from the Table 
menu or select an imported file from the Source Browser tree and choose Report from the shortcut 
menu.  
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For additional information about generating reports, refer to Reports (page 145). 

Updating or Creating Libraries 
You can use imported separated list files to create or update P-CAD libraries. A new library can be 
created from an external source file. Later, you can easily update this library as the external source 
file changes.  

To create or update P-CAD libraries from an imported file, choose Save To Library from the Table 
menu in the Viewer. You can also create or update libraries from the Source Browser by selecting 
the external source file in the Source Browser tree and choosing Save To Library from the shortcut 
menu.  

Placing Components 
To place components into P-CAD PCB or P-CAD Schematic from the Viewer, select the row 
containing the desired component information. Choose Row » Place and select the desired 
application, PCB or Schematic.  

You can also select the component from the Source Browser tree and choose Place » PCB or Place 
» Schematic from the shortcut menu.  

For more information about placing components in a P-CAD PCB or P-CAD Schematic design, see 
Component Placement (page 163). 

Accessing the Imported File  
You can access the imported source file from several locations in Library Executive.  

Accessing from the Source Browser 
Imported source files are stored on the Source Browser tree. The shortcut menu on an imported 
file allows you to view the Viewer spreadsheet, map fields, cross link, generate a report, save the 
imported component attributes to a library, or query. 

Cross link results are also stored on the Source Browser tree. The shortcut menu on a cross link 
result allows you to view the cross link spreadsheet, generate a report, query, cross link again, or 
save the cross link result to a library. 

Accessing from the View Menu 
Choosing the View » Comma-separated File command displays the imported source file in the 
Viewer.  
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CHAPTER 10 

Library Verification 

With P-CAD Library Executive you can easily check for discrepancies between components in 
different sources. You can check for differences between the following sources: 

• An external source file and a P-CAD library 

• A PCB or Schematic design and a library 

• A Query Result and a library 

• A Cross Link Result and a library 

• P-CAD libraries 

Perhaps you have created a P-CAD library from your corporate component database. With library 
verify you can quickly check whether the database has since changed. And how it has changed. 

Perhaps you have been working on a design that may contain some of the altered components. 
With design verify you can validate the design directly and update it to reflect any database 
changes. 

This chapter describes the library and design verification tolls of P-CAD Library Executive. 

Verifying a P-CAD Library 
From P-CAD Library Executive, you can verify difference between a P-CAD library or library set and 
the following sources: 

• an external source file 

• a query result 

• a cross link result 

• another P-CAD library or library set. 

Depending on the desired source, the library verify tool is started in distinct ways. Refer to 
Accessing the Verify Command (page 138) for details. 
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The basic setup of the verification tool is identical, independent of the source. Customizing the 
common verification dialog is covered in The Verification Report (page 140). 

The differences between source and library are logged in a report file. This difference report is 
described in The Verification Report (page 140). 

The Verify command compares component attributes only. Attributes of the attached symbols and 
patterns are not included in the difference report. 

Accessing the Verify Command 
Choose the Verify command to compare a component source to a P-CAD library or library set. The 
Verify command can be accessed from the Source Browser, the File menu or the Table menu. The 
location from which you choose the Verify command defines the components you intend to use as 
a source for the comparison. For example, choosing Verify from a Query Result table generates a 
report of the differences between the components listed in that Query Result and a P-CAD library 
or library set.  

This section describes how and where to choose the Verify command to get the results you want. 

From the Source Browser 
Choose Verify from the shortcut menu for a selected library, library set, query result, or external 
source file in the Source Browser tree. The following list describes the results for each selected 
item:  

• Library: The components listed in that library are compared to components in another 
specified P- CAD library or library set.  

• Library set: The components listed in all libraries in that set are compared to components in 
another specified P-CAD library or library set. 

• Query result: The components listed in that Query Result Viewer are compared to components 
in the specified P-CAD library or library set. 

• Cross link result: The components listed in that Cross Link Result Viewer are compared to 
components in the specified P-CAD library or library set. 

• External source file: The component attributes listed in the file Viewer are compared to 
components in the specified P-CAD library or library set. 

From the Table Menu 
Choose Verify in the Table menu of the Viewer to verify imported source files, query results, cross 
link results and P-CAD libraries.  

From the File Menu 
Choose Verify from the File menu to verify the mapped, imported source file against a specified 
P-CAD library or library set. 
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Setting up the Verify Dialog 
To compare a P-CAD library or library set to a source, follow these steps: 

1. Choose Verify to open the Verify dialog. 

 

See Accessing the Verify Command above for details on how to choose the Verify command to 
check the consistency of different sources.  

2. The Select Source Attributes to Verify box lists the attributes in the selected source. All 
selected attributes are verified against a P-CAD library or library set. Selected attributes are 
indicated by the check mark.  

The Verify command uses source component attributes from the current contents of Library 
Executive memory, as displayed in the Viewer. Verify does not use the original source file for 
comparison. If changes have been made to a library used as a source for the Verify command, 
choose Reload to refresh the Library Executive’s memory before conducting the verification. 

3. The tree structure in the Select Target Library Set/Library to Verify box allows you to view all 
Library Executive library sets and their contents at various levels of detail by expanding or 
collapsing the branches of the tree.  

Groupings containing collapsed levels are shown with a + sign. To expand the grouping, simply 
click the +. Expanded groupings are shown with a – sign. To collapse the grouping, simply click 
the – sign. 

Select the library or library set which you want to verify. If a library is selected, its contents are 
compared to the selected source attributes chosen in step 2. If a library set is selected, all 
libraries within that set are compared. 

If the List components not found in library box is cleared, components in the source that are 
not in the selected library are listed in the difference report. 
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If the Verify only components with matching library box is selected, Library Executive searches 
the source for components whose ComponentLibrary attribute matches the selected library. 
Only matched components are compared to that library. 

If the selected source does not have a ComponentLibrary attribute, the Verify only 
components with matching library check box is ignored. All attributes in the selected source 
are verified. 

When verifying a library, the component’s time stamp attribute VerifyDate, if present, is 
automatically updated with the current date and time. If the Set component verify timestamp 
check box is selected, and the VerifyDate attribute does not exist, the VerifyDate attribute is 
added to the component library. 

4. Type the desired report file name in the box or click the Browse button to navigate to and 
select a report file name. The selected report file name is displayed. 

5. Click Verify to generate the difference report.  

If you checked the View Report checkbox, the difference report is displayed on the screen. 

The Verification Report 
The verification report contains differences in the components or component attributes between 
the source and the target library. These differences are listed in an easy-to-read ASCII format. 

The first line of the report includes the verification source, which can be a library, library set, query 
result or external source file. It also names the first target library against which the source is being 
compared. If the selected target was a library set, the verification report format is repeated for 
second and higher numbered target libraries in the set.  

The differences between the source and target(s) are reported, including the following 
information: component name, attribute, source value and library value. For each component, 
multiple attributes and values may be reported depending on the attributes selected in the Select 
Source Attributes to Verify list of the Verify dialog. 

The following file excerpt is a simple example of a verification report. 
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The verification report is a difference report. It does not include attributes that are the same in both 
the source and the target library. It also does not include attributes that exist in the source, but not 
in the library. 

The Verify command only reports differences between the source and target library. You can also 
choose the Verify command directly from P-CAD PCB and P-CAD Schematic. In this case, Verify 
reports on differences between the current design and the target library. Using Verify from a P-CAD 
design, you can optionally choose to update the writeable component attributes and properties 
from an open library. For details, refer to Using Verify from PCB and Schematic (page 141). 

Using Verify from PCB and Schematic 
With P-CAD Library Executive, you can access the Verify tool from both P-CAD PCB and P-CAD 
Schematic to verify your current design. You can also specifically check the design’s component 
attributes in comparison to a set of open libraries.  

With the Design Verifier, you can easily keep your design current - incorporating updates in the 
corporate component database as it reflects the changing marketplace.  

As with library verification, the Design Verify command compares component attributes only. 
Attributes of the attached symbols and patterns are not included in the difference report. 

Verifying a Design 
Verifying a design from P-CAD PCB or P-CAD Schematic is similar to using the Verify command in 
Library Executive. This section covers in detail the process of verifying a design.  

To verify a design from Schematic or PCB: 

1. Choose Verify Design from the Library menu while the design is in the current workspace to 
open the Design Verification dialog. 
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2. The Library Properties/Attributes list displays only the primary field, ComponentName, and the 
other predefined properties and attributes.  

To add user-defined attributes to the Library Properties/Attributes list, click the Scan button. 
Clicking the Scan button searches all open libraries for user-defined attributes and adds them 
to the list. 

3. Select the attributes in the Library Properties/Attributes list you want to verify between the 
design and any open libraries.  

A grayed check box indicates that the property or attribute is read-only. Read-only attributes 
can be verified, but not updated in the design. 

4. The Open Libraries list box contains all open libraries in the current design. Design verification 
reports on differences between components in the design and all open libraries. 

To add, remove, or rearrange libraries in the Open Libraries list, click the Library Setup button. 
See your PCB or Schematic User’s Guides for additional information. 

If the Report components not found in library option button is selected, components in the 
design that are not in the open libraries are listed in the difference report. 

If the Update Design option button is selected, the difference report is generated and the 
design is updated to correspond to the open libraries.  

The Design Verification dialog does not update the VerifyDate attributes. The VerifyDate time 
stamp marks when the library components, not the design components, have been verified. 

5. Type the desired report file name in the box or click the Report File button to navigate to and 
select a report file name. The selected report file name is displayed. 

6. Click Verify to generate the difference report.  

If you selected the View Report check box, the difference report is displayed on the screen. 
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Updating the Design 
Design verification not only generates a difference report; it also provides the option of updating 
your design. In three easy steps you could import your corporate database, update a P-CAD library 
based on changes to that database and update the design you are working on to instantly reflect 
those database changes.  

By selecting the Update Design option button, you can choose to update the design’s component 
attributes with values from one open library. Two options are available in the Design Verification 
dialog to allow you to select which open library is used to update the component attributes: 

• Using selected libraries: If the Using selected libraries option button is selected, the design 
verifier uses the selections made in the Open Libraries list to determine the library used to 
update the component attributes.  

If more than one library is selected then the first occurrence of the component found is used 
for the design update. The libraries are searched in order from top to bottom of the list. Click 
the Library Setup button to add, delete, or rearrange the libraries in the Open Libraries list. 

• Using matching libraries: If the Using matching libraries option button is selected, then the 
check boxes in the Open Libraries list do not apply. Components in the design with the 
ComponentLibrary attribute matching the name of one of the open libraries are updated. 

These options are available only if the Update Design option button is selected. 

Only selected attributes in the Library Properties/Attributes list are updated in the design from an 
open library. Read-only attributes, marked by a gray colored check box, cannot be updated. 
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CHAPTER 11 

Reports 

With P-CAD Library Executive there are multiple reporting options and enhancements. These 
enhancements span the P-CAD products: PCB, Schematic and Library Executive. 

From P-CAD Library Executive, two report options are available: the basic source component 
reporting feature and the advanced library publisher. From PCB and Schematic, the Bill of Materials 
has been enhanced, with the purchase of Library Executive, to include imported component 
attributes. 

With the Library Executive report command, you can generate a report file containing details of the 
components in the selected source. An ASCII or comma-delimited report can be generated of the 
following sources: 

• An external source file 

• A P-CAD library or library set 

• A query or cross link result 

The Library Publisher command of P-CAD Library Executive generates a detailed report of 
components, patterns and symbols in a P-CAD library. The report is output to Microsoft Word 
97 and can contain a variety of reporting options, including pictures. 

P-CAD Library Executive also provides enhanced reporting capabilities for PCB and Schematic. 
When generating a Bill of Materials, you can select and organize the component attributes to 
include in the report output. These attributes can even be imported from an external source file. 

This chapter describes the reporting capabilities available with P-CAD Library Executive. 

Reports in P-CAD Library Executive 
From Library Executive, you can generate a report file from the following sources: 

• an external library source file 

• a query result 

• A cross link result 
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• Another P-CAD library or library set 

Depending on the desired source, the Report command is chosen in distinct ways. Refer to 
Accessing the Report Command (page 146) for details. 

The basic setup of the report dialog is identical, independent of the source. Customizing this 
common report dialog is covered in Generating a Report (page 146). 

Accessing the Report Command 
Choose the Report command to generate a report file on any Library Executive source. The Report 
command can be accessed from the Source Browser, the File menu and the Table menu. The 
location from which you choose the Report command defines the components listed in the report 
output. For example, choosing Report from a Query Result table generates a report of the 
components listed in that Query Result.  

This section describes how and where to choose the Report command to get the output you want. 

From the Source Browser 
Choose the Report command from the shortcut menu after selecting a library, library set, query 
result, cross link result, or external source file in the Source Browser tree.  

The components in the source you select are listed in the report output. 

From the Table Menu 
Choose the Report command from the Table menu when in the Viewer to generate reports on 
imported source files, query results, cross link results and P-CAD libraries.  

From the File Menu 
Choose the Report command from the File menu to generate a report on the imported source file. 

Generating a Report 
To generate a report on a query result, a cross link result, an imported file, or a P-CAD library: 

1. Choose the Report command to open the Report dialog. 

When reporting on an imported file, choose File » Report. 

Other reports can be generated by selecting the item (query result, cross link result, imported 
file, or P-CAD library) in the Source Browser tree and choosing Report from the shortcut menu.  

A report on the current Viewer contents can be made by choosing the Table Report command. 

The Report command reports on the current contents of Library Executive memory, as 
displayed in the Viewer. Report does not report on the original source file. If changes have 
been made to a library, choose Reload to refresh the library components in Library Executive 
memory before generating the report. 

The Report dialog displays. 
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2. Select the report format in the Style Format frame:  

• Delimiter Separated: A delimiter separated report output with formatting specifications.  

• Report: Generates an ASCII report file. The ASCII report is more readable and formatting 
specifications can be applied. The Page Format frame becomes available and you can 
designate a Header, Footer, Lines per Page and Columns.  

3. Select the desired file Output Destination: 

• File: Define the Output Filename by typing the name in the box or clicking the Filename 
button to navigate to and select the desired file.  

• Screen: Puts the report out to the screen. 

• Printer: The report output is sent directly to the current printer. 

4. Click Generate.  

Publishing a P-CAD Library 
Library Publisher is a powerful Library Executive feature that generates complete, customizable 
reports directly in Microsoft Word. These reports can include pictures of the patterns and 
symbols in the library.  

Microsoft Word 97 is required for the Library Publisher utility.  

Setting up the Library Publisher Dialog 
Choose Library » Publisher to open the Library Publisher dialog. 
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This dialog is the point of access for the content and format options of the Library Publisher.  

To set up the Library Publisher dialog, follow these steps: 

1. Click the Source Library button to navigate to and select the directory and filename of the 
P-CAD library you want to publish. 

2. Click the Save To button to navigate to and select the directory and filename of the output file. 

3. Select the Library Section check box if you want to include a report on the selected P-CAD 
library in the publisher output. 

When this check box is selected, the Library Format button becomes available. Click the 
Library Format button to select the contents of this section, including file name, size, 
component name list, etc. Refer to Format Options (page 149) for additional details. 

4. Select the Component Section check box if you want to include a report on the components in 
the selected P-CAD library in the publisher output. 

When this option is selected, the Component Format button becomes available. Click the 
Component Format button to select the contents of this section, including component name, 
pin table, attribute table, etc. Refer to Format Options (page 149) for additional details. 

The Select Components button becomes available. Click the Select Components button to 
choose which components from the selected library will be included in the report output. 
Refer to Selecting Components, Patterns and Symbols (page 154) for additional details. 

5. If the Component Section check box is selected, several additional sections are available, 
including Attached Pattern Section, Attached Symbol Section and Footer Section check boxes. 

If you select the Attached Pattern Section, Attached Symbol Section, or Footer Section check 
boxes, the appropriate section is added to your publisher output. For instance, selecting the 
Attached Pattern Section check box includes a report of the pattern immediately after the 
report on the component to which it is attached.  
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The footer section is global, so if this check box is selected, specified attributes are included in 
the footer of all pages in the publisher output.  

If any of these sections are included, their corresponding format button is available. Click the 
item’s format button to select the formatting options for that section. Refer to Format Options 
(page 149) for additional details on the Pattern Format, Symbol Format and Footer Format 
dialogs. 

6. Select the Pattern Section check box if you want to include a report on the patterns in the 
selected P-CAD library in the publisher output. 

When selected, the Select Patterns button becomes available, which allows you to select the 
patterns included in this section. All selected patterns from the library are included, whether or 
not they are attached to any library components. Refer to Selecting Components, Patterns and 
Symbols (page 154) for additional details. 

The Pattern Format button is also available. Click the Pattern Format button to select the 
contents of this section, including pattern name, attribute table, a picture of the pattern, etc. 
Refer to Format Options (page 149) for additional details. 

7. Select the Symbol Section check box if you want to include a report on the symbols in the 
selected P-CAD library in the publisher output. 

When this check box is selected, the Select Symbols button becomes available, allowing you to 
select the symbols included in this section. All selected symbols from the library are included, 
whether or not they are attached to any library components. Refer to Format Options (page 
149) for additional details. 

The Symbol Format button is also available. Click the Symbol Format button to select the 
contents of this section, including symbol name, attribute table, a picture of the symbol, etc. 
Refer to Format Options (page 149) for additional details. 

8. When all options have been specified as desired, click OK. The published document includes a 
report on the specified library with the selected sections, items and formatting options. 

Microsoft Word 97 works in the background to generate a published library document of 
the specified name. Open the document in Word to view, to make changes, or to print. To 
open the document, you can select the file name in the recently used file list on Word’s File 
menu. 

Format Options 
If you choose to include a section in your published output by selecting its check box, you can 
modify the contents of the section by clicking its corresponding format button. The format options 
available for each output section are detailed in Library Format Options (page 150). 

Library Publisher uses Word’s Normal.dot template as a basis for the published output. To select 
the font type, font size and page layout for the published library, modify your Normal.dot 
template accordingly. 
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Library Format Options 
When including the Library Section, click the Library Format button to open the Library Format 
Options dialog. 

 

This dialog allows you to specify the contents of the library section by selecting each option’s check 
box.  

When all desired library format options are selected, click Done. The selected options are saved 
and you are returned to the Library Publisher dialog. 

For details about the Library Format options, refer to Library Commands (page 211). 

Component Format Options 
When including the Component Section, click the Component Format button to open the 
Component Format Options dialog. 

 

This dialog allows you to specify the contents of the component section by selecting each option’s 
check box. 
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When all desired component format options are selected, click Done. The selected options are 
saved and you are returned to the Library Publisher dialog. 

For details about the Component Format options, refer to Library Commands (page 211). 

Pattern Format Options 
When including a Pattern Section in your published library, click the Pattern Format button to open 
the Pattern Format Options dialog. 

 

This dialog allows you to specify the contents of the pattern section by selecting each option’s 
check box.  

The pattern section check box can be selected in two locations. If you select the Attached Pattern 
Section check box within the Component Section, the pattern section will directly follow the 
component section of the component to which it is attached. If you select the Pattern Section 
check box outside the Component Section, the pattern section will follow after the component 
section for all components is completed. In this case, the pattern section will contain all of the 
selected patterns in the library consecutively, independent of their associated component.  

Each of these two pattern sections can be formatted separately. Click the Pattern Format button to 
open the Pattern Format Options dialog. 

When all desired pattern format options are selected, click Done. The selected options are saved 
and you are returned to the Library Publisher dialog. For details about the Pattern Format options, 
refer to Library Commands (page 211). 

Symbol Format Options 
When including a Symbol Section in your published library, click the Symbol Format button to 
open the Symbol Format Options dialog. 
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This dialog allows you to specify the contents of the symbol section by selecting each option’s 
check box.  

The symbol section check box can be selected in two locations. If you select the Attached Symbol 
Section check box within the Component Section, the symbol section will directly follow the 
component section (and attached pattern section, if selected) of the component to which it is 
attached. If you select the Symbol Section check box outside the Component Section, the symbol 
section will follow after the component section (and pattern section, if selected) for all components 
is completed. In this case, the symbol section will contain all of the selected symbols in the library 
consecutively, independent of their associated component.  

Each of these two symbol sections can be formatted separately. Click the Symbol Format button to 
open the Symbol Format Options dialog. 

When all desired symbol format options are selected, click Done. The selected options are saved 
and you are returned to the Library Publisher dialog. 

For details about the Symbol Format options, refer to Library Commands (page 211). 

Footer Format Options 
When including the Footer Section, click the Footer Format button to open the Footer Format 
Options dialog. 
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This dialog allows you to specify the footer contents displayed on each page of the component 
section by selecting the desired properties or attributes.  

To select the attributes you want displayed on the bottom of the component section’s pages: 

1. Select a component or attribute from the list of Predefined Options.  

2. Click Add to move the selection to the Footer Contents list. 

To include an attribute that is not predefined, type the attribute name into the User Defined 
Attribute box. Click Add. The attribute will appear in the Footer Contents box. The attribute 
value for the particular component will be found in the library and listed in the footer section. 
You can also double-click the attribute to add it.  

To remove an attribute from the Footer Contents box, select the attribute and click Remove. 
You can also double-click the attribute to remove it. 

Text can be included in the footer. For example, the words “Components Designed By:” can 
become a footer for your published document. To include text, type the text into the User 
Defined Attribute box. Click Add. Since the name is not recognized as an attribute, an attribute 
value will not appear in the footer. 

3. The footer contents are the attributes and their values listed in the order that they appear in 
the Footer Contents box. These attributes appear in order on the bottom of the pages in the 
component section from left to right. 

To organize the Footer Contents box, select the property or attribute you want to move, click 
Move Up or Move Down. These commands rearrange or modify the contents of this box by 
moving the selected attribute higher or lower in the list. 

4. Click Done. The properties and attributes in the Footer Contents box are used to create a 
footer for the published library document. 
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Selecting Components, Patterns and Symbols 
When a Component, Pattern, or Symbol section is included in your published library, you can 
select the items you want to include. The Select Components, Select Patterns and Select Symbols 
buttons open their corresponding component, pattern, or symbol selection list dialogs. A sample 
selection list dialog appears as shown in the following dialog. 

 

A list of all components, patterns, or symbols in the selected library is displayed. If an item is 
selected, the corresponding component, pattern, or symbol is included in the published output.  

1. To select all check boxes, click the Select All button. 

To clear all check boxes, click the Clear All button.  

Click an item to toggle its check box between selected and cleared.  

2. When the desired items are selected, click Done. The selected items will be published in their 
component, pattern, or symbol section. 

The selection dialog is not available for attached patterns and symbols in the component section. If 
Attached Pattern Section or Attached Symbol Section is selected, the patterns and symbols 
published are those attached to the selected component(s). 

Generating the Report Output 
You can generate the published library by clicking OK in the Library Publisher dialog after having 
specified the Library Publisher output: filenames, sections, formatting and item selection 

Microsoft Word 97 works in the background to generate a published library document of the 
specified name. Open the document in Word to view, make changes, or to print. To open the 
document, you can select the file name in the recently used file list on Word’s File menu. 

If you run Word in the foreground after the Library Publisher has been started, be careful not to 
quit the Word application. Exiting Word before Library Publisher has finished will halt the 
publishing process. 
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Bill of Materials from PCB and Schematic 
The File Reports dialogs of P-CAD PCB and P-CAD Schematic provide enhanced capabilities for the 
Bill of Materials report when P-CAD Library Executive is installed. The BOM report may be 
customized to include selected component attributes, including component attributes from an 
external source file. The File Reports dialog provides the initial entry to the Custom Report feature 
and appears. 

 

Select the Bill of Materials report and click the Customize button to open the Customize Reports 
dialog. 
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The Bill of Materials typically lists the component type, pattern, component value (if any), number 
of components with matching characteristics and the reference designator (RefDes) assigned to 
each component.  

In the Selection tab, you can select and organize the component attributes you want to include in 
the report, along with setting selection criteria for all fields except Count. All attributes in the 
design are available to be displayed in the report by selecting the Show check box for the specific 
fields. The Selection tab also provides access to the Import Files feature, which allows you to 
import component attributes from a non-P-CAD source. 

See Setting up a Custom BOM Report (page 156), to learn how to customize your Bill of Materials 
report. 

For information about importing component data from an external source to include in your Bill of 
Materials report, refer to Using an External Source File (page 160). 

Setting up a Custom BOM Report 
When you click the Customize button on the File Reports dialog, the Customize Report dialog is 
opened with the Format tab selected. 

 

Format Tab 
In the Format page you can select the following options: 

Header: Enter the name of the heading for the report if you have chosen the P-CAD Report Style 
Format. 

Footer: Enter the name of the desired footer if the Style Format of P-CAD Report has been selected. 
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Page Format: The Page Format frame applies to reports whose Style Format is the P-CAD Report. 
Choose the desired options by selecting the appropriate check boxes for:  

• Use Header to include the information you specified in the Header box. 

• Use Footer to include the footer information entered in the Footer box. 

• Design Info includes the information you entered in the File Design Info command and dialog. 

• Date/Page includes the current date and the page number. 

• Pagination allows you to create your own pagination (lines per page). 

Lines per Page: Enter the number of lines you want printed on each page. 

Column Width: Defines the number of characters, up to 2000, used to display an attribute. 

File Extension: The File Extension edit box displays the default extension for the selected report. 
You can also enter a new extension if desired. 

Separated List: The Separated List frame is available when the Separated List report style has been 
selected. In this frame you can Include Report Preface and/or Include Column Headers by selecting 
the appropriate check box. 

Selection Tab 
The Selection tab lists the report fields, allows you to choose which are displayed in the report and 
provides the ability to define selection criteria. 

The Customize Report Selection tab appears. 
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The columns in the Selection spreadsheet are: 

• Field: The list of fields specific to the selected report. 

• Show: The Show option turns on the display of selected fields in the report. Cleared fields do 
not appear in the report output. 

• Criteria (And): Contains the selection criteria used to filter the report data. 

• Or: Additional selection criteria can be entered here, if necessary. 

Operators used in the Criteria (And) and Or columns are identical to those used in the Query 
dialog. 

The columns in the spreadsheet can be resized by moving the column separation lines right or left. 
You can append another Or column by clicking the Add Column button. Fields can be repositioned 
in the list by using the Up and Down buttons, which determines the order in which they are output 
to the report. 

If you want to import information from a non-P-CAD source, click the Import Files button to open 
the Import Files dialog. 

 

The External File, Map File, View and Import buttons are used to add component attributes to the 
Bill of Materials report. A specific character can be designated as the start of a comment line from 
the options in the list or by entering the desired character in the box. 

For additional information about this option, refer to Using an External Source File (page 160). 

Sort Tab 
In the Sort tab you can select the field(s) used to sort the report output and choose a sort order. 

The Customize Report Sort tab is shown in the following figure. 
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Options available on the Sort tab are: 

• Available Fields: The list of fields in the selected report. 

• Selected Fields: The fields used to sort the data, the order in which the sort is applied and the 
field’s sorting order, (A) for Ascending or (D) for descending, is displayed in the Selected Fields 
list. 

• Insert: Click the Insert button to move a selected field from the Available Fields list and insert it 
above the selected field in the Selected Fields list.  

• Append: Click the Append button to move the selected field to the bottom of the Selected 
Fields list.  

• Remove: To move fields from the Selected Fields list back to the Available Fields list, select the 
field and click the Remove button. 

• Sorting Order: The Sorting Order is set by selecting the desired option button to sort in 
Ascending or Descending order before moving a field to the Selected Fields list.  

Adding a Custom Report 
Once the desired options are selected, click Add to open the Report Configuration dialog. 
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Enter the Report Name and click the OK button. You are returned to the File Reports dialog where 
the new report is listed in the Reports to Generate area. You can now select the reports and 
generate output by clicking the Generate button. 

Using an External Source File 
You can import component attributes from a non-P-CAD source to be included in the Bill of 
Materials report. For example, you may have a company component database that includes 
additional information about the components not contained in your P-CAD libraries. These 
imported attributes can be included in your Bill of Materials report directly from the File » Report 
command in both P-CAD PCB and Schematic. The imported file must be in a simple separated list 
format.  

If your external source file contains the ComponentName field, refer to Importing a Source File 
with a ComponentName (page 160). This field is essential for P-CAD libraries since it is used as the 
basis for both search and placement of all library components in all P-CAD products. With the 
ComponentName in your external file, component attributes in the file are easily associated with 
their appropriate component for the Bill of Materials report.  

Many external component databases are organized without a unique component name. For 
example, the attribute Part Number may be the index that labels and identifies individual 
components. If your external source file does not contain the ComponentName field, an additional 
file, called a map file, is needed to match the imported attributes with their associated components. 
Importing attributes from an external file without the ComponentName is discussed in Linking with 
a Map File (page 161). 

Importing a Source File with a ComponentName 
If the imported source file contains the ComponentName field, then the attributes are 
automatically linked with their corresponding component in your P-CAD library. In this case, follow 
these steps to generate a Bill of Materials with imported component attributes: 

1. In the Selection dialog, click the External File button.  

2. Navigate to and select the external source file. 

3. Click OK. The filename is displayed in the box. 

4. Click View if you wish to verify the file's contents. The file is displayed on the screen. 

5. To import the file, click Import. The attributes contained within the external file appear in the 
Selected fields will be included in the report box. 

6. Select and organize the attributes for the report contents.  
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7. Click OK to return to the File Reports dialog. 

Linking with a Map File 
If the source file does not contain the P-CAD primary key, ComponentName, then a Map file can 
also be imported to map the component index identifier from the source file to its associated 
library component. This map file is a simple separated list file that contains the ComponentName in 
one column and the identifying attribute in the remaining column(s), which are used in the 
external source, for example Part Number.  

In this case, you must load the map file. The attributes are automatically linked with their 
corresponding component in your P-CAD design. 

Follow the steps in Importing a Source File with a ComponentName (page 160) to generate a Bill of 
Materials with imported component attributes. After importing the external file, click the Map File 
button and choose the separated list map file. Click the View and Import buttons to view and 
import the map file, respectively.  

When imported, the map file is used to map the design’s component names with their 
corresponding index identifier. The now-recognized index identifier in the external file 
automatically attaches the imported attributes to their appropriate P-CAD components. 
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CHAPTER 12 

Component Placement 

With P-CAD Library Executive, you can place components directly into a PCB or Schematic design 
from several sources. These sources include a Query Result, a Cross Link Result, an imported 
library source file and any P-CAD library. 

The component placement feature of P-CAD Library Executive is a perfect companion to Query. 
Imagine the advantage you will achieve by being able to search for a component by various criteria, 
including Cost. And, after finding the ideal component, you can convenient place that component 
directly into your design. 

Component Placement Requirements 
To place a component in a design, the component must be in a P-CAD library. The component 
must also be complete, including all of the required graphical and electrical information.  

If the component is chosen from the Source Browser, the ComponentName and 
ComponentLibrary fields are known. A complete component with the required electrical and 
graphical information may be placed in a design. If the component has an attached pattern, it 
includes the required graphical information to be placed in P-CAD PCB. If the component has an 
attached symbol, it may be placed in P-CAD Schematic.  

If the component is selected in the Viewer, the Viewer must include the ComponentName and 
ComponentLibrary fields. If the component in the specified library has complete electrical and 
graphical information, Library Executive quickly accesses the component and places it in the 
current design.  

Accessing Component Placement 
Choose the Place command to place a component to a P-CAD PCB or Schematic design. The Place 
command can be accessed from the Source Browser and the Row menu. The item selected when 
you choose the Place command defines the component you intend to place in the design. For 
example, choosing Place » PCB from a Query Result table while a component row is selected, 
opens the Place Component dialog in the current PCB design with the component selected.  

This section describes how and where to choose the Place command to get the desired results. 
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From the Source Browser 
From the Source Browser you can open a P-CAD library directly and select a component to place 
into a design.  

Select a component contained within a P-CAD library in the Source Browser tree and choose Place 
from the shortcut menu. Drag the mouse to the right to select the desired application name, PCB or 
Schematic. 

Refer to Placing Components in P-CAD PCB (page 164) and Placing Parts in P-CAD Schematic (page 
164) for additional details. 

From the Viewer 
You can choose to Place a component from a Query Result Viewer or a Cross Link Result Viewer. 
You can also choose to Place a component from a file Viewer, while viewing either a P-CAD library 
or an imported library from an external source.  

To place a component from the Viewer, the Viewer must include the ComponentName and 
ComponentLibrary fields. Select the row on the table corresponding to the desired component by 
clicking the row number to its left. While the row is selected, choose the Place command from the 
Row menu. Drag the mouse to the right to select the desired application name, PCB or Schematic. 

Placing Components in P-CAD PCB 
To place a component in a PCB design, P-CAD PCB must be running with the design in the 
workspace. The Place Component dialog appears with the component selected. Refer to your PCB 
documentation or online help for details on placing a component.  

Component Placement from P-CAD PCB 
Library Executive assists with component placement from P-CAD PCB. If you search for a 
component from within the PCB application by running an embedded query, you can choose to 
place a component from the Query Result table.  

To access the embedded Query, a Query button appears on the Place Component dialog. The 
Library menu of P-CAD PCB also contains the Query command. 

The components satisfying the search criteria are displayed in a Query Result Viewer. Refer to 
Component Placement Requirements (page 163) for details about the requirements for placing a 
component from a Viewer spreadsheet. 

Placing Parts in P-CAD Schematic 
To place a component in a Schematic design, P-CAD Schematic must be running with the design in 
the workspace. The Place Part dialog appears with the component’s parts selected. Refer to your 
Schematic documentation or online help for details on placing a part.  
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Part Placement from P-CAD Schematic 
Library Executive assists with part placement from P-CAD Schematic. If you search for a component 
from within the Schematic application by running an embedded query, you can choose to place a 
component’s parts from the Query Result table.  

To access the embedded Query, a Query button appears on the Place Part dialog. The Library menu 
of P-CAD Schematic also contains the Query command. 

The components satisfying the search criteria are displayed in a Query Result Viewer. Refer to 
Component Placement Requirements (page 163) for details about the requirements for placing a 
component from a Viewer spreadsheet. 
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CHAPTER 13 

Extended Library Features 

This chapter covers using advanced library features for importing and exporting and converting 
libraries form other sources, such as MRP and Tango. It contains a series of simple lessons that will 
teach you how to work with the extended Library Executive features, including: 

• Importing and Updating a Library from an external source file. 

• Importing an external source file without the ComponentName field. 

• Using Query to selectively update a library. 

• Using Query to find and place a component. 

• Reporting on component library updates. 

• Verifying your design against a library. 

• Verifying your libraries against an external source file. 

• Creating a component from the imported file, with help from the Pattern and Symbol Editors. 

• Converting libraries from other sources, e.g. Tango. 

Getting Setup for Learning 
The following information is needed to perform the lessons you will learn in these lessons. 

The Sample Files 
Four sample files are used in the following lessons. These files include two external source files, a 
map file and one P-CAD library.  

All of the sample files can be found in the Tutorial folder in the P-CAD installation directory. 
Make a backup of the original sample files before beginning these lessons. Modifications made to 
the source file, such as during field mapping, are saved automatically. 
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The external source files contain attributes that are associated with many of the components 
included in the sample P-CAD library. For example, one such attribute is Quantity. The values for 
this and other attributes have changed recently in the company database, or MRP, to reflect the 
current inventory. For lessons 1 and 2, you would like to import this data from the company 
database to update your library. The updated library is used for many of the remaining lessons in 
this chapter. 

External Source Files 
When importing data from a non-P-CAD source, such as an MRP database, the first step is to 
generate a simple comma-delimited file containing the database information. In these example 
files, this step has already been completed for you.  

In fact, two comma-delimited files are provided, with the essential difference being whether or not 
the file contains the primary key, ComponentName. The first lesson guides you through the steps 
of importing the MRP data with the primary key using the Map Fields command; lesson 2 uses the 
Cross Link command to import the MRP file without the ComponentName field. 

Refer to the Importing Data from an External Source (page 121) for additional information on how to 
convert your component database information to this simple format. 

• Ale_mrp.txt  

This file is a comma-delimited external source file that contains the primary key, 
ComponentName. The actual field name, Cmp-Name, must be mapped to the field name 
recognized by P-CAD using the Map Fields command.  

 

• Ale_crosslink.txt  

This file is a comma-delimited external source file that, in contrast to the file above, does not 
contain the ComponentName field. The Part Number field from this company database will be 
used to link this file to the sample library, Tutor.lib.  

 

Map File 
In order to import an external source file, such as Ale_crosslink.txt, that does not contain the 
ComponentName, an additional step is required to set up the automated import process. A simple, 
comma-delimited file will be used to initially associate the library ComponentName with a unique 
MRP database index, in this case the Part Number field. This additional file is called a map file.  
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The map file will only be used once, to insert the database index, Part Number, into the component 
library. The Part Number can then be used alone as the import identifier.  

• Ale_map.txt 

This map file is a simple comma-delimited text file that contains two columns: the primary key 
ComponentName and the database index identifier Part Number. This map file is used to enter 
the Part Number attribute into the appropriate library component’s attributes.   

 

P-CAD Library File 
The remaining sample file is a P-CAD library. This library contains many of the same components 
found within the sample MRP databases. These library components are complete and integrated, 
with an attached pattern, attached symbol, and electrical information. 

• Ale_tutor.lib 

This file is a P-CAD library containing the components referenced in the external source file.  

  

Lesson 1: Importing and Updating a Library from an MRP File 
This section illustrates the process of importing component data from a non-P-CAD source. It 
shows the initial comma-delimited source file, importing and field mapping. The imported data will 
then be used to update the library, Ale_tutor.lib. 

In this lesson, you will be importing the sample comma-delimited file, Ale_mrp.txt. This sample 
file contains the primary key, ComponentName. It will be used to introduce the Map Fields 
function of Library Executive.  

The MRP file Ale_mrp.txt is an external source file that contains the ComponentName field. This 
field is essential for P-CAD libraries since it is used as the basis for both search and placement of all 
library components in all P-CAD products. With the ComponentName field in your MRP file, it is 
only a few quick, easy steps to update a P-CAD library.  

Many MRP databases are organized without a unique component name. For example, the attribute 
Part Number may be the index that labels and identifies individual components. If your external 
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source file does not contain the ComponentName, an additional process is needed to initially set 
up and automate the import process.  

Using the sample files, follow these steps to learn how to import and update a library from an MRP 
file:  

Step 1: Import an MRP with a ComponentName 
The first step in importing any external source file is to put the data into a simple comma-delimited 
file format. The source file Ale_mrp.txt is already in the appropriate file format and can be 
imported directly into Library Executive. The Importing Data from an External Source (page 121) 
contains additional information on how to convert your component database information to this 
simple format. 

To import the sample MRP file, follow these steps: 

1. Choose File » Import to open the Import Separated List File dialog. 

 

2. Click the Browse button. Navigate to the Tutorial folder in the P-CAD installation directory 
and select the comma-delimited source file Ale_mrp.txt. 

3. Click the First line contains field names button since the first line of the sample file contains 
the field names that correspond to the file contents. 

If the first line of the external source file did not contain field names, the Generate default field 
names button should be selected. 

4. Enter or select a character in the List Separator box. 

5. Enter or select a character in the Comment Character box.  

6. Click OK. The external source file Viewer appears. 
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The field names are the column headers with the field values filling in the table contents. 

Step 2: Mapping Fields 
Now that you have the external source file imported, you can use the Map Fields command to map 
the field names to those recognized by P-CAD. You will be mapping the Cmp-Name and Pat-Name 
fields to their P-CAD counterparts ComponentName and PatternName. 

The field mapping is remembered. So, if you are regularly importing the same external source file, 
this mapping step need only be completed once. Subsequent imports of the same file will be 
automatically mapped. 

To use the Map Fields command on the imported source file: 

1. From the Table menu of the file Viewer, choose Map Fields to open the Map Fields dialog. 

 

2. Click the Cmp-Name entry in the New Field Names column to display the list of component 
names.  

3. Click the down arrow to display the list of P-CAD recognized field names. Select 
ComponentName. This list disappears and ComponentName is displayed in the column.  
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Press ENTER. The field is recognized by P-CAD when the Mapping column changes from user-
defined to Predefined. 

4. Repeat steps 2 and 3 to map the Pat-Name field to the P-CAD-recognized field, PatternName. 

5. Click the Map button. You are reminded that the original imported file is mapped, any changes 
you have made to the file contents in the Viewer are lost during the mapping process.  

The file Viewer appears with the two fields mapped. 

  

All fields in the sample source file are now mapped to their P-CAD predefined values, if 
available. In this case, the predefined fields ComponentName and PatternName are read-only, 
as indicated by their red color on the file Viewer.  

Step 3: Updating a P-CAD Library with MRP Data  
The number of components available in your company inventory has changed since you created 
the component library. To get a quick turn-around on your design, you would like to search for 
some components based on their availability. You have now imported that new data into Library 
Executive. In this section, you will use the imported file to selectively update the Quantity attribute 
in a P-CAD library.  

This section assumes that you have already set up the Ale_tutor.lib so it is available for Library 
Executive. If not, open the Source Browser and select the DEFAULT_LIBRARY_SET. Choose Add 
Library to add the sample library to the default set. 

To update the Quantity attribute of the Ale_tutor.lib library, follow these steps: 

1. From the Table command of the file Viewer, choose Save to Library. The Save Source dialog 
appears. 
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2. Select the Update option button. 

3. Click the Library button, navigate to the Tutorial folder in the P-CAD installation directory 
and select the Ale_tutor.lib library. Click Open. The selected library name displays in the 
edit box.  

There are no new components in the imported MRP file. Leave the Create new components 
box cleared. 

Since the MRP file does not contain a ComponentLibrary attribute, leave the Update only 
components with matching library name box cleared. 

4. Select the Create component time stamps if not present check box when adding or updating 
the ModifyDate attribute in the component library. 

5. All attributes that will be updated in the library are listed in the Attribute Conflict Resolution 
section. In this section, you can specify how to handle discrepancies between the source and 
the target library. Since you wish to update only the Quantity attribute, click the Source box to 
its right. The MRP file data will be favored and the Quantity attribute will be updated.  

6. Click the Ignore box to the right of all other attributes. 

7. Click OK. The library has been updated to reflect the new Quantity attribute values.  

Lesson 2: Importing an MRP File Without a ComponentName 
This lesson also illustrates the process of importing data from a non-P-CAD source. The imported 
data will again be used to update the P-CAD library, Ale_tutor.lib, using ComponentName as 
the primary key.  

The difference between the two lessons is the data contained within the MRP file. Lesson 2 imports 
a comma-delimited source file that does not contain the primary key, ComponentName. Instead, 
the data in this file is referenced by a unique Part Number.  

In this lesson, you will be importing the sample comma-delimited file, Ale_crosslink.txt. This 
external source file does not contain a ComponentName field. Importing this file will be used to 
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introduce the Cross Linking function of Library Executive. For additional information about the 
Cross Link feature, see the Importing Data from an External Source (page 121). 

Because the imported file does not contain a ComponentName, a few additional steps are 
necessary in comparison to Lesson 1. The first step serves the purpose of inserting the MRP 
database index identifier, Part Number, as an attribute of its associated component. Since this 
attribute is saved with the library, this step need only be completed once.  

The remaining steps are the import and update process for an external file without a 
ComponentName. These steps are completed every time you wish to update the P-CAD library 
components from this external source file. 

This lesson assumes that you have already set up the Ale_tutor.lib so it is available for Library 
Executive. If not, open the Source Browser and select the DEFAULT_LIBRARY_SET. Choose Add 
Library to add the sample library to the default set. 

You can follow along the next few sections, using the sample files to complete each of these steps 
yourself.  

Step 1: Adding the Part Number Attribute to a Library 
When importing an MRP file that does not contain the ComponentName field, some connection 
must be defined that associates a P-CAD library component with its MRP entry. This association can 
be completed in a variety of ways. The most automated technique is through the use of a map file.  

In this section, you will be completing the miniature import/update process of adding the Part 
Number attribute to a P-CAD component library. This attribute is the unique index identifier of the 
MRP database. Once added, Library Executive will automatically know which component you are 
referring to when you import a component identified solely by a Part Number. 

The map file is a simple, comma-delimited external source file. This file provides the cross 
reference between the ComponentName and Part Number fields. With the information in the map 
file, you will merge the external file’s data with the associated component data in the P-CAD library.  

To add the Part Number to the library: 

1. Choose File » Import to open the Import Separated List File dialog. 

 

2. Click the Browse button. Navigate to the Tutorial folder in the P-CAD installation directory 
and select the comma-delimited source file Ale_map.txt. 
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3. Click the First line contains field names button since the first line of the sample file contains 
the field names that correspond to the file contents. 

If the first line of the external source file did not contain field names, the Generate default field 
names button should be selected. 

4. Enter or select a character in the List Separator box. 

5. Enter or select a character in the Comment Character box.  

6. Click OK. The external source file Viewer appears. 

 

The field names are the column headers with the field values filling in the table contents. 

Step 2: Updating the Library 
The Viewer appears with the two column contents of the map file, ComponentName and Part 
Number. At present the components in the P-CAD sample library, Ale_tutor.lib, are only 
referenced by the ComponentName and the MRP database is only referenced by the Part Number. 
The following steps will link the Part Number to an associated ComponentName within the library. 

1. Save the Part Number attribute to the library by choosing the Save to Library command from 
the Table menu. From the Table command of the file Viewer, choose Save to Library. The Save 
Source dialog appears. 
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2. Select the Update option button. 

3. Click the Library button, navigate to the Tutorial folder in the P-CAD installation directory 
and select the Ale_tutor.lib library. Click Open. The selected library name displays in the 
edit box.  

There are no new components in the imported MRP file. Leave the Create new components 
box cleared. 

Since the MRP file does not contain a ComponentLibrary attribute, leave the Update only 
components with matching library name box cleared. 

4. Select the Create component time stamps if not present check box when adding or updating 
the ModifyDate attribute in the component library. 

5. All attributes that will be updated in the library are listed in the Attribute Conflict Resolution 
section. For Part Number, select Source and then click OK to apply the update. 

The Part Number and the ComponentName are now linked. This allows you to reference data 
by the ComponentName or the Part Number fields.  

6. Click OK. The library has been updated to reflect the new PartNumber attribute value.  

Step 3: Importing an MRP without a ComponentName 
Once the Part Number has been added to the sample library, you never have to repeat the above 
step again. The library components are now associated with the Part Number index of the company 
database. From here on out, to import the MRP sample file without a ComponentName, you can 
start with the step you just completed. 

The Ale_crosslink.txt file is a comma-delimited external source file. This sample file has been 
generated from a component database and includes the following attributes: Part Number, Vendor, 
Quantity, and Cost. Note that there is no ComponentName field. The Part Number, which was 
added to the library in the step above, will be used from this point forward to reference the library 
components. 
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Import the map file by following these steps: 

1. Choose File » Import to open the Import Separated List File dialog.  

 

2. Click the Browse button. Navigate to the Tutorial folder in the P-CAD installation directory 
and select the comma-delimited source file Ale_crosslink.txt. 

3. Click the First line contains field names button since the first line of the sample file contains 
the field names that correspond to the file contents. 

If the first line of the external source file did not contain field names, the Generate default field 
names button should be selected. 

4. Enter or select a character in the List Separator box. 

5. Enter or select a character in the Comment Character box.  

6. Click OK. The external source file Viewer appears. 
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The field names are the column headers with the field values filling in the table contents. 

Step 4: Cross Linking the Files 
To cross link the MRP file with the P-CAD sample library: 

1. From the Table menu of the MRP file Viewer, choose Cross Link to open the Cross Link dialog. 

 

2. In the Select Source Fields to Cross Link box, select the box to the left of the Part Number field 
name. 

3. In the Select Target Library/Set to Cross Link box, select the library Ale_tutor.lib file under 
DEFAULT_LIBRARY_SET.  

4. Click OK. The Cross Link Result Viewer appears with the combination of the library and source 
file information for components with matching Part Number attributes. 
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5. In the Viewer table, there are two columns containing values for the Quantity attribute: one 
from the source and one, with the header TARGET:Quantity, from the library. The same is true 
for the Vendor and Cost attributes. 

Select the column TARGET:Quantity by clicking the header. While holding the SHIFT key, click 
and hold the left mouse button and drag the column until a black line appears adjacent to the 
Quantity column. Release the mouse button and the TARGET:Quantity column is placed next 
to the Quantity column. 

6. With the two columns containing component Quantity information adjacent to each other you 
can visually compare changes in inventory.  

Select the TARGET:Quantity, TARGET: Cost and TARGET:Vendor columns by clicking the 
column headers with the SHIFT key pressed. Click DELETE to eliminate the original library 
Quantity values. The updated attribute values are in the file Viewer and ready to be saved. 

Step 5: Updating the Library 
1. Update the Library by choosing the Save to Library command from the Table menu to open the 

Save Source dialog. 

 

2. Select the Update option button. 

3. Click the Library button, navigate to the Tutorial folder in the P-CAD installation directory 
and select the Ale_tutor.lib library. Click Open. The selected library name displays in the 
edit box.  

There are no new components in the imported MRP file. Leave the Create new components 
box cleared. 

Since the MRP file does not contain a ComponentLibrary attribute, leave the Update only 
components with matching library name box cleared. 
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4. Select the Create component time stamps if not present check box when adding or updating 
the ModifyDate attribute in the component library. 

5. Select the Source check box only to the right of the attribute Quantity, since only that attribute 
will be updated. 

6. Click Ignore to the right of all remaining attributes. 

7. Click OK.  

Notice that the Cost attribute for many of these components has changed. You will be 
updating the component Cost in lesson 3. 

Lesson 3: Importing Without Saving 
If for any reason you do not want to add the index identifier to your P-CAD library, you can still 
import a MRP file without a ComponentName. To do so, you will be using the Cross Link feature of 
Library Executive in a slightly different way. For more information about the versatility and power of 
cross linking, refer to the Importing Data from an External Source (page 121). 

Although a complete lesson is not presented here, you may complete all of the following steps 
using the same three sample files as above: Ale_map.txt, Ale_crosslink.txt and 
Ale_tutor.lib.  

The imported file does not contain a ComponentName field. The basic problem is to associate the 
components in a P-CAD library with those of the imported file. As with lesson 2 above, the first step 
serves the purpose of inserting the MRP database index identifier as an attribute for its associated 
component.  

In this case, however, you do not wish the attribute to be saved. So the association between 
ComponentName and Part Number must be repeated for each import process. It only requires one 
quick, easy step. When the index identifier is not saved to the library, the import process for an 
external file without a ComponentName becomes: 

1. Cross Link the Ale_map.txt map file ComponentName field with the P-CAD library. The 
Cross Link result then contains the combination of the Part Number and the library 
components. 

2. Choose File Import to import the map file.  

3. Add the Part Number by choosing the Cross Link command from the Table menu of the file 
Viewer.  

4. Check the ComponentName field in the Select Source Fields to Cross Link box and select the 
Ale_tutor.lib library in the Select Target Library/Set to Cross Link box.  

5. Click OK to display the combination of the library and map file. In this case, it contains the Part 
Number attribute as well as the component attributes inside the library. 

The data in this viewer can be used without saving it to a library until the Library Executive 
application is exited. The Source Browser lists the result of the cross link that you have just 
completed (e.g. Cross Link Result #1). 
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6. Import the Ale_crosslink.txt file. 

7. Cross link the imported file with the library — map file Cross Link result generated in step 1. A 
new cross link result table is generated with a combination of all map file, imported file, and 
P-CAD library component information.  

This step is identical to cross linking, except that, instead of the updated library, the cross link 
result generated in step 1 is selected as the target. 

8. Select the TARGET:Quantity, TARGET:Cost and TARGET:Vendor columns by clicking the 
column headers while pressing SHIFT. Click DELETE to eliminate the original library Quantity 
values. The updated attribute values are in the file Viewer and ready to be saved 

9. Update the library from the new Cross Link results by choosing the Save to Library command. 

The cross link result of step 1 contains all the information of the library updated with the map 
file contents. The two are interchangeable. If you choose to update your library with the Part 
Number, then in step 3 cross link with the updated library. If you choose not to update your 
library with the Part Number, then in step 3 cross link with the map file cross link result.  

The only fundamental difference between the two methods is that saving the index identifier 
to the library saves you a step in subsequent import processes. 

Lesson 4: Using Query to Selectively Update a Library 
Query is a particularly useful tool when updating a library from an external source file. With Query, 
you can select components with particular characteristics to update. For instance, you could 
choose to update only components made by a particular vendor. Or, you could choose to update 
components modified after the date you last updated the library. 

You can choose to query and update from any source in Library Executive: an external source, a 
query result, a cross link result or a P-CAD library. In this lesson, you will be updating components 
that are produced by a particular vendor. This vendor has just changed its component prices, so the 
Cost attribute in the library will be updated.  

This lesson assumes that you have already set up the Ale_tutor.lib so it is available for Library 
Executive. If not, open the Source Browser and select the DEFAULT_LIBRARY_SET. Choose Add 
Library to add the sample library to the default set. 

You can follow along the next few sections, using the sample files to complete each of these steps 
yourself.  

Step 1: Select the Source to Query 
Again you will be using the sample file Ale_crosslink.txt to update the sample library 
Ale_tutor.lib. If this file is not presently in your Source Browser, import the file.  

To select the Ale_crosslink.txt file to Query: 

1. Click the Source Browser toolbar button to open the Source Browser tree.  

2. Select Ale_crosslink.txt and choose Query from the shortcut menu. 
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Step 2: Setting Up the Query Dialog 
In this case, you want to update only components that are produced by CTS. The expression for 
this search criterion is: 

Vendor = CTS 

Since there is only one criterion, it will be placed in the Criteria (And) column of the Query dialog. 

To set up the Query dialog, follow these steps: 

1. Click Set All to list the source fields in the Field column.  

2. Click in the Criteria (And) column to the right of the Vendor attribute, an arrow appears. Click 
the arrow to display a pick list which can help you select the = operator. Enter the expression = 
CTS. 

3. Since only the Cost attribute will be updated in the library, display only the Part Number and 
Cost attributes. The Part Number will be used to cross link to the corresponding library 
components made by CTS. Clear the Show check box to the right of the other attributes. 

4. Check the New Result Table box, so that any previous query results are not overwritten. 

The Query dialog should look like the following:  

 

Step 3: Updating the Library with Query Results 
1. Click Query to display the Query Results Viewer that contains all source components satisfying 

the selected search criteria. In this case, the Query Results Viewer should appear as follows. 
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2. Choose Cross Link from the Query Results Viewer to link the Part Number to its corresponding 
component in the library Ale_tutor.lib.  

3. Delete the TARGET:Cost column to eliminate the out-of-date library values by clicking the 
column heading and then pressing the DELETE key. 

4. Update the library by choosing the Save to Library command. Select the Source check boxes to 
the right of all attributes. All attributes for the vendor’s components will by updated in the 
selected library, including Cost. 

Lesson 5: Using Embedded Query to Find and Place a Component 
The Query utility in P-CAD Library Executive is a perfect aid in finding the ideal component for a 
design. For a simple example, you would like to place a capacitor on your PCB design. With P-CAD 
Library Executive, the perfect capacitor is right at your fingertips! 

If you intend to place a component in a design, the source that you query must contain complete 
components. For example, you could query a P-CAD library and place any query result component 
directly into a design. If, however, the source is an external file, the imported component attributes 
must be attached to a pattern, a symbol, and electrical information before placement.  

To place a component from a Query Result, you must also select to display the ComponentName 
and ComponentLibrary fields in the Query Result Viewer. Refer to the Component Placement 
chapter (page 163) for details on the requirements for placing components. 

Although you can use Query from Library Executive, as in lesson 3, this example illustrates using 
the Query dialog directly from the PCB design in which you want to place the component. The 
Query utility is embedded in the Place Component and Place Part commands of PCB and 
Schematic. The basic structure of these embedded Query dialogs are slightly different than the 
Query accessed directly from Library Executive, however, its basic function is the same.  

Step 1: Open the P-CAD Design 
To access the embedded Query utility, open a P-CAD design after you start PCB. You will be placing 
the capacitor in a blank workspace. Placing a queried component in a design is just as easy. 

1. Choose the Place Component command to open the Place Component dialog. 
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2. Click Query to search for a component to place in a design. The embedded Query dialog 
appears. 

 

Step 2: Setting up the Query Dialog 
In this case, you would like to place a capacitor. In the sample library all capacitors have the letters 
CAP somewhere in their component name. The expression for this search criteria is: 

ComponentName IsLike *CAP* 

The two * wildcards indicate that CAP can be in the beginning, end, or middle of the name. Since 
there is only one criterion, it will be placed in the Criteria (And) column of the Query dialog. 

1. If the Ale_tutor.lib is not in the Open Libraries box, click the Library Setup button and add 
the sample library. Click OK to return to the Query dialog.  

2. In the Open Libraries box, verify that the Ale_tutor.lib is selected. If there are any other 
open libraries, clear the check box to their left. 

3. Click in the Criteria (And) column to the right of the ComponentName field, an arrow appears.  
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4. Click the arrow to display a list from which you should select the IsLike operator. Enter the 
expression: IsLike *CAP*.  

The embedded Query dialog should look like the following: 

 

Step 3: Using Query Results to Place a Component 
When you click Query, the Query Results Viewer appears. This Query Results Viewer is identical to 
that which appears when you access Query directly from Library Executive. The Viewer contains all 
source components satisfying the selected search criteria.  

In this case, the Query Results Viewer should look like the following: 

 

You can use the Query Results to place a capacitor in your design. You will be choosing the CAP400 
capacitor to place in the blank PCB workspace. 

1. Select the row containing the capacitor CAP400 by clicking on the row number to its left. 

2. Click the Place button. The Place Component dialog appears with the chosen component 
selected in the Component Name list.  

3. Click OK. Move the ghosted component outline to accurately place the component on the 
workspace and click the left mouse button. 
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For more details, refer to the Place Component command in your P-CAD PCB User’s Guide. 

Lesson 6: Reporting on Component Library Updates 
You have been working on a design for the past six weeks. It is almost complete, but you want to 
check that changes made to the component library do not critically impact your design.  

In this lesson, you will learn how to generate a quick report of all components that have been 
updated since you loaded the netlist using the timestamp feature of Library Executive. With the 
component update report, you can easily verify that all of your design components are current. 

Assume that your calendar indicates the netlist was loaded and most components were placed on 
June 16th. The steps to report on library changes after this date will be detailed below. 

Step 1: Query the Library for a ModifyDate 
To query the library for all components modified after June 16th, you will be using the timestamp 
feature of Library Executive. When creating, updating, and verifying a P-CAD library, you can use 
timestamp to add CreateDate, ModifyDate, and VerifyDate to the library components. These dates 
can then be used for checking the progress of the libraries and the design components that come 
from them. These timestamps must be added to your library before you can query for the 
timestamp attributes. 

For more information about the timestamp feature, refer to Time Stamps (page 47). 

To query a library for a ModifyDate after June 16th: 

1. Open the Source Browser to add the library to a library set. The library is then available for 
Library Executive utilities. 

If you would like to follow along with this lesson, you can use the Ale_tutor.lib. If you have 
used this file for any other lessons, load a new backup copy of the original library file. Any 
modifications made to this library during the above lessons will have caused the ModifyDate 
attribute to be updated. 

2. Select the library in the Source Browser tree and choose Query from the shortcut menu. The 
Query dialog appears. 

3. Click the Set All button to show the fields contained within the library. Scroll down the list to 
find the ModifyDate attribute.  

4. In the Criteria (And) column, use the pick list to select the >= operator. After the operator, 
type:  June 16, 1997 

The Query dialog appears. 
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5. Click Query. All components in the library modified on or after June 16th, 1997 will appear in 
the Query Results Viewer.  

Step 2: Report on Updated Components 
You can generate a report on these updated components. This report can be easily compared with 
a Bill of Materials from your design. You can determine which attribute changes, if any, impact your 
final board design. 

1. From the Query Results Viewer, choose Report from the Table menu. 

2. Select the Report option button in the Style Format frame.  

3. Type in a header, footer, and output file name.  

4. Select all the check boxes in the Page Format frame, as well as the File option button in the 
Output. 

5. Click OK. Load the file into a text file viewer to view and print the report. 

Lesson 7: Verifying Your Design Against a Library 
In lesson 6, you learned how to generate a report on any library components changed after 
placement. In this lesson, you will learn how to verify the component attributes in the design and 
generate a difference report directly. The design components may be updated automatically to 
reflect these library changes. 

Again you have been working on a design for the past six weeks. It is almost complete, but you 
want to check that changes made to the component library do not critically impact your design.  

The report in lesson 6 lists all library components modified after the design placement date, 
whether or not they exist in the design. The difference report generated in this lesson lists only 
components with attribute discrepancies between the design and library.  
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Step 1: Open a PCB or Schematic Design 
To access the Design Verification utility, open a P-CAD design by starting PCB. You will be 
generating a difference report from a PCB design against a P-CAD library. 

1. Choose File » Open.  

2. Open a design file, such as Demo1_u.pcb in the Demo folder in the P-CAD installation 
directory. 

3. Choose Library » Verify Design. The Design Verification dialog appears. 

Step 2: Set up the Design Verification Dialog 
In this section, you will set up the Design Verification dialog to generate a difference report. The 
difference report will be displayed to the screen, as well as to a specified output file. This report 
will contain components that have differing attributes in the design and the library. It will also list 
the components that have been placed in the design that are not found in the open libraries. 

You can also use the Design Verification utility to update component attributes in your design. For 
more information about updating your design using the Design Verification utility, refer to Library 
Verification (page 137). 

1. In the Design Verification dialog all predefined attributes are listed in the Library Properties/ 
Attributes box. Leave all attribute check boxes in this list selected. You will be verifying all 
component attributes.  

In this case, the library components that you are going to verify, have no additional user-
defined attributes. If the library had additional attributes that you wanted to include in the 
difference report, you would click Scan to add them to the list. 

Design components are verified against all open libraries in the Open Libraries list. The Design 
Verification dialog appears. 

 

2. Type the report file name in the box and select the View Report check box.  
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3. Select the Report components not found in libraries check box to list in the difference report 
design components that were not found in the open libraries. 

Step 3: Generate a Difference Report 
You are now ready to generate a difference report that includes both attribute differences between 
the design and library and design components not found in the open libraries.  

1. Click Verify. A difference report is generated and displayed on the screen. 

The difference report is a simple text file. A sample difference report is shown below. 

 

Lesson 8: Verifying Your Libraries Against an MRP File 
You can also check to see whether your libraries need updating when changes to the MRP database 
are made. If the MRP is equivalent to the library and the library is equivalent to components in the 
design, the components in the design will be up to date with the MRP.  

This section assumes that you have the MRP source imported. The MRP source component must be 
associated with its corresponding ComponentName for library verification. It also assumes that you 
have set up the libraries so that they are available for P-CAD Library Executive. Add the libraries to 
the default library set, or create your own library set to contain the libraries. 

Step 1: Verifying the MRP Source 
After importing the MRP source and setting up the chosen libraries as you did in Lesson 1, 
complete the following steps: 

1. Select the MRP source file from the Source Browser.  

2. Choose Verify to open the Verify dialog. 

The Verify command can also be accessed from the Table menu of the file Viewer. 
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Step 2: Setting up the Verify Dialog 
In this section, you will set up the Verify dialog to generate a difference report. The difference 
report will be displayed to the screen, as well as to a specified output file. This report will contain 
components that have differing attributes in the MRP file and the library. It will also list the 
components that are in the MRP file, but are not found in the selected libraries. 

In contrast to Design Verification, discussed in Lesson 7, the library Verification utility can generate 
or update a VerifyDate attribute in the library indicating when the library was last verified. You will 
be generating a VerifyDate timestamp with the following steps: 

1. In the Verify dialog, all MRP source attributes are listed in the Select Source Attributes to Verify 
box. Leave all attribute check boxes in this list selected. You will be verifying all component 
attributes.  

2. The source MRP components are verified against all selected libraries in the Select Target 
Library Set/Library To Verify list. Select the library or library set. 

3. Type the report file name in the box and select the View Report check box.  

4. Select the List components not found in libraries check box to list in the difference report 
design components that were not found in the open libraries.  

5. Check the Set component verify time stamp box to generate or update the VerifyDate attribute 
in the selected libraries. 

You can also choose to verify only components with matching ComponentLibrary attributes in the 
MRP source and P-CAD library. For more information, about this and other Verify selections, refer 
to Library Verification (page 137). 

Step 3: Generate the Difference Report 
The Verify difference report is similar to that generated by the Design Verification utility discussed 
in Lesson 6.  
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Lesson 9: Library Creation Using Pattern and Symbol Editor 
From any source, you can generate a P-CAD library. The only requirement is that it contain a 
ComponentName field. The other essential attributes that define the pattern, symbol, and electrical 
properties of the component are generated using the tools in Library Executive.  

The process of creating an integrated component library is summarized in this lesson. For more 
information, references are included to other sections of this manual. 

1. Select a source with a ComponentName field. This source could, for instance, be an imported 
MRP file. Display the source in the file Viewer. 

2. Select a component from this source by clicking on the row number to its left. The component 
that you would like to make integrated is now highlighted.  

3. Choose Open from the Row menu. The Component Information dialog is displayed. For 
additional information, refer to the View Commands chapter. 

4. Click the Pattern View button. From this dialog you can attach a pattern to the component.  

To create a new pattern or edit an existing pattern, click Edit Pattern. The Pattern Editor 
appears. To select an existing pattern, click Select Pattern.  

5. Click the Symbol View button. From this dialog you can attach a symbol to the component.  

To create a new symbol or edit an existing symbol, click Edit Symbol. The Symbol Editor 
appears. To select an existing symbol, click Select Symbol.  

6. Return to the Component Information dialog to complete the integrated component. 
Completion includes attaching the pattern and symbol, adding component properties, and 
editing the pins view spreadsheet to designate the component’s electrical information. 

7. Validate and save the component to a P-CAD library by clicking the Validate button on the 
toolbar.  

8. Then, when no errors are found, choose the Component Save command to save the 
component. This command saves the pattern, symbol, and electrical information, as well as all 
of the user-defined attributes included in the imported MRP source. 

9. Repeat from step 2 for all components in the source. 

 

Converting Libraries  

Working with External Libraries 
Unlike Tango-Schematic and Tango-PCB, which use separate symbol and pattern libraries, P-CAD 
applications use integrated libraries, which contain components, symbols, and patterns.  

To use your Tango pattern and symbol libraries with P-CAD Schematic and P-CAD PCB, you must 
translate them first using Library Executive. Once your libraries have been translated, if you intend 



Chapter 13: Extended Library Features Import and Export from External Sources 

192 Library Executive User’s Guide 

to use them with both P-CAD applications, you need to merge the converted pattern libraries into 
the converted symbol libraries. 

This section uses a simple example to walk you through three conversion scenarios: 

• You want to convert Tango-PCB libraries into P-CAD format. 

• You want to convert Tango-Schematic into P-CAD format. 

• You want to create integrated P-CAD libraries from converted pattern and symbol libraries. 

Conversion Example 
For this example, make the following assumptions: 

• You have two Tango-PCB pattern libraries: pcb1.lib and pcb2.lib. 

• Pcb1.lib contains a pattern called DIP14. 

• Pcb2.lib contains a pattern called LLC20. 

• You have one Tango-Schematic library: sch1.lib. 

• Sch1.lib contains two components called SN5400J and SN5400FK. 

• Component SN5400J has a reference to a pattern called DIP14. 

• Component SN5400FK has a reference to a pattern called LLC20. 

Tango-PCB Only 
To translate your Tango-PCB pattern libraries, choose the Library » Translate command. The Library 
Translate dialog appears. 

1. First, you would translate pcb1.lib. 

2. Click the Source Library button to display the Library File Listing dialog, where you can choose 
your pattern libraries. In this example, choose pcb1.lib. 

3. Select the Tango-PCB (DOS) option button in the Source Format frame. 

Note that the only available destination format is P-CAD Binary. 

4. Click the Destination Library button to display the Library File Listing dialog, and type a name 
for your destination library. In this example, type accpcb1.lib. 

Your dialog now appears as follows. 
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5. Click Translate to begin the translation process. 

6. Repeat the process for each pattern library you want to convert. In this example, translate 
pcb2.lib, and name it accpcb2.lib. 

7. Click Close to exit the dialog.  

The translated libraries are now ready to use with PCB, but not with P-CAD Schematic, because 
they don't have symbol information. You can add symbols to the library, or you can merge this 
library with another library having symbols as described in the Library » Merge Patterns command. 

Tango-Schematic Only 
To translate your Tango-Schematic symbol libraries, choose Library » Translate. The Library 
Translate dialog appears. 

1. For this example, we’ll translate sch1.lib. 

2. Select the Source Library option button to display the Library File Listing dialog, where you can 
choose your libraries. Choose sch1.lib. 

3. Select the Tango-Schematic (DOS) option button in the Source Format frame. 

The only available destination format is P-CAD Binary. 

4. Click the Destination Library button to display the Library File Listing dialog, and type a name 
for your destination library. Type prosch1.lib. 

Your dialog now appears as shown in the following figure. 
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5. Click Translate to begin the translation process. 

6. Repeat the process for each symbol library you want to convert. 

7. Click Close to exit the dialog.  

The translated library is now ready to use with P-CAD Schematic, but not with PCB because it 
doesn't have pattern information. You can add patterns to the library or you can merge this library 
with another library having patterns as described in the Library Commands chapter. 

Naming Symbols 
Symbol names in translated Schematic libraries now have the destination library as a name prefix. 
Each symbol in a translated library is assigned a unique symbol name as follows: 

DESTLIB_XX_A 

where DESTLIB is the name of the destination library, XX is a unique number, and A equals 
N(ormal), I(EEE), or D(eMorgan). 

Tango-PCB and Schematic 
When all your pattern and symbol libraries have been converted to P-CAD format, choose Library 
Merge Pattern to merge pattern and symbol libraries into integrated pattern/symbol/component 
libraries which can be used by all P-CAD applications.  

In this example, merge accpcb1.lib and accpcb2.lib into prosch1.lib. 

1. Choose Library » Merge Patterns to display the following dialog. 
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2. Click the Add Library button to display the Library File Listing dialog, where you can choose 
libraries containing patterns. The library names you add appear in the Source Libraries box. 

You need to select all the pattern libraries that contain the patterns referenced in all 
components in the destination library. In this example, choose accpcb1.lib and 
accpcb2.lib.  

3. Click the Destination Library button to display the Library File Listing dialog, where you can 
choose one of your symbol libraries as the destination library. In this example, you would 
choose prosch1.lib.  

4. Click Merge to begin the process. For every component in the destination library, the program 
searches the pattern libraries for the corresponding pattern. The libraries are searched in the 
order they appear in the list.  

5. Repeat the process for each symbol library. 

6. Click Close to exit the dialog.  

Your destination libraries should now be fully integrated and ready to use with both P-CAD 
Schematic and PCB. Following this example, prosch1.lib is a fully integrated library. 
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CHAPTER 14 

File Commands 

In P-CAD Library Executive, the File menu commands allow you to import component information 
from any component library or database in a simple character-delimited file format. A P-CAD library 
of the imported components can be generated or updated, if desired. Importing data from an 
external source is one of the many Library Executive enhancements. 

Any other Library executive features can be accessed from the File menu, including Query, Verify 
and Reports. 

File Import 
In P-CAD Library Executive, you can import a file containing component information from a variety 
of sources, including your corporate component database. The incoming file must be a simple 
separated list format. The separated list file format is described in Importing Data from an External 
Source (page 121). 

The File Import command completes the first step of importing component data from an external 
source. The second step is to convert, or map, the file contents to attributes recognized by P-CAD 
by choosing either the Map Keys or Cross Link commands.  

The imported component data file creates or updates a P-CAD library; and you can Query, Verify 
and Report on the imported components. 

The Import Separated List File Dialog 
The Import Separated List File dialog is opened using one of the following methods: 

• Choose File » Import. 

• Select the root of the Source Browser tree and choose New Character-delimited File from the 
shortcut menu.  
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The Import Separated List File dialog allows you to specify the external source file and its 
organization with the following options: 

• Browse: Opens a dialog where you can navigate to and select the external source file to import. 

• First line contains field names: Select the First line contains field names option button if the 
first line of the separated list source file contains the field name headers for the field values. 
These names appear on the file Viewer. 

• Generate default field names: Select the Generate default field names option button if the first 
line of the separated list source file does not contain field name headers. Default field names 
appear on the file Viewer. 

• List Separator: Select from the list or enter the character you want to use as a delimiter in the 
List Separator box.  

• Comment Character: Select from the list or enter the character you want to use as the 
Comment Character. 

Importing a Separated List File  
To import a separated list file into P-CAD Library Executive, follow these steps: 

1. Choose File » Import to open the Import Separated List File dialog. 

2. Click Browse to navigate to and select the file containing the separated list file. 

3. Click Open. The name of the file to be imported is displayed next to the Browse button. 

4. If the first line of the separated list file contains field names, select the First line contains field 
names option button. 

If the first line of the separated list file does not contain field names, select the Generate 
default field names option button. Default field names are attached to the imported data. 

In both cases, the imported field name headers must be mapped to field names recognized by 
P- CAD in the second stage of the import process. 

5. Click OK. The Viewer dialog appears with the file contents in a spreadsheet format.  
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File Map Fields 
When importing a separated list file from a non-P-CAD source, the imported field names can be 
associated with field names recognized by P-CAD. These fields are properties and attributes that 
define a complete, intelligent component. This association can be completed by choosing the  
File » Map Fields or File » Cross Link commands.  

Map Fields is preferable when the imported file contains the P-CAD primary key, 
ComponentName. With Map Fields, the mapping is remembered so that subsequent external 
source file imports are mapped automatically. 

Cross Link is preferable when the database does not contain a ComponentName field. Cross Link 
initially requires that the component database index number be linked to the corresponding 
P-CAD library component. Once this association has been completed, an external source file 
without a ComponentName may be directly connected to P-CAD library components. Refer to File 
Cross Link (page 201) for additional information. 

The Map Fields Dialog 
The Map Fields dialog is opened when you choose Map Fields from the File menu or Viewer Table 
menu, or by selecting the external source file in the Source Browser tree and choosing Map Fields 
from the shortcut menu. 

The Map Fields dialog appears as shown in the following figure. 

 

The Map Fields dialog is a spreadsheet. Refer to Library Basics (page 3) for information about 
spreadsheet editing and manipulation. 

The Map Fields dialog allows you to specify the new field names and data types to which the 
original fields are mapped. The spreadsheet contains the following columns: 

• Original Field Name: Lists the field names of the imported external source file along with the 
original field names. New rows can be added to generate a one-to-many mapping. For details, 
refer to Using the Map Fields Command (page 200). 

• New Field Name: Lists the field names to which the fields of the imported external source file 
are mapped along with the P-CAD-recognized field names.  
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• Data Type: Contains the data type of the field to be mapped: Integer, String, or Boolean. 
Modifying the data type is used for search and display purposes only.  

Using the Map Fields Command 
After the external source file has been imported into P-CAD Library Executive, you can map the 
field names to the predefined field names recognized by P-CAD. 

Map Fields maps the original separated list file. Any modifications made to the file contents within 
the Viewer will be lost when the Map Fields command is used. To save these modifications, choose 
Save To Library before mapping.  

To map the imported fields: 

1. Choose File » Map Fields to open the Map Fields dialog. 

2. Click in the New Field Name column. A down arrow appears at the right of the selected field 
name. 

3. Click the Down Arrow to display the list of field names. 

4. Select the desired P-CAD field name. The field is automatically placed on the spreadsheet and 
the field type is automatically updated in the Data Type column. 

You can modify the Data Type from the list of data types in the third column. Modifying the 
data type from its default value may be desired for two reasons:  

• Sort order: The Integer and String data types have different sorting orders.  

• Display: Selecting Boolean data type changes Integer 0/1 values to True/False and vice 
versa. 

Read-only attributes are for search and display purposes only. The default data type, String, is 
always used when saving the remaining attributes to a P-CAD library. 

Read-only attributes cannot be modified or saved to a P-CAD library. These attributes are 
displayed in red on the imported file Viewer. 

When the Original Field Name is mapped to a New Field Name, the field type is automatically 
updated in the Mapping column. The field type indicates whether the attribute is a primary 
key, a predefined attribute, or a user-defined attribute. 

5. Click the Add Row button to append a row to the end of the table. A list of original field names 
becomes available in the first column. You can map the original field name to more than one 
P-CAD recognized field name.  

This one-to-many mapping is useful when your corporate database is indexed differently than 
a P- CAD library. For example, the database contains two 7400 components produced by two 
different manufacturers. The database field Part Number can be mapped to both a 
ComponentName field, which must be unique for P-CAD products, and a user-defined 
PartNumber field, which is the original name 7400.  
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Click the Delete Row button to delete a selected row. 

You can only delete rows that have been added to the table. 

6. When all Original Field Names have been mapped to their desired New Field Name, click the 
Map button. The Viewer reappears with the fields mapped to the chosen P-CAD values. The 
identifier (mapped) appears next to the mapped file name. 

Library Executive remembers the specified field mapping for the latest mapped file. If changes 
are made to the corporate component database every week, and you map the fields today, 
then next week when you import the database to verify your P-CAD library the mapping is 
completed automatically.  

If you map a file with the same filename but different field names than the previously mapped 
file, the original mapping will be overwritten. 

File Cross Link 
When importing a separated list file from a non-P-CAD source, the imported field names can be 
associated with field names recognized by P-CAD. These fields are properties and attributes that 
define a complete, intelligent component. This association can be completed by choosing either 
File » Map Fields or File » Cross Link.  

Cross Link is preferable when the database does not contain a ComponentName field. With Cross 
Link, the initial association between the external source file index and its respective P-CAD library 
component is created before linking. The unique index identifier(s) are stored as user-defined 
attributes within the P-CAD library. The subsequent external source files need only contain this 
database index value to connect directly with their associated P-CAD library components. The 
primary key, ComponentName, is not necessary. 

Map Fields is preferable when the imported file contains the P-CAD primary key, 
ComponentName. With Map Fields, the mapping is remembered so that subsequent external 
source file imports are mapped automatically. Refer to File Map Fields (page 199) for additional 
information. 

The Cross Link command is also available from the Viewer Table menu or the Source Browser for 
imported source files, P-CAD libraries, Query Results and Cross Link Results. As with the File » 
Cross Link command, a selected attribute(s) in the cross link source is linked to the target P-CAD 
library or library set.  

The Cross Link Dialog 
The Cross Link dialog is opened when you choose Cross Link from the File menu or Viewer Table 
menu, or by selecting the external source file in the Source Browser tree and choosing Cross Link 
from the shortcut menu. 

The Cross Link dialog appears as shown in the following figure. 
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The Cross Link dialog allows you to specify the field used as the unique external source file index, 
as well as the library or library set to which the source file is linked. The Cross Link dialog contains 
the following options 

• Select Source Fields to Cross Link: Lists the field names of the imported external source file.  

• Select Target Library/Set to Cross Link: Contains a tree of all libraries available to P-CAD Library 
Executive.  

Using the Cross Link Command 
To cross link the imported field, an initial association must be made between the unique index 
value(s) in the external source file and the corresponding components in the P-CAD libraries.  

The Cross Link command links the source files as they are in memory. If changes have been made 
to a library used as the cross link source or target, choose Reload to refresh the library components 
in Library Executive’s memory before conducting the Cross Link.  

To cross link the imported fields: 

1. Choose Cross Link from the Table menu of the Viewer to open the Cross Link dialog. 
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You can also choose the Cross Link command from the File menu on the main Library 
Executive dialog or from the shortcut menu when the imported external file is selected. 

2. In the Select Source Fields to Cross Link list, select the check box to the left of the field 
name(s) you want to use to link to the P-CAD component libraries.  

3. In the Select Target Library/Set to Cross Link list, expand the library groupings by clicking the + 
sign to its left. Navigate to and select the desired target library or library set.  

4. Click OK. 

The selected library is searched for the chosen source field. When a component with a matching 
source field is found in the library, the component information is displayed in the Cross Link Result 
Viewer. 
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The Cross Link Result Viewer is a spreadsheet; attributes found in both the source file and the 
library are displayed. Across the top of the table are the fields found in the source and library. If a 
field name is found in both source and library, values from the library field are distinguished by 
their column header TARGET:FieldName. The field values for each of the components are listed in 
the appropriate column. 

The Cross Link Result Viewer dialog is a spreadsheet. Refer to Library Basics (page 3) for details on 
manipulating spreadsheets. 

File Query 
The File » Query command opens the Query dialog. From this dialog, a query can be conducted on 
the components of the imported external source file. The Query dialog may also be accessed 
through the Table menu on the Viewer dialogs or from the shortcut menu in the Source Browser 
for query results, cross link results, imported files, or P-CAD libraries.  

The Query dialog appears. 
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The Query dialog allows you to specify search criteria to look for components in the selected 
source. You can specify search and display fields, search criteria and output options.  

• Set All/Clear All: Click the Set All button to display all fields defined in the selected source in 
the Field column. Click Clear All to remove all fields from the Field column. 

• New Result Table: Select this check box to generate an additional query result table. If the 
check box is cleared, the present query overwrites the previous result. 

• Query Spreadsheet: The Field column contains both the search and display attributes for the 
query. The Show column is selected if the field is to be displayed in the query result. The 
Criteria (And) and Or columns display the query search criteria.  

• Add Row/Add Column: The Add Row button adds a row to the query table if you wish to 
duplicate an attribute already on the Query dialog. The Add Column button adds another Or 
column to the Query dialog. 

• Query: Click the Query button to search the selected source for components satisfying the 
specified criteria. 

Refer to Querying Libraries (page 103) for more information. 

File Save To Library 
The File » Save To Library command opens the Save Source dialog. From this dialog, a P-CAD library 
can be created or updated from the components of the imported external source file. The Save 
Source dialog may also be accessed through the Table menu on the Viewer dialogs or from the 
shortcut menu in the Source Browser for query results, cross link results, imported files, or P-CAD 
libraries.  

The Save Source dialog appears as shown in the following figure. 
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The Save Source dialog allows you to create or update a P-CAD library using components from the 
selected source. You can specify the library name, save mode and update options.  

• Source: The source contains the components that are saved to the library. It is defined by the 
location from which you selected the Save To Library Command. If Save To Library is chosen 
from the File menu, the source is the imported external source file. If Save To Library is chosen 
from the Source Browser shortcut menus, the source could be a Query Result, a Cross Link 
Result, an external source file, or a P-CAD library.  

• The Save to Library command saves only component attributes. To create a complete, 
integrated component both the electrical and graphical properties must be specified.  

• Save Mode frame: Create New creates a new P-CAD library from the selected source. Update 
updates the selected P-CAD library according to the update criteria for specific attributes. 

• Library: Click the Library button to select the name and directory of the P-CAD library to be 
updated or created. You can also type the name of the library directly into the box. 

• Create new components: If selected, components in the source that are not found in the 
selected library are added to the library when updated. 

• Update only components with matching library name: If selected, components are updated in 
the P-CAD library only if both the ComponentName and the ComponentLibrary field values 
match. 

• Create component time stamps if not present: If selected, the time stamp attributes CreateDate 
and ModifyDate are added to the component with the current date and time value.  

• Attributes to be Created: Lists the attributes in the component source.  

When creating a library, select the Ignore column for attributes you do not wish to generate in 
the library output.  

When updating a library, select the Ignore column for attributes you do not wish to compare to 
the target library. For the remaining attributes, select either the Favor Library or Favor Source 
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check boxes to resolve conflicting attributes. If attribute values differ in the source and library, 
selecting Favor Source updates the attribute, whereas selecting Favor Library does not. 
Attributes in the source that are not found in the library are added to the library if the Ignore 
column is cleared. 

File Verify 
The File » Verify command opens the Verification dialog. From this dialog, the components of the 
imported external source file can be compared to those of a P-CAD library and a difference report 
is generated.  

The Verify command compares component attributes only. Attributes of the attached symbols and 
patterns are not included in the difference report.  

The Verify dialog may also be accessed through the Table menu on the Viewer dialogs or from the 
shortcut menu in the Source Browser for query results, cross link results, imported files, or P-CAD 
libraries.  

The Verify dialog appears. 

 

The Verify dialog allows you to check for differences between selected attributes and a P-CAD 
library or library set. You can specify the attributes to verify, the target components and output 
options.  

• Select Source Attributes to Verify: When the attribute in the Select Source Attributes to Verify 
check box is selected, the attribute is compared to the attributes of the components in the 
target library or library set.  
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• Select Target Library Set/Library to Verify: When the library or library set in the Select Target 
Library Set/ Library to Verify box is selected, the components in the library or library set are 
compared to the component attributes of the source.  

• Browse: Click the Browse button to navigate to and select the directory and file name of the 
output difference report. The path to the desired file can also be typed directly into the box. 

• View Report: Select the View Report check box to display the difference report file on the 
screen. 

• List components not found in library: If selected, the components in the source file are listed in 
the difference report when a component with matching ComponentName is not found in the 
library. 

• Verify only components with matching library: If selected, the source attributes are compared 
only in components that have identical ComponentName and ComponentLibrary field values. 

If the selected source does not have a ComponentLibrary attribute, this check box is ignored. 
All attributes in the selected source are verified. 

• Set component verify timestamp: When verifying a library, the component’s time stamp 
attribute VerifyDate, if present, is automatically updated with the current date and time. If the 
Set component verify timestamp check box is selected and the VerifyDate attribute does not 
exist, the VerifyDate attribute is added to the component library. 

• Verify: Click the Verify button to generate the difference report. 

Refer to Library Verification (page 137) for more information. 

File Report 
The File » Report command opens the Report dialog where you can generate a report on the 
imported external source file. The Report dialog may also be accessed through the Table menu on 
the Viewer dialogs or from the shortcut menu in the Source Browser for query results, cross link 
results, imported files, or P-CAD libraries.  

The Report dialog appears. 
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The Report dialog allows you to define the format of the report. You can specify the report format, 
the report style format and output options. 

• Header/Footer: When the Report Style Format is selected, you can enter any header or footer 
text you want to appear on the query output.  

• Page Format frame: Use Header and Use Footer include the information you specified in the 
header and footer dialog fields. Date/Page includes the current date and the page number. 
Pagination allows you to create your own pagination (lines per page). Page Format is activated 
when the Report Style Format is selected. 

• Style Format frame: Delimiter Separated puts all data in separated list format. This format can 
be imported into other spreadsheet and database programs. Report produces a report format 
with columns and spaces, etc. 

• Output Destination frame: The options in the Output Destination frame determine the source 
of your output. Screen sends the output to a file and opens the file using the selected File 
Viewer. File sends the output to a file. Printer sends the output directly to the current printer. 

• List Separator: Choose a separator character from the list or enter the character in the box. 

• Lines per Page: Allows you to specify the number of lines per page in your query report. 

• Column: Allows you to specify the number of columns per line. 

• Output Filename: Displays the name of the report if you choose to save it to a file. The default 
filename is library.rpt. Click the Filename button to change the default name. 

• Filename: Click the Filename button to designate a report name other than the default name. 
The filename appears in the Output Filename box. 

Generating a Report File 
To generate a report on a query result, cross link result, an imported file, or a P-CAD library: 

1. Choose the Report command to open the Report dialog.  
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Other reports can be generated by selecting the item (query result, cross link result, imported 
file, or P-CAD library) in the Source Browser tree and selecting Report from the shortcut menu. 

2. Select the desired report format check box in the Style Format frame. 

If you choose Delimiter Separated, a character-delimited report output is generated 
automatically, with formatting specifications.  

If you choose Report, an ASCII report file is generated. The ASCII report is more readable and 
formatting specifications can be applied to the Page Format, Header, Footer, Lines per Page 
and Columns. Choose the desired page formatting by selecting the appropriate check boxes.  

3. Select the desired file output destination, Screen or File. 

If File is selected, define the Output Filename by typing the name in the box or clicking the 
Filename button and navigating to the desired file.  

4. Click Generate. The report file is generated and either saved to the specified file, displayed 
directly on the screen, or printed. 

File Exit  
The File » Exit command closes Library Executive. 

If you have an unsaved component, you will be prompted as to whether you want to save changes 
before you exit the program. 
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CHAPTER 15 

Library Commands 

Using the Library Commands 
With the Library commands you can create new libraries, add new item aliases, copy items from 
one library to another, delete library items, or rename library items. You can also update older 
version libraries, translate Tango format libraries into P-CAD format, and merge pattern and symbol 
libraries into integrated libraries. 

P-CAD libraries combine patterns, symbols and components. These sections of a library represent 
all of the information for a component, such as component pin assignments and other electrical 
information, and the graphical pattern and symbol structure. Patterns and symbols referenced by a 
component must reside in the same library as the component.  

Library New 
Library » New allows you to create a new, empty library. 

Library Setup 
A library set is a group of P-CAD library files. You can perform several Library Executive operations, 
such as query and verify, directly on a library set by choosing the Library » Setup command. 

You can organize and manage library file names and library sets in the Library Setup dialog.  
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 The Library Setup dialog allows you to define the libraries contained within a library set.  

• Library Sets frame: Lists the presently defined library sets. Selecting a library set from the 
Library Sets list displays the libraries contained in the set, in the Members list. Within the 
Library Sets frame, the following activities are available: 

• Add Set: Allows you to specify the name of a new library set. 

• Delete: Deletes the selected library set. Deleting a set removes the set and the libraries it 
contains. 

• Rename: Allows you to rename the selected library set. 

• Members frame: Displays the libraries that are contained within a selected library set. Within 
the Members frame the following activities are available: 

• Add Library: Adds a library to the selected set 

• Remove: Removes the selected library from the library set. 

To be usable in P-CAD Library Executive, all available libraries must be in one or more library sets. A 
default library set, called DEFAULT_LIBRARY_SET, includes any open library files that do not have a 
set specified explicitly.  

Library sets defined in the Library Setup dialog are saved in the initialization file, cmp.ini, for the 
next time you run Library Executive. 

You can add, rename and delete selected libraries and library sets directly from the Source Browser 
by choosing Delete from the shortcut menus. 

Library Alias 
An alias is an alternate name for a component, pattern or symbol. You can create multiple names 
for the same item with the Library » Alias command. Aliases allow you the flexibility of using a 
variety of naming conventions for components, patterns, or symbols without renaming them. For 
example, for what P-CAD calls an SN7400N, you may want to use a generic alias of 7400. Or, if you 
have components from a vendor using a particular naming convention, and you want to continue 
using that system, you can use alias names and display them on your design as such. 

An alias is equivalent to creating a new item except the actual data is only referenced not copied. 
When an alias is created for an item, it is not the same as creating copies or renaming. For copying 
or renaming, see the respective Library commands.  

The library that you use in the execution of Library » Alias, Library » Delete, or Library » Rename will 
remain current if you invoke any of the commands during the same Library Executive session. 

Creating an Alias 
1. Choose Library » Alias to open the Library Alias dialog.  
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2. Select the Component or Pattern or Symbol option button in the Alias Item frame. 

3. If the appropriate library is not current, click the Library button to navigate to and select the 
library you want, click OK and the Alias dialog is redisplayed.  

4. Click the button below the Library button to open the Library Browse dialog where you can 
select the desired Component, Pattern or Symbol. Select the desired item and click OK.  

 

5. When you return to the Library Alias dialog, the Pattern, Component, or Symbol you chose is 
displayed in the Pattern, Component, or Symbol list. Enter the desired alias name in the New 
Alias box. Click Add and the new alias is listed in the Aliases list. 
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Library Pattern Graphics 
When you choose Library » Pattern Graphics, the resulting Library Pattern Graphics dialog allows 
you to open a source library, choose a target pattern to which you want to add additional pattern 
graphics and then search through a list of all patterns in the library and select a pattern graphics to 
attach to the target pattern. This assignment of pattern graphics within a library can only be carried 
out using Library Executive. Orientations of the pattern graphics can also set here. 

Target Pattern Tab 
This tab of the Library Pattern Graphics dialog allows you to nominate a target pattern from a 
selected source library, for the purpose of attaching additional pattern graphics. 

 

The following fields are available: 

• Library Button: Click this button to launch the Library Select dialog, from where you can 
browse to open the required library. This is your selected source library. The name of the 
opened library is displayed to the right of the button. 

• Target Pattern: This field shows the current, nominated target pattern, from the source library. 
The target pattern is the pattern that you will attach additional pattern graphics to. The 
dropdown list contains all the patterns in the selected source library. By default, the first 
pattern in the library is entered into the Target Pattern field. To nominate a different pattern, 
just click on an entry in the list. 

• Pattern Graphics List Window: This list window shows all of the pattern graphics attached to 
the nominated pattern in the Target Pattern field. The default pattern graphic for a pattern is 
called ‘Primary’. As more pattern graphics are added to the target pattern, this list updates to 
show all pattern graphics that are currently attached. 
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• Pattern Graphics Visual Window: This window gives a graphical representation of the pattern 
graphic selected in the Pattern Graphics list window. The default display is for the Primary 
pattern graphic. 

Alternates Tab 
This tab of the Library Pattern Graphics dialog allows you to browse through all of the patterns in 
the source library and attach any of the pattern graphics associated with these patterns to your 
nominated target pattern. 

 

The following fields are available: 

• Source Pattern Graphics Frame: This frame is used for browsing the patterns in the source 
library for pattern graphics that you want to attach to the target pattern. The available fields are: 

• Source Patterns: This scrollable list window contains all of the patterns within the source 
library. You can browse the pattern graphics that are attached to each pattern by selecting 
that pattern from the list. The attached pattern graphics are listed in the Pattern Graphics 
list window. 

• Pattern Graphics: This window lists all of the pattern graphics associated with the pattern 
selected in the Source Patterns window. Click on an entry to highlight it, if you wish to 
attach it to your target pattern. 

• New Name: This field shows the current name for the selected source pattern graphic. By 
default, the name is the same as the name of the graphic selected in the Pattern Graphics 
window list. If you want to call the pattern graphic you are attaching by a different name, 
just type the new name into the field, overwriting the default. 

• Copy to Target Button: Click this button to attach the selected source pattern graphic to 
your nominated target pattern graphic. 
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• Target Pattern Graphics Frame: This frame contains a window that displays all of the pattern 
graphics attached to the target pattern. As pattern graphics are copied from the source 
patterns, using the Copy to Target button, they appear in this window. If you decide that a 
certain pattern graphic that has been copied to the target is incorrect or not required, it can be 
removed using the Remove From Target button. 

• Pattern Graphics Visual Window: This window gives a graphical representation of the pattern 
graphic selected. It is shared by both the Source Pattern Graphics and Target Pattern Graphics 
frames. By default, the Primary pattern graphic of the first pattern in the Source Patterns list is 
displayed. 

Orientations Tab 
This dialog allows you to specify which pattern graphics are to be used for a specific orientation.  

 

The dialog contains the following fields: 

• Primary Pattern Graphics: This field allows you to select which pattern graphics are the 
primary (or default) pattern graphics for the pattern. The drop down list shows all of the 
associated pattern graphics for the pattern. The default entry is ‘Primary’. You can select any of 
the pattern graphics in the list to change the default primary pattern. 

• Top and Bottom Rotation Frames: This frame contains editable fields for selecting which of the 
associated pattern graphics will be used for specific rotations. Up to eight different pattern 
graphics can be used to represent various component orientations, depending on whether the 
component is flipped (Bottom Rotation) or unflipped (Top Rotation) and whether it is rotated 
by 0°, 90°, 180° or 270°. By default, all fields will be filled with the name of the selected Primary 
pattern graphics. To select a different pattern graphic for a rotation, left-click on an entry in the 
drop down list. 

The Primary pattern graphic will be used for all other rotations. 
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• Display Window: The display window on the right hand side of the tab gives a graphical 
representation of the pattern graphic selected. The window is shared by the Primary Pattern 
Graphics field and the individual rotation fields. Selecting an entry in any of these fields will 
display the corresponding pattern graphic in the window. 

• Display Pattern in Orientation: This check box allows you to view the selected pattern graphic 
from the Rotation frames in terms of its actual orientation. If you check this box, you will be 
able to see how the graphic will appear when the component is placed with a particular 
rotation. If this box is unchecked, you will see the default, Top Rotation, 0° entry. 

• Use Rotation: This check box allows you to enable/disable the orientations section of the page, 
for editing purposes. This is especially useful if you don’t want to work on all specific rotations. 
If the box is checked, all of the specific rotation fields are enabled and you can set specific 
pattern graphics to specific orientations. If this box is unchecked, the Top Rotation 0° field is 
available only. All other specific orientation fields are disabled. This command, enabled or 
disabled, only applies whilst you are actually in the Orientations tab. 

• Apply Pattern Changes to Library Button: When you have made all of the changes that you 
want to make to the pattern graphics orientations, click the Apply Pattern Changes to Library 
button to update and save to the source library, the changes you have made to the target 
pattern. 

• OK and Cancel Buttons: Use the OK button to close the dialog after having updated and saved 
the pattern to the source library using the Apply Pattern Changes to Library button. Use the 
Cancel button to exit the dialog without effecting any changes made. 

Library Copy 
The Library » Copy command copies an item from one file to another. You can copy more than one 
object at a time from one library to another.  

When you copy a component, you can also copy the pattern and symbol that it references. 

The source and destination libraries designated remain current for the length of the P-CAD session. 

Copying a Library Item 
1. Choose Library » Copy to open the Library Copy dialog. 
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2. Click Source Library to open the Library Select dialog. 

3. Select the source library and click OK. 

4. Click Destination Library to open the Library Select dialog again. 

5. Select the destination library and click OK. The Library Copy dialog displays the paths and 
filenames of the source and destination libraries you selected. 

6. In the Copy Item frame select the type of object you want to copy: Component, Pattern or 
Symbol. The names of the available objects for the selected type appear in the Multiple Source 
Names box.  

7. To select items to copy, choose one of the following key combinations: 

• Left click selects a single object. When a single object is selected, you can enter its 
destination name in the Single Destination Name box. 

• SHIFT+Left Click selects all objects between the last selected object and the next object 
you click on. 

• CTRL+Left Click adds or removes an object from the selection. 

8. Click the Browse to Add button to add selected, single objects to the your selection and click 
OK.  

9. Select your Destination Preferences: Overwrite Items in the destination file, Preserve Items to 
maintain the existing objects, Copy Patterns w/component or Copy Symbols w/component. 
The last two check boxes are available only when copying components. 
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10. Click Copy. The selected objects are copied from the source library to the destination library. 

If you copy an alias into a destination library, Library Executive creates a new component from that 
alias. The destination library now contains an alias that is an actual component. 

Library Delete 
The Library » Delete command removes a selected library item.  

This command deletes the item in name only, if it has aliases. The alternate names (aliases) still exist 
unless you delete them. If an item has only one name and it is deleted, then the item itself is 
deleted from the library. The Library » Alias command provides a way to check an item for an alias. 

The library that you designate in the execution of Library » Alias, Library » Delete, or Library » 
Rename remains current for the length of the Library Executive session. 

If you delete a pattern or symbol, the components in the library that reference that pattern or 
symbol become incomplete and cannot be placed. To prevent this, delete only a pattern alias or 
symbol alias. 

Deleting a Library Item 
1. Choose Library » Delete to open the Library Delete dialog. 

 

2. Click the Library button to open the Library Select dialog where you can navigate to and select 
the library from which you want to delete an item. The selected library is displayed in the 
Library Delete dialog.  

3. Select the desired Delete Item option button (Pattern, Component or Symbol) and the items 
within the displayed library will be listed in the Library Browse dialog. Select one to list it in the 
Component, Pattern or Symbol box of the Library Delete dialog. 

4. Click the Delete button and the item box becomes blank.  

To continue deleting items, follow steps 3 and 4 until you have deleted all the desired items 
from the library. 

5. Click Close to exit the dialog. If you click Close before Delete, the dialog closes and any 
pending delete is ignored.  
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Library Rename 
The Library » Rename command renames a pattern, symbol, or a component. 

If you rename a pattern or symbol, all components in the library that reference that pattern or 
symbol by the original name become incomplete and cannot be placed. To use a different naming 
convention for a pattern, symbol, or component, create an alias for the pattern or symbol by 
choosing the Library » Alias command and use that alias name. 

Renaming a Library Item 
1. Choose the Library » Rename command to open the Library Rename dialog. 

 

2. Click the Library button to open the Library Select dialog, where you can navigate to and select 
the desired library. 

3. In the Rename Item frame, select the type of item to be renamed (Pattern, Component or 
Symbol). Those types of items within the library are listed in the Library Browse dialog.  

4. Select an item to display it in the item list of the Library Rename dialog. 

5. In the New Name box, type the new name of your item. 

6. Click Rename. Both the old name and new name disappear if the rename action is successful. 
You can continue renaming items in the same library by following steps 3 through 5. 

7. Click Close to exit the dialog. If you click Close before Rename, then the dialog closes and 
ignores the pending rename.  

Library Translate 
Translates libraries in the following formats into P-CAD binary and ASCII-formatted libraries. 

• P-CAD Binary 

• P-CAD ASCII 

• TangoPRO Binary 

• TangoPRO ASCII 

• Tango-Schematic (DOS) 
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• Tango-PCB (DOS) 

• PDIF 

P-CAD uses one integrated library that contains components, symbols and patterns. These 
integrated libraries are used by all P-CAD applications. 

PCB makes certain checks when components are added to a PCB design. In particular, the symbols, 
pattern and pin attributes like gate equivalence found in the library for a component are compared 
to those for any components of the same type already present in the design. If the components are 
not the same, PCB reports that the components do not match and does not allow you to add the 
component to the design. The following recommendations should be considered when adding 
components: 

• PCB designs created using previous versions of P-CAD PCB or P-CAD PCB (6/400) using pattern 
libraries should be loaded into PCB with only pattern libraries open. 

• If you encounter a component cache error after using Library Executive to change a 
component that is already placed in a PCB design, you must update all occurrences of that 
component in the design. This must be done before you can place any more instances of that 
component. Choose the Force Update command to replace all occurrences of a component of 
a single type. 

• The Maintain Rotation option in Utils Force Update does not maintain rotations for 
components in designs loaded from P-CAD PCB (6/400). 

Using the Library Translate Command 
1. Choose Library » Translate to open the Library Translate dialog. 

 

2. Click the Source Library button to open the Library File Listing dialog, where you can navigate 
to and select the library to translate. 

3. Click the Destination Library button to open the Library File Listing dialog, where you can 
navigate to and select destination library. 
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4. Select the desired Source Format option button.  

If you select P-CAD Binary, select a Destination Format option button. 

5. Click Translate to begin the translation process. When the library has been translated, an error 
log file is generated and automatically displayed in the Notepad utility. The name of this file is 
Filename.err, where FILENAME is the name of the output library. 

6. Click Close to exit the dialog.  

PDIF Translation 
This section provides the steps you need to follow to create a fully integrated P-CAD library from a 
PDIF symbol library and its corresponding PDIF part library. 

Translating PDIF Symbol Libraries 
To create an integrated P-CAD library from PDIF symbol and part libraries, follow these steps: 

1. Choose Library » Translate to open the Library Translate dialog. 

 

2. In the Source Format frame, select PDIF. The PDIF Cross Reference and Pin to Padstack Map 
buttons appear in the dialog. 

The PDIF Cross Reference File contains power and ground pin assignments. It also attempts to 
group heterogeneous components and is not required for translating libraries. If you don't 
specify a cross reference file, an error message appears, indicating that the number of 
components pins created for a component does not match the number of entries created for 
that component in the PDIF file and that power pins might be missing. 

The Pin to Padstack Map button lets you select a pin mapping file (.pmf) that contains pin 
mapping information used to translate P-CAD PDIF part library files. P-CAD Library Executive 
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uses this pin mapping file to change padstack information to P-CAD pad styles. The pin 
mapping file is not used when translating symbol libraries. 

3. Click Source Library. The Library File Listing dialog opens where you can select the PDIF files 
available in the current directory. 

4. Select the desired PDIF file and then click OK. The Library Translate dialog reappears and 
displays the name of the source library next to the Source Library button. 

5. Click Destination Library. The Library File Listing dialog opens where you can type the path and 
name of the destination library. 

6. Click OK. The Library Translate dialog reappears and displays the name of the destination 
library next to the Destination Library button. 

7. Click OK again to open the Master Designer to P-CAD SCH Layer Mapping dialog. 

 

8. Select the desired layers and map them accordingly.  

9. Click OK.  

While loading, P-CAD Library Executive displays several messages indicating the system’s 
progress. After translating the library, a message box appears indicating any errors or warnings. 
If there are none, you can click Close. 

Translating PDIF Part Libraries 
Master Designer PDIF part libraries are translated just as you translate symbol libraries. The 
difference is that you select a PDIF part library file as your source library, instead of selecting a 
symbol library. 

The layer status of the first component ever entered in a part library sets the status for all other 
parts in that part library. 
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You can also map pin types in the PDIF Part library file to the pad styles during translation. This is 
useful for Master Designer users who want to bring padstack information into P-CAD Library 
Executive. To translate Master Designer binary part libraries, do the following: 

• Start the PIN2PAD utility in Master Designer. This program generates a pin mapping file (.pmf). 

• Load the pin mapping file into P-CAD Library Executive. This step maps the pin types to pad 
styles in P-CAD Library Executive. 

The PIN2PAD utility is a DOS program that is started from the command line. To start it you will 
need: 

• an external ASCII aperture table file (optional) 

• a special symbol file (.ssf) 

• a Master Designer binary part library file (.plb) 

To run the PIN2PAD utility, at the DOS prompt, enter: 

pin2pad <options> -s <special symbol file> -p <library file> 

where <options> are: 

 

<Options> Description 

-a specifies the aperture table file 

-h displays the help screen 

special symbol file specifies the special symbol file 

library file specifies the P-CAD binary part library file 

 

If you do not use an aperture table when running PIN2PAD, the program only translates the 
graphic information over to P-CAD. 

When you run PIN2PAD, the program creates the aperture section of the pin mapping file, which 
occurs only if you specify an aperture table file. Next, the program reads the special symbol file for 
the mapping between pin types and pad stacks. For each pad stack, the program loads the binary 
padstack file and writes the layer and graphic data. PIN2PAD also maintains a list of all the layers in 
all the pad stacks. The program uses the part library file's database unit as the database unit for the 
pin mapping file. If some padstacks in the special symbol file have different database units, 
PIN2PAD converts these database units to the part library file's database unit. 

PIN2PAD displays a warning message if any of the following occurs: 

• Any pin type that exists in the library file is not specified in the special symbol file. 

• PIN2PAD is missing, unable to locate or unable to load a pad stack file. 

• Apertures are specified in the pad stacks but not in the aperture table. 
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PIN2PAD saves the pin mapping file using the part library file's name. For example, if you run the 
program using the part file Parts.plb, the resulting pin mapping file is named Parts.pmf. 

Now that you've created the pin mapping file, load it into Library Executive by following these 
steps: 

1. Start Windows and then start P-CAD Library Executive. 

2. Choose Library » Translate to open the Library Translate dialog. 

3. In the Source Format frame select PDIF. 

The PDIF Cross Reference (.fil) and Pin to Padstack Map (.pmf) buttons appear. 

The Pin to Padstack Map button lets you select a pin mapping file (.pmf) that contains pin 
mapping information that the program uses for translating Master Designer PDIF part library 
files. 

4. Click the Pin to Padstack Map button to open the Library File Listing dialog. 

5. Select the desired pin mapping file, then click OK to return to the Library Translate dialog. 

6. Click the Source Library button to open the Library File Listing dialog that displays the PDIF 
files available in the current directory. 

7. Select the desired PDIF file, then click OK. The Library Translate dialog reappears and displays 
the name of the source library next to the Source Library button. 

8. Click Destination Library to open the Library File Listing dialog. 

9. Enter the name of the destination library, then click OK. The Library Translate dialog reappears 
and displays the name of the destination library next to the Destination Library button. 
Remember not to overwrite a symbol library with the same first name. 

10. Click OK. The Master Designer to P-CAD PCB Layer Mapping dialog appears. 
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11. Select the desired layers and map them accordingly. Then click OK. The translation of the 
P-CAD PDIF part library begins. 

While translating, several messages are displayed indicating the system’s progress. During 
translation, the program loads the pin mapping file, creates the new pad styles and maps the 
appropriate pins to the new pad styles. After translating the library, a message box appears 
indicating if there were any errors or warnings. If there are none, you can click Close. 

Mapping Layers in P-CAD Library Applications 
Mapping layers makes it easier for you to control the data that you carry across by selecting the 
desired layers. For each layer you select, the system translates the data on that layer. For each layer 
you don't select, the system ignores the data on that layer. 

When mapping layers in Library Executive, you need to be aware of a few points: 

• The system always maps the REFDES layer and brings over the data on that layer. 

• Some library data has visibility control and some does not. Graphic objects, such as circles, 
lines and rectangles, do not have visibility control and cannot be hidden or displayed in Library 
Executive. For these objects, the data is translated, mapped to the appropriate layer and 
displayed in your design. Other data, such as such as reference designator, component type 
and value, have visibility control. In this case, the data is translated, mapped to the appropriate 
layer, and hidden or displayed based on the layer visibility setting in Master Designer. For 
example, if the first component ever entered in the library has an attribute on the ATTR layer in 
Master Designer and that layer's visibility is set to ON or ABL, Library Executive translates this 
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data and displays it. On the other hand, if the ATTR layer is set to OFF, Library Executive sets 
this visibility to OFF. 

• When you translate a PDIF symbol library, the Master Designer to P-CAD SCH Layer Mapping 
dialog is opened. This dialog lets you select which layers to map and maps the desired layers. 

 

Layer Description 

Gate Graphics Layer Lists the target layers available for normal gate representation. 

Default Map Assigns all Master Designer layers to a default layer mapping 
structure. 

Select All Layers Selects all layers set to MAPPED or IGNORED. 

Unselect All Layers Deselects all layers set to MAPPED or IGNORED. 

Set Layer Mapped Instructs Library Executive to map this layer and translate its 
data. 

Set Layer Ignore Instructs Library Executive to ignore this layer and any data on it. 

OK Confirms your selections. 

Cancel Cancels the layer mapping and aborts loading the schematic 
design. 

 

When you translate a PDIF part library, the Master Designer to P-CAD PCB Layer Mapping dialog 
opens. 

Master Designer to P-CAD PCB Layer Map: Displays the Master Designer layer mapping 
assignments. A <NONE> next to the Master Designer layer name indicates that PCB will ignore data 
on that layer. A typical layer assignment looks like this: 

PADCOM Top SA 1 

where: 

• PADCOM is the Master Designer layer. 

• Top is the PCB layer assigned to the Master Designer layer PADCOM. 

• S indicates the layer’s status (S=signal, N=nonsignal, P=plane). 

• A indicates the autorouter bias (A=auto, H=horizontal, V=vertical). 

• 1 indicates the layer number. 

P-CAD Layer: Lists the PCB layers available for mapping. 

Map Selected Layer: Assigns the selected Master Designer layer to the selected PCB layer. 
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Create New Layer: Opens the Options Layers dialog so you can create a new layer or modify an 
existing one. 

Default Map: Maps the PCB design signal to signal, plane to plane, and non-signal to non-signal to 
non-signal to non-signal. This option saves you having to create layers manually. The default layer 
map set varies, depending on whether you select embedded aperture tables or pad graphics to 
convert your pad definitions. 

Auto Map All Layers: Automatically maps all unassigned Master Designer layers to PCB layers of the 
same name. If a layer does not have <NONE> next to it, PCB leaves the current assignment. 

Unassign All Layers: Assigns <NONE> to all the Master Designer layers in the list. 

Tool Table: Lets you select which tool table to use. Tool tables specify the hole size to use for each 
pad type in the converted design. 

Use Table: Indicates whether or not to use the Tool Table. PCB needs the tool table to apply the 
correct hole sizes. If you don’t specify a tool table, PCB uses a default hole size for the pad types. 

Polygons: Indicates to convert polygons to polygons. You should select this option if you never ran 
the Merge Polygon Voids command on the Environment Menu in Master Designer 8.5. 

Copper Pours: Instructs PCB to convert polygons to copper pours. Selecting this option 
automatically creates thermal ties to pads and vias in the same net. You should select this option if 
you want to preserve the voids in your design. 

Embedded Aperture Table: Instructs PCB to convert pad definitions from the design’s embedded 
aperture table. 

Pad Graphics: Instructs PCB to convert pad definitions from the design’s pad graphics. 

Important Layer Mapping Tips 
This section provides some important tips for mapping Master Designer layers to P-CAD layers. It 
also explains how Library Executive handles layers for which mapping is not recommended, as well 
as user- defined Master Designer layers. 

Component Layers 
• Component Silk Layers (SLKTOP, SLKSCR): Map these layers to the appropriate P-CAD top or 

bottom silk layers, Top Silk or Bottom Silk. 

• Assembly or Fab Information (DEVICE): Map these layers to the appropriate P-CAD top or 
bottom assembly layers. 

Pad Layers 
• Pad Shapes on Signal Layers (FLSOLD, FLCOMP, PINFTP): If your Master Designer pad shapes 

are defined using aperture flashes, map the flash layers to Top or Bottom, as appropriate. If 
your pad shapes are defined using graphics, map the graphics layers to Top or Bottom. 

• Paste, Mask and Drill Layers: Library Executive does not map these layers automatically 
because the solder mask swell and paste shrink sizes are determined automatically from the 
pad shape. 
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• Drill Symbol Layers (DRILL, FDRILL): Map these layers to <none>. Information on these layers 
is not used in pad definitions. Tool codes and Drill symbols can be assigned for each hole size 
for N/C Drill and Drill Symbol output in the PCB editor. 

• Paste and Solder Mask Layers (MSKGTP, SLDMSK, MSKGBT): Library Executive maps these 
layers to Top Mask or Bottom Mask. It is recommend that you map these layers to <none>. 

Plane Layers 
Plane layers are not mapped in Library Executive, so you get the default thermal on every plane 
layer that you create in your PCB design. Map these layers to <none>. 

Recognizable but unmapped Layers 
Layers that are recognized, but recommended not mapped, are mapped to <none>. It is 
recommended that you map internal signal layers to <none>. 

Unrecognizable Layers 
Any user-defined layers that are not in the list of standard Master Designer layer names are mapped 
to <ignored>. For instance, if you create a user-defined Master Designer layer TEST1, Library 
Executive maps this layer to <ignored>. 

Merging the Libraries 
To merge the libraries, choose Library » Merge Patterns. Select as the Source Libraries the PCB 
pattern libraries to be merged into the Destination Schematic library.  

Once the libraries have been merged into an integrated P-CAD library, you can delete the pattern-
only library or use it for PCB placement if you don’t need integrated library components. 

Library Merge Patterns 
The Library » Merge Patterns command copies patterns from one or more P-CAD libraries 
containing patterns into another P-CAD library that contains pattern references, but not actual 
patterns. This command is useful for merging entire libraries. If you want to integrate an individual 
component, use the Library » Copy command.  

After you translate a Tango Schematic symbol library and Tango pattern library to P-CAD format 
using the Library » Translate command, the Library » Merge Patterns command can be used as a 
way to merge the translated libraries into a single integrated library. 

1. Choose Library » Merge Patterns to open the Library Merge Patterns dialog. 
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2. Click the Add Library button to open the Library File Listing dialog, where you can choose 
libraries containing patterns. The library names you add appear in the Source Libraries list. 
Select all the pattern libraries that contain the patterns for the components in the destination 
library. 

Select a library and click the Remove Library button to remove a library from the Source 
Libraries list. 

3. Click the Destination Library button to open the Library File Listing dialog, where you can 
choose the destination library. This is typically a symbol library that has been converted to 
P-CAD format. The destination library shouldn't contain any patterns.  

4. Click Merge to begin the process. For every component in the destination library, the program 
searches the source libraries for the corresponding pattern. The libraries are searched in the 
order they appear in the list.  

If any patterns exist in the destination library a warning message appears. If you choose to 
continue, these patterns will not be replaced with patterns from the source libraries during the 
merge process. However, the pin mapping will be updated with the information from the 
source libraries.  

5. Click Close to exit the dialog.  

Library Publisher 
Library » Publisher generates complete, customizable reports directly in Microsoft Word. These 
reports can include pictures of the patterns and symbols in the library.  

Microsoft Word 97 is required for the Library Publisher utility. 

The Library Publisher Dialog 
When you choose Library » Publisher, the Library Publisher dialog opens. 
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This dialog is the point of access for the content and format options of the Library Publisher. These 
options are summarized below: 

• Source Library: Click the Source Library button to navigate to and select the directory and 
filename of the library you want to publish. 

• Save To: Click the Save To button to select the directory and filename of the output file. 

• Library Section: Select the Library Section check box to include a report on the selected library 
in the publisher output. The Library Format button becomes available, allowing you to select 
the contents of this section, including file name, size, component name list, etc. Refer to 
Formatting Options (page 232) for additional details. 

• Component Section: Select the Component Section check box to include a report on the 
components in the selected library in the publisher output. Several additional options become 
available, including the Component Format button, Select Components button, Attached 
Pattern Section check box, Attached Symbol Section check box and Footer Section check box.  

• The Component Format button allows you to select the contents of this section, including 
component name, pin table, attribute table, etc. Refer to Formatting Options (page 232) for 
additional details. 

• The Select Components button allows you to select which components from the selected 
library will be included in the report output. Refer to Selecting Components, Patterns and 
Symbols (page 154) for additional details. 

• If you select the Attached Pattern Section, Attached Symbol Section, or Footer Section check 
boxes, the appropriate section is added to your publisher output. For instance, checking the 
Attached Pattern Section box includes a report of the pattern immediately after the report on 
the component to which it is attached. The footer section is global, so if this check box is 
selected, the selected attributes are included in the footer of all pages in the publisher output. 
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If any of these sections are included, their corresponding format button becomes available. 
Refer to Formatting Options (page 232) for additional details on the Pattern Format, Symbol 
Format and Footer Format dialogs. 

• Pattern Section: Select the Pattern Section check box to include a report on the patterns in the 
selected library in the publisher output.  

• The Select Patterns button becomes available, allowing you to select the patterns included in 
this section. All selected patterns from the library are included whether or not they are 
attached to any library components. Refer to Selecting Components, Patterns and Symbols 
(page 154) for additional details. 

• The Pattern Format button becomes available allowing you to select the contents of this 
section, including pattern name, attribute table, a picture of the pattern, etc. Refer to 
Formatting Options (page 232) for additional details. 

• Symbol Section: Select the Symbol Section check box to include a report on the symbols in the 
selected library in the publisher output.  

• The Select Symbols button becomes available allowing you to select the symbols included in 
this section. All selected symbols from the library are included, whether or not they are 
attached to any library components. Refer to Selecting Components, Patterns and Symbols 
(page 154) for additional details. 

• The Symbol Format button becomes available allowing you to select the contents of this 
section, including symbol name, attribute table, a picture of the symbol, etc. Refer to 
Formatting Options (page 232) for additional details. 

Formatting Options 
If you choose to include a section in your published output by selecting its check box, you can 
modify the contents of the section by clicking its corresponding format button. The format options 
available for each output section are detailed below.  

Library Publisher uses Word’s Normal.dot template as a basis for the published output. To select 
the font type, font size and page layout for the published library, modify your Normal.dot 
template accordingly.  

Library Format 
When including the Library Section, you can click the Library Format button to open the Library 
Format Options dialog. 



Library Publisher Chapter 15: Library Commands 

Library Executive User’s Guide 233 

 

This dialog allows you to specify the contents of the library section. These options are described 
below: 

• File Name: The full path and filename of the library being published. 

• File Date & Time: The modified date and time of the library. 

• File Size: The size of the library. 

• Number of Components: The number of components contained in the library. 

• Number of Patterns: The number of patterns contained in the library. 

• Number of Symbol: The number of symbols contained in the library. 

• List of Component Names: The names of the components contained in the library. 

• List of Pattern Names: The names of the patterns contained in the library. 

• List of Symbol Names: The names of the symbols contained in the library. 

• Set All: Selects all options. 

• Clear All: Clears all option selections. 

• Done: Saves the selected options and returns to the Library Publisher dialog. 

Component Format 
When including the Component Section, click the Component Format button to open the 
Component Format Options dialog. 
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This dialog allows you to specify the contents of the component section. These options are 
described below: 

• Component Name: The name of the component. 

• RefDes Prefix: The reference designator prefix. 

• Number of Pins: The number of pins on the component. 

• Homogeneous: Whether or not the component is homogeneous. In a homogeneous 
component, all gates use the same symbol.  

• Gate Numbering: Whether the gate numbering in the reference designator is alphabetic or 
numeric. 

• Number of Gates: The number of gates in the component. 

• Attached Pattern Name: The name of the pattern attached to the component. 

• List of Alias Names: The alias names of equivalent components in the same library.  

• Gate Table: Publishes the Gate Table for the component. This table is displayed in the 
Component Information dialog and includes the following information: Gate #, Gate Eq, 
Normal, IEEE and DeMorgan. Refer to View Commands (page 255) for additional details. 

• Pin Table: Publishes the Pin Table for the component. This table is displayed in the Pins View 
dialog and includes the following information: Pin #, Gate #, Sym Pin #, Pin Name, Gate Eq, Pin 
Eq and Elec Type. Refer to View Commands (page 255), for additional details. 

• Attribute Table: Lists the component attributes and their values. 

• Set All: Selects all options. 

• Clear All: Clears all selected options. 

• Done: Saves the selected options and returns to the Library Publisher dialog. 
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Pattern Format 
When including a Pattern Section in your published library, click the Pattern Format button to open 
the Pattern Format Options dialog. 

 

This dialog allows you to specify the contents of the pattern section. The pattern section check box 
can be selected in two locations. If you select the Attached Pattern Section check box within the 
Component Section, the pattern section will directly follow the component section of the 
component to which it is attached. If you select the Pattern Section check box outside the 
Component Section, the pattern section will follow after the component section for all 
components and contain all selected patterns in the library consecutively, independent of their 
associated component.  

The options on the Pattern Format Options dialog are: 

• Pattern Name: The name of the pattern. 

• Number of Pads: The number of pads in the pattern. 

• Bounding Rectangle Size: The dimensions of the selection box surrounding the pattern 
graphics.  

• List of Pad Styles: Lists all of the pad styles used in the current pattern. 

• List of Camp References: A list of the component names in the current library that have this 
pattern attached. 

• List of Alias Names: The alias names of equivalent patterns in the same library. 

• Attribute Table: Lists the pattern attributes and their values. 

• Picture of Pattern frame: Select this check box to include a picture of the pattern in the 
published output. The Min Size and Max Size boxes become available where you can select the 
size range of the picture output.  
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The minimum size sets the lower bound. If the pattern is smaller than this minimum size, it is 
enlarged. The maximum size sets the upper bound. If the pattern is larger than this maximum 
size, it is reduced. 

If the pattern picture is currently within the selected minimum - maximum range, it is fit to the 
next larger ½ inch increment. For example, a picture with a bounding rectangle size of 4.21 
inches, would be fit to 4.5 inches. 

The pattern pictures can be resized by selecting and modifying them in Word. See your 
Microsoft Word 97 documentation for details. 

• Set All: Selects all options. 

• Clear All: Clears all selected options. 

• Done: Saves the selected options and returns to the Library Publisher dialog. 

Symbol Format 
When including a Symbol Section in your published library, click the Symbol Format button to 
open the Symbol Format Options dialog. 

 

This dialog allows you to specify the contents of the Symbol Section. The Symbol Section check 
box can be selected in two locations. If you select the Attached Symbol Section check box within 
the Component Section, the Symbol Section will directly follow the Component Section (and 
attached Pattern Section, if selected) of the component to which it is attached. If you select the 
Symbol Section box outside the Component Section, the symbol section will follow after the 
Component Section (and Pattern Section, if selected) for all components and contain all of the 
selected symbols in the library consecutively, independent of their associated component. 

The options in the Symbol Format Options dialog are: 

• Symbol Name: The name of the symbol. 

• Number of Pins: The number of pins in the symbol. 
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• Bounding Rectangle Size: The dimensions of the selection box surrounding the symbol 
graphics.  

• List of Comp References: A list of the component names in the current library that have this 
symbol attached. 

• List of Alias Names: The alias names of equivalent symbols in the same library. 

• Attribute Table: Lists the symbol attributes and their values. 

• Picture of Symbol: Select this option to include a picture of the symbol in the published 
output. The Min Size and Max Size boxes become available and you can select the size range 
of the picture output.  

The minimum size sets the lower bound. If the symbol is smaller than this minimum size, it is 
enlarged. The maximum size sets the upper bound. If the symbol is larger than this maximum 
size, it is reduced. 

If the symbol picture is currently within the selected minimum - maximum range, it is fit to the 
next larger ½ inch increment. For example, a picture with a bounding rectangle size of 4.21 
inches, would be fit to 4.5 inches. The symbol pictures can be resized by selecting and 
modifying them in Word. See your Microsoft Word 97 documentation for details. 

• Set All: Selects all options. 

• Clear All: Clears all selected options. 

• Done: Saves the selected options and returns to the Library Publisher dialog. 

Footer Format 
When including the Footer Section, click the Footer Format button to open the Footer Format 
Options dialog. 
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This dialog allows you to specify the footer contents displayed on each page of the component 
section.  

To set the Footer Format Options: 

1. Select a component or attribute from the list of Predefined Options. 

2. Click Add to move the selection to the Footer Contents box. 

To include an attribute that is not predefined, type the attribute name in the User Defined 
Attribute box. Click Add. The attribute will appear in the Footer Contents box. The attribute 
value for the particular component is found in the library and listed in the Footer Section. You 
can also double-click the attribute to add it. 

To remove an attribute from the Footer Contents box, select the attribute and click Remove. 
You can also double-click the attribute to remove it. 

Text can be included in the footer. For example, the words “Components Designed By:” can be 
a footer for your published document. To include text, type the text into the User Defined 
Attribute box. Click Add. Since the name is not recognized as an attribute, an attribute value 
will not appear in the footer. 

3. The footer contents are the attributes and their values listed in the order that they appear in 
the Footer Contents box. These attributes appear in order on the bottom of the pages in the 
component section from left to right. 

To organize the Footer Contents box, select the property or attribute you wish to move, click 
Move Up or Move Down. These commands rearrange or modify the contents of this box by 
moving the selected attribute higher or lower in the list. 

4. Click Done. The properties and attributes in the Footer Contents box are used to create a 
footer for the published library document. 

Selecting Components, Patterns and Symbols 
When a Component, Pattern, or Symbol section is included in your published library, you can 
select the items you want to include. The Select Components, Select Patterns and Select Symbols 
buttons display their corresponding Component, Pattern or Symbol Selection List dialog. A sample 
selection list dialog appears. 
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The box lists all components, patterns, or symbols in the selected library. If selected, the 
corresponding component, pattern, or symbol is included in the published output.  

To select or clear all check boxes, click the Select All or Clear All buttons. When the desired items 
are selected, click Done. The selected items will be published in their Component, Pattern, or 
Symbol Section. 

The selection dialog is not available for attached patterns and symbols in the Component Section. 
If Attached Pattern Section or Attached Symbol Section is selected, the patterns and symbols 
published are those attached to the selected component(s). 

Generating Publisher Output 
You can generate the published library by clicking OK in the Library Publisher dialog after having 
specified the Library Publisher output options: filenames, sections, formatting and item selection. 

Microsoft Word 97 works in the background to generate a published library document of the 
specified name. Open the document in Word to view, make changes, or to print. To open the 
document, you can select the file name in the recently used file list on Word’s File menu. 

If you run Word in the foreground after the Library Publisher has been started, be careful not to 
quit the Word application. Exiting Word before Library Publisher has finished will halt the 
publishing process. 
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CHAPTER 16 

Component Commands 

The Component commands allow you to create new components, open existing components, save 
components and validate components. 

Component New 
The Component » New command allows you to create a new component for later addition into a 
component library. When you choose the Component » New command or click the toolbar button, 
the Open dialog appears. 

 

Navigate to and select a library where the new component will be stored and in which the 
component’s symbol and pattern information reside. When you click Open, the Component 
Information dialog appears. 
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From the Component Information dialog you can attach a pattern and set the component type, the 
number of gates in the component, alternate representations of the component and the Refdes 
prefix. 

Drag and Drop Library Load 
You can also drag and drop a library file (.lib) into Library Executive. From the File Manager, click 
on a filename icon, drag it into the P-CAD window and release. The library file is loaded and the 
path established for use with the Component » New or Component » Open commands. 

Component Open 
The Component » Open command opens an existing component from a library. This command 
allows you to access a component for the purposes of attaching different patterns and symbols, 
changing pin assignments, pin equivalents, etc. for components you have created or for viewing 
the component data. When you choose the Component » Open command or click the toolbar 
button, the Component Open dialog appears. 
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If the library you want to access is not current (does not appear in the Library field), click the 
Library button to navigate to and select the desired library. You can also drag and drop a library file 
(.lib) into a P-CAD Library application.  

Select the desired component and click OK. The Component Information dialog opens and 
displays information for the component. It also provides access to the different views of the 
component where you can attach symbols or patterns and edit component properties. 

Component Save 
The Component » Save command saves the current component to its associated library file. This 
command is also accessible by clicking the Component Save toolbar button. 

Component Save As 
The Component » Save As command saves the component to a different library or with a different 
component name.  

When you choose Component » Save As, the Component Name dialog opens. 

 

Enter the new name for this component or select one from the list. 

Component Validate 
The Component » Validate command verifies all fields for valid entries and reports any errors.  

You cannot save a component using the Save or Save As command if an error exists. 
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CHAPTER 17 

Pattern Commands 

The Library Executive Pattern commands accesses the P-CAD Pattern Editor. In the Pattern Editor, 
you can quickly create a new pattern using the Pattern Wizard or edit an existing pattern. These 
patterns can, at some future time, be attached to a design component. 

All Pattern commands are accessible in Library Executive only. The Pattern menu accesses the 
P-CAD Pattern Editor, an application that simplifies and automates pattern creation. The Pattern 
Editor is partnered with the Library Executive and is one of the many P-CAD Library Executive 
enhancements. 

Pattern New 
The Pattern » New command starts the Pattern Editor program with the Pattern Wizard in the 
workspace.  

Pattern Open 
The Pattern » Open command starts the Pattern Editor program and opens a dialog where you can 
navigate to and choose the pattern to be edited. The pattern can be in a pattern file (.pat) or a 
component library (.lib). 
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CHAPTER 18 

Symbol Commands 

The Library Executive Symbol commands accesses the P-CAD Symbol Editor. In the Symbol Editor, 
you can quickly create a new symbol using the Symbol Wizard or edit an existing symbol. These 
symbols can, at some future time, be attached to a design component. 

All Symbol commands are accessible in Library Executive only. The Symbol menu accesses the 
P-CAD Symbol Editor, an application that simplifies and automates symbol creation. The Symbol 
Editor is partnered with the Library Executive and is one of the many P-CAD Library Executive 
enhancements. 

Symbol New 
The Symbol » New command starts the Symbol Editor program with the Symbol Wizard in the 
workspace.  

Symbol Open 
The Symbol » Open command starts the Symbol Editor program and opens a dialog where you can 
navigate to and choose the symbol to be edited. The symbol can be in a symbol file (.sym) or a 
component library (.lib). 
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CHAPTER 19 

Edit Commands 

The Edit commands are only available after you have created or opened a component (Component 
New or Component Open). 

There are toolbar icon equivalents for Cut, Copy, Paste, Attach Symbols, Attach Pattern and 
Component Attr. 

Edit Undo Spreadsheet Change 
The Edit » Undo Spreadsheet Change command reverses your last completed action to the Pins 
View, Pattern View and Symbol View dialogs (but not in the Component Information dialog). Many 
component commands, such as Component » New and Component » Save cannot be undone. If an 
action cannot be undone (or there is nothing to undo), the Undo command appears grayed on the 
Edit menu. 

The Undo button on the toolbar and the CTRL+U keys are equivalent to the Edit » Undo 
Spreadsheet Change command. 

Edit Cut Spreadsheet Selection 
The Edit » Cut Spreadsheet Selection command moves the data from all selected cells to the 
clipboard, overwriting the previous clipboard contents. You must have one or more cells selected 
before you can cut. 

Edit » Cut Spreadsheet Selection does not function within the Component Information dialog. 

The Paste (CTRL+V) command copies the clipboard data to another cell or cells within the 
spreadsheet. Data in the clipboard can also be pasted into a commercial spreadsheet where it can 
be edited and pasted back into Library Executive. 

Edit Copy Spreadsheet Selection 
The Edit » Copy Spreadsheet Selection command copies the data from all selected cells to the 
clipboard. The original data is not erased from the cells. 
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Edit » Copy Spreadsheet Selection does not function within the Component Information dialog. 
You must have one or more cells selected before you can copy.  

The Paste (CTRL+V) command copies the clipboard data to another cell or cells. Data in the 
clipboard can also be pasted into a commercial spreadsheet where it can be edited and pasted back 
into Library Executive. 

Edit Paste Spreadsheet Selection 
The Edit » Paste Spreadsheet Selection command copies the clipboard data to a cell or cells within 
the spreadsheet.  

Data copied to the Clipboard from a commercial spreadsheet can be pasted into one of the view 
dialog spreadsheets by choosing the Edit » Paste Spreadsheet Selection command. 

Edit » Paste Spreadsheet Selection does not function within the Component Information dialog. 

Edit Slide Selection Up 
The Edit » Slide Selection Up command moves the selected spreadsheet information up one row. 
You can use this command to slide cells, partial or entire rows, and one or more complete rows. 

Edit Slide Selection Down 
The Edit » Slide Selection Down command moves the selected spreadsheet information down one 
row. You can use this command to slide cells, partial or entire rows, and one or more complete 
rows. 

Edit Select Symbols 
The Edit » Select Symbols command allows you to select one or more symbols from the current 
library to attach to the current component. You can attach only symbols that reside in the same 
library as the component. 

This command also can be chosen by clicking the Select Symbol button and by double-clicking in 
either the Normal or Alternate Representations columns of the Component Information dialog. 

When you choose the Edit » Select Symbols command, the Library Browse dialog opens, displaying 
all symbols in the current library. 
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Select a symbol and click OK. For homogeneous components, the symbol is filled in for each gate 
in the component. For heterogeneous components, you need to assign a symbol to each gate. 

Edit Select Pattern 
The Edit » Select Pattern command allows you to select a pattern from the current library and attach 
it to the current component. You can attach a pattern if it resides in the same library as the 
component. 

When you choose Edit » Select Pattern the Library Browse dialog opens, displaying all patterns in 
the current library. 
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Select a pattern and click OK. The Pins View spreadsheet automatically adds a row for each pad in 
the pattern and automatically fills in the PinDes column. 

Edit Component Attribute 
The Edit » Component Attribute command allows you to view, add, modify, or delete component 
attributes and values. If you assign an attribute to a component it is attached to that component 
when you place it in P-CAD PCB or P-CAD Schematic.  

When you choose the Edit » Component Attribute command, the Attributes dialog opens. 

 

The dialog contains a two-column table showing a collection of component attributes. Within the 
collection, each attribute’s name and value appear in the column. You can view, add, modify, or 
delete a collection of component attributes and access reference links from the Attributes dialog.  

• Adding an Attribute: Click the Add button to open the Place Attribute dialog. Select the desired 
Attribute Category and attribute name from the Name list. If you are adding a (user-defined) 
attribute, enter its Name in the Name box and its value in the Value box. Click OK and the 
attribute is added to the table.  
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• Viewing Attribute Properties: Select an attribute from the table and click the Properties button 
(or double- click the attribute) to open the Attribute Properties dialog. This dialog is similar to 
the Place Attribute dialog except that only the Value field can be edited here. See Attribute 
Property Dialog (page 253) for more information. 

• Deleting an Attribute: Select an attribute in the table and click Delete, or press the DELETE key. 

• Launching a Reference Link: When the special attribute, Reference, whose value is a reference 
link, is added to the item, you can select the Reference attribute and click the Launch button to 
start a program, link to a web address or open a document to display the referenced 
information. 

Attribute Property Dialog 
The Attribute Property dialog, similar to the Place Attribute dialog. 

 

The Value field is the only field that can be edited for an existing attribute. Information available in 
the Attribute Properties dialog includes:  

• Category List Box: Lists the attribute categories: All, Component, Net, Clearance, Physical, 
Electrical, Placement, Manufacturing, Router and SPECCTRA.  

• Name List Box: Lists the pre-defined attributes for the specified category. The currently-
selected attribute also appears in the Name box, unless User-defined is selected. In that case, 
the Name box displays the user-defined attribute name. 

• Name Edit Box: Displays the user-defined name of the attribute.  

• Value: Enter a value for the attribute. See Attributes and Their Values (page 254) for an 
explanation of how component attribute values are placed in PCB and Schematic designs. 

• Visible: This check box indicates whether or not the attribute is visible. 

• Location: This frame shows the X and Y coordinates of the component’s reference point. 
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• Text Style: The attribute text style.  

• Rotation: Shows the rotation amount if the pattern has been rotated. 

• Flipped: This check box indicates whether or not the pattern has been flipped.  

• Justification: Shows the reference point of the text string. For example, if the middle button is 
enabled, the text reference point (the lower-left corner) moves to the center of the bounding 
rectangle. 

Attributes and Their Values 
The values given to Attributes become part of a design whenever the component is placed there. 
The following rules dictate which value is used when a component is placed in a PCB or Schematic 
design: 

• If a component attribute has a value, that value is used when the component is placed in either 
a PCB or Schematic design. 

• If a component attribute has no value, but the same named attribute in the pattern has a value, 
the pattern attribute’s value is placed in a PCB design. 

• If a component attribute has no value, but the same named attribute in the symbol has a value, 
the symbol attribute’s value is placed in a Schematic design. 
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CHAPTER 20 

View Commands 

The View commands allow you to access the four modeless dialogs that provide different views of 
the current component. Additional view commands let you show or hide the toolbar and prompt 
line areas. The details of these features are provided below. 

View Component Info 
The View » Component Info command opens the Component Information dialog. 

 

From the Component Information dialog, you can attach a pattern and set the component type, the 
number of gates in the component, alternate representations of the component and the RefDes 
prefix. 

When creating a component, you can enter a minimum of information before entering more 
detailed information in one of the other dialogs. For example, the number of pins must be entered 
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before proceeding to the Pins View dialog, and the number of gates must be entered if you want to 
edit multiple gates from the Symbol View dialog. 

Depending on how much information you provide, some entries are filled in for you:  

• When you attach a pattern, pad numbers are supplied. 

• Pin Des values are filled in when you attach a symbol or a pattern whose Default Pin 
Designators have been specified. 

• When you select a symbol, gate numbers and symbol pin numbers are automatically added. 

• Gate equivalence is automatically applied in Pins View. 

Pins 
If there is no attached pattern, then you can fill in the Number of Pins. If a pattern is attached, the 
Number of Pins is supplied. Attaching gates automatically increases the number of pins if no 
pattern is attached. 

Gates 
If you set the Component Style to Homogeneous, then all Gate Eq values are set to the first Gate Eq 
value. 

Gate numbers appear in order, either alphabetically or numerically. If the number of gates is 
greater than 0, you can select an attached symbol by clicking the Select Symbol button. IEEE and 
DeMorgan equivalents are available if those check boxes are selected in the Alternate Views frame. 

View Pins View 
The View » Pins View command opens the Pins View dialog where you can assign pin data. 
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If there is an attached pattern, the information in the current row also appears in the Pattern View 
dialog. The corresponding pad is selected in the Pattern View dialog. Changes made to row data are 
automatically updated in the Pattern View dialog. 

If there is an attached symbol, the information in the current row of the Pins View dialog also 
appears in the Symbol View dialog. The corresponding pin and gate are selected in the Symbol 
View dialog. Changes made to row data are automatically updated in the Symbol View dialog. 

View Pattern View 
The View » Pattern View command opens the Pattern View dialog where you can assign pin data to 
a component. 

 

The attached pattern appears in a browse window. The Pattern View dialog may be resized to 
increase the display area of the browse window.  

To expand the dialog vertically to display additional spreadsheet rows that may not be displayed, 
press the SHIFT key while dragging an edge of the dialog to the left or right. 

When a pad is selected in the browse window, the following occurs:  

• The pad is selected in the Pattern View browse window. 

• The pad’s corresponding pin is selected in the Symbol View browse window. 

• The corresponding spreadsheet row is selected in the Pattern View and Symbol View dialogs. 

• If pad numbers are missing from the rows or misnumbered, the correspondence between 
rows and pads is not maintained.  

Prev Pad/Next Pad 
The Prev Pad and Next Pad buttons automatically select the next and previous pads. The order of the 
pads is defined by the pad number sequence set during pattern creation. Pressing the UP key when 
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the entire row is selected or clicking the Prev Pad button selects the previous pad. Pressing the 
DOWN key when the entire row is selected or clicking the Next Pad button selects the next pad. If 
the pad number is missing or misnumbered, the corresponding pad is not selected. 

Pattern Selection 
Click the Select Pattern button to select the attached pattern. Changes made in this dialog are 
reflected in the view dialogs. 

Attaching a Pattern 
When you load a pattern into the spreadsheet, you have the option to overwrite the current 
information with the incoming data if a difference is detected. If you choose to overwrite the 
spreadsheet data the following conditions are applied: 

• Incoming pads whose default pin designators match a row’s pin designator are merged with 
the spreadsheet data and the pad number overwritten. A warning is issued when the pad 
numbers are different. 

• Remaining pads are matched by pad number and the pin designator is overwritten. If pin 
designators are different a warning is issued. 

• Rows already matched and merged are not considered for further matches. 

• Unmatched pads are matched to the smallest remaining row number and the pad number and 
pin designator overwritten. If either the pad number or pin designator is different a warning is 
issued. This may cause a random sorting of the pad numbers and pin designators. 

View Symbol View 
The View » Symbol View command opens the Symbol View dialog where you can assign pin data to 
a component. 
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The attached symbol appears in a browse window. The Symbol View dialog may be resized to 
increase the display area of the browse window.  

To expand the dialog vertically to display additional spreadsheet rows that may not be displayed, 
press the SHIFT key while dragging an edge of the dialog to the left or right. 

When a pin is selected, the following occurs:  

• The pin is selected in the Symbol View browse window. 

• The pin’s corresponding pad is selected in the Pattern View browse window. 

• The corresponding spreadsheet row is selected in the Pattern View, Pins View and Symbol View 
dialogs. 

• If pin or gate numbers are missing from the rows or misnumbered, the correspondence 
between rows and pins is not maintained.  

Prev Pin/Next Pin 
The Prev Pin and Next Pin buttons automatically select the next and previous pins within the 
symbol. The order of the pins is defined by the symbol pin number sequence set during symbol 
creation.  

Prev Sym/Next Sym 
If there is more than one gate, the Prev Sym and Next Sym buttons automatically select the next 
and previous gates. The Prev Sym button goes to the last pin of the previous gate; the Next Sym 
button goes to the first pin of the next gate. 

Symbol Selection 
Click the Select Symbol button to select the attached symbol. Changes made in this dialog are 
reflected in the other view dialogs. 

Attaching a Symbol 
When you load a symbol into the spreadsheet, you have the option to overwrite the current 
information with the incoming data if a difference is detected between the incoming and current 
pin designator. If you choose to overwrite the spreadsheet data, the following conditions are 
applied for single gate components: 

• Incoming pins whose default pin designators match a row’s pin designator are merged with the 
spreadsheet data and the spreadsheet pin name and symbol pin number are overwritten. 

• Remaining pins and rows that could not be matched using the pin designator are matched by 
pin name and the pin designator, symbol pin number and gate number are overwritten. 

• Any pins remaining are matched using the symbol pin numbers and the pin designators, pin 
names and gate numbers are overwritten. 
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• Finally, any remaining unmatched pins and rows are written to the spreadsheet in the 
remaining blank rows on a first come, first served basis. No rows will be overwritten unless a 
match is found. If a pattern is not attached, additional rows are inserted to accommodate the 
remaining pins. 

Multi-Gate components use the same matching criteria used for single gate components, except 
the gate number is used in conjunction with the matching criteria and is not overwritten unless the 
gate numbering can not be determined. 

View Source Browser 
The View » Source Browser command opens the Source Browser, shown in the following figure. 

 

From the Source Browser, all data sources available in Library Executive can be accessed, including 
P-CAD libraries and library sets, query results, cross link results and an imported external source file.  

Refer to The Source Browser (page 91), for details on the Source Browser and its function. 

View Comma-separated File 
The View » Comma-separated File command opens the Viewer containing the imported external 
source file.  
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From the Viewer, all Library Executive functions applicable to an imported library file are available, 
including Query, Cross Link, Verify and Reports. One other important function for imported files, 
Map Fields, is also available from the Viewer.  

Refer to Library Basics (page 3) for details on the Viewer and its function. 

View Toolbar 
The View » Toolbar command turns on or off the display of the toolbar. Current visibility is saved to 
the cmp.ini file and restored in subsequent sessions. 

The toolbar buttons are shortcuts for commonly-used commands. Once a toolbar is visible on your 
screen, you can use your mouse to drag it to a new position.  

Tool Tips explain each of the toolbar buttons. To activate a Tool Tip, place the mouse over the 
button. The Tool Tip pops up. 

View Custom Toolbar 
The View » Custom Toolbar turns on or off the display of the Custom toolbar.  

If no tools have been added to the Custom toolbar, the display of the toolbar is turned off. As soon 
as the first custom tool has been added by choosing the Utils » Customize command, the Custom 
toolbar display is turned on. When custom tools exist in the Custom toolbar, you can turn off the 
display of the toolbar by choosing View » Custom Toolbar. 

View Prompt Line 
The View » Prompt Line command turns on or off the display of the prompt line. Current visibility is 
saved to the cmp.ini file and restored in subsequent sessions. 
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CHAPTER 21 

Utils Commands 

The Utils commands let you move quickly to other P-CAD customized applications. 

Utils Query  
The Utils » Query command allows you to search for a wide variety of predefined and user-defined 
attributes in several sources — a P-CAD library or library set, an external library source file, a cross 
link result, or the result of a previous query. The Query utility can also aid in the search for a 
component to place into a PCB or Schematic design. The Query utility is also embedded directly in 
the P-CAD PCB and P-CAD Schematic programs.  

The Query dialog may also be accessed through the File or Table menus on the Viewer dialogs or 
from the shortcut menu in the Source Browser.  

The Query command searches for components from the current contents of Library Executive 
memory, as displayed in the Viewer. Query does not search the original source file. If changes have 
been made to a library, choose Reload to refresh the library components in Library Executive’s 
memory before conducting the Query. 

The Query dialog is shown in the following figure. 
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The following options are available in the Query dialog to specify search criteria, display fields and 
output options: 

• Set All/Clear All: Click the Set All button to display all fields defined in the selected source in 
the Field column. Click Clear All to remove all fields from the Field column. 

• New Result Table: Select this check box to generate an additional query result table. If the 
check box is cleared, the present query overwrites the previous result. 

• Query Spreadsheet: The Field column contains both the search and display attributes for the 
query. Select the Show check box for each field to be displayed in the query result. The Criteria 
(And) and Or columns contain the query search criteria.  

• Add Row/Add Column: The Add Row button adds a row to the query table. The Add Column 
button adds another Or column to the Query dialog. 

• Query: Click the Query button to begin the search for components satisfying the specified 
criteria. 

Additional information on the Query utility can be found in Querying Libraries (page 103). 

Utils Shortcut Directory 
At the time you installed your P-CAD product suite, a sub-directory named ShortcutDirectory 
was created in the P-CAD directory. The ShortcutDirectory contains a list of web addresses for 
semiconductor manufacturers. 

To access this directory: 

1. Choose the Utils » ShortcutDirectory command to open the ShortcutDirectory in Windows 
Explorer. 

2. Select the desired address and choose Open from the shortcut menu, or double click on the 
desired address to start the shortcut. 

Shortcuts to any web site can be added to the ShortcutDirectory. 

Utils PCB 
Starts P-CAD PCB if that program is installed on your computer. Refer to your P-CAD PCB User’s 
Guide for additional information. 

Utils Schematic 
Starts P-CAD Schematic if that program is installed on your computer. Refer to your P-CAD 
Schematic User’s Guide for additional information. 
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Utils Pattern Editor 
Starts P-CAD Pattern Editor.  

Utils Symbol Editor 
Starts P-CAD Symbol Editor.  

Utils Customize 
The Utils » Customize command allows you to define access to other applications from P-CAD 
Library Executive by adding items to the Custom Tools toolbar and the Utils menu. 

When you select Utils » Customize, the Utils Customize dialog opens. 

 

 

The Utils Customize dialog is used to add new tools or delete and modify existing tools on the 
Custom Tools Toolbar and Utils menu. The fields on the dialog are as follows: 

• Custom Tools: Lists the custom tools that currently exist.  

• Menu Text: The description of the tool being added. The Menu Text field allows up to 40 
characters. The buttons on the toolbar display as many letters as can fit on the button. If the 
name of a tool being added to the custom toolbar is too long to be displayed in its entirety, you 
can change the display by using lower case letters or shortening the name of the new tool.  

You may insert an ampersand (&) anywhere in the text string to designate a menu shortcut key. 
For instance, if the Menu Text entry is &Notepad, the menu shortcut key for the tool is the 
letter N.  
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The Utils menu displays the list of custom tools that have been added directly beneath the 
Customize command. 

• Command: The path to the executable file of the new tool. Click the Browse button to navigate 
to and select the desired file. A warning is issued if a non-existent path is entered, but the entry 
will still be added. 

• Arguments: Optional entry used to pass information into the targeted application, if desired. 

• Initial Directory: Sets the initial working directory for the application. 

• Display: Selects the way the application appears on the screen when initialized. Normal (the 
default) to display the application as a window in the workspace, Minimized to start the 
application and display it as an icon at the bottom of the screen, or Maximized to start the 
application and display it across the full screen. 

• Prompt for arguments: Select this check box to automatically display the Arguments dialog 
where you will enter input to be passed to the program at execution time. The entry is saved 
and recalled the next time the program is run. 

• Add: Click the Add button to begin adding a new tool. You can add a maximum of 16 tools to 
the Customized Toolbar. 

• Remove: Select a tool from the custom area and click Remove to delete it from the customized 
toolbar. 

• Move Up/Move Down: Select a tool from the Custom list and change its position in the list by 
clicking the Move Up or Move Down buttons. 

• OK: Click OK to apply additions/modifications and exit the dialog.  

Displaying the Custom Toolbar 
The Custom Toolbar is not displayed in the workspace until a custom tool has been added. Once a 
tool has been added, the toolbar automatically appears with the other Library Executive toolbars. 

The appearance of the Custom Toolbar in the workspace is turned on or off by choosing the View » 
Custom Toolbar command.  

Executing a Custom Tool 
To start an application added as a Custom Tool, choose one of these methods: 

• Click the desired button on the Custom Toolbar. 

• Choose the tool from the list at the bottom of the Utils menu.  

• While the Utils menu is active, select a custom tool by pressing the menu shortcut key 
assigned to it. For instance, if Notepad was set up with the N shortcut key, press the N key.  
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CHAPTER 22 

Help Commands 

P-CAD Library Executive provide extensive online help that contains both reference and tutorial 
information, but differs from the manual in its format and accessibility. 

The main advantages to online help are the availability of hypertext links between related subjects 
(an electronic cross-reference utility) and the keyword search function (an electronic index). 

Help Topics 
The Library Executive Help Topics command displays the online help for Library Executive. It 
includes the Contents tab, which is structured to match the order of commands as they appear in 
the product, and the Index tab, which lets you look up a specific concept or keyword.  

How to Use Help 
The How to Use Help command connects you to the Windows help system, where instructions on 
how to use the help system are provided. 

About P-CAD Library Executive  
The About P-CAD Library Executive command displays a screen that contains information about 
Library Executive, including the product version number, release date, memory used and memory 
available. 
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APPENDIX A 

Importing Master Designer Libraries 

This appendix discusses the differences between the Master Designer PDIF libraries and the P-CAD 
libraries and lists the considerations for importing PDIF libraries. You should read this section 
before importing any Master designer PDIF libraries. 

PDIF Library Considerations 
This section discusses the differences between Master Designer PDIF libraries and P-CAD libraries. 
You may encounter some of these differences when translating Master Designer PDIF libraries. 

• Internal components: All component information must reside in the Master Designer PDIF file. 
External component references are not supported. 

• Library file names: Because a P-CAD PCB library file and a P-CAD Schematic library file may 
have the same name after translating to Master Designer PDIF, be sure to place Master 
Designer PDIF Schematic libraries and Master Designer PDIF PCB libraries in separate 
directories. 

• Attached pattern names: When translating a Master Designer PDIF Schematic library, P-CAD 
Library Executive takes the pattern name from the following sources, listed in order of priority:  

• the component’s PRT attribute 

• the cross reference file 

• the name of the component with .prt added as a suffix.  

Attached pattern names are used when patterns from a PCB library are merged into a 
Schematic library. They are also used to determine the auto-placed pattern during PCB’s netlist 
load operation. 

• Power pin net assignment: Power and ground pins are specified either through a cross 
reference file or the component's PWGD attribute. The PWGD attribute takes precedence over 
an entry in the cross reference file. 

Padstack references: There are no padstacks in a Master Designer PDIF library. Component 
pads in a Master Designer PDIF library reference a padstack number only. During translation 
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from Master Designer PDIF to P-CAD libraries, component pads retain their padstack number. 
As in Master Designer, when a component is placed from the library, the padstack numbers is 
used to determine the correct padstack association.  

If a component is placed onto an existing design that was translated from Master Designer 
PDIF and a padstack with the same number is found, then that padstack will be used. However, 
if no padstack with the corresponding padstack number is located, then the library Default 
padstack is used instead. 

• P-CAD integrated libraries: P-CAD integrated libraries provide the ability to place the same 
component into both Schematic and PCB designs from the same library. An integrated 
component has both the pattern and symbol information and graphics.  

When translating a Master Designer PDIF library to a P-CAD library, the resulting library does 
not contain attached symbol or pattern information and is therefore not an integrated library. 
However, a Master Designer PDIF Schematic library can be translated into a P-CAD Schematic-
only library and used to place symbols into P-CAD Schematic.  

Also, a Master Designer PDIF PCB library can be translated into a P-CAD PCB-only library and 
used to place patterns into P-CAD PCB.  

• Layer mapping differs from PCB: When translating a Master Designer PDIF library to a P-CAD 
library, the default layer mapping from the following table is used. 

 

P-CAD Layer Library Layer 

COMP Top 

PADCOM Top 

PINTOP Top 

SOLDER Bottom 

PADSLD Bottom 

PINBOT Bottom 

INT1 Mid-1 

INT2 Mid-2 

BRDOUT Board 

SLKSCR Top Silk 

DEVICE Top Assy 

ATTR Top Silk 

ATTR2 <NONE> 

REFDES Top Silk 
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P-CAD Layer Library Layer 

SLKTOP Top Silk 

SLKBOT Bottom Silk 

DVCTOP Top Silk 

DVCBOT Bottom Silk 

REFDTP Top Silk 

REFDBT Bottom Silk 

SLDMSK Bot Mask 

MSKGTP Top Mask 

MSKGBT Bot Mask 

PSTGPT Top Paste 

PSTGBT Bot Paste 

 

Library Executive maps all other layers to <NONE>. See Mapping Layers from P-CAD Binary and 
PDIF Files to PCB in the P-CAD PCB User’s Guide for a full description of the layer mapping 
process. 

• Unused pads: Components created from the translation of Master Designer PDIF Schematic 
libraries contain one pin for each pin found. If a pattern is attached to a Schematic component 
that has more pads than pins, the extra pads will have unassigned pins. These pads appear as 
unused in P-CAD PCB. Connections are not allowed to be placed to unused pads.  

Components created from the translation of Master Designer PDIF PCB libraries contain one 
pin for every pin that is matched to a pad. However, a place holder pin is created for every pad 
that did not have a corresponding pin. As a result, all pads have a pin and no unused pads are 
created during translation of Master Designer PDIF PCB design files or Master Designer PDIF 
PCB library files.  

Be aware that component patterns placed from the Schematic library may be different from the 
patterns already placed in the PCB design due to differences in unused pads. If there are 
problems placing component patterns from the Schematic library into an existing or imported 
PCB design, use the PCB library patterns. 

• No-connect padstacks: A component pad translated from a Master Designer PDIF PCB file into 
P-CAD PCB may have an alternate no-connect padstack assigned to it. Since Master Designer 
PDIF libraries do not have padstack information, all components placed from the library have 
the connected padstacks assigned. 

• Heterogeneous Components: See the section Design Considerations in Using P-CAD Files in 
the P-CAD Schematic User’s Guide for details. 
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Translating Master Designer PDIF Libraries 
This section provides the steps used to translate a Master Designer PDIF PCB library or Master 
Designer PDIF Schematic library into a P-CAD library. Once translated, you may merge the resulting 
P-CAD libraries into a single P-CAD integrated library. 

Translating PCB and Schematic Libraries 
1. Choose Library » Translate to open the Library Translate dialog. 

 

2. Select the PDIF check box as the Source Format type. When PDIF is selected, additional 
options appear in the Library Translate dialog. 
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3. If you are using a cross reference file, click the PDIF Cross Reference button to open the 
Library File Listing dialog, where you can choose the PDIF cross reference file that corresponds 
to the library you want to translate. 

4. Click the Source Library button to open the Library File Listing dialog, where you can choose 
the PDIF PCB library to translate. 

5. Click the Destination Library button to open the Library File Listing dialog and choose the 
destination library name. 

6. Click Translate to begin the translation process. Library Executive translates all components 
and adds new alias names. Library Executive also generates and displays an error log file in the 
Notepad utility. The name of this file is Filename.err, where FILENAME is the name of the 
output library. 

7. Review the log file to make sure that all power and ground pins were defined and that 
important information has not been lost. 

8. Repeat steps 3 through 7 to translate the appropriate Master Designer PDIF Schematic Library. 

9. You should now have two P-CAD library files: one from a Master Designer PDIF PCB library; 
the other from a Master Designer PDIF Schematic library.  

10. Click Close to exit the dialog.  

Merging the Libraries 
This section explains how to merge the translated Master Designer PDIF PCB and Master Designer 
PDIF Schematic libraries. 

1. Choose Library Merge Patterns to open the Library Merge Patterns dialog. 
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2. Select the newly created P-CAD library translated from the Master Designer PCB PDIF library as 
the Source Libraries.  

3. Specify the Destination Library as the P-CAD library translated from the Master Designer 
Schematic PDIF library. 

4. Click the Merge button. Library Executive merges the Master Designer PDIF PCB library into 
the Master Designer PDIF Schematic library.  

You can now use this library with both P-CAD PCB and P-CAD Schematic. 

Import Considerations 
This section lists considerations for importing into P-CAD Library Executive. 

• Copper Pours in components are demoted to polygons. 

• Cutouts in components are ignored. 



 

Library Executive User’s Guide 275 

APPENDIX B 

System Messages 

This appendix provides a listing of system messages by message number. Many of these messages relate to 
the verification process. A detailed explanation of each message is included. 

Library Message Listing 
 

Error Number Message Comment 

5635 Duplicate pin des found in 
spreadsheet while loading pattern 

Multiple pins have the same pin designators. 

5636 Duplicate pad numbers found at 
rows __ and __. 

Multiple pads have the same pad numbers. 

5637 Pad number at row ___ is out of 
range 

Valid pad numbers range from 1 to the number of 
rows, inclusively. 

5700 Unable to allocate memory for pin 
data. Component not verified! 

A small amount of memory is required (64K or 
less) to hold the pin information for the entire 
component. 

5701 Gate Number out of range in row #. [-
1 to 255] 

No more than 5,000 gates may be used in a 
component.  -1 or CMN specifies a common pin. 

5702 Common pin in row # has a Gate Eq # 
that does not match any gates! 

The gate equivalence of a common pin is used to 
specify the scope or range of gates that the 
common pin applies to. A common pin by 
definition must exist for at least 2 gates. 

5703 Common pin in row # has a Gate Eq # 
that matches only 1 gate! 

The gate equivalence of a common pin is used to 
specify the scope or range of gates that the 
common pin applies to. A common pin by 
definition must exist for at least 2 gates. 
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Error Number Message Comment 

5704 Gate # missing symbol. A gate was specified in the Component 
Information dialog but no symbol was attached. At 
least one symbol must be associated to every gate.

5705 Gate # missing symbol name. A gate was specified in the Component 
Information dialog but no symbol was attached. At 
least one symbol must be associated to every gate.

5706 NORMAL Symbol name missing from 
library. 

The attached symbol could no longer be found in 
the current library. The library is either corrupted 
or the symbol was removed by another operation 
while creating the component. 

5707 IEEE Symbol name missing from 
library. 

The attached symbol could no longer be found in 
the current library. The library is either corrupted 
or the symbol was removed by another operation 
while creating the component. 

5708 DEMORGAN Symbol name missing 
from library. 

The attached symbol could no longer be found in 
the current library. The library is either corrupted 
or the symbol was removed by another operation 
while creating the component. 

5709 PATTERN name missing from library. The attached pattern could no longer be found in 
the current library. The library is either corrupted 
or the pattern was removed by another operation 
while creating the component. 

5710 Number of rows not equal to 
number of pads. 

If a pattern is attached then the number of rows of 
pin information must exactly match the number of 
pads in the pattern. Rows may be left blank if a 
pattern pad has no corresponding pin associated 
with it. 

5711 Missing PinDes in row #. When there is no attached pattern then every row 
must correspond to a pin and every pin specified 
must have a pin designator. If the row is not 
needed then move the row to the bottom of the 
list and use the Component Information dialog to 
reduce the number of pins by 1. 

5712 Missing PinDes in row #. Only 
unused pads are allowed to have a 
blank PinDes. 

When there is an attached pattern then every row 
corresponds to a pad in that pattern. Only unused 
pads may have an blank pin designator. An 
unused pad is specified by a completely empty 
row. 
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Error Number Message Comment 

5713 Invalid characters in PinDes in row # 
[Bad characters are COMMA, DASH, 
SPACE, TAB, BRACKET, PAREN, HI-
ASCII] 

The pin designator is not allowed to have any of 
the following characters: Comma “,” Dash “-” 
Bracket  “[“ or “]” Paren “(“ or “)” Space Tab or 
characters whose ASCII value are larger than 128. 

5714 POWER pin can't have missing 
PinName in row #. 

A pin with electrical type, Power, must specify the 
pin name since it is used as the default net name 
of that pin. 

5715 Invalid characters in PinName in row 
# [Bad character are SPACE,TAB,HI-
ASCII] 

The pin name is not allowed to have any of the 
following characters: Space, Tab, or characters 
whose ASCII value are larger than 128. 

5716 Gate Number out of range in row #. [-
1 to #] 

The value entered in the Gate# column of the 
spreadsheet must be less than the number of 
gates specified in the Component Information 
dialog. 

5717 Gate & Pin numbers must both be 
zero or both be non-zero in row #. 

The combination of gate number and pin number 
uniquely specify a component pin. They must 
both be zero when specifying an empty row, 
unused pad, or power pin. They must both be set 
to a non-zero value to specify any other pin. 

5718 Pin number _ in row _ exceeds the 
number of pads/ pins 

The pin number in any row can never exceed the 
number of pads when a pattern is attached or can 
never exceed the total number of pins when no 
pattern is attached. 

5719 The gate equivalence specified in 
Component Information for gate # 
does not match the pin's gate 
equivalence specified in row #. 

It is possible to get the gate equivalence to differ 
between the spreadsheet values and the values 
specified in the Component Information dialog. 
Correct the values so that they match by 
reentering the gate equivalence for each gate in 
the Component Information dialog. 

5720 Gate # has multiple Gate Eq values... 
first found in row #. 

Multiple rows with the same gate number have 
differing gate equivalences. 

5721 Equivalent gates # and # have a 
different number of pins. 

Multiple gates with the same gate equivalence 
value (other than 0) must have the same number 
of pins. 

5722 Gate # is missing. Gate numbers must 
be contiguous for homogeneous 
components. 

The spreadsheet is missing information for a gate. 
There are no rows that correspond to the gate 
number found in the Component Information 
dialog. 
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Error Number Message Comment 

5723 The same pin on equivalent gates 
must have the same Pin Eq. See row # 
and #. 

Equivalent gates are considered to have exactly 
the same symbols and symbol information. 

5724 The same pin on equivalent gates 
must have the same Electrical Type. 
See row # and #. 

Equivalent gates are considered to have exactly 
the same symbols and symbol information. 

5725 The same pin on equivalent gates of 
a homogeneous component must 
have the same Pin Name. See row # 
and #. 

Equivalent gates are considered to have exactly 
the same symbols and symbol information. 

5726 Equivalent pins can not have 
different electrical types in the same 
gate. See row # and #. 

None. 

5727 Gate Number # greater than number 
of gates # in row #. 

The gate number specified in the spreadsheet is 
larger than the number of gates specified in the 
Component Information dialog. 

5728 Pin Number # greater than number 
of pins # in row #. 

The pin number specified in the spreadsheet is 
larger than the numbers of pins specified in the 
Component Information dialog. 

5729 Duplicate Pin Number # found in 
gate # in row #. 

The combination of gate number and pin number 
has already been specified. Make sure that a 
common pin's pin number does not match 
another pin's pin number. 

5730 Pin Number # could not be found for 
gate # in row #. 

The pin number specified in the spreadsheet 
could not be found in the symbol corresponding 
to the gate number. 

5731 Common pin defined for gate num-
ber # is greater than number of gates 
# in row #. 

The gate equivalence used to specify the scope or 
range that the common pin is defined for is larger 
that the number of gates. 

5732 Pin Number # for gate # was never 
assigned in the spreadsheet. 

A pin number found in the symbol could not be 
found in the spreadsheet. 

5733 Duplicate pin number # not allowed 
in gate #. Pin numbers must start with 
1 and must be contiguous. 

None. 

5734 Pin Number # is missing from gate #. 
Pin numbers must start with 1 and 
must be contiguous. 

A pin number found in the symbol could not be 
found in the spreadsheet. 
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Error Number Message Comment 

5735 Attempt to assign duplicate pin 
designator name. 

Every pin designator must be unique. 

5736 The jumper pin in row __ is not 
jumpered to any other pin. 

A jumper pin, JMP-n, must be jumpered to 
another pin with the same -n value. 

5737 Invalid jumper pin value in row __. Check jumper pin values. 

5786 Duplicate default pin designators are 
now allowed. 

Default pin designators must be unique. 

12039 Field name changes in file external 
source file name. The saved mapping 
in the .ini file is ignored. 

Field mappings are saved so that if a source file of 
the same name is imported again, the fields are 
mapped automatically. When this warning 
appears, the field names in the external source file 
have been modified since last mapping and must 
be mapped again. 

12070 Duplicate field name: field name. The field name already exists in the source. 
Choose a different name for the added, renamed, 
or mapped field. 

12080 Field mapping will reload the original 
imported file. Changes made to the 
table Viewer will be lost. 

Any changes made to the imported source file in 
the file Viewer will be lost during field mapping. 
The Map Fields command always maps the 
original source file. Map the fields before 
modifying the Viewer contents if you would like 
those changes to be saved. 

12132 Record at line # does not match with 
field description. Do you want to see 
additional errors? (Press Cancel to 
end the import.) 

One or more of the rows in the imported comma-
delimited file has too many or too few field 
entries. Check that all special characters, 
particularly commas within field values, have been 
properly escaped. 

12133 No source is specified for the query. 
Select a source from the source 
browser, then select the right-mouse 
menu Query. 

Conducting a Query from the Source Browser 
specifies a source to search. Utils » Query has no 
means of determining which source is desired. 
After the first Query has been conducted from the 
Source Browser, Utils » Query displays the 
spreadsheet of the previous Query. 
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