PCB Design
Copyrights

Software, documentation and related materials:
Copyright © 2002 Altium Limited

This software product is copyrighted and all rights are reserved. The distribution and sale of this product are intended for the use of the original purchaser only per the terms of the License Agreement.

This document may not, in whole or part, be copied, photocopied, reproduced, translated, reduced or transferred to any electronic medium or machine-readable form without prior consent in writing from Altium Limited.

U.S. Government use, duplication or disclosure is subject to RESTRICTED RIGHTS under applicable government regulations pertaining to trade secret, commercial computer software developed at private expense, including FAR 227-14 subparagraph (g)(3)(i), Alternative III and DFAR 252.227-7013 subparagraph (c)(1)(ii).

P-CAD is a registered trademark and P-CAD Schematic, P-CAD Relay, P-CAD PCB, P-CAD ProRoute, P-CAD QuickRoute, P-CAD InterRoute, P-CAD InterRoute Gold, P-CAD Library Manager, P-CAD Library Executive, P-CAD Document Toolbox, P-CAD InterPlace, P-CAD Parametric Constraint Solver, P-CAD Signal Integrity, P-CAD Shape-Based Autorouter, P-CAD DesignFlow, P-CAD ViewCenter, Master Designer and Associate Designer are trademarks of Altium Limited. Other brand names are trademarks of their respective companies.

Altium Limited
www.altium.com
# Table of Contents

## chapter 1 Introduction to P-CAD PCB

P-CAD PCB Features .......................................................................................................... 1
About this Guide ............................................................................................................... 2
About P-CAD PCB (6/400) ............................................................................................... 2

## chapter 2 Installation and Setup

System Requirements ......................................................................................................... 3
  Recommended System .................................................................................................... 3
  Minimum System ........................................................................................................ 3
Installing P-CAD Products ................................................................................................. 4

## chapter 3 PCB Basics

About the User Interface ...................................................................................................... 6
  Menu Bar ...................................................................................................................... 6
  Toolbars ...................................................................................................................... 6
  Command Toolbar ...................................................................................................... 7
  Placement Toolbar ...................................................................................................... 7
  Route Toolbar ............................................................................................................ 8
  Custom Toolbar .......................................................................................................... 9
  Prompt Line ................................................................................................................ 9
  Status Line ................................................................................................................ 9
  X and Y Coordinates .................................................................................................. 10
  Grid Toggle Buttons .................................................................................................. 10
  Macro Record (Temporary Macro) Button ................................................................. 11
  Layer Display Combo Box and Scroll Buttons ......................................................... 12
  Line Width Combo Box .............................................................................................. 12
  Radius Combo Box .................................................................................................... 12
  Status Information Area ............................................................................................. 12
  Workspace ................................................................................................................ 13
  Using Multiple Windows ............................................................................................ 13
  View Commands ........................................................................................................ 13
  Zoom Commands ....................................................................................................... 13
  (View) Zoom In/Out .................................................................................................. 13
  (View) Zoom Window ............................................................................................... 14
  Other View Options ................................................................................................... 14
chapter 4 Tutorial - PCB Design Session

Introduction ..................................................................................................................................... 33
chapter 7  Auto Routing

Introduction to the Shape-Based Router ................................................. 127
# Routing with Quick Route

- P-CAD Quick Route Steps .............................................................................................. 128
- Completing the PC Board .............................................................................................. 130
- Verifying the Finished Board ......................................................................................... 132
- Setting Up the Route Autorouter Dialog ....................................................................... 132
- Commands Available during Routing ............................................................................ 140
- Toolbar ........................................................................................................................ 144
- Quick Route Limitations ............................................................................................... 145
- Routing Fine Points ..................................................................................................... 145

## chapter 8 Design Verification

- Introduction to Design Verification ................................................................................ 151
- Setting Up DRC Rules .................................................................................................... 151
  - Design Tab .................................................................................................................. 151
  - Layer Tab .................................................................................................................. 151
  - Rooms Tab .................................................................................................................. 153
  - Net Class Tab ............................................................................................................. 154
  - Net Tab ....................................................................................................................... 154
  - Class to Class Tab ..................................................................................................... 155
- Working with Design Rule Check ...................................................................................... 156
- Design Rules by Hierarchy .............................................................................................. 158
- Copper Ties and DRC ..................................................................................................... 164
- Configuring DRC ............................................................................................................ 164
- Online DRC .................................................................................................................... 167
- Using DRC Error Annotation ........................................................................................... 167
  - Finding DRC Errors .................................................................................................... 168
  - Overriding Error Displays .......................................................................................... 169
  - Block Selecting Error Indicators ................................................................................ 169
  - Overriding DRC Errors .............................................................................................. 170
  - Fixing DRC Errors ..................................................................................................... 170
  - Deleting DRC Errors ................................................................................................. 170

## chapter 9 CAM

- Introduction to CAM ....................................................................................................... 171
- Gerber Output ................................................................................................................ 171
  - Set Up Output Files .................................................................................................... 172
  - Aperture Assignments ................................................................................................. 174
  - Setting Drill Symbols .................................................................................................. 176
  - Gerber Format ............................................................................................................. 177
  - Compress Output Files ............................................................................................... 178
  - Generating Gerber Output .......................................................................................... 178
- Gerber Verification ........................................................................................................... 178
- Deleting Gerber Layer Information .................................................................................. 180
  - No Free Pads on the Board ....................................................................................... 180
  - Free Pads on the Board .............................................................................................. 180
- Creating a Padmaster Gerber File .................................................................................... 181
chapter 10 Copper Pours
Introduction to Copper Pours ................................................................. 189
Properties ................................................................................................ 189
Islands ..................................................................................................... 190
Repour .................................................................................................... 190
Pour/Repour Options ........................................................................... 190
Connectivity .......................................................................................... 191
Setting Backoff ..................................................................................... 192
Thermals ............................................................................................... 192
Circles ................................................................................................... 192
Routing ................................................................................................. 192
Autorouting .......................................................................................... 192
Manual and Interactive Routing .......................................................... 192
Auto Plowing ....................................................................................... 193
Overlapping Pours .............................................................................. 193

chapter 11 Interapplication Functions
Introduction to Interapplication Functions .............................................. 195
DDE Hotlinks ....................................................................................... 195
Enabling DDE Hotlinks ...................................................................... 196
Setting the Current Highlight Color .................................................. 196
Highlighting Parts and Components .................................................. 196
Highlighting Nets ............................................................................... 196
Unhighlighting Parts and Components .............................................. 197
Unhighlighting Nets .......................................................................... 197
ECOs ................................................................................................. 197
Types of ECOs .................................................................................... 197
Utils Record ECOs ........................................................................... 198
Utils Import ECOs ........................................................................... 198
Utils Export ECOs ........................................................................... 198
Starting Other P-CAD Applications .................................................. 200
Customizing P-CAD PCB ................................................................. 201

Chapter 12 File Commands
Introduction to File Commands ............................................................ 203
File New .............................................................................................. 203
File Open ............................................................................................. 203
Drag-and-Drop File Load ................................................................. 204
Chapter 13 Edit Commands

Using the Edit Commands ................................................................. 279
Edit Undo ....................................................................................... 280
Edit Redo ....................................................................................... 281
Edit Cut ......................................................................................... 281
Cutting Objects from Nets ............................................................... 282
Edit Copy ....................................................................................... 283
Edit Copy to File .......................................................................... 283
Edit Paste ..................................................................................... 284
Paste Behavior ............................................................................. 284
Paste From Clipboard ................................................................. 286
Paste from File ............................................................................ 286
Paste To Layer ............................................................................ 286
Paste Special ............................................................................... 287
Paste Circuit ............................................................................... 287
Edit Move By RefDes ................................................................. 290
Edit Move to Layer ...................................................................... 291
Moving an Object ........................................................................ 291
Restrictions .................................................................................. 291
Edit Properties ............................................................................ 292
Component Properties ................................................................. 293
Component Reference Links ....................................................... 304
Connection Properties ................................................................. 305
Pad Properties ............................................................................. 307
Net Tab ......................................................................................... 309
Via Properties ............................................................................. 311
Line Properties ............................................................................ 313
Arc Properties ............................................................................. 314
Polygon Properties ...................................................................... 315
Test Point Properties ................................................................... 316

P-CAD PCB User's Guide
chapter 14 View Commands
Using the View Commands ................................................................. 361
View Redraw ...................................................................................... 361
View Extent ....................................................................................... 361
View Last .......................................................................................... 362
View All ............................................................................................. 362
View Center ...................................................................................... 362
View Zoom In .................................................................................. 362
View Zoom Out ............................................................................... 363
View Zoom Window ....................................................................... 363
Using the Zoom Window ................................................................. 363
View Jump Location ........................................................................ 363
Jumping to a Location .................................................................... 364
View Jump Text .............................................................................. 364
Jumping to Text ............................................................................. 364
View Command Toolbar .................................................................. 365
View Placement Toolbar ................................................................. 365
View Route Toolbar ......................................................................... 365
View Custom Toolbar ...................................................................... 366
View Prompt Line ........................................................................... 366
View Status Line ............................................................................ 366
View Snap to Grid ........................................................................... 367

chapter 15 Place Commands
Using the Place Commands ................................................................. 369
Place Autoplace ............................................................................. 370
Performing Autoplacement ............................................................ 372
Place Component ........................................................................... 374
Placing a Component ..................................................................... 374
### chapter 16 Route Commands

<table>
<thead>
<tr>
<th>Using the Route Commands</th>
<th>405</th>
</tr>
</thead>
<tbody>
<tr>
<td>Route Autorouter</td>
<td>406</td>
</tr>
<tr>
<td>Route View Log</td>
<td>407</td>
</tr>
<tr>
<td>Route Manual</td>
<td>408</td>
</tr>
<tr>
<td>Manually Routing a Connection</td>
<td>409</td>
</tr>
<tr>
<td>Terminating a Route</td>
<td>409</td>
</tr>
<tr>
<td>Status Line Information</td>
<td>410</td>
</tr>
<tr>
<td>Routing between Layers</td>
<td>411</td>
</tr>
<tr>
<td>T-Routing</td>
<td>411</td>
</tr>
<tr>
<td>Modifying Traces</td>
<td>411</td>
</tr>
<tr>
<td>Orthogonal Modes (O key)</td>
<td>412</td>
</tr>
<tr>
<td>Online DRC</td>
<td>413</td>
</tr>
<tr>
<td>Overlapping Connections</td>
<td>414</td>
</tr>
<tr>
<td>Routing to Free Copper</td>
<td>414</td>
</tr>
<tr>
<td>Copper Pours</td>
<td>414</td>
</tr>
<tr>
<td>Route Interactive</td>
<td>414</td>
</tr>
<tr>
<td>Routing Connections</td>
<td>414</td>
</tr>
<tr>
<td>Controlling Trace Placement</td>
<td>415</td>
</tr>
<tr>
<td>Pad Entry or Exit</td>
<td>416</td>
</tr>
<tr>
<td>T-Routing</td>
<td>417</td>
</tr>
<tr>
<td>Terminating a Route</td>
<td>417</td>
</tr>
<tr>
<td>Modifying Traces</td>
<td>418</td>
</tr>
<tr>
<td>Changing Layers</td>
<td>418</td>
</tr>
<tr>
<td>Vias, Layers, and Line Widths</td>
<td>419</td>
</tr>
<tr>
<td>Loop Removal</td>
<td>419</td>
</tr>
<tr>
<td>Copper Pours</td>
<td>419</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>419</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>420</td>
</tr>
<tr>
<td>Route Miter</td>
<td>420</td>
</tr>
<tr>
<td>Using the Route Miter Tool</td>
<td>420</td>
</tr>
<tr>
<td>Editing Existing Miters</td>
<td>421</td>
</tr>
</tbody>
</table>

### chapter 17 Options Commands

<table>
<thead>
<tr>
<th>Using the Options Commands</th>
<th>423</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options Selection Mask</td>
<td>423</td>
</tr>
</tbody>
</table>
chapter 18  Library Commands
Using the Library Commands .......................................................................................... 487
Library New ......................................................................................................................... 487
Library Alias......................................................................................................................... 488
Creating an Alias .................................................................................................................. 488
Library Copy ......................................................................................................................... 489
Copying Patterns/Components ............................................................................................ 489
Library Delete ....................................................................................................................... 491
Deleting from a Library ......................................................................................................... 491
Library Rename ..................................................................................................................... 492
Renaming a Pattern/Component ......................................................................................... 492
Library Setup ......................................................................................................................... 493
Drag and Drop File Load ...................................................................................................... 493
Setting Up a Library .............................................................................................................. 493
Library Pattern Save As ........................................................................................................ 494
Saving a Pattern .................................................................................................................... 494
Library Archive Library ...................................................................................................... 495

chapter 19  Utils Commands
Using the Utils Commands ................................................................................................. 497
Utils Renumber ..................................................................................................................... 497
Renumbering Reference Designators ................................................................................ 497
Renumbering Pads ............................................................................................................... 499
Renumbering Default Pin Designators .............................................................................. 500
Utils Force Update ............................................................................................................... 500
Utils Record ECOs ............................................................................................................... 502
Types of ECOs ....................................................................................................................... 502
Utils Import ECOs ............................................................................................................... 503
ECO Filename ....................................................................................................................... 503
Preview ECOs ....................................................................................................................... 504
Pseudo Patterns ..................................................................................................................... 504
Utils Export ECOs ................................................................................................................. 505
View Pending ECOs .............................................................................................................. 505
Save ECOs Now ..................................................................................................................... 505
Chapter 20 DocTool Commands

Using the DocTool Commands.................................................................541
DocTool Place Table ..............................................................................541
The Basic Place Table Dialog ..............................................................542
Note and Revision Note Table Options ..............................................542
Drill Table Advanced Options ............................................................543
DocTool Place Design View ...............................................................543
DocTool Place Detail ..........................................................................545
DocTool Place Diagram .......................................................................546
DocTool Place Picture ........................................................................548
DocTool Titles ....................................................................................548
DocTool Notes ...................................................................................548
DocTool Update ................................................................................548
DocTool Update All ...........................................................................549
DocTool Mirror On Copy ..................................................................549

Chapter 21 Macro Commands

Using the Macro Commands.................................................................551
Macro Setup ........................................................................................551
Setting Up a Macro ............................................................................551
Macro Record .....................................................................................552
Macro Recording Tool ........................................................................552
Recording a Macro ............................................................................553
Recording a Temporary Macro .........................................................553
Macro Delete .....................................................................................554
Macro Rename ..................................................................................554
Macro Run ........................................................................................555
Recording Efficient Macros ...............................................................555
Other Macro Features ........................................................................556
Running a Macro ..............................................................................556
Status Line Recording Indicators .......................................................556
Automatic Delays ............................................................................557
Editing Macro Files ..........................................................................557
Macro File Syntax ............................................................................557
Mouse Events ...................................................................................558
Keyboard Events .............................................................................558
Special Events ................................................................................561
Edit Events .....................................................................................561
File Syntax .......................................................................................561

Chapter 22 Window Commands

Using the Window Commands .............................................................563
Window New Window ........................................................................563
Window Cascade ...............................................................................563
Window Tile .....................................................................................563
Window Arrange Icons .....................................................................564
Selecting a Window ..........................................................................564
Congratulations on your purchase of P-CAD PCB! P-CAD PCB is a highly versatile and flexible productivity-enhancing tool for the professional designer. It meets the design requirements of today’s complex boards in a straight-forward easy-to-use manner.

P-CAD PCB is an advanced printed circuit board design system for the Microsoft® Windows operating systems. It includes a powerful combination of design tools to make your job easier and achieve superior results.

**P-CAD PCB Features**

This section highlights some of the important P-CAD PCB features:

- Up to 999 layers; multiple power and ground planes.
- User-definable board, net, and component attributes.
- Copper pour with clearances following design rules or user settings, plowed tracks, island removal.
- Support for Design Technology Parameters.
- User-definable pad stacks, including blind/buried vias.
- Split power/ground planes.
- Cross-probing with P-CAD Schematic.
- Advanced bi-directional ECO capabilities.
- Component library data integrated for use in both P-CAD Schematic and P-CAD PCB.
- Powerful pattern graphic capabilities with automatic alternate pattern graphic selection based on side of board and component rotation.
- Item rotation to 0.1 degree.
- Curved traces.
• Comprehensive Design Rules Checking with error annotation and on-screen highlighting.
• Tightly integrated with the P-CAD Shape-Based Autorouter.
• Full range of manufacturing and assembly functions.
• Tight integration to the SPECCTRA® autorouter, CAM350®, and Viewlogic® products.
• Integrated web-based request for PCB fabrication quotation feature.
• IDF version 3 import and export options.
• Extensive print and report options.
• Block and subselection allow portions of designs to be copied, moved, rotated and deleted.

About this Guide

This manual provides information about P-CAD PCB, a full-featured printed circuit board design system, and P-CAD PCB (6/400), a reduced-capacity printed circuit board design system.

This manual includes the following sections:

• Getting Started: This section tells what you need to get started using P-CAD PCB. It provides installation instructions and walks you through the basic capabilities of P-CAD PCB. Tutorial chapters provide instructions on creating and navigating a simple design.

• Using PCB: These chapters provide information that you need to work with P-CAD PCB. They give you details on some of PCB’s advanced features such as manual, interactive, and automatic routing, as well as using Design Technology Parameters.

• PCB Reference: This section includes an extensive command reference, covering all of the P-CAD PCB commands

About P-CAD PCB (6/400)

P-CAD PCB (6/400) has the full range of advanced design features available with P-CAD PCB, but with reduced design capacity. It is a Windows-based printed circuit board design system. Differences between the two products have been noted throughout this manual with the symbol you see in the left margin. The following chart provides a summary of those differences:

<table>
<thead>
<tr>
<th>Feature</th>
<th>6/400 Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of components</td>
<td>400</td>
</tr>
<tr>
<td>Maximum number of layers</td>
<td>Maximum of six copper layers, including a predefined Top and Bottom layer and four user-defined signal or plane layers.</td>
</tr>
<tr>
<td>Network Licensing</td>
<td>Unsupported</td>
</tr>
</tbody>
</table>
CHAPTER 2

Installation and Setup

This section lists the required hardware and software settings you need to install the P-CAD Suite.

System Requirements

Make sure that your PC and its software conform to the following P-CAD requirements and recommendations.

Recommended System

- Windows NT 4/2000 Professional
- PC with Pentium III Processor
- 128MB RAM (256MB for high component/net count)
- 400MB Hard Disk Space
- Desktop area 1024x768 pixels
- 32-bit Color Palette
- CD-ROM Drive
- Mouse or compatible pointing device

Minimum System

- Windows 95/98/2000Me
- PC with Pentium 166MHz
- 64MB RAM
- 200MB Hard Disk Space (without ISO libraries)
- Desktop area 800x600 pixels
- 256 Color Palette
Installing P-CAD Products

For up-to-date installation information refer to the file Readme.WRI, located on the product CD. This file can also be found in the application program folder (\Program Files\P-CAD 2002) after installation. Note that the setup program on the Product CD can also be used to Repair or Remove an existing P-CAD Installation.
This chapter introduces many of the basic features you need to know when using P-CAD PCB. It includes general information on such topics as:

- The user interface
- View commands
- Using layers
- Object/action interaction
- Placing objects
- Edit objects
- Properties
- Right mouse commands
- Loading and saving files

What is presented here is a high level look at PCB capabilities. For a detailed description of a particular operation, refer to the appropriate chapters. For instructions on how to perform a particular operation refer to the *Tutorials* chapter.
About the User Interface

The PCB interface follows the standard Windows format, with the addition of PCB-specific controls.

Menu Bar

The menu bar allows you easy access to PCB commands and functions.

To activate a menu, click the menu title or press the ALT key in combination with the underlined letter of the menu title (e.g., ALT+F to open the File menu). When the menu appears, click a menu item, or press the underlined key, to choose a command.

- A command followed by three dots (e.g., Open...) opens a dialog when you choose it.
- The menu bar wraps if you reduce the width of the window. In contrast, other areas of the screen truncate with screen reduction.

Toolbars

Three toolbars provide shortcuts to commonly used commands and PCB functions. Toolbars appear when you choose the appropriate View command. Once a toolbar is visible on your screen, you can use your mouse to drag it to a new position. It can be docked along the edges of your screen, or left floating in the middle of your display. A floating toolbar can be resized.
Tool Tips explain each of the toolbar buttons. To activate a Tool Tip, simply place the mouse over the button.

Command Toolbar

The Command Toolbar provides shortcuts to menu commands and other system functions.

These buttons appear on the Command Toolbar.

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this:</th>
<th>Click this button</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Edit Select]</td>
<td>Edit Select</td>
<td>![Edit Paste]</td>
<td>Edit Paste</td>
</tr>
<tr>
<td>![File New]</td>
<td>File New</td>
<td>![Edit Undo]</td>
<td>Edit Undo</td>
</tr>
<tr>
<td>![File Open]</td>
<td>File Open</td>
<td>![Edit Redo]</td>
<td>Edit Redo</td>
</tr>
<tr>
<td>![File Save]</td>
<td>File Save</td>
<td>![Edit Measure]</td>
<td>Edit Measure</td>
</tr>
<tr>
<td>![File Print]</td>
<td>File Print</td>
<td>![View Zoom Window]</td>
<td>View Zoom Window</td>
</tr>
<tr>
<td>![Edit Cut]</td>
<td>Edit Cut</td>
<td>![Online DRC]</td>
<td>Online DRC</td>
</tr>
<tr>
<td>![Edit Copy]</td>
<td>Edit Copy</td>
<td>![Record ECOs]</td>
<td>Record ECOs</td>
</tr>
</tbody>
</table>

The Undo, Redo and Zoom Window buttons operate in conjunction with other PCB tools. For example, if the Place Arc tool is active and you choose to undo an action, you can then resume placing arcs without having to restart the command.

Placement Toolbar

The Placement Toolbar provides shortcuts to PCB placement commands.
These buttons appear on the *Placement Toolbar*:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this:</th>
<th>Click this button</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Component</td>
<td><img src="image" alt="icon" /></td>
<td>Place Copper Pour</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Connection</td>
<td><img src="image" alt="icon" /></td>
<td>Place Cutout</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Pad</td>
<td><img src="image" alt="icon" /></td>
<td>Place Keepout</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Via</td>
<td><img src="image" alt="icon" /></td>
<td>Place Plane</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Line</td>
<td><img src="image" alt="icon" /></td>
<td>Place Room</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Arc</td>
<td><img src="image" alt="icon" /></td>
<td>Place Text</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Polygon</td>
<td><img src="image" alt="icon" /></td>
<td>Place Attribute</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>Place Point</td>
<td><img src="image" alt="icon" /></td>
<td>Place Field</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td></td>
<td><img src="image" alt="icon" /></td>
<td>Place Dimension</td>
</tr>
</tbody>
</table>

Click these buttons to select a PCB tool such as the *Place Line* tool or the *Select* tool. Once selected, a tool remains active until you select another tool.

When a tool is active you can perform actions associated with the tool as well as certain one-time actions such as zooming, changing layers, and undoing the last operation.

For example, when you enable the *Place Line* tool, you are limited to placing line segments and cannot perform other actions like placing an arc (*Place Arc*) or selecting another object (*Edit Select*).

**Route Toolbar**

The *Route Toolbar* provides shortcuts to PCB route commands.
These buttons appear on the Route Toolbar:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this:</th>
<th>Click this button</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Route Manual" /></td>
<td>Route Manual</td>
<td><img src="image" alt="Route Fanout" /></td>
<td>Route Fanout</td>
</tr>
<tr>
<td><img src="image" alt="Route Interactive" /></td>
<td>Route Interactive</td>
<td><img src="image" alt="Push Traces" /></td>
<td>Push Traces</td>
</tr>
<tr>
<td><img src="image" alt="Route Miter" /></td>
<td>Route Miter</td>
<td><img src="image" alt="Maximize Hugging" /></td>
<td>Maximize Hugging</td>
</tr>
<tr>
<td><img src="image" alt="Route Bus" /></td>
<td>Route Bus</td>
<td><img src="image" alt="Minimize Length" /></td>
<td>Minimize Length</td>
</tr>
<tr>
<td><img src="image" alt="Route MultiTrace" /></td>
<td>Route MultiTrace</td>
<td><img src="image" alt="Visible Routing Area" /></td>
<td>Visible Routing Area</td>
</tr>
</tbody>
</table>

**Custom Toolbar**

You can create a Custom Toolbar for access to other applications from PCB. Programs are added to the Custom Toolbar by choosing the **Utils » Customize** command. You can launch any of the programs by clicking their Custom Toolbar buttons or selecting them from the list of programs that appear in the Utils menu.

Complete instructions on creating and using the Custom Toolbar are found in, *Utils Commands*, (page 497).

**Prompt Line**

The Prompt Line lies below the work area and is the first line of the prompt/status line area, extending the complete width of the PCB display (the second line being the Status Line. Its display can be displayed or hidden using the **View » Prompt Line** command). When there is no prompt, the area is empty.

When you choose a command or process, the Prompt Line displays a prompt message that provides useful instructions on what to do when a certain tool is selected.

**Status Line**

The Status Line area is at the bottom of the screen and its display can be turned on or off by choosing the **View » Status Line** command. A check mark next to the Status Line indicates that the Status Line display is turned on.

The Status Line has the following basic features, from left to right:
X and Y Coordinates

These two values in the lower-left corner of the Status Line show you the position of the cursor as you move it over the workspace. The display lets you enter the exact X and Y coordinates of specific points on the screen.

Keyboard shortcuts listed below are defaults; you can change them by choosing the Options » Preferences command.

If the Select tool is enabled, these boxes act as a shortcut for the View » Jump Location command:
1. Press the J key to get focus on the X coordinate edit box.
2. Type an X coordinate value.
3. Press the TAB key to move to the Y coordinate box.
4. Type a Y coordinate value.
5. Press ENTER. The cursor moves to the new X, Y coordinate, scrolling the workspace if necessary.

If a Placement tool is enabled, these boxes let you specify a specific X, Y location at which to place the object.

For certain multi-point objects such as lines, buses, and polygons, you can use these boxes to place the object at specific locations:
1. Choose one of the Placement commands (e.g., Place » Line).
2. Press the J key to set focus on the X coordinate edit box.
3. Type an X coordinate value.
4. Move to the Y coordinate box.
5. Type a Y value.
6. Press ENTER set the start point of the object.
7. Repeat steps 2 through 6 for each point in the object.
8. Press ESC to complete placement of the object.

The coordinate values express either millimeters or mils, depending on the settings in the Options Configure dialog; the decimal point is placed at hundredths for mm, tenths for mils. Negative numbers appear in relative grid mode only when the relative origin point is somewhere other than the lower-left (absolute) origin.

Grid Toggle Buttons

The Grid toggle button and the Grid combo box beside it allow you to easily switch between grid settings and add new grid settings. The toggle switches between absolute grid (Abs, with white background) and relative grid (Rel, with colored background). Your absolute and relative grid values can be changed from the combo box. The A key toggles between absolute and relative grids.
Absolute grid always uses the lower-left corner of the workspace as the origin point (X and Y are both zero). Relative grid allows you to specify any point as an origin point. You can even make the origin point for relative the same as for absolute, thereby making the toggle button a combination of grid sizes rather than absolute vs. relative.

Choose a new grid from the list to add new grids to your design.

To add a new grid, type a new value and press ENTER. The new grid becomes the current grid. The G key scrolls forward through the list of grid settings. SHIFT+G scrolls back through the list.

Macro Record (Temporary Macro) Button

The Macro toggle button, located on the Status Line, allows you to create temporary macros on the fly to produce shortcut functions for temporary use. These temporary macros are named _DEFAULT in the program. Typically, you would use this temporary macro for a short time within a design process (e.g., repeatedly placing a combination of lines, duplicating the same lengths and angles). The M key is equivalent to the M button.

Only one temporary macro is available at a time; each time you record a new macro, it overwrites the previous one.

To Record a Macro
1. Click the M button (or press the M key) to begin recording; the button displays a red background when it is recording.
2. Perform whatever actions you wish to temporarily record.
3. To stop recording, click the M button (or press the M key) again; the red background disappears when it stops the temporary recording.
4. Press the E key to execute the temporary macro. The actions you recorded will repeat at the cursor location each time you press E.

Although it is not common while recording a temporary macro, you can temporarily halt the recording of the macro (to perform an interim action you don't want to be part of the macro recording). Use the Macro Record/Stop command, and click Pause in the dialog. When you do this, the background color of the M button turns to yellow. To resume recording, use the Macro Record/Stop command again and click Resume. To finish recording, click the M button again.

The M key also ends the recording of a named macro (Macro Record/Stop).

To create more permanent macros, use the Macro Record/Stop command to name the macro before recording it. Refer to the command documentation in the Command Reference section of this manual for more information.

The default macro also can be renamed to a more permanent name using the Macro » Rename command.
Layer Display Combo Box and Scroll Buttons

These buttons are a shortcut to the Options » Layers command and dialog. Use the list box (a list of layers) and scroll buttons to select or change layers.

The list box (enabled with the single down arrow) shows a list of current layers from which you can choose. The scroll buttons (up and down arrows) and L and SHIFT+L allow you to scroll through the enabled layers in order.

The color swatch shows the line color for the corresponding layer. Clicking this swatch opens the Options Layers dialog. Line colors can be viewed or altered by using the Options » Display command.

Line Width Combo Box

This combo box presents a list of line widths set using the Options Current Line dialog. You can select a line width or type a new value to add a new line width to the list. The new width becomes the current width. W and SHIFT+W allow you to scroll up and down through the list of line widths.

Radius Combo Box

The Radius combo box displays the current radius setting used when placing polygonal shapes that have rounded corners. You can select a radius setting from the pull down list or enter a new radius number. Radius settings can also be applied using the Options » Current Radius command. The new radius becomes the current radius.

Status Information Area

Displays information relevant to the action you are currently performing.

The information area displays the following types of data:

- Total length of the current line or route you are creating.
- Identifies selected objects either specifically (net name, reference designator and layer) or generally (number of items selected).
- The delta X and delta Y measurements of objects being moved or line segments being stretched.
- Pad numbers when you are numbering them.
Workspace
The workspace is the logical design area in a design. You can alter your workspace size with the Options » Configure command.

The workspace area and the window are not necessarily the same thing. Since the window is rectangular, if you specify your workspace as square and choose View » Zoom Out or View » All, the square workspace area covers the left area of the window, leaving an “out of bounds” area to the right in which no work can be done. The edge of the workspace can be determined by the edge of the displayed grid, or when the cursor readout stops changing. By resizing the window, you can reduce the size of the out of bounds area.

Using Multiple Windows
PCB allows you to open multiple design files at the same time. Additionally, you can have multiple windows open on the same design to view different parts of it simultaneously.

Each design file you open creates a window inside the application window in which you can edit that design. As is standard in Windows, you can change the length and width of each window in relation to the other windows running on your screen. You can also activate or deactivate other screen areas such as the Placement Toolbar and status/prompt line areas, which alternately decreases or increases the available space in the application window.

View Commands
You can use the view commands to control how your design appears on the screen. You can zoom in to see and edit fine details of your design. You can zoom out to view the entire design. Scrolling allows you to move across the screen. The jump commands allow you to jump to a specific component or location.

Zoom Commands
You can use the zoom commands to zoom in and out and move around the workspace, making it easier to perform such functions as creating a board outline, and manually placing components.

(View) Zoom In/Out
When you use the zoom in/out functions, the cursor changes to a magnifying glass shape until you click in the workspace. The spot where you click becomes the center of the zoom area. The amount of zoom is determined by the Zoom Factor value in the Options Configure dialog.

Another way to zoom in and out is to use the plus + key to zoom in and the minus - key to zoom out. When you use the plus key or minus key, you don’t need to click in the workspace to zoom; the cursor location becomes the center of the zoom area.

You must re-invoke the Zoom command (or Zoom key) for every zoom action.
(View) Zoom Window

The zoom window is drawn to enclose a certain area of your workspace, and then fill the screen with the contents of the window.

The three ways to invoke zoom window are the Z key, the **Placement Toolbar Zoom** button, and the **View » Zoom Window** command on the menu. After you invoke the command, click and drag to define the window size in the workspace. Release the mouse button and the window you designated fills the workspace.

Other View Options

The following view options are also available:

- **View » Center**(the C key): centers the design around the current cursor location.
- **View » Extent**: causes the display to encompass all items in the workspace.
- **View » Redraw**: clears everything in the workspace to the background color and then repaints the screen.
- **View » Last**: redraws the previous (last) view, if you have altered the view in any way.
- **View » All**: redraws the screen with the entire workspace shown.
- **Panning**: You can use the C key for panning across the workspace by moving the cursor and pressing C repeatedly; each time you press the C key the display re-centers around the current cursor location.
- **Scroll bars**: Use the scroll bars and scroll boxes to view items that exist beyond the border of a window. Drag the scroll box or click the **scroll button** to pan through a design moving up and down or from side to side.

Jump Commands

Jump commands allow you to jump to a specific component, location, text string or node. For additional information, see **Utils Commands**, (page 497).

**Jump to a Component**

Use the **Edit Components** dialog to view the components in your design.

Select one component from the Components list box and click **Jump** to jump to that component. The component appears in the center of your workspace.

**View Jump Location**

This command allows you to position the cursor to a specified location (X, Y coordinates).

If you are zoomed in, this command pans the workspace to the specified location, attempting to center the location. If the specified location is already visible on the screen, no panning is necessary. The units used for the location value (mil or mm) are determined by the setting in **Options Configure**.
With the select tool enabled, you can use the X, Y Coordinate boxes in the status bar as a shortcut for this command.

**View Jump Text**

This command accesses the View Jump Text dialog. You can use it to search through all text strings and locate a specific combination of letters.

When PCB finds the first instance of the specified text string, it highlights it in the current highlight color. To search for text matches based on case, enable the **Case Sensitive Search** option. To search all layers for the specified text string, enable the **Search Entire Design** option. If this option is disabled, PCB searches the current layer only.

**Jump to a Node**

You can use the Edit Nets dialog to jump to a node attached to a particular net. Select a node from the Nodes list box and click the **Jump to Node** button.

**Using Layers**

PCB allows you to enable and configure up to 999 layers (including the eleven predefined layers) to accommodate even the most demanding PC board designs.

P-CAD PCB (6/400) designs are restricted to a maximum of six copper layers, including a predefined Top and Bottom layer and four user-defined signal or plane layers. P-CAD PCB (6/400) designs can have a total of 999 layers.

You can use the Options Layers dialog to add, name, number, and assign layers to a PCB design. This dialog also lets you arrange layers to reflect the actual layer order of your board. You can enable or disable layers (for display and routing), and make one of the enabled layers current. The dialog displays all existing design layers, and you can create additional layers as needed.

The Current drop down list in the Options Layers dialog allows you to choose a layer to be the current layer. Clicking on the **color swatch** in the status bar opens the Options Layers dialog.

Additionally, you can use the L key or the layer box on the Status Line (combo box and scroll arrows) as a shortcut for selecting the current layer. The current layer is identified by name and color on the Status Line. Use **SHIFT+L** to scroll backwards through the enabled layers.

**Placing Objects**

When you place an object into a design, it is placed on the current layer unless it is an object that is defined on several layers such as a pad, via, or component. These objects are composed of other objects that may be defined on more than one layer.
Item and Layer Drawing Order
Except where overridden, objects on the layers are drawn as follows: plane and non-signal layers are drawn first, followed by signal layers, with the current layer drawn last. Pads defined on the current layer are the last items drawn on the current layer.

Object/Action Interaction
Consistent with other Windows compliant interfaces, the user interface provides you with menu choices, dialogs, options, and feedback based on what is appropriate given the current state of your design and PCB. The interface provides power, flexibility, and logical choices based on the object(s) currently selected and the command or process currently being invoked. For example, the product main menu changes to reflect only those commands that may be accessed when autorouting after the autorouter has been started.

Object Selection and Placement
Current and enabled layer status (Options Layers) affects the selection and placement of objects. Objects are placed individually on the current layer. Objects can be selected on the current layer or on all enabled layers through the Options » Preferences option to Allow Single Select on All Enable Layers.

Block selection of objects depends on the selection masks and filters set in the Options Selection Mask dialog and may be further filtered by enabling and disabling layers using the Options Layers dialog.

Object Selection and Object Properties
Perhaps the most powerful aspect of the interface is its ability to modify one or more objects by selecting the objects and then performing an action on your selection. Items can be individually selected, selected using a set of selection criteria (Options » Selection Mask), or by other methods such as by using the Select button in the Edit Nets dialog.

After an object or collection of objects is selected, you can select all associated net objects, delete, move as a group, highlight the objects, or if the objects are the same type, you can modify or query their properties. (Many of these most frequently used commands can be accessed by clicking the right mouse button after you have selected the objects. This provides an unprecedented ability to globally or individually modify and enhance your design based on your own preferred design style.

Placing Objects
You can use Place commands to draw new objects or place already created objects, such as components, into your design.

The objects that you can place in your design are those listed on the Place menu, in order: Component, Connection, Pad, Via, Line, Arc, Polygon, Point, Copper Pour, Cutout, Keepout, Plane, Room, Text, Attribute, Field, and Dimension.
When you enable one of these Place commands, it remains enabled until you enable a different tool. However, different tools act differently. For example, for the Line tool each click places another line segment until you click the right mouse button. For the Pad tool, each click places a new pad.

When you place an item, it is always placed at a grid point regardless of your cursor setting. See Options Grids (page 439).

Moving Objects
You can move pads, vias, components, points, text, attributes, and fields while you are placing them. Instead of clicking and releasing on a certain location, you can click and hold the mouse button, then move the ghosted outline of the object before releasing to place it. This is the recommended placement method, as you can be more accurate in placement location.

Some of these objects require the interaction of a dialog before the object can be placed (e.g., content of text), but the placement characteristics are the same.

P-CAD PCB (6/400) designs are restricted to a maximum of six copper layers, including a predefined Top and Bottom layer and four user-defined signal or plane layers. P-CAD PCB (6/400) designs can have a total of 999 layers.

Rotating and Flipping Objects
You can also rotate and flip many objects (e.g., components, pads) that appear on your design while you are placing them. For example, when the Place Component tool is active, when you click and hold the left mouse button, you can rotate the component by pressing R or flip it by pressing F before you finally place it.

You can find details on which objects can be rotated or flipped by looking at the specific place command in the command reference chapter of this manual.

Orthogonal Modes
While placing lines, you can press the O key to cycle through the enabled orthogonal modes. The enabled orthogonal modes are determined by the settings in the Options Configure dialog. For placing lines, the modes are limited to line segments (no arcs).

The orthogonal modes are divided into mode pairs, as shown in the following paragraphs. The F key toggles between the mode pair of the orthogonal mode you are in. The “any angle” straight line mode is always available, no matter what orthogonal modes are enabled.

90/90 Line-Line
Both lines are either horizontal or vertical (displayed perpendicular to each other). For long, the first segment is always longer than the second. For short, the first segment is shorter. You can toggle between the two configurations with the F key.
45/90 Line-Line
The first mode makes the first segment displayed at a 45-degree angle and the second segment is either horizontal or vertical. The second mode makes the first segment either horizontal or vertical and the second segment displays at a 45-degree angle. You can toggle between the two modes with the F key.

While performing manual routing with Route Manual, there are three orthogonal mode pairs (six modes) to choose from, including arcs.

Unwinding Segments
You can unwind (undo) a segment with the BACKSPACE key for lines, polygons, copper pours, cutouts, keepouts, and copper that you place.

When you place a multiple segment object, you can press the BACKSPACE key to delete the previous segment. If you have finished placing the object (clicked the right button), then the unwind function does not work. You can undo the placement of a finished object (Edit » Undo), but you cannot unwind it.

Moving Objects to Another Layer
The Edit » Move to Layer command allows you to select a number of objects, and move the objects to the current layer. This facility enhances the ability to clear out congested areas for routing. Additionally, if you have accidentally placed objects on the wrong layer, you can move them easily to the correct layer.

Changing an Arc Centerpoint
While placing an arc, you can alter the centerpoint before the final placement. After you click, drag, and release, the arc start and end points are defined. A second click defines the center point and, therefore, the radius. If you click and drag, you can alter the centerpoint of the arc before you release.

Selecting the F key allows you to toggle between the arc’s beginning and end points.
Using a Snappy Cursor

Use the View » Snap to Grid command to enable a snappy cursor, meaning that the cursor can only move from grid point to grid point, as opposed to a free floating cursor. The benefits of a snappy cursor are mainly a question of personal preference (e.g., you may be accustomed to a snappy cursor from other program applications). Also, a snappy cursor can create a predictable point of reference and placement when moving and rotating objects or measuring distances.

Items are still placed on grid regardless of the cursor setting.

The current setting for Snap to Grid (whether it is enabled or disabled) is saved to your PCB.ini file when you exit the program.

Selecting Objects

The Select tool lets you select objects, which you have placed in your design. When the Select tool is active, data tips appear when the mouse is over an object in the workspace.

The Select tool can be accessed by:

- choosing the Select command from the Edit menu.
- activating the Select tool from the Placement toolbar.
- pressing the S key.

The Select tool is layer-specific by default. If an item is on a specific layer, then that layer must be current to allow selection. Component selection is an exception, since components are not specific to a single layer.

Items are still placed on grid regardless of the cursor setting.

When you select an object, the object appears in the selection color set by the Options » Display command.

Status Line Information

The Status Line information area identifies the item, either specifically (component RefDes or net name) or generally (number of items selected). When possible, the layer name is also displayed.

Component U12 selected on Top layer

Single Select

Once the Select tool is enabled, you can click a single object to select it; the object appears in the Selection color. Any other selected objects are deselected.

Single selection can also be used in conjunction with a Selection Mask, see Using the Selection Masks (page 21) for more details.
Toggling through Objects
If there are overlapping objects, you can enable the Select tool and toggle through them using either the SPACEBAR or the left mouse button to click repeatedly in the same location. Two strokes of the SPACEBAR equal one click and release.

Multiple Select
You can add or remove selected items by holding down the CTRL key and clicking individual items. When you select multiple objects, the number of objects selected is displayed on the Status Line.

If you release the CTRL key and click anywhere other than one of the selected objects, all items are deselected.

In the Mouse tab of the Options Preferences dialog you can set the SHIFT key as the key to use for multiple selections.

Multiple Selection with Collocated Objects
The behavior of the multiple select feature with collocated objects depends on the setting of the Single Select Mode option in the Single Selection tab of the Options Selection Mask dialog.

If the Single Select Mode is set to Cycle-Picking, then as you hold the CTRL key and left-click each collocated object is selected in turn.

If the Single Select Mode is set to Popup Dialog, then whenever you click on collocated objects the following selection dialog is displayed.

The dialog will include a list of all collocated objects, with a check box next to each. Click to enable the checkbox of each object that you wish to select, then when you are ready, click the button at the top left of the dialog with the exclamation character (!) to carry out the selection. Click the X button to cancel the selection action.

Sub Select
The sub select feature lets you select a single part of an object. Once selected, you can view and, in some cases, modify properties for the item selected.

For example, you can select a component pad and bring up a Properties dialog for that pad. Then you can change the pad style for the selected pad.

In the Mouse tab of the Options Preferences dialog you can set the CTRL key as the key to use for a sub selection.
Example
To select pad 8 in a 7400 component:

Hold down the **SHIFT** key and **left mouse button**, and click the pad. The pad, and not the entire component, will be selected.

Block Select
Where single selection is performed by clicking directly on an object to select it, Block Selection allows you to select multiple objects (a block of objects) in a single action.

To block select a group of objects, click and hold the left mouse button in an unoccupied area of the workspace, then drag the mouse. As you drag the mouse a dotted box is displayed, indicating the area that the block selection is to apply to. The standard behavior can then be modified by setting up the Selection Mask, where you can restrict the objects that are selected, the layers that selection is permitted on, or change the behavior of the selected area.

Using the Selection Masks
Choose **Options > Selection Mask** from the menus to display the **Options Selection Mask** dialog, where you define both the Block Selection mask, and the Single Selection mask.
Block Selection Tab

Notice that there are both item check boxes and item buttons (the buttons are a sub-function of the item boxes). The check boxes, when enabled, instruct the selection mask to include all items of that type (e.g., all lines of any width) on the specified layers.

Notice in the figure of the Options Selection Mask dialog (above) that the grayed items each have an item button that is available. Each button displays its respective selection mask dialog for further selection criteria.

If you want to be more specific in the selection of components (for example, selecting only one type), you need to click the Component check box until it turns gray. This makes the component button available. You can then click on the Component button to display the Options Selection Mask dialog in which you can specify the component type, value, etc.
Layers
The layers that are set (highlighted) are included in the selection criteria along with the enabled items. Thus, the selection mask can include both layers and item combinations.

Layer Sets
Use the Layer Sets list box and **Layer Sets** button to quickly limit the selection to a predefined layer set. Do this by:

1. Select a layer set from the Layer Set drop down list box and
2. Click the **Apply Layer Set** button.

The layers belonging to that set are highlighted in the **Layers** box and are used as part of the selection criteria.

Refer to **Layers** (page 425) for information on creating layer sets.

Select Mode Area
Selection is done by clicking in the workspace and dragging the mouse to form a selection rectangle. If you want the selection to take place within the rectangle, click the **Inside Block** radio button in the Select Mode area of the dialog. If you want the selection to take place outside of the rectangle, then click the **Outside Block** radio button. Touching Block will select all items inside and touching the selection block. This is a more inclusive selection option than Inside Block. After you have set the criteria for block selection, you will use the block select function to perform the actual selection. Use the **Edit » Select** command to click and drag a selecting rectangle.

Performing a Block Select
To do a block select, once you have set your selection filters, click and drag to create a selection box around a block of objects. Any objects meeting your selection criteria (items, layers, select mode area) appear in the selection color.

Single Selection Tab
This tab of the Options Selection Mask dialog is used to control the behavior when performing a single selection. The Single Selection tab includes the same options for Items and Layers, refer to the previous topic for information on these. Single Selection also includes the following features.

Current Layer Only
When this option is enabled you can only perform a single selection on the current layer.

Single Selection Mode

**Cycle-Picking** – in this mode collocated objects are ‘cycled through’ by repeated left-clicking of the mouse (or pressing the SPACEBAR twice).

**Popup Dialog** – when this option is enabled a pop-up dialog box appears whenever you click to select at a location where there are collocated objects. The dialog lists all objects that are overlapping, AND are selected in the Items list, AND are in a selected layer in the Layers frame. The dialog displays information on the type of object (e.g. Line), the layer on which the object is placed.
(e.g. Top), any associated Net (e.g. VCC) and any other useful information about the object (e.g. WIDTH=20mil). Click on an object in the dialog to select that object.

<table>
<thead>
<tr>
<th>Type</th>
<th>Layer</th>
<th>Net</th>
<th>Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Top</td>
<td>C15</td>
<td>Type = CAF300, Value = .1</td>
</tr>
<tr>
<td>Line</td>
<td>Top</td>
<td>VCC</td>
<td>Width = 25.0mil</td>
</tr>
<tr>
<td>Line</td>
<td>Bottom</td>
<td>VCC</td>
<td>Width = 50.0mil</td>
</tr>
</tbody>
</table>

The small pop-up dialog can be resized by clicking and dragging on an edge or corner.

**Edit Deselect All**
You can click on an empty area outside of the selection region or use the **Edit » Deselect All** command to deselect all items. The **Select** tool is enabled, but no objects are selected.

**Edit Select All**
You can select all objects in the active window by using the **Edit » Select All** command.

**Selecting a Net**
There are two ways you can select all items in the net to which an item is connected.

The first way is to use the **Edit Nets** dialog. Select a net from the list in the dialog and click the **Select** button.

The second way is to select the item, click the **right mouse button**, and choose **Select Net** from the popup menu.

In both cases, the complete net is highlighted as selected, subject to any criteria set in **Options » Selection Mask**.

**Select Highlighted**
Highlighted objects can be selected by choosing **Edit » Select Highlighted** from the menus.

**Editing Objects**
Once objects have been selected, you can perform editing functions discussed in this section.

These functions do not work on fixed components.

P-CAD PCB (6/400) designs are restricted to a maximum of 400 components. Therefore, when using P-CAD PCB (6/400), do not exceed this number when pasting components into your design or duplicating components using Copy Matrix.
Selection Reference Point

A selection reference point is used and automatically appears with all select operations such as moving, copying, rotating, flipping and pasting. To specify a location different than the default, select the object(s), click the right mouse button to access the pop up menu containing the Selection Point option, and select the position of the reference point with respect to the selected item. If you don’t specify a different location for the selection reference point, PCB uses a default reference point.

Clipboard cut/copy/paste operations support the user-defined reference point. The default selection point appears in the center during block operations.

Moving Objects

If the selection reference point is off-grid when a move operation begins, then it is automatically snapped to the nearest grid point and all the selected objects move the same relative distance.

Flipping and Rotating Objects

Components are flipped and rotated about the reference point. Additionally, components can be aligned around a selection reference point either horizontally or vertically.

Aligning Components

Components can be aligned vertically or horizontally, around a selection reference point. Place a selection reference point at the point of alignment. Then choose Edit » Align Components and set the desired alignment options.

Copying and Pasting Objects

The selection reference point is saved to the clipboard or to a block file and automatically restored when pasting objects into your design. When pasting, an object’s reference point snaps to grid.

Moving Objects

To move an object, select it, then click on the object and drag the cursor to the new location. Release to place the object. You can also move an object by selecting it and using the arrow keys to reposition the object in the workspace.

When you move an object connected to other objects, the connections remain in place after the move.

If you are moving multiple objects within a selection box, click anywhere in the selection box and drag. All the selected objects in the box follow. Release the button to place the objects.

When selecting and moving several components into position, the connections rubberband to maintain the established nets.

Rotating and Flipping Objects

You can rotate and flip many objects once they have been placed in your design. First select the object. Then press the R key to rotate the object 90 degrees counterclockwise; press SHIFT+R to rotate it by an amount specified in Options Configure. Press F to flip the object.
You can find details on which objects can be rotated or flipped by looking at the specific place command in the command reference chapter of this manual.

**Resizing an Object**

You can resize an object by clicking one of its handles and dragging to stretch the object. Handles are the squares displayed when certain objects are selected singly. They appear only if you select one object, and if the object can be resized.

The resize function varies among the different objects (some objects cannot be resized with this function, e.g., pads and vias).

For example, to resize an arc you click one of the endpoint resize handles and drag the endpoint to increase the sweep angle. To resize a polygon, you can grab one of its vertex handles and move it to change the polygon.

When you move a polygon handle that is on an edge between two vertices, a new vertex is created (allowing you even more reshaping). You can delete a vertex by moving it to an adjacent vertex and releasing.

Lines, Arcs, Polygons, Copper Pours, Keepouts, Planes, Rooms and Cutouts can be resized.

**Rounding Corners of Polygonal Shapes**

The corners of polygonal shapes (polygons, copper pours, polygon keepouts, cutouts and planes) can be rounded. The rounded corner forms a filleted edge, which is the rounded intersection of two edges. This intersection of the two edges is created with an arc of a specified radius that is tangential to both edges.

A new radius can be added by entering it directly into the Radius combo box on the Status Line or by choosing the **Options » Current Radius** command and entering the new values in the **Current Radius** dialog. You can choose the desired radius from those in the Radius combo box drop down list on the Status Line. The radius displayed in the combo box is the current setting.

When a polygonal shape has filleted corners, additional handles appear in the shape as shown below:

To change the radius of a filleted corner, grab the interior handle and drag it until you see the desired radius for the corner. The radius displayed in the Radius combo box on the Status Line only affects the polygonal shape at the time of placement or during modification. You can also access radius settings by double clicking the polygonal shape to display the **Properties** dialog where you can make modifications to the definition or filleted points.
Cutting, Copying, and Pasting Objects

Once an object or objects have been selected, the selection can be cut or copied to the Windows clipboard, and clipboard objects can be pasted back into the design or stored in the file where you can paste the selection in at a later time.

Cutting Objects (Ctrl+X)

You can cut objects from a design and paste them into a new location, into a new design, or even into another application using the cut and paste functions. To cut an object, select it and choose the Edit » Cut command or press Ctrl+X.

The object is moved to the Windows clipboard, from where you can paste it.

When you choose Edit » Cut to remove objects from nets, you can get a variety of results, depending on what you cut and the makeup of the net you remove it from. The function of smart nets is to maintain certain connections when objects such as copper connections, unrouted connections, and net nodes are removed.

Copying Objects (Ctrl+C)

You can copy objects from a design and store them in the Windows clipboard. To copy an object, select it and choose the Edit » Copy command or press Ctrl+C.

Drag-and-Drop (Ctrl+Left Click)

For copying within the same design, you can also use the shortcut copy drag-and-drop. This works just like moving objects with drag-and-drop, except you are copying the object instead of moving it. You first enable Edit » Select mode, click on the object to select it, then Ctrl+left click and drag to where you want to place the copied object.

Copying to a File

The Edit » Copy to File command provides a shortcut for copying objects and net information to a file.

When you select the Edit » Copy to File command a dialog appears where you can pick a filename and save the data you are copying. Later, you can use the Paste from File or Edit » Paste Circuit From File commands to paste the information into a different design or the same design.

Pasting Objects (Ctrl+V)

To paste object(s) from the Windows clipboard, choose the Edit » Paste From Clipboard command or press Ctrl+V. Objects saved to a block file can be pasted using the Edit » Paste From File command.

Objects and net information copied to the clipboard or a block file can be pasted using the Paste Circuit and Paste Circuit From File commands, respectively. These two paste commands provide the ability to control how the copied components and nets are incrementally named when pasted and the option to choose which net attributes are retained.
Pasting From a File
The Edit » Paste from File command provides a shortcut for pasting objects and net information from a file to the design.

Pasting a Circuit From a File
The Edit » Paste Circuit from File command provides a shortcut for pasting objects and net information into a design. When using the Paste Circuit from File command, you retain the ability to control how the pasted objects are named and which net attributes are retained.

Pasting Limitations
You must have enough space in the target workspace location for the items you are pasting. If the space isn't sufficient or you are too close to the edge, the data cannot be pasted.

When cutting or copying objects between designs, the pasted objects automatically appear on the same layer that they were cut or copied from, if they are layer specific, regardless of the current layer. If the target layer does not exist in the target design, the items are not pasted.

Use the Edit » Paste to Layer command to paste all items in the clipboard to a specific layer.

Using the Copy Matrix Command
The Edit » Copy Matrix command allows you to create a matrix of objects. You can use this command to duplicate one or more selected objects in both the horizontal and vertical directions. For example, you could use this command to select a pad and create two columns of eight pads, or you can select an existing column and create any number of additional columns.

The settings selected in the Copy Matrix dialog are retained throughout your PCB session.

Using the Edit Properties Command
The Edit » Properties command allows you to select an object and change many of its settings (i.e., properties). For example, when you select an arc and choose the Edit » Properties command, you can change the arc’s start and end angles. See the next section, Properties, for additional details.

Properties
You can display and change an object’s properties any of the following ways:
• Choose the Edit » Properties command (See the Edit Properties command section).
• Click the right mouse button and select Properties from the pop-up menu that appears.
• Left double-click the selected object.

The Properties dialog that appears depends on the object you selected. For example, if you select a pad and choose Edit » Properties, the Properties dialog that appears would show pad properties.
Properties of Multiple Objects

When displaying the properties of multiple objects, the result depends on whether the objects are of the same type.

Objects of the Same Type

If the objects are the same type, but have different styles or other characteristics, then the Properties dialog appears, but specific information about the objects will be blank or grayed where the information differs between objects.

You can enter information in the dialog and click OK, and then all of the selected objects uniformly take on the characteristics (e.g., dimensions) of what you specified in the dialog. You can use the block selection mask to restrict selection; refer to the Options » Selection Mask command.

Although you cannot display the properties of objects of different types, you can perform other edit commands

Right Mouse Commands

When you select an object and click the right mouse button, a pop-up menu appears providing shortcuts to common commands performed on selected objects. This menu changes depending on the object you select.

The following section summarizes the commands, which appear on the pop-up menu:

Add To Net
This command allows you to add a pad or via to a net. The pad or via must not currently be assigned to a net. Use the complementary Remove From Net to remove a pad or via from a net.

Add Vertex
This command inserts a vertex in the selected line or trace.

Align
A shortcut for Edit » Align Components. Components can be aligned around a selection reference point either horizontally or vertically, and as an option, equally spacing the parts.

Alter
A shortcut for Edit » Alter Components, which allows you to select certain component items and subsequently move, rotate, flip, and (in some cases) delete them.

Copy Matrix
A shortcut to Edit » Copy Matrix. Duplicates selected objects based on parameters you choose.

Copy
A shortcut to Edit » Copy. Allows you to copy the object to the clipboard.

Cut
A shortcut to Edit » Cut. Allows you to cut the object to the clipboard.

Delete
A shortcut to Edit » Delete. This command deletes selected objects.

Edit Nets
A shortcut to Edit » Nets. This command brings up the Edit Nets
dialog with the nets containing the selected objects pre-highlighted in the net list box.

**Explode**
A shortcut to Edit » Explode Component. This command allows you to convert a pattern back to its basic primitives, creating a collection of editable graphic objects.

**Fix**
A shortcut for Edit » Fix » Fix. This command sets the selected object to be fixed in the workspace.

**Highlight**
A shortcut to Edit » Highlight. This command highlights the selected objects in the current highlight color.

**Highlight Attached Nets**
This command highlights nets attached to the selected objects in the current highlight color.

This also highlights the corresponding items (for nets and components) in Schematic if the DDE Hotlinks check box in the Options Configure dialog is checked.

**Highlight Included List**
This command highlights the components in the selected room’s Included Component List.

**Net Info**
This command brings up a dialog providing information about the selected net.

**Properties**
A shortcut to Edit » Properties. Depending on the object(s) selected, the appropriate Edit Properties dialog appears.

**Remove From Net**
This command allows you to remove a pad or via from its net.

**Select Net**
This command highlights all items in the net to which the selected item is connected.

**Selection Point**
This command allows you to relocate a selection reference point for the selected object or objects.

**Unfix**
A shortcut for Edit » Fix » Unfix. This command unfixes the selected object, allowing it to be moved in the workspace.

**Unhighlight**
A shortcut to Edit » Unhighlight. This command removes the highlighting from selected objects.

**Unhighlight Attached Nets**
This command removes the highlighting from nets attached to the selected objects.

**Unhighlight Included List**
This command removes the highlighting from a room’s Included Component List.
Loading and Saving Files

In addition to P-CAD PCB binary files, PCB can also load and save the following file formats:

- ASCII
- P-CAD Shape-Based Router format
- DXF mechanical CAD format
- IDF V3 format
- PDIF files
- RFQ WebQuote format (Save only)

Use the **File » Open**, **File » Save**, and **File » Save As** commands to load and save ASCII. All other formats are accessed via the **File » Import**, and **File » Export** sub-menus. For additional information, refer to the appropriate commands in the reference section of this manual.

Drag and Drop File Load

You can use the drag and drop method for loading files into PCB.

You can use the drag and drop method for opening PCB design files (.pcb), loading netlist files (.net and .alt), and opening library files (.lib) from the File Manager or other Windows file maintenance utilities. Just click the filename in the utility, drag it to the PCB window or reduced icon, and release. The specified file opens.
Tutorial - PCB Design Session

Introduction
Welcome to the P-CAD PCB tutorial. During this tutorial, we will be exploring the design process from setting up the workspace and placing objects through to Gerber file output. This tutorial uses some demonstration files that are supplied with P-CAD.

Setting up the workspace
Before you begin placing components on your board and setting up the design rules, for example, you should specify the physical properties of the board you are designing.

Using the commands in the Options menu, you can set PCB's options to fit your design needs, such as configuration options, layers, display colors and grids. Your settings are saved with your current design and become the new defaults for subsequent design sessions.

Setting workspace configuration and display options
The Options menu commands are used to set up the environment of your workspace. These settings are stored with the current PCB file and become the new defaults for subsequent design sessions.

Setting the workspace size
The workspace is the logical design area in a design. You can alter your workspace size with the Options Configure command.

1. Choose Options » Configure and click the General tab of the Options Configure dialog.
2. Select the **mils** button in the Units frame. Make sure your workspace size is set to 11000 by 8500 mils, to match an 11" x 8.5" sheet of paper (landscape orientation). You may wish to increase the workspace later to allow more space around the sheet during object placement.

3. While we are in this option, click the **Route** tab and select all check boxes in the Orthogonal Modes frame to allow all modes to be available when placing lines and arcs. Click **OK** to continue.
Setting up the workspace

Chapter 4: Tutorial - PCB Design Session

For details on the other options in the Options Configure dialog, refer to the Options Commands chapter.

Setting up layers

Next, we will set up a new layer for a title block. You can use this method to set up the number of layers you require in a design. When you add (create) a layer, you must specify a layer type and a unique name and layer number. The layer definitions you establish here are saved as part of the design file.

1. Choose Options » Layers. The Options Layers dialog appears.

2. Choose a layer Type of Non-Signal, as the title block should reside on a non-signal layer.

3. Type a new layer name in the Layer Name text box, e.g. Title.

4. Specify a Layer Number (up to 988) or allow the program to choose the next available layer number when you click Add.

5. Click Add. The new layer, Title, is enabled (available for use) by default. It is listed in the Layer list with the layer code NE (N=Non-Signal, E=Enabled), the layer number to the right and the Line color set by default. We will look into changing layer display colors later in this section of the tutorial.

6. Select Title from the Current Layer list. This layer becomes the current layer on which you can place the objects that make up a title block and sheet border.

7. Click Close to exit the dialog and retain the settings.

The easiest way to change the current layer is to use the layer controls on the status line. You can also switch between layers by pressing L (cycle downward) or SHIFT+L (cycle upward).
Title blocks

First we will set up a title block and border, as illustrated below, using the Titles tab of the Options Layers dialog. The title block, which comes from a supplied .tbk file, and the border are not selectable and can only be changed or removed through the Titles tab.

When you change layers to start object placement and use a zoom command, the Title layer no longer displays. You can check that placed objects are within the border by making Title the current layer and choosing View » Redraw to see the border and title block again.

1. Choose Options » Layers again and click on the Titles tab.
2. Select Display Border. Notice that the border dimensions have automatically adjusted to allow 500mil (.5 inch) between the edge of your workspace and the edge of the border.
3. Set up the zones that display in the border as reference marks. Type 4 in both # of Zones boxes to create four zones in both horizontal and vertical directions and select Annotate Zone Information.
4. Now we can select a title block that has been supplied with P-CAD with lines and text fields already inserted. Click on Select to choose a filename of an existing title block. Choose ADT_AB.tbk from the Titles folder in the P-CAD installation directory and click Open.

5. Within the title block we chose in the step above, there are design information fields that display the values you enter in their appropriate place. Click Fields to display the Fields tab of the Design Info dialog.
6. Select a field name you wish to include in the title block, e.g. Title, click on Properties and enter the value in the Field Properties dialog, e.g. Tutorial exercise, and click OK.

7. Repeat the step above for all required fields, e.g. Drawing Number, Revision, Date and Drawn By, and click on Close to complete and return to the Options Layers Titles tab.

8. Click Modify to apply the changes and then Close. The title block will display in the workspace with the design information entered.

9. You can change the design information at any time by changing the field properties using the procedure above or choosing File » Design Info. Refresh the screen to see the changes by choosing View » Redraw.

You may wish to create your own title blocks (filename.tbk) by placing lines, fields, graphics and text. For more information about title blocks, refer to Options Commands.

Next we will set up the other workspace options that will be saved with this file.

**Display Options**

Display options allow you to define the color and display preferences for your workspace. You can use the same color on all layers for an item, the same color for all items on a layer, or distinct colors for items per layer. To set your color preferences:

1. Choose Options » Display. The Options Display dialog displays. Click on the Colors tab.

2. There are three ways to set color options:
   - To select a color for everything that appears on a layer, click the corresponding layer button and select a color from the palette that appears. For example, click the Top button to select a color for everything that appears on the Top layer of your design.
To choose a color for every instance of an object, click an item button. For example, click Via to choose a color for vias. This color is applied to vias on all layers of your design.

To choose a color for an object on a specific layer, right-click the colored square where the object and layer meet in the color matrix. Then, choose a color from the pop up color palette.

3. When you’ve finished setting up color options, click OK to close the dialog.

To learn about setting up colors, or the Miscellaneous tab options, see the Options Commands chapter.

**Setting the line width**

The width of lines placed on the board is determined by the current line width. We will set up a current line width here that will allow you to get started with placing lines in the next section of the tutorial.


![Options Current Line dialog](image)

2. Set the line width to 8 mils by typing 8 in the Line Width box and click Add. The line width is added to the list for future easy access from the status line.

3. Alternatively, type a line width in the Line Width list on the status line and press Enter.

**Setting grids**

A 100mil grid works well for placing through-hole components. This gives you maximum flexibility when selecting a grid for routing. Later in this tutorial we will look at non-uniform relative grids, which are useful when routing multiple tracks between pads and autorouting. Default colors for grids are set as green (10X grid) and white (1X grid) and can be changed by choosing the Options » Display.

To set the current absolute grid:

1. Choose Options » Grids and select a grid spacing of 100mil from the options available.

2. If you wish to create a new grid spacing, simply type in the new spacing in the Grid Spacing box and click Add. The new setting appears in the list and becomes the current grid setting.
3. Make sure the grid is **Visible** and the mode is **Absolute**. This sets the grid origin point to be the lower-left corner of the workspace, i.e. X and Y are both zero. Click **OK**.

4. Alternatively, set a grid by using the grid controls on the status line, i.e. click on the **Abs** (Absolute) button to toggle to **Rel** (Relative) and back. Choose a grid spacing from the list to the right of the Abs button, or type a grid spacing in the Grid Select list on the status line and press **Enter**.

5. If the grid is not immediately visible on the screen, use + (plus) key on the keypad to zoom in on your design. Press the - (minus) key to zoom out.

6. Save this file by choosing **File » Save**. Type in the filename **Titleblock.pcb**, choose the directory you want to save it in and click on **Save**. Do not close the file as we will use it during this tutorial as we practice object placement, selection and modification methods.

---

**Object placement**

This section of the PCB tutorial shows you how to place simple objects, such as lines, arcs, pads, vias, text and fields. In the following sections, we will try selecting, moving and modifying the objects you have placed. Remember that you remain in the placement mode you have chosen until you select another mode.

**Placing lines**

Lines are graphical objects used for creating title blocks, board and component outlines. Lines and arcs are non-electrical entities, but they do create copper and will affect design rule checking if you place them on signal layers. You can create a single line or multi-segment lines using the **Place » Line** command.

**Placing a single line**

1. Make sure your new PCB file, **Titleblock.pcb**, is open.

2. Set the line width you wish to use by choosing **Options » Current Line**, or select or enter a line width in the Line Width list on the status line.
3. Select the layer on which to place lines, either by the status line layer feature, or by choosing Options » Layers. You can switch between layers by pressing L or SHIFT+L. Choose the Top layer using one of these methods.

4. Choose Place » Line or click the toolbar button.
   While you draw a line or segments, the cursor is displayed as a crosshair. When you finish the line segments, the cursor returns to its normal shape.

5. Press and hold down the left mouse button where you want to start the line. Drag the mouse to draw the line and release the left button where you want the line to end. Lines will snap to the nearest gridpoint to the cursor. Pressing the BACKSPACE (unwind) key at this stage will return the cursor to the start point.

6. To permanently place the line, right-click or press ESC. The line will change to the color of the layer it is placed on. Then you can begin another line at a new location. You will remain in Line Placement mode until you select another mode.

Placing multi-segment lines
This time we will place multi-segment lines and use the orthogonal modes we set by choosing Options » Configure and clicking the Route tab in the setup section of this tutorial. We will also change layers while placing lines.

To place a multi-segment line, follow these steps:
1. Press and hold down the mouse button where you want to start the line. Drag the mouse to draw the line and release where you want the line to end. Repeat this action and draw two or three more line segments.

2. Watch the status line as you draw line segments. The dX and dY measurements are given while you drag a segment, and the total line length is given when you complete each segment.

3. Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles. The available orthogonal modes are provided as mode pairs. Press the O key to cycle through the mode pairs and the F key to switch (flip) between the current mode pair while you are placing line segments.

4. Between some segments, press the L key (or SHIFT+L) to switch between layers. Lines drawn in different layers will display in its layer color when the line is permanently placed.

5. Use the BACKSPACE (unwind) key to delete the last segment drawn.

6. Right-click or press ESC to finish the series of segments. Choose Edit » Undo or click the Undo toolbar button to delete the whole series of segments.

Placing arcs
Arcs can be partial or full circles and are graphical objects only. The line width of an arc is set in the same way as for placing lines. You remain in arc placement mode until another mode is selected.
Creating an arc
1. Choose Place » Arc or click the toolbar button. The cursor changes to a crosshair while you are drawing an arc.
2. Move the cursor to a grid point in your workspace. Use the X and Y grid readout in the status line to aid in accurate construction.
3. Click and drag up and right at a 45-degree angle to another grid point, then release. The click (down) and release (up) define the start and end point of the arc and so create the diameter of the arc.
4. The unfinished arc should look like a (in the figure shown). Click and drag the centerpoint up and left to form a 90-degree corner like b. Release and you will have created a 90-degree arc, like c.
5. An arc can be flipped over while you are placing it by pressing the F key before you complete it.

Creating a circle
If the start and end point of the arc are in the same place, the arc defines a circle. In this case, the second click and drag moves the center point of the circle away from the defined point on the circumference.
1. To create a circle, move the cursor to a grid point in your workspace and click. This will define a point on the circumference of the circle.
2. Click where you wish the center of the circle to be placed and a circle will appear.

Placing pads
Pads and vias are placed with a pad/via style (also known as a stack) attached. We will explore pad and via styles in more depth in the section Using Pad and Via Stacks later in this tutorial.
To place pads, follow these steps:
1. Choose Options » Pad Style. When the Options Pad Style dialog appears, examine the current pad style. There is at least one default style.
2. Double-click a pad style in the Current Style list. An asterisk (*) marks the current pad style. Then, click Close.
3. Choose Place » Pad or click the toolbar button.
4. Click where you want to place the pad in the workspace. P-CAD places the pad near the cursor location and the pad center snaps to the nearest grid point. If you can’t see the pad, press the + key to zoom in. Pads display in the color set using Options » Display.
5. To place another pad, press and hold down the mouse button, move the ghosted image of the pad to the position you want, and release the mouse button.
6. Place a few more pads, moving them into different positions. You will use these objects later when you practice deleting and modifying objects.
**Placing vias**

Vias do not belong to a particular layer. The via you place has all of the properties associated with the current via style. To place a buried via, for example, the current style must be set up to have a shape defined only on a buried layer. Vias are almost identical to pads in the way that they are placed, rotated, flipped, and edited.

1. Choose **Options » Pad Style**. When the *Options Via Style* dialog appears, examine the current via style.
2. Double-click a pad style in the Current Style list. An asterisk (*) marks the current via style. Then, click **Close**.
3. Choose **Place » Via** or click the toolbar button to place a via in your design.
4. To place another via, press and hold down the mouse button, move the ghosted image of the via to the position you want, and release the mouse button.

   For more information about pad and via styles, see *Using Pad and Via Stacks* later in this tutorial.

**Placing text**

The Place Text command allows you to place text on your design.

1. Choose **Place » Text** command or click the toolbar button and click where you wish to place the text string. The *Place Text* dialog appears at the bottom of the screen. You may need to move the dialog up slightly to access the text style options.
2. Type in the text you require in the dialog. Click **More»** to change the font, rotation or text justification.
3. Click **Place** and the text displays in the color of the layer it has been placed on.

   For information about text styles used with placing text and fields, refer to *Options Text Styles* in the *Options Commands* chapter.
Placing fields

This command places a field containing design information such as date, time, author, etc. The value of a field placed in the design, with the exception of Current Date/Time, Filename and Modified Date, must be specified in the Field Properties dialog, otherwise you place a generic field, e.g. {Author} rather than the author’s name. Current date and current time are taken from the computer’s clock.

1. Choose the **Place » Field** command or click the **Field** toolbar button.
2. The **Field Properties** dialog is accessed from the **File » Design Info** command (**Fields** tab) by selecting a field name and clicking on **Properties**.
3. By selecting a placed field and choosing **Properties** from the shortcut menu, you can change the font and justification properties, or add new text styles.

Placing components

Before you can place components, you need to add one or more libraries that contain the components. The components can come from libraries that are provided with the P-CAD program or they can be ones that you create. Components can then be placed, flipped and rotated.

Setting up libraries

Every time you place a component, the program searches the library you specify in the Place Component dialog. You can open additional libraries, as long as the maximum number of open libraries (100) is not exceeded.

1. Choose **Library » Setup** to open the following dialog.
2. To open a library, click Add. The Library File Listing dialog appears.
3. In the dialog, navigate to the directory containing the library that you want to open, i.e. 
   Demo.lib in the Demo folder of the P-CAD installation directory.
4. Select the library file. Then, click Open to add the library to Open Libraries list.
5. Click OK. The libraries that you have specified are now open and therefore accessible for
   component placement.

Adding components

Once the appropriate libraries are open, it is time to place some components. We will place several
different types of components that we will use later in this tutorial.

1. Choose Place » Component or click the toolbar button and click in the workspace. The 
   Place Component dialog appears.
2. Select the component that has an attached pattern from the Component Name list. A pattern is attached to a component if a pattern name appears in the top-right corner and displays below in the dialog box, e.g. CAP300. We will place some capacitors named CAP300 first.

3. In the Place Component dialog, type a value in the Ref Des box, e.g. C1, to set the reference designator for this component and click OK.

4. A ghosted outline of the component will appear on the cursor and can then be moved to where you wish to place it.

5. Choose one of these methods to place the component:
   - For quick placement, click the location at which you want to place the part.
   - For accurate placement, do the following:
     1. Hold down the left mouse button or press the SPACEBAR.
     2. Move the ghosted component to the location you want. If appropriate, press F to flip or R to rotate the component by 90 degrees counterclockwise. You can press SHIFT+R to rotate the component by the Rotation Increment set in the General tab of Options » Configure. If you do not set a rotation increment, the rotation increment is set to 45 degrees by default.
     3. Place the component by releasing the mouse button or by pressing the SPACEBAR.

6. When you have placed the component, the reference designator and component type are updated.

7. Place a few more components using the different methods outlined in the step above. Choose a variety of components, such as resistors and connectors.
Selecting objects

This section of the tutorial explores the variety of ways to select single and multiple objects. Place two or three pads in the workspace if you haven’t done so in the previous section.

If the Show DataTips feature is enabled in the Miscellaneous tab of Options » Display, a Data Tip appears when you move the cursor over an object in your design. Data Tips show context-sensitive information about design objects and can assist you in selecting the appropriate object.

Selecting single objects

To select a single object, follow these steps:

1. Press the + (plus) key to zoom in on your workspace. This makes viewing objects easier.
2. Press S or click the Select button on the command toolbar as a shortcut for choosing Edit » Select.
3. Click a pad to select it. The pad will display in the selection color (set in Options » Display) with a bounding box around it.
4. To deselect the pad, click in a blank space in your workspace to cancel the selection of the pad.

Selecting multiple objects

To select multiple objects, follow these steps:

1. Select the first pad.
2. Hold down the CTRL key and select another pad (Ctrl+Click). Notice that both pads are selected and the bounding box includes all selected pads.
3. To deselect the pads, click in a blank space in your workspace.

Subselecting objects

You can select objects that make up a component. For example, you can select a pad that belongs to a component. To subselect an object, follow these steps:

1. Place a component in the workspace using the Place » Component command.
2. Press S or click the Select button on the command toolbar as a shortcut for choosing Edit » Select.
3. Hold down the SHIFT key and click on a pad that belongs to the component. Notice that only the pad is selected.

8. When you have finished placing components, right-click or press ESC and then choose S for Edit » Select to exit from part placement mode.

9. We will be using these placed components when we look at selecting and modifying objects, so save the PCB file by choosing File » Save but do not close.
4. Now, you can perform actions on the pad. For example, you can right-click the pad and choose Properties from the shortcut menu to query the pad.

**Block selecting objects**

To select a group of objects, you can perform a block select. To block select, follow these steps:

1. Hold down the mouse button and drag the cursor across your workspace to draw a bounding outline around two or three pads.
2. Release the mouse button to select the pads.
3. Deselect the pads by clicking in a blank area of the workspace.

**Block selecting using Selection Mask**

You can define block selection criteria to specify which particular objects are selected when you perform a block select. This time, we will block select the capacitors, CAP300, we placed earlier by using their Type to define the selection criteria.

1. Choose Options » Selection Mask and click the Block Selection tab if it is not active. The Block Selection dialog appears. The check boxes have three states: checked (included); blank (excluded) or shaded (masked with additional selection criteria).
2. Click the Clear All button to clear the default selection of all items. All of the item check boxes will become blank and the item buttons become shaded.
3. Click the Component check box until a shaded check mark appears. When the Component button becomes available, click Component. The Component Selection Mask dialog appears.
4. In the Type text box, type: CAP300, or choose it from the list.
5. Click OK to save the changes and return to the Options Selection Mask dialog.
6. In the Layers frame, click Set All to select all layers.
7. Select Inside Block as the Select Mode and click OK to set your selection criteria and close the dialog.
8. Choose View »Extent to make sure the entire design is displayed in the workspace.
9. Draw a bounding outline around the entire design. When you release the mouse button, notice that only the CAP300 components are selected.
10. Remember to clear your filter when you have finished using Block selection by choosing Options » Selection Mask again and clicking Set All and OK.

Selecting highlighted objects
You can select objects that have been highlighted with the highlighter feature in P-CAD PCB.

1. Highlight a few objects by selecting them first, then right-click and choose Highlight from the shortcut menu. The objects will display in the Highlight color set using Options » Display.
2. To select the highlighted objects, choose Edit » Select Highlighted. Only the objects highlighted in step 1 will be selected.

Selecting collocated objects
When objects overlap so that you cannot select any one of them, you can switch between the collocated objects even if they reside on different layers. The switching style used depends on the selection made in the Single Select Mode in the Single Selection tab of the Options Selection Mask dialog.

Selecting single collocated objects
Before using these selection modes, add some objects that are collocated (in the same position).

1. Place a line on the current layer, e.g. Top.
2. Switch to another layer and place a line in the same position, e.g., Bottom. Repeat this step on at least one other layer, e.g. Bottom Silk.

Cycle Picking
To toggle through collocated objects and select one object:

1. Set up the single selection criteria by choosing Options » Selection Mask. Click on the Single Selection tab and select Cycle Picking in the Single Select Mode frame.
2. Position the cursor over the collocated objects.
3. Click the left mouse button to toggle between objects. Information about the currently selected item displays in the status line, e.g. 'Component RN3 selected on Top Layer'.

Popup dialog
To choose an object to select from a list of collocated objects on different layers:

1. If you choose Popup Dialog in Single Select Mode frame of the Single Selection tab, click the left mouse button once over the collocated objects to bring up the dialog. The popup dialog
lists information about all overlapping objects that are selected in the Items list and in a selected layer in the Layers frame.

<table>
<thead>
<tr>
<th>Type</th>
<th>Layer</th>
<th>Net</th>
<th>Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Top</td>
<td></td>
<td>Width = 10.0mil</td>
</tr>
<tr>
<td>Line</td>
<td>Bottom</td>
<td></td>
<td>Width = 10.0mil</td>
</tr>
<tr>
<td>Line</td>
<td>Bot Silkscreen</td>
<td></td>
<td>Width = 10.0mil</td>
</tr>
</tbody>
</table>

2. When the dialog first opens, the first object in the list is highlighted. The objects are listed in layer order, from top-most layer to bottom-most layer.

3. Click the required object in the list to make it the selected object and close the dialog.

4. Click again to bring up the dialog if required.

5. To close the dialog without selecting any objects, click on the crossed box or press ESC.

**Selecting multiple collocated objects**

You can select more than one object that has the same position if you have chosen the Popup Dialog option.

1. **Ctrl+Click** over the collocated objects to bring up the popup dialog.

2. Click the checkboxes to choose the objects you require.

3. Click on the box to close the dialog and select the nominated objects in the workspace.

You could also combine the selection of collated objects with the selection of other objects that do not overlap, by using **Ctrl+Click** to multiple select.
Modifying objects

In this section of the tutorial, we will practice modifying the graphical properties and attributes of the objects we have already placed. We will cover the following commands:

- move, align, rotate and resize objects
- copy, paste, duplicate and delete objects
- change object properties using the properties dialogs and selection masks.

Moving objects

To move a single object, follow these steps:

1. Select a pad in the workspace.
2. Press and hold down the mouse button over the selected pad. Then, drag the pad to a new location.
3. Release the button to place the pad at the new location. This works the same with all objects (e.g., lines, arcs, polygons, etc.)

If the selection reference point is off-grid when a move operation begins, then it automatically snaps to the nearest grid point and all selected objects move the same relative distance.

Moving a group of objects

To move a group of objects, follow these steps:

1. Select a group of objects using one of these methods:
   - Block select by dragging a bounding outline around a group of pads to select them
   - Select a pad, hold down the \texttt{CTRL} key, and then click other pads to add them to your selection.

2. After you have selected the pads, press and hold down the mouse button anywhere in the bounding outline. Then, move the objects where you want to place them and release the mouse button. Alternatively, pressing \texttt{ALT+Click} gives you the ability to move the mouse freely without having to keep the left button depressed.

This process works the same way for all objects.

Rotating objects

You can rotate objects, such as lines, arcs, text and components, after they have been placed.

1. Select a component to demonstrate this command.
2. Press and hold down the mouse button. While you are holding the button down, press \texttt{R}. The object rotates 90 degrees counterclockwise. Release the mouse button to place the component.
3. You can also press \texttt{SHIFT+R} to rotate the component by the Rotation Increment set in the \texttt{General} tab of \texttt{Options » Configure}. If you do not set a rotation increment, the rotation increment is set to 45 degrees by default.

4. Deselect the object by clicking in an empty space.

\textbf{Customizing rotation increments}

P-CAD PCB’s 32-bit database provides the precision to rotate objects down to 0.1 degree, without round-off errors. This means, for example, that a component rotated 7.5 degrees 48 times, will be returned to its exact original position.

1. Choose \texttt{Options » Configure} to set the rotation increment.

2. Type a value in the Rotation Increment box in the \texttt{General} tab of the \texttt{Options Configure} dialog.

3. Select one or more components and press \texttt{SHIFT+R} to rotate selected items by the custom Rotation Increment.

\textbf{Resizing objects}

You can resize and reshape lines, arcs, polygons, copper pours, polygonal keepouts, and cutouts. For this exercise, you will resize a line. To do this, follow these steps:

1. Select a line in the workspace. Notice that two resize handles appear at each end of the line.

2. With the line selected, move your cursor and position it over one of the handles. Press and hold down the mouse button over a handle, then move the cursor to increase or decrease the length of the line.

3. Release the mouse button. Notice the size of the line has changed.

4. Deselect the object by clicking in an empty area of the workspace.

\textbf{Adding a vertex}

You can add a vertex to a line or line segment. If multiple lines/line segments are selected, the Add Vertex command will not be available. To add a vertex, follow these steps:

1. Select the line/line segment you wish to add a vertex to.

2. Right-click and select the \texttt{Add Vertex} command from the pop up menu. The line/line segment will be broken into two segments and the first segment will be selected.

3. You can undo vertices that have been added, using the \texttt{Edit » Undo} command. To delete a vertex, click-and-drag its handle onto an adjacent vertex and release the mouse button.

\textbf{Aligning components}

You can only align components, however please note that this command cannot be undone. To align the capacitors you have already placed:

1. Select all the \texttt{CAP300} type components using a Block Selection filter.
2. Right-click, i.e. click the right mouse button, and choose **Selection Point** from the popup menu. Click to locate a point around which we will vertically align the components. The selection point marker displays.

3. Choose **Edit » Align Components** and select **Vertical About Selection Point** and **Space Equally from the dialog**. Enter a spacing of **500 mils** and click **OK**.

4. The capacitors will be stacked vertically. The selection point marker disappears when you deselect the capacitors. Remember to clear your filter when you have finished using Block Selection.

### Copying and pasting objects

Once a section of your board design has been successfully completed, you may find it useful to reuse that information again, either in the current design or in a future design. Objects and net information can be copied to the Clipboard or to a block file and later pasted into a different location using the various copy and paste commands.

More information on all these commands can be found in the *Edit Commands* chapter.

### Copying objects and net information

A copied object is placed on the clipboard. To copy a single object, choose one of these methods:

- Select an object and choose one of the copy commands from the **Edit** menu
- Right-click on a selected object and choose **Copy** from the shortcut menu.

To select a group of objects, or include net information in the copied information:

1. Block select the desired objects.
2. Choose the desired **Copy** command. All selected objects are copied to the clipboard.

### Drag and drop copying

To quickly copy objects within the same design and not affect the clipboard:

1. Select the object(s) you want to copy.
2. **Ctrl+Click** on the selected objects and drag the copy to a new location.

### Pasting from the Clipboard

There are several paste options to choose.

1. Choose **Edit » Paste From Clipboard** and click the workspace. The ghosted outline of the copied objects appears.
2. Before releasing the mouse button, drag the outline to a precise location within the workspace, then place the objects by releasing the mouse button.
**Duplicating objects using Copy Matrix**

To duplicate a group of objects, we will use a pad as an example. This command works with all selected objects.

1. Select a pad.
2. Choose **Edit » Copy Matrix**. Note that the row and column spacing is in mils; you can change the units using **Options » Configure**.
3. Enter information in the appropriate boxes, as shown in the following figure. Positive and negative numbers for Number of Columns duplicate the object to the right and left, respectively. With Number of Rows, a positive value duplicates up, a negative value down.

4. Click **OK** and the pad duplicates as shown in the illustration above.

**Deleting objects**

To delete an object, e.g. a pad:

1. Select a pad you wish to delete. If a pad belongs to a part or component, you cannot move or delete that pad. However, you can subselect the pad to perform certain actions. For details, see **Subselecting Objects**.
2. Choose one of these methods to delete it:
   - Press the **DELETE** key.
   - Right-click and choose **Delete** from the popup menu.
   - Choose **Edit » Delete**.

**Changing object properties**

You can change the properties of a selected object. Each object has a **Properties** dialog which is accessed in the same way. Let's practice by changing the properties of a pad.

The easiest way to bring up a Properties dialog is to double-click on an unselected object.

Alternatively, follow these steps:

1. Select a pad in your workspace.
2. Open the Properties dialog using one of these methods:
   - Right-click and choose Properties from the shortcut menu.
   - Choose Edit » Properties. The Pad Properties dialog appears.

   ![Pad Properties dialog](image)

3. In the Pad Number box, type: 1
4. In the Default Pin Designator box, type: A1
5. From the Pad Style drop-down list select the desired pad style. If the pad style you want does not appear in the list, click the Pad Styles button to display the Options Pad Style dialog, where you can add or modify a pad style.
6. Click OK to exit this dialog and check the pin number and designator have changed.

   For information about pad and via styles, see Using Pad and Via Stacks later in this tutorial. For more information about properties, refer to Edit Commands chapter.

### Unifying values

Now let’s try setting uniform line widths for two lines of unequal widths.

1. Choose Place » Line and place a line with line width of 10mils in the workspace. By default, the line width is 10 mils, unless you have changed this setting using the Options » Current Line command.
2. Select the line. Then, open the Properties dialog using one of these methods:
   - Right-click and choose Properties from the shortcut menu.
   - Choose Edit » Properties.
3. In the Width box, change the line width to 20 mils. Click OK to close the Line Properties dialog. The selected line’s width changes in the workspace.
4. Place another line near the first one, leaving it at the default width.
5. Select both lines by drawing a bounding outline around the lines.

6. Choose Edit » Properties. Because each line has a different width, no value appears in the Line Properties dialog. However, you can change the width of both lines, by entering a value in the Width box. For this exercise, type 50 in the Width box.

7. Click OK and both lines will become 50 mils wide.

Using the Selection Mask
The Block Selection tab in the Options » Selection Mask command provides you with some powerful and labor-saving features. This selection mask can work in very specific or general ways, depending on the parameters you define for the selection filtering process.

In this section you will learn how to complete the following tasks, which would be typical applications for this selection tool.

- Select all lines of a particular width (thickness) on specific layers and change them to another width.
- Select components of a certain type, change their values and make the values visible in the display.

Changing line width
This method of changing line widths allows you to specify which lines will be changed by their current width, regardless of which layer they have been placed on.

1. Choose Options » Selection Mask and click the Block Selection tab.

2. In the Items frame of the Options Selection Mask dialog, click Clear All.

3. Click the Line check box until a shaded check mark appears and the Line button becomes available. Click the Line button. The Line Selection Mask dialog appears.

4. In the Width text box, type: 20 mil and click OK to return to the Options Selection Mask dialog.

5. Select all of the layers in the Options Selection Mask dialog by clicking Set All in the Layers frame. Choose Inside Block. Later, when you do a block select, this setting will select all items inside your bounding outline. Click OK.

6. Draw a bounding outline around the entire design. If necessary, choose View » Extent to view the entire board.

7. While the board is selected, right-click and choose Properties from the shortcut menu.

8. In the Width text box, type: 30 mil and click OK. All of the selected 20 mil lines in your design will now be 30 mil lines.

Modifying components using the Selection Mask
Now, let’s modify all CAP300 components by changing their values from .1 to .05F and making these values visible.
1. Block select all the CAP300 capacitors using Options » Selection Mask.

2. Right-click the selected components and choose Properties from the shortcut menu. The following dialog appears.

3. In the Value text box in the Component Properties dialog, type: .05F

4. In the Visibility frame, select the RefDes, Value and Type check boxes to display them in the workspace and click OK.

5. The formerly invisible value of .1 that was attached to the CAP300 components is now a visible value of .05F.

Replacing components

Next, we’ll replace a component with one of a similar type.

1. Select a CAP300 component and choose Edit » Properties.

2. In the Type combo box, change the type from CAP300 to CAP-NON. The pattern is updated and any connectivity is maintained.

The Component Properties dialog provides a link to the Query function where you can search a library for a desired component to replace the current component. See your Library Executive User’s Guide for more information on using Query.

3. We have now finished using our Titleblock.pcb file for the moment, so choose File » Close and save the changes.

Initial board layout

This section walks you through the steps you need to layout the board. We will use mostly demonstration files supplied with P-CAD during the rest of this tutorial.
Creating a board outline

To start a design, create a board outline using Place » Line on the Board layer. For your convenience we have provided an outline to get you started.

1. Open the Demo1_o.pcb file provided in the Demo folder of the P-CAD installation directory by choosing File » Open.

2. You are now ready to place components or load a netlist generated from a schematic.

Loading a Netlist

To design a PCB, you could place components one at a time and then choose Place » Connections to add connections. However, most designs today are first created as a schematic, from which a netlist is generated. A netlist lists components and their electrical connections. Each set of connections carrying the same signal is a net. Connected component pins are defined as nodes and each net contains at least two nodes.

Components placed using Utils » Load Netlist are located by searching, in order, through the open libraries.

Loading a netlist into PCB has two effects:

- If found in the libraries currently open, components in the netlist are automatically placed in the workspace.
- Electrical connections between nodes are made, forming the ratsnest (blue lines).

To load a netlist:

1. Choose Utils » Load Netlist. The Utils Load Netlist dialog displays.
2. Open the netlist titled Demo1.net found in the Demo folder of the P-CAD installation directory by clicking on Netlist Filename.

3. Set the Netlist Format to P-CAD ASCII.

4. PCB scans the open libraries, retrieves the patterns, and places them in the workspace above your board outline. Then the ratsnest of net connections is created as shown below.

5. Now you are ready to move the components into position within the board outline.

Positioning components

Achieving optimal placement is a crucial foundation to designing high-quality printed circuit boards. The ratsnest provides a visual clue to the densities on the board.

1. You can turn the display of nets ON or OFF with the Edit » Nets command. This is useful to focus on a set of connections, such as address lines or your power and ground nets.

2. After netlist placement, you can move the components manually onto the board or you can move them by reference designator. When you select and move components into position, the connections ‘rubberband’ to maintain the established nets. See below for details about moving components by RefDes (reference designator).

3. Remember you can zoom during editing, pressing the R and F keys rotate and flip the components, and pressing ALT+Click allows you to move the mouse freely without having to hold down the left button.
Moving components by RefDes
You can move components by reference designator. To learn how to do this, you will practice moving a group of capacitors into position within your board outline.

1. Choose **Edit > Move by RefDes**. The *Edit Move by RefDes* dialog appears and the RefDes list contains a list of the components in your design.
2. Select all of the capacitors in the RefDes list. To do this, hold down the **SHIFT** key and click C12 and C23.
3. Click **OK** to close the dialog and return to the workspace.

   When the *Edit Move by RefDes* dialog closes, the status line shows the name of the Next RefDes to move. We’ll move C12 first.
4. Place the component. The status line shows C13 as the Next RefDes to move. Continue placing the parts until you’ve placed all of the capacitors.
5. Once you’ve moved all of the selected components, the *Edit Move By RefDes* dialog appears. You have these options:
   - To move another component or group of components, select the components from the RefDes list.
   - To close the *Edit Move by RefDes* dialog, click **Cancel** or press **ESC**.

Optimizing nets
As components are moved, the connections may have become less efficient than when they were originally placed. PCB includes a command to re-optimize the connections.

1. Choose **Utils > Optimize Nets**.
2. Notice the connections change as each net is evaluated and shortened.
Routing connections

For routing, we need to change some current settings. Then we’ll step through manual routing and discuss the changes that can be made to existing traces, followed by a brief look at interactive and automatic routing.

Creating routing settings

Set up the routing layers, any non-uniform grids and clearance rules before manually routing a board.

Setting routing layers

Routing is only permitted on enabled signal layers.

1. Open Demo1_u.pcb from the Demo folder of the P-CAD installation directory.

2. Choose Options » Layers.

3. Enable all of the layers to be used for routing. The Top and Bottom layers will be used in this example.

Using non-uniform routing grids

We previously set our grid to 100 mils for optimal placement. Non-uniform grids are also supported to route multiple tracks between pads, and for autorouting. A \( 42 \ 8 \ 8 \ 42 \) grid (mils) means that grid points are located in a pattern of 42 mils, 8 mils, 8 mils and 42 mils apart, starting at the origin. This spacing is convenient for routing one or two 8 mil traces between 60 mil pads, using 8 mil clearances, as shown below.
We'll add a non-uniform, relative grid for routing.

1. Choose **Options » Grids** and click **Relative Mode**.

2. Type 42 8 8 42 in the **Grid Spacing** box with the values separated by spaces. Click **Add**. If you are working in millimeters, unit overrides must be typed for each value, e.g. 42 mil, 8 mil etc.

3. Clear the **Prompt for Origin** check box, and enter an origin at X=25.0, Y=0.0. This is needed to align the relative grid with component pads (most pads are 25 mils off of a 100 mil grid with origin at 0, 0).

4. Click **OK** to continue.

### Setting clearance rules

Now we can set some Clearance rules to be used for design rule checking as we route. To set all clearance rules to 8 mils:

1. Choose **Options » Design Rules** and click the **Layer** tab.

2. Click **Set All** to select all entries.

3. Set the **Pad to Pad**, **Pad to Line**, **Line to Line**, **Pad to Via**, **Line to Via** and **Via to Via** values to 8. An easy way is to type in 8 in the Pad to Pad box and then **TAB** to the next box.

4. Click **Update** and then click **Close** to exit the dialog.
Manual routing

Online DRC will annotate and document design rule errors created while routing the board. While routing, look at the status information portion (right side) of the status line for the measurements of your route. Routed arcs are also accurately measured.

Follow these steps to manually route all the connections on your board:

1. Zoom in so you can select unrouted connection lines. Rows and columns of grid points may be seen between pads, displaying convenient routing channels.

2. Choose Route » Manual or click the Route Manual button on the Route toolbar.

3. Enable Online DRC for routing using one of these methods:
   - Choose Options » Configure, click the Online DRC tab and select the Enable Online DRC check box.
   - Click the Online DRC button on the command toolbar.

4. Switch to the Top signal layer, using your layer shortcuts.

5. Using the keyboard shortcut G, toggle to a desired routing grid. This grid should be based upon the chosen connection. During the routing and layer changing process, zoom in (+) and out (-) as needed.

6. Click and hold directly over a connection near a starting pad and drag the trace segment that displays as desired. Release at a location where you want the first vertex. Then, click at the location you want for the third vertex.

7. When the mouse is down, press the O key to access the desired orthogonal shape and the F key to toggle (flip) the vertex. Release the mouse. Notice the second vertex is added for you depending on the orthogonal mode chosen. The orthogonal modes include arcs, 45-degree diagonals, and 90-degree angles.

Press the mouse down again to locate the next segment. To place curved traces, as below, type O to reach the arc orthogonal mode, and release the mouse.
Remember you can limit the enabled orthogonal modes by entering the **Route** tab of the **Options » Configure** command and disabling the unwanted orthogonal modes.

8. Switch to the Bottom layer by pressing the **L** or **SHIFT+L** key (or use the status line controls) to route any segments where you need to cross a blockage. When changing layers in routing mode, the current via or the via style specified within the net attributes is automatically placed to connect the layers.

9. Create obvious clearance violations by routing too close to pads, vias or signals. The machine beeps and an error indicator is placed by the DRC for each violation.

10. Press the **BACKSPACE** key to unwind the offending trace. Notice that the trace and the error indicators generated by the trace are deleted. Each press of the **BACKSPACE** key backs up to the previous point. Leave at least one error in the design.

11. To complete the route all the way to the destination pad, click the right mouse button or press **ESC**. When you route directly to the destination pad, a diamond shape appears, indicating routing is complete with a zero length connection.

   To terminate routing without completing the connection, press either slash key (\ or /). You can finish routing it at any time. Note the current layer has been reset. The keyboard shortcuts used to complete or suspend routing can be customized in the **Route** tab of the **Options » Configure** command.

12. Route a few more connections, practicing with orthogonal modes, placing one or two traces between pads, and toggling between layers.

13. When you have finished practicing your manual routing, close the demo file using **File » Close** without saving it. We will use it again in the next section to demonstrate autorouting.

**Autorouting part or all of a PCB**

We will complete routing the example PCB using P-CAD’s Shape Router. You can automatically route a single connection within a net, all pads on a particular component, or all connections within a defined area by choosing the relevant option from the Tools menu.

1. Open **Demo1_u.pcb** again.

2. Select **View » Extents** to show the extent of all objects placed in the workspace.

3. To automatically route a particular net, select **Route » AutoRouters**. Choose **P-CAD Shape Route** from the AutoRouter pull down menu and select **Start**.
4. The design will enter the Autorouting interface. Select Tools » AutoRoute Net. The cursor will change to an arrow. Select any pad on the relevant net or on any connection line and the P-CAD Shape Based AutoRouter will automatically route the entire net.

5. Continue to select other nets to route.

6. To automatically route the entire board, select Tools » Start AutoRouter from the Shape Based Auto Router menu.

7. When routing is complete, select File » Save and Return to save the routing and return to the PCB editor.

Changing routed connections

Routed segments can be changed in a variety of ways:

- **Reroute**: Rerouting a segment is done by using the Route » Manual command. Click over the segment to be changed; it becomes a ghosted connection that can be manually routed as previously described. Click to locate each new vertex; press O and F to change orthogonal modes; press the BACKSPACE key to unwind.

- **Mitering routes**: Route Miter turns corners into arcs or 45-degree angles. After selecting the cornering style in the Route tab of Options » Configure command, each left click over a 90-degree corner gives you the ability to move the corner back into a mitered angle or arc. To get optimum results, choose a finer grid than your normal routing grid before mitering.

- **Move**: Select a routed segment, then click and drag it (or its corner) to a new location. Notice that the adjacent segments are stretched to maintain connectivity.

- **Line and Arc Properties**: Select a segment, click right button, and choose Properties from the pop-up menu. You can then change the line or arc width.

- **Delete route**: Select a segment, click right button, and choose Delete from the pop-up menu or press the DELETE key. The route reverts back to a connection.

- **Delete connection**: After you delete copper and it reverts to a connection, you can select and delete the connection itself. This is a drastic edit and should be used with caution.
• **Move to Layer**: Select one or more segments routed on the Top layer. Switch the current layer to **Bottom** and choose the **Edit Move To Layer** (SHIFT+T) command. Vias are added and deleted as needed.

**Unrouting a board**

In this procedure you will select all lines, arcs, and vias on all layers, then delete them. This will, in effect, unroute the entire board.

1. If it is not already open, choose **File » Open** and open **Demo1_u.pcb**.
2. Choose **Options » Selection Mask**.
3. In the **Items** frame of the Block Selection tab, click **Clear All** to cancel the selection of the items check boxes. Then, click the **Arc**, **Line**, and **Via** check boxes, to enable these three items.
4. In the Layers frame, click **Clear All**. Then, hold down the **SHIFT** key and click **Top** and **Bottom**.
5. In the Select Mode frame, choose **Inside Block** and click **OK** to close the dialog.
6. Do a block select of the complete board. To do this, draw a bounding outline around the entire board. If necessary, choose **View » Extent** for a complete view of the board.
7. When all arcs, lines, and vias are selected, press the **DELETE** key. The result should be that all the routed items in your design – lines, arcs and vias – will return to connections.

**Other options**

In this section, we will explore some of the options available in P-CAD that are useful when creating a PCB, i.e. pad and via stacks, copper pours and cutouts.

**Pad and via stacks**

PCB supports both simple and complex pads and vias, as well as blind and buried vias. Surface mount pads and uniform, through-hole pads and vias are considered simple. Since these types are predominant in a design, P-CAD 2000 has powerful features specifically for dealing with them.

At this point, we will look closely at complex pads and vias. PCB lets you define different shapes and sizes on the various layers in a design. This feature, called pad stacks, helps you route complex designs and allocate clearance on certain layers. A similar feature, called via stacks, gives you the ability to set up different styles of vias on a layer-by-layer basis and void vias on certain layers, hence creating blind and buried vias.

In the samples supplied, the pad and via shapes and sizes are the same on all internal signal layers. The **Modify Pad Style** and **Modify Via Style** dialogs can be used to create unique styles for any layer.

1. Open **Accsampl.pcb** found in the **Demo** folder of the P-CAD installation directory.
2. Zoom in to Area 4 on the sample board where we have created a pad stack, a via stack, a blind via and a buried via.
Pad stacks
1. Select the pad labeled Pad Stack and choose Edit » Properties. The Pad Properties dialog appears for the select pad.
2. Click Pad Styles. The Options Pad Style dialog appears where the 100x60x38 (width x height x diameter) style is selected as P:EX100Y60D38A.

![Pad Properties dialog](image)

3. Next, click Modify (Complex) to open the Modify Pad Style (Complex) dialog. This is where pad styles are created and changed. To view the details of this style, click each layer in the Layers list. You'll see different sizes and shapes defined for the top, bottom, and internal signal layers.

4. After you exit the dialogs, switch between the signal layers choosing View » Redraw after each layer change. You'll see the different pad shapes as they are defined on each layer for this style.

Via stacks
Via stacks are created and defined the same way. When manually routing from one layer to another, PCB alerts you if you try to insert a via between layers that the current via style does not support.

1. Select the via stack example, right-click, and choose Properties. The Via Properties dialog displays.
2. View the via's characteristics just as you did for the pad.

Now we'll look at the blind and buried vias provided.

1. The blind via has been created by choosing Options » Via Style and clicking the Modify Hole Range button. The via feeds from the bottom through internal signal layers, but does not penetrate the top.

2. Likewise, you can set up buried vias to connect any combination of internal layers by clicking the Modify Hole Range button in this dialog. This via feeds from one internal signal layer to another, but does not penetrate the outer layers.

3. You can prevent pads and vias within the boundaries of a plane or copper pour from automatically connecting to the plane or copper pour. To do this, click on Modify (Complex) in
Chapter 4: Tutorial - PCB Design Session

the Options Via Style dialog and select the Prohibit Copper Pour Connections option in the Modify Via Style (Complex) dialog.


Copper pours

Using the copper pour feature, you can lay down areas of copper with a backoff from tracks and pads within the area defined by the pour outline. You can also define various properties for each copper pour in a design, such as fill characteristics, backoff smoothness, connectivity and more. When you place a copper pour, you first draw the pour outline as a polygon. Then, you flood the pour outline with a copper fill.

To draw a copper pour outline, follow these steps:

1. Open up our original file Titleblock.pcb to practice copper pours.

2. Choose Place » Copper Pour or click the toolbar button.

3. Click where you want to place the first vertex of the copper pour. Make sure you create the copper pour over some lines and other objects that you have previously drawn on the same layer.

4. Drag the cursor to another point and click. Drag the cursor to another point and click at each corner of the polygon you want to draw.

5. When you’ve finished drawing a polygonal shape, right-click, or press ESC. You remain in placement mode until you choose another command.

6. Select the copper pour you want to fill and use one of the following methods to open the Copper Pour Properties dialog:
   - Double-click on the copper pour
   - Choose Edit » Properties
   - Right-click and choose Properties from the popup menu.

![Copper Pour Properties dialog](image)
7. In the Copper Pour Properties dialog, click the Style tab and select the appropriate options in the Fill Characteristics frame. Whatever you specify here applies only to the selected copper pour(s).

8. In the State frame, select Poured.

9. Click OK to close the dialog. P-CAD PCB floods the pours with a copper fill using the pour order set in the Pour/Repour Options frame of the Options Configure dialog.

10. Zoom in to examine the pour more closely, including the way the copper is backed off from pads and traces.

For more information on copper pours, refer to the Copper Pours chapter.

Plowing tracks and cutouts

On occasion, you may need to route a track through an area where copper has been previously poured.

1. Place a track (Place » Line) through the copper pour we have just created.

2. Selecting the pour and pour it again by opening its Properties dialog and selecting Repour.

3. Zoom in to see the newly added track with the defined clearance around it.

Alternatively, you can select Auto Plow Copper Pour to plow tracks through the copper pour as you place them.

1. Choose Options » Configure and click on the General tab in the Options Configure dialog.

2. Select Auto Plow Copper Pour and click OK.

3. Place a track (Place » Line) through the copper pour and zoom in to check the results.

Creating cutouts

To create an unpoured area within a pour, add a cutout. Cutouts can be used to prevent copper from being poured into intricate areas, thus avoiding unwanted islands of copper from forming.

1. Choose Place » Cutout or click the toolbar button.

2. Click where you want to place the first corner of the cutout within the copper pour you created previously.

3. Drag the cursor to another point and click. Drag the cursor to another point and click at each corner of the cutout polygon you want to draw.

4. Right-click or press ESC to establish the cutout polygon. Since we selected Auto Plow Copper Pour in the previous exercise, the area defined by the cutout is not filled. If this option was not selected, you would have to the re-pour the copper pour to create the cutout.

5. Close Titleblock.pcb.
Design verification

Completed designs should always be verified prior to generating final artwork and CAM files. PCB provides a variety of tools to help check your design against the original schematic and against your mechanical design rules, such as DRC (Design Rule Check).

To try out a few of the following operations, open the routed board Rdemo1_p.pcb in the Demo folder of the P-CAD installation directory.

Netlist verification
1. Choose the Utilities » Compare Netlist command to verify the integrity of the current design against the original netlist.
2. If you mistakenly deleted a component or a net from the design, this command shows you the discrepancy. For practice, compare the loaded design to the netlist Demo1.net in the Demo folder of the P-CAD installation directory. They should be identical.

Design Rule Checking
Comprehensive electrical and physical design rule checks can be performed on the board.
1. Choose Utilities » DRC. The Utilities DRC dialog displays. The DRC can generate a comprehensive report that is output to a filename you specify by clicking Filename.
2. The design rules to be checked are specified by enabling specific report options. A complete description of each rule check can be found in the online help. The demonstration board has silk screen violations that you need to find. Select the Silk Screen Violations check box.
3. Click the Design Rules button to set the physical design rule clearances to 12 mils. In the Design Rule dialog, click Set Defaults from the Layers tab and click Close.
4. Select **View Report** so the output report is presented on-screen and select **Annotate Errors** so that error indicators are placed on your board to help spot and fix problems.

5. Select **Summarize Ignored Errors** so that ignored errors are summarized on the report, and then click the **Severity Levels** button to open the **Rules Severity Level** dialog.

6. Select the **Point-To-Point Connectivity** and **Unconnected Pins** rules and choose **Ignored** in the Severity Level frame. Click **OK** to return to the **Utils DRC** dialog.

7. Choose **Region** to define a smaller area of the board for rules checking. To define the region you want to DRC, choose one of these methods:
   - Use Define Region:
     1. Click **Define Region**. PCB takes you back to the design.
     2. Hold down the left mouse button on the first corner of the area you want to define. Drag the cursor until the target zone is completely within the rectangle and release the button. Right-click to finish the region definition.
     3. Confirm that you want to update the region coordinates shown in the message box.
   - Set the region coordinates directly, enter the X and Y coordinates for the Lower Left and Upper Right in the appropriate text boxes.

8. Click **OK** to begin checking.

9. On completion, the DRC output report is opened and can be viewed, edited, or printed from the Notepad utility. Switch back to your design and notice that indicators have been placed at error locations.

10. Select any marker, right-click, and choose **Properties** to view the error descriptions in the **Find Errors** dialog.
11. You can view any error in the design by selecting one or all categories. Scroll sequentially through all the errors using the up and down arrows next to the Error Number text box.

You can also enter an error number in the text box and click **Find** to go directly to that error message.

12. Click **Jump To** to locate an error in the design.

When working with a real design, you would resolve each error and delete the indicators one by one. We'll skip that step here and just delete them. To delete DRC error markers, either:

- block select all of your DRC Errors items and press **DELETE**, or
- choose **Utils » DRC** with no reports enabled. Rerunning the command clears the old markers.

13. Keep the PCB file open as we will use it for generating reports in the next section.

---

### Generating reports

This section of the tutorial shows how to create a variety of useful reports out of a PCB file. These reports can help you verify the integrity of your design and document your work. Reports can be customized and saved with the design to be used in the future. Comma-separated ASCII report files can be output for loading into your word processor, database manager or spreadsheet program for further editing or formatting.

1. With `Rdemol_p.pcb` open, choose **File » Reports** to open the **File Reports** dialog.
2. Choose the reports you want to generate by selecting the appropriate check boxes in the Reports to Generate list. Choose P-CAD Report in the Style Format box and in the Report Destination frame, choose Screen.

3. Click Generate to produce the reports. The selected reports will display in separate Notepad windows, e.g. the Bill of Materials report (Rdemo1_p.bom) shown below that was generated from the file Rdemo1_p.pcb.

4. You can save or print the reports using the Notepad File commands. When you have finished viewing the reports, close each report window and select Close in the File Reports dialog.

For more information on how to customize reports, refer to the File Commands chapter.
Printing and plotting your design

Using PCB, you can generate high-quality artwork on the wide variety of devices supported by Microsoft Windows as well as Gerber-format photoplotters. First you'll set up the printer, then create a print job for each piece of the design to be generated. Finally, you select any number of print jobs and generate the output.

1. We'll demonstrate using Rdemo1_p.pcb, so make it the current design.
2. Choose File » Print Setup to set up your printer, paper size and source, orientation, number of copies and other printer options. Click on Landscape and click OK.

Setting up your print jobs

1. Choose File » Print. The Print Jobs list shows any jobs that are already defined for our demo board, e.g. Components.
2. Click Setup Print Jobs. Here you set up your options including the layers and items to be included, and the scale, offsets, rotation, and drill symbol size for the output.
3. Select Components in the Print Jobs list. You'll see the characteristics defined for that job on the right of the dialog. To change the job, update the options and click Modify.
4. Now we'll create a print job that includes all the layers of the board. To create a new print job, type a new job name, e.g. ALL, in the Print Name box, choose your options e.g. set all layers and other options set in the dialog below and click Add. Multiple jobs can be added or changed before you click Close to return to the File Print dialog.
5. Next, click **Drill Symbols**. We could individually assign each hole size to one of the drill symbols provided. Instead, click **Automatic Assign** to assign them instantly, then close the dialog.

6. Set your output colors by clicking the **Colors** button if you have a color printer.

7. Return to the **File Print** dialog. Select print job names to include or exclude the jobs from being printed. Select **ALL**.

8. You may preview the output before printing by clicking the **Print Preview** button, checking the output and clicking **Close** to return to the **File Print** dialog.

9. Click **Generate Printouts** to send the print jobs to your printer. The following file will be printed showing all layers.

---

**Generating manufacturing files**

This final section of the tutorial looks at generating Gerber and N/C drill files.

The process for generating Gerber-format photoplot files is very similar to that for generating print as discussed in the previous section of this tutorial. You determine the contents of the various photoplot files, select one or more of them, and generate the output. With Gerber files, however, you must also take the extra step of mapping apertures to items on your design using PCB’s automatic aperture assignment.

**Generating Gerber output**

1. Make the file Rdemol_p.pcb the current file and choose **File » Export » Gerber**. The buttons on the right of the **File Gerber Out** dialog are arranged in the order required to step through the process of generating photoplot files.
2. Click **Setup Output Files**. You will notice that there are already some output files generated for you.

3. Now we will create a new output job for the Top Silk layer by setting output file options.

4. Type **TSK** in the File Extension edit box. The output files have the same base name as the design file but with a unique extension, e.g. for Top Silk, etc.

5. Highlight the **Top Silk** layer in the Layers list box. Click all the check boxes, except **Mirror**. Also click **View log file upon completion** to report errors during Gerber generation.

6. Then click **Add** to add **RDEMO1_P.TSK** to the Output File list.
7. Specify the Output Path where the Gerber photoplot files will be stored, e.g. C:\PCAD\Demo.

8. Click Close to exit the dialog and return to the main File Gerber Out dialog. The new Gerber file, RDEMO1_P.TSK, appears in the Output Files list box.

9. Next, click Apertures to assign a photoplot aperture to each item on the board. To save time, just click Auto in the Automatic Describe/Assign frame. PCB automatically assigns an aperture to each item. You can then edit any of the assignments if you wish. Click Close to complete aperture definition.

10. The File Gerber Out dialog provides access to assigning drill symbols. Click Drill Symbols to display the Drill Symbol Assignments dialog. From this dialog, you can assign drill symbols either manually or automatically. Click Automatic Assign to auto assign the drill symbols. Select Close to save your changes.

11. Click Gerber Format from the File Gerber Out dialog to set the format for your output, such as the output units, numeric type and format, in the Gerber Format dialog. By default, the output format is set to 274-D so we do not need to change any settings. Select Close to return to the File Gerber Out dialog.

12. To compress Gerber files into a single compressed file when output, select the Compressed(.ZIP) check box in the Compress Output Files frame of the File Gerber Out dialog. This option requires an unzipping program. Alternatively, select the Self-Extracting (.EXE) check box to produce a single self-extracting compressed file that contains all your selected Gerber output files. We will not compress our small file this time, so leave the check boxes unselected.

13. Finally, choose one or more output files by selecting those files from the Output Files list. Click Generate Output Files to produce the photoplot files that are saved to the nominated directory.

Before we leave Gerber files, we will have a look at viewing the Gerber files we just generated.
Chapter 4: Tutorial - PCB Design Session

Generating manufacturing files

Viewing Gerber photoplot files

Perhaps no other function in PCB provides as positive visual verification as much as the photoplot file viewing facility. By viewing the files just generated on-screen, you can be assured that your aperture selection and options were correctly set.

PCB lets you slide a Gerber file into a layer while the original design is open. As with superimposing two supposedly identical overheads, discrepancies become obvious. You can also read in multiple Gerber files to view a composite of the design.

1. Make the PCB file Rdemo1_p.pcb current.
2. Choose File » Import » Gerber and load RDEMO1_P.TSK from the Demo folder of the P-CAD installation directory. Also select View log file upon completion to check for errors and click OK.

3. Notice how a new layer named Gerber displays the Gerber file information overlaying the original design in the workspace ready for checking for any discrepancies. An error log also opens in Notepad.
4. Further isolate the Top Silk layer and the Gerber layer to show the overlay of these two layers only, by choosing Options » Layers and enabling only these layers.
5. Do not save the Gerber layers within your PCB file as they are usually only used for viewing and verification purposes. Once you have finished checking, close the PCB file without saving.

Generating N/C drill files

The procedure for generating drill files is similar to the procedure for creating prints and photoplot files.

2. Set up output files, layers, assign tools, set the drill file format and produce a compressed (.zip) file or a self-extracting compressed file by selecting the buttons of the File N/C Drill dialog.
3. Select the output files, click Generate Output Files and a drill file (.ncd) is created.

For more information about generating manufacturing files, see the File Commands chapter.
Documentation Tools

Documenting a Design with Document Toolbox

With Document Toolbox you can accelerate the development of a complete, informative documentation package that details the fabrication and assembly of the printed circuit board. The information provided here is an overview of the documentation capabilities of the Document Toolbox.

In this section you will learn about:

- Zoned borders and custom title blocks.
- Drawing and revision notes.
- Dynamically updated Design Views.
- Detail views of a design.
- Annotated depiction of the layer stack-up diagram.
- Tables of drill data.
- Picture graphics.
- Associative dimensions.

Drawing Layers

Assembly or fabrication drawings of the printed circuit board may be integral components of your PCB documentation package. Document Toolbox includes a variety of objects that accelerate the production of these drawings. It is recommended that you place these objects on a nonsignal layer.

You may want to define an additional nonsignal layer for an assembly or fabrication drawing called a drawing layer. On this layer you can place graphics, including design detail views and layer stack-ups as well as drawing-specific notes.
PCB Title Sheets

Document Toolbox helps you create a title sheet for your PCB design. Title sheets, and the information contained within, may be specific to a layer. Building a title sheet incorporates design borders, zones and title blocks. When combined, these objects make up the PCB title sheet similar to the one shown in the following figure:

Each of the objects may also be used independently in whatever combination best fits your design needs.

Borders and Zones

With Document Toolbox you can place a zoned border on any layer. A design border and zones are two of the basics needed to create the PCB Title Sheet. The border and zones are set up in the Titles tab of the Options Layers dialog.

Borders

A layer with its zoned border is shown in the following figure:
The display and structure of borders and zones can be unique for each layer.

The default settings for borders is that the border relative origin is 500 mils in and up from the workspace origin, and the default border width and height is 1000 mils smaller that the workspace height and width (as specified on the General tab of the Options Configure dialog). If, for example, the workspace size has a height and width of 10000.0 mil, the default height and width of the title sheet border would be 9000.0 mil, and the bottom left of the border would be 500 mils in and up from the workspace origin.

The following diagram shows these calculations:

The border is added to the layer that is selected in the Layers field of the Titles tab of the Options Layers dialog. It is only displayed when this layer is the current layer.

Zones
The perimeter of the design can be divided into alphanumeric zones similar to those found on a road map. Zones can be displayed whether or not you have selected to display the border. These zones are useful for locating or referencing drawing objects.
Zones use the dimensions of the perimeter set in the Borders area. Zone width is set by the size of the label text as shown in the illustration above.

To include zones in a border, complete the information in the Zones frame on the Titles tab of the Options Layers dialog.

**Title Blocks**

Title blocks can be placed on any layer. Title blocks, one of the basic building blocks of a PCB Title Sheet, include design information such as Title, Author, Drawing Number, etc.

Several PCB title block (.tblk) files are included with the P-CAD PCB Editor. These sample files can be used directly in your design, or modified to create new title block files. Custom title blocks can also be created.

The title block assigned to each layer can be unique and is specified for the layer through the Titles tab of the Options Layers dialog.

To specify the contents of the title block, you can place fields within the block. These fields can also be unique to each layer by assigning different field sets to the layers. When a title block includes placed fields, design information from the layer’s assigned field set is displayed for the field’s value. Design information used to complete the fields on the title block resides in the Fields tab of the File Design Info dialog.

By saving the placed fields within a title block file, you eliminate time spent repeating field placement in standard locations and automatically display the appropriate field values in their correct locations when the title block is included in a new design or on another layer of the current design.

**Design Views**

In documenting your design you may want to place various sections of the design on a single page for illustration purposes. By using a Design View, you can place a view of a portion of the design into another location in the design or place this same view inside the workspace multiple times. You can also place a Design View in its original state and mirror the same view alongside the original.

**Revision Blocks**

A revision block includes details about differences between versions of a design. An example revision block is seen in the following figure:

![Revision Notes Table]

<table>
<thead>
<tr>
<th>Revision Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>A - Initial Release</td>
</tr>
<tr>
<td>B - Added Resistor Pack RP3 &amp; Deleted Caps C46 &amp; C50 per ECO # 1256.</td>
</tr>
</tbody>
</table>

In Document Toolbox, a revision block is placed as a Revision Notes Table.
Fields and Field Sets

Field values can be grouped into distinct field sets. Each field set can contain different design information such as title, author, drawing number, notes, etc.

<table>
<thead>
<tr>
<th></th>
<th>Field Set 1</th>
<th>Field Set 2</th>
<th>Field Set 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author</td>
<td>M.Smith</td>
<td>M.Smith</td>
<td>T.Miller</td>
</tr>
<tr>
<td>Title</td>
<td>Fabrication</td>
<td>Fabrication</td>
<td>Assembly</td>
</tr>
<tr>
<td>Drawing Number</td>
<td>FB-863-01</td>
<td>FB-863-02</td>
<td>AS-863-01</td>
</tr>
<tr>
<td>Approved By</td>
<td>L. Brown</td>
<td></td>
<td>N. Chapman</td>
</tr>
</tbody>
</table>

From the Options Layers dialog you can assign a field set to a particular layer of your PCB design. The field's values change based on the field set of the layer on which they are located.

You may want to create an assembly and a fabrication drawing of your PCB design. You can create two nonsignal layers on which to create these drawings and assign each to a unique field set. The drawing number for each drawing can be unique, for example, since it will be specific to its field set as defined in the Fields tab of the File Design Info dialog.

Design or revision notes can be placed to informatively explain details of the drawing. These notes are also field set specific.

Drawing and Revision Notes

Notes are used to annotate your PCB drawing. With drawing or design notes, you can clarify details of the design. With revision notes, you can document changes made between drafts or versions of the design.

Drawing and revision notes can be specific to a field set. If you created an assembly and a fabrication drawing of your PCB design, the notes for each drawing can be specific to its field set.

Defining Drawing or Revision Notes

You can annotate your design by placing a drawing note. Drawing notes can be field set specific and can be assigned to a field set in the Notes tab of the File Design Info dialog.

You can also include revision notes specifically pertaining to design changes or revisions. Notes pertaining to design changes should be included on the Revisions tab of the File Design Info dialog. Notes can later be included in your design by placing a note field or a note table. These notes can be annotated using the industry-standard symbols: box, circle or triangle.
Chapter 5: Documentation Tools  Documenting a Design with Document Toolbox

The following figure shows a Notes table with standard note symbols:

<table>
<thead>
<tr>
<th>Notes: Unless otherwise specified.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. R27, L1, L2 and R18 are mounted vertical. Component should be bended .100 spacing from lead to lead before insert to board.</td>
</tr>
<tr>
<td>2. D1, D3 and D4 are mounted vertical. Component should be bended .168 spacing from lead to lead before insert to board. And Anode side should be inserted into the square pad.</td>
</tr>
<tr>
<td>3. Mounting holes item.</td>
</tr>
<tr>
<td>4. Using block ink for marking Assembly Revision number into white rectangle.</td>
</tr>
</tbody>
</table>

Design Details

A magnified view of a region of your board is called a detail. Document Toolbox allows you to include details directly in your design. A detail is a picture containing objects created in the PCB editor; it is a magnified copy of a selected PCB design region.

Details are intended to be used in drawing. Therefore, they should not be items required in the final film artwork or translated to another product using DXF.

A detail can be placed from a file or directly from the clipboard onto any nonsignal layer. An example of a detail is shown in the following figure:

```
11
12
13
14
```

Title of Detail

Scale = 2.0

Details can be cut or copied from one location to the clipboard and pasted into another location. This graphical information can be placed in picture format on the PCB drawing by choosing the **Edit > Paste Special** command. If you choose the **DocTool > Mirror on Copy** command, the selected objects are copied in the opposite perspective of the display, as if viewing the design from its underside.

Detail, diagram and picture objects are not mirrored when copied to maintain the orientation of annotation text.
Graphic Files

A graphic file can be used to permanently store a graphic object, including a detail of your PCB design. The file can be used repeatedly to place the same image in multiple designs or on multiple layers. It can be retained on your computer for use at a later time. Graphic files are ideal for building an archive containing commonly used images.

Graphic images can be created automatically from a block file (.blk). You can place these block files as details on the PCB drawing by choosing the DocTool » Place Detail command. When a block file is placed as a detail it loses its design intelligence and becomes a scaleable snapshot of a region. The layer information of the block file is removed and the detail resides only on the layer on which it is placed. You can also uses graphic files in picture format (.emf) to place a detail. These picture files can be placed by choosing the DocTool » Place Picture, DocTool » Place Detail or Edit » Paste from File commands.

Detail Colors

A detail exists on a single layer, as a picture of design objects, which may be located on multiple layers. To indicate the detail's layer, all design objects within the detail are drawn in the line color of the active layer.

Updating Details

Details are not automatically updates when change are made to the design. Since the detail is generally imported from a file, the block file or picture file containing the board region must be replaced when the detail needs to be updated. The detail of the modified board region can then be placed from the new block file.

You can resize, move or delete a detail after placement, but you cannot rotate or flip it. The detail is a single discrete unit; individual objects within it may not be sub-selected or modified. If you included a scale factor in the detail's title or subtitle, you can modify the value to reflect the current scaling factor by selecting the detail and choosing the Edit » Properties command. Your changes for the title, subtitle, text style and scaling can then be applied in the Detail Properties dialog, or if placed using the DocTool » Place Picture command, in the Picture Properties dialog.

Layer Stackup Diagrams

A depiction of the stacking of board layers is used to annotate the board layers. The layer stackup diagram is displayed in one of two ways, as shown in the following figure:
The layer stackup diagram is placed by choosing the **DocTool » Place Diagram** command. Once placed a diagram may be resized, moved or deleted, but not rotated or flipped. The diagram is a single discrete unit; individual object within it may not be sub-selected.

Diagrams are not automatically updated when changes are made to the design unless you choose specifically to update it. If the board layer arrangement has been modified, the layer stack-up diagram should be updated to reflect the current design information by selecting a single diagram and choosing the **DocTool » Update** command or selecting multiple diagrams and choosing the **DocTool » Update All** command.

The title, subtitle, text style, diagram style scale factor and line width properties of the diagram can be modified. The scale factor, if included in the diagram’s title or subtitle, can be modified to reflect the current scaling factor by choosing the **Edit » Properties** command after selecting the diagram.

### Drill Tables

A drill table maps the drill symbol displayed on the PCB design to its physical characteristics. The information contained within a drill table includes: the hole diameter, the symbol used to identify the drill hole, the number of holes of type in the design, and whether the hole is plated.

A basic drill table is shown in the following figure:

<table>
<thead>
<tr>
<th>Drill Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hole Dia (inch)</td>
</tr>
<tr>
<td>0.015</td>
</tr>
<tr>
<td>0.037</td>
</tr>
<tr>
<td>0.093</td>
</tr>
<tr>
<td>0.138</td>
</tr>
</tbody>
</table>

You can also include user-defined columns in the table, which may include any additional information you require.
The contents of a placed drill table is modified only when you specifically choose to update it. When the drill information of the current design is modified, the drill table should be updated to reflect the design changes. To update a particular drill table, select the table and choose DocTool » Update. To update all tables choose DocTool » Update All.

Updates cannot be undone.

You can also select a drill table, choose Edit » Properties and make changes in the Table Properties dialog for the table’s line width, name and text style.

The drill table is updated when its properties are modified.

**Associative Dimensions**

Dimensions are used to document the distance between objects in your PCB design. Dimensions can be associated with their objects, they can include tolerances and you can modify the various properties of a dimension.

Associative Dimensions are intelligent about the objects they are documenting. When the dimension is placed it becomes associated with dimensioned objects. When one of the objects move, the dimension follows it and marks the new object separation. Associative dimensions are dynamically updated whenever the objects are moved, resized, rotated, flipped or modified. If one of the dimensioned objects is deleted, an associative dimension will also be automatically deleted.

A dimension is placed by choosing the Place » Dimension command. Use the information on the Prompt Line to guide you through the placement process.

For Baseline and Datum type dimensions, you can unwind the last action performed, using either the BackSpace key or the CTRL-BackSpace keystroke.

Once a dimension has been placed it can be modified. Click once to select a dimension, then choose Edit » Properties from the menus to display the Dimension Properties dialog, where you can edit dimension properties such as Units, Layer, Precision and Tolerance. Note that the precision setting applies to the dimension units, the tolerance always displays with 4 decimal places (unless the Suppress Trailing Zeros option is enabled).

You can make a dimension non-associative if you clear the Associated Dimension check box in the Dimension Properties dialog. Once this option is disabled the dimension has no intelligence about its dimensioned objects, and will not move when a dimensioned object is moved.

The dimension arrow and text position can also be altered, to do this click once to select the dimension, then click and hold on the small handle that appears to reposition.
Printer & Plotter Setup

When you choose **File » Print Setup**, the following **Print Setup** dialog appears. This dialog lists any printers and plotters that have been installed on your system.

In the **Print Setup** dialog, select a printer from the Name list. Then, click **Properties** to configure print parameters. Because print parameters are device-specific, the dialog, which appears, will depend upon the printer you select. After you configure your print parameters, click **OK**.

Plotting is similar to printing. For plotting, choose **File » Print Setup**. Like printers, plotter properties are device-specific and customized to the plotter driver you are using.

Printing

When printing from P-CAD PCB, you have access to many useful features, such as:

- Multiple and batch print jobs. You can define unique print options for each print job. For example, you can include or exclude specific layers and objects, X and Y offset, and more.
- Color options. You can customize color output, if you are using a color printer.
- Drill symbol assignments. You can include both manual and automatic describe and assign options.
- Printing the current workspace display based on your current zoom settings.
- Specify the number of pixels used to print the minimum line width.
Setting Up Print Jobs

In this section you will create three different print jobs to practice a typical printing scenario. First, you will set up the options for each of the three print jobs, assign drill symbols, set color options, and then do a batch print of all three jobs.

1. Choose **File » Print** to open the following dialog.

2. Click **Setup Print Jobs**. The following Setup Print Jobs dialog appears.
In this dialog you can specify layers, objects, print regions, and other design print criteria for multiple print jobs. For this tutorial, leave the dialog open and continue with Job One: Board and Top Layers.

Job One: Board and Top Layers
This first print job example prints all copper on the Top layer. The entire design is printed.
1. Press the CTRL key and select the Board and Top layers from the Layers list.
2. In the Display Options frame, select the Pads and Vias check boxes.
3. In the Print Region frame, select the Design Extent check box.
4. Make sure the Board and Top layers are selected in the Layers list. Then, type the following in the Print Job Name text box: TOP
5. Click Add. The job named TOP appears in the Print Jobs list. Leave the Print Setup dialog open, and continue with Job Two: Board and Top Silk Layers.

Job Two: Board and Top Silk Layers
1. Click Clear All.
2. Hold down the CTRL key and click Board and Top Silk in the Layers list. You will define the desired region for printing.
3. In the Display Options frame, select the RefDes, Pads, and Vias check boxes.
4. Clear the Design Extents check box and click Define Print Region. The workspace appears.
5. Hold down the left mouse button and drag it diagonally across the workspace to draw a bounding outline around the desired print region.
6. **Right-click** or press **ESC**. In the Information dialog that appears, click **Yes** to confirm the coordinates of your selected print region.

   The **Setup Print Jobs** dialog appears with the corners of the selected region displayed in the Print Region box.

7. In the Print Job Name text box, type: **TOPSLK**

8. Click **Add**. **TOPSLK** appears in the Print Jobs list. Leave the **Print Setup** dialog open and continue with **Job Three: All Layers**.

**Job Three: All Layers**

1. Click **Set All** to highlight all the layers in the Layers list. The entire design will be printed with the output scaled to fit exactly to a page.

   You can also select all layers using the layer sets feature. Select **All Layers** from the Layer Set list and click **Apply Layer Set**.

2. Select the **RefDes**, **Pads**, and **Vias** check boxes.

3. Select the **Design Extent** and **Scale Fit to Page** check boxes.

4. In the Print Job Name text box, type: **ALL**

5. Click **Add**. **ALL** appears in the Print Jobs list.

Now that you have set up your three print jobs, click **Close** to exit the dialog. In the **File Print** dialog, the following print jobs appear in the Print Jobs list: **TOP**, **TOPSLK**, and **ALL**. Leave the **File Print** dialog open and continue with **Assign Drill Symbols**.

**Assign Drill Symbols**

In the **File Print** dialog, click **Drill Symbols**. The following Drill Symbol Assignments dialog appears.
P-CAD PCB includes alpha-character drill symbols (upper and lowercase). This feature makes it easier for you to provide manufacturing documentation. It also emulates Master Designer's drill symbol assignment feature, so anyone used to Master Designer will have little trouble documenting drill holes in P-CAD PCB.

The available drill symbols are as follows:

- Uppercase characters A-Z, except T, X, and Y. P-CAD PCB already allows these as graphic shapes.
- Lowercase characters a-z, except x.

These drill symbols appear toward the bottom of the Drill Symbols list in the *Drill Symbol Assignments* dialog.

The printed, Gerber, and DXF output files display the new drill symbols as described in the following list:

- All drill symbols are printed in the default text style.
- The character size is approximately the same as the drill size you specify.
- The text stroke width is consistent with the appearance of drill symbols.
- The text character is centered on the location of the drill hole.

The DBX applications, and *Drilltab.dbx*, also recognize the drill symbols and can handle them accordingly.

### Automatic Assign

To assign all drill symbols automatically, click the *Automatic Assign* button in the *Drill Symbol Assignments* dialog. You can click *Unassign All* to clear everything, or *Unassign* to clear the hole diameter that is highlighted.

The list of this dialog displays the hole diameters of the loaded design file and any drill symbol assignments that may exist for those hole diameters, allowing you to view which items are assigned and what those assignments are.

In the *Drill Symbol Assignments* dialog, click *Automatic Assign* to automatically assign a drill symbol to each hole diameter in the design.

### Manual Assign

To make manual drill symbol assignments:

1. Select 18.0 mil in the Hole Diameter list.
2. Select *Diamond_X* from the Drill Symbols list.
3. Click *Assign*. Diamond_X appears next to 18.0 mil in the list.
4. Click *Close*. 
The **File » Print** and **File » Export » Gerber** features share common drill symbol assignments; when symbols are assigned in one, they will apply to the other.

### Setting up Print Colors and Other Options

You can define colored, grayscale, or monochrome printer settings. You can also set the printed size of different reference points in a design. To set up print colors and other options, follow these steps:

1. Choose **File » Print**. The **File Print** dialog appears.
2. Click the **Colors** button to open the **Printer Options** dialog. This dialog contains two tabs: Colors and Miscellaneous. You can make changes in these tabs without affecting your **Options Display** settings.

   The **Printer Options** dialog is similar to the **Options Display** dialog. However, changes to your printer options do not affect your options display settings.

3. Click the **Colors** tab, then choose print colors using one of these methods:

4. If you have a color printer, click the appropriate buttons and choose a color from the color palette that appears.

5. If you have a black and white printer, click the **Defaults** button. This turns all colors to monochrome. We recommend that you use the default settings to avoid undesirable output when color settings are converted to grayscales.

6. Click **OK** to close the **Print Options** dialog. You return to the **File Print** dialog.

   For more information about the options in the Colors or Miscellaneous tab, see **Options Display** (page 442).

### Batch Print

In the **File Print** dialog, you should now see the three print jobs listed. To set up batch printing, follow these steps:

1. Click **Set All** to select all three print jobs.
2. Click **Print Preview** to verify that the output is what you want to print.
3. Click **Generate Printouts**, to print the jobs with the specifications that you set earlier.
4. Click **Close** to exit the dialog.

When you close the **File Print** dialog, the three print jobs that you have created are saved.
Routing Features

This chapter contains information on how to select a router and set up your design for routing. It also explains how to perform manual, interactive, and miter routing in P-CAD PCB, and details using the advanced features such as Route Bus, Route MultiTrace, Route Fanout, Maximize Hugging, Minimize Length and Visible Routing Area.

The section titled General Routing Features, (page 103) details features available with both manual and interactive routing.

The table below shows which button accesses each of the routing tools:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To access this routing tool:</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="#" alt="Route Manual" /></td>
<td><strong>Route » Manual</strong>: Runs the Route Manual tool. This tool allows you to manually route and reroute existing connections or net copper items.</td>
</tr>
<tr>
<td><img src="#" alt="Route Interactive" /></td>
<td><strong>Route » Interactive</strong>: Runs the Route Interactive tool. This tool provides obstacle avoidance, copper hugging, and intelligent route completion.</td>
</tr>
<tr>
<td><img src="#" alt="Route Miter" /></td>
<td><strong>Route » Miter</strong>: Performs mitering. This tool converts square corners on routed connections into mitered corners, tangent arcs, or T-routes using an angle of your choice.</td>
</tr>
<tr>
<td><img src="#" alt="Route Bus" /></td>
<td><strong>Route » Bus</strong>: Runs the Bus Route tool. The Bus Route tool allows you to specify several connections to be guided simultaneously as a bus.</td>
</tr>
<tr>
<td><img src="#" alt="Route MultiTrace" /></td>
<td><strong>Route » MultiTrace</strong>: Runs the MultiTrace Route tool. The MultiTrace Route tool allows you to specify several connections to be routed automatically.</td>
</tr>
<tr>
<td><img src="#" alt="Route Fanout" /></td>
<td><strong>Route » Fanout</strong>: Runs the Fanout routing tool. The Fanout Route tool is used for the systematic placement of fanout traces from a PCB component. These traces can then be used by Bus Route as a start or</td>
</tr>
</tbody>
</table>
Selecting a Route Tool

When selecting a route tool, consider the board design, design rules, and the desired final trace.

- **Manual Route** is a flexible tool that allows you to place traces precisely. An individual trace can be routed along an arc, at any angle, and into loops. You can also T-route from an existing trace. Traces need not obey clearance rules, although online DRC is available. The flexibility of Manual Route is particularly useful for analog boards.

- **Interactive Route** is a more intelligent tool that allows you to place traces while obeying the clearance rules of the design. Routes can be completed automatically, hugging obstacles and entering pads as directed.

- **Miter Route** is a specific tool for easily creating 45 degree angles or arcs out of routed corners or T-junctions.

- **Bus Route** is ideal for situations with a one-to-one correlation of pins and no obstructions, as when routing to an edge connector. With Bus Route, you seemingly route a single, wide trace and all selected connections follow.

- **MultiTrace Route** automatically routes selected connections. It is ideal for regions of the design with collinear connections, which may or may not have obstacles; it can speed repetitive tasks without requiring user intervention. The placement of the traces can be steered by setting options such as minimum length, maximum hugging, and orthogonal mode. With MultiTrace, each trace is routed individually and automatically.

- **Fanout Route** allows you to specify a fanout configuration for a collection of connections as they exit from the pads of a PCB component.

- **Maximize Hugging** allows you to set trace placement to hug obstacles.

- **Minimize Length** lets you set trace placement to seek the straightest line between routes.

- **Visible Routing Area** analyzes the design rules and displays the available routing area on the workspace.
Routing Setup

This section provides information on some basic setup functions you should perform before routing.

Opening a File

To open a design file, choose File » Open. If you want to backup your work before you make changes, choose File » Save As and save the file to a different name.

Placing Connections

Before routing, you must have already placed components and placed connections between the component pads (net nodes). To place connections, choose Place » Connection or click the toolbar button.

For more information see Place Connection (page 377).

Setting your Grids

You need to set your grids for easier and more efficient routing. There are many different ways to set up grids depending on what is appropriate for your particular design. For through-hole designs, a typical Absolute grid spacing is 25 mils. For surface mount or mixed boards, the grid spacing selected should be appropriate for the pad spacing.

For example, you may want to set the Absolute grid spacing to 25 mils and the Relative grid spacing to 8.3 mils.

1. Choose Options » Grids to open the following dialog.

   ![Options Grids Dialog](image)

2. In the Visible Grid Style frame, do the following:
   - Select the Visible check box.
   - Choose the Dotted button.
3. In the Mode frame, choose **Absolute**.
4. In the Grid Spacing text box, type: **25** OR select **25** from the Grids list box.
5. Now, choose the **Relative** button in the Mode frame.
6. In the Grid Spacing box, type **8.3** OR select **8.3** from the Grids list box. The relative grid origin can be set to any (x,y) coordinate relative to the absolute grid origin at the lower left hand corner of the workspace (0,0).
7. Click **OK**.

**Status Line Grid Toggle**

When you switch between **Relative** and **Absolute**, you will activate 8.3 mil and 25 mil grids, respectively. On the Status Line, switch between these two modes by clicking the Grid toggle button and see how the visible dotted grids change. The button appears as **Rel** and has a colored background when in **Relative** mode; it appears as **Abs** when in **Absolute** mode. The value of the relative or absolute grid setting appears next to it.

For more information see, **Options Commands (page 423)**.

**Changing Layers**

You need to be able to change layers easily while you are routing.

The current layer name (e.g., Top) as well as the designated layer line color appear together on the Status Line at the bottom of your screen. The layer color is located between the layer combo box and up and down arrows (a reduced scroll bar) where you can view and change between the enabled layers (making another layer the current layer).

To change to another layer you need only select it from the combo box or the select the layer line color by clicking the **up** and **down arrows**.

**Status line layer control**

To add, delete, enable, or disable layers (which affects the list of layers in the combo box on the Status Line), choose the **Options » Layers** command. It's better not to enable more signal layers than you will immediately need; this is to avoid having to cycle through too many existing layers.

Since you can only route on signal layers, make sure that the signal layers you want to route on are enabled. Then when you want to change layers, you can press the **L** and **SHIFT+L** keys to switch between the signal layers. When you are using a route tool, the **L** key will switch between signal layers.

For more information, see **Options Commands (page 423)**.

**Setting Line Width**

The line width for placing lines and routing is determined by the default current line width. You have two ways to change line width:
• Choosing **Options » Current Line**.

• Select a width from the Line Width list box in the Status Line.

Changing line width affects subsequent line drawings only and has no effect on existing lines. However, it does affect the thickness of any lines or arcs you use with the route tools, unless the net or net class has a WIDTH attribute.

| You can change the line thickness of an existing arc or line with **Edit Properties**. Line width settings do not affect the appearance of polygons, keepouts, copper pours, connections, etc. |

<table>
<thead>
<tr>
<th>To set the default line width</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Choose <strong>Options » Current Line</strong> to open the following dialog.</td>
</tr>
<tr>
<td><img src="image" alt="Options Current Line" /></td>
</tr>
<tr>
<td>2. In the Line Width text box, type: <strong>10 mil</strong>. Or select <strong>10 mil</strong> from the list.</td>
</tr>
<tr>
<td>3. Click <strong>OK</strong>. Subsequent lines will be 10 mils wide.</td>
</tr>
</tbody>
</table>

For more information see **Options Current Line (page 457)**.

**Setting Up Via Style**

You can set up your via styles ahead of time before you place vias or before routing. Vias are placed automatically when you change layers in the middle of routing a segment.

The following section contains an example of setting up a simple via. For more information on setting up vias, see **Options Via Style (page 482)**.

The route tools use the current via style unless you have a VIASTYLE attribute defined on the net or net class that you are routing.

1. Choose **Options Via Style** to open the **Options Via Style** dialog. This dialog allows you to add new styles, delete non-default styles, view the default via style, or modify a non-default via style.
2. Add a new via style based on (Default). Click **Copy** to open the following **Copy Via Style** dialog.

3. Type the new name (e.g., vianew) in the Via Name box and click **OK**. You return to the **Options Via Style** dialog.

4. Since the via style is simple, you can change the characteristics of vianew by selecting it in the list box and clicking **Modify (Simple)**.
5. If the via style is complex, you can change the characteristics of the new via by selecting it in the list box and clicking **Modify (Complex)**.

6. Click **OK** to close the **Modify** dialog and save any changes you made to the style. Click **Close** to exit **Options Via Style**.

**Orthogonal Modes (O key)**

You can press the **O** key to switch between the orthogonal modes while placing lines during manual routing. You can enable/disable certain orthogonal modes in the Route tab of the **Options Configure** dialog. The available orthogonal modes are provided as three mode pairs and a Tangent Arc mode. The mode pairs supply a total of six modes (three types, with two variations on each type). The **F** key flips the mode between the angles in the current mode pair.

For more information, see **Options Commands** (page 423).

**Fixed Routable Objects**

The Edit menu includes three commands that allow a specific set of objects to be fixed in their design locations, which is especially useful during routing. The three commands are: Fix, Unfix and Unfix All. To fix an object first select it, then choose **Edit » Fix » Fix** from the menus.

The following objects are all fixable within your design:
Once an object is fixed, it cannot be moved, rotated, flipped, cut, resized or deleted. A fixed object is displayed in the Fixed object color (setup in the Options Display dialog).

The following commands will be ignored by a fixed component:

- Change Pattern
- Move
- Move by RefDes
- Rotate
- Flip
- Delete
- Cut
- Component Type Replacement
- Explode Component
- Align Component (PCB Only)
- Force Update (PCB Only)

### Point-to-Point Routing

To help ensure design integrity, PCB distinguishes between routes that provide a complete electrical connection and those that are physically connected but, depending on the manufacturing technique, may yield a less than satisfactory electrical connection on the finished board. A trace is point-to-point routed if the overlap at the trace endpoint between the trace and net copper to which it connects is at least half of the trace width. This includes lines and arc traces routed to copper polygons, pads, vias, or other traces.

The DRC Unrouted Nets report includes a warning for those objects that are not point-to-point connected. The warning includes the location of the objects not satisfying point-to-point requirements.

The **Utils » Load Netlist, Utils » Optimize Nets, and Utils » Reconnect Nets** commands generate PCB connections between those objects that are physically connected but not point-to-point routed.
General Routing Features

The following sections summarize the special features of P-CAD PCB that you will find useful while using the manual or interactive routing tools.

Status Line Information

The right side of the Status Line displays the orthogonal mode, measurement and net name information while you are routing.

T-Routing

To invoke T-routing, press the **SHIFT** key while the manual or interactive route tool is enabled. The mouse operations are the same for T-routing as they are for reroute: click (initiate), drag (rubberband), release (commit). Using the **T-Route by Default** option in the Route tab of the *Options Configure* dialog, you can T-route without pressing the **SHIFT** key.

When selecting a trace, there are two possible ways to initiate the route depending on the T-route mode: If T-routing is disabled, the selection is treated as a reroute. If T-routing is enabled using the **SHIFT** key, the tool starts a T-route whereby the selected trace is broken at the selection point (unless that point is an endpoint) and routing continues with a new trace anchored at the selection point.

A connection line is created from the selection point to the nearest, unconnected node to guide you in completing the route. When routing into a trace, the intersecting line is broken at the selection point. Just because this feature is called T-routing does not imply that it only works for T shaped intersections. Routing is permitted to and from any existing net traces on the board.

Routing with Curved Arcs

Curved traces can be incorporated into a route segment by enabling one of the Orthogonal Modes in the *Options Configure* dialog. The radius of the arc is controlled through the **Options → Current Radius** command or by selecting the desired radius from the Radius combo box on the Status Line. The ortho mode is displayed on the Status Line along with the net and measurement information.

The current radius is used to determine the curve of the arc while maintaining tangency between the two line segments and the arc.

You can modify or move a tangent arc by using the Miter tool. With the Miter tool active, grab the arc and drag it until the desired radius is achieved.

The available orthogonal mode pairs are described below:
90/90 Line-Line
Both lines are either horizontal or vertical (displayed perpendicular to each other). For long, the first segment is always longer than the second. For short, the first segment is shorter. You can switch between the two by pressing the F key.

45/90 Line-Line:
You can switch between the two modes by pressing the F key. The first mode makes the first segment display at a 45 degree angle and the second segment is either horizontal or vertical. The second mode makes the first segment either horizontal or vertical and the second segment is displayed at a 45 degree angle.

If the plow mode is enabled during routing, the 45/90 Line-Line orthogonal mode is the only orthogonal mode available.

90/90 Arc-Line
You can switch between two modes by pressing the F key. The first mode makes the first segment display as an arc and the second segment is either horizontal or vertical. The second mode makes the first segment either horizontal or vertical and the second segment is displayed as an arc.

Tangent Arc
A curved arc can be incorporated into a route segment when Tangent Arc is the current orthogonal mode. To change the current radius, choose the Options » Current Radius command or the Radius combo box on the Status Line, is used to determine the curve of the arc while maintaining tangency between the two line segments and the arc. Once placed, the arc can be moved or modified by using the Miter tool, which allows you to grab and drag an arc handle to a new radius. If the radius is set to None, the maximum radius is used.
Drop Via
When the plow mode is turned on during routing, you can place a via by choosing Layers in the shortcut menu. In the Options Layer dialog, select the layer on which the via should be placed and click Close. The next mouse click in the design places the via on the via grid closest to the current point as long as no violation with a fixed object exists. The probe continues from its current location to the center of the dropped via and the trace is laid.

Unwind
If you make a mistake, you can press the BACKSPACE key and the previous route action will unwind (disappear). Each press of the BACKSPACE key backs up to the previous point. A right click ends the temporary route mode, and you can then select another connection to route.

To unwind segments that are connected by vias between layers, the BACKSPACE key will treat each via as a segment, automatically deleting it with a keystroke.

Backtracking
Committing a straight line segment on top of another straight line segment, backtracking, acts as an erase operation and the intersection of the two lines is removed.

Vias cannot be erased with backtracking. You need to perform an unwind operation.

Backtracking detects only lines that precisely trace back over previous lines and only during the routing operation. No backtracking is performed for lines already existing in the design.

Routing to Free Copper
Routing to the center of a pad, via, or the endpoint of a line that is not part of any net adds that item to the net being routed. This occurs as each route operation is completed, without choosing the Utils » Reconnect command or the Utils » Reconnect Nets option in the Utils » Load Netlist command.

To add other objects (arcs and polygons) to the net, choose Utils » Load Netlist with the Reconnect Copper option enabled, or use the Utils » Reconnect Nets command after the routes intersecting free copper have been completed. Polygons and arcs maintain full net information and correctly remove connections after they are added to a net.

Changing Layers
To change to a different layer while routing press the L key, SHIFT+L keys, or use the Layer combo box. A via is automatically placed to connect the layers and the line from that point reflects the new color of the layer.

Trace Cleanup
When you choose the Utils » Trace Clean-up command, redundant trace segments (collinear and overlapping) and extra vertices are removed before the traces are added to the design. Trace cleanup also occurs between newly routed traces and preexisting traces.
Overlapping Connections

When connection lines overlap over a pad, priority is given to the connection line that has the same net ID as the pad. Priority is also given to SMD pads that are defined on the current layer.

Copper Pours and Routing

If the Auto Plow Copper Pours check box in the Options Configure dialog is selected, Copper Pours affected by new copper generated by these tools will autoplow when the route completes or suspends.

Manually Routing Connections

The Manual Route tool allows you to place traces precisely. An individual trace can be routed along an arc, at any angle, and into loops. Traces need not obey clearance rules, although online DRC is available.

The following section contains information specific to the Manual Route tool. See General Routing Features (page 103) for information common to both Manual and Interactive Route commands.

Manual Routing Steps

1. Zoom in so that the unrouted connections are large enough to select. To zoom in, press the + key, the Z key, the Zoom button on the toolbar, or choose one of the View » Zoom commands.
2. Choose the Route » Manual command or click on the Route Manual toolbar button.
3. Change to the Top (signal) layer to begin routing. Press the L key to switch to the Top layer (or use the layer combo box or layer line color arrows on the Status Line).
4. Click directly over a connection near a pad where you want the manual routing to begin. Release at a location where you want the first vertex (you can see the color change in the segment you routed). Then click at the location you want for the third vertex. Press the O key to switch to the appropriate 45 degree orthogonal mode (in effect creating the second vertex).

Click again at the location for the fifth vertex; the orthogonal mode will create the fourth vertex for you. Wherever you click, the route line follows, each click becoming a point where you can create a routing angle or change direction. The F key switches between pairs of the orthogonal mode.

Notice, while routing, that part or all of the net is highlighted in the current highlight color. In the Route tab of the Options Configure dialog, you can select which items are highlighted in the Highlight While Routing box. Item highlight options are Pads Only or Pads, Traces and Connection.
If you want to use the keyboard instead of the mouse, move the cursor over the connection (arrow keys or \texttt{SHIFT+arrow keys}), press the \texttt{SPACEBAR}, move the cursor to move the route, then press the \texttt{SPACEBAR} again to place the routed segment.

**Terminating a Route**

To terminate a route, you can choose do one of the following:

- Complete the remainder of the trace by \texttt{right-clicking} or pressing \texttt{ESC}.
- Stop routing without completing the trace by pressing one of the \texttt{SLASH} keys.

The behavior of the \texttt{right-click} and the \texttt{SLASH} key can be switched using the Route tab in the \texttt{Options Configure} dialog.

When you drag the trace over its termination pad, a diamond shape appears. The diamond symbol represents a zero length connection. It disappears when the connection is completed.

| If the diamond shape remains after completing the connection, it indicates the pad you are routing to is on a different layer than the end of the route. |

**Right Mouse Button**

To route the remainder of a connection (in a straight line all the way to the next node), \texttt{right-click}. You can then \texttt{left-click} over another connection segment to begin routing it.

If the current endpoint of the trace being routed is point-to-point with an object belonging to the same net (pad, via, line, or arc) pressing the \texttt{right mouse} causes the route to be recognized as completed, ending the route. The routing guide connection (the remaining connection displayed during manual routing) is not replaced with a line trace to the original guide connection destination point when the \texttt{right mouse button} is pressed. The guide connection will be updated as appropriate.

The exception to this behavior occurs when routing to a pad that is the endpoint of the current guide connection. \texttt{Right-click} or press \texttt{ESC} to complete the route to the pad center.

This behavior can be switched with the \texttt{SLASH} key as described in the following section.

**Slash Key**

The \texttt{BACKSLASH} and \texttt{FORWARD SLASH} keys stop a route in mid-connection without adding a final copper segment. An unrouted connection remains attached to the last routed segment. Both back and forward slashes stop a route.

When the \texttt{Optimize Partial Route} check box is selected in the General tab of the \texttt{Options Configure} dialog, you can press the \texttt{SLASH} key during manual routing to terminate the route and cause the guide connection line to connect to the nearest net endpoint, if the net doesn’t have an \texttt{OPTIMIZE=NO} attribute.

This behavior can be switched with the right mouse behavior using the controls in the Manual Route frame in the Route tab of the \texttt{Options Configure} dialog.
Arc Routing
The arc orthogonal modes can be used in an area where arcs will make routing easier; you can change between different modes while you are routing.

An orthogonal mode is in effect until you change it to a different one. Choose Options » Configure, click the Route tab, and select the 90/90 Arc-Line and Tangent Arc check boxes in the Orthogonal Modes frame. To switch between orthogonal modes, press the O key.

Orthogonal Modes
While routing, you can practice using the orthogonal modes. Use the Options » Configure command to enable them.

Pressing the O key gives you the ability to gain access to the modes enabled in the Options Configure dialog.

Three of the orthogonal modes are provided in mode pairs of 90/90 Line-Line, 45/90 Line-Line and 90/90 Arc-Line. Press the F key to switch between the pair settings. The fourth orthogonal mode is the Tangent Arc mode, which provides access to available radii used in curved arc routing. When you press the F key, Tangent Arc mode is ignored. When the plow mode is enabled during routing the only orthogonal mode available is the 45/90 Line-Line mode.

For more information regarding orthogonal modes, see PCB Basics (page 17).

Interactive Routing

Choose Route » Interactive to gain access to a powerful P-CAD Interactive route tool. Interactive routing provides design rule intelligence to avoid obstacles, copper hugging, pad entry, and automatic route completion.

The following section contains information specific to the Interactive route tool. See Manually Routing Connections (page 106) and General Routing Features (page 103) for information common to both Manual and Interactive Route commands for information common to both Route Manual and Route Interactive.

Interactive Routing Steps
To route connections with Interactive route tool, follow these steps:

1. Choose Route » Interactive or click the Route Interactive button on the Route toolbar.

2. Pick a connection to route. The end closest to the point where the connection is selected becomes the source point; the other end becomes the destination point. Notice that part or all of the net is highlighted in the current highlight color. In the Route tab of the Options Configure dialog, you can select which items are highlighted in the Highlight While Routing box. Item highlight options are Pads Only or Pads, Traces and Connection.

3. The Interactive Route tool rubberbands uncommitted copper with the proper net width and design rule clearances from the source point to the position of the cursor. The rubberbanding
copper tracks around obstacles, maintaining the proper design rule clearances for that net, from the point of origin to the cursor position. While you are moving the cursor, a connection rubberbands from the cursor to the second node of the connection, indicating what remains to be routed.

4. When you click a coordinate that is not the destination node, the previously uncommitted lines are placed on the board.

5. **Right-click** to open the **Interactive Route** shortcut menu and choose **Complete**. The trace will automatically complete.

   If there is an obstruction requiring a layer change, you will hear a beep. The trace remains incomplete.

   **OR**

   Continue until you click a node that is the other end of the rubberband (this could be a pad, via, line, arc, polygon or copper pour island). The route completes automatically.

6. You are now free to choose another connection to route or cancel the tool.

**Obstacle Hugging**

Track segments follow the shortest path from start point to end point, hugging obstacles to within the clearance amount set using the **Options Design Rules** dialog.

The routing area takes into account the following design rules, net attributes, and net class attributes: Clearance, PadToPad Clearance, PadToLine Clearance, LineToLine Clearance, ViaToPad Clearance, ViaToLine Clearance, and ViaVia Clearance.

A clearance indicator displays if you try to route through an obstruction. The clearance indicator appears as a semicircle with a radius showing the clearance amount between the object being routed and the obstruction.

The router always routes on grid, except for off-grid pads where the route is centered on the pad but ends on a grid point.

**Pad Entry or Exit**

Pad entry or exit is calculated from the pad’s center regardless of whether or not the pad is on-grid. The stub length, set from the Route tab of the **Options Configure** dialog, lets you set the minimum number of grid points from the pad’s outside edge for the first track you route.

When entering a surface mount pad, always place the trace to the pad parallel to the bias of the pad and aligned with the pad center.

**Fanouts**

When routing off-grid pad and via fanouts, the interactive routing tool routes a stub in the direction of the cursor of a length (stub length) at least as long as that specified in the Route tab of the
Options Configure dialog. If the cursor position is closer to the pad than the stub length, no stub is created; the route simply starts at the pad center and ends at the cursor position.

Stubs for pads with matching width and height (e.g., round, square) are routable in four (90 degree orthogonal mode) or eight (45 degree orthogonal mode) directions.

Stubs for elongated pads (e.g., rectangle) route along the major axis only. Stubs on off-grid pads go from the pad center and remain off-grid until the cursor position is reached and then snap first to the closest grid line. The remainder of the route (from the stub endpoint to the cursor) ends on a grid point because the cursor is always on-grid. Entering a pad with a route follows the same logic as leaving a pad. Stubs always go to pad center.

Polygonal Pads

Polygonal pad shapes are supported by the Interactive route tool. However, edges that are not 45 or 90 degrees won't hug closely.

Terminating a Route

To terminate a route with the interactive router, you can choose to:

- Route to the termination of the connection.
- Complete the remainder of the trace automatically (right-click and choose Complete from the shortcut menu).
- Stop routing without completing the trace (press the SLASH keys).
When you drag the trace over its termination pad, a diamond shape appears. Then, you have reached the connection destination. The diamond symbol represents a zero length connection. It disappears when the connection is completed.

If the diamond shape remains after completing the connection, it indicates the pad you are routing to is on a different layer than the end of the route.

**Complete**

Right-click and choose Complete from the shortcut menu to automatically complete the remaining portion of the route. The design rule intelligence of the Interactive Route tool neatly hugs obstacles along the trace path.

**Suspend**

Routing can be suspended by pressing the BACKSLASH or SLASH key and the unrouted portion becomes a new connection from the suspension point to the end node.

**Loop Removal**

The Interactive Route tool looks for loops in routed traces. If one is encountered, the loop, along with any resulting floating copper is removed.

**Miter Routing**

The Route » Miter command converts corners on routed connections into arcs or T-routes. You can also use the Miter tool to miter T junctions and modify existing mitered T junctions.

The line width must be the same for the connecting segments in order to miter a corner.

**Using the Route Miter Tool**

To use the Route Miter tool, follow these steps:

1. Select a corner style by choosing a button in the Miter Mode frame in the Route tab of the Options Configure dialog.

2. To create a curved, mitered corner, click and hold on the corner that you want to miter (see A in the following figure). Drag to create the mitered corner (see B in the following). Don’t release the mouse button until you have the proper length of mitering.

You cannot miter non-net traces.
3. To create a 90 degree arc miter, click and hold on a 90 degree corner (A in the following figure), then drag to create the arc (B in the following figure). Release the mouse button when you have the arc miter that you want.

4. For creating a T miter, click and hold on a selection point (A in the following figure), then drag to create the T miter (B in the following figure). Release the mouse button when you have the T miter that you want.

5. To create a corner whose degree is not 45 or 90, enable the Tangent Arc orthogonal mode in the Options Configure dialog. In the Properties dialog, enable the Show Fillet Handles option. Then grab and drag the corner’s fillet handle (A) until the desired radius is achieved (B). The illustration on the right shows how the ghosted lines of the tangent corner are displayed as you move the cursor in the workspace.

6. To cancel a ghosted miter, right-click.
Orthogonal Modes
While miter routing, you can toggle between the mode pairs by pressing the O key. Only 45 degree line miters are supported for T-routes.

Modifying Routes
The following is a list of how to perform certain modifications to already routed segments.

<table>
<thead>
<tr>
<th>Modify Line</th>
<th>You can select a segment or multiple segments, then click the right button and choose Properties from the popup menu to invoke the Line Properties dialog, where you can change the line width.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reroute</td>
<td>Manual and Interactive route allow you to route the selected segment as if it were a connection. If you pick the exact junction of a connection and a routed segment, it will tend to choose the connection to route rather than rerouting the copper. Miter route allows you to alter the corners where traces meet.</td>
</tr>
<tr>
<td>Edit Select and Move (moving an existing routed, or copper, segment)</td>
<td>Select the copper segment (Edit Select); while it is selected, click and drag the copper to its new location. You can also rotate a copper segment by pressing the R key (90 degrees) while the segment is selected. SHIFT+R will rotate, using the angle set in Options Configure. To undo the move or rotation, press the U key.</td>
</tr>
<tr>
<td>Delete copper</td>
<td>Select the routed segment (Edit Select); press the DEL key, and the segment reverts back to a connection (displayed in whatever the connection color is) if a connection is necessary. If the Optimize after Delete option in the Options Configure dialog is enabled, and the net doesn’t have an OPTIMIZE=NO attribute, the connection added is added in an optimized manner.</td>
</tr>
<tr>
<td>Delete connection</td>
<td>After you delete a routed segment and it reverts to a connection, you can select the connection and delete it completely. Caution this is a drastic move because the connections in the design will no longer match the netlist.</td>
</tr>
<tr>
<td>Leave a partial net</td>
<td>If you want to leave an unfinished piece of copper (part connection, part copper), use the SLASH or BACKSLASH key. For manual routing, this behavior can be switched with the right mouse behavior using the Route tab of the Options Configure dialog.</td>
</tr>
</tbody>
</table>

Route Bus
Choose Route » Bus or click the Route Bus toolbar button to enable the Bus Route tool. The Bus Route tool allows you to specify several connections to be guided simultaneously as a bus.
The Bus Route tool is design rule intelligent. It allows you to guide the placement of a collection of traces. It is ideal for a board region containing signals that feed in the same direction, such as routing to an edge connector.

With Bus Route you can pre-select a group of nets. The Bus Route tool routes the selected traces as a group, or bus. The bus width is the total spacing of the original selected connections.

The Bus Route tool can be used in conjunction with Fanout Route to route a collection of signals using minimum spacing. This maximizes the routing area available on the board for other traces. The following example shows Bus Route and Fanout working together:

While using Bus Route, Online DRC is automatically activated. This enables you to view possible design rule violations arising from bus width changes when routing at an angle.

**Using Bus Route**

To route a series of traces using the **Bus Route** tool, follow these steps:

1. Choose **Route » Bus** or click the **Route Bus** button in the Route toolbar.
2. Use the mouse to select multiple connections. You can make this selection in one of two ways:
   - **Select by window**: Click the workspace, hold the left mouse button down, and drag. When you release the mouse, all connections within the specified region are selected.
   - **Select by mouse click**: By clicking a connection, you select that connection. You can select more than one connection by holding down the **CTRL** key while clicking.

   The connections selected for Bus Route must be aligned either horizontally or vertically on at least one end.

3. Press and hold down the **left mouse button** while the cursor is within the selected region and drag the connections to begin routing. The end closest to the point where the connections are selected becomes the source point; the other end becomes the destination point.

   The Bus Route tool rubberbands uncommitted copper with the proper net width and design rule clearances from the source point to the position of the cursor.

   The **Bus Route** tool routes the collection of traces simultaneously, rubberbanding each bus element individually as the cursor is moved.
MultiTrace Routing

You cannot change layers during bus routing.

While bus routing, pressing the F key switches between pairs of the orthogonal mode.

4. When you click a coordinate that is not the destination node, the previously uncommitted lines are placed on the board.

5. Press the SLASH key or right-click and choose Suspend from the shortcut menu. The bus routed traces up to the suspension point are placed on the board. The unrouted portion becomes a series of new connections from the suspension points to the end nodes

OR

continue until you reach the nodes that are on the other end of the rubberband. When the cursor is positioned over a set of pads or trace end points associated with the termination of the selected connection lines, a diamond appears for each bus line that connects to the pad or trace ends. If the route is suspended over the termination points, these routes complete automatically.

MultiTrace Routing

This button enables the MultiTrace Route tool. The MultiTrace Route tool is designed to automatically route several connections. In contrast to Bus Route, MultiTrace routes each connection individually allowing each trace to find its optimum path. MultiTrace has design rule intelligence to effortlessly avoid obstacles.

The MultiTrace Route tool increases your productivity by automating repetitive tasks, to give you the ability to complete a region of the design without intervention. It is optimal in regions of the board with parallel connections.

As with the Interactive Route tool, the MultiTrace Route tool honors routing design rules and net attributes in the appropriate net class hierarchy.

In the following examples, several connections have been automatically routed with MultiTrace. In the first case, the Maximum Hugging feature has been enabled.
The second example shows the same configuration of pads and connections. In this case, the Minimum Length feature has been enabled when the connections were routed with MultiTrace.

There are several options you can select to control trace placement, including Maximize Hugging, Minimize Length, and Orthogonal Mode. See the sections Maximize Hugging/Minimize Length (page 122) and Interactive Routing (page 108) for more information on these options.

Other trace control opportunities are discussed in Controlling Trace Placement (page 117).

Using MultiTrace

To use the MultiTrace route feature, follow these steps:

1. Choose Route » MultiTrace or click the Route MultiTrace button in the Route toolbar.
2. Use the mouse to select multiple pads and connections. You can make this selection in one of two ways:

- **Select by window**: Click the workspace, press and hold the **left mouse button** down, and drag. When you release the mouse, all connections within the specified region are selected. The pads within the region and any connections to those pads are also selected.

- **Select by mouse click**: By clicking a connection, you select that connection. By clicking a pad, you automatically select every connection to that pad. You can select more than one connection or pad by holding down the **CTRL** key while clicking.

3. **Right-click** and choose **Complete** from the shortcut menu. All traces are automatically routed. If a route of a particular connection cannot be completed, the route is not made. The router continues until all connections have been processed.

   There are several options you can select to control trace placement, including Maximum Hugging, Minimum Length, and Orthogonal Mode. See the sections **Maximize Hugging/Minimize Length** (page 122) and **Interactive Routing** (page 108) for more information on these options.

   Other trace control opportunities are discussed in **Controlling Trace Placement** below.

4. When all connections have been routed, you remain in MultiTrace mode. Continue the process until you have completed MultiTrace routing.

   You can press **ESC** while routing to cancel the process. Routes made up to that point are in the database and can be undone.

### Controlling Trace Placement

In the MultiTrace router, each connection is individually routed; it is as if, in the InterRoute tool, you had selected the beginning of the connection, and then selected **Complete** from the pop-up menu. No rip-up or rerouting is performed. Traces are placed only on the current layer.

How do you control a trace whose placement is completed automatically? In MultiTrace, you have control of trace placement by defining design rules, setting routing options, and understanding the MultiTrace router rules. See the sections **Maximize Hugging/Minimize Length** (page 122) and **Interactive Routing** (page 108) for more information on design rules and routing options.

This section covers the basics of the MultiTrace router rules and how, by knowing these rules, you can influence trace placement.

### Routing Priority

The final trace placement is altered by the order that connections are routed. Traces become obstacles for other traces placed later. Try to select pads and connections in an order, which does not interfere with later traces.

With MultiTrace routing, the connections closest to horizontal and vertical are routed first. Selecting the **Honor Layer Bias** check box in the Route Tab of the **Options Configure** dialog forces traces in the direction of the layer bias. Then the tool routes those connections closest to 45 degrees.
Of the traces that lie at the same angle, the shortest is routed first.

To maximize route completion, sometimes connections must be routed in a different order. To modify the routing order, you can select connections individually that you would like routed first. Then, select a window of connections to complete the remaining connections in the region.

**Routing Direction**

The final trace placement is affected by the direction that connections are routed, e.g. right to left or left to right. Specifically, the path of the trace around obstacles may vary with routing direction.

![](image)

If a connection alone is selected or a connection and both terminating pads, the routing direction defaults to either bottom to top or left to right.

If only one pad of a connection is selected, routing begins from that pad and continues to the other end of the connection.

**Route Fanout**

Choose **Route » Fanout** or click the **Route Fanout** button in the Route toolbar to run the Fanout routing tool. The Fanout Route tool is used for the systematic placement of traces from a PCB component. These traces can then be used by Bus Route as a start or termination point. The component pads do not need to be net-connected when Fanout is applied but can be free objects, which are connected to the net at your discretion.

The Fanout Route tool routes from a group of connection end points to a set of on-grid fanout points. Although the Fanout Route tool can route from the end points of traces, it is particularly useful when exiting pads from a placed component. Several fanout modes are available to specify how the traces leave the component pads.

The fanout traces respect the stub length, and the design rules and attributes.

While using Fanout Route, **Online DRC** is automatically activated. This enables you to view possible design rule violations arising in certain surface mount configurations.

**Using Fanout Route**

To use the Fanout route feature, follow these steps:

1. Choose **Route » Fanout** or click the **Route Fanout** button in the Route toolbar.
2. Use the mouse to select multiple connections. You can make this selection in one of two ways:
   - **Select by window**: Click the workspace, hold the left mouse button down, and drag. When you release the mouse, all connections within the specified region are selected. The
window selection tool uses the current Options Block Select Mode (Inside Block, Outside Block, Touching Block) to select connections. For example, if the current block select mode is touching, all connections in contact with the specified window are automatically selected.

- **Select by mouse click:** By clicking a connection, you select that connection. You can select more than one connection by holding down the **CTRL** key while clicking. (The function of the **CTRL** and **SHIFT** keys may be interchanged; these keys are configurable in the Mouse tab of Options Preferences).

The connections selected for fanout must be aligned either horizontally or vertically on at least one end. If both ends of the connections are horizontally or vertically aligned, a pop-up box appears asking you to left-click near the connection endpoints from which you would like the fanout to begin. More than one connection must be selected for fanout.

3. **Right-click** to open the following shortcut menu.

![Menu](image)

4. Fanout route uses the stub length to calculate its route. Choose **Options** to modify the current settings.

5. In the shortcut menu, choose **Fanout**. The Select Fanout dialog appears:

![Dialog](image)

6. Click the desired fanout configuration. The Select Fanout dialog includes the following options:

- **Fanout Style:** Click the button corresponding to the desired fanout style.
• **Space Traces at Minimum Clearance**: If enabled, this check box places the fanout endpoints at their minimum spacing while satisfying the design clearance rules, line width, and grid spacing. If not enabled, the fanout endpoints remain at the original pad spacing.

• When **Fanout Style #4** is selected, the **Space Traces at Minimum Clearance** option is disabled.

• **Preview**: Displays the fanout selection and orientation.

• **Flip/Flop buttons**: Specify the right/left and down/up orientation of the fanout.

• When **Fanout Style #1** is selected, the fanout placement is centered with all trace placement oriented towards the center-most connection. In this case, the **Flop** button (on the right) is disabled.

| If the orthogonal mode is 90 degrees, only Fanout Styles # 1 and 2 are available |

7. Click **OK**. The Fanout Route tool automatically places the fanouts for the specified connections.

**A Fanout Example**

In the following example three connections have been selected between vertically aligned pads.

When Fanout is selected from the shortcut menu, a dialog appears asking from which end the fanouts should begin. Click **OK**. Click the connections near the pads on the left to begin the fanout. This confirmation dialog appears only when there is uncertainty about the fanout direction, as in this case when both ends are aligned and on the current layer.

| If the connection endpoints are not aligned on the current layer, there is no uncertainty about the fanout direction. The **Select Fanout** dialog appears immediately. |

The **Select Fanout** dialog appears:

![Select Fanout Dialog](image)
The Fanout Style # 1 is chosen and the **Flip** button toggled until the fanout display in the Preview box exited the pads to the right. The **Space Traces at Minimum Clearance** box was checked to minimize the spacing between traces at the fanout endpoints.

When **OK** is clicked, a dialog appears asking from which end the fanouts should begin. Click a selected connection near the left end, where the fanouts in this example should begin. This confirmation dialog appears only when there is uncertainty about the fanout direction, as in this case when both ends are aligned and on the current layer.

Again, choose **Fanout** from the shortcut menu. To complete the fanouts from the remaining pads, the **Select Fanout** dialog is modified by clicking the **Flip** button. Otherwise, the same fanout configuration is used.

Click **OK**. Note that the traces are placed in the same fanout configuration, but in the opposite direction.
Maximize Hugging/Minimize Length

The Maximize Hugging/Minimize Length features lets you set trace placement to hug obstacles or to seek the straightest line between routes. These features are available with InterRoute, Fanout, Bus Route, and MultiTrace Route tools. You can toggle between these two settings by clicking their buttons on the toolbar or in the Route Tab of the Options Configure dialog.

When you click the Maximize Hugging button on the Route toolbar, trace placement is set to maximize the hugging of obstacles.
When you select the **Minimize Length** button from the Route toolbar, trace placement seeks the straightest (minimizing corners) possible vialess route. This feature optimizes the use of 45° traces.

### Visible Routing Area

The Visible Routing Area feature analyzes the design rules and displays on the workspace the available routable area. Specifically, it shows the grid points in the area that are legal to route over. The Visible Routing Area feature is available with the InterRoute and Bus Route tools.

By viewing the routable area, you can plan ahead for board design and trace placement. You can see where a trace might go without attempting to place it.

As with the **InterRoute** tool, the routing area takes into account the following design rules, net attributes, and net class attributes: Width, ViaStyle, Clearance, PadToPadClearance, PadToLineClearance, LineToLineClearance, ViaToPadClearance, ViaToLineClearance, and ViaToViaClearance.

> If the design rules or net attributes are modified while routing, the Visible Routing Area remains unchanged until a new connection is selected

The Visible Routing Area is displayed as a region centered around the current cursor position. It expands as the cursor moves outside the region. Under Windows NT the routable area is a transparent hatch and under Windows 95 the area is gray.
Shortcut Menu Commands

When you select a routing tool with InterRoute Gold and right-click, a shortcut menu appears providing shortcuts to frequently used menu commands. The commands in this menu change depending on the tool you select.

The following section summarizes the commands, which appear on the shortcut menus:

- **Cancel** undoes all routing actions and puts the original connection back. The tool remains active.
- **Complete** routes the remaining portion of the trace automatically.
- **Deselect All** cancels the selection of all selected items.
- **Fanout** opens the Select Fanout dialog.
- **Layers** opens the Options Layers dialog.
- **Options** opens the Route tab of the Options Configure dialog.
- **Suspend**, equivalent to the SLASH key, leaves the unrouted portion as a connection.
- **Unwind**, equivalent to the BACKSPACE key, removes the last line or via that was committed.
- **Via Styles** opens the Options Via Style dialog.
Options Configure Route Tab

The Route tab of the Options Configure dialog allows you to set options for the Manual and Interactive route tools. When the Route Interactive tool is active, you can access this dialog by right-clicking and choosing Options from the shortcut menu.

This section describes Interactive Route options.

- **Honor Layer Bias**: When enabled, the layer bias is honored. If the bias is set to Auto, bias is determined based on the following rule: The Top layer is biased in the direction of the longest side of the bound rectangle of the items on the Board layer. All layers then alternate with opposing bias until the Bottom layer is reached.

  You can set layer bias to horizontal or vertical for each signal layer with the Options » Layers command. See Options Layers (page 450) for additional information.

- **Visible Routing Area**: When enabled, the routable area is displayed on the workspace, taking into account the routing parameters such as clearance and trace width. Under Windows NT the area is shown as a transparent hatch; under Windows 95 the area is shaded.

- **Stub Length**: The suggested minimum length or number of Grid Points to use for line segments that enter or exit pads. For nonuniform grids, one grid space is the sum of the grid values.

- **Trace Length**: When you select Maximize Hugging, trace placement is set to maximize the hugging of obstacles. The Minimize Length option generates the straightest (minimizing corners) possible vialess route. This option optimizes the use of 45 degree traces.
Online DRC:

An interactive, online DRC capability notifies you of clearance and net width rule violations, shorts created during manual, interactive, and miter routing, and net references to non-existent via styles by placing DRC error indicators, beeping, and displaying an optional report file. Online DRC does not check tie nets.

An edit operation or DBX command that changes lines, arcs, component and non-component pads/vias, polygons or text are checked for rule violations when online DRC is enabled. This includes the following commands:

- Select move objects.
- Paste, paste from file and paste circuit.
- Modify objects.
- Move to layer.
- Place line.
- Place arc.
- Place text.
- Place polygon.
- DBX-in commands.

You can enable or disable this feature by selecting the Online DRC toolbar button, or by selecting the Enable Online DRC check box in the Online DRC page of the Options Configure dialog. A View » Report option allows you to specify if a report should be presented at the completion of routing for each connection. You can also select from a variety of report options, gain access to the Design Rules and set Severity Levels in the Online DRC page.

The File Reports dialog has a report called DRC Error Indicators. This generates a report of all DRC error indicator locations and descriptions in the active design. In addition, you can use the Utils Find Error command to find the errors.
The P-CAD PCB Editor interfaces to a number of autorouters, including:

- **Quick Route** – a built-in grid based autorouter
- **Shape-Based Router** – a powerful and fast shape-based autorouter that is ideally suited to dense and complex designs. The Shape-Based Router is included with the P-CAD 2002 Suite.
- **SPECCTRA Autorouter** – from Cadence Design Systems, Inc.

All of the autorouters are run from the Route Autorouters dialog. Select the required autorouter in the Autorouters drop-down list and clicking the Start button to start that autorouter.

### Introduction to the Shape-Based Router

The Shape-Based Router runs as a separate application in Windows. The Shape-Based Router requires very little setup or operator intervention, it analyses the board and selects a suitable routing strategy, based on the types of components, the line width and clearance, and the density of the board. The Shape-Based Router includes a number of routing passes, as it runs it adaptively selects the most appropriate routing pass, swapping back and forth between passes to achieve the best result.

For more information on using the Shape-Based Router refer to the on-line help, which can be accessed from the PCB Editor Help menu, or the Shape-Based Router Help menu.

### Routing with Quick Route

This section describes how to use P-CAD Quick Route, the embedded autorouter. You select Quick Route from the Autorouter list in the Route Autorouters dialog. After selecting Quick Route the dialog will change to display the Quick Route control options. These options are described in detail in the Setting Up the Route Autorouter Dialog topic (page 132).

Quick Route routes the active PCB design in a different window. When you start Quick Route an input PCB file is created which contains the PCB with only the placed components, special keepout areas (that Quick Route will not allow traces to cross) and prerouted connections. The design also
includes the netlist information created using a schematic capture program such as P-CAD Schematic, or defined in the PCB Editor.

The netlist information in the PCB file tells Quick Route the connections it must make, while the component and board outline sections of the PCB file define the constraints that Quick Route must work within. When you are laying out your board, remember that the degree of autorouting success depends on the component placement.

Before routing, you can define keepouts and preroutes. Keepouts are areas that you do not want lines to cross. Choose Options » Current Keepout to set the style and layer for the keepout. Then place it to define an area for the router to stay away with.

Quick Route lets you preroute critical lines, such as high-speed ECL clock lines. In addition to performing a complete design rule check on all prerouted connections, Quick Route will not place lines that short the preroutes.

**P-CAD Quick Route Steps**

After you have finished placing components, keepouts and preroutes, P-CAD Quick Route is ready to go to work.

Your PC board appears in the workspace. As connections are completed, they appear on screen, allowing you to monitor P-CAD Quick Route’s progress. The Status Line displays the following messages, giving the status of each step in the routing process:

- **Checking setup parameters**: Checks setup information for errors and output files that already exist.
- **Reading PCB file**: Reads the input PCB file.
- **Assigning pads to nets**: Assigns pads to nets.
- **Assigning lines to nets**: Checks preroutes to make sure they belong to the proper nets.
- **Optimizing prerouted lines**: Reviews and arranges preroutes.
- **Processing pads**: Performs a design rule check on all pads.
- **Processing polygons**: Performs a design rule check on prerouted polygon fills.
- **Processing lines**: Performs a design rule check on prerouted lines.
- **Processing keepouts**: Records all keepout areas as defined in PCB.
- **Processing polygons**: (1) – Records all polygon fill areas as defined in PCB.
- **Optimizing lines**: Compresses the internal data.
- **Optimizing nets**: Processes all nets to find the optimum (shortest) connections.
- **Processing surface pads**: Places vias automatically beside surface pads to facilitate autorouting to them. Unnecessary vias are later removed by the Via Minimization pass, if enabled.
• **The Routing Passes:** Performs each enabled routing pass, listing on the Prompt Line the name of the pass, the percentage of connections completed and, in parentheses, the ratio of the number of completed connections to the total number of required connections.

• **Writing no-route data:** Writes information about uncompleted connections to the log file.

• **Writing routed PCB file:** Writes the routed board information to the output PCB file.

• **Route completed:** Indicates that routing is finished. P-CAD Quick Route displays the percentage of completed connections. In parentheses, the program displays the number of completed connections and the total connections (separated by a / ).

The steps in the routing process fall into four categories:

• Loading files

• Design rule checking

• Routing passes

• Writing the log and PCB output files

The following sections describe design rule checking, each of the routing passes and the contents of the log file.

### Design Rule Checking

P-CAD Quick Route checks that all prerouted connections on the PC board match the netlist (electrical check) and that they maintain the minimum clearance between items in different nets (clearance check). These two checks comprise the Design Rule Check (DRC). The clearance can range from 1 mil up to a maximum number of mils determined by the grid selected.

> **P-CAD Quick Route performs its DRC only on layers enabled for routing. You must place prerouted lines on the same layers you intend to use for autorouting, and then enable those layers, causing both the DRC to be performed and the preroutes to be processed.**

The DRC handles both off-grid and on-grid items. Line segments that cross at any angle are considered connected. Any connections between pads and/or line segments must be proper. The centerlines of connecting line segments must cross; lines that overlap only slightly cause a warning message to be issued. Similarly, if a pad overlaps a line segment, but does not lie on the line centerline, a warning message is issued.

A check is also performed on uncommitted pins (all component pins that do not appear in the net information and therefore should be unconnected). If an uncommitted pin is connected to anything, an error message is issued. However, this does not apply to free pads or free vias (pads and vias that do not belong to a component). A free pad or via that is prerouted to a node in a net is considered a part of that net. P-CAD Quick Route can then use the free pad or via as an additional target for routing to that node.

P-CAD Quick Route will actually clean up a few situations it encounters in the input PCB. This is not to be interpreted that the program will correct electrical or clearance violations – these must be
corrected manually. However, there are a few situations that the program looks for and will change for the better:

- If two lines are collinear (linked end-to-end in a straight line) and their common endpoint is not on a pad, polygon fill or other line, the lines are combined into a single line.
- If a line ends within a pad but not at the pad centerpoint, a small line is added to make that connection.
- If a pad centerpoint lies exactly on a line centerline, the line is divided into two lines at the pad.

The DRC is useful on finished boards as well as partially routed boards. If P-CAD Quick Route does not achieve 100% completion, return the routed file to PCB to manually complete the remaining connections.

Routing Passes
After performing the DRC, P-CAD Quick Route sorts the net information. This involves analyzing each net and finding the optimum (shortest) connections for each node in a net.

The Horizontal, Vertical, L, C, Z and Maze routing passes use these optimum connections.

The Wide Lines, Any Node (2 vias) and Any Node (Maze) passes consider all of the possibilities. All prerouted connections are accounted for and P-CAD Quick Route attempts to complete the remaining net connections.

By default, all routing passes are enabled. For more information see Passes (page 136).

Completing the PC Board
After you complete the routing passes and generate the output files, you can find uncompleted connections. If P-CAD Quick Route’s completion rate is approximately 90 percent or more, you have the following options:

- Modify the component placement on the board and try routing it again.
- Manually route the remaining connections.

The Iterative Approach
If your completion rate is significantly less than 90 percent, you have the following options:

- Manually route the remainder of the board.
- Move components for better placement.
- Enable or disable the Power and Ground planes in the Nets section of P-CAD PCB.
- Immediately return to P-CAD Quick Route and try different passes, more layers, or finer grids.

Advanced planning can help with later changes. For example, if you place your components on a 50 mil grid, you can autoroute on a 25, 16.7 or 12.5 mil grid. However, if you use a 20 mil routing grid on the same placement, the pads on 50 mil centers will be off-grid, lowering the possible completion rate.
When you view the rat's nest of unrouted connections in PCB, look for areas with obvious congestion. Often, you can relieve congestion by moving components. If you find bottlenecks, move the components on the board and then feed the board back into P-CAD Quick Route. Typically, this approach can be simpler than an attempt to route around the high-density areas in P-CAD PCB.

With Quick Route, you can typically cycle through the following procedure several times, before completing the board manually in P-CAD PCB:

1. In P-CAD Quick Route, route the board.
2. In PCB, move the components to minimize the density of unrouted connections.
3. In P-CAD Quick Route, route the board again.
4. If necessary, repeat steps 2 and 3.

**Iterative Approach Guidelines**

A frequently asked question is: When should you attempt this iterative approach vs. when is it time to manually complete the board? While there is no absolute answer, the following conditions typically favor the iterative approach:

- **The components can be moved**: If design constraints do not require fixed component locations, try moving the components in PCB and run the board through P-CAD Quick Route again. A 100 mil grid is best, especially for through-hole designs.

- **The PCB design contains few, if any, preroutes**: This simplifies the process of moving components on the PCB.

- **The routing grid can be changed**: If you have selected a grid for placement such as 50 mil, you can be able to switch routing grids from say 25 mil to 16.7 mil without adding a lot of off-grid components. The finer routing grid can produce better results but must be within the fabrication capabilities of your board manufacturer.

- **More signal layers can be added**: This is a fast way to increase completion percentage, if you can afford the expense of multilayer board fabrication.

- **Add Power and Ground layers**: The Power and Ground layers can be added.

- **The routing process is relatively short, for the potential gain in completion**: If routing takes an hour and only leaves a few connections unfinished, it might be faster to complete them in PCB. On the other hand, if routing takes a few minutes and leaves 20 or more connections unrouted, it is worth a few iterations to reduce the number of no-routes.

- **The completion improves with each iteration**: After a while, the iterative process yields diminishing rates of return. You can even find that an iteration actually increases the number of no-routes. If this happens, it is time to back up one step and complete the design in PCB.
Verifying the Finished Board

Once the board is finished, verify your work by requesting a DRC report, or by feeding the PCB file back into P-CAD Quick Route. Quick Route performs a design rule check on the entire board. Be sure to take the following steps:

- Choose **P-CAD Quick Route** with the finished PCB file as the active PCB design file.
- Set the DRC Clearances to match the capabilities of your PC board fabrication bureau. The program displays any clearance violations on the screen and saves the DRC results in the log file.
- Check the log file for any nets that are still not completely routed. These incomplete nets can result from removing lines in PCB while finishing the board.

Setting Up the Route Autorouter Dialog

Choose **Route » Autorouters** to open the **Route Autorouters** dialog. As shown in the following figure, Quick Route is selected by default in the Autorouter list.

![Route Autorouters dialog](image)

Use the options in the **Route Autorouters** dialog to select the autorouter that you want to use to route your designs. You also use these options to set autorouter options for the selected autorouter, as well as to start and restart the autorouting process.

The following sections describe the Quick Route options that are available in the **Route Autorouters** dialog.
Strategy File
You can save your routing options in a strategy file, which can be opened later for reuse. To open a
strategy file, open the Route Autorouters dialog and click Strategy File. When the Select Strategy
File dialog appears, select the name and location of a strategy file that you want to open.

A strategy file is a collection of settings that you set up in the Route Autorouters dialog. It includes
all data needed by Quick Route to route the board. The strategy filename initially appears as the
same name as the current design file, but with an .str file name extension. This is the default
filename. You can, however, save route strategies to a file with any name.

All Quick Route router configuration settings are saved in the strategy file under the section
[STRATEGY2]. The section [AUTOROUTER] contains keywords specific to all autorouters. One such
keyword is Autorouter= which indicates the currently selected autorouter. The section
[STRATEGY2] contains all the settings specific to Quick Route.

Output Log File
P-CAD Quick Route produces a comprehensive statistical autorouting report that is written to the
file you specify using this button. Click Output Log File in the Route Autorouters dialog to open the
Select Output Log File dialog, in which you can specify the name and location of your report file.

Valuable information about your PCB design, routing strategy and route preference data is
included in this report file.

Click Output PCB File to save the routed design to a file. When you click this button, a dialog
appears in which you can specify the name and location of your output design file. A name for the
output file is provided by default. The letter R (for routed) precedes the current design filename.
The last character is dropped if the new name exceeds eight characters. The file name extension is
.pcb by default. You can override the default name by typing a new name over the default name.

Before routing starts, the input PCB is analyzed. General information as well as your routing
strategy and router-selected options are written to the log file. After each pass, per-pass and total
routing statistics are written to the file. When routing is completed, summary information is written
to the file.

Load Button
Click Load to open a previously saved strategy file. Choose the strategy filename, then click Load.
The design and routing data is updated with the values from the strategy file. You will see these
changes in the Route Autorouters dialog.

Save Button
Anytime after you have selected a strategy filename, you can capture the current strategy by
clicking Save. The strategy file is also saved automatically when you start the route. Binary files can
be saved in a compressed format if you select the Compress Binary Designs check box in the
General tab of the Options Configure dialog.
Set Base Button
Click Set Base to return the strategy and output files to their default filenames. This is a simple way to go back and start over again when assigning filenames. The default names are derived from the design filename, including the full path.

Layers
As a shortcut for choosing Options » Layers, click Layers in the Route Autorouters dialog. The following Options Layers dialog appears:

You can add, delete, enable, disable and modify the routing bias of a layer. Changes made for autorouting apply to PCB.

Quick Route supports up to four (4) plane layers. The nets connected to the planes are defined in PCB when the netlist is first loaded. These can also be defined manually when a plane layer is created.

PCB provides Top, Bottom, Board, and several non-signal layers automatically. Additional signal layers (e.g., MID1-MID8) and power and ground plane layers are automatically defined when a PC board is loaded.
When you create a layer, you must give it a unique name, specify a layer number (one that is not already defined), a routing bias (signal layers only) and a layer type. When you create a plane layer, you must also give it a net name.

Net Attrs
As a shortcut for choosing Edit Nets, you can click **Net Attrs** in the Route Autorouters dialog. The Edit Nets dialog appears as follows.

Use the controls in this dialog to display or hide connections, edit or view net and net layer attributes, change net names, get net information or select net(s) by attributes, attributes on specific layers or node count. It also allows you to view and highlight nets within the design, view nodes attached to a particular net and jump to a node. In addition, you can select one or more nodes and modify their pad or via styles.

Setting net attributes is important for routing, because it lets you override the global values on a net-by-net basis (for example, the line width and via style). For more information on the options in this dialog, see Edit Nets (page 345).

Quick Route supports the following net attributes. These attributes override the default settings for each net to which they are attached.

- **AUTOROUTEWIDE** = <TRUE/FALSE>
- **VIASTYLE** = <via style name> (for wide nets)
- **WIDTH** = <routing track width in current units>
- **NOAUTOROUT** = <TRUE/FALSE>
- **MAXVIA** = <number of vias> (for maze route only)
Passes

Click **Passes** in the Route Autorouters dialog to enable different types of routing passes. When you click this button, the following Pass Selection dialog appears:

![Pass Selection Dialog]

All passes except Route Cleanup and Via Minimization default to **ON**. A description of each pass follows:

**Wide Line Routing**

This pass routes all specified Wide Line nets before executing other passes. Specify wide line nets by adding the AUTOROUTEWIDE attribute to them. The Wide Lines Routing pass makes horizontal or vertical connections only and uses any enabled layer. If you require a wide line that is not horizontal or vertical, preroute the line in PCB using the desired width. Quick Route maintains this width.

All routing of wide lines is based on the same grid selected for routing single lines. To guarantee the correct clearance, it is necessary for the wide lines to occupy more than one grid point.

To route the wide line nets, do the following:

1. Run the board through Quick Route with only the **Wide Lines Routing** pass enabled. Clear the check boxes for all other passes.
2. If Quick Route cannot complete the Wide Line nets, finish routing these nets manually using PCB.
3. Run the board through Quick Route again; this time select all routing passes. Clear the Route Cleanup and Via Minimization check boxes, post-routing passes until all nets on the board are completely routed.

**Horizontal**

This pass completes simple connections on any layer selected with a horizontal bias, with no vias and minimal deviations from a straight, horizontal line.
Vertical
This pass completes simple connections on any layer selected with a vertical bias, with no vias and minimal deviations from a straight, horizontal line.

L Routes (1 via)
This pass is formed by the intersection of two lines and one via, forming an L. The lines have minimal deviations from their center lines and can be placed on any two enabled layers with opposite bias (horizontal and vertical). The L can have any orientation.

Lines are placed no more than 100 mils outside the rectangle defined by the two endpoints in the connection. Although the pass is enabled by default, it is automatically disabled if at least two layers are not set to route in opposite directions (i.e., horizontal and vertical).

Z Routes (2 vias)
This pass is formed with three lines and two vias, forming an orthogonal Z. The Z can have any orientation. Lines are placed no more than 100 mils outside the rectangle defined by the two endpoints in the connection. Although the pass is enabled by default, it is automatically disabled if at least two layers are not set to route in opposite directions (i.e., horizontal and vertical).

C Routes (2 vias)
This pass is formed with three lines and two vias, forming a C. The C can have any orientation. The C route is more flexible than the L or Z routes; it allows lines to be placed more than 100 mils outside the rectangle defined by the two endpoints in the connection. Any enabled layers can be used to complete the C route. Although the pass is enabled by default, it is automatically disabled if at least two layers are not set to route in opposite directions (i.e., horizontal and vertical).

Any Node (2 vias)
The previous passes attempted to route only the optimized connections (the set of connections for a net that would minimize the total line length). To attain the highest possible number of completed connections, the Any Node pass analyzes each net and attempts to make a connection between any nodes in the net.

Maze Routes
This pass attempts optimum connections only (rather than any node in a net). This pass is not restricted by line orientation. It allows the line orientation to differ from the standard orientation of lines on the board layer, to make turns, and to double back.

The Maze pass inserts vias, as required to complete a connection. Specify the maximum number of vias that are allowed for each connection using the MAXVIAS net attribute. The default is 10.

The lines generated by the Maze pass can block channels that you can need to hand-route remaining lines. If so, you might consider an iterative approach; run the board through Quick Route with maze routing disabled, hand-route the desired lines in PCB, and then re-route with Maze routing enabled.
Any Node (Maze)
This pass uses the same routing strategy as the Maze pass. The Maze pass attempts to route only the optimized connections. The Any Nodes (maze) pass attempts to obtain the highest possible number of completed connections by analyzing each net and attempted to make a connection between any nodes in the net.

Route Cleanup
This pass is included to improve a board’s aesthetics and manufacturability. The autorouter intentionally hugs lines during routing for efficiency and higher completion rates. The Route Cleanup pass re-routes some of the lines to eliminate extra jogs where possible. This pass uses the concept of copper sharing to combine lines in the same net. The reduction in line segments has the added benefit of reducing the size of your design file.

Via Minimization and Route Cleanup passes should be run together as a separate operation from other routing passes.

Via Minimization
This pass attempts to reduce the number of free vias. During this pass, Quick Route checks all the lines connected to each free via. If the lines can be swapped to another enabled layer without violating the design rules, they are swapped and the via is removed.

This pass doesn’t affect pads. If you want to ensure that all prerouted vias remain intact, disable this pass or use a through-hole pad instead of a via for connecting prerouted lines on opposite signal layers.

Via Style
A via style defines a stack of shapes for each layer or layer type that make up the via. This option indicates the via style to be used for vias added by the autorouter. You can add, delete, or edit via styles by using the series of available dialogs. This command also sets the current via style for Place Via in P-CAD PCB. You can gain access to this command by choosing Options Via Style.
With this command you define the global defaults for nets as they relate to a via style. For wide routes, you can override these defaults on a net-by-net basis by adding the VIASTYLE attribute by choosing Edit Nets.

You set the default routing via by setting the desired via to be current. The current via is marked with an asterisk (*). To make a via current, select the via style from the list and click **Close**.

Do not inadvertently mistake the default routing via for the default via style. The default via style, which is seen as (Default) in the Options Via Style dialog, is a single style provided as part of PCB. It cannot be changed or deleted. The default routing via is the via style that the autorouter uses to route all nets, except ones with the VIASTYLE attribute set to override this default. The default routing via can be the default via style, or it can be any other style you choose. See [Quick Route Limitations](page 145) for information on via use.

You can create a new via style or modify an existing one directly from this dialog. In addition, you can view the default via style and delete an existing via style.

**Routing Grid and Line Width**

The Routing Grid list contains a list of grids allowed by Quick Route.

![Routing Grid]

The Line Width scroll box lets you select a legal line width whose minimum value is 0.1 mil and maximum value is a function of the Routing Grid selection. The routing line width can’t exceed half the grid value.

The Line Width scroll box lets you select a legal line width whose minimum value is 0.1 mil and maximum value is a function of the Routing Grid selection. The routing line width can’t exceed half the grid value.
For example, if a 25 mil grid is selected, the Line Width option varies from 0.1 mil (.01mm) to 12 mil (.30mm) in 0.1 mil (0.01mm) increments. If you type too large a value, the scroll box automatically self-adjusts to its maximum value when you move to another field. Use the up and down arrows to scroll through valid values.

Error Messages
Use the Error Messages box to set where you would like error messages to appear. You can direct the messages to appear on the screen only, only in the Output Log File, or both (the default setting). If you choose Output to Log File, routing continues uninterrupted, because you do not have to respond to error messages.

Start Button
Click Start in the Route Autorouters dialog to start the routing process. Several changes occur to the screen:

- The menu bar changes to offer route-specific commands.
- The Route toolbar appears replacing the existing toolbar.
- The Status Line displays each step of the routing process.

The autorouter is then initialized, the board is prepared for routing, data is transferred to the router and the router analyzes your design. During this process, the Status Line keeps you informed of all activities. Routing begins, pass-by-pass, and the Status Line displays each completed line as it is routed.

Because you are in Windows, you can gain access to other Windows-based programs during the routing process. However, autorouting is a resource-intensive process, which can affect the performance of the router and other programs as the demand for resources increases.

P-CAD Quick Route routes the board using the current design and route strategy information. Your board must be saved prior to routing to ensure a known base.

If you choose the command after editing a strategy file that contains an existing output filename, the program prompts you to overwrite the output file or cancel. This way, you can avoid overwriting any files that you want to keep.

Commands Available during Routing
During the routing process, you can gain access to a number of commands in the following P-CAD PCB menus. These include:

View Commands
During the routing process, you can choose one of the following commands without interrupting the routing process:
View Redraw
Choose View » Redraw to clear everything in the workspace to the background color and then redraws the screen. To interrupt a redraw in progress, right-click or press ESC.

View Extent
Choose View » Extent to view the extent of all objects placed in the workspace. PCB computes and draws the workspace such that all placed objects on enabled layers are visible. Disabled layers are ignored.

View Last
Choose View » Last to redraw the previous view. This command is shaded and if you have not altered the view in any way. To make the command available, choose a View command and changes the view area.

If you choose View » Last multiple times, you switch between the last two views. Scrolling, centering, and redrawing do not affect the previous view.

View All
Choose View » All to redraw the entire workspace. View All is the view that appears by default, when you start P-CAD PCB. The workspace size is determined by the settings in the Workspace Size frame of the Options Configure dialog. To change the workspace size, choose Options » Configure when the router is not running. The scroll bars do not appear at this zoom level.

View Center
Choose View » Center to redraw the screen using the cursor as the relative center point. When you choose this command, the cursor takes the shape of a magnifying glass to signify that you are in zoom mode. If you click the workspace, the point your click becomes the center of the screen. To cancel the zoom after the magnifying glass cursor appears, right-click or press ESC.

View Zoom In
Choose View » Zoom In to zoom in by the current zoom factor set in the Options Configure dialog. When you choose this command, the cursor takes the shape of a magnifying glass to signify that you are in zoom mode. You click the workspace to zoom in on the workspace. The point you click becomes the center of the zoomed-in area. You must re-invoke the command for every zoom action. To cancel the zoom action, right-click or press ESC when the cursor takes the shape of a magnifying glass.

View Zoom Out
Choose View » Zoom Out to zoom out by the current zoom factor set in the Options Configure dialog. When you choose this command, you are prompted to click for the center point of the zoomed area. The cursor position becomes the center of the zoomed-out area. You must re-invoke the command for every zoom action. To cancel the zoom after the zoom cursor appears, right-click or press ESC.
View Zoom Window
Choose View » Zoom Window to zoom to an area of the workspace that is specified by a zoom window. When you choose this command, the cursor takes the shape of a magnifying glass to indicate that the zoom window tool is active. To learn how to use this tool, see View Zoom Window (page 363).

View Toolbar
Choose any View » Toolbar command to show or hide the toolbar of your choice. Toolbars contain buttons that act as shortcuts for frequently used menu commands.

Disabling the command increases the space within the applicable window. The setting of the toolbar visibility is saved to your PCB.ini file when you quit the program, and restored when you restart it.

View Status Line
Choose View » Status Line to either show or hide the Status Line. The Status Line provides route status information. A check mark next to the command indicates that the Status Line is visible. Disabling the command increases the space within the applicable window.

The state of the Status Line is saved to your Pcb.ini file when you quit the program, and restored when you restart it.

Route Commands
During the routing process, you can choose one of the following commands without interrupting the routing process:

Route Info
Choose Route » Info to open the Information dialog that shows up-to-the-minute statistics on your computer system, including available memory, disk size and disk space free.

The top line for each pass provides information for the pass: the pass name and number, the number of connections, fanouts or nets scheduled and completed, the percentage completed, routing time and vias added or removed. Note that the numbers of items scheduled and completed differ from pass to pass.

The second line for each pass contains overall routing statistics through completion of the pass. This includes the total connections routed, a total percentage of connections completed, overall routing time and the total number of vias. Routing is suspended when this information box appears.

Route Pause
Choose Route Pause to pause the routing process at the point where the command is invoked. While paused, you can change your view, obtain routing information or online help, or cancel the route. This command allows you to temporarily free computer resources to perform other CPU-intensive tasks without terminating the routing process.
Route Resume
Choose Route Resume to resume a route that has been paused. Routing starts at the point at which it was paused.

Route View Log
Choose Route » View Log to view the log file deriving from your routing session with P-CAD Quick Route. P-CAD PRO Route generates a comprehensive report file at the end of the routing session, detailing the results of the session. The report is presented in Notepad. Viewing the log file does not interrupt routing.

Valuable information about your PCB design, routing strategy and route preference data is provided.

Before routing starts, the input PCB is analyzed. General information as well as your routing strategy and router-selected options are written to the log file. After each pass, per-pass and total routing statistics are written to the file. When routing is completed, summary information is written to the file.

The report file contains the following information:

- **General**: The report provides a list of the input PCB, output PCB and strategy filenames, your selected units, the available memory and the route start time. The report also lists the routing grid.

- **Layer Settings**: Provides a listing of the selected layers, indicating their directional bias (horizontal, vertical). Net names are provided for plane layers.

- **Net Classes**: Provides a listing of each net class and their defined width, via pad stack and the maximum number of vias. The autorouter routes all nets belonging to the same net class together in a pass.

- **Pass Settings**: Lists the scheduled passes and identifies the net classes to be routed during each. Some scheduled passes cannot be run, as explained in the next section.

- **Pass Performance**: For each routing pass completed, the report file lists a count and percentage of the lines scheduled and completed during the pass, and for the entire run so far. Also reported are vias that were added or deleted during the pass as well as for the entire routing session.

- **Final Board Statistics**: Final board statistics lists the total number of pads on the board, the number of equivalent 16-pin ICs (EICs), the dimensions and area of the design, the density (in square units per EIC; the lower this number is, the denser the board), the vias added during the routing process, the total number of routed lines (and percentage of routed lines to total lines), the total number of unrouted lines (and percentage of unrouted lines to total lines) and the total execution time for the routing session.

If you abort the routing process, the report file reflects the final board statistics only up to the point of termination. A warning message appears in the report file, indicating the type of termination request made (stop and save or stop and don't save).
Route Cancel

Choose **Route Cancel** to terminate a route before it is completed. When you choose this command, the following dialog appears:

The **Route Cancel** dialog contains the following options:

- **Stop routing and save**: Stops routing and saves an output PCB file with the name provided in the **Route Autorouters** dialog.
- **Stop routing and do not save**: Stops routing and does not save an output PCB file. The input design file is restored to its original state.

**Options Commands**

During the routing process, you can choose one of the following commands without interrupting the routing process:

**Options Display**

Choose **Options » Display** to define color preferences, cursor style, and other display-related options. The **Options Display** dialog has two tabs: Colors and Miscellaneous.

With the Colors tab, you set layer, item, and display colors for your workspace. With the Miscellaneous tab, you set various other options. Your settings are saved in the *Pcb.ini* file and remain in effect until you change them.

For more information on the options in this dialog, see **Options Display (page 442)**.

**Help Commands**

The commands in the Help menu give you the ability to gain access to the PCB Help file and the Help file for supported routers.

**Toolbar**

The following buttons appear from left to right:

- Route Info
Quick Route Limitations

Quick Route has the following limitations. If you fail to use it within these limits, you receive an error message when starting the routing process.

- Only simple pad and via styles are allowed. Quick route does not support the No Connect pad/via style.
- Only a single via style is allowed across all non-wide net classes. The current routing via as specified in the Route Autorouters dialog must be geometrically identical to any VIASTYLE attribute that exists for a net that is not routed with the wide pass.
- For nets routed with the wide pass, each of the net attributes VIASTYLE, WIDTH, and AUTOROUTEWIDE must be specified. There can be a different via style or line width for each wide net.
- The routing via can be no larger in diameter than twice the current routing grid. In the case of non-uniform routing grids, the smallest of the individual grid values is the limit.
- The allowed routing grids are 10 mil, 12.5 mil, 16.7-16.6-16.7 mil, 20 mil, and 25 mil. Metric grids are not supported, even in mm mode.
- The routing line width cannot exceed one half of the grid value. In the case of non-uniform grids, the smallest of the individual grid values is the limit.
- Global ripup and the RIPUP attribute are not supported.
- The MAXVIAS attribute is supported for maze routing only.
- There is no via grid multiple. Vias are placed on the routing grid.
- Blind and buried vias are not supported.
- Quick Route supports pads rotated in 90 degree increments only. If pads are rotated other than 90 degrees, shorts can be created.

Routing Fine Points

There are several fine points to routing a board that will help you obtain a consistently high percentage of connections:

- Prerouted connections
- Keepouts
- Off-grid items
- Plane connections
Chapter 7: Auto Routing

Routing with Quick Route

- Surface pads
- Grid selection
- Pad selection

This chapter describes these fine points.

**Prerouted Connections**

P-CAD Quick Route allows you to preroute any critical connection, such as high-speed clock lines, using PCB. Quick Route checks all prerouted connections for electrical and clearance violations, and eliminates prerouted nets from its netlist so that they are not routed a second time. The preroute processing, however, is limited to layers enabled for routing.

If a free pad or via is prerouted to a node in a net, the free pad or via is added to that net. This is useful for connecting surface-mount components and edge connectors to the Power and Ground planes, as described in *Plane Connections* (page 147).

If a prerouted connection consists of several line segments, always try to place the segments end-to-end. Also, if an area needs to be filled with copper, use polygon fills instead of placing a number of criss-crossing line segments. These practices reduce the amount of memory required to process the preroutes and speed the processing of preroutes.

**Keepouts**

With PCB you can specify areas of the board where P-CAD Quick Route will not place lines. By placing a line segment or polygon fill on a Keepout, you are directing P-CAD Quick Route to avoid routing over these locations on all enabled layers of the PC board. A line segment, as opposed to a polygon fill, is really a “don’t cross”, so lines can both restrict routing from a section or confine routing within a border.

You can create a keepout on a particular layer by placing lines or a polygon fill on that specific layer. Quick Route will not place lines that cross a line or polygon fill.

For example, in a typical board design, edge connectors are often placed so that they partially extend beyond the board outline, and are trimmed later during the manufacturing process to create a clean edge. The board outline (placed on the Board layer in PCB) acts as a barrier for Quick Route. All lines will be routed inside of the board outline. However, since part of your edge connector extends beyond the board outline, it is possible that Quick Route might connect edge connector pads using lines outside of the board outline.

To avert this, create a keepout area over that portion of the edge connector, which extends beyond the board outline. The easiest way to do this is to place an all-layer polygon fill. Be sure the filled area extends at least 50 mils beyond the outside of the edge connector.

**Off-Grid Items**

If a pad is not centered on the selected grid, the program routes to the nearest grid point and then adds a small line segment between the grid point and the center of the pad. Off-grid pads and line segments tend to block subsequent routes more than do on-grid items, and they also lower the completion percentage. In PCB, try to place your components on the selected routing grid or some multiple thereof.

146  P-CAD PCB User's Guide
Plane Connections
Quick Route derives its Power and Ground plane information from the net connection section of the PCB file. You can specify the nets to be connected to the Power and Ground planes when loading a netlist in PCB.

If needed, you can specify a single plane net, such as for a board that has only a Ground plane (the power connections are routed).

If you specify plane nets using Nets Load in PCB, every pad on the input PCB that appears in these nets is processed as follows:

- If the pad is not already connected to a plane, it is connected to the correct plane either directly or with a thermal relief, as determined by dialog selection in the Nets Load section of PCB, and no error message is issued.
- If the pad is connected in the original input file to the wrong plane, either with a thermal relief or a direct connection, it is connected to the correct plane either directly or with a thermal relief and an error message is issued.
- If the pad is already connected to the correct plane, P-CAD Quick Route does not modify the connection.

After processing each pad in the plane nets, P-CAD Quick Route checks all the other pads on the PCB. If any of these pads are connected to a plane, the program removes the connection and displays a message to notify you of the removal.

A free pad or via that is prerouted to a node in a net becomes a new node in that net. Preroutes are taken into account during the processing of plane nets. A free pad or via that is prerouted to a node in one of the plane nets is processed like any other node in that net.

Split Planes
P-CAD Quick Route does not support the split plane feature. It routes a net that is assigned to a split plane, unless you assign the NONAUTOROUTE attribute to the net.

If the net contains SMD pads, you must add via fanouts to connect the pads to the split plane.

Connecting Surface Pads to a Plane
In PCB, you can place two types of pads:

- Through-hole pads (which belong to all PC board layers). The through-hole pads are used for component packages with leads that pass through all board layers.
- Surface pads (which belong to either the Top or Bottom layer). The surface pads are used for surface-mount components and edge connectors.

You can connect through-hole pads directly to the Power or Ground plane. Surface pads, however, require that you connect the pad to a plane by means of a free via or free pad.

Quick Route automatically places a via beside surface pads on the board, including SMDs and edge connectors, providing that:

- The surface pads are part of a net.
Chapter 7: Auto Routing

Routing with Quick Route

- The surface pads are not already connected to a through hole pad.

Vias connected to power or ground pins in the surface mount device are automatically connected to the appropriate power or ground plane. You can prevent connectivity by setting the plane layer Shape to No Connect or by selecting the Prohibit Copper Pour Connections check box in the Modify Via Style (Complex) dialog. If you have interrupted a via's connectivity, PCB displays a blue connection line to indicate that you should route the connection.

The Via Minimization post-routing pass removes a via if the program can swap the via's connecting lines to another layer without violating the design rules. The Via Minimization pass, however, does not affect vias connected to the Power and Ground planes. A via prerouted to a surface pad (for the purpose of connecting the surface pad to a plane) will not be removed.

Direct Connections and Thermal Reliefs

A component lead is connected to a plane by not clearing copper from the area on the plane where the hole will be drilled. This provides good conduction between the lead and the entire plane, both electrically and thermally. The first is desirable, the second is not necessarily so.

When the board is soldered, any leads connected to a large area of copper will not rise in temperature as quickly as other leads. This can either cause poor solder joints or require more heat, neither of which is desirable.

The solution is to connect the lead electrically, but not thermally, to the plane of copper, using a special symbol called a thermal relief. A thermal relief is a small island of copper around the lead, isolated from the plane by an annular gap. The plane is then connected to the island by two or four narrow bridges of copper (termed spokes). These spokes provide the electrical connection and the gap provides the thermal isolation.

When the planes are interior to the PCB, thermal reliefs are generally used. If you are designing a double-sided PCB and you want a bare copper Ground plane for the Bottom layer (as is often the case for RF designs), use direct connections to the Ground plane.

Surface Pads

While P-CAD Quick Route permits you to set the orientation of routes on any layer, a typical double-sided board will be routed with horizontal lines on the Top layer and vertical lines on the Bottom layer. This convention makes it difficult to route a set of surface pads that are arranged horizontally on the Top layer or vertically on the Bottom layer.

For example, consider an edge connector on the Top layer with surface pads arranged parallel to the bottom of the board. P-CAD Quick Route will have difficulty completing connections to the middle pads in the edge connector (all pads other than the first and last) since it cannot easily access these pads with horizontal lines.

To ensure high rates of completions in these cases, P-CAD Quick Route automatically places a via beside surface pads on the board, including SMDs and edge connectors, providing that:

- The surface pads are part of a net
- The surface pads are not already connected to a through hole pad

The via or pad then becomes a potential target for routes to the surface pad.
Selecting the Right Grid
Five different grids are available for use in P-CAD Quick Route. Selecting a finer grid permits one, two, three, even five lines to be autorouted between adjacent pads. This can result in higher completion rates on fewer board layers.

With this flexibility comes the added responsibility for carefully planning the pad sizes, line widths and component placement grid so that you can get the most out of P-CAD Quick Route.

The first step is to determine your board manufacturer’s capabilities and to verify the yields available with various line densities. This will help you determine the best design rules to enforce both on your placement and prerouting, and on the autorouted lines in P-CAD Quick Route.

Planning in advance is absolutely required. If you place your components on a 50 mil grid, you can autoroute on a 25, 16.7 or 12.5-grid. Placing components on a 20 mil grid suggests the use of the 20 or 10 mil grids in P-CAD Quick Route. The least common denominator supporting all routing grids is a 100 mil grid for component placement. Changing grids in P-CAD Quick Route could result in many off-grid components and pads, thus lowering completion rates.

Selecting the Right Pads
In addition to selecting an optimum grid for placement of your components, pad sizes also effect the ability of the autorouter to place one or more lines between adjacent pads. The following table provides the maximum pad sizes for each routing grid, which give the desired effect.

<table>
<thead>
<tr>
<th>Grid Size</th>
<th>Recommended DIP Pad Diameter</th>
<th>Recommended Via Diameter</th>
<th>SMT Pad Diameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>62</td>
<td>40</td>
<td>--</td>
</tr>
<tr>
<td>20</td>
<td>50</td>
<td>40</td>
<td>--</td>
</tr>
<tr>
<td>16.7</td>
<td>40</td>
<td>40</td>
<td>--</td>
</tr>
<tr>
<td>12.5</td>
<td>54</td>
<td>32</td>
<td>30</td>
</tr>
<tr>
<td>10</td>
<td>66,46</td>
<td>24</td>
<td>26</td>
</tr>
</tbody>
</table>
CHAPTER 8

Design Verification

Introduction to Design Verification

This chapter discusses procedures used to verify your design. Included is a description of the attributes checked by DRC for each category of rules. There is also an explanation of the hierarchy used to obtain a value for an attribute's DRC check, from lowest to highest. In addition, the effect of a copper tie on DRC is detailed.

Setting Up DRC Rules

The rules for a board's clearances, widths, lengths and placements are set in the Options Design Rules dialog, which is opened by selecting Design Rules from the Options menu.

Design rules can be defined on each of six levels: Design, Layer, Rooms, Net Class, Net and Class-to-Class. Each of these levels, found on individual tabs in the dialog, is briefly described in the following sections. More information on the Options Design Rules dialog can be found in Options Design Rules (page 459).

Design Tab

The Design tab of the Options Design Rules dialog displays the clearance values that are applied at the “design” level of the rules hierarchy, as shown in the following figure:
To add design rules, click the **Add** button to open the *Place Attribute* dialog. The **Properties** button opens the *Attribute Properties* dialog where the value of an attribute can be modified. For more information on the *Place Attribute* and *Attribute Properties* dialogs, see *Edit Properties* (page 292).

**Layer Tab**

As shown in the following figure, the **Layer** tab contains a list of enabled layers and the clearance values of the currently loaded design file.
In the Layer tab, click **Set All** to select all layer names with items in the Layers list. Click **Clear All** to cancel the selection of all layers in the list. You can select or cancel the selection of a layer by clicking a layer in the list.

Clearance values for the selected layer appear in the Pad to Pad, Pad to Line, Line to Line, Pad to Via, Line to Via, and Via to Via boxes. If you have a variety of settings and you click on two layers that contain conflicting values, the box will be blank.

To modify a clearance value for the selected layers, type a value in one of the text boxes and click **Update**. Nets with clearance attributes defined will override the layer clearance values for DRC. The report produced by the DRC includes clearances specified for specific nets. Additionally, clearance violation tests report shorts except where two or more nets are tied with a copper tie and the TieNet values of the nets and copper tie are the same.

Click **Edit Rules** to open the **Attribute** dialog where you can add, delete and view an attribute’s properties. To define a value for an attribute, click **Add**. The **Attribute** dialog appears. You can assign a value to any number of attributes in various categories. For information on the **Attribute** dialog, see **Place Attribute** (page 396).

Click **Set Defaults** to return all layer/item settings to 12 mil clearances.

Click **OK** when you have finished setting up the design rules (and return to the main **DRC** dialog). From the main dialog, click **OK** to begin the design rule checking process.

**Rooms Tab**

The **Rooms** tab displays the rooms in the design as shown in the following figure:
The rules associated with a selected room are displayed in the Rules list box. The Placement Side frame shows the side of the layer where the room has been placed. Room rules can be modified by clicking the Edit Rules button or double-clicking the rule in the Rules list box.

**Net Class Tab**

The **Net Class** tab of the Options Design Rules dialog displays the defined Net Classes and their associated Rules, as shown in the following figure:

The Net Class tab lists all net classes and the rules associated with each Net Class and Net Class Layer. In the Net Class tab you can access the Net Class and Net Class Layer Rules, select net classes by net class and layer rules, Edit the net classes and view rules.

For more information on the Net Class tab options, see *Net Class Tab* (page 462).

**Net Tab**

The **Net** tab of the Options Design Rules dialog provides access to the net and net layer rules.

When you click the **Net** tab, the dialog appears as follows:
The options in the Net tab allow you to specify clearance rules for a specific net in the design. The dialog lists all nets and shows the net and net layer rules associated with the selected net. In addition, you can select nets by net rules or layer rules, view rules and edit the nets.

For more information on using the Net tab of the Options Design Rules dialog, see Net Tab (page 464).

**Class to Class Tab**

When you click the **Class to Class** tab, the dialog appears as shown in the following figure:
Use the options in the Class-to-Class tab to specify clearance rules for a specific class-to-class in the design. The dialog lists all defined class-to-classes and shows the rules and layer rules associated with them. In addition, you can select class-to-classes by class-to-class rules or layer rules, view rules and edit the class-to-classes.

For more information on using the Class-to-Class tab of the Options Design Rules dialog, see Class to Class Tab (page 466).

Working with Design Rule Check

In working with the rules you want to apply to your circuit board, you need to know not only which rules are included in the Design Rule Check, but also the valid hierarchical levels for those rules and the rule category to which they apply.

Design Rules by Hierarchy

The first table shows the rules included in the Design Rule Check to which values can be assigned in each test category. It also includes the order of precedence (hierarchy), from high to low, by which the Rule Check looks for the presence of the rule’s value. For instance, if the Clearance rule has a value only at the Layer level, the Design Rule Check would have searched and found no assigned Clearance value in the Class-To-Class, Net, and Net Class rules and would then use the value set at the Layer level.

<table>
<thead>
<tr>
<th>Test Category</th>
<th>Rules</th>
<th>Hierarchy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Netlist Compare</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Clearance Violations</td>
<td>Clearance, LineToLineClearance, PadToLineClearance, PadToPadClearance, ViaToLineClearance, ViaToPadClearance, ViaToViaClearance, BoardEdgeClearance</td>
<td>Class-To-Class Layer, Class-To-Class, Net Layer, Net, Net Class Layer, Net Class, Layer (except Clearance), Layer, Design</td>
</tr>
<tr>
<td>Width Violations</td>
<td>Width</td>
<td>Net Layer, Net, Net Class Layer, Net Class, Layer, Design</td>
</tr>
<tr>
<td>Test Category</td>
<td>Rules</td>
<td>Hierarchy</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Netlist Violations</td>
<td>MaxVias</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>ViaStyle</td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Unrouted Nets</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Unconnected Pins</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Net Length</td>
<td>MinNetLength</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>MaxNetLength</td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Silk Screen Violations</td>
<td>SilkscreenClearance</td>
<td>Design</td>
</tr>
<tr>
<td>Copper Pour Violations</td>
<td>Clearance</td>
<td>Class-to-Class</td>
</tr>
<tr>
<td></td>
<td>LineToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToLineClearance</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td>ViaToLineClearance</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>BoardEdgeClearance</td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Plane Violations</td>
<td>Clearance</td>
<td>Class-to-Class Layer</td>
</tr>
<tr>
<td></td>
<td>LineToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToLineClearance</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td>ViaToLineClearance</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Component Violations</td>
<td>PlacementSide</td>
<td>Component</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Room</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td>MaxComponentHeight</td>
<td>Room</td>
</tr>
<tr>
<td>Drilling Violations</td>
<td>HoleToHoleClearance</td>
<td>Design</td>
</tr>
</tbody>
</table>
### Design Rules by Hierarchy

The next table illustrates how the test categories apply to the hierarchical levels, and lists the applicable rules. This table begins with the most specific hierarchical level and graduates up to the most general level.

<table>
<thead>
<tr>
<th>Hierarchy</th>
<th>Test Category</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Netlist Compare</td>
<td>None.</td>
</tr>
<tr>
<td></td>
<td>Unrouted Nets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unconnected Pins</td>
<td></td>
</tr>
<tr>
<td>Component</td>
<td>Component Violations</td>
<td>PlacementSide only.</td>
</tr>
<tr>
<td>Room</td>
<td>Component Violations</td>
<td>PlacementSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxComponentHeight</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Class-to-Class Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Class-to-Class</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Net Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Width Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>Width</td>
<td>NOTE: Lines, arcs and vias cannot touch a keepout.</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>Net</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Netlist Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Net Length</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Test Point Violations</td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxVias</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaStyle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MinNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointRequired</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointGrid</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSpacing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointPermitted</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointAccuracy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointCenter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NOTE: Lines, arcs and vias cannot touch a keepout.</td>
</tr>
<tr>
<td>Net Class Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Width Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Width</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NOTE: Lines, arcs and vias cannot touch a keepout.</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>Net Class</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Netlist Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Net Length</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Test Point Violations</td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxVias</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaStyle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MinNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointRequired</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointGrid</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSpacing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointPermitted</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointAccuracy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointCenter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NOTE: Lines, arcs and vias cannot touch a keepout.</td>
</tr>
</tbody>
</table>

P-CAD PCB User’s Guide
### Additional Design Rules

The third table, shown on the following page, lists additional checks performed by DRC, which are not user-specified. You do not have to add attributes or specify values for attributes in order for DRC to check these constraints. For instance, DRC checks components for inclusion in a Room. You cannot set a value for this check since there is no attribute associated with it, but it is part of the verification that DRC performs.
<table>
<thead>
<tr>
<th>Test Category</th>
<th>DRC Checks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>Component Side</td>
</tr>
<tr>
<td></td>
<td>Component Height</td>
</tr>
<tr>
<td></td>
<td>Room Inclusion</td>
</tr>
<tr>
<td></td>
<td>Empty Room</td>
</tr>
<tr>
<td>Copper Pour</td>
<td>Copper Pour Clearance</td>
</tr>
<tr>
<td></td>
<td>Unconnected Copper Pour Island</td>
</tr>
<tr>
<td></td>
<td>Unpoured Copper Pour</td>
</tr>
<tr>
<td></td>
<td>Copper Pour No Net</td>
</tr>
<tr>
<td>Drilling</td>
<td>Drilling Clearance</td>
</tr>
<tr>
<td></td>
<td>Hole Range Same Layer</td>
</tr>
<tr>
<td></td>
<td>Hole Range Conflict</td>
</tr>
<tr>
<td>Net Length</td>
<td>Net Length</td>
</tr>
<tr>
<td>Netlist</td>
<td>Point-to-Point Connectivity</td>
</tr>
<tr>
<td></td>
<td>Pseudo Pattern</td>
</tr>
<tr>
<td></td>
<td>Undefined Via Style</td>
</tr>
<tr>
<td></td>
<td>Tie Net Connectivity to Copper Tie</td>
</tr>
<tr>
<td></td>
<td>Net Connectivity to Uncommitted Pins</td>
</tr>
<tr>
<td>Plane</td>
<td>Plane Clearance</td>
</tr>
<tr>
<td></td>
<td>Fragmented Plane</td>
</tr>
<tr>
<td></td>
<td>Plane Partial Connections</td>
</tr>
<tr>
<td></td>
<td>Plane Shorts</td>
</tr>
<tr>
<td></td>
<td>Plane Unconnected</td>
</tr>
<tr>
<td></td>
<td>Plane No Net</td>
</tr>
<tr>
<td></td>
<td>Plane Overlap</td>
</tr>
<tr>
<td>Silk Screen</td>
<td>Silk Screen</td>
</tr>
<tr>
<td>Clearance</td>
<td></td>
</tr>
<tr>
<td>Test Point</td>
<td>Test point not on net copper.</td>
</tr>
<tr>
<td></td>
<td>Test point not positioned on grid.</td>
</tr>
<tr>
<td></td>
<td>Test point violates spacing rule.</td>
</tr>
<tr>
<td></td>
<td>Test point not permitted on object.</td>
</tr>
<tr>
<td></td>
<td>Test point not centered on SMT.</td>
</tr>
<tr>
<td></td>
<td>Test point not centered on thru hole.</td>
</tr>
<tr>
<td></td>
<td>Test point pad and via accuracy.</td>
</tr>
<tr>
<td></td>
<td>Test point required by net.</td>
</tr>
<tr>
<td></td>
<td>Test point on wrong side.</td>
</tr>
</tbody>
</table>
Chapter 8: Design Verification
Configuring DRC

<table>
<thead>
<tr>
<th>Test Category</th>
<th>DRC Checks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Text Clearance</td>
</tr>
<tr>
<td>Unconnected Pin</td>
<td>Unconnected Pin</td>
</tr>
<tr>
<td>Unrouted Net</td>
<td>Unrouted net</td>
</tr>
<tr>
<td></td>
<td>Hole Range No connect</td>
</tr>
<tr>
<td></td>
<td>Hole Range Violation</td>
</tr>
</tbody>
</table>

**Copper Ties and DRC**
When Design Rules Checking encounters a copper tie the standards listed below are applied and errors or warnings are issued where appropriate:

- DRC does not report a short when two or more nets are connected by a copper tie. However, if two nets are already in a shorted condition, an error is reported even if a copper tie is laid on top of the shorted area.
- An error is issued when a copper tie is placed without physically touching at least two nets.
- A net with a TieNet value, which is not connected to a copper tie with the same TieNet value, is an error.
- An error occurs when a copper tie has a clearance violation or shorts with another net that does not have the same TieNet value.

**Configuring DRC**
This section describes how to set up the report file destination and specify report options.

1. Choose **Utils » DRC**. The **Utils Design Rule Check** dialog appears as shown in the figure:
The name of the destination report appears next to the Filename button. By default, the report has the same name as the design file with the .drc file name extension.

2. In the Report Options frame, select the following options:
   - **View » Reports**: Select this check box to view the DRC report file when design rule checking is complete.
   - **Summarize Ignored Errors**: Select this check box to include the number of ignored errors in the report. Ignored errors are not included in the output of the report unless this option is selected.
   - **Summarize Overridden Errors**: Select this check box if you have overridden the display of errors in the design, but want them to be summed in the report.

3. In the Error Options frame, select the following options:
   - **Annotate Errors**: Select this check box to create DRC error indicators, which will be displayed on your design. These indicators can then be selected for viewing of error information. The error information is determined by the other error/violation options that you enable in design rule checking.
   - **Clear All Overrides**: Select this check box to clear all overridden errors.

4. Click **Design Rules** to open the Options Design Rules dialog. Use this dialog to add, delete and modify rules. For more information, see **Options Design Rules** (page 459).

5. In the **Utils Design Rule Check** dialog, click **Severity Levels**, The Rules Severity Level dialog appears as shown in the following figure:

   Use this dialog to change the severity of the design rules. In the Rules Severity Level dialog, select a rule from the Rule list and choose one of the buttons in the Severity Level frame: Error,
Warning or Ignored. To restore the default settings, select the Set Default check box. Then, click OK to close the dialog.

If you choose Ignored in the Summarize Errors frame, the error is not listed in the report, but will be summarized in the report if you select the Summarize Ignored Errors check box in the Report Options frame on the Utils Design Rule Check dialog.

6. In the Design Rule Checks frame, select the following options:

- **Netlist Compare**: Select this check box to compare a Tango, P-CAD ASCII, or PCAD ALT format netlist file with the current nets in the design.

- **Clearance Violations**: Select this check box to enable air-gap and board edge clearance checking and report shorts. If the Clearance Violations option is disabled, no clearance errors will be reported.

The clearance violation check considers items physically connected if they overlap or have a clearance of 0 mil. Arcs, polygons, pads, lines, copper pours and vias can be physically connected to one another, however, lines, arcs and vias cannot touch a keepout. In addition, the bounding rectangle of text placed in the design is checked to assure that it does not short to other copper on the signal layers.

- **Text Violations**: Select this check box to report all clearance violations between text and other items on signal layers.

- **Netlist Violations**: Select this check box to enable electrical checking against the netlist within the design. The report includes a warning for those objects that are not point to point routed. If there are no nets in the design, this option is ignored.

- **Width Violations**: Select this check box to verify that the line and arc widths are within the designated widths.

- **Unrouted Nets**: Select this check box to enable reporting of any nets that are currently unrouted (unrouted connections still exist in the design). The warning includes the location of the objects.

- **Unconnected Pins**: Select this check box to enable the reporting of all pins that are not connected to other pins. This includes all of the single-node routes as well as pins that are not connected or assigned to a net.

- **Net Length**: Select this check box to enable the reporting of net lengths, which exceed the minimum, and/or maximum lengths set for lines and arcs within the net.

- **Silkscreen Violations**: Select this check box to enable checking on pad/via to silkscreen violations. Silkscreen on pads on top layer can interfere with soldering process; on vias it can cause paint dripping or collecting in unwanted areas.

- **Copper Pour Violations**: Select this check box to enable reporting of unflooded copper pour entities, copper pours that are not part of a net, copper pour island clearance violations, unconnected islands, fill areas and thermal connections that have clearance violations.
• **Plane Violations:** Select this check box to enable reporting of overlapping planes, invalid pad and via copper connections, connected pad and vias that are not electrically connected to the plane, isolated areas of copper in a plane.

• **Component Violations:** Select this check box to enable reporting of violations, which occur when the desired space between components is less than the specified value.

• **Drilling Violations:** Select this check box to enable connectivity checking of pads/vias through their attached layers, utilizing the layer ordering and hole range for determining where the pad/vias begin and end.

  - In addition, Drilling Violations checks for layer separation, interference between holes, collocated holes, and vias existing solely on a signal layer.

• **Test Point Violations:** Select this check box to check for nets that do not have a required test point. This option also checks for test points that do not fall on the correct object, or on the specified test point grid or pad center. In addition, it checks for test points that fall inside of the minimum spacing or on a different side of the board than the net requires.

7. Click **OK** to start the design rule check. If you selected the **View Reports** check box, the DRC report file appears when design rule checking is complete.

**Online DRC**

Online DRC is available to interactively display rule violations as the board is being built. Online DRC checks for clearance and net width violations, shorts of traces (both lines and arcs) and vias, and net references to non-existent via styles that are added to a design during manual routing. Depending on the options chosen in the General tab of the **Options Configure** dialog, online DRC performs a check of the traces and vias against all items, excluding copper pours, on signal layers to determine if a DRC violation occurred. A violation occurring on a non-signal layer (such as a via intersecting a silk layer item) is not detected with Online DRC.

Online DRC is activated by clicking the **Online DRC** button on the toolbar or selecting the **Enable Online DRC** check box in the **Online DRC** page of the **Options Configure** dialog. For complete information on the options available to Online DRC, see **Options Design Rules** (page 459).

**Using DRC Error Annotation**

This section describes the steps for displaying and viewing DRC annotated errors. You will also learn how to override the display of error indicators individually and globally. The commands you will learn to use include the following:

• **Utils Find Errors:** This command opens the **Find Errors** dialog, which provides quick access to all annotated errors. For details, see **Finding DRC Errors** (page 168).

• **Options Display:** This command opens the **Options Display** dialog. If you select the **Display Overridden Errors** check box in the Miscellaneous tab, overridden error indicators will appear in the design. For details, see **Overriding Error Displays** (page 169).
Chapter 8: Design Verification

- **Options » Selection Mask**: This command opens the Options Selection Mask dialog, in which you can set whether to include DRC annotated error indicators in block selection. For details, see Block Selecting Error Indicators (page 169).

- **Edit Override/Unoverride**: This command lets you set the shape used when individual error indicators are seen in the design. For details, see Overriding DRC Errors (page 170).

- **Edit » Properties**: This command gives you access to error information for a selected error indicator by providing another path to the Find DRC Errors dialog. For details, see Fixing DRC Errors (page 170).

- **Edit Delete**: This command gives you the ability to delete DRC error indicators from your design as they are resolved. For details, see Deleting DRC Errors (page 170).

The DRC error annotations that are generated with the Utilities DRC command are displayed as graphic indicators in your design. Newly added indicators are always visible.

**Finding DRC Errors**

The recommended method for using DRC error annotation to find design errors is as follows.

1. Choose **Utils Find Errors** to view the errors in the Find DRC Errors dialog.

2. Show the error you want to correct and go directly to it in the design by clicking **Jump To**.

   If you do not want to see a particular error while scrolling through the list of errors, enable the **Override - Don’t display this error again** option. To scroll through only the overridden errors, enable the **Show Only Overrides** option.

To view another error you can use any of these methods:

- If you know the number of the error, you can enter it in the **Error Number** box and click **Find**. The error finder goes directly to that error and displays it in the Description area.

- You can scroll through the errors using the up and down arrows next to the **Error Number** box until you find the error you want to view.

- If you have block selected an area in the design, and want to view only the errors in that area, select the **Show Only Selected** check box.
Click **Jump To** and the error finder positions the cursor in the center of the error indicator in your design.

### Overriding Error Displays

To globally control the display of DRC error indicators, choose **Options » Display**. When the **Options Display** dialog appears, click the **Miscellaneous** tab. Then, select the **Display Overridden Errors** check box in the Miscellaneous frame.

![Options Display Dialog](image)

When the **Display Overridden Errors** check box is selected, any DRC error whose display has been overridden appears in the design as an inverted triangle.

If you do not want to see a particular error while scrolling through the list of errors, enable the **Override - Don’t display this error again** option. To scroll through only the overridden errors, enable the **Show Only Overrides** option.

### Block Selecting Error Indicators

To include DRC error indicators in a block selection, enable the **DRC Error** item in the **Options Selection Mask** dialog.
**Overriding DRC Errors**

To override the display of a DRC error indicator, select an error. Then, right-click the error and choose **Override** from the shortcut menu. When overriding an error indicator, you can hide it from view or change its shape.

The **Utils » DRC** command ignores an error condition if the error was previously overridden.

To show overridden errors, select the **Display Overridden Errors** check box in the Miscellaneous tab of the **Options Display** dialog. When selected, an overridden error indicator appears as an inverted triangle.

To remove an override from an error indicator, select the error. Then, right-click and choose **Unoverride** from the shortcut menu.

**Fixing DRC Errors**

The recommended method for using DRC error annotation to fix design errors is as follows:

1. Choose **Utils Find Errors** to open the **Find DRC Errors** dialog.
2. Display the error to correct. Then, click **Jump To** to go directly to the design.
3. Continue resolving the errors in the design in this same manner until all errors are fixed.

**Deleting DRC Errors**

You can delete the DRC error indicators from your design as they are resolved. To delete an error indicator, choose one of these methods.

- To delete an error, select the error and press the **DELETE** key or choose **Edit Delete**.
- To delete resolved error indicators only, choose **Utils » DRC**. This deletes all resolved error indicators, leaving only unresolved errors. Each time you choose **Utils » DRC**, all existing DRC error indicators are removed automatically.

You can also hide an error indicator by selecting an error and choosing **Edit Override**. To do this, clear the **Display Overridden Errors** check box in the Miscellaneous tab of the **Options Display** dialog.
CHAPTER 9

CAM

Introduction to CAM

This chapter explains how to perform CAM functions for both Gerber and N/C Drill file output. We have provided you with a special design, Tutor3.pcb, for you to use in this chapter. Load this design using the File » Open command.

Gerber Output

In this section, you will set up Gerber output files, assign and describe apertures both automatically and manually, set up the Gerber format, and then finally generate the output.

Choose File » Export » Gerber to open the File Gerber Out dialog shown in the following figure:
From this dialog you can gain access to a number of dialogs and features, as shown in the following illustration.

Use the *File Gerber Out* dialog to generate the Gerber output, and where you set or clear files for output, produce compressed output or executable files in addition to accessing other important dialogs.

The Generate Output Files, Set All, and Clear All buttons are shaded and not available until you define the output files.

**Set Up Output Files**

To set up output files, follow these steps:

1. Choose **File > Export > Gerber** to open the *File Gerber Out* dialog.
2. Click **Setup Output Files**. The following *Setup Output Files* dialog appears.
3. Your output files have the same base name as the design file, but each with a unique extension. Typical extensions used to differentiate files would be layer-specific, such as .top for Top layer, .bot for Bottom layer, .tsk for Top Silk, etc.

4. In the File Extension box, type: TEXT

5. In the Layers list, select Top.

6. Select the Pads and Vias check boxes. Then, click Add to add Tutor3.top to the Output File list.

7. In the File Extension text box, type: BOT

8. Select the Bottom layer in the Layers list.

9. Use the same options and output path as you did for TOP. Click Add to add Tutor3.bot to the Output File list.

10. In the File Extension text box, type: TSK

11. Select the Top Silk layer in the Layers list.

12. Select the Ref Des, Type, and Value check boxes, and clear all other check boxes.

13. Click Add to add Tutor3.tsk to the Output File list.

14. Specify the Output Path as C:\PCAD\TUTORIAL. If you enter an invalid path, you'll get an error message when you try to close the dialog.

The pathname (Output Path) is a global option – all output files are placed in the same directory.
15. Click **Close** to exit the dialog and return to the *File Gerber Out* dialog. The Gerber files Tutor3.top, Tutor3.bot, Tutor3.tsk appear in the Output Files list.

### Aperture Assignments

In the *File Gerber Out* dialog, click **Apertures**. The *Aperture Assignments* dialog appears. Use the options in this dialog to create and assign apertures automatically or manually.

#### Automatic Create and Assign

To automatically create and assign apertures, select the **Clear current apertures** check box. If you don’t want to clear your current apertures and assignments, clear the **Clear current apertures** check box. Then, click **Auto**. The program creates and assigns any additional apertures that are required.

The list in this dialog displays the items of the loaded design file and any aperture assignments that may exist for those items, allowing you to view which items are assigned and what those assignments are.

1. Select the **Clear current apertures** check box.
2. Click **Auto** to automatically describe and assign all apertures for all items. The dialog displays the assignments, as shown in the following figure.
Assigning Apertures Manually

To describe and assign an aperture manually (or to change an existing assignment), double-click an item line, or select an item line and click **Assign**. The *Describe/Assign Apertures* dialog appears.

You will unassign certain apertures that were assigned automatically in the previous lesson, and then manually assign them.

1. In the *Aperture Assignments* dialog, select **PAD EL 50 mil 50 mil 50.0 mil**, then click **Assign** to open the following dialog.

2. Whatever item name you highlighted on the previous dialog appears in the Assign Aperture to field at the top of this dialog. The aperture names appear in the Apertures list.

Modifying an Assignment

The item characteristics are listed to the right of the list, and the aperture characteristics are listed there as well (if an aperture is assigned). You can change the characteristics by using the text boxes and the Shape and Type combo boxes. You can also enter a comment for future reference.
1. The aperture D015 is already selected because it had been automatically created and assigned in the previous dialog. To select a different aperture to assign, select the item in the Apertures list.

2. Modify any of the options that appear on the right side of the dialog. For example, change the Type to Flash/Draw.

3. When you have entered the characteristics, click Modify. The changes you made are reflected in the selected aperture.

4. Click Close to return to the Aperture Assignments dialog, where the assignments you’ve made are now listed. From Aperture Assignments you can click Close to return to the main File Gerber Out dialog.

Setting Drill Symbols

From the File Gerber Out dialog, click Drill Symbols to open the Drill Symbol Assignments dialog. From this dialog, you can assign drill symbols manually or automatically.

Automatic Assign

To automatically assign drill symbols, you can either let the program automatically make all assignments, or you can clear (unassign) all existing assignments and then automatically assign all of them. You can click Unassign All to clear everything or Unassign to clear the hole diameter that is highlighted.

The list of this dialog displays the hole diameters of the loaded design file and any drill symbol assignments that may exist for those hole diameters, allowing you to view which items are assigned and what those assignments are.
1. Click **Automatic Assign** to automatically assign a drill symbol to each hole diameter in the design.

**Manual Assign**

To manually assign drill symbols:

1. Select **18.0 mil** under Hole Diameter in the list.
2. Select **Diamond X** from the Drill Symbols list.
3. Click **Assign**. Diamond X will appear next to 18.0 mil in the list.
4. Click **Close**.

The **File » Print** and **File » Export » Gerber** features share common drill symbol assignments; when symbols are assigned in one, they will apply to the other.

**Gerber Format**

In this section you’ll be setting output units, the numeric format, and other format options for Gerber output.

From the **File Gerber Out** dialog, click the **Gerber Format** button to open the **Gerber Format** dialog.

![Gerber Format dialog](image)

You will be using the default Gerber output format, RS-274-D. To output this format, clear the **Include Aperture Definitions** check box.

Choose **Inches** in the Output Units frame. This option is selected by default.

1. Choose **4.4** in the Numeric Format frame. This option is selected by default.

   The format 4.4 means that there are four digits to the left of the decimal point and four digits to the right. The format 5.3 means that there are five digits to the left of the decimal point and three digits to the right.

2. Leave the G54 w/ apertures option disabled. It determines whether or not to send a G54 tool select code with each command to change apertures.
3. Clear the **Include aperture definitions** check box.  
   This option determines whether or not definitions, assignments, and macros are to be included in the body of the file. These options use RS-274-X format.

4. Click **Close** to exit the dialog (returning to the **File Gerber Out** dialog) and the format you specified will be applied when the output is generated.

---

**Compress Output Files**

You may elect to produce files in a compressed format by enabling the **Compressed (.zip)** or **Self-Extracting (.exe)** option.

Both .zip and .exe files will compress the selected output files into one smaller file. The .zip option produces a smaller file than the .exe option but requires an unzip.exe program to decompress the file when you need to access it. The compression done in the self-extracting .exe option outputs a larger file than is output by the .zip option because its uncompress function is included in the compress program.

---

**Generating Gerber Output**

You have set up the output files, done aperture assignments, and set Gerber format. Now you can generate the output files.

1. Select the files you want to generate. If you want to generate all of the files you have set up, click **Set All**.

2. Click the **Generate Output Files** button in the **File Gerber Out** dialog.

---

**Gerber Verification**

In this section you will use the **File » Import » Gerber** command to verify the accuracy of a Gerber file. With this command, you can open a series of Gerber files. You can load a Gerber file into the editor to check its accuracy. Each file is loaded onto a separate layer.

You can load a Gerber file either into an empty workspace or superimpose it onto an existing design. If you are going to superimpose a Gerber file onto an existing design, be sure to save your design first. If you forget, see the Deleting Gerber Layers section. Loading a Gerber file can be useful for checking pad size, line width, etc. Superimposing a file onto a design is a good way to verify the Gerber file against the design.

---

You can load multiple Gerber files onto your design file, each inhabiting its own layer. Therefore, the layer names must be unique. So, the first file loaded would be on the layer Gerber, the next file loaded would receive the default name Gerber1, then Gerber2, etc.

1. Choose **File » Clear** to clear all items from the current workspace. You can only load the Gerber file into an empty workspace if you had opened the design file in the same window (so that the aperture definitions are still in memory).
Aperture definitions are saved and loaded in the design file. Loading a new design file can completely change the current aperture settings. The File » Clear command does not clear current aperture definitions. Choose File » Clear to clear the workspace without clearing current definitions before loading a newly created Gerber file. As soon as the Gerber file is loaded, choose File » Save As to save the Gerber file using a different design file name. This allows you to keep any image of the Gerber and apertures for later use.

2. Choose File » Import » Gerber to open the File Gerber In dialog.

3. Click Gerber Filename to open the following File Gerber In dialog.

4. Navigate to your Gerber file and select it (e.g., Tutor3.top). Then, click Open to return to the File Gerber In dialog.

5. In the File Gerber In dialog, type a layer name in the Layer Name box. Then select a layer number from the Layer Number list.

6. Select or clear the View log File upon completion check box. The layer name Gerber is provided as a default, but may be changed.

7. Click OK to load the Gerber file. A progress indicator appears, as shown in the following figure.
Important: The D Code apertures that are called out by the loaded Gerber file must be present and be defined as they were in the original Gerber file. If a D Code is no longer present, then the program flags the error. If the D Code is present but its definition has changed, no error is flagged, but you may get unexpected results. This could occur if you loaded an old Tango Series II Gerber file without recreating the aperture definitions properly. Our advice is not to redefine D Codes at all between the creation of the Gerber file and reloading it for design file/Gerber file comparison.

Deleting Gerber Layer Information

After a Gerber layer is loaded into PCB, you may inadvertently save it with the PCB design file. Generally, this information is used only for viewing, to verify that the Gerber files were generated correctly. If you inadvertently save those layers, the Gerber information and layers need to be deleted, leaving the rest of the file untouched.

Layers can only be deleted one at a time, so the following procedure needs to be performed for each Gerber layer that was saved with the file. Depending on the items that are on the board, this can be done in one of two ways. The first procedure should be used if the board does not contain free pads. The second procedure should be used if the board does contain free pads.

No Free Pads on the Board

With no free pads on the board, the Gerber layer can be deleted as follows.

1. Choose Options » Selection Mask. The Options Selection Mask dialog appears.
2. Click Clear All in the Layers frame. Select the Gerber layer you want to delete. In the Items box, clear the component and via check boxes.
3. Block select the entire board by choosing the Edit Select command. Everything on the Gerber layer should selected.
4. Press the DELETE key.
5. Choose Options » Layers. The Gerber layer can now be deleted. Select the Gerber layer and then click Delete.

Free Pads on the Board

With free pads on the board, additional steps are needed to clear the Gerber layer. You must enable one Gerber layer at a time, otherwise the pads and vias are deleted from all layers, not just the Gerber layers.
1. Choose **Options » Layers**. Disable all layers except the Gerber layer you want to delete. Your display should now show only the information found on the Gerber layer.

2. Choose **Options » Selection Mask**.

3. Clear all layers in the Layers box, then select the Gerber layer you want to delete. In the Items box, clear the component and via check boxes.

4. Block the entire board using the select command. Everything on the Gerber layer should be selected.

5. Press the **DELETE** key.

6. Choose **Options » Layers**. The Gerber layer can now be deleted. Click on the Gerber layer and then click **Delete**. Now enable all other layers by clicking **Enable All**.

### Creating a Padmaster Gerber File

Occasionally, a padmaster Gerber file containing all through hole pads and vias is requested by the service bureau that is generating the artwork for a board. To create a padmaster Gerber file:

1. Choose **Options » Layers** to create an unused signal layer.

2. Choose **File » Export » Gerber in Setup Output File** to create the padmaster Gerber file using the unused signal layer you just created and enabling only thru pads and vias.


### N/C Drill Output

This section takes you through the steps for generating N/C Drill files.

The features for N/C Drill are similar to that of Gerber output. If you have followed the Gerber output tutorial in the previous section, then you already understand much about how PCB handles N/C Drill output. Therefore this N/C Drill output tutorial is much less complex, taking you through the minimum number of steps to acquaint you with certain features and options that are different from the Gerber output.

In this section you will set up one output file, perform automatic tool assignment, set some N/C Drill format options, and then generate the output file. Choose the **File » Open** command to open **Tutor3.pcb**.

Choose **File » Export » N/C Drill** to open the **File N/C Drill** dialog shown in the following figure:
The *File N/C Drill* dialog gives you the ability to output individual or batch files in these formats: compressed, non-compressed or self-extracting executable. But before you generate output, you are going to establish N/C Drill settings in some of the multiple dialogs available from the *File N/C Drill* dialog, as shown in the following figure.

When you have established all of the options for output files, tool assignments, and other drill settings, the resulting output files will be listed in the Output Files list.

**Setting Up Output Files**

In this section, you will setup an output file. Click **Setup Output Files** to open the following dialog.
The filename for the output file you set up here is determined by the file name extension you assign to the file (e.g., Filename.ncd). Most of the time only one file is used for N/C Drill, so that you have the design filename as the root name, and the extension as .ncd. If you had two files, you could use extensions such as .nc1 and .nc2 (e.g., for designs with blind and buried vias). This is to differentiate it from the regular design file and Gerber files in the same directory (.pcb, .top, .bot, etc.)

1. Click **Set All** to select all the layers in the Layers list.
2. In the File extension box, type: NCD
3. Leave **X offset** and **Y offset** boxes blank.

   If you are using blind and buried vias, you need two or more .ncd files. Select only the layers spanned by your blind or buried vias for each .ncd file

4. Click **Add** to add NCD to the list of Output Files.
5. In the Output path box, type the following: C:\PCAD\TUTORIAL
6. Click **Close** to return to the File N/C Drill dialog.
7. You now have set up an N/C Drill file for output: Tutor3.ncd. Next, you will assign tools.

**Assigning Tools**

In this section, you will make tool assignments. Click **Tools** in the File N/C Drill dialog to open the following Tool Assignments dialog.
Chapter 9: CAM

N/C Drill Output

184 P-CAD PCB User's Guide

All the existing hole diameters in the Tutor3.pcb design file are listed in the Hole column.

**Assigning Tools Automatically**

This section describes how you would assign tools automatically.

1. Click **Auto**. All of the tool assignments will appear in the Tool column, each tool listed next to each hole.

2. Select **Hole 18.0 mil** and click **Unassign**.

**Assigning Tools Manually**

Now you will manually assign a tool (the same one you just unassigned in the previous section).

With the same hole/tool assignment highlighted, click **Assign** to open the following dialog, where you can manually describe and assign tools.
The hole/tool you highlighted on the previous dialog is displayed at the top of this dialog in the Assign Tool to field. The hole and its diameter are displayed in the Hole and Diameter fields.

1. Select the **T01 18.0 mil** tool code in the Tools list.

2. Click Close to complete the assignment and return to the Tool Assignments dialog. The Tool Assignments dialog should now display all of the tool assignments, performed both automatically and manually.

3. Now, click Close to exit the dialog and return to the File N/C Drill dialog.

### Set Format Options

You will now set format options for File N/C Drill.

1. In the File N/C Drill dialog, click **N/C Drill Format** to open the following dialog.
2. In the Output Units frame, choose **Inches**. The units are now in inches and the format is automatically set to 2.4, which is two digits to the left of the decimal point and four digits to the right. If you select Millimeters, the format is automatically set to 4.2, which is four digits to the left of the decimal point and two digits to the right.

3. In the Output Code Type frame, choose **ASCII None**.

4. In the Zero Suppression frame, choose **None**.

5. Click **Close** to save format options settings and return to the **File N/C Drill** dialog.

**Compress Output Files**

In the **N/C Drill** dialog, you have the ability to produce files in a compressed format by selecting the **Compressed (.ZIP)** or **Self-Extracting (.EXE)** check box in the Compress Output Files frame.

Both (.zip) and (.exe) files will compress the selected output files into one smaller file. The (.zip) option produces a smaller file than the (.exe) option but requires an **unzip.exe** program to decompress the file when you need to access it. The compression done in the self-extracting (.exe) option outputs a larger file than is output by the (.zip) option because its uncompress function is included in the compress program.

**Generate N/C Drill Output**

Now you will generate your N/C Drill output files.

1. Choose **File » Export » N/C Drill**. The following **File N/C Drill** dialog appears.
Creating a Drill Symbol Legend

Many service bureaus wish to have a print out of the drill symbols for a board. We allow you to assign your own symbols for each hole on the board, however, a time may arise when you wish to attach a legend to the drill file itself explaining what the different symbols represent. This can be done in the following manner.

1. Choose File » Reports.
2. Generate a Statistics report. This report summarizes important design facts, such as physical dimensions and object quantities.
3. To create a drill symbol table, select an area for the legend.
4. Choose Options » Layers to create a non-signal layer called DRILL.
5. On the DRILL Layer, place the first pad listed on your Statistics report.
   Begin with the smallest hole size and then gradually increase in size, placing one pad after another in a column. Be sure to place pads, which are representative of every unique drill hole size on your board.

2. Click Set All to select all files in the Output Files list.
3. Click Generate Output Files.

The output file is written to Tutor3.ncd. You can open this file with any text editor, such as WordPad or Notepad.
6. Next to each pad, directly to the right, choose the **Place > Text** command to place a label indicating the drill size associated with that pad.

7. To complete the legend, choose **Place > Line** and draw a rectangle around the pads and text just placed.

**Generating Drill Drawing**

When all the pads are placed and labeled you are ready to generate the Drill Drawing using the **File > Print** or **File > Export > Gerber** command.

To generate the drill file, do the following:

1. Click **Setup Print Files** in the **File Print** dialog or click **Setup Output Files** in the **File Gerber Out** dialog.

2. In the **Setup Print Files** or **Setup Output Files** dialog, select all plane and signal layers. Then, select the new **DRILL** layer and close the dialog.

3. Generate the Gerber Output File or Printout.

4. If your design includes blind and buried vias, generate additional drill drawings having only those layers enabled that span the blind and buried vias in the design.

Create a different drill drawing for each set of vias spanning different layers.

When you generate your drill drawing, each pad with a unique hole size is represented by a unique drill symbol. The text indicating the hole size it represents appears to right of each symbol. Accordingly, each of the pads in your drill symbol table are replaced with its appropriate drill symbol, creating an annotated legend.
Introduction to Copper Pours

A copper pour is a polygonal shape that you can place on any layer of a PCB design. To place a copper pour in a design, you use the following two-step process:

- First, place the pour outline. For instructions, see Drawing a Pour Outline (page 387).
- Next, flood the pour outline with a copper fill. For instructions, see Filling a Copper Pour (page 388).

In a PCB design, you can choose various fill patterns, including a hatched, lined, or solid pattern. Typically, the flooded area will backoff from almost any object on the same layer, unless the object and filled area are associated with the same net. Two pours not associated with any net are common; they do not backoff from each other. When one pour is associated with a net and the other pour is not, they are considered different. Therefore, the order in which you select the copper pours is very important.

When a copper pour is placed on a non-signal layer, it is a graphical object only. Typically, you will place copper pours on signal layers, as opposed to non-signal or plane layers. A pour on a non-signal layer, such as the Top Paste layer, adds the copper pour image to the layer’s output, but the layer is not considered for DRC and connectivity.

Because a copper pour has a polygonal shape, you can create rounded-corners for the copper pour. To learn how to create rounded-corners for a polygonal shape, see Polygon Properties (page 315), or Place Polygon (page 383).

Properties

You can modify various properties associated with a copper pour using the Copper Pours Properties dialog. For information on these properties, see Copper Pour Properties (page 317) and Edit Commands (page 279).
Islands

Isolated islands of copper pour are areas of copper separated from the rest of a pour. They result when objects are avoided and when the backoff criteria is set too small. These islands can be minimized by increasing the line width (which inhibits the ability to penetrate small areas), increasing the backoff criteria, or avoiding these areas when defining the copper pour.

For large designs, where manual island detection is slow, break pours into smaller pours to speed up editing.

Otherwise, you can use the Copper Pours Properties dialog to automatically remove islands. You can also manually delete islands. To do this, hold down the **SHIFT** key, select the object and choose **Edit Delete**.

Repour

Moving a filled pour automatically causes a repour. However, if you need to manually repour a copper pour, you can use the repour options in the Copper Pour Properties dialog. To manually repour a copper pour, do the following:

1. Select the copper pour.
2. **Right-click** and choose Properties from the shortcut menu. The Copper Pour Properties dialog appears.
3. In the State frame, choose Repour.
4. Click **OK**.

Pour/Repour Options

When you choose to pour or repour a group of copper pour outlines, you can control the order in which P-CAD PCB pours or repours the copper fill. This is useful when you have a number of unpoured copper pour outlines in a design, or when you want to repour a group of copper pours and control the order. This can be used to ensure that smaller copper pours that lie within larger copper pours are repoured correctly.

To set your pour/repour options, follow these steps:

1. Choose **Options » Configure**. The Options Configure dialog appears.
2. Click the **General** tab, shown in the following figure.
3. In the Pour/Repour Option frame, choose one of the following buttons:

- **Smallest to Largest**: Choose this button to have P-CAD PCB pour the copper fill according to pour size, from smallest to largest. For best results, choose this button when you want to use the block selection method to select a group of copper pours.

- **Select Order**: Choose this button to have P-CAD PCB pour the copper fill according to the order that you selected the copper pour. For best results, choose this button when you want to select a group of copper pours using the **CTRL+click** selection method.

   If you do not choose a button in the Pour/Repour Option frame, the **Smallest to Largest** button is selected by default.

4. Click **OK** to close the **Options Configure** dialog.

---

**Connectivity**

Individual islands of a pour are connectivity aware. This means that connection routing with a pour will work by removing connections between nodes that are connected to the pour, optimization of the net will take copper pour islands into account.
Chapter 10: Copper Pours

Setting Backoff

To specify the distance that you want between the copper pour and any objects that may be inside the copper pour polygon, open the Copper Pour Properties dialog. In the Backoff frame, choose the Fixed button and type a value in the text box. This option also creates a backoff from any objects that are outside the copper pour polygon if they are too close to it. The copper pour backs off from any copper item that is not in the net associated with the pour. The backoff options takes the object’s thickness into account.

To set backoff values for a specific net, choose Options » Design Rules. Backoff clearances are fixed at the greatest of the Line to Line or Line to Pad clearance amount in Options Design Rules dialog.

Thermals

When enabled, copper pour thermal spokes are used to connect copper pour pads and vias of the same net to copper pour islands.

The connectivity of pads and vias to the copper pour can be controlled using the Modify Pad/Via Styles (Complex) dialogs. The Prohibit Copper Pour Connections option in these dialogs, when enabled, prevents connections to the copper pours for selected nodes on specified signal layers.

For more information on using the Modify Pad/Via Styles (Complex) dialogs, see Options Commands (page 423).

Circles

When you create a full circle using a single arc, copper pours do not penetrate the arc. However, if you want to create a circular area and flood it with a backoff inside and out, use multiple arcs to create the circle.

Routing

Autorouting

None of the autorouters supplied with P-CAD PCB recognize copper pours. It unpours them and routes the connections. This can cause changes to the design once the pours are repoured, such as the addition of new islands, which can render the pour ineffective. Thus, it is recommended that pours should be placed last in a design.

Manual and Interactive Routing

You can manually route connections to copper pour islands using the Route Manual or Route Interactive tool. Routed lines and vias that belong to another net cause the pour to auto plow around the new copper.
Auto Plowing

Copper Pours affected by new copper generated by the Route Manual or Route Interactive tool will auto plow when the route Completes or Suspends.

Any new copper (e.g., lines, pads, vias) placed or routed so as to overlap islands of a filled copper pour cause those islands to regenerate so that the backoff rules are not violated.

In the Options Configure dialog, you can enable or disable the Auto Plow Copper Pours option. Plowing can create more islands if you splinter existing islands, yet Automatic Islands Removal is still performed using the settings you established for that copper pour.

Overlapping Pours

Overlapping pours of different net associations present unique problems. The order of pouring determines which pour occupies the area. The order of selection in a single pour request, determines the relative dominance.

For the following examples, assume that the copper pours have been placed, but not associated to a net or poured.

- **Pour A and B overlap**: This example applies to multiple pours with overlapping areas. You have two copper pours, which are overlapping each other. Select the first pour, associate it to a net, and pour it. Now select the second placed pour, associate it to a different net, and pour it. The second pour backs off from the islands of the first pour.

- **Pour A is inside Pour B**: You have two copper pours, one inside the other. Always work from the inside out. Select and pour the inside pour first and then select and pour the outside pour.

- **Pour A is inside Pour B inside Pour C**: You have three copper pours, one inside the other. Always work from the inside out. Select and pour the inside pour first, pour the second, and finally, pour the third.

For information on controlling the repour order, see Pour/Repour Options (page 190).
CHAPTER 11

Interapplication Functions

Introduction to Interapplication Functions

Several sophisticated features are available in PCB, which allow you to more fully integrate various aspects of the design process. These features include:

- Hotlinks
- ECOs
- Interapplication launches
- Custom application access

DDE Hotlinks

With the DDE hotlinks feature, you can cross probe between an P-CAD Schematic and PCB design, to examine the relationships between the designs. To turn this feature on refer to Enabling DDE Hotlinks (page 196).

This feature enables the exchange of hotlink data, which consists of highlighting and unhighlighting commands for parts, components, and nets. For example, when you apply the current highlight color to a net in P-CAD PCB, the current highlight color is also applied to the corresponding net in P-CAD Schematic.

You can also change the highlight color of an object in P-CAD PCB, and the corresponding object in P-CAD Schematic is automatically updated with the highlight color. To set the current highlight color, see Setting the Current Highlight Color (page 196).

When the DDE Hotlinks feature is turned on in both programs, you can cross probe between the following programs at one time:

- P-CAD PCB/Relay and P-CAD Schematic
- P-CAD PCB/Relay and P-CAD Schematic Viewer
• P-CAD PCB Viewer and P-CAD Schematic Viewer
• P-CAD Schematic and P-CAD PCB Viewer.

Once the feature is turned on, you can use several commands to invoke this feature. For details, see Unhighlighting Parts and Components (page 197) and Highlighting Nets (page 196).

Enabling DDE Hotlinks
To turn the DDE hotlinks feature on, follow these steps:
1. Choose Options » Configure. The Options Configure dialog box appears.
2. Select the DDE hotlinks check box.
3. Click OK to close the Options Configure dialog box.

This feature hotlinks data between two P-CAD programs. To operate properly, you must turn on the DDE hotlinks feature in both programs.

Setting the Current Highlight Color
To set the current highlight color for P-CAD PCB, follow these steps:
1. Choose Options » Display. The Options Display dialog appears.
2. Click the Colors tab.
3. In the Display Colors frame, click the Highlight button. A color palette appears.
4. Select a color from the palette and click the Close button.
5. Click OK to close the Options Display dialog.

To change the current highlight color, repeat this procedure. However, notice that the color change does not affect existing highlighted objects, unless a highlighted object is selected.

Highlighting Parts and Components
To apply the current highlight color to an object in your PCB design, choose one of these methods:

• Select an object. Then, choose Edit Highlight or right-click and choose Highlight from the shortcut menu.
• Choose Edit » Components. When the Edit Components dialog appears, select a component from the list and click Highlight.

When you apply the current highlight color to an object, it remains highlighted until you unhighlight that object. For instructions, see Unhighlighting Parts and Components (page 197).

Highlighting Nets
To apply the current highlight color to components and nets attached to a particular part in your PCB design, choose one of these methods:
ECOs Chapter 11: Interapplication Functions

- Choose **Edit » Components**. When the *Edit Components* dialog appears, select one or more components from the list and click **Highlight Attached Nets**. The highlight color is applied to all items in the net, including lines, polygons, arcs, copper pours, pads and vias.

- Choose **Edit Nets**. When the *Edit Nets* dialog appears, select one or more nets from the Nets list and click **Highlight**.

To remove the highlight color from a net, see *Unhighlighting Nets*(page 197).

**Unhighlighting Parts and Components**
To remove the highlight color from a part or component, choose one of the following methods:

- Choose **Edit Unhighlight All** to remove the highlight color from all objects.
- Select an object. Then, choose **Edit Unhighlight** or right-click and choose **Unhighlight**.
- Choose **Edit » Components**. When the *Edit Components* dialog appears, select one or more component from the list and click **Unhighlight**.

**Unhighlighting Nets**
To remove the highlight color from a net choose one of the following methods:

- To remove the highlight color from the components and nets attached to a part, choose **Edit » Components**. When the *Edit Components* dialog appears, select one or more components from the list and click **Unhighlight Attached Nets**.
- To remove the highlight color from a net, choose **Edit Nets**. When the *Edit Nets* dialog appears, select one or more nets from the Nets list and click **Unhighlight**.

**ECOs**
With P-CAD PCB, you have the ability to record Engineering Change Orders (ECOs) that can be used with P-CAD Schematic. You can also import ECOs generated by P-CAD Schematic into P-CAD PCB. In addition, pending ECOs can be viewed while still in memory.

**Types of ECOs**
The following types of ECOs can be recorded:

- RefDes change (Was-Is).
- Net name changes.
- Additions, deletions, and modifications of components.
- Component swaps (Replace).
- Additions and deletions of nets, net classes and class to classes.
- Net class name changes.
Chapter 11: Interapplication Functions

ECOs

- Net additions to and deletions from net classes.
- Additions and deletions of net nodes.
- Additions, deletions, and modifications of attributes (i.e., in nets, net classes, class to classes, etc.)

The format of the ECO file is determined by the setting in the Options Configure dialog. Full Report ECO files have an .eco file name extension, and Was/Is ECO files have a .was file name extension.

**Utils Record ECOs**

Choose **Utils » Record ECOs** to record ECOs. When you choose this command, the following dialog appears:

You can choose the buttons in the ECO Recorder frame to start or stop the ECO recorder. You can also start the ECO recorder by clicking the toolbar button. In either case, when the ECO recorder is started, the toolbar button is indented.

If there are pending ECOs, you are prompted when a design is saved on whether to append the pending ECOs to the current ECO file.

**Utils Import ECOs**

Choose **Utils Import ECOs** to import an ECO file and apply the ECO changes to the current design file. The ECO file is created in P-CAD Schematic to capture schematic changes that impact your design. When you choose this command the following dialog appears:

Selecting an ECO Filename

1. In the **Utils Import ECOs** dialog, click **ECO Filename** to open the following dialog:
2. Type, or select from the list, the name of the file you want to open in the Filename box.
   - .eco files are assumed to be full ECO format
   - .was files are assumed to be Was/IIs format.

3. Click **Open** to return to the **Utils Import ECOs** dialog.

4. To load components with placeholder pattern, select the **Create Pseudo Patterns** check box.
   For more information see **Pseudo Patterns** (page 199).

5. Click **OK** to import the ECOs.

**Previewing ECOs**

After you select an ECO filename in the **Utils Import ECOs** dialog, click **PreView ECOs** to view existing ECOs before you import them. ECOs appear in the Notepad.

**Pseudo Patterns**

You can select the **Create Pseudo Patterns** check box in the **Utils Import ECOs** dialog to load P-CAD Schematic components that don’t have attached patterns.
If a component does not have a pattern and matches a component in the open libraries, P-CAD PCB automatically creates a placeholder pattern.

For each pseudo pattern created, a message appears to let you know which components are affected.

**Utils Export ECOs**

With the *Utils Export ECOs* command you can save ECOs to the ECO file at any time, without saving the design file. If there are pending ECOs, the following dialog appears when you choose *Utils Export ECOs*:

![Utils Export ECOs dialog](image)

**View Pending ECOs**

When you click the *View Pending ECOs* button in the *Utils Export ECOs* dialog, you can view pending (outgoing) ECOs, which are still stored in memory. The pending ECO data are written to a temporary ASCII file and displayed in the Notepad. The format displayed is either full ECO or Was/Is, depending on the setting in the *Options Configure* dialog.

**Save ECOs Now**

1. To save pending ECOs, click the *Save ECOs Now* button. A warning message appears:

   ![Warning dialog](image)

   It is important to remember that if you save ECOs without saving the design, your file and the ECOs may be out of sync. That is, the ECOs might not reflect the current state of the design.

2. To continue, click *Yes*. The warning message closes and the *Save ECOs* dialog appears:
3. The ECO filename appears at the top of the dialog. It is the last used ECO file. To change it, click the **ECO Filename** button and the following dialog appears.

4. Type, or select from the list, the name of the file you want to open in the Filename box. Click **OK** to return to the **Save ECOs** dialog.

5. Full ECO files must have an `.eco` extension, and Was/IWs files must have a `.was` extension.

6. In the Comments box, type any comments that can help document the ECOs.

7. To append ECOs to the ECO file, click **Append ECOs to File**.

8. To discard ECOs, click **Discard ECOs**. Once ECOs are discarded, they cannot be recovered.

---

### Starting Other P-CAD Applications

With P-CAD PCB, you have the ability to gain direct access to other P-CAD design tools, including:

- P-CAD Schematic Editor
- P-CAD Library Executive
If the P-CAD tool that you select is installed on your computer it will automatically start, and become the active program. For PCB-related tools, such as InterPlace/PCS and Signal Integrity, the current PCB is passed to the chosen tool, ready for analysis.

Customizing P-CAD PCB

With P-CAD PCB, you can create shortcuts that give you the ability to gain access to other programs and documents that you frequently use. To do this, you use the *Utils Customize* dialog and create a custom menu command and toolbar button for the program or document.

For complete instructions, see *Utils Customize* (page 537).
CHAPTER 12

File Commands

Introduction to File Commands

File commands allow you to open, close, save, and print designs, output reports and perform CAM output in PCB.

Most of the File commands cannot be undone: once an action is taken, it cannot be reversed using the Undo command.

File New

Choose **File » New** to open a new, untitled design window. When the new window appears, all styles and design parameters return to their default settings.

File Open

Choose **File » Open** to open files. When you open a file, P-CAD PCB displays the file in a new window.

If you attempt to reopen a file that is already open, P-CAD PCB loads another instance of the file in a new window. This is the same as the **Window » New Window** command. For details, see Window New Window (page 563).

When you choose **File » Open**, the Open dialog appears.
Chapter 12: File Commands

The Look In list displays the current folder and a list of files in that folder appears directly underneath. The Filename boxes let you select or enter a design file name, with the file name extension specified in the Files of type list. Notice that the file name extension is .pcb by default. This is the default file name extension for P-CAD binary and Tango PCB ASCII files.

Drag-and-Drop File Load
You can use a simple drag-and-drop operation to open PCB design files (.pcb).

Open a File
To open a file, do the following:

1. Choose File » Open. The Open dialog appears.
2. Type, or select from the list, the name of the file you want to open in the Filename box. If the file you want is not in the current folder, then either type the folder name in front of the document name, or select the correct folder.

Global and local attributes in PCB design files are merged when the files are loaded from versions 3.05 and earlier.

3. Click Open.

Opening a Recently Used File
To open one of the last four files, click the File menu and choose the name of the file you want to open. The most recently opened file will be the one at the top of the list.

Opening an ASCII File
A file filter in the List Files of Type list reads PCB ASCII files. The new file filter is ASCII Files (*.pcb).

Errors and warnings generated while loading an ASCII file are written to a file named Design-name.log, which is automatically displayed using in the Notepad.
If any of the design limits are exceeded, your design cannot be opened using P-CAD PCB (6/400).

File Close

Choose File » Close to close all windows for the active design.

If the file you want to close has any unsaved changes, a message dialog prompts you to save the changes. If you close the last design, it is automatically replaced with a new, untitled design.

File Save

Choose File » Save to save any changes to the design in the active window and create a backup file with the .bak file name extension.

When you choose File » Save, the active file remains open so you can continue working on it, and a backup file is copied. The current file name and location are unchanged by this command. To save the current file to a different name or location, choose File » Save As.

When you enable the recording of Engineering Change Orders (ECOs), they are created in PCB to capture design changes. Pending ECOs are appended to an ECO file or discarded when you save a design file. If there are pending ECOs, the following dialog appears:

1. The ECO filename appears at the top of the dialog by default. To change it, click ECO Filename. The following dialog appears.
2. Type, or select from the list, the name of the ECO file you want to use in the Filename box. Click Save to return to the Save ECOs dialog.
3. In the Comments box, type any comments that can help document the ECOs.
4. To append ECOs to the ECO file, click Append ECOs to File.
5. To discard ECOs, click Discard ECOs. Discarded ECOs cannot be recovered.

For more information on ECOs, see Utils Record ECOs (page 502), Utils Import ECOs (page 503), and Utils Export ECOs (page 505).

Saving an ASCII File

If the current design was opened in PCB from an ASCII file, a PCB ASCII file is generated instead of a PCB binary file.

ASCII File Save uses a temporary file for file generation. The file is named file.pc$, where file is the name you specify in the File Save As dialog or the current design name if you are using the File Save dialog. If you cancel the save process or it is interrupted by an error condition, the temporary file will contain the ASCII contents written up to the point where the process was terminated. A description of the PCB ASCII format can be found in the file ASCII.doc.

Net Classes

Net classes are saved to binary and ASCII design files.

File Save As

Choose File » Save As to save a copy of the active design file to the drive or directory you specify. You can either name a new file or save an existing file under a new name (the original file remaining the same, if there is an original). If you save to an existing file, this command creates a backup file (.bak). You can also use this command to save files in ASCII format.

When you choose File » Save As, the Save As dialog appears. Use this dialog to enter a name for the file and to choose the drive and directory in which to save the file. The Save in box displays the current folder. The area just below shows all files in the current folder with the file name extension specified in the Save File as type list. Notice that your default file name extension is .pcb. Select a file or type a new filename in the File Name list.

Save a File to a Name and Location

To save a file to a different name and location:

1. Choose File » Save As to open the Save As dialog.
2. Type the filename you want to use in the Filename box.

If the current folder is not appropriate, then either type the folder name in front of the document name, or select the folder.
3. Make sure the file name extension is correct by selecting the Save file as type check list.

4. Click Save to save the file as you have specified.

If there are pending ECOs, you are prompted to save them. See File Save (page 205) for detailed instructions.

**Saving an ASCII File**

If ASCII is selected in the Save as type list of the File Save As dialog, an ASCII file is generated instead of a PCB binary file. The output file is a complete design file, and it contains all design data represented in a PCB binary file. A description of the PCB ASCII format can be found in the file ASCII.doc.

ASCII File » Save As uses a temporary file for file generation. The file is named file.pc$, where file is the name you specify in the File Save As dialog or the current design name if you are using the File Save dialog. If you cancel the save process or it is interrupted by an error condition, the temporary file will contain the ASCII contents written up to the point where the process was terminated.

If any of the design limits are exceeded, your design cannot be opened using P-CAD PCB (6/400).

**File Clear**

Choose File » Clear to clear the workspace and reset the title bar. When you choose this command, a message prompts you to save changes to the current file before it is cleared from the workspace.

The File » Clear command does not clear the style or layer definitions setup by Options » Pad Style, Options Layers, etc. for the file that was open at the time the workspace is cleared. This allows you to use template information from that file. The command also does not clear the Aperture list defined by the File » Export » Gerber command, allowing you to load a photoplot file without redefining all of the apertures.

**File Print**

This command prints a copy of the current PCB file, using the printing specifications you have set. When you choose File » Print, the following dialog appears.
This dialog is used to generate individual or batch print jobs according to a variety of specifications. If you already have print jobs set up, you can generate them from this dialog. Additional dialogs for further specifications are accessible from this dialog:

**Print Preview**

To view a print job before you print it, click **Print Preview** in the **File Print** dialog.

When you click **Print Preview**, the specified print output appears on your screen. The Print Preview window offers the following options for viewing the print job output:

- **Print**: Sends the current print jobs to the printer.
- **Next Page**: Displays the next page of the print output in the Print Preview window.
- **Prev Page**: Displays the previous page of the print output in the Print Preview window.
• **Two Page/One Page**: Allows you to view two pages at a time or only one page.

• **Zoom In**: Zooms in on the center area of the current page. Use the scroll bars to move to the desired viewing region.

• **Zoom Out**: Zooms out on the current page.

• **Close**: Closes the Print Preview window.

**Generating Print Jobs**

After you have set up the print jobs, drill symbols, and colors, return to the *File Print* dialog to generate the print jobs. You can do a batch print by highlighting multiple print jobs in the list. You can individually highlight or de-highlight print jobs by clicking them in the list.

When you click **Generate Printouts**, the highlighted print job(s) are processed and printed.

Click **Close** to exit the dialog and save the settings for the *File Print* dialog and related dialogs.

You can use this command to setup and generate custom print jobs.

**Using the Current Window**

When setting up a print job, you may specify a region of your workspace to print. Select the **Use Current Window** check box in the Print Job Overrides frame to override the regional settings specified for the print jobs. The layers and items printed are defined by the highlighted print job; the region is defined by the viewable area on your workspace.

To print a print job with the region defined as the current window, follow these steps:

1. Use the View commands to select the desired window in P-CAD PCB.
2. Choose **File ➤ Print**. The *File Print* dialog appears.
3. In the Override Settings frame, select the **Use Current Window** check box.
4. Select the desired print job and click **Generate Printouts**. P-CAD PCB prints out the print job with the region defined by the current window. The printout may be on one page, or on many pages, depending on the size of the window and the printer settings.

**Scaling to Fit Page**

When printing, you can override the scale settings for all print jobs so that their output fits exactly on a page.

To print scaled print jobs, follow these steps:

1. Choose **File ➤ Print**. The *File Print* dialog appears.
2. In the Override Settings frame, select the **Scale to Fit Page** check box.
3. Select the desired print job(s) in the Print Jobs list. To define a new print job, click **Setup Print Jobs** and follow the instructions in *Setup Print Jobs* (page 210).
4. Click **Generate Printouts**. P-CAD PCB prints out the contents of the selected print job. The print output is scaled to fit exactly on a page.
5. The File » Print Scale to Fit Page overrides the scale settings for all print jobs. To scale an individual print job to fit a single page, select the Scale to Fit Page check box in the Setup Print Jobs dialog.

**Setup Print Jobs**

Click Setup Print Jobs in the File Print dialog to open the Setup Print Jobs dialog shown in the following figure.

In this dialog you can set up multiple print jobs, with each job including specific layers, a printing region, design items, and other print options. You can also modify existing print jobs to include or exclude layers, items, etc.

**Print Jobs**

Any print jobs that have been set up for the active design appear in the Print Jobs list. Each job can have its own particular layers, and other options specified.

After you set up your print jobs, you can select a job and the layers and options associated with that job appear in the Print Job Selections frame. When you close the dialog, any jobs appearing in the Print Jobs list also appear in the File Print dialog.

Below the Print Jobs list are three buttons: Add, Modify, and Delete.

- To add a print job, type a job name in the Print Job Name box, define any print job selections, and click Add.
To modify a print job, select a job from the Print Jobs list, edit the print job selections, and click Modify.

To delete a print job, select a job from the Print Jobs list and click Delete.

The collection of print jobs defined in the dialog are saved to the design file, so you can print them at any time.

**Print Job Selections**

The following controls appear in the Print Jobs Selections frame:

- **Print Job Name**: Shows the name of the job selected in the Print Jobs list. To add a print job, type a job name in this box, define any print job selections, and click Add.

- **Layers**: Shows any layers associated with the job selected in the Print Jobs list. Pads and vias must be enabled separately. For example, to include all items on the top layer in the print output, select Top in the Layers list. When creating output for a specific hole range, you need to select all the layers on which a pad and via’s hole has been defined.

- **Set All**: Click this button to select all of the layers in the Layers list.

- **Clear All**: Click this button to cancel the selection of all layers in the Layers list.

- **Apply Layer Set**: Click this button to apply a layer set to a print job.

- **Layer Sets**: Below the Apply Layer Set button is a drop-down list. You select a layer set from this list. To do this, follow these steps:
  1. Select a layer set from the drop-down list.
  2. Click Apply Layer Set. The layers in that set are selected in the Layers box.

To create a layer set, choose Options » Layers. For instructions, see Adding or Modifying a Layer Set (page 455).

**Print Adjustments frame**

The Print Adjustments frame contains the following controls:

- **Scale to Fit Page**: Select this check box to scale the print job to fit on a single page. When selected the Scale, X offset, and Y offset boxes are shaded. Clear this check box to define the Scale, X offset, and Y offset.

- **Scale**: Enter a value in this box to increase or decrease the size of the print job by a specific factor. The value you enter affects the X axis and Y axis equally. For example, 0.100 reduces the output by a factor of 10, while 10.00 enlarges the output by a factor of 10.

- **X and Y Offset**: Enter a value in each box to offset your printout horizontally or vertically by the value you specify. Minus values go left and/or down; plus values go right and/or up. Default units are the values settings in Options Configure. You can override the default units by entering the units with the value (e.g., mil, mm, in).

**Print Region frame**
The Print Region frame contains the following controls:

- **Design Extents**: Select this check box to print the entire design for the current print job. When selected, the other controls in this frame are shaded. Clear this check box to define a region.

- **Define Region**: Click this button to define a specific area of your design to print. This button is active only when the Design Extents check box is clear.

- **Lower Left Corner** and **Upper Right Corner**: These boxes contain the X and Y coordinates of the selected print region. The Lower Left Corner and Upper Right Corner boxes are disabled when the Entire Design check box is selected.

**To define a print region:**

1. Clear the **Design Extents** check box in the **Setup Print Jobs** dialog. Then, click the **Define Region** button. The dialogs close, uncovering the workspace.
2. Hold down the left mouse button to define the first corner of the print region rectangle.
3. Drag the cursor to define the rectangle. The coordinates of the rectangle are displayed in the Status Line. The View commands are available to help you navigate the design and define the region precisely.
4. Release the mouse button to fix the rectangle’s size and location. You may return to step 2 if you wish to edit the rectangle.
5. **Right-click** or press **ESC** key to commit the rectangle.
6. You are prompted to confirm the updated coordinates. Click **Yes**. The **Setup Print Jobs** dialog appears.

The coordinates of the selected print region can be viewed or modified in the Print Region box in the **Setup Print Jobs** dialog.

**Display Options frame**

The Display Options frame contains the following check boxes. Select a check box to enable the display of an item. Clear the check box to disable the display of an item:

- **Rotate**: Select this check box to rotate the printed image clockwise by 90 degrees. If the Mirror check box is selected with this option, the image mirrors before it rotates.

- **Mirror**: Select this check box to print a mirror image of the design’s typical view. Generally, each layer is displayed as seen from the Top layer. Selecting the mirror option would print the board as it appears from the Bottom layer (as if you flipped the board over horizontally and looked at it with the Bottom layer facing up).

- **Draft**: Select this check box to allow an outline rough draft to be printed (normally speeding up the print job). This would be a printout of only the outlines for pads, vias, polygons, copper pours, etc.

- **Thin Line Stroked Text**: Select this check box to display text objects in a thin line form.
• **RefDes, Type, Value, Pads, Vias, Pad/Via Holes, Pick and Place, Glue Dot, Test Point, Keepout, Cutouts, Connections, and Titles**: Select a check box to include an item in the printout. Clear a check box to exclude an item from the printout.

• **No Mt Hole Cut**: Select this check box to exclude mounting hole copper from the printout. Clear this check box to include mounting hold copper in the printout.

**Drill Symbols frame**

The Drill Symbols frame contains the following controls:

• **Drill Symbols**: Select this check box to print drill symbols. When selected, the other controls in this frame become available.

• **Size**: Enter a value in this box to adjust the size of the drill symbol (usually for size reduction), which represents the drill hole location. For example, you would reduce the drill symbol size so that the drill symbols will not overlap in the printout if they are located close to one another.

• **Plated Holes, Non-plated Holes or All Holes**: Choose one of these buttons to select the type of holes to print.

After you have set up your print job, click **Close** to return to the **File Print** dialog.

**Drill Symbols**

To define drill symbols in your printer output, click the **Drill Symbols** button in the **File Print** dialog. The **Drill Symbol Assignments** dialog appears.

To generate a drill symbol drawing, you must enable all signal and power/ground layers on which the pad is defined. Enabling **Drill Symbols** excludes all copper from this print job and sends just the assigned symbol in its place.

![Drill Symbol Assignments](image)
Chapter 12: File Commands

The purpose of this dialog is to list all of the currently used hole diameters in the design, along with their plating characteristics and corresponding drill symbols. Holes of equal size with different plating characteristics appear as separate entries in the list. An asterisk next to a drill symbol indicates that it is already assigned to a hole diameter.

To attach a drill symbol to a hole diameter, highlight both of them and then click Assign. You can clear the assignment in the same way by clicking Unassign.

If you click Automatic Assign, the drill symbol and hole diameter lists will automatically match up from top to bottom, the first hole diameter assigned to the first drill symbol, the second symbol to the second diameter, etc. Unassign All clears all of the drill symbol assignments.

Click Close to save all of the assignments and return to the File Print dialog.

Colors and Other Print Options

You can define colored, grayscale, or monochrome printer settings. You can also set the size of various points that appear in a design. To set up print colors and other options, follow these steps from the File Print dialog:

1. Click the Colors button. This opens the Printer Options dialog shown in the following figure.

   ![Printer Options Dialog](image)

   The Printer Options dialog is similar to the Options Display dialog. However, changes to your printer options do not affect your options display settings. For more information about the Colors or Miscellaneous tab, see Options Display (page 442).
2. Click the **Colors** tab, then choose print colors using one of these methods:
   - If you have a color printer, click the appropriate buttons and choose a color from the color palette that appears.
   - If you have a black and white printer, click the **Defaults** button. This turns all colors to monochrome. We recommend that you use the default settings to avoid undesirable output when color settings are converted to grayscales.

3. Click **OK** to close the **Print Options** dialog. You return to the **File Print** dialog.

**File Print Setup**

Displays a list of installed printers and allows you to set the current printer. You can also change device-specific parameters. When you choose **File » Print Setup**, the following dialog appears.

Select a printer from the Name list and click **Properties** to configure print parameters. Because print parameters are device-specific, the dialog, which appears, is different depending upon the printer you selected.

To select a printer, select the printer from the Printers list. Then, click **OK** to close the dialog.

**File Reports**

Choose **File » Reports** to generate reports with specific output options.

You can customize the standard reports and save the new report to a file that can be reused. The format you select in the Style Format frame determines the options available for each of these styles:

- **Separated-List**
- **P-CAD Report**
With the P-CAD Report style, in addition to setting Lines per Page and Report Destination, you may select the page format and define the Header and Footer. The Customize feature gives you the ability to choose which fields are displayed in the report, their sort order and other format options. These options are saved when you quit the program.

The File Reports dialog appears as follows:

![File Reports dialog](image)

**Filename**

The Filename button gives you the ability to gain access to files other than the current design through a standard open file dialog. The Filename is the same as that of the current design by default, it is also saved to the location where saved reports are stored.

**Reports to Generate**

You may select the reports you wish to generate from the list of report types in the Reports to Generate list. The Reports to Generate box lists all the predefined reports along with any customized reports stored with the design. Each report has a unique file name extension, which is displayed alongside the report. These file name extensions cannot be changed.

The available reports are as follows:

- **Aperture Information**: Lists aperture information such as units used, definitions (D code, type, etc.), and aperture assignments.
- **Attributes**: Contains component and net attributes.
- **Bill of Materials**: Lists the component attributes you have selected for inclusion in the report. Any attribute present in the design can be chosen to appear in the report.
If you have special components that have hidden reference designators (RefDes) and you want to exclude them from the Bill of Materials, you can explode the component (Edit Explode Component) and delete the RefDes, or just delete the component from the report.

- **Component Locations**: Lists, for each component, the reference designator and location (the X and Y coordinates). Fixed components are also identified. If you have special components in the design, see the note with the BOM report option above.

- **DRC Error Indicators**: Generates a list of all the DRC error indicators, locations and text on the board. This allows you to generate a hardcopy for all the DRC error indicators generated by Online DRC.

- **Glue Dot Locations**: Lists the layer and position of all glue dots in the current design.

- **Library Contents**: Lists all of the components that are contained in all of the currently open libraries. See **Library Setup (page 493)** for information on opening libraries.

- **Pick and Place Locations**: Lists the layer and position of all pick and place points in the current design.

- **Rooms**: Lists the properties of the rooms such as Name, Placement Side, Rules and Included Components along with their value. Another section lists the components in the design and the room in which each component resides.

- **Statistics**: Contains a variety of information about the current design, such as primitives count, board dimension, line widths used, layer types used, etc.

- **Test Point**: Shows the X,Y coordinates of the test points in the current design, the net name to which points are attached, the side of the board the point is tested from, and whether or not the point is a fixed object.

**Report Destination Frame**
In the Report Destination frame, choose one of the following options:

- Choose **Screen** to save the report file and automatically display it in the Notepad.
- Choose **File** to send the report output to a file.
- Choose **Printer** to send the report output to the printer. This option does not create a report file.

**Report Origin Frame**
The X and Y coordinates of the default report origin are 0,0, which represents the lower left corner of the design. If you want to offset the report origin, enter the desired X and Y coordinates in the appropriate boxes. Coordinates printed in the report output indicate their position relative to the designated coordinates.

Report origins are printed in the first line of the output report in the standard P-CAD Report format.
Style Format Frame

Choose one of the following buttons in the Style Format frame.

- **Separated List**: Choose this option to place all data in character-separated format. You can import this format into other spreadsheet and database programs.
- **P-CAD Report**: Choose this option to produce a report format with columns and spaces, etc.

If you choose *Separated List*, type the character you want to use as the separator or choose one from the List Separator list. The character that appears in this list by default is the list separator defined in your Regional Settings for Microsoft Windows.

File Reports Buttons

The buttons below the Reports to Generate list control report settings, provide access to the *Customize Report* dialog, and give you the ability to generate reports.

The buttons perform the following functions:

- **Delete**: Removes a customized report from the design. You cannot delete the predefined reports described in *Reports to Generate* (page 216).
- **Customize**: Opens the *Customize Report* dialog where you can set many options to adapt a report and save it for future use. See *Custom Report Option* (page 218) for more information.
- **Set Defaults**: Returns all settings to the PCB reports default values.
- **Set All**: Selects all the reports in the list.
- **Clear All**: Cancels the selection of any selected reports in the list.
- **Generate**: Creates the selected reports using the options.

Custom Report Option

When you click *Customize* in the *File Reports* dialog, the following *Customize Report* dialog appears with the *Format* tab selected:
Format Tab

The Format tab contains the following options:

- **Header**: Type a heading for the report. This option is only available with the P-CAD Report format.
- **Footer**: Type a footer for the report. This option is only available with the P-CAD Report format.
- **Page Format**: The check boxes in the Page Format frame apply to reports whose Style Format is the P-CAD Report. Select the desired check boxes from the following:
  - **Use Header**: Select this check box to include the information you specified in the Header box.
  - **Use Footer**: Select this check box to include the footer information entered in the Footer box.
  - **Design Info**: Select this check box to include the information you entered in the File Design Info dialog.
  - **Date/Page**: Select this check box to include the current date and the page number.
  - **Pagination**: Select this check box to create your own pagination (lines per page).
  - **Lines per Page**: Enter the number of lines you want printed on each page.
  - **Attribute Column Width**: Defines the number of characters, up to 2000, used to display an attribute.
  - **File Extension**: The File Extension box displays the default file name extension for the selected report. You can also enter a new file name extension if desired.
Selection Tab

The Selection tab in the Customize Report dialog lists the report fields and gives you the ability to choose which fields appear in the report. With this tab, you can also define selection criteria, as shown in the following figure:

The columns in the Selection spreadsheet are as follows:

- **Field**: The list of fields specific to the selected report.
- **Show**: Select the Show check box to display the corresponding fields in the report. Cleared check boxes do not appear in the report output.
- **Criteria (And)**: Contains the selection criteria used to filter the report data.
- **Or**: Additional selection criteria can be entered here, if necessary.

Operators available for use in the Criteria (And) and Or columns are shown in the table below:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Exactly equal to.</td>
</tr>
<tr>
<td></td>
<td>If used with a wildcard operator, * or ?, this operator becomes literal. It searches for a set of characters with, for example, a question mark at the end.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to.</td>
</tr>
</tbody>
</table>
### Operator Function

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to.</td>
</tr>
<tr>
<td>IsLike</td>
<td>If used with a wildcard operator, IsLike means is similar to. For example, IsLike 5* could be 50, 510, 5, etc. If not used with a wildcard operator, IsLike is equivalent to =.</td>
</tr>
<tr>
<td>IsNotLike</td>
<td>If used with a wildcard operator, IsNotLike means is not similar to. For example, IsNotLike 5* could be 14 or 20 or 42, but not 50, 510 or 5. If not used with a wildcard operator, IsNotLike is equivalent to &lt;&gt;.</td>
</tr>
<tr>
<td>Exist</td>
<td>The attribute exists.</td>
</tr>
<tr>
<td>NotExist</td>
<td>The attribute does not exist.</td>
</tr>
<tr>
<td>AnyValue</td>
<td>The attribute exists and it has some value.</td>
</tr>
<tr>
<td>NoValue</td>
<td>The attributes exists, but it is assigned no value.</td>
</tr>
</tbody>
</table>

The columns in the spreadsheet can be resized by moving the column separation lines right or left. You can append another or column with the Add Column button. To reposition fields in the list, click Up or Down, which determines the order in which they are output to the report.

The system generates the value in the Count field when the report is produced. Selection criteria cannot be applied to the Count field.

If you have installed P-CAD Library Executive, the File Reports Selection utility allows you to add attributes from a non-P-CAD source, if desired, using the Import Files button. See your P-CAD Library Executive User's Guide for details on this feature.

### Sort Tab

The Sort tab provides you with the ability to select the field(s) used to sort the report output and choose a sort order. The Sort tab appears as follows:
The **Sort** tab contains the following options:

- **Available Fields:** The list of fields in the selected report.

- **Selected Fields:** The fields used to sort the data, the order in which the sort is applied and the field’s sorting order (A) for Ascending or (D) for Descending, are displayed in the Selected Fields list.

  The Insert button takes a selected field from the Available Fields list and inserts it above the selected field in the Selected Fields list. The **Append** button moves the field to the bottom of the Selected Fields list. To move fields from the Selected Fields list back to the Available Fields list, select the field and click the **Remove** button.

- **Sorting Order:** The Sorting Order is set by clicking the desired option button to sort in Ascending or Descending order before moving a field to the Selected Fields list.

### Adding a Custom Report

Once you have selected your report options, click **Add** to open the following **Report Configuration** dialog:
Type a name for the report in the Enter Report Name box and click **OK**. You are returned to the *File Reports* dialog where the new report is listed in the Reports to Generate list. You can select the reports and generate output by clicking **Generate**.

If you select and generate both the custom report and the one on which it was based, both results are output in a single file or report. To get individual outputs, generate each report separately.

### File Design Info

Choose **File » Design Info** to enter design information, review design statistics, and to query or modify design attributes and fields. You can also group fields into distinct field sets and incorporate design and revision notes into your design. When you choose this command, the *Design Info* dialog appears with the General tab selected:

![Design Info Dialog](image)

The fields placed in your design using the **Place » Field** command use the information entered in this dialog.

For example, suppose you placed a Title field in your design. If you changed the value of the Title field on the Fields page of this dialog to *design02*, then the Title field in your design would be updated to display *design02*. If you had numerous Titles placed in your design, they would all be changed to reflect what you enter here. See *Place Field* (page 398) for information on placing fields.

The information that you specify with this command is saved with and restored from the design file.
The following sections describe the tabs in the File Design Info dialog.

**General Tab**

The General tab in the File Design Info dialog contains information about the design file, including its location, size, and creation date.

Many of these fields appear in the Place Field dialog and may be placed in the design. Their values are automatically assigned based on the file information displayed on the General tab. These system generated fields include: Design Name, Location of Design, Size, and Last Modified Date.

**Fields Tab**

The Fields tab in the File Design Info dialog includes all the predefined and user-defined fields contained within the design. All fields listed in this dialog may be placed by choosing Place » Field.

When a field value is modified in this dialog, all fields of that type in the design are automatically updated to reflect the new value.

Predefined field types include: Approved By, Author, Checked By, Company Name, Current Date, Current Time, Date, Drawing #, Drawn By, Engineer, Filename, GUID, Layer Name, Modified Date, Revision, Time and Title.
You can also create custom, user-defined fields to contain design data of your choice and group fields into Field Sets. The Fields tab contains the following options:

- **Name**: This list displays the non-system generated, predefined fields and their values. If there are any user-defined fields, their names and values are displayed here also.

- **Value**: The Value assigned to the field. For instance, the Value of the field Author may be John Doe. If the Value of a field is blank and you place that field in your design, the Name of the field, instead of its value, is displayed at the field location.

To add a new field and its value:

1. Click Add.
2. Click Properties to modify only the Value of an existing field. When adding a new field, the Field Properties dialog appears, as shown in the following figure:

![Field Properties dialog](image)

3. To modify the Location, Text Style or Justification of a field that has been placed in the current design, select the field in the design. **Right-click** and choose **Properties** from the shortcut menu.

The Field Properties dialog contains the following options:

- **Name**: Enter the name of a new field. The name of an existing field is displayed here.
- **Value**: The Value assigned to the field.
- **Text Style**: The Text Style in which the Value of the field is displayed.
- **Location**: The current X and Y coordinates of the field’s location in the design.
- **Justification**: Displays the current chosen justification of the field’s value within its boundaries.
- **Flip**: A check indicates that the field has been flipped.
- **Rotation**: When the field has been rotated the rotation degree is displayed here.

4. To remove a user-defined field, select the field in the Field Set list and click **Delete**.

To add or delete field sets:
1. Click **Field Sets** in the Fields, Notes or Revisions tabs to open the *Field Sets* dialog as shown in the following figure:

![Field Sets dialog](image)

2. Add a new field set by typing a name in the Field Set Name box and clicking Add.

3. Delete a field set by selecting the field set name in the Field Set list and clicking Delete. When a field set is removed, all layers referencing the removed field set are reassigned to the default field set. The default field set cannot be deleted. The field values contained within the removed field set are deleted.

**Attributes Tab**

The **Attributes** tab in the *File Design Info* dialog gives you the ability to view and modify design-level attributes:

![Attributes tab](image)

These are attributes that are attached to a particular design, rather than a component or net.
You can view, add, modify, or delete a collection of design attributes. The dialog contains a two-column table showing the collection of design attributes. Within a collection, each attribute’s name and value appear in the column.

- **Adding an Attribute**: To add an attribute, click the **Add** button to open the *Place Attribute* dialog. Enter and name and value for the attribute and set the attribute properties. Click **OK**, and the attribute is added to the table.

- **Viewing or Changing Attribute Properties**: To view or change an attribute’s properties, select an attribute from the table and click **Properties** (or double-click the attribute) to open the *Attribute Properties* dialog.

- **To Delete an Attribute**: Select an attribute in the table and click **Delete**, or press **DELETE**.

- **Launching a Reference Link**: When the special attribute Reference, whose value is a reference link, is added to the component, you can select the Reference attribute and click **Launch** to start a program that displays a document, or to launch the Internet Explorer and go to a specific web site.

For details about this function and a complete listing of attributes, see *Place Attribute* (page 396).

**Notes Tab**

In the **Notes** tab you can specify design or drawing notes, which can later be included in your design by placing a Note field or a Notes table. These notes can be annotated using the industry-standard symbols: box, circle, triangle or none. The Notes tab appears as shown in the following figure:
The options available on the Notes tab are:

- **Field Set**: To modify a particular field set’s contents, select the field set name from the **Field Set** list. The notes for that field set can be modified directly by editing the entries in the dialog. Field sets can be added or deleted by clicking the **Field Sets** button.

- **Number of Notes**: The total number of notes.

- **Note Text**: Enter or modify notes text in the Notes box.

- **Annotation**: Select the **Annotation** type for the note number: box, circle, triangle or none.

- **Add**: Click **Add** to begin entering notes or to add a note to the end of the list.

- **Delete**: To remove a note, place the cursor in the note text and click **Delete**.

- **Import/Export**: To import a note from an ASCII text file, click **Import**. To export a note to an ASCII text file, click **Export**.

### Revisions Tab

The **Revisions** tab is identical to the Notes tab, except that the **Annotation** options and the ability to Import/Export from an ASCII file are not present. Revision notes are used specifically to document changes between drafts of a design. See **Notes Tab** (page 227) for information on the options available on the Revisions tab.

### Statistics Tab

The **Statistics** tab in the **File Design Info** dialog displays the design statistics, as shown in the following figure:
A File ➤ Design Technology Parameters file (*.dtp) stores design data, such as pad styles, via styles, net classes, layer sets, and design rules. You can use this file as a template for other P-CAD designs.

A .dtp file is organized in a hierarchy. The file is divided into technology groups. These groups can contain different, but related, types of design data and can be placed into a design. A technology group consists of one or more pre-defined sections; these sections contain sets of items of the same type. Each item possesses properties, which correspond to specific design data.

A design technology parameters file is like a storage box. You can reorganize it, add or remove items, alter some of its contents, and use what is stored inside. For a project or series of projects, you may have several items that you will have to use repeatedly for creating PCB designs. The design technology parameters file is a perfect storage box for the following design items: class-to-class rules, global rules, layer sets, net class definitions, net class and net class layer rules, net and net layer rules, pad styles, and via styles.

First you must build your storage box, and organize it so that you can find items when you need them. The starting point is the Design Technology Parameters dialog described below. From there you can build, browse, and modify the contents of the DTP file.
Creating or Opening a Design Technology Parameters File

1. Choose File » Design Technology Parameters from the menus.
2. If you have never used a DTP file before the Open dialog will appear, where you can browse and locate an existing DTP file. If you wish to create a new DTP file type in a Filename then click Open.
3. If you have previously used a DTP file this file will automatically be reopened. To select a different DTP file, or to create a new file, click the Technology Filename button. When the Open dialog appears browse to locate an existing file, or type in a Filename if you wish to create a new one.
4. When the correct DTP file is open you ready to work on the design technology parameters in the Design Technology Parameters dialog.
5. When you create a new DTF file it will be empty. The first thing you need to do is to create a new Group. To do this click on the icon for the DTP filename at the top of the hierarchy, then click the New Group button (this button is only available when you click on the DTP filename icon). The Group is where the various sections of the DTP file are stored, each section corresponds to a different technology parameter. The supported sections include:
   - Apertures
   - Class to Class Rules
   - Design Rules
   - Global Rules
   - Layers
   - Layer Sets
   - Net Class Definitions
   - Net Class Rules
   - Net Rules
   - Pad Styles
   - Via Styles

Design Technology Parameters Dialog

When you choose File » Design Technology Parameters, the following Design Technology Parameters dialog appears:
Notice that information is arranged in a tree structure, similar to the arrangement of folders and files.

From this dialog you can set up the design technology parameter, copy design technology parameter data to or from a design, view or modify data properties, and browse or modify the file’s hierarchy. The options in this dialog are described in the following sections.

**Technology Filename Button**

In the Design Technology Parameters dialog, click Technology Filename to open the Open dialog. With this dialog, you can choose the folder and file name of the file you want to open or create.

- To open a design technology parameters file, select the folder and file name of the file you wish to open. Click Open.

- To create a design technology parameters file, select the folder in which you want to create the file. Type the filename in the Filename box. Click Open. You are asked to confirm your new design technology parameters file creation.

**Read-only Files**

If a .dtp file is read-only, the Read-only check box just below the Technology Filename button is selected and the term “read-only” appears next to the filename. You can make a .dtp file read-only by selecting this check box.

If a .dtp file is read-only, you cannot update it with data from a design, modify an item’s properties, rename an item, or delete an item.
The Design Technology Parameters Tree

The contents of the open parameters file appear as a tree structure, or hierarchy, in the *File Design Technology Parameters* dialog. You can browse the tree to view its contents. Also, you can highlight groups, sections, or items in the tree to select them for copying to a design, editing properties, and completing other functions described in this section.

The tree structure allows you to view your entire file at various levels of detail by expanding or collapsing the branches of the tree.

Groupings containing collapsed levels are shown with a + sign. To expand the grouping, click the +. Expanded groupings are shown with a – sign. To collapse the grouping, click the – sign.

- When you open a new design technology file, only the filename appears in the tree.

**Update From Design Button**

Click **Update From Design** to add information from your current design to the design technology parameters file.

To add design data to your design technology parameters file, select a group, section, or item. If you select a group or section, all items contained below it in the hierarchy are selected. Click **Update From Design**.

- If you select a group, the *Select Section Type* dialog appears. Select the sections you want to update. See *New Section Button* (page 240) for more details.

- If a selected item exists in the parameters file, you are asked to confirm its replacement by clicking the appropriate button: **Yes To All**, **Yes**, **No** or **Cancel**.

- If the selected item does not exist in the parameters file, it is added automatically.

**Copy To Design Button**

Click **Copy to Design** to modify your current design using data contained within your design technology parameters file.
To modify your design using data in the design technology parameters file, select a group, section, or item. If you select a group or section, all items contained below it in the hierarchy are selected. Click Copy to Design.

- If a selected item exists in the design, you are asked to confirm its replacement by clicking the appropriate button: Yes To All, Yes, No or Cancel.
- With three exceptions, if the selected item does not exist in the design, it is added automatically. Net rule, net class definition, and global layer rule items are not created if they do not exist in a design.

When you click Copy to Design, the design changes that occur depend on the type of item selected. For class-to-class rule, net class rule, and net rule items, you can choose to replace or merge the rules in the design with those of your design technology parameters file. Make this selection by choosing the Merge Attributes or Replace Design Attributes option button in the Design Technology Parameters dialog before clicking Copy to Design.

The following sections describe options for each item type, and the design data changes that occur when that item is added to a design.

Class-To-Class Rule Item
If both net classes exist in the design, you have a choice of three options: to create, to merge, or to replace class-to-class rules. A class-to-class rule is created if it does not already exist. To choose between the merge or replace options, enable the corresponding option button in the Design Technology Parameters dialog before clicking Copy to Design.

- Replace Design Attributes: Replaces a design’s class-to-class rules with the rules from the Class-To-Class Rule Item.
- Merge Attributes: Merges the rules of the Class-To-Class Rule Item with the design’s class-to-class rules, favoring the Class-To-Class Rule Item rules over the design.

If both net classes do not exist in the design, a class-to-class rule is not created.

Global Layer Rule Item
If a global layer rule item of the same name exists in the design, its layer rules are replaced with the layer rules defined by this Item.

If a global layer rule item of the same name does not exist in the design, it is not created.

Layer Set Item
If a layer set of the same name exists in the design, then its layers are replaced with the layer members defined by this Item.

If a layer set of the same name does not exist in the design, then a layer set with the layer names defined by this item is created in the design.

Net Class Definition Item
If a net class of the same name exists in the design, its net members are replaced with the net members defined by this Item. The net class and net class layer rules are not changed.
If a net class of the same name does not exist in the design, it is not created.

**Net Class Rule Item**
If the net class already exists in the design, you have a choice of two options: to merge or to replace the net class and net class layer rules. To choose between the merge or replace options, enable the corresponding option button in the Design Technology Parameters dialog before clicking **Copy to Design**.

- **Replace Design Attributes**: Replaces a design’s net class rules with the rules from the Net Class Rule Item.
- **Merge Attributes**: Merges the rules of the Net Class Rule Item with the design’s net class rules, favoring the Net Class Rule Item rules over the design.

The net class, with the Net Class Rule Item rules, is created if it does not already exist in the design.

**Net Rule Item**
If the net already exists in the design, you have a choice of two options: to merge or to replace the net and net layer rules. To choose between the merge or replace options, enable the corresponding option button in the Design Technology Parameters dialog before clicking **Copy to Design**.

- **Replace Design Attributes**: Replaces a design’s net rules with the rules from the Net Rule Item.
- **Merge Attributes**: Merges the rules of the Net Rule Item with the design’s net rules, favoring the Net Rule Item rules over the design.

If the net does not already exist in the design, the net, with its Net Rule Item rules, is not created.

**Pad Style Item**
Design technology parameters file pad style(s) are added to the design. A pad style of the same name is replaced.

> Replacing pad styles can change physical connections in your design file. Choose **Utils » DRC** to locate unconnected pins and shorts after copying a pad style to your design.

**Via Style Item**
Design technology parameters file via style(s) are added to the design. A via style of the same name is replaced.

> Replacing via styles can change physical connections in your design file. Choose **Utils » DRC** to locate unconnected pins and shorts after copying a via style to your design.

**Properties Button**
Click the **Properties** button to view and modify an item’s properties. When you highlight an item in the design technology parameters file tree and click **Properties**, an item-specific dialog appears.

When you modify properties of items in your parameters file using Properties, the changes are made immediately to the file. If you want to create a new design technology file based on an
existing file, first make a copy of your original design technology file, saving the copy under the new name. Then, modify the design technology file copy.

If the design technology parameters file is read-only, any changes you make to an item are discarded.

The properties available to view or modify for each item are discussed in the following sections.

**Class-to-Class, Net Class, NetClass Layer and Net Rules Properties**

To open the DTP Item Properties dialog, select a class-to-class, net class, net class layer or net rule item. Then, click **Properties**. The DTP Item Properties dialog appears, as shown in the following example for a NetClass:

The dialog contains two lists, depending on the selected item; one for the Item Rules and another for the Item Layer Rules. Within the lists, each attribute's name and value appear in the column.

To add, modify or delete an Item Rule, click **Edit** to open the Attributes dialog shown in the following figure:
The Attributes dialog contains a two-column table showing the collection of attributes. Within the collection, each attribute’s name and value appear in the column.

- **Adding an Attribute**: To add an attribute, click the Add button to open the Place Attribute dialog (shown below). Select an attribute category and name, or if the attribute is user-defined enter an attribute name. Give the attribute a value and click OK to add it to the table.

- **Editing Attribute Properties**: To edit an attribute’s properties, select an attribute from the table and click the Properties button (or double-click the attribute) to open the Place Attribute dialog.

- **Deleting an Attribute**: Select an attribute in the table and click Delete.

- **Launching a Reference Link**: When the special attribute Reference, whose value is a reference link, is added to the item, you can select the Reference attribute and click Launch to start a program or to launch Internet Explorer and go directly to a web site.

The Attribute dialog appears as shown in the following figure:
For complete information on the Attribute dialog, see Attribute Properties (page 328).

To add, modify or delete an item layer rule, click **Edit** to open the Edit Item Layer Rules dialog, as shown in the figure below:

The **Edit Item Layer Attributes** dialog lists the Layers and indicates whether the layer Has Attributes with an asterisk. You can select layers having a specific attribute by clicking the Select by Attribute button to display the Set By Attribute dialog. See Set By Attribute (page 349). You can also modify layer attributes by clicking the **Edit Layer Attributes** button. See Edit Attributes (page 350).

**Global Layer Rules Properties**
A Global Rules section can contain layer rule items. To open the Layer Clearance dialog, select a layer rule item and click Properties. The following dialog appears:

![Layer Clearance Dialog]

The clearance values of the layer rule you selected appear in the Pad to Pad, Pad to Line, Line to Line, Pad to Via, Line to Via, and Via to Via boxes.

**Layer Set Properties**

When a layer set item is selected, and you click the Properties button, the Layer Sets Definition dialog appears:

![Layer Sets Definition Dialog]

Layers sets let you group layers to control the selection, display, printing, Gerber output, N/C Drill output, and DXF output. For details, see Options Commands (page 423).

1. Type a layer name in the Layer Name box.
2. Click Add.

3. Repeat the process until you have added all layers to the layer set.

**Net Class Definition Properties**

When a net class definition item is highlighted and the **Properties** button is selected, the **Net Class Definition** dialog appears:

This dialog allows you to create net classes and add nets to the class. For details, see Options Commands (page 423).

To add a net class definition, follow these steps:

1. Type a layer name in the Net Name box.
2. Click Add.
3. Repeat the process until you have added all nets to the class.

**Pad Style Properties**

When a pad style item is highlighted and the **Properties** button is selected, the **Modify Pad Style (Complex)** dialog appears:
From here you can modify the shape, dimensions, hole diameter and other properties of the selected pad style. For details, see Options Pad Style (page 472).

Via Style Properties
Via styles are almost identical to pad styles in the way that you add, edit, modify, view, delete and rename them.

When a via style item is highlighted and the Properties button is selected, the Modify Via Style (Complex) dialog appears. For details, see Options Via Style (page 482).

New Group Button
When you highlight the filename in the tree, the New Group button allows you to create a new group in your design technology parameters file. When you click New Group, the following dialog appears:

Type a name for the group in the New Name box. Then, click OK.

New Section Button
When you highlight a group name in the File Design Technology Parameters tree, the New Section button gives you the ability to create a new section within the selected group.

To create a section, do the following:
1. Click New Section in the DTP dialog. The New Section Type dialog appears:
2. In the Section Type frame, select the section type check boxes that you want to add to the group. Once you’ve added a section, it is shaded out in the dialog. Available sections are listed below:

- Class-to-Class Rules
- Global Rules
- Layer Sets
- Net Class Definitions
- Net Class Rules
- Net Rules
- Pad Styles
- Via Styles

3. Click OK.

The selected section or sections are automatically named and added to the group.

**New Item Button**

When you select a section name in the File Design Technology Parameters tree, the New Item button allows you to create a new item in your design technology parameters file. When you click New Item, an item-specific dialog appears similar to the Enter Net Class Name dialog shown in the following figure:
Type the desired item name in the New Name box. Click OK. This item name should either match an item name found in your design, or be the name of a new item you are creating.

**Rename Button**
Click the Rename button in the Design Technology Parameters dialog to rename a group or item. Sections cannot be renamed.

To rename a group or item, follow these steps:
1. Select the group or item.
2. Click Rename and a dialog appears similar to the Rename Net Class dialog shown in the following figure:

3. Type a name in the New Name box and click OK.

**Delete Button**
Use the Delete button in the DTP dialog to delete objects from the tree.

**IMPORTANT:** When a group or section is deleted, all items contained within it will be removed. Your delete selection cannot be undone.

To delete a group, section, or item:
1. Select a group, section, or item from the tree.
2. Click Delete.
3. When prompted to confirm your selection, click OK.

**Statistics Button**
Use the Statistics button in the DTP dialog to view statistics about the design technology parameters file. When you click this button, the following Statistics dialog appears.
Attribute Handling on Copy

For Net Rule, Class-to Class Rule, and Net Class Rule Items you can choose to replace or merge attributes when copying these rule items to a design. The Attribute Handling on Copy group box in the Design Technology Parameters dialog contains the following options:

- **Replace Design Attributes**: Replaces a design’s rules with the rules from the design technology parameter file item.
- **Merge Attributes**: Merges the rules of the design technology parameter file item with the design’s rules, favoring the rules of the design technology parameter file item over the design.
File Import Shape Route

The P-CAD Shape-Based Router runs as a separate program in Windows. As well as running the Shape-Based Router directly from the Route Autorouters dialog, you can launch it separately, load a Shape Route file that has been exported from P-CAD PCB, route it, save the routing results, then Import the routes back into the P-CAD PCB Editor by selecting the File » Import » Shape Route command.

File Import Gerber

Choose File » Import » Gerber to load a series of Gerber files. You can load a Gerber file into the editor to check its accuracy. Each file is loaded onto a separate layer.

You can load a Gerber file either into an empty workspace (choose File » Clear to clear the workspace) or superimpose it onto an existing design. Loading a file alone is usually for checking pad size, line width, or other possible errors. Superimposing a file onto a design is a good way to verify the Gerber file against the design.

To avoid the risk of cluttering a working design with unwanted Gerber geometry, save the design in its current state (choose File » Save or File » Save As) before importing data from Gerber files.
You can examine the Gerber file through the workspace display in addition to analyzing the error file displayed in Notepad.

When you choose **File » Import » Gerber**, the following dialog appears.

Click **Gerber Filename** to open the *File Gerber In* dialog, shown in the following figure.

![File Gerber In dialog](image)

Select your Gerber file and click **Open** to return to the *File Gerber In* dialog. Then, specify the **Layer Name** and **Layer Number** and select or clear the View log file upon completion check box. The layer name Gerber is provided by default, but you can change this name.

You can load multiple Gerber files onto your design file, each inhabiting its own layer. When you load a Gerber file, it automatically creates a non-signal layer named Gerber, using the next free layer in sequence. For example, if you have eleven layers, the twelfth is used.

Therefore, the layer names must be unique. So, the first file loaded would be on the layer Gerber, the next file loaded would receive the default name Gerber1, then Gerber2, etc. Normally you would load multiple files to verify that the layers are aligned and registered properly.

**IMPORTANT:** The D Code apertures that are called out by the loaded Gerber file must be present and be defined as they were in the original Gerber file. If a D Code is no longer present, then the program will flag the error. If the D Code is present but its definition has changed, no error will be flagged, and you may get unexpected results. For example, this could occur if you loaded an old Tango Series II Gerber file without first recreating the aperture definitions properly. Our advice is that you should not redefine D Codes at all between the creation of the Gerber file and reloading it for design file/Gerber file comparison.
Aperture definitions are saved and loaded in the design file. Loading a new design file can completely change the current aperture settings. The **File > Clear** command does not clear current aperture definitions, so you can choose **File > Clear** to clear the workspace before loading a newly created Gerber file.

**IMPORTANT:** Do not save Gerber layers with your .pcb file. See *Deleting Gerber Layer Information (page 180)* for instructions on how to delete Gerber layers that were accidentally saved along with your design.

Click **OK** to load the photoplot file.

If the layer limit is exceeded, your design cannot be loaded using P-CAD PCB (6/400). P-CAD PCB (6/400) designs are restricted to a maximum of six copper layers, including a predefined Top and Bottom layer and four user-defined signal or plane layers. P-CAD PCB (6/400) designs can have a total of up to 1,000 layers.

---

**File Import DXF**

DXF (Drawing Interchange Format) files generated using AutoCAD® Version 9.0 through 14 or other conforming CAD programs can be loaded into PCB. Using this command, you can create dimensions, board outlines, manufacturing instructions, artwork, logos, etc., and then import the resulting DXF file into PCB.

**Loading a DXF File**

To load a DXF file into PCB, choose the **File > Import > DXF** command. A standard *Open File* dialog appears where you can navigate to the file you want to load. When you click **OK**, the *File DXF In* dialog appears as shown in the following figure:
The *File DXF In* dialog contains the following options, which determine how the file is treated when loaded:

### DXF to P-CAD PCB Layer Map

The DXF to P-CAD PCB Layer Map list displays the layers in the imported file and the PCB layer to which each is mapped. The P-CAD Layer box and the buttons located directly below it are used to specify layer mapping for selected layers.

If a DXF file contains layers whose names use AutoCAD reserved keywords (i.e., `vport`, `view`), a syntax error occurs and causes the file load to abort. Rename the layer to work around this limitation.

The buttons perform the following functions:

- **Map Selected Layers**: Each selected DXF layer is mapped to the layer chosen in the P-CAD Layer drop-down list by clicking the *Map Selected Layers* button after one or more layers has been selected.

- **Create New Layer**: Opens the *Options Layer* dialog where you can add a new layer if the desired layer does not appear in the drop-down list. To automatically create layers use the *Default Map* and *Auto Map Layers* options.
• **Default Map**: Maps the selected layers to the default layer of DXF_1. If this layer already exists the default mapping is to DXF_2, etc.

• **Auto Map Layers**: Maps the selected DXF layer to a corresponding PCB layer of the same name. If the DXF layer has the same name as an existing signal layer in the design, you will have to map it to a non-signal layer. If the DXF layer name exceeds the number of characters allowed in a PCB layer, the PCB layer name is truncated.

• **Unassign Layers**: Removes whatever mapping is present for the selected layers and sets the mapping to <None>.

• **Remove Unneeded Mappings**: Clears layer mappings that don’t exist in the current DXF file. DXF layer mapping information is stored in the PCB.ini file.

• **Set All**: Selects all the layers in the list.

• **Clear All**: Cancels the selection of all the layers in the list.

When you click the OK button, PCB verifies that no more than 999 layers exist. If a DXF layer is mapped to a PCB layer that does not exist, the PCB layer is created. PCB also verifies that there are no mappings to signal or plane layers.

**DXF Units**

The DXF Units frame of the *File DXF In* dialog provides the ability to choose which units will be used to apply proper scaling when loading the DXF file. Click the appropriate option button to set the unit for Inch, Cm or Mm.

**Locate DXF Origin**

The P-CAD PCB workspace uses positive X and Y coordinates. Since DXF items can be placed at negative X and Y coordinates, you may have to direct P-CAD PCB to adjust the position of your imported DXF geometry. On the *File DXF In* dialog, select a method of translation to positive coordinates using the Locate DXF Origin buttons.

• **Absolute Workspace Origin**: If your DXF geometry is positioned only at positive coordinates, click the Absolute Workspace Origin button. No coordinate translation is made.

• **Relative Grid Origin**: Loads the DXF geometry so its origin is placed at the Relative Grid Origin of your workspace. The Relative Grid Origin is specified with the Options » Grids command.

• **Auto Adjust to Workspace**: Automatically adjusts the placement of your DXF geometry into positive coordinates.

When you import data into P-CAD PCB from a DXF file, and you enable the Auto Adjust to Workspace option, the P-CAD PCB automatically translates the position of the lower left extent of the DXF file data into the positive P-CAD PCB workspace. The DXF data’s lower left extent is the coordinate defined by the EXTMIN variable in the header section of the DXF file. If the EXTMIN variable is absent from the DXF file, then P-CAD PCB automatically calculates a suitable solution based on the extents of the geometry in the DXF file.
It is suggested that you set the current grid to a uniform value consistent with the grid of your DXF design. This grid spacing optimizes the on-grid placement of components. Set your current grid with the **Options » Grids** command before importing your DXF file.

If DXF geometry items still fall outside the P-CAD workspace, a warning is written to the log file and the items are not imported. Your DXF geometry can fall outside the workspace if the translated items are still positioned at negative coordinates or if the geometry is larger than the workspace size. If the geometry is larger than the workspace size, choose **Options » Configure** to increase your workspace size and import the DXF file again.

**View Log File Upon Completion**
To view the log file when the import is complete, select the **View Log File Upon Completion** check box in the **File DXF In** dialog.

**Items Supported for Translation**
The following items and features are supported for translation:

**Header Variables**
The AutoCAD® state variables are grouped together at the top of the file in the HEADER section. Supported variables are listed and described below, with default values in parentheses.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>$ACADVER</code></td>
<td>The AutoCAD® drawing database version number (must be 9.0 or higher.)</td>
</tr>
<tr>
<td><code>$ANGBASE</code></td>
<td>The angle zero direction. The DXF coordinate system is rotated by this angle. (0)</td>
</tr>
<tr>
<td><code>$ANGDIR</code></td>
<td>The angular orientation: 1 = clockwise; 0 = counterclockwise. (0)</td>
</tr>
<tr>
<td><code>$MIRR TEXT</code></td>
<td>Mirror text if non zero. (0)</td>
</tr>
<tr>
<td><code>$TEXTSIZE</code></td>
<td>Default text height.</td>
</tr>
</tbody>
</table>

**Tables**
The **DXF In** command supports the LTYPE, LAYER and STYLE tables.

**Blocks**
The only entries in the BLOCKS section that are supported are the dimension blocks. All dimensions that are translated come from this section.

**Entities**
The majority of a DXF file is made up of entities. These include lines, arcs, text, block insertions and others. Only two-dimensional entities are supported; z-axis values are ignored. All block insertion entities are ignored. Information embedded in the entities for color and layer are also ignored.
<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LINE</td>
<td>DXF LINE entities have infinitesimal width. They are translated into P-CAD lines of one mil.</td>
</tr>
<tr>
<td>ARC</td>
<td>DXF ARCS are translated into P-CAD arcs of one mil.</td>
</tr>
<tr>
<td>CIRCLE</td>
<td>DXF CIRCLES are translated into P-CAD arcs with a sweep angle of 360 degrees and a one mil width.</td>
</tr>
<tr>
<td>POLYLINE</td>
<td>DXF POLYLINES are a sequence of possibly tapered, straight and curved lines that are connected end-to-end. These may be open or closed. P-CAD does not support tapering and only supports normal 2-D (unflagged) DXF vertices. POLYLINES are translated into P-CAD arcs and lines with a thickness equal to the initial POLYLINE thickness.</td>
</tr>
<tr>
<td>LWPOLYLINE</td>
<td>DXF POLYLINES are translated into P-CAD arcs and lines with a thickness equal to the initial LWPOLYLINE segment thickness.</td>
</tr>
<tr>
<td>MTEXT</td>
<td>MTEXT is the same as TEXT except that MTEXT can handle multiple lines.</td>
</tr>
<tr>
<td>VERTEX</td>
<td>Vertices define DXF POLYLINES. When translated, they become the defining vertices of the translated P-CAD item. Only normal 2-D DXF vertices are supported (no spline-fit, curve-fit, 3-D mesh, or other special flags).</td>
</tr>
<tr>
<td>SOLID</td>
<td>DXF solids are filled three or four sided polygons. They are translated into P-CAD polygons. Four sided solids that form a complex polygon will be ignored.</td>
</tr>
<tr>
<td>TRACE</td>
<td>DXF traces are lines with thickness that can be filled or unfilled. They are treated the same as DXF solids and are translated into polygons.</td>
</tr>
<tr>
<td>TEXT</td>
<td>DXF text is translated using an appropriate text style in P-CAD. True Type fonts are mapped to the same font and text height. Text that cannot be mapped to an identical font is translated into the P-CAD default font. Due to the difference in fonts, translated text strings may be of different total width than the DXF version. The bar over barred text may not align exactly with the text.</td>
</tr>
</tbody>
</table>

The following is a specific (but not comprehensive) list of entries that are not supported:

- All BLOCKS, except the dimension blocks.
- SHAPE, ATTDEF, and ATTRIB entities.
- 3DLINE, 3DFACE and 3DSOLID entities.
• Curve- or spline-fit vertices or meshes for POLYLINE and VERTEX entities. Tapering POLYLINEs are also not supported.

• Three-dimensional entities and coordinates; thickness for all entities will be ignored, and only the first two values of a coordinate-triplet will be used.

• Dashed and dotted lines are converted to the P-CAD thin width.

• Color values for individual entities. Color values for entities will depend on the P-CAD primitive and layer to which the entity is translated.

**DXF Import Notes**

The following is a list of notes that are important or useful when using the File » Import » DXF command:

• The EXPLODE command in AutoCAD® can be used to transform blocks into individual entities.

• An important item to be translated from a DXF file is the dimension. AutoCAD® creates a new dimension block every time a dimension is moved, edited, or altered in any way. The user should use the PURGE command to eliminate any unreferenced copies of the dimension blocks created by AutoCAD®. The user should then output the design to DXF format immediately after the PURGE command, before editing or modifying dimensions.

• Text fonts and styles are more accurately translated from AutoCAD® when the style has been defined prior to entering text.

**File Import PDIF**

Choose File » Import » PDIF to open .pdf format design files.

**Open a File**

To open a PDIF file, do the following:

1. Choose File » Import » PDIF to open the following dialog.

![PDIF File Name Dialog]

2. Type, or select from the list, the name of the file you want to open in the Filename box.
3. If the file you want is not in the current folder, then type the folder name in front of the document name, or select the correct folder.

4. Click Open.

If any of the design limits are exceeded, your design cannot be loaded using P-CAD PCB (6/400).

File Import IDF

The Intermediate Data Format (IDF) format is used to exchange design data between electrical and mechanical CAD/CAE systems.

The IDF Import feature allows the mechanical designer to define the board outline in a mechanical CAD program, as well as pre-position placement-critical components and mounting holes, and then transfer this information to the PCB designer, who imports it by selecting File » Import » IDF. The IDF Import command can load version 2 and version 3 IDF files.

When you select File » Import » IDF the File Import IDF dialog appears. Enable those options that you wish to import from the IDF file.

Board Outline
Select this option to import board outline details contained in the .brd file. The board outline section of the IDF file is translated into lines and arcs within the PCB design. Board cutout
information will be imported as line segments only (arcs are converted to line segments). Existing lines and arcs found on the Board layer are removed during import.

**Drilled Mounting Holes**
A free pad is placed for each Drilled Mounting Hole in the IDF file. The pad styles defined in the PCB are first searched for a pad which has the correct hole size, and has its shape set to mounting hole. If a suitable pad is not found a new pad style is created for each unique mounting hole in the IDF file.

**Placement**
When this option is enabled existing PCB components are updated (location, orientation and side of board), and new components are imported. Note that components are only imported if a matching pattern can be found in the current libraries. Components are identified by their RefDes.

If an existing component is Fixed on the PCB then it is owned by the PCB (ownership is assumed to be ECAD), and is not updated during IDF import. If a component in the IDF file is has its ownership set to MCAD it is set to Fixed in the PCB. In the case of an ownership conflict, the PCB ownership takes precedence.

**Placement Group Area and Placement Outline**
The Placement Group Area represents the name, position and dimensions of a room. When this option is selected, the importer tries to match any of these objects found in the IDF file to existing rooms on the PCB, if an exact match to an existing room is found the IDF definition is not imported, if there is no existing room then a new room is created.

The Placement Outline defines the maximum allowed height of the room, whose name, position and dimensions are defined by the Placement Group Area.

**Routing Keepout**
When this option is selected any routing keepout information contained in the IDF file is imported as polygon keepouts in the PCB design.

---

**File Export Shape Route**
The P-CAD Shape-Based Router runs as a separate program in Windows. As well as running the Shape-Based Router directly from the Route Autorouters dialog, you can launch it separately and load a Shape Route file. To create a Shape Route file select **File » Export » Shape Route** from the menus. The **File PRF Out** dialog appears, where you can select the location and name of the PRF file and create the PRF file.

---

**File Export Gerber**
Choose **File » Export » Gerber** to output Gerber files with a variety of options and specifications. You can cancel this command before the dialog appears (while the program is searching the database for items) by clicking **Cancel** or pressing **ESC**.

Choose **File » Export » Gerber** to open the following dialog.
There are several dialogs that you can gain access to by clicking a button in the File Gerber Out dialog, as shown in the following chart.

Setup Output Files

Click Setup Output Files to open a dialog where you can set up multiple output files with specific output options.
Output File List Box

The Output File list contains the filenames of the output files you set up. Each set of options you specify (described in the following paragraphs) comprises a separate output file, differentiated by its filename extension. After you have set options and the extension for a particular file, you can click Add to add it to the list. After you have a file list, you can choose to change a file (click Modify), or delete it from the list (click Delete).

Your output files will have the same base name as the design file, but each with a unique extension. Typical file name extensions used to differentiate files would be layer-specific, such as .top, .bot, and .tsk (i.e., Top, Bottom, and Top Silk layer).

Output File Selections Area

The Output File Selections frame allows you to set options for each output job such as: layer, file name extension, X and Y offset, drill symbol size, and items included (Pads, Type, etc.), and the output path of the particular file.

- File Extension should be a meaningful name for the output (e.g., .top). Avoid potentially conflicting file name extensions such as .exe and .pcb. When you click Add, the base filename with the file name extension you specify will be added to the file list.
- X Offset and Y Offset allow you to set the origin of the plot in a different position than the home position of the plotter. For X offset, enter a negative number to offset the plot towards the left, positive to the right. For Y offset, enter a negative number to offset downward, positive to offset upward.
- RefDes, Type, and Value check boxes are typically selected for silkscreen generation, with the silkscreen layers.
- Mirror is typically used to produce a mirror-image output for bottom layers (e.g., Bottom, Bottom Silk, Paste Mask, Solder Mask, Assembly, etc.). Some fabrication shops prefer to mirror the output themselves, so check with them before using Mirror.
• Pads, Vias and Pad/Via Holes should be selected if you want them included in the Gerber output.

When producing an output file for a specific hole range, you need to select all the layers on which a pad and via’s hole has been defined.

• No Mt Hole Cu must be selected if you want to exclude the mounting hole copper from the output.

• Titles provides the option to include or exclude Title Sheets that exist on the selected layers in Gerber output. Select this box to include titles.

• Drill Symbols frame size value determines the sizes of the drill symbols output in the particular file.

• Select or clear the check boxes to include or exclude items and attributes from the output.

• Output Path allows you to output the files to a particular location. The default setting for the output is the directory of the current design. You may type a new output destination directly into the box, or click the Output Path button to open the Windows Search dialog where you can navigate to the desired directory.

• View error file upon completion opens WordPad where you can view the log file.

• The Layers box lists all current layers of the design. You can highlight any number of them for output to a particular file.

• The Layer Sets box is used to designate specific, predefined layer sets to output. Select a layer set from the list and click Apply Layer Set.

To generate a drill symbol drawing, you must enable all layers that match the pad stack (plane and signal). Also, you must enable pads, vias, and drill symbols.

After you have set up your output files list in the dialog, click Close and return to the Gerber File Out dialog, which will list the files that you set up for output.

**Apertures Assignments**

To assign/describe apertures automatically or manually, click the Apertures button in the File Gerber Out dialog to open the following Aperture Assignments dialog.
The list of this dialog displays the items of the loaded design file and any aperture assignments that may exist for those items. You can click a line and the item’s characteristics will be listed to the right of the list. If an aperture is assigned to the item, the aperture characteristics are listed there as well.

To manually describe and assign an aperture (or change an existing assignment), double-click a line, or select a line and click **Assign**, to open the *Describe/Assign Apertures* dialog.

Click **Unassign** to delete the aperture assignment for the item that is selected in the Assignment list.

Click **Unassign All** to clear all aperture assignments. This allows you to describe and assign apertures using the Auto Assign feature.

**Auto (Automatic Describe/Assign)**

To automatically assign apertures, set the appropriate options and click **Auto**. PCB automatically assigns all apertures that have not been assigned manually.

- You can select the **Pad/Via holes** check box to have PCB create apertures with holes, but this is generally not recommended for two reasons:
  - Drilling holes through the board could break drill bits if the flashed pad/via holes don’t line up through the board exactly.
  - Non-hole apertures are usually less numerous; a 50 x 50 round with no hole can be used for a 50 x 50 on the Top layer and also for a 40 x 40 via with a 5 mil swell solder mask.

- **Clear current apertures**. This check box is selected by default. If the check box is cleared, the current apertures remain. Typically, you want to select this check box to clear apertures when you auto-assign.

- **Draw Rotated or Offset Pads/Vias**. Select this check box to assign the draw aperture to pads and vias with non-orthogonal rotations, or offset holes (non-orthogonal being rotations other than 0 or multiples of 90-degrees).
Chapter 12: File Commands

File Export Gerber

- **Draw Polygon Pad/Via.** Select this check box to have the program draw polygon pads. When the check box is cleared, polygon pads are assigned flash apertures.

- **Draw Aperture Size.** Enter a value in this box to define the default draw aperture size for any unassigned apertures, such as drawn drill symbols and polygons.

After you have taken these steps, click **Auto** to automatically describe and assign all unassigned apertures to the appropriate items.

**Assign (Manual)**

To manually describe/assign apertures, click **Assign** to open the **Describe/Assign Apertures** dialog. You can also double-click an item line in the previous dialog to open the dialog, shown in the following figure:

![Describe/Assign Apertures Dialog](image)

The item name you highlighted on the previous dialog appears in the Assign Aperture to field at the top of this dialog. If the item was already assigned an aperture, that aperture name appears highlighted in the Apertures list. The item characteristics are listed to the right of the list, and the aperture characteristics are listed there as well (if an aperture is assigned).

In the D Code box, enter a value in the range of 10 through 999 for the draft code used to select the aperture. The program automatically prefixes the value with the letter D.

The **Shape** combo box displays the aperture shape. The following shapes are supported:

- Ellipse
- Oval
- Polygon
- Rounded
- Rectangle
- **Ellipse** is a rounded shape with separately specifiable X and Y dimensions; an ellipse with equal X and Y dimensions is a circle (frequently called a round).

  Embedded apertures for flashed elliptical pads are defined as ovals.

- **Oval** is a short line segment with round end caps (half-circles), the radius of which is 1/2 the length of the shortest side; if the X and Y dimensions are equal, this too is circular or round.

- **Polygonal** is a free-form polygonal shape defined using the Polygonal Pad Shapes dialog. For details about this dialog, see Options Pad Style (page 472).

- **Rounded Rectangle** contains 1/4 circles on the corners of a rectangle. The 1/4 circle radius is 1/4 the length of the shortest side.

- **Rectangle** shapes are X=width and Y=height.

  If you want a circle pad, you use the ellipse shape with identical height and width (the example shown is an oblong ellipse). If you want a square pad, use a rectangle with identical height and width.

- **Thermal apertures** are typically used for connection to planes, where heat is a factor. These apertures are constructed from two or four arc segments separated from each other by spokes. The other dimension is the diameter of the outer edge of the arc-segments, the inner dimension measures the inside edge, and the gap measures the spoke width, or amount of copper connection on a reverse-screened plane layer. Thermals are always circular, and the size is a function of the pad/via hole size.

**Thermal Spoke Apertures**

- 2 spoke
- 2 spoke 90
- 4 spoke
- 4 spoke 45

**Thermal Diameters and Spoke Width**

- outer diameter
- inner diameter
- spoke width
• A **Target** is used for layer registration.

![Target](image1)

• **Mounting Hole** is a circle shape with a cross in it used to represent a mounting hole.

![Mounting Hole](image2)

• **Drill Symbol** could be any of the drill symbol shapes assigned in the *Drill Symbols* dialog.

• X Dim and Y Dim are the X (horizontal) and Y (vertical) dimensions for the aperture. These values may be entered with your choice of units.

• The H Dia is the hole diameter for the aperture. This value may be entered with your choice of units. The hole diameter cannot exceed the minimum aperture dimension.

• Angle is the amount in degrees that an aperture is rotated.

• X Off and Y Off are horizontal and vertical offset amounts of the hole in an aperture.

The Type combo box lists the aperture types (type indicates whether the aperture can be flashed, drawn or both). The type is specified using either Flash, Draw, or Flash/Draw. Flash and Draw are typically specified for use with mechanical or vector photoplotters, because different holders must be used for the two types of apertures. Flash/Draw is used with laser photoplotters, which do not have this limitation.

The Comment box allows you to enter a comment of up to 32 characters. This is especially helpful for further describing thermal reliefs and drill symbols.

**Available Procedures**

There are basically four procedures available in this dialog:
• To create a new aperture, enter information in the D Code, Shape, and other fields. Then, click **Add**. The Shape and Type combo boxes allow you to select the shape and type of the aperture.

For polygonal pad shapes, X Dim and Y Dim options are unavailable and the *Polygonal Pad Shapes* dialog appears when you click the **Add** or **Modify** button. See *Defining Polygonal Pad Shapes* (page 477) for more information.

• To modify an existing aperture, change the aperture descriptions as appropriate. However, keeping the same name (D Code). When finished, click **Modify**. The assignment remains the same (item to aperture), but the characteristics of the aperture have been changed.

For polygonal pad shapes, X Dim and Y Dim options are unavailable and the *Polygonal Pad Shapes* dialog appears when you click **Modify**.

You can use the *Polygonal Pad Shapes* dialog to browse through the list of polygon apertures to see what they look like.

• To create a new aperture based on existing one, change the name (D Code) of the aperture and change the aperture descriptions as appropriate. Then, click **Add**.

• To delete an aperture assignment/description, click **Delete**.

Click **Close** to save your changes. You return to the *Aperture Assignments* dialog, which lists your assignments. The currently selected aperture is used as the assignment for the item shown in the dialog.

**Setting Drill Symbols**

From the *File Gerber Out* dialog, click **Drill Symbols** to open the *Drill Symbol Assignments* dialog. From this dialog you can assign drill symbols either manually or automatically.
**Automatic Assign**
To automatically assign drill symbols, click **Automatic Assign** in the *Drill Symbol Assignments* dialog. PCB automatically clears (unassigns) all existing assignments and then automatically assigns all of them.

The list of this dialog displays the hole diameters of the loaded design file, plating information, and any drill symbols that may exist for those hole diameters, allowing you to view which items are assigned and what those assignments are.

1. Click **Unassign All** to clear all existing drill symbol assignments.
2. Click **Automatic Assign** to automatically assign a drill symbol to each hole diameter in the design.

**Manual Assign**
To manually assign drill symbols:

1. Click **Unassign All** to clear any drill symbol assignments.
2. Click a hole diameter in the list to highlight it.
3. Click the drill symbol you want to assign to the hole diameter. The drill symbols are listed in the Drill Symbols combo box/list on the right of the dialog. The Assign and Unassign buttons become available.
4. Click **Assign**. The drill symbol will appear next to the hole diameter it is assigned to in the list.

You can manually unassign drill symbols in the same manner.

**Gerber Format**
To gain access to the Gerber options, click **Gerber Format** in the *File Gerber Out* dialog. The following *Gerber Format* dialog appears:

Select **Inches** or **Millimeters** from the Output Units frame.
Select one of the following options in the Numeric Format frame, on the basis of the required resolution.

- The format 4.4 means that there are four digits to the left of the decimal point and four digits to the right.
- The format 5.3 means that there are five digits to the left of the decimal point and three digits to the right.
- The default Gerber output format is RS-274-D. To output this format, clear the Include Aperture Definitions check box.

The G54 With Apertures determines whether or not to send a G54 tool-select code with each command to change apertures.

The Include Aperture Definitions check box determines whether definitions and assignments macros are to be included in the output. These embedded apertures use RS-274-X Gerber format.

Click Close to exit the dialog, and the format you specified will be applied when the output is generated.

**Compress Output Files**

You may elect to produce files in a compressed format by selecting the Compressed (.ZIP) or Self-Extracting (.EXE) check boxes in the File Gerber Out dialog.

Both (.zip) and (.exe) files will compress the selected output files into one smaller file. The (.zip) option produces a smaller file than the (.exe) option but requires an Unzip.exe program to decompress the file when you need to access it. The compression done in the self-extracting (.exe) option outputs a larger file than is output by the (.zip) option because its uncompress function is included in the compress program.

If the process is canceled prior to execution, the output files are not compressed. If a compressed image exists, you must confirm that the file is to be overwritten. Compressed Gerber output files are identified by the .exe or .zip file name extensions added to the base name of the design file. For example, MyboardGbr.zip.

**Generate Output Files**

After you have set up the output files, aperture assignments, drill symbols, Gerber format, and optionally selected a compression format, you can generate the output files by selecting them from the Output Files list and clicking Generate Output Files in the File Gerber Out dialog.
A progress indicator displays the name of the file being converted. When finished, the log file is displayed if the View error file upon completion box was selected in the Setup Output Files dialog.

Text objects in TrueType font mode causes the Gerber output process to fail. An error is written to the Gerber log file. Change the display type of all text styles in the design to stroke font mode and generate the Gerber file again.

**File Export N/C Drill**

Choose **File » Export » N/C Drill** to output an N/C Drill file for your design in Excellon format. You can cancel this command before the dialog appears (while the program is searching the database). Choose **File » Export » N/C Drill** to open the following dialog.
The *File N/C Drill* dialog allows you to output individual or multiple files in compressed, non-compressed or self-extracting executable formats. Before you generate output, you may need to establish N/C Drill settings in some of the multiple dialogs available from the *File N/C Drill* dialog, as shown in the following figure.

When you have established all of the options for output files, tool assignments, and other drill settings, the resulting output files will be listed in the Output Files list. You can individually select the filenames to enable or disable a file for output. **Set All** selects all of the files for output (you can then deselect individually). **Clear All** cancels the selection of all files (you can then select files
individually). Then, click **Generate Output Files** to generate drill files according to what you have specified.

**Setup Output Files**

When you click **Setup Output Files** in the **File N/C Drill** dialog, the following dialog appears.

![Setup Output Files Dialog](image)

The filenames for the output files you set up here are determined by the individual file name extensions you give them (e.g., `filename.nc1`, `filename.nc2`). Most of the time only one file is used for N/C Drill, so that you have the design filename as the root name, and the extension as `.ncd`. This is to differentiate it from the regular design file and Gerber files in the same folder (.pcb, .top, .bot, etc.)

The Layers list fills with defined signal layers; no non-signal layers appear.

When producing an output file for a specific hole range, you need to select all the layers on which a pad and via's hole has been defined. In this way it is possible to generate files for blind and buried vias. If your board contains only through-hole pads/vias (not blind or buried vias), then only one file is necessary, and it should contain all of the signal and plane layers.

The Layer Sets box is used to designate specific, predefined layer sets to output. To select a layer set, select a layer set from the list and click **Apply Layer Set**.

You can perform four basic procedures for output files from within this dialog:

- Create an output file. Specify an extension (e.g., `.nc1`) and the X,Y offset settings. Choose the hole style to be output. Select layers to be included or use the **Set All** or **Clear All** button to select all or cancel the selection of all layers, respectively. For example, if you set all layers, you can then cancel the selection of one or two layers that you want to exclude. Click **Add**.

- Modify an existing output file. Select a filename from the list. Keep the same file name extension, but change the settings accordingly, including X, Y offset, and layers and hole styles to be included. Click **Modify**.
• Create a new output file from an existing one. Select (highlight) a filename from the list. Change the extension of the file, and either change settings and included layers, or leave them alone, as appropriate. Select the desired hole style to be output. Click **Add**.

• Delete an output file from the list. Select (highlight) a filename from the list. Click **Delete**. Specify the destination of your output files by specifying the path in the Output Path box. You can also select or clear the View error file upon completion check box.

Click **Close** to save your output files settings and return to the File N/C Drill dialog.

**Tools Assignments**

To assign N/C Drill tools, click **Tools** in the File N/C Drill dialog. The following Tool Assignments dialog appears.

In this dialog you can unassign tools, and then either automatically or manually describe/assign what remains.

To manually describe/assign tools, click **Assign** to open the Describe/Assign Tools dialog. Or you can double-click on a hole/tool line to open the dialog.

To individually unassign a tool, select a tool assignment in the list to highlight it, then click **Unassign**. To unassign all tools, click **Unassign All**.

Click **Auto** to automatically describe/assign all remaining unassigned tools. The **Auto** button always assigns unique drill tools to holes that have equivalent size, but differing plating. Select the **Clear current tools** check box and the tools will automatically clear when you click **Auto**.

Click **Close** when your descriptions and assignments are set.
Assign (Manual)

Click Assign to open the following dialog, where you can manually describe/assign tools.

![Assign Tool Dialog]

The hole name of the hole or tool you highlighted on the previous dialog appears at the top of this dialog in the **Assign Tool to** field.

All tools appear in the list; if the hole already has a tool assigned to it, then that tool is selected in the Tools list, and the tool’s Tool code and Tool Diameter and Hole Plated and Hole Diameter values appear in the appropriate frames. If the hole has no tool assigned (no tool is highlighted) then the Tool frame boxes are blank. The non-editable Hole frame always displays the Hole Diameter, Yes if the hole is Plated or No if non-plated.

In the Tool Code box, you can enter a value in the range of 1 through 80 for the tool code used to select the drill bit. The program automatically prefixes the value with the letter T and fills in the leading zero for codes T01 through T09.

In the Diameter box, you can enter a value to determine the diameter of the drill bit.

There are four procedures available in this dialog:

- **Create a new tool assignment** by describing/assigning the tool (filling in the T Code and Diameter) and clicking Add to assign it to the hole.

- **Modify an existing tool assignment** by changing the Diameter, but keeping the same T Code, then clicking Modify. The assignment remains the same (tool to hole), but the diameter of the tool has been changed.
• **Use an existing tool to create a new one** by changing the name (T Code) of the tool, and then using the same diameter and hole assignment. You would then click Add, in effect creating a new tool assignment.

• **Delete a tool assignment/description** by clicking Delete. The tool assignment must be highlighted to delete it.

Click **Close** to save changes. You then return to the Tool Assignments dialog, which lists your assignments.

**N/C Drill Format**

To establish N/C Drill format settings, click **N/C Drill Format** in the File N/C Drill dialog. The following **N/C Drill Format** dialog appears.

In the Output Units frame, if you select Inches, the units are in inches and the format is automatically set to 2.4 (two digits to the left of the decimal point and four digits to the right). If you select Millimeters, the format is automatically set to 4.2 (four digits to the left of the decimal point and three digits to the right).

Select the appropriate buttons in the Output Code Type and Zero Suppression frames. Check with the fabrication house for the appropriate settings. These options are saved in your **Pcb.ini** file.

**Compress Output Files**

As with File Gerber Out, you may elect to produce files in a compressed format by selecting the Compressed (.ZIP) or Self-Extracting (.EXE) check box in the File N/C Drill dialog.

Both (.zip) and (.exe) files will compress the selected output files into one smaller file. The (.zip) option produces a smaller file than the (.exe) option but requires an **Unzip.exe** program to decompress the file when you need to access it. The compression done with the self-extracting (.exe) option outputs a larger file than the (.zip) option because its uncompress function is included in the compress program.
After you have established settings in *N/C Drill Format*, click **Close** to save settings and return to the *File N/C Drill* dialog.

**File Export DXF**

The **File » Export » DXF** command is used to create DXF files of your PCB designs. These files can then be transferred to AutoCAD and other mechanical CAD packages. The output is compatible with AutoCAD® Version 9.0, and above.

When you choose **File » Export » DXF**, the following *File DXF Out* dialog appears:

![File DXF Out dialog](image)

To use this dialog, do the following:

1. Click **DXF Filename**. The following *File DXF Out* dialog appears, so you can select a file or enter a file name.
2. Type the name of the DXF file to you want to save in the Filename box.

3. Click **Save**. You return to the **File DXF Out** dialog.

4. Select the PCB layers you wish to output using the Layers list. Each PCB layer is output to a separate DXF layer. The **Set All** and **Clear All** buttons let you select and clear all the board layers at one time.

   You can use the Layer Sets box to designate specific, predefined layer sets to output by selecting a layer set from the list and clicking **Apply Layer Set**.

5. If you select **Output Drill Symbols**, you need to specify a size for the resulting drill symbols. The default value is 80 mils (or the equivalent if you’re in metric mode). To use a different value, type it in the Size box. If you specify zero, the Drill Drawing layer is output without drill symbols.

6. Select your desired hole output options: Plated Holes, Non-plated Holes or All Holes.

   To make or examine drill symbol assignment, click **Setup**. The **Drill Symbol Assignments** dialog appears. For details, see **File Export Gerber** (page 253).

7. Choose the desired output unit, **Inch**, **Cm** or **Mm**, by clicking the appropriate option button in the DXF Units area.

8. If you want to output only certain objects, select those objects in the design and select the **Selected Objects** check box.

9. Select the **Draft** check box to output in draft mode.

   DXF polylines are normally used for all lines, arcs, and pad and via shapes. A room consists of a polyline and two vertices. Solids are normally used for polygons. Polylines are filled lines with thickness. Select the **Draft** check box to output DXF arcs, lines, and circles instead of polylines, and polygon outlines instead of DXF solids. Draft mode produces smaller files that process faster, but the drawings are not technically accurate since the lines have no width and areas are not filled.

10. Check the **Component Height** box to output the component height. For more information, see **Component Height Check Box** (page 272).

11. Suppress the output of mounting hole copper with a check next to the **No Mt Hole Cu** box.
12. Check the **Include Title Sheet** box to output title sheets.

13. Check the **Include True Type Fonts** box to output true type text. Clearing this box allows you to export a DXF file that is compatible with Revision 9 DXF. True Type Fonts are compatible only with Revision 14 DXF when the Include True Type Fonts option is enabled, PCB outputs text as MTEXT; otherwise it is output as TEXT.

14. Click **OK** to generate the DXF output file. While the file is generating, the Status Line indicates progress by displaying the current layer being output. While the file is being generated, you can press **ESC** or **right-click** to cancel the operation.

**Component Height Check Box**

When you select the Component Height check box, PCB automatically detects valid ComponentHeight attributes assigned to components, and writes corresponding component height geometry to the DXF.

PCB uses the geometric primitives in a component’s pattern to produce component geometry in a DXF (circles, lines, arcs, and polygons). Pads, vias, text, and signal layer items are ignored. Component height geometry is created in the DXF on layers that are consistent with the source geometry.

In the DXF, the height of an individual component extends upward or downward from the design, depending on whether the component resides on the top or bottom layer.

When the DXF is read into a 3-D CAD system (such as AutoCAD), the specified heights are represented as geometric elements of the proper PCB components when viewed in 3-D mode.

**DXF Output Considerations**

- **Layers.** Items are output to individual layers, which keep their PCB names. DXF substitutes the underscore for unsupported characters such as spaces to maintain compatibility with AutoCAD naming conventions. If AutoCAD reserved keywords are used in the PCB layer name, and you import this file back to PCB, a syntax error occurs causing the file load to abort.

- **Blocks.** DXF blocks are used to combine individual entities into a common unit, to be treated as a whole by the CAD package, analogous to a part or component. Blocks are used, where possible, to make CAD processing easier, and to reduce the size of the DXF file. For example, a component block has the name of the reference designator; exploding a component block produces text (for attributes) and a pattern block. This in turn can be exploded to produce some single items and padstyle blocks. These can be exploded to produce padshape blocks; which can be exploded to produce solids and polylines.

- **Polygons.** PCB polygons are also represented as blocks containing a collection of three- or four-sided solids. In this way they can be processed as a unit.

- **Copper Pours.** PCB copper pours are represented as blocks containing a collection of lines that outline and fill the copper pour. In this way they can be treated as a unit.

- **Lines.** When not in Draft mode, lines consist of a straight polyline and two round endcaps. Note that due to limitations in how blocks are scaled in DXF, lines are not blocks; the endcaps
and polylines are separate from one another. In Draft mode, lines become DXF LINEs with no endcaps.

- **Arcs.** When not in Draft mode, arcs consist of a curved polyline and two round endcaps. Note that due to limitations in how blocks are scaled in DXF, arcs are not blocks; the endcaps and polylines are separate from one another. In Draft mode, arcs become DXF ARCs with no endcaps.

- **Text.** True Type font text styles are created and included in the DXF file. P-CAD stroke font text strings are converted into DXF text strings of the same height, rotation, mirroring, and justification; the AutoCAD® STANDARD font is used. Note that due to the difference in fonts, translated text strings may be of different total width than in PCB.

- **Pads and Vias.** These are blocks of pad shapes, which are in turn blocks of SOLIDs and POLYLINES. For example, a rounded rectangle is a block consisting of two SOLIDs forming a thick “plus” and four circular POLYLINES in the corners. A pad is a block containing a stack of what could be different shapes on different layers. When not in Draft mode, these shapes are filled; in Draft mode, only the outlines are represented with lines, arcs, and circles. Pads and vias are not output with holes.

- **Selected Objects.** When specific objects have been selected for inclusion in the DXF file, they are exported regardless of the layer on which they reside. A single layer object can be exported even if its layer is not selected. A selected multi-layer object includes all of its pieces, even when some of the pieces reside on unselected layers. Selecting objects overrides layer selection.

- **Title Sheets.** Title sheets can be included in the DXF output file by enabling the Include Title Sheet option. Block output of title sheets are named TITLE_SHEET_xx, where xx is the layer number on which the title sheet resides. The title blocks consist of lines, text and other objects that form the title sheet and title block.

### File Export PDIF

Choose **File » Export » PDIF** to create PDIF files of your PCB designs.

#### PDIF File Export

To export a PDIF file, do the following:

1. Choose **File » Export » PDIF**. The **PDIF File Name** dialog appears:

   If the current folder is not appropriate, then either type the folder name in front of the document name, or select the correct folder.

2. Type the filename you want to use in the Filename box.

3. Make sure the correct file name extension is selected in the Save File as Type list.

4. Click **Save** to save the file as you have specified.
File Export IDF

The Intermediate Data Format (IDF) format is used to exchange design data between electrical and mechanical CAD/CAE systems.

The IDF Export feature allows you to transfer design data from the P-CAD PCB Editor to a mechanical designer, who can then perform solid model form-fit analysis of the assembled PCB in the product enclosure. You can export to an IDF file by selecting the **File » Export » IDF** command. The IDF file is created in the IDF version 3 format.

When you select **File » Export » IDF** the **File Export IDF** dialog appears. Enable those options that you wish to include in the IDF file.

When you click OK to complete the export process 2 files created, a BRD file, which details all the board information that you chose to export, and a PRO file, which is a library file detailing the components.

**Board Outline**

Select this option to export board outline details contained in the PCB design. The board outline is the largest closed shape on the board layer, made up of lines and arcs. All other lines and arcs that do not constitute this polygon are exported. If there is no closed shape on the board layer a
Bounding rectangle of all the primitives is used. Design cutout information is exported as line and arc segments.

**Drilled Holes**

Export the location and diameter of drill holes, according to the option selected in the Drilled Holes frame. For each hole exported, the entry in the IDF file contains information for diameter, position, plating style, hole type and owner (MCAD, ECAD or UNOWNED). Component pads and routing vias are set to ECAD, free pads are set to UNOWNED.

- **All Holes**: component thru hole pads, free thru hole pads, and vias are exported.
- **Mounting Holes**: free thru hole pads with their pad shape set to mounting hole are exported.
- **Minimum Hole Diameter**: component thru hole pads, free thru hole pads, and vias with a hole diameter greater than the amount specified are included in the IDF file.

**Placement**

When this option is selected, component information contained in the PCB design is exported. Information related to component RefDes, position, side, rotation and whether it is fixed or not, is exported into the Placement area of the .brd file. For each component that is exported, a library component is also created in the IDF Library File (.pro). Within this file, each component is defined by its outline information and also its height, which is taken from the ComponentHeight attribute.

The set of components that are exported is determined by the option selected in the Components frame.

- **All Components**: all components are included in the IDF export. Components boundaries are defined either by the outline defined on the layer specified by the PackageOutlineLayer attribute, or if this can not be detected, by the outline on the silkscreen layer.
- **Components with IDF_COMP Attribute**: only those components that include a user-defined attribute IDF_COMP are exported.

To determine the component shape, each component is checked to see if it has a PackageOutlineLayer attribute, if it does the shape defined on this layer is used. If a component does not include a PackageOutlineLayer attribute then the design-level attributes are checked for a PackageOutlineLayer attribute, if found the shape on this layer is used. If no PackageOutlineLayer attribute can be found the component silkscreen boundary is used.

**Placement Group Area and Placement Outline**

The Placement Group Area represents the name, position and dimensions of a room. When this option is selected, one Placement Group Area is created for each of the existing rooms in the PCB design, in terms of name, specified position and dimensions.

The Placement Outline defines the maximum allowed height of the room, whose name, position and dimensions are defined by the Placement Group Area.
Routing Keepout
When this option is selected, any polygon keepouts in the PCB design are exported as routing keepouts in the IDF file.

Routing Outline
The IDF routing keepout is only created if there is a BoardEdgeClearance attribute defined for the PCB. This keepout is calculated from the board outline, contracted by the amount defined in the BoardEdgeClearance attribute.

File Export RFQ Format

The WebQuote, or AutoRFQ feature allows you to request a quotation to fabricate or assemble your board from within the P-CAD PCB Editor. This feature extracts relevant PCB data, passes it to the Request For Quotation application (AutoRFQ), which then interfaces to the WebQuote web site (http://www.webquote.com) to configure and request for a quotation on the PCB.

The WebQuote site is a portal to PCB fabricators all over the world. From this site you can select which manufacturers you wish to participate in the quoting process, and also choose if you wish to use an open bidding process, where each fabricator is notified of the other fabricators’ quotes (allowing them to requote), or a closed bidding process, where they are not notified.

The Request For Quotation feature can either be run by selecting the Utilis » P-CAD AutoRFQ command, which creates the RFQ file and then loads it into the AutoRFQ program, or by selecting the File » Export » RFQ Format command to create the RFQ file. This file can then be opened manually in the AutoRFQ program.

Once the RFQ file is loaded in the AutoRFQ program it is displayed as an RFQ for PCB Fabrication window. This file details the necessary design specifications that have been extracted from your PCB.

From the AutoRFQ application you can then set up a new request for quotation by clicking the New RFQ button that appears at the top of the RFQ for PCB Fabrication window. The first time you attempt to do this you will be prompted to create an account, once this is done the job can be configured, ready for a quotation.

When you click the New RFQ button the data in the RFQ file is passed to the PCB MarketPlace web site, and another window appears. Work your way down this window, clicking the Modify or Enter buttons and completing the information required on each page that appears. Once your RFQ has been successfully submitted you will receive a confirmation email, then when the quotes from the manufacturers are received you will be emailed these as well.

File Exit
Choose File » Exit to quit the P-CAD PCB program.

If any open designs have been modified since the last save, you are prompted whether you want to save the changes to each design.
The program writes information to the Pcb.ini file when you choose Exit. This information, which will apply to subsequent PCB sessions, consists of parameters and settings such as workspace size, units and values set in Options Configure, report file settings from File » Reports and Utils » DRC, etc.
Using the Edit Commands

Use the commands in the Edit menu to modify objects that have been placed in a design. Shortcuts to a number of the Edit commands appear on the command toolbar as shown in the table directly below the command toolbar.

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To do this:</th>
<th>Click this button</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Edit Select</td>
<td></td>
<td>Edit Undo</td>
</tr>
<tr>
<td></td>
<td>Edit Cut</td>
<td></td>
<td>Edit Redo</td>
</tr>
<tr>
<td></td>
<td>Edit Copy</td>
<td></td>
<td>Edit Measure</td>
</tr>
<tr>
<td></td>
<td>Edit Paste</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Most of the actions associated with the Edit commands can be undone by choosing Edit » Undo. Other actions can be unwound by pressing the BACKSPACE key when the action is finished. For details, see Edit Undo (page 280).

Many Edit commands are available only when an object is selected. To learn how to select objects, see Edit Select (page 356).

Two of the Edit commands, Edit » Paste and Edit » Fix, contain additional options:
Chapter 13: Edit Commands

The **Edit » Paste** commands give you the ability to paste information from the Clipboard or file, include circuitry information, and control the way the objects are renamed when pasted. See **Edit Paste** (page 284) for more information.

The **Edit » Fix** commands give you the ability to Fix or Unfix one or more selected objects. All fixed objects can be unfixed using the **Unfix All** command. See **Edit Fix** (page 342) for more information.

### Edit Undo

Choose **Edit » Undo** to undo the last completed action in the active design. As a shortcut for choosing this command, click the **Undo** button on the toolbar, press the U key, or press **CTRL+Z**.

With this command, you can undo up to 10 of your last actions by default. To increase or decrease this number, you modify your Pcb.ini file. In this file, the keyword “UndoLimit” controls the number of stored activities for both **Edit Undo** and **Edit Redo**.

**IMPORTANT:** Although you can set the undo limit to any number, keep in mind that each stored, undoable action requires memory. Setting a large UndoLimit may use up your computer’s available memory, which can slow down your system’s performance and cause unpredictable results.

You can undo **Place** commands, **Edit » Delete**, **Edit » Copy Matrix**, and component modifications such as move, rotate, and flip (actions performed in select mode). If an action cannot be undone or there is no action to undo, the **Edit » Undo** command is shaded in the menu.

You can only undo a finished **Place** command. For example, if you are placing an object that requires more than one click in the workspace (such as drawing lines, polygons, arcs), you must finish the segment or arc before you can undo it. To unwind line segments (delete the previous segment) before you finish the series of segments, press the **BACKSPACE** key.

The list of undoable actions is deleted when you save the design. The Undo list is also cleared when you use any of the commands in the following list:

- File Close
- File Save
- File Save As
- Delete Textstyle
- Utils Renumber
- File DBX In
- File DTP (Close or ESC)
- File Design Info (Close or ESC)
- Utils Force Update
- Utils Record ECOs
- Import ECOs
- Delete Layer
- Delete Padstyle
- Delete Viastyle
- Place Autoplacement (can lead to file save)
- Route Autorouters (can lead to file save)
- Utils DRC
- Utils Reconnect Nets
- Utils Load Netlist
- Utils Trace CleanUp
- Utils Optimize Nets
- Edit Nets PadStyle Swap
- Modify TextStyle in use
- Connection tool (merging one or two plane nets with a connection line)
- Edit Nets (rename a net)
- Modify PadStyle in use
- Modify ViaStyle in use

**Edit Redo**

Choose **Edit » Redo** to re-apply an action that has been undone. As a shortcut for choosing this command, click the **Redo** button on the toolbar, press **SHIFT+U**, or press **CTRL+Y**.

Each modification made to a design results in a copy of the design being placed in the Undo list, as described in **Edit Undo** (page 280).

If you have stepped backwards in the list using the **Edit » Undo** command, and find that you want to move forward to a later version of the modification, choose **Edit » Redo**.

With this command, you can redo multiple actions. The keyword “UndoLimit” in the **Pcb.ini** file controls both the **Edit » Undo** and **Edit » Redo** commands.

**Edit Cut**

Choose **Edit » Cut** to remove objects from your design and move them to the Clipboard. When objects are moved to the Clipboard, you can paste them into another design, to another location within the current design, or into another program.
To cut objects from a design and move them to the Clipboard, choose Edit » Select or press S to enable the select tool. Then, select at least one object. If you do not enable the select tool, the Edit » Cut menu command is shaded and the CTRL+X shortcut key is inoperative.

Once you move items to the Clipboard, you can save them to a clipboard file (.clp). To do this, open the Clipboard Viewer and choose File » Save to create a clipboard file. To paste data from the clipboard file, you load the clipboard file into the Clipboard, then paste from the Clipboard into your design file.

You can cut multiple objects by using multiple select and block select operations. See Edit Select (page 356) for information.

Cutting Objects from Nets
When you choose Edit » Cut to remove objects from nets, you can get a variety of results, depending on what you cut and the makeup of the net you remove it from. The function of smart nets is to maintain certain connections when objects such as copper connections, unrouted connections, and net nodes are removed. In general, the following can occur:

- If you remove free copper (no connections), then the copper disappears and no connection compensation occurs.
- If you remove a node (such as node a in the following connections figure), then the remaining nodes are still part of the net, and there will be compensation to maintain connections between the remaining nodes.
- If you remove a component, you are removing nodes from all nets to which the component’s pads were connected. The connectivity feature of PCB reconnects the remaining nodes in each net in the most efficient way.
- If two nets become merged, and one net is a plane net, then the plane layer net takes precedence and the merged net is a plane net.
- If you remove a connection from the middle of a net, the net is split. One portion retains the net name and the other is given a new net name. For example, in the following figure, the net has three connections: ab, bc, and cd. If you remove connection bc, you cut the net into two nets: ab and cd.

- If you remove a connection that isolates a pad from the rest of the net, you end up with a disconnected node. For example, in the previous figure, if you remove connection cd, the node d becomes isolated from the net.
Edit Copy

Choose **Edit » Copy** to copy objects to the Clipboard. From there you can paste them to another design, to another location within the same design, or to another program.

To copy objects in a design and move them to the Clipboard, choose **Edit » Select** or press **S** to enable the select tool. Then, select at least one object. If you do not enable the select tool, the **Edit » Cut** menu command is shaded and the **CTRL+X** shortcut key is inoperative.

Instead of choosing **Edit » Copy** and **Edit » Paste**, you can press **CTRL+Left Mouse** button (a drag-and-drop operation) to copy and paste objects within the same design. The **CTRL+Left mouse** action does not copy items to the Clipboard.

Once items are in the Clipboard, you can either immediately paste them to another design location, or save them to a clipboard file (.clp). Choose **File » Save** in the Clipboard program to create a clipboard file. After you load a clipboard file into the Clipboard, you can paste a clipboard file into your design file.

See **Edit Paste (page 284)** for the rules and parameters of pasting objects.

Edit Copy to File

Choose **Edit » Copy to File** to copy selected objects to a block file (.blk) or P-CAD picture file (.emf). You can paste the objects in a block file into a design at a later time by choosing **Edit » Paste From File** or **Edit » Paste Circuit From File**.

A block file is design intelligent in that it includes layer information, design rules, etc. When pasted back into a design using the **Edit » Paste From File** command, objects from the block file become an integrated part of the design. When a bock file is placed into PCB using the **DocTool » Place Detail** command, it loses its design intelligence but becomes an accurately scaled representation of the selected design objects.

The P-CAD picture file includes no design intelligence. A picture is a snapshot of selected objects, which can be pasted into a PCB design as a dumb object with one of the following commands: **Edit » Paste From File**, **DocTool » Place Picture** or **DocTool » Place Detail**. When a P-CAD picture is created the **Mirror on Copy** setting is honored.

To choose this command, you must be in select mode (choose **Edit » Select** or press **S**) and you must select at least one item; otherwise the command is shaded and not available. You can copy multiple objects by using multiple select and block select operations. for more information, see **Edit Select (page 356)**.

When you choose **Edit » Copy to File**, the following dialog appears:
The Save in list displays the current folder; the list below the box displays any files in that folder with the file name extension specified in the Save as Type list. The Filename box lets you enter or select a file name and the Save as type box allows you to select one of the following types of files: Block File (.blk) or P-CAD Picture File (.emf). Specify a location and name of the block file to which you wish to copy the selection.

You may choose to save storage space by selecting the Compress Binary Designs check box in the General tab of the Options Configure dialog.

**Edit Paste**

Choose Edit » Paste to paste objects/items into your design file from the Clipboard or a block file. You must be in select mode to choose this command.

When you choose Edit » Paste, a submenu appears, from which you can choose a paste method. The methods range from the simple options such as Paste From Clipboard, Paste From File and Paste To Layer, in which objects are pasted without net information, to the more intelligent Paste Circuit and Paste Circuit From File commands which give you the ability to control changes to component and net names and retain net information.

> If any of the design limits are exceeded, the object/item cannot be pasted in your design using P-CAD PCB (6/400).

**Paste Behavior**

After items have been copied and you click in the workspace, the ghosted outline of the copied item(s) appears until you release the mouse button to commit them to the desired location. Before releasing the left mouse button, you can drag the items to a more precise location in the workspace.

There must be sufficient space to accommodate the objects being pasted. Error messages inform you if the target space is not large enough or if you are attempting to paste too close to or outside of the edge of the workspace.

To cancel a paste operation, right-click, press ESC, or choose another tool.
If an item is layer-specific, then it will be pasted onto the same layer that it was cut/copied from, regardless of the current layer setting. If the target layer doesn’t exist, then the item(s) will not be pasted. To paste to a different layer, choose **Edit » Paste to Layer**.

Components of the same type can be placed only if they have the same pin mapping (i.e., pin number to pin designator to pad number. If you place the same component from different libraries, the first instance of the component type establishes the standard pin mapping for that type of component. Any components of that type placed subsequently have to conform to the pin logic of the first or they will be unplaceable.

If you have cut or copied a room, and subsequently paste it to a new design where there is a room with the same name, the pasted room is given a new default name (i.e., Room1, Room2, etc.).

If while pasting a component, components of the same name but from a different library already exist in the destination design, the component may not be able to be pasted due to the probable conflict in pin assignments. This conflict could also occur when components from a Tango Series II board are mixed with components of the same name in a P-CAD library. In effect, the first instance of the component name establishes the standard.

When you paste vias, pads, and text (usually in a component) from a different design that contains styles that have the same names but different data than those in the current design, the incoming style name has a bracketed number appended to it to indicate the style name conflict. The following figure shows a duplicated text style.

The new, bracketed style names will be added to the list of available styles in the current design. For object style information, see the following sections:

- **Edit Properties** (page 292).
- **Options Pad Style** (page 472).
- **Options Text Style** (page 482).

When you choose **Edit » Paste Circuit** and **Edit » Paste Circuit From File** you acquire additional functionality and control. If you are pasting components you have the option to specify how their
names should be changed. When pasting nets you can specify not only how the net names are to be changed, but you can also choose to retain the current name by choosing Edit » Paste Circuit. With these commands, data can be pasted into your design multiple times without having to invoke the command each time you want to paste.

**Paste From Clipboard**

Choose Edit » Paste from Clipboard to paste objects from the Clipboard to your design. You must be in select mode to choose this command. The Paste From Clipboard command is shaded and unavailable when no data has been copied to the Clipboard.

When you choose Edit » Paste From Clipboard, PCB places the copied information in the new location in the design, renames the design objects to the next sequentially available name and retains the component attributes and their values.

**Paste from File**

Choose Edit » Paste from File to paste items from a block file or a P-CAD Picture file into the current design. These files must have been created using Edit » Copy to File. When selected, the following dialog appears:

![Paste from File dialog](image)

The Look In list shows the current folder. Directly underneath, a list of files in that folder appear. The Files of type list shows the active file format. The Filename text box lets you select or enter a design file name.

Select the block file containing the item(s) you wish to paste. Once the file is selected, this command works like the Edit » Paste command.

**Paste To Layer**

This command gives you the ability to paste items to a different layer from what they were cut or copied from, within the same design or to a different design. This feature includes single, multiple, or block selection cuts and copies.

- The Edit » Paste To Layer command accepts only Clipboard data in PCB format. Clipboard data from other programs cannot be pasted into the PCB workspace.

- If you block select items that reside on different layers, e.g., one line on the Top layer and one on the Bottom, they will both be pasted onto the current layer.
• Multi-layer items, such as pads, will remain as multi-layer.
• When items are ghosted for pasting, you can press the L key to switch between layers before you do the final paste.
• You can paste to layer from a clipboard file (.clp) after you load the clipboard file onto the Clipboard. This data cannot be loaded or pasted to or from any other Windows utility; it is PCB-specific.

Paste Special

This command allows you to paste from the clipboard into the design as a P-CAD picture object. A P-CAD picture may be cut or copied to the clipboard using the Edit » Cut and Edit » Copy commands.

When you choose the Edit » Paste Special command, the Paste Special dialog opens:

![Paste Special Dialog]

The P-CAD Picture Format is selected. When you click OK you are returned to the workspace where you should click and drag the ghosted object to its desired location, placing it by releasing the mouse button.

A P-CAD picture cannot contain a picture, detail, design view or diagram. If a picture, detail, design view or diagram has been copied to the clipboard, the clipboard contents cannot be placed using the picture format of the Edit » Paste Special command. Clipboard contents can, however, be pasted as a block file using the Edit » Paste from Clipboard command.

Paste Circuit

The Edit » Paste Circuit command provides a way to control the naming of components and nets being pasted into a design and stipulate net attribute bias. Circuit information pasted with the Paste Circuit command includes:

• Components
• Pads and Vias
• Lines, arcs, polygons (including copper tie polygons) and copper pours
• Points
• Cutouts and keepouts
Chapter 13: Edit Commands

- Split Planes
- Rooms
- Text, attributes and fields
- Dimensions
- Global net information such as whether a net is attached to a plane, split plane or a component’s power pin
- Net names and IDs

When you choose Edit » Paste Circuit, the following dialog appears:

Reference Designators

In the Reference Designators frame you can choose how the components are named when pasted. You can choose to have PCB to incrementally change the components names, or you can control the way components are renamed by adding a qualifier in a specific position in the new name. A qualifier is a set of characters that you can add to a reference designator to modify the RefDes.

To rename the components using a qualifier, do the following:

1. Select the Create new refdes using qualifier check box.
2. Type up to four characters that you want to add to the name in the Qualifier box.
3. Choose the desired position within the RefDes name for the qualifier. Each choice in the following list places the qualifier in a different location:
   - Add before name
   - Add before numeric suffix
   - Add to end of name
A sample appears in the Example frame so that you can see how the qualifier will appear after the change is made.

If you do not want to designate the way the RefDes names are modified on paste, select the **Create new refdes using qualifier** check box.

Each time a component is pasted, the RefDes is sequentially incremented alphanumerically to the next available RefDes for that component. If you have added a qualifier, the qualifier is incremented in the same manner. Then, if the component name still conflicts with an existing component name, it will be incremented until it is unique.

### Net Attributes

When pasting data containing net information, either from the same design or another design, you can choose how the net attributes are handled by enabling the desired action from one of the following choices:

- **Merge Favor Circuit**: With this option, incoming net attributes take precedence over existing net attributes. When the net attributes in the incoming circuit information match those already in the design, but the values are different, the design attributes are modified to match those of the incoming circuit. All other incoming net attributes are merged with those in the design.

- **Merge Favor Design**: Existing net attributes are retained when you merge net attributes favoring the design. When the design and incoming circuit have matching net attributes with different values, the design attribute values are retained. Other incoming net attributes are merged with those in the design.

- **Replace Design**: This option removes all existing net attributes and replaces them with those of the incoming circuit.

- **Ignore Circuit**: Net attributes attached to the incoming circuit are ignored and existing net attributes left unchanged.

### Nets

In the Nets frame you can choose which nets are renamed and how they are named when pasted. This process is similar to the way the components are renamed in the Reference Designators frame.

To rename the nets, do the following:

1. Select the **Create new net name using qualifier** check box.
2. Type the characters (no more than four) that you want to add to the name in the Qualifier box.
3. Choose the desired position for the qualifier within the net name. Each choice in the following list places the qualifier in a different location:
   - Add before name
   - Add before numeric suffix
   - Add to end of name.
A sample displays in the Example area, so that you can see how the addition will appear when the change is made.

If you do not want to designate the way the net names are modified on paste, clear the Create new net name using qualifier check box.

Each time a net is pasted, the net name is sequentially incremented alphanumerically to the next available net name. If you have added a qualifier, the qualifier is incremented in the same manner. Then, if the net name still conflicts with an existing net name, it will be incremented until it is unique.

Choose which nets to rename using the qualifier and which nets will retain their current names. You can designate individual nets to retain the current name by clicking the specific nets in the Net Names list. You can also choose to retain all power net names and/or non-system net names by enabling the appropriate option in the Maintain Original Net Names frame.

Nets connected to power pins, planes and split-planes are considered power nets.

**Edit Move By RefDes**

Choose Edit » Move By RefDes to move components by reference designator. This opens the following Edit Move By RefDes dialog.

Use this dialog to select the reference designators of the components you’d like to move. The following describes this dialog in more detail:

- **RefDes**: This list shows all of the components in your design, except for fixed components. To unfix a component, choose Edit » Properties, click the Pattern tab, and clear the Fixed check box.

You can select one or more components from the RefDes list. To select multiple components, hold down the CTRL or SHIFT key and click the components of your choice.
If you select components in your design before you open this dialog, those components are selected in the RefDes list when the dialog appears.

When you double-click a component in this list, the dialog closes. At this time, you can place the component into a new position by clicking a point on your design workspace.

- **Select RefDes By:** Type search criteria in this text box to search the RefDes list for a match. You can enter wildcard characters in this field.
- **Select All:** Click this button to select all of the items in the RefDes list.
- **Clear All:** Click this button to cancel the selection of all items in the RefDes list.

After selecting components from the dialog, click **OK** to return to your workspace. The Status Line shows the Next RefDes to move. To skip to the next RefDes, press **N**. To move to the previous RefDes, press **B**.

**Edit Move to Layer**

Choose **Edit » Move to Layer** to move selected objects to the active layer. This facility enhances the ability to clear out congested areas for routing. In addition, if you have inadvertently placed objects on the wrong layer, you can move them easily to the correct layer.

**Moving an Object**

To move one or more objects to a different layer, follow these steps:

1. Select the object or objects. For details on selecting objects, see **Edit Select** (page 356).
2. Switch to the layer to which you want to move the objects using the Layers list below the Status Line.
3. Choose **Edit » Move to Layer** or press **SHIFT+T**.

All of the selected single-layer objects move to the current layer. You return to select mode and the objects remain selected.

**Restrictions**

- If an object has net information, it can move between signal layers only.
- Multi-layer objects will not be moved (components, glue dot points, all layer keepouts, pads, pick and place points, reference points, or vias). Objects that can be moved are single layer objects (arcs, copper pours, cutouts, single layer keepouts, lines, polygons, attributes, fields, and text).
- If you select multi-layer and single-layer objects simultaneously, the tool will ignore the multi-layer objects and only move the single-layer objects.
- Single-layer objects on different layers will all be moved to the current layer.
• If the single-layer objects are of mixed net and non-net types and you are moving them to a non-signal layer, a warning message will appear telling you that only the non-net objects will be moved. You can cancel this command at this time.

• The **Edit » Move To Layer** command performs auto-insertion of vias with a slight difference compared with the **Route » Manual** command. A via will not be inserted if a line segment is already connected to a pad or via. If the existing pad or via is incorrect for maintaining physical connectivity, the line segment will not be moved.

• When moving copper traces between layers, vias are not added for free copper, only for net copper. The net attribute VIASTYLE will be honored as it is in Route Manual.

• When multiple objects are moved and the physical connectivity cannot be maintained for some of the objects (e.g., if a via cannot be added), a warning message appears prompting you to continue or cancel the command. If you press **Cancel**, the objects moved before the cancel will not be moved back. If you press **Continue**, the object with the error will not be moved and the tool will skip to the next object.

• Test points can be moved to non-signal layers only. If you attempt to move a test point to a signal layer, a message appears to notify you that the object cannot be moved.

• If a copper pour is currently poured, it will be unpoured before the move and automatically repoured after a move. If the pour is not correct, use the **Copper Pour Properties** dialog to repour the pour. To open this dialog, select the copper pour, **right-click** and choose **Properties** from the shortcut menu. If the pour is not poured, it will remain unpoured after the move. A pour’s net connectivity will be maintained.

**Edit Properties**

To use this command, you select one or more objects in your design and then choose **Edit » Properties**. When you do, a **Properties** dialog appears for the selected object(s). Typically, you must enable the select tool (choose **Edit » Select**) before you can choose **Edit » Properties**, except when selecting components and nets.

With the **Properties** dialog, you query and modify the selected object’s properties. If multiple objects are selected, they must all be of the same type (e.g., arcs), otherwise the **Edit » Properties** command is shaded and not available. If the objects are of the same type, the changes you make apply to all selected objects.

As a shortcut for choosing **Edit » Properties**, there are other two methods for opening the **Properties** dialog box.

• **Right-click method**: Select an object. Then, right-click the object and choose **Properties** from the shortcut menu. The available commands in this menu depend upon the object you select.

• **Double-click method**: Double-click an object to open that object’s **Properties** dialog. Before you can use this method, select the **Double Click Displays Properties** check box in the **Options Preferences** dialog. For details, see **Options Preferences (page 448)**.
Component Properties

When you select one or more components and choose Edit » Properties, the Component Properties dialog appears. As shown in the following figure, the Pattern tab is selected.

Use the Component Properties dialog to examine and modify component properties. As shown in the previous figure, the selected component appears in the browse window in this dialog.

The Component Properties dialog contains these provide tabs, which provide access to additional information:

- Pattern
- Pattern Pads
- Component
- Component Pins
- Attributes
- Pattern Graphics

**Pattern Tab**

The Pattern tab contains the following options:
The RefDes box shows the reference designator name. To change the reference designator, type a new value in the RefDes box. If you selected more than one component, this value cannot be changed.

The Value box shows the component’s value. To change the value, type a new value in the Value box.

The Type box shows the component type. You may swap the component by selecting a different component from the Type list that appears when you click the down arrow button.

Swapping the component type follows the rules used by the **Utils » Force Update** command, when merging library component attributes with design component attributes:

- If an attribute exists in the library component and not in the design component, the library attributes and their values are moved into the design component.

- If the same attribute exists in both the design component and the library component with different values, the value of the library component attribute will replace the value of the design component attribute.

- An existing design component attribute, which has no matching library component attribute, is retained, unchanged, in the design component.

When the Value attribute is present in both the design component and the library component, and has a different value in both places, you must choose which value to keep in the design when prompted.

The Libraries box lets you select a library when you want to change the type of component.

The Visibility check boxes apply to the attribute directly to their left. The Visibility option indicates whether the selected component(s) has visible, invisible, or undetermined RefDes, Value, and Type attributes.

If a box is selected, the attribute is visible. If the box isn’t selected, the attribute is invisible. If the box is shaded, then the attribute either does not exist (e.g., there is no Value attribute for the selected component), or there is a conflict between multiple components selected (e.g., the attribute on one component is visible, but is invisible on another).

The Text Style frame lets you select the text styles for the component’s RefDes, Value, and Type. To use another text style, select a style from the appropriate list.

To add a new text style, or modify an existing text style, click **Text Styles**. See **Text Styles Button** (page 328).

**Change Pattern:** Click this button to create a new component from the current component and a pattern selected from the current library. This button is shaded for fixed components.

For more information, see **Change Pattern Button** (page 296).
• The **Pattern** field displays the pattern name. An image of the pattern appears just below this field.

• The Location frame shows the X and Y coordinates of the component’s reference point.

• **Flip**: When this check box is selected, the pattern has been flipped. When the check box is clear, the pattern has not been flipped.

• The Fixed box indicates whether or not the component has been fixed into position. In your design, fixed components display in the color assigned to fixed components. You set this color in the Colors tab of the Options Display dialog.

All commands that change the location of a fixed component ignore that component. This includes the following commands:

• Change Pattern
• Move
• Edit Move By Refdes
• Rotate
• Flip
• Edit Delete
• Edit Cut
• Component Type replacement
• Edit Explode Component
• Edit Align Component
• Utils Force Update

• The Rotation field shows the rotation amount, if the pattern has been rotated.

• The Glue Dot Locations list shows a list of all glue dot locations. **Glue Dots** hold components in place until they are soldered during manufacturing.

You can change the size of the glue dots in the Miscellaneous tab of the Options Display dialog. For instructions, see *Glue Dots* (page 445).

• The Pick and Place Locations list shows a listing of all pick and place locations. Pick and Place points provide reference points in directing the pick and place mechanism (or auto insert) in manufacturing (picking up the component and placing it on the board).

You can change the size of the pick and place points in the Miscellaneous tab of the Options Display dialog. For instructions, see *Pick and Place* (page 445).
Replacing a Component
To replace the component(s) associated with this pattern with another component from any open library:

1. To select a component from another open library, select a new library from the Libraries list.
2. Select a new component from the Type list.
3. Click OK to replace the component or components with the new component.

The new component is placed at the same Reference Point and same Rotation as the component you are replacing.

The net connectivity is maintained after the swap. If connectivity can’t be maintained, a warning message appears and the component is swapped.

Using the Properties function to swap a component can result in changes to the netlist if the pin designators on the replacement component are not the same as those on the original component.

If a warning message indicates that netlist changes have occurred, not only may some netlist nodes and their corresponding from-to connections be missing, but the net names may be removed if they result in a single node net. Additionally, any intelligent copper connected to the pads that are no longer netlist nodes are stripped of their netlist information. Choose Edit » Undo if you want to undo the component swap.

Text Styles Button
Click Text Styles in the Properties dialog to open the Options Text Style dialog. From this dialog you can add, delete, rename, or edit text styles. For more information, see Options Text Style (page 482).

Change Pattern Button
You can click Change Pattern in the Properties dialog to create a new component from the current component and a pattern selected from the current library.

1. In the Properties dialog, click Change Pattern. The following Library Browse dialog appears.
Since this dialog shows a list of matching patterns from the current library, the Pattern list contains only patterns that have the exact same number of pads as the currently attached pattern.

2. Select a pattern name from the Pattern list.

3. Click **OK**. The **Component Name** dialog appears.

4. Type a name for the component or select one from the list. Then, click **OK** to save it to the current library. You can overwrite an existing component if that component is not used in your design.

The **Change Pattern** button is shaded if more than one component is selected and the components are of differing types. It is also unavailable for fixed components.

**Pattern Pad Tab**

When you click the **Pattern Pad** tab, the **Component Properties** dialog appears as follows:
Use this tab to change the pad style of specific pads within the component and edit the pad style itself. This tab contains the following options:

- **The Pads list** lists the pin numbers of the pads in the selected component. The information fields to the right display information about the highlighted pad.
- **Set All**: Click this button to select all of the pads in the Pads list.
- **Clear All**: Click this button to cancel the selection of all pads in the Pads list.
- **The Location fields** show the X and Y coordinates of the selected pad. This field is read-only.
- The Flip check box indicates whether or not the pad has been flipped. This field is read-only.
- The Rotation field shows the rotation amount if the pad has been rotated. This field is read-only.
- The Net Name field shows the name of net to which the pad is attached. This field is read-only.
- The Default Pin Designator field shows the Pandas assigned to the pad. This field is read-only.
- The Tool Code field shows the code used to select the drill bit for the corresponding hole diameter. This field is read-only.
- **Pad Style**: Use this list to perform single or multiple pad editing. The pad numbers are highlighted in the Pads list and you can either change to another pad style for those pads, or you can click **Pad Styles** to open the **Options Pad Style** dialog, so you can modify an existing pad style, rename it, or create a new one based on an existing style.

![Component Properties Tab](image-url)
• **Apply:** Click this button to apply any changes to the selected pad or pads.

**Component Tab**

When you click the **Component** tab, the *Component Properties* dialog appears as follows.

![Component Properties Dialog](image)

This tab shows information for the component or components selected on a gate-by-gate basis. This information is view-only and can’t be modified from this dialog. To show information for a different gate, select the gate from the Gate Number list.

The **Reference** button, when activated by the presence of the Reference attribute, quickly opens the program or Internet Explorer where the document or web site containing the reference information is located.

See the *P-CAD Library Executive User’s Guide* for information about this dialog’s fields.

**Component Pins Tab**

When you click the **Component Pins** tab, the *Component Properties* dialog appears as follows:
With this tab, you view at pin information for the component pins within the symbol or component. In this tab, the following information appears:

- **Pad #**: The number of the corresponding pad on the attached pattern.
- **Pin Des**: The pin designator of each pin in the component.
- **Gate #**: This column indicates part number defines the part that the pin is associated with. In multi-part components, the parts are uniquely numbered from 1 through n.
- **Pin #**: This column shows the number of the corresponding pin on the attached symbol.
- **Pin Name**: This column indicates the pin name associated with that pin designator.
- **GateEq**: This column defines which gates are equivalent. All gates with the same GateEq number are equivalent. P-CAD Schematic uses this information when automatically incrementing reference designators (e.g., Place Part, Utils Renumber. P-CAD PCB uses this information to determine which gates can be swapped during manual or automatic gate swapping).
- **PinEq**: This column indicates which pins within a gate are logically equivalent and may be swapped using the **Utils » Optimize Nets** pin swap commands. The pin equivalence values must be non-zero and identical for a swap to occur between two pins. Non-swappable pins are indicated with a zero value.
- **Elec Type**: This column indicates the electrical type of the pin.
Attributes Tab
Use this tab to view and modify component attributes for the selected component. When you click the Attributes tab, the dialog appears as follows.

You can view, add, modify, or delete a collection of component attributes. The dialog contains a two-column table showing the collection of component attributes. Within the collection, each attribute’s name and value appear in the column.

- **Adding an Attribute:** To add an attribute, click the Add button to open the Place Attribute dialog. You can select a pre-defined attribute from a specific category or define your own attribute by selecting the (user-defined) attribute. Type the name and value for the attribute and set the attribute properties. Click OK, and the attribute is added to the table.

- **Viewing or Changing Attribute Properties:** To view or change an attribute’s properties, select an attribute from the table and click Properties (or double-click the attribute) to open the Attribute Property dialog.

- **To Delete an Attribute:** Select an attribute in the table and click Delete, or press the DEL key.

- **Launching a Reference Link:** When the special attribute Reference, whose value is a reference link, is added to the component, you can select the Reference attribute and click Launch to start a program to view a document or a web site.

Attribute Property Dialog
The Attribute Property dialog appears as follows:
Chapter 13: Edit Commands

Edit Properties

The following information appears in the dialog:

- **Category list**: Displays a list of the attribute categories: All, Component, Net, Clearance, Physical, Electrical, Placement, Manufacturing, Router, and SPECCTRA. Selecting a category brings up a list of predefined attributes for that category.

- **Name list**: Displays all predefined attributes for the specified category. The first entry in the list is User-defined.

The currently-selected attribute also appears in the Name text box, unless User-defined is selected. In that case, the Name text box is blank so that you can enter a user-defined attribute name.

- **Name Text Box**: For user-defined attributes, enter a name for the attribute.

  If the dialog is accessed to display an attribute’s properties, then the Category list, Name list, and Name text box are filled in, but shaded. If the attribute doesn’t have a name, these options are enabled.

- **Value**: Use this text box to enter a value for the attribute.

- **Visible**: This check box indicates whether or not the attribute is visible.

- **Location**: This area shows the X and Y coordinates of the component’s reference point.

- **Text Style**: This area lets you select the attribute text style. Text styles appear in the Text Style list. To change the selected Text Style, click on the text style you want from the list. To modify the text style, click the **Text Style** button.

- **Rotation**: Shows the rotation amount if the pattern has been rotated.

- **Flipped**: A check mark in this box indicates that the pattern has been flipped.
• **Justification**: Under Justification are nine buttons, which allow you to change text justification by setting the reference point of the text string. For example, if you enable the middle button, the text reference point (the lower-left corner) moves to the center of the text area.

**Pattern Graphics Tab**

P-CAD PCB supports alternate pattern graphics. The alternate pattern graphics feature allows you to define different pattern graphics (as part of the same component), which are used on the board in different circumstances. For example, it is common practice to use a different pattern for a top side SMD component to when the same component is mounted on the bottom side of the board.

Different pattern graphics can be pre-assigned to the side of the board, as well as the rotation. If you enable the Auto Swap Graphics option during component placement then as you rotate or flip the component the pattern is automatically updated, according to the assignments defined for the component in the P-CAD Library Executive.

- **Pattern Graphic Orientations**: Note that the Auto Swap Pattern Graphic option is on, but is grayed out. This indicates that the component was originally placed with the Auto Swap Pattern Graphic option enabled. If this component was now rotated the pattern graphic would automatically change to the pattern specified in the layer and orientation table in the center of the dialog. The table shows the 8 pattern assignments defined for the component, in this case there are only 2 pattern graphics assigned, one called Primary, the other called Secondary. These side of board and orientation assignments are set up in the P-CAD Library Executive or the P-CAD Pattern Editor.

- **Current Pattern Graphics**: This component is currently using the Secondary pattern graphic.
• **Solder Flow Direction**: The Solder Flow Direction is set up in the Manufacturing tab of the Options Configure dialog. This feature selects the pattern graphic based on the pre-defined assignments shown in the table below. The default solder flow direction is Top to Bottom. Note that the pattern graphic assigned to each rotation changes with the different solder flow direction option.

If for some reason you change the solder flow direction after components have already been placed on the board, you should enable the **Synchronize Components** option in the Solder Flow Direction frame – each component on board is checked, and if required its pattern graphic is changed for the correct alternative.

<table>
<thead>
<tr>
<th>Solder Flow Direction</th>
<th>Top (Non-Flipped)</th>
<th>Bottom (Flipped)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0°</td>
<td>90°</td>
</tr>
<tr>
<td>Top to Bottom</td>
<td>Pat 1</td>
<td>Pat 2</td>
</tr>
<tr>
<td>Left to Right</td>
<td>Pat 4</td>
<td>Pat 1</td>
</tr>
<tr>
<td>Right to Left</td>
<td>Pat 2</td>
<td>Pat 3</td>
</tr>
<tr>
<td>Bottom to Top</td>
<td>Pat 3</td>
<td>Pat 4</td>
</tr>
</tbody>
</table>

**Component Reference Links**

With the **Attribute Properties** or **Place Attribute** dialog, you can add a reference attribute to a component. A reference attribute is a link between a web site or document and a P-CAD component.

When you place a component with a reference attribute in a design, you can gain access to the web site or document associated with the reference. To do this, **right-click** the component and choose Properties. For details, see **Accessing a Reference Link** (page 305).

**Adding a Reference Link**

To add the Reference attribute to a component, choose **Place » Attribute**. The following **Place Attribute** dialog appears:
In the Place Attribute dialog, choose Component from the Attribute Category list and select Reference from the Name list. In the Value box, type the path and file name of a document (e.g., C:\PCAD\Text.doc) or the address of a web page (e.g., www.pcad.com). Then, click OK.

Next, save the Reference attribute to a component in a library. For more information on placing attributes and creating components, see Place Attribute (page 396).

Accessing a Reference Link

Once you've added the reference attribute to a component, you can right-click the component and choose Properties from the shortcut menu. Then, you can choose one of the following methods to gain access to the reference link:

- Click the Component tab, and click Reference.
- Click the Attributes tab, and click Launch.

For more information on the options in each tab, see Component Tab (page 299) and Attributes Tab (page 301).

Connection Properties

When you select a connection and choose Edit » Properties, the Connection Properties dialog appears. As shown in the following figure, the Net tab selected by default.
For information on the options in this tab, see Net Tab (page 464).

**Connections Tab**

When you click the **Connections** tab in the **Connection Properties** dialog, the dialog appears as follows:
The options in the Connection tab show you the start and end points for the selected connection and the Net Name to which the net belongs, as described below:

- **Net Name**: The net name of the connection.
  
  For the connection Start and End points, you see:

- **X and Y coordinates**: The X and Y location of the start and end point.
- **Node**: The node name to which this connection is connected.
- **Type**: The type of start or end point shows what the connection is connected to (e.g., pad).

**Pad Properties**

When you select a pad and choose *Edit > Properties*, the *Pad Properties* dialog appears. As shown in the following figure, the Pad tab is selected by default.
Chapter 13: Edit Commands

Edit Properties

The Pad tab contains the following options. The fields in this tab are read-only:

- **Net Name**: The name of the net associated with the selected pad.
- **Tool Code**: The tool code used to select the drill bit for the corresponding hole diameter. See *File Export N/C Drill (page 264)* for additional information.
- **Flip**: The Flip box indicates whether or not the pad has been flipped.
- **Rotation**: The Rotation field shows the degree of rotation.

### Changing Pad Properties

You can change pad properties as follows:

If the pad is part of a pattern, you can change only the pad style; you cannot change the pad number and location.

- **Pad Number**: Changing the pad number is useful when you only want to change one or two pads. If you want to renumber a series of pads, choose **Utils » Renumber**. For details, see *Utils Renumber (page 497)*.
- **Default Pin Designator**: You can assign a pin designator for each pad which, when saved, becomes the pad’s default designator in the library. If you have selected multiple pads, which have different default pin designators, the Default Pin Designator text box displays “Hetero_Selection”.
- **Location**: Type new X and Y coordinates for the pad.
• **Fixed:** Select the Fixed check box to secure a free pad in its design location. When fixed, a free pad cannot be moved, flipped, rotated, cut or deleted. The Fixed box does not appear in the Properties dialog when the selected pad is part of a pattern.

• **Pad Style:** You can change the style of the selected pad by selecting one of the existing pad styles in the Pad Style list.

**Pad Styles Button**

In the Pad tab, click **Pad Styles** to open the Properties dialog for pad styles. From this dialog you can add a new style based on an existing style, modify a non-default pad style, or delete a non-default pad style.

For detailed instructions on all the features, see **Options Pad Style (page 472).**

**Net Tab**

When you click the **Net** tab, the **Pad Properties** dialog appears as follows:

**Net Tab**

A number of objects have net information appearing on a Net tab with the object’s Properties dialog. This section describes the information you will find on the Net tab whenever that tab appears in a dialog.

**Net Name**

The Net Names text box contains the name of the net associated with this pad.
Nodes List Box
The Nodes list contains the names of all nodes in the net associated with this pad.

Layers List Box
The Layers list contains the names of all layers associated with this net.

Connection Lengths
This area shows the Manhattan length, the Selected length, and the Total length of all connections in the net. The Manhattan length is an approximation of the final routed length of a diagonal connection.

![diagram](image)

It only measures the X and Y distances, not depth (such as via length to another layer). Arc length is included (accurately) in the calculation of connection lengths.

Copper Lengths
This area shows the Selected length and the Total length of all copper in the net.

It only measures the X and Y distances, not depth (such as via length to another layer). Arc length is included (accurately) in the calculation of copper lengths.

Counts
The Counts frame counts the following objects in the selected net:

- Arcs
- Lines
- Pads
- Polygons
- Pours
- Vias

Net Attrs Button
When you click Net Attrs in the Net tab, the following dialog appears.
This dialog shows a collection of net attributes for the selected net. You can add, change, edit and delete attributes for the net and launch a reference to a document or web site.

For details about this function and a complete listing of attributes, see Edit Nets (page 345).

**Via Properties**

When you select a via and choose **Edit » Properties**, the Via Properties dialog appears. As shown in the following figure, the Via tab is selected by default.
Use this dialog to view or change the style of the selected via and to change its location. A Net tab provides net information when the via is part of a net.

The following fields are available for viewing only:

- **Net Name**: The name of the net associated with the selected pad.
- **Tool Code**: The tool code used to select the drill bit for the corresponding hole diameter. See *File Export N/C Drill (page 264)* for additional information.
- **Flip**: The Flip box indicates whether or not the via has been flipped.
- **Rotation**: This field shows the rotation of the via.

### Changing Via Properties

You can only change these properties if the via is not part of a net and is not connected to other objects.

- **To change the via Location**: The X and Y coordinates of the selected via appear in the Location box. You can move the via by entering new coordinates.
- **Fixed**: Select the **Fixed** check box to secure the free via in its design location. When fixed, a via cannot be moved, flipped, rotated, cut or deleted.
- **To change the Via Style**: Select the desired via style from the Via Style list.

### Via Styles Button

In the Via tab, click **Via Styles** to open the *Properties* dialog for via styles. From this dialog you can add a new style based on an existing style, modify a non-default via style, or delete a non-default via style.

For more information, see *Options Via Style (page 482)*.

### Net Tab

When you click the **Net** tab, the *Via Properties* dialog appears as follows:
For detailed information about this tab, see Net Tab (page 309).

**Line Properties**

When you select a line and choose **Edit » Properties**, the *Line Properties* dialog appears.

The *Line Properties* dialog shows you the Length of the selected line.

**Changing Line Properties**

To change the line’s Width: Type a new width over the value in the Width box.

To change the line’s End Points: Type new X and Y coordinates over the values in the X and Y boxes.

To fix a free line in its location: Select the *Fixed* check box. A fixed line cannot be moved, flipped, cut, rotated, deleted or resized.
Arc Properties

When you select an arc and choose Edit » Properties, the following Arc Properties dialog appears.

The Arc Properties dialog shows you the start and end points for the selected arc. For the free arc Center Point, Start Point, and End Point, you see:

- **X and Y coordinates**: The X and Y location of the Start and End point.
- **Tangent Slope Angle**: The tangent slope angle of the arc.

**Changing Arc Properties**

You can change the following properties if the arc is not part of a net and if it is not connected to other objects.

- To change the arc’s start angle: Click the scroll buttons (up and down arrows) in the Start Angle box to scroll through arc start angles or type a new value.
- To change X and Y coordinates of the Center Point: Type over the existing X and Y values in the Center Point frame.
- To change the arc’s Sweep Angle: Click the scroll buttons (up and down arrows) to scroll through arc sweep angles.
- To change the arc’s Radius: Type a new radius over the existing value in the Radius box.
- To change the arc’s line width: Type a new Value over the existing one in the Width box.
- To fix a free arc in its location: Select the Fixed check box. A fixed arc cannot be moved, flipped, cut, rotated, deleted or resized.
Polygon Properties

When you select a polygon and choose Edit » Properties, the following Polygon Properties dialog appears with the Polygon tab selected:

You can only change end points if a line is not part of a net and is not connected to other objects.

The Polygon tab of the Polygon Properties dialog contains the following options:

- **Area**: The area of the polygon.

- **Definition Points**: The X and Y location of each vertex in the polygon along with the total number of definition points it contains. If the corners of the polygon are filleted, the radius of the fillet is also displayed.

- **Filleted Points**: The X and Y location of each filleted point in the polygon, along with the total number of filleted points it contains.

- **Chord Height**: The chord height is the maximum distance between the actual arc and its representation as line segments. Curved edges are drawn using a series of line segments. The more line segments used to draw the arc, the closer the arc approaches a perfect curve, producing a small chord height. The default value is 5 mil and is stored in the .ini file.

- **Show Fillet Handles**: Turns on or off the display of the fillet handles in the polygon. The fillet handles are used to move or adjust filleted corners.

The Tie tab of the Polygon Properties dialog contains the following options:

- **Copper Tie**: Select the Copper Tie check box to make the polygon a copper tie. When a polygon and two or more nets are given the same TieNet value, and positioned so that the nets are touching the polygon, the polygon becomes a copper tie. The nets cannot be touching
each other (i.e., shorted) except through the Copper Tie. This gives you the ability to tie nets together while treating each net separately for routing purposes.

- **TieNet**: Set the TieNet value of the polygon with an entry in this field. You may enter a TieNet value or select an existing value from the drop-down list. The TieNet value can be any combination of alpha and/or numeric characters (i.e., 123, Ab1, 5, A1, etc.). Selecting a TieNet value from existing values in the drop-down list moves all nets with the same TieNet value from the Existing Nets list to the Tied To list.

- **Tied To**: The nets listed in this area are those that have the same TieNet value selected for the copper tie polygon.

- **Existing Nets**: All nets in the design are listed here. You can move a net from the Existing Nets list to the Tied To list by selecting the net then clicking the *left arrow* button. Conversely, move a net from the Tied To list to the Existing Nets list by selecting it and clicking the *right arrow* button.

When a net is moved into the Tied To nets list, the TieNet attribute value for that net is set to the current TieNet value of the copper tie. When a net is moved back to the Existing Nets list, its TieNet attribute reverts back to the value it had prior to being moved to the Tied To list. Any changes made in this dialog are applied when you close the dialog by clicking *OK*.

Copper Ties must be hidden from the routers to prevent being seen as shorts. You must place a polygon keepout around each copper tie before routing the design.

**Test Point Properties**

To open the Properties dialog for test points, select a test point and choose *Edit » Properties*. Or, select a test point, then *right-click* and choose *Properties* from the shortcut menu. As shown in the following figure, you can view and modify test point properties with this dialog:

![Test Point Properties dialog](image)

The Test Point Properties dialog contains the following options:

- **Side of Board frame**: There are two options buttons in the Side of Board frame: Top and Bottom. The button you choose indicates whether the point is tested from the Top or Bottom of the board. Since test points are not layer-specific, you can physically place a point on the bottom non-signal layer and choose *Top* to test the point from the top of the board.
- **Fixed**: Select the **Fixed** check box to make the point a fixed object. In your design, fixed points appear in the color assigned to fixed objects in the *Options Display* dialog. Clear the **Fixed** check box to indicate that the point is a moveable object. If a point is moveable (or unfixed), it appears in the appropriate layer color. If this check box is shaded, the test point is part of a pattern.

- **Snap to Center**: Select the **Snap to Center** check box when you want the test point centered on a pad or via. If you choose this option and the test point is on a pad or via, the point snaps to the center of the pad or via.

- **Net**: The Net text box shows the name of the net on which the point is located.

- **Location frame**: The text boxes in the Location frame show the X,Y coordinates of the test point. Both the Net and Location information is read-only. To modify these properties, you must move the test point from within your design.

To learn more about test points see *Test Points* (page 376) and *Placing Test Points* (page 386).

**Copper Pour Properties**

When you select one or more copper pours and choose *Edit > Properties*, the *Copper Pour Properties* dialog appears. As shown in the following figure, the Style tab is active when you choose this command.

Use the options in this dialog to set up or modify the properties associated with a copper pour. When a design contains more than one copper pour, you can modify all of the copper pours in the design at the same time.

Typically, you will use this dialog to change the state of the copper pours in your design from Unpoured to Poured or from Poured to Repour. For example, assume you place three copper pour outlines in a design (for instructions, see *Placing a Copper Pour* (page 387). To flood all three pours with a copper fill, do the following:
1. Hold down the **CTRL** key and select each pour.
2. **Right-click** and choose **Properties** from the shortcut menu.
3. When the **Copper Pour Properties** dialog appears, choose **Poured** in the State frame.
4. Click **OK**. P-CAD PCB floods all of the copper pours with the copper fill according to the pour order set in the Pour/Repour Option frame of the **Options Display** dialog. For details, see **Pour/Repour Option** (page 430).

**IMPORTANT:** You can inadvertently split the copper pour in half (more than two pieces) by modifying lines or polygons that were inside the pour region to where they are longer than the copper pour polygon. In that case, the electrical connection would be severed and a connection line will be created between the two islands if the pour is associated with a net.

The **Copper Pour Properties** dialog contains the following tabs:
- **Style tab**
- **Connectivity tab**
- **Island Removal tab**
- **Net tab**
- **Polygon tab**

**Style Tab**
Use the options in this tab to select a fill pattern, set line characteristics, and choose backoff options.

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To choose this fill pattern</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Solid Pattern" /></td>
<td>Solid copper fill will actually be banded (striped) with lines.</td>
</tr>
<tr>
<td><img src="image" alt="Horizontal Pattern" /></td>
<td>Horizontal fills the pour with horizontal lines (no hatching).</td>
</tr>
<tr>
<td><img src="image" alt="Vertical Pattern" /></td>
<td>Vertical fills the pour with vertical lines (no hatching).</td>
</tr>
<tr>
<td><img src="image" alt="45-Degree Cross" /></td>
<td>45-degree Cross is cross-hatched diagonally, at a 45-degree angle (like X).</td>
</tr>
<tr>
<td><img src="image" alt="90-Degree Cross" /></td>
<td>90-degree Cross is cross-hatched horizontally and vertically, at a 90-degree angle (like +).</td>
</tr>
</tbody>
</table>

- **Line Width:** Type a value in this box to determine the width of the lines used in filling and hatching.
• **Line Spacing**: Type a value in this box to determine the separation between fill or hatch lines. If you selected Solid for the Fill Pattern, then the Spacing box is shaded and not available.

• **Backoff**: Choose one of the following buttons in this frame.

• **Fixed**: Choose this button and type a value in the text box to specify a value for the distance you want between the copper pour and any objects that may be inside of the copper pour polygon. This option also backs off from any objects that are outside the copper pour polygon if they are too close to it. The copper pour backoffs from any copper item that is not in the net associated with the pour. The backoff options takes the object’s width into account.

• **Use Design Rules**: Click this button to set backoff values for a specific net. Backoff clearances are fixed at the greatest of the Line to Line or Line to Pad clearance amount set for the current layer in Options Design Rules dialog.

• **Backoff Smoothness**: The irregularities and roughness around the copper pours can be smoothed using the options in the Backoff Smoothness frame. Choose one of the following buttons to set the smoothness of backoff polygons. There are three degrees of smoothness:
  
  • Low specifies eight- to 10-sided polygons.
  
  • Medium specifies 12- to 14-sided polygons.
  
  • High specifies 16- to 18-sided polygons.

• **State**: Choose one of the following option buttons to set the state of the copper pour.

• **Poured**: Choose this button to flood the selected copper pours with a copper fill.

• **Unpoured**: Choose this button to leave the selected copper pours unfilled.

• **Repour**: Choose this button to repour an already filled pour to recalculate its islands. Typically, you will use this option when you load a netlist or move a copper pour. For details, see Repour (page 190).

Changing the values of **Line Width**, **Pour Backoff**, or **Backoff Smoothness** causes the copper pour to regenerate if **Poured** is enabled. Changes to any other value merely redraws the pour with the new settings.

• **Save Settings As Default**: Select this check box to save the selected settings for Fill Characteristics, Thermals, Backoff Smoothness and Automatic Island Removal are retained and applied to the next copper pour created.

**Connectivity Tab**

When you click the **Connectivity** tab, the Copper Pour Properties dialog appears as follows:
The Connectivity tab contains the following options:

- **Net**: Select the net to which you want to connect the copper pour from this list. The copper pour will backoff from all copper items not in this net. If no net is specified, the copper pour backs off from all copper objects inside the pour region except other “no-net” copper pours.

- **Thermals**: Choose one of the following option buttons in this frame to determine whether to use thermals, and if so, what type.
  - **45 and 90** specify 45- or 90-degree thermals.
  - **Direct Connect** specifies that the copper will pour right over pads and vias (no thermals) that belong to the same net as the copper pour.

- **Spoke Width**: Type a value in this box to specify a value for the width of the thermal spokes.

**Island Removal Tab**

When you click the **Island Removal** tab, the *Copper Pour Properties* dialog appears as follows:
Automatic Island Removal
Select the options in this frame to set criteria for the automatic removal of islands.

- **Minimum Area:** Select this check box and type a value in the box to specify a minimum area an island can have before being removed. Type a minimum value (in square units) in the text box. For example, to remove tiny islands about the size of the default via, enter 1600 as the area (40 mil x 40 mil).

- **Interior:** Select this check box to specify that all islands in a pour that don't have an edge in common with the perimeter of the copper pour are removed.

- **Unconnected:** Select this check box to automatically remove any copper pour island that is not connected to thermals or other copper. P-CAD PCB does not remove islands when all copper pour islands are unconnected.

- **Do not repour:** Select this check box to remove islands without repouring the copper pour. Because you do not have to wait for the pour to regenerate, selecting this check box is a quick way to remove unwanted islands.

**Net Tab**
When you click the **Net** tab, the *Copper Pour Properties* dialog appears as follows:
For detailed information about this tab, see Net Tab (page 309).

**Polygon Tab**

When you click the **Polygon** tab, you have the ability to gain access to the options shown in the following figure:

The options in this tab are similar to the options in the Polygon tab of the **Polygon Properties** dialog. For details, see **Polygon Properties** (page 315).

Copper Pours can be fixed in their location by selecting the **Fixed** check box. When a copper pour is fixed it cannot be moved, flipped, cut, rotated, deleted or resized.
Cutout Properties

When you select a cutout and choose Edit » Properties, the Cutout Properties dialog appears as follows.

The Cutout tab of the Cutout Properties dialog contains the following options:

- **Layer**: The layer on which the cutout appears. To change the layer, select a new layer from the list.

The Polygon tab of the Cutout Properties dialog, shown in the following figure, provides you with the ability to gain access to the same information available on the Polygon tab of the Polygon Properties dialog.

See Polygon Properties (page 315) for complete details.

Plane Properties

When you select a plane and choose Edit » Properties, the Plane Properties dialog appears with the Plane tab selected:
The Plane tab of the *Plane Properties* dialog presents the following information:

- **Net**: Use the list to assign the plane to an existing net or type in the net name.
- **Boundary Width**: This box defines the line width for the Polygonal outline. The default is the current default line width. Change the width by typing over the default value.

**Net Plane Color Button**
To select a net plane color, click **Net Plane Color** in the Plane tab of the *Plane Properties* dialog. When the color palette appears, select a color from the palette.

**Net Tab**
When you select the **Net** tab, the *Plane Properties* dialog appears as follows:
For detailed information about this tab, see Net Tab (page 309).

**Polygon Tab**
The Polygon tab of the Plane Properties dialog, shown in the following figure, provides you with the ability to gain access to the same information available on the Polygon tab of the Polygon Properties dialog.

See Polygon Properties (page 315) for complete details.

**Room Properties**
The Room Properties dialog, shown in the following figure, is used to modify the properties of one or more selected rooms.
The *Rooms Properties* dialog contains the following options:

- **Name**: The unique name of the Room. You may type a new name in the text box. A room's name cannot be greater than 20 characters or contain spaces. The default Room name is the word Room followed by a number, which is incrementally allocated each time a Room is created (i.e., Room1, Room2, etc.).

- **Edit Rules**: Click this button to open the *Attributes* dialog where you can assign attributes and their values to the Room rules. See *Attributes Tab* (page 301) for more information on the *Attributes* dialog.

- **Placement Side**: Choose one of the buttons in this frame to designate the Room placement on the board to the Top, Bottom, or Top or Bottom layer. The *Top Or Bottom* option is selected by default, giving you the ability to place rooms on either the Top or Bottom layer.

- **Included Components**: A list of the components included in the selected Room.

- **Design Components**: The list of all components in the design that are not already included in the room.

You may select one or more components from the Design Components list and click <<Add>> to move them to the Included Components list. To remove selected components from the Included Components list, click <<Remove>>.

In addition to selecting components by name from the Design Components list, you can select all components with the same Attribute and value for inclusion in the Included Components list. Click *Select by Attribute* to open the *Set By Attribute* dialog. You can then choose the *Attribute* to be used to select the desired components. The *Set By Attribute* dialog is explained in *Set By Attribute* (page 349).
• **Fill Pattern:** The pattern that fills the room when displayed can be Clear, Solid or Hatched.

• **Fixed:** Check this box to secure the Room in its location. When the Fixed check box is selected, the Room cannot be moved, rotated, flipped, stretched, cut or deleted.

• **Location:** The location coordinates are provided for viewing purposes and cannot be changed.

**Text Properties**

When you select one or more text items and choose *Edit » Properties*, the *Text Properties* dialog appears:

![Text Properties dialog](image)

The *Text Properties* dialog remains displayed in your workspace until you close it or choose another tool. Changes made to the text in the text box are instantly mirrored in the location of the selected text in the design. You can adjust the zoom factor in the design to more easily view the text while the dialog remains on the screen.

From this dialog, you can change the text content, justification, style and location. The text can also be rotated and flipped, and any non-default text styles can be modified.

**Changing Text Properties**

**To change the Text:** Type over the text displayed in the text box and click **OK**. For multi-line text, **ENTER** creates a line break. You can enter a maximum of 2,000 characters.

While the text box has focus, you can press **CTRL+V** to paste text from the Clipboard.

**To change the text Location:** The X and Y coordinates of the selected text appear in the Location box. You can move the text by typing new coordinates.

**To change the text Justification:** In the Justification frame, choose one of the buttons to change text justification. The reference point of the text string is, by default, at the location of the first character in the string and set to the lower left corner. When you change the justification button, the text moves around the reference point. For instance, if the text “STRING” is displayed in its default settings, the reference point (the small solid square) is as shown in the following illustration:
If you change the Justification to the upper right corner button, the text “STRING” rotates around the reference point and appears in the design as shown in the following illustration:

**To Flip the Text:** Select the **Flip** check box to flip the text.

**To Rotate the Text:** Click **Rotate** to rotate the text by the number of degrees shown on the button. To change degree of rotation, type a value in the Rotation Increment box in the General tab of the **Options Configure** dialog. The number of degrees that the text has been rotated is displayed next to the **Rotate** button.

**To change the Text Style:** Click the text style you want from the Text Style list.

**Text Styles Button**

Click **Text Styles** to open the **Options Text Style** dialog. From this dialog you can add, delete, rename, or edit text styles.

For more information on the **Text Style** dialog, see **Options Text Style** (page 482).

For more information on placing text, see **Place Text** (page 393).

**Attribute Properties**

When you select an attribute and choose **Edit » Properties**, the **Attribute Property** dialog appears as follows:
The following information appears in the dialog:

- **Category list**: Displays a list of all attribute categories: All, Component, Net, Clearance, Physical, Electrical, Placement, Manufacturing, Router, and SPECCTRA. Selecting a category brings up a list of predefined attributes for that category.

- **Name list**: Displays all predefined attributes for the specified category. The first entry in the list is User-defined.

The currently-selected attribute also appears in the Name text box, unless User-defined is selected. In that case, the Name text box is blank so that you can enter a user-defined attribute name.

- **Name**: For user-defined attributes, enter a name for the attribute.

If the dialog is accessed for an attribute that already has a name, then the Category list, Name list, and Name text box are filled in, and shaded. If the attribute doesn’t have a name, these options are enabled.

- **Value**: Use this text box to enter a value for the attribute.

- **Visible**: This check box indicates whether the attribute is visible or not.

- **Location**: This area shows the X and Y coordinates of the component’s reference point.

- **Text Style**: This area lets you select the attribute text style. Text styles appear in the Text Style list. To change the selected Text Style, click on the text style you want from the list. To modify the text style, click the Text Style button.

- **Rotation**: Shows the rotation amount if the pattern has been rotated.

- **Flipped**: This box indicates whether or not the pattern has been flipped.
• **Justification**: In the Justification frame, choose one of the buttons to change text justification by setting the reference point of the text string. For example, if you enable the middle button, the text reference point (the lower-left corner) moves to the center of the bounding rectangle.

**Field Properties**

When you select a field and choose **Edit » Properties**, the *Field Properties* dialog appears as follows.

![Field Properties Dialog](image)

The *Field Properties* dialog lets you view and/or change selected information about the selected field’s properties. You can modify the field’s Location, Text Style and Justification. The Value of the field can be modified using the **File » Design Info** command.

The following information about the selected field can be viewed:

- **Name**: The name of the existing field is displayed here.
- **Value**: The Value assigned to the field.
- **Flip**: The Flip box indicates whether or not the field has been flipped.
- **Rotation**: The Rotation field shows the rotation amount if the field has been rotated.

The following information about the selected field can be modified:

- **Text Style**: Choose text style from the list of styles that appear when you click the **down arrow** button.
- **Text Styles**: If the text style you need does not appear in the Text Style list, click the **Text Styles** button to display the *Options Text Style* dialog where you can define a new text style. For information on the *Options Text Style* dialog, see *Options Text Style* (page 482).
- **Location**: The current X and Y coordinates of the field’s location. You may enter new coordinates and the field will be placed in the new location when you exit the dialog by clicking **OK**.
- **Justification**: Choose the reference point of the field by clicking the desired button. For example, if you enable the middle button, the field reference point (the lower-left corner) moves to the center of the bounding rectangle of the field.
Design View Properties

A view of a specific region of your design, or design view, can be defined and placed in a new location. When you select a design view in the design and choose the Edit » Properties command, the Design View Properties dialog opens:

The Design View Properties dialog is identical in appearance to the Place Design View dialog. All fields are available for editing and use with the exception of the Define Region interactive tool. If the location of the Design view needs to be modified, you can enter the new X and Y coordinates directly into the appropriate boxes.

For additional information on the Design View dialog, see Place Commands (page 369).

Detail Properties

A scaled region of a PCB board, or detail, can be places as a graphic into your PCB design. When you select a places detail and choose the Edit » Properties command, the Detail Properties dialog opens:
Chapter 13: Edit Commands

Edit Properties

The Detail Properties dialog is identical to the Place Detail dialog. All fields are available for edit, with the exception of the File name.

For additional information on the Detail dialog, see Place Commands (page 369).

Diagram Properties

An annotated diagram depicting the stack-up of board layers can be generated and placed into the PCB design. When you select a placed diagram and choose the Edit » Properties command, the Diagram Properties dialog opens:

The Diagram Properties dialog is identical to the Place Diagram dialog. All fields are available for edit.

For additional information on the Diagram dialog, see Place Commands (page 369).
**Picture Properties**

An image in P-CAD picture format can be placed into your PCB design using the DocTool » Place Picture command. When you select a placed picture in your design and choose the Edit » Properties command, the Picture Properties dialog opens:

The Picture Properties dialog allows you to specify the Scale of the picture. Enter the scaling factor for the picture (values > 0). A scaling factor of 1 specifies no size change. A scaling factor greater than 1 specifies magnification. A selected picture object can be resized by dragging one of its vertex handles to the desired size.

**Table Properties**

Several tables can be generated and placed into your PCB design. When you select a table and choose Edit » Properties, the Table Properties dialog opens:

The Table Properties dialog is identical to the Place Table dialog. All fields are available for edit, with the exception of the Table Type. When the properties are modified, the table is automatically
updated. To update the information in the table if the design itself has been modified, choose DocTool » Update or DocTool » Update All.

**Dimension Properties**

When you select a dimension and choose **Edit » Properties**, the *Dimension Properties* dialog appears as follows.

The *Dimension Properties* dialog lets you view information about the selected dimension’s properties. You can modify the dimension’s Text Style and Line Width.

Information about the selected field includes:

- **Style**: Shows the dimension style entered in the *Place Dimension* dialog.
- **Units**: Displays the measuring units of the dimension.
- **Layer**: Indicates the layer on which the dimension has been placed.
- **Precision**: Indicates how many numbers are displayed after the decimal point.
- **Symbol Size**: Shows the selected size of the symbol for a Leader style dimension.
- **Center Size**: Shows the selected center size for the center of the symbol.
- **Display Units**: Select this check box to turn on the display of the specified Unit.
- **Display Diameter Symbol**: Select this check box to turn on the display of the Diameter Symbol.
- **Suppress Leading Zeros**: Select this check box to turn off the display of leading zeros in the dimension’s value.

- **Suppress Trailing Zeros**: Select this check box to turn off the display of trailing zeros in the dimension’s value.

- **Associated Dimension**: Select this check box to associate the dimension with the objects it is measuring.

**Points**
The Points frame displays the points upon which the dimension is built. The numbers include the dimension endpoints and text location.

**Text Styles**
The Text Styles frame displays the current text style. To change the style, click **Text Styles** to open the Options Text Style dialog. From this dialog you can add, delete, rename or edit text styles. For more information, see Options Text Style (page 482).

**Line Width**
The Line Width frame displays the current value of the line width. To change the line width, click **Line Width** to open the Options Current Line dialog. From this dialog you can edit the current line width. For more information, see Options Current Line (page 457).

**Arrowhead**
The Arrowhead frame displays, and allows you to change, the Length and Width of the dimension’s arrowhead.

**Tolerance**
The Tolerance frame displays, and allows you to change, the Positive and Negative Tolerance values. To turn on the display of the tolerances, select the **Display Tolerance** check box. The tolerance is always displayed with 4 digits, unless the Suppress trailing Zeros option is enabled.

---

**Edit Delete**

Choose **Edit » Delete** to delete all selected objects. As a shortcut for choosing this command, you can press the **DEL** key.

Choosing this command does not move the selected data to the Clipboard, as does **Edit » Cut**. As there is nothing to paste, the only way to reverse a delete action is to use the **Edit » Undo** command.

**Delete Objects**

1. Choose **Edit » Select** (or click the toolbar button or press the **S** key).
2. Select the object you want to delete.
Choose **Edit > Delete** (Or press the **DELETE** key, or right-click and choose **Delete** from the shortcut menu). If you inadvertently delete an object, choose **Edit > Undo** to reverse the delete action.

This operation can also be performed with multiple objects by using multiple select and block select operations. See **Edit Select** (page 356).

### Deleting Objects from Nets

When you delete objects from nets, you can get a variety of results, depending on what you delete and the makeup of the net you delete from. The function of smart nets is to maintain certain connections when objects such as copper connections, unrouted connections, and net nodes are deleted. In general, the following can occur.

- If you delete free copper (no connections), then the copper disappears and no connection compensation occurs.
- If you delete a connection to a jumper pad, hidden connections to other jumpered pads are removed.
- If you delete a connection to a jumper pad and no other net objects are connected to any of the jumpered pads, then all jumpered pads are removed from the net.
- If you delete a node, then the remaining nodes are still part of the net, and there is compensation to maintain connections between the remaining nodes.
- If you delete a component, you are removing nodes from all nets to which the component’s pads were connected. The connectivity feature of PCB reconnects the remaining nodes in each net in the most efficient way.
- If you delete a connection from the middle of a net, the net is split. One portion retains the original net name and the others are given new system-generated names. For example, in the following example the net has three connections: ab, bc, and cd. If you delete connection bc, you cut the net into two nets: ab and cd.

```
a ─── b
c   └── d
```

- If you delete a connection that isolates a pad from the rest of the net, you end up with a disconnected node that is no longer part of any net. For example, in the above figure, if you delete connection cd, the node d becomes isolated from the net.
• If you delete a copper segment that is part of a net, that segment is not deleted, but instead becomes a connection (in effect unrouting the net. In this case, the net remains intact, although changed).

**Edit Copy Matrix**

Choose **Edit » Copy Matrix** to duplicate all of the selected objects according to the parameters you specify. The objects must be selected before the **Edit » Copy Matrix** command is available.

When you choose **Edit » Copy Matrix** the following dialog appears.

![Edit Copy Matrix dialog](image)

In the **Edit Copy Matrix** dialog, the Number of Columns and Number of Rows determine the number of X (horizontal) and Y (vertical) duplications, respectively, of a selected object.

In the Column Spacing and Row Spacing, you can enter a value, in current units, to determine the spacing between the duplicated objects. With column spacing, a positive value duplicates to the right, a negative value to the left. With row spacing, a positive value duplicates up, a negative value down. For example, if you specify 200 mil for Column Spacing and 200 mil for Row Spacing (and specify 3 rows and 3 columns), the result is a matrix with 9 objects 200 mils apart, as shown in the following illustration.

```
  
  
```

The values represented default to mm (millimeters) or mil, depending on what you have set in Options Configure (your current units). You can specify a measurement value (overriding Options Configure) by typing in mil, mm, cm, or in after the numeric value.

**Duplicating an Object(s)**

To duplicate objects, do the following:

1. Choose **Edit » Select**. Then, select the object(s) you want to duplicate.
2. Choose **Edit » Copy Matrix**. The Edit Copy Matrix dialog appears.
3. In the Number of Columns box, specify how many duplications you want to perform horizontally. In the Column Spacing box, enter a value to determine the spacing between duplications and in which direction (positive=right, negative=left) to duplicate.

4. In the Number of Rows box, specify how many duplications you want to perform vertically. In the Row Spacing box, enter a value to determine the spacing between duplications and in which direction (positive=up, negative=down) to duplicate.

5. An error message appears if what you specify for your duplication is too large to fit in the workspace.

6. Click **OK**. If you are not satisfied with the object you duplicated, choose **Edit » Undo** to reverse the action and try again.

P-CAD PCB (6/400) designs are restricted to a maximum of 400 components. Therefore, when using P-CAD PCB (6/400), do not exceed this number when duplicating components in your design.

---

**Edit Explode Component**

Choose **Edit » Explode Component** to convert a component back to its basic primitives, creating a collection of editable graphic objects. When you explode a component, the collection of objects is no longer a component or a pattern.

You cannot explode a fixed or exploded component.

This feature is useful for modifying an existing component or creating a new pattern/component from an existing one. After you explode the component, you can then perform changes to the objects such as adding more pads, adding test points, changing line size or thickness, renumbering pin designators, etc. In addition, the default pin designators are updated with the value of the current pin designators after exploding.

**Exploding a Component**

To explode a component, do the following:

1. Click the **Select** button on the toolbar or choose **Edit » Select** to enable the select tool.

2. Select the object that you want to explode and choose **Edit » Explode Component**. The component becomes a collection of modifiable objects.

To create a component again, you must save the objects as a pattern. To do this, select the objects and choose **Library Pattern Save As**. Then, attach the pattern to a component in P-CAD Library Executive.

If you inadvertently explode a component, choose **Edit » Undo** to reverse the action.

---

**Edit Alter Component**

Choose **Edit » Alter Component** to move, rotate, flip, or delete selected objects.
With these editing processes you can alter certain component characteristics either for aesthetic reasons or manufacturing improvement, such as avoiding any co-location problems during manufacturing (e.g., through-holes and silkscreen paint). The rules/restrictions are as follows:

- Pads cannot be selected, and therefore cannot be edited in any way.
- When the Allow Single Select on All Enabled Layers check box is selected in the Mouse tab of the Options Preferences dialog, selections across enabled layers are done in the following order:
  1. Current layer items.
  2. Multi-layer items; i.e., all-layer keepouts, pads, vias, connections and points.
  3. All other layer items in order.
     - Reference designators (RefDes), Type, Value and reference points (RefPoints) cannot be deleted. However, you can hide the following items:
       - To hide the RefDes, Value, or Type: Select the component and choose Edit » Properties. Then, clear the corresponding Visibility check box in the Pattern tab.
       - To hide glue dot and pick and place points: Choose Options » Display and click the Miscellaneous tab. Then, choose the appropriate Hide option button.
       - You cannot undo any alter actions until the operation is complete.

Altering a Component

To alter a component, follow these steps:

1. Choose Edit » Select. Then, select the component you want to edit.
   
   You may enable the Allow Single Select on All Enabled Layers option in the Mouse tab of the Options Preference dialog or by pressing the CTRL+L keys, to select a component across enabled layers.

2. Choose Edit » Alter Component. When the cursor takes the shape of a crosshair cursor, you are in edit mode.

3. Zoom in sufficiently. Change layers if necessary. You can select items individually if you are on the correct layer or you use a block select. The settings in Options » Selection Mask can affect your results here.

   Editable items typically reside on the Top Silk layer, except for Ref Points, which are not layer items, but this depends on how the pattern was originally created.

4. After you have selected individual item(s), you can then move, delete, or otherwise alter them (according to the restrictions mentioned previously). Right-click or press ESC to end the editing mode.
Chapter 13: Edit Commands

Edit Align Components

Components can be aligned around a selection reference point either horizontally or vertically, and as an option, the components can be equally spaced. If a number of components are off-grid, these components can be aligned back on-grid.

- The alignment of components is undoable.
- The alignment of components has full macro support.

This command does not work on fixed components.

Align Horizontally or Vertically

To align a component, follow these steps:

1. Select the components to align. The Edit » Align Components command becomes available.
2. Right-click and choose Selection Point from the shortcut menu. Then, place a selection reference point, which is a point about which the components will be horizontally or vertically aligned.
3. Choose Edit » Align Components. The Edit Align Components dialog appears. Without selecting a selection reference point, the alignment and component spacing options are shaded.
4. Select either horizontal or vertical alignment.
5. To align the components with equal spacing, select the Space Equally check box and enter the Spacing value. The spacing value is the distance between the reference points of the components.
6. Press OK and the selected components will be aligned.

Align to Grid

To align a component to grid do the following:

1. Select the components. Only components can be selected for this command to be enabled.
2. Choose Edit » Align Components. The Edit Align Components dialog appears.
3. Click OK and the selected components are aligned to grid. Each selected off-grid component is moved to the nearest grid point.

**Edit Select All**

Choose **Edit » Select All** to selects all items on all enabled layers.

**Edit Deselect All**

Choose **Edit » Deselect All** to cancel the selection of all items.

**Edit Highlight**

Choose **Edit » Highlight** to highlight selected objects. To highlight an item in your design, select an object and then choose **Edit » Highlight**. The object is highlighted in the current highlight color.

To change the highlight color, choose **Options » Display**. In the Colors tab, click **Highlight** and choose a new color. When you close the dialog, notice that the color change does not affect existing highlighted objects, unless a highlighted object was selected when you performed the color change.

When you highlight objects, they retain the highlight color until they are unhighlighted. When you select a highlighted object, the selection color overrides the highlight color, so you won’t see the highlight color until the items are deselected.

You can also highlight objects using the shortcut menu. To do this, select an item or items. Then right-click and choose **Highlight** from the shortcut menu.

**DDE Hotlinks**

If PCB and P-CAD Schematic are both running, and if the **DDE Hotlinks** check box in the **Options Configure** dialog is selected in both programs, then component and net highlight information is communicated between the two programs. Highlighting a net in one program highlights the corresponding net in the other program; highlighting a pattern in PCB highlights the corresponding symbol(s) in P-CAD Schematic and vice versa.

If you change the highlight color of an object in P-CAD PCB, the same object in P-CAD Schematic is automatically updated with the same highlight color.

**Edit Unhighlight**

Choose **Edit » Unhighlight** to remove the highlighting from the selected item or items and restores the normal object colors.

If PCB and P-CAD Schematic are both running, and if the **DDE Hotlinks** check box in the **Options Configure** dialog is selected in both programs, the highlight color is removed from the selected items in both programs.
You can also gain access to this command by selecting an item or items and then right-clicking to bring up the shortcut menu, and choosing Unhighlight.

### Edit Unhighlight All

Choose **Edit » Unhighlight All** to remove the highlight from all items on all layers in the design and to restore the normal object colors. This command applies to all highlighted objects, regardless of whether they are selected or not.

If PCB and P-CAD Schematic are both running, and if the **DDE Hotlinks** check box in the Options Configure dialog is selected in both programs, the highlights are removed in both programs.

### Edit Select Highlighted

Choose **Edit » Select Highlighted** to select all highlighted objects. This is useful when you want to edit a group of highlighted objects.

Your block selection criteria determines which highlighted objects are selected when you use this command. To set block selection criteria, see Options Selection Mask (page 423).

If an item within a component is highlighted, it will not be selected when you choose the **Edit » Select Highlighted** command. For example, if you highlight two pins within a component and then choose **Edit » Select Highlighted**, neither the pins nor the component will be selected.

If any items are selected, but not highlighted, when you choose **Edit » Select Highlighted**, those items remain selected. For example, highlight three components on a layer and then select another component, but do not highlight it. Now, choose **Edit » Select Highlighted**. P-CAD PCB selects the three highlighted components, and the other component remains selected.

### Edit Fix

Choose **Edit » Fix** to fix and unfix objects in their locations in the design. Fixed objects cannot be moved, rotated, flipped, cut, deleted or resized.

When you choose **Edit » Fix**, the menu contains a sub menu, as shown in the figure on the left. Choose the appropriate command from the sub menu.

#### Edit Fix

Choose **Edit » Fix** to secure the selected objects in their location in the design and prevents them from being moved, rotated, flipped, cut, deleted or resized.

#### Edit Unfix

Choose **Edit » Unfix** to release the selected, fixed objects from their secured location, allowing them to be moved, rotated, flipped, cut, deleted or resized.
Edit Unfix All

Choose Edit » Unfix All to release all fixed objects in the design.

Edit Rooms

Choose Edit » Rooms to edit rooms that exist in your design. When you choose Edit » Rooms, the Edit Rooms dialog appears. This dialog gives you the ability to find and select the components included in the selected rooms.

When one or more Rooms are selected, the Edit Rooms dialog displays the following information:

- **Rooms**: The Rooms list contains the names of the Rooms in the design.

- **Included Components**: The Included Components lists the components that have been assigned to the selected Rooms. When multiple Rooms are selected, the Included Components list contains the components included in all of the selected Rooms. The Included Components list is blank when a Room with no included components is selected.

- **Properties**: Click Properties to open the Properties dialog for the Rooms in the design. In the Room Properties dialog you can assign components to the Included list, set the Placement Side and Fill Pattern and Fix the room to its location. See Room Properties (page 325) for more information.

- **Highlight/Unhighlight Rooms**: Click Highlight to display the selected rooms in the highlight color set in the Colors tab of the Options Display dialog. The Unhighlight button returns any highlighted rooms to its normal display color.

- **Highlight Included/Unhighlight Included**: Click Highlight Included to display the components included in all of the selected rooms in the highlight color set in the Colors tab of the Options Display dialog. The Unhighlight Included button returns the highlighted, included components to their normal display color.
• Set All/Clear All: Click Set All to select all rooms and the Clear All button to cancel the select of all rooms.

Edit Components

Choose Edit » Components to edit the components in your design and to jump to a particular component. With this command, you can also highlight components and to highlight nets attached to a particular component.

Choose Edit » Components to open the following dialog.

Components List Box

The Components list contains the names of all components in the active design. You can select individual or multiple components in the list. Once selected, you can highlight and unhighlight components and attached nets and jump to a component.

Set All/Clear All

If you want to select all components in the Components list, click Set All. If you don’t want any components selected, click Clear All.

Properties

Click Properties to open the Component Properties dialog for the selected component or components. For details, see Edit Properties (page 292).

Highlight/Unhighlight

The Highlight button highlights one or more components selected from the Components list in the current highlight color set in the Colors tab of the Options Display dialog. You can use this feature...
to highlight objects using different colors. When you change the highlight color of one object, it
does not affect the highlight color of other highlighted objects, which are not selected.

When you choose this command, the chosen components are drawn in the highlight color until
they are unhighlighted. The selection color overrides the highlight color, so you won’t see the
highlights until the components are deselected.

Component highlight information is communicated between the two programs when the following
is true:

- Both PCB and P-CAD Schematic are running.
- The DDE Hotlinks check box in General tab of the Options Configure dialog is selected in both
  programs.

Highlighting a component in PCB highlights the corresponding part in P-CAD Schematic. If you
change the highlight color of an object in P-CAD PCB, the same object in P-CAD Schematic is
automatically updated with the same highlight color.

The Unhighlight button removes the highlighting from the selected components.

**Highlighting an Attached Net**

You can highlight nets, which are attached to the components selected in the Components list.

1. To highlight attached nets, select one or more components from the Component list (or, click
   Set All to select all components in the list),
2. Click Highlight Attached Nets to highlight all segments of the attached net, including lines,
   polygons, arcs, copper pours, pads and vias. The attached nets are highlighted in the highlight
color set in the Colors tab of the Options Display dialog.
3. To remove a highlight, select one or more components from the Component list.
4. Click Unhighlight Attached Nets.

**Jumping to a Component**

To jump to a component, do the following:

1. Select one component from the list. The Jump button is shaded if more than one component is
   selected.
2. Click Jump to jump to the specified component. The specified component appears in the
   center of your workspace.

**Edit Nets**

Choose Edit » Nets to show, hide, and rename nets, display net information, select net items, and
edit net attributes. With this command you can also view and highlight nets within your design,
view nodes attached to a particular net and to jump to a node. In addition, you can select one or
more nodes and modify their pad or via styles and delete them from the net.
When you choose Edit » Nets, the Edit Nets dialog appears.

![Edit Nets dialog](image)

The dialog contains the following options:

- **Nets**: The Nets list box contains the names of all nets in the active design. Directly beneath the Nets list are the command buttons, described below, that are used to set the nets you want to modify:

  - **Set All Nets**: Selects all the nets in the Nets list box.
  - **Clear All Nets**: Clears all selected nets.
  - **Set Nets By Attribute**: Opens the Set Nets by Attribute dialog where you can select one or more attributes, which, if present in a net, result in the net being set in the Nets list.
  - **Set Net By Layer Attributes**: Opens the Select Layer dialog where you can choose a specific layer whose attributes you want to use to set the nets.
  - **Set Nodes by Node Count**: Allows you to select nets with a nod count between the range specified in the corresponding Min and Max edit boxes.

- **Nodes**: The Nodes list box contains the names of all nodes in the net(s) selected in the Net Names list box along with the Pad Styles for each node. Directly beneath the Nodes list are the command buttons, described below, that are used to set the nodes you want to modify:

  - **Set All Nodes**: Selects all the nodes in the Nodes list.
  - **Clear All Nodes**: Clears all node selections.
• **Jump to Node**: Positions the cursor over a single, selected node, which is placed in the center of the workspace.

• **Pad Properties**: Opens the Pad Properties dialog when one or more nodes are selected. From the Pad Properties dialog, you can click the Pad Styles button to open the Options Pad Style dialog and make changes to the selected node(s) properties.

• **Remove Nodes**: When one or more nodes from one or more nets are selected in the Nodes list box, you can disconnect those nodes from the net by clicking the Remove Nodes button.

When using the Pad Properties dialog to change the style properties for selected nodes remember that the changes you make are applied to all the selected nodes.

The left side of the Edit Nets dialog contains a number of command buttons, which allow you to rename nets, show connections, highlight nets and modify net attributes. The buttons are:

• **Rename**: Allows you to rename the selected net. If more than one net is selected, the Rename button is grayed and unavailable.

• **Info**: Displays net information for the selected net. The Net Information dialog displays detailed information about length and characteristics of the selected net.

• **Edit Attributes**: Allows you to add and edit net attributes. When you click the Edit Attributes button, the Attributes dialog appears. For details, see Edit Attributes (page 350).

You can view, add, modify, or delete a collection of net attributes. The dialog contains a two-column table showing the collection of net attributes. Within the collection, each attribute’s name and value appear in the column.

• **Edit Net Layer Attributes**: Allows you to select and edit the net attributes for a specific layer. When you choose Edit Net Layer Attributes, the Edit Net Layer Attributes dialog appears:

The Edit Net Layer Attributes dialog lists the layers and indicates whether the layer has Attributes with an asterisk. You can select layers having a specific attribute by clicking the Select by Attribute button to display the Set By Attribute dialog. See Set By Attribute (page 349).

You can also modify layer attributes by clicking the Edit Layer Attributes button. See Edit Attributes (page 350).
• **View » Attributes**: Opens the Windows Notepad utility and displays a list of attribute names and values for each selected net.

In conjunction with the **Set Nets By Attributes** button, the **View** option makes it easy to find nets with the same attribute value, and then view all attribute values for those nets.

• **Show Conns**: Displays the connections for the net(s) in the list box. A check in the check box in front of the net name means the connections are visible.

• **Show Conns Only on Drag**: Displays the connections for the net(s) selected in the list box when you drag a component within the net. An opaque check box in front of the net name means the connections are visible only when you drag a component.

• **Hide Conns**: Hides the connections for the net(s). An empty check box in front of the net name means the connections are invisible.

• **Highlight**: Highlights selected nets in the current highlight color chosen through the **Options » Display** command. All items of a selected net, including lines, polygons, arcs, copper pours, pads and vias, are highlighted by the **Highlight** command.

You can use this feature to highlight objects using different colors. When you change the highlight color of one object, it does not affect the highlight color of other highlighted objects, which are not selected.

When you choose this command, the selected nets are drawn in the highlight color until they are unhighlighted. The selection color overrides the highlight color, so you won’t see the highlights until the nets are deselected.

If PCB and P-CAD Schematic are both running, and if the **DDE Hotlinks** check box in the **Options Configure** dialog is checked in both applications, then net highlight information is communicated between the two applications. Highlighting a net in one application highlights the corresponding net in the other application.

• **Unhighlight**: The Unhighlight button removes the highlighting from the selected nets and restores the normal object colors.

If PCB and P-CAD Schematic are both running, and if the **DDE Hotlinks** check box in the **Options Configure** dialog is checked in both applications, the highlights are removed from the selected nets in both applications.

• **Select**: Allows you to select a net or multiple nets in the design by highlighting the net names in the list box in the **Edit Nets** dialog, then clicking the **Select** button (the button is enabled only if a net is chosen). The nets in the design will highlight.

The performance of Select Net is directly affected by the settings in **Options » Selection Mask**. For example, you could configure **Options » Selection Mask** to allow you to select line segments in a net while ignoring the vias (it ignores the inside/outside block specifications), allowing you to modify line widths for all segments in a net.

This feature is useful for narrating a design (net by net) by highlighting routed copper items and deleting them. Be careful to disable selection of connections when unrouting nets. If a connection is deleted, the corresponding net is changed or destroyed.
Set By Attribute

When you click **Set Nets By Attribute**, the **Set By Attribute** dialog appears.

If you select an attribute from the Name=Value list and click **OK**, you are returned to the *Edit Nets* dialog where all nets that have the selected attribute defined are highlighted in the Nets list.

Selecting an attribute from the list allows you to find all nets containing that attribute, regardless of the attribute value. If you want to find nets with attributes with a specific value, select an attribute from the Name=Value list and click the **Change Value** button to display the *Change Attribute Value* dialog:

The *Change Attribute Value* dialog lists all values assigned to the selected attribute and also includes the option to select *(Any Value)*. Select the desired Value and click **OK** to return to the *Set By Attribute* dialog.

To set all of the attributes, click the **Set All** button. To clear the selected attributes, click the **Clear All** button. Choose the **Clear Current Items** check box if you want to remove previously selected items each time you modify your selection criteria.

You can also select multiple attribute names and values in the Name=Value list. When you return to the *Edit Nets* dialog, only those nets with all of the selected attribute names and values are highlighted (i.e., the Nets list is cleared first.) Otherwise, those nets are added to the list of highlighted nets.
Set Nets By Layer Attribute

To set nets by layer attributes, click Set Net By Layer Attribute to open the Select Layer Name dialog shown in the following figure:

Select the layer whose attributes you want to use to set the nets. When you click OK, the Set By Attribute dialog appears and you can select the desired attributes and values. For more information on the Set By Attribute dialog, see Set By Attribute (page 349).

Rename Nets

When you highlight a single net name in the Nets list, the Rename button becomes active. Click Rename and the following Net Name dialog appears.

Type in the new name and click OK to rename the net and return to the Edit Nets dialog.

Edit Attributes

Click Edit » Attributes to display and modify net attributes for the selected component. When you click this button, the following dialog appears:
You can view, add, modify, or delete a collection of net attributes. The dialog contains a two-column table showing the collection of net attributes. Within the collection, each attribute’s name and value appear in the column.

- **Adding attributes**: To add an attribute, click the **Add** button. The *Place Attribute* dialog appears, which is similar to the *Attribute Properties* dialog shown in the following figure, except that you can choose the desired Attribute Category and Name, and the Name and Value text boxes can be changed. To add a pre-defined attribute, choose the desired category and attribute name and enter the attribute values. To define a new attribute, choose the {user-defined} attribute and type the Name and Value for the attribute. Click **OK**, and the attribute is added to the table. For instructions, see *Place Attribute* (page 396).

- **Viewing or changing attribute properties**: To view or change an attribute’s properties, select an attribute from the table and click the **Properties** button (or double-click the attribute) to open the *Attribute Property* dialog (shown in the following figure).

- **To delete an attribute**: Highlight an attribute in the table and click **Delete**, or press the **DEL** key.

- Launching a reference link: When the special attribute Reference, whose value is a reference link, is added to the item, you can select the Reference attribute and click **Launch** to start an program or web address to display a document or web site.

**Attribute Property Dialog**

The *Attribute Properties* dialog appears as follows:
The following information appears in the dialog:

- **Category list**: Displays a list of all attribute categories, All, Component, Net, Clearance, Physical, Electrical, Placement, Manufacturing, Router, and SPECCTRA. Selecting a category brings up a list of predefined attributes for that category.

- **Name list**: Displays all predefined attributes for the specified category. The first entry in the list is User-defined. The currently-selected attribute also appears in the Name text box, unless User-defined is selected. In that case, the Name text box is blank so that you can enter a user-defined attribute name.

- **Name Text Box**: For user-defined attributes, enter a name for the attribute.

If the dialog is accessed for an attribute that already has a name, then the Category list, Name list, and Name text box are filled in, but shaded. If the attribute doesn’t have a name, these options are enabled.

- **Value**: Use this text box to enter a value for the attribute.

The following items appear shaded in the dialog:

- **Visible**: This check box indicates whether or not the attribute is visible.

- **Location**: This area shows the X and Y coordinates of the component’s reference point.

- **Text Style**: This area lets you select the attribute text style. Text styles appear in the Text Style list. To change the selected Text Style, click on the text style you want from the list. To modify the text style, click the **Text Style** button.

- **Rotation**: Shows the rotation amount if the pattern has been rotated.
- **Flipped**: This check box indicates whether the pattern has been flipped or not.
- **Justification**: Under Justification are nine buttons, which allow you to change text justification by setting the reference point of the text string. For example, if you enable the middle button, the text reference point (the lower-left corner) moves to the center of the bounding rectangle.

**Attribute Description for Autorouting**

The following attributes are recognized by the autorouter. All other predefined net attributes are ignored for routing.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WIDTH</td>
<td>Overrides global line width settings for the selected nets. A valid line width should be entered as the value.</td>
</tr>
<tr>
<td>VIASYLE</td>
<td>Overrides global via style settings for the selected nets. An existing via style name should be provided.</td>
</tr>
<tr>
<td>MAXVIAS</td>
<td>Defines the maximum number of vias that can be placed for this net. Valid values are 0 (no vias) - n (any specific number).</td>
</tr>
<tr>
<td>RIPUP</td>
<td>Overrides the global ripup setting for the selected nets. Valid values are No, 0 and False. All indicate that the net should not be ripped up. You can use Yes, 1, and True.</td>
</tr>
<tr>
<td>NOAUTOROUTE</td>
<td>Indicates that the selected nets will not be routed. You can use Yes, 1, and True.</td>
</tr>
<tr>
<td>AUTOROUTEWIDE</td>
<td>Indicates that the selected nets are scheduled as WIDE passes when you select passes manually. You can use Yes, 1, and True.</td>
</tr>
</tbody>
</table>

**Clearance Attributes**

Along with other predefined net attributes, which are available from the Names list, the following clearance attributes are available:

- **PADTOPADCLEARANCE**
- **PADTOLINECLEARANCE**
- **PADTOVIACLEARANCE**
- **LINETOLINECLEARANCE**
- **LINETOVIACLEARANCE**
- **VIATOVIACLEARANCE**
- **CLEARANCE**
In addition to the attributes listed above, a DRC error is reported whenever a line, arc or via touches a keepout. An error indicator is displayed in the design and an error explanation appears in the DRC report.

By adding one of these attributes to a net and assigning it a value, the matching global default clearance is overridden for DRC. The value may have a suffix to define the units. If the units are left off, then the current global units are used. If the clearance value can’t be converted to a valid number for DRC or auto routing, then the attribute is considered undefined and the corresponding global clearance is used.

The last predefined attribute, CLEARANCE, defines a clearance value for all object pairs in this net. For example, if the net-specific clearance between every object pair in a net is the same value, then the CLEARANCE attribute can be used to store that value. This eliminates the need to assign the same value to each of the six clearance attributes.

PCB PRO Route honors the clearances for all object pairs, but doesn’t use the clearance attributes defined in specific nets. The log produced by PCB PRO Route includes the clearance values used for all object pairs. QuickRoute clearances are set to approximately 1/2 of the routing grid. The SPECCTRA autorouter uses net specific clearance attributes, net class clearance attributes, and class to class clearance attributes.

Pad Properties

When a node is selected in the Nodes list, you can open the following Pad Properties dialog by clicking Pad Properties.

The Pad Properties dialog is explained earlier in this chapter in Edit Nets (page 345). Remember that any changes made in this dialog are uniformly applied to all the selected nodes.
Info Button

When you highlight a single net name in the Nets list, the Info button becomes active. Click Info to open the following Net Information dialog.

This dialog displays detailed information about length and characteristics of the selected net. It only measures the X and Y distances, not depth (such as via length to another layer). Arc length is included (accurately) in the calculation of connection and copper lengths. The Manhattan length is an approximation of the final routed length of a diagonal connection.

Edit Measure

Choose Edit » Measure to measure the X distance, Y distance, and total distance between two points. As a shortcut for choosing this command, click the Ruler button on the toolbar.

You can measure vertical, horizontal, and diagonal distances and the results appear on the Status Line. The measurements are in either mils or millimeters, depending on current settings in Options Configure.

Measure is a mode, meaning that if you were placing or selecting objects, when you use Measure you exit the mode to go into measure mode. After you have measured, you need to restart whatever mode you were in to resume editing.

1. Choose Edit » Measure or click the toolbar button.

2. Press and hold down the mouse button where you want to start the measurement. Then, drag the mouse cursor to the end point of the measurement and release the mouse button.

3. The measure line and the results stay until you perform another measurement of choose another command.

Measurements do not snap to grid if the View » Snap to Grid command is disabled.
Edit Select

Choose Edit » Select to enable the select tool (a.k.a., select mode). With this tool, you can perform operations on objects and items in your design. As a shortcut for choosing this command, click the toolbar button or press the S key.

Select Actions

- single-, multiple-, block-select, or subselect
- move, resize, rotate, flip, copy, modify, highlight, unhighlight, and delete

When you select an item, the Status Line information area identifies the item, either specifically (part reference designator) or generally (number of items selected).

Select Commands

The following commands are available when you are in select mode: Edit » Cut, Edit » Copy, Edit » Copy to File, Edit » Paste, Edit » Paste from File, Edit » Paste to Layer, Edit Select All, Edit Deselect All, Edit Delete, Edit Highlight, Edit Unhighlight, Edit » Copy Matrix, Modify, and Edit Explode Component. In addition, the Net Info and Select Net commands are available from the Select shortcut menu. To open the shortcut menu, select the item and then right-click, or choose Edit » Nets.

Select actions are possible only if an object is selected. For example, you cannot move an arc unless it has been selected.

Information included in this section only covers the mouse/cursor actions for Select.

Selecting Objects

To single select, click a single object; all other selected objects are deselected. You must be on the appropriate layer if the Allow Single Select on All Enabled Layers check box in the Options Preferences Mouse tab is not selected.

To select multiple objects, first select a single object, then hold down the CTRL key and click on additional objects/items. The selected objects are surrounded by a selection box, which increases as you add items to the multiple selection. Click again on selected items (still using the CTRL key) to deselect them individually. To cancel the selection of all items, release the CTRL key and click anywhere other than one of the selected objects.

To cancel the selection of all items, click an empty area of the workspace to cancel the selection of all items outside the selection region. Or, choose Edit Deselect All to cancel the selection of all items.

To block select a group of items, press and hold down the left mouse button. Then, drag the cursor across your workspace to draw a bounding outline around a range or items. Then, release the mouse button to select any items that match your current block selection criteria. You can add objects to the block selection individually by doing a multiple select (see above paragraph). To cancel while dragging the selection box, right-click.
If you choose the Outside Block option (with the Options » Selection Mask command), then the selection occurs outside of the selection block. If you have the Touching Block option enabled, a block selection includes everything inside and touching the selection block.

A block selection mask can be used. Objects can be filtered or masked in a variety of ways, depending on how you set up the selection options. Choose the Options » Selection Mask command to alter or set the selection options. The selection mask can be setup to select components on the Top layer only or the Bottom layer only.

To subselect, hold down the SHIFT key and click the part of the object you want to select. This allows you to select a single object, which is part of another object (e.g., a single pad in a component or an island in a copper pour).

**When Objects Overlap**

When objects overlap, it may seem difficult to select an underlying object. Continue clicking without moving the cursor and Select cycles through all objects underneath the cursor.

The SPACEBAR is easier to use than the mouse in this situation (pressing the SPACEBAR twice equals click and release for the left mouse button). For multiple select, press and hold down the SHIFT key, then click the left mouse button without moving the mouse.

**Moving and Copying Objects**

To move an object, select it, then click the object and drag the cursor to the new location. Release to place the object.

If you are moving multiple objects within a selection box, click anywhere in the selection box and drag; all the selected objects in the box follow. Release the button to place the objects.

You can copy objects in the same manner; after you select the object(s), hold the CTRL key and left mouse button and drag a copy of the object(s) to where you want to place it. When copying a component, the RefDes (reference designator) will change in the copy, and connections will not copy. Any copper that is copied becomes free copper that is not associated with any net.

To cancel a move or copy in progress, hold down the left mouse button and right-click. Then, release the left mouse button.

**Resizing Objects**

You can resize a selected object by clicking one of its handles, and dragging to stretch the object. The resize function varies for the different objects.

For example, to resize an arc you click one of the endpoint resize handles and drag the endpoint to increase the sweep angle. To resize a polygon, you can grab one of its vertex handles and move it to change the polygon.
When you move a handle that is on an edge between two vertices, a new vertex is created (allowing you even more reshaping). You can delete a vertex by moving it to an adjacent vertex and releasing.

Lines, Arcs, Polygons, Copper Pours, Keepouts, Rooms and Cutouts can be resized with the select mode resize function.

**Rounding Corners of Polygonal Shapes**

The corners of polygonal shapes (polygons, copper pours, polygon keepouts, cutouts and planes) can be rounded. The rounded corner forms a filleted edge, which is the rounded intersection of two edges. This intersection of the two edges is created with an arc of a specified radius that is tangential to both edges.

A new radius can be added by entering it directly into the Radius combo box on the Status Line or by choosing **Options » Current Radius** and entering the new values in the **Current Radius** dialog. You can select the desired radius from those in the Radius drop-down list on the Status Line. The radius displayed in the combo box is the current setting.

When a polygonal shape has filleted corners additional handles appear in the shape as shown in the following figure:

![Polygonal Shape with Filleted Corners](image)

To change the radius of a filleted corner, grab the interior handle and drag it until you see the desired radius for the corner. The radius displayed in the Radius combo box on the Status Line affects the polygonal shape at the time of placement or during modifications. You can also access radius settings by double clicking the polygonal shape to display the **Properties** dialog where you can make modifications to the definition or filleted points.

**Rotating and Flipping**

Select an object. Press **R** to rotate 90 degrees counterclockwise. To flip the object in the X direction (about the Y axis), press **F** while the object is selected.

**SHIFT+R** rotates the object by the value specified in the Rotation Increment field of the **Options Configure** dialog (default is 45 degrees).

This function works on multiple- or block-selected objects as well.

---

**IMPORTANT:** When you flip a pad or component, pad characteristics on Top, Top Silk, Top Paste, and Top Mask layers are swapped by corresponding characteristics on the Bottom, Bottom Silk, etc. layers. All other layers are left alone. Perform the operation with caution.

**Modifying (Edit Properties)**

To modify an object’s properties, press **S** as a shortcut for choosing **Edit Select**. Then, select an object in your design and choose **Edit » Properties**. When the **Properties** dialog appears, you can modify the object’s properties.
You can modify the following objects: Components, Lines, Arcs, Pads, Vias, DRC error indicators, Copper Pours, Rooms and Text. Each entity is enabled in the same manner, but has its own particular Properties dialog and subsequent results. For information on modifying objects, see Edit Properties (page 292).

**Shortcut Menu Commands**

When you select an object and right-click, a shortcut menu appears. The shortcut menu provides you with access to frequently used menu commands. The options available in the shortcut menu depend on the object you select.

**Selection Reference Point**

The selection reference point is used with all select operations, such as moving, copying, rotating, flipping, or pasting. However, a selection reference point is not required for these operations. If one is not selected, PCB uses a default reference point.

The selection reference point is saved to the clipboard or to a block file and automatically restored when pasting from the Clipboard or block file. If the selection reference point is off-grid when a move operation begins, then it is automatically snapped to the nearest grid point and all the selected objects move the same relative distance.

The selection reference point is automatically erased when all the objects are deselected.

**Placing a Selection Reference Point**

To place a selection reference point, do the following:

1. Select the object or objects.
2. Right-click and choose Selection Point from the shortcut menu.
3. Press and hold down the left mouse button. Then, drag the ghosted outline of the selection reference point into position.
   
   Right-click to cancel placement of the selection reference point.
   
   Dragging the selection reference point over pads (within a pattern or free pads), vias, or ref points (within a pattern or free), causes the selection reference point to snap to that object’s center point. The shape of the selection reference point changes from a square to a diamond when it snaps to an objects’ center point. If the selection reference point does not snap to an object, then it moves to the nearest grid point.
4. Release the left mouse button to place the selection reference point. The selection reference point is redrawn in the selection color.
5. To move a selection reference point, repeat the steps to place a selection reference point.

**Radial Placement**

1. This function can be used for radial placement (e.g., of components). To do so, follow these steps:
2. Select the object to be radially copied.

3. Move the selection point to the point about which the object is to be rotated (right mouse down, and release the selection point).

4. Holding down the **CTRL** key, select the object, moving the mouse slightly so that the cursor snaps to the selection point (this copies the object), then release the **mouse button** and **CTRL** key.

5. Press **R** or **SHIFT**+**R** to rotate the copy.
CHAPTER 14

View Commands

Using the View Commands

Use the commands in the View menu to modify the view of the workspace to better pinpoint locations and objects in your design. You can also enable or disable the display of information and shortcut action buttons.

For more permanent adjustments to your display characteristics, such as color display and style changes to objects, see Options Commands (page 423).

View Redraw

Choose View » Redraw to redraw the view of your workspace. This command is useful when you make design changes and want to restore the screen or update your data. For example, you would choose View » Redraw to remove leftover traces or shapes that result from moving or deleting objects.

To interrupt a redraw, right-click or press ESC.

When you choose View » Redraw, the items that reside on the current layer are drawn last. For more information about layers, see Options Layers (page 450).

This command also causes collocated Top and Bottom layer items to be drawn in the correct order. For example, if the current layer is Top, all Top layer SMT pads of an edge connector are drawn on top all Bottom layer SMT pads in the edge connector. Other View/Zoom commands do not necessarily draw collocated pads in the correct order.

View Extent

Choose View » Extent to show the extent of all objects placed in the workspace. This command redraws the workspace such that all placed objects on enabled layers are visible. Any disabled layers are ignored.

P-CAD PCB User’s Guide 361
View Last

Choose View » Last to restore the previous view in your active window. For example, if you have the full design in view and then zoom in on an area, choose View » Last to restore the full design view.

If you choose to scroll, center, or redraw the design, the View » Last command will not restore the view that was visible before the scroll, center, or redraw action.

View All

Choose View » All to redraw the entire design workspace. The size of a workspace is set in the Options Configure dialog box.

When you start P-CAD PCB, View All is the zoom level that appears by default. Notice that the scroll bars don't appear at this zoom level.

View Center

Choose View » Center to redraw the screen using the cursor location as the relative center point.

When you choose View » Center, the cursor takes the shape of a magnifying glass. Move the cursor to a point on your design and click the workspace. The point where you click is centered on the screen. To cancel the zoom after the magnifying glass cursor appears, right-click or press ESC.

As a shortcut for choosing this menu command, move the cursor to a point in your design and press the C key. This is quick way to pan across your workspace, if you've selected the Autopan check box in the Options Configure dialog. You don't need to click the mouse button, just move the cursor to the point you want centered and press C.

View » Center is a temporary command. For example, if you choose Place » Pad and then choose View » Center, the point where you click in the workspace becomes the center of the screen. Then, if you click again, you will place a pad, resuming the previous tool.

The selected point may not be in the center of the screen if you are near a workspace boundary.

View Zoom In

Choose View » Zoom In to zoom in by the current zoom factor set in the General tab of Options Configure.

When you choose this command, the pointer takes the shape of a magnifying glass. First, move the pointer over the area to zoom in on. Then, click the left mouse button. The cursor's position determines the center point of the zoomed-in area. You must choose View » Zoom In every time you want to zoom in on an area.

As a shortcut, press the plus (+) key. The current cursor location determines the center point of the zoomed in area.
**View Zoom Out**

Choose **View » Zoom Out** to zoom out by the current zoom factor set in the General tab of *Options Configure*.

When you choose this command, the cursor takes the shape of a magnifying glass. First, move the cursor over the area to zoom out on and then click the **left mouse button**. You must choose **View » Zoom Out** every time you want to zoom out on your design.

As a shortcut for choosing this command, you can press the minus (-) key. The current cursor location determines the center point of the zoomed out area.

To cancel a zoom action, **right-click** or press the **ESC** key.

**View Zoom Window**

Choose **View » Zoom Window** or click the **toolbar button** to zoom in on an area of the workspace. When you choose this command, the zoom window tool becomes active. You use this tool to draw a bounding outline around a selected region of your workspace.

As a shortcut for choosing this command, press the **Z** key.

**Using the Zoom Window**

To zoom to an area using the zoom window tool, follow these steps:

1. Choose one of these methods to enable the zoom window tool:
   - Click the **Zoom Window** toolbar button.
   - Press the **Z** key.
   - Choose **View » Zoom Window**.

   When the cursor takes the shape of a magnifying glass, you are in zoom mode.

2. Press and hold down the **mouse button**. Then, drag the cursor diagonally across the workspace. This draws a bounding outline around the region you select.

3. Release the mouse button when you’ve drawn your zoom window. The area enclosed within the bounding outline is enlarged.

**View Jump Location**

Choose **View » Jump Location** to move the cursor to a specific X,Y coordinate on your design. As a shortcut for choosing this command, press the **J** key and enter the coordinates in the X and Y coordinate text boxes on the Status Line.

If you are zoomed in, this command pans the workspace to the specified location, attempting to center the location. Your current zoom setting is not changed by the jump location panning.
(except View Last will be updated). If the specified location is already visible on the screen, no panning is necessary.

The units used for the location value (mil or mm) are determined by the setting in Options Configure. Choose Options » Configure to override the default settings.

The location is also based on the Options Grids setting, either Absolute or Relative; e.g., if your grid setting is in Relative mode, then the location is a Relative coordinate. Also, you can use negative coordinate values when in Relative mode. For more information, see Options Grids (page 439).

Jumping to a Location
1. Choose View » Jump Location. The View Jump Location dialog appears as follows:

   ![View Jump Location dialog]

2. Enter the coordinates you want to jump to in the X and Y boxes.
3. Click OK.

View Jump Text

Choose View » Jump Text to search for a jump to a text character or text string in your design. When you choose this command, a dialog box appears in which you enter your search criteria. You can also enable on or both of these search options:

- **Case Sensitive Search**: Select this check box to search for matching text based on case. If you clear this check box, text case is ignored in the search.

- **Search Entire Design**: Select this check box to search all layers for the matching text. Clear this check box to search only the current layer.

Jumping to Text

To jump to text, follow these steps:
1. Choose View » Jump Text. The following dialog box appears:

   ![View Jump Text dialog]

2. Enter your search criteria in the text box.
3. To search for matching text based on the case you entered, select the **Case Sensitive Search** check box.

4. To search all layers or sheets for the matching text, select the **Search Entire Design** check box.

5. Click **Search**. If P-CAD PCB finds a match, you jump to the location of that text. If there is more than one match, click **Next** to move to the next match.

6. Click **OK** to close the View Jump Text dialog box.

### View Command Toolbar

Choose **View » Command Toolbar** to show or hide the Command Toolbar. This toolbar gives you the ability to gain access to frequently used menu commands.

The toolbar is active and visible when **View » Command Toolbar** is a checked command. When no check mark appears next to the menu command, the toolbar is not visible. The following figure shows you the toolbar:

![Command Toolbar](image)

Choosing to hide the Command Toolbar increases the space within the active window. The state of the toolbar is saved in the **Pcb.ini** file when you quit the program, and restored when you restart it.

### View Placement Toolbar

Choose **View » Placement Toolbar** to show or hide the Placement Toolbar. The toolbar gives you the ability to gain access to frequently used Place menu commands. The following figure shows you the toolbar:

![Placement Toolbar](image)

Choosing to hide the Placement Toolbar increases the space within the active window. The state of the toolbar is saved in the **Pcb.ini** file when you quit the program, and restored when you restart it.

### View Route Toolbar

Choose **View » Route Toolbar** to show or hide the route toolbar. The toolbar gives you direct access to frequently used routing commands, such as Route Manual, Route Interactive, and Route Miter.

The following figure shows you the Route toolbar:
Choosing to hide the Placement Toolbar increases the space within the active window. The state of the toolbar is saved in the Pcb.ini file when you quit the program, and restored when you restart.

View Custom Toolbar

Choose View » Custom Toolbar to either show or hide the custom toolbar. A check mark next to the Custom Toolbar menu item indicates that the Custom Toolbar is visible.

If no tools have been added to the Custom Toolbar, the display of the toolbar is turned off. As soon as the first custom tool has been added using the Utils » Customize command in the Utils menu, the Custom Toolbar display is turned on. When custom tools exist in the Custom Toolbar, you can turn off the display of the toolbar by choosing View » Custom Toolbar.

View Prompt Line

Choose View » Prompt Line to show or hide the Prompt Line. A check mark next to the Prompt Line menu item indicates that the Prompt Line is visible. The following figure shows you the Prompt Line.

Press and release <Left> or <Space><Space> to select a component.

The Prompt Line is a message line that provides useful instructions when a tool is selected. For example, while you are in one of the Place object modes, it tells you what to do next, depending on what action you have already taken.

Choosing to hide the Prompt Line increases the space within the active window. The state of the Prompt Line is saved in the Pcb.ini file when you quit the program, and restored when you restart it.

View Status Line

Choose View » Status Line to either show or hide the Status Line. A check mark next to the Status Line menu item indicates that the Status Line is visible. The Status Line provides status information and allows you to change layers and execute temporary macros.

A check mark alongside the command indicates that the Status Line is visible. The following figure shows you the Status Line:
Choosing to hide the Status Line increases the space within the active window. The state of the Status Line is saved in the Pcb.ini file when you quit the program, and restored when you restart it.

**View Snap to Grid**

Choose View » Snap to Grid to enable or disable a snappy cursor. When a check mark precedes the command, a snappy cursor moves from grid point to grid point. When the command is not checked, a free floating cursor moves freely between grid points.

If View » Snap to Grid is disabled, P-CAD PCB uses a free-floating cursor. At times you may want to use a free-floating cursor to enhance your ability to select objects. For example, a line that does not run along true grid points may be easier to select with a free-floating cursor.

The snappy cursor is active when View » Snap to Grid is a checked command. When no check mark appears, P-CAD PCB uses a free-floating cursor.

The View » Snap to Grid command does not support the DataTips feature. When View » Snap to Grid is a checked command, the DataTips feature is temporarily disabled.

The state of the View » Snap to Grid command (ON or OFF) is saved in the Pcb.ini file when you quit the program, and restored when you restart it.
CHAPTER 15

Place Commands

Using the Place Commands

Use the commands in the Place menu to place various objects in a design. When you choose a Place command and click the workspace, one of the following occurs:

- P-CAD places an object at the cursor location (e.g., Place Pad).
- You can begin placing a segment (e.g., Place Line, Place Polygon).
- A dialog appears so you can define specific criteria for the type of object you want to place (e.g., Place » Component).

The Placement Toolbar provides shortcuts to the Place commands:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To choose this command</th>
<th>Click this button</th>
<th>To choose this command</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon1.png" alt="Button" /></td>
<td>Place Component</td>
<td><img src="icon2.png" alt="Button" /></td>
<td>Place Copper Pour</td>
</tr>
<tr>
<td><img src="icon3.png" alt="Button" /></td>
<td>Place Connection</td>
<td><img src="icon4.png" alt="Button" /></td>
<td>Place Cutout</td>
</tr>
<tr>
<td><img src="icon5.png" alt="Button" /></td>
<td>Place Pad</td>
<td><img src="icon6.png" alt="Button" /></td>
<td>Place Keepout</td>
</tr>
<tr>
<td><img src="icon7.png" alt="Button" /></td>
<td>Place Via</td>
<td><img src="icon8.png" alt="Button" /></td>
<td>Place Plane</td>
</tr>
<tr>
<td><img src="icon9.png" alt="Button" /></td>
<td>Place Line</td>
<td><img src="icon10.png" alt="Button" /></td>
<td>Place Room</td>
</tr>
<tr>
<td><img src="icon11.png" alt="Button" /></td>
<td>Place Arc</td>
<td><img src="icon12.png" alt="Button" /></td>
<td>Place Text</td>
</tr>
</tbody>
</table>
Chapter 15: Place Commands

Place Autoplace

Click this button To choose this command Click this button To choose this command

Place Polygon Place Attribute

Place Point Place Field

Place Dimension

To learn more about each command, see the appropriate section in this chapter.

Place Autoplace

Choose Place » Autoplace to exchange placement data between P-CAD PCB and SPECCTRA. This includes the following items:

- Predefined SPECCTRA placement attributes that you can assign to components.
- P-CAD-to-SPECCTRA design file transfer program that interprets SPECCTRA placement attributes and component geometries, and automatically translates them to SPECCTRA as component placement rules, properties, and component image outlines.
- Autoplacement graphical user interface, which automates the autoplacement process sequence.
- SPECCTRA-to-P-CAD design file transfer program that accepts any of three SPECCTRA-generated file types: SPECCTRA session files (placement plus routing information), placement files (component placement information only), and/or routes files (routing information only).

The SPECCTRA placement attributes appear in the following table:

<table>
<thead>
<tr>
<th>SPECCTRA Placement Attribute</th>
<th>Data Type</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMPONENT_HEIGHT</td>
<td>real</td>
<td>Component height --- room placement constraint, or “-1”</td>
</tr>
<tr>
<td>LOCK_POSITION</td>
<td>boolean</td>
<td>Locks a component in its current position “n[<em>]”, f[</em>]”, “off”, or “0” (case insensitive) equate to “FALSE”. Otherwise, “TRUE”.</td>
</tr>
<tr>
<td>OPPOSITE_SIDE</td>
<td>boolean</td>
<td>Permit/prohibit back-to-back placement of components.</td>
</tr>
<tr>
<td>PERMIT_ORIENT_FRONT</td>
<td>string</td>
<td>Restrict orientation of front side components --- “horiz[ontal]”, “vert[ical]”, “0 90 180 270” (space-separated list of angles in multiples of 90), or “-1”</td>
</tr>
<tr>
<td>SPECCTRA Placement Attribute</td>
<td>Data Type</td>
<td>Effect</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------</td>
<td>--------</td>
</tr>
<tr>
<td>PERMIT_ORIENT_BACK</td>
<td>string</td>
<td>Restrict orientation of back side components — “horizontal”, “vertical”, “0 90 180 270” (space-separated list of angles in multiples of 90), or “-1”</td>
</tr>
<tr>
<td>PERMIT_SIDE</td>
<td>string</td>
<td>Side restriction — “top”, “front”, “upper”, “bottom”, “back”, or “both”</td>
</tr>
<tr>
<td>PROPERTY_POWER_DIS</td>
<td>real</td>
<td>Component power dissipation property, or “-1”</td>
</tr>
<tr>
<td>PROPERTY_TYPE</td>
<td>string</td>
<td>Component type property — “large”, “small”, “capacitor”, or “discrete”</td>
</tr>
<tr>
<td>SPACE_PIN_PIN/front</td>
<td>real</td>
<td>Min spacing between pin components on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_PIN_PIN/back</td>
<td>real</td>
<td>Min spacing between pin components on back side, or “-1”</td>
</tr>
<tr>
<td>SPACE_PIN_SMD/front</td>
<td>real</td>
<td>Min spacing of pin to smd components on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_PIN_SMD/back</td>
<td>real</td>
<td>Min spacing of pin to smd components on back side, or “-1”</td>
</tr>
<tr>
<td>SPACE_PIN_AREA/front</td>
<td>real</td>
<td>Min spacing of pin components to edges on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_PIN_AREA/back</td>
<td>real</td>
<td>Min spacing of pin components to edges on back side, or “-1”</td>
</tr>
<tr>
<td>SPACE_SMD_SMD/front</td>
<td>real</td>
<td>Min spacing between smd components on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_SMD_SMD/back</td>
<td>real</td>
<td>Min spacing between smd components on back side, or “-1”</td>
</tr>
<tr>
<td>SPACE_SMD_AREA/front</td>
<td>real</td>
<td>Min spacing of smd components to edges on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_SMD_AREA/back</td>
<td>real</td>
<td>Min spacing of smd components to edges on back side, or “-1”</td>
</tr>
<tr>
<td>SPACE_AREA_AREA/front</td>
<td>real</td>
<td>Min edge to edge component spacing on front side, or “-1”</td>
</tr>
<tr>
<td>SPACE_AREA_AREA/back</td>
<td>real</td>
<td>Min edge to edge component spacing on back side, or “-1”</td>
</tr>
</tbody>
</table>
To keep SPECCTRA attributes consistent and to distinguish between placement and routing attributes, the existing SPECCTRA attributes category is now named “SPECCTRA Routing” attributes. Using the SPECCTRA placement attributes, you can export P-CAD PCB components to SPECCTRA for placement, then read the placed components back into P-CAD PCB.

In cases where you specify component attributes and SPECCTRA placement attributes of the same name, the SPECCTRA placement attribute has priority. For example, if you specify the P-CAD placement attribute ComponentHeight and the SPECCTRA placement attribute COMPONENT_HEIGHT to the same component, P-CAD PCB translates the SPECCTRA placement attribute COMPONENT_HEIGHT to the SPECCTRA Router.

The default component image outline is a rectangular boundary defined by the centers of the lines and arcs and the extents of polygons on all layers of a P-CAD PCB pattern. SPECCTRA augments this bounding rectangle with its default bounding box surrounding the component pads. The combination produces an outline that is representative of the pattern’s size and shape. SPECCTRA uses this image outline to determine intercomponent spacing during placement.

Optionally, to further control the component outline, you can modify the pattern by adding a polygon and the P-CAD PackageOutlineLayer attribute to produce a specific component image outline in SPECCTRA. Attach a PackageOutlineLayer attribute to the P-CAD PCB pattern and set its value to a valid nonsignal layer name. Then, create a single polygon on the specified layer that defines the component outline and encloses all bounding boxes of the component’s pads. Include this polygon in the pattern’s geometry. The translator will use this polygon to produce the SPECCTRA image boundary for that component pattern. If any of the conditions listed above are not met, the translator reverts back to its default behavior.

You can pass fixed components into the AutoPlace tool and they will be recognized as fixed by the SPECCTRA router. However, you must fix the component in P-CAD PCB to make sure that it remains fixed if the component is translated from SPECCTRA back to P-CAD PCB.

**Performing Autoplacement**

To perform auto placement in P-CAD PCB, follow these steps.

1. Choose **Place » Autoplace**. The following *Place Autoplacement* dialog appears:
2. Click **DO Wizard** to create the DO file. The *SPECCTRA* **DO File Wizard** dialog appears.

3. Create the DO file, either manually or by clicking **Auto Create DO File**. P-CAD PCB either generates the DO file from the commands you entered, or creates a default DO file.

4. Click **OK**. P-CAD PCB returns you to the **Place Autoplacement** dialog.

5. Click **Start**. P-CAD PCB begins translating your design to the SPECCTRA file format. At this point, the program `Accl2spw.exe` transfers all design, routing, and placement rules and attributes to SPECCTRA as AutoRoute and AutoPlace rules and component properties.

6. Once done, the system launches SPECCTRA. SPECCTRA executes the DO file you specified in P-CAD PCB. At this point, you're ready to adjust component placement in SPECCTRA.

   Make any design and placement changes in SPECCTRA.

7. After making any design placement adjustments in SPECCTRA, remember to rewrite the session file or placement file using the filename that was originally written from the DO file. This safely captures the results of any interactive work that you performed in SPECCTRA.

8. When you are satisfied with your results, quit SPECCTRA.

   When you quit SPECCTRA, the system automatically merges the session or placement file (referenced in the DO file) with the original P-CAD PCB design (in ASCII form), to create a new design. The system then returns you to P-CAD PCB and loads the new design.
Place Component

Choose **Place » Component** or click the **toolbar button** to place named components at a specified location. You can place a component only when the following is true:

- Both the component and its corresponding pattern has been created and assigned to a library.
- The library containing that component is open.

**P-CAD PCB (6/400) designs are restricted to a maximum of 400 components.**

Placing a Component

To place a component, do the following:

1. Choose **Place » Component** or click the **toolbar button**.
2. Click the workspace to open the **Place Component** dialog.
3. Click **Browse** to expand the dialog and view a picture of the part in the browse window, as shown in the following figure:

4. Select a component from the Component Name list. This list shows all of the components in the current library.

   If the component you want does not appear in the Component Name list, click the **Library » Setup** button to select the library that contains the component.

5. Type a reference designator in the RefDes box. If you leave this box blank, P-CAD PCB uses the RefDes prefix assigned to the component at component creation time by default. If you do not assign a number, P-CAD PCB automatically assigns the next available number.
6. (Optional) Modify the value in the Value box. (e.g., electrical values for resistors and capacitors; typically you will leave this box blank for logical parts). The value you enter here overrides the value from the library component.

When a component has a Value attribute, the value displays in the Value box based on the following rules: If the symbol has a Value attribute, but no component Value attribute, the symbol’s Value attribute value is used. If the component has a Value attribute, the component’s Value attribute value will take precedence and be used even if the symbol has a Value attribute.

7. Select the desired Pattern Graphic from the drop down list, or enable the Auto Swap Graphics check box. If this check box is enabled, and the component has alternate pattern graphics, then as you rotate and flip the component its pattern graphic will automatically change to the pattern graphic defined in the P-CAD Library Executive.

8. Click **OK** to close the *Place Component* dialog. In the workspace, the cursor takes the shape of a crosshair cursor.

9. Move the cursor to the location where you want to place the component. Then, choose one of the following methods to place the component:
   - Hold down the left mouse and drag the ghosted outline of the component into position. Then, release the mouse button to place it.
   - Click the workspace to place the component.

Notice that before you place a component, the RefDes appears in the Status Line. To increment the component’s RefDes, press **D** before you click the workspace or while the cursor is still a crosshair. To decrement it, press **SHIFT+D**. To cancel component placement, **right-click** when the ghosted component outline is visible.

10. Continue placing the same component by clicking in selected locations. Each component you place has a unique reference designator. In addition, each component will have displayed its type, name, and any other attributes previously specified (from the *Place > Attribute* function).

11. If you want to place a different type of component, **right-click** or press **ESC** to exit the place mode for that particular component. As you are still in placement mode, you can click in the workspace to display the dialog and select another component to place.

**Rotating or Flipping a Component**

To rotate or flip a component after placement, select the component and choose one of the following methods:

- Press **F** to flip the component.
- Press **R** to rotate the object by 90-degrees.
- Press **SHIFT+R** to rotate the object by the current rotation increment set in *Options Configure*.

To rotate or flip a component before you place it, hold down the left mouse button. When the ghosted outline of the component appears, press **F**, **R**, or **SHIFT+R**. When you use this method, any
rotation applies to the next component you press R. For example, if you rotate a component 25-degrees before you place it, the next component is placed at the same 25-degree angle without any rotation. This lets you place multiple components at the same angle.

If you right-click to end the temporary placement mode and then left-click to place another component, the rotation memory will not apply; the rotation memory applies only to the temporary placement mode.

If a component has a test point, the point's side of board property changes when you flip the component. For example, a test point on the Top side of the board switches to the Bottom when flipped. Likewise, a point on the Top Silk layer switches to the Bottom Silk layer when flipped. To learn more about test points see Test Points (page 376) and Placing Test Points (page 386).

Placed components with connections can be rotated without attempting to reconnect if you hold down the left mouse button during the rotation. Only after the left mouse button is released will the connections be updated.

Components of the same type can be placed only if they have the same pin mapping (i.e., pin designator to pin name to pad number). If you place the same component from different libraries, the first instance of the component type establishes the standard pin mapping for that type of component. Any components of that type placed subsequently have to conform to the pin logic of the first or they will be unplaceable.

When you place components that include vias, pads, and text that are of styles that have the same names but different data than those in the current design, the incoming style names are bracketed to indicate the style conflict. The bracketed style names are added to the list of available styles in the current design. For object style information, see Edit Properties (page 292), Options Pad Style (page 472) and Options Text Style (page 482).

Attributes

If two parts of a component have the same attribute names, but different values, the first part’s attributes are preserved, and the second’s is overwritten.

Attributes added to the symbol or the pattern in the design are not accessible from the Attributes dialog in P-CAD Library Executive.

Jumper Pads

Components with jumper pads are handled in a special way. Any time this command adds a node to a net, P-CAD PCB checks to see if the node is a jumper pad. If it is, the component behaves as if all of the pads marked as being jumpered together are connected. In PCB, if necessary, blue line connections may be added to the other pads.

Test Points

When test points are built into a component, the points typically appear in your design when you place that component.
If you flip a component with test points, P-CAD PCB changes the side of board property for that test point. For example, if a test point is on the Top side of the board, it will be on the Bottom after you flip the component.

In addition, if a test point is on a predefined layer, the layer is affected. For example, if a point is on the Top silk, it will be on the Bottom silk when flipped. However, if a point is on a user-defined layer when flipped, it remains on that layer.

You can place test points on non-signal layers. If you attempt to place a test point on a signal or plane layer, a message notifies you that test points cannot be placed on signal or plane layers.

**Place Connection**

Choose **Place » Connection** to place a connection between pads and vias. To place a connection to a via, either the via or its connecting pad or via must be part of an existing net. Connections do not belong to a particular layer and do not have a user-definable width.

To place a connection, you must have already placed free pads or vias and/or component pads. The connected pads become nodes of a net.

You need to change layers to place connections between surface pads or vias that are on different layers. For example, switch the current layer to Top, begin the connection on one of the Top layer pads, change layers to the Bottom and complete the connection to a bottom layer pad.

**Placing a Connection**

To place a connection, do the following:

1. Choose **Place » Connection**. The pad or via must have a non-zero definition on the layer you are on.

2. Click over a pad or via, drag to another pad or via, and release. To place a connection to a via, either the via or its connecting pad or via must be part of an existing net.
   - If you place a connection between nodes that do not share a node with an existing net, you are prompted for a new net name. Click **OK** for the default net name or enter a new net name.
   - If you place a connection between pads or vias belonging to two different nets, you are prompted for a name for the merged net.

3. You can continue placing connections in the same manner, from pad to pad (node to node), from pad to via, or from via to via.
You can place connections to free pads, but the free pads will not appear in the netlist when you generate a netlist by choosing **Utils » Generate Netlist**.

You can place connections to free vias, but the connecting pad or via must be a part of an existing net. Like free pads, vias do not appear in the netlist.

Components can have unused pads that are electrically inactive (i.e., they have no designator). You cannot place a connection to an unused component pad.

**Merging Nets**

If you attempt to place a connection between two nets (i.e., if you attempt to merge nets) the following **Merge Nets** dialog appears. Use this dialog to choose to name the merged net one of the two net names that are being merged, or give it a new name.

To route the connections, choose **Route » Manual** or **Route » Interactive**. For details, see **Route Commands*** (page 405). To optimize the connections for minimum length, choose **Utils » Optimize Nets**. For details, see **Utils Optimize Nets*** (page 525).

**Jumper Pads**

Any time a connection adds a node to a net, P-CAD PCB checks to see if the node is a jumper pad. If it is, the component behaves as if all of the pads marked as being jumpered together are connected.

**Place Pad**

Choose **Place » Pad** to place a pad of the current style. Pads do not belong to a particular layer. To place a surface pad, for example, the current style must be set up to have a shape defined only on a surface layer.

Choose **Options » Pad Style** to define new pad styles and to set the current pad style. For details, see **Options Pad Style*** (page 472). Choose **Edit » Properties** to open the **Pad Properties** dialog, in which you change pad styles or pad numbers of already placed pads. For details, see **Pad Properties*** (page 307).

**Placing a Pad**

To place a pad, do the following:
1. Choose **Place » Pad** or click the **toolbar button**.

2. Move the cursor to where you want to place the pad. Then, choose one of the following methods to place the pad:
   - Hold down the **left mouse button**. Then, drag the ghosted outline of the pad into position and release the mouse button to place the pad.
   - Click the **mouse** to place the pad.

**Rotating or Flipping a Pad**

To rotate or flip a pad, select a pad and choose one of the following methods:

- Press **F** to flip the pad.
- Press **R** to rotate the pad 90 degrees
- Press **SHIFT + R** rotates the pad by the rotation increment set in **Options Configure**.

You can rotate a pad before you place it, and whatever angle is the result of the rotation will apply to the next pad you place. You must keep the button down while you are rotating it (before the pad is permanently placed). For example, you are placing a pad and you rotate it 25-degrees before you finish it (**SHIFT + R**, with 25-degrees set in **Options Configure**). Then you place another pad; it will be placed at the same 25-degree angle without any rotation action. If you decide to rotate the second pad, it will increment 25-degrees more, resulting in a 50-degree angle. Therefore, you can place multiple pads at the same angle but only have to perform the rotation action on the first pad.

If you are rotating or flipping a placed pad that has associated connections, you can prevent the connections being changed each time you rotate or flip by pressing the **left mouse button** while changing the pad's orientation.

To flip a pad as you are placing it, press **F** while the pad is ghosted before final placement. When you flip a pad, the hole range does not flip with it.

Pads and vias share the same rotation memory. In other words, if you place and rotate a pad at 90 degrees, then immediately place a via, that via will be placed at a 90-degree angle. This rotation memory derives only from rotation action during placement, not from select-and-rotate actions that take place after object placement.

**Renumbering Pads**

If you want to number the pads you placed, you must enable the Select tool (choose **Edit Select**) and then choose **Utils » Renumber**. A dialog appears where you can choose **Pad Num** as the type, then specify the start value and increment value. Then you can click on each pad manually and they will be numbered in sequence. You can also use the **Pad Properties** command to assign a pad number. For more information, see **Utils Renumber** (page 497) and **Pad Properties** (page 307).

**Modifying Pad Styles**

If you want to place pads of a particular style, choose **Options » Pad Style** to modify the current style. New styles can also be added with this command. You can change the style of an existing (i.e.,
placed) pad by opening the Pad Properties dialog. To open the dialog, select the pad, then right-click and choose Properties from the shortcut menu.

**Place Via**

Choose Place » Via to place a via of the current style. Vias do not belong to a particular layer. To place a buried via, for example, the current style must be set up to have a shape defined only on particular layers.

Choose Options Via Style to define new via styles and to set the current via style. To change the style of a via that has been placed, select the via, then right-click and choose the Properties command from the shortcut menu. The Via Properties dialog appears. For information on this dialog, see Via Properties (page 311).

Vias are almost identical to pads in the way that they are placed, rotated, flipped, and edited. See Place Pad (page 378) for detailed information.

**Place Line**

Choose Place » Line to place a line (or a series of line segments) of the current line width on the current layer. To change the current line width, choose Options » Current Line.

**Placing a Line**

To place a line, do the following:

1. Choose Place » Line or click toolbar button.

   While you draw a line or segments, the cursor is displayed as a crosshair shape. When you finish the line segments, the cursor returns to its normal shape.

2. With the cursor in the workspace, press and hold down the mouse button at the starting point, then drag the line to its second point and release to place the line. You can continue with connected segments in the same manner.

   You can use ALT+left mouse button instead so you don't have to hold the button down while dragging line segments.

   While you are drawing a line or segments, the cursor appears as a crosshair shape. When you finish the line or segments, the cursor returns to its typical shape.

3. To finish the line or line segments, right-click or press ESC. Then you can begin another line beginning at a new location.

   You will remain in Place Line mode until you enable another mode.

**Status Line**

The Status Line information area displays line measurements for delta X and delta Y while you are dragging a line segment. When the line segment is finished, the total length measurement of the
segment(s) appears, each subsequent segment being included in the total measurement, and each segment with a delta X and delta Y length while it is being dragged.

| Total Length=5295.3 |

When the line is finally placed, all measurements on the Status Line disappear.

**Orthogonal Modes (for Line Segments)**

There are orthogonal modes that you can use while placing lines. While the Place » Line tool is enabled and you are dragging a line segment, you can press hold down the left mouse button and press the O key to cycle through the enabled orthogonal modes.

Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles. The available orthogonal modes are provided as mode pairs. Press the O key to cycle through the mode pairs and the F key to switch between the current mode pair. You can enable or disable the orthogonal modes in Options Configure.

For placing lines, only the linear orthogonal modes are available (no arcs).

**90/90 Line-Line**

Both lines are either horizontal or vertical (displayed perpendicular to each other). For long, the first segment is always longer than the second. For short, the first segment is shorter. You can switch between the two modes by pressing the F key.

**45/90 Line-Line**

You can switch between the two modes by pressing the F key. The first mode makes the first segment displayed at a 45-degree angle and the second segment is either horizontal or vertical. The second mode makes the first segment either horizontal or vertical and the second segment is displayed at a 45-degree angle.

Press the BACKSPACE key to unwind any previous segments, unless you have finished the line or segments, in which case the Undo key (or toolbar button) will Undo the whole series of finished segments.
Chapter 15: Place Commands

Place Arc

Choose Place » Arc to place an arc or circle of the current line width on the current layer. With this command, you can create arcs of varying length and radius and circles of varying radius.

To change the current arc width (line width of the arc), choose Options » Current Line. For more information, see Options Current Line (page 457).

Arcs are partial circles. Arcs and circles are constructed counter-clockwise; the click (down) and release (up) define the start and end point of the arc, therefore a stationary click/release comes full circle and defines a circle. In this case, the second click and drag moves the center point away from the defined point on the circumference.

Placing an Arc

To place an arc, do the following:

1. Choose Place » Arc or the arc icon on the toolbar. Move the cursor to the starting point of the arc.
   While you draw an arc, the cursor appears as a crosshair shape. When you finish the arc, the cursor returns to its normal shape.

2. Click and drag to the end point of the arc. Release and the start and end points are established as a 180-degree arc.
   The arc sweeps counterclockwise as you place it. (e.g., left-to-right the arc sweeps up; right-to-left the arc sweeps down, etc.) If you click and release without dragging (i.e., the start and end points are the same), you create a circle.

3. After the start and end points are established, click and drag the cursor to define or alter the center point, thereby increasing or decreasing the sweep angle and radius of the arc.
   You can flip the arc (swapping the end points) by pressing F while the arc is still unfinished.

To cancel ghosting of an arc, right-click.

Move, Rotate, Flip, Change

- To move, resize, rotate, flip or perform other types of changes to the arc (after it is permanently placed), use the Edit Select mode.

- To rotate or flip an arc, select it, and hold down the left mouse button and press R to rotate or F to flip.

- For rotation, the default increment rotation is 90 degrees, which is activated by the R key. You can set a different rotation increment with Options Configure. For instructions, Options Configure (page 429). To rotate an arc the increment set in Options Configure, press SHIFT+R.

- To move the arc, click within the selection box (not on the handles) and drag the arc.
To resize an arc, click and move the center handle to change the radius or move the start or end point to change the sweep angle.

**Place Polygon**

Choose **Place » Polygon** to place a solid, filled polygon on the current layer.

**Placing a Polygon**

To place a polygon, do the following:

1. Choose **Place » Polygon** or click the **Polygon** button on the toolbar. If you want to place a polygon with square corners, select the (None) setting in the Radius combo box on the Status Line. Select a radius of your choice from the drop-down list or enter the desired value to create a polygon with rounded corners.

While you draw a polygon, the cursor appears as a crosshair shape. When you finish the polygon, the cursor returns to its normal shape.

2. Put the cursor at the starting point of where you want your polygon. Hold down the left mouse button and drag the cursor to the second point. Then, release the mouse button.

3. Drag the cursor to a third point to draw a triangle. Any subsequent polygon points are connected by a line to the first point you selected, e.g., the fourth point of a polygon is connected to the first point automatically.

   Complex polygons are not allowed. A complex polygon is a self-intersecting or self-crossing polygon. Polygon sides can touch each other but not cross each other.

4. When you have established all your points in creating the polygon, right-click or press **ESC** to finish and fill the polygon.

**Draft or Outline Display Mode**

Polygons can be drawn and printed as outlines by choosing one of these options:

- To draw polygons in outline form, choose **Options » Display**. Then, click the **Miscellaneous** tab and select the **Draft Mode** check box.

- To print polygons in outline form, choose **File » Print**. Then, click the **Setup Print Jobs** button. In the dialog that appears, select the **Draft** check box in the Display Options frame.

**Rotating or Flipping a Polygon**

You can rotate or flip a polygon after you have placed it. Select the polygon and press **R** to rotate or **F** to flip while the polygon is selected.

Press **R** to rotate the polygon by 90-degrees. You can press **SHIFT+R** to rotate the polygon by the rotation increment set in **Options Configure**. For information, see **Options Configure** *(page 429).*
Altering the Shape of a Polygon

You can alter the shape of a placed polygon (move, add, delete vertices and round the corners) by selecting the polygon, then clicking and dragging one of the handles.

When you move one of the handles that lies between two vertices, a new vertex is created. To delete a vertex, grab its handle and move it to an adjacent vertex and release. A polygon can have square or rounded corners.

To alter a polygon's corners follow these steps:

1. Set the desired radius in the Radius combo box on the Status Line by selecting an existing radius or entering a new radius. You may also add a radius directly in the combo box or choose Options » Current Radius to open the Options Current Radius dialog where you can add and delete radius values. Choose the (None) radius setting if the polygon should have square corners.

2. Select the Polygon to be modified.

3. Enable the display of the fillet handles by choosing Edit » Properties or by double-clicking the shape and selecting the Show Fillet Handles check box in the Properties dialog.

4. Press and hold down the left mouse button to grab the fillet handle in the interior of the polygon.

5. Drag the handle to the location where the corner radius is the one you want. Release the mouse button to place it.

Place Point

Choose Place » Point or click the toolbar button to place one of the following point types in a design:

<table>
<thead>
<tr>
<th>Reference Point. When you place a reference point on an object, the object moves with the cursor at that point. Objects also flip and rotate about this point.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glue Dot. Glue dots, or glue points, hold components in place until they are soldered during manufacturing. A glue dot can be placed in a pattern before saving the pattern in a library.</td>
</tr>
<tr>
<td>Pick and Place. Pick and place points direct the pick and place mechanism in manufacturing. This mechanism, also called auto insert, picks up the component and places it on a board.</td>
</tr>
</tbody>
</table>
Test Point. Test points can be placed only on non-signal layers. With test points, you can evaluate the nets in a design for electrical connectivity.

Unlike other points (e.g., reference points, glue dots, etc.), you can assign specific properties to a test point when you place one in your design.

To learn more about test points, see Test Points (page 376) and Placing Test Points (page 386).

The following procedures show you how to place a point, set point size, and also how to show or hide points in your design.

Placing Points

To place a point, follow these steps:

1. Choose Place » Point or click the toolbar button.
2. Click the design workspace to open the following dialog:

3. In the Points frame, choose one of the following options buttons:
   - RefPoint
   - Glue Point
   - Pick and Place
   - Test Point

If you choose the Test Point option button, you must also choose the appropriate options in the Test Point Details frame. To learn about these options, see Placing Test Points (page 386).
4. In the Place Point dialog, click OK. You are now in placement mode.

5. In your workspace, click where you want to place the point. If you want to place another point, click another location.

6. When you no longer want to place points of that type, right-click or press ESC. The place point tool remains enabled until you select another tool.

7. To move a point, select it and then drag it to a new location.

### Placing Test Points

When you choose the Test Point option button in the Points frame of the Place Point dialog, the controls in the Test Point Details frame become available.

The following list describes each option:

- **Top**: Choose this option button to place the point on the top side of the board. When you choose this option, the point is tested from the Top of the board.

- **Bottom**: Choose this option button to place the point on the bottom side of the board. When you choose this option, the point is tested from the Bottom of the board.

- **Fixed**: Select this check box to make the test point a fixed object. Clear this check box to make the point a moveable object.

- **Snap to Center**: Select this check box to snap the test point to the center of a pad or via. Clear this check box to place a test point anywhere on a pad or via.

You can place test points on non-signal layers.
As with other points, you can rotate and flip test points. However, when you flip a test point, the side of board property for that point changes. For example, a point on Top switches to the Bottom when flipped.

In addition, the layer on which the point appears may also change when you flip a point. If a point is on the Top Silk layer, it switches to the Bottom Silk when flipped.

For more information, see Test Points (page 376).

### Showing or Hiding Points

In P-CAD PCB, you can show or hide points. To do this, follow these steps:

1. Choose Options » Display. The Options Display dialog appears.
2. Click the Miscellaneous tab.
3. Choose the Show or Hide option button in each of these frames:
   - DRC Errors
   - Glue Points
   - Pick and Place

You can also choose to include or exclude these items from your printer output (File Print) by specifying the items in the Setup Print Jobs dialog.

### Place Copper Pour

A copper pour is a polygonal shape that you can place on any layer of a PCB design. To place a copper pour in a design, you use the following two-step process:

- First, you place the pour outline.
- Next, you flood the pour outline with a copper fill.

The following instructions show you how to place a copper pour.

#### Placing a Copper Pour

When you place a copper pour, you first draw the pour outline. Then, you flood the pour outline with a copper fill.

#### Drawing a Pour Outline

To draw a copper pour outline, follow these steps:

1. Choose Place » Copper Pour or click the toolbar button.
2. Click where you want to place the copper pour.
3. Drag the cursor to another point and click. Drag the cursor to another point and click at each corner of the polygon you want to draw.

Complex copper pour polygons are not allowed. A complex polygon is self-intersecting or self-crossing.

4. When you’ve finished drawing a polygonal shape, right-click to stop placing the pour outline. You remain in placement mode, so you can draw another copper pour outline.

5. If you don’t want to place another pour outline, choose another command to disable the Place » Copper Pour command.

Filling a Copper Pour

After you draw a pour outline, you flood the copper pour with a copper fill. To do this, follow these steps:

1. Select one or more copper pours using one of the following methods:
   - To select one copper pour, click within the boundary of the pour outline.
   - To block select a group of copper pours, set the appropriate block selection criteria in the Options Selection Mask dialog.
   - To select a group of copper pours, hold down the CTRL key and click each copper pour you want to select.

2. Select the copper pours you want to fill and use one of the following methods to open the Copper Pour Properties dialog:

3. Choose Edit » Properties.

4. Right-click and choose Properties from the shortcut menu.
5. In the Copper Pour Properties dialog, select the appropriate options in the Fill Characteristics frame. Whatever you specify here applies only to the selected copper pour(s).

6. In the State frame, choose Poured.

7. Click OK to close the dialog. P-CAD PCB floods the pours with a copper fill using the pour order set in the Pour/Repour Options frame of the Options Configure dialog.

**Rotate or Flip**

You can rotate or flip a copper pour after you have placed it.

- To rotate a copper pour by 90 degrees, select the pour and press the R key.
- To rotate a copper pour by the rotation increment set in the General tab of the Options Configure dialog, press SHIFT+R.
- To flip a copper pour, select the pour and press the F key.

For copper pours with associated connections, press the left mouse button while rotating or flipping to prevent reconnection attempts each time you rotate or flip. Connections are committed when the left mouse button is released.

**Place Cutout**

Choose Place » Cutout to place a cutout on your design. A cutout is a polygonal void area for planes, which will not be filled with copper when the pour is flooded. Cutouts do not affect solid polygons or keepout polygons. Cutouts are recognized only by pours.

Since a cutout is a polygonal shape, the edges can be rounded if desired. For instructions on how to round the edges of a polygonal shape, see Polygon Properties (page 315), or Place Cutout (page 389).

**Placing a Cutout**

1. Choose Place » Cutout or click the toolbar button.

2. Move the cursor the first point of the cutout. The cursor will take on a crosshair shape while you are placing the cutout. Press and hold down the mouse button at the first point of your cutout. Then, drag the cursor to the second point of your cutout and release the mouse button to establish the first edge of the polygon cutout.

   Press and hold down the mouse button. Then, drag the cursor to the third point of your cutout. Release the mouse button to establish the outline of the cutout. Drag the cursors as described to establish subsequent points.

   Complex (self-intersecting or self-crossing) polygons are not supported.

3. Right-click or press ESC to establish the cutout polygon; it appears as an outline. When the pour is re-poured, the area defined by the cutout is not filled.

   Cutouts are drawn as polygon outlines using the polygon color for that layer.
**Rotate or Flip**

You can rotate or flip a cutout after you have placed it. Select the cutout and press R to rotate or F to flip while the cutout is selected.

The R key rotation is 90 degrees. You can press SHIFT+R to rotate to whatever rotation increment is set in Options Configure.

**Place Keepout**

Choose **Place » Keepout** to create a barrier to either keep in or keep out routing on a specific area of the board. You can place either a line keepout or polygon keepout.

Keepouts are non-electrical items that affect only the autorouter; they are ignored by nets and planes.

First, choose **Options » Current Keepout** to set the type of keepout you want to place (line or polygon) and on what layers (all or current).

An all-layer Keepout is recognized on all layers of the design. For more specific control on a layer-by-layer basis, place current layer keepouts on multiple layers.

Placement of line keepouts works like Place Line, except that a line keepout has no real width, and therefore cannot be modified like a line. Polygon keepouts work like Place Polygon. For specific instructions, see **Polygon Properties (page 315)**, or **Place Polygon (page 383)**.

Since a polygon keepout is a polygonal shape, the edges can be rounded if desired. For instructions on how to round the edges of a polygonal shape, see **Polygon Properties (page 315)**, or **Place Polygon (page 383)**.

**Place Plane**

Choose **Place » Plane** to create a split plane outline on a plane layer.

To create a split plane, you place a polygon outline on a plane layer. The area within the polygonal outline is the split plane’s copper. A split plane is associated with a single net. When you select the net, all split planes in that net are selected. Split planes appear and are printed in negative video.

Since a plane is a polygonal shape, you can round the edges of the shape. For instructions, see **Polygon Properties (page 315)**, or **Place Polygon (page 383)**.

**Placing a Plane**

To place a plane, do the following:

1. Choose **Options » Layers** and create a plane layer that will be split.
   
   When you create this layer, you can decide whether to assign a net to the plane layer. If you decide to assign a net, and then split the net in two, you need only place a single plane object.

2. Choose **Options » Layers** and make the plane layer the current layer.
3. Choose **Place » Plane** or click the toolbar button.

4. Move the cursor to the first point of the plane. Click for the first point and drag to the second point and release to establish it.

   Place the third point in the same manner. (You can see the outline of the plane so far).

   Click and drag to establish subsequent points.

5. **Right-click** to terminate the placing of the outline and establish the outline of the plane shape.

   The plane is drawn using the polygon color defined for that plane layer.

   It is illegal to have two planes that intersect, because connectivity to the planes will not be correct. Design Rule Checking (DRC) will report this error if you enable Plane Violations in the **Utils DRC** dialog.

   The line width (set using the **Option Current Line** command) determines the clearance between two plane nets.

Now you need to access the **Plane Properties** dialog. This name will change to establish the characteristics of your plane.

1. Select the plane outline, then choose **Edit » Properties**.

   ![Plane Properties dialog]

   For details about modifying the plane’s properties, see **Plane Properties** (page 323).

**Pads and Vias**

For a pad to electrically connect to a split plane, the pad and the split plane must be in the same net and the pad’s hole must intersect the split plane. If the pad’s hole partially intersects the split plane, the pad is still considered electrically connected to the split plane, but DRC reports this partial connection as a warning.

Net connectivity is maintained with split planes, just as net connectivity is maintained with plane layers. For example, if two pads are electrically connected because they both connect to the same
split plane, then a connection line is not necessary between the two pads. If two pads are electrically connected to the same split plane, P-CAD PCB assumes that copper in the split plane is continuous between these two pads.

Connections between pads/vias and planes can be controlled using the Modify Pad/Via Styles (Complex) dialogs. If you choose the No Connect Shape, then the selected pads or vias are not connected to planes on the specified layers.

**Rotating or Flipping a Plane**

To rotate or flip a plane, select the plane and choose one of the following methods:

- Press F to flip the plane.
- Press R to rotate the plane by 90 degrees.
- Press SHIFT+R to rotate the plane by the rotation increment set in the General tab of Options Configure. For details, see Options Configure (page 429).

**Place Room**

Choose Place » Room to place a room in the design. A room is a logical object, which creates a region to which you can assign components and rules. Placing components in a Room is an excellent way to help you control the layout of your design.

The steps used to organize components in a room are as follows:

- Placing a Room in the Design.
- Defining Room Properties.
- Assigning Components to the Room.
- Verifying Placement with DRC.

To place a room in your design, do the following:

1. Choose Place » Room or click the Place Room button on the toolbar.
2. Place the room by choosing one of the following methods:

   - Position the cursor in the design where you want to place the room corner and click the left mouse button. Go to the position of the room’s opposite corner and click the left mouse button again.
   - Position the cursor in the design where you want to place the room corner, press and hold down the left mouse button and drag the cursor to the room’s opposite corner. Release the mouse button.

Performing either option displays the room’s boundaries in the workspace. You can place one room entirely inside of or overlapping another room, if desired.
Place Text

Choose Place » Text to enter or place text on your design using the following basic steps.

1. Choose Place » Text or by click the toolbar button.
2. Click the workspace at the location where the text is to be placed.
3. Type the text you want to place in the design in the Text area of the Place Text dialog.
4. Click Place in the dialog or click the Place Text tool again to commit the text in the design.

Place Text Dialog

Text entered in the Place Text dialog is instantly displayed at the location in the design where you clicked the mouse button to begin the place text function. You can change the location of the text by dragging it to a new location.

The Place Text dialog can be displayed in the expanded version, an intermediate size or minimized to a one-line display. The display size and location at the time the dialog is closed become the default settings that are used the next time you enter the Place Text mode.

To display the expanded version of the Place Text dialog, click More located directly beneath the scroll bar, on the right side of the text box. To reduce the dialog to the intermediate size, click <<Less. To reinstate the minimized dialog to its previous size, click Maximize. To reduce the dialog to its minimized size, click Minimize.

The minimized version of the dialog appears as follows:

![Minimized Place Text Dialog]

The intermediate version of the dialog appears as follows:

![Intermediate Place Text Dialog]

The expanded version of the dialog appears as follows:

![Expanded Place Text Dialog]
The Place Text dialog contains the following options:

- **Text**: The Text box is where you type the text you want to place in the design. You can also paste text from the Clipboard to the box, by pressing **CTRL+V**. If you want to enter multiple lines you can start new lines in the Text box by using a carriage return (press the **ENTER** key). A single text object can have up to 2,000 characters.

- **Location**: If the text has not been placed yet, the Location section displays the X and Y coordinates of the location of the cursor when the mouse button was released. While placing the text the coordinates cannot be modified. When you select committed text and choose **Edit ➤ Properties**, the location coordinates can be modified to move the text to a different area in the design.

- **Flip**: The Place Text dialog provides the option to flip the text by selecting the **Flip** check box.

- **Rotate**: You can rotate the text by clicking **Rotate**. Each time you click **Rotate**, the text rotates by the increment specified in the **Options Configure** dialog. For information, see **Options Configure** (page 429). The degree of rotation is displayed next to the button.

- **Text Styles**: You can view the default text styles and add, modify and delete a non-default text style by clicking **Text Styles** to open the **Options Text Style** dialog. Changes to the text style appear instantly in the design at the time they are made.

The text style for the selected text or the text being placed can be changed by choosing the new style from the drop-down list in the Text Style list. Fonts and font sizes cannot be mixed within the same text item. Barred text can be inserted in the text item by placing a tilde (~) on either side of the text you want to bar. Type two consecutive tildes to cause a single tilde to be displayed. Changes that cause the text to placed outside the workspace are not allowed.

See **Options Text Style** (page 482) for detailed information on adding, modifying, viewing and deleting text styles.

- **Place/Cancel**: Commit the text to the current location in the workspace by clicking **Place** or the place text toolbar button.

To cancel the text placement dialog and remove the temporary text from the design, click **Cancel** or press **ESC**. The Text tool is still active, but the dialog disappears from view.
Whenever you are typing, flipping or rotating text, and zooming or panning the workspace, the dialog remains on the screen. At the time the text is committed to the design by clicking the Place button on the dialog, choosing the Place » Text command or the toolbar button, the dialog closes. The Place Text tool remains active so that you can click in the workspace to indicate the location for the next text item, display the dialog again and place more text.

**Place Text Features**

The Place Text tool provides additional features that enhance the basic placement functionality and make placing the text easier and more accurate. This section describes how to rotate, flip, zoom and pan text during or after placement.

**Rotating Text**

You can rotate text as you are placing it. Click and hold the left mouse button on the text, then press the R key. Clicking the Rotate button will also rotate the text. The R key and Rotate button functions rotate the text by the degree specified in the Options Configure dialog. For information, see Options Configure (page 429). The text moves about its reference point.

To rotate text after it has been placed, select it and press R to rotate while the left mouse button is depressed or choose Edit » Properties to open the Text Properties dialog where you can click Rotate.

For rotation, whatever angle is the result of the rotation will apply to the next text you place. For example, you are placing text and you rotate it 25 degrees before you finish it (SHIFT + R, with 25 degrees set in Options Configure). Then you place more text; it will be placed at the same 25 degree angle without any rotation action. (If you decide to rotate the second text string, it will increment 25 degrees more, resulting in a 50 degree angle.) Therefore, you can place multiple text objects at the same angle but only have to perform the rotation action on the first text string.

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate text at 90 degrees, then immediately place a field, that field will be placed at a 90-degree angle.

In the Place Text dialog, click the box again to continue typing new text.

**Flipping Text**

You can flip text as you are placing it if you change focus from the dialog to the workspace. To do this, press and hold down the left mouse button. When a ghosted outline of the text appears, press the F key. Then, release the mouse button.

You can also flip text when in the dialog. To do this, select the Flip check box.

The F key and Flip check box functions flip the text 180 degrees to the right or left of the original location. The text moves about its reference point.

To flip text after it has been placed, select it and then press F to flip, or choose Edit » Properties to open the Text Properties dialog and select the Flip check box.

Click again in the box of the Place Text dialog to continue typing new text.
Zooming and Panning While Placing Text

The Place Text dialog remains on the screen while you zoom or pan the workspace. Click the workspace to assure that the focus is in the workspace before choosing any of the zoom commands. To zoom in or out of the workspace while placing text, use one of the following methods:

- Press the (+) and (-) keys.
- Choose View » Zoom In and View » Zoom Out.
- Click the Zoom Window button on the command toolbar.

The workspace can be panned by moving the scroll bars up, down, right and left, or by pressing one of the arrow keys.

Click again in the box of the Place Text dialog to continue typing new text.

Text Summary

- The text you enter is case-sensitive; what you enter is what you will get. Changes to text styles are displayed in the design at the time the change is made. Fonts and font sizes cannot be mixed within the same text item. Barred text is supported.

- If you want to enter multiple lines (e.g., a list), you can start new lines in the box by using the ENTER key.

- You can change the text justification by specifying one of nine justification points in the Place Text dialog or Text Properties dialog.

- With Text Properties, you can change the content of already placed text. Select the text, then right-click and choose Properties from the shortcut menu to open the dialog. You can change the text style, add/delete a text style, or modify the text justification in the Place Text or Text Properties dialogs. To change, add or delete a text style, click the Text Styles button, which activates the Options Text Style dialog, where you can add, modify, view, rename, or delete text styles.

- Text cannot be placed outside the workspace.

You cannot delete a text style currently in use.

Place Attribute

Choose Place » Attribute to place a free attribute according to the Name and Value options you select in the dialog.

To edit a free attribute after it's been placed, select the attribute and choose Edit » Properties or File » Design Info. Then, click the Attributes button (Some attribute values can be specified elsewhere, such as component name in Component Manager when you create the component).
Placing an Attribute

To place an attribute, do the following:

1. Choose **Place » Attribute** or click the **Attribute** toolbar button.
2. Click the workspace to open the following **Place Attribute** dialog.

   ![Place Attribute dialog](image)

To place a predefined attribute, do the following:

1. Choose an attribute category from the Category list. All predefined attributes for the category appear in the Name list.
2. Select an attribute from the Name list. This name, unless you selected user-defined, appears in the Name box.

To place a user-defined attribute:

1. Type an attribute name in the Name box.
2. Type a value for the attribute in the Value box.
3. Set **Attribute Properties**. See **Attribute Properties (page 328)** for more information.
4. Click **OK**.
5. Click the workspace, drag the attribute into position and release the mouse button place the attribute. Before you release the button to place it, you can move, rotate, or flip the placement box.

**Rotating or Flipping a Field**

To rotate or flip an attribute after it has been placed, select it and choose one of these methods:
• Press F to flip the field.
• Press R to rotate the field by 90 degrees.
• Press SHIFT+R to rotate the field by the rotation increment set in the General tab of the Options Configure dialog. For details, see Options Configure (page 429).

You can rotate or flip an attribute as you are placing it. For rotation, whatever angle is the result of the rotation will apply to the next attribute you place. For example, you are placing an attribute and you rotate it 25-degrees before you finish it (SHIFT+R, with 25-degrees set in Options Configure). Then you place another attribute; it will be placed at the same 25-degree angle without any rotation action. You can place multiple attributes at the same angle by rotating the first attribute as you place it.

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate text at 90-degrees, then immediately place an attribute, that attribute will be placed at a 90-degree angle. This rotation memory derives only from rotation action during placement, not from select and rotate actions that take place after object placement.

If you don't specify a value for an attribute, the attribute key name appears in brackets, e.g., {Type}.

**Place Field**

Choose Place » Field to place a field containing design information such as date, time, author, etc. The information that appears when you place certain fields is determined by what you specify in the File Design Info dialog. You can place a field from a selection of predefined field types including the following fields:

• Approved By
• Author
• Checked By
• Company Name
• Current Date, Current Time
• Date
• Drawing Number
• Drawn By
• Engineer
• Filename
• GUID (Globally Unique Identifier)
• Layer Name
• Modified Date
The Globally Unique Identifier (GUID) field is targeted to P-CAD PDM users. However, this pre-defined field is available for placement in any design.

You can also define additional fields using File » Design Info and then place them in your design. The current date and time fields use the settings from your computer’s Date/Time Properties. If you just select date then you must specify the date in the File Design Info dialog. The same is true for time (as opposed to current time).

The value of a field placed in the design, with the exception of Current Date/Time, Filename and Modified Date, must be specified in the Field Properties dialog, otherwise you place a generic field, e.g., {Author} rather than “W. Shakespeare”. To open the Field Properties dialog, choose File » Design Info or select a field, then right-click and choose Properties from the shortcut menu.

Fields are handy for use within title blocks.

**Placing a Field**

To place a field, do the following:

1. Choose Place » Field and click the workspace. The following Place Field dialog appears.

2. From the Name list, select the type of field you want to place. Click OK.

3. Move the cursor to where you want to place the field; click to place it. If you click again, the Place Field dialog opens, so you can place another type of field.

4. You can rotate or flip a field as you are placing it. See Rotating or Flipping a Field (page 397).

To cancel before a field is placed, right-click.

**Rotating or Flipping a Field**

To rotate or flip a field after it has been placed, select it.
• Press F to flip the field.
• Press R to rotate to rotate the field by 90 degrees.
• Press SHIFT+R to rotate to the field by the rotation increment set in the General tab of Options Configure. For details, see Options Configure (page 429).

You can rotate or flip a field as you are placing it. For rotation, whatever angle is the result of the rotation will apply to the next field you place. For example, you are placing a field and you rotate it 25 degrees before you finish it (SHIFT+R, with 25 degrees set in Options Configure).

When you place another field; it will be placed at the same 25 degree angle without any rotation action. If you decide to rotate the second field, it will increment 25 degrees more, resulting in a 50 degree angle. Therefore, you can place multiple fields at the same angle but only have to perform the rotation action on the first field.

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate text at 90 degrees, then immediately place a field, that attribute will be placed at a 90-degree angle. This rotation memory derives only from rotation action during placement, not from select and rotate actions that take place after object placement.

**Place Dimension**

Choose Place » Dimension to place a dimension at a specified location. A dimension is frequently used for describing distances, center points and angles between items. You can also choose to place an Associative Dimension: an intelligent dimension associated with its objects, which is dynamically updated whenever objects are moved. The selections made in the Place Dimension dialog are retained throughout your session in PCB. The default settings are applied at the beginning of each PCB session until changes are made for that session.

**Placing a Dimension**

To place a dimension, do the following:

1. Choose Place » Dimension or click the toolbar button.
2. Click the workspace to open the following Place Dimension dialog.
3. Select one of the following dimension styles from the Styles list:
   - **Point to Point**: Measures the distance between two points.
   - **Baseline**: Measures the distance between a single reference point and subsequent points. The dimension text is placed between the extension lines.
   - **Leader**: Leader is a dimensioning line extending from a piece of text or symbol to the dimensioned object. It can be used for dimensioning or notation.
   - **Center**: Center is a cross-hair marking of the center of an arc or circle. You can also dimension two center dimensions.
   - **Radius**: Measures the radius of an arc or circle.
   - **Diameter**: Measures the diameter of a circle.
   - **Angular**: Measures the angle between lines.
   - **Datum**: Measures the distance between a single reference points and subsequent points. The dimension text is placed at the end of the extension line. In datum dimensioning, there are no dimension lines connecting the extension lines.

4. In the Orientation frame, select the **Horizontal** or **Vertical** option button to set the dimension’s orientation.

5. In the Text Orientation frame, select the **Horizontal** or **Vertical** option button to set the orientation of the text that appears between the dimension lines.

6. Select a measurement scale from the Units list.
7. Select the layer on which you will place the dimension from the Layer list. If, upon reentering the dimension dialogs, the selected layer does not exist in the design, the Board layer is used as the default.

8. Select the desired level of precision from the Precision list. This setting determines the number of significant digits used to display the dimension measurement.

9. Enable the Display Tolerance check box if you wish to include a tolerance with the dimension. The tolerance is always displayed with 4 digit precision.

10. In the Symbol frame, choose one of these buttons to set the type of notation for a Leader style dimension: Text, Circle, Square or Triangle.

11. Enter a symbol size in the Symbol Size box.

12. When placing a dimension based on center points, specify a center size for the center of the symbol in the Center Size box.

13. Click Text Style to open the Options Text Style dialog. Then, choose the desired text style. The default is always the current text style set by choosing Options Text Style. For more information, see Options Text Style (page 482).

14. In the Line Width box, set a line width for the dimension lines.

15. In the Arrowhead box, you can set the length and width of an arrowhead.

16. Select the Display Units check box to display the specified units.

17. Select the Display Diameter Symbols check box to turn on the display of the symbol.

18. If you want to suppress zeros in the dimension, select the Suppress Leading Zeros or Suppress Trailing Zeros check boxes.

19. To add intelligence to the dimension and its associated objects, select the Associated Dimension check box. An associative dimension follows its associated objects and updates the dimension value whenever the objects are moved.

20. Click OK to return to the workspace.

21. Point in the workspace to place the dimension.

   The mouse click procedure to place a dimension depends on the dimension style selected. If you need assistance placing a dimension, see the Prompt Line at the bottom of your workspace for instructions. To learn about the Prompt Line, see View Prompt Line (page 366).

22. Select the location for the dimension text and lines.

   Hold down the left mouse button while placing the text. A ghosted outline of the dimension appears. While ghosted, the dimension can be moved. The dimension is placed in the desire location when the mouse button is released.

   When placing a Baseline or Datum dimension, you can unwind the last action performed by pressing the BACKSPACE key.
23. Continue placing dimensions as necessary. To stop placing dimensions, press **ESC** or right-click.

You cannot place dimensions on a test point. To learn more about test points, see *Place Point* (page 384).

**Modifying a Dimension**

A dimension can be modified after placement in a variety of ways:

- A selected dimension can be modified directly using the *Dimension Properties* dialog. This includes the ability to edit the dimension’s unit, layer, and precision.

- Dimension text can be moved and modified after placement by selecting the dimension and dragging the handle that appears over the text.

- After placement, dimensions can be moved along the dimensioning line to change the text position for Point to Point, Datum, Baseline and Angular dimensions. Simply choose the select tool, grab the handle on the dimension and drag it to the desired location on the dimension line.

- Leader, Radius and Diameter dimensions can be moved around the arrowhead point by grabbing the handle and repositioning the dimension in a new location once they have been placed.

**Rotating a Dimension**

To rotate a dimension after it has been placed, select it, and choose one of the methods:

- Press **R** to rotate the dimension by 90 degrees.

- Press **SHIFT+R** to rotate the object by the rotation increment set in the General tab of *Options Configure*. For details, see *Options Configure* (page 429).
CHAPTER 16

Route Commands

Using the Route Commands

Use the commands in the Route menu give you the ability to gain access to a variety of routing options. For example, choose Route » Manual to manually route and reroute existing connections or net copper items.

With the Route » Interactive command, you can gain access to InterRoute, the interactive routing tool, which provides obstacle avoidance, copper hugging, and intelligent route completion.

With Route » Miter, you can convert 90 degree corners on routed connections into 45 degree mitered corners, 90 degree arcs, or T-routes. P-CAD PCB supports the following autorouters:

- QuickRoute
- PRO Route 2/4
- PRO Route
- SPECCTRA (valid for SP10, SP4P, SP2, and SP6 products)

The look and feel of the user interface is consistent for all autorouters. The supporting dialogs are router-sensitive, so that router-specific data such as pass selection are different for each autorouter.

The Route Toolbar provides shortcuts to the route commands:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To choose this command</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Route Manual" /></td>
<td>Route Manual</td>
</tr>
<tr>
<td><img src="image" alt="Route Interactive" /></td>
<td>Route Interactive</td>
</tr>
</tbody>
</table>
When you choose **Route > Autorouters**, the *Route Autorouters* dialog appears. Use this dialog to choose the autorouter that you want to use to route your designs.

In this dialog, you can also set autorouter options for the autorouter, as well as start and restart the autorouting process. The following figure shows you the *Route Autorouters* dialog:
The Autorouter combo box defaults to QuickRoute, the embedded router. To select a different router, click the down arrow and choose a router from the list. Notice that the dialog changes depending on the router you select. To get information about a specific router, click a router from the list.

**Route View Log**

Choose **Route » View Log** to view the log file generated from your autorouting session. Each router produces a comprehensive report file at the end of the routing session, detailing the results of the session. The report appears in the Notepad. You can view the log file without interrupting the routing process.

Before routing starts, the input PCB is analyzed. General information as well as your routing strategy and router-selected options are written to the log file. After each pass, per-pass and total routing statistics are written to the file. When routing is completed, summary information is written to the file.

The report file contains the information detailed in the following sections.

**Headers and Footers**

The name and version number of the router being used is found in the header. The footer displays the date and time the report was created. You can define your own header and footer by choosing **File Reports** in P-CAD PCB. This information is stored in the Pcb.ini file.
Chapter 16: Route Commands

General
The report provides a list of the input PCB, output PCB and strategy file names, your selected units, the available memory and the route start time. The report also lists the routing grid and via grid settings, the checkpoint interval, rip-up preroutes, diagonal routing and copper sharing options, the iterative and manufacturing pass counts and whether manufacturing passes should be run if the board is not completely routed.

Layer Settings
Provides a listing of the selected layers, indicating their directional bias (horizontal, vertical. Net names are provided for plane layers).

Net Classes
Provides a listing of each net class and their defined width, via pad stack and the maximum number of vias. The autorouter routes all nets belonging to the same net class together in a pass.

Pass Settings
Lists the scheduled passes and identifies the net classes to be routed during each. Some scheduled passes may not be run, as explained in Pass Performance (page 408).

Pass Performance
For each routing pass completed, the report file lists a count and percentage of the lines scheduled, completed and deferred during the pass, and for the entire run so far. Also reported are vias and copper length that were added or deleted during the pass as well as for the entire routing session.

Final Board Statistics
Final board statistics lists the total number of pads on the board, the number of equivalent 16-pin ICs (EICs), the dimensions and area of the design, the density (in square units per EIC; the lower this number is, the denser the board), the vias added during the routing process, the total number and length of routed lines (and percentage of routed lines to total lines), the total number of unrouted lines (and percentage of unrouted lines to total lines) and the total execution time for the routing process.

If you abort the routing process, the report file reflects the final board statistics only up to the point of termination. A warning message appears in the report file, indicating the type of termination request made (stop and save or stop and don't save).

Route Manual
Choose Route » Manual to manually route and reroute existing connections or net copper items.

Route Manual gives you the ability to precisely place traces. An individual trace can be routed along an arc, at any angle, and into loops. You can also T-route from an existing trace. Traces need not obey clearance rules, although Online DRC is available. The flexibility of Route Manual is particularly useful for analog boards.
Before you route you must have already placed components and placed connections between the component pads (net nodes). For information about components and connections, see Place Component (page 374) and Place Connection (page 377). You can also get connections by loading a netlist. See Utils Load Netlist (page 520).

Also, before you route, you should have all the layers enabled that you will be using during your routing procedure. To see the list of enabled layers, use the Layer combo box on the Status Line. You can change between these enabled layers (making each layer the current layer, in turn). Choose Options » Layers to alter the list of enabled layers (enable, disable, add to, delete, modify) as an alternate way to change the current layer. For details, see Options Layers (page 450).

The program does not allow routing on a nonsignal layer. If you try to route on a nonsignal layer, an error message appears.

See Routing (page 95) for additional information about setting up your board for routing and selecting a route tool.

Manually Routing a Connection
To manually route a connection, do the following:

1. Zoom in so that the connections you want to route are large enough to select.
2. Choose Route » Manual.
3. Click the connection. Notice that part or all of the net is highlighted in the current highlight color. In the Route tab of the Options Configure dialog, you can select which items are highlighted in the Highlight While Routing box. Item highlight options are Pads Only or Pads, Traces and Connection.
4. Drag the connection to where you want to route the connection and release. The new segment appears in the current layer color. The new copper segment starts from the end of the connection to which it is closest.

An alternate method for click-and-drag is to press the ALT key, then click the left mouse button (ALT+left mouse). You can then drag the routed line anywhere without having to keep the mouse button depressed.

5. You can continue routing by clicking at points where you want the route to go. Click to select a route point on the connection line, drag the line to the new location. Select the next point and do the same thing. Continue this process until the connection is completely routed.

6. To complete the routing of a segment, right-click.

Terminating a Route
To terminate a route, choose one of these methods:

- Complete the remainder of the trace (right-click or press ESC).
- Stop routing without completing the trace (press FORWARD SLASH (/) or BACKSLASH (/) keys).
Chapter 16: Route Commands

The behavior of the right-click action and the SLASH key can be modified using the Route tab in the Options Configure dialog. For details, see Options Configure (page 429).

When you drag the trace over its termination pad, a diamond shape appears. Then, you have reached the connection destination. The diamond symbol represents a zero length connection. It disappears when the connection is completed.

If the diamond shape remains after completing the connection, it indicates the pad you are routing to is on a different layer than the end of the route.

**Right-Click**

To route the remainder of a connection (in a straight line all the way to the next node), right-click. You can then left-click over another connection segment to begin routing it.

If the current endpoint of the trace being routed is point-to-point with an object belonging to the same net (pad, via, line, or arc) right-clicking causes the route to be recognized as completed, ending the route. The routing guide connection (the remaining connection is displayed during manual routing) is not replaced with a line trace to the original guide connection destination point when the right mouse button is pressed. The guide connection will be updated as appropriate.

The exception to this behavior occurs when routing to a pad that is the endpoint of the current guide connection. Right-clicking completes the route to the pad center.

The behavior of the right-click action and SLASH key can be modified using the Route tab of the Options Configure dialog. For details, see Options Configure (page 429).

**Slash Keys**

The SLASH keys (/) and (\) stop a route in midconnection without adding a final copper segment. Both back and forward slashes stop a route.

When the Optimize Partial Route check box is selected in General tab of the Options Configure dialog, pressing the SLASH key during manual routing terminates the route and causes the guide connection line to connect to the nearest net endpoint if the net doesn’t have an OPTIMIZE=NO attribute.

The behavior of the right-click action and the SLASH key can be modified using the Route tab of the Options Configure dialog. For details, see Options Configure (page 429).

**Status Line Information**

While you are manually routing, measurement information appears in the Status Line, along with the name of the net being routed, and the current orthogonal mode.

For example, the Status Line in the following figure shows the delta X and delta Y measurements of a ghosted segment while you are dragging, and the total length of the segment being routed when you release. The measurement does not include already routed or yet-to-be route portions of a net.
Routing between Layers

You must switch layers if you attempt to route from, or to, a pad on a different layer from the current layer. Changing layers is also useful when crossing a blockage.

Press the L key or press \texttt{SHIFT}+L keys as a shortcut to cycle between enabled layers. A via of the current style is automatically inserted when you change layers, unless you have a ViaStyle attribute. The line from that point reflects the color of the new layer.

T-Routing

To invoke T routing, press the \texttt{SHIFT} key while the Route Manual tool is enabled. The mouse operations are the same for T routing as they are for reroute: click (initiate), drag (rubberband), release (commit). By selecting the T-Route by Default check box in the Route tab of the Options Configure dialog, you can T-route without pressing the \texttt{SHIFT} key.

When selecting a trace, there are two possible ways to initiate the route depending on the T route mode: If T routing is disabled, the selection is treated as a reroute. If T routing is enabled using the \texttt{SHIFT} key, the tool starts a T route whereby the selected trace is broken at the selection point (unless that point is an endpoint) and routing continues with a new trace anchored at the selection point. You do not need to hold down the \texttt{SHIFT} key for the entire route, just to start the route.

You can set T routing to be the default mode using the Route tab of the Options Configure dialog. Otherwise, rerouting is the default operation. For information, see Options Configure (page 429).

A connection line is created from the selection point to the nearest, unconnected node to guide you in completing the route. When routing into a trace, the intersecting line is broken at the selection point. Just because this feature is called T routing does not imply that it only works for T shaped intersections. Routing is permitted to and from any existing traces on the board. If there is no unconnected node to anchor the end of the connection line, no connection line appears.

Modifying Traces

There are several ways to modify traces. In Route Manual mode, you can select a routed trace to reroute it. During trace placement, you can unwind or backtrack to remove or modify the previously placed segments. Also, Route Manual features trace cleanup to automatically remove overlapping trace segments.

Unwind

If you make a mistake, you can press the \texttt{BACKSPACE} key, and the previous segment disappears (unwinds). With each press of the \texttt{BACKSPACE} key, a previous segment or via is unwound.
Backtracking
Committing a straight line segment on top of another straight line segment, backtracking, acts as an erase operation and the intersection of the two lines is removed.

Vias cannot be erased with backtracking. You need to perform an unwind operation.

Backtracking detects only lines that precisely trace back over previous lines and only during the routing operation. No backtracking is performed for lines already existing in the design.

Trace Cleanup
When you choose **Utils » Trace Clean-up**, redundant trace segments (collinear and overlapping) and extra vertices are removed before the traces are added to the design. Trace cleanup also occurs between newly routed traces and preexisting traces.

Orthogonal Modes (O key)
You can press the **O** key to switch between the orthogonal modes while placing lines during manual routing. You can enable/disable certain orthogonal modes in the **Options Configure** dialog. The available orthogonal modes are provided as three mode pairs and a Tangent Arc mode. The mode pairs supply a total of six modes (three types, with two variations on each type). Press the **F** key to flip the mode between the angles in the current mode pair.

See **Options Configure (page 429)** for more information.

90/90 Line-Line
The 90/90 Line-Line modes are horizontal or vertical, as shown in the following. In long mode, the first segment is always longer than the second. In short mode, the first segment is shorter. To switch between the two modes, press the **F** key.

45/90 Line-Line
You can switch between the two modes by pressing the **F** key. The first mode makes the first segment display at a 45 degree angle and the second segment is either horizontal or vertical. The second mode makes the first segment either horizontal or vertical and the second segment is displayed at a 45 degree angle.

90/90 Arc-Line
You can switch between two modes by pressing the **F** key. The first mode makes the first segment display as an arc and the second segment is either a horizontal line or a vertical line. The second
mode makes the first segment either horizontal or vertical line and the second segment is displayed as an arc.

**Tangent Arc**
A curved arc can be incorporated into a route segment when Tangent Arc is the current orthogonal mode. The current radius, controlled through the Options » Current Radius command or the Radius combo box on the Status Line, is used to determine the curve of the arc while maintaining tangency between the two line segments and the arc. Once placed, the arc can be moved or modified by using the miter tool, which allows you to grab and drag an arc handle to a new radius.

**Online DRC**
If Online DRC is enabled using Options » Configure or the toolbar button, online DRC checking is performed after each mouse or keyboard click fixes the end of a segment during manual routing. Each routing click can cause up to two trace segments (either lines or arcs) and a via to be placed in the design; all newly created items are checked for DRC violations. When a violation is detected, a beep is generated and a DRC error indicator is placed at the approximate location of the violation; no error message appears. Multiple violations result in two beeps and multiple error indicators.

When a connection is completed, the number of DRC error indicators generated for the connection appears in the Status Info box on the Status Line, and a report of the violations is presented automatically if you selected the View » Report check box in the Options Configure dialog and there is at least one violation. This report includes a summary count of the violations created during the routing of the connection, plus the information from the individual DRC error indicators.

The clearance values used for clearance testing of pads, vias, and lines on a particular signal layer are taken from the Options Design Rules dialog and the Clearance attributes on the nets. Clearance attributes on the nets take precedence. Net class and class to class rules are also honored. This dialog is discussed in the Clearances section.

Associated DRC error indicators are automatically deleted when unwinding a route, and when undoing a completed connection with violations. Otherwise, DRC error indicators are not automatically removed when the violation is corrected. See Options Configure (page 429) for more information.
Width Attribute
DRC error indicators are generated if the width of any segment or arc of a net with a Width attribute differs (smaller or larger) from the that specified by the attribute. Both batch and online DRC generate DRC indicators.

Overlapping Connections
When connection lines overlap over a pad, routing selection priority is given to the connection line that has the same net ID as the pad. Priority is also given to SMD pads that are defined on the current layer.

Routing to Free Copper
Manual routing to the center of a pad, via, or the endpoint of a line that is not part of any net adds that item to the net being routed. This occurs as each route operation is completed, without choosing the Utilities » Reconnect Nets command or the Utilities Reconnect Nets option in the Utilities Load Netlist dialog.

To add other objects (arcs and polygons) to the net, choose Utilities » Load Netlist with the Reconnect Copper option enabled, or use the Utilities » Reconnect Nets command after the routes intersecting free copper have been completed. Arcs and polygons maintain full net information and correctly remove connections after being added to a net.

Copper Pours
Copper Pours affected by new copper generated by this tool will autoplow when the route completes or suspends.

Route Interactive
Choose Route » Interactive to start the InterRoute tool. Interactive routing provides design rule intelligence for easy obstacle avoidance, copper hugging, pad entry, and automatic route completion.

The InterRoute tool has many features and options for you to control trace placement, including T-routing from existing trace segments.

Routing Connections
To route connections, follow these steps:
1. Choose Route » Interactive or click the Route Interactive button on the InterRoute toolbar.
2. Pick a connection to route. The end closest to the point where the connection is selected becomes the source point; the other end becomes the destination point.
Notice that part or all of the net is highlighted in the current highlight color. In the Route tab of the Options Configure dialog, you can select which items are highlighted in the Highlight While Routing box. Item highlight options are Pads Only or Pads, Traces and Connection.

3. The Route Interactive tool rubberbands uncommitted copper with the proper net width and design rule clearances from the source point to the position of the cursor. The rubberbanding copper tracks around obstacles, maintaining the proper design rule clearances for that net, from the point of origin to the cursor position.

While you are moving the cursor, a connection rubberbands from the cursor to the second node of the connection, indicating what remains to be routed.

4. When you click a coordinate that is not the destination node, the previously uncommitted lines are placed on the board.

5. Continue this process until you are ready to complete the route.

6. Right-click and Complete from the shortcut menu. The InterRoute tool automatically finds the optimal path to complete the trace.

Or

7. Click a node that is the other end of the rubberband (this could be a pad, via, line, arc, polygon or copper pour island). If the selected node is a termination point for the connection, the route completes automatically.

You are now free to choose another connection to route or cancel the tool.

### Controlling Trace Placement

The interactive routing tool has many features for controlling trace placement.

You can initially route from a pad as if you were in Route Manual mode, with the added assistance of Route Interactive tool’s design rule intelligence.

When you are ready to terminate the route, choose Complete from the shortcut menu. The trace completes automatically. Many options are available to steer this trace.

This section discusses the following trace control features of P-CAD InterRoute:

- Status Line Information
- Obstacle Hugging
- Net Attributes

For additional information on routing control, see Pad Entry or Exit (page 416) and T-Routing (page 417).

### Status Line Information

While you are manually routing using the InterRoute tool, the right side of the Status Line displays measurement information, the name of the net being routing, and the current orthogonal mode.
For example, the Status Line in the following figure displays the delta X and delta Y measurements of a ghosted segment while you are dragging, and the total length of the segment being routed when you release. The measurement does not include already routed or yet-to-be route portions of a net.

| Ortho=90 Net = NET0004 dX= 100.0, dY= 25.0 |

**Obstacle Hugging**

Track segments follow the shortest path from start point to end point, hugging obstacles to within the clearance amount set using the Options Design Rules dialog.

A clearance indicator appears when you try to route through an obstruction. The clearance indicator appears as a semicircle with a radius showing the clearance amount between the object being routed and the obstruction.

The router always routes on grid, except for off-grid pads where the route is centered on the pad but ends on a grid point.

**Net Attributes**

The net attributes Width, ViaStyle, Clearance, PadToPadClearance, PadToLineClearance, LineToLineClearance, ViaToPadClearance, ViaToLineClearance, and ViaToViaClearance will be honored given the appropriate net class hierarchy.

**Pad Entry or Exit**

Pad entry or exit is calculated from the pad’s center regardless of whether or not the pad is on-grid. The stub length, set from the Route tab of the Options Configure dialog, lets you set the minimum number of grid points from the pad’s center for the first track you route.

When entering a surface mount pad, always place the trace to the pad parallel to the bias of the pad and aligned with the pad center.

**Fanouts**

When routing off-grid pad and via fanouts, InterRoute tool routes a stub in the direction of the cursor of a length (stub length) at least as long as that specified in the Route tab of the Options Configure dialog. If the cursor position is closer to the pad than the stub length, no stub is created; the route simply starts at the pad center and ends at the cursor position.
Stubs for pads with matching width and height (e.g., round, square) can go in four (90-degree orthogonal mode) or eight (45-degree orthogonal mode) directions. End points snap to grid lines.

Stubs for elongated pads (e.g., rectangle) go along the major axis only. Stubs on off-grid pads go from the pad center and remain off-grid until the cursor position is reached and then snap first to the closest grid line. The remainder of the route (from the stub endpoint to the cursor) ends on a grid point because the cursor is always on-grid. Entering a pad with a route follows the same logic as leaving a pad. Stubs always go to pad center.

**Polygonal Pads**

Polygonal pad shapes are supported. However, edges that are not 45- or 90-degrees won’t hug closely.

**T-Routing**

T-Routing when using the interactive routing tool works the same as it does when using the manual routing tool described earlier in this chapter. Copper share capability found in the interactive routing tool is the same as in the manual routing tool. The Interactive routing tool avoids obstacles, and allows you to terminate the route on a track segment as well as start a T route from a track segment.

**Terminating a Route**

To terminate a route with the interactive router, you can choose to do one of the following:

- Route to the termination of the connection.
- Complete the remainder of the trace automatically and **right-click** when complete.
- Stop routing without completing the trace (**SLASH** keys).

When you drag the trace over its termination pad, a diamond shape appears. Then, you have reached the connection destination. The diamond symbol represents a zero length connection. It disappears when the connection is completed.

If the diamond shape remains after completing the connection, it indicates the pad you are routing to is on a different layer than the end of the route.
Complete
Right-click and choose Complete from the shortcut menu. The remaining portion of the route is completed automatically. The design rule intelligence of the InterRoute tool neatly hugs obstacles along the trace path.

Slash Key
Routing can be suspended by pressing the SLASH (/) keys and the unrouted portion becomes a new connection from the suspension point to the end node.

Modifying Traces
There are several ways to modify traces. With the Route Interactive tool enabled, you can simply select a routed trace to reroute it. During trace placement, you can unwind or backtrack to remove or modify the previously placed segments. Also, Route Interactive tool features trace cleanup to automatically remove overlapping trace segments.

Rerouting Lines
The routing of existing lines is supported by the interactive routing tool. While using the Route Interactive tool, select a trace. Route the trace along a new path and terminate when complete.

The shortcut menu behaves the same as when rerouting connections.

Unwinding
Any segments or vias that are committed can be uncommitted by pressing the BACKSPACE key or by right-clicking and choosing Unwind from the shortcut menu.

Backtracking
Committing a straight line segment on top of another straight line segment, backtracking, acts as an erase operation and the intersection of the two lines is removed.

The routing tool also looks for loops in routed traces. If one is encountered, the loop, along with any resulting, floating copper is removed.

Vias cannot be erased with backtracking. You need to perform an unwind operation.

Trace Cleanup
When you choose Utils » Trace Clean-up, redundant trace segments (collinear and overlapping) and extra vertices are removed before the traces are added to the design. Trace cleanup also occurs between newly routed traces and preexisting traces.

Changing Layers
Changing layers adds vias in the same manner as is done with the Route Manual tool except that once you switch to a new layer, the Route Interactive tool recalculates its internal data structures to reflect obstacles on the new layer.
Blind and buried vias are handled as they are with the manual router. Changing layers while on a through hole pad simply changes layers (if the hole range allows it).

Vias, Layers, and Line Widths
Using the commands in the **Options** menu, you can select vias, layers and line widths during the routing operation. For information on these commands, see *Options Commands* (page 423).

Loop Removal
The Route Interactive tool looks for loops in routed traces. If one is encountered, the loop, along with any resulting floating copper is removed.

Copper Pours
If the **Auto Plow Copper Pours** check box is selected in the **Options Configure** dialog, copper pours affected by new copper generated by these tools will autoplow when the route completes or suspends. For more information, see *Routing* (page 192).

Shortcut Menu
You can open a shortcut menu during the routing process. To do this, **right-click**. The following shortcut menu appears:

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete</td>
</tr>
<tr>
<td>Suspend</td>
</tr>
<tr>
<td>Cancel</td>
</tr>
<tr>
<td>Options...</td>
</tr>
<tr>
<td>Layers...</td>
</tr>
<tr>
<td>Via Style...</td>
</tr>
<tr>
<td>Unwind</td>
</tr>
</tbody>
</table>

The following command appear in the shortcut menu:
- **Complete**: Autoroutes the remaining portion of the route.
- **Suspend**: Equivalent to press the / or \ keys, which leaves the unrouted portion as a connection.
- **Cancel**: Undo all routing actions and puts the original connection back. The Route Interactive tool remains active.
- **Options**: Opens the Route tab of the **Options Configure** dialog.
- **Layers**: Opens the **Options Layers** dialog.
- **Via Style**: Opens the **Options Via Style** dialog.
- **Unwind**: Removes the last line or via that was committed.
Keyboard Shortcuts
The following keyboard shortcuts are available during the routing process:

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENTER</td>
<td>Same as left mouse, commits the current routed series of lines.</td>
</tr>
<tr>
<td>ESC</td>
<td>Opens the shortcut menu.</td>
</tr>
<tr>
<td>/ or \</td>
<td>Stops routing the connection and leaves remaining, unrouted portion as a connection.</td>
</tr>
<tr>
<td>BACKSPACE</td>
<td>Undoes the last segment placed.</td>
</tr>
<tr>
<td>O</td>
<td>Switches between 45-degree and 90-degree orthogonal mode.</td>
</tr>
</tbody>
</table>

Route Miter
Choose Route » Miter to create 90-degree corners on routed connections into 45-degree mitered corners, 90-degree arcs, or T-routes. The 90-degree corner must be true horizontal and vertical segments and have the same line width.

You can also use the Route Miter tool to miter T junctions and existing mitered T junctions.

Using the Route Miter Tool
To use the Route Miter tool, do the following:

1. Select a corner style using the Route tab of the Options Configure dialog.

2. To create a 45-degree mitered corner, press and hold down the left mouse button on the 90-degree corner that you want to miter (see Figure A as follows).

3. Drag to create the mitered corner (see Figure B. Don’t release the mouse button until you have the proper length of mitering).

4. To create a 90-degree arc miter, press and hold down the left mouse button over on a 90-degree corner (see Figure A as follows), then drag to create the arc (see Figure B. Release the mouse button when you have the arc miter that you want).
5. For creating a T miter, press and hold down the mouse button on a selection point (see Figure A as follows), then drag to create the T miter (see Figure B. Release the mouse button when you have the T miter that you want).

6. To cancel a ghosted miter, right-click.

Press the O key while mitering to switch between 45 degree line and 90 degree arc miters. However, only 45 degree line miters are supported for T routes.

You cannot miter non-net traces.

Online DRC detects clearance or netlist violations for mitered traces.

**Editing Existing Miters**

Choose Route » Miter to pick an existing miter (line or arc) and change the miter distance as you would when creating new miters.
Options Commands

Using the Options Commands

You use the commands in the Options menu to change settings affecting many PCB actions. For example, you can use the Options commands to determine block selection criteria (selection mask), set default units (mm or mils), grid settings, object display colors, and object styles.

Options Selection Mask

Choose Options » Selection Mask to open a dialog that you use to define your selection criteria for block select operations, and for defining the single selection behavior for collocated objects. With this command, you can configure the block select feature to select all objects, objects by type, or even objects with specific parameters. You can also specify your selection criteria on a layer-by-layer basis. For example, certain types of objects for one layer, another type for another layer, etc.

The selection possibilities can be as specific or general as you choose. For example, if you want to change 10 mil lines to 15 mil lines on a specific layer set, you could do it very easily with this command with Edit Select and Line Properties, without affecting any other line widths on these or any other layers (not to mention ignoring all other objects within the block selection).

After you set up your block selection criteria, you can block select a group of objects by drawing a bounding outline around a group of objects. A bounding outline is the dotted rectangle that appears when you drag the mouse cursor across your workspace, to select a range of items or a design region. For more information, see Edit Select (page 356).

When you choose Options » Selection Mask, the Options Selection Mask dialog appears. From this dialog you can set criteria affecting the selection of specific objects and layers, as shown in the following figure.
Items

In the Items frame of the Options Selection Mask dialog, you can specify the objects that you want to include or exclude in a block select. If you want to include or exclude only a few items, choose one of these methods:

- If you want to include only a few items in your selection, click **Clear All** to cancel the selection of all check boxes in this frame. Then, select the check boxes that correspond to the items you want to select.

- If you want to exclude only a few items from your selection, click **Set All** to select all of the item check boxes. Then, clear the check boxes that correspond to the items that you want to exclude from your selection.

**Items Buttons (Selection Mask Dialogs)**

Some of the check boxes in the Items frame have a corresponding item button (e.g., Arc, Component). These check boxes have three states:

- Included (The check box is selected).
• Excluded (The check box is cleared).
• Masked (A shaded check mark appears).

The following figure shows you an example of a check box in each state: selected (e.g., Arc), cleared (e.g., Attribute), and shaded (e.g., Component).

When you click a check box so a shaded check mark appears, the corresponding item button becomes active. You can then click the button to open a Selection Mask dialog. You use this dialog to create a selection mask, which narrows the scope of your block selection criteria.

For example, if you click the Arc check box so a shaded check mark appears, the Arc button becomes active. Then, when you click Arc, the following Arc Selection Mask dialog appears:

In the Selection Mask dialog, you can specify the parameters for the particular object that you want as part of the selection block.

For example, to create a selection mask for arcs, you set the search criteria (in this case, arcs with an arc width of 50 mil) in the Arc Selection Mask dialog. If you designate 50 mil for the Arc Width, then when you do a block select, only 50 mil arcs will be selected within the block.

**Layers**

Use the options in the Layers frame of the Options Selection Mask dialog to select any combination of layers for the selection mask. When you choose a layer, it becomes highlighted in the list. You can individually select or cancel the selection of a layer by clicking on a succession of layer names and they will become part of (or be excluded from) the selection list.

If you want to exclude only a small number of layers, click Set All (the default setting) and individually choose the layers to exclude. To include only a limited number of layers, click Clear All, then individually choose the layers to include in your block selection.
Layer Sets
Use the Layer Sets list to apply the selection to specific, predefined layer sets. To select a layer set, do the following:
1. Select a layer set from the Layer Sets list.
2. Click Apply Layer Set.

The layers belonging to that set are selected in the Layers box.

See Options Layers (page 450) for information on creating layer sets.

Select Mode Frame
The options in the Select Mode frame give you the ability to include or exclude items in a block select, depending on their position relative to the bounding outline of the selection block. These options are as follows:
- **Inside Block**: Choose this button to select all items completely inside the bounding outline of the selection block.
- **Outside Block**: Choose this button to select items that are outside of the bounding outline of the selection block. All of the selection criteria that you specify in the Options Selection Mask dialog will apply to objects that are outside the selection block, rather than inside the block.
- **Touching Block**: Choose this button to select all items that both touch and fall inside the bounding outline of the selection block. This is a more inclusive selection option than Inside Block.

Selection Mask Parameters
This is a basic summary of the parameters you can choose from in the Selection Mask dialog.
- **Arc**: You can specify line width of arcs for a block select. You can also block select arcs that have been fixed in place. For more information, see Edit Properties (page 292) and Arc Properties (page 314).
- **Line**: You can specify line segments for a block select and block select fixed lines. For more information, see Line Properties (page 313).
- **Component**: You can specify component type, reference designator, pattern, value, fixed property and attributes. For example, you can include a specific component of a certain value, and the block select will include only those of that value. For details, see Edit Properties (page 292).
- **Copper Pour**: You can specify Pour Pattern, backoff, smoothness, state, thermal island removal, line properties and a specific net to include in the selection criteria. If the copper pour has filleted corners you can block select using the fillet handles and the chord height. You can also select copper pours that are fixed in place. For more information, see Copper Pour Properties (page 317).
Options Selection Mask

Chapter 17: Options Commands

- **Cutout**: You can specify the layer as part of the selection criteria. If the cutout has filleted corners you can block select using the fillet handles and the chord height. For more information, see Cutout Properties (page 323).

- **Polygon Keepout**: You can specify the layer as part of the selection criteria. If the keepout has filleted corners you can block select using the fillet handles and the chord height. See Polygon Properties (page 315) for more information.

- **Pad**: You can include Pad Number, Pad Style and Fixed pads in the selection criteria. For more information, see Pad Properties (page 354).

- **Plane**: You can include Net and Boundary Width in the selection criteria. If the plane has filleted corners you can block select using the fillet handles and the chord height. See Plane Properties (page 323) for details.

- **Polygon**: You can include the copper tie, fillet handles and the chord height if the polygon has filleted corners. See Polygon Properties (page 315) for more information.

- **Room**: You can include Name, Rules, Placement Side, Fill Pattern and the Fixed Property in the selection criteria. For details, see Room Properties (page 325).

- **Test Points**: You can choose the Top or Bottom option button to select points that reside on either the Top or Bottom side of the board. You can also select the Fixed or Snap to Center check boxes to choose points with those properties. For more information, see Test Point Properties (page 316).

- **Text**: You can use the mask feature to search for a specific text string, justification, and text style in your block select. For more information, see Text Properties (page 327).

- **Via**: You specify the via style to include in the block select as well as selecting only fixed vias. See Via Properties (page 311) for more information.

Selecting and Modifying

This is a scenario for selecting and modifying all lines of a width of 12 mil and changing them to 15 mil.

1. Choose **Options > Selection Mask** to open the dialog.
2. Click **Clear All** to cancel the selection all of the items in the Items frame (the X disappears from each box).
3. Click the **Line** check box until a shaded check mark appears. The Line button then becomes shaded.
4. Click the **Line** button to open the Line Selection Mask dialog.
5. In the Width box, type: 12.0mil
6. Click OK to return to the Options Selection Mask dialog.
7. In the Layers frame, click Set All to select objects on all layers.
8. In the Select Mode frame, choose Inside Block.
9. Click OK to close the Options Selection Mask dialog.
10. In your workspace, block select the entire design. To do this draw a bounding outline around the entire design. Only the 12 mil lines will be selected.
11. Choose Edit » Properties. In the Width box, type: 15 mil
12. Click OK.
   All 12 mil lines in the design will be converted to 15 mil.

   Items, which are part of a component (e.g., pads, silk attributes) are not affected.

Single Selection Tab
The Single Selection tab is used to control two selection features:

- Masking Objects during single selection – the options in the Single Selection tab are the same as the Block Selection tab, they are used to define exactly which object(s) on which layer(s) are able to be selected.

- How Collocated Objects are dealt with – the options in the Single Select Mode frame determine what happens when you click on collocated objects. If the Cycle-Picking option is selected then each collocated object is selected in turn as you continue to click on the collocated objects. If Popup dialog is selected a small dialog is displayed, from which you can click to choose the object to be selected.

   The popup dialog is also displayed when you use the CTRL click feature to perform a multiple selection at a location where there are collocated objects. In this case each entry in the popup dialog includes a check box, enable the check box for each collocated object you want to select. Click on the exclamation mark at the top left of the dialog to carry out the selection.
Options Configure

Choose **Options » Configure** to set various configuration options and parameters for P-CAD PCB. When you choose this command, the **Options Configure** dialog appears with the General tab active, as shown in the following figure:

![Options Configure dialog](image)

For details on the options available in each tab, see the following sections:

- **General Tab**, page 429.
- **Online DRC Tab**, page 433.
- **Route Tab**, page 435.
- **Manufacturing Tab**, page 437.

### General Tab

The **General** tab contains the following options:
Units
You can alter your display units between mils and millimeters with this option. Dimensions are not altered, only the unit of measurement of dimension. A mil equals 0.001 inch or 0.0254 mm. A mm equals 0.001 meter. When the selected unit is mm, you can control the number of digits displayed to the right of the decimal point by modifying the MillimeterPrecision setting in the `.ini` file. The default displayed precision is three decimal digits, but can be changed to an integer value of 2 through 5.

This setting affects all dialogs, reports, Status Line displays, etc., containing measurements. For example, setting Units to mm causes dialogs such as DXF Out, Pad Style, Via Style, etc., to display measurements in millimeters. These units can be overridden in many command settings.

Workspace Size
You can set your workspace size to the specified dimension. If you change units, then the values in this box will change to reflect the units (although the size will remain constant).

Pour/Repour Option
Choose one of the buttons in the Pour/Repour Option frame to define the pour order that P-CAD uses when you select a group of copper pours.

- **Smallest to Largest**: Choose this button to pour or repour a group of selected copper pours according to size, from smallest to largest. This option is selected by default.
- **Selected Order**: Choose this button to pour or repour a group of selected copper pours in the order you select them.

ECO Format
To generate Engineering Change Orders (ECOs), you turn on the ECO recorder by choosing **Utils » Record ECOs**. From the **Options Configure** dialog, you can select a format for these ECO files. This format applies to the active design.

The ECO file is generated in a ECO format or a Was/Is format. Choose the **ECO Format** or the **Was/Is Format** radio button to select a format.

ECO format records full ECOs. The Was/Is format records only RefDes changes.

Connection Options
Select the **Optimize Partial Route** check box to indicate whether the guide connection is to be optimized for Manhattan length after manual routing. When this option is selected, pressing the **SLASH** key during manual routing terminates the route and causes the guide connection line to connect to the nearest net endpoint. This optimization doesn’t occur if the check box is not checked, or if the net being routed has an “OPTIMIZE=NO” attribute.

The Optimize After Delete check box is used to indicate whether any connections added after a trace is deleted should be added in an optimized manner. If it is not necessary to add a connection to maintain connectivity, none will be added. If a connection is necessary, and either the check box is not checked or the net has an “OPTIMIZE=NO” attribute, the connection is added at the same location as the deleted trace.
The Optimize Max Node Count check box is used to specify the maximum node count desired when determining whether a net is automatically optimized. If a net has more than the number entered here it is not optimized. The default count is 20 and the count specified is saved in the Pcb.ini file.

To prevent a net(s) from optimizing, set the net attribute OPTIMIZE = “False”. See Edit Commands (page 279) for more information on setting net attributes.

| IMPORTANT: If you have chosen to include Connections in the Options Selection Mask dialog, and select a block of data in the design, any connections present in the group of selected items are not optimized. |

**AutoSave**

Use the options in the AutoSave frame to enable the AutoSave feature, which regularly saves your files at a user-defined interval, in a compressed or non-compressed format. AutoSave won’t be performed during autorouting or if a tool is busy.

The AutoSave frame contains the following options:

- **Enable AutoSave**: Select this check box to turn on the AutoSave feature.

- **AutoSave Time Interval**: Enter the time between saves. AutoSave uses a rolling backup to save files, incrementing each subsequent autosave file.

- **Purge Previous Backups**: When selected, the option causes all backups saved from the previous design session to be deleted when you begin a new design session.

- **Number of Backup Files**: Allows you to specify the number of design files to be archived before file names are reused. This must be a number between 1 and 99.

- **Compress AutoSave Files**: Compresses the file so that it uses less space when saved.

**Autopan**

Enter a value in the Autopan box to adjust the amount of autopanning that occurs when you move the cursor to the edge of the screen with the arrow keys. An autopan of 25 moves anything at the edge of the screen 25% nearer to the center of the screen; 50 moves fringe objects to the center, etc.

**Rotation Increment**

Enter a value in the Rotation Increment box to set a rotation value. The value you set here is activated when you select an object and press \( \text{SHIFT} + \text{R} \) to rotate it. Values must be between 0 and 360 degrees, and can be specified down to tenth degree resolution.

You can also press the \( \text{R} \) key to rotate a selected object by 90 degrees; \( \text{R} \) is not affected by what you specify in this dialog.
**Zoom Factor**
Enter a value in the Zoom Factor box to adjust the amount of zoom that occurs when you use the View » Zoom In or View » Zoom Out commands. A factor of 2.00 will double (or halve) the size of objects in the workspace, etc. Zoom factors must be greater than 1.00.

**File Viewer**
In the File Viewer box, enter the name of the program that you want to use as your system’s default file viewer. For example, type: Notepad. Then, when you view a report, log file, or error report, the document appears in the default file viewer you selected. If the program is in a directory that is not included in your Autoexec.bat path statement, include the complete pathname here.

**DDE Hotlinks**
Select the DDE Hotlinks check box to enable the exchange of hotlink data with P-CAD Schematic. Hotlink data consists of highlighting and unhighlighting commands for components and nets. The state of the DDE Hotlinks option is saved in the Pcb.ini file. For more information, see DDE Hotlinks (page 195).

**Solder Mask Swell**
Enter a value in the Solder Mask Swell box to set the solder mask swell value globally for all pads on the Top and Bottom solder mask layers. You can override the global swell value by specifying a pad style for the Top Mask and Bottom Mask layers (Options Pad Style).

A Solder Mask Swell resists the solder mask on the mask layers, in effect allowing solder to be placed both on the pad and the swell around it. The swell that is created conforms to the shape of the pad increasing the pad shape by the swell value. The swell value is added to the pad as a radius, enlarging the pad shape in all directions; therefore, if you have a 60 mil diameter pad and add a swell of 10 mil, the total diameter of the swell would be 80 mils. When you define a pad size for the Mask layer (creating a local swell value), the global swell value is ignored.

You can view the increased size by making the Mask layer current, and then redrawing (View Redraw) to see the results.

**Paste Mask Shrink**
Enter a value in the Paste Mask Shrink box to set the paste mask shrink value globally for the Top and Bottom Paste layers. You can override the global value with a local value by specifying a reduced pad size for the Top and Bottom Paste layers (Options Pad Style).

A Paste Mask Shrink reduces the size of the area that paste will be applied to when components are attached to the board in manufacturing (to prevent paste from squeezing out when it shouldn’t). The shrink is a radius value and should be figured as such when subtracting it from the diameter value of a pad. For example, a 60 mil pad with a 10 mil shrink value will create a 40 mil diameter entity. When you define a pad size on the Paste layer (creating a local shrink value), the global shrink value is ignored.

You can view the reduced size by making the Top Paste layer current, and then redrawing (View Redraw) to see the results.
**Plane Swell**
Enter a value in the Plane Swell box to define the global plane swell setting. You can override the global value by enabling and setting the **Local Swell** option in the Pad Style Properties dialog.

A Plane Swell is the gap between the copper on the plane layer and the hole on a pad or via which is not connected to the plane. A plane swell would not be applicable to pads or vias that are thermally or directly connected to the plane.

**Auto Plow Copper Pours**
When you select the **Auto Plow Copper Pours** check box, copper pours affected by new copper generated by the Route Manual or Route Interactive tools will autoplow when the route Completes or Suspends. Plowing can create more islands if you splinter existing islands, yet Automatic Island Removal is still performed using the settings you established for that copper pour.

**Compress Binary Designs**
Select the **Compress Binary Designs** check box to automatically compress binary files when you save them.

**Online DRC Tab**
You can enable several Online DRC features by selecting various options in the Online DRC tab, as shown in the following figure:
With the Online DRC function, select the **Enable Online DRC** check box to check for clearance and net width violations, shorts of traces (both lines and arcs) and vias, and net references to non-existent via styles that are added to a design during manual routing. Depending on the options chosen in the General tab of the **Options Configure** dialog, online DRC performs a check of the traces and vias against all items, excluding copper pours, on signal layers to determine if a DRC violation occurred. A violation occurring on a non-signal layer (such as a via intersecting a silk layer item) is not detected with Online DRC.

When Online DRC is enabled, the following DRC checks can be included if you select the appropriate check boxes in the Report Options list: Netlist Violations, Clearance Violations, Text Violations, Silk Screen Violations, Component Violations and Width Violations. The following DRC options are not available with Online DRC: Netlist Compare, Unrouted Nets, Unconnected Pins, Net Length, Copper Pour Violations, Plane Violations, Tie Nets and Drilling Violations.

In addition to setting report options, you can open the **Options Design Rules** dialog by clicking the **Design Rules** button. See [Options Design Rules](page 459) for details.

Severity Levels can be set for each rule in the design. In the Online DRC tab, click **Severity Levels** to open the **Rules Severity Level** dialog shown in the following figure.
You can select one or more rules and, in the Severity Level frame, choose one of the three levels (Error, Warning or Ignored) by clicking the appropriate radio button. When a rule is in violation and its severity level is set to Ignored it is summarized in the report if the **Summarize Ignored Errors** option is enabled in the **Utils Design Rule Check** dialog. For more information, see **Utils DRC** (page 506).

If you select the **View Report** check box, a report of violations created during routing is automatically presented after the command is complete.

Although you can enable or disable the Online DRC feature at any time, the feature defaults to disabled when you create a new design. The current Online DRC setting is saved to a design file and restored when a design file is opened.

A button for Online DRC is included on the toolbar. When the button is indented, Online DRC is turned ON; otherwise, it is OFF. You can also enable and disable Online DRC from within macros. See **Route Manual** (page 408) for additional information.

**Route Tab**

When you click the **Route** tab, the **Options Configure** dialog appears as follows:
Use the Route tab to set options for the Route Manual and Route Interactive tools. When the Route Interactive tool is active, you can open this dialog by right-clicking and choosing Options from the shortcut menu.

This dialog contains the following options:

**T-Route Default**
- **T-Route Default**: When the check box is selected, T-routing is the normal mode. You don’t need to press the **SHIFT** key first.

**Highlight While Routing**
- **Highlight While Routing**: Use these radio buttons to select which items to highlight while routing. Choose **Pads Only** to highlight only pads. Choose **Pads, Traces and Connections** to highlight the pads their connections and traces as you lay them down.

**Miter Mode**
Choose one of the buttons in the Miter Mode frame to select a miter mode for the **Route » Miter** command. You can choose **Line (45° corners)** or **Arc (90° rounded corners)**.
Manual Route
Choose one of the buttons in the Manual Route frame to set the behavior of the SLASH key and right-click action while manual routing:

- Choose **Right Mouse to Complete/Slash Key to Suspend** when you want to be able to right-click to complete a route and press the SLASH key to suspend routing.
- Choose **Slash Key to Complete/Right Mouse to Suspend** when you want to be able to press the SLASH key to complete a route and right-click to suspend routing.

Orthogonal Modes
Orthogonal modes are used while routing (Route Manual) or placing lines (Place Line) using lines that are horizontal, vertical, at 45-degree angles or with arcs. Orthogonal modes provided consist of three mode pairs, along with the tangent mode. Press the O key to switch between orthogonal modes and press the F key to switch between the current mode pair.

- **90/90 Line-Line**: Creates true 90-degree angles, long and short.
- **45/90 Line-Line**: Creates 45/90 and 90/45 angles.
- **90/90 Arc-Line**: Creates a combination straight line and arc, in long and short.
- **Tangent Arc**: Creates arcs that are tangential to their connected lines using the current radius.

Interactive Route
The options in the Interactive Route frame apply to the actions you can perform with the Route Interactive tool:

- **Stub Length**: The suggested minimum length in grid points of the line segment, which is used to enter or exit the pad. For non-uniform grids, one grid space is the sum of the grid values.

Manufacturing Tab
Use the Manufacturing tab of the Options Configure dialog to specify the solder flow direction and other physical behaviors for the manufacturing process.
Solder Flow Direction
The Solder Flow Direction group allows the user to specify the direction the solder flow is traversing the board. The available options are: Top to Bottom, Left to Right, Right to Left and Bottom to Top.

Synchronize Components to solder flow, on OK
The Synchronize Components to solder flow, on OK, checkbox determines whether the patterns in the design will be updated in line with the chosen solder flow direction. If the check box is checked, then upon pressing OK, after changing the direction of solder flow, the patterns on the board will be updated automatically with the appropriate alternate pattern graphics for the new solder flow direction.

Solder Mask Swell
Allows you to set the solder mask swell value globally for all pads on the Top and Bottom solder mask layers. You can override the global swell value by specifying a pad style for the Top Mask and Bottom Mask layers (Options Pad Style).

The swell that is created will conform to the shape of the pad, increasing the pad shape by the swell value. The swell value is added to the pad radially, enlarging the pad shape in all directions. When
you define a pad size for the Mask layer (creating a local swell value), the global swell value is ignored.

You can view the swell size by making the Mask layer current, and then redrawing (View Redraw) to see the results.

**Paste Mask Shrink**

Allows you to set the paste mask shrink value globally for the Top and Bottom Paste layers. You can override the global value with a local value by specifying a reduced pad size for the Top and Bottom Paste layers (Options Pad Style).

The shrink value is applied radially to all sides of the pad. For example, a 60 mil pad with a 10 mil shrink value will create a 40 mil diameter entity. When you define a pad size on the Paste layer (creating a local shrink value), the global shrink value is ignored.

You can view the reduced size by making the Top Paste layer current, and then redrawing (View Redraw) to see the results.

**Plane Swell**

Allows you to set the plane swell value for all pads, which applies unless a pad has its local swell option enabled.

Plane Swell is the gap between the copper on the plane layer and the hole on a pad or via which is not connected to the plane. Plane swell is not applicable to pads or vias that are thermally or directly connected to the plane.

### Options Grids

Choose **Options » Grids** to define the current editing grid. Grid options and settings are saved in your design file.

The grid units used are determined by the Units setting in **Options Configure**. For details, see Options Configure (page 429).
Chapter 17: Options Commands

Options Grids

Mode
In the Mode frame, choose Absolute when you want the grid origin point to be the lower-left corner of the workspace. Choose Relative to allow any point as an origin point.

A typical setting is to set your Absolute mode to 100 mil grid spacing and Relative to 25 mil grid spacing. You can then click the Abs and Rel toggle buttons on the Status Line to switch between 100 mil and 25 mil grid. (The relative grid origin should be set to Absolute 0,0 for this to work.)

Visible Grid Style
Select the Visible check box to show or hide grids. When you select this check box, the grid style options are available. Dotted pinpoints grid points, while Hatched draws lines along the grids to show grid intersections (similar to graph paper).

Relative Grid Origin
To specify your X and Y relative grid origins, enter the coordinates in the X and Y boxes. When you do this, you must clear the Prompt for Origin check box.

If you switch to a relative grid (by choosing Relative in the Options Grids dialog) and the Prompt for Origin check box is selected, you will be prompted for the new origin point after you click OK. You will be prompted every time you change from absolute to relative grids by clicking the Abs or Rel toggle button on the Status Line. Or, by pressing the A key.

Grid Spacing: Uniform/Non-uniform
You can select appropriate values for grid spacing for specific modes in the Grids list. You are not limited to using the grids in the list; you can specify your own custom grid spacing in the Grid Spacing box, then click Add to add it to available choices in the list. To delete a grid-spacing value, select the value in the Grids list and click Delete.

The routing grid defines the spacing pattern of the grid points. The grid pattern may be uniform (equal spaces between all lines) or it may be non-uniform to allow one or more lines to pass between component pads, while keeping the number of grid points to a minimum.

Uniform grids are generally used for relatively simple, low-density PC-boards. The illustration below shows 60-mil pads spaced 100-mils apart, 50-mil grid spacing (using the hatched grid option), with one routing connection running between the pads.
Non-uniform grids are typically required on complex, high-density PC-boards to achieve completion of the connections in the minimum amount of time.

The main benefit of the non-uniform grid over the uniform grid is performance: it produces far fewer grid positions without the loss of route paths. Thus, completion time is shortened and more freedom in placement is allowed.

For example, if you have 100-mils between grid points, you can set non-uniform grid spacing to 40-20-40, which would allow two grid points between pads spaced 100 mils apart.

Remember to set up your grids correctly before you place your components. It is important that you place the components on the appropriate grids (e.g., standard DIP components on 100-mil absolute). You can subsequently alter your grid spacing for routing purposes (such as non-uniform as described above).

**Grid Toggle Button (or G key)**

You can switch between your absolute and relative grid settings by clicking the **Abs** or **Rel** grid toggle button. Or, you can press the **G** key. Your absolute and relative grids are determined by what you have set in the *Options Grids* dialog. For example, if you have Relative set to 25 mils and Absolute set to 100 mils, the Status Line will read 25 mil when you are in Relative grid and 100 mil when you are in Absolute grid.
If you click the Grid toggle button or press the G key to switch to Relative grid, you will be prompted for the origin point if you have the Prompt for Origin check box selected in the Options Grids dialog. The crosshair cursor (the cursor displayed when the system is awaiting input) is displayed; when you click in the workspace, that becomes the relative origin point (X=O, Y=O) and the cursor returns to normal.

### Options Display

Choose Options > Display to open the Options Display dialog. There are two tabs in this dialog: Colors and Miscellaneous. With these tabs, you define your workspace preferences.

![Options Display dialog]

#### Colors

This tab contains two frames and a Defaults button. Click Defaults to return your display setup to the default scheme. Any color settings established here are saved in your Pcb.ini file when you close the dialog. These settings affect your designs in subsequent sessions, until you change them.

If you have a color printer, clicking the Defaults button also restores default color settings for printing. For information on print colors, see Colors and Other Print Options (page 214).

The following sections describe how to use the controls in the Layers/Items Colors frame and the Display Colors frame. If you have a color printer, any changes you make in these frames also affect your print colors.
Layer/Item Colors

The Layer/Item frame contains a color matrix with item buttons across the top and layer buttons along the side. Use the arrows or slider in the scroll bar to scroll down to any of the available layer buttons.

There are three ways to choose color options:

- To select a color for everything that appears on a layer, click the corresponding layer button and select a color from the palette that appears. For example, click the Top button to select a color for everything that appears on the top layer of your design.

- To choose a color for an object on a layer, click an Item button. For example, click Via to choose a color for vias on all layers of your design.

- To choose a color for an object on a specific layer, right-click the colored square where the object and the layer meet in the matrix. Then, choose a color from the palette.

You can also set a custom color. To learn how, see the following section. To close the color palette without choosing a color, press ESC or click Close.

Setting A Custom Color

To set a custom color, click Custom in the color palette. This opens a Color dialog that is standard to Windows. Next, choose a color from this dialog using one of these methods:

Method 1: Select a Defined Custom Color

1. Click one the colors in the Basic colors frame.
2. Click OK to return to the color palette.

Method 2: Define a Custom Color

1. Click the color matrix to define the Red/Green/Blue settings, or type the desired settings in the Red/Green/Blue boxes.
2. Click Add to Custom Colors.
3. When selected color appears in the Custom Colors area, click OK to return to the color palette.

Some custom colors can display only when supported by your screen settings. If your screen supports 256 Colors, custom colors are approximated to the nearest solid color, while retaining the Red/Green/Blue settings. If your screen supports more than 256 colors, custom colors display accurately.

Once custom colors are selected, they appear as the chosen item or display color on the Options Display dialog or the Printer Colors dialog. These colors are saved in the .ini file for use in later design sessions. In the Custom Colors section of color palette, however, colors not selected for an item/display color are forgotten once you quit the P-CAD program.
Display Colors
In the Display Colors frame, there are several command buttons. Click one of these buttons to determine various PCB display colors. The settings configured with these buttons appear in your workspace, regardless of layer or item colors.

When setting your display colors, make sure that the colors you pick do not conflict with any layer or item colors. For example, if the background color is set to be the same as the line color, lines will not be visible in your design.

When you click a display color button, a color palette appears, so you can select a color for that item. For example, click Highlight to choose a color for highlighted objects. Later, if you choose to highlight an object during a PCB design session, the object color changes to the color set here. To highlight an object, click an object in your workspace and choose Edit Highlight.

You can use highlight colors to highlight objects using different colors. To do so, change the highlight color, select the object, and choose Edit Highlight. Repeat this process for each object you want to highlight, so that each object selected has a different highlight color. When you change the highlight color of one object, it does not affect the highlight color of other highlighted objects, which are not selected.

Miscellaneous
To set up other display options for your workspace, click the Miscellaneous tab in the Options Display dialog. As shown in the following figure, this tab contains a number of options:
**DRC Errors**
DRC error indicators contain information about design errors and the layer on which errors appear. In the DRC Errors frame, you have these options:

- **Show**: Choose this button to show DRC error indicators in your design.
- **Hide**: Choose this button to hide DRC error indicators.
- **No Change**: Choose this button to keep the current display setting.

For information on DRC errors, see * Utils DRC (page 506).*

**Glue Dots**
Glue dots hold components in place until they are soldered during manufacturing. In the Glue Dots frame, you have these options:

- **Show**: Choose this button to show glue dots in your design.
- **Hide**: Choose this button to hide the display of glue dots.
- **No Change**: Choose this button to keep the current display setting.

To learn more about glue dots, see *Place Point (page 384).*

**Pick and Place**
A reference point that directs the pick and place mechanism (or auto insert) in manufacturing. In the Pick and Place frame, you have these options:

- **Show**: Choose this button to display Pick and Place points in the workspace. A pick and place point can be part of a pattern when you create it.
- **Hide**: Choose this button to hide the display of pick and place points.
- **No Change**: Choose this button to keep the current display setting.

For instructions on placing pick and place points, see *Place Point (page 384).*

**Cursor Style**
To change the style of your cursor, choose one of the following option buttons:

- **Arrow**
- **Small Cross**
- **Large Cross**

The large cross extends horizontally and vertically to the edges of the PCB screen. There is no default setting for this frame. When you click **Defaults**, your current setting remains in effect.

*The Large Cross cursor style does not support the DataTips feature. Enabling this option clears the Show DataTips check box and makes the feature unavailable.*
Free Pads
Choose one of these option buttons to change the display options for free pads:

- **Pin Des.** Show the default pin designators
- **Number.** Show the pad numbers.

There is no default setting for this frame. When you click **Defaults**, your current setting remains in effect.

**Miscellaneous**
The Miscellaneous frame contains a number of check boxes. To enable an option, select its check box. Clear a box to disable an option. To restore the default settings at any time, click **Defaults**.

- **Draft Mode.** Enables the display of two items: (1) a thin (single-pixel) outline for pads, vias, and text. (2) a segmented and outlined representation of arcs, lines, and any line segment objects such as, polygons, cutouts, etc.

  When enabled, draft mode helps with faster redraws and viewing of any segment overlaps.

- **Thin Stroked Text.** Select this check box to display text in thin line mode. Clear this check box to display text in regular mode.

- **Display Pad Holes.** Select this check box to display pad holes in the active window. If the Translucent Drawing check box is also selected, pad holes are disabled from display.

- **Display Pin Designators.** Select this check box to display pin designators. Designators appear just above the pad center, but only when you are zoomed in sufficiently. This setting also affects the display of default pin designators and free pad numbers.
• **Display Plane Indicator.** This option sets whether or not the plane indicator is displayed, allowing you to see to which plane a pad is attached.

   When viewing Gerber drill files, be sure to disable this option so they are not confused with drill symbol output.

• **Display Pad Net Names.** This option enables or disables the display of the pad net names just below the pad centers. To view net names, you must be zoomed in sufficiently. The following illustration shows the net names NET00001 and NET00002.

• **Display Overridden Errors.** Select this check box to display overridden errors in your design. Clear this check box to disable the display of overridden errors. To learn more about overrides, see *Utils DRC* (page 506).

• **Drag by Outline.** Clear this check box to show a ghosted image of the part and a bounding outline when you move or copy objects in your design. Select this check box to show only the bounding outline. This setting affects only the move and copy operations associated with the *Edit Select* command.

• **Silkscreen in Background.** Select this check box if you want silk layers to be drawn in the background. Clear the check box to have silk layers drawn in the foreground.

• **Translucent Drawing.** Select this check box to show objects in translucent mode. Clear this check box to show objects in opaque mode.

• **Use Fixed Color.** Select this check box to have fixed components drawn in the fixed component color. To set this color, click *Fixed* in the Colors tab.

• **Scroll Bars.** Select this check box to show Windows scroll bars in the active window. Clear this check box to hide the display of scroll bars.

• **Show DataTips.** Select this check box to show DataTips in the workspace. Clear the check box to hide the display of DataTips.
The Large Cross cursor style and the View » Snap to Grid command do not support the DataTips feature. For details, see Cursor Style (page 445) and View Snap to Grid (page 367).

Options Preferences

Choose Options » Preferences to set up your keyboard and mouse preferences for P-CAD PCB. When you choose this command, the Options Preferences dialog appears with the Keyboard tab selected, as shown in the following figure.

Keyboard Tab

Use the options in the Keyboard tab to customize key assignments for menu commands, shortcut key commands, and macros.

- **Command Type**: Choose the type of command for which you want to change shortcut key assignments.

- **Menu Commands/Shortcut Commands/Macros**: Select the command or macro you want to add a shortcut key assignment to or from which you want to remove a shortcut key assignment.

- **Current Keys**: Displays the existing key assignments for the command or macro you select in the Menu Commands/Shortcut Commands/Macros list.
Options Preferences

Chapter 17: Options Commands

- **Press a Shortcut Key:** Press the keys you want to assign to the selected command or macro. You can press the **CTRL** or **SHIFT** key plus any other combination of numeric or alphabetic keys and function keys.

**F10** is reserved by Windows and cannot be assigned to any other command or macro.

If the shortcut is currently assigned, the current assignment appears in the **Current Binding** field just below this box.

- **Assign:** Assigns the key appearing in the Press a Shortcut Key box to the selected command or macro. If the shortcut is currently assigned, the current assignment disappears.

- **Remove:** Removes the key you select in the Current Keys box.

- **Key File:** Allows you to select or create a key binding file to use with this application. When the **Select Key File** dialog appears, select the file you want to use. The current key file appears at the top of the dialog, and is written to the **Pcb.ini** file.

- **Defaults:** Restores original default shortcut key assignments to all commands or macros.

**Mouse Tab**

When you click the **Mouse** tab, the **Options Preference** dialog appears as follows:

The Mouse tab lets you customize certain mouse behaviors.
• **CTRL/SHIFT Behavior:** Allows you to choose which keys to use (CTRL or SHIFT) for multiple (extended) selections and for subselections.

• **Cycle-Picking Threshold:** The number of pixels you can move the mouse during cycle-picking.

• **Double-Click Displays Properties:** When enabled, this option allows you to double-click an object to bring up the Properties dialog for that object.

• **Allow Single Select on All Enabled Layers:** When enabled this option provides the ability to single select across multiple, enabled layers. This option can also be enabled/disabled by pressing CTRL+L. The search order is as follows:
  1. Current layer items.
  2. Current layer components if on the Top or Bottom layers.
  3. Multi-layer items; i.e., all-layer keepouts, components, pads, vias, connections and points.
  4. All other layers in order.

In addition, the Status Line shows the layer name of the selected object.

### Options Layers

Choose **Options » Layers** to view layers and make modifications to layer properties.

When you choose **Options » Layers**, the Options Layers dialog appears. This tab contains the following tabs: Layers, Sets and Titles. When the dialog first appears, the Layers tab is selected, as shown in the following figure:
This dialog allows you to set the current layer for the Place and Select commands. You can also arrange layers in a specific order. You can also add, delete, reorder, enable, and disable layers, and modify the routing bias of a layer.

**Layers Tab**

The Layers tab contains the following options:

**Layers**

In the Layers box are listed all existing layers of your design. The letter codes between the layer name and layer number represent the following:

**Type:** S = Signal, P = Plane, N = Non-Signal  
E = Enabled, D = Disabled  
**Routing Bias:** A = Auto, H = Horizontal, V = Vertical (signal layers only)
Layers can be moved up and down the list by clicking Move Up and Move Down.

Layer Name
Shows the name of the currently selected layer.

Layer Number
Shows the number of the currently selected layer.

Line Color
Shows the line color for the current layer.

Routing Bias
These options are applied to a new signal layer (Add) or an existing signal layer (Modify). The bias values are used only by the autorouter; the Route » Manual command does not use these options.

Type
These options are applied to a new layer (Add). You cannot modify the Type of an existing layer.

Actions
The following list shows the actions performed for each button in the dialog:

- **Move Up/Move Down**: Arranges layers in your design to reflect the actual layer order of your board. However, signal and plane layers must be between the Top and Bottom layers.
- **Add**: Adds to the list whatever Layer Name you have specified, with the Layer Number, Routing Bias, and Type specified.
- **Modify**: Changes the routing bias on a signal layer and to change the net name of a plane layer. To modify the routing bias, select a signal layer, choose a routing bias option and click Modify. To modify a plane layer net name, select a plane layer, click Modify and enter the new name in the Plane Layer Net Name dialog.

You can rename a layer although you can’t change the Type or layer number. You can also reassign a plane net name.

- **Delete**: Removes a selected layer. You can delete any user-defined layer that is empty. You cannot delete a predefined layer.

| When you delete a layer, components are processed and stripped of any items that existed on the deleted layer; this is done without warning. |

When you delete a layer that a pad/via style’s hole range is dependent on, an error message appears explaining the dependency and which style you should correct. You are not allowed to delete a layer until there are no styles that are dependent on it.

- **Current**: Makes the selected layer the current layer (indicated by an asterisk).
The current layer cannot be disabled. Also, items on disabled layers don’t appear and can’t be edited.

- **Enable/Disable**: Enables or disables the selected layer.
- **Enable All/Disable All**: Enables or disables all existing layers regardless of which layer is selected in the Layers list.

### Add a Layer

When you add (create) a layer, you must give it a unique name, specify a layer number (one that is not already occupied), a routing bias, and a layer type. When you create a plane layer, you must give it a net name.

1. In the **Options Layers** dialog, type the new layer name in the Layer Name box and specify the Layer Number to enter the Add mode. The **Add** button is shaded until you specify layer name and number.
2. If you are adding a signal layer, click on the **Routing Bias** you want to use (used only by the autorouter).
3. Click the **layer Type** you want.
4. Click **Add**. The new layer will be listed in the list, with the layer type (S, P, or N), E for enabled, and the layer number you specified.
   - Once a layer has been created/added, you cannot change its layer number or type.
   - Signal/plane layers are placed just above the Bottom layer. Non-signal layers are placed at the bottom of the list.
5. Click **Move Up** and **Move Down** to arrange the layers in the appropriate order.
6. If this is a plane layer, you are prompted for a net name.

P-CAD PCB (6/400) designs are restricted to a maximum of six copper layers, including a predefined Top and Bottom layer and four user-defined signal or plane layers. P-CAD PCB (6/400) designs can have a total of up to 999 layers.

### L key and Status Line

You can press the **L** key or the Layer box on the Status Line (combo box and scroll arrows) as a shortcut for selecting the current layer. The current layer is identified by name and color on the Status line. Press **SHIFT-L** to scroll backwards through the enabled layers.

### Sets Tab

When you click the **Sets** tab, the dialog appears as follows:
Layers sets let you group layers to control the selection, display, and printing of your design, Gerber output and N/C Drill output, DXF output.

**Current Layer**

The **Current Layer** list displays the name of the current layer for the selected layer set. You can change the current layer by selecting a different layer from the list.

**Layers**

The Layers box displays a list of all layers in the design.

**Set Name**

The Set Name box allows you to add a layer set name.

**Layer Sets**

The Layer Sets box displays a list of all layer sets in the design.
**Set Contents**
The Set Contents box displays a list of all layers in the currently selected layer set.

**Adding or Modifying a Layer Set**
To add or modify a layer set, follow these instructions:

To add a new layer set, type a new name in the Set Name box and press **New**. The newly-added layer set is empty.

1. To add a layer to the set, select the layer set from the Layer Sets box. Select the layer to be added from the Layers box and click **Add**.

2. To remove a layer from a layer set, select the layer set from the Layer Sets box. Select a layer from the Set Contents box and click **Remove**.

3. Click **Enable Layers** to save the layer set.

4. To delete a layer set, select it and click **Delete**.

**Titles Tab**
The Titles tab of the Options Layers dialog allows you to specify the look of your title block, design boundary and zones for each layer in your design. You can also assign a field set to a layer, so that each layer can be uniquely annotated. The Titles tab appears as shown in the following figure:
When setting up output files (Gerber, Print and DXF) only the data displayed in the workspace is output. It is important, therefore, to turn on the appropriate display options (Display Border and Annotate Zone Information) on the Titles tab of the Options Layers dialog.

The options available in the Titles tab are:

**Layers**
Lists the layers of the design. To specify the **Titles** options of a layer(s), select the desired layer(s) in the list.

**Border Frame**
In the Border frame you can set the following options:

- **Height/Width**: Shows the height and width of the border that surrounds the design. The default border height and width have a 1/2 inch buffer from the workspace bounds.
• **Display Border**: To display the border in the workspace or on the printed output or to include it in a Gerber output file, select the **Display Border** check box. The border outline the boundaries of the design.

**Zone Frame**
The Zone frame accesses the following settings in both the Horizontal and Vertical frames:

- **Alpha or Numeric** for the zone label display.
- **Ascending** to specify zone labels increasing vertically from top-to-bottom or horizontally from left- to-right.
- **Descending** to specify zone labels decreasing in the same directions as the Ascending option.
- **# of Zones**.

**Annotate Zone Information**
Select the **Annotate Zone Information** check box to display the zone labels.

**Text Style**
Select the style of text you want to use from the list of Text Styles.

**Title Block Frame**
The following information appears is the Title Block frame:

- **File » Name**: Display the currently selected title block file name. To change the to another block file, click the **Select** button. To remove the selected title block, click the **Remove** button.
- **Lower-Right Offset**: If the origin of the border differs from the default in the lower left hand corner of the workspace, specify different X and Y coordinates in this frame.

**Field Set**
Select the field set you want to assign to the currently selected layer(s) from the list. Click the **Field Sets** button to modify, delete or add a field set. Click the **Fields** button to open the **File Design Info** dialog where you can assign fields and notes to each field set.

**Modify/Close**
Click the **Modify** button to update the Titles options of the layers selected in the Layers list with the current settings. Click **Close** to exit the **Options Layers** dialog and save the modifications.

---

**Options Current Line**
Choose **Options » Current Line** to set the current line width for the Place Line, Place Arc, and Route Manual commands. The current line setting doesn’t affect placing of line segments for polygons, copper pours, keepouts, connections, etc.
When the dialog appears, the Line Width box contains the current line width value. The current line width is highlighted in the list.

To choose a new line width value, select a new value from the list.

To add a new line width value, type the new value in the Line Width box and click Add. The new value is inserted in the list before the highlighted value. To add a new value and make it the current value in one step, type the new value in the Line Width box and click OK.

To delete a value, select it from the list and click Delete.

**Overriding Default Units**

The units displayed as default in Options » Current Line are determined by what is set in Options Configure. To reset units, use Options Configure, or you can override the default units by typing in an explicit suffix (e.g., in) in the Options Current Line dialog. Valid suffixes are: mm, mil, in, and cm.

The current line settings are saved to the Pcb.ini file.

To change the line width (thickness) of existing lines and arcs (routed lines and arcs as well), choose Edit » Properties.

**Options Current Keepout**

Keepouts are used to designate certain areas of your design as off limits to certain processes, for example routing. Keepouts can be either polygons or lines, and they can be specific to a layer, or can apply to all layers.

Choose Options » Current Keepout to set the keepout Style and Layer in the Options Current Keepout dialog. These settings will apply when you select the Place » Keepout command. The following figure shows you the Options Current Keepout dialog:
In the Style frame, choose the style of the keepout barriers (Line or Polygon). In the Layers frame, choose **Current** to restrict keepouts to only certain layers (the current layer) or **All** to place one object that applies to all signal and plane layers.

For related information, see *Place Keepout (page 390)*.

**Options Current Radius**

When you choose **Options » Current Radius**, the following **Options Current Radius** dialog appears:

Use the **Options Current Radius** dialog to select the radius to be used when rounding the corners of polygonal shapes, including copper pours, cutouts, polygon keepouts, planes and polygons. The Current Chord Height, which is the maximum distance between a perfect arc and the actual arc, can be designated in the **Options Current Radius** dialog as well.

The radius setting you choose determines the curvature of the arc used to draw the rounded corner. Since the majority of polygonal shapes have on-grid corners with fillet radii that are multiples of the placement grid, it is suggested that the radius setting be a multiple of the grid.

You can add new settings and delete those that you have added in the **Options Current Radius** dialog. The predefined settings shown above cannot be deleted. The current radius setting is displayed in and can also be controlled from the Current Radius combo box on the Status Line.

See *Edit Commands (page 279)* for related information on rounding the corners of the polygonal shapes listed above.

**Options Design Rules**

The rules for a board's clearances, widths, lengths and placements are set in the **Options Design Rules** dialog, which is opened by choosing the **Options » Design Rules** command. Design rules can be defined on each of six levels: Design, Layer, Rooms, Net Class, Net and Class-to-Class. Each of these levels, found on individual tabs in the dialog, is described in the following sections.

**Design Tab**

The **Design** tab displays the clearance values that are applied at the “design” level of the hierarchy:
To add design rules, click **Add** to open the *Place Attribute* dialog. The **Properties** button opens the *Attribute Properties* dialog where the value of a rule can be modified. For more information on the *Place Attribute* and *Attribute Properties* dialogs, see *Edit Attributes* (page 350).

**Layer Tab**

As shown in the following figure, the **Layer** tab contains the default clearance values for signal layers:
In the Layer tab, the following options are available:

- **Set All**: Click Set All to select all layer names with items in the Layers list.
- **Clear All**: Click Clear All to cancel the selection of all layers in the list. You can select or cancel the selection of a layer by clicking a layer in the list.
- **Update**: The clearance values of the layer you select appear in the Pad to Pad, Pad to Line, Line to Line, Pad to Via, Line to Via, and Via to Via boxes. If you have a variety of settings and you click on two layers that contain conflicting values, the box is blank. The value you enter in the box is applied to the selected layer(s) when you click Update.
  
To modify a clearance value for the selected layers, type a value in one of the text boxes and click Update. Nets with clearance rules defined will override the layer clearance values for DRC. The report produced by the DRC includes clearances specified for specific nets. Additionally, clearance violation tests report shorts except where two or more nets are tied with a copper tie and the TieNet values of the nets and copper tie are the same.

- **Edit Rules**: Click Edit Rules to open the Attribute dialog where you can add, delete and view a rule’s properties. For information on the Attribute dialog, see Place Attribute (page 396).
- **Set Defaults**: Click Set Defaults to return all layer/item settings to 12 mil clearances.
- **OK**: When you have finished setting up the design rules, click OK.

**Clearance Rules**

When a clearance rule for a specific object is requested (e.g., DRC), the design rules category determines which rules apply and the order in which they are applied.
The order of evaluation matches the order of evaluation used by the SPECTRA Router. P-CAD PRO Route uses only layer and net clearance rules.

P-CAD DRC ignores SPECTRA Router clearance rules that have been added as attributes.

### Rooms Tab

Clicking the **Rooms** tab displays the Rooms in the design, as shown in the following figure:

![Rooms Tab](image)

The following information appears in the Rooms tab:

- **Rooms**: The Rooms list shows the rooms in the design.
- **Rules**: The Rules list shows the rules that have been defined for the selected Room.
- **Placement Side frame**: The Placement Side frame shows whether the Room has been placed on the Top, Bottom or Top or Bottom of the layer.

To add, delete or edit the rules click the **Edit Rules** button and make the appropriate changes in the **Attribute** dialog. You can also access a rule’s properties by double clicking the rule in the Rules list.

### Net Class Tab

When you click the **Net Class** tab, the dialog appears as follows:
The Net Class tab lists all net classes and the rules associated with each Net Class and Net Class Layer. The options available on the Net Class tab are:

- **Net Classes**: The Net Classes list shows the name of each Net Class and indicates the presence of Net Class or Layer rules. Net Class rules are indicated with an N, while Net Class Layer rules are indicated with an L.

- **Net Class Rules**: The Net Class Rules list shows the net class rule names and values. To modify the Net Class Rules, click the **Edit** button to open the Attributes dialog to make changes (see *Edit Attributes (page 350)* for details on the Attribute dialog) or double-click a rule in the list box to modify the rule’s value.

- **Net Class Layer Rules**: The Net Class Layer Rules list shows the net class layer rule names and values. To modify the Net Class Layer rules, either double-click the rule in the list box to make changes to the rule’s value or click **Edit** to open the *Edit Net Class Layer Rules* dialog:
The Edit Net Class Layer Rules dialog lists the Layers and indicates whether the layer has Rules with an asterisk. You can select net classes having specific layer rules and values by clicking the Select by Rule button to open the Set By Attribute dialog (for details on the Set By Attribute dialog see Set By Attribute (page 349). You can also click the Edit Layer Rules button to open the Attributes dialog for modifications.

- **Select Net Class by frame:** The Select Net Class by frame allows you to set Net Classes by Net Class Rules or Net Class Layer Rules.

Click Net Class Rules to go directly to the Set By Attribute dialog (for details on the Set By Attribute dialog see Set By Attribute (page 349). The Layer Rules button opens the Select Layer dialog where you can choose the layer with the attributes you intend to use to set the Net Classes, and then opens the Set By Attribute dialog when you click OK (for information on the Select Layer dialog, see Set Nets By Layer Attribute (page 350).

- **View Rules:** Opens the Notepad and displays a list of rule names and values for each selected Net Class.

- **Edit Net Classes:** Click Edit Net Classes to open the Net Classes dialog where you can define a group of nets that share the same rules as a Net Class. The Net Classes dialog also displays the Net Class and Net Class Layer rules and their values. For complete information on the Net Classes dialog see Options Net Classes (page 469).

### Net Tab

When you click the Net tab, the dialog appears as follows:
Use the options in the Net tab to specify rules for a specific net in the design. The dialog lists all nets and shows the net and net layer rules associated with the selected net. The following options are available in the Net tab:

- **Nets**: The Nets list shows the name of each Net and indicates the presence of Net or Net Layer rules using the legend shown in the Has Rules frame. Net rules are indicated with an \( N \), while Net Layer rules are indicated with an \( L \).

- **Net Rules**: The Net Rules list shows the net attribute name and values. To modify the Net Rules, click **Edit** to open the **Attributes** dialog. See **Edit Attributes** (page 350).

- **Net Layer Rules**: The Net Layer Rules list shows the net layer rule names and values. To modify the Net Layer rules, click **Edit** to open the following **Edit Net Layer Rules** dialog:
Similar to the Edit Net Class Layer Rules dialog, the Edit Net Layer Rules dialog lists the Layers and indicates whether the layer Has Rules with an asterisk. You can select layers having specific rules and values by clicking the Select by Rule button to open the Set By Attribute dialog (see Set By Attribute (page 349) for details).

- **Select Net by:** The Select Net by frame provides access to the Set by Attribute dialog where you can select the attributes and values you want to use to set the Nets. Click the Net Rules button to go directly to the Set by Attribute dialog (see Set By Attribute (page 349)). The Layer Rules button opens the Select Layer dialog where you can choose the layer with the attributes you intend to use to set the Nets (for information on the Select Layer dialog see Set Nets By Layer Attribute (page 350)).

- **View Rules:** Opens the Notepad and displays a list of rule names and values for each selected item.

- **Edit Nets:** Click Edit » Nets to open the Edit Nets dialog, where you can view and modify net information. See Edit Nets (page 345) for details.

### Class to Class Tab

When you click the Class to Class tab, the dialog appears as follows:

Use the options in the Class to Class tab to specify clearance rules for a specific class-to-class in the design. The dialog lists all defined class-to-classes and shows the rules associated with them. The Class to Class tab contains the following options:

- **Class to Class:** The Class to Class list shows the name of each Class-to-Class and indicates the presence of Class-to-Class or Class-to-Class Layer rules using the legend shown in the Has

466 P-CAD PCB User's Guide
Rules frame. Class-to-Class rules are indicated with a C, while Class-to-Class Layer rules are indicated with an L.

- **Class to Class Rules:** The Class to Class Rules list shows the Class-to-Class rule name and values. To modify the Class-to-Class Rules, click **Edit** to open the **Attributes** dialog. See **Edit Attributes** (page 350).

- **Class to Class Layer Rules:** The Class to Class Layer Rules list shows the class-to-class layer rule names and values. To modify the Class-to-Class Layer rules, click **Edit** to open the **Edit Net Class To Net Class Layer Rules** dialog:

  ![Edit Net Class To Net Class Layer Rules dialog](image)

  Similar to the Edit Net Class Layer Rules dialog, the Edit Net Class to Net Class Layer Rules dialog lists the Layers and indicates whether the layer Has Rules with an asterisk. You can select layers having specific attributes and values by clicking the Select by Rule button to open the Set By Attribute dialog (see **Set By Attribute** (page 349) for details).

- **Select Class-to-Class by:** The Select Class-to-Class by frame provides access to the **Set by Attribute** dialog where you can select the attributes and values you want to use to set the Class-to-Class Classes. Click **Class-to-Class Rules** to open the **Set by Attribute** dialog (see **Set By Attribute** (page 349) for details). The **Layer Rules** button opens the **Select Layer** dialog where you can choose the layer with the attributes you intend to use to set the Class-to-Class (for information on the **Select Layer** dialog see **Set Nets By Layer Attribute** (page 350).

- **View Rules:** Opens the Notepad utility and displays a list of rule names and values for each selected item.

- **Edit Class to Class:** Click **Edit » Class to Class** to open the **Edit Net Class to Net Class Definition** dialog, where you can view and modify Class to Class information:
The following information is available in the *Net Class To Net Class Definition* dialog:

- **Net Class To Net Class Definitions**: Lists the defined net class combinations.
- **Net Class Name**: These combo boxes are used to combine two Net Classes into a Class To Class.
- **Modify Definition**: Click this button to make changes to a selected Class To Class.
- **Delete Definition**: Click this button to remove a selected Class To Class.
- **Add Definition**: Click this button to create a Class To Class when you have selected the two desired Net Class Names.
- **Rules**: The Rules list shows the rules and values assigned to the Class To Class. Click **Edit** to open the *Attributes* dialog to make changes to the rules. See *Edit Attributes* (page 350) for more information.
- **Layer Rules**: The Layer Rules list shows the attributes and values assigned to the layers in a Class To Class. To modify the layer rules, click **Edit** to open the following *Edit Net Class To Net Class Layer Attributes* dialog:
Similar to the *Edit Net Class to Net Class Layer Rules* dialog, the *Edit Net Class to Net Class Layer Attributes* dialog lists the Layers and indicates whether the layer has Rules with an asterisk. You can select layers having specific rules and values by clicking the *Select by Rule* button to open the *Set By Attribute* dialog (see *Set By Attribute* (page 349) for details).

The order of evaluation matches the order of evaluation used by the SPECTRA Router. P-CAD PRO Route uses only layer and net clearance rules.

P-CAD DRC ignores SPECTRA Router clearance rules that have been added as attributes.

**Options Net Classes**

Choose *Options Net Classes* to define a group of nets that share common rules. Collections of nets sharing the same rules are referred to as a net class.

When you click *Net Classes*, the following *Net Classes* dialog appears.
This class editor allows you to create named net classes using predefined clearance rules or predefined SPECCTRA autorouter clearance rules and then assign nets to that class. You can also add user-defined attributes to the net classes for your own use.

Net classes are transferred from the Schematic design to PCB via the P-CAD format netlist or through ECO’s. PCB Design Rules Checking verifies clearances and the attributes listed below when they have been defined in the net class:

- MaxNetLength
- MaxVias
- MinNetLength
- ViaStyle
- Width

For net clearances the rules can be further refined by specifying clearance rules for pairs of objects, like pad to pad clearances or line to via clearances.

The net class information is written to binary and ASCII design files. P-CAD Master Designer PCB does not support Net Classes so this information is lost when exporting a P-CAD design to P-CAD format.

To create named net classes, do the following:
1. Enter a class name in the Class Name box.

2. Click **Add**.

3. To include a net from the Unassigned Nets list to the new net class you may use any of the following methods:
   - Select a single net and click **Add**.
   - **Double click** on a net to move it from Unassigned to Nets in this Class and vice versa.
   - Select multiple nets in a block by either 1) holding down the **SHIFT** key while selecting the first and last nets in the block or, 2) select the first net in the list, hold the left mouse button and drag the cursor to the last net in the list and release. Then click **Add**.
   - Select individual nets by holding the **CTRL** key while clicking on each net, then click **Add**.

4. To remove a net from the Nets in this Class list, use the same methods detailed above, but click **Remove** instead of **Add**.

   In addition to the normal selection process you may employ the **Set Nets From Design Selection** buttons to quickly place all currently selected nets in the design into either the Unassigned Nets or Nets in this Class lists. When no nets are selected in the design, the inactive **Set Nets From Design Selection** buttons are gray. If nets in either list are selected and you click the **Set Nets From Design Selection** button, the other selected nets become unselected.

5. The Net Class Attributes assigned to the Net Class are listed in the list. To make modifications to any of the existing attributes, or to add new attributes, click **Edit** to open the **Attributes** dialog. See **Edit Attributes** (page 350).

6. Net Class Layer Attributes and their values are shown in this list. To modify these attributes, click **Edit** which opens the following **Edit Net Class Attributes** dialog:

   The **Edit Net Class Attributes** dialog lists the Layers and indicates whether the layer has Rules with an asterisk. You can select net classes having specific layer attributes and values by clicking the **Select by Rule** button to open the **Set By Attribute** dialog (for details on the **Set By**
Chapter 17: Options Commands

Options Pad Style

Choose **Options > Pad Style** to set the current pad style (a.k.a., pad stack) for the **Place Pad** command. You can add, delete, purge unused pad styles, edit pad styles and set hole ranges using the series of dialogs available.

A pad style (or pad stack) is a collection of pad information concerning pad shape relative to layer, hole size, offset, etc.

Choose **Options > Pad Style** to open the following **Options Pad Style** dialog.

![Options Pad Style Dialog](image)

The Default pad style cannot be modified. When the Default pad style is selected, the **Modify** buttons become **View (Simple)** and **View (Complex)**.

Surface-only (SMT) pads have a default paste mask shape and a default solder mask shape, which is automatically based on the shape and size of the pad on the top or bottom signal layer. However, the default paste and solder mask definitions are not appropriate for surface pads in edge connectors. To be sure that no solder and/or paste is applied to the edge connector pads, you must explicitly define the component’s padstyle with values of zero on the paste and solder mask layers.

- To add a new pad style, select a similar pad style and click **Copy**. The **Copy Pad Style** dialog appears.
- To modify a simple pad style, select a simple non-Default pad style (e.g., new1), and then click **Modify (Simple)**. The **Modify Pad Style (Simple)** dialog appears. Simple and complex pad styles are defined below. If the pad style is complex, this button appears gray, and cannot be clicked.
- To modify a complex pad style, select a non-Default pad style (e.g., new1), and then click **Modify (Complex)**. The **Modify Pad Style (Complex)** dialog appears. Simple and complex pad styles are defined below.
• To view the default pad style, select Default, and then click View Simple or View Complex (View appears instead of Modify when Default is highlighted). The read-only View Default Pad Style dialog appears.

• To delete a pad style, select a non-Default pad style name in the list and click Delete. The pad style name will disappear from the list. You can only delete a style if it is not currently used by a pad.

• To purge unused pad styles, click Purge Unused Styles. All unused pad style definitions are deleted from the current PCB design.

• To rename a pad style, highlight the non-Default pad style you want to rename and click Rename. The Rename Style dialog appears.

• To set a pad style hole range, click Hole Range. The Options Pad/Via Hole Range dialog appears. If you don’t set a hole range, PCB assumes a through-hole.

• To Merge Pad Styles click Merge. The Merge Style dialog appears.

Simple and Complex Pad Styles
A simple pad style must meet the following criteria:

• Shapes can be defined only on the built-in Top, Bottom, (Signal), (NonSignal), and (Plane) layers. No other custom layer definitions are allowed.

• The shapes and dimensions on the Top, Bottom, and (Signal) layers must either be identical (a uniform thru-pad), be defined on the Top layer only (a top surface pad), or be defined on the bottom layer only (a bottom surface pad).

• To qualify as a simple, uniform thru-pad, the signal layer shape must be an ellipse, an oval, a rectangle, a rounded rectangle, a target, or a mounting hole. If a signal layer shape is an ellipse, oval, rectangle, or rounded rectangle, the (Plane) shape must be a Direct Connect or a 45-degree, 4-spoke Thermal.

• To qualify as a simple, top surface pad, the shapes must have zero width and zero height on the Bottom, (Signal), (NonSignal), and (Plane) layers. The Top shape must be an ellipse, an oval, a rectangle, or a rounded rectangle.

• To qualify as a simple, bottom surface pad, the shapes must have zero width and zero height on the Top, (Signal), (NonSignal), and (Plane) layers. The Bottom shape must be an ellipse, an oval, a rectangle, or a rounded rectangle.

• If there is a hole defined for the pad, the X and Y hole offsets must both be zero.

Any pad style that does not meet all of the above criteria is considered a complex pad style.

Adding a Pad Style
To add a pad style, click Copy. The following Copy Pad Style dialog appears.
Type the new pad name (e.g., mypad) and select a pad style to copy it from (e.g., *(Default)). Click OK to return to the Options Pad Style dialog.

Modify a Simple Pad Style
To modify a simple pad style, select a simple pad style and click Modify (Simple). The following Modify Pad Style (Simple) dialog appears. This button is shaded and unavailable if you select a complex pad style.

Use this dialog to set the width, height, hole diameter and shape, select a pad type. For thru type pad styles, you can select either a thermal or direct plane connection. You can designate the hole to be Plated and change its Diameter. You can also set the plane swell value; either enable the Use Global Swell option (set in Options Configure), to use the global plane swell setting in Options Configure, or disable it and specify a Local Swell option, overriding the global Options Configure setting.

Modify a Complex Pad Style
To modify a complex pad style, select a complex pad style and click the Modify (Complex) button. The Modify Pad Style (Complex) dialog appears.
The values represented will default to mil or mm (millimeters), depending on what you have set in Options Configure (your current units). You can specify a measurement value (overriding Options Configure) by typing in mil, mm, cm, or in after the numeric value.

The Pad Definition frame allows you to add a new pad definition to the Layers list, or modify an existing pad definition for a layer. You can change the Width and Height dimensions and choose a Shape from those available in the drop-down list.

The connectivity of pads to planes and copper pours are controlled in the Pad Definition frame as well. If you choose the No Connect Shape for the pad or a plane layer, you can prevent the connection to the plane. When you select the Prohibit Copper Pour Connections check box, a thermal connection between the pad and copper pours is prevented.

If you choose to prohibit a copper pour or plane connection, and by doing so cause a break in the net connectivity, a blue connection line from the pad to a neighboring net node is displayed. You must manually add the necessary connection.

The Hole frame lets you define the pad hole diameter, specify the plating characteristics and designate X and Y offsets. The Hole frame applies to all layers of the pad and are not part of the Add/Modify/Delete function for pad definitions. Specify the Hole dimensions, plating on or off, and the X and Y offset. X Off and Y Off are horizontal and vertical offset amounts of the hole in an aperture.

With the Plane Swell options you can set the plane swell value; either select the Use Global Swell check box to use the global plane swell setting in Options Configure, or disable it and enter a value in the Local Swell box, overriding the global Options Configure setting.

**Pad Definitions**

The Add, Modify, and Delete buttons in the Pad Definition frame of the dialog work as follows:

1. To add a pad definition to a layer in the Layers list select a layer from the Layer combo box in the Pad Definition frame, select a shape from the Shape drop-down list, set the hole dimensions, plating, width, height and spoke width, then click Add. The new layer is added to the list.
For polygonal pad shapes, Width and Height options are unavailable and the *Polygonal Pad Shapes* dialog appears when you click **Add**. See *Defining Polygonal Pad Shapes* (page 477) for details.

2. To modify a pad definition for one of the layers in the Layers list highlight a layer name in the list; then you can change pad shape (Shape options), and (in the case of thermal pads) define the dimensions for Outer Dia and Inner Dia and Spoke Width; then click **Modify**.

You can view the pad definition of a layer by clicking on the layer name in the list. The pad definitions are listed by shape, width, and height in the Pad Definition frame.

3. To delete a pad definition, highlight a layer in the list and click **Delete** (a reverse action to number 1 above). If the layer is predefined (e.g., Top), it cannot be deleted.

4. Click **OK** and all of the changes or settings will be saved and applied. All pads that currently use this style will be immediately updated.

---

For further clarification, the basic difference between adding and modifying a pad style is as follows:

To add a pad style, you copy an existing style, choose a unique name, and then modify it to new specifications.

To modify a pad style, you edit an existing style (but not the default style) without renaming it.

---

After you have set the pad style(s), the available pads that you place in Place Pad mode have the style you set here. When you choose to change to a different pad style with the **Edit » Properties** command, the available pad styles will be listed. See *Pad Properties* (page 307) for related details.

**Standard Pad Shapes**

This section shows and describes some standard pad shapes and thermal spoke pads.

- **Ellipse** is a rounded shape with separately specifiable X and Y dimensions; an ellipse with equal X and Y dimensions is a circle (frequently called a round).
- **Oval** is a short line segment with round end caps (half-circles), the radius of which is 1/2 the length of the shortest side; if the X and Y dimensions are equal, this too is circular or round.
- **Polygonal** is a free-form polygonal shape defined using the *Polygonal Pad Shapes* dialog.
- **Rounded Rectangle** contains 1/4 circles on the corners of a rectangle. The 1/4 circle radius is 1/4 the length of the shortest side.
- **Rectangle** shapes are X=width and Y=height.
If you want a round pad, you use the ellipse shape with identical height and width (the example above is an oblong ellipse). If you want a square pad, use a rectangle with identical height and width.

Spoke width, and the inner and outer diameters, are specifications for thermals. There are four thermal pad styles, which appear as follows:

2 spoke  
2 spoke 90  
4 spoke  
4 spoke 45

Thermal diameters and spoke width:

Offset aperture hole

- Direct Connect pads directly touch the plane layer.
- No Connect pads are holes with swell.
- Target pad style provides a way to line up board layers.
- Mounting Hole pads are manufacturing indicators for securing components or board layers.

**Defining Polygonal Pad Shapes**

You can define polygonal pad shapes from the *Modify Pad Style (Complex)* dialog. To do so:

1. Select **Polygon** from the Shape list.
Notice that the Width and Height boxes are no longer available.

2. Click Add.

To modify a polygonal pad shape, select it and click Modify. The Polygonal Pad Shape dialog appears with its current polygon set to correspond with the pad being modified. You can then specify a different polygonal shape for the pad.

The Polygonal Pad Shape dialog appears:

This dialog is used as to select polygonal shapes using several methods:

- Specification of parameters that define a simple regular polygon shape.
- Selection of a polygon shape from those that currently reside within existing pad styles.
- Selection of a polygon shape from polygon aperture definitions.
- Selection of an irregular custom polygon shape from those currently selected in the design workspace.

The Polygonal Pad Shape dialog options are as follows:

**Regular Polygons**

To create regular polygons, use the following options:

- Click Regular Polygons to specify simple polygon shapes.
- Use the arrows to set the Sides box. You can select a value from 3 to 10. The default setting is 3.
- The Diameter box allows you to specify polygon pad size. Its default setting is 60 mil. This value represents the diameter of a circle that circumscribes the polygon.
• The Rotation box allows you to specify orientations of polygon pads individually within their pad styles. The default setting is 0.0.

• Click Update to update the Polygonal Shape with the new settings. If any of the settings are blank or contain erroneous data, the display window is cleared and an appropriate error message appears.

Existing Pad Style Polygons
To select existing polygon shapes, use the following options:

• The Pad Style Polygons button allows you to select polygon shapes that currently reside within existing pad styles in their designs.

• The Pad Style combo box is automatically populated with the names of all the pad styles that contain polygon shapes (sorted alphabetically). The default setting is its first list entry.

• The Layer combo box is consistently updated so as to contain layer names on which polygon shapes reside within the currently selected Pad Style. The default setting is its first list entry.

When you change the current settings of either combo box, the display window is automatically updated to display the proper polygonal shape. If the currently selected pad style polygon happens to be a regular shape, then the Regular Polygons fields are automatically updated.

If no pad styles in the current design contain polygon shapes, then the Pad Style Polygons button, the Pad Style combo box, the Layer combo box are all disabled.

Existing Aperture Definitions
To select polygon shapes based on existing aperture definitions, use the following options:

• The Aperture Polygons button allows you to select polygon shapes from polygon apertures definitions.

• The Aperture combo box is automatically populated with the names of all polygon apertures definitions.

When you select a new definition, the display window is automatically updated to display the proper polygonal shape. If the currently selected pad style polygon happens to be a regular shape, then the Regular Polygons fields are automatically updated.

If there are no polygonal aperture definitions in the current design, then these options are all disabled.

Currently Selected Polygon/Reference Point Pairs
To select irregular custom polygon shapes, use the following options:

• The Selected Polygons button allows you to select irregular custom polygon shapes from polygon/Reference Point pairs that are currently in the design workspace selection list.

When you open the Polygonal Pad Shape dialog, the P-CAD PCB (6/400) examines the list of currently selected items, looking for polygons and reference points. It matches each polygon with a
single currently selected Reference Point touching the polygon's boundary to construct a list of polygon/Reference Point pairs. The list uses the following criteria:

- Selected items that are not polygon/Reference Point pairs are discarded.
- Polygons comprised of more than 48 sides are discarded.
- Polygons that fail to match to a selected Reference Point are discarded.
- Polygons that match to more than one Reference Point are discarded.

Click the **Next** button to view the next item in the list; click **Previous** to see the previous item.

If no valid polygon/Reference Point pairs are found on the current selection list (or the selection list is empty), then the **Selected Items** button and the **Previous** and **Next** buttons become shaded an unavailable.

### Purging Pad Styles

To purge Pad Styles click **Purge Unused Styles**. A confirmation dialog appears:

Click **Yes** to confirm purging of all unused styles.

### Renaming a Pad Style

To add a pad style, click **Rename**. The **Rename Pad Style** dialog appears:

Type a new pad style name in the New style name list, and click **OK**.

### Setting a Hole Range

To set a pad style hole range, click **Modify Hole Range**. The **Options Modify Pad Hole Range** dialog appears.
This dialog allows you to set up the hole ranges for pads. Only those styles with a hole diameter greater than zero appear.

The Hole Range Layers list reflects the signal/plane layer ordering of your board as you established in the Options Layers dialog.

To set a hole range, do the following:
1. Select a pad from the Styles list.
2. Select the beginning and ending layers for the hole range.
3. Select another pad and repeat the process.
4. Upon completion, click OK.

**Merging Pad Styles**
To merge Pad Styles click Merge. The Merge Styles dialog appears:
Select the Pad styles you want to merge and click **Apply** to perform the merge. Click **Close** when you complete merging Pad Styles.

**Options Via Style**

Choose **Options Via Style** to set the current via style for the **Place Via** command. You can add, delete, rename, or edit via styles by using the series of available dialogs. This dialog can also be used to set hole ranges for vias.

Choose **Options Via Style** to open following the **Options Via Style** dialog.

![Options Via Style dialog]

Via styles are almost identical to pad styles in the way that you add, edit, modify, view, delete, and rename them in PCB. You can also purge unused via styles and create hole ranges. See **Options Pad Style** (page 472) for more information.

Vias don’t support Mounting Hole and Target shapes.

**Options Text Style**

Choose **Options Text Style** to set the current text style for the **Place Text** command and allows you to add, delete, rename, or edit text styles by using the series of available dialogs. The text styles you create or edit here are available when you use the **Place » Text** command, or when you want to modify already placed text with the **Edit » Properties** command.

The Default style can’t be deleted, renamed, or modified. The DefaultTTF style can be displayed in TrueType or stroke font, but can otherwise not be modified, renamed or deleted. The other default styles can be modified, but not deleted or renamed.

When you flip text that is currently displayed in TrueType font the result is a mirrored version of the text in its stroke definition.

Choose **Options Text Style** to open the following dialog:
Adding Text Style
To add a text style, do the following:

1. In the Options Text Style dialog, click Add. The following Add Text Style dialog appears.

2. Select the style of text you want to base the new style on.
3. Specify the text style name you are adding (e.g., busstyle).
4. Click OK and the Text Style Properties dialog appears. For details on this dialog, see Text Style Properties (page 484).

Changing Text Display
You may change text display from Stroke to TrueType and vice versa. From the Options Text Style dialog follow these steps:

1. Select one or more text styles from the list provided.
2. Click Display Stroke or Display TrueType for the type of display style you desire.

The Display Stroke button displays all selected text styles in their stroke font definitions.

The Display TrueType button displays all selected text styles that allow TrueType in their TrueType font definitions. Selected text styles that do not allow TrueType are not affected by pressing the Display TrueType button.
Text Style Properties

Remember, you cannot change the properties of Default text style; you can only query it. The DefaultTTF text style can be changed to the equivalent stroke font style for display purposes only.

To query and edit text style properties:
1. In the Options Text Style dialog, select a text style from the Text Style list.
2. Click Properties and the Text Style Properties dialog appears. To learn about this dialog, see Text Style Properties (page 484).
3. Modify the Height, Thickness, and Font fields for non-default fonts.

Purging Text Styles

To purge Text Styles click Purge Unused Styles. A confirmation dialog appears:

Click Yes to confirm purging of all unused styles.

Renaming Text Style

To rename a text style, follow these steps:
1. In the Options Text Style dialog, select the non-default text style that you want to rename.
2. Click Rename to open the Rename Style dialog.
3. The text style appears in the list.
4. Specify the new name by typing over the existing name.
5. Click OK.

Deleting Text Style

To delete a text style, do the following:
1. In the Options Text Style dialog, select the non-default text style you want to delete.
2. Click Delete.

A message appears asking you to confirm your deletion.
3. Click Yes, and the highlighted text style disappears from the list.

You cannot delete default text styles or a text style that is currently in use.

Text Style Properties Dialog

This Text Style Properties dialog appears when you click the OK button in the Options Add Text Style dialog or the Properties button in the Options Text Style dialog.

This dialog lets you add and modify font properties of the selected (non-default) text style.

The values represented appear as mm (millimeters) or mil, depending on what you have set in Options Configure (your current units). You can specify a measurement value (overriding Options Configure) by typing in mil, mm, cm or in after the numeric value.

You can set the following stroke font properties.

- **Height**: The font's height.
- **Thickness**: The text thickness.
- **Font**: Choose between QUALITY, BASIC, or LCOM fonts. QUALITY and BASIC fonts are interchangeable. Basic is simpler and therefore draws faster. LCOM is a serif font (a little fancier).

```
quality font
basic font
lcom font
```

When working with a TrueType font style other than DefaultTTF, the following options are enabled in the TrueType Font Properties and Display areas of the dialog:

**TrueType Font Properties**:

- **Size**: Enter the desired size of the font.
- **Font**: Click Font to open the Font dialog shown in the following figure, where you can choose the font, font style, font size, and script style.
Click OK to confirm and apply your choices.

**Display:**

- **Stroke Font:** Click Stroke Font to enable the text display in the Stroke Font style.
- **TrueType Font:** Click TrueType Font to enable the text display in the TrueType Font style.

When you click OK, the new (or modified) text style is available for assignment.

**Merging Text Styles**

To merge Text Styles click Merge. The Merge Styles dialog appears:

Select the Text Styles you want to merge and click Apply to perform the merge. Click Close when you complete merging Text Styles.
CHAPTER 18

Library Commands

Using the Library Commands

Use the Library commands to create aliases, copy items from one library to another, delete library items, rename library items, open libraries, and save patterns that you create to component libraries.

P-CAD libraries are a combination of components, PCB patterns, and Schematic symbols (not used by PCB). The component section of a library contains component information, such as what pattern is attached to a particular component, what its pin assignments are, etc. The pattern section contains the structural information about the pattern that is attached to a component. Without a pattern, a component has no graphical representation and cannot be placed. A pattern by itself is only a graphical structure. A component and its pattern reside in the same library; the component references a particular pattern, its structure, when that pattern is attached to it. For example, an SN7400N component with its component attributes and pin assignments occupies the same library with a DIP14 pattern, which it references.

It is typical for multiple components within a library to reference the same pattern. A library could conceivably contain 100 components while only containing five patterns (multiple components referencing the same pattern). If you change one of the patterns, then all of the components referencing that pattern are affected.

Library New

Choose Library » New to create a new library. The new library is empty; it has no components, patterns, or symbols.

When you choose Library » New, the Library New dialog is opened and you can specify the filename of your new library.
Library Alias

Choose Library » Alias to create an alias for an item in a library. In P-CAD PCB, an alias is an alternate name for component or pattern. You can create multiple equivalent names for the same item with this command.

When you create aliases for an item, it is not the same as creating copies or renaming. For details, see page Library Copy (page 489).

Aliases allow you flexibility of using a variety of naming conventions for components or patterns, without renaming them. For example, what P-CAD calls an SN7400N, you may want to use as a generic alias of 7400. Or, if you are using components from a vendor using a particular naming convention, and you want to continue using that system, you can use alias names and display them on your design as such.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename remains current if you re-invoke any of the commands during the same session.

Creating an Alias

To create an alias, follow these steps:

2. If the name of the current library does not appear next to the Library button, click Library. The Library Select dialog appears.
3. In the Library Select dialog, navigate to the appropriate library, select it, and click Open. You return to the Library Alias dialog.
4. In the Alias Item frame, choose Component or Pattern. The Symbol button is shaded and not available in P-CAD PCB.
5. Click the Component or Pattern button. The Library Browse dialog appears.
6. Select the item from the Component or Pattern list, as shown in the following figure:
7. Click **OK**. You return to the **Library Select** dialog.

8. Enter the new alias for the item in the **New Alias** box.

9. Click **Add** to add it to the Aliases list.

10. Click **Close** to close the **Library Select** dialog.

**Library Copy**

Choose Library > **Copy** to copy an item from one file and save it the current library or to another library.

To copy a component with its associated Schematic symbols, use the Library > **Copy** command in P-CAD Library Executive. P-CAD PCB does not support the management of symbol data.

It’s important to note that a library part has these sections:

- A component section (type, reference designator, etc.)
- A pattern section (the PCB graphics)
- A symbol section (the Schematic graphics).

Generally, you need to copy the component and its pattern when copying between different libraries (notice that the Copy Item section of the dialog has a choice between Pattern and Component). When you copy a component, you are prompted as to whether you want to include its associated pattern; you would normally respond Yes. When you copy a pattern, no components will be included in the copy.

Also, when copying items from one library to another, you can choose to preserve items in the destination library or overwrite them. And when copying components, you can choose to copy the corresponding patterns.
The dialog allows you to select source library and item name as well as destination library and item name.

The source library and destination library that are used with Rename will remain current if you reinvoke the command during the same session.

If you are copying a component or pattern but are not changing its name, you can leave the Single Destination Name box blank.

**Copying Patterns/Components**

To copy one or more patterns or components, follow these steps:

1. Choose **Library » Copy**. The Library Copy dialog appears:

   ![Library Copy dialog](image)

2. Click **Select Source Library**. The Library Select dialog appears.

3. Select the source library. Then click **OK**. Notice that the source library you selected appears in the Library Copy dialog.

4. Click **Destination Library**. The Library Select dialog appears again.

5. Select the destination library. Then click **OK**. The Library Copy dialog appears with the paths and filenames of the source and destination libraries you selected.

6. In the **Copy Item** section of the dialog, select which type of item you want to copy. The available items are **Component** and **Symbol**. For the item type you select, the names of the available items appear in the Multiple Source Names box. In the example above, the dialog lists all the components available in the source library Demo2.lib.

490

**P-CAD PCB User's Guide**
7. Select the item(s) to copy by using the standard Windows selection key combinations. You can select either a single item, a group of items, or all the items in the list. The table below explains how to select items for copying:

<table>
<thead>
<tr>
<th>Use these keys</th>
<th>To select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + Left mouse</td>
<td>all items between the last selected (highlighted) item and the item you</td>
</tr>
<tr>
<td>button</td>
<td>click on.</td>
</tr>
<tr>
<td>CTRL + Left mouse</td>
<td>add items to or subtract items from the selection.</td>
</tr>
<tr>
<td>button</td>
<td></td>
</tr>
</tbody>
</table>

You can also click the **Browse to Add** button to add single items to your selection. To do this, click **Browse to Add**. When the Library Browse dialog appears, select the desired item, then click **OK**. The program highlights the selected item in the Multiple Source Names list box.

8. In the **Destination Preferences** section of the dialog, indicate whether to overwrite existing items in the destination file, preserve existing items, and copy patterns and symbols with a component. The last two check boxes are only available if you're copying components.

9. Click **Copy**. P-CAD Library Executive copies the selected objects from the source library to the destination library.

10. Click **Close** to exit the dialog.

**Library Delete**

Deletes a library item.

This command deletes the item in name only. The alternate names (aliases) still exist unless you delete them. If the item has only one name and no aliases and you delete it, then the item itself is deleted from the library. Use the **Library » Alias** command to check whether an item has aliases.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename remains current if you re-invoke any of the commands during the same session.

**IMPORTANT:** If you delete a pattern, then all of the components in the library that reference that pattern will be without structure, and would therefore be unplaceable. Normally you would want to delete a pattern alias only, which is not dangerous unless a component used a pattern alias.

**Deleting from a Library**

To delete items from a library, follow these steps:

1. Choose **Library Delete** to display the dialog.
2. Select the **Delete Item type** (Component or Pattern radio button) for your delete action. The **Symbol** option button is grayed in PCB.

3. Click the **Library** button. The **Library Select** dialog is displayed, from which you can select the library in which you want to delete an item.

4. The library you selected in **Library Select** is displayed in the **Library Delete** dialog.

5. Click the item button (**Pattern**... or **Component**...) and the items within the displayed library will be listed in the **Library Browse** dialog. Select one and it will then be listed in the **Library Delete** dialog.

6. Click the **Delete** button and the item box becomes blank. This way you can continue to delete items from the same library.

7. Click **Close** to exit the dialog.

---

### Library Rename

Renames a pattern or a component.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename will remain current if you re-invoke any of the commands during the same session.

**IMPORTANT:** If you rename a pattern, then all of the components in the library that reference that pattern by the original name will have no pattern reference, and will therefore be unplaceable. If you want to use a different naming convention for a pattern, and then create an alias for the pattern (**Library » Alias** command) and use that alias name. Likewise for components: if you want to use a different naming convention, using aliases is much safer than renaming.

---

### Renaming a Pattern/Component

To rename a pattern or component, follow these steps:

1. Choose **Library Rename** to open the dialog.
2. First select the **Rename Item** type (Component or Pattern radio button). The Symbol option button is grayed in PCB.

3. Click the **Library** button to open the **Library Select** dialog, where you can choose the library to access.

4. The library you selected in **Library Select** appears in the **Library Rename** dialog.

5. Click the item button (**Pattern...** or **Component...**) and the items within the displayed library will be listed in the **Library Browse** dialog. Select one and it will then be listed in the **Library Rename** dialog.

6. In the **New Name** section type the new name of your item, then click **Rename**. Both the old name and new name disappear if the rename action is successful. You can continue renaming items in the same library.

7. Click **Close** to exit the dialog.

**Library Setup**

The **Library » Setup** command opens libraries from which you can access components.

The **Place » Component** and **Utils » Load Netlist** commands use the Open Library list to place components. The **Library Pattern Save As** command also uses the Open Library list.

When you want to place a component, the library file where the component resides must be open. You can open up to 100 libraries at one time.

**Drag and Drop File Load**

You can use the drag and drop method for opening library files (.lib) from the File Manager or other Windows file maintenance utilities. Drag the .lib icon(s) onto your PCB icon or workspace.

**Setting Up a Library**

To set up a library, follow these steps:

1. Choose **Library » Setup** to open the dialog.
Chapter 18: Library Commands

Library Pattern Save As

The dialog lists any libraries that are already open in the Open Libraries list box.

2. To add another library to the list, click **Add** to display the **Library File Listing** dialog. From there you can access the library directory to select a library file.

   When you select a file from the Library File Listing (and click **OK**), that filename appears in the Open Libraries list box in the **Library Setup** dialog.

3. To rearrange the list order, select a library name and click the **Move Up** or **Move Down** buttons.

4. To remove a library from the list, select the library name from the Open Libraries list box and click **Delete**.

5. Click **OK** and the libraries that you have specified are now open and accessible for component placement or saving patterns.

   In order to save a pattern or a component, you will need to setup the library in advance. The list of open libraries is saved to the **pcb.ini** file and therefore saved for subsequent sessions.

Many commands start looking for components in the first open library. To ensure your component is found in the correct library, open custom libraries first or move them to the top of the list.

Library Pattern Save As

The **Library » Pattern Save As** command saves a pattern to a library.

This command allows you to group a selected collection of objects as a pattern, and save the pattern to a library. From the library you can later attach the pattern to a component. You must have a library already open to save a pattern to it.

Saving a Pattern

To save a pattern, follow these steps:

1. Use the block select function to select the objects you want included in your pattern.

2. While the objects are selected, choose **Library » Pattern Save As** to display the dialog.
3. Select a library that you want to save the pattern to, and then specify a pattern name. If you want to just create a pattern (not a component), click **OK**.

4. To automatically create a component that corresponds to the pattern, enable the **Create Component** option before you click **OK**.

   The auto-created component has pin designators, which match the Default Pin Designator of the individual pads. Give the component a new name in the **Save Component As** dialog; otherwise the component will be named the same as the pattern name.

   If the Create Component box is cleared, the pattern is created without a component; to create a component that uses this pattern use the Library Executive to build the component and then attach this pattern to it. The **Library Executive User's Guide** includes a detailed tutorial on creating a 7400 component.

5. Enable the **Match Default Pin Designators to Pad Numbers** option if you want to apply default pin designators that match the pad numbers. If the pattern’s pads have existing default pin designators, you must confirm that you want them overwritten with the pad numbers.

   Duplicate default pin designators are not allowed, except blank. If any duplicates are found, an error message is displayed and the offending pads are highlighted.

---

**Library Archive Library**

Choose **Archive Library** to store component information from open libraries for components used in the active design file. Saving the component information in one library file can be extremely helpful, especially for large designs, to keep the design component information in a single, readily accessible location. This eliminates the need to store the complete set of libraries used to create the design.

When the **Archive Library** command is chosen, the following file search dialog appears:
The definitions for each component in the current design must reside in at least one open library.

The Save in area displays the current folder and any files in that folder. The File name area lets you enter or select a file name with the extension specified in the Save as Type area.

1. If the folder you want is not displayed in the Save In area, move through the directory tree to select the proper folder.

2. Type a new library file name in the File » Name area or select one from the list displayed in the Save In area.

3. Click Save.

If the library already exists, and you want to replace the data in the file, you must confirm that you want the file to be overwritten.

The results of the Archive Library command are displayed in an output file named ArchiveLibrary.err located in the same directory as the destination library. This file contains errors, warnings and informational messages logged during the archive process.
Using the Utils Commands

The Utils commands provide handy functions such as renumbering pads and reference designators, running design rule checking, and performing a variety of netlist tasks along with adding customized access to other applications.

The Utils menu has additional command options if you have purchased P-CAD Library Executive. Utils commands P-CAD Library Executive, P-CAD Pattern Editor, and P-CAD Symbol Editor launch their respective P-CAD application. Refer to your Library Executive User’s Guide for details on these products.

Utils Renumber

Utils » Renumber is a triple-function command for assigning pad numbers and default pin designators to free pads, and assigning reference designators to components manually or automatically.

For components, you can also specify designator templates (e.g., U) and increment values (e.g., 1) for reference designators (U1, U2, etc.).

Renumbering Reference Designators

1. Choose Utils » Renumber. The following Utils Renumber dialog appears:
2. In the Type frame, choose RefDes. The options in the dialog change accordingly (for RefDes), such as the Starting RefDes (e.g., U1) and Increment Value (e.g., 1). You also have the option of Manual or Auto, Top to Bottom or Left to Right.

3. If you choose Manual in the Method frame, you are in a temporary mode of assigning numbers, so every left-button click on a component for Manual renumbering will increment the value next to the designator. Notice that the Top to Bottom and Left to Right options are unavailable.

   You can enter the starting value in the Starting RefDes box. For example, if you entered the value U100 in the Starting RefDes box, then specify the Increment Value as 10, the first component you click is designated U100, the next one U110, then U120, etc. If you started at U000 and incremented by 1, the first would be U000, the second U001, etc.

4. Right-click or press ESC to end the temporary mode of Utils Renumber.

To choose Auto in the Method frame, you must have multiple components selected before you use this command (Auto is shaded if you don't). After you click OK, the reference designators will automatically increment according to your specification. Only the selected components will be renumbered. For example, you have selected nine components positioned horizontally that are numbered randomly C1 through C9, you renumber them with the Increment Value of 1, automatically (Auto) and enabled Top to Bottom. When you click OK, they will renumber C1, C2, and C3, etc. in rows as shown in the following figure:

If you choose Left to Right, with an increment value of 1, they will be numbered C1, C2, C3, etc. in columns as shown in the following figure.
Renumbering Pads

To renumber pads, do the following:

1. Choose **Utils » Renumber**. The following **Utils Renumber** dialog appears.

2. In the Type frame, choose **Pad Num**; the rest of the choices in the dialog change accordingly. Then specify Starting Number, and Increment Value, as appropriate. Manual is the only choice for pad numbering; Auto is shaded.

3. You are in a temporary mode of assigning numbers. Click a pad to assign that pad a number.

   For example, the first pad you click on would be number 1 (if Start Value was specified as 1), the second pad number 2 (if the Increment Value was specified as 1). As you click on a pad while in the Renumber mode, it highlights to show that a number has been assigned.

   The Status Line shows the pad number every time you (re)number a pad.

   You can use the unwind feature to reverse the renumbering process. The **BACKSPACE** key unwinds the renumbering.

4. **Right-click** or press **ESC** to end the Renumber temporary mode.

The renumber feature is sensitive to layers when renumbering pads. You must be on the appropriate layer for the pad to renumber it. For example, the current layer must be Top for a top SMT pad.
Renumbering Default Pin Designators

1. Choose **Utils » Renumber**. The following *Utils Renumber* dialog appears.

2. In the Type frame, choose **Default PinDes**; the rest of the choices in the dialog will change accordingly. Then specify Starting PinDes, and Increment Value, as appropriate. Manual is the only choice for default pin designator numbering; Auto is shaded.

3. You are in a temporary mode of assigning numbers. Click a pad to assign that pad a number.

   For example, the first pad you click on would be assigned a default pin designator of A1 (if Start Value was specified as A1), the second pad’s default pin designator is A2 (if the Increment Value was specified as 1). As you click on a pad while in the Renumber mode, it highlights to show that a default pin designator has been assigned.

   The Status Line shows the default pin designator number every time you (re)number a pad.

   To reverse the renumbering process, press the **BACKSPACE** key. This unwinds the renumbering one pad at a time.

4. **Right-click** or press **ESC** to end the Renumber temporary mode

**Utils Force Update**

Choose **Utils » Force Update** to replace all components of a given type in your design with the first component of that type in an open library. This is useful when you modify a component in P-CAD Library Executive and want to replace the original component in a PCB design with the modified component.

For example, suppose you change the number of pins in a component or add a test point to a component in a library. When you try to place the modified component in the design, an error message appears. Choose **Utils Force Update** to update all occurrences of that component in the design to reflect the changes. When all existing components of that type have been changed in the design, you can place more of the newly modified component into the design without incurring an error.

You cannot Force Update a fixed component in the design with a modified component of the same type.

Choose **Utils » Force Update** to open the following *Force Update* dialog.
Select a component from the Components list, or click **Set All** to select all components. Then, click **Update**. To cancel your selections, click **Clear All**. The command looks in all open libraries in the order they are listed in the Library Setup list for the replacement components.

Select the **Maintain Rotation** check box to maintain the rotation of any rotated components. It does not maintain rotations for components in designs loaded from Tango Series II.

The buttons in the Attributes Handling frame let you choose the method used to update component attributes in your design with the same type of components from the library. Remember that there are rules used to determine an attribute value. For more information see the *P-CAD Library Executive User’s Guide*.

- **Merge Attributes (Favor Library)**: This merge option combines library and design component attributes in the component being used in the design. It favors component attributes from the library over the component attributes of the same name in the design.

The following rules determine which attributes and values are kept in the design component:

- If an attribute exists in the library component and not in the design component, the library attributes and their values are copied into the design component.

- If the same attribute exists in both the design component and the library component with different values, the value of the library component attribute will replace the value of the design component attribute.

- An existing design component attribute, which has no matching library component attribute, is retained, unchanged, in the design component.

- **Merge Attributes (Favor Design)**: Again, this merge option combines library and design component attributes in the component being used in the design. This merge option favors component attributes in the design over the component attributes of the same name in the library.

These rules decide which attributes and values are kept in the design component:
If an attribute exists in the design component and not in the library component, the design attributes and their values are kept, unchanged, in the design component.

If the same attribute with different values exists in both the design component and the library component, the value of the design component attribute takes precedence and is retained in the design.

**Replace Attributes in The Design**: Choose this option to replace all of the attributes and their values in the design component with those defined in the library component. Current design attributes are removed from the component.

**Ignore Attributes From Library**: Keeps attributes in the design and ignores those in the library. This feature gives you more control over what to update in the design if you want to preserve any specific attribute modifications. With this feature, you can handle attributes in the same manner that is used when loading netlists in P-CAD PCB.

### Utils Record ECOs

Choose **Utils » Record ECOs** to record Engineering Change Orders (ECOs). The following **Utils Record ECOs** dialog appears.

![ECO Recorder](image)

In the ECO Recorder frame, choose **On** or **Off** to enable or disable the ECO recorder. If there are pending ECOs, you are prompted when a design is saved on whether to append the pending ECO to the current ECO file.

This function can also be activated using the ECO icon on the toolbar. When this function is activated (either from the toolbar or the **Record ECOs** dialog), the toolbar button is enabled.

### Types of ECOs

The following types of ECOs can be recorded:

- RefDes change (Was-Is).
- Net name changes.
- Additions, deletions, and modifications of components.
- Component swaps (Replace).
- Additions and deletions of nets.
- Additions and deletions of net nodes.
• Additions, deletions, and modifications of attributes.
• Pin and gate swap changes.

The format of the ECO file is determined by the setting in the Options Configure dialog. Full ECO-format files have an `.eco` file name extension, and Was/Is ECO files have a `.was` file name extension.

PCB ECO was-is format differs from Tango-PCB ECO format to be more consistent with other industry was-is formats. In particular, temporary refdes names are different. To read these files into Tango- Schematic or Tango-PCB, you will need to edit the file and add a colon (`:`) before any temporary RefDes name.

**Utils Import ECOs**

Choose **Utils » Import ECOs** to import an ECO file and apply the ECO changes to the current design file. The `.eco` file is created in P-CAD Schematic to capture schematic changes that impact your design.

**Fixed components can be deleted by importing an ECO file.**

When you choose this command the following dialog appears:

![ECO Filename dialog](image)

1. Click **ECO Filename** to open the following **ECO Filename** dialog.

2. Type, or select from the list, the name of the file you want to open in the Filename box.
3. `.eco` files are assumed to be full ECO format; `.was` files are assumed to be Was/Is format.
Chapter 19: Utils Commands

Utils Import ECOs

4. Click **Open** to return to the **Utils Import ECOs** dialog.

5. To load components with a pseudo pattern, check the **Create Pseudo Pattern** check box. See for details.

6. Click **OK** to import the ECOs.

**Preview ECOs**

When you select an ECO filename and then click **Preview ECOs**, you can view ECOs, if there are any, before importing them. The ECOs are displayed in the Notepad.

![Notepad Preview ECOs](image)

If you have added the same attribute to two parts in the same component from P-CAD Schematic, PCB rejects the multiple additions when it reads the ECO file with these changes. You need to delete the extra CompAttrAdd statements from the ECO file before reading it into PCB.

**Pseudo Patterns**

You can use the **Create Pseudo Pattern** option to load components that don’t have attached patterns. If a component does not have a pattern and matches a component in the open libraries, P-CAD PCB automatically creates a pseudo pattern.

For each pseudo pattern created, a message appears to let you know which components are affected. A DRC error is reported for each pseudo pattern on the design.

Output is restricted on designs with pseudo patterns. You can print the design, but **Gerber Out**, **NC Drill**, and **PDIF Out** are disabled. You can use the **Utils Force Update** command to replace components with pseudo patterns after you have finished creating and attaching the correct patterns for your components.
Choose **Utils » Export ECOs** to save ECOs to the ECO file at any time, without saving the design file. If there are pending ECOs, the following dialog appears when you choose this command:

View Pending ECOs
When you click **View Pending ECOs**, you can view pending (outgoing) ECOs, which are still stored in memory. The pending ECO data are written to a temporary ASCII file and displayed in Windows Notepad. The format displayed is either full or Was/Is, depending on the setting in the **Options Configure** dialog.

Save ECOs Now
1. To save pending ECOs, click **Save ECOs Now**. The following warning message appears:

   ![Warning 5235](image)

   It is recommended that you save ECOs at the same time you save your design using the **File » Save** command. If you save ECOs without saving the design, your file and the ECOs may not match. That is, the ECOs might not reflect the current state of the design.

2. To continue, click **Yes**.

   The **Save ECOs** dialog appears:
3. The ECO filename appears at the top of the dialog. It is the last used ECO file. To change it, click ECO Filename and the following dialog appears:

4. Type, or select from the list, the name of the file you want to open in the Filename box. Click Save to return to the Save ECOs dialog.

   Full ECO files must have an .eco extension, and Was/Is files must have a .was extension.

5. In the Comments box, type any comments that can help document the ECOs.

6. To append ECOs to the ECO file, click Append ECOs to File.

7. To discard ECOs, click ECOs. Once discarded they cannot be recovered.

**Utils DRC**

Choose **Utils » DRC** to set up Design Rule Checking (DRC). This process ensures that all electrical connections in the design layout match the connections in the netlist; the program also checks to see if minimum clearances have been maintained throughout the design.

DRC uses the design rules to determine the minimum clearance allowed between two objects. See for the order in which the rules are searched.

This minimum clearance is calculated as follows:

- The minimum allowed clearance for each object is determined by searching the design clearance rules in a specific order.
- Then the maximum of these two clearance rules is used as the minimum clearance allowed between the objects.

If the calculated clearance between the two objects is less than the minimum clearance, DRC reports a clearance violation.

**DRC ignores SPECCCTRA Router clearance rules.**

Choose **Utils » DRC** to open the following dialog:
Filename

Click **Filename** to open the *Design Rule Check Report* dialog. From this dialog you choose a **DRC** report file to which you can save the report information.

View Report

In the Report Options frame, select the **View Report** check box to open the DRC report file when the DRC is complete.

Design Rules (DRC Setup)

You can specify the rules for the design in **Options » Design Rules.** To open this dialog from the *Utils Design Rule Check* dialog, click **Design Rules.** The *Options Design Rules* dialog appears.
In the Options Design Rules dialog, each of the six tabs allows you to set design rules on different hierarchical levels: Design, Layer, Rooms, Net Class, Net and Class to Class.

**Design Rules by Test Category**

Each rule in the Design Rules Check is associated with a test category. The test categories are linked to the order, or precedence, by which Design Rules Check applies the rules to the design.

The following table shows the DRC rules to which values can be assigned for each test category. It also includes the order of precedence (hierarchy), from high to low, by which DRC looks for the presence of the rule’s value. For instance, if the Clearance rule has a value only at the Layer level, the Design Rule Check would have searched and found no assigned Clearance value in the Class-To-Class, Net, and Net Class rules and would then use the value set at the Layer level.

<table>
<thead>
<tr>
<th>Test Category</th>
<th>Rules</th>
<th>Hierarchy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Netlist Compare</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Clearance Violations</td>
<td>Clearance</td>
<td>Class-To-Class Layer</td>
</tr>
<tr>
<td></td>
<td>LineToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToPadClearance</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td>ViaToLineClearance</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>ViaToPadClearance</td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td>ViaViaClearance</td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td>BoardEdgeClearance</td>
<td>Layer (except Clearance)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Test Category</td>
<td>Rules</td>
<td>Hierarchy</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Width Violations</td>
<td>Width</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Netlist Violations</td>
<td>MaxVias</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>ViaStyle</td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Unrouted Nets</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Unconnected Pins</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Net Length</td>
<td>MinNetLength</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>MaxNetLength</td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Silk Screen Violations</td>
<td>SilkscreenClearance</td>
<td>Design</td>
</tr>
<tr>
<td>Copper Pour Violations</td>
<td>Clearance</td>
<td>Class-to-Class Layer</td>
</tr>
<tr>
<td></td>
<td>LineToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToLineClearance</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td>ViaToLineClearance</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>BoardEdgeClearance</td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Plane Violations</td>
<td>Clearance</td>
<td>Class-to-Class Layer</td>
</tr>
<tr>
<td></td>
<td>LineToLineClearance</td>
<td>Class-To-Class</td>
</tr>
<tr>
<td></td>
<td>PadToLineClearance</td>
<td>Net Layer</td>
</tr>
<tr>
<td></td>
<td>ViaToLineClearance</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Test Category</td>
<td>Rules</td>
<td>Hierarchy</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Component Violations</td>
<td>PlacementSide</td>
<td>Component</td>
</tr>
<tr>
<td></td>
<td>MaxComponentHeight</td>
<td>Room</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Room</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Layer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Design</td>
</tr>
<tr>
<td>Drilling Violations</td>
<td>HoleToHoleClearance</td>
<td>Design</td>
</tr>
<tr>
<td>Test Point Violations</td>
<td>TestPointAccuracy</td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td>TestPointCenter</td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td>TestPointGrid</td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td>TestPointPermitted</td>
<td>Design</td>
</tr>
<tr>
<td></td>
<td>TestPointRequired</td>
<td>Net Class</td>
</tr>
<tr>
<td></td>
<td>TestPointSide</td>
<td>Net</td>
</tr>
<tr>
<td></td>
<td>TestPointSpacing</td>
<td>Net Class</td>
</tr>
</tbody>
</table>

**Design Rules by Hierarchy**

The next table illustrates how the test categories apply to the hierarchical levels, and lists the applicable rules. This table begins with the most specific hierarchical level and graduates up to the most general level.

<table>
<thead>
<tr>
<th>Hierarchy</th>
<th>Test Category</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Netlist Compare</td>
<td>None.</td>
</tr>
<tr>
<td></td>
<td>Unrouted Nets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unconnected Pins</td>
<td></td>
</tr>
<tr>
<td>Component</td>
<td>Component Violations</td>
<td>PlacementSide only.</td>
</tr>
<tr>
<td>Room</td>
<td>Component Violations</td>
<td>PlacementSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxComponentHeight</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Class-to-Class Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Class-to-Class</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Net Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Width Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td>Width</td>
<td>NOTE: Lines, arcs and vias cannot touch a keepout.</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>Net</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Netlist Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Net Length</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Test Point Violations</td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxVias</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaStyle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MinNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointRequired</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointGrid</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSpacing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointPermitted</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointAccuracy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TestPointCenter</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Net Class Layer</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Width Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Width</td>
</tr>
<tr>
<td></td>
<td>NOTE: Lines, arcs and vias</td>
<td>cannot touch a keepout.</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Test Category</td>
<td>Rules</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>Net Class</td>
<td>Clearance Violations</td>
<td>Clearance</td>
</tr>
<tr>
<td></td>
<td>Netlist Violations</td>
<td>LinetoLineClearance</td>
</tr>
<tr>
<td></td>
<td>Net Length</td>
<td>PadToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Copper Pour Violations</td>
<td>PadToPadClearance</td>
</tr>
<tr>
<td></td>
<td>Plane Violations</td>
<td>ViaToLineClearance</td>
</tr>
<tr>
<td></td>
<td>Test Point Violations</td>
<td>ViaToPadClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaToViaClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BoardEdgeClearance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxVias</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ViaStyle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MinNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MaxNetLength</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointRequired</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointGrid</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointSpacing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointPermitted</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointAccuracy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointSide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TesPointCenter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NOTE: Lines, arcs and vias cannot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>touch a keepout.</td>
</tr>
</tbody>
</table>
Chapter 19: Utils Commands

Utils DRC

Additional Design Rules

The third table, shown below, lists additional checks performed by DRC, which are not user specified. You do not have to add attributes or specify values for attributes in order for DRC to check these constraints. For instance, DRC checks components for inclusion in a Room. You cannot set a value for this check since there is no attribute associated with it, but it is part of the verification that DRC performs.

<table>
<thead>
<tr>
<th>Test Category</th>
<th>DRC Checks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clearance</td>
<td>Short</td>
</tr>
<tr>
<td></td>
<td>Short to Copper Tie</td>
</tr>
<tr>
<td></td>
<td>Uncommitted Pins Shorted</td>
</tr>
<tr>
<td>Test Category</td>
<td>DRC Checks</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>Component</td>
<td>Component Side</td>
</tr>
<tr>
<td></td>
<td>Component Height</td>
</tr>
<tr>
<td></td>
<td>Room Inclusion</td>
</tr>
<tr>
<td></td>
<td>Empty Room</td>
</tr>
<tr>
<td>Copper Pour</td>
<td>Copper Pour Clearance</td>
</tr>
<tr>
<td></td>
<td>Unconnected Copper Pour Island</td>
</tr>
<tr>
<td></td>
<td>Unpoured Copper Pour</td>
</tr>
<tr>
<td></td>
<td>Copper Pour No Net</td>
</tr>
<tr>
<td>Drilling</td>
<td>Drilling Clearance</td>
</tr>
<tr>
<td></td>
<td>Hole Range Same Layer</td>
</tr>
<tr>
<td></td>
<td>Hole Range Conflict</td>
</tr>
<tr>
<td>Net Length</td>
<td>Net Length</td>
</tr>
<tr>
<td>Netlist</td>
<td>Point-to-Point Connectivity</td>
</tr>
<tr>
<td></td>
<td>Pseudo Pattern</td>
</tr>
<tr>
<td></td>
<td>Undefined Via Style</td>
</tr>
<tr>
<td></td>
<td>Tie Net Connectivity to Copper Tie</td>
</tr>
<tr>
<td></td>
<td>Net Connectivity to Uncommitted Pins</td>
</tr>
<tr>
<td>Plane</td>
<td>Plane Clearance</td>
</tr>
<tr>
<td></td>
<td>Fragmented Plane</td>
</tr>
<tr>
<td></td>
<td>Plane Partial Connections</td>
</tr>
<tr>
<td></td>
<td>Plane Shorts</td>
</tr>
<tr>
<td></td>
<td>Plane Unconnected</td>
</tr>
<tr>
<td></td>
<td>Plane No Net</td>
</tr>
<tr>
<td></td>
<td>Plane Overlap</td>
</tr>
<tr>
<td>Silk Screen Clearance</td>
<td>Silk Screen</td>
</tr>
<tr>
<td>Test Category</td>
<td>DRC Checks</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Test Point</td>
<td>Test point not on net copper.</td>
</tr>
<tr>
<td></td>
<td>Test point not positioned on grid.</td>
</tr>
<tr>
<td></td>
<td>Test point violates spacing rule.</td>
</tr>
<tr>
<td></td>
<td>Test point not permitted on object.</td>
</tr>
<tr>
<td></td>
<td>Test point not centered on SMT.</td>
</tr>
<tr>
<td></td>
<td>Test point not centered on thru hole.</td>
</tr>
<tr>
<td></td>
<td>Test point pad and via accuracy.</td>
</tr>
<tr>
<td></td>
<td>Test point required by net.</td>
</tr>
<tr>
<td></td>
<td>Test point on wrong side.</td>
</tr>
<tr>
<td>Text</td>
<td>Text Clearance</td>
</tr>
<tr>
<td>Unconnected Pin</td>
<td>Unconnected Pin</td>
</tr>
<tr>
<td>Unrouted Net</td>
<td>Unrouted net</td>
</tr>
<tr>
<td></td>
<td>Hole Range No connect</td>
</tr>
<tr>
<td></td>
<td>Hole Range Violation</td>
</tr>
</tbody>
</table>

When you have finished setting up the design rules click **Close** to return to the **Utils Design Rule Check** dialog.

**Annotate Errors**

To show DRC error indicators on your design, select the **Annotate Errors** check box in the Error Options frame. These error indicators can then be selected to view error information. The error information is determined by the other error/violation options that you enable in design rule checking.

To view the error associated with an error indicator, select it and choose **Edit » Properties**. This opens the **Find DRC Errors** dialog. The display of the error indicators can also be controlled in the Miscellaneous tab of the **Options Display** dialog; the selection criteria for DRC error indicators (for block selecting) is determined by the **Options » Selection Mask** command. For details, see **Miscellaneous (page 444)** and **Options Selection Mask, (page 423)**.

The DRC error indicators can be output to a report, which lists all of the locations and the errors that they are indicating.

When you are finished setting up the DRC options, click **OK** to begin the design rule checking process. Error indicators are cleared when you choose **Utils » DRC**.

**Severity Levels**

In the **Utils Design Rule Check** dialog, click the **Severity Levels** button to open the **Rules Severity Level** dialog where you can set the severity level of each design rule.
By choosing one of the **Severity Level** option buttons, you can set one of three severity levels: error, warning, or ignored.

- If you choose the **Error** button, DRC error indicators are created for you to display, select, and view.
- If you choose the **Warning** button, DRC errors are included in the DRC report but not annotated in the design.
- If you choose the **Ignored** button, DRC errors are not annotated in the design. An error summary appears in the report only if you select the **Summarize Ignored Checks** check box in the Report Options frame of the **Utils Design Rule Check** dialog.

Select one or more rules and click the appropriate option button to change the severity level of the rule(s). Rule categories include the following: clearance, netlist, unconnected pins, copper pour, drilling, unrouted nets, silkscreen, text, width, component, plane, and test point.

To restore the default values for the severity level of all rules, select the **Set to Default** check box and click **OK**.

**Summarize Ignored Errors**

If a design rule has a severity level set to Ignored, it is not listed in the output report. The count of Ignored errors can be summarized in the report, however, by enabling the **Summarize Ignored Errors** option.

**Summarize Overridden Errors**

When a design has a number of errors that you do not wish to see again, such as unconnected pins, you can override their appearance in the design by choosing the **Edit Override** command and disabling the **Display Overridden Errors** option in the Miscellaneous tab of the **Options Display** dialog. To summarize this type of error in the DRC report, enable the **Summarize Overridden Errors** option in the **Utils DRC** dialog.
Clear All Overrides

When errors in the design have been overridden, and you want to clear or delete them from the design, enable the Clear All Overrides option.

Design Rule Checks

The Design Rule Checks frame contains a number of report options. When a check box is selected, that option appears in the DRC report. When a check box is clear, the option is not included in the report.

- **Netlist Compare.** Compares a Tango, P-CAD ASCII, or Master Designer ALT format netlist file with the current nets in the design.

- **Clearance Violations.** Enables air-gap and board edge clearance checking and reports existing shorts. Items are considered to be physically connected if they overlap or have a clearance of 0 mil. Items that can be physically connected to one another are arcs, polygons, pads, lines, copper pours and vias. The bounding rectangle of text placed in the design is checked to assure that it does not short to other copper on the signal layers. If this check box is clear, no clearance errors will be reported.

- **Text Violations.** Reports all clearance violations between text and other items on signal layers.

- **Netlist Violations.** Enables electrical checking against the netlist within the design. If there are no nets in the design, this option is ignored. The report includes a warning for those objects that are not point-to-point routed. The warning includes the location of the objects.

- **Width Violations.** Verifies that the line and arc widths do not exceed the DRC designated widths.

- **Unrouted Nets.** Enables reporting of any nets that are currently unrouted (unrouted connections still exist in the design). Unconnected Pins enables the reporting of all pins that are not connected to other pins. This includes all of the single-node routes as well as pins that are not connected to anything at all.

- **Net Length.** Enables the reporting of net lengths, which exceed the minimum, and/or maximum lengths set for lines and arcs within the net.

- **Silkscreen Violations.** Enables checking on pad/via to silkscreen violations. Silkscreen on pads on top layer can interfere with soldering process; on vias it can cause paint dripping or collecting in unwanted areas.

- **Copper Pour Violations.** Enables reporting of unflooded copper pour entities, copper pours that are not part of a net, copper pour island clearance violations, unconnected islands, fill areas and thermal connections that have clearance violations.

- **Plane Violations.** Enables reporting of overlapping planes, invalid pad and via copper connections, connected pad and vias that are not electrically connected to the plane, isolated areas of copper in a plane.

- **Component Violations.** Enables error reporting when violations occur in a component’s height and layer side placement. In addition, a violation is reported when a Room’s Included
Component list is empty, or if any of the Included Components have not been properly placed in the Room.

- **Drilling Violations.** Enables connectivity checking of pads/vias through their attached layers, utilizing the layer ordering and hole range for determining where the pad/vias begin and end. Also enables checking for layer separation, interference between holes, collocated holes, and vias existing solely on a signal layer.

- **Test Point Violations.** Select this check box to check for nets that do not have a required test point. This option also checks for test points that do not fall on the correct object, or on the specified test point grid or pad center. In addition, it checks for test points that fall inside of the minimum spacing or on a different side of the board than the net requires.

**Area To DRC**

If you are working in a specific area of the board and only want to check violations in that area, you can choose where to apply the DRC with one of the following options:

- **Entire Workspace:** This default setting checks rules violations for the entire design.

- **Room:** If your design has one or more rooms, you can choose a specific room to DRC by clicking the Room radio button and selecting the desired room from the drop down list provided. PCB checks the design rules on all layers for design objects that intersect the room.

- **Region:** When you click the Region button, you can define the exact area to DRC. The Region can be defined in two ways:

  - Click the Define Region button. PCB takes you back to the design. Press and hold the left mouse button on the first corner of the area you want to define. Drag the cursor until the target zone is completely within the rectangle and release the button. Click the right mouse button or press the ESC key and confirm that you want to update the region coordinates provided in the message.

  To set the Region Coordinates directly, enter the X and Y coordinates for the Lower Left and Upper Right in the appropriate boxes.

  Click OK to begin the design rule checking process.

**Utils Find Errors**

Choose the **Utils Find Errors** command to open the Find DRC Errors dialog. In this dialog, you can view and find the rules violations in your design:
If you have not run the **Utils » Design Rules Check**, then the **Find DRC Errors** dialog displays a message informing you that there are no DRC error points. When you choose the **DRC command**, you have access to all the errors through the **Find DRC Errors** dialog.

The sections of the dialog are as follows:

- **Categories**: Displays the rule categories in a drop down list. You can view the errors for one or all categories by selecting the desired category.

- **Description**: Displays the error number along with an explanation for the error.

- **Error Number**: In the Error Number box you can type the number of the error you want to see and click the **Find** button to go directly to it. If you want to scroll through the errors sequentially, use the up and down arrows next to the box.

- **Show Only Selected**: If you have block selected an area in the design, and want to see just the errors in that location, enable the **Show Only Selected** option.

- **Jump To**: When you find an error in the report that you want to locate in the design, click the **Jump To** button. The error finder positions the cursor in the center of the error indicator.

- **Override**: Don’t display this error again: As you display each error in the design, individual errors can be removed from the error display by checking the **Override - Don’t display this error again** option. The overridden errors can be summarized in the reports by enabling the **Summarize Overridden Errors** option in the **Utils Design Rule Check** dialog.

The **Find DRC Errors** dialog remains on the screen until you click the **Close** button. As long as there are error indicators in the design, you can retrieve the error information in the **Find DRC Errors** dialog with the **Utils Find Errors** command.

### Utils Load Netlist

Choose the **Utils » Load Netlist** command to load a netlist from a .net file into your design. If you have a board outline created, the components will be placed directly above the board outline. If there is no board outline, the components will be placed into the lower-left corner of the workspace.

If any of the design limits are exceeded, your design cannot be loaded using P-CAD PCB (6/400). See Chapter 1, *Introduction to P-CAD PCB*, for a listing about the actual limit.
Loading a Netlist

1. Choose the **Utils » Load Netlist** command. The **Utils Load Netlist** dialog appears.

   ![Utils Load Netlist dialog](image)

2. To choose a netlist file, click the **Netlist Filename** button. The **Netlist File** dialog appears from which you choose a netlist file.

3. Use the Netlist Format field and combo box to select the correct source file format for the netlist file so that the PCB file filter can read the format.

   Your choices are P-CAD ASCII, Master Designer ALT, and Tango format. P-CAD ASCII format includes attributes attached to each net and component in the netlist. Tango format is the standard Tango format.

4. If you select P-CAD ASCII, four options for attribute handling are available: attributes may be merged with current design attributes, favoring either the netlist or the design attribute if the attribute exists in both; attributes may be ignored; or all design attributes may be removed and replaced with those present in the netlist.

   If you select P-CAD ASCII, two net class options are available. You can choose to replace existing net classes with net classes in the netlist, or to ignore the net class information in the netlist.

5. If you select the Master Designer ALT file format, use the **Xref Filename** button to open a cross-reference file (*.xrf) for type mapping.

6. To load components with pseudo patterns, check the **Create Pseudo Pattern** check box.
7. When you select a file from the Netlist File dialog, you will return to the Netlist File Load dialog, where the filename will appear. Click OK and the netlist from the file will load onto your design.

**Loading a Netlist on an Existing Board**

You can load a netlist into an existing board (which already has items), with the following rules and results:

- Components with matching RefDes must also have matching Types. If there is any conflict with the component section of the netlist, the load is aborted.
- Any existing components on the board that are not part of the netlist will be preserved.
- Any components in the netlist being loaded that are new to the design will be added.
- For components that include, pads and text that are of styles that have the same names but different data than those styles in the current design, the incoming style names will be bracketed to indicate the style conflict. The new (bracketed) style names will be added to the list of available styles in the current design.
- The net information and connections of the existing design will be replaced by the new net information.
- If you enable the Reconnect Copper check box, an analysis done by the program may find nets that are shorted. Shorted nets are listed in the error log file.
- When a new net is found to be open, a connection will be created. When extra connections, or misconnections, are found, a warning message appears.
- In the event that existing copper and new nets match, no connection lines will appear because the nets are already routed.

**Pseudo Patterns**

You can choose the Create Pseudo Pattern option to load netlist components that don’t have attached patterns. If a netlist component does not have a pattern and matches a component in the open libraries, P-CAD PCB automatically creates a pseudo pattern.

For each pseudo pattern created, a message appears to let you know which components are affected.

**Jumper Pads**

Components with jumper pads behave as if all of the pads marked as being jumpered together are connected.

**Optimize Nets**

The Optimize Nets check box can be used to inhibit the automatic optimization of the rats nest connections. If optimization is disabled, the connections are made in the order given in the netlist. Disabling this option also speeds up the netlist load process since the time-consuming
optimization phase is skipped. Once the netlist is loaded, you can choose the **Utils » Optimize Nets** command at any time.

**Reconnect Copper**

Select the **Reconnect Copper** check box to inhibit the automatic “reconnect” of existing copper on the board. If reconnect is disabled, the net connections match the netlist exactly, and all existing copper on the board is converted to “free” (non-intelligent) copper. Free copper isn’t associated with any net. If there is existing copper on the board, and the reconnect option is enabled, the reconnect phase can take a long time. Therefore, it is recommended that you only disable the reconnect option if you want to quickly load a netlist into a board with existing copper, and you are willing to accept having free copper.

When the **Reconnect Copper** check box is enabled, **Utils Load Netlist** generates connections between those objects that are physically connected but not point-to-point routed.

If you disable reconnect, it is possible that existing free copper on the board will short one or more nets together. This can only be detected by choosing the **Utils » DRC** command.

After you have loaded the netlist, you can select the components and connections either as a group (a block select) or individually (single select) to move them into their appropriate positions in the design.

**Check for Copper Sharing**

If the **Check for Copper Sharing** option is enabled, line to line trace intersections and line traces crossing the center of a pad or via are detected. Intersecting line traces are split at the point of intersection and lines are split at pad or via centers, creating point-to-point routes.

---

**Utils Generate Netlist**

Choose the **Utils » Generate Netlist** command to create a netlist from the combination of connections you have established (or loaded) in a design file.

Free copper (non-net connections) will not generate a netlist. Free pads, which are a valid part of a net, are not listed as net nodes in the netlist.

**Generate a Netlist**

1. Choose the **Utils » Generate Netlist** command to open the dialog.
2. To choose a netlist file, click the **Netlist Filename** button. The **Netlist File** dialog appears from which you can choose a file.

3. If you want to generate your netlist to a different format, use the Netlist Format box and combo box to specify the destination format.

   Your choices are Tango format and P-CAD ASCII format. Tango format is the standard Tango format. P-CAD ASCII format includes attributes attached to each net and component in the netlist.

4. Enable the **Include Library Information** check box if you want an optional library section to be written to the netlist.

   Library information is read by PCB but not processed; it is merely informational. The Library section may be used to create a P-CAD library, however, by removing the non-library information from the file and using the Library Executive to translate the ASCII form of the Library into a binary library.

5. Click **OK** in the **Netlist Generate** dialog and the netlist will be created with the filename and netlist format you have specified.

**Utils Compare Netlist**

Choose the **Utils » Compare Netlist** command to compare the current nets of the design you have in memory with the netlist file that you specify. This useful feature verifies the integrity of your design against the original netlist. For example, if you mistakenly deleted a component or net, this command will show you the discrepancy. This command compares logical net information. That is, it works even if there are open (unrouted) nets. Use the **Utils » DRC** command to check existing copper.

**Comparing a Netlist**

1. Choose **Utils » Compare Netlist** to open the dialog.
2. Click the **Netlist Filename** button to display the **Netlist File** dialog. From here you can access the netlist filename of the original netlist, which you loaded into your design file.

You can use this command to compare the design file with any of the available file formats, which are:

- Tango
- P-CAD ASCII
- Master Designer ALT

If you compare the design against a P-CAD ASCII netlist, P-CAD PCB reports on the differences between the design and netlist attributes for netlist and component attributes, as well as net classes. This feature enables you to check attributes as well as connectivity in your design.

The Master Designer ALT file format also supports the use of a cross-reference file (.xref) for type mapping.

3. The **Attributes area** allows you to choose the categories you want to compare from the list of Categories in the Netlist file. Move selected attribute categories from the Categories listbox to the Compare listbox, or vice versa, by clicking the appropriate direction arrow. You can also double click a category in either list box to move it to the opposite box.

Attributes placed in the Compare listbox are retained throughout your PCB session.

4. Click **OK** and any discrepancies appear on the screen.

## Utils Optimize Nets

Choose the **Utils » Optimize Nets** command to perform netlist optimization to shorten the length of connections between net nodes. Further, this command allows you to perform pin and gate swapping to rearrange connections logically in order to produce shortened or more direct routings, or dispersed routings to ease congestion in certain areas.

Generally, you apply a gate or pin swap on logical connections created as a result of placing components in PCB. You can convey gate and pin swaps, which result in net list modifications, back to P-CAD Schematic from PCB with the ECO utility.

### Utils Optimize Nets Command

The **Optimize Nets** command allows you to select automatic or manual pin and gate swapping. To choose this command, you must be in **Select** mode.

1. Choose the **Utils » Optimize Nets** command to open the **Utils Optimize Nets** dialog.
The dialog defaults to Auto, with the Gate Swap and Pin Swap options disabled. To perform only a minimization of the nets connection, click OK.

When you click OK, connections are rearranged to shorten the total connection length. If Gate Swap or Pin Swap are checked the gate and pin swaps occur in accordance with the rules found later in this section.

**Automatic Pin and Gate Swapping**

1. Be sure that the Auto radio button in the Method box is selected.
2. For gate swapping, click the Gate Swap box.
3. For pin swapping, click the Pin Swap box.
4. To perform gate and pin swapping in the entire design, click the Entire Design radio button.
5. To perform gate and pin swapping on selected objects, click the Selected Objects radio button. This button is grayed out unless you have selected objects before choosing the Utils » Optimize Nets command.
6. Click OK.

The Not-Undoable Operation warning message appears. If you press No, you are returned to the Optimize Net dialog. If you press Yes, the Optimize Nets Progress dialog appears.

The Optimize Nets Progress dialog provides you with the current and cumulative status of the command. You can stop the command at any time without losing the accumulated results by clicking Stop.

The Current Status box describes the current activity. The current activity can show swapping gates or pins, or minimizing connection length. Any swaps that occur follow the swapping rules.

**Entire Design/Selected Objects**

If you selected the Entire Design radio button on the Utils Optimize Nets dialog, the following actions occur:

- If you selected Gate Swap or Pin Swap, pin or gate swapping occurs between any components in the design following the swapping rules outlined in the section below entitled When components and net connections are selected. All nets are guaranteed to not have their connection lengths increase.
- Minimum length optimization occurs for all nets.
If you selected the **Selected Objects** radio button, the following actions occur:

**When only components are selected:**
- If you selected **Gate Swap** or **Pin Swap**, swapping is restricted to pins and gates among the selected components. Swapping occurs only to improve (decrease the Manhattan connection length of) those nets with connections to the selected components' pads. Other nets' connections may increase in length.
- Minimum length net optimization occurs on the connections between the selected components.

**When only net connections are selected:**
- If you selected **Gate Swap** or **Pin Swap**, swapping occurs only to improve (decrease the Manhattan connection length) the selected connections' nets. This means that all gates and pins are eligible for swapping, as long as a selected net improves from the swap. Connections that are not selected may increase in length.
- Minimum length net optimization occurs on the selected connections.

**When components and net connections are selected:**
- If you selected **Gate Swap** or **Pin Swap**, swapping is restricted to pins and gates among the selected components. Swapping occurs only to improve (decrease the Manhattan connection length) the selected connections' nets. Those un-selected connections may increase in length.
- Minimum length net optimization occurs on the selected connections.

**Manual Gate Swap**

You can use the **Manual Gate Swap** options to perform gate swapping manually on selected pads.

To perform manual gate swapping,

1. Select **Manual Gate Swap** on the **Utils Optimize Nets** dialog.
2. Click the **OK** button. The **Optimize Nets** dialog disappears, and the cursor changes to the “more points” shape. If you click the **right mouse button** or press the **ESC** key, the command is aborted and you are returned to the **Select** tool. The cursor shape returns to the original shape.
3. Click a pad and all pads of that gate, along with the connections that are attached to those pads, appear highlighted in cyan, the first swap color.

   All the pads of the eligible equivalent gates (as defined by the gate swapping rules), and their connections, appear highlighted in magenta, the second swap color.

   If you click a pad that isn't part of a gate that can be swapped you will hear a beep. If you click the **right mouse button** or press the **ESC** key, the command restarts at the initial state, with all of the pads and their connections being unhighlighted.
Chapter 19: Utilis Commands

Utils Optimize Nets

The current layer must be a layer on which the pad is defined for the pad to be selected. Otherwise you hear a beep, indicating no action can take place.

4. Click one of the eligible pads (those highlighted in the second swap color). Its gate and its connections now appear in the first swap color, and the Manual Gate Swap dialog now appears.

<table>
<thead>
<tr>
<th>Net name</th>
<th>Manhattan len.</th>
<th>Percent change</th>
</tr>
</thead>
<tbody>
<tr>
<td>GND</td>
<td>0.0Unk</td>
<td>Inf</td>
</tr>
<tr>
<td>VCC</td>
<td>0.0Unk</td>
<td>Inf</td>
</tr>
</tbody>
</table>

The dialog presents you with a list of the affected nets and their new connection lengths. The Manhattan connection length is calculated by determining the Manhattan length after an optimization. The percent changed is the percentage of the difference of the connection lengths before and after swapping. Below the list box the total for all of the nets appears.

If net copper is attached to any pads of the two selected gates, then the Swap button is grayed and a warning appears in the dialog. Nets that have copper attached are preceded by an asterisk. The warning tells you that net copper is attached to a gate’s pad, and it must be removed before swapping can occur. Free copper is ignored.

5. To perform the gate swap, click Swap.

All of the nets attached to the first gate are swapped with all the nets attached to the second gate. The dialog disappears and the cursor returns to its original shape, ready for the next gate swap. All of the highlighted pads and connections are unhighlighted.

6. Click Cancel to cancel the operation.

The dialog disappears, no swap occurs, and the pads of the second gate, with their connections, revert to highlight color two. You can now select another gate for swapping.

Manual Pin Swap

You can use the Manual Pin Swap options to perform pin swapping manually on selected pads. To perform manual pin swapping,


2. Click the OK button. The Optimize Nets dialog disappears, and the cursor changes to the “more points” shape. If you click the right mouse button or press the ESC key, the command is aborted and you are returned to the Select Tool. The cursor shape returns to the original shape.
3. Click a pad. That pad, along with the connections that are attached to that pad, appear highlighted in cyan, the first highlight color. All of the eligible equivalent pads (as defined by the pin swapping rules), and their connections, appear in magenta, the second highlight color. If you click the right mouse button or press the **ESC** key, the command restarts at the initial state, with all of the pads and their connections being unhighlighted.

   The current layer must be a layer that the pad is defined on for the pad to be selected. Otherwise you hear a beep.

4. Click a pad. The pad and its connections appear in cyan, the first highlight color. If the selected pad is not an equivalent pad, a warning message appears stating: “The selected pad is not recommended for swapping, proceed with caution.” This action constitutes a forced swap. The **Swap Pins** dialog now appears.

   ![](image)

   The dialog presents you with a list of the affected nets and their new connection lengths. The Manhattan connection length is calculated by determining the Manhattan length after an optimization. The percent changed is the percentage of the difference of the connection lengths before and after swapping. Below the list box the total for all of the nets appears.

   If net copper is attached to either of the two selected pads, then the Swap button is grayed and a warning appears in the dialog. Nets that have copper attached are preceded by an asterisk. The warning tells you that net copper is attached to one of the pads, and it must be removed before swapping can occur. Free copper is ignored.

5. To perform the pin swap, click **Swap**.

   All of the net connections attached to the first pad swap with all the net connections attached to the second pad. The dialog disappears, and the cursor returns to its original shape, ready for the next pin swap. All of the highlighted pads and connections are unhighlighted.

6. Click **Cancel** to cancel the operation.

**Rules for Pin Swapping**

The rules for pin swapping are:

- Pin swapping occurs within a gate between logically equivalent pins. The equivalence values must be non-zero and identical for a swap to occur between two pins. Swapping is allowed between non-equivalent pins, but only after you give confirmation (a forced swap). Forced
swaps can occur only during a manual pin swap; they do not occur during automatic pin swapping.

- No swapping occurs if net copper is connected to either pad.
- Swapping does not occur if a net connected to the pin has the `OPTIMIZE` attribute set with a value of "NO".
- Swapping does not occur if the component has the NOSWAP attribute set to Yes.

**Rules for Gate Swapping**

The rules for gate swapping are:

- The gates must be logically equivalent.
- The gates must be of the same component type with equivalent value if swapping across components. The component values must be the same so that gate swapping with discrete parts works correctly. (For example, a gate swap between two RES components, one with a value of 50 ohm and the other 100 ohm, isn't allowed).
- The swapping of gates between components can be further restricted by use of the swap eligibility attribute (SWAPEQUIVALENCE). For example, one circuit might be used to monitor another circuit on the board. It would defeat the purpose of the monitor circuit to have its gates swapped with the gates in the other circuit. By setting the components in the monitor circuit to have a swap eligibility attribute different than the other circuit, swapping can be kept from occurring between the two circuits.
- Swapping does not occur if the component has the NOSWAP attribute set to Yes.
- Swapping does not occur if net copper is connected to either of the gates.
- Swapping does not occur if any net connected to the gate has the `OPTIMIZE` attribute with a value of "NO".

**Impact on the Library Executive**

**Gate Equivalency maintenance:** Currently, the Library Executive allows the gate equivalency of pins in the same gate to be different. This causes gates to be non-equivalent by ambiguity. To correct this problem, when you change a part number, or gate equivalence for some gate, the spreadsheet automatically updates the gate equivalence field of the other pins of that gate to match. Existing components with this problem can be read in but cannot be saved until the ambiguity is corrected.

**Pin Equivalence:** Pin equivalence is allowed only between pins with the same electrical type. The electrical types Unknown and Passive are considered the same for purposes of pin equivalence.

**Utils Reconnect Nets**

Choose the `Utils » Reconnect Nets` command to use the current design netlist to re-establish the net information for copper traces, arcs, pads, polygons, and vias having point-to-point routes to
copper in an existing net. You can also create system-generated nets for circuits composed entirely of objects that are not in any net. This makes it easy for you to bring non-net circuits into your design. You can bring in these non-net circuits either from the Clipboard, a PCB block file, or by using the PCB Editor’s drag/copy feature. Then, at a later time, you can convert these non-net circuits into net circuits with unique net names.

When you choose this command, the Reconnect Nets dialog appears.

This command is like the Reconnect Copper option within the Load Netlist command, except that it uses the current design netlist information instead of an external netlist file.

Point-to-point routing is not required. Routes that are physically connected but not point-to-point routed are indicated by a connection (blue-line).

When a copper tie with a TieNet value is encountered, connectivity is halted. This keeps the polygon from being assigned to a net and the nets from being merged. Any nets without a TieNet attribute value that touch a copper tie will be merged or shorted.

Shorted nets are indicated in the log file with a warning. These nets are not merged.

Check for Copper Sharing
If the Check for Copper Sharing option is enabled, line to line trace intersections and line traces crossing the center of a pad or via are detected. Intersecting line traces are split at the point of intersection and lines are split at pad or via centers, creating point-to-point routes.

Jumper Pads
Components behave as if all of the pads marked as being jumpered together are connected. In PCB, if necessary, blue line connections may be added to the other pads.

Create Nets From Free Copper
To create system-generated nets, follow these steps:

1. Choose Utils » Reconnect Nets. The Utils Reconnect Nets dialog appears.
2. Click Create Nets From Free Copper. This instructs P-CAD PCB to create a unique, system-generated net for each free circuit found in the design. This process essentially turns a free circuit into a net circuit.
A free circuit consists of two or more component pads connected with lines, arcs, polygons, vias, and pads to form a circuit with no net intelligence. A “net circuit” is similar to a free circuit except that it has net intelligence. Each free circuit must have at least two free component pads.

3. Click Yes to reconnect free circuits or No to abort.

**Utils Trace Clean-up**

Choose the **Utils » Trace Clean-up** command to go through the nodes of each net contained in the design and remove all redundant trace segments (collinear and overlapping) and any extra vertices.

When you choose this command, a dialog appears warning the your that this operation is undoable. Click Yes to begin the trace cleanup process.

**Utils Shortcut Directory**

When you installed P-CAD PCB, a sub-directory called Shortcut was created in the P-CAD directory. The Shortcut contains a list of web addresses for semiconductor manufacturers.

Choose the **Utils » Shortcut Directory** command to open the Shortcut in Windows Explorer. Select the desired address and, from the right mouse menu, choose the Open command.

Shortcuts to any web site can be added to the Shortcut.

**Utils P-CAD Schematic**

If P-CAD Schematic is installed on your computer, choose this command to start P-CAD Schematic. If P-CAD Schematic is not running, it is launched. If Schematic is already running, it becomes the active program. See for how to start Schematic if it is installed in a different directory than PCB.

**Utils P-CAD Library Executive**

Choose this command to start P-CAD Library Executive, if P-CAD Library Executive is installed on your computer. Refer to your *Library Executive User’s Guide* for additional information.

**Utils P-CAD Pattern Editor**

Choose this command to start P-CAD Pattern Editor, if P-CAD Pattern Editor is installed on your computer. Refer to your *Library Executive User’s Guide* for additional information.

**Utils P-CAD Symbol Editor**

Choose this command to start P-CAD Symbol Editor, if P-CAD Symbol Editor is installed on your computer. Refer to your *Library Executive User’s Guide* for additional information.
The **Utils » P-CAD InterPlace/PCS** command provides access to both P-CAD Parametric Constraint Solver and P-CAD InterPlace. Refer to your *InterPlace/PCS User's Guide* for additional information.

**Utils P-CAD Signal Integrity**

Choose this command to launch the P-CAD Signal Integrity Analyzer. The Signal Integrity Analyzer allows you to check the board for noise effects like ringing and crosstalk, as well as calculate the impedances of the nets.

The Signal Integrity Analyzer is based on a Fast Reflection and Crosstalk Simulator which produces very accurate simulations, using industry-proven algorithms. The P-CAD Signal Integrity simulator uses the characteristic impedance of the traces calculated through a transmission line calculator and I/O buffer macro-model information as input for the simulations. Where model information is not available the system utilizes fallback models.

**Running a Signal Integrity Analysis**

When you select the **Utils » P-CAD Signal Integrity** command the *P-CAD Signal Integrity* window opens. This window is your interface to the various features available in the Signal Integrity Analyzer. This window is shown below.
Getting the Nets
When the Signal Integrity window first opens it will be blank, because there are no nets loaded. To load the nets select File » Get Nets from the menus.

Selecting the Nets to Analyze
The entire set of nets on the board are listed in the All Nets frame on the left. To perform any analysis you must select the net (or nets) you are interested in, then choose Edit » Take Over (or click the Takeover Over Selected Nets button).

Generally, you will be doing one of 2 things when you take over nets – take over all nets to perform a net screening, or take over one or 2 nets to perform a reflection or crosstalk analysis. You can use the standard Windows selection strategies to select the nets: click and drag a window to select a block of nets, use the Shift+left click to select multiple nets, or Ctrl+left click to select individual nets.

Performing a Net Screening
The net screening feature is used to do a quick analysis of the chosen nets. It displays the results in a spreadsheet-like window, which can then be sorted to identify problem nets. After taking over the required nets, choose Simulation » Screening from the menus (or click the Net Screening button on the main toolbar). The P-CAD Signal Integrity Screening window will appear.
Changing the Displayed Information

By default the screening window will open to display all possible information, each in a separate column in the table. There are 4 type of information that the screening window can display, these are:

- **Net Data** – this includes net length, number of components and number of traces.
- **Impedance** – this includes the average impedance, maximum impedance and minimum impedance.
- **Voltage** – this includes the voltage top value, maximum overshoot (rising edge), maximum undershoot (rising edge), base value, maximum overshoot (falling edge) and maximum undershoot (falling edge).
- **Timing** – this includes the flight time and slope for the rising edge, and the flight time and slope for the falling edge.

You can selectively hide and display information in the View menu, or by clicking the appropriate view button on the main toolbar.

Sorting the Displayed Information

As well as filtering the screening results to only display the information that you are interested in, you can also sort the entire table to order the results from smallest to largest, or from largest to smallest.

In the previous figure only the Voltage information is displayed. This has then been sorted to display the largest value for Maximum Overshoot on the rising edge. To do this you click the title of the Max. Overshoot (Rising Edge) column. You will notice that the amount of overshoot on DX7 is 1.07. The next step would be to examine this net in more detail by performing a reflection analysis.

Performing a Reflection Analysis

A reflection analysis is performed from the main P-CAD Signal Integrity window. It is important to note that you should not attempt to perform a reflection analysis on all nets, this would take a long time, and would result in a waveform window so many waveforms that you would not be able to analyze the results. To perform a reflection analysis:

1. First take over the net that you are interested in.
2. Select Simulation » Reflection from the menus, or click the Reflection Simulation button.
3. The P-CAD WaveAnalyzer window will appear, displaying the reflection analysis results. An example is shown below. Use the measurement options in the Analyze menu to give more accurate information about the waveforms.
Exploring Termination Options

The P-CAD Signal Integrity Analyzer is an excellent tool in helping you ensure that your board is not going to have signal integrity issues when it is built. As the designer you will have to decide how to resolve problem nets, perhaps changing the device family, modifying the component layout, or adding termination to critical nets.

The P-CAD Signal Integrity Analyzer includes a Termination Advisor, which you can use to explore different what-if scenarios with different termination options. There are 2 approaches to termination, adding termination to the output pin on the net, or terminating the last input on the net.

To explore the termination options:

1. First take over the net that you are interested in.
2. Select the pin on the net that you want to apply the termination to, for this example we have selected the output pin.
3. Select Simulation » Termination to display the Termination Advisor dialog. As we are adding termination to an output pin the appropriate termination method is Serial R (all other termination methods are for input pins).
4. Click OK to add the theoretical termination to the net.
5. Rerun the Reflection Analysis and examine the results.
The WebQuote, or AutoRFQ feature allows you to request a quotation to fabricate or assemble your board from within the P-CAD PCB Editor. This feature extracts relevant PCB data, passes it to the Request For Quotation application (AutoRFQ), which then interfaces to the WebQuote web site (http://www.webquote.com) to configure and request for a quotation on the PCB.

The WebQuote site is a portal to PCB fabricators all over the world. From this site you can select which manufacturers you wish to participate in the quoting process, and also choose if you wish to use an open bidding process, where each fabricator is notified of the other fabricators’ quotes (allowing them to requote), or a closed bidding process, where they are not notified.

When you choose the **Utils » P-CAD AutoRFQ** command an RFQ file is created and loaded into the AutoRFQ program. Once the RFQ file is loaded in the AutoRFQ program it is displayed as an RFQ for PCB Fabrication window. This file details the necessary design specifications that have been extracted from your PCB.

From the AutoRFQ application you can then set up a new request for quotation by clicking the *New RFQ* button that appears at the top of the RFQ for PCB Fabrication window. The first time you attempt to do this you will be prompted to create an account, once this is done the job can be configured, ready for a quotation.

When you click the *New RFQ* button the data in the RFQ file is passed to the PCB MarketPlace web site, and another window appears. Work your way down this window, clicking the Modify or Enter buttons and completing the information required on each page that appears. Once your RFQ has been successfully submitted you will receive a confirmation email, then when the quotes from the manufacturers are received you will be emailed these as well.

**Utils Customize**

Choose the **Utils » Customize** command to set up a quick and easy way to access other programs from P-CAD PCB. This quick and easy access is accomplished by adding items to the Custom Tools toolbar and the Utils menu.

When you select **Utils » Customize** the following dialog appears:
Chapter 19: Utils Commands

Utils Customize

The *Utils Customize* dialog is used to add new tools or delete and modify existing tools on the Custom Tools toolbar and Utils menu. The fields on the dialog are as follows:

- **Custom**: Provides a list of the custom tools that currently exist.

- **Menu Text**: Enter the description of the tool being added. The Menu Text field allows up to 40 characters. The buttons on the toolbar display as many letters as can fit on the button. If the name of a tool being added to the custom toolbar is too long to be displayed in its entirety, you can change the display by using lower case letters or shortening the name of the new tool.

  You may insert an ampersand (&) anywhere in the text string to designate a menu shortcut key. For instance, if the Menu Text entry is &Notepad, the menu shortcut key for the tool is the letter N.

  The Utils menu displays the list of custom tools as shown to the left.

- **Command**: Enter the path to the executable file of the new tool. Click the **Browse** button to display a standard **File Open** dialog where the desired file can be chosen. A warning is issued if a non-existent path is entered, but the entry will still be added.

- **Arguments**: Optional entry used to pass information into the targeted program, if desired.

- **Initial Directory**: Sets the initial working directory for the program.

- **Display**: Selects the way the program appears on the screen when initialized. Normal (the default) to display the program as a window in the workspace, Minimized to start the program and display it as an icon at the bottom of the screen, or Maximized to start the program and display it across the full screen.

- **Prompt for arguments**: Check this box to automatically display the **Arguments** dialog to enter input that must be passed to the program at execution time. The entry is saved and recalled the next time the program is run.
• **Add**: Click the Add button to begin adding a new tool. You can add a maximum of 16 tools to the Customized Toolbar.

• **Remove**: Select a tool from the custom area and click Remove to delete it from the customized toolbar.

• **Move Up/Move Down**: Select a tool from the Custom list and change its position in the list by clicking the Move Up or Move Down buttons.

Once all selections and entries have been made, click OK to apply them.

**Displaying the Custom Toolbar**

The Custom Toolbar is not displayed in the workspace until a custom tool has been added. Once a tool has been added, the toolbar automatically appears with the other PCB toolbars.

You may control the appearance of the Custom Toolbar in the workspace using the View » Custom Toolbar command.

**Executing a Custom Tool**

To launch a program added as a Custom Tool, you may choose any of these methods:

• Click the desired button on the custom toolbar.

• Select the tool from the list at the bottom of the Utils menu.

While the Utils menu is active select a custom tool by pressing the menu shortcut key assigned to it. For instance, select Notepad by pressing the N key.
DocTool Commands

Using the DocTool Commands

With the documentation tools in P-CAD PCB, you can detail the fabrication, assembly, and testing of the printed circuit board. Using the commands in the DocTool menu, you can perform the following tasks:

- Create versatile zoned borders and custom title blocks.
- Include drawing and revision notes.
- Insert tables that include design data such as: net locations, power and ground net data, as well as last used, not used, and spare gate information.
- Place annotated sheet connectors.
- Track nets between schematic sheets.

This chapter contains a detailed explanation of each command in the DocTool menu.

DocTool Place Table

Choose the DocTool » Place Table command in P-CAD PCB to place a table in your design or drawing. When you choose this command, the Place Table dialog box opens.

The basic method of setting up, placing, and modifying a table is summarized in The Basic Place Table dialog box. For several of the table types additional options are available when the table is selected. These options are detailed in this chapter.

Once placed in the design, a table can be moved, rotated, flipped, deleted, cut, copied, and pasted, but only as a single unit; text inside the table cannot be selected, edited, or removed.

The design data displayed in a table can be updated if the design changes using the DocTool » Update or DocTool » Update All commands.
The Basic Place Table Dialog

The Place Table dialog is shown in the following figure:

Click Advanced in the Place Table dialog box to gain access to various drill table options.

In the Place Table dialog you can specify the following options:

- **Table Type**: Choose the type of table you wish to place.
  
  If you select the Drill Table, the Advanced button becomes active. If you select a Power, Note, or Revision Note table, other additional options appear.

- **Line Width**: The width of the lines surrounding a table cell is specified by the line width. The line color is set by the Line option in the Options Display dialog box.

- **Table Name**: Enter the table name. This name appears above the table.

- **Text Style**: Select the text style for the table. Click Text Styles to modify text styles.

To place a table, click OK to confirm the selections in the dialog box. You are returned to the design workspace. Click the location where you would like to place the lower left hand corner of the table. To more precisely place the table, click and hold the mouse button to drag a ghosted outline of the table borders.

The table cannot be placed outside the workspace.

Note and Revision Note Table Options

When you choose to place a Note or Revision Note table, the Place Table dialog box contains the following fields:

- **Note Numbering frame**: Choose Top to Bottom or Bottom to Top to indicate the direction of incrementing note numbers.
- **Width of Note Column**: Type a value in this text box to specify the column width in number of characters. When a note exceeds the column width, the text wraps to the following line.

Note number or symbols do not appear in a revision notes table. The Note Numbering option specifies the order of the placed notes, with or without the numbers displayed.

**Drill Table Advanced Options**

When placing a Drill table in PCB, click the **Advanced** button to expand the **Place Table** dialog, as shown in the following figure:

With the advanced options, you can customize your Drill Table as follows:

- **Hole Dia Units**: Choose **Inch** or **mm** as the units for the hole diameter column.
- **Label**: Type a name for the column label in this text box.
- **Width**: Type the column width in this text box.
- **Add**: Enter values in the Label and Width text boxes. Then, click **Add** to add the column to the table. Use the scroll bars to scroll to the new column.
- **Delete**: To delete a user-defined column click the **column header** and then click **Delete**.
- **Table Viewer**: Displays the drill table with the current specifications. In this view you can select a column to make it current by placing the cursor in a column cell. Enter data for the user-defined columns directly in the cells of this table viewer.

**DocTool Place Design View**

Choose the **DocTool » Place Design View** command to make an image of a specific region of the design and place it in one or more locations in the workspace. The image is dynamically updated whenever the original data changes.
The Design View can be moved, scaled, printed and mirrored. You can include specific layers and assign title and subtitle information. Items imaged in the Design View are displayed even when layers in the original section have been disabled. Title Sheet information included in the Design View is not displayed.

Design views may be placed only on a nonsignal layer.

The Place Design View dialog box appears as follows:

In the Place Design View dialog, the following options are available:

- **Title**: The name assigned to the Design View.
- **Subtitle**: The subtitle assigned to the Design View.
- **Text Style**: Select a text style for the Design View from the drop down list or click Text Styles to open the Options Text Style dialog box where you can add or modify any non-default style.
- **Scaling**: Enter the scale factor (greater than or equal to zero) for the Design View.
- **Region Coordinates**: The X and Y coordinates for the defined region can be entered in the Lower Left and Upper Right boxes or you can click the Define Region button to use the interactive definition tool. With this interactive tool, you can draw a bounding outline around the target area in the design that automatically enters the X and Y coordinates of that region in the Region Coordinates boxes. To exit the interactive tool, right-click and confirm that you want to update the coordinates with the newly defined region.
• **Layers**: Select the layers whose objects are to be included in the Design View. You can select individual layers, **Set All layers**, **Clear All layers** or **Apply a Layer Set** by clicking the appropriate button.

• **Mirror Design View**: If you want to show a mirror image of the objects in the Design View, select the **Mirror Design View** check box.

---

### DocTool Place Detail

Choose the **DocTool > Place Detail** command to place a close-up perspective of the board into your PCB design or drawing.

The board region in the close-up view is imported from a block file or a P-CAD picture file. These files can be created using the **Edit > Copy to File** command.

---

**Details may be placed only on a nonsignal layer.**

The detail can be moved, deleted, cut, copied, and pasted, but only as a single unit; individual objects inside the detail cannot be selected, edited, or removed. A detail may not be rotated or flipped.

A scaling factor can be specified when the detail is placed. This indicates the magnification of the detail from its original size. You can also specify a value for the line width when you do not want to retain the default value of 10.0 mils.

To update a detail if the design changes, the block file or P-CAD picture file from which the detail was placed must be recreated.

The **Place Detail** dialog is shown in the following figure:

![Place Detail dialog](image)

In the **Place Detail** dialog you can specify the following options:

• **File**: A block file (.blk) or a P-CAD picture (.emf) containing the board region must be imported. Click **Browse** and navigate to the desired block file or P-CAD picture file.

---

To place a detail from a block file, that block file must be generated from P-CAD PCB. Also, the file cannot contain P-CAD picture, detail, or diagram objects.
DocTool Place Diagram

Choose the DocTool » Place Diagram command in P-CAD PCB to place a depiction of the layer stackup of the board into your PCB design or drawing.

Diagrams may be placed only on a nonsignal layer.

The layer stackup diagram displays the configuration of the signal and plane layers in an annotated illustration. There are two types of layer stackup diagrams. An example of each layer stackup diagram is shown as follows:

The diagram can be moved, deleted, cut, copied, and pasted, but only as a single unit; individual objects inside the diagram cannot be selected, edited, or removed. A diagram may not be rotated or flipped.

The scaling factor, which indicates the magnification of the diagram from its original size, can be modified when the diagram is placed. Because the specified scale factor is not applied to the diagram's line widths and text, you must designate a specific line width and/or text font size to maintain their relative locations in the diagram.
The design data displayed in a diagram can be updated if the design changes using the **DocTool » Update** or **DocTool » Update All** commands.

The **Place Diagram** dialog is shown in the following figure:

![Place Diagram dialog](image)

In the **Place Diagram** dialog you can specify the following options:

- **Diagram Type**: Shows the diagram type. The **Layer Stackup** diagram expands and documents each layer in the board.
- **Title**: The title text is centered beneath the diagram.
- **Subtitle**: The subtitle text is centered beneath the title. It is suggested that you include the scale factor in the diagram’s subtitle.
- **Text Style**: Select the text style for the diagram. Click **Text Styles** to modify text styles.
- **Scale**: Enter the scaling factor (>0) for the diagram. A scaling factor of 1 specifies no size change from the diagram’s initial placement size. A scaling factor greater than 1 specifies magnification.
- **Line Width**: Enter the line width to be used in the layer stackup diagram. The default value is 10.0 mils.

Line widths and text are not scaled when the scale factor is changed. To maintain the relative location of the lines and text in the diagram you must provide line widths and text fonts sized proportionately to the designated scale factor.

- **Diagram Style**: Choose the style of the Layer Stackup diagram: **Style #1** or **Style #2**. An example of each style is displayed above.

To place the diagram, complete the dialog box options. After clicking **OK**, you are returned to the workspace. Use the mouse to drag the diagram to its desired location. Release the mouse button to place the diagram.
DocTool Place Picture

Choose the **DocTool » Place Picture** command in P-CAD PCB to place a P-CAD picture file (.emf) in your PCB design or drawing. This picture can be a magnified image of objects in the PCB design, a detail.

P-CAD pictures of the design may be created by choosing the **Copy to File** command. For details about creating a picture of a selected region of your board design, see *Edit Copy to File* (page 283).

The **Place Picture** dialog is used to navigate to the directory containing the picture by following these steps:

1. Choose **P-CAD Picture File** (.emf) in the Files of Type box.
2. Select the desired picture file and click **Open**.
3. Use the mouse to drag the picture to its desired location.
4. Release the mouse button to place the picture.

P-CAD pictures may be placed only on a nonsignal layer.

A picture object can be moved, deleted, cut, copied, and pasted, but only as a single unit; individual objects inside the picture object cannot be selected, edited, or removed. A picture may not be rotated or flipped. Picture objects may be scaled by selecting the object and dragging the handles at its vertices or by specifying a scaling factor in the **Picture Properties** dialog box. For instructions, see *Edit Properties* (page 292).

DocTool Titles

Choose the **DocTool » Titles** command to customize a title sheet for your design or drawing.

The **DocTool » Titles** command provides direct access to the Titles tab of the **Options Layers** or **Options Sheets** dialogs. From there you can custom build a title sheet for your design or drawing. This title sheet can include any or all of the following elements: title block, border, and zones.

DocTool Notes

Choose the **DocTool » Notes** in to define or import notes that you can place in your design or drawing.

The **DocTool » Notes** command provides direct access to the Notes tab of the **File Design Info** dialog box. From there you can define or import notes that can later be placed in your design.

DocTool Update

Choose the **DocTool » Update** command in to recalculate the design data and update the selected tables or diagrams embedded in the design.
DocTool Update All

Choose the **DocTool » Update All** command to recalculate the design data and update all tables or diagrams embedded in the design.

DocTool Mirror On Copy

Choose the **DocTool » Mirror On Copy** command to copy selected objects in the opposite perspective of the display, as if viewing the design from its underside.

To turn this feature ON, choose the **DocTool » Mirror On Copy** command. The feature is ON when a check mark appears next to the menu command.

To turn the feature OFF, choose the **DocTool » Mirror On Copy** command. The feature is OFF when no check mark appears next to the menu command.

When the feature is on, you can choose the following commands:

1. Choose the **Edit » Copy** command to move a mirror image of the selected objects to the Clipboard. Detail, diagram, and picture objects within the selected region are not mirrored.

2. Choose the **Edit » Copy to File** command to copy the mirror image of a P-CAD picture format to a file.

   **If the block file format is chosen using Edit » Copy to File, the Mirror On Copy option is ignored.**

These picture objects can be placed back in the design using the **Edit » Paste Special, Place Detail**, or **Place Picture** commands.
Using the Macro Commands

You use the commands in the Macro menu to setup, record, modify, and run macros. A macro is a shortcut for a sequence of actions. After you record a macro, you can assign a keyboard shortcut to a macro. Then, you can press the keyboard shortcut to playback the series of actions associated with the macro.

Macro Setup

Before you record a macro, choose Macro » Setup to specify the directory in which you want to store the macros you record. If you do not specify a directory, your macros are stored in the P-CAD directory by default.

When you choose Macro » Setup, the Macro Set Up dialog appears. Use the controls in this dialog to set up your directory options and to change the playback speed for your macros.

Setting Up a Macro

To set up a macro, do the following:


2. Click Browse. The Open dialog appears.

3. Select the directory that you want to use as your default macro directory. Then, click Open. You return to the Macro Set Up dialog.
4. Type a value in the Playback Delay (seconds) box to control the playback speed for each action in a macro. You can set the interval to the thousandths (.001 of a second).

5. Click OK to save your settings.

**Macro Record**

Choose **Macro » Record** to name and record a macro. When you choose **Macro » Record**, the **Macro Recorder** dialog appears. Use this dialog to assign a name to the macro you are about to record. For instructions on using this dialog, see [Macro Recording Tool (page 552)](#).

After you name your macro, click **OK** in the **Macro Recorder** dialog. P-CAD PCB begins recording your actions and the Macro Recording Tool appears. For details on this tool, see [Macro Recording Tool (page 552)](#).

**Macro Recording Tool**

The Macro Recording Tool contains various buttons that give you the ability to control the recording process:

<table>
<thead>
<tr>
<th>Click this button</th>
<th>To perform this function:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Stop Recording: Click this button to stop the recording process and save the recorded events in the designated macro file. To stop recording, you can also press <strong>M</strong> or click <strong>M</strong> button on the status bar.</td>
</tr>
<tr>
<td></td>
<td>Pause Recording: Click this button to pause the recording process. When you pause a recording this button changes to the Resume Recording button.</td>
</tr>
<tr>
<td></td>
<td>Recording Suspend: Click this button to suspend the recording process. This creates a pause during playback. You can also suspend recording by pressing the Pause/Break key.</td>
</tr>
<tr>
<td></td>
<td>Resume Recording: When you pause the recording process, this button appears in place of the Pause Recording button. It also appears during playback whenever the playback reaches a recorded suspend activity.</td>
</tr>
<tr>
<td></td>
<td>Recording Origin: Click this button to place an origin in the macro. When a recorded origin is encountered, you can click the left mouse button in the workspace to set a relative playback location during playback.</td>
</tr>
</tbody>
</table>
Recording a Macro

To record a macro, do the following:

1. Choose Macro » Record. The following Macro Recorder dialog appears.

   ![Macro Recorder Dialog]

2. Type a name for the macro in the Macro Name box.

3. Click OK. The following Macro Recording Tool appears. For details on the options associated with this tool, see Macro Recording Tool (page 552).

   ![Macro Recording Tool]

4. Perform any actions that you want to record.

5. Click the Stop button in the Macro Recording Tool.

   P-CAD PCB saves the macro in the directory you specified in the Macro Set Up dialog. Your macro is given the .mac file name extension by default.

   After you record a macro, you can assign a keyboard shortcut to a macro. Then, you can press the keyboard shortcut to playback the series of actions associated with the macro. Or, you can add the macro to the Utils menu.

   - To assign a keyboard shortcut to a macro, choose Options » Preferences. For instructions, see Options Preferences (page 448).
   - To add a command for the macro in the Utils menu, choose Utils » Customize. For instructions, see Utils Customize (page 537).

   A macro command that moves or deletes a component has no effect on a fixed component.

Recording a Temporary Macro

A temporary macro is a macro that is stored in your computer's memory and named Pcb_default.mac by default. To playback a temporary macro, you press the E key. Only one temporary macro is available; each time you record a temporary macro, it overwrites the previous one.
To record a temporary macro, do the following:

1. Click the M button on the Status Line or press M to begin recording. The button has a red background while the recording process is ON.

2. Complete the actions that you want to record. The entire group of macro functions is available to a temporary macro, including pause and suspend.

3. To stop recording, click the M button on the Status Line or press M. The button has a white background when the recording process is OFF.

To playback the temporary macro, press E. The actions you record will repeat each time you press E.

If you want to record a macro, but don’t want to save it as the temporary macro, choose the Macro » Record command. You can rename a macro or temporary macro by choosing the Macro » Rename command.

Macro Delete

Choose Macro » Delete to delete a macro. When you choose this command, the following Macro Delete dialog appears.

To delete a macro, select the macro to delete from the Macro Name list and click Delete. The Macro Name list displays all of the *.mac files that are saved in your default macro directory.

Macro Rename

Choose Macro » Rename to change the name of a macro. You can rename any macro, including the temporary macro named Pcb_default.mac. However, if you rename Pcb_default.mac, it is no longer the temporary macro.

When you choose this command, the following Macro Rename dialog appears.
Select the file to rename from the Old Macro Name list. The combo box lists all the *.mac files found in the default macro directory set in the Macro Setup dialog. Enter a new name in the New Macro Name box. Then, click Rename and click Close.

Macro Run

Choose Macro » Run to playback a named macro. When you choose this command, the following dialog appears.

To run the macro, enter the macro name by typing it in or selecting it from the combo box. The combo box lists all the *.mac files found in the default macro directory set in the Macro Setup dialog. Click OK. The M button on the Status Line is green when a macro is running.

To playback the temporary macro, press E. To record a temporary macro, press M, complete a series of actions, and press M again to stop recording.

After you record a macro, you can assign a keyboard shortcut to a macro. Then, you can press the keyboard shortcut to playback the series of actions associated with the macro. Or, you can add the macro to the Utils menu.

- To assign a keyboard shortcut to a macro, choose Options » Preferences. For instructions, see Options Preferences (page 448).
- To add a command for the macro in the Utils menu, choose Utils » Customize. For instructions, see Utils Customize (page 537).

Recording Efficient Macros

The macro recording process records every keystroke and mouse click you make in the workspace. As a result, you may find it more efficient to use the menu and keyboard shortcuts when recording a macro. To help you record efficient macros, the following list provides some helpful hints that you can use during the recording process:

- If you click a toolbar button during the recording process, the toolbar must be in the exact same location during playback. To minimize possible playback issues, use the keyboard shortcuts instead of the toolbar buttons.

- Choose menu commands instead of shortcut menu commands. For example, choose Edit » Properties instead of right-clicking an object and choosing Properties from the shortcut menu. The position of the shortcut menu changes based on mouse location.
When a dialog prompts you for a response during the recording process, insert a suspend command by clicking the Pause/Break button in the Macro Recording Tool. This gives you the ability to interact with various dialogs during the playback process.

There are times when you may select an item from a drop down list during event recording. If the order of the items in the list is subject to change due to additions or deletions, the most effective way to eliminate choosing the wrong item is to type the desired value in the box instead of selecting from the list. Then you are assured that the correct item is incorporated into the event.

Whenever options on the Status Line are recorded, such as changing a layer, make sure that the Status Line view is enabled when running the macro. If the Status Line is not visible during macro playback, the location of the recorded command cannot be identified nor executed.

When working with text it is best to make changes using keys such as DELETE, BACKSPACE, etc.

Retain the same size workspace and focus during playback as you used when recording. Changing the workspace size or zoom factor causes adjustments in location coordinates. For instance, if you place a component in the outer regions of a design and change the zoom so that those coordinates are no longer visible in the workspace, the component cannot be placed during playback.

The resolution of the system in which you are running a recorded macro should match the resolution of the system in which the macro was recorded.

### Other Macro Features

The macro tool features extend beyond the record and play functions. This section describes these additional features.

#### Running a Macro

You can start P-CAD PCB and a macro from the command line by entering the correct system path to the executable and then the macro file name.

```
<full path>.PCB.exe /e
<full path><macro name>
```

If PCB is already running, this command plays back the macro in the current PCB session. If PCB is not currently running, the program starts and the macro opens.

#### Status Line Recording Indicators

When the Status Line is visible, the background of the Macro toggle button (M) changes color to indicate the type of activity being performed.

- **Red** indicates the recording process is active.
- **Green** indicates the playback process is active.
• **Yellow** indicates a pause in the recording, or shows that a suspend or origin command has been encountered during playback.

**Automatic Delays**
Whenever you open a *Print Setup, Font, or Custom Color* dialog during the recording process, P-CAD PCB automatically inserts a delay. This allows the dialog time to appear in the workspace. If the delay interval is not large enough for the playback to accommodate the next event, you can increase the delay interval by editing the *.*.mac file or by editing the Pcb.ini file and changing the MacroCommonDialogDelay value to a larger number.

**Editing Macro Files**
You can use a text editor, such as the Notepad, to create or edit macro files. For example, you may want to modify a file to add or change delays, start other applications, etc.
However, you should be familiar with the proper syntax before you modify a macro file.

**Macro File Syntax**
Before you modify a macro file with a text editor, such as the Notepad, you should be familiar with the syntax used to record the events in the macro file. Syntax is very important in the macro files. Each macro command is case sensitive and each line must contain a carriage return.

A sample macro, opened in a text editor, is shown in the following figure:

![Sample Macro File](image)

In a macro file, there are several event types: Mouse Events, Keyboard Events, Special Events, and Edit Events. Each event type has its own keywords and syntax. In the following sections, syntax descriptions show a comma to separate the parts of the format for readability. The commas are not to be inserted into the actual format of the command. An example of an actual syntax is provided as well.
Mouse Events

Mouse events occur when the cursor is positioned over the workspace or another part of the P-CAD PCB window (e.g., over a menu, toolbar, dialog, etc.). Events that occur when the cursor is over the workspace are recorded as appunit locations. Events occurring when the cursor is over a menu, toolbar, etc., are recorded in pixels.

- **Syntax:** Keyword, white space, positive integer, white space, unit string, white space, positive integer, white space, unit string.

  \[
  \text{LeftMouseDown} \ 21 \ \text{appunits} \ 150 \ \text{appunits} \\
  \text{LeftMouseUp} \ 18 \ \text{pixels} \ 583 \ \text{pixels} \\
  \text{LeftMouseDown}\&\text{KeyStroke} \ 179 \ \text{appunits} \ 50 \ \text{appunits} \ \text{Shift}
  \]

- **Keywords:** LeftMouseDown, LeftMouseUp, LeftMouseDoubleClick, RightMouseDown and RightMouseUp, LeftMouseDown\&KeyStroke appunits or pixels Ctrl, LeftMouseDown\&KeyStroke appunits or pixels Shift, LeftMouseDown\&KeyStroke appunits or pixels Alt.

- **Unit Strings:** A unit string in a mouse event is either pixels or appunits. In the example above, 20 and 150 are the X and Y coordinates of the left mouse down action, and pixels indicates that the mouse click was made on a toolbar or within a dialog command. If the unit string contains appunits, then the mouse click was made in the workspace at the indicated X and Y coordinates.

Keyboard Events

- **Syntax:** Keyword, white space, quoted character string.

  \[
  \text{SendKeys} \ \{\text{Shift+N}\}\{\text{E}\}\{\text{W}\}
  \]

- **Keywords:** SendKeys

- **Character Strings:** Each key stroke, and combinations thereof, must be enclosed in curly brackets and the string of curly bracketed strokes enclosed in quotations. In the example above, the word New is recorded using the keyboard syntax format.

- **Keyboard Codes:** The following list defines the recordable keys and how they are represented in the macro file.

<table>
<thead>
<tr>
<th>Keys</th>
<th>Codes</th>
</tr>
</thead>
<tbody>
<tr>
<td>a - z</td>
<td>A - Z</td>
</tr>
<tr>
<td>A - Z</td>
<td>Shift+A - Shift+Z</td>
</tr>
<tr>
<td>0 - 9</td>
<td>0 - 9</td>
</tr>
<tr>
<td>F1 - F12</td>
<td>F1 - F12</td>
</tr>
<tr>
<td>Alt</td>
<td>Alt</td>
</tr>
<tr>
<td>Back Space</td>
<td>Backspace</td>
</tr>
</tbody>
</table>
## Keys

<table>
<thead>
<tr>
<th>Keys</th>
<th>Codes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>End</td>
<td>End</td>
</tr>
<tr>
<td>Escape</td>
<td>Esc</td>
</tr>
<tr>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Insert</td>
<td>Insert</td>
</tr>
<tr>
<td>Num Lock</td>
<td>Not recordable</td>
</tr>
<tr>
<td>Page Down</td>
<td>PageDown</td>
</tr>
<tr>
<td>Page Up</td>
<td>PageUp</td>
</tr>
<tr>
<td>Pause Break</td>
<td>Not recordable</td>
</tr>
<tr>
<td>Print Screen</td>
<td>Not recordable</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td>Not recordable</td>
</tr>
<tr>
<td>Space</td>
<td>Space</td>
</tr>
<tr>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Down</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Left</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Right</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>Up</td>
</tr>
<tr>
<td>Numpad 0</td>
<td>Numpad0</td>
</tr>
<tr>
<td>Numpad 1</td>
<td>Numpad1</td>
</tr>
<tr>
<td>Numpad 2</td>
<td>Numpad2</td>
</tr>
<tr>
<td>Numpad 3</td>
<td>Numpad3</td>
</tr>
<tr>
<td>Numpad 4</td>
<td>Numpad4</td>
</tr>
<tr>
<td>Numpad 5</td>
<td>Numpad5</td>
</tr>
<tr>
<td>Numpad 6</td>
<td>Numpad6</td>
</tr>
<tr>
<td>Numpad 7</td>
<td>Numpad7</td>
</tr>
<tr>
<td>Numpad 8</td>
<td>Numpad8</td>
</tr>
<tr>
<td>Numpad 9</td>
<td>Numpad9</td>
</tr>
<tr>
<td>Numpad /</td>
<td>NumpadDivide</td>
</tr>
<tr>
<td>Numpad -</td>
<td>NumpadMinus</td>
</tr>
<tr>
<td>Numpad *</td>
<td>NumpadMultiply</td>
</tr>
<tr>
<td>Numpad +</td>
<td>NumpadPlus</td>
</tr>
<tr>
<td>Numpad Clear</td>
<td>Clear</td>
</tr>
<tr>
<td>'</td>
<td>Backquote</td>
</tr>
<tr>
<td>Keys</td>
<td>Codes</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
</tr>
<tr>
<td>-</td>
<td>Minus</td>
</tr>
<tr>
<td>=</td>
<td>Equal</td>
</tr>
<tr>
<td>\</td>
<td>Backslash</td>
</tr>
<tr>
<td>;</td>
<td>Semicolon</td>
</tr>
<tr>
<td>'</td>
<td>Singlequote</td>
</tr>
<tr>
<td>/</td>
<td>Slash</td>
</tr>
<tr>
<td>.</td>
<td>Period</td>
</tr>
<tr>
<td>,</td>
<td>Comma</td>
</tr>
<tr>
<td>[</td>
<td>LeftBracket</td>
</tr>
<tr>
<td>]</td>
<td>RightBracket</td>
</tr>
<tr>
<td>~</td>
<td>Shift+Backquote</td>
</tr>
<tr>
<td>!</td>
<td>Shift+1</td>
</tr>
<tr>
<td>@</td>
<td>Shift+2</td>
</tr>
<tr>
<td>#</td>
<td>Shift+3</td>
</tr>
<tr>
<td>$</td>
<td>Shift+4</td>
</tr>
<tr>
<td>%</td>
<td>Shift+5</td>
</tr>
<tr>
<td>^</td>
<td>Shift+6</td>
</tr>
<tr>
<td>&amp;</td>
<td>Shift+7</td>
</tr>
<tr>
<td>*</td>
<td>Shift+8</td>
</tr>
<tr>
<td>(</td>
<td>Shift+9</td>
</tr>
<tr>
<td>)</td>
<td>Shift+0</td>
</tr>
<tr>
<td>_</td>
<td>Shift+Minus</td>
</tr>
<tr>
<td>+</td>
<td>Shift+Equal</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>{</td>
<td>Shift+RightBracket</td>
</tr>
<tr>
<td>)</td>
<td>Shift+LeftBracket</td>
</tr>
<tr>
<td>`</td>
<td>Shift+Singlequote</td>
</tr>
<tr>
<td>:</td>
<td>Shift+Semicolon</td>
</tr>
<tr>
<td>?</td>
<td>Shift+Slash</td>
</tr>
<tr>
<td>&gt;</td>
<td>Shift+Period</td>
</tr>
<tr>
<td>&lt;</td>
<td>Shift+Comma</td>
</tr>
</tbody>
</table>

Special Windows Keys: Not recordable
Special Events

- **Syntax:** Keyword.
  
  Origin
  Suspend
  Delay 1.001

- **Keywords:** Origin, Suspend and Delay.

- **Exception:** The Delay keyword is generated by the macro utility whenever a print setup, font or custom color dialog is invoked in the macro. Inserting a one-time delay interval pauses the playback so that there is time to set up the next recorded event. The Delay keyword is followed by a positive floating number. This delay time is added to the global playback interval set using the Macro » Setup command.

Edit Events

- **Syntax:** Keyword, qualifier.
  
  Wait 4
  ExecuteCommand "C:\P-AD\PATED.EXE"

- **Keywords:** Wait, ExecuteCommand.

- **Qualifier:** Each keyword has its own type of qualifier. The Wait keyword is followed by a positive number indicating the pause interval in seconds. During playback the wait interval is counted down in the status bar and the playback resumes when the interval is complete.

  The ExecuteCommand launches another application and requires the application name enclosed in quotes. It may also require the path to the application name or file.

File Syntax

- **Beginning:** The first line of the macro file begins with the keyword PcbMacro, followed by the name of the macro and a comment string. The comment string, which can also be added to any line in the macro, must begin with a single quote.

- **Ending:** Every macro must end with the keyword End.

- **Other:** Every line must begin with one of the keywords. Although optional, a tab at the end of each line helps increase a macro’s readability when it is edited.
Window Commands

Using the Window Commands

Use the commands in the Windows menu to arrange and manage open windows.

In P-CAD PCB, you can open multiple design files at the same time. You can also open multiple views of a single design.

The window you are working in is the active window; the design you are working with is the active design. The work that you perform is entered in the active design, and the commands that you use, for the most part, affect only the active design.

Window New Window

Choose Window New Window to open a new window that contains an alternate view of the active design. You can move independently in each window, making it easy to compare different parts of the same design.

A number identifying the window is added to the file name in the title bar and at the bottom of the Window menu. For example, C:\PCAD\TUTORIAL\CHAP9.PCB:2.

Window Cascade

Choose Window Cascade to arrange all open windows so that the title bar of each open window is visible. All windows overlap, starting in the upper-left corner of your workspace. You can see each window's title, making it easy to switch between windows.

As a shortcut for choosing this command, you can press SHIFT+F5.

Window Tile

Choose Window Tile to arrange all open windows so each open window is visible. Windows are resized and arranged side-by-side so that all windows are visible and none overlap.
As a shortcut for choosing this command, you can press \texttt{SHIFT+F4}.

\textbf{Window Arrange Icons}

Choose \textbf{Window Arrange Icons} to arrange design file icons in the P-CAD PCB window.

Design files can be minimized into icons using the Control menu or by clicking the \textit{down arrow} in the upper-left corner of the screen. This command arranges these icons so that they are evenly spaced and don't overlap.

You can open one of these design icons by double clicking it or choosing \textbf{Restore} from the icons Control menu.

\textbf{Selecting a Window}

The bottom of the Window menu lists all open windows. To make a window active select it from this list. Designs appear on the Windows menu in the order that you opened them.

If there are more than nine windows opened, a \textit{More Windows...} command appears. Choose this command to view additional windows.

To close a window, double click the control button in the upper-left corner of the window. Closing the last window automatically opens a new, untitled window.
Help Commands

Help P-CAD PCB Help Topics
Choose Help P-CAD PCB Help Topics to open the P-CAD PCB Help file. The Contents tab is structured to match the order of commands as they appear in the product and the Index tab, gives you the ability to look up a specific concept, definition, or keyword.

How to Use Help
Choose Help How to Use Help to open the Windows Help file. This file contains instructions on how to use the help system.

Series II Commands
Choose Help Series II Commands to open a list that shows the mapping relationship between P-CAD PCB (6/400) Series II commands and P-CAD PCB commands and features.

About P-CAD PCB
Choose Help About P-CAD PCB to open a dialog that contains information such as the product version number, release date, memory used, memory available, and license number.
This appendix summarizes the commands and functions that you can gain access to using P-CAD shortcut keys and standard Windows accelerators.

Standard Windows key combinations are functional for all of the menu commands; use the normal combination ALT, X, Y, where x equals the underlined menu character, and y equals the underlined command character.

You can use the Options Preference dialog to change shortcut keys for commands and macros.

### Keyboard Shortcuts in P-CAD PCB

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT+F4</td>
<td>A shortcut for choosing File » Exit, which quits the P-CAD program. If the current design has been modified since the last save, you will be prompted (YES or NO) as to whether you want to save the changes to the file. The program writes this information to the PCB.ini file.</td>
</tr>
<tr>
<td>ALT+ Mouse Click</td>
<td>For any click-and-drag or drag-and-drop operations, you can hold down the ALT key, click the left mouse button, then move or drag the object wherever you want without having to keep the mouse button depressed. Without the ALT key, you would typically have to click and drag with the button depressed while you are dragging.</td>
</tr>
<tr>
<td>arrow keys</td>
<td>The arrow keys move the cursor to the next grid point. Press CTRL+arrow to move the cursor 10 grid points.</td>
</tr>
<tr>
<td>CTRL+C</td>
<td>A shortcut for choosing Edit » Copy. Copies objects from your design to the clipboard.</td>
</tr>
<tr>
<td>CTRL+Mouse Click</td>
<td>You can copy-and-drag an object by first selecting the object, holding down CTRL and clicking the left mouse button in the selected object region, and dragging a copy of the object to a location and releasing to paste it.</td>
</tr>
</tbody>
</table>
### Appendix A: Keyboard Reference

#### Keyboard Shortcuts in P-CAD PCB

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CTRL+N</strong>  (File New)</td>
<td>A shortcut for choosing File » New. This command opens a window containing a new, untitled window.</td>
</tr>
<tr>
<td><strong>CTRL+O</strong>  (File Open)</td>
<td>A shortcut for choosing File » Open, which opens the Open dialog box. Use the controls in this dialog to navigate to the file that you want to open.</td>
</tr>
<tr>
<td><strong>CTRL+P</strong>  (File Print)</td>
<td>A shortcut for choosing File » Print.</td>
</tr>
<tr>
<td><strong>CTRL+S</strong>  (File Save)</td>
<td>Saves changes to the current design without closing it. To save the design to a different file, choose the File » Save As command. To clear the workspace, choose File » New.</td>
</tr>
<tr>
<td><strong>CTRL+V</strong>  (Edit Paste)</td>
<td>A shortcut for choosing Edit » Paste. You can paste objects from the clipboard to the your design.</td>
</tr>
<tr>
<td><strong>CTRL+X</strong>  (Edit Cut)</td>
<td>A shortcut for choosing Edit » Cut. Cuts objects from the design to the clipboard.</td>
</tr>
<tr>
<td><strong>CTRL+Z</strong>  (Edit Undo)</td>
<td>A shortcut for choosing Edit Undo. If you have not completed your action (e.g., you are in Place Line mode and have not finished a series of segments), Undo will not reverse the action. Press the BACKSPACE key to unwind the unfinished actions when you are in a placement mode.</td>
</tr>
<tr>
<td><strong>CTRL+F4</strong></td>
<td>Closes the active window.</td>
</tr>
<tr>
<td><strong>CTRL+F6 or CTRL+TAB</strong></td>
<td>Switches focus to the next window. Press CTRL+SHIFT+F6 or (CTRL+SHIFT+TAB) to switch focus to the previous window.</td>
</tr>
<tr>
<td><strong>SHIFT+T</strong>  (Move to Layer)</td>
<td>A shortcut for choosing Edit » Move to Layer.</td>
</tr>
<tr>
<td><strong>SHIFT+F4</strong>  (Window Tile)</td>
<td>A shortcut for choosing Windows Tile. Windows are resized and arranged side-by-side so that all windows are visible and none overlap.</td>
</tr>
<tr>
<td><strong>SHIFT+F5</strong>  (Window Cascade)</td>
<td>A shortcut for choosing Windows Cascade. All windows overlap, starting in the upper-left corner of your Workspace. You can see each window's title, so you can click a title bar to switch between windows.</td>
</tr>
<tr>
<td><strong>DEL</strong>  (Delete)</td>
<td>Deletes all selected objects</td>
</tr>
<tr>
<td><strong>F1</strong>  (Help)</td>
<td>The F1 key displays context-sensitive help. If you put focus on a command or dialog (by mouse or keyboard) and press F1, the Help window appears containing information specific to the focus item.</td>
</tr>
<tr>
<td><strong>PAGE DOWN</strong></td>
<td>Scrolls down by one page in the workspace. Press CTRL+PAGE DOWN to scroll one page to the right.</td>
</tr>
<tr>
<td><strong>PAGE UP</strong></td>
<td>Scrolls up by one page in the workspace. Press CTRL+PAGE UP to scroll one page to the left.</td>
</tr>
<tr>
<td><strong>Keyboard Shortcuts in P-CAD PCB</strong></td>
<td><strong>Appendix A: Keyboard Reference</strong></td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td><strong>SPACEBAR</strong></td>
<td>To simulate a click and release of the mouse button, you need to press the SPACEBAR twice. To simulate pressing and holding down the left mouse button, you press the SPACEBAR once.</td>
</tr>
<tr>
<td><strong>BACKSPACE * (Unwind)</strong></td>
<td>Used as unwind command while placing objects with multiple segments (e.g., lines, polygons, route manual). Each backspace * stroke unwinds the previously placed item.</td>
</tr>
<tr>
<td><strong>ESC (Escape)</strong></td>
<td>Terminates placement of objects with multiple segments; it also cancels a redraw in progress. It is often equivalent to right-clicking. ESC also exits from dialogs (equaling the Close or Cancel button), which is a Windows feature.</td>
</tr>
<tr>
<td><strong>PLUS Key (Zoom In)</strong></td>
<td>Press the plus (+) key on either the keyboard or keypad to zoom in at the cursor location. This is a shortcut for choosing View » Zoom In. When you press the plus (+) key, the zoom cursor does not appear. The zoom cursor only appears when you choose a zoom command from the View menu.</td>
</tr>
<tr>
<td><strong>MINUS Key (Zoom Out)</strong></td>
<td>Press the minus (-) key on either the keyboard or keypad to zoom out from the cursor location. This is a shortcut for choosing View » Zoom Out. When you press the minus (-) key, the zoom cursor does not appear. The zoom cursor only appears when you choose a zoom command from the View menu.</td>
</tr>
<tr>
<td><strong>A key (Grid Toggle)</strong></td>
<td>Switches between absolute and relative grid settings.</td>
</tr>
<tr>
<td><strong>C Key (View Center)</strong></td>
<td>A shortcut for choosing View » Center. This command allows you to center your cursor location. Place the cursor in the area of your design that you want centered and press C. Pressing the C key is an effective way of panning across the workspace.</td>
</tr>
<tr>
<td><strong>D Key (Increment RefDes)</strong></td>
<td>Increments the RefDes if while the Place Component tool is enabled. Press SHIFT+D to decrement the RefDes.</td>
</tr>
<tr>
<td><strong>F Key (Flip Object)</strong></td>
<td>Flips an object during place and move operations. Not all objects can be flipped. The F key also switches between orthogonal mode pairs.</td>
</tr>
<tr>
<td><strong>G Key (Grid Select)</strong></td>
<td>Scrolls forward through the list of grid settings. Press SHIFT+G to scroll back through the list.</td>
</tr>
<tr>
<td><strong>J Key (Enter Coordinate)</strong></td>
<td>Places focus on the X coordinate text in the Status Line. From there, you can enter new X and Y coordinates.</td>
</tr>
<tr>
<td><strong>L and SHIFT+L (Change Layer)</strong></td>
<td>L cycles downward through the board’s layer list, duplicating the function of the down arrow on the layer list/combo box on the Status Line. Press SHIFT+L to cycle upward through the layer list.</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts in P-CAD PCB

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>O and SHIFT+O</strong> (Orthogonal Mode)</td>
<td>O sequences forward through the orthogonal modes during placement of line objects or manual routing; <strong>SHIFT+O</strong> sequences backward throughout the modes. The F key switches between orthogonal mode pairs. Orthogonal modes are set in the Options Configure dialog.</td>
</tr>
<tr>
<td><strong>Q Key</strong> (Draft Mode)</td>
<td>Turns draft mode on and off.</td>
</tr>
<tr>
<td><strong>R and SHIFT+R</strong> (Rotate)</td>
<td>Press R to rotate objects by 90 degrees during Place and Select operations. Press <strong>SHIFT+R</strong> to rotate objects by your current rotation increment. For more information about rotating objects with place and select operations.</td>
</tr>
<tr>
<td><strong>S Key</strong> (Select)</td>
<td>A shortcut for choosing <strong>Edit » Select</strong> (also the toolbar Select button). When enabled, you are able to click objects to highlight them, then move, rotate, delete, duplicate, and otherwise modify them.</td>
</tr>
<tr>
<td><strong>U Key</strong> (Undo)</td>
<td>A shortcut for choosing <strong>Edit » Undo</strong>. For the unwind feature, See the BACKSPACE key description in this section.</td>
</tr>
<tr>
<td><strong>Y Key</strong> (Options Layers)</td>
<td>A shortcut for choosing <strong>Options » Layers</strong>. This key opens the Options Layers dialog.</td>
</tr>
<tr>
<td><strong>W Key</strong> (Line Width Scroll)</td>
<td>Scrolls forward through the list of line widths established in the design. Press <strong>SHIFT+W</strong> to scroll back through the list.</td>
</tr>
<tr>
<td><strong>X Key</strong> (Cursor Style)</td>
<td>Switches between the cursor styles: Arrow, Small Cross, and Large Cross.</td>
</tr>
<tr>
<td><strong>Y Key</strong> (Options Layers)</td>
<td>A shortcut for choosing <strong>Options » Layers</strong>. This key opens the Options Layers dialog.</td>
</tr>
<tr>
<td><strong>Z Key</strong> (Zoom Window)</td>
<td>A shortcut for choosing <strong>View » Zoom Window</strong>. Just press Z and then draw the zoom window; the cursor takes the shape of a magnifying glass to indicate that you are in zoom mode. Whatever you surround with the zoom window will fill the screen.</td>
</tr>
<tr>
<td><strong>Slash Keys (/ or )</strong></td>
<td>Stops a route in mid-connection without adding a final copper segment. A backward slash functions identically to a forward slash.</td>
</tr>
</tbody>
</table>
P-CAD System Messages

This appendix documents the messages that you might encounter when importing or exporting a PDIF file in P-CAD PCB or Schematic.

### Error Messages

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>A reference designator is required in instance &lt;name&gt; near line &lt;line number&gt;.</td>
<td>The reference designator is missing.</td>
<td>Enter the reference designator and try again.</td>
</tr>
<tr>
<td>Attribute &lt;key name&gt; near (x, y) does not exist in original symbol.</td>
<td>The system found an attribute in the normalized symbol that does not exist in symbol being translated.</td>
<td>N/A</td>
</tr>
<tr>
<td>Bad PIN_DEF record #&lt;number&gt; near line &lt;line number&gt;. Pad ignored.</td>
<td>A syntax error was encountered. A PIN_DEF entry is malformed.</td>
<td>Check the PDIF file at the designated line number to determine the cause. Then consult your PDIF manual to correct the syntax.</td>
</tr>
<tr>
<td>Component instance &lt;name&gt; (&lt;ref des&gt;) pin &lt;pin des&gt; references an unknown net &lt;name&gt; near line &lt;line number&gt;.</td>
<td>The net does not exist.</td>
<td>Either create it in Master Designer or reset the pin’s net name.</td>
</tr>
<tr>
<td>Data in this design extends beyond 60 square inches. Load aborted.</td>
<td>P-CAD PCB allows a maximum of 60 square inches for a design. This design is too big.</td>
<td>Either make it smaller or break up the design.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Cause</td>
<td>Solution</td>
</tr>
<tr>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Device expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>Each entry in a cross reference file has a device, but one was not found.</td>
<td>Add the device name at the specified line number.</td>
</tr>
<tr>
<td>Duplicate pin designator &lt;pin des&gt; in instance &lt;name&gt; near line &lt;line number&gt;. Pin ignored.</td>
<td>P-CAD PCB and Schematic do not allow duplicate pin designators. The duplicate pins will not show up in the resulting component.</td>
<td>Edit the PDIF file to change the pin designators.</td>
</tr>
<tr>
<td>Duplicate reference designator &lt;reference designator&gt; in instance &lt;name&gt; near line &lt;line number&gt;. Instance ignored.</td>
<td>A duplicate reference designator was found. P-CAD PCB and Schematic do not support duplicate reference designators. This instance was ignored.</td>
<td>Either change the reference designator in Master Designer or edit the PDIF file and change the Rd statement.</td>
</tr>
<tr>
<td>Equal sign expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>A syntax error was encountered. An entry in a cross reference file may have the power and ground pins listed.</td>
<td>Enter an equal sign. The format is (<em>pin des</em> = <em>net name</em>,...). The system logs this error if it encounters a pin designator, which is not followed by an equal sign.</td>
</tr>
<tr>
<td>File revision number is unrecognized.</td>
<td>The PDIF version number was not recognized.</td>
<td>Use a PDIF file from Master Designer version 6.0 or later.</td>
</tr>
<tr>
<td>Gate number expected on line &lt;line number&gt; of &lt;file name&gt;</td>
<td>A syntax error was encountered. Each entry in a cross reference file has a gate number, but one was not found.</td>
<td>Check the PDIF file at the designated line number to determine the cause. Then consult your PDIF manual to correct the syntax.</td>
</tr>
<tr>
<td>Instance &lt;name&gt; referenced an undefined component (COMP_DEF=&lt;name&gt;) near line &lt;line number&gt;.</td>
<td>A syntax error was encountered. An instance references the name of a COMP_DEF that was not defined prior to the instance.</td>
<td>Check the PDIF file at the designated line number to determine the cause. Then consult your PDIF manual to correct the syntax.</td>
</tr>
<tr>
<td>Keyword expected on line &lt;line number&gt;</td>
<td>A syntax error was encountered.</td>
<td>Check the PDIF file at the designated line number to determine cause. Then consult your PDIF manual to correct the syntax.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Cause</td>
<td>Solution</td>
</tr>
<tr>
<td>---------------</td>
<td>-------</td>
<td>----------</td>
</tr>
<tr>
<td>Left paren expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>A syntax error was encountered.</td>
<td>Correct the syntax. The format is <code>&lt;pin des&gt; = &lt;net name&gt;</code>,...). The system logs this error if it encounters a net name, which is not followed by a left paren or comma.</td>
</tr>
<tr>
<td>Load failed near line &lt;line number&gt;.</td>
<td>A syntax error was encountered.</td>
<td>Check the PDIF file at the designated line number to determine the cause. Then consult your PDIF manual to correct the syntax.</td>
</tr>
<tr>
<td>Net name expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>A syntax error was encountered</td>
<td>Correct the syntax. The format is <code>&lt;pin des&gt; = &lt;net name&gt;</code>,...). The system logs this error if it encounters an equal sign, which is not followed by a net name.</td>
</tr>
<tr>
<td>No {Lystr...} section found.</td>
<td>A syntax error was encountered.</td>
<td>Check the PDIF file at the designated line number to determine cause.</td>
</tr>
<tr>
<td>No pad stacks defined near line &lt;line number&gt;.</td>
<td>PDIF PCBs require an attached PAD_STACK record to load properly into P-CAD PCB.</td>
<td>Edit the PDIF file at the designated line number to include the name of the attached pad stack.</td>
</tr>
<tr>
<td>Not enough memory</td>
<td>This means the system could not allocate enough memory to do its work.</td>
<td>Close some applications and try again.</td>
</tr>
<tr>
<td>Pad stack &lt;name&gt; has shape &lt;PDIF object&gt; (&lt;number&gt;X&lt;number&gt;) that is smaller than both the pad hole size (&lt;number&gt;) and the via hole size (&lt;number&gt;) near line &lt;line number&gt;: Hole size set to 0.</td>
<td>A pad type (Pt) is trying to set too big a hole. The hole is assigned either through the tool table file or the pad/via default sizes specified in the PCB.ini file.</td>
<td>Either change the default pad/via hole sizes in the PCB.ini file, or change the specified tool table. See Cleanup Tips in the Using P-CAD Files chapter.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Cause</td>
<td>Solution</td>
</tr>
<tr>
<td>--------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Part file name expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>Each entry in a cross reference file has a part file name, but one was not found.</td>
<td>Check the PDIF file at the designated line number to determine the cause.</td>
</tr>
<tr>
<td>P-CAD attribute near (x, y) has no value.</td>
<td>This message means that the system found a Master Designer attribute that does not have a value.</td>
<td>N/A</td>
</tr>
<tr>
<td>PDIF item &lt;PDIF object&gt; is not supported in nets.</td>
<td>Some PDIF objects are not supported in P-CAD PCB or Schematic nets.</td>
<td>Remove the object and try again.</td>
</tr>
<tr>
<td>Pin &lt;pin des&gt; of part &lt;part number&gt; of component &lt;name&gt; could not be added near line &lt;line number&gt;.</td>
<td>A memory or resource limit has been reached.</td>
<td>N/A</td>
</tr>
<tr>
<td>Pin number expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>A syntax error was encountered. An entry in a cross reference file may have the power and ground pins listed.</td>
<td>Correct the syntax. The format is (&lt;pin des&gt; = &lt;net name&gt;,...). The system logs this error if it encounters a equal sign, which is not preceded by a pin number.</td>
</tr>
<tr>
<td>Power or ground pin &lt;pin des&gt; for component &lt;name&gt; does not have a net name or a pin name.</td>
<td>A power pin was found that does not have a net name or does not have a pin name.</td>
<td>Check the PDIF file at the designated line number to determine the cause.</td>
</tr>
<tr>
<td>Right paren expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>An entry in a cross reference file may have the power and ground pins listed. The format is (&lt;pin des&gt; = &lt;net name&gt;,...). The system logs this error if it encounters a equal sign which is not preceded by a pin number</td>
<td>Check the PDIF file at the designated line number to determine the cause.</td>
</tr>
<tr>
<td>Symbol file name expected on line &lt;line number&gt; of &lt;file name&gt;.</td>
<td>A syntax error was encountered. Each entry in a cross reference file has a symbol file name, but one was not found.</td>
<td>Check the PDIF file at the designated line number to determine the cause.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Cause</td>
<td>Solution</td>
</tr>
<tr>
<td>---------------------------------------------------------</td>
<td>-----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Too many power and ground pins for error file.</td>
<td>If a component is heterogeneous, the system writes the cross-reference file lines to the error file. The cross-reference file line consists of the number of gates, the device, the part file name, the power and ground pins, and the symbol file name. There is a limit to how many power and ground pins can be written to the error file. This message means that limit was exceeded.</td>
<td>Edit the cross-reference file and add any pins that are missing.</td>
</tr>
<tr>
<td>Too many symbols on this sheet to create P-CAD symbol name.</td>
<td>P-CAD symbol instances require a name. This name’s format consists of NCssssxxxx; where ssss is sheet number and xxxx is a symbol number. This only allows for 9999 symbols on a sheet. If the system detects that there are more than 9999 symbols on a sheet, which require a symbol name, it logs this error.</td>
<td>Create a new sheet and move some of the parts onto it.</td>
</tr>
<tr>
<td>Unable to open file &lt;file name&gt;.</td>
<td>This could mean that the file does not exist, or that the system is trying to open for writing a read-only file.</td>
<td>Make sure the specified file exists and that it is not a read-only file.</td>
</tr>
<tr>
<td>Unable to rename file &lt;file name&gt; to &lt;file name&gt;.</td>
<td>This could mean that the file exists and that it is not a read-only file.</td>
<td>Make sure the specified file exists and that it is not a read-only file.</td>
</tr>
<tr>
<td>Unable to translate text object near (x, y).</td>
<td>The system was unable to get the data from a text object so that it could be translated.</td>
<td>N/A</td>
</tr>
<tr>
<td>Unable to translate text style for text object near (x, y).</td>
<td>The system found a text object that is using an unrecognizable text style.</td>
<td>N/A</td>
</tr>
</tbody>
</table>
## Warning Messages

<table>
<thead>
<tr>
<th>Warning Message</th>
<th>Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute key too long near (x, y).</td>
<td>PDIF format allows only 23 characters for an attribute key. The system found a key with more than 23 characters.</td>
<td></td>
</tr>
<tr>
<td>Attribute object near (x, y) has no value.</td>
<td>The system found an attribute with no value. PDIF format requires a value so this attribute was ignored by the system.</td>
<td></td>
</tr>
<tr>
<td>Attribute value too long near (x, y).</td>
<td>PDIF format allows only 255 characters for an attribute value. The system found an attribute value with more than 255 characters.</td>
<td>The attribute value is translated truncated to 255 characters.</td>
</tr>
<tr>
<td>Cannot open file &lt;file name&gt;.</td>
<td>This could mean that the file does not exist, or that the system is trying to open for writing a read only file.</td>
<td></td>
</tr>
<tr>
<td>COMP_DEF &lt;name&gt; has a package pin number (&lt;number&gt;) that is out of range near line &lt;line number&gt;.</td>
<td>The pin number specified in the SPKG Sp record does not map to any pad in the PIN_DEF record. Either the pin des number is greater than the number of pads or a pad with the same name (number) could not be found.</td>
<td></td>
</tr>
<tr>
<td>COMP_DEF &lt;name&gt; has no SPKG section near line &lt;line number&gt;. Pin names will start at '1'.</td>
<td>The COMP_DEF has no pin to pad mapping (packaging) information. The components pins created will have pin designators that match the pad’s position in the PIN_DEF array. The component is most likely a PCB only component.</td>
<td></td>
</tr>
<tr>
<td>Warning Message</td>
<td>Cause</td>
<td></td>
</tr>
<tr>
<td>-------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>COMP_DEF &lt;name&gt; references unknown pad stack &lt;number&gt;. Style &lt;name&gt; used instead.</td>
<td>A pad references a padstack number (Pt) that is not defined in the PAD_STACK record. The PCB “(Default)” padstack will be used instead.</td>
<td></td>
</tr>
<tr>
<td>Component &lt;name&gt; has had its name changed to &lt;name&gt;. This is required to maintain uniqueness in P-CAD.</td>
<td>A component’s type in Master Designer is used as the file name for the symbol data. This limits the component’s type to 8 characters. In P-CAD PCB and Schematic, the component’s type can be 17 characters. This means that the type is truncated to 8 characters and slightly modified to make it unique if there is more than one component that has that 8 character prefix.</td>
<td></td>
</tr>
<tr>
<td>Component &lt;name&gt; is heterogeneous and will be written as &lt;number&gt; separate COMP_DEFs. Cross reference file data follows:</td>
<td>Master Designer does not allow heterogeneous components. During translation the heterogeneous components are separated into homogeneous components. The cross reference file data is included in the error file for your convenience.</td>
<td></td>
</tr>
<tr>
<td>Component &lt;Ref Des&gt;, type &lt;type&gt; was given a PRT attribute of &lt;PRT attribute value&gt; which may cause packaging errors in P-CAD.</td>
<td>The PRT attribute value is the file name for the PCB part data. The value is created by combining the type with “.prt”. In P-CAD PCB and Schematic, the type can be longer than 8 characters. If the type is longer than 8 character, this is an illegal file name. You will need to fix this attribute in Master Designer before you can package the schematic.</td>
<td></td>
</tr>
<tr>
<td>Copper Pour not allowed in pattern &lt;name&gt; (&lt;ref des&gt;) near line &lt;line number&gt;. Pour demoted to polygon.</td>
<td>PCB does not support copper pours in patterns. The pour was converted to a polygon, which is supported.</td>
<td></td>
</tr>
<tr>
<td>Could not create pad/via style for pad &lt;number&gt; near line &lt;line number&gt;.</td>
<td>A memory or resource limit has been reached. Reduce the number of padstack in the design or simplify their construction.</td>
<td></td>
</tr>
<tr>
<td>Cross reference file missing entry for &lt;name&gt;. Unable to attach symbol name for multi-part component.</td>
<td>The attached symbol name could not be added to the component because there was no cross reference file entry for the part.</td>
<td></td>
</tr>
<tr>
<td>Heterogeneous component &lt;name&gt; is missing gates &lt;part number&gt;. Parts &lt;ref des&gt; cannot be placed. Place the missing gates as spares and reload.</td>
<td>Heterogeneous components are found in the cross reference file but the PDIF data is not found in the PDIF file. If you place the missing gates in Master Designer, re-create the PDIF file, the PDIF data will be included and a complete heterogeneous component can be created in Schematic.</td>
<td></td>
</tr>
</tbody>
</table>

P-CAD PCB User's Guide  577
<table>
<thead>
<tr>
<th>Warning Message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Homogeneous part <code>&lt;name&gt;</code> has non-constant gate equivalencies.</td>
<td>Master Designer does not store gate equivalence. The system is warning you that it found a homogeneous part with non-constant gate equivalencies.</td>
</tr>
<tr>
<td>Iat value too long at line <code>&lt;line number&gt;</code></td>
<td>PDIF format allows only 255 characters for an Iat value. The system found an Iat value with more than 255 characters. The attribute value is translated truncated to 255 characters.</td>
</tr>
<tr>
<td>Instance <code>&lt;name&gt;</code> does not specify a location, (0,0) assumed, near line <code>&lt;line number&gt;</code>.</td>
<td>The instance PI record is missing.</td>
</tr>
<tr>
<td>Instance <code>&lt;name&gt;</code> has an illegal Ipt record near line <code>&lt;line number&gt;</code>.</td>
<td>The number of entries in the instance Ipt record does not match the number of entries in the COMP_DEF PIN_DEF record.</td>
</tr>
<tr>
<td>Instance <code>&lt;name&gt;</code> referenced a package number <code>&lt;part number&gt;</code> that does not exist in COMP_DEF <code>&lt;name&gt;</code> near line <code>&lt;line number&gt;</code>.</td>
<td>An instance of a heterogeneous component references a part number that is not defined for the number of parts in the component. The heterogeneous information in the cross reference file may be incorrect.</td>
</tr>
<tr>
<td>Layer name <code>&lt;name&gt;</code> has been truncated to <code>&lt;name&gt;</code>.</td>
<td>The layer name is used as the PDIF file name. File names are limited to 8 characters. The system truncates the layer name to 8 characters and if necessary, slightly modifies it to make it unique if there are more than one layer that have the same first 8 characters.</td>
</tr>
<tr>
<td>Missing pad stack name for pad/via <code>&lt;number&gt;</code> near line <code>&lt;line number&gt;</code>.</td>
<td>A syntax error was encountered. The padstack name is missing from the PAD_STACK record.</td>
</tr>
<tr>
<td>Name <code>&lt;name&gt;</code> truncated to <code>&lt;number&gt;</code> characters near line <code>&lt;line number&gt;</code>.</td>
<td>The object’s name was too long and truncated so that it would be a valid PCB or Schematic name.</td>
</tr>
<tr>
<td>Net <code>&lt;name&gt;</code> attribute lost. <code>&lt;key&gt;</code> = <code>&lt;value&gt;</code>.</td>
<td>Master Designer does not have net attributes. When the system warns you when it detects a net attribute.</td>
</tr>
<tr>
<td><code>&lt;number&gt;</code> pin(s) were created for a <code>&lt;number&gt;</code> pin symbol (COMP_DEF= <code>&lt;name&gt;</code>, <code>I= </code>&lt;name&gt;<code>) near line </code>&lt;line number&gt;`.</td>
<td>The number of entries in the PIN_DEF record does not match the number of Sp records in the SPKG record.</td>
</tr>
<tr>
<td>Object near line <code>&lt;line number&gt;</code> failed to load.</td>
<td>A syntax error was encountered. Check the PDIF file at the designated line number to determine cause.</td>
</tr>
<tr>
<td>Warning Message</td>
<td>Cause</td>
</tr>
<tr>
<td>--------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Pad stack <name> does not have consistent enough shapes to set the predefined (Signal) layer near line <line number>. Pad/via style layer (Signal) set to 0. | 1. The padstack shape defined for the Top layer does not match the shape defined for the Bottom layer.  
2. The padstack shapes defined for internal signal layers are not all the same. |
| PDIF item <PDIF object> is not supported in nets.                               | Some PDIF objects are not supported in PCB or Schematic nets. It could be a DRC error indicator.                                   |
| PDIF item <PDIF object> is not supported in pad stacks                         | Some PDIF objects are not supported in PCB pad stacks. These include polygons, text, flashes and lines.                         |
| PID too long at line <line number>. Truncated.                                  | Master Designer’s PID is equivalent to PCB’s type attribute. The PID is limited to 15 characters. If PCB’s type attribute is longer than 15 characters, it is truncated to 15 characters. |
| Power and ground attribute is too long for symbol <name>.                      | If you get this warning and are not using Master Designer Version 8.0 software, switch to Version 8.0 if possible. Version 8.0 uses multiple PWGD attributes to handle case. If you are using Version 8.0 and still get this message the PWGD attribute is truncated. If you cannot use Version 8.0 and are getting this message, the PWGD attribute is truncated. |
| Power pin <pin des> of component <name> could not be added near line <line number>. Probably duplicate. | A duplicate power pin was detected in the component. Check the cross reference file or the PWGD(i) attribute(s) and try again. |
| Rotation rounded to <angle> at line <line number>.                             | Master Designer Schematic can only be rotated to 0, 90, 180, 270. If a rotation other than those values is detected, the object is rotated to the nearest allowable angle. |
| Symbol <name> already exists in table on line <line number> of <file name>.     | A duplicated symbol file name was found in the cross reference file. First one found is used. Others are discarded.              |
| Text height is less than 2 at line <line number>.                             | P-CAD PCB and Schematic’s text height is used as the text size for PDIF translation. Master Designer’s text size cannot be less than 2. If a text height is found to be less than 2, 2 is used. |
| Text object near (x, y) has no string, object ignored.                          | An empty text object was found and ignored.                                                                                        |
| Text too long near (x, y).                                                      | Text is limited to 255 characters. Text is truncated to 255.                                                                      |
### Appendix B: P-CAD System Messages

#### Warning Messages

<table>
<thead>
<tr>
<th>Warning Message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>The number of components pins created for <code>&lt;name&gt;</code> does not match the number of PIN_DEF entries near line <code>&lt;line number&gt;</code>. Power pins might be missing.</td>
<td>The number of P statements in the COMP_DEF’s PIN_DEF section determines the number of pins.</td>
</tr>
<tr>
<td>The number of pins in section <code>&lt;part number&gt;</code> (COMP_DEF=<code>&lt;name&gt;</code>) is not equal to the number of pins defined (PIN_DEF) near line <code>&lt;line number&gt;</code>.</td>
<td>A PKG part section does not have the same number of entries (pins) as the PIN_DEF record.</td>
</tr>
<tr>
<td>Translating TangoPRO polygon object near (x, y) as P-CAD lines.</td>
<td>Master Designer Schematic does not have a filled polygon object. If the system detects a polygon object is translates it as lines for Master Designer.</td>
</tr>
<tr>
<td>Unrecognized keyword <code>&lt;key&gt;</code> near line <code>&lt;line number&gt;</code>. Keyword ignored.</td>
<td>A syntax error was encountered. Check the PDIF file at the designated line number to determine cause.</td>
</tr>
<tr>
<td>Via references unknown pad stack <code>&lt;number&gt;</code>. Style <code>&lt;name&gt;</code> used instead.</td>
<td>The padstack number referenced by a via does not exist. The via style used will be <code>&lt;name&gt;</code>, probably (Default).</td>
</tr>
</tbody>
</table>
## Index

### -A-  
accessing a Reference Link ............................................ 305  
adding  
a new field ........................................................................ 225  
attributes ........................................... 227, 236, 301, 351  
Custom Reports ......................................................... 222  
DTP groups .............................................................. 240  
DTP items ............................................................... 241  
DTP sections ............................................................. 240  
Layer Sets ................................................................. 455  
layers .............................................................................. 453  
notes .............................................................................. 228  
Pad Styles ................................................................. 473  
Reference Links ............................................................. 304  
Text Styles ................................................................. 483  
tools to Customized Toolbar ........................................... 539  
ad advanced  
drill table options .............................................................. 543  
alias  
creating .......................................................................... 488  
Alias, Library command .................................................. 488  
Align Components, Edit command ................................... 340  
align to grid ....................................................................... 340  
All, View command ......................................................... 362  
Alter Component, Edit command ...................................... 338  
altering a component ....................................................... 339  
annotate errors .................................................................. 165  
any node routes  
(2 vias) .......................................................................... 137  
(maze) ............................................................................. 138  
aperture  
assign/describe (Gerber) .................................................. 256  
assigning manually ........................................................... 175  
assignment  
modifying ....................................................................... 175  
setting up for Gerber ....................................................... 174  
shapes ............................................................................. 258  
thermal ............................................................................. 259  
types ............................................................................... 260  
ar  
changing centerpoint ......................................................... 18  
curved .............................................................................. 104, 413  
flipping ............................................................................. 382  
mitering ............................................................................ 112, 420  
moving .............................................................................. 382  
placing .............................................................................. 382  
properties ......................................................................... 314  
rotating ............................................................................. 382  
routing .............................................................................. 104, 108, 412  
selection criteria .............................................................. 426  
Arc, Place command ......................................................... 382  
Archive Library, Library command ................................. 495  
assign  
apertures for Gerber ......................................................... 174  
apertures manually ............................................................ 175  
N/C Drill tools .................................................................... 184, 268  
Attribute, Place command ............................................... 396  
attributes  
adding ............................................................................. 302, 329, 352  
deleting ............................................................................. 227, 301, 351  
modifying ......................................................................... 302, 329, 352  
net310, 350  
placing ............................................................................. 397  
properties .......................................................................... 301, 303, 328, 351  
automatic  
assign/describe apertures ................................................. 174  
assignment of drill symbols .............................................. 92, 176, 262  
apopanning, adjusting ....................................................... 431  
Autoplace, Place command ............................................... 370
Autorouter, Route command ..........406
autorouting
attribute description ..............353
selecting .........................407
supported autorouters ..........405
autosave
adjusting .........................431

-B-
backtracking ..........................105, 412, 418
basics .......................................5
batch printing ..........................93, 209, 210
blind and buried vias violators (DRC) ..................167, 519
block select ................................21
procedure ...............................23
select mode frame ....................426
bounding outline ........................363
View Zoom Window ..................363
bus routing
changing layers ......................115
Bus, Route command ..............113

-C-
C Routes (2 vias) ....................137
CAM
File Gerber In ......................244
File Gerber Out ......................253
File N/C Drill .........................264
tutorial ...............................171
Cascade, Window command .........563
Center, View command ..............362
changing layers ......................418
circles, placing ......................382
class editor .............................470
Class to Class clearances .........466
cleaning up traces ...................532
Clear, File command ...............207
clearances
attributes .............................353
design rules ............................461
DRC ......................................151, 507
violations ..............................166
clipboard file, pasting ............280, 284
Close, File command ..............205
closing a window ....................205
collocated objects
how PCB redraws ......................361
colors
display .....................................444
options ....................................442
layer/entity ..............................443
print ......................................214
setting highlight color .............196
Command Toolbar ..................7
Command Toolbar, View command ...365
Compare Netlist, Utils command ....524
complex polygon, defined ..........383
component
align to grid .........................340
altering .................................338, 339
deleting from a library ..........491
exploding ...............................338
highlight an attached net ..........345
jump to a component ..............14, 344, 345
pin properties ..........................299
placing .................................374
connections ............................377
properties ..............................293, 299
reference links .......................304
renaming ...............................492
replacing ...............................500
rotating and flipping ...............375
selection criteria ....................426
violations (DRC) .....................167, 518
Component, Place command .......374
components
aligning ...............................52
moving by RefDes ....................60
Components, Edit command ........344
Compress binary designs ..........433
Configure, Options command .....429
connection
deleting from a net ..................336
jumper pads ............................378
length ..................................310, 355
manually routing ....................409
optimizing ..............................524
options ..................................430
physical ..............................102
properties .............................305
Connection, Place command ......377
coordinates, X and Y ..............30

copper length .......................310, 355
copper pour ..........................106, 414, 419
Index

copying
an object (drag and drop)....................27
copy practice; paste practice ...............53
corner, mitering ..................................111
creating
a new file ........................................203
a new library ...................................487
apertures .........................................174
Custom Toolbar .................................9
drill symbol legends .........................187
DTP file .........................................231
DTP groups .......................................240
DTP items .........................................241
DTP sections ....................................240
graphic images .................................85
macros .............................................11
manual routing ..................................106
mitered corners ................................111, 420
nets from free copper .........................531
padmaster Gerber file .......................181
pseudo patterns ...............................199
title blocks ......................................82
title sheets ......................................80
Cross-probing .................................. see DDE Hotlinks
current highlight color ......................196
Current Keepout, Options command .......458
Current Line, Options command .........98, 457
current radius ................................104, 413
Current Radius, Options command ....12, 459
current zoom factor .........................141
for View Zoom In ...............................362
for View Zoom Out ............................363
cursor
free floating .....................................19
snappy .............................................19
snappy vs. free-floating .....................367
style ..................................................445
tracker .............................................10
curved traces ................................104, 412
routing .............................................108
custom toolbar .................................9
displaying .........................................539
Custom Toolbar, View command .........366
custom tools
executing .........................................539
Customize, Utils command .................537
Customizing P-CAD PCB ..................202
cut and paste ................................280, 284, 284
between designs ...............................27
Cut, Edit command .............................281
Cutout, Place command .....................389
cutouts
defined ..........................................389
placing ............................................389
properties .......................................323
rotating and flipping ......................390
### Index

**D**

- **D Code (Gerber)** .................................................. 258  
- **DDE Hotlinks** .................................................. 195, 341, 432  
- **enabling the feature** ............................................. 196  
- **highlighting nets** .................................................. 196  
- **setting the current highlight color** ................................ 196  
- **unhighlighting nets** .............................................. 197  
- **unhighlighting parts and components** ................................ 197  
- **default pin des** .................................................... 500  
- **Delete, Edit command** ........................................... 335  
- **Delete, Library command** ......................................... 491  
- **Delete, Macro command** ......................................... 554  
- **deleting**  
  - attributes ........................................................... 227, 236  
  - copper pour islands .............................................. 190  
  - DRC error indicators ........................................... 168, 170  
  - DTP groups, sections, or items .................................. 242  
  - field sets ............................................................ 226  
  - Gerber layer info .................................................. 180  
  - items from a library .............................................. 491  
  - items in a block .................................................... 426  
  - macros ................................................................. 554  
  - Net objects .......................................................... 336  
  - notes ................................................................. 228  
  - objects ............................................................... 282, 335  
  - pad styles ............................................................. 480  
  - previous segments .................................................. 18, 105  
  - print jobs ............................................................. 211  
  - Text Styles ........................................................... 484  
  - vertexes ............................................................... 26  
- **Deselect All, Edit command** ..................................... 341  
- **design**  
  - print current window ............................................. 209  
  - printing .................................................................. 74  
- **Design Info, File command** ...................................... 223  
- **design rules** .......................................................... 459  
  - additional DRC checks ........................................... 162, 514  
  - by category ............................................................ 156, 508  
  - by hierarchy ............................................................ 158, 510  
  - checking ................................................................. 445, 506  
  - clearances ............................................................ 459  
- **Design Rules, Options command** ................................ 459  
- **design technology parameters** .................................... 459

---

**adding a group** ................................................... 240  
**adding a section** ................................................... 240  
**adding an item** ..................................................... 241  
**attribute handling** .................................................. 243  
**browsing** ............................................................... 232  
**building the hierarchy** ............................................ 240  
**copying to a design** ................................................ 232  
**delete button** .......................................................... 242  
**dialog** ................................................................ 242  
**merge attributes** ..................................................... 243  
**opening** ................................................................. 231  
**properties** .............................................................. 234  
**rename** ................................................................ 242  
**replace attributes** .................................................... 243  
**statistics button** ...................................................... 242  
**tree** .................................................................. 232  
**updating** ............................................................... 232  

**Design Technology Parameters, File command** ................. 229  

**design verification** .................................................. 523  
**Design Verification** ................................................... 70  
**Design Rule Checking** ............................................. 70  
**Netlist Verification** ................................................... 70  
**dialog convention** ................................................... 6  
**dialogs**  
  - Aperature Assignments ............................................ 174  
  - Copy Via Style ....................................................... 100  
  - Describe/Assign Tools ............................................. 184  
  - Drill Symbol Assignments ......................................... 91, 176  
  - ECO Filename ......................................................... 198  
  - ECO Warning .......................................................... 200  
  - Edit Nets ................................................................. 135  
  - File Gerber In ........................................................ 179  
  - File Gerber Out ....................................................... 171  
  - File N/C Drill .......................................................... 181, 186  
  - File Print ................................................................. 89  
  - Find Errors .............................................................. 168  
  - Gerber Format .......................................................... 177  
  - Modify Via Style (Complex) ....................................... 101  
  - Modify Via Style (Simple) ......................................... 100  
  - N/C Drill Format ....................................................... 185  
  - Options Configure ................................................... 125  
  - Options Current Line ............................................... 99  
  - Options Design Rules  
    - Class To Class tab ............................................... 155  
    - Design tab .......................................................... 151  
    - Layer tab ........................................................... 152
Field Colors
setting highlight color ........................................... 196
properties .................................................................. 334
Dimension, Place command ........................................ 400
Display Colors
dimension defined ...................................................... 400
properties defined ...................................................... 334
Display, Options command .......................................... 442
DocTool Commands
Mirror on Copy ......................................................... 549
Notes .................................................................. 548
Place Design View ................................................... 543
Place Detail ............................................................. 545
Place Diagram .......................................................... 546
Place Picture ............................................................. 548
Titles .................................................................. 548
Update .................................................................. 548
Update All .............................................................. 549
DocTools
associative dimensions ............................................... 87
borders ................................................................ 80
design details .............................................................. 84
design views ................................................................ 82
drawing and revision notes ........................................... 83
drawing layers .............................................................. 79
drill tables ................................................................ 86
fields sets ............................................................... 83
graphic files ............................................................... 85
detail colors ............................................................... 85
update details ............................................................... 85
layer stackup diagrams ............................................... 85
revision blocks ............................................................ 82
title blocks ................................................................. 82
title sheets ................................................................. 80
zones .................................................................. 81
Documentation Toolbox ................................................. 79
draft mode
for polygons ............................................................... 383
for printing ................................................................. 212
drag and drop ............................................................... 357
Drawing
a board outline ......................................................... 58
Drawing Interchange Format ......................................... 246
drawing order ............................................................ 16
DRC
clear overrides .......................................................... 518
configuration ............................................................. 164
copper ties ................................................................. 164
define area ................................................................. 519
errors .................................................................. 445
annotation ................................................................. 167
block selection ............................................................ 169
finding .................................................................. 168
flags .................................................................. 165
global display ............................................................ 169
ignored ................................................................. 517
 overridden ............................................................ 517
 overrides .............................................................. 170
rules .................................................................. 151
setup ................................................................. 507
Severity Levels ............................................................ 516
DRC, Utils command ................................................. 445, 506
drill drawing
generating ................................................................. 188
drill symbols
alpha-character .......................................................... 92
assign for printing ..................................................... 91
automatic assignment ................................................. 92, 176
emulating Master Designer ........................................ 92
Gerber output .............................................................. 261
legends ................................................................. 187
manual assignment ................................................. 92, 177, 262
print ................................................................. 213
Index

setting in Gerber.................................176
drill table........................................543
Drill, N/C........................................264
duplicating objects.........................337
DXF file
  items supported for translation.......249
  loading .......................................246
  view log file ...............................249
DXF In, File command ......................246
DXF Out
  component Height .......................272
DXF Out, File command .................270
DXF output ................................272

-E-

ECO ..............................................197
export ........................................200, 505
filename ......................................198
format .........................................430
import ........................................198, 503
pseudo patterns ..........................504
record .......................................198, 502
saving .........................................200
types of changes ......................197, 502
view pending ..................................505

Edit Commands
  Align Components ..........................340
  Alter Component ..........................338
  Attributes ..................................350
  Components ..................................344
  Copy ..........................................283
  Copy Matrix ..................................337
  Copy to File ..................................283
  Cut ...........................................281
  Delete .......................................335
  Deselect All ..............................24, 341
  Explode Component ....................338
  Fix 280, 342
  Highlight ...................................341
  Measure .....................................355
  Move By RefDes ..........................290
  Move to Layer ..............................291
  Nets ..........................................345
  Paste ........................................280, 284
  Paste Circuit ...............................287
  Paste From Clipboard ...................286
  Paste from File ............................286
  Paste Special ............................287
  Paste To Layer ............................286
  Properties ..................................28, 292
  Redo .........................................281
  Rooms .......................................343
  Select .......................................356
  Select All ..................................24, 341
  Select Highlighted ......................342
  Undo .........................................279, 280
  Unfix ........................................342
  Unfix All ..................................343
  Unhighlight ...............................341
  Unhighlight All ..........................342

editing
  attributes ......................236, 301, 310, 351
  components ...........................338, 344
  existing miter ...........................421
  items in a block ......................426
  Layer design rules ....................153
  macros ........................................557
  Nets ........................................135, 345
  objects .....................................24
  overriding errors ....................168
  properties ................................292

  Arc314
  Attributes ..................................328
  connections ..............................305
  Copper Pour ...............................317
  Cutout .......................................323
  Design View ................................331
  Detail ........................................331
  Diagram .....................................332
  Dimension ..................................334
  Field ..........................................330
  Line .........................................313
  Pad ..........................................307
  Picture ......................................333
  Plane ........................................323
  Polygon .....................................315
  Room .........................................325
  Table .........................................333
  Test Point ..................................316
  Text .........................................327
  Rooms design rules ....................154
  Text Styles ..................................485
  electrical pin type .....................300
  enabling DDE hotlinks ..............196
Index

Engineering Change Orders ........................................................... 198, 430, 502
error annotation
  DRC ............................................................. 167
error messages ................................................................. 571
errors
  annotate ..................................................... 165
examining design relationships
  DDE Hotlinks ............................................................. 195
existing aperture definitions ..................................................... 479
existing pad style polygonals ..................................................... 479
Exit, File command ................................................................. 276
Explode Component, Edit command ............................................. 338
Export ECOs, Utils command ..................................................... 505
exporting
  ECOs ............................................................. 505
Extent, View command ............................................................ 361

-F-

Fanout, Route command ............................................................. 118
fanouts ................................................................................. 109
features ................................................................................. 1
field properties ........................................................................ 398
Field, Place command ............................................................... 398
Field Commands
  Clear ................................................................. 207
Close ........................................................ ............... 205
Design Info .............................................................................. 223
  Attributes tab .................................................. 226
  Fields tab .......................................................... 224
  General tab ....................................................... 224
  Notes tab .......................................................... 227
  Revision tab ....................................................... 228
  Statistics tab ....................................................... 228
Design Technology Parameters ..................................................... 229
DXF In ................................................................................. 246
DXF Out ................................................................................. 270
Exit ..................................................................................... 276
Gerber In ................................................................................. 244
Gerber Out ............................................................................. 253
N/C Drill ................................................................................. 264
New .................................................................................... 203
Open ................................................................................. 203
PDIF In ................................................................................. 251
PDIF Out ................................................................................. 273
Print .................................................................................... 207
Printer Setup ........................................................................... 215
Reports ................................................................................. 215

Save ................................................................................. 205
Save As ................................................................................. 206
files
  compression
    binary ........................................................................... 433
drag and drop ................................................................. 204
drag and drop file load ..................................................... 31
Gerber Out ............................................................................. 171
loading and saving ............................................................. 31
N/C Drill command ............................................................... 181
opening a recently used file .................................................. 204
opening an ASCII file ......................................................... 204
saving an ASCII file ............................................................ 206, 207
types ................................................................................. 31
Find Errors, Utils command ..................................................... 519
flipping objects ..................................................................... 17
font
  changing text style ......................................................... 485
  style examples ............................................................. 485
Force Update, Utils command ................................................... 500
format
  Gerber ............................................................................. 262
  N/C Drill ......................................................................... 269
free floating cursor ............................................................... 367
free pads .............................................................................. 180
displaying ............................................................................ 446

-G-

gate swapping
  manual .............................................................................. 527
  rules ................................................................................. 530
Generate Netlist, Utils command ................................................... 523
generating a netlist .............................................................. 523
Gerber
  deleting layer information ................................................... 180
  format .............................................................................. 177, 262
  output .............................................................................. 171
  compress files .................................................................. 178, 263
  files ................................................................................. 172
  generating ........................................................................ 178
  verification ........................................................................ 178
Gerber In, File command ............................................................ 244
Gerber Out, File command ........................................................... 253
glue dots ............................................................................. 445
grid
  non-uniform ..................................................................... 440
  origin .............................................................................. 440

P-CAD PCB User's Guide 587
setup for routing.................................97
snap cursor to.................................19
spacing..............................................440
Status Line toggle button.................98
style (visible, dotted, hatched).........440
toggle
  absolute and relative settings.......10
  uniform........................................440
Grid Toggle button.........................441
Grids, Options command .................439

-H-

hardware requirements....................3
Help
  About P-CAD PCB...............................565
  How to Use Help...............................565
  P-CAD PCB Help Topics.......................565
  Series II Commands..........................565
Help Commands.................................565
hiding
  connections....................................348
  points..........................................387
highlight
  an attached net..............................345
  nets ............................................348
  while routing................................436
Highlight, Edit command....................341
hole range.......................................480, 482
horizontal
  alignment......................................340
  routing pass....................................136
hotlinks, enabling...........................432
how to use help...............................565

-I-

icons, toolbar..................................6
imperial units..................................430
Import ECOs, Utils command...............503
importing
  ECOs............................................503
  Info, Net.......................................355
Initial Board Layout.........................57
  Creating a Board Outline..................58
  Loading a Netlist..........................58
  Moving Components........................59
Initial Board Setup
  Aligning Components......................52
  Finite Rotation............................52
  Optimize Nets................................60
  Replace Components........................57
Installation and Setup.......................3
installing P-CAD products......................4
  system requirements........................3
interactive routing...........................108
backtracking.................................418
changing layers...............................98, 418
complete.......................................111, 418
controlling trace placement...............415
copper pours....................................419
layers.............................................419
line widths.....................................419
loop removal....................................111, 419
modifying traces..............................418
net attributes..................................109, 416
obstacle hugging..............................109, 416
options.........................................437
pad entry or exit.............................109, 416
polygonal pads................................417
pop-up menu.....................................419
rerouting lines...............................418
slash lines......................................418
status line information....................415
suspend.........................................111, 418
terminating a route...........................110, 417
Trace Cleanup..................................418
T-routing .........................................103, 417
unwinding.......................................418
vias...............................................419

Interapplication Functions
  DDE hotlinks..................................195
InterPlace/PCS, Utils command.............533, 537
InterRoute Gold
  maximum hugging............................122
  minimum length.............................122
  right mouse menu...........................124
  visible routing area.......................123
InterRoute, Route command..................414
island removal................................320
items..............................................22

-J-

jump
  to a location...............................364
  to text........................................364
Jump Commands

P-CAD PCB User's Guide
| Jump to a Component                  | 14 |
| Jump Location, View command       | 14, 363 |
| Jump Text                          | 15, 364 |
| Case Sensitive Search              | 364 |
| Search Entire Design               | 364 |
| Jump Text, View command            | 15, 364 |
| Jump to a Node                     | 15 |
| jumper pads                        | 376, 522, 531 |
| connections                        | 378 |
| keep                               | |
| selection criteria                 | 427 |
| keepout styles and layers          | 458 |
| Keepout, Options Current           | 458 |
| Keepout, Place command             | 390 |
| Keyboard preferences               | 448 |
| L Routes (1 via)                   | 137 |
| Last, View command                 | 362 |
| layers                             | 23, 134, 419 |
| adding or deleting                 | 35 |
| changing for routing               | 98 |
| enabling/disabling                 | 15, 451 |
| Layer Sets                         | 23, 426 |
| nonsignal                          | 15 |
| photoplot file                     | 256 |
| print                              | 211 |
| selecting items                    | 19 |
| selection mask                     | 425 |
| setting                            | 61 |
| signal                             | 15 |
| status line                        | 453 |
| using                              | 15 |
| Layers, Options command            | 12, 450 |
| library                            | |
| alias                              | 488 |
| definition                         | 487 |
| deleting pattern/component         | 491 |
| opening with drag-and-drop file    | 493 |
| setting up                         | 493 |
| Library Commands                   | 487 |
| Alias                              | 488 |
| Archive Library                    | 495 |
| Copy                               | 489 |
| Delete                             | 491 |
| New                                | 487 |
| Pattern Save As                    | 494 |
| Rename                             | 492 |
| Setup                              | 493 |
| line                               | |
| length, measuring                  | 380 |
| orthogonal mode                    | 17 |
| placing                            | 380 |
| properties                         | 313 |
| selection criteria                 | 426 |
| shapes (orthogonal modes)          | 381 |
| width                              | 139, 419 |
| setting up for routing              | 98 |
| Line Width Combo Box               | 12 |
| Line, Place command                | 380 |
| Load Button                        | 133 |
| Load Netlist, Utils command        | 320 |
| loading a file                     | 97 |
| loading PDIF files                  | 251 |
| location, jumping to               | 14 |
| macro                              | |
| defined                            | 551 |
| deleting                           | 554 |
| file syntax                        | 557 |
| recording                          | 553 |
| renaming                           | 554 |
| running                            | 555, 556 |
| setting up                         | 551 |
| using effectively                  | 555 |
| Macro Commands                     | 551 |
| Delete                             | 554 |
| Macro Record toggle button         | 11 |
| Record/Stop                        | 552 |
| Rename                             | 554 |
| Run                                | 555 |
| Setup                              | 551 |
| manual                             | |
| assignment of drill symbols        | 92, 177, 262 |
| manual gate swap                   | 527 |
| manual routing                     | 106 |
| arcs                               | 104, 412 |
| backtracking                       | 412 |
| between layers                     | 411 |
| changing layers                    | 98 |
| completing a trace                 | 107, 409 |
| copper pours                       | 414 |
Index

crossing a blockage.................................411
curved traces ............................................108
incomplete traces ............................107, 409
modify .....................................................411
online DRC................................................413
options .......................................................437
orthogonal modes........ 101, 102, 412, 437
overlapping connections .......................414
rerouting a trace ......................................411
right mouse button .................................107
routing to free copper .........................414
Slash key ....................................................107
status line information ...........................410
temporary stop.........................................107
trace cleanup ............................................412
T-routing............................................103, 411
unwinding .................................................411
Width attribute.........................................414
Manual, Route command.........................408
matrix, delete and copy ...............................28
minimum length..........................................122
mirror
image, printing .....................................212
photplot plot file......................................255
Mirror on Copy, DocTool command.....549
miscellaneous options...............................446
Miter tool
editing existing miters ....................421
options ......................................................436
T-routing ...............................................112, 421
using ......................................................111, 420
Miter, Route command ..............................420
modes, changing absolute and relative
grid ...........................................................440
modifying
complex pad style.................................474
display text ............................................483
existing routes ........................................113
object properties ....................................28

simple pad style.................................474
traces..................................................411, 418
mounting hole apertures.......................260
mouse preferences ...............................449
Move By RefDes, Edit command..............290
Move to Layer
restrictions..........................................291
Move to Layer, Edit command..........291
moving
by RefDes ............................................290
filled pour ............................................190
items in a block ....................................426
objects .........................................17, 25, 357
objects to another layer ...............18, 291
Moving Components
by RefDes ..............................................60
multiple windows ..................................13
MultiTrace routing ...............................115
routing direction ..................................118
routing priority ....................................117
trace placement .................................117

-N-
N/C Drill
assigning/describing tools ..................183
compress output files .....................186, 269
format options ..................................185, 269
generating files ..................................186, 265
output tutorial .....................................181
setup output files ..................................182
N/C Drill, File command ..................181, 264
net
attributes .....................................109, 135, 416
clearances ............................................464
deleting named net classes .............470
deleting net objects ......................282, 336
edit attributes .....................................347, 350
information ............................................347
jump to node ...........................................347
layer attributes .....................................347
length (DRC) ............................................166
name, specifying ..................................377
Net Attrs button ..................................310
Net Class tab .........................................462
Net Info button ..................................355
optimizing .............................................525
renaming ..................................................347

590

P-CAD PCB User's Guide
renaming ................................................... 350
selecting .............................................. 24, 348
tab properties ......................................... 309
unhighlight ........................................... 348
view attributes ........................................ 348
Net Classes, Options command .............. 469
netlist
check for copper sharing ....................... 523
compare, DRC violations ....................... 166
format .................................................. 521
generating ........................................... 521
jumper pads ........................................... 522
loading .................................................. 520
loading on an existing board ............... 522
optimization ........................................... 525
optimize nets ....................................... 522
pseudo patterns ..................................... 522
reconnect copper ................................... 523
violations ............................................. 166, 518
Nets, Edit command............................ 345
New Window, Window command .......... 563
New, File command ................................ 203
New, Library command....................... 487
No Mt Hole Cu ...................................... 256
nodes
  clear all ............................................ 346
  set all ............................................. 346
non-signal layer .................................... 451
non-uniform grid spacing ...................... 440
no-route zones (keepouts) ..................... 458
note tables .......................................... 542
Notes, DocTool command ..................... 548
numbering pads .................................... 497

-0-

objects
  cutting, copying, and pasting .......... 27
  deleting ........................................ 335
  editing ....................................... 24
  moving ....................................... 25
  moving to another layer ............... 18, 291
  object/action interaction ............. 16
  pasting .................................... 280, 284
  placing .................................... 15, 16
  resize ....................................... 26
  rotating and flipping ................... 25
selecting ........................................... 19
selection and modification ............... 16
selection and placement ................... 16
selection mask ................................... 424
what can be placed ......................... 16
obstacle hugging ............................. 109, 416
offset
  X, Y in drill file .............................. 266
  X, Y in photoplot file ....................... 255
Online DRC ..................................... 126, 167
Open, File command ......................... 203
opening
  a file .......................................... 203
Optimize Nets, Utils command ........... 525
options
  route .......................................... 429, 435
Options
  Block Selection .................................. 56
Options Commands .............................. 423
  Configure ..................................... 429
  Current Keepout .............................. 458
  Current Line ................................ 98, 457
  Current Radius ................................ 12, 459
  Design Rules ................................ 459
  Display ....................................... 442
  Grids .......................................... 439
  Layers .......................................... 12, 450
  Net Classes ................................... 469
  Pad Style ...................................... 472
  Preferences ................................... 448
  Selection Mask ............................... 423
  Text Style ................................... 482
  Via Style .................................... 99, 482
Options Configure
  General tab .................................... 429
  Online DRC tab ............................... 429, 433
  Plow tab ....................................... 437
  Route tab ..................................... 125, 429, 435
Options Display
  setting highlight color ................... 196
  orthogonal modes ............................ 17
  routing with .................................. 101, 102, 412
output
  plotter ........................................ 88
  output files
  setting up ..................................... 182, 266
  for Gerber .................................... 172
Index

Output Log File..............................................133
overlapping objects, selecting..................357

-P-

pad properties
changing ..........................................................54
Pad Style, Options command ..................472
Pad, Place command ..........................378
Padmaster Gerber file ..........................181
pads
entry or exit ..............................................109, 416
jumper pads ..............................................376
modifying styles ...........................................379
net names
displaying ..................................................447
no connect pads, no connect shape ........392
number ..........................................................300
placing ...........................................................378
placing connections ..................................377
properties ..................................................307
renumbering ...............................................379, 499
rotating and flipping .............................379
selection criteria ...........................................427
shapes
polygonal pads ............................................477
stacks (pad styles) ......................................472
style
complex ..........................................................473
hole range ....................................................480
modify pad definition ..................................476
modifying complex pad style ................474
modifying simple pad style ....................474
plated pads ....................................................474
renaming ......................................................480
shapes .............................................................476
simple .............................................................473
thermal spokes (diameter and width)
.................................................................477
vias, pad/via holes ........................................256
panning ...........................................................14
screen, adjusting ...........................................431
part number ....................................................300
Passes button ...................................................136
Paste from File, Edit command .................286
Paste Special, Edit command .................287
Paste To Layer, Edit command .................286
Paste, Edit command ..........................280, 284
pasting
circuits .......................................................28, 287
clipboard file .................................................280, 284, 286
from a file .......................................................28
limitations .......................................................28
mask shrink ...............................................432, 433
merging net attributes ...........................289
paste behavior ..............................................284
renaming
Nets .........................................................289
RefDes .......................................................288
pattern
deleting from a library ..............................491
pad properties .................................................297
placeholder ....................................................199
pseudo .........................................................522
renaming .......................................................492
Pattern Save As, Library command ..........494
P-CAD
launching applications ..................201, 532
Pattern Editor
running .......................................................532
PCB
DDE Hotlinks .............................................195
ECOs .........................................................197
features .........................................................1
Help Topics ................................................565
PCB (6/400)
features .........................................................2
Relay and DDE Hotlinks .......................195
Schematic
DDE Hotlinks .............................................195
ECOs .........................................................197
Scout
DDE Hotlinks .............................................195
Symbol Editor
running .......................................................532
Tango PCB
component restrictions .......................374
P-CAD Library Executive
Utils command ...........................................532
P-CAD Pattern Editor, Utils command .....532
P-CAD Schematic, Utils command .......532
P-CAD Symbol Editor, Utils command ...532
PDIF In, File command .........................251
PDIF Out, File command .........................273
photoplot file, generating .......................253

592

P-CAD PCB User’s Guide
### Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>photoplot file, viewing</td>
<td>78</td>
</tr>
<tr>
<td>Pin and Place</td>
<td></td>
</tr>
<tr>
<td>show or hide</td>
<td>445</td>
</tr>
<tr>
<td>Pin</td>
<td></td>
</tr>
<tr>
<td>designators</td>
<td>300</td>
</tr>
<tr>
<td>equivalence</td>
<td>300</td>
</tr>
<tr>
<td>name</td>
<td>300</td>
</tr>
<tr>
<td>pin and gate swapping</td>
<td>525</td>
</tr>
<tr>
<td>automatic</td>
<td>526</td>
</tr>
<tr>
<td>impact on Library Manager</td>
<td>530</td>
</tr>
<tr>
<td>pin swapping</td>
<td></td>
</tr>
<tr>
<td>manual</td>
<td>528</td>
</tr>
<tr>
<td>swapping rules</td>
<td>529</td>
</tr>
<tr>
<td>PinEq</td>
<td>300</td>
</tr>
<tr>
<td>Place Commands</td>
<td>369</td>
</tr>
<tr>
<td>Arc382</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>396</td>
</tr>
<tr>
<td>Autoplacement</td>
<td>370</td>
</tr>
<tr>
<td>Component</td>
<td>374</td>
</tr>
<tr>
<td>Connection</td>
<td>377</td>
</tr>
<tr>
<td>Copper Pour</td>
<td>387</td>
</tr>
<tr>
<td>Cutout</td>
<td>389</td>
</tr>
<tr>
<td>Dimension</td>
<td>400</td>
</tr>
<tr>
<td>Field</td>
<td>398</td>
</tr>
<tr>
<td>Keepout</td>
<td>390</td>
</tr>
<tr>
<td>Line</td>
<td>380</td>
</tr>
<tr>
<td>Pad</td>
<td>378</td>
</tr>
<tr>
<td>Plane</td>
<td>390</td>
</tr>
<tr>
<td>Point</td>
<td>384</td>
</tr>
<tr>
<td>Polygon</td>
<td>383</td>
</tr>
<tr>
<td>Room</td>
<td>392</td>
</tr>
<tr>
<td>Text</td>
<td>393</td>
</tr>
<tr>
<td>Via380</td>
<td></td>
</tr>
<tr>
<td>Place Design View, DocTool command</td>
<td>543</td>
</tr>
<tr>
<td>Place Detail, DocTool command</td>
<td>545</td>
</tr>
<tr>
<td>Place Diagram, DocTool command</td>
<td>546</td>
</tr>
<tr>
<td>Place Picture, DocTool command</td>
<td>548</td>
</tr>
<tr>
<td>placeholder patterns</td>
<td>199</td>
</tr>
<tr>
<td>placement practice</td>
<td>40</td>
</tr>
<tr>
<td>Placement Toolbar</td>
<td>7</td>
</tr>
<tr>
<td>Placement Toolbar, View command</td>
<td>365</td>
</tr>
<tr>
<td>placing an arc</td>
<td>382</td>
</tr>
<tr>
<td>attributes</td>
<td>397</td>
</tr>
<tr>
<td>component</td>
<td>374</td>
</tr>
<tr>
<td>connections and merging nets</td>
<td>378</td>
</tr>
<tr>
<td>Copper Pour</td>
<td></td>
</tr>
<tr>
<td>cutout</td>
<td>387</td>
</tr>
<tr>
<td>dimension</td>
<td>389</td>
</tr>
<tr>
<td>line</td>
<td>380</td>
</tr>
<tr>
<td>pad</td>
<td>378</td>
</tr>
<tr>
<td>plane</td>
<td>390</td>
</tr>
<tr>
<td>points</td>
<td>385</td>
</tr>
<tr>
<td>polygon</td>
<td>383</td>
</tr>
<tr>
<td>test points</td>
<td>386</td>
</tr>
<tr>
<td>text</td>
<td>393</td>
</tr>
<tr>
<td>text summary</td>
<td>396</td>
</tr>
<tr>
<td>plane indicator displaying</td>
<td>447</td>
</tr>
<tr>
<td>layer</td>
<td>451</td>
</tr>
<tr>
<td>pads and vias</td>
<td>391</td>
</tr>
<tr>
<td>properties</td>
<td>323</td>
</tr>
<tr>
<td>selection criteria</td>
<td>427</td>
</tr>
<tr>
<td>swell</td>
<td>433</td>
</tr>
<tr>
<td>Plane, Place command</td>
<td>390</td>
</tr>
<tr>
<td>plated pads</td>
<td>474</td>
</tr>
<tr>
<td>Point, Place command</td>
<td>384</td>
</tr>
<tr>
<td>points</td>
<td></td>
</tr>
<tr>
<td>Glue Dot</td>
<td>384</td>
</tr>
<tr>
<td>Pick and Place</td>
<td>384</td>
</tr>
<tr>
<td>placing</td>
<td>385</td>
</tr>
<tr>
<td>point-to-point routing</td>
<td>102</td>
</tr>
<tr>
<td>Reference Point</td>
<td>384</td>
</tr>
<tr>
<td>showing or hiding</td>
<td>387</td>
</tr>
<tr>
<td>size, setting</td>
<td>386</td>
</tr>
<tr>
<td>Test Point</td>
<td>385</td>
</tr>
<tr>
<td>Polygon, Place command</td>
<td>383</td>
</tr>
<tr>
<td>polygons</td>
<td></td>
</tr>
<tr>
<td>altering the shape</td>
<td>19, 384</td>
</tr>
<tr>
<td>draft mode</td>
<td>383</td>
</tr>
<tr>
<td>polygonal pads</td>
<td>417, 477</td>
</tr>
<tr>
<td>properties</td>
<td>315</td>
</tr>
<tr>
<td>reference point pairs</td>
<td>479</td>
</tr>
<tr>
<td>rotating and flipping</td>
<td>383</td>
</tr>
<tr>
<td>rounded corners</td>
<td>26, 358</td>
</tr>
<tr>
<td>selection criteria</td>
<td>427</td>
</tr>
<tr>
<td>pop-up menu</td>
<td>419</td>
</tr>
<tr>
<td>Preferences, Options command</td>
<td>448</td>
</tr>
<tr>
<td>preview ECO file</td>
<td>199, 504</td>
</tr>
<tr>
<td>Print, File command</td>
<td>207</td>
</tr>
<tr>
<td>Printer Setup, File command</td>
<td>215</td>
</tr>
<tr>
<td>printing</td>
<td>88</td>
</tr>
</tbody>
</table>
batch ............................................ 93, 209, 210
current window .................................. 209
design extents .................................. 212
drill symbol assignments ...................... 88, 91
job name ........................................... 211
print jobs .......................................... 210
  generating .................................... 207
  setting up ................................... 89, 209, 210
print preview ................................... 208
printer setup ................................... 88, 215
scaling to fit page ................................ 209
setting up colors ................................ 93, 214
thin line text ..................................... 212
Probing ........................................... 212
  see DDE Hotlinks
prompt line
  displaying ..................................... 9
Prompt Line, View command .................... 9, 366
properties
  arc ................................................. 314
  attributes ...................................... 301, 303, 328
  component ...................................... 293, 299
  component pins ................................ 299
  connection ...................................... 305
  copper pour .................................... 317
  cutout .......................................... 323
  dimension ...................................... 334
  field .............................................. 330
  line .............................................. 313
  multiple objects .............................. 29
  pad .............................................. 307
  pattern pad ..................................... 297
  plane ............................................ 323
  polygon ......................................... 315
  rooms ............................................ 325
  test point ...................................... 316
  text .............................................. 327
  using the edit command ...................... 28
  via 311
Properties, Edit command ....................... 28, 292
pseudo patterns .................................. 504, 522

-Q-
Quick Route
  assigning
    lines to nets .................................. 128
    pads to nets .................................. 128
  checking setup parameters .................. 128
commands available during routing ...... 140
completing the PC board ....................... 130
design rule checking ......................... 129
error messages ................................. 140
grid selection .................................. 149
iterative approach ............................ 130
guidelines ....................................... 131
keepouts ......................................... 146
limitations ....................................... 145
netlist information ............................ 128
off-grid items .................................. 146
optimizing
  lines and nets .................................. 128
  pre-routed lines ................................ 128
  pad selection ................................... 149
  plane
    connecting surface pads to a plane .... 147
    connections .................................... 147
    split planes .................................... 147
  pre-routed connections ..................... 146
processing
  keepouts ....................................... 128
  lines ............................................ 128
  pads ............................................ 128
  polygons ........................................ 128
  surface pads ................................... 128
reading PCB file ................................ 128
Route Autorouter dialog ....................... 132
routinig
  fine points .................................... 145
  grid and line width .......................... 139
  passes .......................................... 129, 130
  route completed ................................ 129
  steps .......................................... 128
strategy file ..................................... 133
surface pads .................................... 148
verifying the finished board ............... 132
via styles ....................................... 138
writing
  no-route data .................................. 129
  routed PCB file ................................. 129
-R-
radial placement ................................ 359
radius
  rounded and filleted corners ............. 358
Radius Combo Box .............................. 12
Index

rats nest, defined ..........................................59
Reconnect Nets
   creating nets from free copper ..........531
   jumper pads .....................................531
Reconnect Nets, Utils command ...........530
Record ECOS, Utils command ..............302
Record, Macro command .....................552
Redo, Edit command ............................281
Redraw, View command .......................361
reference
   attribute .............................................304
   designator .........................................300
links
   accessing a link ................................305
   adding a link ....................................304
   launching .......................................227, 301
   linking to a component ....................304
regular polygons ......................................478
removing
   current highlight color .................197
   free copper .....................................282
   leftover traces ..................................361
Rename, Library command ...................492
Rename, Macro command ......................554
renaming
   a net ...............................................350
   a pattern or component ....................492
   pad styles .......................................480
   Text Styles ......................................484
renumber
   pads ..............................................497
   reference designators .................497
Renumber, Utils command ....................497
report
   custom ..........................................218
   adding custom reports ......................222
   format ..........................................219
   selection .......................................220
   sorting .........................................221
DRC files ...........................................164
list separator .....................................218
origin ..............................................217
style format ......................................218
   types .............................................216
Reports and Output .........................72
Generating N/C Drill Files ..................78
Gerber Output ....................................76
Printing your Design ..........................74
Viewing Photoplot Files .....................78
Reports, File command .......................215
rerouting lines ....................................418
resizing
   objects ...........................................26, 357
revision notes table ............................542
right-click mouse
   button ............................................292
   commands .......................................29
Room, Place command .......................392
rooms ..............................................392, 462
design components ............................326
fill pattern ........................................327
fixed ................................................327
highlight .........................................343
highlight included .............................343
included components .......................326, 343
properties ........................................325, 343
   selection criteria ...........................427
   unhighlight ....................................343
   unhighlight included ........................343
Rooms, Edit command .......................343
rotating
   items in a block ..............................426
   objects ..........................................426
   rotation increment ...........................431
   when printing ..................................212
Route Autorouters dialog
   Net Attrs button ...............................135
   Start button ....................................140
Route Commands ...............................405
Autorouter ..................................406
Bus ...............................................113
Fanout ...........................................118
Interactive ....................................414
Manual ..........................................408
Miter .............................................420
View Log .........................................407
Route Tool
   arcs and curved trace routing ..........103
   Route Toolbar ..................................8
   Route Toolbar, View command ..........365
   routing .........................................95
   backtracking .................................105
   between layers ................................411
   bias .............................................451

P-CAD PCB User's Guide 595
### Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>bus routing</td>
<td>113</td>
</tr>
<tr>
<td>changing layers</td>
<td>98, 105</td>
</tr>
<tr>
<td>cleanup</td>
<td>138</td>
</tr>
<tr>
<td>clearance rules</td>
<td>507</td>
</tr>
<tr>
<td>connections</td>
<td>97, 414</td>
</tr>
<tr>
<td>copper pours</td>
<td>106, 192</td>
</tr>
<tr>
<td>curved traces</td>
<td>104, 412</td>
</tr>
<tr>
<td>drop via</td>
<td>105</td>
</tr>
<tr>
<td>Fanout routing</td>
<td>118</td>
</tr>
<tr>
<td>features</td>
<td>95</td>
</tr>
<tr>
<td>free copper</td>
<td>105, 414</td>
</tr>
<tr>
<td>general features</td>
<td>103</td>
</tr>
<tr>
<td>grid</td>
<td>139</td>
</tr>
<tr>
<td>grid setup</td>
<td>97</td>
</tr>
<tr>
<td>interactive</td>
<td>108</td>
</tr>
<tr>
<td>manual</td>
<td>106</td>
</tr>
<tr>
<td>miter</td>
<td>111</td>
</tr>
<tr>
<td>modifying existing routes</td>
<td>113</td>
</tr>
<tr>
<td>options</td>
<td>125</td>
</tr>
<tr>
<td>orthogonal modes</td>
<td>108, 113</td>
</tr>
<tr>
<td>overlapping connections</td>
<td>106</td>
</tr>
<tr>
<td>placing keepouts</td>
<td>458</td>
</tr>
<tr>
<td>polygons</td>
<td>105</td>
</tr>
<tr>
<td>point-to-point</td>
<td>102</td>
</tr>
<tr>
<td>selecting a tool</td>
<td>96</td>
</tr>
<tr>
<td>setting options</td>
<td>429, 435</td>
</tr>
<tr>
<td>setup</td>
<td>97</td>
</tr>
<tr>
<td>Status Line information</td>
<td>103</td>
</tr>
<tr>
<td>toolbar</td>
<td>144</td>
</tr>
<tr>
<td>tools</td>
<td>144</td>
</tr>
<tr>
<td>trace cleanup</td>
<td>95</td>
</tr>
<tr>
<td>trace styles</td>
<td>104, 412</td>
</tr>
<tr>
<td>T-routing</td>
<td>103</td>
</tr>
<tr>
<td>unwinding routed segments</td>
<td>18, 105</td>
</tr>
<tr>
<td>routing bias</td>
<td>35</td>
</tr>
<tr>
<td>Routing Commands</td>
<td></td>
</tr>
<tr>
<td>Cancel</td>
<td>144</td>
</tr>
<tr>
<td>Help</td>
<td>144</td>
</tr>
<tr>
<td>Info</td>
<td>142</td>
</tr>
<tr>
<td>Options Display</td>
<td>144</td>
</tr>
<tr>
<td>Pause</td>
<td>142</td>
</tr>
<tr>
<td>Resume</td>
<td>143</td>
</tr>
<tr>
<td>View All</td>
<td>141</td>
</tr>
<tr>
<td>View Last</td>
<td>141</td>
</tr>
<tr>
<td>View Log</td>
<td>143</td>
</tr>
<tr>
<td>View Redraw</td>
<td>141</td>
</tr>
<tr>
<td>View Status Line</td>
<td>142</td>
</tr>
<tr>
<td>View Toolbar</td>
<td>142</td>
</tr>
<tr>
<td>View Zoom In</td>
<td>141</td>
</tr>
<tr>
<td>View Zoom Out</td>
<td>141</td>
</tr>
<tr>
<td>View Zoom Window</td>
<td>142</td>
</tr>
<tr>
<td>Routing Connections</td>
<td>61</td>
</tr>
<tr>
<td>Changing Routed Connections</td>
<td>65</td>
</tr>
<tr>
<td>Routing the Connections</td>
<td>63</td>
</tr>
<tr>
<td>Setting Layers</td>
<td>61</td>
</tr>
<tr>
<td>Run, Macro command</td>
<td>555</td>
</tr>
<tr>
<td>Save As, File command</td>
<td>206</td>
</tr>
<tr>
<td>Save Button</td>
<td>133</td>
</tr>
<tr>
<td>Save, File command</td>
<td>205</td>
</tr>
<tr>
<td>saving</td>
<td></td>
</tr>
<tr>
<td>a file</td>
<td>205</td>
</tr>
<tr>
<td>a file to a name or location</td>
<td>206</td>
</tr>
<tr>
<td>a pattern to a library</td>
<td>494</td>
</tr>
<tr>
<td>ASCII file</td>
<td>206, 207</td>
</tr>
<tr>
<td>AutoSave</td>
<td>431</td>
</tr>
<tr>
<td>ECOS</td>
<td>200, 505</td>
</tr>
<tr>
<td>fields within a title block</td>
<td>82</td>
</tr>
<tr>
<td>files</td>
<td>31</td>
</tr>
<tr>
<td>routing options</td>
<td>133</td>
</tr>
<tr>
<td>scale, print</td>
<td>211</td>
</tr>
<tr>
<td>Scout</td>
<td></td>
</tr>
<tr>
<td>and DDE Hotlinks</td>
<td>196</td>
</tr>
<tr>
<td>scroll bars</td>
<td>14</td>
</tr>
<tr>
<td>displaying</td>
<td>447</td>
</tr>
<tr>
<td>select actions</td>
<td>356</td>
</tr>
<tr>
<td>copying objects</td>
<td>357</td>
</tr>
<tr>
<td>drag and drop</td>
<td>357</td>
</tr>
<tr>
<td>moving</td>
<td>357</td>
</tr>
<tr>
<td>resizing</td>
<td>357</td>
</tr>
<tr>
<td>rotating and flipping</td>
<td>358</td>
</tr>
<tr>
<td>Select All, Edit command</td>
<td>341</td>
</tr>
<tr>
<td>Select Highlighted, Edit command</td>
<td>342</td>
</tr>
<tr>
<td>Select, Edit command</td>
<td>356</td>
</tr>
<tr>
<td>selecting</td>
<td></td>
</tr>
<tr>
<td>block</td>
<td>21</td>
</tr>
<tr>
<td>deselect</td>
<td>24</td>
</tr>
<tr>
<td>embedded layers</td>
<td>339, 356</td>
</tr>
<tr>
<td>filter (for object selection)</td>
<td>423</td>
</tr>
<tr>
<td>items in a block</td>
<td>426</td>
</tr>
<tr>
<td>mask parameters</td>
<td>426</td>
</tr>
<tr>
<td>multiple</td>
<td>20</td>
</tr>
<tr>
<td>objects</td>
<td>19, 341, 356</td>
</tr>
</tbody>
</table>

**S**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As, File command</td>
<td>206</td>
</tr>
<tr>
<td>Save Button</td>
<td>133</td>
</tr>
<tr>
<td>Save, File command</td>
<td>205</td>
</tr>
<tr>
<td>saving</td>
<td></td>
</tr>
<tr>
<td>a file</td>
<td>205</td>
</tr>
<tr>
<td>a file to a name or location</td>
<td>206</td>
</tr>
<tr>
<td>a pattern to a library</td>
<td>494</td>
</tr>
<tr>
<td>ASCII file</td>
<td>206, 207</td>
</tr>
<tr>
<td>AutoSave</td>
<td>431</td>
</tr>
<tr>
<td>ECOS</td>
<td>200, 505</td>
</tr>
<tr>
<td>fields within a title block</td>
<td>82</td>
</tr>
<tr>
<td>files</td>
<td>31</td>
</tr>
<tr>
<td>routing options</td>
<td>133</td>
</tr>
<tr>
<td>scale, print</td>
<td>211</td>
</tr>
<tr>
<td>Scout</td>
<td></td>
</tr>
<tr>
<td>and DDE Hotlinks</td>
<td>196</td>
</tr>
<tr>
<td>scroll bars</td>
<td>14</td>
</tr>
<tr>
<td>displaying</td>
<td>447</td>
</tr>
<tr>
<td>select actions</td>
<td>356</td>
</tr>
<tr>
<td>copying objects</td>
<td>357</td>
</tr>
<tr>
<td>drag and drop</td>
<td>357</td>
</tr>
<tr>
<td>moving</td>
<td>357</td>
</tr>
<tr>
<td>resizing</td>
<td>357</td>
</tr>
<tr>
<td>rotating and flipping</td>
<td>358</td>
</tr>
<tr>
<td>Select All, Edit command</td>
<td>341</td>
</tr>
<tr>
<td>Select Highlighted, Edit command</td>
<td>342</td>
</tr>
<tr>
<td>Select, Edit command</td>
<td>356</td>
</tr>
<tr>
<td>selecting</td>
<td></td>
</tr>
<tr>
<td>block</td>
<td>21</td>
</tr>
<tr>
<td>deselect</td>
<td>24</td>
</tr>
<tr>
<td>embedded layers</td>
<td>339, 356</td>
</tr>
<tr>
<td>filter (for object selection)</td>
<td>423</td>
</tr>
<tr>
<td>items in a block</td>
<td>426</td>
</tr>
<tr>
<td>mask parameters</td>
<td>426</td>
</tr>
<tr>
<td>multiple</td>
<td>20</td>
</tr>
<tr>
<td>objects</td>
<td>19, 341, 356</td>
</tr>
</tbody>
</table>
Reference Point ........................................... 25, 359
Select Mode area ........................................... 23
selection commands ....................................... 356
single ............................................................ 19
sub select ......................................................... 20
selecting objects, block ..................................... 56
Selection Mask dialogs ....................................... 424
Selection Mask, Options command .................... 423
Set Base Button ............................................... 134
Set By Attribute ............................................. 349
setting
point size ..................................................... 386
Setting up the Design ..................................... 33
Grids ............................................................. 39
Line Width ..................................................... 39
Options Configure ........................................... 33
Options Display ............................................. 38
Options Layers ............................................. 35
Title Blocks .................................................. 36
Setup, Library command ................................... 493
Setup, Macro command .................................... 551
setup, printer ................................................... 215
shortcut
right-click mouse commands ......................... 29
ShortcutDirectory, Utils command ..................... 532
showing or hiding points .................................. 387
shrink, paste mask ........................................... 432, 433
signal layer ..................................................... 451
clearances .................................................... 460
silkscreen, violations (DRC) ......................... 166, 518
single select
on enabled layers ........................................... 339, 356
slash
key ............................................................... 410
lines ............................................................. 418
Snap to Grid, View command ......................... 367
snappy cursor ................................................... 367
software requirements ...................................... 3
solder mask swell ........................................... 432
SPECCTRA
placement attributes ..................................... 370
placement tool support .................................... 370
split plane
violations (DRC) ............................................ 167, 518
Status Information area ................................ 12
status line
information .................................................... 19
layer box ........................................................ 453
Status Line, View command ............................. 9, 366
stopping a macro ............................................. 552
subselect .......................................................... 47
swapping
pin and gate ............................................... 300
swell
plane ............................................................. 433
solder mask ................................................... 432
symbols, drill ............................................... 176
system
requirements ................................................ 3
setup .............................................................. 429

-T-

T_routing ..................................................... 112, 421
tables
drill ............................................................. 543
revision note ................................................... 542
tabs
Attributes, Component Properties .................. 301, 303
Attributes, File Design Info ............................ 226
Class To Class, Options Design Rules ............ 155
Component Pins, Component Properties ............ 299
Component, Component Properties ................ 299
Design, Options Design Rules ......................... 151
Fields, File Design Info ................................ 224
Format, Customize Report dialog .................... 219
General, File Design Info ................................ 224
General, Options Configure ............................ 429
Layer, Options Design Rules .......................... 152
Net Class, Options Design Rules ..................... 154
Net, Options Design Rules ................................ 154
Notes, File Design Info ................................ 227
Pattern Pad, Component Properties ................. 297
Pattern, Component Properties ....................... 293
Revisions, File Design Info ............................ 228
Rooms, Options Design Rules ......................... 153
Route, Options Configure ............................... 125
Selection, Customize Report ........................... 220
Sets, Options Configure ................................... 453
Sort, Customize Report .................................... 221
Statistics, File Design Info ............................. 228
Tango PCB

P-CAD PCB User’s Guide

Index

597
features ..........................................................2
target apertures .............................................260
technology files
  browsing ....................................................232
  building the hierarchy .................................240
  copying to a design ...................................232
  opening ....................................................231
  updating ....................................................232
  technology parameters ..................................229
test point ....................................................376
  flipping ....................................................376, 377
  online DRC ..............................................519
  placing .....................................................386
  printing .....................................................213
  report .......................................................217
  selection criteria .......................................427
  signal and plane layers ................................377
text
  changing display text ..................................483
  flipping .....................................................328, 395
  jumping to text ...........................................364
  justification ..............................................303, 327, 330, 353
  location .....................................................327
  properties ...................................................327
  rotating/flipping .........................................327
  selection criteria ........................................427
  style
    deleting ...................................................484
    fonts .......................................................485
    properties ...............................................484
    renaming ...................................................484
    TrueType Font ..........................................482
  zooming and panning ...................................396
Text Style Properties dialog ..........................485
Text Style, Options command ...........................482
Text, Place command ......................................393
thermal apertures ........................................259
Tile, Window command ...................................563
Title sheets ..................................................563
Titles ..........................................................548
Titles, DocTool command ................................548
toolbars ..........................................................6
custom toolbar ..............................................366
tools
  assigning ....................................................
automatically .............................................184
manually .........................................................184
N/C Drill .....................................................183, 267
code in N/C Drill ..........................................268
Trace Clean-up, Utils command ........................532
traces
  cleanup .....................................................412, 418
  curved .......................................................104, 412
  routing curved ............................................108
  translucent drawing ......................................447
  T-Route option ............................................436
  T-routing .....................................................103, 411, 417
type swapping ................................................294

-U-
unconnected pins (DRC) ................................166, 518
Undo, Edit command .......................................279, 280
Unhighlight All, Edit command ........................342
Unhighlight, Edit command ................................341
uniform grid spacing .......................................440
unify value practice .........................................55
units of measurement, changing ....................430
unrouted nets (DRC) .......................................166
unwinding .....................................................418
  routes .........................................................105, 411
Update All, DocTool command .......................549
Update, DocTool command ................................548
Upgrading Design Technology Parameters ............232

user interface
  menu bar .....................................................6
  P-CAD PCB ..................................................6
  prompt line ...............................................9
  status line ...............................................9
Using the Zoom Window ..................................363
Utils Commands
  Compare Netlist .........................................524
  Customize ..................................................537
  DRC .............................................................164, 445, 506
  Export ECOs ...............................................200, 505
  Find Errors ................................................519
  Force Update ..............................................500
  Generate Netlist .........................................523
  Import ECOs ...............................................198, 503
  InterPlace/PCS ...........................................533, 537
Index

Load Netlist ........................................520
Optimize Nets .....................................525
P-CAD Library Executive ........................532
P-CAD Pattern Editor ............................532
P-CAD Schematic ................................532
P-CAD Symbol Editor ............................532
Reconnect Nets ..................................530
Record ECOs ......................................198, 502
Renumber ..........................................497
Shortcut Directory ..............................532
Trace Clean-up ....................................532

verification of a netlist ..........................70
vertical alignment ................................340
routing pass ......................................137
via ..................................................419
location ...........................................312
minimization ....................................138
placing connections ...........................377
properties ........................................311
selection criteria ...............................427
setting up a style ...............................99
style hole range .................................482
Via Style, Options command ...............482
Via, Place command ............................380
View Center
 Autopan .........................................362
View Commands ..............................13
 All 14, 362
 Center ........................................14, 362
 Command Toolbar ..........................365
 Custom Toolbar ..............................366
 Extent ..........................................14, 361
 Jump Location .................................14, 363
 Jump Text .....................................15, 364
 Last ..............................................362
 Placement Toolbar ..........................365
 Prompt Line ..................................366
 Redraw .........................................14, 361
 Route Toolbar ................................365
 Snap to Grid ..................................19, 367
 Status Line ....................................366
 Zoom In .......................................362
 Zoom Out .....................................363
 Zoom Window .................................363

View log
 final board statistics .......................408
general ...........................................408
headers and footers .........................407
layer settings .................................408
net classes .....................................408
pass
 performance ................................408
 settings .......................................408
View Log, Route command ..................407
View Snap to Grid
 free-floating cursor ........................367
 snappy cursor ................................367
visible routing area .........................123

warning messages ..........................571
wide line routing ...............................136
width violations(DRC) .....................166, 518
window ..........................................13
selecting a ...................................654
Window Commands .........................563
Arrange Icons .................................564
Cascade .........................................563
New Window ..................................563
Tile ...............................................563
workspace
 setting size ................................33
 size ..............................................13, 430

X and Y distance, measuring .............355

Z Routes (2 vias) .............................137
zoom
 commands ....................................13
 zoom in/out ................................13
 zoom window ................................14
factor ..........................................432
level
 View All is default .........................362
 window ........................................363
Zoom In, View command ....................362
Zoom Out, View command ..................363
Zoom Window, View command ............363