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CHAPTER 1 

Introducing P-CAD Schematic 

Congratulations on your purchase of P-CAD Schematic! P-CAD Schematic is a complete schematic 
design system for Microsoft Windows 95, Windows 98, Windows 2000, or Windows NT 
operating systems. 

P-CAD Schematic distinguishes itself with a suite of features that make schematic creation fast and 
easy. It includes a powerful combination of placement, editing, and browse tools to quickly achieve 
superior design results. 

P-CAD Schematic Features 
This section highlights some of the key features in P-CAD Schematic: 

• Powerful placement and editing tools, object resize, multiline unwind, rewire, drag and drop 
move, and align. 

• User-definable sheet, part, and net attributes. 

• Intelligent wires and buses, which carry net information and attributes. 

• Comprehensive Electrical Rules Checking (ERC) with error annotation and violations 
highlighted on screen. 

• Support for Design Technology Parameters. 

• Cross probe between P-CAD Schematic and P-CAD PCB design. 

• Advanced bi-directional ECO capabilities. 

• Automatic junction and bus entry placement. 

• Single mouse-click (Click) access to edit and select options. 

• Support for hierarchical schematic designs. 

• Component library data integrated for use in both P-CAD Schematic and P-CAD PCB. 

• Standard and user-defined schematic sheet sizes. 
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• Versatile documentation tools, which include zoned borders, custom title blocks, tables, 
annotated sheet connectors, and the ability to track nets between sheets. 

• Extensive print and report options. 

About the User’s Guide 
This user’s guide includes the following sections: 

• Getting Started: This section explains what you what you need to know to get started using P- 
CAD Schematic. 

• Tutorials: Tutorial chapters provide instructions on creating and navigating a simple schematic 
design.  

• Command Reference: This section provides you with an extensive reference for the menu 
commands in P-CAD Schematic. 
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CHAPTER 2 

Installation and Setup 

This chapter lists the required hardware and software settings you need to install the P-CAD  Suite.  

System Requirements 
Make sure that your PC and its software conform to the following P-CAD requirements and 
recommendations.  

Recommended System 
• Windows NT 4/2000 Professional 

• PC with Pentium III Processor 

• 128MB RAM (256MB for high component/net count) 

• 400MB Hard Disk Space 

• Desktop area 1024x768 pixels 

• 32-bit Color Palette 

• CD-ROM Drive 

• Mouse or compatible pointing device. 

Minimum System 
• Windows 95/98/2000Me 

• PC with Pentium 166MHz 

• 64MB RAM 

• 200MB Hard Disk Space (without ISO libraries) 

• Desktop area 800x600 pixels 

• 256 Color Palette 

• CD-ROM Drive 

• Mouse. 
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Installing P-CAD Products 
For up-to-date installation information refer to the file Readme.WRI, located on the product CD. 
This file can also be found in the application program folder (\Program Files\P-CAD 2002) 
after installation. Note that the setup program on the Product CD can also be used to Repair or 
Remove an existing P-CAD Installation.
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CHAPTER 3 

P-CAD Schematic Basics 

This chapter introduces many of the basic features you need to know when using Schematic. It 
includes general information on such topics as: 

• About the User Interface 

• Configuration Options 

• Schematic Sheets 

• Opening Design Files 

About the User Interface 
The features in the P-CAD Schematic user interface make it easy to create and modify schematic 
designs. The following topics provide you with information the elements in the P-CAD Schematic 
graphical user interface. 

P-CAD Schematic Window 
When you start P-CAD Schematic, a new, untitled P-CAD Schematic window appears. This window 
gives you a graphical view of your design and also provides you with the ability to gain access to 
numerous features. The following figure shows you this window: 
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Menu Bar 
Just below the P-CAD Schematic title bar lies the menu bar, which gives you the ability to gain 
access to a variety of P-CAD Schematic functions. You can choose a command from one of these 
menus to perform the actions associated with that command. The following figure shows you the 
menu bar: 

 

If you minimize the P-CAD Schematic window, the menu bar wraps. In contrast, other window 
elements become truncated when you minimize the window. To learn how to minimize a window, 
see Close, Minimize, and Maximize Buttons (page 13). 

Opening a Menu 
To open a menu, click the menu title or hold down the ALT key and press the underscored letter in 
the menu title. For example, press ALT+F to open the File menu. 

Choosing Menu Commands 
When you open a menu, you can gain access to the functions associated with a command by 
clicking the command or by pressing the underscored letter in the menu and command titles. For 
example, press ALT+F+O to choose File » Open. When an ellipsis follows a command (e.g., File 
Open...), a dialog box appears. 
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If a menu command is shaded, the function associated with that command is not available. 
Typically, you must perform another type of action for the command to become available. For 
example, if the Edit » Paste command is shaded, you must first select the component you want to 
paste and then choose Edit » Cut or Edit » Copy. 

Toolbars 
You can gain access to various toolbars in the P-CAD Schematic window. Each of toolbar contains a 
set of buttons that act as shortcuts for frequently used menu commands.  

• Command Toolbar (page 8) 

• Placement Toolbar (page 8) 

• Custom Toolbar (page 9) 

• DocTool Toolbar (page 9) 

Showing or Hiding a Toolbar 
To show or hide a toolbar, click one of the toolbar commands in the View menu. When a check 
mark appears in front of one of these commands, the corresponding toolbar is visible. The 
following illustration shows you View » Command Toolbar as a checked command: 

 

Moving a Toolbar 
To move a toolbar, click a docked toolbar or click the title bar of a floating toolbar. Then, drag the 
toolbar to a new position. You can dock a toolbar below the P-CAD Schematic title bar or on the 
left or bottom edge of the window.  

A toolbar is a docked toolbar when you use a drag-and-drop operation to snap it to the edge of the 
P- CAD Schematic window. It does not have a title bar, as shown in the following figure: 

 

A floating toolbar has a title bar and is not attached to the edge of the program window, as shown 
in the following figure: 
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Command Toolbar 
The buttons in the Command toolbar, act as shortcuts for frequently used menu commands. To 
show or hide this toolbar, choose View » Command Toolbar. When a check mark appears next to 
this menu command, the following Command toolbar is visible: 

 

The following table describes each button in the Command toolbar: 

 

Click this 
button 

As a shortcut for choosing 
this command 

Click this 
button 

As a shortcut for choosing 
this command 

 
Edit » Select 

 
Edit » Paste 

 
File » New 

 
Edit » Undo 

 
File » Open 

 
Rewire » Manual 

 
File » Save 

 
Utils » Rename Net 

 
File » Print 

 
Edit » Measure 

 
Edit » Cut 

 
View » Zoom Window 

 
Edit » Copy 

 
Utils » Record ECOs 

 

Placement Toolbar 
The buttons in the Placement toolbar act as shortcuts for frequently used Place menu commands. 
To show or hide this toolbar, choose View » Placement Toolbar. When a check mark appears next 
to this menu command, the following Placement toolbar is visible: 
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The following table describes each button in the Placement toolbar: 

 

Click this 
button 

As a shortcut for choosing 
this command 

Click this 
button 

As a shortcut for choosing 
this command 

 
Place » Part 

 
Place » Polygon 

 
Place » Wire 

 
Place » Point 

 
Place » Bus 

 
Place » Text 

 
Place » Port 

 
Place » Attribute 

 
Place » Pin 

 
Place » Field 

 
Place » Line 

 
Place » IEEE Symbol 

 
Place » Arc   

 

Custom Toolbar 
You can add your own buttons to the custom toolbar, which provides you with access to frequently 
used software programs or other documents. For example, you can add a button that gives you 
quick access to Notepad or Internet Explorer. For instructions, see Utils Customize (page 352). 

Once you’ve added buttons to the Custom toolbar, you can show or hide it in the P-CAD Schematic 
window by choosing View » Custom Toolbar. When a check mark appears next to this menu 
command, the following Custom Tools toolbar is visible: 

 

DocTool Toolbar 
The buttons in the DocTool toolbar act as shortcuts for frequently used DocTool menu commands. 
To show or hide this toolbar, choose View » DocTool Toolbar. When a check mark appears next to 
this menu command, the following DocTool toolbar is visible: 
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The following table describes each button in the DocTool toolbar: 

 

Click this 
button 

As a shortcut for choosing 
this command 

Click this 
button 

As a shortcut for choosing 
this command 

 
DocTool » Place Table 

 
DocTool » Update 

 
DocTool » Titles 

 
DocTool » Update All 

 
DocTool » Notes   

 

P-CAD Schematic Workspace 
The workspace is the logical design area within the P-CAD Schematic window. When you start 
P-CAD Schematic, the full extent of the workspace is shown. As shown in the following figure, the 
edges of the grid display determine the edges of the P-CAD Schematic workspace. 

 

When you start P-CAD Schematic, the workspace contains a single schematic sheet. A schematic 
design can require multiple sheets, to show the connection of the parts on the board. To learn 
about sheets, see Schematic Sheets (page 19). 

On the schematic sheet, a title sheet displays by default. As shown in the previous figure, a title 
sheet contains a design border, zones, and a title block by default. To learn about title sheets, see 
Title Sheets (page 98). 
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Prompt and Status Lines 
Just below the P-CAD Schematic workspace lays the prompt line and status line. To show or hide 
the prompt line or status line, choose View » Prompt Line or View » Status Line. 

Prompt Line 
The Prompt Line displays various messages that instruct you as to what actions you can perform 
when a particular tool is enabled. 

 

Status Line 
Just below the prompt line lies the Status Line, which contains various features that give you more 
control over you P-CAD Schematic workspace. 

 

 
 

The following sections describe each element of the P-CAD Schematic status line. 

X and Y Coordinate Boxes 

The X and Y Coordinate boxes on the status line display the position of the mouse pointer as you 
move it over the workspace. To move the pointer to a specific location on your workspace, type an 
X and Y co-ordinate in the boxes.  

Grid Toggle Button 

Click the Grid Toggle button to switch between your absolute and relative grid settings. When you 
click this button, the button’s label changes to indicate whether you can switch to your absolute or 
relative grid settings.  

• Click  to switch to absolute grid mode. When active, the button background is white. 

• Click  to switch to relative grid mode. When active, this button background is colored. 

Grid Combo Box 

Use the Grid Combo box to select a new grid and to add grids to your design. To add a grid, type a 
value in the box and press ENTER. The new grid becomes the current grid. 
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As a shortcut for selecting items from the box, you can press the following keys: 

• Press G to scroll forward through the list. 

• Press SHIFT+G to scroll back through the list. 

Macro Record Button 

To create and record macros on the fly, click the M button on the status line. When you click this 
button, the button background changes to colored, and the macro recording process begins. After 
you record a series of actions, click the M button again to stop recording.  

When you record a macro with this button, P-CAD Schematic names the macro Sch_default.mac 
and saves the file in the Macro folder in your PCAD installation directory by default. To learn more 
about this feature, see Macro Record (page 362). 

Sheet List Box and Scroll Buttons 

Use the Sheet List and Scroll box as a shortcut for choosing Options » Sheets. To make a sheet the 
current sheet in view, select a sheet from the list. To scroll through all enabled sheets, click the 
arrow buttons on the scroll box.  

As a shortcut, you can also press the L key to scroll through the sheets in descending order. To 
scroll through the sheets in ascending order, click the down arrow or press SHIFT+L. 

Line Width List 

The Line Width combo box shows a list of available line widths. Because this is a combo box, you 
can select an existing line width or type a custom width in the box. 

As a shortcut for selecting a line width from the box, you can press the W key to scroll forward 
through the list. Or, press SHIFT+W to scroll back through the list. 

You can also set line widths by choosing Options » Current Line. For more information, see 
Options Current Line (page 313). 

Status Line Information Area 

The Status Line information area displays information relevant to the action you are currently 
performing. The status line shows the following types of data: 

• Identifies selected objects either specifically (type or reference designator) or generally 
(number of items selected). 

• The delta X and delta Y measurements of objects being moved or line segments being 
stretched. 

• The net name of selected nets. 

• Results of the Edit » Measure command. 

• The next part being placed while placing parts. 
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Other Window Elements 
As with most Windows-based products, the P-CAD Schematic window contains other elements: 

Close, Minimize, and Maximize Buttons 
Every P-CAD Schematic window has three buttons in the upper-right corner. You can click one of 
the following buttons to perform one of these actions: 

• Click  to close the window and quit the P-CAD Schematic program. 

• Click  to minimize the window. 

• Click  to maximize the window. 

Scroll Bars 
Two scroll bars surround the P-CAD Schematic workspace. You can click the scroll arrows to move 
the workspace up and down, or to the left and right. You can also drag the scroll box to move 
through the workspace. 

 

Shortcut Menu Commands 
When you right-click an object that has been placed in a design, a shortcut menu appears. This 
menu contains commands that can be performed on the selected object(s). The following table 
describes these commands: 

 

Choose this shortcut 
menu command 

To perform this action 

Add to Net A shortcut to connect a part’s sub-selected pin to an existing net. 

Add Vertex A shortcut to add a vertex to a single selected line/line segment. 

Align 
A shortcut for Edit » Align Parts. Parts can be aligned around a 
selection point either horizontally or vertically, and as an option, 
equally spacing the parts. For details, see Edit Align Parts (page 237). 

Ascend 
A shortcut for View » Ascend. Ascends the hierarchy of the design 
from the selected link to the corresponding module. For details, see 
View Ascend (page 255). 

Copy Matrix 
A shortcut for Edit » Copy Matrix. Duplicates selected objects based 
on parameters you choose. For details, see Edit Copy Matrix (page 
236). 

Copy A shortcut for Edit » Copy. Allows you to copy the object to the 
clipboard. 
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Choose this shortcut 
menu command 

To perform this action 

Cut A shortcut for Edit » Cut. Allows you to cut the object to the 
clipboard. For information, see Edit Cut (page 203). 

Delete A shortcut for Edit » Delete. This command deletes selected objects. 
For details, see Edit Delete (page 234). 

Descend 
A shortcut for View » Descend. Descends the hierarchy of the design 
from the selected module to the corresponding link. For information, 
see View Descend (page 255). 

Edit Nets 
A shortcut for Edit » Nets. This command brings up the Edit Nets 
dialog with the nets containing the selected objects highlighted in 
the Net List box. See Edit Nets (page 240) for more information. 

Explode 
A shortcut for Edit » Explode Part. This command allows you to 
convert a symbol back to its basic primitives, creating a collection of 
editable graphic objects. See Edit Explode Part (page 237) for details. 

Highlight 

A shortcut for Edit » Highlight. This command highlights the selected 
objects in the current highlight color set in the Colors tab of the 
Options Display dialog. For information, see Options Display (page 
297). It also highlights the corresponding items (for nets and 
components) in P- CAD PCB if the DDE Hotlinks check box in the 
Options Configure dialog is selected. For information, see Options 
Configure (page 292). 

Highlight Attached 
Nets 

Highlights nets attached to the selected objects in the current 
highlight color. For information, see Options Display (page 297). 

Net Info Opens a read-only dialog containing information about the selected 
net. 

Properties 
A shortcut for Edit » Properties. Depending on the object(s) selected, 
the appropriate Edit Properties dialog appears. For information, see 
Edit Properties (page 211). 

Remove from Net Disconnects a part’s sub-selected pin from the net. 

Select Contiguous Selects all ports and wires in the design visually connected to the 
selected item.  

Select Net Selects all items in the net to which the selected item is connected. 

Selection Point Relocates a selection point for the selected object or objects. 

Unhighlight 
A shortcut for Edit » Unhighlight. This command removes the 
highlighting from the selected objects. For information, see Edit 
Unhighlight (page 238). 
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Choose this shortcut 
menu command 

To perform this action 

Unhighlight Attached 
Nets 

Removes the highlighting from nets attached to the selected objects. 

 

Configuration Options 
With P-CAD Schematic, you can use various features and tools only after you set them up properly. 
The topics in this section show you how to set up the following configuration options for P-CAD 
Schematic. 

Showing or Hiding DataTips 
A Data Tip shows context-sensitive information about buses, pins, symbols, and wires. To show or 
hide DataTips in your workspace, follow these steps: 

1. Choose Options » Display to open the Options Display dialog. 

2. Click the Miscellaneous tab. 

 

3. Choose one of these options: 

• To show DataTips, select the Show DataTips check box. 

• To hide DataTips, clear the Show DataTips check box. 
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The Large Cross cursor style and the View » Snap to Grid command do not support the 
DataTips feature. Enabling the Large Cross cursor style clears the Show DataTips check box and 
makes the feature unavailable. Enabling the View » Snap to Grid command disables the Show 
DataTips feature. 

4. Click OK to close the Options Display dialog.  

When the DataTips feature is turned on, you can view a Data Tip by placing the mouse cursor over 
an object in your design.  

Selecting a Default File Viewer 
In P-CAD Schematic, the default file viewer is used for viewing reports; log files, error reports, etc. 
To select a file viewer, do the following: 

1. Choose Options » Configure to open the Options Configure dialog. 

 

2. Type the program name in the File Viewer box. For example, type: Notepad 

If the program you want to use as the default file viewer is in a directory that is not included in 
your system's path statement, type the pathname in the File Viewer box. 
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3. Click OK to close the Options Configure dialog. 

Setting the Current Zoom Factor 
The current zoom factor is a value that determines the apparent enlargement of objects when you 
zoom in or zoom out on a design. To set the current zoom factor, follow these steps: 

1. Choose Options » Configure to open the Options Configure dialog. 

2. Enter a value in the Zoom Factor box. 

You must enter a zoom factor that is greater than 1.00 (i.e., 1.01 or greater). 

3. Click OK to close the Options Configure dialog. 

To learn how to zoom in and out on a design, see View Commands (page 251). 

Setting the Autopan Percent Display 
The autopan percent display controls the process of panning across your design. For example, an 
autopan of 25% moves anything at the edge of the screen 25% closer to the center of the screen. 

To set the autopan percent display, follow these steps from the Options Configure dialog: 

1. Choose Options » Configure to open the Options Configure dialog. 

2. Enter a number in the Autopan% Display box. 

3. Click OK to close the Options Configure dialog. 

Enabling Orthogonal Modes 
You can use orthogonal modes when you place horizontal and vertical segments for wires, buses 
and lines. In P-CAD Schematic, the 90/90 and 45/90 modes are enabled by default. To learn more 
about orthogonal modes, see Aligning Objects (page 87). 

Specifying a Net Increment Value 
A net increment value defines the step value for incrementing net names when you use CTRL/Drag 
Copy and Edit » Copy Matrix commands. A value of 1 appears in the Net Increment Value box by 
default. To learn more about the increment value, see Options Configure (page 292). 

Choosing an ECO Format 
You use the controls in the ECO Format frame to choose a format for ECO files. In P-CAD 
Schematic, the ECO Format button is selected by default.  

Enabling the AutoSave Feature 
The AutoSave feature creates backup files of your current design at intervals you define. To enable 
the AutoSave feature, follow these steps: 

1. Choose Options » Configure to open the Options Configure dialog. 
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2. Select the Enable AutoSave check box.  

3. Notice that the Purge Previous Backups check box is selected by default. This option causes all 
backups saved from the previous design session to be deleted when you begin a new design 
session 

4. To turn the AutoSave feature off, clear the Enable Auto Save check box.  

5. Click OK to close the Options Configure dialog. 

When enabled, AutoSave won’t be performed during auto-routing or if a tool is busy.  

Compressing Binary Designs 
Typically, compressed files take up less storage space. To automatically compress a binary file when 
you save it, follow these steps: 

1. Choose Options » Configure to open the Options Configure dialog. 

2. Select the Compress Binary Designs check box.  

3. Click OK to close the Options Configure dialog. 

Enabling DDE Hotlinks 
The DDE hotlinks feature gives you the ability to create a connection between two related design 
files created in separate P-CAD programs. With this feature, you can explore the relationships 
between designs when you run the following programs: 

• P-CAD Schematic and P-CAD PCB/Relay 

• P-CAD Schematic and P-CAD PCB Viewer. 

With DDE Hotlinks, you can update information in one design and the feature automatically 
updates the same information in a related design. For example, you could apply the current 
highlight color to a part in a Schematic design and the DDE Hotlinks feature updates the related 
part in P-CAD PCB. Or, when you highlight a net in a PCB design, the DDE Hotlinks feature 
highlights the corresponding net in a related Schematic design. 

To enable this feature, choose Options » Configure and then select the DDE Hotlinks check box. 

Using a Snappy Cursor 
Choose View » Snap to Grid to turn the snappy cursor on and off. When a check mark precedes the 
command, a snappy cursor moves from grid point to grid point. When the command is not 
checked, a free-floating cursor moves freely between grid points.  

A snappy cursor can create a predictable point of reference when you move and rotate objects or 
measure distances. A free-floating cursor can enhance your ability to select items in the workspace, 
such as when you want to select a line that does not run true along grid points. 

The View » Snap to Grid command does not support the DataTips feature. When View » Snap to 
Grid is a checked command, the DataTips feature is disabled by default. 
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Your current View » Snap to Grid setting (on or off)is saved in the Sch.ini file when you quit the 
program. 

Schematic Sheets 
A schematic design can be a single sheet or multi-sheet design. When you start P-CAD Schematic, a 
new, untitled design window contains a single sheet. In this section, you’ll find instructions that 
show you how to perform the following tasks:  

Adding a Sheet 
To add a sheet to a design, do the following: 

1. Choose Options » Sheets to open the Options Sheets dialog. 

2. Type a name for the sheet in the Sheet Name box. For example, type: Sheet2 

When you add a sheet, you must give it a unique name. 

3. Click Add. The new sheet name appears in the Sheets list. 

When you add a sheet to a design, P-CAD Schematic automatically assigns the sheet a sequential 
sheet number, which represents the order in which the sheet appears in the Sheets List.  

Reordering Sheets 
To reorder the sheets in a design, follow these steps: 

1. Choose Options » Sheets to open the Options Sheets dialog. 

2. Select the sheet you want to move from the Sheets list. 

3. Click Move Up or Move Down. 

When you move the sheet to a different position in the Sheets list, the sheet number adjusts 
accordingly. 

Defining the Current Sheet 
To define the current sheet, follow these steps: 

1. Choose Options » Sheets to open the Options Sheets dialog. 

2. Select the sheet that you want to define as the current sheet from the Sheets list. 

3. Click Current. The asterisk (*) moves to the sheet you selected, to indicate that it is now the 
current sheet. 

The current sheet is the sheet that is actively in view. As a shortcut, you can also define the current 
sheet by selecting a sheet from the Sheets list in the status line. For details, see Status Line (page 
11). 
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Renaming a Sheet 
To change a sheet name, follow these steps: 

1. Choose Options » Sheets to open the Options Sheets dialog. 

2. Select the sheet that you want rename from the Sheets list. 

3. Type a new name for the sheet in the Sheet Name box.  

4. Click Modify. The sheet name changes in the Sheets list.  

Deleting a Sheet 
To delete the current sheet, follow these steps: 

1. Choose Options » Sheets to open the Options Sheets dialog. 

2. Select the sheet that you want to delete from the Sheets list. 

3. Click Delete. The sheet name no longer appears in the Sheets list. 

Tracking Nets Across Sheets 
P-CAD Schematic includes a combination of features with which you can track nets between sheets 
of the design. To print a net tracked between the sheets in a schematic design, follow these steps: 

1. Choose Edit » Nets to open the Edit Nets dialog.  

2. Select the desired net in the Net Names box. The sheets on which the net appears are 
automatically selected in the Sheets box.  

3. Click Highlight to highlight the selected net.  

4. Click Print Sheets to open the File Print dialog.  

5. In the File Print dialog, click Print Options to open the Print Options dialog. 

6. Select the Print Highlighted Wires/Buses as Haloed check box. This option distinguishes these 
highlighted nets in your print output.  

7. Click OK to return to the File Print dialog.  

8. Select the Tile Sheets check box to consolidate all of the net's sheets onto a single printed 
page. 

9. To view the tiled sheets of the tracked nets on the screen, click Print Preview.  

10. To send the tiled sheets of the tracked nets directly to the printer, click Generate Output. 
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Opening Design Files 
You can open files that have been saved as Schematic Files (*.sch), Tango Series II ASCII Files 
(*.s01), and P- CAD CFG Files (*.cfg). As a shortcut for opening files with the File » Open 
command, you can also use one of the following methods: 

• Use a drag-and-drop operation to open a Schematic File (*.sch). To do so, drag a file from the 
Windows Explorer or File Manager and drop it on the P-CAD Schematic window. 

• To open a recently used file, click one the file names that appear below the Exit command in 
the File menu. 

When you open files that were created in the Schematic Version 3.05 or earlier, P-CAD Schematic 
merges any global and local attributes in the file. 

Opening Schematic Files (*.sch)  
In P-CAD Schematic, design files saved in the Binary or ASCII format are given the *.sch file name 
extension by default. To open a *.sch file, follow these steps: 

1. Choose File » Open to display the Open dialog. 

2. Select Schematic Files (*.sch) from the Files of Type list. 

3. Select the file that you want to open.  

4. Click Open. Schematic opens the .sch file. As the file loads, several messages appear to 
indicate the systems progress. 

If an error or warning condition occurs when you open a file, P-CAD Schematic creates a log file 
<Design-name.log. A message box also prompts you to view this file. When you click OK, the log 
file appears in the Notepad by default. For details about possible error or warning conditions, see 
Appendix C, P-CAD System Messages. 

Opening Multisheet Designs 
If you’re opening a Design.cfg file, Schematic translates all the PDIF files into a single multi-sheet 
design. Schematic also preserves the name of the *.cfg file you loaded. In the design, each sheet 
has its own window. To switch between sheet windows, select the desired sheet from the Sheet 
Display combo box on the status line. 

Opening a Tango Schematic Series II File 
The File » Open command can read schematics in Tango Series II ASCII format. In Tango Series II, 
each sheet in a design is saved as a separate file. When you open the first sheet file in a Series II 
design, a dialog appears asking you if you want all subsequent sheets in the Series II design 
converted into a single design file. 
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Before loading a Tango Series II file, you must do the following: 

1. Create a corresponding archived library containing all of the symbols found in your P-CAD 
Schematic designs. 

2. Translate the archived Tango Series II library into a component/symbol library by choosing the 
Library » Translate command in P-CAD 2002 Library Executive.  

Some cleanup may be necessary due to design complexity and interpretation differences due to 
ambiguous design practices. 

Opening an ASCII File 
P-CAD Schematic supports the import and export of ASCII files, which contain complete design 
information. This is useful to archive and restore designs in a readable format. 

After a file is saved in ASCII format, other utilities may be used to perform these alterations: 

• Translation of design data from P-CAD Schematic to other design tools, and vice versa. 

• Automated modification of schematic designs with custom designs. 

• Interactive manual user modification of design data with text editing tools. 

Errors and warnings generated while opening an ASCII file are written to a file named <design-
name.log, which automatically appears in the Notepad. 
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CHAPTER 4 

Schematic Design Tutorials 

This chapter contains the following five tutorials that will take you through a Schematic design 
session from setup to printing: 

• Setting up a Schematic Design 

• Working with Schematic Objects 

• Verifying a Schematic Design 

• Generating Schematic Reports and Netlists 

• Printing a Schematic Design. 

Tutorial 1 - Setting Up a Schematic Design 
P-CAD Schematic provides you with a number of workspace options. This tutorial will show you 
how to configure various options for the P-CAD Schematic workspace, such as workspace size, title 
sheets, display options, measurements and grids. This tutorial uses some demonstration files that 
are supplied with P-CAD. 

For more information about the topics in this tutorial, press F1 for online Help, or refer to the 
relevant chapters in this User’s Guide. 

Setting the Workspace Size 
The workspace is the logical design area within the P-CAD Schematic window. To choose a size for 
the workspace: 

1. Start P-CAD Schematic. An empty workspace named Untitled1 is displayed. 

2. Choose Options » Configure to open the Options Configure dialog.  
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3. In the Workspace Size frame, choose A. 

The A-size workspace is the smallest of the predefined sheet sizes. For the design in this 
tutorial, an A-size drawing is adequate. However, if this becomes too small, open the Options 
Configure dialog and choose another size. You can switch to a smaller sheet at any time, as 
long as all of the objects in your schematic fit within the area. 

4. Click OK to close the Options Configure dialog. 

Setting Up a Title Sheet 
A title sheet can consist of a design border, zones and a title block. We will set up an A-sized global 
title sheet for all the sheets you will create within a design session. You can also select different title 
sheets for different sheets in a design by choosing the Custom sheet option. This option will 
override the global default title sheet for each selected sheet. 

Standard title sheets (filename.ttl) are supplied with P-CAD Schematic in the Titles folder of 
your P-CAD installation directory. The title blocks supplied can only be changed, e.g. if you want 
another text size or font, by modifying the original .ttl file. You may wish to create your own title 
sheets later by modifying one of these files and saving it as a new .ttl file. 

For more information about title sheets, refer to Options Commands, (page 287). 
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To set a global title sheet that will be automatically applied to all new sheets in your design: 

1. Open the Options Sheets dialog using one of the following methods: 

• Choose Options » Configure to open the Options Configure dialog. In the Title Sheets 
frame, click Edit Title Sheets. 

• Choose Options » Sheets. Then, click the Titles tab. 

• Choose DocTool » Titles. 

 

2. Select Global from the Sheets list box.  

3. Select Display Border. Notice that the border dimensions have automatically adjusted to allow 
500mil (.5 inch) between the edge of your workspace and the edge of the border. 

4. Set up the zones that display in the border as reference marks. Type 4 in both # of Zones boxes 
to create four zones in both horizontal and vertical directions and select Annotate Zone 
Information. 

5. Now we can select a title block that has been supplied with P-CAD with text fields already 
inserted for your design information. Click on Select in the Title Block frame to choose the 
filename of an existing title block. The Open Title Block dialog displays. 
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6. Navigate to the P-CAD Titles directory. Select ADT_AB.ttl and click Open to return to the 
Options Sheets dialog. The file name ADT_AB.ttl appears in the Title Block frame. 

7. Within the title block we selected in the step above, there are design information fields that 
display the values you enter in their appropriate place. When corresponding design 
information has been entered for a field, a field result appears in place of the field code, e.g. 
Schematic Design 1 replaces {Title}. To change the field codes into relevant design information 
in the title block, click Fields to display the Design Info dialog. 

 

8. Select a field name you wish to include in the title block, e.g. Title, click on Properties and 
enter the value in the Field Properties dialog, e.g. Schematic Design 1, and click OK. 
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9. Repeat the step above for all required fields, e.g. Drawing Number, Revision and Drawn By, 
and click on Close to complete and return to the Options Sheets dialog. 

10. Click Modify to apply the changes and then Close. If you return to the Options Configure 
dialog, click OK to close this dialog. The title sheet, border, and title block, with the design 
information entered, now appear in the workspace, as shown below. 

 

You can change the design information at any time by choosing File » Design Info and clicking 
the Fields tab to display the Fields Properties dialog. 

11. Now we have set up our title sheet, let’s save the design file by choosing File » Save. In the Save 
As dialog that appears, name your schematic Design1.sch and save it in the folder of your 
choice. 

If the last saved title block is displaying when opening a new file and you do not wish to use it, 
remove the title block file from the Title tab of the Options Sheets dialog by clicking Remove, 
then Modify and Close. Close all open design files until a blank untitled workspace is left, exit 
P-CAD and then restart P-CAD Schematic before choosing File » New. 
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Next we will set up the other workspace options that will be saved with this file. 

Choosing a Unit Measurement Scale 
In P-CAD Schematic, you can display units in mils, mm, or inches. To choose a unit measurement 
scale: 

1. Choose Options » Configure to open the Options Configure dialog. 

2. In the Units frame, choose mm or inch. Notice that the Width and Height values in the 
Workspace Size frame change as P-CAD Schematic’s 32-bit database converts all data to the 
measurement scale you choose. 

3. Choose mil in the Units frame and click OK to close the Options Configure dialog. 

Defining Color Preferences 
You can define a background color, distinguishing colors for different objects and more using the 
options in the Options Display dialog.  

1. Choose Options » Display to open the Options Display dialog and click the Colors tab. 

 

2. Click a button in the Item Colors or Display Colors frame to open a color 
palette. 

3. Click the color swatch in the palette that you want displayed and you are 
returned to the Options Display dialog. The color you chose displays next to 
the Item or Display button. 

4. From this Colors tab you can also change the junction size and bus connection 
mode. For this tutorial, we will use the default settings, so click Defaults and leave the Options 
Display dialog open. 
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Setting Up Miscellaneous Display Options 
To set up miscellaneous display options, follow these steps from the Options Display dialog. 

1. Click the Miscellaneous tab.  

 

2. Select the following check boxes in the Miscellaneous frame: 

• Display Default PinDes  

• Display Open Ends 

• Display Part Gate Number 

• Scroll Bars 

• Show Data Tips. 

3. To show the ERC error indicators in your design, select Show in the ERC Errors frame. 

4. Choose Arrow in the Cursor Style frame and click OK to close the dialog. 

Adding a Sheet 
A design will always have one sheet open. You can add additional sheets at any time during a 
design session. To add a sheet to a design: 

1. Choose Options » Sheets to open the Options Sheets dialog and click on the Sheets tab.  
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2. Type Sheet2 in the Sheet Name box and click Add. Sheet2 appears in the Sheets list box. 

3. Select Sheet1 in the Sheets list box. If an asterisk (*) does not appear next to Sheet1, click 
Current to define Sheet1 as the current sheet. 

4. Click Close to exit the dialog. Notice that Sheet2 has been added to the list box on the status 
line at the bottom of the screen. 

5. You can switch between sheets easily by selecting the required sheet name from the Sheet list 
box on the status line, or clicking on the empty box next to it to display the Options Sheets 
dialog and selecting the current sheet, or using the up and down arrows to scroll through the 
sheet list. 

 

Setting Up the Grid Spacing 
You can set up a new grid spacing at any time during a design session. To add some new grids to 
your design, such as a 50 mil and a 25 mil spacing: 

1. Choose Options » Grids to open the Options Grids dialog.  
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2. Type 50 in the Grid Spacing box and click Add. 50.0 is selected in the Grids list box. 

3. Select Visible and Dotted in the Visible Grid Style frame. Select Absolute in the Mode frame 
and click OK to close the dialog. A dotted 50.0 mil grid appears in the workspace. 

4. Another way to change the grid is to type the new grid spacing into the Grid Select list box on 
the status line. Type 25 and press ENTER to add the 25.0 grid spacing to the list. The 25.0 mil 
grid appears in the workspace. 

5. To switch between the grid spacings you just created, select 50.0 from the Grid Select list box 
on the status line to switch to the 50.0 mil grid. 

6. Choose File » Save to save the settings you have chosen during this tutorial. 

Zooming In and Out 
You can use a number of commands to zoom in and zoom out on the schematic workspace.  

1. Rest the mouse pointer over the area you wish to view. Press the + key to zoom in on your 
design. To zoom out, press the - key. 

2. Create a zoom window by choosing View » Zoom Window or clicking  in the command 
toolbar. Draw a bounding outline around the region of the design you want to zoom in on. 
P-CAD Schematic zooms in on the region you select. 

3. Choose View » Extent to view the extent of your design, that is, any objects placed. 

4. Choose View » All to view the entire workspace, including the title border. 

This concludes Tutorial 1. Please refer to Tutorial 2 to investigate working with Schematic objects. 
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Tutorial 2 - Working with Schematic Objects 
In this tutorial ‘Working with Schematic Objects’, we will explore how to place the objects that 
make up a schematic design, such as parts, wires, buses and ports. Off sheet connectors are also 
investigated to show you how to place and connect parts and nets across sheets. Once we have 
practiced some of the placement commands, we’ll look at the various ways of selecting placed 
objects and modifying their properties and finish with some useful commands for working with 
nets and attributes. 

For more information about the topics in this tutorial, press F1 for online Help, or refer to the 
relevant chapter in this User’s Guide. 

Object Placement 
Placing Parts and Components 
This section shows you how to place parts in your schematic design. A component contains logical 
and electrical data and can have one or more parts. A symbol shows a graphical representation only 
of the component and is used to display a part in a schematic design. 

Opening a Library  
A P-CAD library contains component and symbol information. Before you can place components or 
symbols in a schematic design, you must open the libraries that contain the parts you want to use. 
To set up a library to use: 

1. Open Design1.sch created in tutorial 1, or create a new schematic design file by choosing 
File » New. 

2. Choose Library » Setup to open the Library Setup dialog.  

3. Click Add to open the Library File Listing dialog.  

 

4. Select Demo.lib, located in the Demo folder in your P-CAD installation directory. 

5. Click Open. The system path to the selected file appears next to the Path label and the name of 
the selected library appears in the Open Libraries list. 
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6. Click OK to close the Library Setup dialog. 

You can also use a simple drag-and-drop operation to open a library file in P-CAD Schematic. To do 
this, open the File Manager or Windows Explorer. Navigate to the folder that contains the file you 
want to open. Then, select the file, drag it to the P-CAD Schematic window, and release the mouse 
button to open the library. 

Placing Parts 
Now that the appropriate library is open, you can start placing parts. 

1. Open the Place Part dialog using one of the following methods: 

• Choose Place » Part. 

• Click  in the placement toolbar. 

The following figure shows you the collapsed view of the Place Part dialog. 
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2. Click Browse>> to expand the Place Part dialog to display the symbol associated with the 
selected component.  

3. Select 74LS244 in the Component Name list box. As shown in the following figure, the number 
2 appears next to the Num Parts label, to indicate that the component package contains two 
parts.  

 

4. Click OK to close the Place Part dialog. In the P-CAD Schematic workspace, a ghosted outline 
of the first part in the 74LS244 component package appears. 

5. To place the first part of the 74LS244 component package: 

• Move the mouse pointer to drag the ghosted outline of the part to the left of the 
workspace center.  

• As you drag the component across the workspace, the information box on the status line 
indicates that you will be placing the first part of the component package, RefDes U1:A. 

• Click the workspace to place the part. Notice that the information box now indicates that 
you will be placing RefDes U1:B, which is the second part of the component package. 

A RefDes distinguishes each part in a component package and generally contains a prefix and a 
suffix. 

The prefix typically contains a letter and number. For example, integrated circuits start with the 
letter U (e.g. U1), resistors (R1), capacitors (C1), connectors (J1), switches (SW1) and so on.   

The suffix indicates that the part is a member of the component package. For example, the 
74LS244 package contains two parts: U1:A and U1:B. The A indicates that the part is the first 
member of the U1 component package, and B indicates that it is the second part of the U1 
package. 

6. To place the second part of the 74LS244 component package (U1:B), move the cursor to the 
right of U1:A. While you are positioning a part you can increase or decrease the numbering of 
the next part or RefDes using the following shortcut keys: 
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• To change the displayed part number to the next available value, press the P key. To select 
the next available reference designator, press D.  

• To return the RefDes to U1:B, press SHIFT+P until you return to the previous part number. 
Press SHIFT+D to select the previous available reference designator. Pressing these keys 
decrements the RefDes.  

7. Click the workspace to place U1:B in your design. 

8. Right-click to quit placing the 74LS244 component package.  

Notice that the Place Part button in the placement toolbar remains indented. This indicates 
that you are in placement mode. If you click the workspace, the Place Part dialog would appear 
so you could place another component type. Cancel out of part placement mode by selecting 
another tool. 

9. Choose the Select tool using one of the following methods: 

• Press S or choose Edit » Select. 

• Click  in the command toolbar. 

10. Select part U1:A in the schematic workspace again. 

11. Hold down the CTRL key and drag the ghosted outline of the part so it is just above U1:A. 

12. Release the mouse button to place a copy of the part. Notice that part is labeled U2:A, 
indicating it is the first part (A) of a new component package (U2).  

Sheet 1 of your schematic design should now resemble the following illustration.  

 

Switching Between Sheets to Place Parts 
This section shows you how to switch from Sheet1 to Sheet2, so you can place a part on Sheet2. 
Later in this tutorial we will wire these parts together and place sheet connectors. 

1. Select Sheet2 from the Select Sheet list box in the status line.  
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2. Open the Place Part dialog using one of the following methods: 

• Choose Place » Part. 

• Click  in the placement toolbar. 

3. Select 74154 from the Component list box. Notice that this component package has only one 
part. 

4. Click OK to close the Place Part dialog. Notice that the information box on the status line 
indicates that you will be placing RefDes U3. 

5. Place the part on the left side of Sheet2 by clicking the workspace. 

6. Right-click to quit placing the 74154 component package. 

Notice that the Place Part button in the placement toolbar remains indented. This indicates that 
the placement tool is active. If you clicked the workspace, the Place Part dialog would appear 
so you could select another component to place. 

7. Select Sheet1 from the Select Sheet list box on the status line. 

8. Click the workspace to open the Place Part dialog.  

9. Select the 74LS138 component from the Component list box.  

10. Click OK to close the Place Part dialog. Notice that the information box on the status line 
indicates that you will be placing RefDes U4. 

11. Place the U4 part to the right of U1:B by clicking the workspace.  

Sheet1 of your schematic design should now resemble the following illustration.  

 

Placing Wires 
This section shows you how to place wires in your schematic design. You will place wires in your 
design to connect the parts you have just placed as shown below. 
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1. Select the Place Wire tool using one of the following methods: 

• Choose Place » Wire. 

• Click  in the placement toolbar. 

2. Hold down the left mouse button on U1:B pin 9 and drag the mouse pointer towards U4 pin 1. 
Click where you want to place vertices (corners). 

3. While placing a wire, try selecting other orthogonal modes by pressing the O key. Also you can 
flip the wire by pressing the F key. 

4. Release the mouse button when you reach U4 pin 1 to place the wire. Notice that the 
information box on the status line indicates that you have placed NET00000. 

After you place a wire, the Place Wire button in the placement toolbar remains indented. This 
indicates that the wire placement tool is active. If you click the workspace, you would place 
another NET00000 wire segment. 

5. Right-click or press ESC to stop placing wire segments for NET00000. The information box on 
the status line indicates that you will be placing NET00001. 

6. Connect U1:B pin 7 with U4 pin 2. Then, right-click to stop placing NET00001. By default, P-CAD 
Schematic places wires with a 10.0 mil width.  

Changing the Current Wire Width 
The current wire width is the active width setting that is used when you place wires in a design. It is 
set for display purposes only. In P-CAD Schematic, the wire width is set to Thin (10.0 mil) by default. 
To change this setting: 

1. Choose Options » Current Wire to open the Options Current Wire dialog. 
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2. Choose the User option button and type 12.0mil in the text box and click OK. 

3. Connect U1:A pin 12 with U4 pin 3, as shown in the following figure. Then, right-click to stop 
placing NET00002. Sheet1 of your schematic design should now resemble the following 
illustration. 

 

If you place a wire segment in the incorrect position, choose Edit » Select and then choose Edit » 
Undo. Then restart the wire placement tool by choosing Place » Wire. You can also add a new 
vertex to a single wire by selecting it, right-clicking and choosing Add Vertex from the menu. 

Placing an Open-ended Wire 
With P-CAD Schematic, you can place a wire in a schematic design without starting the wire at a 
pin. To place an open-ended wire: 

1. Choose Place » Wire or click  in the placement toolbar.  

2. Click and hold down the left mouse button at the left side of the 
schematic workspace. Then, drag the pointer to U1:A pin 1 and release 
the mouse button to place the wire. A square appears on the open end 
of the wire, as shown.  

If a square does not appear on the open end of the wire, you must turn on the Display Open 
Ends feature found in the Miscellaneous tab of the Options Display dialog. 
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3. Press S as a shortcut for choosing Edit » Select. 

4. Select the wire you just placed. Then, right-click and choose Properties from the shortcut 
menu to open the Wire Properties dialog. 

5. Select the Display check box.  

At this time, you could rename the wire using the options in the Net tab of the Wire Properties 
dialog. For this tutorial, leave the default name that appears in this field. 

6. Click OK to close the Wire Properties dialog. Use the zoom in 
command (+) to see the net name on the wire. 

7. Press the SHIFT key and select the net name that appears above 
the wire. When the selection box appears, release the SHIFT key 
and drag the net name to the left. Then, release the mouse 
button to place the net name in its new position, as shown.  

Naming Nets by Placing Power Parts 
Power parts have an automatic net naming feature. When you place a power part in a schematic 
design and attach it to a net, the net name changes to the name defined by the power part. To 
automatically name a net by placing a power part in your design: 

1. Open the Place Part dialog by choosing Place » Part or click  in the placement toolbar. 

2. Select GND from the Components list box and click OK to close 
the Place Part dialog. 

3. Click the open end of the wire to place the GND part. The open 
end symbol disappears, to indicate that the connection is 
complete.  

As shown, the net name of the wire changes to GND because the 
GND component is a power part.  

Automatic Junction Placement 
When you connect a wire to another wire, P-CAD Schematic automatically places a junction at the 
connection point. To see how P-CAD adds junctions: 

1. Rest the mouse pointer on the ground wire you have just placed. 

2. Choose Place » Wire and draw a connection to U1:B pin 19.  

Notice that a junction is automatically placed and the new wire is added to the ground net. 
Junction size can be changed by choosing Options » Display. 

3. Connect U4 pin 15 with U2:A pin 1. Draw the connection as shown in the following figure, so 
you can later see how to move multiple items.  



Chapter 4: Schematic Design Tutorials Tutorial 2 - Working with Schematic Objects 

40 P-CAD Schematic User’s Guide 

 

4. Choose File » Save.  

Placing Buses 
To place a data bus in your schematic design: 

1. Select the bus placement tool by using one of the following methods: 

• Choose Place » Bus. 

• Click  in the placement toolbar. 

2. Hold down the mouse button and drag the pointer across the workspace to draw a horizontal 
bus below the parts you’ve placed in your design.  

3. Right-click to end bus placement. 

Connecting Wires to a Bus 
To connect wires to the bus just placed: 

1. Choose Place » Wire or click  in the placement toolbar.  

2. Place three wires to connect the bus to the following pins: U1:A pin 2, U1:A pin4 and U1:B pin 11. 

You can start or end the wires anywhere along the bus. Sheet 1 of your design should now 
resemble the following diagram.  
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Placing Ports 
Ports identify unconnected subnets of a single net and give you the ability to explicitly identify 
subnets on one or more sheets. Placing ports in a design also prevents unintentional net merges.  
To place a port: 

1. Open the Place Port dialog using one of the following 
methods: 

• Choose Place » Port. 

• Click  in the placement toolbar.  

2. Click in the workspace and the Place Port dialog displays. 

3. Type IN1 in the Net Names box and clear the Increment Port 
Name check box. 

4. Click  in the Port Shape frame. Ports with two 
connections are placed in-line and those with only one 
connection are attached to the left, right, above or below the 
wire. Click OK to close the dialog. 

5. Hold down the left mouse button and drag the port to the wire 
connecting U1:A pin 2. Release the mouse button to place it. 

If you need to rotate the port during placement, press R. To flip the port, press F. 

6. Place another port on the wire connecting U1:B pin 11 with the bus by clicking the desired 
location. 

7. Choose another command, e.g. S for Edit » Select, to quit port placement mode. 



Chapter 4: Schematic Design Tutorials Tutorial 2 - Working with Schematic Objects 

42 P-CAD Schematic User’s Guide 

Placing Ports to Continue a Net on Another Sheet  
To create global nets that continue from one sheet to another, you need to create a port through 
which the wires of the net will pass to the next sheet. You can also then add annotated sheet 
connectors that show the connecting sheet’s name and the zone location.  

First of all, we’ll create the port for a net we will name OUT1 that goes from Sheet1 to Sheet2. 

1. Choose Place » Port or click  in the placement toolbar to open the Place Port dialog. 

2. Click  in the Port Shape frame and select Two-pin in the Pin Count frame. 

3. Choose Horizontal in the Pin Orientation frame and click OK. 

4. Click U4 pin 7 to place the port and press S for Edit » Select to end port placement. 

5. Double-click on the port you just placed to open the Port Properties dialog and click the Net 
tab. 

 

6. Rename the net by typing OUT1 in the Net Name box and click OK. The 
new net name appears inside the port symbol. 

7. Hold down the left mouse button and drag the ghosted outline of the 
port away from the pin. Then, release the mouse button to place the 
port. Notice a wire is automatically added to fill the gap, as shown. 

Connecting a Net to a Part on Another Sheet Using a Port 
Now we will place a port to connect the continued net OUT1 on Sheet2 to component U3. You 
could switch to Sheet2 by selecting this sheet from the Sheets list box on the status line. 

Alternatively, you can jump to Sheet2.  
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1. Press S as a shortcut for choosing Edit » Select and then choose Edit » Parts to open the Edit 
Part dialog. 

2. Select U3 in the Parts list and click Jump. The mouse pointer rests on the reference point for 
U3 on Sheet2. 

3. Choose Place » Port or click  in the placement toolbar. Click in the workspace to open the 
Place Port dialog. Then, define the characteristics of the port using the following specifications: 

• Type OUT1 in the Net Name box. 

• Click  in the Port Shape frame and select Two-pin in the Pin Count frame. 

• Choose Horizontal in the Pin Orientation frame and click OK. 

4. Place the port at U3 pin 23.  

5. Press S as a shortcut for choosing Edit » Select and select and drag the port to the left, away 
from the pin. Sheet2 of your schematic design should now look like this. 

  

Let’s quickly check that net OUT1 does connect across the sheets. To do this: 

1. Choose Edit » Parts to open the Edit Parts dialog. 

2. Select U3 from the Parts list box. 
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3. Click Highlight Attached Nets and click Close to exit the dialog. Notice the current highlight 
color is applied to OUT1 on both Sheet1 and Sheet2. 

Using Annotated Sheet Connector Symbols 
You can place an annotated sheet connector to indicate that the net continues on another sheet. 
Annotated sheet connectors show the connecting sheet’s name and zone location using P-CAD 
Schematic’s zone intelligence, so you must have a sheet border with zones displayed for this 
feature to work. Also Show Cross Referencing must be selected in the Miscellaneous tab of the 
Options Display dialog. 

For information about using sheet borders with zones references, refer to P-CAD Schematic 
Tutorial 1 – Setting up a Schematic Design. 

 First we must place in and out sheet connector symbols that are supplied in Demo.lib. 

1. Go to Sheet1 and zoom in around the port named OUT1. Set your grid spacing to 25mil at this 
stage for accurate placement. 

2. Choose Place » Part or click  in the placement toolbar to open the Place Part dialog.  

3. Select SHEETOUT  from the Component Name list box and place it on the spare pin at 
the end of the port OUT1 connected to part U4. 

4. Press S as a shortcut for choosing Edit » Select to exit out of part placement mode. 

5. Now go to Sheet2 and place a part named SHEETIN  on the spare pin of the port named 
OUT1 connected to part U3.  

To display the annotated sheet connectors: 

1. Choose Options » Display and click the Miscellaneous tab of the Options Display dialog. 

2. Select the Show Cross Referencing check box in the Sheet Connector Cross Referencing frame 
and click OK. The sheet connectors display in the workspace, e.g.  which means 
this net continues on Sheet2 at zone location A, 2. On Sheet2, the sheet connector will display 

the cross reference back to Sheet1, e.g. . 

When you display cross references, all sheet connectors on all sheets are annotated. If a net’s 
location is moved or if a sheet connector is added or deleted from the net, the sheet connector 
cross references for all sheet connectors associated with that net are automatically updated. 

You can use these annotated sheet connectors to jump to its cross reference on another sheet 
by double-clicking on the SHEETIN or SHEETOUT part and clicking on the Sheet Connector tab 
in the Parts Properties dialog. 



Tutorial 2 - Working with Schematic Objects Chapter 4: Schematic Design Tutorials 

P-CAD Schematic User’s Guide 45 

 

3. Select the Cross Referenced Sheet Connector for the sheet you wish to go to and click on 
Jump. You are taken to the selected sheet and the cursor displays on the cross-referenced 
sheet connector. 

Placing Text 
To place text in your schematic design: 

1. Choose Place » Text or click  in the placement toolbar. A positioning cursor  appears. 

2. Click on the workspace where you want the text to be positioned and the Place Text dialog 
displays. Click on More» to expand the dialog, if necessary. 

 

3. Type in the text and choose a predefined style from the Text Style list.  

4. Click Place to display the text on the schematic design. 

5. Press S as a shortcut for choosing Edit » Select to exit out of text placement mode. 

For information about creating new text styles, refer to Options Text Style, (page 314). 

Now we have placed a few objects, we will look at the various ways of selecting them. 
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Selecting Objects 
This section of the tutorial shows you how to select single and multiple objects. We’ll be practising 
on the parts and wires that you have placed earlier in this tutorial. 

If the Show DataTips feature is enabled in the Miscellaneous tab of Options » Display, a Data Tip 
appears when you move the cursor over an object in your design. Data Tips show context-sensitive 
information about design objects and can assist you in selecting the appropriate object.  

Selecting Single Objects 
To select a single object: 

1. Press the + (plus) key to zoom in on your workspace. This makes viewing objects easier. 

2. Press S or click the Select button  on the command toolbar as a shortcut for choosing Edit » 
Select. 

3. Click an object to select it.  The object will display in the selection color (set in Options » 
Display) with a bounding box around it. 

4. To deselect the object, click in a blank space in your workspace to cancel the selection.  

Selecting Multiple Objects 
To select multiple objects: 

1. Select a part. Hold down the CTRL key and select another part (Ctrl+Click). Notice that both 
parts are selected and the bounding box includes all selected parts. 

2. Click a blank space to cancel the selection of the parts.  

Subselecting Objects 
You can select objects that make up a part or component. For example, you can select a pin that 
belongs to a component. To subselect an object: 

1. Place a component in the workspace using the Place » Component command. 

2. Press S or click the Select button on the command toolbar as a shortcut for choosing Edit » 
Select. 

3. Hold down the SHIFT key and click on a pin that belongs to the component. Notice that only 
the pin is selected.  

4. Now, you can perform actions on the pin. For example, you can right-click the pin and choose 
Properties from the shortcut menu to query the pin. 

Block Selecting Objects 
To select a group of objects, you can perform a block select. To block select: 

1. Hold down the mouse button and drag the cursor across your workspace to draw a bounding 
outline around two or three parts.  
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2. Release the mouse button to select the parts. 

3. Deselect the parts by clicking in a blank area of the workspace. 

Block Selecting Wires 
To change your block selection criteria to select all the wires in your design so we can display their 
net names: 

1. Choose Options » Block Selection to open the Options Block Selection dialog. 

 

2. Click Clear All to clear the default selection of all items. All of the item check boxes will 
become blank and the item buttons become shaded. 

3. Click the Wire check box until a solid check mark appears.  

4. Choose Outside Block in the Select Mode frame and click OK. 

5. Draw a bounding outline in an empty area of the workspace. Release the mouse button to 
select all of the wires in your design. 

6. Right-click and choose Properties from the shortcut menu to open the Wire Properties dialog 
and click the Wire tab. 

7. Click the Display check box until a solid check mark appears. 

At this point, your design should look like the following diagram:  
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8. Click OK to close the dialog. Notice that net names now appear on all wires. 

Block Selecting Using a Selection Mask 
You can define block selection criteria to specify which particular objects are selected when you 
perform a block select. This time, we will block select only the 74LS244 components, we placed 
earlier by using their Type to define the selection criteria. 

1. Choose Options » Block Selection.  The Block Selection dialog appears. The enable/check 
boxes have three states: checked (included); blank (excluded) or shaded (masked with 
additional selection criteria). 

2. Click the Clear All button to clear the default selection of all items. 

3. Click the Parts check box until a shaded check mark appears. When the Parts button becomes 
available, click Parts. The Part Selection Mask dialog appears. 



Tutorial 2 - Working with Schematic Objects Chapter 4: Schematic Design Tutorials 

P-CAD Schematic User’s Guide 49 

 

4. Type 74LS244 in the Type text box or choose it from the Type list. 

5. Click OK to save the changes and return to the Options Block Selection dialog. 

6. Select Inside Block as the Select Mode and click OK to set your selection criteria. 

7. Choose View » Extent to make sure the entire design is displayed in the workspace. 

8. Draw a bounding outline around the entire design. When you release the mouse button, 
notice that only the 74LS244 parts are selected. 

Restoring the Block Selection Criteria 
Remember to clear your filter when you have finished using Block Selection. To restore your block 
selection criteria: 

1. Choose Options » Block Selection to open the Options Block Selection dialog. 

2. Click Set All to select all of the check boxes in the Items frame. Choose Inside Block in the 
Select Mode frame and click OK.  

Selecting Highlighted Objects 
You can select objects that have already been highlighted on screen with the highlighter feature.  

1. First we will highlight a few objects by selecting them, right-clicking and choosing Highlight 
from the shortcut menu. Deselect the objects and they will display in the Highlight color set 
using Options » Display (default color is turquoise). 

2. Now to select the highlighted objects again, choose Edit » Select Highlighted. Only the objects 
highlighted in step 1 will be selected. 
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Notice that the Edit » Select Highlighted command selects all highlighted objects, regardless of 
the highlight colors that have been applied to the objects in a design. 

3. Right-click and choose Unhighlight from the shortcut menu.  

4. Click anywhere in the workspace. Notice that the highlight color is removed from all selected 
objects. 

To remove the highlight color from all objects, you can also choose Edit » Unhighlight All. 

Selecting Collocated Objects 
When objects overlap so that you cannot select any one of them, you can switch between the 
collocated objects to select the correct one. 

1. Add some objects that are collocated (in the same position) and position the cursor on top of 
them. 

2. Click the left mouse button to toggle between objects. Information about the currently 
selected item displays in the status line, e.g. ‘Part U1:A selected’.  

3. Delete these objects by selecting them and pressing the DELETE key. 

Now that we have gone through the different selection modes, it’s time to look at what can be 
done with objects when they are selected.  

Modifying Objects 
This section of the tutorial covers moving, rotating, resizing and changing properties of placed 
objects. 

Moving Objects 
1. Select the object(s) to be moved. 

2. Click on the object (or within the bounding box of several selected objects) and drag the 
cursor to the new location. 

The following topics show you the various methods you can use to move parts in a design. 

Moving Parts by RefDes 
To move parts by Reference Designator: 

1. Choose Edit » Move by RefDes to open the Edit Move by RefDes dialog. 
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2. Select U2:A from the RefDes list box and click OK. 

3. Hold down the left mouse button and drag the ghosted outline of U2:A so it rests to the right 
of its current position.  

4. Release the mouse button to place the part in its new position. 

Notice that U2:A moves to the right and that the connections are maintained. In addition, Edit 
Move by RefDes dialog opens again, so you can move another part. 

5. Click Cancel to close the Edit Move by RefDes dialog. 

Moving Parts by Block Selecting 
To move parts using the block selection feature:  

1. Draw a bounding outline around U2:A and the two wire segments closest to pin 1, as shown in 
the following figure. 

 

If your bounding outline does not select one of these items, hold down the CTRL key and 
select the missing items. Then, hold down the CTRL button and complete step 2. 

2. Drag the selected items to the right so that U2:A is above U4. Notice that the long horizontal 
segment shortens automatically, maintaining connectivity. 
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Moving Components and Wire Segments 
This section shows you how to move a component that is attached to a wire segment. 

1. Select U2:A and move it up one or two grid points. Notice that the wire becomes non-
orthogonal. 

2. Restore the orthogonal by selecting the diagonal wire segment. 

3. Drag the left endpoint up one or two grid points to create a 90-degree corner.  

To avoid creating a diagonal, you could have selected both the wire and U2:A before moving 
the part upwards. To select multiple items, hold down the CTRL key and select the items of 
your choice. 

Moving Wires and Maintaining Connectivity 
To see the connectivity maintained when moving wires:  

1. Select a vertical wire segment in your design. 

2. Drag the wire to the left and back to the right. Notice that connectivity is maintained.  

Remember that when moving items, you can always undo the action by pressing the U key, 
choosing Edit » Undo, or by clicking the Undo button on the command toolbar. 

Resizing Objects 
Selected objects can be resized by selecting and moving their editing handles. 

1. Select an object in your design, e.g. a wire or bus. 

2. Clicking on an editing handle and drag the cursor (with the outline of the object) to stretch the 
object. 

Rotating and Flipping Objects 
Selected objects can be rotated and flipped.  

1. Select an object and rotate it by 90 degrees counterclockwise by pressing the R key. 

2. Flip the object in the X direction (i.e. about the Y axis) by pressing the F key. 

Placed objects with connections will attempt to reconnect each time, so pressing the left 
mouse button while you choose R or F, will stop reconnections until you release the mouse 
button. 

Changing Properties 
This section looks at assessing and changing an object’s properties.  

1. There are a couple of ways to display an object’s Properties dialog: 

• Double-click on an object 
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• Select an object and choose Properties from the right-click menu 

• Select an object and choose Edit » Properties. 

A Properties dialog displays, such as the Parts Properties dialog below. 

 

2. Make any necessary changes and click OK. 

Changing the Width of a Selected Wire 
You can change the thickness of a selected wire by changing its properties. 

1. Select the first wire segment of NET00001. 

2. Right-click and choose Properties from the shortcut menu to open the Wire Properties dialog. 
As shown in the following figure, the Wire tab is selected for you by default.  

 

3. Choose the Thick option in the Width frame to change the wire thickness to 15.0 mil and click 
OK. The displayed width of the selected wire changes to 15.0 mil. 
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4. Select the wire segment again. Right-click and choose Properties from the shortcut menu to 
open the Wire Properties dialog. 

5. Restore the 10.0 mil wire width by choosing the Thin option button in the Width frame and 
clicking OK to close the Wire Properties dialog. 

Renumbering Reference Designators 
Before you verify your design and generate output, you should renumber your reference 
designators (RefDes). To see how renumbering works with parts: 

1. Place three RES500 resistors in the workspace, as shown below. 

 

2. Press S as a shortcut for choosing Edit » Select. 

3. Choose Utils » Renumber to open the Utils Renumber dialog.  

 

4. Choose the following settings: 

• Choose RefDes in the Type frame. 

• Choose Top to Bottom in the Direction frame. 

• Choose Auto Group Parts in the RefDes frame. 

5. Click OK to close the Utils Renumber dialog. A warning displays a message that states this 
operation is undoable. Click Yes to continue. 

6. Notice that the reference designators have been renumbered in top-to-bottom order within 
prefix types. 
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In particular, your resistors are renumbered starting with R1, and the ICs are renumbered starting 
with U1. Notice also, renumbering of U3 and U4 was done across sheets. 

Adding Values after Placing Parts 
You can add values after you place a part. To practice this: 

1. Select R1 and R2.  

2. Right-click and choose Properties from the shortcut menu to open the Properties 
dialog and click on the Symbol tab. 

3. Type 10 in the Value box and click OK. Notice the field results for the value field 
changes to “10” for each selected resistor. 

Deleting Objects 
1. Select all of the RES500 parts you placed.  

2. Press DELETE, or right-click and choose Delete from the shortcut menu. The resistors are 
removed from your design. 

Copying and Pasting Objects 
This section investigates copying and pasting objects and circuits. 

Copying a Group of Objects Using Drag-and-Drop 
To copy the group of selected objects : 

1. Block select the section of your circuit as shown below. 

 

2. Choose View » All. 

3. Hold down the CTRL key and drag the selected group of objects to an empty part of the 
workspace and release. Notice that you can view the exact distance of the move in the X and Y 
coordinates boxes on the status line. 

4. Zoom in to view the copied block by pressing the + key. 
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5. Probe the wires in the group of copied objects by selecting a wire and choosing Properties 
from the shortcut menu. You will notice the following about copied items: 

• Global nets maintain their original names. Global nets include nets with ports, e.g. IN1, 
nets attached to power parts, e.g. GND, and hidden power nets. 

• Nets that are not global are assigned unique default system names, e.g. NET00002. 

• Components are given unique reference designators. 

Copying Circuitry 
Suppose a section of circuitry you have completed previously could be used in more than one area 
of your design. In this situation, you could copy and paste the desired data, including net names, 
net attributes and net information.  

To copy and paste a section of circuitry: 

1. Add a new sheet to the design and name it Sheet3.  

2. Select the group of objects that you just copied using the drag-and-drop method. 

3. Copy this group of parts to the clipboard using one of the following methods: 

• Choose Edit » Copy 

• Right-click and choose Copy from the shortcut menu. 

4. Go to Sheet 3 and choose View » All.  

5. Choose Edit » Paste » Circuit to open the Edit Paste Circuit dialog. 

 

6. Select the Create new refdes using qualifier check box. This appends the specified characters 
to all the components in the copied data. 
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7. Type the characters to append to each RefDes in the Qualifier edit box, e.g. type A. 

8. Choose the Add to end of name option to append A to the end of the RefDes name. 

Now you can select the nets whose names you want to modify and specify the type of change 
you want to apply. 

9. Select the Create new net name using qualifier check box in the Nets frame and type _A in the 
Qualifier box. 

10. Choose the Add before numeric suffix button. In the Example frame, notice that your qualifier 
(_A) will be placed after the T in NET and before the first zero in the net name (i.e., 
NET_A00001). 

11. In the Maintain Original Net Names frame, select the Global Nets check box. This maintains 
the current names for all global nets and also selects all of the global nets in the Net Names list 
box. In this tutorial, all the nets are global. Optionally, you can choose individual nets to 
maintain their original names by checking the box next to each net. 

12. If you were copying the circuitry from another design where net attribute values may be 
different than the values of the same attributes in the destination file, you must choose how to 
handle the merge from the options in the Net Attributes frame. 

Since this copy and paste operation is within the same design and one of the options must be 
enabled, select the Merge Favor Design check box. This option keeps all of the net attribute values 
as they currently exist. 

Pasting the Copied Circuitry 
When all selections have been made in the Edit Paste Circuit dialog: 

1. Click the OK button to display the positioning cursor  in the workspace of Sheet3. 

2. Click the left mouse button and the ghosted outline of the copied items appears.  

3. Drag the objects to their destined location in the middle of the sheet and release the mouse 
button. The copied data is placed in the workspace as shown below. 

 

4. Notice that the RefDes and net names are modified with the qualifiers that you added. Each 
time you paste this same circuitry the qualifier is incremented to the next available name for 
each component or net name.  

5. To quit using the Paste command, right-click, or press the ESC key, or choose another 
command.  
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Working with Your Design 
This section takes a closer look at some options you may need to use when working with nets and 
attributes. Before you start, make sure Design1.sch is the current design. 

Working with Nets 
Now we’ll have a look at some commands you may need when working with nets in a design. 

Selecting a Subnet or an Entire Net 
To select a subnet or an entire net: 

1. Select any segment on the IN1 net, which is the net that attaches U1:B to the bus.  

2. Right-click and choose Select Contiguous from the shortcut menu to select the physically 
connected wires only.  

3. Right-click and choose Select Net from the shortcut menu. Notice now that the entire net is 
selected. 

Viewing Nets in a Bus 
If you ever need to recall what nets are attached to your bus, this information is readily available. To 
view the nets in a bus: 

1. Choose Edit » Nets to open the Edit Nets dialog.  

 

2. Select Bus in the Type frame.  

3. Select BUS00000 from the Bus Names list. Notice that a list of attached nets appear in the Edit 
Nets box and click Close to exit the Edit Nets dialog. 

Renaming Nets 
This section shows you how to rename the nets you have already placed. 

1. Choose Utils » Rename Nets. Click the workspace to open the Utils Rename Wire/Port dialog. 
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2. Type the following text in the Net Name box: DATA0. Select the Increment Name check box 
and click OK to close the dialog. 

3. Click each net in your design to name them DATA1, DATA2 and DATA3 respectively.  

4. Right-click or press ESC to stop renaming nets. The Utils Rename Nets tool remains active, so 
select another command to quit this mode, e.g. S for Edit » Select. 

Splitting a Net 
To split a net, we can place parts or delete sections of a net. 

1. Place a RES500 resistor on the horizontal GND wire directly above U1:B. 

2. Probe the wires on both sides. Note that the GND net is split.  

3. Select the vertical GND wire at the junction and press DELETE. Notice that the GND net is split 
again. 

4. Choose Utils » Rename Nets and click the workspace to open the Utils Rename Wire/Port 
dialog. 

 

5. Type IN2 in the Net Name box, choose Contiguous Wire in the Domain frame and click OK. 

6. Click the IN1 wire on the right side of the object group. Notice only the selected subnet is 
renamed. 

Working with Attributes 
P-CAD Schematic provides you with predefined attributes that can be associated with nets or 
components or used to add extra data to the design, e.g. physical or manufacturing information. 
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You can also create user-defined attributes. All or selected attributes can be included in a 
customized Attributes report generated using File » Reports. 

Attributes values can be simply displayed on a design using the Place » Attribute command. If you 
are creating your own symbols and require attributes such as ResDef, Type and Description of a 
part to be visible, you would place the attributes this way. Component attributes, such as 
Description or Reference to a web site, can be made visible on placed parts when added through 
the Attributes tab of the Properties dialog of a selected component. 

Attributes, however, are a far more powerful feature when set to define design rules. By defining 
the value of some attributes, e.g. Net, Clearance or Physical attributes, a design rule for each 
attribute is automatically created, e.g. defining the clearance rules that will apply when routing the 
board in P-CAD PCB. These design rules are stored with the design and can then be passed to 
P-CAD PCB via the netlist. 

For more information about attributes, refer to Place Commands, (page 259). 

Adding Net Attributes 
In the example we will use below, a Width attribute of 20mil will be set for the net OUT1. Setting 
such an attribute will also create a Width design rule for this net. This design rule will automatically 
set the width of all tracks in OUT1 to 20 mil when you route the board in PCB using the netlist 
generated from this schematic design. 

1. Choose Edit » Nets to open the Edit Nets dialog and click OUT1 in the Net Names list box. 

 

2. Click Edit Attributes to open the Attributes dialog. Attributes can be added or deleted through 
this dialog. Click Add to open the Place Attribute dialog. 
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3. Select Net from the Attribute Category list box. A list of attributes associated with that category 
appears in the Names list box. 

4. Select Width from the Names list box and type 20.0mil in the Value box and click OK. The 
attribute name and value appears in the Attributes dialog. 

 

5. If you need to modify a selected attribute, click Properties from this dialog to open the 
Attribute Properties dialog again. Click OK until you return to the Edit Nets dialog and click 
Close. 

6. Now to check that the design rule has been created, choose Options » Design Rules, click on 
the Net tab and select OUT1. The Width rule appears in the Net Rules frame. 



Chapter 4: Schematic Design Tutorials Tutorial 2 - Working with Schematic Objects 

62 P-CAD Schematic User’s Guide 

 

7. Click Close and save your design file by choosing File » Save.  

This concludes Tutorial 2. Please refer to Tutorial 3 to learn how to verify a schematic design. 
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Tutorial 3 - Verifying a Schematic Design 
Welcome to the P-CAD Schematic tutorial ‘Verifying a Schematic Design’. During this tutorial, we 
will check that a design is valid according to the Electrical Rules Check (ERC). The ERC utility will 
find any errors in the design, such as unconnected pins or wires, or rule violations. This tutorial 
uses a demonstration file that is supplied with P-CAD. 

For more information about the topics in this tutorial, press F1 for online Help, or refer to the 
relevant chapter in this User’s Guide. 

Design Verification 
P-CAD Schematic offers a range of Electrical Rules Checks (ERCs) that you can use to verify a 
design. This section shows you how to set up the rules you will be checking for and the level of 
severity, how to run the ERC report and then view the errors on screen. Finally we will have a go at 
fixing the errors that have been purposely included in a demonstration schematic file.  

For more information about the options in Electrical Rules Check utility, refer to the Utils 
Commands, (page 329). 

Setting up the ERC Options 
1. Open ERC.sch from the Tutorial folder of the P-CAD installation directory. 

2. Choose Utils » ERC to open the Utils Electrical Rules Check dialog.  

 

3. Select all of the check boxes in the Design Rule Checks frame.  

4. Select the View Report check box to present an on-screen report when the checks are 
complete and select the Summarize Ignored Errors check box. 

5. Select the Annotate Errors check box to place ERC error indicators in your design. These 
indicators graphically identify violation locations.  
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6. Click the Severity Level button to open the Rules Severity Level dialog. 

 

Notice the severity levels for most rules are set to Error as indicated by a ‘Yes’ in the Error 
column. You can change the severity level of a rule by selecting a rule in the list and choosing 
one of the options – Error, Warning or Ignored – in the Severity Level frame. Only Errors will 
display on the design when Annotate Errors is turned on. Warnings and ignored rules will only 
show on the ERC report. 

7. We will set a few rules to be ignored because the rigorous testing of the ERC will display errors 
that have been proven to be correct design choices for this schematic, e.g. pins have been 
correctly named as bidirectional in this case but may be problematic in a different design.  

Select the following rules and choose the Ignored button in the Severity Level frame: Bi Pin To 
Power Pin, Power Pin To Bi Pin, No Input Pins In Net and No Output Pins In Net. 
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8. Click OK to close the Rules Severity Level dialog and return to the Utils ERC dialog. 

9. Click OK to begin the ERC process. ERC will check all rules and will summarize those set to the 
Ignored severity level.  

10. When the process is complete, an ERC report appears in the text editor, e.g. Notepad, as shown 
below. A copy is automatically saved to file with the filename defaulting to the name of the 
design file with an .erc extension.  

Five errors and one warning will be reported, including a single node net, some unconnected 
wires and bus/net violations.  An unconnected pin will be flagged as a warning. 

 

11. You can print the report by choosing File » Print. Keep it open for cross referencing. 

Viewing any Errors in the Design 
1. Switch from the report to your design by clicking the workspace and notice that ERC error 

indicators  appear at error locations. Each error marker contains error information. 

2. To find and view information about all the errors, choose Utils » Find Error. The Find Errors 
dialog displays with Error 1 information. 
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3. In the Error Number scroll box, type another number or click the arrows to show information 
for all errors. The Description area shows the first error in the selected category, the error 
number and the reason for the error. The Categories drop-down list allows you to limit the 
type of errors listed, e.g. only Unconnected Wire errors. 

4. Select Error Number 1 from the Error Number scroll box and click Jump To. You are switched 
to the workspace, the error indicator is selected and the cursor is placed on it. 

 

5. To view information about any other visible error indicator while in the workspace, select the 
indicator, right-click, and choose Properties from the shortcut menu to display the Find Errors 
dialog again. Alternatively, just double-click on an unselected error indicator.  

6. Note that an error indicator for an unconnected pin on part J8:2-2 (co-ordinates 3050.0, 3000.0) 
is not shown because it was flagged as a Warning only in the ERC severity rules. You can only 
view warnings in the ERC report. 

Fixing Errors in the Design 
Now we will have a look at fixing the design errors found in this schematic. 
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Fixing the Single Node Net and Unconnected Wire Errors 
1. Select Error Number 1 again from the Error Number scroll box of the Find Errors dialog. The 

description tells us it’s a single node net error. Click Jump To. The cursor is placed on that 
selected error indicator.  

2. Now double-click the second error indicator on that wire. Error 3 information will display in 
the Find Errors dialog, indicating an unconnected wire. Click back to the workspace and 
double-click on the next indicator to the right (Error 2) which is also an unconnected wire 
error. These three errors are therefore related to the break in the wire. 

3. Click back on the workspace and fix the error by connecting the wire. This will resolve Errors 1, 
2 and 3. 

4. If you wish to delete the errors from the list as you solve them, click Override – Don’t Display 
Again in the Find Errors dialog. 

Fixing the Bus/Net Errors 
Now we will look at the remaining two errors, which are bus/net errors.  

1. Click on the Find Errors dialog box, select Error 4 (Bus ENBUSS only has one ref to net EN4) and 
Jump To. The clue lies in the fact that there is only one reference to net EN4. There should be a 
reference for the net going into the bus and another for it coming out again. This error 
description therefore implies that net EN4 is not properly connected to ENBUSS. 

2. Find net EN4 by choosing Edit » Nets, selecting EN4 from the Net Names list and click on Jump 
to Node. Now highlight net EN4 by selecting any wire in it, right-click and select Highlight Net. 
The entire net is highlighted for easy tracing. 

3. View the entire net EN4 by zooming and scrolling around the workspace. You will notice that 
EN4 goes into ENBUSS but then is wired straight into part U9:D instead of coming out of 
ENBUSS first. This is the design error we will have to fix. 

4. Since EN4 is individually wired directly to U9:D as well as attempting to go through the bus, 
one solution to this error is simply to select the wire segment that connects to ENBUSS and 
press DELETE.  Alternatively, you could modify the wiring from U9:D pin 13 back into the 
ENBUSS. 

5. Now we’ll fix the last error, Error 5 – Bus DATABUSS only has one ref to net EN1. Highlight net 
EN1 (see step 2 for details) to trace the net through the design. It appears that the net is 
connected to the wrong bus (DATABUSS). 

6. Select the wire segment that goes from U6:A pin1 to DATABUSS and stretch it to ENBUSS.  A 
new bus connector is displayed. Delete the old bus connector marker. 

7. Finally, let’s just check that warning of an unconnected pin that appeared on the report as 
‘Warning 1 -- Unconnected pin J8:2-2 on sheet:Sheet1 at mils (3050.0,3000.0)’. This appears to be 
simply a mistake, so delete the part by selecting it and pressing DELETE. 
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8. Choose Utils » ERC to rerun the ERC report and to clear the indicators of all errors that have 
been fixed. Check that there are no more errors in the ERC report. Choose File » Exit to close 
the ERC report and exit from the text editor. 

9. Save and close the design.  

The following suggestions form a basic strategy for resolving multiple errors in a design. First of all, 
run ERC checking only for single node nets, no node nets and unconnected pins and wires. Fix any 
errors and then rerun ERC to check for bus/net and net connectivity rules. Fix errors and rerun for 
component rules. Finally, select only the electrical and hierarchy rules (if you have a hierarchical 
design) and rerun ERC. With each pass, the number of related errors should diminish. 

Now you have verified your design, please refer to Tutorial 4 for instructions about generating 
reports and netlists. 
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Tutorial 4 - Generating Reports and Netlists 
Welcome to the P-CAD Schematic tutorial ‘Generating Schematic Reports and Netlists’. During this 
tutorial, we will generate reports using a demonstration file that is supplied with P-CAD. Then we 
will generate a netlist from this file that will include all the component and net information in the 
design. 

For more information about the topics in this tutorial, press F1 for online Help, or refer to the 
relevant chapter in this User’s Guide. 

This section covers generating standard reports from your schematic design, such as a Bill of 
Materials (BOM) and Attributes, Global Nets and Parts Usage reports. These reports can be viewed 
on screen, saved in a file or sent to a printer. You can customize your reports to include format 
options, like headers and footers, or set data selection or sort options.  

For more information about customizing your reports, refer to the File Commands, (page 169). 

Generating a Report  
To generate a report: 

1. Open the schematic design file Digdemo.sch from the P-CAD Demo directory. 

2. Choose File » Reports. The File Reports dialog appears. 

 

3. In the Reports to Generate list, select the check boxes that correspond to the type of reports 
you want to generate. 

4. Click Filename. The Reports File Save As dialog appears. 
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5. Navigate to the directory in which you want to save the report file and type a name for the 
report file in the File Name box. 

6. Select Report Files (*.*) from the Save As Type list and click Save. You return to the File Reports 
dialog. 

7. In the Report Destination frame, choose one of the following buttons: 

• Screen - Sends the output to a file and opens the file using the Notepad Utility. 

• File - Sends the output to a file. 

• Printer - Sends output directly to the printer without creating files. 

8. In the Style Format frame, choose one of the following buttons: 

• Separated List - Puts all data in character-separated format. This format can be imported 
into other spreadsheet and database programs. 

• P-CAD Report - Produces a report format with columns and spaces, etc. 

If you choose Separated List, select a separator from the List Separator list. 

The list separator character displayed in the box is used for both imported and exported files. 
The default character is your computer’s regional setting. 

9. Click Generate and the selected reports will display on the screen in your text editor, such as 
an Attributes report displayed in Notepad below, or will be sent straight to the printer or 
nominated file. 

 

Generating Netlists  
With P-CAD Schematic, you can generate netlist that lists the components and nets in your design. 
Typically, a netlist is used by a printed circuit board editor, such as P-CAD PCB, to form the basis of 
your board design.  
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To generate a netlist: 

1. Open the schematic design file Digdemo.sch, located in the P-CAD Demo directory. 

2. Choose Utils » Generate Netlist. The following Utils Generate Netlist dialog appears.  

 

3. Click Netlist Filename. The following Netlist File dialog appears.  

 

4. Navigate to the directory in which you want to save the netlist file and type a name for the 
netlist file in the File name box. 

5. Select Netlist Files (*.net) from the Save As Type list and click Save. You return to the Utils 
Generate Netlist dialog. 

6. In the Netlist Format list, select P-CAD ASCII as your netlist format. 

The P-CAD ASCII format supports attribute passing. If you select this option, you may also 
select the Include Library Information check box. 

7. Click OK to generate the netlist. The netlist is saved with the filename and in the directory you 
specified. 

This concludes Tutorial 4. Please refer to Tutorial 5 for information about printing your schematic. 
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Tutorial 5 - Printing a Schematic Design 
Welcome to the P-CAD Schematic tutorial ‘Printing a Schematic Design’ in which we will look at 
setting up print jobs. This tutorial uses a demonstration file that is supplied with P-CAD. 

For more information about the topics in this tutorial, press F1 for online Help, or refer to the 
relevant chapter in this User’s Guide. 

This final tutorial covers printing or plotting your schematic design. First, we’ll check the 
printer/plotter and page setups, then set the print options, before previewing and generating a 
print job that goes directly to the printer. 

Setting Up a Printer or Plotter 
To set up or change the printer or plotter settings on your computer: 

1. Choose File » Print Setup to open the Print Setup dialog.  

 

2. Select a print device from the Name list box. This list shows the printers and plotters that have 
been installed on your computer. 

3. Select the paper size and source from the corresponding list boxes in the Paper frame and 
choose Landscape in the Orientation frame. 

4. Click Properties to open the Properties dialog and configure other print parameters and click 
OK. 

Since print parameters are device-specific, the options in the Properties dialog depend upon 
the print device you selected. 

5. Click OK to close the Print Setup dialog. 
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Setting Up Page Setup Options 
For each sheet, you can scale your image to fit standard or custom size papers, define a print 
region, set horizontal and vertical offsets, show a title, and rotate the image. Individual sheets 
within a design can have different options set and these are saved with the design. We will print 
our Digdemo.sch file in this section. 

To define your page setup options: 

1. Choose File » Print to open the File Print dialog. 

 

2. Select the sheet(s) from the Sheets list to which you are applying these options and click Tile 
Sheets and Scale to Fit Page to display all sheets on one page. 

3. Click Page Setup to open the Page Setup dialog.  

For more information about options in this dialog, such as Print Region, refer to the File 
Commands, (page 169). 
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4. Select Title to display the title block on the printed image. 

5. Click Update Sheet to apply your changes to the print sheet and click Close to return to the 
File Print dialog, where we can set the print options. 

Setting Up Print Options 
With the Print Options dialog, you can set up various print options, such as color and display.  

1. Click Print Options from the File Print dialog to open the Print Options dialog and click the 
Colors tab. 

 

2. Choose your print colors using one of these methods: 

• If you have a color printer, click a command button in the Item Colors or Display Colors 
frame. When the color palette appears, click a color swatch. 
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• If you have a black and white printer, click the Defaults button. This sets all color options 
to monochrome. We recommend that you use this setting to avoid undesirable output 
when your printer converts color settings to grayscales. 

3. Choose Small, Large or User in the Junction Size frame.  

Notice that you can enter a value in the Size box only when you choose User. You can enter a 
value in inches, centimeters, etc. However, the value must be between 0 - 10 mm. 

4. Click the Miscellaneous tab. In this tab, you can choose to show or hide ERC error indicators 
and set other miscellaneous print options as shown in the following figure.  

 

5. We’ll use the default settings, so click the Defaults button and click OK to return to the File 
Print dialog. 

Previewing a Print Job 
To check that the print job you have set looks right, preview the print job. 

1. Click Print Preview in the File Print dialog. The specified print output appears on your screen, 
such as the Digdemo schematic below.  
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2. Click the Zoom In button to zoom in on the center area of the current page. Use the scroll bars 
to move to the desired viewing region to check that the print job is correct. 

3. Click Print to send the current print jobs directly to the printer, or click Close to close the Print 
Preview window and return to the File Print dialog. 

Generating Printouts and Printing Sheets 
After you have defined your page setup and print options, return to the File Print dialog to print the 
sheets.  

1. Click Set All in the File Print dialog to enable all the sheets in the design. 

2. Click Generate Printouts to print the selected sheets. 
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CHAPTER  5 

Working with Objects 

Consistent with other Windows compliant interfaces, the P-CAD user interface provides you with 
the menu choices, dialogs, options, and feedback based on what is appropriate given the current 
state of your design and P-CAD. The interface provides power, flexibility, and logical choices based 
on the object(s) currently selected and the command or process currently being invoked. 

This chapter includes detailed information on such topics as: 

• Placing Objects 

• Selecting Objects 

• Defining Object Selection Preferences 

• Block Selecting a Group of Objects 

• Moving Objects 

• Rotating and Flipping Objects 

• Aligning Objects 

• Using Orthogonal Modes 

• Resizing an Object 

• Pasting Objects 

• Object Properties 

• Editing Nets 
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Placing Objects 
To place an object in a schematic design, choose a command from the Place menu or click a button 
in the Placement toolbar shown in the following figure: 

 

When you choose a Place command, the tool remains active until you choose another command. 
For example, when you choose Place » Wire, you remain in wire placement mode until you choose 
another command, such as Place » Port or Edit » Select. 

Each Placement Command operates differently. Some objects require the interaction of a dialog 
before the object can be placed (e.g., content of text), but the general placement characteristics are 
the same.  

For example, when you choose Place » Line, P-CAD Schematic automatically places a line segment 
each time you click the workspace. Whereas, when you choose Place » Pin and click the 
workspace, a dialog box appears. After you set the pin characteristics using the options in the 
dialog, P-CAD Schematic places a new pin each time you click the workspace. 

Placing an Object 
There are two methods than you can use to place an object. For quick placement, click the 
workspace. For more precise placement, hold down the left mouse button and drag the object into 
position. Then, release the mouse button to place the object. You remain in placement mode until 
you right-click or press ESC. 

When you place objects in your design, P-CAD Schematic places the object at a grid point, 
regardless of your cursor setting. For more information, see Options Grids (page 295). To learn 
more about object placement, see Place Commands (page 259). 

Selecting Objects 
This section summarizes the techniques you can use to select objects in a schematic design. Once 
you are familiar with these techniques, you can define various object selection preferences. For 
details, see Defining Object Selection Preferences (page 81). 

Selecting an Object 
Use the single selection feature to select an object in your design. To select an object, follow these 
steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 
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• Choose Edit » Select 

• Press the S key. 

2. Click an object in the workspace.  

When you select an object, the object appears in the selection color set in the Options Display 
dialog. To change this color, see Choosing a Selection Color (page 82). 

To cancel your selection, click anywhere in the workspace. 

Selecting Multiple Objects 
Use the multiple selection feature when you want to select more than one object at a time. To 
select multiple objects, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Hold down the CTRL key and click the objects that you want to select.  

P-CAD Schematic is set up to use the CTRL key for multiple selections by default. To change this 
behavior, see Selecting Part of an Object (page 79). 

To cancel your selection, click anywhere in the workspace.  

Selecting Part of an Object 
The subselection feature lets you select a part of an object. For example, you can select a single pin 
in a part. To select part of an object, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Hold down the SHIFT key and click the part of the object that you want to select.  

P-CAD Schematic is set up to use the SHIFT key for subselections by default. To change this 
behavior, see Selecting Part of an Object (page 79). 

Once selected, you can view and in some cases modify properties associated with the part of the 
object. For example, if you selected a pin, you can open a Properties dialog for the pin and then 
change the pin style. To cancel your selection, click anywhere in the workspace.  
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Selecting Collocated Objects 
When objects on different sheets overlap, you can switch between the collocated objects, to select 
objects that reside on different sheets. When objects overlap, do the following: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Hold down the SPACEBAR and click the left mouse button to switch between the collocated 
objects. 

Pressing the SPACEBAR twice is equivalent to a mouse click (a press and release of the mouse 
button). 

Selecting All Objects 
To select all objects in a design, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Choose Edit » Select All. 

When you select an object, the object appears in the selection color set in the Options Display 
dialog. To change this color, see Choosing a Selection Color (page 82). 

To cancel the selection of all objects, choose Edit » Deselect All or click outside the selection box. 

Selecting Highlighted Objects 
If you’ve applied a highlight color to objects in your design, you can select all of those objects. To 
do this, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key 

2. Choose Edit » Select Highlighted. The highlighted objects are selected. 
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The highlighter features interact with DDE hotlinks feature, to enable the exchange of hotlink data 
between two P-CAD programs. In Schematic, hotlink data consists of highlighting and 
unhighlighting commands for parts and nets. In PCB, hotlink data is for components and nets. 

Selecting a Net 
There are two ways you can select all items in the net to which an item is connected. 

• Choose Edit » Nets and select a net from the list in the dialog that appears. Then, click Select. 

• Right-click a net and choose Select Net from the shortcut menu.  

In both cases, the complete net is selected, subject to any criteria set in Options Block Selection. 
For information, see Defining Block Selection Criteria (page 83). 

Selecting Contiguous Net Objects 
With the select contiguous feature, you can select all contiguous net objects of a selected net. Net 
objects are contiguous if they are visually connected on the design. For instance, wires are 
contiguous if they are connected from endpoint to endpoint. If a net consists of multiple subnets, 
only the sub-net to which the selected item belongs is selected. 

To use the select contiguous feature, right-click a wire or port, then choose Select Contiguous from 
the shortcut menu. This feature only works for one net at a time. 

Block Selecting Objects 
With P-CAD Schematic, you can also use the block selection feature. For details, see Block 
Selecting a Group of Objects (page 82). 

Defining Object Selection Preferences 
You can define various object selection preferences for P-CAD Schematic. This section provides 
you with information on your options. To learn about the techniques you can use to select objects, 
see Selecting Objects (page 78). 

Setting the CTRL/SHIFT Behavior 
By default, P-CAD Schematic is set up to use the CTRL key for multiple selections and the SHIFT key 
to select part of an object. However, you can reverse this setting. To do this, follow these steps: 

1. Choose Options » Preferences to open the Options Preferences dialog. 

2. Click the Mouse tab. 

3. In the Ctrl/Shift Behavior frame, choose the Ctrl subselects; Shift extends selection button. 

4. Click Close in the Options Preferences dialog. 

To learn how to extend a selection, see Selecting Multiple Objects (page 79). For instructions on the 
subselection process, see Selecting Part of an Object (page 79). 
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Specifying a Selection Point 
When you select one or more objects, a selection point appears at the closest grid point to the 
center of the selection box by default. However, you can change the location of this point by 
following these steps: 

1. Select one or more objects. 

2. Right-click and choose Selection Point from the shortcut menu. 

3. Press and hold down the left mouse button. Then, drag the ghosted outline of the selection 
point into position. The following figure shows you a selection point. 

 

4. Release the mouse button to set the selection point at the cursor location. 

When you cut or copy an object from a design, the selection point moves to the Clipboard or block 
file. When you paste an object, the selection point snaps to the grid. 

If the selection point is off-grid when a move operation begins, then it is automatically snapped to 
the nearest grid point and all the selected objects move the same relative distance.  

Parts can be vertically or horizontally aligned around a selection point. To do this, place a selection 
point at the point of alignment, choose Edit » Align Parts, and then set the desired alignment 
options in the dialog that appears. 

Choosing a Selection Color 
When you select objects in a P-CAD Schematic design, the objects appear in the selection color set 
in the Options Display dialog. To choose a selection color, follow these steps: 

1. Choose Options » Display to open the Options Display dialog. 

2. Click the Colors tab. 

3. In the Display Colors frame, click Selection. A color palette appears. 

4. Click a color in the palette. Then, click . 

5. Click OK to close the Options Display dialog. 

Block Selecting a Group of Objects 
The block selection feature gives you the ability to select a group of objects. You can configure this 
feature to include or exclude specific types of objects and your selection criteria can be as specific 
or as general as you choose. 

The procedures in this section show you how to perform the following use and set up the block 
selection feature. 
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Block Selecting Objects 
To block select a group of objects, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Drag the cursor diagonally across an area of the design to draw a selection box around a 
region.  

3. Release the mouse button. Any objects that match your block selection criteria are selected. To 
learn how to define block selection criteria, see Defining Block Selection Criteria (page 83). 

To remove the selection box, click outside the box. 

Defining Block Selection Criteria 
You can configure the block select feature to select all objects, objects by type, or even objects 
with specific parameters. To define block selection criteria, follow these steps: 

1. Choose Options » Block Selection to open the Options Block Selection dialog. 

2. In the Items frame, select the check boxes that correspond to the objects you want to block 
select.  

Some check boxes have corresponding command buttons (e.g., Line, Part, Pin). To make a 
command button available, click a check box until a shaded check mark appears. Then, click the 
button to open a  Selection Mask dialog. You use the options in these dialogs to narrow your 
selection criteria. For more information, see Edit Properties (page 211). 

3. In the Select Mode frame, choose of the following buttons: 

• Inside Block. Choose this button to select all items within the selection box. 

• Outside Block. Choose this button to select items outside the selection box. 

• Touching Block. Choose this button to select all items inside or touching the selection 
box. 

4. Click OK to close the Options Block Selection dialog. 

Moving Objects 
There are several ways to move objects in a P-CAD Schematic design. When moving an object, any 
connections rubber band to maintain the established nets.  
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Moving an Object 
There are two basic methods for moving objects in P-CAD Schematic: 

• Select the object that you want to move and drag it to a new position. 

• Select an object and press the arrow keys. 

With either method listed above, you can move one or multiple objects. To move multiple objects, 
draw a bounding outline around the group of objects to move. Then, drag them to a new position 
or press the arrow keys.  

As described in the following sections, you can also move objects during the placement process or 
with the Edit » Move by RefDes command. 

Moving Objects During Placement 
You can move parts, wires, buses, ports, points, text, attributes, fields and IEEE symbols before you 
place them in a design. To move an object during the placement process, follow these steps: 

1. Choose a command from the Place menu. For example, choose Place » Port. The Place Port 
dialog appears. 

2. Use the controls in the Place Port dialog to specify the characteristics of the port you are about 
to place. Then, close the dialog box. 

3. Press and hold down the left mouse button. Then, drag the ghosted outline of the object to a 
location.  

4. Release the mouse button to place the object at the cursor location. 

As a shortcut for holding down the mouse button during a drag-and-drop operation, press the ALT 
key and click the workspace. When the ghosted outline of the object appears, move the object to a 
location and press ALT to release the object at the cursor location. 

Moving Parts by RefDes 
To move parts by reference designator, follow these steps. 

1. Choose Edit » Move by RefDes to open the Edit Move by RefDes dialog. 
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If you select parts in your design before you open this dialog, those parts are selected in the RefDes 
list when the dialog appears 

2. Use one of the following methods to select parts from the RefDes list: 

• To select one part: Double-click a RefDes in the list. Or, select a RefDes from the list and 
then click OK or press ENTER. 

• To select all parts: Click Select All. Then, click OK. 

• To select a range of parts: Hold down the SHIFT key and click the first and last parts in the 
range to select. Then, click OK or press ENTER. 

• To select various parts: Hold down the CTRL key and click each part to select. Then, click 
OK or press ENTER. 

• To search for parts in the RefDes list: type search criteria in the Select RefDes By box and 
then press ENTER. 

When the Edit Move by RefDes dialog closes, the status line shows the name of the Next 
RefDes to move. You are in placement mode. 

To cancel your selection, press ESC or right-click. This reopens the Edit Move by RefDes dialog, 
so you can choose another part to move. 

3. Choose one of these methods to place the parts: 

• For quick placement, click the location at which you want to place the part.  

• For precise placement, do the following: (1) press and hold down the left mouse button or 
press the SPACEBAR. (2) Move the ghosted outline of the part to a location. If appropriate, 
press F to flip or R to rotate the part. (3) Place the part by releasing the mouse button or by 
pressing the SPACEBAR. 
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If you selected multiple parts, the status line shows the Next RefDes to move. To skip to the 
next RefDes, press N. To move to the previous RefDes, press B. 

4. Once you’ve moved all of the selected parts, the Edit Move By RefDes dialog appears. You have 
these options: 

• To move another part, select it from the RefDes list. 

• To close the Edit Move by RefDes dialog, click Cancel or press ESC. 

Rotating and Flipping Objects 
You can rotate and flip many objects in your design. When you rotate or flip an object, P-CAD 
Schematic rotates the object about the selection point. For details, see Specifying a Selection Point 
(page 82). 

For items with associated connections, hold down the left mouse button while rotating or flipping 
to prevent reconnection attempts each time you rotate or flip. Connections are changed when the 
left mouse button is released. 

To find out which objects you can rotate or flip, see the appropriate section in Place Commands 
(page 259). 

Rotating Objects During Placement 
To rotate an object during the placement process, follow these steps: 

1. Choose a command from the Place menu. For example, choose Place » Port. 

2. Click the workspace to place the selected object. If a dialog appears, use the options in the 
dialog to specify the characteristics of the object you are about to place. Then, close the dialog 
box. 

3. Hold down the left mouse button. Then, press R to rotate the object 90 degrees. 

4. Release the mouse button to place the object in your design. 

Rotating Objects in a Design 
To rotate an object that has been placed in a design, follow these steps: 

1. Choose one of these methods to enable the select tool: 

• Click in the Command toolbar 

• Choose Edit » Select 

• Press the S key. 

2. Select the object that you want to move. Then, press R to rotate the object 90 degrees. 
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Flipping Objects 
To flip an object that has been placed in a design, select the object that you want to flip. Then, press 
F to flip the object. When you flip an object, P-CAD Schematic flips the object about the selection 
point. For details, see Specifying a Selection Point (page 82). 

Aligning Objects 

Aligning Parts Horizontally or Vertically 
To align parts horizontally or vertically, follow these steps: 

1. Select the parts to align. Only parts can be selected for this command to be enabled. 

2. Right-click the parts and choose Selection Point from the shortcut menu. This is the point 
about which the parts will be aligned, either horizontally or vertically. 

3. Place the selection reference point by clicking in the workspace. Without selecting a selection 
reference point, the alignment and part spacing options are shaded. 

4. Choose Edit » Align Parts. The Edit Align Components dialog appears: 

 

5. Select either horizontal or vertical alignment. 

6. To align the parts with equal spacing, select the Space Equally check box and enter the Spacing 
value. The spacing value is the distance between the reference points of the parts. 

7. Click OK and the selected parts will be aligned. 

Aligning Parts To Grid 
To align parts to grid, follow these steps: 

1. Select the parts to align to grid. Only parts can be selected for this command to be enabled. 
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2. Choose Edit » Align Parts. The Edit Align Parts dialog appears. 

3. Click OK and the selected parts will be aligned to grid. Each selected off-grid part will be 
moved to the nearest grid point. 

Using Orthogonal Modes 
During the line placement process, you can press the O key to switch between the enabled 
orthogonal modes. The available orthogonal modes are divided into the following mode pairs: 

• 90/90 Line-Line Mode: Both lines are either horizontal or vertical (displayed perpendicular to 
each other). For long, the first segment is always longer than the second. For short, the first 
segment is shorter. To switch between the two configurations, press the F key. 

 

• 45/90 Line-Line Mode: The first mode makes the first segment displayed at a 45-degree angle 
and the second segment is either horizontal or vertical. The second mode makes the first 
segment either horizontal or vertical and the second segment. To switch between the two 
modes, press the F key.  

 

Enabling Orthogonal Modes 
To enable an orthogonal mode, follow these steps: 

1. Choose Options » Configure. The Options Configure dialog appears. 

2. In the Orthogonal Modes frame, select the following check boxes to enable a mode pair. 

• 90/90 Line-Line Mode 

• 45/90 Line-Line Mode 

For placing lines, the modes are limited to line segments (no arcs). 

3. Click OK to close the Options Configure dialog. 

After you enable the orthogonal modes, you can switch between the enabled modes, or switch 
between the mode pairs. For instructions, see Switching Between Orthogonal Modes (page 89) and 
Switching Between Mode Pairs (page 89). 
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Switching Between Orthogonal Modes 
Press the O key to switch between the orthogonal modes. The non-orthogonal mode straight-line 
mode is always available, no matter which orthogonal modes are enabled. 

Switching Between Mode Pairs 
Press the F key to switch between the mode pair of the orthogonal mode you are in. The non-
orthogonal mode straight-line mode is always available, no matter which orthogonal modes are 
enabled. 

Unwinding Segments 
You can unwind (undo a segment by pressing the BACKSPACE key) wires, lines, and polygons.  

When you place a multiple segment object, you can press the BACKSPACE key to delete the 
previous segment. If you have finished placing the object by right clicking, then the unwind 
function does not work. You can undo the placement of a finished object (Edit » Undo), but you 
cannot unwind it. 

Resizing an Object  
You can resize an object by clicking one of its handles and dragging to stretch the object. Object 
handles are the squares that appear when you select certain objects (e.g., arcs or polygons). 
Handles appear only if you select one object, and if the object can be resized. 

The resize function varies among the different objects. However, some objects cannot be resized 
(e.g., pins).  

For example, to resize an arc you click one of the endpoint resize handles and drag the endpoint to 
increase the sweep angle. To resize a polygon, you can grab one of its vertex handles and move it 
to change the polygon.  

  

When you move a polygon handle that is on an edge between two vertices, a new vertex is created 
(allowing you even more reshaping). You can delete a vertex by moving it to an adjacent vertex and 
releasing. 

Lines, wires, buses, arcs, and polygons can be resized. 

Cutting and Copying Objects 
In P-CAD Schematic, you can cut or copy objects to the Clipboard, which is a temporary storage 
area on your computer that houses the information that you want to transfer between designs, 
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documents, etc. You can also copy objects to a Meta file or block file. For details, see Copying 
Objects to a File (page 91). 

Cutting Objects from a Design 
You can cut objects from a design and paste them to another location, design, or program. To cut 
an object from a design, follow these steps: 

1. Select the objects that you want to cut. 

2. Choose Edit » Cut or press CTRL+X.  

The objects move to the Clipboard. When you cut objects from nets, you can get a variety of 
results, depending on what you cut and the makeup of the net from which you remove it. For 
example, deleting a wire from a net may split the net if the net is a contiguous net. 

Cutting Objects From Nets 
When you choose Edit » Cut to remove objects from nets, the results depend on what you cut and 
the makeup of the net you remove it from. 

 

• If you remove a wire from the middle of a net (bc in the example above): 

• If the deleted wire has a system-assigned net name (for example, NET00001) then one of the 
nets is given a new system-assigned net name, while the other retains the original net name. 

• If the deleted wire was connected to a global net, the subnet still attached to the port or power 
symbol retains the original net name, while the other net is renamed to a unique system-
assigned net name. 

• If both subnets are connected to a port or power symbol, then both subnets will retain the 
original name.  
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• If the wire was connected to a jumper pin and nothing else is connected to that jumper pin. 
Then all the jumpered pins are removed from the net. 

If you delete a wire that isolates a pin from the rest of the net, you end up with a disconnected 
node that is no longer part of any net. For example, in the above figure, if you delete wire cd, the 
node d becomes isolated from the net. 

Copying Objects to the Clipboard 
You can copy objects and move them to the Clipboard. To do this, follow these steps 

1. Select one or more objects. 

2. Choose Edit » Copy or press CTRL+C.  

The object moves to the Clipboard. You can then paste the contents of the Clipboard into your 
design, to another design, or even another program. 

Copying Objects to a File 
To copy objects to a block or Meta file, follow these steps: 

1. Select one or more objects. 

2. Choose Edit » Copy to File. The Edit Copy to File dialog appears. 

3. Navigate to the directory in which you want to save the file. 

4. Type a name for your file in the File Name box. 

5. Select one of the following file formats from the Save as Type list: 

• Block Files (*.blk). A file format that stores the information that you want to transfer 
between P- CAD Schematic designs. 

• Meta Files (*.wmf). An image file format that can be transported between computers. 

6. Click Save. 

Copying Objects within the Same Design 
To copy objects within the same design, follow these steps: 

1. Select one or more objects. 

2. Hold down the CTRL key. Then, drag the ghosted outline of the selected objects to a position. 

3. Release the mouse button to place a copy of the selected object at the cursor location. 

Copying Nets 
When you copy a contiguous net, P-CAD Schematic always creates a new system-assigned net 
name. CTRL/Drag and Copy Matrix provide automatic net name incrementation based on 
increment values you set using the Options Configure dialog.  
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Nets are contiguous if they are visually connected on the design. For instance, wires are contiguous 
if they are connected endpoint to endpoint. 

When wires are placed down, without being connected to an existing net, they are automatically 
given a unique net name, for example, NET00001. These system-assigned nets can subsequently be 
renamed, or ported to a new or existing net. 

The Wire Properties and Utils Rename Net commands allow you to rename a selected net. 

Copying a Matrix 
A matrix is an array of circuit elements. With the Edit » Copy Matrix command, you can duplicate 
one or more selected objects in both the horizontal and vertical directions.  

For example, you could choose this command to select a pin and create a column of four pins, or 
you can select an existing column and create any number of additional columns. 

To create a matrix of objects, follow these steps: 

1. Select the objects that you want to duplicate. 

2. Choose Edit » Copy Matrix to open the Edit Copy Matrix dialog. 

 

3. In the Number of Columns box, specify how many duplications you want to perform 
horizontally. In the Column Spacing box, enter a value to determine the spacing between 
duplications and in which direction (positive=right, negative=left) to duplicate. 

4. In the Number of Rows box, specify how many duplications you want to perform vertically. In 
the Row Spacing box, enter a value to determine the spacing between duplications and in 
which direction (positive=up, negative=down) to duplicate. 

You will receive an error message if what you specify for your duplication is too large to fit in 
the Workspace. 

5. Click OK. If your duplication is unsatisfactory, choose Edit » Undo to reverse the action. 

Pasting Objects 
Once you cut or copy information to the Clipboard or a block file, you can paste the objects into a 
schematic design. This section summarizes the techniques you can use to paste objects in a design. 
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You must have enough space in the target workspace location for the items you are pasting. If the 
space isn't sufficient or you are too close to the edge, the data can’t be pasted to the design. 

Pasting Clipboard Objects 
To paste the contents of the Clipboard to a design, follow these steps: 

1. Cut or copy information to the Clipboard. 

2. Move the cursor to the location where you want to paste the information. 

3. Choose Edit » Paste From Clipboard or press CTRL+V. 

To learn how to copy information to the Clipboard, see Copying Objects to the Clipboard (page 
91). 

Pasting From a File 
To paste objects from a file to a design, follow these steps: 

1. Copy information to a file. For instructions, see Copying Objects to a File (page 91). 

2. Choose Edit » Paste From File or Edit » Paste Circuit form File. The Edit Paste from File dialog 
appears. 

3. Select the file that stores the objects you want to paste in your design. Then, click Open. The 
cursor takes the shape of a crosshair cursor. 

4. Click the workspace at the location at which you want to paste the contents of the file.  

To learn how to copy objects to a file, see Copying Objects to a File (page 91). 

Splitting a Net 
The naming of nets separated as a result of a cutting, moving, or pasting action depends on 
whether the nets were global or local. This situation may arise when a wire is deleted from a net or 
when a 2-pin part is inserted over a wire segment. 

• If the original wire has a system-assigned net name (for example, NET00001) then one of the 
nets is given a new system-assigned net name, while the other retains the original net name. 

• If the original wire was connected to a global net, the sub-net still attached to the port or 
power symbol retains the original net name, while the other net is renamed to a unique 
system-assigned net name. 

• If both sub-nets are connected to a port or power symbol, then both sub-nets retain the 
original name.  

Net splitting occurs if an inserted part has only two pins, and it is inserted over a single wire 
segment. 



Chapter 5: Working with Objects Object Properties 

94 P-CAD Schematic User’s Guide 

Object Properties 
With P-CAD Schematic, you can gain access to a Properties dialog that contains context-sensitive 
information about and object in a design. 

When displaying the properties of multiple objects, the result depends on whether the objects are 
of the same type. 

If the objects are the same type, but have different styles or other characteristics, then the 
Properties dialog appears, but specific information about the objects will be blank or grayed where 
the information differs between objects.  

You can enter information in the dialog and click OK, and then all of the selected objects uniformly 
take on the characteristics (e.g., dimensions) of what you specified in the dialog. You can use the 
block selection mask to restrict selection. For information, see Options Block Selection (page 287). 

Although you cannot display the properties of objects of different types, you can perform other 
edit commands. 

Opening a Properties Dialog 
To open a Properties dialog, choose one of these methods: 

• Select an object and choose Edit » Properties. 

• Right-click an object and choose Properties from the shortcut menu. 

• Double-click an object. A Properties dialog only displays if you’ve selected the Double-Click 
Displays Properties check box in the Mouse tab of the Options Preferences dialog. 

Editing Nets 
This section discusses deleting objects from nets, managing net connections and the edit nets 
function. 

Deleting Objects from Nets  
When you delete objects from nets, you get a variety of results depending on what you delete and 
the makeup of the net from which you delete the objects. The function of smart nets is to maintain 
certain connections when objects such as wires, parts, and net nodes are deleted. In general, the 
following can occur. 

If you remove a wire from the middle of a net: 

• If the deleted wire has a system-assigned net name (for example, NET00001) then one of the 
nets is given a new system-assigned net name, while the other retains the original net name. 

• If the deleted wire was connected to a global net, the subnet still attached to the port or power 
symbol retains the original net name, while the other net is renamed to an unique system-
assigned net name. 
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• If both sub-nets are connected to a port or power symbol, then both sub-nets will retain the 
original name.  

• If you delete a wire that isolates a pin from the rest of the net, you end up with a disconnected 
node that is no longer part of any net. 

Managing Net Connections 
A single symbol pin or a part’s sub-selected pin can be connected to a net. To do this, right-click 
the pin and choose the Add to Net command. When the Add to Net dialog appears, select a pin you 
must supply the name of the existing net to which it will be connected. 

A symbol pin connected to a net can be disconnected from the net. To do this, right-click the pin 
and choose the Remove from Net command. The pin remains in the design as a single pin. 

Using the Edit Nets Dialog 
You can also use the Edit Nets dialog to select nets, edit net attributes and rename and delete nets 
and buses. A net is an electrical connection (e.g., two pins connected by a wire). Buses are a 
graphical representation of a bundle of one or more wires used to show multiple parallel wires on 
the schematic.  

If you click the Edit Attributes or View Attributes button, the Attributes dialog appears. Within the 
collection, each attribute’s name and value appear in the column. 

• Adding an Attribute: To add an attribute, click the Add button to open the Place Attribute 
dialog. Add a pre-defined attribute by choosing first the Category and then the desired 
attribute. To add a new attribute, select {user-defined} in the Name list and enter the name for 
the attribute. Enter the Value for the attribute and click OK, and the attribute is added to the 
table.  

• Editing Attribute Properties:  To edit an attribute’s properties, select an attribute from the table 
and click the Properties button (or double-click the attribute) to open the Place Attribute 
dialog.  

• Deleting an Attribute: Highlight an attribute in the table and click Delete. 

• Launching a Reference Link: When the special attribute Reference, whose value is a reference 
link, is added to the pattern, you can select the Reference attribute and click Launch to launch 
an application or web address to display a document or web site. 
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CHAPTER 6 

Documentation Tools 

The Documentation Toolbox focuses on accelerating the development of a complete, informative 
documentation package that details the fabrication, assembly, and testing of the printed circuit 
board. This chapter includes the following topics: 

• Title Sheets 

• Revision Blocks 

• Fields and Field Sets 

• Sheet Connector Cross Referencing 

• Net Index Tables 

• Note Tables 

• Power and Ground Tables 

• Revision Note Tables 

• Spare Gate Tables 

• Working with Tables 

• Reporting on Schematic Designs 

• Generating Reports 

• Generating a Netlist 
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Title Sheets 
With P-CAD Schematic, you can create custom title sheets for each sheet in your schematic design 
or you can select one of P-CAD’s standard title sheets to use on all of the sheets in your design. 

• Custom title sheets give you the ability to add a design border, zones, and a title block 
independently, using the combination and layout that best fits your design needs. For 
instructions, see Creating a Custom Title Sheet (page 101). 

• Standard title sheets are a collection of title sheet templates that come with P-CAD Schematic. 
These sheets contain a design border, zones, and title block by default. For instructions, see 
Using a Standard Title Sheet (page 100). 

A title sheet can contain several items. As shown in the following figure, a title sheet can contain a 
design border, zones, and a title block. 

 

Before you create a custom title sheet or use a standard sheet, you should be familiar with the basic 
components of a title sheet: design borders, zones, and title blocks. 

Design Borders 
Depending on your workspace size, the design border around a title sheet has a default dimension 
of 1/2 inch (500mils or 12.7mm) inside each edge of the workspace. The following table details the 
standard workspace sizes and the corresponding border dimensions in P-CAD Schematic: 
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Workspace Size Dimensions (inches) Workspace Size Dimensions (millimeters) 

A 8.5 x 11 A4 210 x 297 

B 11 x 17 A3 297 x 420 

C 17 x 22 A2 420 x 594 

D 22 x 34 A1 594 x 841 

E 34 x 44 A0 841 x 1187 

 

Zones 
A design border and its zones are the primary components in a schematic title sheet. Like a road 
map, zones divide the horizontal and vertical areas of the design into various sections. The 
following figure shows you a portion of a design border and its zones: 

 

The zone intelligence in P-CAD Schematic give you the ability to track nets between sheets and 
automatically include these net locations as annotations in your design. This feature is enabled by 
default, whether or not the zones are displayed in the workspace. However, to prevent overlay, it is 
recommended that you turn off the display of the border and zones when you use a standard title 
sheet.  

Title Blocks 
You can place a title block on any sheet, which includes design information such as, Title, Author, 
Design Number and Revision fields. The following figure shows you a sample title block: 
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The structure of a title block can be unique for each schematic sheet. P-CAD Schematic includes 
several schematic title block files that you can use in your design. 

You can create your own title block files. In addition, you place fields within the block. These fields 
can also be unique to each sheet. For information, see Fields and Field Sets (page 103). 

In P-CAD Schematic, title block files have the *.ttl file name extension. In P-CAD PCB, title block 
files have the *.tbk file name extension. 

After you are familiar with the basic components of a title, see one of the following topics to learn 
how to include title sheets and related components in your design: 

• Using the Global Title Sheet (page 100). 

• Using a Standard Title Sheet (page 100). 

• Creating a Custom Title Sheet (page 101). 

Using the Global Title Sheet 
To use the global title sheet, follow these steps: 

1. Open the Options Sheets dialog using one of the following methods: 

• Choose Options » Sheets. 

• Choose DocTool » Titles.  

• Choose Options » Configure. Then, click Edit Title Sheets in the Title Sheets frame. 

2. When the Options Sheets dialog appears, click the Titles tab. 

3. From the Sheets list, select the sheet to which you want to apply the standard title sheet. 

4. Choose Global. 

5. Click Modify. 

6. Click Close. 

Unless otherwise specified, the global title sheet appears on every sheet in your design by default. 

Using a Standard Title Sheet 
A standard title sheet includes a design border and zones. Several title sheet files are available in 
the Titles folder, which is located in your installation directory. To use one of these title sheets in 
your design, follow these steps: 

1. Open the Options Sheets dialog using one of the following methods: 

• Choose Options » Sheets. 

• Choose DocTool » Titles.  

• Choose Options » Configure. Then, click Edit Title Sheets in the Title Sheets frame. 
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2. When the Options Sheets dialog appears, click the Titles tab. 

3. From the Sheets list, select the sheet to which you want to assign the standard title sheet. 

4. In the Title Block frame, click Select. The Open Title Block dialog appears. 

5. Select the title sheet file you want to use and click Open. Standard title sheet files are located 
in the Titles folder of the P-CAD installation directory and have the *.ttl file name 
extension. 

6. (Optional) Turn off the display of the design border and its zones: 

• To turn off the display of the design border, clear the Display Border check box.  

• To turn off the display of the zones, clear the Annotate Zone Information check box.  

To correspond to the zoned perimeter included on the standard title sheet, enter information 
in the Borders and Zones frames. However, it is recommended that you turn off the display of 
the design border and its zones to prevent overlay. The border selections specify the 
dimensions of the perimeter; the default border dimensions correctly specify the bounds of a 
standard title sheet. The zones selections specify the number of zones in the horizontal and 
vertical directions. The zone intelligence is enabled whether or not the zones are displayed 
and is included to annotate a sheet connector or to complete one of the tables of design data. 

7. Click Modify to apply your changes to the selected sheet. 

8. Click Close. 

Creating a Custom Title Sheet 
To create a custom title sheet that you can later use in P-CAD Schematic designs, follow these 
steps: 

1. Create a one-sheet design in P-CAD Schematic. For title sheets, you may place: 

• Lines 

• Arcs 

• Polygons 

• Text 

• Attributes 

• Fields 

2. Choose File » Save As. The Save As dialog appears. 

3. Navigate to the Titles folder in your P-CAD installation directory. 

4. In the File name box, type the file name and file name extension as shown in the following 
example: “title.ttl” 
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When you type the file name, you must enclose the filename and file name extension in 
quotation marks (e.g., “TitleA.ttl”). 

5. Click Save. 

You can now use the custom title sheet in your designs. For instructions on using a custom title 
sheet, see the following section. 

Using a Custom Title Sheet 
To use a custom title sheet in a design, follow these steps: 

1. Open the Options Sheets dialog using one of the following methods: 

• Choose Options » Sheets. 

• Choose DocTool » Titles.  

• Choose Options » Configure. Then, click Edit Title Sheets in the Title Sheets frame. 

2. When the Options Sheets dialog appears, click the Titles tab. 

3. In the Sheets list, select the schematic sheet on which you want to place the title sheet 
components. 

4. Choose Custom. The options in the Titles tab become available. 

If you choose Global, P-CAD Schematic uses the Global title sheet. The Global title sheet 
contains a design border, zones, and a title block by default. 

5. In the Border frame, select the Display Border check box to show a border in the workspace. 

6. In the Relative Origin frame, type a value in the Height and Width boxes. Then, type a value in 
the X and Y boxes.  

Alternatively, select the Size to Workspace check box to use the default border size and 
location. 

7. To add zones to the design border, follow these steps: 

• In the Horizontal frame, select the Alpha or Numeric button and the Ascending or 
Descending button. 

• In the Vertical frame, select the Alpha or Numeric button and the Ascending or 
Descending button. 

• Select the Annotate Zone Information check box. 

• Select a text style from the Text Style box.  

8. If you want to add a title block, enter values in the File Name and Lower Right Offset boxes in 
the Title Block frame. For information, see Title Block (page 99). 

9. (Optional) To add a title block, follow these steps: 
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• Click Select. When the Open Title Block dialog appears, select a *.ttl file from the 
Titles folder in your P-CAD installation directory. 

• Select the Field Set, which includes the fields to place in the title block. For details on 
assigning a field set to a sheet, see Fields and Field Sets (page 103). 

10. Click Modify. This assigns the chosen title sheet components to the selected sheets. Repeat 
from step 1 for other sheets if desired. 

11. When you click Close, the modified sheets show the border, zones, and title blocks specified. 

Revision Blocks 
A revision block details the differences between versions of a design. In P-CAD Schematic, a 
revision block is placed as a Revision Note Table.  For more information, see Revision Note Tables 
(page 114). The following figure shows you an example revision block, as it looks in a schematic 
design. 

 

Fields and Field Sets 
A field acts as a placeholder for specific design information and you can insert a field anywhere in a 
design or title block. For example, if you insert the Title field in a design, P-CAD Schematic 
automatically displays the design title wherever the field is placed. After you place a field in a 
design, either a field code or field result appears.  

P-CAD Schematic includes the following fields by default: Approved By, Author, Checked By, 
Company Name, Date, Drawing Number, Drawn By, Engineer, Revision, Time and Title. You can 
also create custom fields to include in a design. 

As shown in the following illustration, a field code appears between the braces (e.g., {Drawing 
Number} or {Date}). A field result appears when any corresponding design information exists (e.g., 
Title (Digdemo.sch), Size (C), and Rev (5s). 
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You can also group fields into field sets and then assign a set to a schematic sheet. P-CAD 
Schematic automatically updates the field information as field values change, based on the field set 
of the sheet on which they are located. 

To learn how to use fields and field sets in a design, see one of the following topics: 

• Adding a Custom Field (page 104). 

• Placing Fields in a Design (page 105). 

• Changing Field Results (page 105). 

• Adding a Field Set (page 105). 

• Assigning Field Sets to Schematic Sheets (page 107). 

Adding a Custom Field 
To add a custom field to a design, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Fields tab. 

3. Click Add. The following Field Properties dialog appears. 

 

4. Type a name for the custom field in the Name box. 

5. Type a value for the custom field in the Value box. 
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6. Click OK to close the Field Properties dialog. You custom field appears in the spreadsheet of 
the Fields tab. 

To learn how to place fields in a design, see the following procedure. 

Placing Fields in a Design 
To place a field in a design, follow these steps: 

1. Choose Place » Field or click the Place Field button in the Placement toolbar. 

2. Click the workspace. The Place Field dialog appears. 

 

3. Select a field from the Name list. For example, select Approved By. 

4. Click OK to close the Place Field dialog. 

5. Click the workspace in the location at which you want to place the field. The field code 
{Approved By} appears. 

6. To place another field, click the workspace again and repeat steps 3 - 5. 

7. To exit field placement mode, choose Edit » Select or another menu command. 

When design information exists for a field, a field result replaces the field code. For more 
information, see Changing Field Results (page 105). 

Changing Field Results  
When corresponding design information exists for a field, a field result appears in place of the field 
code (e.g., J.Smith replaces {Approved By}). To change field results, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Fields tab. 

3. Open the Field Properties dialog using one of the following methods: 

• Double-click the field name. 
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• Select the field name and click Properties. 

4. When the Field Properties dialog appears, enter information in the Value box. For example, 
enter a name, as shown in the following figure: 

 

5. Click OK to close the Field Properties dialog. 

6. Click Close in the Design Info dialog. The value you entered appears in the field placeholder. 

Adding a Field Set 
You can group fields into distinct field sets, which can contain fields such as title, author, drawing 
number, etc. To create a field set, follow these steps: 

1. Choose File » Design Info. The File Design Info dialog appears. 

2. Click the Fields tab. 

3. Click Field Sets. The Field Sets dialog appears. 

4. Click Add. As shown in the following figure, the name Field Set 1 appears in the Fields Sets list 
and the Field Set Name box. 

 

5. In the Field Set Name box, type a name for your new field set. 

6. Click Close to return to the Fields tab of the File Design Info dialog. Your new field set is 
available in the Field Set list. 



Sheet Connector Cross Referencing Chapter 6: Documentation Tools 

P-CAD Schematic User’s Guide 107 

Assigning Field Sets to Schematic Sheets 
You can assign sheet-specific field sets to the sheets in a schematic design. To do this, follow these 
steps: 

1. Open the Options Sheets dialog using one of the following methods: 

• Choose Options » Sheets. 

• Choose DocTool » Titles.  

• Choose Options » Configure. Then, click Edit Title Sheets in the Title Sheets frame. 

2. Click the Titles tab. 

3. Select the sheet to which you want to apply the field set from the Sheets list. 

4. Select a field set from the Field Sets list. For instructions on adding sets to this list, see Adding a 
Field Set (page 106). 

5. Click Modify to apply your changes to the selected sheet. 

6. Click Close. 

Sheet Connector Cross Referencing 
When a schematic sheet contains zones, you can cross-reference the sheet connectors. A sheet 
connector is annotated with the zone location of all other cross sheet connectors associated with 
the same net on all schematic sheets. For more information, see one of the following topics: 

• Sheet Connector Overview (page 107) 

• Annotating Sheet Connectors (page 108) 

• Viewing Sheet Connector Properties (page 110) 

• Jumping to Sheet Connectors (page 110) 

Sheet Connector Overview 
To create a component to use as a sheet connector, you must save it as a Sheet Connector. Sample 
sheet connectors (i.e., SHEETIN, SHEETOUT) are located in the Demo.lib file in the Demo folder of 
your P-CAD installation directory. 

A cross-referenced sheet connector is annotated with the sheet name or sheet number, as well as 
the alphanumeric zone location of all instances of sheet connectors belonging to the same net. A 
sample cross-referenced sheet connector is displayed in the following figure:  
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A sheet connector indicates that the attached net is continued on another sheet. It has no net 
intelligence, with the exception that when placed in a schematic design, the value attribute is set to 
the net name. You can display the net name, along with the sheet connector’s zone location. For 
details, see Annotating Sheet Connectors (page 108). 

If the value attribute of a sheet connector changes, it will automatically be reset to the net name 
when you load the design into P-CAD Schematic. 

A sheet connector does not impact whether the net is local or global. For the net to be global, a 
sheet connector must be used in conjunction with a port. The port designates the net as global; the 
sheet connector provides the ability for cross sheet annotation. 

These sheet connector cross-reference zone locations can be summarized in a net index table. This 
table can be placed on a schematic sheet for reference. For information, see Net Index Tables (page 
111). 

Zone locations of global nets are automatically included in the Global Nets report. For information, 
see File Reports (page 177). 

Annotating Sheet Connectors 
When a net spans more than one schematic sheet, a sheet connector is a graphical indication that 
the net continues on another sheet. Using P-CAD Schematic’s zone intelligence, you can record the 
sheet on which the net is continued. The sheet connector can be annotated with the connecting 
sheet’s name and its zone location on that sheet.  

To annotate a sheet connector, follow these steps: 

1. Choose Options » Display. The Options Display dialog appears. 

2. Click the Miscellaneous tab. 

3. In the Sheet Connector Cross Referencing frame, select the Show Cross Referencing check 
box as shown in the following figure: 
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4. Select a text style for the cross-reference text from the Text Style list. 

5. Specify the desired X and Y Offset from the part origin to the beginning of the cross-reference 
text. 

6. Click OK to close the Options Display dialog. 

The title sheet border must be zoned to include alphanumeric zone locations in the reference, 
although the zones need not be displayed. 

When you choose to display cross-references, all sheet connectors on all sheets are annotated. If a 
net’s location is moved or if a sheet connector is added or deleted from the net, the sheet 
connector cross-references for all sheet connectors associated with that net are automatically 
updated. 

If updating the sheet connector cross-reference causes the annotation to fall outside the 
workspace, the annotation is relocated to its original offset point on the workspace. Subselect and 
drag the cross-reference text to move it. 

Originally the cross-reference annotations for a single sheet connector are organized in a column 
at the offset point. You can subselect the annotations and relocate them. The relocated annotations 
will be automatically rescreened based on the sheet name. The resequencing order is from left to 
right, then from top to bottom, as shown in the following example: 

Sheet1[A3] Sheet2[C5] Sheet3[H4] 
Sheet4[B2] Sheet5[D1] 
Sheet6[J4] 
Sheet7[K5] 
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Viewing Sheet Connector Properties 
To view sheet connector properties, follow these steps: 

1. Select a cross-referenced sheet connector. 

2. Open the Part Properties dialog choosing one of the methods: 

• Choose Edit » Properties. 

• Right-click and choose Properties from the shortcut menu. 

The Part Properties dialog appears, with the Sheet Connector tab selected: 

 

This tab lists the net name, sheet, and zone information of the selected sheet connector, and 
all sheet connectors belonging to the same net on other sheets.  

Jumping to Sheet Connectors 
You can jump to a sheet connector of the same net on another sheet:  

1. Select a sheet connector. 

2. Right-click and choose Properties from the shortcut menu. The Part Properties dialog appears. 

3. Select the sheet connector to which you want to jump in the Cross-referenced Sheet 
Connectors list. 

4. Click Jump. The focus of the window jumps to the selected sheet connector. 
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Net Index Tables 
A net index table summarizes the sheet connector cross-references in a design. This table can be 
placed on a schematic sheet as a reference of net locations. The following is a sample net index 
table: 

 

The sheet connectors must be cross-referenced between sheets in order to include zone 
information in a net index table. For details, see Annotating Sheet Connectors (page 108). 

When the nets are relocated or the sheet connector information of the current design is otherwise 
modified, the net index table should be updated to reflect the design changes. For instructions, see 
Updating Tables (page 118). 

You can also select a net index table and choose Edit » Properties. Through the Properties dialogs 
you can change a variety of object characteristics but not the table type or the design data 
contained within the table. With table properties, you can modify the table’s line width, name, and 
text style.  

A table is updated when its properties are modified. 

Placing a Net Index Table 
To place a table in a design, follow these steps: 

1. Choose DocTool » Place Table. The Place Table dialog appears. 

2. Select Net Index Table from the Table Type list. 



Chapter 6: Documentation Tools Note Tables 

112 P-CAD Schematic User’s Guide 

3. Type a name for the table in the Table Name box. The name of the table type appears in this 
box by default. 

4. Select a text style for the table from the Text Style list. 

5. Click OK to close the Place Table dialog. 

6. Click the workspace at the location at which you want to place the table. A table cannot be 
placed outside the workspace.   

7. (Optional) To place another table, click the workspace again. Then, repeat steps 2 - 6. 

8. To quit placing tables, choose Edit » Select or another menu command. 

Note Tables 
A note table contains any notes that you’ve added to your design. To learn how to place a notes 
table in a design, see Placing a Notes Table (page 113). 

Adding Notes to a Note Table 
To add notes to a note table, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Notes tab. 

3. Click Add. 

4. Type a note in the next available Note Text box. 

5. Click Close. 

After you add or delete revision notes to a table, you must update the table. For instructions, see 
Updating Tables (page 118). 

Importing Text Files as Notes 
To import a notes file, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Notes tab. 

3. Click Import. The Open dialog appears. 

4. Select the file to import and click Open. You return to the Design Info dialog. 

5. Click Close. 

Exporting Notes to a Text File 
To export a notes file, follow these steps: 
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1. Choose File » Design Info. The Design Info dialog appears. 

2. Click Export. The Save As dialog appears. 

3. Navigate to the directory in which you want to save the text file. 

4. Type a name for the text file in the File name box. 

5. Select Text Files (*.txt) from the Save as type list. 

6. Click Save. 

Placing a Notes Table 
To place a table in a design, follow these steps: 

1. Choose DocTool » Place Table. The Place Table dialog appears. 

2. Select Note Table from the Table Type list. 

3. Type a name for the table in the Table Name box. The name of the table type appears in this 
box by default. 

4. Select a text style for the table from the Text Style list. 

5. Choose the following options. 

• In the Note Numbering frame, choose Top to Bottom or Bottom to Top. 

• Enter a value in the Width of Note Numbering box. 

6. Click OK to close the Place Table dialog. 

7. Click the workspace at the location at which you want to place the table. A table cannot be 
placed outside the workspace.  

8. (Optional) To place another table, click the workspace again. Then, repeat steps 2 - 6. 

9. To quit placing tables, choose Edit » Select or another menu command. 

Power and Ground Tables 
A power table summarizes the power and ground nets in a schematic. This table can be placed on a 
schematic sheet for reference. The following figure shows you a power table: 
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The table includes the reference designator of all components that have power and ground pins. 
You can choose to include all pins, or restrict it to include hidden pins only. You can also restrict by 
reference designator prefix. 

The power table summarizes the reference designator, component type, component pattern, and 
the power and ground nets for the component’s power pins. 

Placing a Power Table 
To place a power and ground table in your design, follow these steps: 

1. Choose DocTool » Place Table. The Place Table dialog appears. 

2. Select Power Table from the Table Type list. 

3. Type a name for the table in the Table Name box. The name of the table type appears in this 
box by default. 

4. Select a text style for the table from the Text Style list. 

5. Choose the following options. 

• In the Pins to Include frame, choose Hidden Pins Only or All Pins. 

• In the Components to Include frame, choose Only RefDes Prefix or All Components. 

6. Click OK to close the Place Table dialog. 

7. Click the workspace at the location at which you want to place the table. A table cannot be 
placed outside the workspace.   

8. To quit placing tables, choose Edit » Select or another menu command. 

Revision Note Tables 
A revision block details the differences between versions of a design. An example revision block is 
shown as follows: 
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In P-CAD Schematic, a revision block is placed as a Revision Notes Table. To learn how to place a 
table in the design, see Placing a Revision Note Table (page 116). 

Adding Revision Notes to a Table 
To add revision notes to a table, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Revisions tab. 

3. Click Add. 

4. Type a revision note in the next available Note Text box. 

5. Click Close. 

After you add or delete revision notes to a table, you must update the table. For instructions, see 
Updating Tables (page 118). 

Importing Text Files as Revision Notes 
To import a text file as a revision note, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Revisions tab. 

3. Click Import. The Open dialog appears. 

4. Select the file to import and click Open. You return to the Design Info dialog. 

5. Click Close. 

Exporting Revision Notes to a Text File 
To export a notes file, follow these steps: 

1. Choose File » Design Info. The Design Info dialog appears. 

2. Click the Revisions tab. 

3. Click Export. The Open dialog appears. 

4. Select the file to import and click Open. You return to the Design Info dialog. 

5. Click Close. 
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Placing a Revision Note Table 
To place a table in a design, follow these steps: 

1. Choose DocTool » Place Table. The Place Table dialog appears. 

2. Select Revision Note Table from the Table Type list. 

3. Type a name for the table in the Table Name box. The name of the table type appears in this 
box by default. 

4. Select a text style for the table from the Text Style list. 

5. Choose the following options. 

• In the Note Numbering frame, choose Top to Bottom or Bottom to Top. 

• Enter a value in the Width of Note Numbering box. 

6. Click OK to close the Place Table dialog. 

7. Click the workspace at the location at which you want to place the table. A table cannot be 
placed outside the workspace.   

8. To quit placing tables, choose Edit » Select or another menu command. 

Spare Gate Tables 
A spare gate table summarizes the last used, unused, and spare gates in a design. This table can be 
placed on a schematic sheet to determine which components have all parts included in the design. 
The following figure shows you a sample of a spare gate table: 
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The last used and not used columns contain the last placed and the remaining unused reference 
designators for each reference designator prefix included in the design. The spare gate column 
includes the reference designator and section number of any unused gate, when at least one 
section of the multigate component is included in the design. 

Placing a Spare Gate Table 
To place a table in a design, follow these steps: 

1. Choose DocTool » Place Table. The Place Table dialog appears. 

2. Select Spare Gate Table from the Table Type list. 

3. Type a name for the table in the Table Name box. The name of the table type appears in this 
box by default. 

4. Select a text style for the table from the Text Style list. 

5. Click OK to close the Place Table dialog. 

6. Click the workspace at the location at which you want to place the table. A table cannot be 
placed outside the workspace.   

7. To quit placing tables, choose Edit » Select or another menu command. 

Working with Tables 
P-CAD Schematic gives you the ability to create and insert a variety of tables in your schematic 
design. Once you’ve placed a table in your design, you can modify and update the information 
using the procedures described in this section. 

Modifying Tables 
To modify a table, follow these steps: 

1. Select the table that you want to modify. 

2. Choose one of the methods to open the Table Properties dialog. 

• Choose Edit » Properties. 

• Right-click and choose Properties from the shortcut menu. 

3. (Optional) To change the table name, type a new name in the Table Name box. 

4. (Optional) To change the text style, select a style from the Text Style list. 

5. (Optional) To change the line width, type a new value in the Line Width box. 

6. If you are updating a Power Table, you can modify the following information. 

• In the Pins to Include frame, choose All Pins or Hidden Pins. 

• In the Components to Include frame, choose All Components or Only RefDes Prefix. 
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7. Click OK to close the Table Properties dialog. 

Updating Tables 
If you modify any of the data that is included in a table, you must update the table. To do this, 
follow these steps: 

1. Choose one of these methods to update tables: 

• Select one or more tables and choose DocTool » Update. 

• Select one table. Then, right-click and choose Update from the shortcut menu. 

• Choose DocTool » Update All to update all of the tables and diagrams in your design. 

2. A warning message appears to notify you that the update action cannot be undone. Click Yes 
to acknowledge this message. 

Reporting on Schematic Designs 
The report options in P-CAD Schematic give you the ability to choose which fields appear in a 
report, the sort order, as well other formatting options such as lines per page, headers, footers, etc. 
These options are saved with the design file when you quit P-CAD Schematic.  

Reports Available in P-CAD Schematic 
P-CAD Schematic provides you with a collection of standard reports to help you track and manage 
the schematic design process. The following reports are available: 

• Attributes Report  

• Bill of Materials Report  

• Global Nets Report 

• Last Used RefDes Report 

• Library Contents Report  

• Parts Location Report 

• Parts Usage Report. 

You can customize a standard report or you can create a custom report, based on one of the 
existing reports. For instructions, see Customizing a Standard Report (page 119) or Creating a 
Custom Report (page 120). 

Attributes Report 
The Attributes Report lists all of the design-level attributes that are assigned to the parts and nets in 
your schematic. The Attributes Report contains two sections: Component Attributes and Net 
Attributes.  
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For instructions, see Generating Reports (page 119). 

Bill of Materials Report 
The Bill of Materials Report lists the parts in your schematic diagram, as well as any attributes you 
have selected for inclusion in the report.  

To add attributes from a non-P-CAD source, click the Import Files button in the Customize Report 
dialog. For details on importing files, see the P-CAD Library Executive User’s Guide. 

The Count field is system-generated at the time the report is produced. Selection criteria cannot be 
applied to the Count field. 

Global Nets Report 
The Global Nets Report lists the sheets on which a net appears, for each global net in your 
schematic design. A global net is any net that includes a port, a power symbol, or a hidden power 
pin. It can consist of one or more ported subnets, subnets connected by power symbols, one or 
more hidden power pins with the same net name, or a combination of all the above.  

The sheet connectors must be cross-referenced between sheets in order to include zone 
information in a Global Nets report. For details, see Annotating Sheet Connectors (page 108). 

Last Used RefDes Report 
The Last Used RefDes Report lists the last used reference designator for each component type in 
your schematic design. 

Library Contents Report 
The Library Contents Report lists all of the components in any open libraries. To learn how to open 
a library, see Library Setup (page 325). 

Parts Location Report 
The Parts Location Report lists the reference designator, sheet number, and sheet location of each 
part in your schematic design. 

Parts Usage Report 
The Parts Usage Report lists all unused parts of multipart components in your schematic design. It 
can help you minimize the total number of components used in a design. 

Generating Reports 

Customizing a Standard Report 
To customize one of the standard reports provided with P-CAD Schematic, follow these steps: 

1. Choose File » Reports. The File Reports dialog appears. 

2. Select a report in the Reports to Generate list. 
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3. Click Customize. The Customize Report dialog appears. Notice that the title bar displays the 
report type. 

4. Set your custom report options as appropriate.  

5. Click OK to close the Customize Report dialog. 

After you customize a report, you can generate it. For instructions, see Generating a Report (page 
123). 

Creating a Custom Report 
When you create a custom report, you base it on a standard report and give it a unique name. To 
create a custom report, follow these steps: 

1. Choose File » Reports. The File Reports dialog appears. 

2. Select the report on which you want to base your custom report from the Reports to Generate 
list. 

3. Click Customize. The Customize Report dialog appears. Notice that the title bar displays the 
type of report you are customizing. 

4. Set your report options as appropriate. For instructions, see one of the following topics: 

• Setting Format Options (page 121). 

• Setting Data Selection Options (page 121). 

• Setting Sort Options (page 122). 

5. Click Add. The Report Configuration dialog appears: 

 

6. Type a name and file name extension for the custom report in the Enter Report Name box. For 
example, type: Digdemo.bom 

7. Click OK to return to the File Reports dialog. 

Your new report is listed by name in the Reports to Generate list. You can now generate the report 
output. For instructions, see Generating a Report (page 123). 

If you select and generate both the custom report and the one on which it was based, both results 
are output in a single file or report. To get individual outputs, generate each report separately. 
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Setting Format Options 
If you generate a report using the P-CAD Report or Separated List style format, you have various 
formatting options. To set these formatting options, follow these steps: 

1. Click the Format tab. 

2. If you are setting up the format for a Separated List, skip to step 6. Otherwise, continue with 
steps 3 - 7. 

3. Type a header and footer in the Header and Footer boxes. 

4. In the Page Format frame, select the following check boxes as appropriate: 

• Use Header: Includes the information you specified in the Header box. 

• Use Footer: Includes the footer information entered in the Footer box. 

• Design Info: Includes the information you entered in the File Design Info command and 
dialog. 

• Date/Page: Includes the current date and the page number. 

• Pagination: Allows you to create your own pagination (lines per page). 

5. In the Lines per Page box, type the number of lines you want printed on each page. 

6. Type a file name extension in the File Extension box. Each report has a file name extension that 
appears in this box by default. 

7. In the Separated List frame, choose one of the following option buttons: 

• Include Report Preface: Select this check box to include a report preface.  

• Include Column Headers: Select this check box to include column headers at the top of 
your report. 

To set the width of a single column, click the Selection tab. Next, choose a field from the 
spreadsheet. Then, click the Format tab and type a width for that column in the Column Width 
box. Columns are set to 20 characters in width by default. 

Setting Data Selection Options 
To set data selection options for your report, follow these steps: 

1. Click the Selection tab. 

2. Select a section from the Report Section list. This list is only available for the Attributes Report. 

3. In the Show column, select the check boxes that correspond to the fields you want to include 
in the report. 

4. To change the order of the fields in the list, select a field and click Move Up or Move Down. 
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5. If you can add attribute fields to a report, the Add Row button is available. Click this button to 
open the Select Attribute dialog. 

6. Select an attribute from the list and click OK. A row of data is added to the report spreadsheet 
in the Selection tab. 

7. To set report criteria for a row of data, enter information in the appropriate cells of the Criteria 
(And) and Or columns. To learn how to enter information in these fields, see Selecting Report 
Criteria (page 122). 

8. To add an Or column to the report spreadsheet, click Add Column. Then set additional report 
criteria. 

Setting Sort Options 
1. Click the Sort tab. 

2. Select a section from the Report Section list. This list is only available for the Attributes Report. 

3. In the Available Fields list, select the fields you want to include in the report.  

4. Add the field to the report using one of the following methods: 

• Select a field from the Selected Fields list and click Insert. P-CAD Schematic inserts the 
field above the field you select. 

• Click Append. The fields you want to include appear at the bottom of the Selected Fields 
list. 

5. In the Sorting Order frame, choose Ascending or Descending to define the sort order for the 
list. 

Selecting Report Criteria 
The following table shows the operators available for use in the Criteria (And) and the Or columns: 

 

Use this operator To perform this function 

= Exactly equal to 

If used with a wildcard operator, * or ?, this operator becomes literal. It 
searches for a set of characters with, for example, a question mark at the 
end. 

< Less than 

> Greater than 

<= Less than or equal to 

>= Greater than or equal to 

<> Not equal to 
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IsLike If used with a wildcard operator, IsLike means is similar to. For example, 
IsLike 5* could be 50, 510, 5, etc. 

If not used with a wildcard operator, IsLike is equivalent to =. 

IsNotLike If used with a wildcard operator, IsNotLike means is not similar to. For 
example, IsNotLike 5* could be 14 or 20 or 42, but not 50, 510, or 5. 

If not used with a wildcard operator, IsNotLike is equivalent to <>. 

Exist The attribute exists. 

NotExist The attribute does not exist. 

AnyValue The attribute exists and it has some value. 

NoValue The attribute exists, but it is assigned no value. 

 

Generating a Report 
After you’ve set up your custom report options, you can generate a report. To do this, follow these 
steps: 

1. Choose File » Reports. The File Reports dialog appears. 

2. In the Reports to Generate list, select the check boxes that correspond to the type of reports 
you want to generate. 

3. Click Filename. The Reports File Save As dialog appears. 

4. Navigate to the directory in which you want to save the report file. 

5. Type a name for the report file in the File name box. 

6. Select Report Files (*.*) from the Save As type list. 

7. Click Save. You return to the File Reports dialog. 

8. In the Report Destination frame, choose one of the following buttons: 

• Screen. Sends the output to a file and opens the file using the Notepad Utility. 

• File. Sends the output to a file. 

• Printer. Sends output directly to the printer without creating files. 

9. In the Style Format frame, choose one of the following buttons: 

• Separated List. Puts all data in character-separated format. This format can be imported 
into other spreadsheet and database programs. 

• P-CAD Report. Produces a report format with columns and spaces, etc. 

• If you choose Separated List, select a separator from the List Separator list. 
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The list separator character displayed in the box is used for both imported and exported files. 
The default character is your computer’s regional setting. 

10. Set any customized options for an individual report type. For instructions, see Customizing a 
Standard Report (page 119) or Creating a Custom Report (page 120). 

11. Click Generate Reports. 

Generating a Netlist  
With P-CAD Schematic, you can generate netlist that lists the components and nets in your design. 
Typically, a netlist is used by a printed circuit board editor, such as P-CAD PCB, to form the basis of 
your board design.  

To generate a netlist, follow these steps: 

1. Open a schematic design file. 

2. Choose Utils » Generate Netlist. The following Utils Generate Netlist dialog appears. 

 

3. Click Netlist Filename. The following Netlist File dialog appears. 

 

4. Navigate to the directory in which you want to save the netlist file. 

5. Type a name for the netlist file in the File name box. 
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6. Select Netlist Files (*.net) from the Save As type list.  

7. Click Save. You return to the Utils Generate Netlist dialog. 

8. In the Netlist Format list, select one of the following formats for your netlist: 

• P-CAD ASCII 

• Tango 

• FutureNet Netlist 

• FutureNet Pinlist 

• Master Designer 

• EDIF 2.0.0 

• Pspice 

• Xspice. 

The P-CAD ASCII format supports attribute passing. If you select this option, you may also 
select the Include Library Information check box. 

9. Click OK to generate the netlist. The netlist is saved with the filename and in the directory you 
specified. 
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CHAPTER 7 

DDE Hotlinks 

DDE Hotlinks provides a means of linking component and net highlight information between 
P-CAD Schematics and P-CAD PCB applications. This chapter includes the following topics: 

• Setting up the DDE Hotlinks Feature 

• Using DDE Hotlinks 

Setting up the DDE Hotlinks Feature 

About DDE Hotlinks 
The DDE Hotlinks feature gives you the ability to create a connection between two related design 
files created in separate P-CAD programs. With this feature, you can explore the relationships 
between designs when you run the following programs: 

• P-CAD Schematic and P-CAD PCB/Relay 

• P-CAD Schematic and P-CAD PCB Viewer 

With DDE Hotlinks, you can update information in one design and the feature automatically 
updates the same information in a related design. For example, you could apply the current 
highlight color to a part in a Schematic design and the DDE Hotlinks feature updates the related 
part in P-CAD PCB. Or, when you highlight a net in a PCB design, the DDE Hotlinks feature 
highlights the corresponding net in a related Schematic design. 

Enabling DDE Hotlinks 
To the DDE Hotlinks feature in P-CAD Schematic, follow these steps: 

1. Choose Options » Configure to open the Options Configure dialog. 
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2. Select the DDE Hotlinks check box. 

3. Click OK to close the Options Configure dialog.  

Selecting the Current Highlight Color 
To select the current highlight color, follow these steps: 

1. Choose Options » Display to open the Options Display dialog. 

2. Click the Colors tab. 

3. Click Highlight to open the color palette. 

4. Click a color in the palette. 

5. Close the palette. 

6. Click OK to close the Options Display dialog. 
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Using DDE Hotlinks 

Highlighting Parts 
To highlight parts so you can explore the relationships between parts in a Schematic and PCB/Relay 
design, follow these steps: 

1. Start P-CAD Schematic and open a .sch design file. 

2. Start P-CAD PCB and open a .pcb design file. 

3. Choose Edit » Parts to open the Edit Part dialog. 

 

4. Select a part in the Parts list box. 

5. Click Highlight. 

6. Click Close to exit the Edit Parts dialog box. The part remains selected in P-CAD Schematic and 
highlighted in P-CAD PCB/Relay. 

7. Click anywhere in the P-CAD Schematic workspace to cancel the selection of the. The part 
appears in the current highlight color. 

Unhighlighting Parts 
1. Choose Edit » Parts to open the Edit Part dialog. 

2. Select a part in the Parts list box. 

3. Click Unhighlight. 
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4. Click Close to exit the Edit Parts dialog box and to remove the highlight color from the part in 
both programs. 

5. Select a part in the P-CAD Schematic workspace. 

When you rest the mouse pointer over the parts in your design, a Data Tip appears. 

6. Right-click the part and choose Highlight from the shortcut menu. The part remains selected in 
P- CAD Schematic and the corresponding part becomes highlighted in P-CAD PCB/Relay. 

7. Click anywhere in the P-CAD Schematic workspace to cancel the selection of the part. The part 
appears in the current highlight color. 

8. Right-click the part again and choose Unhighlight from the shortcut menu. 

Highlighting and Unhighlighting Attached Nets 
To explore the relationship between the nets in a Schematic and PCB/Relay design, follow these 
steps: 

1. Select a part in P-CAD Schematic. 

2. Right-click and choose Highlight Attached Nets from the shortcut menu. In both programs, all 
attached nets become highlighted, included bus connections, junctions, ports, wires, and pins. 

3. Select the again. Then, right-click and choose Unhighlight Attached Nets from the shortcut 
menu. This removes the highlight color from all nets attached to the selected part. 

4. In P-CAD Schematic, choose Edit » Parts to open the Edit Parts dialog box. 

5. Select part U23 in the Parts list. 

6. Click Highlight Attached Nets. In both programs, all attached nets become highlighted, 
included bus connections, junctions, ports, wires, and pins. 

7. Click Close to exit the Edit Parts dialog box.  Notice that the nets appear in the current highlight 
color. 

8. Choose Edit » Unhighlight All to remove the highlight color from all of the objects. 

Highlighting Nets 
To highlight nets in a design, follow these steps: 

1. Choose Edit » Nets to open the Edit Nets dialog. 
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2. Select AD3 in the Net Names list box. 

3. Click Highlight. 

4. Click Close to exit the Edit Nets dialog box. 

Selecting All Highlighted Objects in a Design 
When you want to perform editing functions on a group of highlighted objects, follow these steps: 

1. Highlight one or more objects in your design. 

2. Choose Edit » Select Highlighted to select all of the highlighted objects in a design 

If a highlighted object is not selected when you choose Edit » Select Highlighted, open the 
Options Block Selection dialog and change your block selection criteria. 
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CHAPTER 8 

Verifying a Schematic Design 

P-CAD provides powerful Electrical Rules Checking (ECR) capabilities. The information contained in 
this chapter includes the following topics: 

• Configuring the ERC Feature 

• Using ERC Error Annotation 

Configuring the ERC Feature 

Setting up Checks and Severity Levels 
An electrical rules check verifies that your design does not violate the rules set up in the Utils 
Electrical Rules Check dialog.  

To set up these rules, follow these steps: 

1. Choose Utils » ERC to open the Utils Electrical Rules Check dialog. 
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By default, a file name for the ERC report automatically appears next to the Filename button. 

2. Click Filename to open the Electrical Rules Check Report dialog box. 

3. Change the name of the file in the File name box. 

4. Select the check boxes of your choice in the Design Rule Checks frame, to apply specific rules 
to the design for validation. 

5. Select the View » Report check box in the Report Options frame to automatically display the 
report when the validation process is complete. 

Before you click OK to start the validation process, you will set up the ERC report options and 
choose Severity Levels as described in the next lesson. 

6. Select all of the check boxes in the Design Rules Checks frame.  The following describes each 
option: 

• Single Node Nets: Reports all nets with only one node. 

• No Node Nets: Reports all nets with no nodes. 

• Electrical Rules: Reports incompatible pin types connected together. For example, two 
output pins connected together or an output pin connected to a power pin.  

• Unconnected Pins: Reports all pins that are not connected to any other pins (single node 
nets). This includes pins that are not connected to anything at all. 

• Unconnected Wires: Reports all wires that are unconnected (floating). An unconnected 
wire is one that is not attached to a pin. 

• Bus/Net Rules: Reports on nets only referenced once in a bus (i.e., a wire goes into a bus, 
but doesn't come out). 

• Component Rules: Reports on all components that are on top of other components. 

• Net Connectivity Rules: Reports on power net errors. This option is discussed in more 
detail later in this chapter. 

• Hierarchy Rules: Reports on module and link errors. Each module must have a link 
attribute with pins of matching electrical type and quantity. These module and link pins 
must be connected. All link pins must be placed within the design and have an attribute 
referencing a valid link component. 

7. Select the Annotate Errors check box to annotate all errors. 

8. Click Severity Level to open the Rules Severity Level dialog. 
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9. Select one or more rules in the list box. Then, change the severity level to Ignored. To do this, 
choose the Ignored button in the Severity Level frame.  

10. Click OK to return to the Utils Electrical Rules Check dialog. 

11. To summarize the errors you set to a severity level of Ignored, select the Summarize Ignored 
Errors check box. 

12. Click OK to validate the design. 

The system performs its Electrical Rules Checking according to the options you have specified.  

• ERC error indicators are created for you to display, select, and view if the severity level has 
been set to Error.  

• Rules with a severity level of Warning are written to the report but not annotated in the 
design.  

• The rules whose severity level was set to Ignored are not annotated in the design, but will 
be summarized in the report, since you selected the Summarized Ignored Checks check 
box. 

Every time you choose Utils ERC, all existing ERC error indicators are removed. 

Using ERC Error Annotation  
The lessons in this section explains how to use the ERC error annotation options. 

Finding ERC Errors 
To find ERC errors, follow these steps: 

1. Choose Utils » Find Errors to open the Find Errors dialog box. 



Chapter 8: Verifying a Schematic Design Using ERC Error Annotation 

136 P-CAD Schematic User’s Guide 

 

2. From the Categories drop-down list, select Net Connectivity. Information about the first error 
in that category appears in the description area. The last error you viewed remains in the 
description area until another error is requested. 

If your design has a number of errors, such as unconnected pins, and you do not want to see 
those errors when scrolling through the list of errors in the Find Errors dialog, check the 
Override – Don’t display this error again option. Conversely, you can choose to display only 
the errors that have overrides applied to them by enabling the Show Only Overrides option. 

3. View another error by using one of the following methods: 

• If you know the number of the error, enter it in the Error Number box and click Find. 
Information about that error appears in the description area. 

• You can scroll through the errors using the up and down arrows next to the Error Number 
box until you find the error you want to view. 

• Click Jump To and the error finder positions the cursor in the center of the error indicator 
in your design. 

Overriding Error Displays 
The display of overridden, annotated errors can be globally controlled. To do this, follow these 
steps: 

1. Choose Options » Display to open the Options Display dialog. 

2. Click the Miscellaneous tab. 

3. Select the Display Overridden Errors check box.  

When enabled, any error indicator whose display has been overridden will appear in the design as 
an inverted triangle. 

To hide overrides from view, clear the Display Overridden Errors check box in the Miscellaneous 
tab of the Options Display dialog. When the check box is enabled, an overridden error indicator 
appears as an inverted triangle in your design. 
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Block Selecting Error Indicators 
If you want to include ERC error indicators in a block selection,  

1. Choose Options » Block Selection to open the Options Block Selection dialog. 

2. Click Clear All to cancel the selection of check boxes in the Items frame. 

3. Select the ERC Errors check box in the Items frame. 

4. Click OK to close the Options Block Selection dialog box. 

Overriding ERC Errors 
Individual ERC error indicators can be removed from the design without being resolved when you 
override their display. You may want to hide errors such as unconnected pins when the errors will 
not be resolved and you do not want to see them in the design. 

To apply an override, follow these steps: 

1. Select an error. 

2. Right-click and choose Override from the shortcut menu. 

To remove an override from a selected error, right-click and choose Unoverride from the 
shortcut menu. 

Fixing and Deleting ERC Errors 
The recommended method for using ERC error annotation to fix design errors is as follows: 

1. Choose Utils » Find Errors to view the errors. 

2. Display an error you want to correct and go directly to it in the design by clicking the Jump To 
button. Continue resolving the errors in the design in this same manner until all errors have 
been fixed. 

3. Select an error indicator and press the DELETE key. You can delete the ERC error indicators 
from your design as they are resolved.  

4. Another way to delete ERC error indicators is to choose Utils » ERC; all existing error indicators 
are deleted, and the program flags only the remaining errors. Or you can leave the ERC errors 
on the sheet. The next time you choose the Utils » ERC command, all existing ERC error 
indicators will be removed automatically.  
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CHAPTER  9 

Printing a Schematic 

This chapter includes the following topics: 

• Setting up Printers and Plotters 

• Setting up Print Jobs. 

Setting up Printers and Plotters 
This section explains how to set up a printer or plotter in P-CAD Schematic. Before set up a print or 
plot job, you must install a printer or plotter on your system. For instructions, see your Windows 
documentation. 

Print Features 
Printing in P-CAD Schematic contains many useful features: 

• Flexible print options, where each sheet in a print job can be defined with unique printing 
options such as preset and custom scaling, print region, X and Y offset, and more. 

• Color options, where you can customize color output (if you are using a color printer). 

• Preview, where you can verify the layout of the output before sending to the printer. 

• Batch printing of multiple sheets. 

Selecting a Printer or Plotter 
To select the printer or plotter that you want to use from P-CAD Schematic, follow these steps: 

1. Choose File » Print Setup to open the Print Setup dialog.  
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2. Select a print device from the Name list. This list shows the printers and plotters that have been 
installed on your system. 

3. Select a paper size and paper source from the corresponding list boxes in the Paper frame. 

4. Choose Portrait or Landscape in the Orientation frame. 

5. Click the Properties button to open a dialog box in which you can specify other print 
parameters. Then, click OK to close the Properties dialog.  

Because print parameters are device-specific, the options in the Properties dialog depend upon 
the print device you selected. 

6. Click OK to close the Print Setup dialog box. 

You have selected a print device. You can now define your page setup options. 

Setting up Print Jobs 

Defining Image Options, Image Scale, and a Print Region 
For each sheet, you can scale your image to fit standard or custom size papers, define a print 
region, set horizontal and vertical offsets, display a title, and rotate the image. 

1. Choose File » Print to open the File Print dialog. 

2. Click Page Setup to open the Page Setup dialog. 
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You can set different print options for each sheet in a design. However, this procedure shows 
you how to define you page setup options for a single sheet.   

3. Select Sheet 1 in the Sheets list. 

4. Choose one of the buttons in the Image Scale frame to select an image scale to the selected 
sheet. 

Although you will not choose the Scale to Fit Page button in this tutorial, choosing this option 
would scale the  print region to fit on a single page. Page size is determined by your print 
driver. 

5. Select the Title check box in the Image frame to display a title around your design.  A title 
prints only if you have set one up with the Options Configure dialog. 

6. In this tutorial, you will define a print region in your design. To do this, clear the Sheet Extents 
check box to enable the other fields in this frame.  Then, click Define Region. The workspace 
appears.   

If you prefer to print the entire design, select the Sheet Extents check box in the Print Region 
frame and skip to step 7. Select this option only if you want to print the entire design. 

7. Hold down the left mouse button and drag the pointer across the workspace to draw a 
bounding outline around the desired print region. 
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8. Right-click or press ESC.  An information message appears to confirm the coordinates of the 
selected print region. Click Yes to accept these coordinates. 

9. A message appears, warning you to apply these changes to the print job/sheet. Click OK to 
acknowledge this message. 

The Page Setup dialog reappears.  In the Print Region frame, the X and Y coordinates display 
for the lower left and upper right corners of the print region. 

10. Click Update Sheet to apply these changes to the print job/sheet. 

11. Click Close to close the Page Setup dialog and return to the File Print dialog. 

You have set up your page options.  Next, you will set up your print options.  For instructions, see 
Setting your Print Options (page 142). 

Setting your Print Options 
With the Print Options dialog, you can set up various print options. This dialog contains two tabs: 
Colors and Miscellaneous. To use this dialog, do the following: 

1. Choose File » Print to open the File Print dialog. 

2. Click Print Options to open the Print Options dialog.   

3. Click the Colors tab.  

 

4. Choose your print colors using one of these methods: 

• If you have a color printer, click a command button in the Item Colors or Display Colors 
frame. When the color palette appears, click a color swatch and then close the palette. 
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• If you have a black and white printer, click the Defaults button.  This turns all colors to 
monochrome. We recommend that you use the defaults setting to avoid undesirable 
output when color settings are converted to grayscales. 

5. In the Junction Size frame, choose the Small, Large, or User radio button.  

Notice that you can enter a value in the Size text box only when you choose the User radio 
button. You can enter a value in inches, centimeters, etc.  However, the value must be less than 
or equal to 100 mils. 

6. Click the Miscellaneous tab.  In this tab, you set the size or ERC error indicators and reference 
points. In addition, you set other miscellaneous print options as shown in the following figure: 

 

To use the default settings, click the Defaults button. 

7. In the ERC Errors frame, choose one of these buttons: 

• Show. Enables the display of ERC errors in your printed design. 

• Hide. Disables the display of ERC errors in your printed design. 

• No Change. Keeps the current display setting. 

8. Select these check boxes in the Miscellaneous frame:   

• Draft Mode:  Enables a thin outline of the design components in the printed output. 

• Thin Stroked Text:  Prints text in its stroke mode. 
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• Display Open Ends:  Prints an indicator showing any open ends. 

• Display Part Gate Number:  Enables the printing of Part Gate Numbers. 

• Print Highlighted Wires & Busses as haloed: Distinguishes any wires or buses that are 
currently highlighted as haloed lines. 

9. Click OK to return to the File Print dialog. 

You have set up your print options.  Next, you will learn how to preview your print job. 

Previewing a Print Job 
Before you print a document, you can view it in a print preview window. To open this window, click 
the Print Preview button in the File Print dialog. The print preview window contains these options: 

• Print: Sends the current print jobs to the printer. 

• Next Page: Displays the next page of the print output in the Print Preview window. 

• Prev Page: Displays the previous page of the print output in the Print Preview window. 

• Two Page/One Page:  Allows you to view two pages at a time or only one page. 

• Zoom In: Zooms in on the center area of the current page. Use the scroll bars to move to the 
desired viewing region. 

• Zoom Out: Zooms out on the current page. 

• Close: Closes the Print Preview window. 

Generating Printouts 
After you have defined your page setup and print options, return to the File Print dialog to print the 
sheets.  The following shows you how: 

1. In the File Print dialog, click Set All to enable all the sheets in the design. 

2. Click Generate Printouts to print the highlighted sheets. 

Now that you’ve generated a printout, you will learn how to use the override settings on print a job.  

Override Settings 
You have two options for overriding your print settings.  You can print your current schematic 
window, or you can scale the print area to fit on a single page.  The following lessons guide you 
through each option. 

Printing the Current Window 
To print the current window, follow these steps from your design workspace: 

1. Use the View commands to select the desired window in Schematic. For example, zoom in on 
an area in your current design. 



Setting up Print Jobs Chapter 9: Printing a Schematic 

P-CAD Schematic User’s Guide 145 

2. Choose File » Print.  The File Print dialog appears. 

3. Highlight the sheet to print in the Sheets list box.   

4. In the Override Settings frame, select the Current Window check box. 

Selecting the Current Window check box overrides the Print Region settings for the current 
sheet’s print job. 

5. Click Generate Printouts.  P-CAD Schematic prints out the print job with the region defined by 
the current window.  The printout may be on one page, or on many pages, depending on the 
size of the window and the printer settings. 

Scaling to Fit Page 
When printing, you can override the page settings for all sheets so that the print output is scaled to 
fit on a single page. To print scaled print jobs, follow these steps: 

1. Choose File » Print to open the File Print dialog. 

2. Select the Scale to Fit Page check box in the Override Settings frame. 

3. Select the desired print job(s) in the Sheets list.  To define a new sheet print job, click the Page 
Setup button and follow the instructions in Defining Image Options, Image Scale, and a Print 
Region (page 140). 

4. Click Generate Printouts.  P-CAD Schematic prints out the contents of the selected sheets.  The 
print output is scaled to fit exactly on a page.  The page size is set by the print driver. See your 
print driver’s options for the page sizes. 

The File » Print Scale to Fit Page overrides the scale settings for all print jobs.  To scale an individual 
sheet’s print job to fit a single page, use the Scale to Fit Page check box in the Page Setup dialog. 
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CHAPTER 10 

Design Technology Parameters 

The Design Technology Parameters (DTP) feature gives you the ability to capture design 
information, including net class definitions and design rules. With this feature, you can create and 
save design information in a DTP file, which can then be used in any P-CAD design. This chapter 
includes the following topics: 

• Introducing the DTP Feature 

• Opening and Creating DTP Files 

• Working with DTP Files 

Introducing the DTP Feature 

What is DTP? 
The Design Technology Parameters (DTP) feature gives you the ability to capture design 
information, including net class definitions and design rules. With this feature, you can create and 
save design information in a DTP file, which can then be used in any P-CAD design.  

About DTP Files 
A design technology parameters file (*.dtp) gives you the ability to create and save information 
that is associated with various aspects of a P-CAD design, such as Class to Class rules, net class 
definitions, and more. 

The data in a DTP file is organized in a hierarchical structure with the following levels: Files, 
Groups, Sections, and Items.  As shown in the following figure, the Digdemo.dtp file contains a 
group named Digdemo. Within this group are several Sections, such as Class To Class Rules, Global 
Rules, and so on. Each section contains a collection of items. For example, the Global Rules section 
contains two items: Bottom and Top. 
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When you create a design, you can also create a DTP file and organize the information as 
appropriate. You can then build, browse, and modify the hierarchy of your DTP file. To do this, use 
the options in the Design Technology Parameters dialog shown in the previous figure. 

Opening and Creating DTP Files 
The procedures in this section familiarize you with the DTP file creation process.  

Opening a DTP File 
To create a new DTP file or to open an existing file, follow these steps: 

1. Start P-CAD Schematic and open a design file. For example, open Digdemo.pcb, which is 
located in the Demo folder of your P-CAD installation directory. 

2. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. The system path and DTP file name appears next to the Technology Filename button. 

Creating a DTP File 
To create and save a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog.  
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2. Click Technology Filename to display the Open dialog. 

 

3. Type a name for your DTP file in the File name box. For example, type: Digdemo1 

4. Select Design Technology Parameter Files (*.dtp) in the Files of type list. 

5. Click Open to display the following Open dialog: 
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6. Click Yes. The new DTP file name appears next to the Technology Filename button in the 
Design Technology Parameters dialog, as shown in the following illustration. 

 

When you create a DTP file, only the Filename appears in the list box. To add groups, sections, 
and items, see one of the following sections: Adding a Group (page 150), or Adding a Section 
(page 151). 

7. Click Close to the exit the Design Technology Parameters dialog. 

Adding a Group 
To add a group to a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 
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2. Open the DTP file that you want to modify by clicking the Technology Filename button. For 
example, open Digdemo1.dtp. 

3. Click New Group to open the New Group Name dialog. 

4. Type a name in the New Name box. For example, type: Group1 

 

5. Click OK to close the New Group Name dialog. The new group name appears in the DTP tree, 
as shown in the following figure: 

 

6. Click Close to exit the Design Technology Parameters dialog. 

Adding a Section 
To add a section to group in a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Open the DTP File of your choice by clicking the Technology Filename button. For example, 
open Digdemo1.dtp. 
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3. Select a group in the DTP tree. For example, select Group1. The label on the New Group 
button changes to New Section. 

4. Click New Section to open the New Section Type dialog. 

 

5. Select the check boxes that correspond to the sections you want to create. 

6. Click OK to close the New Section Type dialog. The selected sections appear in the DTP tree, 
as shown in the following figure: 
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Adding an Item 
To add an item to a section in a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Open the DTP File of your choice by clicking the Technology Filename button. For example, 
open Digdemo1.dtp. 

3. Select a section in the DTP tree in the Design Technology Parameters dialog. For example, 
select Net Class Definitions. The label on the New Section button changes to New Item. 

4. Click New Item to open the Enter Net Class Name dialog. 

 

5. Type a name in the New Name box. For example, type: ITEM1 

6. Click OK to close the Enter Net Class Name dialog. The new item appears in the appropriate 
section of the DTP tree. 

Working with DTP Files 
Once you created a DTP file, you can browse and modify the contents of that file. In addition, you 
can update a file with information from your active design, as well as copy DTP data to your design. 
This section contains procedures that show you how to perform these actions and more. 

Browsing the Contents of a DTP File 
To browse the contents of a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Click Technology Filename to display the Open dialog. 

3. Navigate to the directory in which the DTP file is located. For example, navigate to the Demo 
folder in the P-CAD installation directory. 

4. Select the DTP file that you want to open from the list. For example, select Digdemo.dtp. 

5. Click Open. The DTP filename appears next to the Technology Filename button. 

If a .dtp file is read-only, the Read-only check box is selected and the term read-only appears 
next to the filename. You cannot modify or delete a read-only DTP file. 
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6. Expand a group or section by clicking the + sign. When a group or section is expanded, the - 
sign appears.  

7. Collapse a group or section by clicking the – sign. When a group or section is collapsed, a + 
sign appears. 

Use the options in the Design Technology Parameters dialog to set up the design technology 
parameters, copy parameter data to or from a design, view or modify data properties, and browse 
or modify the file’s hierarchy. To learn more about these options, see the appropriate section in 
this chapter.  

Renaming a Group or Item 
To rename a group or item, follow these steps: 

1. Select a group or item in the DTP tree. 

2. Click Rename to open the Rename Net dialog. 

 

3. Type a name in the New Name box. 

4. Click OK to close the Rename Net dialog. The new name appears in the DTP tree. 

Deleting DTP File Information 
To delete information from a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Select a group, section or item in the DTP tree. 

3. Click Delete to open a Warning dialog. 

 

4. Click Yes to delete your selection. If you are deleting a group or section, all objects within that 
group are deleted. This action cannot be undone. 
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Viewing Item Statistics 
To the statistics of an item in a DTP file, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Select an item in the DTP tree to make the Statistics button active. Click Statistics to open an 
Item Statistics dialog. 

 

3. Click OK to close the Item Statistics dialog.  This dialog contains information about 
modifications made to the item. 

Updating a DTP Group with Design Information 
To update a group in a DTP file with information from the active design, follow these steps from the 
Design Technology Parameters dialog: 

1. Select a group in the DTP tree. For example, select Digdemo, as shown in the following figure. 
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2. Click Update From Design to open the Select Section Type dialog. 

3. Select the check boxes that correspond to the sections you want to update. For example, select 
all of the check boxes, as shown in the following figure. 

 

4. Click OK to close the Select Section Type dialog. If the update. If the update is successful, the 
following message appears. 

 

5. Click OK to close the Information message box. 

You can also update individual sections in a DTP file by selecting a section from the DTP tree 
and clicking Update from Design. 

Copying DTP Data to a Design 
To copy DTP data to a P-CAD design, follow these steps: 

1. Choose File » Design Technology Parameters to open the Design Technology Parameters 
dialog. 

2. Select a group or section in the DTP tree. For additional information about your options, see 
Setting up Attribute Handling for Copy Actions (page 158). 
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3. Click Copy To Design. If the information that you want to copy will change any existing 
information, the Overwrite Warning dialog appears. 

 

4. Click one of the following buttons to acknowledge the message: 

• Click Yes to overwrite the information specified in the Message dialog. 

• Click Yes to All to overwrite the information listed in the Message dialog, as well as any 
other potential warnings associated with the section. 

• Click No to keep the information as is. 

• Click Cancel to cancel the copy action.  

If the selected item does not exist in the design, it is added automatically. Net rule and net 
class definition items are not created if they do not exist in a design.  
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Setting up Attribute Handling for Copy Actions 
You can copy sections to a design: Class To Class Rules, Net Class Definitions, Net Class Rules, and 
Net Rules. When you select one of these sections in your DTP tree, the options in the Attribute 
Handling on Copy frame become active as shown in the following figure: 

 

The following describes each option in the Attribute Handling On Copy frame: 

• Replace Design Attributes: Choose this button to replace the rules associated with an item in a 
design with the rules associated with an item in the DTP file. 

• Merge Attributes: Choose this button to merge the rules associated with the item in the DTP 
file with rules associated with the item in the design. When you choose this button, P-CAD 
Schematic favors the rules of the DTP file over the rules of the design. 

For information about item-specific options, see Item-Specific Information About Copy Actions 
(page 158). 

Item-Specific Information About Copy Actions 
The following information explains how P-CAD Schematic supports the copy action for various 
objects in a DTP tree. 

Class to Class Rules. If a design has two net classes, you can merge or replace the class to class 
rules. If a class to class rule doesn’t already exist, a rule is created. To merge or replace class to class 
rules, choose the appropriate button in the Attribute Handling on Copy frame before you click the 
Copy to Design button. 

• Replace Design Attributes: Choose this option to place a design’s class-class rules with the 
rules from the Class to Class Rule Item. 

• Merge Attributes: Merges the rules of the Class to Class Rule Item with the design’s class-to- 
class rules, favoring the Class to Class Rule Item rules over the design. 

If both net classes do not exist in the design, a class to class rule is not created. 

Layer Rules. Layer rule items cannot be updated from P-CAD Schematic. 

Layer Sets. Layer set items cannot be updated from P-CAD Schematic. 

Net Class Definitions. If a net class of the same name exists in the design, its net members are 
replaced with the net members defined by this Item. The net class rules are not changed. If a net 
class of the same name does not exist in the design, it is not created. 

Net Class Rules. If the net class already exists in the design, you have a choice of two options: to 
merge or to replace the net class rules. To choose between the merge or replace options, choose 
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the corresponding option in the Design Technology Parameters dialog before clicking Copy to 
Design. 

• Replace Design Attributes: Replaces a design’s net class rules with the rules from the Net Class 
Rule Item. 

• Merge Attributes: Merges the rules of the Net Class Rule Item with the design’s net class rules, 
favoring the Net Class Rule Item rules over the design. 

The net class, with the Net Class Rule Item rules, is created if it does not already exist in the 
design.  

Net Rules. If the net already exists in the design, you have a choice of two options: to merge or to 
replace the net rules. To choose between the merge or replace options, choose the corresponding 
option in the Design Technology Parameters dialog before clicking Copy to Design. 

• Replace Design Attributes: Replaces a design’s net rules with the rules from the Net Rule Item. 

• Merge Attributes: Merges the rules of the Net Rule Item with the design’s net rules, favoring 
the Net Rule Item rules over the design. 

If the net does not already exist in the design, the net, with its Net Rule Item rules, is not 
created.  

Pad Styles. Pad style items cannot be updated from Schematic. 

Via Styles. Via style items cannot be updated from Schematic. 

Modifying Item Properties 
To view or modify the properties of an item in a DTP tree, follow these steps: 

1. Choose File Design Technology Parameters to open the Design Technology Parameters dialog. 

2. Select an item in the DTP tree. 

3. Click Properties to open an item-specific dialog.  

Properties of certain items (pads, vias, global rules, layer sets) cannot be accessed in P-CAD 
Schematic. In such cases, the Properties button is shaded and not available. 

When you modify properties of items in your parameters file using Properties, the changes are 
made immediately to the file. If you want to create a new design technology file based on an 
existing file, first make a copy of your original design technology file, saving the copy under the 
new name. Then, modify the design technology file copy.  

If the design technology parameters file is read-only, P-CAD Schematic discards any changes you’ve 
made. 

Class to Class, Net Class, and Net Rules Properties 
To open the Attributes dialog, select a class to class rule, net class rule, or net rule item in the File 
Design Technology Parameters tree. Then, click Properties. 
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The two-column spreadsheet in the Attributes dialog shows the collection of net attributes. Within 
the collection, each attribute’s name and value appear in the column. 

• Adding an Attribute: To add an attribute, click Add to open the Place Attribute dialog. Add a 
pre- defined attribute by choosing first the Category and then the desired attribute. To add a 
new attribute, select {user-defined} in the Name list and type the name for the attribute. Type 
the Value for the attribute and click OK, and the attribute is added to the table. Complete 
instructions on using the Place Attribute dialog are found in Place Commands (page 259). 

• Editing Attribute Properties: To edit an attribute’s properties, select an attribute from the table 
and click the Properties button (or double-click the attribute) to open the Place Attribute 
dialog.  

• Deleting an Attribute: Highlight an attribute in the table and click Delete.  

• To launch a reference link: When the special attribute Reference, whose value is a reference 
link, is added to the item, you can select the Reference attribute and click Launch to start a 
program or to launch Internet Explorer to reference additional information about the item. 

Global Layer Rules Properties 
P-CAD Schematic does not support Layer rule properties. 

Layer Set Properties 
P-CAD Schematic does not support Layer set properties. 
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Net Class Definition Properties 
To open the Net Class Definition dialog, select a net class definition item in the File Design 
Technology Parameters tree. Then, click Properties. 

 

Use this to create net classes and add nets to the class. For details, see Options Net Classes (page 
309). 

To add a net class definition: 

1. Type a layer name in the Net Name box. 

2. Click Add. 

3. Repeat the process until you have added all nets to the class. 

Pad Style Properties 
Pad style properties are not available from Schematic. 

Via Style Properties 
Via style properties are not available from Schematic. 
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CHAPTER 11 

Simulating a Circuit Design 

With the Mixed-Signal Circuit Simulator you can perform an array of mixed-signal simulations on 
your design. Simulations are run directly from your schematic (including multi-sheet designs), 
providing an easy way to investigate the performance of a circuit throughout the design cycle. 

The analog/mixed-signal simulation engine uses an enhanced version of Berkeley SPICE3f5/XSPICE, 
allowing you to accurately simulate any combination of analog and digital devices without manually 
inserting D/A or A/D converters. This “mixed-signal” or “mixed-mode” simulation is possible 
because of the inclusion of accurate, event-driven behavioral models for digital devices, including 
TTL and CMOS. 

Due to the complexity of digital devices it is generally not practical to simulate them using 
standard, non-event-driven, SPICE instructions. For this reason, the simulator includes a special 
descriptive language that allows digital devices to be simulated using an extended version of the 
event-driven XSPICE. The digital devices included in the simulation-ready schematic libraries are 
modeled using the Digital SimCode language. 

The simulator allows unlimited circuit-level analog simulation and unlimited gate-level digital 
simulation. Circuit size is only limited by the amount of RAM you have in your system. 

The Mixed-Signal Circuit Simulator runs in a separate application, called the Design Explorer. When 
you select Run from the new Simulate menu in the P-CAD 2002 Schematic Editor the schematic is 
analyzed and an XSPICE netlist is generated. This netlist is automatically opened in the Design 
Explorer, a simulation performed, and the results displayed as waveforms in the Design Explorer's 
oscilloscope-like waveform display window.  

The types of analyses supported include: AC small signal, Transient, Noise and DC transfer, Monte 
Carlo analysis, parameter and temperature sweeping, and Fourier analysis. Analyses can be 
configured in either the P-CAD 2002 Schematic Editor, or in the Design Explorer. Refer to the on-
line help for more information on using the circuit simulator. 
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Using the P-CAD Circuit Simulator 

Configuring the Schematic 
Before you can successfully simulate your circuit you need to ensure that your schematic contains 
all the necessary information. In general, the following rules must be adhered to before you will be 
able to run any of the available simulations: 

• All components and parts in the schematic must properly reference a simulation device model. 

• You must place and wire up suitable signal sources to provide drive to the circuit during 
simulations. 

• The circuit must include a Ground net. 

• If necessary, you must set the initial simulation conditions of the circuit using the .IC and .NS 
devices.  

Selecting simulation-ready schematic components 
To perform simulation analyses, all parts placed on your schematic must contain special simulation-
specific information which tells the simulator how these components are to be treated. In general 
this means that schematic parts must include a reference to an appropriate SPICE device model. 
This information is defined as attributes of the component symbol. 

The easiest way to create a schematic for simulation is to use simulation-ready parts from the new 
P-CAD 2002 component libraries. There is a complete Library Index included with the new P-CAD 
2002 component libraries (Library Index.XLS). Refer to the New features.WRI file for details on 
how to use this index to locate simulation-ready components. In most cases you simply place a 
simulation-ready component, set the value (such as the resistance) and simulate. Each component 
includes all the information required for SPICE simulation, including designator prefix information 
and pin mapping for multiple-gate components. 

SPICE supports many extended features that allow you to more accurately model component 
behavior, for example specifying the operating temperature of a transistor. This extra information is 
entered into the pre-defined SimFields in the Attributes tab of the components' Properties dialog 
after the component has been placed on the schematic sheet.  

Setting up the Simulation Analyses 
To select which simulation analyses are enabled, select Simulate » Setup from the P-CAD 2002 
Schematic Editor menus. The Analyses dialog will pop up, the required analyses are enabled in the 
General tab of the dialog.  

When you run a simulation, data for all enabled analyses will be calculated and displayed in the 
simulation waveform viewer window. Click the Help button in this dialog for information about 
each type of analysis, and for information on the other options in the Analyses Setup dialog.  
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Running a Simulation 
Once the required analyses are enabled and the parameters of the enabled analyses are configured 
in the appropriate tab in the dialog, you are ready to run the simulation.  

To run a simulation: 

1. Choose Simulate » Setup from the main menu in P-CAD Schematic to setup the analysis. The 
Design Explorer window opens and the Analyses Setup dialog displays. 

 

Alternatively, choose Simulate » Run and the simulation is run straight away. You can also run 
the analysis  from the Design Explorer menus when the simulation netlist is the active 
document. 

2. Select the criteria for the simulation n the appropriate tab of the Analyses Setup dialog and 
click Run Analysis. The Circuit Simulator runs the analysis. Refer to the online help for more 
information about the setup dialog. 

An Xspice netlist is generated from the design and placed in the same directory as the schematic. 
This is then imported into a design database (.ddb file) of the same name as the schematic and 
the database opened in the Design Explorer 99 SE. The netlist that was generated in P-CAD 
Schematic is then loaded and passed to the simulation engine. 
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The first time a simulation is run on a design, a default configuration file (.cfg) will be created. 
When you make any changes in the Analyses Setup dialog, they are stored in this .cfg file and 
subsequently applied to future simulations of that particular design. The setup information in the 
configuration file is added to the netlist when the simulation is run. No setup information is 
contained in the netlist generated by P-CAD. 

You can also generate the Xspice netlist from your P-CAD Schematic design, using the Utils » 
Generate Netlist command. You are then free to import the netlist into Design Explorer 99 SE and 
run the simulation at a later stage, from the Mixed-Signal Circuit Simulator. 

Information can also be directly added into the netlist, by manually editing the .nsx file using the 
Design Explorer's Text Editor. Upon running the simulation, a dialog will appear, giving you the 
option to use the netlist file as is, or to ignore the setup information that has been added and use 
the configuration file instead. 

The attributes that must be specified in order to make a part simulatable, are all part of the 
Simulation category in the Place Attribute dialog / Attribute Properties dialog. These attributes 
consist of: SimType, SimModel, SimFile, SimPins, SimNetlist, SimDefaults and SimFields 1-16. 

The .ddb file is created if it does not already exist (in the same directory as the .sch and .nsx 
files). If it does exist, the netlist file generated will replace the previous version of the same name. 

The XSpice netlist exported directly from Schematic does not contain any setup information. This 
information is added to the netlist from the configuration file, to create a modified netlist which is 
stored external to the .ddb, when the simulation is run. Upon completion of the simulation, the 
modified netlist file is deleted. 

If a simulation is already running (started from the Mixed-Signal Circuit Simulator) and you start a 
simulation with the same netlist from P-CAD, then the netlist will be imported to the .ddb, but 
simulation will not proceed because a simulation is already running. This is the same for a  
simulation running on a different netlist. 

Working with Simulation Waveforms 
When you run a simulation, a simulation results document is created and displayed in the 
waveform analysis viewer. 

When the waveforms appear the results of each analysis performed during the simulation run are 
displayed on separate tabs (these tabs are at the bottom of the window), click on a tab to examine 
the results of that analysis, as shown below. 
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The waveform viewer window operates much like an oscilloscope, simply adjust the scale options 
in the Browse SimData panel to show exactly the part of the waveform that you would like to 
examine. The Waveform analysis pane also includes measurement cursors for taking 
measurements directly from the waveforms. 

Click on the appropriate tab at the bottom of the window to display the results for that type of 
analysis. Operating Point results are displayed as a list of voltage, current and power calculations 
for nodes or devices. 

Troubleshooting simulation problems 
When a circuit will not simulate you must identify if the problem is in the circuit, or the process of 
simulation. To troubleshoot simulation problems, read the topics listed in the Simulation 
troubleshooting topics listed in the on-line help and work through the suggested points, trying one 
at a time. 

Sometimes during a simulation a message will be displayed reporting errors or warnings. These 
messages are saved in a text document (DesignName.ERR). 

Warning Messages  
Warning messages are not fatal to the simulation. They generally provide information about 
changes that SPICE had to make to the circuit in order to complete the simulation. These include 
invalid or missing parameters, and so on. Digital SimCode warnings may include information such 
as timing violations (tsetup, thold, trec, tw, etc.) or significant drops in power supply voltage on 
digital components. Note that valid simulation results are normally generated even if warnings are 
reported. 

Error Messages 
Error messages provide information about problems that SPICE could not resolve and were fatal to 
the simulation. Error messages indicate that simulation results could not be generated, so they 
must be corrected before you will be able to analyze the circuit. 
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CHAPTER 12 

File Commands 

Using the File Commands 
File commands allow you to open, save, and print designs and output reports in P-CAD Schematic. 
Most of the File commands cannot be undone: once an action is taken, it cannot be reversed using 
the Undo command 

File New 
Choose File » New to open a new, untitled design window. The File » New command clears the 
styles, sheet definitions, and sheet sizes for the new design. All design parameters are returned to 
their default settings. 

File Open 
Choose File » Open to open a file the P-CAD Schematic window. When you choose this command, 
the Open dialog appears. In this dialog, you can choose the directory and filename of the file you 
want to open. 
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Notice that the default file name extension in the Files of Type list is *.sch. This file name 
extension applies to binary P-CAD Schematic designs as well as ASCII files. Other file name 
extensions include: 

• .s01 to open Tango Series II ASCII files. 

• .cfg to open PCAD CFG files. 

To learn more about the options in the Open dialog box, see your Windows documentation. To 
learn how to open files in P-CAD Schematic, see Opening Design Files (page 21). 

File Close 
Choose File » Close to close the currently active design window. If the design has been changed 
but not yet saved, you are asked whether or not you want to save your changes before closing. If 
you have opened more than one design window, the next window will become the active window. 
If you close the last open design, a new, untitled design window appears. 

File Save 
Saves the changes to the active design and creates a backup file (.bak). When you choose File » 
Save, the file remains open so you can continue working on it, and a backup file is created. The file 
name and location are unchanged by this command.  

Saving a File with ECOs 
To save a file that has ECOs attached, follow these steps: 

1. Choose File » Save. Pending Engineering Change Orders (ECOs) must be appended to an ECO 
file or discarded when a design file is saved. If there are pending ECOs, the following dialog 
appears: 

 

2. The ECO filename appears at the top of the dialog. It is the last used ECO file. To change it, 
click ECO Filename. 

3. Type a file name in the File name box, or select a file from the list area. Click Save to return to 
the Save ECOs dialog. 
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4. In the Comments box, type any comments that can help document the ECOs. 

5. To append ECOs to the ECO file, click Append ECOs to File. 

6. To discard ECOs, click Discard ECOs. Once discarded they cannot be recovered. 

For more information on ECOs, see the following sections: 

• Utils Record ECOs (page 338) 

• Utils Import ECOs (page 339) 

• Utils Export ECOs (page 340) 

Saving an ASCII File 
If a P-CAD ASCII file type was selected in the File Type list box in the File Save dialog, a P-CAD 
ASCII file is generated instead of a P-CAD binary file. 

File Save As 
Choose File » Save As to save a copy of the active design. When you save a copy of the design, you 
can specify a unique file name and location to save the file. This command also creates a backup 
file (.bak). You can either name a new file or save an existing file to a new name.  

When you choose this command, the File Save As dialog appears. In this dialog, choose the folder 
and type the new filename. The Save in list displays the current folder and any files in that folder. 
The File name box lets you type or select a file name with the extension specified in the Save as 
Type list box. The default file name extension is .sch. This extension applies to P-CAD Schematic 
designs as well as ASCII files.  

Saving a Copy of a File  
To save a copy of a file, to a different name or location, follow these steps: 

1. Choose File » Save As to open the Save As dialog. 

2. Type a name for the file in the File name box.  

3. If the current folder is not appropriate, then navigate to the appropriate directory in which you 
will save the file.  

4. Make sure the correct file name extension appears in the Save As Type list box. 

5. Click Save to save the file as you have specified. 

6. If there are pending ECOs, you are prompted to save them. For detailed instructions, see File 
Save (page 170). 
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File Print 
Choose File » Print to print one or more sheets in your current schematic design. When you 
choose this command, the File Print dialog appears.  

 

From the File Print dialog, you can create print settings for all of the sheets in a design, or you can 
create custom print settings for each sheet. When you close this dialog, your settings become part 
of the design file.  

The File Print dialog contains the following options: 

• Sheets (list). Shows all of the sheets in your active design. Choose one or more sheets from this 
list. 

• Set All (button). Click this button to select all sheets in the Sheets list box. 

• Clear All (button). Click this button to cancel the selection of all sheets in the Sheets list box. 

• Page Setup (button). Click this button to open the Page Setup dialog. For more information, 
see Page Setup Dialog (page 173). 

• Print Options (button). Click this button to open the Print Options dialog. For more 
information, see Print Options Dialog (page 174).  

• Generate Printouts (button). Click this button to send your current print job to the printer. 

• Tile Sheets (check box). Select this check box and click Print Preview to display all sheets of the 
schematic on your screen. The sheets are resized and arranged side-by-side so that all are 
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visible and none overlap. When you print with this option selected, the tiled sheets are output 
to a single printed page. 

• Print Preview (button). Click this button to view your design in a print preview window. 

• Minimum Line Width (spin box). Select or type the minimum desired printed line width. 

Override Settings Frame 
Current Window. Select this check box to print only what appears in your active window. For 
example, if you are zoomed in on your design, select this check box to print only the area in view. 

Scaling to Fit Page. Select this check box to override the page scale settings for all sheets. For 
example, if you select this box the print output for each sheet is adjusted to fit on one page. 

Page Setup Dialog 
To open the Page Setup dialog, click Page Setup in the File Print dialog. 

 

The Page Setup dialog contains the following options: 

• Sheets (list box). Select one or more sheets from the list to define page setup options. After 
you select your print options, click Update Sheet  

• Update Sheet (button). Change any print options and then click this button to update the 
sheet’s print options.  

• Close (button). Click this button to return to the File Print dialog. 
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Image Options Frame 
Rotate (check box). Select this check box to rotate the printed image clockwise by 90 degrees.  

Title (check box). Select this check box to print the design title with your design. To assign a title to 
a design, use the Options Configure dialog. Clear this check box to omit the title block from the 
printout. 

X Offset and Y Offset (boxes). Type a value to offset your printout horizontally or vertically by that 
value. The default unit is the value set in Options Configure. You can override the default units by 
entering the units with the value (e.g., mil, mm, in). 

Print Region Frame 
Sheet Extents (check box). Select this check box to print the entire design. Notice that the Lower 
Left Corner and Upper Right Corner boxes are not active when this check box is selected. Clear this 
check box to define a print region. 

Define Region (button). Choose this button to define a print region. The Page Setup dialog is 
hidden and the design window is displayed. Click and hold the left mouse button to define a 
selection window. Click the right mouse button to return to the Page Setup dialog. 

Lower Left Corner/Upper Right Corner (value box). Manual alternative to the Define Region button. 
Type the lower left and upper right limits of the desired print region. 

Image Scale Frame 
User Scale Factor (button). Choose this button to increase or decrease the size of the print job by a 
specific factor. The value you enter affects the X axis and Y axis equally. For example, 0.100 reduces 
the output by a factor of 10, while 10.00 increases the output by a factor of 10.  

Scale to Fit Page (button). Choose this button to scale the print job to fit on a single page. When 
selected the User Scale Factor, X offset, and Y offset boxes are not active. 

Print Options Dialog 
To open the Print Options dialog, click Print Options in the File Print dialog. This opens the Print 
Options dialog. Like the Options Display dialog, this dialog contains both a Colors tab and a 
Miscellaneous tab. 

Colors Tab 
The following figure shows you the options in the Colors tab. To learn about these options, see 
Options Display (page 297). 
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The Colors tab contains the following options: 

Default (button). Click this button to restore the default color scheme for your printed output. 

Item Colors Frame 
To select a color for an item, click the corresponding button in this frame. When you do, a color 
palette appears. Choose a color from the palette by clicking the appropriate button. The palette will 
automatically close.  

Display Colors Frame 
To select a color for a display item, click the corresponding button in this frame. When you do, a 
color palette appears. Choose a color from the palette by clicking the appropriate button. The 
palette will automatically close. 

Junction Size Frame 
• Small (option button). Choose this option to use the small junction size in the printed output. 

• Large (option button). Choose this option to use the large junction size in the printed output. 

• User (option button). Choose this option define a custom junction size for the printed output. 
Then, enter a value in the User box. 

• User (box). When you choose the User button, enter a value to define a custom junction size 
for the printed output. Your entry can be in inches, centimeters, etc., as long as the value is 
between 0 - 10 mm. 
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Miscellaneous Tab 
The following figure shows you the options in the Miscellaneous tab. To learn about these options, 
see Options Display (page 297). 

 

The Miscellaneous tab contains the following options: 

ERC Errors Frame 
• Show (button). Choose this button to show ERC errors in the workspace. 

• Hide (button). Choose this button to hide the display of ERC errors in the workspace. 

• No Change (button). Choose this button to keep the current display setting. 

• Size (text box).Type a value in this box to set the size of ERC errors. Your entry can be in inches, 
centimeters, etc., as long as the value is between 0 - 10 mm. If you do not choose a size, the 
default is 100 mil. 

Miscellaneous Frame 
• Draft Mode (check box). Select this check box to show these two items in your design: (1) a 

thin, single- pixel outline for pads, vias, and text. (2) a segmented and outlined representation 
of arcs, lines, and any line segment objects such as, polygons, cutouts, etc. Draft mode 
improves redraw speed and helps you view segment overlaps. 
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• Thin Stroked Text (check box). Select this check box to show text in thin line mode. Clear this 
check box to display text in regular mode. 

• Display Open Ends (check box). Select this check box to show open ends on unconnected pins 
and wires. Open ends appear as open squares, and no longer appear when a positive 
connection is made. 

• Display Part Gate Number (check box). Select this check box to show a part’s reference 
designator gate number. You can also use the Print Options dialog to show or hide the gate 
number in your hardcopy. The options are independent of each other, so you can show the 
gate number on screen for editing, but hide it from your hardcopy at the same time. 

• Print Highlighted Wires and Busses as Haloed (check box). Select this check box to distinguish 
any wires or buses that are currently highlighted in your Schematic as haloed lines.  

File Print Setup 
Choose File » Print Setup to view a list of installed printers. This command also lets you to set the 
current printer. You can also change device-specific parameters. When you choose File » Print 
Setup, a dialog similar to the one in the following figure appears. 

 

To learn about the options in this dialog, see your Windows and printer documentation. 

File Reports 
Choose File » Reports to generate various reports. P-CAD Schematic provides you with a collection 
of standard reports to help you track and manage the schematic design process. For information on 
a specific report, see Reporting on Schematic Designs (page 118). 

When you choose File » Reports, the following File Reports dialog appears: 
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The File Reports dialog contains the following options: 

• Filename (button). Click this button to select a design file. By default, the name of the active 
design file appears here. Any report settings defined in this dialog apply only to the file that 
appears in the Filename area. This is also the file to which reports are saved and stored. 

• Delete (button). Click this button to remove a custom report from the design. You cannot 
delete any predefined reports. 

• Customize (button). Click this button to open the Customize Report dialog. For details on the 
fields in this dialog, see Customize Report Dialog (page 179). To learn how to customize 
reports, see Customizing a Standard Report (page 119). 

• Set Defaults (button). Click this button to restore the default settings for P-CAD Schematic. 

• Set All (button). Click this button to select all of the reports in the Reports to Generate list. 

• Clear All (button). Click this button to cancel the selection of all reports in the Reports to 
Generate list. 

• Generate (button). Click this button to generate the selected reports. 

Reports to Generate Frame 
This list contains a collection of standard reports to help you track and manage the schematic 
design process. To generate a report, select the appropriate check box. For details on each report, 
see Reporting on Schematic Designs (page 118). 
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Report Destination Frame 
• Screen (button). Choose this button to send the output to a file and open the file using 

Notepad. 

• File (button). Choose this button to send the output to a file. 

• Printer (button). Choose this button to sends the output directly to the printer without creating 
files. 

Report Origin Frame 
X and Y coordinates (boxes). By default, the report origin is 0,0, which represents the lower left 
corner of the design. To offset the report origin, enter an X and Y coordinates in the appropriate 
boxes. Coordinates printed in the report output indicate their position relative to the designated 
coordinates. Report origins are printed in the first line of the output report in the standard P-CAD 
Report format. 

Style Format Frame 
The Style Format you select determines which customization options are available.  

• Separated List (button). Choose this button to place all data in character-separated format. This 
format can be imported into other spreadsheet and database programs. 

• List Separator (list). If you choose Separated List, select the character you want to use as the 
separator. The separator that appears in the box is used for imported and exported files. P-CAD 
Schematic uses the character defined in your Windows Regional Settings by default. 

• P-CAD Report (button). Choose this button to produce a report format with columns and 
spaces, etc. When you choose this button, you can gain access to most of the options in the 
Format tab of the Customize Report dialog. 

Customize Report Dialog 
To open the Customize Reports dialog, select a report from the Reports to Generate list and click 
Customize. When the dialog appears, the Format tab is selected by default. In addition, the type of 
report you selected appears in the title bar.  

Format Tab 
Use the options in this tab to set up the page format of your report. Depending on the style format 
of your report (i.e., P-CAD Report or Separated List) different options are available in this tab. The 
following figure shows you the Format tab. 
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• Header (box). Type a report header. This box is only available when you choose the P-CAD 
Report style format. 

• Footer (box). Type a report footer. This box is only available when you choose the P-CAD 
Report style format. 

Page Format Frame 
If you choose the P-CAD Report style format, you can select one of the following check boxes to 
enable the corresponding page format option:  

• Use Header. Includes the information you specified in the Header box. 

• Use Footer. Includes the footer information entered in the Footer box. 

• Design Info. Includes the information you entered in the File Design Info command and 
dialog. 

• Date/Page. Includes the current date and the page number. 

• Pagination. Gives you the ability to create your own pagination (lines per page). 

• Lines per Page: Type the number of lines you want printed on each page. This box is only 
available when you choose the P-CAD Report style format 

• Column Width: Enter a value in this box to set the width of a single column. To do this, click 
the Selection tab. Next, choose a field from the spreadsheet. Then, click the Format tab and 
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type a width for that column in this box. Column width is set to 20 characters by default. This 
box is only available when you choose the P-CAD Report style format 

• File Extension: This box displays the default file name extension for the selected report. You 
can also type a new extension if desired. This box is available with the P-CAD Report and 
Separated List style formats. 

Separated List Frame 
• Include Report Preface (check box). Select this check box to include a report preface. This box 

is only available when you choose the Separated List style format. 

• Include Column Headers (check box). Select this check box to include column headers at the 
top of your report. This box is only available when you choose the Separated List style format. 

Selection Tab 
The following figure shows you the Selection tab. 

 

• Report Section (list). Select a report section from this list. This option is only available with the 
Attributes report. 

• Field (column). Lists the fields specific to the selected report. 

• Show (column) Displays the selected fields in the report. Unchecked fields do not appear in 
the report output. 
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• Criteria (And) (column). Contains the selection criteria used to filter the report data. To learn 
how to enter information, see Selecting Report Criteria (page 122). 

• Or (column). Type additional selection criteria here if necessary. To learn how to enter 
information, see Selecting Report Criteria (page 122). 

• Add Column (button). Click this button to add an Or column to the report spreadsheet. 

• Add Row (button). Click this button to add a row of data to the report spreadsheet. This button 
is only available when you can add attribute fields to the report. When you click this button, 
the Select Attribute dialog appears. 

• Move Up (button). Click this button to move the selected row of data up one position. 

• Move Down (button). Click this button to move the selected row of data down one position. 

• Add Row (button). Click this button to add a row of data to the spreadsheet. 

• Remove Row (button). Click this button to remove a row of data from the spreadsheet. You 
cannot remove a row of predefined data from the report spreadsheet. 

Sort Tab 
The following figure shows you the Sort tab. 

 

• Available Fields (list). The list of fields in the selected report. 

• Selected Fields (list). The fields used to sort the data, the order in which the sort is applied and 
the field’s sorting order, (A) for Ascending or (D) for Descending, are displayed in the Selected 
Fields list. 
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• Insert (button). Click this button to move a field from the Available Fields list and insert it 
above the selected field in the Selected Fields list. 

• Append (button). Click this button to move a field from the Available Fields list to the bottom 
of the Selected Fields list. 

• Remove (button). Click this button to move a field from the Selected Fields list to the Available 
Fields list. 

Sorting Order Frame 
• Ascending (button). Choose this button to sort report data in ascending order. 

• Descending (button). Choose this button to sort report data in descending order. 

File Design Info 
Choose File » Design Info to enter design information, review design statistics, and query/modify 
design attributes and fields. When you choose this command, the Design Info dialog appears. 

General Tab 
Click the General tab to view basic file information about the active design. The options in this tab 
are read-only.  

 

• Filename. Displays the name and file name extension of the schematic design. To place this 
field in a design, choose Place Field and select Filename. 
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• Location. Shows where the design is located on your computer or network. 

• Size. Displays the size of the design file. 

• Created. Shows the date the file was created. 

• Modified. Shows the date and time the file was last modified. To place this field in a design, 
choose Place Field and select Modified Date. 

• Accessed. Shows the date and time the file was last viewed 

• Attributes Frame 

• To modify the attributes shown in this frame, you must change the design file properties in 
Microsoft Windows. For more information, see your Windows documentation. 

• Read-Only (check box). A check mark in this box indicates that the design has been saved as a 
read- only file. 

• Hidden (check box). A check mark in this box indicates that the design is hidden, which means 
that you cannot see or use it unless you know the filename. 

• Archive (check box). A check mark in this box indicates that the file should be backed up. 

• System (check box). A check mark in this box shows that the design has been marked as a 
system file.  

Fields Tab 
Click the Fields tab view a list of all the fields that can be placed in a design. To learn how to add 
fields to this list or to place a field in a design, see Fields and Field Sets (page 103). 
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• Field Set (list box). Select a field set from this list. For information on field sets, see Fields and 
Field Sets (page 103). 

• Field Sets (button). Click this button to add or modify a field set. For information, see Adding a 
Field Set (page 106). 

• Name/Value (spreadsheet). The Name column lists all fields that can be placed in the design. 
The Value column lists any values assigned to the field. 

• Add (button). Click this button to open the Field Properties dialog. You use this dialog to add a 
name and value to the fields list. 

• Properties (button). Click this button to open the Field Properties dialog. You use this dialog to 
view or modify properties associated with a field. 

• Delete (button). Select a user-defined field from the list and click this button to delete if from 
the list. 

Field Properties Dialog 
To open the Field Properties dialog, click the Add or Properties button in the Design Info dialog. 
This dialog contains the following options: 

• Name (text box). Enter a name for the selected field. This field is only available for user-defined 
fields. 

• Value (text box). Enter a value for the selected field. 

For details about using Fields and Field Sets, see Fields and Field Sets, (page 103). 

Attributes Tab 
Click the Attributes tab to view and modify design-level attributes: 
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• Name/Value (spreadsheet). Displays a list of attributes that have been added to the design, as 
opposed to a component or net. 

• Add (button). Click this button to open the Place Attribute dialog. For details about this 
function and a complete listing of attributes, see Place Attribute (page 279). 

• Delete (button). Select an attribute from the Name/Value spreadsheet and click this button to 
remove the attribute from the design. 

• Properties (button). Select an attribute from the Name/Value spreadsheet and click this button 
to open the Attribute Properties dialog. 

• Launch (button). Select a Reference link from the attributes list and click this button to open 
the program associated with the link, or to launch Internet Explorer and go to the website 
associated with the link.  

Notes Tab 
Click the Notes tab to add design or drawing notes that can later be inserted in a design as a Notes 
field or Notes table: 

 

The Notes tab contains the following options: 

• Field Set (list box). Select a field set from this list. For information on field sets, see Fields and 
Field Sets (page 103). 

• Field Sets (button). Click this button to add or modify a field set. For information, see Adding a 
Field Set (page 105). 
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• Number of Notes (data field). Shows the total number of notes that have been added 

• Note Text (text box). Click Add and then type new notes or modify the notes that appear in this 
box. Or, modify the notes that appear here. 

• Annotation: Select one of the following annotation markers from this list: box, circle, triangle, 
or none. The following figure shows you what each annotation looks like: 

 

• Add (button). Click this button to enter notes or to add a note to the end of the list. 

• Delete (button). Place the text insertion point in one of the Note boxes. Then, click this button 
to remove that note. 

• Import (button). Click this button to import a note from an ASCII text file. To learn more about 
importing notes, see Importing Text Files as Notes (page 112). 

• Export (button). Click this button to export a note to an ASCII Text file. To learn more about 
exporting notes, see Exporting Notes to a Text File (page 112). 

Revisions Tab 
Click the Revisions tab to add, import, and export revision notes. Revision notes are used 
specifically to document changes between drafts of a design. 

 

For details about the dialog box and its options, see Notes Tab (page 186). 
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Statistics Tab 
Click the Statistics tab to design statistics for the current design. The information in this tab is read- 
only. 

 

File Design Technology Parameters 
Choose the File » Design Technology Parameters command to view design data such as net class 
definitions and design rules. When you choose this command, the File Design Technology 
Parameters dialog appears. The information in this dialog is stored in a design technology 
parameters file (*.dtp), which contains data that can be updated or copied to any P-CAD design. 

Design Technology Parameters Dialog 
When you choose the File » Design Technology Parameters command, the following File Design 
Technology Parameters dialog appears. 
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• Technology Filename (button). Click this button to display the Open dialog, from which you 
can choose the folder and filename of the file you want to open or create. 

• System Path (field). The field displays the system path to the active DTP file. 

• Read-only file (check box). If a .dtp file is read-only, this check box is selected and the term 
“read-only” appears next to the filename. To make a .dtp file read-only, select this check box. 
If a .dtp file is read- only, you cannot update it with data from a design, modify an item’s 
properties, rename an item, or delete an item. 

• DTP tree (directory list box). The contents of the open parameters file appear as a tree 
structure, or hierarchy, in the Design Technology Parameters dialog. You can browse the tree 
to view its contents. Also, you can highlight groups, sections, or items in the tree to select them 
for copying to a design, editing properties, and completing other functions described in this 
section. The tree structure allows you to view your entire file at various levels of detail by 
expanding or collapsing the branches of the tree. Groupings containing collapsed levels are 
shown with a + sign. To expand the grouping, simply click the +. Expanded groupings are 
shown with a – sign. To collapse the grouping, simply click the – sign. 

• Update From Design (button). The Update From Design button allows you to add information 
from your current design to the design technology parameters file.  

• Copy to Design (button). The Copy to Design function allows you to modify your current 
design using data contained within your design technology parameters file.  
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• Properties (button). This button allows you to view and modify an item’s properties. When you 
highlight an item in the design technology parameters file tree and click Properties, an item-
specific dialog appears 

• New Group (button). Select the DTP filename in the tree and click this button to add a new 
group to your DTP file.  

• New Section (button). Select a group from the DTP tree and click this button to create a new 
section in your DTP file.  

• New Item (button). When you highlight the filename in the tree, click this button to create a 
new item in your DTP file.  

• Rename (button). Select a group or item from the DTP tree and click this button to rename the 
selected object. You cannot rename sections with this button.  

• Delete (button). Click the Delete button to delete objects from the tree. 

• Statistics (button). Click the Statistics button to view statistics about the DTP file. When you 
click this button, the Statistics dialog appears. This dialog contains information about 
modifications made to the item. 

Attribute Handling on Copy Frame 
• Replace Design Attributes (button). Replaces a design’s rules with the rules from the design 

technology parameter file item. 

• Merge Attributes (button). Merges the rules of the design technology parameter file item with 
the design’s rules, favoring the rules of the design technology parameter file item over the 
design. 

File DXF In  
DXF (Drawing Interchange Format) files generated using AutoCAD Version 9.0 through 14 or other 
conforming CAD programs can be opened in P-CAD Schematic. Using this command, you can 
create dimensions, board outlines, manufacturing instructions, artwork, logos, etc., and then 
import the resulting DXF file into P-CAD Schematic.  

Opening a DXF File 
To open a DXF file in P-CAD Schematic, choose the File » DXF In command. The File DXF In dialog 
appears as shown in the following figure:  
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DXF Filename 
Click the DXF Filename button to open the Open dialog where you can navigate to the desired file. 

Sheet Name/Number 
The name and number of the sheet where the DXF items are placed when imported. If the sheet 
name contains any AutoCAD reserved keywords, a syntax error occurs which causes the file load 
to abort. Rename the layer in AutoCAD to work around this limitation. 

View Log File Upon Completion 
Select the View Log File Upon Completion check box to display the log file when the import is 
complete. 

DXF Units 
The DXF Units section of the File DXF In dialog provides the ability to choose which units will be 
used to apply proper scaling when loading the DXF file. Select the appropriate option to set the 
unit for inches (inch), centimeters (cm) or millimeters (mm). 

Locate DXF Origin 
The P-CAD Schematic workspace uses positive X and Y coordinates. Since DXF items can be placed 
at negative X and Y coordinates, you may have to direct P-CAD Schematic to adjust the position of 
your imported DXF geometry. In the File DXF In dialog, select a method of translation to positive 
coordinates in the Locate DXF Origin radio box.  

• Absolute Workspace Origin: If your DXF geometry is positioned only at positive coordinates, 
select Absolute Workspace Origin. No coordinate translation is made.  

• Relative Grid Origin: Loads the DXF geometry so its origin is placed at the Relative Grid Origin 
of your workspace. The Relative Grid Origin is specified in the Options Grids command.  

• Auto Adjust to Workspace: Automatically adjusts the placement of your DXF geometry into 
positive coordinates.  
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When you import data into P-CAD Schematic from a DXF file, and you enable the Auto Adjust to 
Workspace option, P-CAD Schematic automatically translates the position of the lower left extent 
of the DXF file data into the positive P-CAD Schematic workspace. The DXF data’s lower left extent 
is the coordinate defined by the EXTMIN variable in the header section of the DXF file. If the 
EXTMIN variable is absent from the DXF file, then P-CAD Schematic automatically calculates a 
suitable solution based on the extents of the geometry in the DXF file. 

It is suggested that you set the current grid to a uniform value consistent with the grid of your DXF 
design. This grid spacing optimizes the on-grid placement of items. Set your current grid in the 
Options Grids dialog before importing your DXF file.  

If DXF geometry items still fall outside the P-CAD workspace, a warning is written to the log file and 
the items are not imported. Your DXF geometry can fall outside the workspace if the translated 
items are still positioned at negative coordinates or if the geometry is larger than the workspace 
size. If the geometry is larger than the workspace size, use the Options Configure command to 
increase your workspace size and import the DXF file again. 

Importing a DXF File 
To import a DXF file with the correctly positioned geometry: 

1. Click the DXF Filename button to open the Open dialog.  

2. Type a file name in the File name box, or navigate to the directory where the file is located. 

3. Select the appropriate Locate DXF Origin option button on the File DXF In dialog. 

4. From the File DXF In dialog, type a sheet name or use the one selected for you. The sheet name 
is used to create a sheet in P-CAD Schematic onto which all the DXF items are placed. After the 
DXF items have been translated and placed onto the new sheet, these items are equivalent to 
other P- CAD primitives. The new lines, arcs, text, and polygons can be modified as usual. 

5. Click OK. 

A progress indicator shows the status of the DXF translation. Some items supported in the DXF 
language cannot be translated for use by P-CAD Schematic (see list below). Errors and warning 
messages are placed in a report file, which you may view at the end of the translation. 

Items Supported for Translation 
The following items and features are supported for translation: 

Header Variables 
The AutoCAD® state variables are grouped together at the top of the file in the HEADER section. 
Supported variables are listed and described below, with default values in parentheses: 

 

$ACADVER The AutoCAD® drawing database version number (must be 9.0 or 
higher.) 

$ANGBASE The angle zero direction. The DXF coordinate system is rotated by 
this angle. (0) 
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$ANGDIR The angular orientation: 1 = clockwise;  

0 =  counter clockwise. (0) 

$MIRRTEXT Mirror text if non zero. (0) 

$TEXTSIZE Default text height. 

 

Tables 
DXF In supports LTYPE and STYLE tables. 

Blocks 
The only entries in the BLOCKS section that are supported are the dimension blocks. All 
dimensions that are translated come from this section. 

Entities 
The majority of a DXF file is made up of entities. These include lines, arcs, text, block insertions and 
others. Only two-dimensional entities are supported; z-axis values are ignored. All block insertion 
entities, except dimensions, are ignored. Information embedded in the entities for color are also 
ignored. 

 

LINE DXF LINE entities have infinitesimal width. They are translated into 
P-CAD lines of 10 mil. 

ARC DXF ARCs are translated into P-CAD arcs of 10 mil. 

CIRCLE DXF CIRCLEs are translated into P-CAD arcs with a sweep angle of 
360 degrees and a 10 mil width. 

POLYLINE  DXF POLYLINEs are a sequence of possibly tapered, straight and 
curved lines that are connected end-to-end. These may be open or 
closed. P-CAD does not support tapering and only supports normal 
2-D (unflagged) DXF vertices. POLYLINEs are translated into P-CAD 
arcs and lines with a thickness equal to the initial POLYLINE 
thickness. 

LWPOLYLINE DXF LWPOLYLINEs are translated into P-CAD arcs and lines with a 
thickness equal to the initial LWPOLYLINE segment thickness. 

MTEXT Same as TEXT except it handles multiple lines and supports Bold 
and Italic styles. 

VERTEX Vertices define DXF POLYLINEs. When translated, they become the 
defining vertices of the translated P-CAD item. Only normal 2-D 
DXF vertices are supported (no spline-fit, curve-fit, 3-D mesh, or 
other special flags). 
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SOLID DXF solids are filled three or four sided polygons. They are 
translated into P- CAD polygons. Four sided solids that form a 
“Complex” polygon will be ignored. 

TRACE DXF traces are lines with thickness that can be filled or unfilled. 
They are treated the same as DXF solids and are translated into 
polygons. 

TEXT DXF text is translated into P-CAD text. Oblique angle text is not 
supported. The font used for translation when a direct match 
cannot be made is the P- CAD default font. Due to the difference in 
fonts, translated text strings may be of different total width than the 
DXF version. The bar over barred text may not align exactly with the 
text. 

 

The following is a specific (but not comprehensive) list of items that are not supported: 

• All BLOCKS, except the dimension blocks. 

• SHAPE, ATTDEF, and ATTRIB entities. 

• 3DLINE and 3DFACE entities. 

• Curve- or spline-fit vertices or meshes for POLYLINE and VERTEX entities. Tapering POLYLINEs 
are also not supported. 

• Oblique angle text and font are not supported for TEXT entities. Font is supported for True 
Type text. 

• Three-dimensional entities and coordinates; thickness for all entities will be ignored, and only 
the first two values of a coordinate-triplet will be used. 

• Dashed and dotted lines are converted to the P-CAD thin width. 

• Color values for individual entities. Color values for entities will depend on the P-CAD 
primitive and layer to which the entity is translated. 

DXF In Notes 
The following is a list of notes that are important or useful when using the DXF In command: 

• The EXPLODE command in AutoCAD® can be used to transform blocks into individual entities. 

• An important item to be translated from a DXF file is the dimension. AutoCAD® creates a new 
dimension block every time a dimension is moved, edited, or altered in any way. The user 
should use the PURGE command to eliminate any unreferenced copies of the dimension 
blocks created by AutoCAD®. The user should then output the design to DXF format 
immediately after the PURGE command, before editing or modifying dimensions. 

• Text fonts and styles are more accurately translated from AutoCAD® to P-CAD when the style 
has been defined prior to entering text. 
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File DXF Out 
Choose File » DXF Out to create DXF (Drawing Interchange Format) files of your Schematic designs. 
These files can then be transferred to AutoCAD® and other mechanical CAD packages. The output 
is compatible with AutoCAD® Version 9.0 or later. 

Creating a DXF File 
To create a DXF file, follow these steps: 

1. Open a schematic design. 

2. Choose File » DXF Out. The following File DXF Out dialog appears. 

 

3. Click DXF Filename. The following File DXF Out dialog appears. 
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4. Type a name in the File name box and select the folder in which you want to save the file. Make 
sure DXF Files (*.dxf) is selected in the Save As Type list. 

5. Click Save. You return to the File DXF Out dialog. 

6. In the Sheets list, select the sheets you want to output. Each sheet is output to a separate DXF 
layer. 

You can click Select All to select all of the sheets in the design, or click Clear All to cancel the 
selection of all sheets in the design. 

7. In the Output Mode frame, select the Draft check box to output in draft mode. 

If you selected specific objects in the design before choosing the File DXF Out command, you 
can output only those objects by selecting the Selected Objects check box. 

DXF polylines are normally used for all lines, wires, arcs, pins, and buses. Solids are normally 
used for polygons. Polylines are filled lines with thickness. When you select the Draft check 
box DXF outputs arcs, lines, and circles instead of polylines, and polygon outlines instead of 
DXF solids. Draft mode produces smaller files that process faster, but the drawings are not 
technically accurate since the lines have no width and areas are not filled. 

8. To include title sheets in the DXF file, select the Include Title Sheet check box. The title sheets 
must be displayed in the design before they can be output to DXF.  

To display title sheets in a design, select the Display Title Sheets check box in the Options 
Configure dialog. 

9. Select the Include True Type Fonts check box to output true type text. Clearing this check box 
gives you the ability to export a DXF file that is compatible with Revision 9 DXF. True Type 
Fonts are compatible only with Revision 14 DXF.  

10. In the DXF Units frame, choose Inch, Cm or Mm. 

11. Click OK to generate the DXF output file. All selections are saved in the design file. While the 
file is generating, the Status line indicates progress by displaying the current layer being 
output. While the file is being generated, you right-click or press ESC to cancel the operation. 

DXF Out normally tries to produce as faithful a picture as possible: lines and arcs have 
thickness. Draft mode does everything with DXF LINEs, ARCs, and CIRCLEs, which have no 
thickness: lines and arcs become thin and polygons become outlines. 

DXF Output Considerations 
• Line Styles: The solid, dashed, and dotted line types are supported for output. The line styles 

are mapped as follows: P-CAD Dashed to AutoCAD Dashed, P-CAD Dotted to AutoCAD Dot 
and P-CAD Solid, Thick or User to AutoCAD Continuous. These specifications may not match 
those of your CAD package for lines of the same style. 
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• Sheets: P-CAD sheets become DXF layers with the same name. DXF substitutes the underscore 
for unsupported characters such as spaces to maintain compatibility with AutoCAD naming 
conventions. 

• Blocks: DXF blocks are used to combine individual entities into a common unit, to be treated 
as a whole by the CAD package, analogous to a part or component. Blocks are used, where 
possible, to make CAD processing easier, and to reduce the size of the DXF file. For example, a 
part block has the name of the reference designator; exploding a part block produces text (for 
attributes) and pin blocks. These in turn can be exploded. 

• Polygons: P-CAD polygons are also represented as blocks containing a collection of three- or 
four-sided solids. In this way they can be processed as a unit. 

• Lines: When not in Draft mode, lines consist of a straight polyline and two round endcaps. 
Note that due to limitations in how blocks are scaled in DXF, lines are not blocks; the endcaps 
and polylines are separate from one another. In Draft mode, lines become DXF LINEs with no 
endcaps. 

• Arcs: When not in Draft mode, arcs consist of a curved polyline and two round endcaps. Note 
that due to limitations in how blocks are scaled in DXF, arcs are not blocks; the endcaps and 
polylines are separate from one another. In Draft mode, arcs become DXF ARCs with no 
endcaps. 

• Text/Mtext: True Type font text styles are created and included in the DXF file. P-CAD stroke 
fonts text strings are converted into DXF text strings of the same height, rotation, mirroring, 
and justification; the AutoCAD® STANDARD font is used. Note that due to the difference in 
fonts, translated text strings may be of different total width than in P-CAD. The bar over barred 
text may not align exactly with the text. Mtext is output if True Type is selected. 

• Pins: A Schematic pin is composed of DXF POLY LINE, LINE, and ARC entities; POLY LINES are 
not used in Draft mode. 

• Wires: These become DXF 2D POLYLINEs. 

• Buses: When not in Draft mode, these become POLYLINEs; in Draft mode, they are DXF LINEs. 

• IEEE Symbols: These become individual LINE entities, much as they are now for plotting. 

• Title Sheets: Title sheets are output to DXF in the block format. These blocks consist of the 
lines, text and other objects that form the title sheet and title block. Title blocks are named 
TITLE_SHEET_xx, where xx is the sheet number on which the title sheet resides. 

File PDIF In 
Choose File » PDIF In to import Pcad.pdf files. When you choose this command, the PDIF File 
Name dialog appears: 
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File PDIF Out 
Choose File » PDIF Out to export schematic files to the PDIF file format. When you choose File » 
PDIF Out, the File PDIF Out dialog appears: 

 

The File PDIF Out dialog contains the following options: 

• PDIF Directory (button). Click this button to select the directory in which you want to save the 
file. 

• Sheets (list box) Lists the sheets by name. 

PDF Versions Frame 
• 6.0/7.0 (button). Choose this button to select the file format for version 6 and 7. 

• 8.0 (button). Choose this button to select the file format for version 8. 
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File Exit 
Choose the File » Exit command to quit P-CAD Schematic.  

If any open design has been modified since the last save, you are prompted whether you want to 
save the changes to the file. 

The program writes information to the Sch.ini file when you choose File » Exit. This information, 
which applies to subsequent P-CAD Schematic sessions, consists of parameters and settings such 
as workspace size, units and values set in Options » Configure and report file settings from File » 
Reports and Utils » ERC. 
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CHAPTER 13 

Edit Commands 

Using the Edit Commands 
Use the Edit menu commands to modify objects in your design.  The following list summarizes 
some of the actions you can perform with various Edit menu commands. 

• You can choose Edit » Undo to undo recent actions and, if you decide you didn’t want to undo 
an action, you can choose Edit » Redo.  

• Some actions cannot be undone, but can be unwound by pressing the BACKSPACE key. For 
details, see Edit Undo (page 201). 

• When you choose Edit » Paste, you have a number of paste options. See Edit Paste (page 204) 
for more information. 

• Before you can choose some Edit commands, you must select an object. See Edit Select (page 
247) and Options Block Selection (page 287) for more information. 

Edit Undo 
Choose Edit » Undo to undo your last action. For example, if you place a part in a design, you can 
choose Edit » Undo to remove the part you placed. As a shortcut for choosing this command, you 
can click the Undo button on the Command toolbar, press CTRL+Z, or press the U key. 

By default, you can undo up to 10 actions with the Edit » Undo command. To change the undo limit, 
open the Sch.ini file. Then, modify the UndoLimit value.  

You can set the UndoLimit to any number. However, each stored, undoable action requires 
memory. Setting a large UndoLimit may use up your computer’s available memory, causing slow 
performance and often unpredictable results. 

If an action cannot be undone, the Edit » Undo command is shaded and not available. The list of 
undoable actions is deleted when you save the design. Any of the commands in the following list 
also cause the undo list to be cleared: 
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• Place Commands 

• Edit Delete 

• Edit Copy 

• Edit Cut 

• Moving Objects 

• Rotating Objects 

• Flipping Objects 

• File Save 

• File Save As 

• Delete TextStyle 

• Utils Renumber 

• File DBX In 

• File Design Technology Parameters (Close or ESC) 

• File Design Info (Close or ESC) 

• Utils Force Update 

• Utils Record ECOs 

• Utils Import ECOs 

• Delete Sheet 

• Utils ERC 

• Utils Resolve Hierarchy 

• Utils Module Wizard 

Edit Redo 
Choose Edit » Redo to repeat an action that has been undone. 

Each modification made to a design results in a copy of the design being placed in the undo list, as 
explained in Edit Undo (page 201). If you have stepped backwards in the list using Edit » Undo, and 
find that you want to move forward to a later version of the modifications, choose Edit » Redo. 

The redo button on the toolbar, the CTRL+Y and SHIFT+U keys are equivalent to the Edit » Redo 
command. The UndoLimit setting in the Sch.ini file also applies to the Edit » Redo command. To 
change the undo limit, open the Sch.ini file. Then, modify the “UndoLimit” value. 
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Edit Cut 
Choose Edit » Cut to remove selected objects from your design and save them to the Clipboard. 
From there you can paste them into another design, into another location within the current 
design, or into another program. 

You need to enable the Select tool (Edit » Select) and select at least one object to choose this 
command; otherwise the menu command is shaded and the CTRL+X shortcut key is unavailable. 

You can copy selected items to a disk file instead of the Clipboard. For details, see Edit Copy to File 
(page 203). You can also cut multiple objects by using multiple select and block select operations. 
For information, see Edit Select (page 247). 

Edit Copy 
Choose Edit » Copy  to copy selected objects to the Clipboard, from where you can paste them to 
another design, to another location within the same design, or to another location. 

You need to enable the Select tool (Edit » Select) and select at least one object to choose this 
command; otherwise the menu command is shaded and the CTRL+C shortcut key is unavailable. 

Instead of Copy and Paste, you can use CTRL + left mouse button (a drag-and-drop operation) to 
copy the selection within the same design quickly. The CTRL + left mouse action does not affect the 
clipboard. 

You can copy selected items to a disk file instead of the Windows clipboard. For details, see Edit 
Copy to File (page 203). 

You can copy multiple objects by using multiple select and block select operations. For 
information, see Edit Select (page 247). 

Edit Copy to File 
Choose Edit » Copy to File to copy selected objects to a block file or meta file. You can later paste 
objects from these files into a schematic design. To copy objects to a file, you must select at least 
one item and then choose Edit » Copy to File. When you choose this command, the following 
dialog appears: 
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You use the options in the Edit Copy to File dialog to name the file and select one of the following 
file formats: 

• Block Files (*.blk). A file format that stores the information that you want to transfer between 
P-CAD Schematic designs. 

• Meta Files (*.wmf). An image file format that can be transported between computers. 

To save storage space, select the Compress Binary Designs check box in the Options Configure 
dialog before you save the file. This is beneficial when working with large design files. 

For detailed instructions, see Copying Objects to a File (page 91). 

Edit Paste 
Choose Edit » Paste to paste objects into your design file from either the clipboard or a block file. 
You must be in Select mode to choose this command. 

When you choose Edit » Paste, a sub-menu appears, from which you can choose a paste method. 
The paste choices range from the simple options Paste From Clipboard and Paste From File in 
which objects are pasted without net information, to the more intelligent Paste Circuit and Paste 
Circuit From File commands which allow you to control changes to component and net names and 
retain net information. 

Paste Behavior 
After items have been copied and you press and hold down the left mouse button in the 
workspace, the ghosted outline of the copied item(s) appears until you release the mouse button 
to commit them to the desired location. Before releasing the left mouse button, you can drag the 
items to a more precise location in the workspace.  

There must be sufficient space to accommodate the objects being pasted. Error messages inform 
you if the target space is not large enough or if you are attempting to paste too close to or outside 
of the edge of the workspace. 

If, while pasting a part, parts of the same name but from a different library already exist in the 
destination design, the part may not be pasted/placed depending on possible conflicts in pin 
assignments. This conflict could also occur when parts from a Tango Series II schematic are mixed 
with parts of the same name in a P-CAD library. In effect, the first instance of the part name 
establishes the standard. 

When you paste text of a style that has the same name but a different definition than in the current 
design, the incoming style name has a bracketed number appended to it to indicate the style 
conflict.  
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The new, bracketed style name is added to the list of available styles in the current design. For style 
information, see Edit Properties (page 211) and Options Text Style (page 314). 

If you are pasting components or nets that have the same names as objects that already exist in the 
design, you have the option to specify how their names should be changed if you choose the Edit » 
Paste Circuit and Edit » Paste Circuit From File commands. With these commands you can also 
force a specified net to be pasted into the design while retaining the same name. 

Paste From Clipboard 
Choose Edit » Paste From Clipboard to paste Clipboard objects into your design. This command is 
available only when data has been copied to the Clipboard and when you are in Select mode. 

When you choose Edit » Paste From Clipboard, Schematic places the copied information in the new 
location in the design, renames the design objects to the next sequentially available name and 
retains the component attributes and their values. 

Paste From File 
Choose the Edit » Paste From File command to paste items from a block file into the current file. To 
create a block file, select one or more objects and choose the Edit » Copy to File command.  

To paste objects from a block file into the current file, choose Edit » Paste From File. The following 
dialog appears: 
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The Look In list box displays the current folder; a list of files in that folder appearing directly 
underneath. The File name box lets you select or enter a design file, with the extension specified in 
the Files of type list. 

Select the block file containing the item(s) you wish to paste. Once the file is selected, this 
command works like the Edit » Paste From Clipboard command. For details, see Paste From 
Clipboard (page 205). 

Paste Circuit 
Choose Edit » Paste Circuit to control the naming of components and nets being pasted into a 
design and stipulate net attribute bias. When you choose Edit » Paste Circuit, the following dialog 
appears: 

 

Using Paste Circuit 
As long as you have not disabled the paste circuit function, you can paste the data from the 
clipboard as many times as necessary. Each time you paste the same data with a left mouse click, 
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the component and net names are incremented starting from the last net or component name 
resident in the design. If you have added a qualifier for the component or net names, the qualifier 
is incremented with each paste until the component or net name is unique. You can, however, 
choose to retain the current net names. 

When you have finished pasting and you have exited the paste function by right-clicking, you can 
begin pasting the data again with another Paste Circuit command. This time, when you paste this 
same data, the component and net names begin incrementing from their original names. 

Reference Designators 
In the Reference Designators frame you can choose how the components are named when pasted. 
You can either allow Schematic to incrementally change the component names, or you can control 
the way components are renamed by adding a qualifier in a specific position in the new name.  

To rename the components using a qualifier: 

1. Select the Create new refdes using qualifier check box. 

2. Type the characters (no more than four) that you want to add to the name in the Qualifier box. 

3. Choose the desired position within the RefDes name for the qualifier. Each of following 
choices places the qualifier in a different location: 

• Add before name. 

• Add before numeric suffix. 

• Add to end of name. 

The Example frame shows a sample, so you can view the change before it is made. 

If you do not want to designate the way the RefDes names are modified on paste, clear the Create 
new refdes using qualifier check box.  

Each time a component is pasted, the RefDes is sequentially incremented alphanumerically to the 
next available RefDes for that component. If you have added a qualifier, the qualifier is 
incremented first in the same manner. Then, if the component name still conflicts with an existing 
component name, it will be incremented until it is unique. 

Net Attributes 
When pasting data containing net information, either from the same design or another design, you 
can choose how the net attributes are handled choosing one of the following radio buttons in the 
Net Attributes frame: 

• Merge Favor Circuit: With this option, incoming net attributes take precedence over existing 
net attributes. When the net attributes in the incoming circuit information match those already 
in the design, but the values are different, the design attributes are modified to match those of 
the incoming circuit. All other incoming net attributes are merged with those in the design. 

• Merge Favor Design: Existing net attributes are retained when you merge attributes favoring 
the design. When the design and incoming circuit have matching net attributes with different 
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values, the design attribute values are retained. Other incoming net attributes are merged with 
those in the design. 

• Replace Design: This option removes all existing net attributes and replaces them with those of 
the incoming circuit. 

• Ignore Circuit: Net attributes attached to the incoming circuit are ignored and existing net 
attributes left unchanged. 

Nets 
In the Nets frame you can choose which nets are renamed and how they are named when pasted. 
This process is similar to the way the components are renamed in the Reference Designators frame. 

To rename the nets, follow these steps: 

1. Select the Create new net name using qualifier check box. 

2. Type the characters (no more than four) that you want to add to the name in the Qualifier box. 

3. Choose the desired position for the qualifier within the net name. Each of the following 
choices places the qualifier in a different location: 

• Add before name. 

• Add before numeric suffix. 

• Add to end of name. 

The Example frame shows a sample, so you can view the change before it’s made. 

If you do not want to designate the way the net names are modified on paste, disable the 
Create new net name using qualifier box.  

Each time a net is pasted, the net name is sequentially incremented alphanumerically to the 
next available net name. If you have added a qualifier, the qualifier is incremented first in the 
same manner. Then, if the net name still conflicts with an existing net name, it will be 
incremented until it is unique. 

4. The last step is to choose which nets should be renamed using the qualifier and which should 
retain their current names. You can designate individual nets to retain the current name by 
clicking the specific nets in the Net Names list box. You can also choose to retain all global net 
names by enabling the Global Nets option in the Maintain Original Net Names section. 

Nets connected to ports are considered global if the port is also copied. If the port is not 
copied, the nets are considered part of a signal net. This distinguishes the global nets so that 
you can choose to keep the same net name for the global nets when they are pasted. 

Paste Circuit From File 
Choose the Edit » Paste Circuit From File command to open the Edit Paste Circuit From File dialog 
and select the file to be pasted. Once the file is selected, the paste operation functions in the same 
manner as the Edit » Paste Circuit command. For details, see Paste Circuit (page 206). 
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Edit Move By RefDes 
Choose the Edit » Move By RefDes command to move parts by reference designator. This opens 
the following dialog. 

 

Use this dialog to select the reference designators of the parts you’d like to move. The following 
describes this dialog in more detail: 

• RefDes. This list shows all of the parts on your current sheet. You can select one or more parts 
from this list. To select multiple parts, hold down the CTRL or SHIFT key and click the parts to 
choose. 

• If you select parts in your design before you open this dialog, those parts are selected in the 
RefDes list box when the dialog appears. 

When you double-click a part in this list, the dialog closes. At this time, you can place the part 
into a new position by clicking a location in your workspace.  

• Select RefDes By. Type search criteria in this box to search the RefDes list for a match. You can 
enter wildcard characters in this field.  

• Select All. Click this button to select all of the items in the RefDes list. 

• Clear All. Click this button to deselect all of the items in the RefDes list box. 

After selecting parts from the dialog, click OK to return to your workspace. The status line shows 
the Next RefDes to move. To skip to the next RefDes, press N. To move to the previous RefDes, 
press B. 

Moving Parts by RefDes 
To move parts by reference designator, follow these steps. 



Chapter 13: Edit Commands Edit Move By RefDes 

210 P-CAD Schematic User’s Guide 

1. Choose Edit » Move by RefDes to open the Edit Move by RefDes dialog. 

 

If you select parts in your design before you open this dialog, those parts are selected in the 
RefDes list box when the dialog appears. 

2. Use one of these methods to select parts from the RefDes list: 

• To select one part: Double-click a RefDes in the list. Or, select a RefDes from the list and 
then click OK or press ENTER. 

• To select all parts: Click Select All. Then, click OK. 

• To select a range of parts: Hold down the SHIFT key and click the first and last parts in the 
range to select. Then, click OK or press ENTER. 

• To select various parts: Hold down the CTRL key and click each part to select. Then, click 
OK or press ENTER. 

• To search for parts in the RefDes list: type search criteria in the Select RefDes By box and 
then press ENTER. 

When the Edit Move by RefDes dialog closes, the status line shows the name of the Next 
RefDes to move. You are in placement mode. 

To cancel your selection, press ESC or right-click. This reopens the Edit Move by RefDes dialog, so 
you can choose another part to move. 

3. Choose one of these methods to place the parts: 

• For quick placement, click the location at which you want to place the part.  

• For precise placement, do the following: (1) press and hold down the left mouse button or 
press the SPACEBAR. (2) Move the ghosted part to the location you want. If appropriate, 
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press F to flip or R to rotate the part. (3) Place the part by releasing the mouse button or by 
pressing the SPACEBAR. 

If you selected multiple parts, the status line shows the Next RefDes to move. To skip to the 
next RefDes, press N. To move to the previous RefDes, press B. 

4. Once you’ve moved all of the selected parts, the Edit Move By RefDes dialog appears. You have 
these options: 

• To move another part, select it from the RefDes list. 

• To close the Edit Move by RefDes dialog, click Cancel or press ESC. 

Searching the RefDes List 
To search for parts in the RefDes list, follow these steps: 

1. Enter search criteria in the Search by RefDes box. You can type wildcard characters as follows: 

• Type an asterisk (*) at the end of your search criteria. For example, type RN* to search for 
any reference designators that begin with RN (e.g., RN1, RN2, RN3). 

• Type a question mark (?) to match a single character in that position. For example, type 
C?2 to search for reference designators, such as C12, C22, C32. 

2. Click OK or press ENTER to initiate a search of the RefDes list. Then, do the following: 

• If parts matching your wildcard search are selected in the Edit Move by RefDes list, verify 
the accuracy of the match, and click OK. You can now move these parts. 

• If the Edit Move by RefDes dialog closes and you return to the workspace. You can now 
move these parts on the current sheet. 

• If a message notifies you that no match was found, click OK to close the message box. 
Then, try another search. 

Edit Properties 
Choose Edit » Properties to open the Properties dialog for the objects you select. With this dialog, 
you can query and modify the selected object’s properties. Before you can choose Edit » 
Properties, you must enable the Select tool and then select the objects. 

The Properties dialog that appears is specific to the object you select. If multiple objects are 
selected, they must all be of the same type (e.g., arcs), otherwise the command is shaded and no 
dialog will appear. If the objects are of the same type, the changes you make apply to all selected 
objects. 

Right-Click to Select Properties 
As a shortcut for choosing the Edit » Properties command, you can select an object, right-click to 
open a shortcut menu, and choose Properties. The commands available from this shortcut menu 
vary depending on the object you select. 
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For more information, see Shortcut Menu Commands (page 13). 

Double Click to Select Properties 
As a shortcut for choosing the Edit » Properties command, double-click an object to open the 
Property dialog. This shortcut is available only if the Double Click Displays Properties check box is 
selected in the Mouse tab of the Options Preferences dialog. For more information, see Options 
Preferences (page 301). 

Part Properties 
When you select one or more parts and choose the Edit » Properties command, the Part Properties 
dialog appears, as shown in the following figure: 

 

Use the Properties dialog to examine properties for the selected part and to modify certain symbol 
properties. From this dialog, you can selectively replace the component type of one or more gates 
at the same time. This feature is useful because it lets you replace several gates in your design 
automatically, preserve reference designators and, where possible, preserve gate connectivity. 

Additional tabs provide access to additional information: 

• Symbol Pins 

• Component 

• Component Pins 

• Attributes 
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Symbol Tab 
The following information appears on the symbol tab: 

• The Ref Des box shows the reference designator name. To change the reference designator, 
type a new value in the Ref Des field. If you selected more than one part, this value cannot be 
changed. 

• The Value box shows the part’s value. To change the value, type a new value in the Value field. 

• The Type list box shows the component type. You can change this value by selecting a different 
component Type from the drop-down list that appears when you click the down arrow button. 

A component Type swap follows the rules used by the Utils » Force Update command if you choose 
the Merge Attributes (Favor Library) option. The rules are: 

• If an attribute exists in the library component and not in the design component, the library 
attributes and their values are moved into the design component. 

• If the same attribute exists in both the design component and the library component with 
different values, the value of the library component attribute will replace the value of the 
design component attribute. 

• An existing design component attribute, which has no matching library component attribute, is 
retained, unchanged, in the design component. 

When the Value attribute is present in both the design component and the library component, 
and has a different value in both places, you must choose which value to keep in the design 
when prompted. 

• The Library list box shows the part libraries available, and displays the currently selected 
library. 

• The Query button provides a direct link to the Library Executive Query function where a 
selected part from the Query output dialog can replace the current part and its properties by 
clicking the Replace button. 

• The Visibility frame contains check boxes indicating whether the selected part(s) have visible, 
invisible, or undetermined RefDes, Value, and Type attributes.  

• If a box is checked, the attribute is visible. If the box isn't checked, the attribute is invisible. If 
the box is shaded, then the attribute either does not exist (e.g., there is no Value attribute for 
the selected part), or there is a conflict between multiple parts selected (e.g., the attribute on 
one part is visible, but is invisible on another).  

• The Alternate frame lets you select the Normal, IEEE or DeMorgan representations of a part if 
they exist. The symbols displayed for these representations are assigned in Library Executive.  

• The Location frame shows the X and Y coordinates of the part’s reference point. 

• The Flip check box indicates whether or not the symbol has been flipped.  

• The Rotation field shows the rotation amount if the symbol has been rotated. 
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• The Pattern box displays the pattern name. To change the pattern, type a new pattern name in 
the box. Changing the pattern in this dialog doesn't change the pattern attached to the 
component in the library. 

• A netlist loaded into PCB after these pattern changes will load a component and its pattern for 
the modified component, depending on the contents of the open libraries. P-CAD PCB will 
load the first component in an open library having a type matching the modified component. If 
a component with a matching type cannot be located, a component with a type name matching 
the modified component pattern name is loaded. 

• The Gate Number box shows the section number of this part within the component. To 
reassign this gate, type a new gate number in the box. You can use a numeric or alphabetic part 
designation, within the range shown by the Number of Symbols field (Component tab). 

• The Text Style frame shows the symbol’s text font (PartStyle). 

Text Styles Button 
The part’s text style (PartStyle) appears in the Text Style field. Click Text Styles to open the Options 
Text Style dialog. From this dialog you can edit the part’s text style.  

Refer to Options Text Style (page 314) for more information. 

Symbol Pins Tab 
The Symbol Pins tab shows the following dialog: 

 

This tab allows you to change several pin properties of one or more pins within the part.  
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Pins 
The Pins list box lists the pin designators in the selected part as well as power pins in the 
component. The information fields to the right display the information about the pin that is 
highlighted.  

Pin Designator/Pin Name 
The Pin Name and Pin Designator boxes each contain a display check box and a combo box. The 
Display check box indicates whether the pin designator or pin name on the selected pin(s) are 
visible, invisible, or indeterminate. In the Text list boxes, you can set the text style for the pin name 
and pin designator.  

Net Name/Pin Length 
You can change the pin length of visible pins and the net name of hidden, global power pins by 
typing new values in the appropriate Pin Length and Net Name boxes. If a pin is connected to a 
wire or net, you cannot change the pin length, and the Pin Length box is shaded. 

Set All/Clear All 
The Set All and Clear All buttons can be used to highlight and unhighlight all pins in the list box. 

Query Fields 
The following fields allow you to see information about the selected pin: 

• Location: The X and Y coordinates of the selected pin. 

• Flip: The Flip box indicates whether or not the pin has been flipped. 

• Rotation: The Rotation field shows the rotation amount if the pin has been rotated. 

• Default Pin Des: When a default pin designator has been assigned to the pin, the value is 
displayed here. If multiple pins are selected, and all have the same default pin designator, the 
value is displayed. When multiple selected pins have different default pin designators, this area 
remains blank. 

Text Styles 
Click Text Styles to open the Options Text Style dialog. From this dialog you can edit all text style’s 
properties. If you modify a text style in this dialog, all text in your design with that style changes. 
For more information, see Options Text Style (page 314). 

Component Tab 
When you select the Component tab, the Port Properties dialog appears as follows: 
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This tab shows information for the component(s) you selected on a gate-by-gate basis. This 
information is display only; it can’t be modified from this dialog. To show information for a 
different gate, select the gate from the Gate Number drop-down list box.  

The Reference button, when activated by the presence of the Reference attribute, quickly launches 
the reference link entered as the Reference attribute’s value. If the link is a web address the 
Internet Explorer is launched and the web site opened. If the link is a document, the associated 
program is started and the document displayed. 

See the Library Executive User’s Guide for information about this dialog’s fields.  

Component Pins Tab 
The Component Pins tab appears as follows: 
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Use this dialog to look at pin information for the component pins within the symbol or component. 
The following information appears: 

• Pad #: The number of the corresponding pad on the attached pattern. Pad numbers must be 
unique, and they must exist in the attached pattern. 

• Pin Designator: The pin designator of each pin in the component. 

• Gate #: The part number defines the part that the pin is associated with. In multipart 
components, the parts are uniquely numbered from 1 through n. 

• Pin #: The number of the corresponding pin on the attached symbol. Pin numbers must be 
unique and must exist in the attached symbol. 

• Pin Name: The pin name associated with that pin designator. 

• Gate Eq: The gate equivalence column defines which gates are equivalent. All gates with the 
same Gate Eq number are defined to be equivalent. This information is used by P-CAD 
Schematic when automatically incrementing reference designators (e.g., Place » Part and Utils 
» Renumber commands) and by P-CAD PCB to determine which gates can be swapped during 
manual or automatic gate swapping. You cannot set the gate equivalency of pins in the same 
gate to be different. When you change a part number or gate equivalence for a gate, the 
spreadsheet updates the gate equivalence field of the other pins of that gate to match.  

• Pin Eq: Indicates which pins within a gate are logically equivalent. The pin equivalence values 
must be non-zero and identical for a swap to occur between two pins. Non-swappable pins are 
indicated with a zero value. 

• Elec Type: The type of pin.  
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Attributes Tab  
When you click the Attributes tab, the dialog appears as follows: 

 

You can view, add, modify, or delete a collection of component attributes and access a web site. 
The dialog contains a two-column table showing the collection of component attributes. Within the 
collection, each attribute’s name and value appear in the column. 

Wire Properties  
When you select a wire and choose the Edit » Properties command, the Wire Properties dialog 
appears as shown in the following figure: 

 

The following information appears on the Wire tab of the Wire Properties dialog: 
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• The Net Name field contains the name of the net to which the wire is associated. 

• Select the Display option to display or hide the wire name. 

• The Width frame contains the width of the selected wire.  

• The End Points frame shows the X, Y coordinates for the wire’s start and end points. 

• The Text Style field shows the text style used for the wire name. 

Wire Width 
In the Width grouping, you can modify the width of the selected wire. The wire width can be Thin 
(10 mils), Thick (15 mils), or User defined. User defined wire widths can range from 0.1 to 100 mils. 

For example, to set the wire width to 11 mils: 

1. Choose the User radio button in the Width frame. The box becomes active. 

2. In the box, type: 11mil and click OK. 

To maintain the appearance of P-CAD Schematic designs before V13.0, all wires less than 11mils 
wide are displayed as 1 pixel.  To set the default wire width, see Options Current Wire (page 312). 

Text Styles Button 
Click Text Styles to open the Options Text Style dialog. From this dialog you can add, delete, rename, 
or edit text styles including the wire style. For more information, see Options Text Style (page 314). 

Net Tab 
When you click the Net tab, the Wire Properties dialog appears as follows: 

 

On the Net tab of the Wire Properties dialog, you can set the following fields: 
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• Net Name: The Net Names list box contains the name of the net associated with this wire. If 
you attempt to rename the net with the name of an existing net, and one of the nets is not 
global, an error message appears. You must confirm that you want to autoplace ports to make 
both nets global by clicking the Yes button. The nets are merged and renamed. 

• Nodes: The Nodes list box contains the names of all nodes in the net. 

• Sheets: The Sheets list box contains the names of all sheets on which the net exists. 

• Global: The Global check box indicates whether or not the net is a global net. 

• Pin Count: The Pin Count field displays the pin count for the selected net. 

• Net Attrs: When you click the Net Attrs button, the Attributes dialog appears. 

Bus Properties 
When you select a bus and choose the Edit » Properties command, the Bus Properties dialog 
appears: 

 

The following information appears on the Bus Properties dialog: 

• Bus Name: The Bus Name list box contains the name of the bus. 

• Display: Select this check box to display the bus name. Clear the check box to hide the bus 
name. 

• Connected Nets: This list box contains the names of all nets connected to the bus. 

• Sheets: This list box contains the names of all sheets on which the bus is placed. 

• Text Style: This field shows the text style used for the wire name. 

• Text Styles: Click the Text Styles button to open the Options Text Style dialog. From this dialog 
you can add, delete, rename, or edit the text style of the bus name. Refer to Options Text Style 
(page 314) for more information. 
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Port Properties 
When you select a port and choose the Edit » Properties command, the Port Properties dialog 
appears with the Port tab selected: 

 

Ports consist of the net name, an optional box surrounding it, and one or two pins to connect it to 
wires.  

The following information appears on the dialog: 

• Net Name: Shows the name of the net to which the selected port is attached.  

• Pin Count: Choose the One Pin or Two Pin radio button. 

• Pin Length: Choose the Short (100 mil) or Long (500 mil) radio button. 

• Pin Orientation: Choose either Horizontal or Vertical. 

• Port Shape: Select one of the Port Shape buttons. If you don’t want a port outline, choose the 
None button. 

Net Tab 
When you click the Net tab, the Port Properties dialog appears: 
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The following information appears on the dialog: 

• Net Name: The Net Names list box contains the name of the net associated with the port. You 
can change the net by typing a new net name in the Net Name box or by choosing a new net 
from the drop-down list box. If you attempt to rename the net with the name of an existing net, 
and one of the nets is not global, an error message appears. You must confirm that you want to 
autoplace ports to make both nets global by clicking the Yes button. The nets are merged and 
renamed. 

• Nodes: The Nodes list box contains the names of all nodes in the net. 

• Sheets: The Sheets list box contains the names of all sheets on which the net is placed. 

• Global: The Global field indicates whether or not the net is a global net. 

• Pin Count: The Pin Count field displays the pin count for the selected net. 

• Net Attrs: When you click the Net Attrs button, the Attributes dialog appears. 

Pin Properties 
If the pin is part of a symbol, you can access its properties using the subselect feature described in 
Selecting Objects (page 78) or through the Parts Properties dialog discussed above. 

When you select a pin and choose the Edit » Properties command, the Pin Properties dialog 
appears:    
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The following information appears on the dialog: 

• Length: Select Short (100 mil), Normal (300 mil), Long (500 mil), or set your own length by 
clicking the User option and entering a length in the box. You cannot change the length of a 
subselected pin if it is connected to a wire. 

• Pin Number: You can renumber the pin, by typing over the value that appears in the Pin 
Number box. You cannot renumber a symbol pin. 

• Display: Select the Pin Name and Pin Des check boxes to display the pin name and pin 
designator. Clear the check box to hide the name or designator. 

• Text Style: In the Pin Name and Pin Des list boxes, you can set the text style for the pin name 
and pin designator. Click Text Styles to open the Options Text Style dialog. From this dialog 
you can edit all text style’s properties. If you modify a text style in this dialog, all text in your 
design with that style changes. 

• Pin Name: For a symbol pin, the pin name, like a pin number, cannot be edited. For a free pin, 
the pin name, or default pin name, is a placeholder for the real pin name. The Pin Name box 
may be left blank. Use this default label to change the orientation or position of the pin name.  

• Default Pin Des: Use the Default Pin Des box to assign or change a pin designator for the 
selected pin. If you have selected multiple pins, which have different default pin designators, 
the Default Pin Des box displays “Hetero_Selection”. Changing the value in this box changes 
the default pin designator for all the selected pins. 
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• Display Characteristics: Display characteristics include all attribute symbols that may be 
attached to a pin for design clarification. They are for graphical appearance only. Refer to Place 
Pin (page 269) for examples. 

After reviewing or updating the information, click OK to close the Pin Properties dialog. 

Pin Name and Pin Designator Properties 
When you subselect a pin name or pin designator and choose Edit » Properties, the Text Properties 
dialog appears: 

 

You can view the text properties including style and rotation. Also, you can modify the location or 
justification of the subselected pin name or pin designator. 

A sub-selected pin name or pin designator can be rotated, flipped, and moved. 

To modify the text or text style, see Pin Properties (page 222). For more information about text 
properties, see Options Text Style (page 314). 

Line Properties 
When you select a line and choose the Edit » Properties command, the Line Properties dialog 
appears as follows:  
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The following information appears on the dialog: 

• The Width frame lets you choose a radio button to set Thick, Thin, or User (defined) lines. If 
you select User, enter a line width in the corresponding box. 

• The Style frame lets you choose a radio button to set a Solid, Dashed, or Dotted line style for 
thin lines.  

• The End Points frame lets you change the lines start and end points by typing new X and Y 
coordinates over the existing values. 

• The Length box shows the line’s length. 

If you select multiple lines to modify that are of differing styles and/or widths, the values in the 
dialog appear blank. You can select a value and make all the selected lines the same style and/or 
width.  

Arc Properties 
When you select an arc and choose the Edit » Properties command, the Arc Properties dialog 
appears:  

 

The Properties dialog for arcs shows you the start and end points for the selected arc.  

Query Fields 
For the free arc Center, Start, and End points, see one of the following: 

• X and Y coordinates: The X and Y location of the Start and End point. 

• Tangent Slope Angle: The tangent slope angle of the arc. 

Changing Arc Properties 
To change the properties of an arc, follow these steps:  
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• Start Angle: Click the scroll buttons (up and down arrows) to scroll through arc start angles.  

• X and Y coordinates of the Center Point: Type over the existing X and Y values in the Center 
Point box. 

• End Angle: Click the scroll buttons (up and down arrows) to scroll through arc end angles.  

• Radius: Type a new radius over the existing value.  

• Width: Type a new line width over the existing value. 

Polygon Properties 
When you select a polygon and choose Edit » Properties, the Free Polygon Properties dialog 
appears as follows:  

 

The Free Polygon Properties dialog for free polygons shows you the following information:  

• Area: The area of the polygon. 

• Points: The X and Y location of each point in the free polygon. 

Text Properties 
When you select one or more text items and choose Edit » Properties, the Text Properties dialog 
appears:  
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The Text Properties dialog remains displayed in your workspace until you close it or choose 
another tool. Changes made to the text in the box are instantly displayed in the selected text in the 
design. You can adjust the zoom factor in the design to more easily view the text while the dialog 
remains on the screen. 

From this dialog, you can change the text content, justification, style and location. The text can also 
be rotated and flipped, and any non-default text styles can be modified. 

Changing Text Properties 
To change the properties of text, follow these instructions: 

• Text: Type over the text displayed in the Text box and click OK. For multi-line text, ENTER 
creates a line break. You can enter a maximum of 2,000 characters. While the Text box has 
focus, you can use CTRL+V to paste text from the Clipboard.  

• Location: The X and Y coordinates of the selected text appear in the Location box. You can 
move the text by typing new coordinates. 

• Justification: Under Justification are nine buttons, which allow you to change text justification. 
The reference point of the text string is, by default, at the location of the first character in the 
string and set to the lower left corner. When you change the Justification button, the text 
moves around the reference point. For instance, if the text “STRING” is displayed in its default 
settings the reference point is as shown in the following illustrations: 

 

If you change the Justification to the upper right corner button, the text “STRING” rotates 
around the reference point and appears in the design as shown in the following illustration: 

 

• Flip: Enable the Flip option by clicking in the box. The text appears flipped. 

• Rotate: Click the Rotate 90.0 button to rotate the text 90 degrees. The degree of rotation is 
displayed next to the Rotate 90.0 button.  

• Text Style: Click on the text style you want from the Text Style list box. 

• Text Styles: Click the Text Styles button to display the Options Text Style dialog. From this 
dialog you can add, delete, rename, or edit non-default text styles.  

Refer to the Options Text Style (page 314) for information. 
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Attribute Properties 
When you select an attribute and choose the Edit » Properties command, the Attribute Properties 
dialog appears: 

 

The following information appears in the dialog: 

• Attribute Category: This list box displays a list of all attribute categories, All, Component, Net, 
Clearance, Physical, Electrical, Placement, Manufacturing, Router, and SPECCTRA. Selecting a 
category brings up a list of predefined attributes for that category. 

• Name: This list box displays all predefined attributes for the specified category. The first entry 
in the list is User-defined. The currently-selected attribute also appears in the Name box, 
unless User-defined is selected. In that case, the Name box is blank so that you can enter a 
user-defined attribute name. 

• Name: For user-defined attributes, enter a name for the attribute in this box. 

If the dialog is accessed for an attribute that already has a name, then the Category list box, 
Name list box, and Name box are filled in, but shaded. If the attribute doesn’t have a name, 
these controls are enabled. 

• Value: Use this box to enter a value for the attribute. 

• Visible: This check box indicates whether or not the attribute is visible. 

• Location: This frame shows the X and Y coordinates of the attribute’s reference point. 

• Text Style: This frame lets you select the attribute text style. Text styles appear in the Text Style 
drop-down list box. To change the selected text style, click on the text style you want from the 
list box. To modify the text style, click the Text Style button. 

• Rotation: Shows the rotation amount if the pattern has been rotated. 
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• Flipped: This box indicates whether or not the pattern has been flipped.  

• Justification:   In the Justification frame nine buttons allow you to change text justification by 
setting the reference point of the text string. For example, if you enable the middle button, the 
text reference point (the lower-left corner) moves to the center of the bounding rectangle. 

Component References 
A special attribute, which provides direct access to information located in a document or web site, 
can be added to the part using the Attribute Properties dialog. The attribute is named Reference 
and is associated with the Component Attribute Category. The Reference attribute’s Value should 
be a document or web site address where the additional information about this part is located. 

When you add the Reference attribute and Reference location, the Place Attribute dialog appears. 

 

Once the Reference attribute has been added, the Reference button on the Component tab of the 
Properties dialog is activated and displays the reference link (in this case a web address), as shown: 
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Also, when the Reference attribute and reference link have been added and selected, the Launch 
button on the Attributes tab becomes available, as shown in the following figure: 

 

Click the Launch button on the Attributes tab or the Reference button on the Component tab to 
start Internet Explorer and go directly to the designated web address. If the reference link is a 
document, the associated program is started and the document appears. 

Field Properties 
When you select a field and choose the Edit » Properties command, the Field Properties dialog 
appears as shown on the following page.  
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The Field Properties dialog lets you view and/or change information about the selected field’s 
properties. You can modify the following fields:  

• Text Style (list). Select a text style for the field from this list. 

• Text Styles (button). Click this button to open the Options Text Style dialog. You use this dialog 
to add or modify a text style. 

• Rotation (data field). Displays the degree of rotation for the field. 

• Justification (frame). Choose a button in this frame to set the text justification for a field. 

• X and Y (boxes). Enter an X and Y coordinate to set the location of the field in the design. 

Query Fields 
The following information about the selected field can be viewed: 

• Value: The Value assigned to the field.  

• Name: The name of the existing field is displayed here.  

• Flip: The Flip box indicates whether or not the field has been flipped. 

• Rotation: The Rotation field shows the rotation amount if the field has been rotated. 

Editable Fields 
The following information about the selected field can be modified: 

• Text Style: Choose a Text Style from the list of styles that appear when you click the down 
arrow button. 

• Text Styles: If the text style you need does not appear on the Text Style drop-down list, click 
the Text Styles button to display the Options Text Style dialog where you can define a new text 
style. Complete information on the Options Text Style dialog can be found in Options Text 
Style (page 314). 
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• Location: The current X and Y coordinates of the field’s location. You may enter new 
coordinates and the field will be placed in the new location when you exit the dialog by 
clicking the OK button. 

• Justification: Choose the reference point of the field by clicking the desired button. For 
example, if you enable the middle button, the field reference point (the lower-left corner) 
moves to the center of the bounding rectangle of the field. 

ERC Errors Properties 
When you select ERC error indicators and choose the Edit » Properties command, the Find Errors 
dialog appears.  

Each indicator represents an error or violation detected in the electrical rules checking pass (Utils 
ERC). You can select multiple error indicators with block select and cycle through them by error 
number. 

To generate ERC error indicators, use the Utils ERC command to enable the Annotate Errors option. 

To block select ERC error indicators, use the Options » Block Selection command to include the 
indicators in a block selection, then perform the block select. 

Viewing ERC Errors 
To view ERC errors, follow these instructions: 

1. Select ERC error(s) either individually or through a block select. 

2. Right-click the error and choose Properties from the shortcut menu, or choose Edit » 
Properties. The Find Errors dialog appears as follows: 

 

The Find Errors dialog options are: 

• Error Text (scroll box): Displays the error text. 

• Show Only Selected (check box): Click this box to view selected errors. 

• Show Only Overrides (check box): Click this box to view errors that have been marked as 
overridden. 
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• Category (list box): Select one or all categories to ERC errors to view. 

• Error Number (spin box): Click the Error Number spin box to scroll forward and backward 
through the errors associated with the selected ERC error indicators. 

• Overrides – Don’t Display Again (check box): Click this box to override an error. 

• Find (button): To find an error within the design. 

• Jump To (button): To jump to a particular error. 

Replacing Component Types 
P-CAD Schematic lets you selectively replace the component type of one or more gates at the same 
time. To replace component types, you need to delete an existing gate, then add a new one. With 
this feature, you can replace several gates in your design automatically, preserve reference 
designators and, where possible, preserve gate connectivity. 

If you're replacing a group of gates, each gate in the selection must be of the same type. Also, if you 
select one gate in a multigate component, P-CAD Schematic automatically selects all the gates in 
that component, even if some of them are not on the current sheet. 

Although P-CAD Schematic does its best to preserve gate connectivity, there are some cases where 
gates lose their connectivity. This occurs if:  

• The old and new component types have different pin designators or different numbers of 
gates. In this case, the program replaces gates by gate ordering. That is, the first gate of the old 
component type is replaced by the first gate of the new component type, and so on until all 
gates are replaced. If the old component type has more gates than the new component type, 
the program removes the extra gates from the design. However, if the new component type 
has more gates than the old component type, the extra gates are left unused. 

• The new symbol is different from the old symbol. 

If P-CAD Schematic cannot maintain gate connectivity, a warning message appears. 

To replace component types, follow these steps: 

1. Select the component(s) you wish to replace. 

2. Choose Edit » Properties. The Part Properties dialog appears, as shown in the following figure: 
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Notice the dialog has two list boxes, Type and Library. 

• Type: Lists the component types available, and displays the component type of the 
currently selected component. 

• Library: Lists the part libraries available, and displays the currently selected library. 

3. Click the Type list box. A drop-down list box shows the available component types in the 
current library. 

4. Select the desired component type. If the desired component type is not in the current library, 
select another library from the Library list box. 

5. Click OK. P-CAD Schematic replaces the selected components with the new component type. 

When type swapping, the program does not apply other Parts Properties changes. 

Edit Delete 
Choose the Edit » Delete command to delete all selected objects. As a shortcut for choosing this 
command, press the DEL key or select an object, right-click and choose Delete from the shortcut 
menu.  

This command does not cut the data to the clipboard as does Edit » Cut. To reverse the Delete 
action choose the Edit » Undo command. 



Edit Delete Chapter 13: Edit Commands 

P-CAD Schematic User’s Guide 235 

Deleting Objects 
1. Choose Edit » Select or click the Select button on the toolbar. Click the object you want to 

delete.  

2. Choose Edit » Delete. If you inadvertently delete an object, choose Edit » Undo to reverse the 
delete action. 

This operation can also be performed with multiple objects by using multiple select and block 
select operations. Refer to Edit Select (page 247). 

Deleting Objects from Nets 
When you use the Edit » Delete command to remove objects from nets, the results depend on 
whether the net is a global or local net.  

 

If you delete a wire that isolates a pin from the rest of the net, you end up with a disconnected 
node that is no longer part of any net. For example, in the above figure, if you delete wire cd, the 
node d becomes isolated from the net. 

• If the deleted wire has a system-assigned net name (for example, NET00001) then one of the 
nets is given a new system-assigned net name, while the other retains the original net name. 

• If the deleted wire was connected to a global net, the subnet still attached to the port or power 
symbol retains the original net name, while the other net is renamed to a new system-assigned 
net name. 

• If both subnets are connected to a port or power symbol, then both subnets retain the original 
name. 

• If the wire was connected to a jumper pin and nothing else is connected to that jumper pin. 
Then all the jumpered pins are removed from the net. 
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Edit Copy Matrix 
Choose Edit » Copy Matrix to duplicate all the selected objects according to the parameters you 
specify. The objects must be selected before Copy Matrix can function.  

When you choose Edit » Copy Matrix the following dialog appears: 

 

In the Edit Copy Matrix dialog, the Number of Columns and Number of Rows boxes determine the 
number of X (horizontal) and Y (vertical) duplications, respectively, of a selected object.  

The Column Spacing and Row Spacing boxes allow you to enter a value, in current units, to 
determine the spacing between the duplicated objects. With Column Spacing, a positive value 
duplicates to the right, a negative value to the left. With Row Spacing, a positive value duplicates 
up, a negative value down. For example, if you specify 350 mil for Column Spacing and 350 mil for 
Row Spacing, and specify 3 rows and 3 columns, the result is a matrix with 9 objects 350 mils apart, 
as shown in the following illustration. 

 

The values represented default to mm (millimeters), mil, or in (inches) depending on what you have 
set in Options » Configure (your current units). You can specify a measurement value (overriding 
Options » Configure) by typing in mil, mm, or in after the numeric value. 

Duplicating an Object 
To duplicate an object, follow these steps: 

1. Select the object(s) you want to duplicate by clicking the objects to highlight them.  

2. Choose Edit » Copy Matrix to open the Edit Copy Matrix dialog.  
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3. In the Number of Columns box, specify how many duplications you want to perform 
horizontally. In the Column Spacing box, enter a value to determine the spacing between 
duplications and in which direction (positive=right, negative=left) to duplicate.  

4. In the Number of Rows box, specify how many duplications you want to perform vertically. In 
the Row Spacing box, enter a value to determine the spacing between duplications and in 
which direction (positive=up, negative=down) to duplicate. 

You will receive an error message if what you specify for your duplication is too large to fit in 
the Workspace. 

5. Click OK. If your duplication is unsatisfactory, select Undo to reverse the action. 

Copying Nets 
When you copy a contiguous net, P-CAD Schematic always creates a new system-assigned net 
name. CTRL/Drag and Copy Matrix provide automatic net name incrementation based on 
increment values you set using the Options Configure dialog.  

Edit Explode Part 
Choose the Edit » Explode Part command to convert a part back to its basic primitives and creates a 
collection of editable graphic objects. When you explode a symbol, the collection of objects is no 
longer a part and the default pin designators are updated with the current pin designators. 

This feature is useful for modifying an existing part or creating a new part from an existing one. 
After you explode the symbol, you can then perform changes to the objects, such as adding more 
pins, changing line size or thickness, renumbering pin designators, etc. To aid in creating a new 
component, the pins default pin designators are updated with the values of the current pin 
designators after exploding. 

Make sure that the part you are editing has not been flipped because if some objects in the symbol 
are flipped and others aren't, the behavior might be unexpected when you flip the symbol. 

Edit Align Parts 
Parts can be aligned around a selection reference point either horizontally or vertically, and as an 
option, equally spacing the parts. Or, if a number of parts are off-grid, these parts can be aligned 
back on-grid.  

There are two important things to remember about the Edit » Align Parts command: 

• The alignment of parts cannot be undone.  

• The alignment of parts has full macro support. 
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Edit Select All 
Choose Edit » Select All to select all items on the current sheet. For more information on this 
command, see Selecting All Objects (page 80). 

Edit Deselect All 
Choose Edit » Deselect All to cancel the selection of all selected items.  

Edit Highlight 
Select one or more items in your design and choose Edit » Highlight to apply the current highlight 
color to those items. The objects retain the highlight color until you use the Edit » Unhighlight 
command to remove the highlight color from an item. 

You can also access this command by selecting an item or items, right-clicking the items and 
choosing Highlight from the shortcut menu. 

This command interacts with the DDE Hotlinks feature. 

Edit Unhighlight 
Choose Edit » Unhighlight to remove the highlight color from the items you select. As a shortcut 
for choosing this command, you can also select an item, right-click and choose Unhighlight from 
the shortcut menu. 

This command interacts with the DDE Hotlinks feature. 

Edit Unhighlight All 
Choose Edit » Unhighlight All to remove the highlight color from all items on all sheets in the 
design. When you use this commands, the objects typical color is restored. This command applies 
to all highlighted objects, regardless of whether they are selected or not. 

This command interacts with the DDE Hotlinks feature. 

Edit Select Highlight 
Choose the Edit » Select Highlight command to select all highlighted objects in your design. This is 
useful when you want to edit a group of highlighted objects. 

Your block selection criteria determines which highlighted items are selected when you use this 
command. To set block selection criteria, see Options Block Selection (page 287). 



Edit Parts Chapter 13: Edit Commands 

P-CAD Schematic User’s Guide 239 

In addition, this command won’t select highlighted sub-items within an object. For example, if you 
highlight two pins within a component and choose Edit » Select Highlight, neither the pin nor the 
component will be selected. 

If any items are selected, but not highlighted, when you choose Edit » Select Highlight, those items 
remain selected. For example, highlight three components on a sheet and then select another 
component, but do not highlight it. Now, choose Edit » Select Highlight. P-CAD Schematic selects 
the three highlighted components, and the other component remains selected. 

Edit Parts 
Choose Edit » Parts to edit parts within your design and to jump to a particular part. This command 
also allows you to highlight parts and nets attached to a particular part.  

 

Parts List Box 
The Parts list box contains the names of all parts in the active design. You can select individual or 
multiple parts in the list box. Once selected, you can highlight and unhighlight parts and attached 
nets and jump to a part.  

When you close the dialog, parts selected in the list box are automatically selected in the design.  

Set All/Clear All  
If you want to select all parts in the Parts list box, click the Set All button. If you don't want any parts 
selected, click the Clear All button. 

Properties 
The Properties button accesses the Part Properties dialog for the selected part or parts. See Part 
Properties (page 212) for details. 
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Highlight/Unhighlight 
 The Highlight button highlights the part or parts selected from the Parts list box in the current 
highlight color set in the Colors tab of the Options Display dialog. You can use this feature to 
highlight objects using different colors. When you change the highlight color of one object, it does 
not affect the highlight color of the other highlighted objects. 

When you choose this command, the selected parts are drawn in the highlight color and remain 
displayed in that color until the highlighting is removed. The selected color overrides the highlight 
color, so you won't see the highlights until the parts are deselected. 

If P-CAD Schematic and P-CAD PCB are both running, and if the DDE Hotlinks check box in the 
Options Configure dialog is selected in both programs, then part highlight information is 
communicated between the two programs. Highlighting a part in P-CAD Schematic highlights the 
corresponding component in the P-CAD PCB. 

If you change the highlight color of an object in P-CAD PCB, the corresponding object in P-CAD 
Schematic is automatically updated with the same highlight color. 

The Unhighlight button removes the highlighting from the selected part or parts.  

Highlight/Unhighlight an Attached Net 
You can highlight nets, which are attached to the part or parts selected in the Parts list box:  

1. To highlight attached nets, select a part from the Parts list box. (You can use the Set All button 
if you want to select all parts in the list for highlighting.) 

2. Click the Highlight Attached Nets button. The attached nets, including bus connections, 
junctions, ports, wires and pins, are highlighted with the highlight color set in the Colors tab of 
the Options Display dialog. 

3. To remove a highlight, select the part from the Parts list box. 

4. Click the Unhighlight Attached Nets button. 

Jump 
This button allows you to jump to the selected part: 

1. Select one part from the list. 

2. Click Jump to jump to the specified part. The specified part appears in the center of your 
workspace. 

Edit Nets 
Choose Edit » Nets to select nets, edit net attributes and to rename and delete nets and buses. A 
net is an electrical connection (e.g., two pins connected by a wire). Buses are a graphical 
representation of a bundle of one or more wires used to show multiple parallel wires on the 
schematic.  
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When you choose Edit » Nets, the following dialog appears: 

 

• Rename (button). Click this button to open the Net Name dialog, which gives you the ability to 
rename the selected net. 

• Edit Attributes (button). Select a net in the Net Name list and click this button to open the 
Attributes dialog, which gives you the ability to modify net attributes. 

• View Attributes (button). Select a net in the Net Name list and click this button to open the 
Attributes dialog, which gives you the ability to view net attributes.  

• Highlight (button). Select a net and click this button to highlight the net. 

• Unhighlight (button). Select a net a click this button to remove the highlight color from the 
selected net. 

• Select (button). Select a net and click this button to select the net in the schematic design. 

• Delete (button). Select a net a click this button to delete the selected net from the schematic 
design. 

Type Frame 
• Net (button). Choose this button to edit nets. 

• Buses (button). Choose this button to edit buses. 
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Net Filter Frame 
• All Nets (button). Choose this button to view all nets. 

• Global Nets Only (button). Choose this button to view only global nets. 

Net Names/Bus Names 
• Net Names (list box). This list contains the names of all nets in the active design. Nets from 

global power pins also appear in the list box. You can select individual or multiple nets in the 
list box. Once selected, you can edit net attributes, rename a single net, delete nets, and select 
nets.  

• Bus Names (list box). This list contains the names of all buses from the active design. You can 
select individual or multiple buses in the list box. Once selected, you can delete or rename 
buses. 

• Set All Nets (button). Click this button to select all nets listed in the Net Names or Bus Names 
list box. 

• Clear All Nets (button). Click this button to cancel the selection of all next listed in the Net 
Names or Bus Names list box. 

• Set Nets by Attribute (button).  

• Set Nets by Node Count (button). Nets with a specific number or range of nodes can be 
selected by entering the Min and Max values and clicking the Set Nets By Node Count button. 

Nodes 
• Nodes (list box) contains the list of nodes in the selected Net or Bus.  

• Jump to Node (button). After selecting a Net Name and then one of the Nodes in the net, click 
the Jump to Node button to be placed in that node’s location. 

• Remove Node (button). You can select a node from the list of nodes on a net and remove that 
node from the net by clicking the Remove Node button. 

Sheets 
• Sheets (list box). When a net from the Net Names box is selected, the Sheets box contains a list 

of the sheets on which the select net appears. 

• Print Sheets (button). Click this button to open the File Print dialog, with the sheets selected in 
the Sheets box of the Edit Nets dialog selected in the Sheet box of the File Print dialog. For 
details on the File Print dialog, see File Print (page 172). 
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Attributes Dialog 

 

The dialog contains a two-column spreadsheet showing the collection of net attributes. 

The Place Attribute dialog appears as follows: 

 

The following information appears in the dialog: 

• Attribute Category (list box): Displays a list of all attribute categories: All, Component, Net, 
Clearance, Physical, Electrical, Placement, Manufacturing, Router, and SPECCTRA. Selecting a 
category brings up a list of predefined attributes for that category. 
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• Name (list box): Displays all predefined attributes for the specified category. The first entry in 
the list is User-defined. The currently-selected attribute also appears in the Name box, unless 
User-defined is selected. In that case, the Name box is blank so that you can enter a user-
defined attribute name. 

• Name (text box): For user-defined attributes, enter a name for the attribute.  

If the dialog is accessed for an attribute that already has a name, then the Category list box, 
Name list box, and Name box are filled in, but shaded. If the attribute doesn’t have a name, 
these controls are enabled. 

• Value: Use this box to enter a value for the attribute. 

• Visible: This check box indicates whether or not the attribute is visible. 

• Location: This frame shows the X and Y coordinates of the component’s reference point. 

• Text Style: This frame lets you select the attribute text style. Text styles appear in the Text Style 
drop-down list box. To change the selected Text Style, click on the text style you want from the 
list box. To modify the text style, click the Text Style button. 

• Rotation: Shows the rotation amount if the pattern has been rotated. 

• Flipped: This box indicates whether or not the pattern has been flipped.  

• Justification: Under Justification are nine buttons, which allow you to change text justification 
by setting the reference point of the text string. For example, if you enable the middle button, 
the text reference point (the lower-left corner) moves to the center of the bounding rectangle. 

Rename 
The Rename button is enabled only when you have highlighted a single net or bus.  

For Nets 
When you highlight a single net name in the Net Names list box, the Rename button becomes 
active. Click Rename and the Net Name dialog appears: 

 

Type a new name and click OK to rename the net and return to the Edit Nets dialog. If the name is 
already assigned to another net, and one of the nets is not global the following error message 
appears: 
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You must confirm that you want the autoplace Ports to make both nets global by clicking the Yes 
button. Ports are placed on both nets and the net is renamed. 

For Buses 
When you highlight a single bus name in the Bus Names list box, the Rename button becomes 
active. Click Rename and the Bus Name dialog appears: 

 

Type a new name and click OK to rename the bus and return to the Edit Nets dialog. If the name is 
already assigned to another bus, you are asked if you want to merge the buses. 

View Attributes 
When you click the View Attributes button, a report showing the attributes and their values is 
generated and displayed in the Notepad. 

An example of the report is shown in the following figure: 

 

Highlight/Unhighlight Nets 
When the Net radio button is selected, the Highlight button highlights the net or nets selected 
from the Net Names list box in the current highlight color set in the Colors tab of the Options 
Display dialog. Highlighted items include bus connections, junctions, ports, wires and pins. If 
hotlinks are enabled, the corresponding nets are highlighted in PCB. 

This options works in the same way as the Edit Highlight command discussed above. 
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The Unhighlight button removes the highlighting from the selected net(s) and included items. If 
hotlinks are enabled, the corresponding nets are no longer highlighted in P-CAD PCB. 

Highlight/Unhighlight Buses 
When the Bus radio button is selected, the Highlight button highlights the bus or buses selected 
from the Bus Names list box in the current highlight color set in the Colors tab of the Options 
Display dialog.  

The Unhighlight button removes the highlighting from the selected bus or buses.  

Delete 
The Delete button deletes nets or buses highlighted in the list box. 

Select 
The Select button selects all items in the nets highlighted in the list box. Select is sensitive to the 
settings in Options Block Selection. 

You can select a net or multiple nets in the design by highlighting the net names in the list box in 
the Edit Nets dialog, then clicking the Select button (the button is available only if a net is chosen). 
The nets in the design are displayed in the selection color. You can also select nets through the 
Select shortcut menu.  

Edit Measure 
Choose the Edit » Measure command to measure the X distance, Y distance, and total distance 
between two points. As a shortcut for choosing this command, click the Edit Measure toolbar 
button. You can measure vertical, horizontal, and diagonal distances and the results will be 
displayed on the status line. The measurements appear either in mils, millimeters or inches 
depending on the current settings in Options Configure.  

The Measure tool remains enabled until you enable another tool. 

Using Edit Measure 
To measure between two points on your workspace: 

1. Choose Edit » Measure or click the toolbar button.  

2. Move the cursor to the first point of your measurement in the workspace. Click and drag to the 
end point of the measurement.  

3. The results will be displayed on the status line for X distance, Y distance, and T (for total) 
distance (in mm or mils). You can't see the measurements if the status line is disabled (View » 
Status Line). 

Measuring with the mouse does not snap to grid if you have View » Snap to Grid disabled. 
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Edit Select 
Choose the Edit » Select command to enable the Select tool. When you are in Select mode, you can 
select objects in a design and perform various actions on those objects. As a shortcut for choosing 
this command, you can click the toolbar button or press the S key. 

Status Line Information 
The status line information area identifies selected items, either specifically (part reference 
designator, net name, or bus name) or generally (number of items selected). 

 

Select Commands 
When you are in Select mode, the following commands are available: 

• Edit Cut 

• Edit Copy 

• Edit Copy to File 

• Edit Paste 

• Edit Paste From File 

• Edit Delete 

• Edit Copy Matrix 

• Modify 

• Edit Explode Part 

• Edit Highlight 

• Edit Unhighlight 

In addition, Select Net is available from the Select shortcut menu or through Edit » Nets. 

Select actions are possible only if an object is selected. For example, you cannot move a part unless 
it is selected; you cannot modify a line unless it is selected. 

Information included in this section only covers the mouse/cursor actions for Select:  

• For keyboard equivalents to standard mouse functions in P-CAD Schematic, see Keyboard 
Reference (page 377). 

• For the Edit menu command descriptions, refer to the respective command in this chapter.  
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Selecting Objects 
• To single select, click an object. All other selected objects are deselected. Selected objects are 

drawn in the selection color, and are contained within a boundary box. Primitive objects (arcs, 
lines, etc.) have handles (small squares used for sizing an object). 

• To multiple select, first select a single object, then hold down the CTRL key and click on 
additional objects/items. The selected objects are surrounded by a selection box, and the 
selection box increases as you add items to the multiple selection. Click again on selected 
items (still using the CTRL key) to deselect them individually. If you release the CTRL key and 
click anywhere other than one of the selected objects, all are deselected.  

These are the default keys, but you can use the Options Preferences dialog to change these 
select keys. 

• To subselect, hold down the SHIFT key and left mouse click the object. This command lets you 
select a single item on an object (a pin on a part). Once selected, you can view and, in some 
cases, modify properties for the item selected. 

• To select all objects, choose the Edit » Select All command. All objects on the current sheet in 
the current design are selected. 

• To deselect all objects, click on an empty area of the Workspace to deselect all items or choose 
the Edit » Deselect All command. 

• To block select, click, hold and drag the cursor to create a selection box surrounding a block of 
objects, then release the button. You can add or delete objects to or from the block selection 
individually by doing a multiple select. To cancel while dragging the selection box, right-click. 

• If you have the Outside Block radio button selected in the Options Block Selection dialog, 
then the selection occurs outside of the selection block. If you have the Inside Block radio 
button selected, then the selection occurs inside of the selection block. If you have the 
Touching Block option enabled, a block selection includes everything inside and touching the 
selection box. 

• A block selection mask can be used. Objects can be filtered or masked in a variety of ways, 
depending on how you set up the selection options. Use the Options » Block Selection 
command to set the selection options; refer to the command documentation for complete 
information. 

When Objects Overlap 
When objects overlap, it may seem difficult to select an underlying object. Continue clicking 
without moving the cursor and Select cycles through all objects underneath the cursor. The 
SPACEBAR is easier to use than the mouse in this situation (pressing the SPACEBAR twice equals 
click and release for the left mouse button). 

Moving and Copying Objects (Drag-and- Drop) 
To move an object, first select it, then click on the object and drag the cursor (with the object 
attached) to the new location. Release to place the object. 
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If you are moving multiple objects, click anywhere in the selection box and drag; all the selected 
objects in the box follow. Release the button to place the objects. 

You can copy objects in the same manner; after you select the objects, hold the CTRL key down 
and drag a copy of the objects to where you want to place them. When copying a part, the RefDes 
(reference designator) changes in the copy. When copying non-global nets, the copy’s net name is 
incremented or decremented depending on the value you set for the Options » Configure Net 
Increment option. To cancel a move or copy in progress, right-click while holding down the left 
mouse button. 

Resizing Objects 

 

You can resize a selected object by clicking on one of its handles, and dragging to stretch the 
object. The resize function varies for the different objects. For example, to resize an arc you click 
on one of the endpoint resize handles and drag the endpoint to increase the sweep angle.  

To resize a polygon, you can grab one of its vertex handles and move it to change the polygon. 
When you move a handle that is on an edge between two vertices, a new vertex is created. You can 
delete a vertex by moving it to an adjacent vertex and releasing. 

Wires, buses, lines, arcs, and polygons can be resized with the Select mode resize function. 

Rotating and Flipping 
Select an object. This function works on multiple- or block-selected objects as well. 

Press R to rotate 90 degrees counterclockwise. To flip the object in the X direction (about the Y 
axis), press F while the object is selected. For items with associated connections, press the left 
mouse button while rotating or flipping to prevent reconnection attempts each time you rotate or 
flip. Connections are committed when the left mouse button is released. 

Edit Properties 
With the Select tool enabled, choose Edit » Properties or use the shortcut menu after an object is 
selected. This displays a Properties dialog for the selected object. For details, see Edit Properties 
(page 211). 

Select Contiguous  
The Select Contiguous command allows the selection of all contiguous net objects of a selected 
net. 

For example, to use the Select Contiguous command: 

1. Select a wire or port. 
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2. Right-click the wire or port to open a shortcut menu.  

 

3. From the shortcut menu, choose the Select Contiguous command.  

All contiguous net objects of the net are selected unless you set the Block Selection mask to filter 
out wires or ports. 

This feature will only work for one net at a time. 
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CHAPTER 14 

View Commands 

Using the View Commands 
The View commands allow you to temporarily alter the display characteristics of your workspace to 
better pinpoint locations and objects in your design. You can also alternately enable or disable the 
information displays and the toolbar. 

For more permanent adjustments to your display characteristics, such as color display and style 
changes to objects, refer to the Options menu. 

View Redraw 
Choose View » Redraw to clear and then repaint the active window without changing the current 
view. 

Use View » Redraw when you have leftover wires and shapes from moving or deleting objects, to 
erase leftover graphics. 

To interrupt a redraw in progress, right-click or press ESC. 

View Extent 
Choose View » Extent to display the extent of all objects on the current sheet in the active window. 

P-CAD Schematic computes and draws the workspace so that all objects on the current sheet are 
visible. Any items on the title sheet are not considered in the extent. 

View Last 
Choose View » Last to redraw the previous view for the active window, if you have altered the view 
in any way in this window.  

There is no previous view until you run at least one View command that changes the view area. If 
you run View » Last multiple times, you toggle between the last two views. 
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Scrolling does not affect the previous view. 

View All  
Choose View » All to redraw the entire workspace in the active window.  

The workspace size displayed is determined by the Workspace Size option set in Options 
Configure. If you want to make the workspace smaller to fit the design you are working on, then 
size it accordingly using Options Configure. The scroll bars don’t appear at this zoom level.  

View » All is the default view when you start up P-CAD Schematic with an empty workspace. 

View Center 
Choose the View » Center command to redraw the screen using the cursor as the relative center 
point.  

When you choose View » Center, the cursor takes the shape of a magnifying glass. Move the cursor 
to a point on your design and click the workspace. The point where you click is centered on the 
screen. To cancel the zoom after the magnifying glass cursor appears, you can right-click or press 
ESC. 

As a shortcut for choosing this menu command, move the cursor to a point in your design and 
press the C key. This is quick way to pan across your workspace. You don't need to click the mouse 
button, just move the cursor to the point you want centered and press C.  

View Zoom Out 
Choose the View » Zoom Out command to zoom out by the magnification factor set in Options 
Configure. This is a temporary mode that does not affect the mode you may be operating in. 

When you select View » Zoom Out, the cursor takes on the shape of a magnifying glass (the zoom 
cursor), prompting you to click for the center point of the zoomed area. The cursor position 
becomes the center of the zoomed-out area. You must reinvoke the command for every zoom 
action. To cancel the zoom after the zoom cursor appears, right-click or press ESC. 

Minus Key (-) 
An easier way to zoom out is to press the minus key (-) as a shortcut (the keypad minus key is also 
functional). Your current cursor location becomes the center of the zoom action when you press 
the minus key; you don't have to click the workspace. 

View Zoom Window 
Choose the View » Zoom Window command or click the toolbar button to zoom in on an area of 
the workspace. When you choose this command, the zoom window tool becomes active. As a 
shortcut for choosing this command, press the Z key. 
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You use the zoom window tool to draw a bounding outline around a selected region of your 
workspace. A bounding outline is dotted rectangle that appears when you drag the mouse cursor 
across your workspace, to select a range of items or a design region. The bounding outline is also 
called a selection block or zoom window. 

The zoom window mode is a temporary mode that does not affect whatever other mode you may 
be operating in. 

Zooming In with a Zoom Window 
To zoom in on a region of the design with a zoom window, follow these steps: 

1. Press the Z key, click the Zoom button on the toolbar, or choose the View » Zoom Window 
command. The cursor takes the shape of a white magnifying glass shape.  

2. Press and hold down the left mouse button. Then, drag the mouse cursor across your 
workspace to draw a bounding outline around the region you want to view.  

3. Release the mouse button when you have completed the bounding outline. Whatever you 
surround with the outline will be enlarged on the active window.  

The mode you were in is still active and will resume after you do the zoom window action (the 
zoom window action is a temporary mode).  

You must drag the cursor to create a zoom window. If you click and release in the active window 
workspace without dragging the cursor, the program responds with a beep, and does not zoom in. 

To cancel the zoom action once the zoom cursor appears, right-click or press ESC. 

View Jump Location 
Choose the View » Jump Location command to move the cursor to a specified location (X, Y 
coordinates).  

This command pans the active window to the specified location, attempting to center the location. 
Your current zoom setting is not changed by the jump location panning (except View » Last is 
updated). If the specified location is already visible on the active window, no panning is necessary. 

The units used for the location value (mil, mm, or in) are determined by the setting in Options 
Configure. Choose Options » Configure to override the default settings. 

The location is also based on the Options Grids setting, either Absolute or Relative; e.g., if your grid 
setting is in Relative mode, then the location is a Relative coordinate. Also, you can use negative 
coordinate values when in Relative mode. Refer to Options Grids (page 295) for more information. 

Jump to a Location 
1. Choose the View » Jump Location command. The following dialog appears: 
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2. In the dialog, specify the X and Y coordinates (in the boxes) of where you want your cursor to 
be in the workspace.  

3. Click OK. 

View Jump Text 
Choose the View » Jump Text command to search through all text strings to locate a specific 
combination of letters. The character string that you specify can be part of a word or a complete 
word.  

 

Case Sensitive Search. Select this check box to search for text matches based on case. If you disable 
this option, text case will be ignored in the search. 

Search Entire Design. Click this check box to search all sheets for the specified text string. It will 
search only the current sheet when you clear the check box. 

Jump to Text 
1. Choose View » Jump Text. The View Jump Text dialog appears.  

2. Type the text you want to search for in the Text box. Notice that the OK button is grayed out. 
Click Search.  

3. If the matching text is not already on the active window, the program pans the active window 
at the current zoom level to locate the text and center its reference point. You can set the text 
reference point by setting the justification with the Options Text Style command.  

4. After P-CAD finds the first instance of the specified text string (highlighting it in the highlight 
color), the Search button changes to Next, allowing you to find subsequent instances of the 
same text string. You can continue to cycle through all occurrences of the search pattern until 
you click Cancel or OK. 

Once a string has been found, the OK button is no longer grayed; if you click it, the program moves 
the cursor to the highlighted text and the highlighting disappears. 
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Highlighted text may be obscured by the dialog; move the dialog to view the text if necessary. 

View Descend  
In a hierarchical schematic design, you can easily move down the hierarchy by choosing the View » 
Descend command. When you select a module, the View Descend command becomes available. 
Choose View » Descend and the Hierarchy Navigator dialog appears: 

 

Select a link pin number from the Select Pin list and click OK. The selected link becomes the 
worksheet’s focus. 

A shortcut command is available for View Descend.  

View Ascend  
In a hierarchical schematic design, you can easily move up the hierarchy by choosing the View » 
Ascend command. When you select a link pin, the View Ascend command is enabled. Choose View 
» Ascend and the Hierarchy Navigator dialog appears: 

 

Highlight a module reference designator and click OK. The selected module becomes the 
worksheet’s focus. 
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A shortcut command is available for View Ascend.  

View Command Toolbar 
Choose the View » Command Toolbar command to show or hide the Command toolbar. A check 
mark next to the toolbar menu item indicates that the toolbar is visible. The toolbar gives you quick 
access to the most frequently used editing commands (such as the Select tool).  

 

Disabling the command increases the space within the active window. 

The setting of the toolbar visibility is saved to your Sch.ini file when you quit the program, and 
restored when you restart it. 

View Placement Toolbar 
Choose the View » Placement Toolbar command to show or hide the Placement toolbar. The 
toolbar gives you quick access to the most frequently used Place commands.  

 

Disabling the command increases the space within the applicable window. 

The setting of the Placement toolbar visibility is saved to your Sch.ini file when you exit the 
program, and restored when you restart it. 

View Custom Toolbar 
Choose View » Custom Toolbar to either show or hide the custom toolbar. A check mark next to 
this menu command indicates that the Custom toolbar is visible. 

If no tools have been added to the custom toolbar, the display of the toolbar is turned off. As soon 
as the first custom tool has been added using the Utils » Customize command, the Custom toolbar 
display is turned on. When custom tools exist in the Custom toolbar, you can turn off the display of 
the toolbar by choosing View » Custom Toolbar. 

View Prompt Line 
Choose View » Prompt Line to either show or hide the prompt line. The prompt line gives 
instructions on what to do in certain modes. 
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A check mark alongside the command indicates that the prompt line is visible. Disabling the 
command increases the space within the applicable window. 

The setting of the prompt line visibility is saved to your Sch.ini file when you exit the program, 
and restored when you restart it. 

View Status Line 
Choose View » Status Line to either show or hide the P-CAD Schematic status line. The status line 
provides status information and allows you to change sheets and execute temporary macros. 

 

A check mark alongside the command indicates that the status line is visible. Disabling the 
command increases the space within the applicable window. 

The setting of the status line visibility is saved to your Sch.ini file when you exit the program, and 
restored when you restart it. 

View Snap to Grid  
Choose the View » Snap to Grid command to turn on and off a snappy cursor. When a check mark 
precedes the command, a snappy cursor moves from grid point to grid point. When the command 
is not checked, a free floating cursor moves freely between grid points.  

A snappy cursor can create a predictable point of reference when you move and rotate objects or 
measure distances. A free floating cursor can enhance your ability to select items in the workspace, 
such as when you want to select a line that does not run true along grid points. 

The View Snap to Grid command does not support the DataTips feature. When View Snap to Grid 
is a checked command, the DataTips feature is temporarily disabled. 

Your current View Snap to Grid setting (on or off) is saved in the Sch.ini file when you quit the 
program. 
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CHAPTER 15 

Place Commands 

Using the Place Commands 
Use the commands in the Place menu to place various items and objects in a design. After you 
choose a command, click the workspace to place the selected item. With some commands, a dialog 
box appears so you can select specific properties for the item you are about to place. 

Before an item is placed in a design, it appears in a highlighted color to distinguish it from placed 
items. Once placed, they appear in their normal color. To modify an object after it has been placed 
in a design, select the object and choose Edit » Properties. 

Place Part 
Choose Place » Part to place a part in your active design. With this command, you can select the 
type of part to place, as long as the part and its corresponding symbol has been created and 
assigned to an open library. 

Parts of the same type in different libraries can be placed only if they have the same pin mapping 
(i.e., pin designator to pin name to pad number). In other words, if you place the “same” part from 
different libraries, the first instance of the part type establishes the standard pin mapping for that 
type of part. Any parts of that type placed subsequently have to conform to the pin order of the first 
or they cannot be placed. 

When you place parts that include text with styles that have the same names but different 
definitions than those in the current design, the new style names are bracketed to indicate the style 
conflict. The bracketed style names are added to the list of available styles in the current design. For 
additional information, see Edit Properties (page 211) and Options Text Style (page 314) and the 
P-CAD Library Executive User’s Guide. 

Placing a Part 
To place a part, follow these steps: 

1. Choose Place » Part or click the Place Part button in the Placement toolbar. 
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2. Click the workspace. The following Place Part dialog appears. 

 

3. Select a part from the Component Name list. The list shows all of the components in the library 
currently selected in the Library list. To view the contents of another library, select a library 
from this list. 

To add a library to this list, click Library Setup. For more information, see Library Setup (page 
325). 

4. Click Browse to expand the dialog and view a graphical representation of the part, as shown in 
the following figure: 
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5. In the Part Num box, select which gate in the highlighted component will be placed first. To do 
this, type the part number in the box. Notice that the Num Parts field shows the number of 
parts associated with the selected component.  

6. In the Alternate frame, choose one of the following radio buttons to select a graphical 
representation: Normal, IEEE, or DeMorgan.  

In addition to the typical commercial representation of components, P-CAD Schematic 
includes IEEE and DeMorgan representations of many parts. The IEEE alternate representations 
are based on the component specifications from IEEE/ANSI Standard 91-1984. 

7. Specify a reference designator in the RefDes box. 

If you leave this field blank, the program uses the default RefDes prefix assigned to the part at 
part creation. If you do not assign a number, the program automatically assigns the next 
available number. 

8. If the component being placed has a value, it is displayed in the Value box. You may change 
the value in the Value box, when necessary (e.g., electrical values for resistors and capacitors; 
typically blank for logic parts). The new value overrides the value taken from the library 
component. 

When a Value attribute exists in the component, its value is displayed in the Value box based 
on the following rules: 

• If the symbol has a Value attribute and there is no component Value attribute, the 
symbol’s Value attribute value is used. 

• If the component has a Value attribute, the component’s Value attribute value will take 
precedence and be used even if the symbol has a Value attribute value. 

9. Click OK when the desired information is displayed in the Value box. The Place Part dialog 
closes. You are now in part placement mode. 

10. Choose one of the following methods to place the part: 

• Move the cursor to the location in the design where you want to place the part. Click to 
place it. 

• Press and hold the left mouse button down to display a ghosted outline of the part. Drag 
the ghosted outline to the desired location and release the left mouse button to place the 
part.  

• Hold down the ALT key and click the left mouse button. Release the ALT key and move the 
part with the mouse. You do not have to hold down the left mouse button. Then, click to 
place the part. To cancel placement of the part, right-click. 

To rotate or flip a part, press R or F while holding down the left mouse button. For details, see 
Rotating Objects During Placement (page 86). 
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11. Continue to place the same part by clicking the desired locations in the workspace. Notice that 
each part is given a unique reference designator. 

To change the displayed part number to the next available value, press P; to change to the 
previous available value, press SHIFT+P. To select the next available reference designator, 
press D. To select the previous available reference designator, press SHIFT+D. 

12. If you want to place a different part, right-click or press ESC to stop placing the selected part. 
As you are still in part placement mode, you can click the workspace to open the Place Part 
dialog and select another part to place (as in step 2). 

To gain access to the embedded Query utility, click the Query button. For details on this feature, 
see the Library Executive User’s Guide. 

Power Components 
Power Components are used to rename nets. For example, connecting a GND power component to 
a net will force that net to have a net name of GND. Although they have reference designators, 
power components do not appear in any netlist you generate. Create a power component by 
selecting the Power radio button in the Save Component As dialog; the pin name is the name of the 
net that will be created. See Library Symbol Save As (page 326) for more information. 

If you place a power component that has a pin name such as GND or VCC when the design 
contains a non-global net with the same name, a warning message appears. The message informs 
you that a port has been added to the net and shows the sheet number where the port was placed. 

Splitting a Net 
This section explains how the Place Part command handles the resulting net splitting when a two-
pin part is placed, copied, or moved on top of a single wire segment. The portion of the wire 
between the two pins is deleted so that the wires connect to the pin endpoints.  

Net Naming for Delete and Insert Part  
Splitting a net, by inserting a part over a wire segment (or deleting a wire segment) results in 
retaining the original net name on one side, and renaming the other to a new system-assigned net 
name.  

If a port or power symbol is attached to a net created by the splitting process, that portion of the 
net retains the original name. If both portions are attached to a port or power symbol, then both 
keep the original net name. 

Jumper Pins 
Components with jumper pins are handled in a special way. Any time this command adds a pin to a 
net, P-CAD Schematic checks to see if the pin is a jumper pin. If it is, the component behaves as if 
all of the pins marked as being jumpered together are connected. Jumper pins are ported to force 
them to belong to the appropriate net. 
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Place Wire  
Choose Place » Wire to place a wire or series of wire segments on the current sheet.  

When you place a wire, the wire is the width specified in the Options Current Wire dialog. To 
change the current wire width, choose Options » Current Wire. 

Wires can start or end on a pin, on a bus, in an open space or on another wire. If you place a wire 
so that it ends on a wire or pin, the wire is automatically connected. Unconnected wires display 
open ends if the Display Open Ends check box is selected in the Miscellaneous tab of the Options 
Display dialog. To indicate that the wire is unconnected, open ends take the shape of small boxes at 
the end of a wire. Starting or ending a wire on an existing wire automatically creates a junction. 
Starting or ending a wire on a bus creates a bus entry. 

The illustration on the left shows three wire segments. Where they intersect is a junction. The 
illustration on the right shows a bus connection where the wire is connected to the bus, and an 
open end where the wire is unconnected.  

  

1. Choose Place » Wire or click the Place Wire toolbar button. 

While you draw a wire or wire segments, the cursor is displayed as a crosshair shape to 
indicate that wire placement is in progress. 

2. With the cursor in the active window, click and hold the button at the starting point, then drag 
the wire to its second point and release to place the wire. You can continue with connected 
segments in the same manner. 

You can press ALT+left click instead so you don't have to hold the button down while dragging 
wire segments. 

You can unwind any wire segments by pressing the BACKSPACE key or backtracking the 
mouse over the wire segments. If you have finished the wire segments, press ESC or the right 
mouse button, choose Edit » Undo, or click the toolbar button to undo the whole series of 
finished segments. 

3. To finish the wire or wire segments, right-click or press ESC. Then you can begin another wire 
beginning at a new location. 

4. If you are creating a new net, the Net Name is automatically assigned. Each successive net is 
incremented by the increment value you set up in the Options Configure dialog. 

You remain in wire placement mode until you choose another command. 
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Adding Wires to Nets  
When you connect a new wire to an existing net, it automatically places a junction. If the existing 
wire belongs to a different net, the following dialog appears: 

 

With the Merge Contiguous Nets dialog, you choose the net name after the nets are merged. The 
Name the Contiguous Net combo box shows the net names of the existing nets. Select a net name 
from the list or type a new name and click OK. 

Jumper Pins 
Any time a wire adds a pin to a net, P-CAD Schematic checks to see if the pin is a jumper pin. If it is, 
the component behaves as if all of the pins that have been as being jumpered together are 
connected. Jumper pins are ported to force them to belong to the appropriate net. 

Orthogonal Modes 
There are orthogonal modes that you can use while placing wires. While you are in wire placement 
mode and dragging a wire segment, you can press the O key while holding down the left mouse 
button to switch between the enabled orthogonal modes. 

Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles. Press the O key 
to switch between the enabled modes. You can enable or disable the orthogonal modes in the 
Options Configure dialog. The non-orthogonal mode, with straight line placement at any angle, is 
always enabled. 

The 90/90 and 45/90 orthogonal modes are provided as mode pairs. Press the F key to switch 
between the current mode pair. 

90/90 Line-Line 
Wires are placed horizontally and vertically in 90/90 Line-Line mode. In the first mode, the first wire 
segment is always longer than the second. In the second mode, the first segment is shorter. You 
can switch between the two by pressing the F key. 
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45/90 Line-Line 
With 45/90 Line-Line mode, you can press the F key to switch between the two modes. The first 
mode makes the first segment displayed at a 45-degree angle and the second segment is either 
horizontal or vertical. The second mode makes the first segment either horizontal or vertical and 
the second segment is displayed at a 45-degree angle. 

 

Place Bus 
Choose the Place Bus command to place a bus (or series of bus segments) on the current sheet. 
Buses are used to show multiple parallel wires on the schematic, such as address and data lines. 
Buses graphically represent a bundle of one or more wires. 

To place a bus, follow these steps: 

1. Choose Place » Bus or click the Place Bus toolbar button. 

While you draw a bus or segments, the cursor is displayed as a crosshair shape to indicate that 
bus placement is in progress. When you finish the bus segments, the cursor returns to its 
normal shape. 

2. With the cursor in the active window, click and hold the left mouse button at the starting point, 
then drag the bus to its second point and release to place the bus. You can continue with 
connected segments in the same manner. 

You can press ALT+click instead so you don't have to hold the button down while dragging bus 
segments. 

You can unwind any previous bus segments by pressing the BACKSPACE key or backtracking 
the mouse over the segments. If you have finished the bus by pressing ESC or right-clicking, 
choose Edit » Undo or click the toolbar button to undo the whole series of finished segments. 
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3. To finish the bus or bus segments, right-click or press ESC. Then you can begin another bus 
beginning at a new location. 

You remain in bus placement mode until you choose another command. 

Status Line Measurements 

 

The status line information display area (on the right side of the status line) displays bus 
measurements for delta X and delta Y while you are dragging a bus segment. When the bus 
segment is finished, the total length measurement of the segment(s) is displayed.  

When the bus is finally placed, all measurements on the status line disappear. 

Orthogonal Modes 
The orthogonal modes that you can use while placing buses work in the same way as they do for 
wires. While you are in bus placement mode and dragging a bus segment, you can hold down the 
left mouse button and press the O key to switch between the enabled orthogonal modes.  

Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles. Press the O key 
to switch between the enabled modes. You can enable or disable the orthogonal modes in the 
Options Configure dialog. The non-orthogonal mode, with straight line placement at any angle, is 
always enabled. 

The 90/90 and 45/90 orthogonal modes are provided as mode pairs. Press the F key to switch 
between the current mode pair. For illustrations, see Place Wire (page 263). 

Bus Connections  
Bus connections are formed automatically when you connect a wire to a bus. They let you know 
that the connection has been made.  

The bus connection you place defaults to the type of connection you using the Bus Connection 
Mode field in the Colors tab of the Options Display dialog.  

To change a connection, select it, then right-click and choose Properties from the shortcut menu. 
Press the B key to switch between bus connection styles while placing wires.  

 

Select one of the three styles for the required connection. 
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Place Port 
Choose the Place » Port command to place ports in your design. Ports indicate connectivity 
between non-contiguous portions, or subnets, of the same net. In other words, ports provide a 
visible means to connect contiguous portions of a net in different locations of the design without 
having to wire them together directly. Ported nets may be on the same or different sheets.  

Display Characteristics 
Ports consist of the following items: the net name, an optional box surrounding it, and one or two 
pins to connect it to wires. Sixteen different styles of ports are provided. 

Placing Ports 
To place ports, follow these steps: 

1. Choose the Place » Port command or click the Place Port toolbar button.  

2. Click the workspace to open the Place Port dialog. If you click over a wire, the Net Name box is 
preset with the net name. Otherwise, it is preset with the last name you used. 

 

3. To increment net names when placing multiple ports, select the Increment Port Name check 
box. Net names are incremented only when the name ends in a number. 

4. Type the net name in the Net Name box.  

5. In the Pin Count frame, choose the One Pin or Two Pin radio button. 

6. In the Pin Length frame, choose the Short (5 mils) or Long (50 mils) radio button. 
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7. In the Pin Orientation frame, choose the Horizontal or Vertical radio button. 

8. Click OK to close the Place Port dialog. You are now in port placement mode. 

9. In your workspace, move the cursor to the location where you want to place the port. Click the 
workspace to place it. 

If you elected to increment ports, subsequent mouse clicks place ports with incremented net 
names, otherwise each click places a port with the same name.  

10. To rotate the port, press R while holding down the left mouse button. To change the port 
display type, press P while holding down the mouse button. 

If you are placing a port anywhere on a non-global net, an error message appears. The message 
informs you that a net can only be renamed to an existing net name if both nets are global, and 
asks if you want to autoplace ports to make both nets global. If you click the Yes button, the 
ports are placed, and nets are merged and renamed. 

11. Right-click to end the place port session. 

Hotkeys 
While placing a port, you can change the orientation of the port using a hot key. Press R to rotate 
the port or F to flip it. You can also switch between the following port styles by pressing the P key: 

• End-wire 

• Inline 

• Off-wire-side 

• Off-wire-top  

• Off-wire-bottom  

Placing an Inline Port  
If you place an Inline port over a wire, the occluded wire is automatically deleted. This is especially 
useful for labeling bus entries. If a port is not placed at a wire end or inline, a junction will 
automatically be created. 

Jumper Pins 
Any time placing a port adds a node to a net, P-CAD Schematic checks to see if the node is a 
jumper pin. If it is, the component behaves as if all of the pins marked as being jumpered together 
are connected. In Schematic, pins are ported to force them to belong to the appropriate net. 

Moving Ports  
Ports may be moved like components. If a port is moved any attached wires will be rubber banded 
to the new location. 
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Renaming Ports  
The net to which a port is attached may be renamed as follows: 

• Selecting the port and clicking the right mouse button to modify. 

• Using the Edit Nets dialog. 

• Using the Net Rename tool. 

• Selecting and modifying the net name of a wire to which the port is attached. 

Modifying a Port's Text Style 
The font and text size of all the ports can be changed by entering the Options Text Style dialog, and 
modifying the [Wirestyle]. 

Deleting Ports  
Ports may be selected and deleted, like any other object, however, when an inline port is deleted, a 
wire is automatically drawn to maintain connectivity. If you delete a port where opposing pins are 
connected to wires of different widths, the resulting contiguous wire will be of uniform width. 

Backward Compatibility 
The following rules apply when loading designs and block files from P-CAD versions earlier than 
2.60: 

• If a net is comprised of a single contiguous net, then the net is a local net. 

• If a net is comprised of two or more subnets, then the net is a global net and will have a port 
attached to each non-contiguous subnet. 

• If a net has a wire attached to a power symbol or is part of a hidden power net, the net is 
considered global. 

• If a wire has a power symbol attached to it, it does not require a port to be attached; bus 
entries do. 

• If a block is pasted into the design, the rules for porting apply as well. Nets of existing net 
names will retain their net names if they were ported; if they were not ported they are given 
unique system-assigned net names.  

Place Pin  
Choose the Place Pin command to place a free pin in the workspace. To place a pin, follow these 
steps: 

1. Choose Place » Pin or click the Place Pin toolbar button. 

2. Click the active window to open the Place Pin dialog shown in the following figure: 
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3. Select the pin length from the options in the Length box. In the Display frame, select the Pin 
Name or Pin Des check box to choose the visibility of the pin name and pin designator.  

4. In the Text Style frame, set the text style for the pin name and pin designator. Click the Text 
Styles button to open the Options Text Style dialog. From there you can add or modify existing 
text styles for your design.  

5. Type the default pin name, if desired, in the Default Pin Name box. The default pin name is a 
placeholder for the real pin name. Use this default label to change the orientation or position 
of the pin name. The default pin name, like a pin number, cannot be edited once attached to a 
symbol. 

6. Enter the default pin designator, if desired, in the Default Pin Designator box. The default pin 
designator can be edited once attached to a symbol. 

7. In the Display Characteristics frame, choose the desired characteristics by selecting or typing 
information in the four combo boxes. Click OK. 

8. You are now in the place mode of Place Pin. Move the cursor to the location in the active 
window where you want to place the pin. Click the left mouse button to place it. Or you can 
hold the left mouse button down to make a ghost, then drag and drop (release) to place it 
more accurately. (An alternate method for drag-and-drop is ALT+click, then release the ALT 
key. You can then move the pin freely with the mouse without having to keep the button 
depressed.) To cancel ghosting of a pin, right-click. 

You can rotate a pin while placing it by pressing R while holding down the left mouse button. A 
pin can also be flipped during placement using the F key while holding down the left mouse 
button. 
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You can continue to place similar pins by clicking in additional locations. Pin attributes 
previously specified (in the Place Pin dialog) are also displayed. 

9. To place a different pin, right-click or press ESC to exit the place mode for that particular pin. 
As you are still in pin placement mode, you can click the active window to open the dialog and 
select another pin to place. 

Once placed, pins can be renumbered. For more information, see Utils Renumber (page 329). 

A part’s sub-selected pin can be connected to a specified net using the Add to Net command in the 
shortcut menu.  

Pin names and pin designators can be sub-selected for moving, flipping and rotating.  

Display Characteristics 
Display characteristics include all attribute symbols that may be attached to a pin for design 
clarification. They are for graphical appearance only. You may specify display characteristics for 
each item shown in the following illustrations:  

Outside 

 

Outside Edge 

 

Inside 
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Inside Edge 

 

Place Line  
Choose the Place » Line command to place a series of line segments of the current line width on 
the current sheet. In P-CAD Schematic, lines are graphical representations only; they carry no net 
information. 

To change the current line width, choose the Options » Current Line command. 

Placing a Line 
To place a line on the workspace, follow these steps: 

1. Choose the Place » Line command or click the Place Line toolbar button. 

2. With the cursor in the workspace, click and hold the left mouse button at the starting point, 
then drag the line to its second point and release to place the line. You can continue with 
connected segments in the same manner. 

You can press ALT+click instead so you don't have to hold the mouse button down while 
dragging line segments. 

While drawing a line or segments, the cursor is displayed as a crosshair shape. When you finish 
the line or segments, the cursor returns to its normal shape. 

You can unwind any line segments by pressing the BACKSPACE key or backtracking the mouse 
over the segments. If you have finished the line segments by pressing ESC or right-clicking, 
choose Edit » Undo or click the toolbar button to undo the whole series of finished segments.  

3. To finish the line or line segments, right-click or press ESC. Then you can begin another line 
beginning at a new location.  

You remain in line placement mode until you select another tool or command. 

Status Line Measurements 

 

The status line information display area (on the right side of the status line) displays line 
measurements for delta X and delta Y while you are dragging a line segment. When the line 
segment is finished, the total length measurement of the segment(s) appears.  

When the line is finally placed, all measurements on the status line disappear. 
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Orthogonal Modes 
The orthogonal modes used while placing lines work in the same way as for wires. While you are in 
place line mode and dragging a line segment, you can press the O key while holding down the left 
mouse button to switch between the enabled orthogonal modes. 

Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles. Press the O key 
to switch between the enabled modes. You can enable or disable the orthogonal modes in the 
Options Configure dialog. The non-orthogonal mode, with straight line placement at any angle, is 
always enabled. 

The 90/90 and 45/90 orthogonal modes are provided as mode pairs. Press the F key to switch 
between the current mode pair. For illustrations, see Place Wire (page 263). 

90/90 Line-Line 
Both lines are either horizontal or vertical (displayed perpendicular to each other). For long, the 
first segment is always longer than the second. For short, the first segment is shorter. You can 
switch between the two by pressing the F key. 

45/90 Line-Line 
You can switch between the two modes by pressing the F key. The first mode makes the first 
segment displayed at a 45-degree angle and the second segment is either horizontal or vertical. The 
second mode makes the first segment either horizontal or vertical and the second segment is 
displayed at a 45-degree angle. 

Place Arc  
Choose the Place » Arc command to place an arc or circle of the current line width on the current 
sheet. With this command, you can create arcs of varying length and radius and circles of varying 
radius. In P-CAD Schematic, arcs are graphical representations only; they carry no net information. 

To change the width of an existing arc, choose the Edit » Properties command. To change the arc 
width for new arcs, choose the Options » Current Line command. 

Arcs are partial circles. Arcs and circles are constructed counter-clockwise; the click (down) and 
release (up) define the start and end point of the arc, therefore a stationary click/release defines a 
circle. In this case, the second click and drag moves the center point away from the defined point 
on the circumference. 

Placing an Arc 
To place an arc on the workspace, follow these steps: 

1. Choose Place » Arc or click the Place Arc toolbar button.  

2. Move the cursor into the active window to where you want the starting point of the arc. 

While you draw an arc, the cursor is displayed as a crosshair shape. When you finish the arc, 
the cursor returns to its normal shape. 
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3. Click and drag to where you want the end point of the arc to be. Release and the start and end 
points are established as a 180-degree arc. 

The arc sweeps counterclockwise as you place it. (e.g., left-to-right the arc sweeps up; right-to-
left the arc sweeps down, etc.) If the start and end points are the same (i.e., you click and 
release without dragging), you create a circle. 

4. After the start and end points are established, click and drag the cursor to define/alter the 
center point, thereby increasing or decreasing the sweep angle and radius of the arc.  

5. You can flip the arc (swapping the end points) by pressing F while the arc is still unfinished. 
When you release the mouse button, the arc is permanently placed. 

6. To cancel ghosting of an arc, right-click. 

Changing Arcs  
You use select mode to move, resize, rotate, flip or perform other types of changes to the arc (after 
it is placed):  

• To rotate or flip an arc, select it, and press R to rotate or F to flip while the button is depressed. 

• To move the arc, click within the selection box (not on the handles) and drag the arc. 

• To resize, click and move the center handle to change the radius or move the start or end point 
to change the sweep angle. 

Changing an Arc Center Point 
While placing an arc, you can alter the center point before the final placement. After you click, 
drag, and release, the arc start and stop points are defined. A second click defines the center point 
and the radius. If you click and drag, you can alter the center point of the arc before you release. 

• To toggle between the arc’s beginning and end points, press the F key. For more information, 
see Place Arc (page 273). 

Place Polygon   
Choose the Place Polygon command to place a solid filled polygon on the current sheet. In P-CAD 
Schematic, polygons are graphical representations only; they carry no net information. 

1. Choose Place » Polygon or click the Place Polygon toolbar button. 

While you draw a polygon, the cursor appears as a crosshair. When you finish the polygon, the 
cursor returns to its normal shape. 

2. Put the cursor at the starting point of where you want your polygon. Click and drag to the 
second point and release. 

3. Click and drag to a third point and you have a triangle. Any subsequent polygon points are 
connected by a line to the first point you selected, e.g., the fourth point of a polygon is 
connected to the first point automatically. 
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4. When you have established all points for the polygon, right-click or press ESC to finish and fill 
the polygon. 

Complex polygons are not allowed. A complex polygon is a self-intersecting or self-crossing 
polygon. Polygon sides can touch each other but not cross each other. 

Draft/Outline Display Mode 
Polygons can be drawn and printed as outlines. They are drawn in outline form when the Draft 
Mode check box is selected in the Miscellaneous tab of the Options Display dialog. To switch 
between draft mode on and off, press the Q key. 

Rotate/Flip  
To rotate a polygon, select it and press R to rotate the polygon by 90 degrees. To flip a polygon, 
select it and press the F key. 

Altering the Shape 
You can alter the shape (move, add, or delete vertices) by selecting the polygon, then clicking and 
dragging one of the handles. When you move one of the handles that lies between two vertices, a 
new vertex is created. To delete a vertex, grab and move it to an adjacent vertex and release. 

Place Ref Point  
Choose the Place » Ref Point command to place a reference point on the active sheet. When you 
place a reference point, it appears in the 1x grid color set in the Colors tab of the Options Display 
dialog. You can also set reference point size in the Miscellaneous tab of Options Display. For more 
information, see Options Display (page 297). 

When you place a reference point on a symbol, the symbol moves with the cursor at the reference 
point. Symbols are flipped and rotated about the reference point. If you are creating a symbol, you 
should place a reference point on the symbol object before saving it in a symbol library using the 
Library » Symbol Save As command explained in Library Symbol Save As (page 326). 

Placing a Reference Point 
1. Select Place » Ref Point or click the Place Ref Point toolbar button. 

2. Move the cursor to the location on an object or with a collection of objects. Click to place the 
reference point; or click, drag and release to place the  

3. You can move a reference point by selecting it and dragging it to a new location. 

To cancel placement of a reference point, right-click. 

Place Text  
Choose the Place Text command to place text on your design using the following basic steps:  
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1. Choose the Place » Text command or click the Text Placement toolbar button. 

2. Click the workspace at the location where the text is to be placed.  

3. Type the text you want to place in the design in the Text area of the Place Text dialog.  

4. Click the Place button in the dialog or click the Place Text tool again to commit the text in the 
design. 

Place Text Dialog 
Text entered in the Place Text dialog is instantly displayed at the location in the design where you 
clicked the mouse button to begin the place text function. You can change the location of the text 
by dragging it to a new location. 

The Place Text dialog can be displayed in the expanded version, an intermediate size or minimized 
to a one-line display. The display size and location at the time the dialog is closed become the 
default settings that are used the next time you enter the Place Text mode. 

To open the expanded version of the Place Text dialog, click the More>> button located directly 
beneath the scroll bar, on the right side of the Text edit box. To reduce the dialog to the 
intermediate size, click the <<Less button, located where the More>> button used to be. To 
reinstate the minimized dialog to its previous size, click the Maximize button next to the Minimize 
button at the top right corner of the dialog. To reduce the dialog to its minimized size, click the 
Minimize button at the top right corner of the dialog. 

The minimized version of the dialog appears as shown below: 

 

The intermediate version of the dialog appears as follows: 

 

The expanded version of the dialog appears as follows: 
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The Place Text dialog contains the following options: 

• Text: The Text edit box is where you type the text you want to place in the design. You can also 
paste text from the clipboard into the edit box, using CTRL+V. If you want to enter multiple 
lines (e.g., a list), you can start new lines in the box by using a carriage return (the ENTER key). 
A single text object can have up to 2,000 characters.  

• Location: If the text has not been placed yet, the Location section displays the X and Y 
coordinates of the location of the cursor when the mouse button was released. While placing 
the text the coordinates cannot be modified. When you select committed text and choose the 
Edit » Properties command, the location coordinates can be modified to move the text to a 
different area in the design. 

• Justification: In the Justification box you can specify the text reference point. The reference 
point defines the cursor location on text placement, and also the point on which text is rotated 
or flipped. The default reference point for text is the lower-left corner of the text block. There 
are nine different reference point options.  

• Flip: The Place Text dialog provides the option to flip the text by checking the Flip box. 

• Rotate: To rotate the text by 90 degrees, click the Rotate button. Each time you click the Rotate 
button the text rotates another 90 degrees. The degree of rotation is displayed next to the 
Rotate button. 

• Text Styles: You can view the default text styles and add, modify and delete a non-default text 
style by clicking the Text Styles button to open the Options Text Style dialog. Changes to the 
text style appear instantly in the design at the time they are made. 

The text style for the selected text or the text being placed can be changed by choosing the 
new style from the drop down list in the Text Style edit box. Fonts and font sizes cannot be 
mixed within the same text item. Barred text can be inserted in the text item by placing a tilde 
(~) on either side of the text you want to bar. Type two consecutive tildes to cause a single tilde 
to be displayed. Changes that cause the text to be placed outside the workspace are not 
allowed. 

See Options Text Style (page 314) for detailed information on adding, modifying, viewing and 
deleting text styles. 
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• Place/Cancel: Commit the text to the current location in the workspace by clicking the Place 
button or the Place Text button on the Placement toolbar.  

To cancel the text placement dialog and remove the temporary text from the design, click the 
Cancel button or press the ESC key. The Text tool is still active, but the dialog disappears from view. 

Whenever you are typing, flipping or rotating text, and zooming or panning the workspace, the 
dialog remains on the screen. At the time the text is committed to the design by clicking the Place 
button on the dialog, choosing the Place » Text command or clicking the Place Text button on the 
Placement toolbar, the dialog disappears from the screen. The Place Text tool remains active so that 
you can click the workspace to indicate the location for the next text item, display the dialog again 
and place more text. 

Place Text Features 
The Place Text tool provides additional features that enhance the basic placement functionality and 
make placing the text easier and more accurate. This section describes how to rotate, flip, zoom 
and pan text during or after placement.  

Rotating Text 
You can rotate text during placement. Click and hold the left mouse button on the text, then press 
R or click the Rotate button. This rotates the text by 90 degrees. The text moves about its reference 
point, but always reads from left to right. 

To rotate text after it has been placed, select it and press R to rotate while the left mouse button is 
depressed or choose the Edit » Properties command to open the Text Properties dialog where you 
can click the Rotate button.  

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate 
text at 90 degrees, then immediately place a field, the field’s text will be placed at a 90-degree angle.  

Click again in the box in the Place Text dialog to continue typing new text. 

Flipping Text 
You can flip text as you are placing. If you change focus from the dialog to the workspace, click and 
hold the left mouse button on the box, and then press the F key. While in the dialog you can flip 
the text by checking the Flip box. 

The F key and Flip check box functions flip the text 180 degrees to the right or left of the original 
location. The text moves about its reference point, but always reads from left to right. 

To flip text after it has been placed, select it and then press F to flip, or choose the Edit » Properties 
command to open the Text Properties dialog and select the Flip check box. 

Click again in the box in the Place Text dialog to continue typing new text. 

Zooming and Panning While Placing Text 
The Place Text dialog remains on the screen while you zoom or pan the workspace.  

Click the workspace to assure that the focus is in the workspace before choosing any of the zoom 
commands. To zoom in or out of the workspace while placing text press the Plus (+) and Minus (-) 
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keys, the View » Zoom In and View » Zoom Out commands or click the Zoom Window button on 
the Command toolbar.  

The workspace can be panned by moving the scroll bars up, down, right and left, or by pressing 
one of the arrow keys. 

Click again in the box in the Place Text dialog to continue typing new text. 

Place Attribute  
Choose the Place » Attribute command to place an attribute according to the Name and Value 
options you select in the dialog. This command allows you to place an attribute within a collection 
of objects comprising a symbol or part. 

The predefined Names are: Filename, Name, Part Number, RefDes, Type and Value. 

The Value box specifies the attribute definition, e.g., the actual filename rather than just the 
placeholder {Filename}.  

Placing an Attribute 
To place an attribute, follow these steps 

1. Choose Place » Attribute or click the Place Attribute toolbar button. 

2. Click the workspace to open the dialog:  

 

3. Choose an attribute category from the Attribute Category list.  

4. All pre-defined attributes for the category appear in the Name list. To place a predefined 
attribute, select an attribute from the Name list.  

5. To place a user-defined attribute, select user-defined from the Name list. Type an attribute 
name in the Name edit box.  
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6. Type a value for the attribute in the Value edit box. 

7. Set attribute properties. See Attribute Properties (page 228) for more information. 

8. Click OK. 

9. Move the cursor into the workspace and click, drag and place the attribute. Before you release 
the mouse button to place it, you can move, rotate, or flip the placement box (see the 
following section). 

Rotate/Flip 
To rotate or flip an attribute after it has been placed, select it and press R to rotate or F to flip while 
it is selected. 

The R key rotation is 90 degrees. 

You can rotate or flip an attribute as you are placing it. For rotation, the angle that is the result of 
the rotation applies to the next attribute you place. For example, you are placing an attribute, and 
you rotate it 90 degrees before you finish it. Then you place another attribute; it is placed at the 
same 90-degree angle without any rotation action. You can place multiple attributes at the same 
angle by rotating the first attribute as you place it.  

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate 
text at 90 degrees, then immediately place an attribute, that attribute will be placed at a 90-degree 
angle. This rotation memory derives only from rotation action during placement, not from select 
and rotate actions that take place after object placement. 

If you don't specify a value for an attribute, the attribute key name will be displayed in brackets, 
e.g., {Type}. See File Design Info (page 183) for information on design-level attributes. 

Place Field   
Choose the Place » Field command to place a field containing design information such as date, 
time, author, etc. 

The information that appears when you place certain fields is determined by what you specify in 
the Field tab of the File Design Info dialog. You can place a field from a selection of predefined 
field types including: Approved By, Author, Checked By, Company Name, Current Date, Current 
Time, Date, Drawing Number, Drawn By, Engineer, Filename, Modified Date, Note, Number of 
Sheets, Revision, Revision Note, Sheet Name, Sheet Number, Time, and Title.  

You can also define and place additional fields using File » Design Info. For instructions on adding a 
user-defined field, see File Commands (page 169). 

Current date and current time are taken from the computer's clock. If you just select date then you 
must specify the date in the File Design Info dialog. The same is true for time (as opposed to 
current time). 

The value of a field placed in the design, with the exception of Current Date/Time, Filename and 
Modified Date, must be specified in the Field Properties dialog, otherwise you place a generic field, 
e.g., {Author} rather than “W. Shakespeare”. To open the Field Properties dialog, choose the File » 
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Design Info command and click the Properties button in the Fields tab. Or, select a field in your 
design, right-click, then choose Properties from the shortcut menu. 

Fields are handy for use within title blocks. 

Placing a Field 
1. Choose Place » Field and click the workspace. A dialog appears with a list box containing field 

types. 

 

2. From the Name list box, select what kind of field you want to place. Click OK. 

3. Move the cursor to where you want to place the field; click to place it. If you click again, the 
Place Field dialog will be displayed so that you can choose another type of field for placement. 

4. You can rotate or flip a field as you are placing it. See the following section for more details. 

To cancel before a field is placed, right-click. 

Rotate/Flip 
To rotate a field, select it and press R to rotate the field by 90 degrees. To flip a field, select it and 
press F. 

You can rotate or flip a field as you are placing it. For rotation, the angle that is the result of the 
rotation will apply to the next field you place. For example, you are placing a field and you rotate it 
90 degrees before you finish it. When you place another field; it is placed at the same 90-degree 
angle without any rotation action. If you decide to rotate the second field, it is incremented 90 
degrees more, resulting in a 180-degree angle. Therefore, you can place multiple fields at the same 
angle but only have to perform the rotation action on the first field. 

Attributes, text, and fields share the same rotation memory. In other words, if you place and rotate 
text at 90 degrees, then immediately place a field, that attribute is placed at a 90-degree angle. This 
rotation memory derives only from rotation action during placement, not from select and rotate 
actions that take place after object placement.  
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Place IEEE Symbol   
Choose the Place » IEEE Symbol command to place an IEEE symbol in the design. Once placed, an 
IEEE symbol cannot be modified. It must be deleted and replaced with a new symbol. You can place 
the following symbols: 

 

 
Adder 

 
Amplifier 

 
Astable 

 
Complex 

 
Generator 

 
Hysteresis 

 
Multiplier 

 

Placing a IEEE Symbol 
1. Choose Place » IEEE Symbol or click the corresponding toolbar button. 

2. Click the active window. A dialog appears listing the IEEE symbol types. 
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3. From the Symbol Type group, select the kind of IEEE symbol you want to place. You may also 
change the height of the symbol.  

4. Click OK to close the Place IEEE Symbol dialog. 

5. Move the cursor in the active window to where you want to place the IEEE symbol; click to 
place it. If you click again, the Place IEEE Symbol dialog appears so that you can choose another 
type of IEEE symbol for placement. 

To cancel before an IEEE symbol is placed, right-click. 
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CHAPTER 16 

Rewire Commands 

Using the Rewire Command 
There is a single Rewire command in P-CAD Schematic, Rewire » Manual. 

Rewire Manual 
Choose the Rewire » Manual command to reroute wire segments quickly and easily.  This lets you 
make room for other objects, or to make aesthetic enhancements to a design.  The Rewire » 
Manual command maintains the width of the wire.  

Using the Rewire Manual Command 
To enter rewire mode: 

1. Choose the Rewire » Manual command or click the Rewire Manual toolbar button. 

2. Point to the wire segment you want to change. 

3. Click the segment at the location where you would like to begin rerouting, then move the 
cursor to a new location and click to complete the new segment.  Each click in a new location 
adds a new wire segment. 

Press the BACKSPACE key to undo the last rewired segment. After the current rewire session is 
ended, the entire session is undoable. 
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CHAPTER 17 

Options Commands 

Using the Options Commands 
Use the commands in the Options menu to change various settings that affect a number of P-CAD 
Schematic actions such as block selection criteria (selection mask), default units (mm, mils, or in), 
grid settings, object display colors, and object styles. 

Options Block Selection 
Choose Options » Block Selection to open the Options Block Selection dialog. You use the options 
in this dialog, to set block selection criteria that affects the selection of specific objects when you 
are in Select mode, as shown in the following figure: 
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Select Mode Frame 
The Select Mode frame contains the following radio buttons: 

• Inside Block. This option is selected by default. Choose this button to select items within the 
selection block, according to the selection criteria you establish in this dialog. 

• Outside Block. Choose this button to select items outside the selection block. All of the 
selection criteria that you specify in the Options Block Selection dialog functions outside the 
block rather than inside. 

• Touching Block. Choose this button to select all items inside or touching the selection block. 
This is a more inclusive selection option than Inside Block. 

Items Frame 
In the Items frame, you specify all of the objects listed in the dialog individually determining 
whether or not they are included in a block select. If you want to include only one or two items in 
your selection, click Clear All to clear all check boxes, then select individual check boxes to enable 
specific items. If you want to exclude only one or two items in your selection, click Set All to select 
all check boxes (if they are not already enabled), then individually clear the check boxes you want 
to exclude. 

Selection Mask Dialogs 
Some check boxes in the Items frame have corresponding command buttons (e.g., Line, Part, Pin). 
These check boxes have three states: 
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• included (selected). 

• excluded (cleared). 

• masked (shaded). 

This feature allows you to narrow your selection further by setting specific properties as selection 
criteria for any item with a corresponding button. To access these property “masks”, click the 
check box until a shaded check mark appears. For example, the Line button becomes available 
when a shaded check mark appears in the Line check box, as shown in the following figure. 

 

Then, click a button to open the corresponding dialog. For example, click the Line button to open 
the following Line Selection Mask dialog: 

 

With the Selection Mask dialog, you can specify parameters for the particular object that you want 
as part of the selection mask or screening process. In the above example, if you specify a thin, solid 
line, your block selections will only select thin, solid lines. 
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Selection Mask Parameters 
This is a basic summary of the parameters you can work with in the Selection Mask dialogs. Refer to 
Edit Properties (page 211) for detailed information about a specific object’s properties. 

Line 
For Line, you can specify line width and style. For details, see the illustration on the previous page. 

Part 
For Part, you can specify reference designator, value, type, and attributes, as shown in the following 
dialog:  

 

Pin 
For Pin, you can specify Length, Display Characteristics, Display, and Pin Number for a block select, 
as shown in the following dialog: 
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Port 
When the No Port Change check box is selected, you can select the Nets tab to specify Net Name. 
When the No Port Change check box is cleared, you can specify Pin Count, Pin Length, Pin 
Orientation, Port Shape, and Net Name, as shown in the following dialog: 
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Text 
For Text, you can specify a specific text string, Text Styles, and Justification, as shown in the 
following dialog:  

 

Wire 
For Wire, you can specify a Width, as shown in the following dialog: 

 

Related Topics 
For more information on using the Selection Mask dialogs, see Edit Properties (page 211). 

For information about block selection, refer to Edit Select (page 247). 

Options Configure  
Choose the Options » Configure command to open the Options Configure dialog. Use this dialog 
to set many of the Schematic parameters. Some of these parameters affect all open designs, and 
some affect only the active design.  
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Workspace Size 
Use the controls in this frame to set the size of the current design to one of five, standard imperial 
sizes (A-E) or five standard metric sizes (A4-A0). Choose the User radio button to create a custom 
workspace size by providing values for Width and Height. The minimum size for both Width and 
Height is 1 inch; the maximum is 60 inches. 

Title Sheets 
The Edit Title Sheets button allows you to specify global and individual title sheet attributes. See 
Title Sheets, (page 98) for information on how to define and modify your title sheets. 

Units 
Allows you to alter your display units between mils, millimeters, and inches. Dimensions are not 
altered, only the display of measurements are updated. A mil equals 0.001 inch or .0254 mm. A mm 
equals 0.001 meter. When the selected unit is mm, you can control the number of digits displayed 
to the right of the decimal point by modifying the MillimeterPrecision setting in the .ini file. The 
default displayed precision is three decimal digits, but can be changed to an integer value of 2 
through 5. 
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This setting will affect all dialogs, reports, status line displays, etc. containing measurements. For 
example, setting Units to mm causes all dialogs to display measurements in millimeters. These units 
can be overridden in many command settings. 

Orthogonal Modes 
Orthogonal modes are for use while placing wires, buses and lines, using segments that are 
horizontal, vertical, and at 45-degree angles.  

Press the O key to switch between the enabled modes. You can enable or disable the orthogonal 
modes in the Options Configure dialog. The non-orthogonal mode, with straight-line placement at 
any angle, is always enabled. 

The 90/90 and 45/90 orthogonal modes are provided as mode pairs. Press the F key to switch 
between the mode pair of the current mode.  

• 90/90 Line-Line creates true 90-degree angles, long and short. 

• 45/90 Line-Line creates 45/90 and 90/45 angles. 

Refer to the Place Wire (page 263), Place Bus (page 265), and Place Line (page 272) for more details 
about the orthogonal modes. 

Net Increment 
The Net Increment frame contains an Increment Value edit box. The Increment Value edit box lets 
you specify the step value for incrementing net names: a negative value causes the name to 
decrement instead of increment, and a zero value disables the copy increment feature. CTRL/Drag 
Copy and Edit » Copy Matrix are the commands that use this increment value. 

ECOs 
Engineering Change Orders (ECOs) are recorded when you choose the Utils » Record ECOs 
command. From the Options Configure dialog, you can select a format for the ECO files. This 
setting applies to the active design. 

The ECO file is generated in an ECO format or a Was/Is format, which is compatible with Tango 
Series II. Click either the ECO Format or the Was/Is Format radio button to select a format:  

• ECO format records full ECOs.  

• The Was/Is format records only Was/Is ECOs. It keeps track of RefDes changes only and 
generates a file that is compatible with Tango Series II. 

AutoSave 
Use the controls in the AutoSave frame to enable the AutoSave feature, which regularly saves your 
files at a user-defined interval in a compressed or non-compressed format. AutoSave won’t be 
performed during autorouting or if a tool is busy. 

The following options are available: 

• Enable AutoSave: Select this check box to turn on the AutoSave feature. 
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• AutoSave Time Interval: Enter the time between saves. AutoSave uses a rolling backup to save 
files, incrementing each subsequent autosave file. 

• Purge Previous Backups: When enabled, the option causes all backups saved from the 
previous design session to be deleted when you begin a new design session. 

• Number of Backup Files: Allow you to specify the number of design files to be archived before 
file names are reused. This must be a number between 1 and 99.  

• Compress AutoSave Files: Compresses the file so that is uses less space when saved. 

File Viewer 
Enter a value in this text box to define the viewer to be used for viewing reports, log files, error 
reports, etc. Enter the application name (e.g., Notepad). If the application is in a directory that is not 
included in your Autoexec.bat path statement, include the complete pathname here. 

Zoom Factor 
Enter a value in this text box to adjust the amount of zoom that occurs when you choose the View » 
Zoom In or View » Zoom Out command. A factor of 2.00 doubles (or halves) the size of objects in 
the Workspace, etc. Zoom factors must be greater than 1.00. 

Autopan 
Allows you to adjust the amount of autopanning that occurs when you move the cursor to the edge 
of the screen with the arrow keys. An autopan of 25 moves anything at the edge of the screen 25% 
nearer to the center of the screen; 50 moves fringe objects to the center. 

Compress Binary Designs 
Select the Compress Binary Designs check box to enable the automatic compression of binary files 
whenever those files are saved.  

DDE Hotlinks 
If selected, this check box enables exchange of hotlink data with P-CAD PCB. Hotlink data consists 
of highlighting and unhighlighting commands for parts and nets. The state of the DDE Hotlinks 
option is saved in the Sch.ini file. 

Options Grids  
Choose the Options » Grids command to define various properties for your grids. Grid values are 
stored with each, individual design file. When you choose the Options » Grids command, the 
following dialog appears: 
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The grid units used are determined by the Units setting in Options Configure. 

Grid Spacing 
Use the controls in the Relative Grid Origin frame to select appropriate values for grid spacing for 
specific modes in the Grids list box. You are not limited to using the grids in the list box; you can 
specify your own custom grid spacing in the Grid Spacing box, then click Add to add it to available 
choices in the Grids list box. To delete a grid-spacing value, highlight it in the Grids list box and 
click Delete. 

Grid Toggle Buttons 
The Status Line Grid Toggle button and the Grid combo box, allow you to easily switch between 
grid settings and add new grid settings. The toggle switches between absolute grid (Abs, with white 
background) and relative grid (Rel, with colored background). Your absolute and relative grid 
values can be changed from the combo box. The A key toggles between absolute and relative grids. 

If you use the Grid Toggle button to switch to Relative, you are prompted for the origin point if you 
have the Prompt for Origin option enabled in Options Grids. The cursor takes the shape of a 
crosshair cursor while the system is awaiting input; when you click in the active window, that 
becomes the relative origin point (X=0, Y=0) and the cursor returns to normal. 

Visible Grid Style 
The Visible Grid Style check box allows you to either show or hide grids. When you select the 
check box, two grid style options are available. Dotted pinpoints grid points, while Hatched draws 
lines along the grids to show grid intersections (like graph paper). 

Relative Grid Origin 
Use the controls in the Relative Grid Origin frame to specify your X and Y relative grid origins by 
entering the coordinates. You must have the Prompt for Origin option disabled for it to work.  

If you switch to Relative grid in the dialog and the Prompt for Origin check box is selected, you are 
prompted for the new origin point after you click OK. You are prompted every time you switch 
between Absolute to Relative grids by clicking the Grid Toggle button or by pressing the G key. 
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Mode 
In the Mode frame, choose the Absolute radio button when you want the grid origin point to be 
the lower- left corner of the Workspace. You can choose the Relative radio button to allow any 
point as an origin point. 

Options Display  
Choose the Options » Display command to open the Options Display dialog. There are two tabs in 
this dialog: Color and Miscellaneous. Use these tabs to define your workspace preferences.  

 

Colors 
This tab contains four frames and a Defaults button. Click the Defaults button to return your 
display setup to the default scheme. 

Any color settings established here are saved in your Sch.ini file when you close the dialog. 
These settings affect your designs in subsequent sessions, until you change them. 

The following sections describe how to use the controls in these frames: 

If you have a color printer, clicking the Defaults button also restores default color settings for 
printing. 

• Item Colors 

• Display Colors 
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• Junction Size 

• Bus Connection Mode 

Item Colors 
To select a color for an item, click the corresponding button in this frame. When you do, a color 
palette appears. Choose a color from the palette by clicking the appropriate button. The palette 
closes automatically. 

You can also set a custom color. To close the color palette without choosing a color, press ESC or 
click the Close button. 

Setting A Custom Color 
To set a custom color, click the Custom button in the palette to open the Color dialog. Then, 
choose a color from this dialog using one of these methods: 

Method 1: Select a Defined Custom Color 

1. Click one the colors in the Basic Colors frame. 

2. Click OK to return to the color palette. 

Method 2: Define a Custom Color 

1. Click the color matrix to define the Red/Green/Blue settings, or type the desired settings in the 
Red/ Green/Blue boxes.  

2. Click the Add to Custom Colors button.  

3. When the selected color appears in the Custom Colors section, click OK to return to the color 
palette. 

Some custom colors are displayed only when supported by your video display settings. If your 
video display supports 256 Colors, custom colors are approximated to the nearest solid color, while 
retaining the Red/Green/Blue settings. If your video display supports more than 256 colors, custom 
colors display accurately. 

Once custom colors are selected, they appear as the chosen item or display color on the Options 
Display dialog or the Printer Colors dialog. These colors are saved in the .ini file for use in later 
design sessions. In the Custom Colors section of the color palette, however, colors not selected for 
an item/display color are forgotten once the P-CAD application is exited. 

Display Colors 
In the Display Colors frame, there are several command buttons. Click one of these buttons to 
determine various Schematic display colors. The settings configured with these buttons appear in 
your workspace, regardless of layer or item colors.  

When setting your display colors, make sure that the colors you pick do not conflict with any layer 
or item colors. For example, if the background color is set to be the same as the line color, lines will 
not be visible in your design. 
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Junction Size 
To set a size for junctions, choose one of the following radio buttons in the Junction Size frame: 

• Small. When you choose this option, the junction size appears in the Size box. 

• Large. When you choose this option, the junction size appears in the Size box. 

• User. When you choose this option, you can type a value in the Size box. Your entry can be in 
inches, centimeters, etc., as long as the value is between 0 - 10 mm. 

Bus Connection Mode 
Click one of these buttons to determine the bus connection mode: 

 

In a design session, bus connections form automatically when you connect a wire to a bus. For 
more information, see Place Bus (page 265). 

Miscellaneous 
To set up other display options for your workspace, click the Miscellaneous tab in the Options 
Display dialog. As shown in the following figure, this tab contains a number of options: 
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ERC Errors 
In the ERC Errors frame, you have these options: 

• Show: Choose this button to show ERC errors in the workspace. 

• Hide: Choose this button to hide the display of ERC errors in the workspace. 

• No Change: Choose this button to keep the current display setting. 

Sheet Connector Cross Referencing 
See Annotating Sheet Connectors, (page 108) for details on how to define sheet connector cross-
referencing. 

Cursor Style 
To change the style of your cursor, choose from an arrow, small cross or large cross. 

The large cross style stretches horizontally and vertically to the edges of the Schematic window. 

The Large Cross cursor style does not support the DataTips feature. Enabling the Large Cross cursor 
clears the Show DataTips check box and makes the feature unavailable. 

Miscellaneous 
The Miscellaneous frame contains a number of check boxes. To enable an option, select its check 
box. Clear a check box to disable an option. 

• Draft Mode: Select this check box to show these two items in your design: (1) a thin, single-
pixel outline for pads, vias, and text. (2) a segmented and outlined representation of arcs, lines, 
and any line segment objects such as, polygons, cutouts, etc. Draft mode improves redraw 
speed and helps you view segment overlaps. 

• Thin Stroked Text: Select this check box to show text in thin line mode. Clear this check box to 
display text in regular mode. 

You can use the draft mode shortcut key to switch between draft and non-draft display modes. 
Based on the combination of options enabled (e.g., Draft Mode and Thin Stroked Text), the 
current selection is retained and used to produce a comparable, opposite display when the 
draft mode shortcut key is pressed. For instance, if you begin with both Draft Mode and Thin 
Stroked Text enabled, and you switch to non-draft mode, the display produced is normal 
figures and regular text. 

• Display Open Ends: Select this check box to show open ends on unconnected pins and wires. 
Open ends appear as open squares, and no longer appear when a positive connection is made. 

• Display Part Gate Number: Select this check box to show a part’s reference designator gate 
number. You can also use the Print Options dialog to show or hide the gate number in your 
hardcopy. The options are independent of each other, so you can show the gate number on 
screen for editing, but hide it from your hardcopy at the same time. 
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• Drag by Outline: Clear this check box to show a ghosted image of the part and a bounding 
outline when you move or copy objects in your design. Select this check box to show only the 
bounding outline. This setting affects only the move and copy operations associated with the 
Edit Select command. 

• Display Overridden Errors: Select this check box to show overridden ERC error indicators. 
Clear the check box to hide overridden errors. 

• Display Default PinDes: Select this check box to show the default pin designator for free pins. 
Clear this check box to display only pin numbers. 

• Scroll Bar: Select this check box to show scroll bars in the active window. Clear this box to hide 
the scroll bars. 

• Show DataTips: Select this check box to show DataTips in the active window. Clear the check 
box to hide the display of DataTips in the active window. 

The Large Cross cursor style and the View Snap to Grid command do not support the DataTips 
feature. For details, see Cursor Style (page 300) and View Snap to Grid (page 257). 

Options Preferences  
Choose the Options » Preferences command to define keyboard, mouse, and toolbar preferences 
used to set up the application. When you choose this command, the following dialog appears with 
the Keyboard tab selected: 
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Keyboard Tab 
The Keyboard tab lets you customize key assignments for menu commands, shortcut key 
commands, and macros. 

• Command Type (check box): Choose the type of command for which you want to change 
shortcut key assignments. 

• Menu Commands/Shortcut Commands/Macros (list box): Select the command or macro you 
want to add a shortcut key assignment to or from which you want to remove a shortcut key 
assignment. 

• Current Keys (text box): Displays the existing key assignments for the command or macro you 
select in the Menu Commands/Shortcut Commands/Macros box. 

• Press a Shortcut Key (text box): Press the keys you want to assign to the selected command or 
macro. You can press the CTRL or SHIFT key plus any other combination of numeric or 
alphabetic keys and function keys. 

If the shortcut is currently assigned, the current assignment appears in the Current Binding 
field just below this box. 

• Assign (button): Assigns the key appearing in the Press a Shortcut Key box to the selected 
command or macro. If the shortcut is currently assigned, the current assignment disappears. 

• Remove (button): Removes the key you select in the Current Keys box. 

• Key File (button): Allows you to select a key binding file to use with this application. When the 
Select Key File dialog appears, select the file you want to use. The current key file appears at 
the top of the dialo0 

• Defaults (button): Restores original default key assignments to all commands or macros. 

Mouse Tab 
When you select the Mouse tab the Options Preference dialog appears as follows: 
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The Mouse tab lets you customize certain mouse behaviors. 

• CTRL/SHIFT Behavior: Allows you to choose which keys to use (CTRL or SHIFT) for multiple 
(extended) selections and which to use for Sub Selections. 

• Cycle-Picking Threshold: The number of pixels you can move the mouse during cycle-picking. 

• Double-Click Displays Properties: When enabled, this option allows you to double-click an 
object to bring up the Properties dialog for that object. 

Options Design Rules  
When you choose the Options » Design Rules command, the Options Design Rules dialog appears. 

Design Tab 
The Design tab shows global clearance rules that are applied to the entire design.  
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Clearance Rules 
When a clearance rule for a specific object is requested (e.g., DRC), the design rules category is 
searched in the following order of priority: 

• Class to class rules (highest priority). 

• Net rules. 

• Net class rules. 

• Global rules (lowest priority). 

Within each category, the clearance rules are searched in the following order of priority: 

• Object pair clearance rules (e.g., Pad to Line clearance). 

• Clearance rules. 

The order of evaluation matches the order of evaluation used by the CCT SPECTRA Router. P-CAD 
PRO Route uses only global clearance rules.  

Net Class Tab 
Use the Net Class tab to specify clearance rules for pads, vias, lines, and object pairs (such as pad to 
pad or line to via). The dialog lists all net classes, indicates the presence of rules in the Rules list, 
and shows the rules and their values in the Net Class Rules list box, as shown in the following 
figure:  
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When an attribute exists for multiple Net Classes, and the value of the attribute is different for each 
Net Class, the Net Class Rules list shows the attribute and indicates the value as mixed when you 
select more than one Net Class. 

Click the Select Net Class by Rule button to display the Set By Attribute dialog, shown in the 
following figure, where you can choose the attribute(s) you want to use to select the Net Classes. 
Selecting an attribute from the list box allows you to find all net classes containing that attribute, 
regardless of the attribute value.  

 

If you select an attribute from the Name=Value list box and click OK, you are returned to the 
Options Design Rules dialog where all net classes that have the selected attribute defined are 
highlighted in the Net Class list box. 
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To find net classes with attributes having a specific value, select an attribute from the Name=Value 
list box and click the Change Value button to display the Change Value Attribute dialog, shown in 
the following figure. 

 

The Change Attribute Value dialog lists all values assigned to the selected attribute and also 
includes the option to select {Any Value}. Select the desired Value and click OK to return to the Set 
By Attribute dialog. 

To set all of the attributes, click the Set All button. To clear the selected attributes, click the Clear 
All button. Choose the Clear Current Items check box if you want to remove previously selected 
items each time you modify your selection criteria. 

If you select multiple attribute names and values in the Name=Value list box, only those nets with 
all of the selected attribute names and values are highlighted when you return to the Options 
Design Rules dialog.  

To make changes to the Net Classes, click the Edit Net Classes button to display the Net Classes 
dialog: 
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In the Net Classes dialog you can define a group of nets that share common rules. Collections of 
nets sharing the same rules are known as a Net Class. For more information on using the Net 
Classes dialog, see Options Net Classes (page 309). 

Click the View Rules button to see the rules in the Notepad as shown in the following figure: 

 

To modify the rules click the Edit Rules button to display the Attributes dialog.  

Net Tab 
When you click the Net tab, the Options Design Rules dialog appears as shown in the following 
figure:  

 

The Net tab allows you to specify clearance rules for a specific net in the design. The dialog lists all 
nets, indicates the presence of rules and shows the rules associated with the net you select from 
the Nets list box.  

Click the Select Net by Rule button to display the Set By Attribute dialog where you can choose the 
attribute(s) you want to use to select the Net. The Set By Attribute dialog is explained in Net Class 
Tab (page 304). 
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To modify the nets in the design, click the Edit Nets button to display the Edit Nets dialog. 
Complete information on the Edit Nets dialog is found in Edit Nets (page 240). 

Click the View Rules button to see the rules in the Notepad format. 

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog. 

Class to Class Tab 
When you click the Class to Class tab, the dialog appears as follows: 

 

The Class to Class tab allows you to specify clearance rules between nets grouped into a Net Class. 
The dialog lists all class to class definitions and the rules associated with each. 

Click the Select Class to Class By Rule button to display the Set By Attribute dialog, where you can 
choose the attribute(s) you want to use to select the Class to Classes.  The Set By Attribute dialog is 
explained in Net Class Tab (page 304). 

Click the View Rules button to see the rules in the Notepad format. 

To create a new Class to Class definition or modify an existing Class to Class, click the Edit Class to 
Class button to display the Edit Class to Class Definition dialog shown in the following figure: 
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To create a Class to Class definition, select Net Classes from the two Net Class name list boxes, and 
click Add Definition. Once created, the Class to Class definition can be modified or deleted by 
clicking the Modify Definition or Delete Definition buttons. Rules associated with the Class to Class 
definition appear in the Class to Class Rules list box. 

To add, delete or modify rules, click the Edit Rules button to access the Attributes dialog. 

Options Net Classes  
Choose the Options » Net Classes command to define a group of nets that share common rules. 
Collections of nets sharing the same rules are referred to as a ‘net class’.  When you choose this 
command, the Net Classes dialog appears:  
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This class editor allows you to create named net classes using pre-defined clearance rules or pre-
defined SPECCTRA autorouter clearance rules and then assign nets to that class. You can also add 
user-defined attributes to the net classes for your own use. 

Net classes are transferred from the Schematic design to PCB via the P-CAD format netlist or 
through ECO’s. PCB Design Rules Checking verifies clearances and the attributes listed below 
when they have been defined in the net class: 

• MaxNetLength 

• MaxVias 

• MinNetLength 

• ViaStyle 

• Width 

For net clearances the rules can be further refined by specifying clearance rules for pairs of objects, 
like pad to pad clearances or line to via clearances.  

The net class information is written to binary and ASCII design files. P-CAD Master Designer PCB 
does not support Net Classes so this information is lost when exporting a P-CAD design to P-CAD 
format. 

To create named net classes, follow these steps: 

1. Enter a class name in the Classes box. 

2. Click Add. 

3. To include a net from the Unassigned Nets area to the new net class, you may use any of the 
following methods: 

• Select a single net and click the Add button. 

• Double click on a net to move it from Unassigned to Nets in this Class and vice versa. 

• Select multiple nets in a block by either 1) holding the SHIFT key while selecting the first 
and last nets in the block or, 2) select the first net in the list, hold the left mouse button 
and drag the cursor to the last net in the list and release. Then click Add. 

• Select individual nets by holding the CTRL key while clicking on each net, then click Add. 

4. To remove a net from the Nets in this Class area, use the same methods detailed above, but 
click the Remove button instead of the Add button. 

In addition to the normal selection process you may use the Set Nets From Design Selection 
buttons to quickly place all currently selected nets in the design into either the Unassigned 
Nets or Nets in this Class areas. When no nets are selected in the design, the inactive Set Nets 
From Design Selection buttons are gray. If nets in either area are selected and you click the Set 
Nets From Design Selection button, the other selected nets become unselected. 
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5. Use the Edit Attributes button to assign one or more attributes to this new net class. Refer to 
Edit Nets (page 240) for details. 

Options Sheets  
Choose the Options » Sheets command to switch to a different sheet by defining the current sheet. 
You may also add, delete, reorder and change the name of any sheet in a design.  

 

With P-CAD Document Toolbox, the Options Sheets dialog is enhanced to include a Titles tab. On 
this tab you can specify independent borders, zone divisions, and title blocks.  

Sheets 
In the Sheets box are listed all sheets, excluding the title sheet, defined for the design. The current 
sheet has an asterisk next to it. 

Buttons 
The Add button adds a sheet to the list using the Sheet Name you have specified. The specified 
sheet name must be unique. 
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The Modify button allows you to change a sheet name. Choose a sheet name from the list, make 
the desired changes in the Sheet Name box and click Modify.  

The Delete button deletes the selected sheet. You can delete any empty, non-current sheet.  

The Current button makes the selected sheet the current sheet, indicated by the asterisk. This 
sheet then appears in your display.  

The Move Up button positions the selected sheet one step above its current location in the list. The 
first sheet on the list can only be moved down in the list. When the first sheet is selected the Move 
Up button is grayed and unavailable 

The Move Down button positions the selected sheet one step below its current location in the list. 
The last sheet on the list can only be moved up in the list. When the last sheet is selected the Move 
Down button is grayed and unavailable. 

Whenever a sheet is moved up or down, the sheet number changes to indicate its new position in 
the list and is reflected across the application wherever the sheet number appears. 

Adding a Sheet 
When you add (create) a sheet, you must give it a unique name. Schematic assigns Sheet Numbers 
sequentially, using the next available number.  

To add a sheet, follow these steps: 

1. In the Options Sheets dialog, type the new sheet name in the Sheet Name box. 

2. Click Add. The new sheet name is listed in the list box with the sheet number automatically 
specified. 

Once a sheet has been created/added, the sheet number displayed represents the order in which it 
appears in the list. If the sheet is moved up or down to a different position in the list the sheet 
number is adjusted accordingly. 

Options Current Wire  
Choose the Options » Current Wire command to set the current wire width for the Place » Wire 
command. When you choose this command, the Options Current Wire dialog appears. In this 
dialog, select a wire width and click OK. 
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Wire Width options are: 

• Thick wires are 15 mils. 

• Thin wires are 10 mils.  

• User defined wires can range from 0.1 to 100 mils. To maintain the appearance of P-CAD 
Schematic designs before V13.0, all wires less than 11mils wide are displayed as 1 pixel. The 
current wire settings are saved to the Sch.ini file. 

To change the wire width of existing wires, choose the Edit » Properties command. 

Options Current Line  
Choose the Options » Current Line command to set the current line width and style for the Place » 
Line and Place » Arc commands. Select a line style and width and click OK.  

 

Thick and user-defined lines are always solid. Thin lines can be solid, dashed or dotted. Arcs are 
always solid, but can be thick or thin. The current line settings are saved to the Sch.ini file. 

You can also change the current line width using the line width combo box on the status line.  

To change the line width (thickness) of existing lines and arcs, choose the Edit » Properties 
command.  
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Options Text Style  
Choose the Options » Text Style command to set the current text style for the Place » Text 
command. This command also allows you to add, delete, rename, or edit text styles by using the 
series of available dialogs. The text styles you create or edit here are available when you enable the 
Place » Text command, or when you want to modify already placed text with the Edit » Properties 
command. 

The Default and DefaultTTF styles cannot be deleted, renamed, or modified. The other default 
styles (PinStyle, PartStyle, WireStyle and PortStyle) can be modified, but not deleted or renamed. 
You can base a new text style on any of the default styles. 

Choose Options » Text Style to open the following dialog:  

 

Add a Text Style 
1. To add a text style, follow these steps: 

2. In the Options Text Style dialog, click Add. The Add Text Style dialog appears:  

 

3. Select the style of text from the Based On list box. 
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4. Enter the text style name you are adding (e.g., Bus style).  

5. Click OK and the Text Style Properties dialog appears. For a picture of this dialog, see Text Style 
Properties (page 315). 

Delete a Text Style 
To delete a text style: 

1. Highlight the non-default text style you want to delete.  

2. Click Delete. A message appears asking you to confirm your deletion. 

3. Click Yes, and the selected text style disappears from the list.  

You cannot delete default text styles or a text style that is currently in use. 

Rename a Text Style 
To rename a text style: 

1. Select the non-default text style you want to rename.  

2. Click Rename. In the Rename Style box, the existing style name appears.  

 

3. Type over the existing style name to specify the name of the new text style. 

4. Click OK to return to the Options Text Style dialog. 

Text Style Properties 
The Text Style Properties dialog lets you add and modify font properties of the selected (non-
default) text styles. You cannot change the properties of Default text style; you can only query it. 

To query and edit text style properties: 

1. Select a text style from the Current Text Style list.  

2. Click Properties and the Text Style Properties dialog appears (shown below). 

3. From this dialog, you can modify the Height, Thickness, and Font fields for non-default fonts.  

As shown below, the Text Style Properties dialog appears when you click the OK button in the 
Options Add Text Style dialog or the Properties button in the Options Text Style dialog: 
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The stroke font text style is automatically assigned to text in a Schematic design. You may change 
the Height, Thickness and Font properties of the stroke font in the Stroke Font Properties area. In 
addition, when the Allow TrueType box is enabled, you may choose the Font, Font Style and Size 
for the selected style’s corresponding TrueType representation using the standard Font dialog.  

Stroke Font Properties 
You can set the following Stroke Font Properties.  

• Height: The font’s height. 

• Thickness: The text thickness.  

• Font: Choose between QUALITY, BASIC, or LCOM fonts. QUALITY and BASIC fonts are 
interchangeable. BASIC is simpler and therefore draws faster. LCOM is a serif font (a little 
fancier). 

 

TrueType Font Properties 
When the Allow True Type check box is selected, you can change the font type, size and style of the 
text’s TrueType representation. 
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The TrueType Font Properties frame, shown in the previous figure, displays this information:  

• Font: The TrueType font name. 

• Font Style: The font style (E.g., Regular, Bold, etc.)  

• Italic: An X indicates an italic font style. 

• Size: The font size in mils or mms depending on what you have set in the Options Configure 
dialog. 

To change TrueType font properties, click the Font button. 

Click the OK button to apply your selection and return to the Text Style Properties dialog. 

Display Area 
If you have enabled the Allow TrueType option in the Text Style Properties dialog, you may choose 
to display the text in either Stroke Font or TrueType Font by clicking the appropriate button. 

Click OK to return to the Options Text Style dialog. 

Display Stroke and Display TrueType Buttons 
Whenever a text style has had its Allow TrueType option enabled, you can quickly change its 
display mode by clicking the Display Stroke or Display TrueType button in the Options Text Style 
dialog. This changes the selection in the Display area of the Text Style Properties dialog without 
having to go into the dialog and make a new selection. 
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CHAPTER 18 

Library Commands 

Using the Library Commands 
With the Library commands, you can create new libraries, create item aliases, copy items from one 
library to another, delete library items, rename library items, open libraries for access, save symbols 
that you use to create a component libraries, and create an archive library. 

P-CAD libraries are a combination of components, Schematic symbols and PCB patterns (not used 
by Schematic). The component section of a library contains component information, such as what 
symbol is attached to a particular part, what its type is, etc. The symbol section contains the 
graphical information for the symbol that is attached to a part. Without a symbol, a part has no 
graphical representation, and is not placeable. A symbol by itself is only a graphical structure. A 
component and its symbol reside in the same library; the component references a particular 
symbol, its structure, when that symbol is attached to it. For example, a 7400N component with its 
component attributes and pin assignments occupies the same library with a SYMBOL100_N symbol, 
which it references. 

It is typical for multiple components within a library to reference the same symbol. A library could 
conceivably contain 100 components while only containing five symbols (multiple components 
referencing the same symbol). If you changed one of the symbols, then all of the components 
referencing that symbol would be affected. 

If you have purchased P-CAD Library Executive, the Library menu has two additional commands: 
Query and Verify Design. These commands access the embedded component search utility and the 

design verification utility, respectively. See your P-CAD Library Executive User’s Guide for details. 

Library New 
Choose Library » New to create a new library. The new library is empty; it has no components and 
no symbols. 

When you choose Library » New, the Library New dialog is displayed, which is a Windows 
common dialog. In the dialog, you can specify the filename of your new library. 
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Library Alias 
Choose the Library » Alias command to create an alias for a component or symbol. An alias is an 
alternate name for an item (component or symbol). You can create multiple equivalent names for 
the same item with this command. 

When you create aliases for an item, it is not the same as creating copies or renaming. For copying 
or renaming, see the respective Library commands. 

Aliases allow flexibility in using a variety of naming conventions for components or symbols, 
without renaming them. For example, what P-CAD calls an SN7400N, you may want to use a generic 
alias of 7400. Or, if you have components from a vendor using a particular naming convention, and 
you want to continue using that system, you can use alias names and display them on your design 
as such. 

Creating an Alias 
1. Choose Library » Alias to open the following Library Alias dialog:  

 

2. If the appropriate library is not current, click the Library button to open the Library Select 
dialog.  

3. The Library Select dialog is similar to the File Open dialog. 

4. Select the library you want, click Open, and the Alias dialog reappears. 

5. In the Alias Item frame, choose the Component or Symbol radio button. The Pattern radio 
button is grayed in Schematic. 

6. Click the Component or Symbol button to open the Library Browse dialog. Select the item you 
want from the list and click OK.  
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7. You have now returned to the Library Alias dialog. Enter the alias for the symbol in the New 
Alias box, and click Add to append it to the Aliases list. Click Close when finished. 

Library Copy 
Choose the Library » Copy command to copy one or more items from one file to another (either in 
the same or in a different library). The items you copy can be a component or symbol.  

It's important to note that a library part consists of a component section (type, reference 
designator, etc.), a symbol section (for Schematic graphics), and a pattern section (for PCB 
graphics). To place the copied component on a schematic design, you need to copy the component 
and its symbol when copying between different libraries (notice that the Copy Item frame of the 
dialog has a choice between Symbol and Component). When you copy a component, you are 
prompted whether you want to include its associated symbols; you would typically respond Yes. 
When you copy a symbol, no components are included in the copy. 

Also, when copying items from one library to another, you can choose to preserve items in the 
destination library or overwrite them. And when copying components, you can choose to copy the 
corresponding symbols. 

The dialog allows you to select source library and symbol name as well as destination library and 
destination name. 

The source library and destination library that are used with Copy will remain current if you re-
invoke the command during the same P-CAD session. 

If you are copying a component or symbol but are not changing its name, you can leave the 
Destination Name box blank. 
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Copying Symbols/Components 
To copy one or more symbols or components, follow these steps: 

1. Choose Library » Copy. The Library Copy dialog appears as shown in the following figure: 

 

2. Click Source Library. The Library Select dialog appears. The Library Select dialog is similar to the 
File Open dialog. 

3. Select the source library. Click Open. Notice that the source library you selected appears in the 
Library Copy dialog. 

4. Click Destination Library. The Library Select dialog appears again. 

5. Select the destination library. Click Open. The Library Copy dialog displays the paths and 
filenames of the source and destination libraries you selected. 

6. In the Copy Item frame, select the type of item you want to copy. The available items are 
Component and Symbol. For the item type you select, the names of the available items appear 
in the Multiple Source Names list box.  

7. Select the item(s) to copy by using the standard Windows selection key combinations. You 
can select either a single item, a group of items, or all the items in the list. The table below 
explains how to select items for copying: 

 

Do this: To select this: 

Left mouse button 
A single item. If you select a single item, you can enter its 
destination name in the Single Destination Name box. 
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SHIFT+Left mouse button All items between the last selected (highlighted) item and the 
item you click on. 

CTRL+Left mouse button Add items to or subtract items from the selection. 

 

8. You can also click the Browse to Add button to add single items to the your selection. To do 
this, click Browse to Add. Then select the desired item, then click OK. The program highlights 
the selected item in the Multiple Source Names list box. 

9. In the Destination Preferences section of the dialog, indicate whether to overwrite existing 
items in the destination file, preserve existing items, and copy patterns and symbols with a 
component. The last two check boxes are only available if you're copying components. 

10. Click Copy. P-CAD Library Executive copies the selected objects from the source library to the 
destination library. 

11. Click Close to exit the Library Copy dialog. 

Library Delete 
Choose the Library » Delete command to delete a library item or its alias.   

This command deletes the item in name only, if it has aliases. The alternate names (aliases) still exist 
unless you delete them. If the item has only one name and no aliases and you delete it, then the 
item itself is deleted from the library. Use the Library » Alias command to check whether an item 
has aliases. 

IMPORTANT: If you delete a symbol, then all of the components in the library that reference that 
symbol have no graphics, and therefore cannot be placed. Typically you would want to delete a 
symbol alias only, which is not dangerous unless a component used a symbol alias. 

Deleting from a Library 
1. Choose the Library » Delete command to open the following dialog: 

 

2. In the Delete Item frame, select the Component or Symbol radio button. The Pattern radio 
button is shaded in Schematic.  

3. Click the Library button. The Library Select dialog is displayed, from which you can select the 
library in which you want to delete an item.  
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4. The library you selected in Library Select appears in the Library Delete dialog.  

5. Click the item button (Symbol or Component) and the items within the displayed library are 
listed in the Library Browse dialog. Select one and it is listed in the Library Delete dialog. 

6. Click the Delete button and the item box becomes blank. You can continue to delete items 
from the same library. 

7. Click Close to exit the Library Delete dialog.  

Library Rename 
Choose the Library » Rename command to rename a symbol or a component. 

If you rename a symbol, then all of the components in the library that reference that symbol by the 
original name have no symbol graphics, and cannot be placed. If you want to use a different 
naming convention for a symbol, then create an alias for the symbol (Library Alias command) and 
use that alias name. Likewise for components:  if you want to use a different naming convention, 
using aliases is much safer than renaming. 

 Renaming a Symbol/Component 
1. Choose the Library » Rename command to open the following dialog:  

 

2. Select the Rename Item type (Component or Symbol radio button) to specify the item you 
want to rename. Pattern is shaded in Schematic. 

3. Click the Library button to display the Library Select dialog, where you can choose the library 
to access.  

The Library Select dialog is the standard Windows File Open dialog. The library you select in 
Library Select is displayed in the Library Rename dialog. 

4. Click the Symbol or Component button and the items within the displayed library are listed in 
the Library Browse dialog. Select one and it is listed in the Library Rename dialog. 

5. In the New Name text box, type the new name of your item, then click Rename. Both the old 
and new name disappear if the rename action is successful. Then you can continue renaming 
items in the same library. 

6. Click Close to exit the Library Rename dialog.  
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Library Setup 
Choose the Library » Setup command to open libraries from which you can access parts.  

The Place » Part command uses the open library list to place parts. The Library » Symbol Save As 
command also uses the open library list. 

When you want to place a part, the library file where the part resides must be open. You can open 
up to 100 libraries at one time. 

Drag and Drop File Load 
You can use the drag and drop method for opening library files (.lib) from the File Manager or 
other Windows file maintenance utilities. Drag the .lib icon(s) onto your Schematic icon or 
workspace.  

Setting Up a Library 
To setup a library, follow these steps: 

1. Choose the Library » Setup command to open the following dialog:  

 

2. The dialog lists libraries that are already open in the Open Libraries list box. 

3. To add another library to the list, click Add to open the Library File Listing dialog. From there 
you can gain access to the library directory to select a library file. 

When you select a file from the Library File Listing dialog (and click OK), that filename appears 
in the Open Libraries list box in the Library Setup dialog. 

4. To rearrange the list order, select a library name and click the Move Up or Move Down 
buttons. 

5. To remove a library from the list, select the library name from the Open Libraries list box and 
click Delete.  
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6. Click OK and the libraries that you have specified are now open and accessible for part 
placement or saving symbols. 

In order to save a symbol or a component, you need to setup the library in advance. The list of 
open libraries is saved to the Sch.ini file and therefore saved for subsequent P-CAD sessions. 

Many commands start looking for components in the first open library. To ensure your component 
is found in the correct library, open custom libraries first or move them to the top of the list. 

Library Symbol Save As 
Choose the Library » Symbol Save As command to save a symbol to a library. Optionally creates a 
component based on the symbol (you can later attach the symbol to a component using P-CAD 
Library Executive), or match the default pin designators to the pin numbers You must have a library 
already open to save a symbol to it. 

Saving a Symbol 
To save a symbol to a library, follow these steps: 

1. Use the block select function (Edit Select mode, draw a selecting rectangle) to include all 
objects you want to be included in your symbol. At a minimum, a symbol must include a 
RefDes attribute, a Type attribute, and a reference point. All pins must be consecutively 
numbered, starting with 1. No duplicate default pin designators are allowed except for blank. 

2. Any pins numbered 0 will be automatically renumbered for you. 

3. While the objects are selected in your workspace, choose Library » Symbol Save As to open the 
following dialog:  

 

4. From the Library list, choose the library that you want to save the symbol to, then specify a 
symbol name.  
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5. In the Display frame, select the appropriate check boxes to set the default display 
characteristics for the display of reference designators, type, and value. 

To automatically create a component that corresponds to the symbol, select the Create 
Component check box. 

6. To set the default pin designators to match the pin numbers, select the Match Default Pin 
Designators to Pin Numbers check box. You must confirm that you want to overwrite existing 
data if default pin designators had previously been assigned. 

7. Click OK. The symbol is saved to the library. 

8. If the Create Component check box is selected, the Save Component As dialog appears: 

 

9. Type a component name in the Component Name box and select a component type. Make 
additional modifications using the Library Executive. See the P-CAD Library Executive User’s 
Guide for more information. 

10. Click OK. 

Library Archive Library 
Choose the Library » Archive Library command to copy the component and symbol information 
from the open libraries for components used in the active design file. Saving the component 
information in one library file can be extremely helpful, especially for large designs, to keep the 
design component information in a single, readily accessible location. This eliminates the need to 
store the complete set of libraries used to create the design. 

The definitions for each component in the current design must reside in at least one open library. 

1. When you choose Library » Archive Library, the following file search dialog appears:  
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2. The Save In list box shows the current folder and any files in that folder. In the File Name box, 
enter or select a file with the file name extension specified in the Save As Type list box. 

3. If the folder you want is not displayed in the Save In list box, move through the directory tree 
to select the proper folder. 

4. Type a new library file name in the File Name area or select one from the list displayed in the 
Save In area. 

5. Click Save. 

If the library already exists, and you want to replace the data in the file, you must confirm that you 
want to overwrite the file.  

The results of the Archive Library command are displayed in an output file named 
ArchiveLibrary.err located in the same directory as the destination library. This file contains 
errors, warnings and informational messages logged during the archive process. 
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CHAPTER 19 

Utils Commands 

Using the Utils Commands 
Use the commands in the Utils menu to renumber pins and reference designators, run electrical 
rule checking, record Engineering Change Orders, generate netlists, start other P-CAD or third-
party program, and gain access to various web sites. 

Utils Renumber 
Choose Utils » Renumber to manually assign sequential pin numbers and default pin designators 
to pins, and to automatically renumber reference designators on parts. You must be in Select mode 
to choose this command. 

For reference designators, renumbering is automatic across all sheets. 

Renumbering Reference Designators 
1. Choose Utils » Renumber to open the Utils Renumber dialog: 

 

2. In the Type frame, choose RefDes. The controls in the Direction and RefDes frames become 
available and the box labels change to Starting RefDes and Increment Value.  
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3. In the RefDes frame, choose one of these buttons: 

• Choose Auto Group Parts to minimize the number of components by renumbering parts 
so that they fill existing components.  

• Choose Keep Parts Together to renumber components, but leave every component you 
placed, regardless of the number of parts of that component you placed. 

4. In the Direction frame, choose one of the buttons: 

• Top to Bottom: Renumbers reference designators so that lower numbers appear at the top 
of the design and higher numbers appear at the bottom.  

• Left to Right: Renumbers reference designators so that lower numbers appear to the left of 
the design and higher numbers appear to the right. 

5. Click OK. 

Examples 
The following examples show you how the renumbering options work. The illustration below 
shows you the design before renumbering: 

 

If you chose the Left to Right and Keep Parts Together buttons in the Direction and RefDes frames 
of the Utils Renumber dialog, your design should now appear as shown in the following figure: 
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If you choose the Top to Bottom and Auto Group Parts options in the Direction and RefDes frames 
of the Utils Renumber dialog, your design should now appear as follows: 

 

Renumbering Pins 
1. Choose Utils » Renumber to open the Utils Renumber dialog.  

2. In the Type frame, choose Pin Num. The controls in the Direction and RefDes frame become 
shaded and the box labels change to Starting Number and Increment Value, as shown in the 
following figure: 
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3. Click OK to begin pin renumbering manually. You are in a temporary mode of assigning 
numbers, so every left-button click on a pin renumbers it. 

For example, the first pin you click on would be number 1 (if Start Value was specified as 1), the 
second pin number 2 (if the Increment Value was specified as 1). As you click on a pin while in 
the Renumber mode, it highlights to show that a new number has been assigned. 

The status line shows the next pin number every time you number a pin. 

You can use the unwind feature (BACKSPACE) to reverse the renumbering process. 

4. Right-click or press ESC to end the renumber process. 

Renumbering Default Pin Des 
1. Choose Utils » Renumber to open the Utils Renumber dialog. 

2. Choose the Default Pin Des button. The controls in the Direction and RefDes frame become 
shaded and the box labels change to Starting PinDes and Increment Value, as shown here.  

 

3. Click OK. Then click on the pins in the order in which you want the default pin designators to 
be numbered. The status line shows the next pin number every time you number a pin. You 
can use the unwind feature (BACKSPACE) to reverse the renumbering process. 

4. Right-click or press ESC to end the renumber process. 
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Utils Force Update 
Choose Utils » Force Update to replace all components of a given type in your design with the first 
component of that type in an open library. This is especially useful when you have modified a 
component in the Library Executive and want to place the modified component in a Schematic 
design that has the original one. 

For example, you change the number of pins in a component in the library. When you try to place 
the modified component into the design you will receive an error. Choose the Utils » Force Update 
command to update all occurrences of that component in the design to reflect the changes. When 
all existing components of that type have been changed in the design, you can place more of the 
newly modified component into the design without incurring an error. 

When you choose the Utils » Force Update command, the Force Update dialog appears. 

 

Select a component type, or click the Set All button to select all component types. Then, click the 
Update button. To cancel your selections, click the Clear All button. The command looks in all 
open libraries in the order they are listed in the Library Setup list for the replacement components. 

Select the Maintain Rotation check box to maintain the rotation of any rotated components. It does 
not maintain rotations for components in designs loaded from Tango Series II. 

In the Attribute and Pin Label Handling frame, choose the method used to update component 
attributes in your design with the same type of components from the library. Remember that there 
are rules used to determine an attribute value. 

• Merge Attributes (Favor Library): This merge option combines library and design component 
attributes in the component being used in the design. It favors component attributes from the 
library over the component attributes of the same name in the design.  
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The following rules determine which attributes and values are kept in the design component: 

• If an attribute exists in the library component and not in the design component, the library 
attribute and its value is copied into the design component. 

• If the same attribute exists in both the design component and the library component with 
different values, the value of the library component attribute will replace the value of the 
design component attribute. 

• An existing design component attribute, which has no matching library component attribute, is 
retained, unchanged, in the design component. 

• Merge Attributes (Favor Design): Again, this merge option combines library and design 
component attributes in the component being used in the design. This merge option favors 
component attributes in the design over the component attributes of the same name in the 
library.  

These rules decide which attributes and values are kept in the design component: 

• If an attribute exists in the design component and not in the library component, the design 
attribute and its value is kept, unchanged, in the design component. 

• If the same attribute with different values exists in both the design component and the library 
component, the value of the design component attribute takes precedence and is retained in 
the design. 

• Replace Attributes in The Design: Choose this option to replace all of the attributes and their 
values in the design component with those defined in the library component. Current design 
attributes are removed from the component. 

• Ignore Attributes From Library: Keeps attributes in the design and ignores those in the library. 
This feature gives you more control over what to update in the design if you want to preserve 
any specific attribute modifications.  

Utils ERC 
Choose the Utils » ERC command to perform electrical rules checking on your design. Schematic 
then produces a report listing design errors. This process looks for design errors such as single 
node nets and output pins connected to output pins. 

When you choose Utils » ERC, the following dialog appears:  
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• Filename button: Click this button to open the Electrical Rule Check Report dialog (a 
Windows common File Save As dialog). From this dialog choose an ERC report file to which 
you can save the report information. 

• Design Rule Checks frame: Select a check box to include that item on the ERC report: 

• Single Node Nets: Reports all nets with only one node. 

• No Node Nets: Reports all nets with no nodes. 

• Electrical Rules: Reports pins of incompatible types connected together, for example, two 
output pins connected together or an output pin connected to a power pin.  

• Unconnected Pins: Reports all pins that are unconnected to other pins. This includes pins that 
are not connected to anything at all. 

• Unconnected Wires: Reports all wires that are unconnected (floating). 

• Bus/Net Rules: Reports on nets only referenced once in a bus (i.e., a wire goes into a bus, but 
doesn't come out). 

• Component Rules: Reports on all components that are on top of other components. 

• Net Connectivity: Lists conditions that are ambiguous regarding power and ground nets. This 
may occur when the nets have been renamed or merged. 

There are three possible warnings that can occur on the report: 

• A power symbol is connected to a net causing the net name to be ambiguous. 
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• A component’s global hidden pin is attached to a net, which is different from its default 
net name. (For example, the net merge of a hidden pin with a net can cause a hidden pin 
to no longer be connected to its default net name. 

• Warning nets (X) and (Y) have been merged as (X), but net (Y) still exists. This warning is 
designed to let you know you must use the Edit Nets function to rename the nets and any 
connections that may have been added after the merge occurred. 

• Hierarchy Rules: Reports on module and link errors. Each module must have a link attribute 
with pins of matching electrical type and quantity. These module and link pins must be 
connected. All link pins must be placed within the design and have an attribute referencing a 
valid link component. 

• Report Options frame: Select a check box to enable one of these features: 

• View Report: Select this check box to display the ERC report file when the ERC is complete. 
When this check box is cleared, the ERC report file is generated, but not displayed. 

• Summarize Ignored Errors: When the severity level of an error has been set to Ignored, the 
error annotation is not displayed in the design. You can show the summary of these errors by 
selecting this check box. 

• Summarize Overridden Errors: When a design has a number of errors that you do not wish to 
see again, such as unconnected pins, and you have overridden their display using the Edit 
Override command, you can include a count of these errors by selecting this check box. 

• Annotate Errors: Select this check box to display ERC error indicators in your design. These 
indicators can then be selected for viewing of error information. The error information is 
determined by the other options that you enable in rule checking.  

To view the error associated with an error indicator, select it and choose Edit Properties. The 
selection criteria for ERC error indicators (for block selecting) is determined by the Options 
Block Selection command.  

You can also define the size of ERC error indicators in a design in the Miscellaneous tab of the 
Options Display dialog. For information, see Options Display (page 297). 

• Clear All Overrides: When errors in the design have been overridden, and you want to clear or 
delete them from the design, enable the Clear All Overrides option. 

• Severity Level: Click the Severity Level button to open the Rules Severity Level dialog shown in 
the following figure: 



Utils Find Errors Chapter 19: Utils Commands 

P-CAD Schematic User’s Guide 337 

 

In this dialog you can apply a severity level of Error, Warning or Ignored to individual rules. Rules 
marked Ignored are not listed in the ERC report, but you can summarize the number of Ignored 
rules that have violations if you enable the Summarize Ignored Checks option in the Utils Electrical 
Rules Check dialog. 

To change the severity level, select one or more rules and click the radio button next to the desired 
severity level. You can remove the changes you’ve made and return to the original settings by 
clicking the Set to default box. Click OK to return to the Utils ERC dialog. 

When you are finished setting up the ERC options, click OK to begin the rule checking process. 
Existing error indicators are cleared when you choose Utils » ERC. 

Utils Find Errors 
Choose the Utils » Find Errors command to open the Find Errors dialog.  

 

If you have not run the Utils Electrical Rules Check, then the Find Errors dialog displays a message 
informing you that there are no ERC error points. When you have run an ERC command, you have 
access to all the errors through the Find Errors dialog. 
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Information contained in the Find Errors dialog is as follows: 

• Categories: The drop-down list displays the rule categories. You can view the errors for one 
category by selecting it from the list. To select all the categories choose All Categories.  

• Description: Displays the error number along with a brief explanation for the error. 

• Error Number: In the Error Number box you can type the number of the error you want to see, 
and click the Find Specific button to go directly to it. If you want to scroll through the errors 
sequentially, use the up and down arrows next to the box. 

• Show Only Selected: If you have block selected an area in the design, and you only want to 
view the errors in that area, check the Show Only Selected option.  

• Jump To: When you find an error in the report that you want to locate in the design, click the 
Jump To button. The error finder positions the cursor in the center of the error indicator. If you 
have block selected an area in the design the Jump To button positions the cursor inside that 
area and retains the selections. 

• Override – Don’t display this error again: As you display each error in the design, individual 
errors can be removed from the error display by checking the Override – Don’t display this 
error again option. The overridden errors can be summarized in the reports by enabling the 
Summarize Overridden Errors option in the Utils Electrical Rules Check dialog. 

• Show Only Overrides: Provides access to scroll through only those errors to which an override 
has been applied.  

The Find Errors dialog remains on the screen until you click the Close button. As long as there are 
error indicators in the design, you can retrieve the error information in the Find ERC Errors dialog 
with the Utils » Find Errors command. 

Utils Record ECOs 
Choose the Utils » Record ECOs command to record Engineering Change Orders (ECOs). When 
you choose this command, the following dialog appears: 

 

In the ECO Recorder frame, choose the appropriate radio button to turn the ECO recorder on or 
off. As a shortcut for choosing this command, click the ECO button on the toolbar. 

If there are pending ECOs, you are prompted when a design is saved on whether to append the 
pending ECO to the current ECO file.  
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Types of ECOs 
The following types of ECOs can be recorded: 

• RefDes change (Was-Is). 

• Net and net class name changes. 

• Additions, deletions, and modifications of components and parts. 

• Component swaps (Replace). 

• Additions and deletions of nets, net classes and class to classes. 

• Net additions to and deletions from net classes. 

• Additions and deletions of net nodes. 

• Additions, deletions, and modifications of attributes (i.e., in nets, net classes, class to classes, 
etc.). 

• Pin and gate swap changes. 

The format of the ECO file is determined by the setting in the Options Configure dialog. Full ECO 
format files have an .eco extension, and Was/Is ECO files have a .was extension. 

When using the ECO feature to import NetNodeAdds into Schematic, the wire stubs that are auto- 
created may be off-grid. If this happens, you can place another wire on-grid so that it overlaps the 
existing wire stub; the two wires will be merged. 

Was-Is ECO events record only reference designator changes, not part number changes. If the ECO 
recorder is on and is recording only Was-Is events, the Utils » Renumber command should be used 
with the Keep Parts Together option to ensure that the generated ECOs are correct. 

Utils Import ECOs 
Choose the Utils » Import ECOs command to import an ECO file and to apply the ECO changes to 
the current design file. The ECO file is created in P-CAD PCB to capture post-schematic changes 
made to your design.  

If a component attribute is modified through ECOs, it is updated in all parts of the component. 

When you choose this command the following dialog appears: 
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ECO Filename 
1. In the Utils Import ECOs dialog, click the ECO Filename button. The following ECO Filename 

dialog appears: 

 

2. Navigate to the file you want to open or type the name of the file to open in the File Name text 
box. 

3. Click Open to return to the Utils Import ECOs dialog. 

.ECO files are assumed to be full ECO format; .WAS files are assumed to be Was/Is format. 

Preview ECOs 
When you select an ECO filename and then click the Preview ECOs button, you can view a list of 
ECOs before you import them. When you click Preview ECOs, any ECOs appear in Windows 
Notepad: 

 

Utils Export ECOs 
Choose the Utils » Export ECOs command to save ECOs to the ECO file at any time, without saving 
the design file. If there are pending ECOs, the following dialog appears when you choose this 
command: 
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The Utils » Export ECOs command is grayed and unavailable when no ECOs exist. 

View Pending ECOs 
When you click the View Pending ECOs button, you can view pending (outgoing) ECOs, which are 
still stored in memory. The pending ECO data are written to a temporary ASCII file and displayed in 
Windows Notepad. The format displayed is either full or Was/Is, depending on the setting in the 
Options Configure dialog. 

Save ECOs Now 
To save pending ECOs, follow these steps: 

1. Click the Save ECOs Now button in the Utils Export ECOs dialog. The following warning 
message appears: 

 

It is important to remember that if you save ECOs without saving the design, your file and the 
ECOs may not match. That is, the ECOs might not reflect the current state of the design. 

2. To continue, click Yes. The Save ECOs dialog appears: 
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3. The ECO filename appears at the top of the dialog. It is the last used ECO file. To change it, 
click the ECO Filename button and the following dialog appears: 

 

4. The ECO Filename dialog is a standard File Open dialog. Type, or select from the list, the name 
of the file you want to open in the File name box. Click OK to return to the Save ECOs dialog.  

5. Full ECO files must have an .eco extension, and Was/Is files must have a .was extension. 

6. In the Comments box, type any comments that can help document the ECOs. 

7. To append ECOs to the ECO file, click the Append ECOs to File button. 

8. To discard ECOs, click the Discard ECOs button. Once discarded they cannot be recovered. 

Utils Generate Netlist  
Choose the Utils » Generate Netlist command to create a netlist from the combination of 
connections you have established (or loaded) in a design file.  

1. With your design file opened, choose the Utils » Generate Netlist command. The following 
dialog appears: 

 

2. To choose a netlist file, click the Netlist Filename button. This will display the Netlist File dialog, 
which is a standard Windows File Open dialog. 
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3. Select the destination format in Netlist Format combo box to specify the destination format. 
Available formats are: 

• P-CAD ASCII 

• Tango 

• FutureNet Netlist 

• FutureNet Pinlist 

• PCAD 

• EDIF v2.0.0 

• Pspice 

• Xspice. 

4. Select the Include Library Information check box to write an optional library section to the 
netlist. 

5. Library information is read by P-CAD PCB but not processed; it is merely informational. The 
Library section may be used to create a P-CAD library, however, by removing the non-library 
information from the file and using the Library Executive to translate the ASCII form of the 
Library into a P-CAD binary library. 

6. Click OK in the Netlist Generate dialog to create the netlist with the filename and netlist format 
you have specified. 

Utils Rename Net 
Choose the Utils » Rename Net command to input a seed net name and an increment value, and 
rename one or more nets by selecting one net at a time. 

Renaming a Net 
To rename a net: 

1. Choose the Utils » Rename Net command or click the Rename Net button in the toolbar.  

2. In your design workspace, click a wire or port. The Utils Rename Wire/Port dialog appears: 
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3. Use this dialog to set your initial selection for net renaming. Depending upon the selected 
object and which options you set, you can rename a net, split a net, or merge a net.  

4. Set the seed name for renaming the nets and indicate whether or not to increment the 
subsequent names. 

5. To split a net, choose the Contiguous Wire button.  

6. A net can be split if the selected wire or port is part of a subnet and there are other subnets in 
that net. The net is split with the selected subnet getting the new name and the other subnets 
keeping the original name.  

7. A subnet can be split from one net and merged with another, if the net name already exists and 
is global. If the net is split, the selected subnet is merged with the existing net, while the other 
subnets retain their original name. 

8. To rename an entire net, you must either select the Entire Net option or select a net that is 
comprised of a single contiguous subnet. 

If the new name does not already exist within the design, the entire net is renamed. If you 
attempt to rename a net with the name of an existing net, and one of the nets is not global, an 
error message appears. You must confirm that you want to autoplace ports to make both nets 
global by clicking the Yes button. The nets are merged and renamed. 

9. Click OK to return to your design. Each time you make a selection, the net is renamed using 
the values set in the dialog.  

Jumper Pins 
Jumpers behave as if all of the jumper pins are connected. In Schematic, pins are ported to force 
them to belong to the appropriate net.  

Utils Resolve Hierarchy 
Once you create a module and place it in your design, you must resolve the hierarchy before 
performing ECOs or generating netlists. 

To resolve a hierarchy, follow these steps: 

1. Choose the Utils » Resolve Hierarchy command. A message box appears, asking you if you 
want to save the design before proceeding. Resolving hierarchies alters your design, so you 
should save it before proceeding. 

2. Click Yes to save your design, No to proceed without saving your design, or Cancel to abort 
the command. Clicking Yes displays the Save As dialog, which prompts you for a filename for 
saving the design. 

3. Select the desired design name, or enter it in the File Name field. 

4. Click OK. P-CAD Schematic resolves the hierarchy. In the case of a complex hierarchy, the 
program copies the definition sheet for each module that references it. In this process, ports 
are added to module and link pins. 
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If a problem occurs, P-CAD Schematic displays an error message indicating that the hierarchies 
were not resolved and explains why the hierarchies were unresolved. In this case, you can click Yes 
to view the errors in Notepad. 

One important condition that causes an error message to appear is called a passthrough condition. 
A passthrough condition occurs when two links are connected together by wires, ports, or a 
combination of the two. 

Utils Module Wizard 
P-CAD Schematic supports hierarchical schematic designs. The Utils » Module Wizard command 
makes it easier for you to create and manage complex designs. 

With a hierarchical design, you can reference several sub-circuits from the main, or top-level, 
schematic design. 

You create a hierarchical design by placing a module, or black box, on your design. P-CAD 
Schematic represents this module as a component with a component type MODULE. A module is 
an abstract representation of the sub-circuit to which you are referring. Each module has pins 
representing the interface to the sub-circuit. These pins connect to the inputs and outputs of the 
sub-circuit. 

Each module also requires a link, which connects the module to its definition. A definition, or 
defined sheet, is a sheet that contains the actual circuitry of a module. P-CAD Schematic represents 
a link as a component with a component type LINK. Both the module definition and its link must be 
on the same sheet, and a sheet can only contain one module definition. 

Your design can have simple or complex hierarchies. A simple hierarchy has one module 
referencing one link, while a complex hierarchy has multiple modules referencing a single link. 

You can place modules and links the same way you place any other part. 

P-CAD Schematic stores modules and links as components in a component library, complete with 
type names, reference designators, and user-defined attributes. 

After placing modules and links, you must resolve the hierarchy. This converts a complex hierarchy 
to a simple hierarchy so that you can generate a netlist. Once you resolve a hierarchy, you can 
import and export ECOs, generate netlists, and save your schematic to a PDIF file. 

You can ascend and descend the unresolved designs using the Ascend and Descend commands 
found on the right mouse button pop-up menu. 

To create and use a hierarchy in your design, you must: 

• Create a module and its link. You can either create a new module and its link or reuse an 
existing module. 

• Place the module in the schematic design. 

• Resolve the hierarchy. 
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Creating a New Module and its Link 
This section explains how to create a module and its link, then place the module in a schematic 
design: 

1. Choose Utils » Module Wizard. The Module Wizard dialog appears: 

 

2. Choose the Create a new module and its link button. Then, click the Next button. 

3. Another Module Wizard dialog appears, as shown below. 

 

The Module Wizard dialog allows you to specify module and link parameters. The preview 
window displays the module symbol. As you define the module's parameters, the preview 
window reflects these changes in the module's appearance. For instance, if you change the 
number of input pins from two to three, this change appears in the preview window. 

• Module name: The name of the module. 

• Number of input pins: The number of input pins for the module symbol. 

• Number of output pins: The number of output pins for the module symbol. 

• Symbol width: The width (in mils) of the module symbol. 

• Pin length: The length (in mils) of the input and output pins. 

• Pin spacing: The spacing (in mils) between each input and output pin. 
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• Create Corresponding Link: Indicates whether or not to create a corresponding link for 
the module. If you don't select this check box, the program asks you to select a link 
already placed on the schematic. 

• Link name: The name of the link between the module and its definition. 

• Save in Library: Indicates whether or not to save the module in a library. 

• Library: The library to which you are saving the module and link. 

• Pin Designator: The default pin designator that the Module Wizard automatically assigns. 

• Pin Name: Lets you change the default pin names. While you are in this box, if you press 
Enter, the program automatically updates the pin name and the box automatically cycles.  

4. Enter the module and link parameters. Then, click the Next button. The following Module 
Wizard dialog appears: 

 

This dialog displays the following information: 

• Placement of new link: The name of the new link. 

• Currently defined sheets: The sheets currently defined in the design. Defined sheets have 
three restrictions: 

• A defined sheet can contain circuitry for only one module. 

• The module's circuitry must be contained within one sheet. 

• If you create the defined sheet with the Module Wizard, its name is the same as the 
module's name. 

• Link will be placed on sheet: The name of the sheet where the module links are to be 
placed. By default, the sheet name is the same as the module name. 
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• The link refdes is also: The link reference designator is automatically set to the sheet name. 

5. Enter the link definition information for the target sheet and the Link RefDes. Then, click the 
Next button. 

The module placement dialog appears, indicating that you are about to place the module you 
just created. 

 

You can click OK to place the module, click Back to go back to the previous dialog, or click 
Cancel to abort. If you click OK, P-CAD Schematic returns you to the design in Place Part 
mode, meaning that you can now place the module in your design. 

6. Select the desired location for your module, then click the left mouse button to place it. 

Reusing an Existing Module 
You can reuse an existing module if you don't want to create one from scratch. To reuse an existing 
module, follow these steps: 

1. Choose the Utils » Module Wizard command. A Module Wizard dialog appears, as shown 
below: 

 

2. Choose the Reuse an existing module button. Then, click the Next button. 

Another dialog appears, prompting you to select the library containing the module and the 
module you wish to place on the schematic. 
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3. Select the library containing the module, then select the desired module. 

4. Click Next. Another dialog appears, asking you if you want to place a new link, or reference an 
existing link: 

 

5. Choose the Place a new link button. Then, click the Next button. Another dialog appears, 
prompting you to select the library containing the link and the link itself. 

Alternatively, select reference an existing link. P-CAD Schematic displays a dialog prompting 
you for a reference designator for the link. Select the desired reference designator from the 
list, or type the reference designator of an existing link, then click Next. Now skip to step 9. 
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6. Select the library containing the link from the Library list box, then select the desired link from 
the Link list box. 

7. Click Next. Another dialog appears. The list on this dialog displays the currently defined sheets. 
However, P-CAD Schematic places the link on a new sheet unless you specify the name of an 
existing sheet in the text box. 
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8. Make any desired changes to the default sheet name displayed in the text box, then click Next. 

The module placement dialog appears, indicating the reference designator of the module you 
are about to place. 

 

9. Make any desired changes to the reference designator. Then click OK to place the module, 
click Back to go back to the previous dialog, or click Cancel to abort. 

If you click OK, P-CAD Schematic returns you to the design in place part mode, meaning that 
you can now place the module in your design. 

10. Select the desired location for your module, then click the left mouse button to place it. 

You can create your own default link symbol by saving a single pin symbol with the name LINK_PIN 
into your custom library. When the Module Wizard places a link, it uses that symbol. 

Utils Shortcut Directory 
When you installed P-CAD Schematic, a sub-directory called ShortcutDirectory was created in the 
P-CAD directory. The ShortcutDirectory contains a list of web addresses for semiconductor 
manufacturers.  

Choose the Utils » Shortcut Directory command to open the ShortcutDirectory in Windows 
Explorer. Select the desired address and choose the Open command from the right mouse menu, 
or double click on the address. 

Shortcuts to any web site can be added in the ShortcutDirectory.  

Utils P-CAD PCB 
If P-CAD PCB is installed on your computer, choose the Utils » P-CAD PCB command to start 
P-CAD PCB. Refer to your P-CAD PCB User’s Guide for additional information. 

• If P-CAD PCB is not running, choose this command to start P-CAD PCB.  

• If PCB is already running, choose this command to make P-CAD PCB the active program.  
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Utils P-CAD Library Executive 
Choose this command to start P-CAD Library Executive, if P-CAD Library Executive is installed on 
your computer. Refer to your P-CAD Library Executive User’s Guide for additional information. 

Utils P-CAD Pattern Editor 
Choose this command to start P-CAD Pattern Editor, if P-CAD Pattern Editor is installed on your 
computer. Refer to your P-CAD Library Executive User’s Guide for additional information. 

Utils P-CAD Symbol Editor 
Choose this command to start P-CAD Symbol Editor, if P-CAD Symbol Editor is installed on your 
computer. Refer to your P-CAD Library Executive User’s Guide for additional information. 

Utils InterPlace/PCS 
Choose Utils » InterPlace/PCS command in the Schematic Utils menu provides access to both 
P-CAD Parametric Constraint Solver and P-CAD InterPlace. P-CAD searches your license files and, 
depending on which license(s) are found, starts the appropriate program(s). 

Utils Customize 
Choose Utils » Customize to add items to the Utils menu and custom toolbar, so you can gain to 
access other programs from P-CAD Schematic. The Utils Customize dialog appears. 
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The Utils Customize dialog is used to add new tools or delete and modify existing tools on the 
Custom Tools toolbar and Utils menu. The fields on the dialog are as follows: 

• Custom: Provides a list of the custom tools that currently exist.  

• Menu Text: Enter the description of the tool being added. The Menu Text field allows up to 40 
characters. The buttons on the toolbar display as many letters as can fit on the button. If the 
name of a tool being added to the custom toolbar is too long to be displayed in its entirety, you 
can change the display by using lower case letters or shortening the name of the new tool.  

• You may insert an ampersand (&) anywhere in the text string to designate a menu shortcut key. 
For instance, if the Menu Text entry is &Notepad, the menu shortcut key for the tool is the 
letter N.  

• The Utils menu displays the list of custom tools as shown to the left. 

• Command: Enter the path to the executable file of the new tool. Click the Browse button to 
display an Open dialog where the desired file can be chosen. A warning is issued if a non-
existent path is entered, but the entry will still be added. 

• Arguments: Optional entry used to pass information into the targeted program, if desired. 

• Initial Directory: Sets the initial working directory for the program. 

• Display: Selects the way the program appears on the screen when initialized. Normal (the 
default) to display the program as a window in the workspace, Minimized to start the program 
and display it as an icon at the bottom of the screen, or Maximized to start the program and 
display it across the full screen. 

• Prompt for arguments: Check this box to automatically display the Arguments dialog, which 
provides a way to enter input that must be passed to the program at execution time. The entry 
is saved and recalled the next time the program is run. 

• Add: Click the Add button to begin adding a new tool. You can add a maximum of 16 tools to 
the Custom toolbar. 

• Remove: Select a tool from the custom area and click Remove to delete it from the customized 
toolbar. 

• Move Up/Move Down: Select a tool from the Custom list and change its position in the list by 
clicking the Move Up or Move Down buttons. 

Once all selections and entries have been made, click OK to apply them.  

Displaying the Custom Toolbar 
The Custom toolbar is not displayed in the workspace until a custom tool has been added. Once a 
tool has been added, the toolbar automatically appears with the other Schematic toolbars. 
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You may control the appearance of the Custom toolbar in the workspace using the View » Custom 
Toolbar command. See View Custom Toolbar (page 256) for more information. 

Executing a Custom Tool 
To launch an program added as a Custom Tool, you may choose any of these methods: 

• Click the desired button on the Custom toolbar 

• Select the tool from the list at the bottom of the Utils menu (shown above).  

While the Utils menu is active select a custom tool by pressing the menu shortcut key assigned to 
it. For instance, select Notepad by pressing the N key. 

 



 

P-CAD Schematic User’s Guide 355 

CHAPTER 20 

Simulate Commands 

Simulate Run 
Choose the Simulate » Run command to run a simulation on your schematic. The command will 
only become available if you have a schematic design open. If you have created your schematic 
design using parts that have simulation models associated with them, clicking Simulation » Run will 
invoke the Mixed-Signal Circuit Simulator (from within the Design Explorer 99 SE application) and 
run a simulation on the design. 

If you want to specify analysis criteria prior to running a simulation on your design, you can choose 
the Simulate » Setup command. This command will invoke the Mixed-Signal Circuit Simulator 
(from within the Design Explorer 99 SE application) and launch the Analyses Setup dialog, from 
where you can specify your simulation criteria before executing the simulation. 

If you choose to run a simulation on a schematic that includes parts not supported by simulation 
models, the Mixed-Signal Circuit Simulator will not invoke. Instead a notepad window will launch, 
displaying an error log containing all simulation-related errors that are preventing the schematic 
from being simulated. 

Simulate Setup 
Choose the Simulate » Setup command to allow you to specify analysis criteria prior to a simulation 
of your design being executed. The command will only become available if you have a schematic 
design open. If you have created your schematic design using parts that have simulation models 
associated with them, clicking Simulation » Setup will invoke the Mixed-Signal Circuit Simulator 
(from within the Design Explorer 99 SE application) and bring up the Analyses Setup dialog. From 
this dialog, you can determine which analses to run on your design. Analyses available include: 
Operating Point, Transient/Fourier, AC Small Signal, DC Sweep, Noise, Transfer Function, 
Temperature Sweep, Parameter Sweep and Monte Carlo. 

If you want to run a simulation on your design straight away, choose the Simulate » Run command. 

For more information, refer to the online help documentation. 
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CHAPTER 21 

DocTool Commands 

Using the DocTool Commands 
With the documentation tools in P-CAD Schematic, you can detail the fabrication, assembly, and 
testing of the printed circuit board. Using the commands in the DocTool menu, you can perform 
the following tasks: 

• Create versatile zoned borders and custom title blocks. 

• Include drawing and revision notes. 

• Insert tables that include design data such as: net locations, power and ground net data, as well 
as last used, not used, and spare gate information. 

• Place annotated sheet connectors.  

• Track nets between schematic sheets. 

This chapter contains a detailed explanation of each command in the DocTool menu. 

DocTool Place Table 
Choose DocTool » Place Table to place a table in your schematic design. To learn how you can use 
tables in a design, see one of the following topics. 

When you choose this command and click the workspace, the following dialog appears: 
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The Place Table dialog contains the following options: 

• Table Type (list box). Select the type of table you want to place from this list. 

• Table Name (text box). Type a name for your table in this box. When you place a table in the 
design, this name appears above the table. 

• Text Style (list). Select a text style for the table from this list.  

• Text Styles (button). Click this button to open the Options Text Style dialog. Use the controls in 
this dialog to modify text styles. 

Note Numbering Frame 
The options in this frame are only available when you place a Note Table or Revision Note Table. 
For more information, see, Note Tables (page 112) or Revision Note Tables (page 114). 

• Top to Bottom (option button). Choose this button to increment note numbers from the top to 
the bottom of the table. 

• Bottom to Top (option button). Choose this button to increment note numbers from the  
bottom to the top of the table. 

• Width of Note Column (text box) Type a value in this box to specify the column width in 
number of characters. When a note exceeds the column width, the text wraps to the following 
line.  

Note number or symbols do not appear in a revision notes table. The Note Numbering option 
specifies the order of the placed notes, with or without the numbers displayed. 

Pins to Include Frame 
The options in this frame are only available when you place a Power Table. For more information, 
see Power and Ground Tables (page 113). 

• All Pins (option button). Choose this button to include all pins in the table. 
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• Hidden Pins Only (option button). Choose this button to include only hidden pins in the table. 

Components to Include Frame 
The options in this dialog are only available when you place a Power Table. For more information, 
see Power and Ground Tables (page 113). 

• All Components (option button). Choose this button to display all components in the table 

• Only RefDes Prefix (option button). Choose this button to only display components of a 
particular value. 

DocTool Titles 
Choose DocTool » Titles to create a custom title sheet for your schematic design.  

When you choose this command, the Options Sheets dialog appears with the Titles tab selected. 
You use the options in this dialog build title sheets that can include any or all of the following 
elements: design border, zones, and a title block. 

In Schematic, zones are intelligent and can be used to mark the locations of sheet connectors, as 
well as cross- reference these connected nets between schematic sheets. For details, see Sheet 
Connector Cross Referencing (page 107). 

For more information, see Title Sheets (page 98) and Options Sheets (page 311). 

DocTool Notes 
Choose DocTool » Notes to add or import notes that you can place in your schematic design. 

When you choose this command, the Design Info dialog appears with the Notes tab selected. You 
use the options in this dialog to add or import notes into your design. 

For more information, see Placing a Net Index Table (page 111) and File Design Info (page 183). 

DocTool Update 
Choose DocTool » Update to recalculate the design data and update the selected tables or 
diagrams embedded in the design. 

DocTool Update All 
Choose DocTool » Update All in P-CAD Schematic to recalculate the design data and updates all 
tables or diagrams embedded in the design. 





 

P-CAD Schematic User’s Guide  361 

CHAPTER 22  

Macro Commands 

Using the Macro Commands 
The Macro menu lists the commands available to record and run macros. A series of actions that is 
often repeated during a design session can be recorded, assigned to a key sequence and played 
back at any time, automating the design process. 

Macro Setup 
Choose Macro » Setup to specify the directory in which macros are stored and the playback delay 
interval. 

Before you start recording the set of actions that will make up a new macro, you should choose 
Macro » Setup if you want the macro to be stored in a directory other than the default directory, or 
if you need to change the playback interval. 

Setting Up a Macro 
1. Choose Macro » Setup to open the following dialog. 

 

2. Click Browse to open the Open dialog. 

3. Select the directory you want to use as the default macro storage location. Then, click Open to 
return to the Macro Setup dialog. 
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4. Enter the Playback Delay interval in seconds. The number you enter here controls how fast 
each recorded event appears in the workspace when the macro is run. You can set the interval 
to the thousandths (.001 of a second). 

5. Click OK to commit your setup selections or click Cancel to exit without changing the settings. 

Macro Record 
Choose Macro » Record to record a macro and to assign a name to that macro.  

1. Choose Macro » Record to open the following dialog:  

 

2. Type a name for the macro you will record in the Macro Name text box. 

3. Click OK to close the dialog. The Macro Recording Tool appears and the background of the M 
button in the status line is red, to indicate that you are in recording mode. Any actions you 
perform are recorded.  

4. To stop recording, click M on the status line or press the M key. 

After you record a macro, you can assign it to a shortcut key by choosing Options Preferences. 
Alternatively, you can add it to the Utils menu by choosing Utils » Customize. For additional 
information, see Options Preferences (page 301) and Utils Customize (page 352). 

Macro Recording Tool 
While recording events in a macro, the following controls are available in the Macro Recording 
Tool: 

 

The buttons in the Macro Recording Tool perform the following functions: 

 

 
Stop Recording:  Terminates the recording process and stores the 
events in the designated file. The recording process can also be 
stopped by pressing M or clicking M on the status bar. 
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Pause Recording:  Temporarily disables the recording process. 
When you pause a recording this button changes to the Resume 
Recording button. 

 
Recording Suspend:  Inserts a suspend that creates a pause during 
playback. You can also insert a suspend by pressing the Pause/Break 
key. 

 
Resume Recording: This button appears in the Macro Recording 
Tool instead of the Pause Recording button whenever you pause 
recording. It also appears during playback whenever the playback 
reaches a recorded suspend activity. 

 
Recording Origin:  Places an origin in the macro. When a recorded 
origin is encountered, you can click the left mouse button in the 
workspace to set a relative playback location during playback. 

 
Cancel Recording:  Terminates the recording process and does not 
save the file. 

 

Temporary Macro Record (M Toggle Button)  
The Macro toggle button (M button located on the status line) allows you to create temporary 
(filename is Sch_default.mac) macros on the fly. Typically, you would use this macro for a short 
time within a design process (e.g., repeatedly placing a combination of lines, duplicating the same 
lengths and angles, etc.). 

Only one temporary macro is available at a time; each time you record a temporary macro, it 
overwrites the previous one. 

Recording a Temporary Macro 
To record a temporary macro, follow these steps: 

1. To begin recording, click M on the status line or press M; the button background changes to 
red. 

2. Perform the actions you wish to record. 

3. To stop recording, click M or press M again; the colored background disappears. 

4. Press E (execute) to playback the temporary macro. The actions you recorded repeat each time 
you press E. 

The entire group of macro functions is available to a temporary macro, including pause and 
suspend. 

The name of the temporary macro is Sch_default.mac, so don't create any macros by that name. 

If you want to create a more permanent macro, then you need to name it and record it with Macro 
Record. You can rename any macro with Macro Rename.  
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Macro Delete 
Choose Macro » Delete to delete a macro. When you choose this command, the following dialog 
appears: 

 

Select the macro you want to delete from the Macro Name combo box, or type the name of the 
macro. The combo box lists all the *.mac files found in the default macro directory set in the 
Macro Setup dialog. Click Delete and the macro disappears from the list. 

Macro Rename 
Choose Macro » Rename to rename a saved macro or the temporary macro Sch_default.mac. 
When you rename Sch_default.mac, it is no longer a temporary macro, but a saved, named 
macro. 

When you choose this command, the following dialog appears: 

 

Select the file to rename from the Old Name combo box. This combo box lists all the *.mac files 
found in the default macro directory, which is set in the Macro Setup dialog. For instructions, see 
Macro Setup, (page 361). 

The Macro menu lists the commands available to record and run macros. A series of actions that is 
often repeated during a design session can be recorded, assigned to a key sequence and played 
back at any time, automating the design process. 

Enter a new name for the selected macro in the New Name edit box. Next, click Rename and then 
click Close.  
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Macro Run 
Choose Macro » Run to playback a saved macro. While the macro is running, the M button on the 
status line has a green background. 

When you choose this command, the following dialog appears: 

 

To run the macro, type a name or select one from the Macro Name combo box. This combo box 
lists all the *.mac files found in the default macro directory set in the Macro Setup dialog. Click OK 
to run the selected macro. 

This command is also handy for viewing your list of macros before you run one.  

If you use a macro frequently, you can assign it to a key as a shortcut by choosing Options » 
Preferences. Or, you can add it to the Utils menu by choosing Utils » Customize. For information, 
see Options Preferences (page 301) and Utils Customize (page 352). 

Running Temporary Macros 
To run the temporary macro, press E. To record a temporary macro, press M, do a series of actions, 
and press M again to end recording. 

To clear the temporary macro, press M twice to record nothing. 

Recording Efficient Macros 
The macro utility records every keystroke and mouse click that occurs in the workspace. Because 
the macro utility focus is toward pressing keys and clicking the mouse, it is advantageous to use the 
menu commands and the keyboard. 

By understanding how the macro utility operates, you can make the most of this powerful tool 
when recording your macros. The following list provides some helpful hints that will maximize the 
effectiveness of your recordings: 

• If you click a button in the toolbar while recording, the toolbar must be in the same location 
during playback. By using the shortcut keystrokes instead of toolbar buttons, the toolbar can 
be in any location without affecting the playback. 

• When choosing commands, use the menu commands by clicking on them with the left mouse 
button instead of the commands in the shortcut menu. The right mouse menu changes 
location based on mouse location. 
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• When information dialogs appear while recording a macro, and you need to interact with the 
dialog during playback, insert a suspend command by pressing the Pause/Break key. 

• There are times when you may select an item from a drop down list during an event recording. 
If the order of the items in the list is subject to change due to additions or deletions, the most 
effective way to eliminate choosing the wrong item is to type the desired value in the edit box 
instead of selecting from the list. Then you are assured that the correct item is incorporated 
into the event.  

• Whenever options on the status line are recorded, such as changing a layer, you must assure 
that the status line view is enabled when running the macro. If the status line is not visible 
during macro playback, the location of the recorded command cannot be identified nor 
executed. 

• When working with text it is best to make changes using keys such as DEL, BACKSPACE, etc. 

• Retain the same size workspace and focus during playback as you used when recording. 
Changing the workspace size or zoom factor causes adjustments in location coordinates. For 
instance, if you place a component in the outer regions of a design and change the zoom so 
that those coordinates are no longer visible in the workspace, the component cannot be 
placed during playback. 

• The resolution of the system in which you are running a recorded macro should match the 
resolution of the system in which the macro was recorded. 

Macro Features 
The macro tool features extend beyond the record and play functions. This section describes these 
additional features: 

• Running a Macro: You can launch the Schematic program and a particular macro from the 
command line by entering a fully qualified path to the executable and then the macro files 
name. 

<full path>.SCH.exe /e 

<full path><macro name> 

If Schematic is already running, this command opens the macro in the current Schematic 
session. If Schematic is not currently running it is launched and the macro opened. 

• Status Line Recording Indicators: When the status line is enabled, the Macro Toggle button (M) 
displays different colors to indicate the type of activity being performed. When recording, the 
background is red. During playback, the background is green. Yellow indicates a pause in the 
recording, or shows that a suspend or origin command has been encountered during playback. 

• Automatic Delays: The macro recording automatically inserts a delay into a macro whenever a 
Print Setup, Font or Custom Color dialog has been displayed. This allows the dialog time to 
appear in the workspace. If the interval is not large enough for the playback to accommodate 
the next event, you can change it directly be editing the *.mac file or by editing the Sch.ini 
file and changing the “MacroCommonDialogDelay” to a larger number. 
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• Editing Macro Files: You can directly edit a macro file to add or change delays, launch other 
programs, etc. Each additional command that you add must use the correct syntax. 

The following section describes the commands that can be added and the proper syntax for each. 

Macro File Syntax 
If you have a recorded macro that needs to be modified slightly and you do not want to record the 
entire chain of events again, you can edit the macro directly. This section explains the syntax used 
to record the events in the macro file. 

Syntax is very important in the macro files. Each macro command is case sensitive and each line 
must contain a carriage return. 

A sample macro, opened in a text editor, is shown below: 

 

There are a variety of event types:  mouse, keyboard, special and edit. Each has its own keywords 
and syntax format as shown below. Syntax descriptions show a comma to separate the parts of the 
format for readability. The commas are not to be inserted into the actual format of the command. 
An example of an actual syntax is provided as well. 

Mouse Events 
Mouse events occur while the cursor is over the workspace and also when the cursor is over the 
program, but not in the workspace (i.e., over a menu, toolbar, dialog, etc.). Events that occur when 
the cursor is over the workspace are recorded as appunit locations. Events occurring when the 
cursor is over a menu, toolbar, etc., are recorded in pixels. 

Syntax: Keyword, white space, positive integer, white space, unit string, white space, positive 
integer, unit string. 

LeftMouseDown 23 Pixels 101 pixels 

LeftMouseUp 18 pixels 583 pixels 

LeftMouseDown&KeyStroke 179 appunits 50 appunits SHIFT 
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Keywords: LeftMouseDown, LeftMouseUp, LeftMouseDoubleClick, RightMouseDown, 
RightMouseUp, LeftMouseDown&Keystroke<appunits or 
pixels>Ctrl,LeftMouseDown&Keystroke<appunits or 
pixels>SHIFT,LeftMouseDown&Keystroke<appunits or pixels>Alt. 

Unit Strings: A unit string in a mouse event is either pixels or appunits. In the example above, 23 
and 101 are the X and Y coordinates of the left mouse down action, and pixels indicates that the 
mouse click was made on a toolbar command. If the unit string contains appunits, then the mouse 
click was made in the workspace at the indicated X and Y coordinates. 

Keyboard Events 
Syntax: Keyword, white space, quoted character string. 

SendKeys “{SHIFT+N}{e}{w} 

Keywords: SendKeys 

Character String: Each keystroke, and combinations thereof, must be enclosed in curly brackets 
and the string of curly bracketed strokes enclosed in quotations. In the example above, the word 
New is recorded using the keyboard syntax format. 

Keyboard Codes: The following list defines the recordable keys and how they are represented in 
the macro file. 

 

Keys Codes 

a – z A – Z 

A – Z SHIFT+A – SHIFT+Z 

0 – 9 0 – 9 

F1 - F12 F1 – F12 

Alt ALT 

Back Space Backspace 

Ctrl CTRL 

Delete Delete 

End End 

Escape ESC 

Home Home 

Insert Insert 

Num Lock Not recordable 

Page Down PageDown 
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Keys Codes 

Page Up PageUp 

Pause Break Not recordable 

Print Screen Not recordable 

Scroll Lock Not recordable 

Space Space 

Tab TAB 

Down Arrow Down 

Left Arrow Left 

Right Arrow Right 

Up Arrow Up 

Numpad 0 Numpad0 

Numpad 1 Numpad1 

Numpad 2 Numpad2 

Numpad 3 Numpad3 

Numpad 4 Numpad4 

Numpad 5 Numpad5 

Numpad 6 Numpad6 

Numpad 7 Numpad7 

Numpad 8 Numpad8 

Numpad 9 Numpad9 

Numpad / NumpadDivide 

Numpad - NumpadMinus 

Numpad * NumpadMultiply 

Numpad + NumpadPlus 

Numpad Clear NumpadClear 

` Backquote 

- Minus 

= Equal 
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Keys Codes 

\ Backslash 

; Semicolon 

‘ Singlequote 

/ Slash 

. Period 

, Comma 

[ LeftBracket 

] RightBracket 

~ SHIFT+Backquote 

! SHIFT+1 

@ SHIFT+2 

# SHIFT+3 

$ SHIFT+4 

% SHIFT+5 

^ SHIFT+6 

& SHIFT+7 

* SHIFT+8 

( SHIFT+9 

) SHIFT+0 

_ SHIFT+Minus 

+ SHIFT+Equal 

| SHIFT+Backslash 

{ SHIFT+RightBracket 

} SHIFT+LeftBracket 

“ SHIFT+Singlequote 

: SHIFT+Semicolon 

? SHIFT+Slash 

< SHIFT+Comma 
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Keys Codes 

> SHIFT+Period 

Special Windows keys Not recordable 

 

Special Events 
Syntax: Keyword. 

Origin 

Suspend 

Delay 1.001 

Keywords: Origin, Suspend and Delay. 

Exception: The Delay keyword is generated by the macro utility whenever a print setup, font or 
custom color dialog is invoked in the macro. Inserting a one-time delay interval pauses the 
playback so that there is time to set up the next recorded event. The Delay keyword is followed by 
a positive floating number. This delay time is added to the global playback interval set using the 
Macro Setup command. 

Edit Events 
Syntax: Keyword, qualifier. 

Wait 4 

ExecuteCommand “C:\ACCEZZL\PATED.EXE” 

Keywords: Wait, ExecuteCommand. 

Qualifier: Each of these keywords has its own type of qualifier. The Wait keyword is followed by a 
positive number indicating the pause interval in seconds. During playback the wait interval is 
counted down in the Status Bar and the playback resumes when the interval is complete.  

The ExecuteCommand launches another program and requires the program name enclosed in 
quotes. It may also required the path to the program name or file. 

File Syntax 
Beginning: The macro file begins with the keyword SchMacro, followed by the name of the macro 
and a comment string. The comment string, which can also be added to any line in the macro, must 
begin with a single quote. 

Ending: Every macro must end with the keyword End. 

Other: Every line must begin with one of the keywords. Although optional, a tab at the end of each 
line helps increase a macro’s readability when it is edited. 
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CHAPTER 23 

Window Commands 

Window New Window 
Choose Window » New Window to open additional windows for the active design. You can move 
independently in each window, making it easy to compare different parts of the same design.  

A number identifying the window is added to the file name in the title bar and at the bottom of the 
Window menu.  

Window Cascade 
Choose Window » Cascade to arrange all open windows so that the window tiles are visible. 

All windows overlap, starting in the upper-left corner of your workspace. You can see each 
window's title, making it easy to switch between windows. 

Window Tile 
Choose Window » Tile to open all open windows so that all windows are visible. 

Windows are resized and arranged side-by-side so that all windows are visible and none overlap. 

Window Arrange Icons 
Choose Window » Arrange Icons to arrange all minimized design windows in the P-CAD Schematic 
window. This command positions these icons so that they are evenly spaced and don’t overlap. 

To minimize a window, click the  button. When you do, the window becomes minimized, as 
shown in the following illustration: 

To restore a minimized window to the maximum window size, double-click the window. 
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Window 1,2,  
The bottom of the Window menu lists all open windows. Select the name of the window you want 
to make active from the Window menu. Designs appear on the Windows menu in the order that 
you opened them. 

If there are more than nine windows opened, the option More Windows appears. Select it to view 
additional windows. 
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CHAPTER 24 

Help Commands 

P-CAD Schematic Help Topics 
Choose this command to open the P-CAD Schematic Help file. 

How to Use Help 
Choose this command to connect to the Windows Help file, which shows you how to use the 
online Help system. 

Series II Commands 
Choose this command to view a list that maps the Tango Schematic Series II commands to its 
equivalent P-CAD commands and features. 

About P-CAD Schematic 
Choose this command to open a dialog box that contains information about the P-CAD Schematic 
program, such as the product license number, version number, release date, memory used, and 
available memory. 
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APPENDIX A 

Keyboard Reference 

This appendix is a reference of commands and functions accessed through P-CAD shortcut keys.  

Standard Windows key combinations are functional for all of the menu commands; use the normal 
combination ALT, X, Y where X equals the underscored menu character, and Y equals the 
underscored command character. 

You can use the Options Preference dialog to change shortcut keys for commands and macros. For 
details, see Options Preferences (page 301). 

 

Schematic Keyboard Reference 
 

Press this key combination To perform this action 

ALT+F4 (File Exit) 

A shortcut for the File » Exit command. Choose this command to quit 
the P-CAD Schematic program. If any open design has been modified 
since the last save, you are prompted whether you want to save the 
changes to the file. The program writes configuration information to 
the Sch.ini file when you exit. For details, see File Exit (page 199). 

ALT + MOUSE CLICK 

For any click-and-drag or drag-and-drop operations, you can hold 
down the ALT key, click the left mouse button, then move or drag the 
object wherever you want without having to keep the mouse button 
depressed. Without the ALT key, you would normally have to click 
and hold the button down while you are dragging. 

ARROW KEYS 
Press an arrow key to move the cursor to the next grid point. Press 
CTRL+arrow to move the cursor 10 grid points. This is useful to pan 
the window. 
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CTRL+MOUSE CLICK 

You can copy-and-drag an object by selecting the object, holding 
down CTRL and clicking the left mouse button in the selected object 
region, and dragging a copy of the object to a location and releasing 
to paste it. 

CTRL+C (Edit Copy) A shortcut for the Edit » Copy command. For details, see Edit Copy 
(page 203). 

CTRL+N (File New) 
A shortcut for File » New. This command opens a new, untitled 
design window in the workspace. For details, see Using the File 
Commands, (page169). 

CTRL+O (File Open) 
A shortcut for File » Open. When you choose this command, the File 
Open dialog appears, where you can choose a design file to open. 
For details, see File Open (page 169).  

CTRL+P (File Print) 
A shortcut for File » Print. When you choose this command, the File 
Print dialog appears, where you can print sheets from your design 
and set options for your output. For details, see File Print (page 172). 

CTRL+S (File Save) 

A shortcut for File » Save. Choose this command to save changes to 
the current, active design without closing it. For details, see File Save 
(page 170). To save the design to a different file, choose File » Save 
As. For details, see File Save As (page 171).  

CTRL+V (Edit Paste) A shortcut for the Edit » Paste command. For details, see Edit Paste 
(page 204) 

CTRL+X (Edit Cut) A shortcut for the Edit » Cut command. For details, see Edit Cut (page 
203). 

CTRL+Z (Edit Undo) 

A shortcut for Edit » Undo, which reverses a completed action. If you 
have not completed your action (e.g., you are in Place Line mode and 
have not finished a series of segments), Undo will not reverse the 
action. Use the BACKSPACE key to unwind the unfinished actions 
when you are in a placement mode. For details, see Edit Undo (page 
201). 

CTRL+F4 Closes the active window. 

CTRL+F6 and CTRL+TAB Switches focus to the next open window. Use CTRL+SHIFT+F6 to 
switch focus to the previous window. 

SHIFT+F4 (Window Tile) 
A shortcut for the Windows » Tile command. Windows are resized 
and arranged side-by-side so that all windows are visible and none 
overlap. For details, see Window Tile (page 373).  



Schematic Keyboard Reference Appendix A: Keyboard Reference 

P-CAD Schematic User’s Guide 379 

SHIFT+F5 (Window Cascade) 

A shortcut for the Windows » Cascade command. All windows 
overlap, starting in the upper-left corner of your Workspace. You can 
see each window's title, making it easy to switch between windows. 
For details, see Window Cascade (page 373).  

DEL (Edit Delete) A shortcut for the Edit » Delete command, which deletes all selected 
objects. For details, see Edit Delete (page 234). 

F1 (Help) 
Press the F1 key to display context-sensitive help. If you put focus on 
a command or dialog (by mouse or keyboard) and press F1, the Help 
window appears containing information specific to the focus item. 

PAGE DOWN Scrolls one page down in the workspace. CTRL+PAGE DOWN scrolls 
one page right. 

PAGE UP Scrolls one page up in the workspace. CTRL+PAGE UP scrolls one 
page left. 

SPACEBAR 

The SPACEBAR can be used in place of the left mouse button; but the 
action is different. To simulate a typical click-and-release of the 
mouse button, you need to press and release the SPACEBAR twice. 
Therefore, to simulate the click-and-hold mouse action, you press 
and release the SPACEBAR once. 

As the left mouse button is used in such a variety of ways throughout 
the P-CAD program, this SPACEBAR keystroke can become a regular 
part of your work. 

BACKSPACE (Unwind) 
Used as unwind command while placing objects with multiple seg-
ments (e.g., lines, polygons). Each BACKSPACE stroke unwinds the 
previously placed segment. 

ESC (Escape) 

Terminates placement of objects with multiple segments; it also can-
cels a redraw in progress. It is often equivalent to the right mouse 
button. ESC also exits from dialogs (equaling the Close or Cancel 
button). 

+ PLUS KEY (Zoom In) 

Press the + key as a shortcut for choosing the View » Zoom In com-
mand. The plus key causes a zoom in to occur at the cursor location. 
The plus key does not change the cursor to a zoom cursor (as do the 
zoom commands from the View menu). 

- MINUS KEY (Zoom Out) 

Press the - key as a shortcut for choosing the View » Zoom Out com-
mand. The keypad minus key also works. The minus key causes a 
zoom out to occur at the cursor location. The minus key does not 
change the cursor to a zoom cursor (as do the zoom commands from 
the View menu). For details, see View Zoom Out (page 252). 

A KEY (Grid Toggle) Press the A key to switch between absolute and relative grid settings. 
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C KEY (View Center) 

A shortcut for the View » Center command. This command allows 
you to center your cursor location. Place the cursor in the area of 
your design that you want centered and press C. For details, see View 
Center (page 252). 

D and SHIFT+D (Change 
Reference Designators) 

Press D to switch to the next available reference designator; SHIFT+D 
changes the reference designator to the highest unused preceding 
reference designator.  

E KEY (Play Macro) 

Press E to play back (executes) the temporary macro (named 
_DEFAULT). Temporary macros are recorded by clicking the Macro 
button or by pressing the M key. Each successive temporary macro 
overwrites the previous one. See Macro Record (page 362) for more 
information. 

F KEY (Flip Object) 

Press the F key to flip an object during Place and Select operations. 
Not all objects can be flipped. Refer to Edit Select (page 247) for more 
information about flipping objects. 

The F key also switches between orthogonal mode pairs; see Options 
Configure (page 292) for details on orthogonal modes. 

G KEY (Grid Select) This key scrolls forward through the list of grid settings. Use SHIFT+G 
to scroll back through the list. 

J KEY (Enter Coordinate) Gives focus to the X coordinate box in the status line. From there, 
you can enter new X and Y coordinates. 

L and SHIFT+L Keys (Sheets) L sequences forward through the sheets in the design file of the 
active window; SHIFT+L sequences backward through the sheets. 

M KEY (Record Macro) 
Duplicates the macro toggle button (M button on the Status line) for 
starting/stopping recording of the temporary macro (see E key 
description). See  Macro Record (page 362) for more information. 

O and SHIFT+O Keys 
(Orthogonal Mode) 

O sequences forward through the orthogonal modes during 
placement of wires and lines; SHIFT+O sequences backward 
throughout the modes. Press the F key to switch between orthogonal 
mode pairs. Orthogonal modes are set in the Options Configure 
dialog box. See Options Configure (page 292) for more information. 

P and SHIFT+P (Change 
Reference Designators) 

Press the P key to change the reference designator to the next gate; 
Press SHIFT+P to change the reference designator to the previous 
gate.  

Q KEY (Draft Mode) Press the Q key to switch between draft mode ON and OFF. 

R KEY (Rotate)  
R Rotates objects 90 degrees during Place and Select operations. For 
more information about rotating objects with Place and Select opera-
tions Edit Select (page 247). 
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S KEY (Select) S key (Select) 

U KEY (Undo)  

A shortcut for the Edit » Undo command, which reverses a completed 
action. See Edit Undo (page 201) for more information. For the 
unwind feature, refer to the BACKSPACE key description in this 
section. 

W KEY (Line Width Scroll)  
Scrolls forward through the list of line widths established in the 
design. Use SHIFT+W to scroll back through the list. 

X KEY (Cursor Style)  Press the X key to switch between the three cursor styles: Arrow, 
Small Cross, and Large Cross. 

Z KEY (Zoom Window)  

A shortcut for the View » Zoom Window command. Just press Z and 
then draw the zoom window; a zoom cursor (magnifying glass) 
appears until you draw the zoom window. Whatever you surround 
with the zoom window fills the screen. For details, see View Zoom 
Window (page 252). 
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APPENDIX B 

Translating Tango-Schematic Designs 

This appendix provides information on translating Tango-Schematic designs into P-CAD Schematic. 

If you choose the Archive Library command in Tango-Schematic Version 1.30a or earlier, the Pattern 
Attribute is not included in each part. If you want pattern information saved in your translated 
design, use version 1.40 to archive your parts or add pattern data manually with a text editor.   

Also, verify that all parts have a RefDes, in particular power parts and logos. The Archive Library 
command does not save parts without a RefDes. You need to copy these parts to the archived 
library. 

Translation Process 
Before translating a Tango-Schematic design (using the File » Open command in P-CAD Schematic) 
you should prepare your designs by performing the following steps:   

1. Choose the Post Cleanup command to remove any collinear (overlapping) wire segments.  

2. Choose the Post Compile command and the DRC report to detect existing errors. Errors may 
be fixed in Tango-Schematic before translation or after translation using P-CAD Schematic. 

3. Convert any hierarchical designs into a flat format. All ports and modules should be replaced 
with the necessary schematic information in order to retain all net connectivity between 
sheets. All files of the design must have the same root name, with extensions of .S01, .S02, 
etc. Each file is translated to sheets in your P-CAD Schematic design, with corresponding 
default names Sheet1, Sheet2, etc.  

4. Save your design files in ASCII format. P-CAD Schematic does not accept Tango-Schematic 
designs in binary format.  

After translation you can generate an ERC report in P-CAD Schematic and compare the results to 
your Tango- Schematic report. You can also use the NETCOMP netlist-compare utility to compare 
netlists generated by Tango-Schematic and P-CAD Schematic. This utility compares nets on a node-
by-node basis, disregarding net names since they can be different, and lists all nets not having 
identical matches. These differences are often caused by problems described throughout this 
section.  
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You can fix errors discovered during these tests in Tango-Schematic before translation or after 
translation using P-CAD Schematic. 

The Tango-Schematic libraries associated with the design must be translated prior to opening a 
Tango-Schematic design in P-CAD. Refer to the P-CAD Library User’s Guide for instructions on how 
to do this. After translating the libraries, run the Library Setup command in P-CAD Schematic to 
open all libraries needed for the translation.  

P-CAD Schematic will use the first occurrence of a part found in the open libraries. If a part occurs 
in more than one library, the first open library with the desired part format will be used before any 
other library containing the same part. You may wish to insure that your archived library is first in 
the list of open libraries. 

Considerations 
For a complete and correct translation, the translated Tango-Schematic libraries must contain the 
parts exactly as they exist on your schematic design. If the library part definition is different from 
the part on the design, you must either alter the library part to have the correct definition, or 
replace all instances of the part on the Tango- Schematic design with the part from the library and 
correct any errors caused by the change. Some common differences that become evident after 
translation are: 

• The part in the library does not have the same orientation as the part on the sheet. These parts 
appear rotated on the translated sheet.  

• The part in the library has a reference point, which is different from the reference point of the 
part on the design. These parts appear offset from the correct location. 

• The pin positioning and definition are not the same. If the pins are out of position, having 
differing lengths, or have different pin designators, the translation reflects these differences.  

• The RefDes, type, or value locations for a library part are different from the part on a sheet. This 
can happen when these attributes are moved on the sheet for cosmetic reasons; these parts 
can appear different in P- CAD Schematic, but these differences are only cosmetic and do not 
affect normal processing.  

Design Practices Considered 
Tango-Schematic interprets some ambiguous design practices differently from P-CAD Schematic.  

• Placing a wire so that it crosses over the endpoints of non-connected pins. In Tango-
Schematic, a wire touching pin endpoints without stopping over them is not connected. P-CAD 
includes these pins in the net.  

• Global Hidden Pins made visible on the sheet, and connected pin-to-pin to another part. These 
occurrences are flagged as an error and must be modified to include a wire.  

• Parts that do not have a “Type” flag an error in P-CAD. These parts must be modified to include 
a Type field. 
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• Placing junctions over wires or pins that do not require a junction for connectivity. Tango-
Schematic allows the placement of extraneous junctions. Using P-CAD Schematic, junctions 
are necessary only when an intersection of three or more wires and/or pins need to be 
connected together. 

The default net names given to nets that were not specifically named on your Tango-Schematic 
designs are renamed using P-CAD default net names. These are not necessarily the same as those 
used in Tango- Schematic. When you compare netlists generated by the two products, take these 
different defaults into account. 

If you use wires instead of lines for bus entries in Tango-Schematic, you may get wires that appear 
to short together after translating the design to P-CAD Schematic. This can be changed by replacing 
the wires used for bus entries by lines in Tango-Schematic, or by manually moving the translated 
wires in P-CAD Schematic. 
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APPENDIX C 

P-CAD System Messages 

This appendix documents the messages that you might encounter when importing or exporting a 
PDIF file in P- CAD PCB or P-CAD Schematic. 

Error Messages 
 

Error Message Cause Solution 

A reference designator is 
required in instance <name> 
near line <line number>. 

The reference designator is 
missing. 

Enter the reference designator 
and try again 

Bad PIN_DEF record #<number> 
near line <line number>. Pad 
ignored. 

A syntax error was encoun-
tered. A PIN_DEF entry is mal-
formed. 

Check the PDIF file at the des-
ignated line number to determine 
the cause. Then consult your PDIF 
manual to correct the syntax. 

Component instance <name> 
(<ref des>) pin <pin des> 
references an unknown net 
<name> near line <line 
number>. 

The net does not exist. Either create it in Master Designer 
or reset the pin’s net name. 

Data in this design extends 
beyond 60 square inches. Load 
aborted. 

P-CAD PCB allows a maximum 
of 60 square inches for a 
design. This design is too big. 

Either make it smaller or break up 
the design. 

Device expected on line <line 
number> of <file name>. 

Each entry in a cross-reference 
file has a device, but one was 
not found. 

Add the device name at the 
specified line number. 
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Error Message Cause Solution 

Duplicate pin designator <pin 
des> in instance <name> near 
line <line number>. Pin ignored. 

P-CAD PCB and Schematic do 
not allow duplicate pin 
designators. The duplicate 
pins will not show up in the 
resulting component. 

Edit the PDIF file to change the pin 
designators. 

Duplicate reference designator 
<reference designator> in 
instance <name> near line <line 
number>. Instance ignored. 

A duplicate reference 
designator was found. P-CAD 
PCB and Schematic do not 
support duplicate reference 
designators. This instance was 
ignored. 

Either change the reference 
designator in Master Designer or 
edit the PDIF file and change the 
Rd statement. 

Equal sign expected on line <line 
number> of <file name>. 

A syntax error was 
encountered. An entry in a 
cross-reference file may have 
the power and ground pins 
listed. 

Enter an equal sign. The for mat is 
(<pin des> = <net name>,...). The 
system logs this error if it 
encounters a pin designator, 
which is not followed by an equal 
sign. 

File revision number is 
unrecognized. 

The PDIF version number was 
not recognized. 

Use a PDIF file from Master 
Designer version 6.0 or later. 

Gate number expected on line 
<line number> of <file name>. 

A syntax error was 
encountered. Each entry in a 
cross-reference file has a gate 
number, but one was not 
found. 

Check the PDIF file at the 
designated line number to deter 
mine the cause. Then consult your 
PDIF manual to correct the syntax. 

Instance <name> referenced an 
undefined component 
(COMP_DEF=<name>) near line 
<line number>. 

A syntax error was 
encountered. An instance 
references the name of a 
COMP_DEF that was not 
defined prior to the instance. 

Check the PDIF file at the 
designated line number to 
determine the cause. Then consult 
your PDIF manual to correct the 
syntax. 

Keyword expected on line <line 
number>. 

A syntax error was 
encountered. 

Check the PDIF file at the 
designated line number to 
determine cause. Then consult 
your PDIF manual to correct the 
syntax. 

Left paren expected on line <line 
number> of <file name>. 

A syntax error was 
encountered. 

Correct the syntax. The format is 
(<pin des> = <net name>,...). The 
system logs this error if it 
encounters a net name, which is 
not followed by a left paren or 
comma. 
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Error Message Cause Solution 

Load failed near line <line 
number>. 

A syntax error was 
encountered. 

Check the PDIF file at the 
designated line number to deter 
mine the cause. Then consult your 
PDIF manual to correct the syntax. 

Net name expected on line <line 
number> of <file name>. 

A syntax error was 
encountered. 

Correct the syntax. The format is 
(<pin des> = <net name>,...). The 
system logs this error if it 
encounters an equal sign, which is 
not followed by a net name. 

No {Lystr...} section found. A syntax error was 
encountered. 

Check the PDIF file at the 
designated line number to deter 
mine cause. 

No pad stacks defined near line 
<line number>. 

PDIF PCBs require an attached 
PAD_STACK record to load 
properly into P-CAD PCB. 

Edit the PDIF file at the designated 
line number to include the name 
of the attached pad stack. 

Not enough memory. This means the system could 
not allocate enough memory 
to do its work. 

Close some applications and try 
again. 

Pad stack <name> has shape 
<pdif object> 
(<number>X<number>) that is 
smaller than both the pad hole 
size (<number>) and the via hole 
size (<number>) near line <line 
number>. Hole size set to 0. 

A pad type (Pt) is trying to set 
too big a hole. The hole is 
assigned either through the 
tool table file or the pad/via 
default sizes specified in the 
PCB.INI file. 

Either change the default pad/ via 
hole sizes in the PCB.INI file, or 
change the specified tool table.  

Part file name expected on line 
<line number> of <file name>. 

Each entry in a cross-reference 
file has a part file name, but 
one was not found. 

Check the PDIF file at the 
designated line number to 
determine the cause. 

P-CAD attribute near (x, y) has 
no value. 

This message means that the 
system found a Master 
Designer attribute that does 
not have a value. 

N/A 

PDIF item <pdif object> is not 
supported in nets. 

Some PDIF objects are not 
supported in P-CAD PCB or 
Schematic nets. 

Remove the object and try again. 

Pin <pin des> of part <part 
number> of component <name> 
could not be added near line 
<line number>. 

A memory or resource limit 
has been reached. 

N/A 
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Error Message Cause Solution 

Pin number expected on line 
<line number> of <file name>. 

A syntax error was 
encountered. An entry in a 
cross-reference file may have 
the power and ground pins 
listed. 

Correct the syntax. The format is 
(<pin des> = <net name>,...). The 
system logs this error if it 
encounters a equal sign, which is 
not preceded by a pin number. 

Power or ground pin <pin des> 
for component <name> does not 
have a net name or a pin name. 

A power pin was found that 
does not have a net name or 
does not have a pin name. 

Check the PDIF file at the 
designated line number to deter 
mine the cause. 

Right paren expected on line 
<line number> of <file name>. 

An entry in a cross-reference 
file may have the power and 
ground pins listed. The format 
is (<pin des> = <net 
name>,...).The system logs this 
error if it encounters a equal 
sign, which is not preceded by 
a pin number. 

Check the PDIF file at the 
designated line number to deter 
mine the cause. 

Symbol file name expected on 
line <line number> of <file 
name>. 

A syntax error was 
encountered. Each entry in a 
cross-reference file has a 
symbol file name, but one was 
not found. 

Check the PDIF file at the 
designated line number to deter 
mine the cause. 

Too many power and ground 
pins for error file. 

If a component is 
heterogeneous, the system 
writes the cross-reference file 
lines to the error file. The 
cross-reference file line 
consists of the number of 
gates, the device, the part file 
name, the power and ground 
pins, and the symbol file 
name. There is a limit to how 
many power and ground pins 
can be written to the error file. 
This message means that limit 
was exceeded 

Edit the cross-reference file and 
add any pins that are missing. 
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Error Message Cause Solution 

Too many symbols on this sheet 
to create P-CAD symbol name. 

P-CAD symbol instances 
require a name. This name’s 
format consists of NCssssxxxx; 
where ssss is sheet number 
and xxxx is a symbol number. 
This only allows for 9999 
symbols on a sheet. If the 
system detects that there are 
more than 9999 symbols on a 
sheet, which require a symbol 
name, it logs this error. 

Create a new sheet and move 
some of the parts onto it. 

Unable to open file <file name>. This could mean that the file 
does not exist, or that the 
system is trying to open for 
writing a read-only file. 

Make sure the specified file exists 
and that it is not a read- only file. 

Unable to rename file <file 
name> to <file name>. 

This could mean that the file 
the system is trying to rename 
does not exist, or that a file 
already exists that it is trying 
to rename it to. 

Make sure the specified file exists 
and that it is not a read- only file. 

Unable to translate text object 
near (x, y). 

The system was unable to get 
the data from a text object so 
that it could be translated. 

N/A 

Unable to translate text style for 
text object near (x, y). 

The system found a text object 
that is using an 
unrecognizable text style. 

N/A 

Unrecognized CN format in 
instance <name> near line <line 
number>. 

A syntax error was 
encountered. 

Make sure the CN syntax is 
correct. The CN format can be of 2 
styles: {CN <net name> ...}  Or 
{CN <pin name> <net name> ...}. 

Unrecognized justification style. You are using a justification 
style that is currently 
unrecognizable to the system. 

Use a justification style that the 
system recognizes. 
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Warning Messages 
 

Warning Message Explanation 

Attribute key too long near 
(x, y). 

PDIF format allows only 23 characters for an attribute key. The system 
found a key with more than 23 characters. 

Attribute object near (x, y) 
has no value. 

The system found an attribute with no value. PDIF format requires a value 
so this attribute was ignored by the system. 

Attribute value too long 
near (x, y). 

PDIF format allows only 255 characters for an attribute value. The system 
found an attribute value with more than 255 characters. The attribute 
value is translated truncated to 255 characters. 

Cannot open file <file 
name>.  

This could mean that the file does not exist, or that the system is trying to 
open for writing a read only file. 

COMP_DEF <name> has a 
package pin number 
(<number>) that is out of 
range near line <line 
number>. 

The pin number specified in the SPKG Sp record does not map to any pad 
in the PIN_DEF record. Either the pin des number is greater than the 
number of pads or a pad with the same name (number) could not be 
found. 

COMP_DEF <name> has no 
SPKG section near line 
<line number>. Pin names 
will start at '1'. 

The COMP_DEF has no pin to pad mapping (packaging) information. The 
components pins created will have pin designators that match the pad's 
position in the PIN_DEF array. The component is most likely a PCB only 
component. 

COMP_DEF <name> 
references unknown pad 
stack <number>. Style 
<name> used instead. 

A pad references a padstack number (Pt) that is not defined in the 
PAD_STACK record. The PCB “(Default)” padstack will be used instead. 

Component <name> has 
had its name changed to 
<name>. This is required to 
maintain uniqueness in 
P-CAD. 

A component’s type in Master Designer is used as the file name for the 
symbol data. This limits the component’s type to 8 characters. In P-CAD 
PCB and Schematic, the component’s type can be 17 characters. This 
means that the type is truncated to 8 characters and slightly modified to 
make it unique if there is more than one component that has that 8 
character prefix.  

Component <name> is 
heterogeneous and will be 
written as <number> 
separate COMP_DEFs. 
Cross reference file data 
follows: 

Master Designer does not allow heterogeneous components. During 
translation the heterogeneous components are separated into 
homogeneous components. The cross-reference file data is included in 
the error file for your convenience. 
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Warning Message Explanation 

Component <Ref Des>, 
type <type> was given a 
PRT attribute of <PRT 
attribute value> which may 
cause packaging errors in P- 
CAD. 

The PRT attribute value is the file name for the PCB part data. The value is 
created by combining the type with “.prt”. In P-CAD PCB and Schematic, 
the type can be longer than 8 characters. 

If the type is longer than 8 character, this is an illegal file name. You will 
need to fix this attribute in Master Designer before you can package the 
schematic. 

Copper Pour not allowed in 
pattern <name> (<ref des>) 
near line <line number>. 
Pour demoted to polygon. 

PCB does not support copper pours in patterns. The pour was converted 
to a polygon, which is supported. 

 

Could not create pad/via 
style for pad <number> 
near line <line number>. 

A memory or resource limit has been reached. Reduce the number of 
padstack in the design or simplify their construction. 

Cross reference file missing 
entry for <name>. Unable 
to attach symbol name for 
multi- part component. 

The attached symbol name could not be added to the component 
because there was no cross-reference file entry for the part. 

 

Heterogeneous component 
<name> is missing gates 
<part number>. Parts <ref 
des> cannot be placed. 
Place the missing gates as 
spares and reload. 

Heterogeneous components are found in the cross-reference file but the 
PDIF data is not found in the PDIF file. If you place the missing gates in 
Master Designer, re-create the PDIF file, the PDIF data will be included 
and a complete heterogeneous component can be created in Schematic. 

Homogeneous part 
<name> has non-constant 
gate equivalencies. 

Master Designer does not store gate equivalence. The system is warning 
you that it found a homogeneous part with non- constant gate 
equivalencies.  

Iat value too long at line 
<line number>. 

PDIF format allows only 255 characters for an Iat value. The system found 
an Iat value with more than 255 characters. The attribute value is 
translated truncated to 255 characters. 

Instance <name> does not 
specify a location, (0,0) 
assumed, near line <line 
number>. 

The instance Pl record is missing. 

 

Instance <name> has an 
illegal IPT record near line 
<line number>. 

The number of entries in the instance Ipt record does not match the 
number of entries in the COMP_DEF PIN_DEF record. 
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Warning Message Explanation 

Instance <name> 
referenced a package 
number (<part number>) 
that does not exist in 
COMP_DEF <name> near 
line <line number>. 

An instance of a heterogeneous component references a part number 
that is not defined for the number of parts in the component. The 
heterogeneous information in the cross-reference file may be incorrect. 

Layer name <name> has 
been truncated to <name>. 

The layer name is used as the PDIF file name. File names are limited to 8 
characters. The system truncates the layer name to 8 characters and if 
necessary, slightly modifies it to make it unique if there are more than 
one layer that have the same first 8 characters. 

Missing pad stack name for 
pad/ via <number> near 
line <line number>. 

A syntax error was encountered. The padstack name is missing from the 
PAD_STACK record. 

Name <name> truncated to 
<number> characters near 
line <line number>. 

The object’s name was too long and truncated so that it would be a valid 
PCB or Schematic name. 

Net <name> attribute lost. 
<key> = <value>. 

Master Designer does not have net attributes. When the system warns 
you when it detects a net attribute. 

<number> pin(s) were 
created for a <number> pin 
symbol 
(COMP_DEF=<name>, 
I=<name>) near line <line 
number>. 

The number of entries in the PIN_DEF record does not match the number 
of Sp records in the SPKG record. 

 

Object near line <line 
number> failed to load. 

A syntax error was encountered. Check the PDIF file at the designated 
line number to determine cause. 

Pad stack <name> does not 
have consistent enough 
shapes to set the 
predefined '(Signal)' layer 
near line <line number>. 
Pad/via style layer '(Signal)' 
set to 0. 

The padstack shape defined for the Top layer does not match the shape 
defined for the Bottom layer. 

The padstack shapes defined for internal signal layers are not all the 
same. 

 

PDIF item <pdif object> is 
not supported in nets. 

Some PDIF objects are not supported in PCB or Schematic nets. It could 
be a DRC error indicator. 

PDIF item <pdif object> is 
not supported in pad 
stacks. 

Some PDIF objects are not supported in PCB pad stacks. These include 
polygons, text, flashes and lines. 
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Warning Message Explanation 

PID too long at line <line 
number>. Truncated. 

Master Designer’s PID is equivalent to PCB’s type attribute. The PID is 
limited to 15 characters. If PCB’s type attribute is longer than 15 
characters, it is truncated to 15 characters. 

Power and ground attribute 
is too long for symbol 
<name>. 

If you get this warning and are not using Master Designer Version 8.0 
software, switch to Version 8.0 if possible. Version 8.0 uses multiple 
PWGDi attributes to handle case. If you are using Version 8.0 and still get 
this message the PWGDi attribute is truncated. If you cannot use Version 
8.0 and are getting this message, the PWGD attribute is truncated. 

Power pin <pin des> of 
component <name> could 
not be added near line 
<line number>. Probably 
duplicate. 

A duplicate power pin was detected in the component. Check the cross 
reference file or the PWGD(i) attribute(s) and try again. 

Rotation rounded to 
<angle> at line <line 
number>. 

Master Designer Schematic can only be rotated to 0, 90, 180, 270. If a 
rotation other than those values is detected, the object is rotated to the 
nearest allowable angle. 

Symbol <name> already 
exists in table on line <line 
number> of <file name>. 

A duplicated symbol file name was found in the cross-reference file. First 
one found is used. Others are discarded. 

Text height is less than 2 at 
line <line number>. 

P-CAD PCB and Schematic’s text height is used as the text size for PDIF 
translation. Master Designer’s text size cannot be less than 2. If a text 
height is found to be less than 2, 2 is used. 

Text object near (x, y) has 
no string, object ignored. 

An empty text object was found and ignored. 

Text too long near (x, y). Text is limited to 255 characters. Text is truncated to 255. 

The number of components 
pins created for <name> 
does not match the number 
of PIN_DEF entries near line 
<line number>. Power pins 
might be missing. 

The number of P statements in the COMP_DEF’s PIN_DEF section 
determines the number of pins. 

 

The number of pins in 
section <part number> 
(COMP_DEF=<name>) is 
not equal to the number of 
pins defined (PIN_DEF) 
near line <line number>. 

A PKG part section does not have the same number of entries (pins) as 
the PIN_DEF record. 
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Warning Message Explanation 

Translating TangoPRO 
polygon object near (x, y) 
as P-CAD lines. 

Master Designer Schematic does not have a filled polygon object. If the 
system detects a polygon object is translates it as lines for Master 
Designer. 

Unrecognized keyword  
<key> near line <line 
number>. Keyword 
ignored. 

A syntax error was encountered. Check the PDIF file at the designated 
line number to determine cause.  

Via references unknown 
pad stack <number>. Style 
<name> used instead. 

The padstack number referenced by a via does not exist. The via style 
used will be <name>, probably '(Default)'. 
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APPENDIX D 

The Tango Netlist Format 

A Tango netlist file is an ASCII text file, with a carriage return and a line feed at the end of every 
line. The netlist is divided into two sections:  the component section and the net section. 

The Component Section 
This section describes each component in the netlist, such as the component type, reference 
designator, cost, ordering code, etc. 

There can be any number of component descriptions in the component section. Each component 
description is contained within square brackets [ ], with each square bracket being the first and 
only character on a line. 

The component description has the following format: 

[ 

refdes 

package 

type 

(blank line) 

(blank line) 

] 

The refdes is the reference designator, which can be up to 16 alphanumeric characters in length. All 
letters in the reference designator must be upper-case. (For example: U1, R3, XTAL2.) 

The package is the component package, which must be the name of a PCB library pattern. The 
package can be up to 16 alphanumeric characters in length. All letters in the package must be 
upper-case. (For example: DIP40, RES400, DB9.) 

The type is the component type. The type can be up to 16 alphanumeric characters in length. (For 
example:  Z80ACPU, 47K, 4.00 MHz, DB9.) 
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The following example is a netlist description for Z80ACPU: 

[ 

U5 

DIP40 

Z80ACPU 

] 

The Net Section 
This section contains one or more net definitions. A net is a group of nodes to be connected 
together. A node consists of a component label, a delimiter and a pin designator.  

There can be any number of nets in the net section. Each net is contained within parentheses ( ), 
with each parenthesis being the first and only character on a line.  

Each net in the net section has the following format: 

( 

net 

node 

node 

. 

. 

. 

node 

) 

The net is the net name, which can be up to 16 alphanumeric characters. You can use upper-case 
and lower-case characters. Since case is not significant when comparing net names, P-CAD PCB 
forces all characters entered to upper-case. Therefore, do not use case alone to distinguish net 
names. Do not use parentheses or square brackets for the first character in a net name.  

The lines after the net name contain the nodes in the net, with one node per line. Each node 
consists of: 

• A component name (up to 16 alphanumeric characters long) 

• A single-character delimiter (a hyphen or a comma) 

• A pin designator (up to 16 alphanumeric characters long) 

Each node is scanned from left to right until the first occurrence of a delimiter  (a hyphen or a 
comma) is found. Everything to the left of the delimiter is considered the component name; 
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everything to the right is considered the pin designator. Do not use any of the delimiter characters 
in your component names, since this will cause the program  to incorrectly read the netlist.  

A node must appear only once in the netlist, since by definition a node can only belong to one net. 
A node appearing in more than one net would imply that those nets should be joined into one net, 
since they have the node in common. If a node appears in more than one net, P-CAD PCB issues an 
error message and halts the netlist load. 

A sample net section is shown as follows: 

( 

A0 

U1-10 

U2-10 

U3-10 

U4-10 

U5-30 

U6-34 

) 

( 

CPUCLK 

R5-2 

U6-20 

U9-6 

) 

( 

U10.1_J2.2 

J2-2 

U10-1 

) 
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selecting highlighted objects................131 
unhighlighting parts ...............................129 
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net attributes ..............................................95 
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properties....................................................52 
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tables ..........................................................117 
Text properties.........................................227 

electrical pin type .......................................217 
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electrical rule checking .............................334 
Enabling 

DDE Hotlinks ............................................127 
Engineering Change Order (ECO)..........338 
ERC 

annotate errors ........................................134 
Bus/Net Errors ..........................................134 
clear all overrides ....................................336 
Component Errors...................................134 
configuration............................................133 
Hierarchy Errors.......................................336 
Net Connectivity Errors..........................335 
No Node Nets...................................134, 335 
setting up checks.....................................133 
severity levels ...........................................336 
Single Node Nets.............................134, 335 
summarize ignored checks ...................135 
summarize ignored errors.....................336 
summarize overridden errors...............336 
Unconnected Pins ...................................335 
Unconnected Wires........................134, 335 

ERC Error, View command........................232 
ERC errors 

controlling display of..............................136 
finding........................................................135 
fixing and deleting ..................................137 
overriding..................................................137 

ERC, Utils command...................................334 
error indicators 

overriding..................................................137 
Existing module 

reusing .......................................................348 
Exit, File command......................................199 
Explode Part, Edit command.....................237 

Export ECOs, Utils command .................. 340 
exporting 

Note Table notes..................................... 112 
Revision Note Table ............................... 115 

Extent, View command ............................. 251 

-F- 
features..............................................................1 
Field, Place command ............................... 280 
fields 

code, defined........................................... 103 
Field Properties ....................................... 230 
field sets, defined ................................... 106 
fields defined........................................... 103 
result, defined ......................................... 103 
rotating/flipping ...................................... 281 
user-defined fields ................................. 183 
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Open...................................................... 6, 169 
PDIF In....................................................... 197 
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reports........................................................178 

Loading PDIF files .......................................197 
local net ........................................................108 
location, jumping to...................................253 

-M- 
Macro Commands......................................361 

Delete.........................................................364 
Record..................................................12, 362 
Rename ......................................................364 
Run..............................................................365 
Setup ..........................................................361 

macros 
edit events.................................................371 
editing ........................................................367 
executing...................................................363 
features ......................................................366 
file syntax...........................................367, 371 
keyboard codes .......................................368 
keyboard events ......................................368 
mouse events ...........................................367 
recording tool ..........................................362 
running ..............................................365, 366 
special events ...........................................371 
status line indicators...............................366 
temporary..................................................363 
temporary macro name..........................363 
using effectively.......................................365 

Manual, Rewire command ....................... 285 
matrix, defined...............................................92 
maximize button ...........................................13 
Measure, Edit command........................... 246 
menu bar 

defined ...........................................................6 
menu commands ............................................6 
merging 

net attributes............................................ 207 
metric units.................................................. 293 
MillimeterPrecision setting...................... 293 
minimize button............................................13 
modes 

changing absolute and relative grid ... 297 
pairs, defined ..............................................88 

modifying...............................see also editing 
arcs ............................................................. 274 
field results............................................... 105 
objects ..........................................................50 
reports ....................................................... 119 
tables ......................................................... 117 

Module Wizard 
creating a link .......................................... 346 
creating a module................................... 346 
introduction ............................................. 345 
reusing an existing module .................. 348 

Module Wizard, Utils command ............ 345 
Mouse tab.................................................... 302 
Mouse-Click Behavior 

double-click displays properties ............94 
Move By RefDes, Edit command............. 209 
moving 

a toolbar.........................................................7 
an object ......................................................84 
items in a block ....................................... 288 
objects ..........................................................50 
objects during placement........................84 
parts by RefDes ................................. 84, 209 
ports........................................................... 268 
rotating and flipping objects...................86 

multiple selection, defined.........................79 
Multisheet designs 

loading .........................................................21 

-N- 
net 

attributes 
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merge when pasting ............................207 
copy ..............................................................91 
creating named net classes ...................310 
Delete command .....................................246 
deleting objects from .............................235 
highlight.....................................................245 
increment ..................................................294 
increment value, defined.........................17 
local vs. global ..........................................108 
managing net connections; .....................95 
netlist format 

Tango.......................................................397 
netlist, generating..................... 70, 124, 342 
renaming............................................208, 244 
Select command ......................................246 
unhighlight................................................245 

net attribute selection..................................57 
Net Classes, Options command..............309 
Net Index Tables .........................................111 

placing........................................................111 
Nets, Edit command ...................................240 
New, File command....................................169 
New, Library command .............................319 
New, Window command ..........................373 
Note Tables ..................................................112 

adding notes .............................................112 
exporting notes........................................112 
importing notes .......................................112 
placing........................................................113 

numbering pads ..........................................329 

-O- 
objects 

nets 
deleting.....................................................94 

pasting........................................................204 
properties ....................................................94 
selecting preferences ...............................81 

Open, File command .................................169 
opening................................. see also loading 

ASCII Files ...................................................22 
menus.............................................................6 
multisheet designs ....................................21 
Schematic Files (*.sch)..............................21 
Tango Series II Files ..................................21 

Options Commands 
Block Selection.........................................287 

Configure.................................................. 292 
Current Line ............................................. 313 
Current Wire ............................................ 312 
Design Rules ............................................ 303 
Display....................................................... 297 
Grids........................................................... 295 
Net Classes ............................................... 309 
Preferences............................................... 301 
Sheets ........................................................ 311 
Text Style................................................... 314 

Options Design Rules 
Class to Class tab..................................... 308 
Design tab................................................. 303 
Net tab ....................................................... 307 

Orthogonal Modes .................................... 273 
45/90 Line-Line Mode ....................... 88, 294 
90/90 Line-Line Mode ....................... 88, 294 
enabling .................................................... 294 
enabling ortho modes ............................. 88 
mode pairs, defined ................................. 88 
ortho modes,defined ............................... 88 

output 
netlist ......................................................... 124 

outside block 
defined ........................................................ 83 

overridden errors....................................... 336 
Overriding 

error indicators........................................ 137 

-P- 
pad number ................................................. 217 
panning 

screen, adjusting ..................................... 295 
setting the autopan % display................ 17 

part 
exploding.................................................. 237 
highlight an attached net ...................... 240 
highlight/unhighlight ............................. 240 
jump to .............................................. 239, 240 
list box ....................................................... 239 
number...................................................... 217 
placing ......................................................... 32 
power components ................................ 262 
properties ................................................. 239 
selection criteria...................................... 290 
splitting a net ........................................... 262 

Part Properties............................................. 212 
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Attributes Pin tab.....................................218 
Component Pin tab.................................216 
Component tab........................................215 
Symbol Pins tab........................................214 
Symbol tab ................................................213 
Text Styles button....................................214 

Part, Place command..................................259 
Parts, Edit command...................................239 
Paste, Edit command..................................204 
pasting 

behavior.....................................................204 
circuits........................................................206 
circuits from a file....................................208 
Clipboard objects......................................93 
from a file ............................................93, 205 
from clipboard .........................................205 

P-CAD Binary Files 
loading multisheet designs .....................21 
opening .SCH files.....................................21 

P-CAD CFG Files (*.cfg) ...............................21 
P-CAD Library Executive, Utils command
........................................................................352 
P-CAD Pattern Editor, Utils command ...352 
P-CAD PCB, Utils command.....................351 
P-CAD Schematic window, defined ...........5 
P-CAD Symbol Editor, Utils command...352 
P-CAD system messages ...........................387 
PDIF files.......................................................197 
PDIF In, File command ..............................197 
PDIF Out, File command...........................198 
pin 

designator .................................................217 
modifying text .......................................223 
moving....................................................224 

display ........................................................223 
display characteristics ............................224 
equivalence...............................................217 
name...........................................................217 

modifying text .......................................223 
moving....................................................224 

pin des, renumbering default...............332 
renumbering.............................................331 
selecting length .......................................223 
selection criteria ......................................290 

Pin, Place command ...................................269 
PinEq..............................................................217 
pins 

display characteristics............................ 271 
Place Attributes dialog .............................. 243 
Place Commands........................................ 259 

Arc 273 
Attribute.................................................... 279 
Bus.............................................................. 265 
Field ........................................................... 280 
IEEE Symbol .............................................. 282 
Line....................................................... 78, 272 
Part ............................................................. 259 
Pin 78, 269 
Polygon ..................................................... 274 
Port....................................................... 78, 267 
Ref Point.................................................... 275 
Text............................................................. 275 
Wire ..................................................... 78, 263 

Place Table, DocTool command ............. 357 
Placement Toolbar..........................................8 
Placement Toolbar, View command...... 256 
placing ................................... see also pasting 

arcs ............................................................. 273 
attributes................................................... 279 
buses.............................................................40 
custom fields............................................ 105 
fields .......................................................... 280 
IEEE symbols............................................. 282 
inline ports ............................................... 268 
lines............................................................ 272 
Net Index Tables ..................................... 111 
Note Tables .............................................. 113 
objects ..........................................................78 
pins............................................................. 269 
polygons ................................................... 274 
ports..................................................... 41, 267 
Power Table.............................................. 114 
reference points...................................... 275 
Revision Note Table ............................... 116 
Spare Gate Table..................................... 117 
text ....................................................... 45, 275 
wires..............................................................36 

play macro key............................................ 380 
polygon 

altering the shape ................................... 275 
complex .................................................... 275 
draft mode................................................ 275 
query/modify ........................................... 226 
resizing a polygon .....................................89 
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rotating/flipping .......................................275 
Polygon, Place command ..........................274 
port 

deleting ......................................................269 
moving .......................................................268 
placing inline ............................................268 
renaming....................................................269 
selection criteria ......................................291 

Port Properties 
Net tab........................................................221 

Port, Place command .................................267 
Power Table..................................................113 

placing........................................................114 
Preferences, Options command .............301 
preview ECO file .........................................340 
previous view...............................................251 
print 

colors..................................................172, 174 
colors setup ..............................................142 
Image Options, defined .........................140 
Image Scale, defined...............................140 
print job setup..........................................140 
Print Region, defined ..............................140 
scaling to fit page.....................................145 
selecting a printer....................................139 
set up..........................................................173 
setting up...................................................139 

Print Setup, File command........................177 
Print, File command....................................172 
prompt line, defined ....................................11 
Prompt Line, View command...................256 
properties 

arc 225 
bus...............................................................220 
double clicking to access.......................212 
field .............................................................230 
line ..............................................................224 
part..............................................................212 
pin 222 
polygon......................................................226 
pop-up menu............................................211 
port .............................................................221 
replacing component types ..................233 
text ..............................................................226 
View ERC Errors........................................232 
wire .............................................................218 

Properties dialog 

opening the dialog.................................... 94 
Properties, Edit command ........................ 211 

-R- 
Record ECOs, Utils command................. 338 
Record, Macro command......................... 362 
recording a macro.............................. 362, 363 
Redo, Edit command.................................. 202 
redraw, interrupting .................................. 251 
Redraw, View command........................... 251 
Ref Point, Place command........................ 275 
reference 

launching a link ....................................... 160 
locations.................................................... 229 

reference designators ............................... 217 
renaming................................................... 207 
renumbering ...................................... 54, 329 

relative grid toggle ..................................... 296 
removing ......................................see deleting 
Rename Net, Utils command................... 343 
Rename, Library command ...................... 324 
Rename, Macro command ....................... 364 
renaming 

a net.................................................... 244, 343 
while pasting......................................... 208 

ports ........................................................... 269 
reference designators ............................ 207 
sheet names ............................................... 20 

renumber 
pads............................................................ 329 
reference designators ............................ 329 

Renumber, Utils command ...................... 329 
reordering 

sheets in a design...................................... 19 
replacing 

component types .................................... 233 
report 

Attributes .................................................. 118 
Bill of Materials........................................ 119 
custom 

adding..................................................... 120 
formats ................................................... 179 
selections............................................... 181 
sorting .................................................... 182 

extensions................................................. 178 
format options ......................................... 121 
generating......................................... 119, 123 
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Global Nets ...............................................119 
Last Used RefDes.....................................119 
Library Content ........................................119 
options.......................................................178 
origin ..........................................................179 
Parts Location ...........................................119 
Parts Usage................................................119 
selecting criteria ......................................122 
setting 

data selection options.........................121 
sort options ...........................................122 

style format ...............................................179 
types ...........................................................178 
types of reports........................................118 

Reports, File command..............................177 
resizing 

objects............................................52, 89, 249 
Resolve Hierarchy, Utils command ........344 
Revision Blocks ...........................................103 
Revision Note Table ...................................114 

adding ........................................................115 
exporting ...................................................115 
importing...................................................115 
placing........................................................116 

Rewire Commands .....................................285 
Manual .......................................................285 

rotating 
items in a block........................................288 
objects..........................................................52 
polygons ....................................................275 

run temporary macro.................................365 
Run, Macro command ...............................365 
Run, Simulate command...........................355 

-S- 
Save As, File command..............................171 
Save, File command....................................170 
saving 

a symbol to a library................................326 
an ECO file ................................................341 
new name or location.............................171 

Schematic Files (*.sch).................................21 
Schematic Sheets 

adding a sheet ............................................19 
changing a sheet name ............................20 
defining the current sheet.......................19 
deleting a sheet..........................................20 

reordering in a design ..............................19 
scroll bars, defined .......................................13 
search for text ............................................. 254 
searching 

RefDes list................................................. 211 
Select All, Edit command.......................... 238 
Select Highlight, Edit command ............. 238 
Select, Edit command................................ 247 
selecting 

a block ..........................................................83 
a default file viewer ...................................16 
a net ..............................................................81 
a printer or plotter.................................. 139 
all objects.....................................................80 
an object ......................................................78 
choosing a selection color.......................82 
collocated objects......................................80 
contiguous net objects.................... 81, 249 
contiguous, defined ..................................81 
current highlight color .......................... 128 
defining 

block selection criteria..........................83 
selection preferences ............................81 

error indicators........................................ 137 
highlighted objects........................... 80, 131 
items in a block ....................................... 288 
items, status line info ............................. 247 
multiple objects .........................................79 
nets............................................................. 246 
objects ................................................. 46, 248 
overlapping objects................................ 248 
part of an object .........................................79 
select actions 

copying objects.................................... 248 
drag and drop....................................... 248 
moving ................................................... 248 
resizing................................................... 249 
rotating and flipping ........................... 249 

Selection Mask 
dialog.........................................................83 
parameters ............................................ 290 

specifying a selection point........ 82, 86, 87 
setting up 

display options ...........................................29 
ERC options.................................................63 
grid spacing.................................................30 
print jobs................................................... 140 
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printers and plotters ...............................139 
Setup, Library command ...........................325 
Setup, Macro command ............................361 
Setup, Simulate command........................355 
severity levels...............................................134 

ERC..............................................................336 
sheet 

adding ..................................................29, 312 
connectors 

annotating ..............................................108 
cross-referencing .................................107 
definition..........................................44, 108 
example ..................................................107 
jump to....................................................110 
viewing properties ...............................110 

enabling/disabling ...................................311 
re-ordering................................................312 

Sheets, Options command .......................311 
Shortcut Directory, Utils command........351 
shortcut menu, defined...............................13 
Showing 

DataTips .......................................................15 
toolbars ..........................................................7 

Simulate Commands..................................355 
Run..............................................................355 
Setup...........................................................355 

single selection, defined .............................78 
Snap to Grid, View command ..................257 
software requirements ..................................3 
Spare Gate Table .........................................116 

placing........................................................117 
splitting a net .................................................59 
standard title sheets .....................................98 
status line 

defined.........................................................11 
information ...............................................247 
information, defined.................................12 

Status Line, View command .....................257 
subselection, defined ..................................79 
summarize overridden errors 

ERC..............................................................336 
swapping 

pin and gate ..............................................217 
switching 

between sheets ..........................................35 
symbol 

copying ......................................................322 

deleting from a library ........................... 323 
pin 217 
renaming................................................... 324 

Symbol Save As, Library command ........ 326 
system 

requirements ............................................... 3 

-T- 
tables 

modifying.................................................. 117 
updating .................................................... 118 

tabs 
Attributes, Design Info .......................... 185 
Attributes, Part Properties..................... 218 
Class to Class, Options Design Rules. 308 
Colors, Options Display ........................ 297 
Colors, Print Options ..................... 142, 174 
Component Pins, Part Properties ........ 216 
Component, Part Properties................. 215 
Design, Options Design Rules ............. 303 
Fields, Design Info .................................. 184 
Format, Customize Report .................... 179 
General, Design Info .............................. 183 
Keyboard, Options Preferences .......... 302 
Miscellaneous, Options Display.... 29, 176 
Miscellaneous, Print Options............... 143 
Mouse, Options Preferences ............... 302 
Net Class, Options Design Rules......... 304 
Net, Options Design Rules ................... 307 
Net, Port Properties ................................ 221 
Net, Wire Properties............................... 219 
Notes, Design Info.................................. 186 
Port, Port Properties ............................... 221 
Port, Port Selection Mask ...................... 291 
Revision, Design Info ............................. 187 
Selection, Customize Report Attributes

.............................................................. 181 
Sheet Connector, Part Properties........ 110 
Sheets, Options Sheets.......................... 311 
Sort, Customize Report Attributes...... 182 
Statistics, Design Info............................. 188 
Symbol Pins, Part Properties................. 214 
Symbol, Part Properties ......................... 213 
Wire, Wire Properties ............................ 218 
Wire, Wire Selection Mask ................... 292 

Tango 
Tango designs 
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translating ..............................................383 
Tango netlist format................................397 
Tango Series II ASCII Files (*.s01) ..........21 
Tango Series II Files 

loading......................................................21 
Technology Files .........................................188 
temporary macro ................................363, 365 
text 

flipping...............................................227, 278 
jump to (searching for text) ..................254 
justification .......................227, 229, 244, 277 
location ......................................................227 
properties..................................................226 
rotating ......................................227, 277, 278 
selection criteria ......................................292 
style 

adding.....................................................314 
default styles .........................................314 
deleting...................................................315 
display options......................................317 
display TrueType ..................................317 
properties ..............................................315 
renaming ................................................315 
stroke font properties .........................316 
TrueType fonts......................................316 

zooming/panning ....................................278 
Text Style, Options command .................314 
Text, Place command .................................275 
Tile, Window command ............................373 
title sheets ......................................................98 

adding ........................................................293 
design borders ...........................................98 
setting up.....................................................24 
title blocks, defined ..................................99 
using a standard title sheet ...................100 
zones, defined............................................99 

toolbars 
Command Toolbar ..............................8, 256 
Custom Toolbar ...........................................9 
docked toolbar, defined ............................7 
DocTool Toolbar....................................9, 10 
floating toolbar, defined............................7 
moving a toolbar..........................................7 
Placement Toolbar ..............................8, 256 
showing or hiding a toolbar......................7 

touching block 
defined.........................................................83 

translating 
Tango designs.......................................... 383 

tutorials 
generating reports and netlists...............69 
printing a design ........................................72 
setting up a design ....................................23 
verifying a design.......................................63 
working with objects ................................32 

type swapping............................................. 213 

-U- 
underscored letter, defined .........................6 
Undo, Edit command ................................ 201 
Undo, shortcut command........................ 381 
unhighlight .................................................. 130 

an attached net................................ 130, 240 
parts ........................................................... 129 

Unhighlight All, Edit command............... 238 
Unhighlight, Edit command..................... 238 
units of measurement 

changing ................................................... 293 
choosing a scale .........................................28 

User’ s Guide 
about the guide............................................2 

using 
Edit Nets dialog ..........................................95 
title sheets 

custom ................................................... 102 
global...................................................... 100 
standard................................................. 100 

Utils Commands......................................... 329 
Customize ................................................ 352 
ERC............................................................. 334 
Export ECO............................................... 340 
Find Errors ................................................ 337 
Force Update ........................................... 333 
Generate Netlist .............................. 124, 342 
Import ECOs ............................................ 339 
InterPlace/PCS ......................................... 352 
Module Wizard........................................ 345 
P-CAD Library Executive........................ 352 
P-CAD Pattern Editor.............................. 352 
P-CAD PCB ............................................... 351 
P-CAD Symbol Editor ............................. 352 
Record ECOs............................................ 338 
Rename Net.............................................. 343 
Renumber................................................. 329 
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Resolve Hierarchy....................................344 
Shortcut Directory...................................351 

-V- 
View Commands.........................................251 

All 252 
Ascend........................................................255 
Center ........................................................252 
Command Toolbar ..............................8, 256 
Custom Toolbar ...................................9, 256 
Descend.....................................................255 
DocToolbar ...................................................9 
Extent..........................................................251 
Jump Location ..........................................253 
Jump Text...................................................254 
Last ..............................................................251 
Placement Toolbar...............................8, 256 
Prompt Line...............................................256 
Redraw .......................................................251 
Snap to Grid..............................................257 
Status Line .................................................257 
Toolbar...........................................................7 
Zoom Out..................................................252 
Zoom Window..........................................252 

view ECO file................................................341 
viewing 

errors in a design .......................................65 

-W- 
Window Commands ..................................373 

1,2 (other windows).................................374 
Arrange Icons ...........................................373 
New Window............................................373 
Window Cascade.....................................373 

Window Tile ............................................. 373 
wire 

adding to nets .......................................... 264 
orthogonal modes .................................. 264 
properties ................................................. 218 
resizing ........................................................ 89 
selection criteria...................................... 292 
setting wire width ................................... 219 
width .......................................................... 219 

Wire Properties 
Net tab ....................................................... 219 
Text Style button ..................................... 219 

Wire, Place command ............................... 263 
working with objects ................................... 77 
workspace 

defined ........................................................ 10 
setting size.................................................. 23 
setting the autopan percent display ..... 17 
setting the current zoom factor............. 17 
size ............................................................. 293 

-Z- 
Zones 

zone intelligence, defined ...................... 99 
zones, defined ........................................... 99 

zoom 
current zoom factor, defined ................. 17 
in and out.................................................... 31 
zoom factor, defined.............................. 295 
zoom window key................................... 381 
zooming, key............................................ 379 

Zoom Out, View command ..................... 252 
Zoom Window, View command ............. 252 
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